RDPCrystalEDILibrary Namespace

RDPCrystal EDI Library API
RDPCrystalEDILibrary Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary
RDPCrystal EDI Library
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary
Namespace RDPCrystalEDILibrary
namespace RDPCrystalEDILibrary
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | Ack997Generator | Responsible for generating a 997 Acknowledgement EDI File
 | Ack999Generator | Responsible for generating an 999 Acknowledgement EDI File
 | HTTPS..::..CertificateValidationDelegate |
 | CertificationEventArgs | CertificationEventArgs
 | Code | Class used by EDIRulesCreator to create a code object
 | EDIValidator..::..CodeConditionEvent | Delegate used for raising an event to perform a custom code condition check
 | CodeList | Represents a set of codes that a DataElement can contain
 | DataElement | A DataElement Object
 | DataElements | A collection of DataElement Objects
 | DataSegment | A DataSegment Object
 | Delimiters | Represents the delimiters of X12 and EDIFACT standards
 | DocumentCompositeElement | For Typed Documents
 | DocumentCreator |
 | DocumentLoop | Represents a loop in an EDI document. For example, FUNCTIONAL GROUP,ST HEADER,1000B etc
 | DocumentSegment | Represents a Segment
 | HTTP..::..DownloadFileCompletedDelegate |
 | HTTP..::..DownloadFileProgressChangedDelegate |
 | EDIDocument | Creates EDI X12 and EDIFACT document files
 | EDIDocumentException | Exception thrown when an exception occurred while generating an EDI document
 | EDIError | Represents a general EDI error. Errors are available after validation
 | EDIFileJoiner | Component used to join EDI files
 | EDIFileLoader | Parses and loads EDI files without any rules
 | EDIFileLoader..::..EDIFileLoadingCompletedEvent | Delegate used for raising and event after EDI file loading has completed
 | EDIFileParser | Responsible for parsing an EDI file line by line
 | EDIFileScrubber | Parses and scrubs EDI files
 | EDIFileScrubber..::..EDIFileScrubbingCompletedEvent | Delegate used for raising and event after EDI file scrubbing has completed
 | EDIFileSplitter | Component used to split EDI files
 | EDILightWeightDocument | A light weight version of the EDIDocument used to creates EDI X12 and EDIFACT document files
 | EDIRulesCreator | Allows EDI Rules to be created
 | EDIRulesReader | Reader that reads and loads EDI rules from an EDI file
 | EDIRulesReaderEventArg | Represents an general error that may occur while parsing an EDI rules file
 | EDISource | Represents the source of the EDI data to validate
 | EDISpecification | Reponsible for retrieving EDI message specific data
 | EDIValidationMessage | Represents different EDI messages
 | EDIValidator | Validates and loads EDI X12 and EDIFACT files
 | EDIWarning | Represents a general EDI warning. Warnings are available after validation
 | EDIXmlConverter | Class responsible for generating XML data from EDI data
 | Element | Basic element used by EDI Rules Reader
 | ElementCodeList | Represents a list of values that an element can contain
 | ElementConditionalConstraint | Represents a conditional constraint for a segment
 | ElementCounterDisplay | Used by EDIRuleCreator
 | ElementDataType | Represents the possible element types
 | ElementDescriptionInfo | Represents a description that an element can have at a certain position
 | ElementDescriptionList |
 | ElementEqualityDisplay | Used by EDIRuleCreator
 | ElementExclusionConstraint | Object that holds a exclusiong constraint for a segment
 | ElementFormat | Used when creating EDI Rules rules
 | ElementFormatInfo | Represents format information for an Element
 | ElementFormatting | Used by EDI Rules Reader for element formatting
 | ElementListConditionalConstraint | Represents a list conditional contraints
 | ElementPairConstraint | Represents a element pair relationship
 | ElementPosition | Represents the position of an element with the EDI file
 | ElementRequiredConstraint | Represents a required constraint for a segment
 | ElementSchema | Represents an element schema used by EDI Rules Reader
 | ElementUniqueValueInfo |
 | ElementUniqueValues |
 | ElementValueInfo | Represents an element and its possible values at a specific location
 | EDIRulesReader..::..ErrorEvent |
 | ExtCodeList | Contains all the external code lists
 | FileJoinLevel | Enum to specify where file joining should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileJoiner
 | FileLoadingEventArgs | Represents data pertaining to the time it took to load an EDI file
 | FileLoadingException | An exception that represents an errors that occur while loading an EDI file with the EDIFileLoader component
 | FileOperationCompletedEventArgs | FileOperationCompletedEventArgs
 | FileOperationStatus |
 | FileSplitLevel | Enum to specify where file splitting should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileSplitter
 | FileType | EDI File Type
 | Format | Represents a regular expression format that a data element's value must conform to
 | FoundSegmentCollection |
 | EDIRulesReader..::..GeneralEvent |
 | EDIValidator..::..GeneralEvent | Delegate used for raising general events relating to progress
 | GeneralEvent | General event delegate
 | GeneralEventArgs |
 | GeneralTypeConverter |
 | HTTP | HTTP component
 | HTTPS | HTTPS Component
 | LicenseException | Exception thrown when a license is invalid
 | LightWeightElement | Represents a lightweight data element
 | LightWeightLoop | A light weight version of the Loop class
 | LightWeightSegment | A DataSegment Object
 | Loop | Summary description for Loop.
 | LoopSchema |
 | Mask | Represents a mask that segment's use to decide how their elements are used
 | MaximumErrorLimitReachedException | Maximum number of errors reached event
 | PackageLicense | Responsible for checking that a valid license exist
 | RuleDisplay | Used by EDIRuleCreator
 | RuleOperator |
 | ScrubPosition |
 | ScrubRule |
 | Segment |
 | SegmentSchema | Represent basic segment information used by EDIRulesReader and EDIRulesCreator
 | SelfRule | Represents a rule that a segment uses to check itself
 | SemanticRule | Represents a rule that a segment or element must conform to
 | SemanticsProcessor | This class is resonsible for taking a string and extracting the rules from it
 | SnipTestLevel | Snip Levels
 | SummaryDisplay | Used by EDIRuleCreator
 | TypedDocument | Base class of all Typed EDI Document. Subclass this class if you need to create your own typed document that we don't support
 | HTTP..::..UploadFileCompletedDelegate |
 | HTTP..::..UploadFileProgressChangedDelegate |
 | Usage | Represents how a segment/element usage requirements
 | EDIValidator..::..ValidationCompletedEvent | Delegate used for raising an event while validation is being performed
 | ValidationEventsArgs | Represents data pertaining to the time it took to validate a file and if the file has passed validation
 | ValidationException | An exception that represents an errors that occur while validation is taking place
 | EDIValidator..::..ValidationStartedEvent | Delegate used for raising an event when validation begins
 | WriteArguments | Arguments to pass in for EDI file creation
 | XmlConfigOptions | Xml Configuration Options

Copyright 2020 Crystal Universe Software Inc.


Ack997Generator Class

Ack997Generator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator
RDPCrystal EDI Library
Responsible for generating a 997 Acknowledgement EDI File
Declaration Syntax
C# Visual Basic Visual C++
public class Ack997Generator
Public Class Ack997Generator
public ref class Ack997Generator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ack997Generator()()()() | Initializes a new instance of the Ack997Generator class.
 | Delimiters | Segment and element delimiters
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Generate(EDIValidator) | Generates a 997 Acknowledgement EDI file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupControlNumber | Get/set the group control number
 | InterchangeControlNumber | Get/set the interchange control number
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaddingChar | Char used to pad empty spaces
 | SegmentSeparatorString | String to insert between segments for formatting
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TransactionSetControlNumber | Get/set the Transaction Set Control Number
Inheritance Hierarchy
Object
Ack997Generator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Ack997Generator Constructor

Ack997Generator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► Ack997Generator()()()()
RDPCrystal EDI Library
Initializes a new instance of the Ack997Generator class.
Declaration Syntax
C# Visual Basic Visual C++
public Ack997Generator()
Public Sub New
public:
Ack997Generator()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► Delimiters
RDPCrystal EDI Library
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Generate Method (ediValidator)

Generate Method (ediValidator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► Generate(EDIValidator)
RDPCrystal EDI Library
Generates a 997 Acknowledgement EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument Generate(
    EDIValidator ediValidator
)
Public Function Generate ( _
    ediValidator As EDIValidator _
) As EDIDocument
public:
EDIDocument^ Generate(
    EDIValidator^ ediValidator
)
Parameters
ediValidator (EDIValidator)
The edivalidator
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► GroupControlNumber
RDPCrystal EDI Library
Get/set the group control number
Declaration Syntax
C# Visual Basic Visual C++
public int GroupControlNumber { get; set; }
Public Property GroupControlNumber As Integer
    Get
    Set
public:
property int GroupControlNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► InterchangeControlNumber
RDPCrystal EDI Library
Get/set the interchange control number
Declaration Syntax
C# Visual Basic Visual C++
public int InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As Integer
    Get
    Set
public:
property int InterchangeControlNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PaddingChar Property

PaddingChar Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► PaddingChar
RDPCrystal EDI Library
Char used to pad empty spaces
Declaration Syntax
C# Visual Basic Visual C++
public char PaddingChar { get; set; }
Public Property PaddingChar As Char
    Get
    Set
public:
property wchar_t PaddingChar {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSeparatorString Property

SegmentSeparatorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► SegmentSeparatorString
RDPCrystal EDI Library
String to insert between segments for formatting
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSeparatorString { get; set; }
Public Property SegmentSeparatorString As String
    Get
    Set
public:
property String^ SegmentSeparatorString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► TransactionSetControlNumber
RDPCrystal EDI Library
Get/set the Transaction Set Control Number
Declaration Syntax
C# Visual Basic Visual C++
public int TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As Integer
    Get
    Set
public:
property int TransactionSetControlNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Ack999Generator Class

Ack999Generator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator
RDPCrystal EDI Library
Responsible for generating an 999 Acknowledgement EDI File
Declaration Syntax
C# Visual Basic Visual C++
public class Ack999Generator
Public Class Ack999Generator
public ref class Ack999Generator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ack999Generator()()()() | Initializes a new instance of the Ack997Generator class.
 | Delimiters | Segment and element delimiters
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Generate(EDIValidator) | Generates a 999 Acknowledgement EDI file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupControlNumber | Get/set the group control number
 | InterchangeControlNumber | Get/set the interchange control number
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaddingChar | Char used to pad empty spaces
 | SegmentSeparatorString | String to insert between segments for formatting
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TransactionSetControlNumber | Get/set the Transaction Set Control Number
Inheritance Hierarchy
Object
Ack999Generator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Ack999Generator Constructor

Ack999Generator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► Ack999Generator()()()()
RDPCrystal EDI Library
Initializes a new instance of the Ack997Generator class.
Declaration Syntax
C# Visual Basic Visual C++
public Ack999Generator()
Public Sub New
public:
Ack999Generator()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► Delimiters
RDPCrystal EDI Library
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Generate Method (ediValidator)

Generate Method (ediValidator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► Generate(EDIValidator)
RDPCrystal EDI Library
Generates a 999 Acknowledgement EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument Generate(
    EDIValidator ediValidator
)
Public Function Generate ( _
    ediValidator As EDIValidator _
) As EDIDocument
public:
EDIDocument^ Generate(
    EDIValidator^ ediValidator
)
Parameters
ediValidator (EDIValidator)
The edivalidator
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► GroupControlNumber
RDPCrystal EDI Library
Get/set the group control number
Declaration Syntax
C# Visual Basic Visual C++
public int GroupControlNumber { get; set; }
Public Property GroupControlNumber As Integer
    Get
    Set
public:
property int GroupControlNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► InterchangeControlNumber
RDPCrystal EDI Library
Get/set the interchange control number
Declaration Syntax
C# Visual Basic Visual C++
public int InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As Integer
    Get
    Set
public:
property int InterchangeControlNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PaddingChar Property

PaddingChar Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► PaddingChar
RDPCrystal EDI Library
Char used to pad empty spaces
Declaration Syntax
C# Visual Basic Visual C++
public char PaddingChar { get; set; }
Public Property PaddingChar As Char
    Get
    Set
public:
property wchar_t PaddingChar {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSeparatorString Property

SegmentSeparatorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► SegmentSeparatorString
RDPCrystal EDI Library
String to insert between segments for formatting
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSeparatorString { get; set; }
Public Property SegmentSeparatorString As String
    Get
    Set
public:
property String^ SegmentSeparatorString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► TransactionSetControlNumber
RDPCrystal EDI Library
Get/set the Transaction Set Control Number
Declaration Syntax
C# Visual Basic Visual C++
public int TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As Integer
    Get
    Set
public:
property int TransactionSetControlNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CertificationEventArgs Class

CertificationEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs
RDPCrystal EDI Library
CertificationEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class CertificationEventArgs : EventArgs
Public Class CertificationEventArgs _
    Inherits EventArgs
public ref class CertificationEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CertificationEventArgs()()()() | Initializes a new instance of the CertificationEventArgs class
 | Cancel | Gets or sets a value indicating whether this CertificationEventArgs is cancel.
 | Certificate | Gets or sets the certificate.
 | Chain | Gets or sets the chain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SslPolicyErrors | Gets or sets the SSL policy errors.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CertificationEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CertificationEventArgs Constructor

CertificationEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► CertificationEventArgs()()()()
RDPCrystal EDI Library
Initializes a new instance of the CertificationEventArgs class
Declaration Syntax
C# Visual Basic Visual C++
public CertificationEventArgs()
Public Sub New
public:
CertificationEventArgs()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Cancel Property

Cancel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► Cancel
RDPCrystal EDI Library
Gets or sets a value indicating whether this CertificationEventArgs is cancel.
Declaration Syntax
C# Visual Basic Visual C++
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
Value
true if cancel; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Certificate Property

Certificate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► Certificate
RDPCrystal EDI Library
Gets or sets the certificate.
Declaration Syntax
C# Visual Basic Visual C++
public X509Certificate Certificate { get; set; }
Public Property Certificate As X509Certificate
    Get
    Set
public:
property X509Certificate^ Certificate {
    X509Certificate^ get ();
    void set (X509Certificate^ value);
}
Value
The certificate.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Chain Property

Chain Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► Chain
RDPCrystal EDI Library
Gets or sets the chain.
Declaration Syntax
C# Visual Basic Visual C++
public X509Chain Chain { get; set; }
Public Property Chain As X509Chain
    Get
    Set
public:
property X509Chain^ Chain {
    X509Chain^ get ();
    void set (X509Chain^ value);
}
Value
The chain.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SslPolicyErrors Property

SslPolicyErrors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► SslPolicyErrors
RDPCrystal EDI Library
Gets or sets the SSL policy errors.
Declaration Syntax
C# Visual Basic Visual C++
public SslPolicyErrors SslPolicyErrors { get; set; }
Public Property SslPolicyErrors As SslPolicyErrors
    Get
    Set
public:
property SslPolicyErrors SslPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}
Value
The SSL policy errors.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Code Class

Code Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code
RDPCrystal EDI Library
Class used by EDIRulesCreator to create a code object
Declaration Syntax
C# Visual Basic Visual C++
public class Code
Public Class Code
public ref class Code
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code()()()() | Create a new Code object
 | Description | Get/Set the description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Value | Get/Set the value
Inheritance Hierarchy
Object
Code

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Code Constructor

Code Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code ► Code()()()()
RDPCrystal EDI Library
Create a new Code object
Declaration Syntax
C# Visual Basic Visual C++
public Code()
Public Sub New
public:
Code()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code ► Description
RDPCrystal EDI Library
Get/Set the description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Value Property

Value Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code ► Value
RDPCrystal EDI Library
Get/Set the value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeList Class

CodeList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList
RDPCrystal EDI Library
Represents a set of codes that a DataElement can contain
Declaration Syntax
C# Visual Basic Visual C++
public class CodeList
Public Class CodeList
public ref class CodeList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeList()()()() | Create a new CodeList object
 | Codes | Codes that a DataElement can contain
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExternalCodeList | Get/Set whether this is an internal codelist (codes included in the rules files) or external (codes are in their separate file)
 | ExternalDelimiter | Get/Set the character that delimits code list values from their description
 | ExternalFilename | Get/Set the external file that contains code list data
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of code list
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
CodeList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeList Constructor

CodeList Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► CodeList()()()()
RDPCrystal EDI Library
Create a new CodeList object
Declaration Syntax
C# Visual Basic Visual C++
public CodeList()
Public Sub New
public:
CodeList()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Codes Property

Codes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► Codes
RDPCrystal EDI Library
Codes that a DataElement can contain
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, Code> Codes { get; set; }
Public Property Codes As Dictionary(Of String, Code)
    Get
    Set
public:
property Dictionary<String^, Code^>^ Codes {
    Dictionary<String^, Code^>^ get ();
    void set (Dictionary<String^, Code^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ExternalCodeList Property

ExternalCodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► ExternalCodeList
RDPCrystal EDI Library
Get/Set whether this is an internal codelist (codes included in the rules files) or external (codes are in their separate file)
Declaration Syntax
C# Visual Basic Visual C++
public bool ExternalCodeList { get; set; }
Public Property ExternalCodeList As Boolean
    Get
    Set
public:
property bool ExternalCodeList {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ExternalDelimiter Property

ExternalDelimiter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► ExternalDelimiter
RDPCrystal EDI Library
Get/Set the character that delimits code list values from their description
Declaration Syntax
C# Visual Basic Visual C++
public char ExternalDelimiter { get; set; }
Public Property ExternalDelimiter As Char
    Get
    Set
public:
property wchar_t ExternalDelimiter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ExternalFilename Property

ExternalFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► ExternalFilename
RDPCrystal EDI Library
Get/Set the external file that contains code list data
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalFilename { get; set; }
Public Property ExternalFilename As String
    Get
    Set
public:
property String^ ExternalFilename {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► Name
RDPCrystal EDI Library
Name of code list
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Class

DataElement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement
RDPCrystal EDI Library
A DataElement Object
Declaration Syntax
C# Visual Basic Visual C++
public class DataElement : LightWeightElement
Public Class DataElement _
    Inherits LightWeightElement
public ref class DataElement : public LightWeightElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataElement()()()() | Creates a new DataElement object
 | DataElement(String, String) | Creates a new DataElement object
 | DataElement(String, Int32) | Creates a new DataElement object
 | DataElement(Int32, Int32, Int32) | Creates a new DataElement object
 | DataElement(Int32) | Creates a new DataElement object
 | DataElement(String, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, String) | Creates a new DataElement object
 | DataElement(String, Int32, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String) | Creates a new DataElement object
 | DataElement(String, ElementDataType) | Creates a new DataElement object
 | DataElement(Boolean) | Creates a new DataElement object
 | DataElement(String, ElementDataType, String) | Creates a new DataElement object
 | AcceptedValues | Get/Set accepted values for this DataElement
 | Clone()()()() | Deep clones this instance.
 | CodeList | Get/Set codelist for this DataElement
 | CodeListName | Get/Set the name of the codelist that DataElement must get its values from
 | Codes | Get/Set codes for this DataElement
 | Composite | Returns whether this is a composite data element (Inherited from LightWeightElement.)
 | ContainsData()()()() | Checks whether there is data in DataElement (Inherited from LightWeightElement.)
 | ContainsNoData()()()() | Checks whether there is data in DataElement (Inherited from LightWeightElement.)
 | DataType | Get/Set the type of data
 | DataValue | Get/Set the actual data in DataElement (Inherited from LightWeightElement.)
 | Description | Get/Set the description
 | ElementNumber | Get/Set the position of this DataElement in the containing DataSegment (Inherited from LightWeightElement.)
 | Elements | Get/Set the child elements if this is a composite data element
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatCollection | Get/Set element formats for this DataElement
 | GetAcceptedValues()()()() | Returns a list of accepted values for this data element
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAcceptedValues()()()() | Checks whether this data element has a list of accepted values
 | HasRepeatingCompositeElements | Check whether this elements has repeating composite elements (Inherited from LightWeightElement.)
 | HasRepeatingElements | Check whether this elements has repeating elements (Inherited from LightWeightElement.)
 | ImplicitWideningImplicitImplicitImplicit(String to DataElement) | Overides the asignment operator to directly convert a string to a DataElement
 | InAcceptedValues(String) | Checks whether the supplied paramater value exists in the DataElement's accepted values list
 | MaximumLength | Get/Set the maximum length of the data value
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumLength | Get/Set the minimum length of the data value
 | Name | Get/Set the name of DataElement
 | PaddingCharacter | Get/Set the padding character used to meet maximum lengths
 | RepeatingCompositeElements | Gets or sets the repeating composite elements. (Inherited from LightWeightElement.)
 | RepeatingElementsValues | Gets or sets the repeating elements values. This is only set when this element does not represent a composite element (Inherited from LightWeightElement.)
 | Tag | Used for any reason at all
 | ToString()()()() | Returns a String that represents this instance. (Inherited from LightWeightElement.)
 | UniqueValueOnRepetition | Get/Set whether everytime this DataElement repeats a new value must be present
 | Usage | Returns the usage of this dataelement
Inheritance Hierarchy
Object
 | LightWeightElement
 |  | DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor

DataElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | DataElement()()()() | Creates a new DataElement object
 | DataElement(String, String) | Creates a new DataElement object
 | DataElement(String, Int32) | Creates a new DataElement object
 | DataElement(Int32, Int32, Int32) | Creates a new DataElement object
 | DataElement(Int32) | Creates a new DataElement object
 | DataElement(String, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, String) | Creates a new DataElement object
 | DataElement(String, Int32, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String) | Creates a new DataElement object
 | DataElement(String, ElementDataType) | Creates a new DataElement object
 | DataElement(Boolean) | Creates a new DataElement object
 | DataElement(String, ElementDataType, String) | Creates a new DataElement object

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor

DataElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement()()()()
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement()
Public Sub New
public:
DataElement()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (composite)

DataElement Constructor (composite)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(Boolean)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    bool composite
)
Public Sub New ( _
    composite As Boolean _
)
public:
DataElement(
    bool composite
)
Parameters
composite (Boolean)
true if this is a composite dataelement, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (elementNumber)

DataElement Constructor (elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(Int32)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    int elementNumber
)
Public Sub New ( _
    elementNumber As Integer _
)
public:
DataElement(
    int elementNumber
)
Parameters
elementNumber (Int32)
position of DataElement in the containing DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (elementNumber, min, max)

DataElement Constructor (elementNumber, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(Int32, Int32, Int32)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    int elementNumber,
    int min,
    int max
)
Public Sub New ( _
    elementNumber As Integer, _
    min As Integer, _
    max As Integer _
)
public:
DataElement(
    int elementNumber,
    int min,
    int max
)
Parameters
elementNumber (Int32)
position of DataElement in the containing DataSegment
min (Int32)
minimum length of data value
max (Int32)
maximum length of data value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (dataValue)

DataElement Constructor (dataValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue
)
Public Sub New ( _
    dataValue As String _
)
public:
DataElement(
    String^ dataValue
)
Parameters
dataValue (String)
value of DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (name, dataType)

DataElement Constructor (name, dataType)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, ElementDataType)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string name,
    ElementDataType dataType
)
Public Sub New ( _
    name As String, _
    dataType As ElementDataType _
)
public:
DataElement(
    String^ name,
    ElementDataType dataType
)
Parameters
name (String)
name of DataElement
dataType (ElementDataType)
type of data stored in this DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (name, dataType, dataValue)

DataElement Constructor (name, dataType, dataValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, ElementDataType, String)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string name,
    ElementDataType dataType,
    string dataValue
)
Public Sub New ( _
    name As String, _
    dataType As ElementDataType, _
    dataValue As String _
)
public:
DataElement(
    String^ name,
    ElementDataType dataType,
    String^ dataValue
)
Parameters
name (String)
name of the DataElement
dataType (ElementDataType)
type of data stored in this DataElement
dataValue (String)
value of the DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (dataValue, elementNumber)

DataElement Constructor (dataValue, elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int elementNumber
)
Public Sub New ( _
    dataValue As String, _
    elementNumber As Integer _
)
public:
DataElement(
    String^ dataValue,
    int elementNumber
)
Parameters
dataValue (String)
value of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)

DataElement Constructor (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, Usage, Boolean, array<String>[]()[][])
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    params string[] acceptedValues
)
Public Sub New ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    uniqueValueOnRepetition As Boolean, _
    ParamArray acceptedValues As String() _
)
public:
DataElement(
    String^ elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
usage (Usage)
usage of DataElement
uniqueValueOnRepetition (Boolean)
if true then everytime this DataElement repeats a new value must be present
acceptedValues (array<String>[]()[][])
accepted values of DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (elementName, elementNumber, usage, acceptedValues)

DataElement Constructor (elementName, elementNumber, usage, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, Usage, array<String>[]()[][])
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string elementName,
    int elementNumber,
    Usage usage,
    params string[] acceptedValues
)
Public Sub New ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    ParamArray acceptedValues As String() _
)
public:
DataElement(
    String^ elementName,
    int elementNumber,
    Usage usage,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
usage (Usage)
usage of DataElement
acceptedValues (array<String>[]()[][])
accepted values of DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (dataValue, min, max)

DataElement Constructor (dataValue, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, Int32)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int min,
    int max
)
Public Sub New ( _
    dataValue As String, _
    min As Integer, _
    max As Integer _
)
public:
DataElement(
    String^ dataValue,
    int min,
    int max
)
Parameters
dataValue (String)
value of DataElement
min (Int32)
minimum length of data value
max (Int32)
maximum length of data value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (dataValue, elementNumber, description)

DataElement Constructor (dataValue, elementNumber, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, String)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int elementNumber,
    string description
)
Public Sub New ( _
    dataValue As String, _
    elementNumber As Integer, _
    description As String _
)
public:
DataElement(
    String^ dataValue,
    int elementNumber,
    String^ description
)
Parameters
dataValue (String)
value of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
description (String)
description of DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (dataValue, elementNumber, description, minLength, maxLength)

DataElement Constructor (dataValue, elementNumber, description, minLength, maxLength)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, String, Int32, Int32)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int elementNumber,
    string description,
    int minLength,
    int maxLength
)
Public Sub New ( _
    dataValue As String, _
    elementNumber As Integer, _
    description As String, _
    minLength As Integer, _
    maxLength As Integer _
)
public:
DataElement(
    String^ dataValue,
    int elementNumber,
    String^ description,
    int minLength,
    int maxLength
)
Parameters
dataValue (String)
value of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
description (String)
description of DataElement
minLength (Int32)
minimum length of data value
maxLength (Int32)
maximum length of data value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (dataValue, description)

DataElement Constructor (dataValue, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, String)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    string description
)
Public Sub New ( _
    dataValue As String, _
    description As String _
)
public:
DataElement(
    String^ dataValue,
    String^ description
)
Parameters
dataValue (String)
value of DataElement
description (String)
description of DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElement Constructor (name, dataValue, min, max)

DataElement Constructor (name, dataValue, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, String, Int32, Int32)
RDPCrystal EDI Library
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string name,
    string dataValue,
    int min,
    int max
)
Public Sub New ( _
    name As String, _
    dataValue As String, _
    min As Integer, _
    max As Integer _
)
public:
DataElement(
    String^ name,
    String^ dataValue,
    int min,
    int max
)
Parameters
name (String)
name of DataElement
dataValue (String)
value of DataElement
min (Int32)
minimum length of data value
max (Int32)
maximum length of data value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AcceptedValues Property

AcceptedValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► AcceptedValues
RDPCrystal EDI Library
Get/Set accepted values for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> AcceptedValues { get; set; }
Public Property AcceptedValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ AcceptedValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Clone Method

Clone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Clone()()()()
RDPCrystal EDI Library
Deep clones this instance.
Declaration Syntax
C# Visual Basic Visual C++
public DataElement Clone()
Public Function Clone As DataElement
public:
DataElement^ Clone()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeList Property

CodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► CodeList
RDPCrystal EDI Library
Get/Set codelist for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public CodeList CodeList { get; set; }
Public Property CodeList As CodeList
    Get
    Set
public:
property CodeList^ CodeList {
    CodeList^ get ();
    void set (CodeList^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeListName Property

CodeListName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► CodeListName
RDPCrystal EDI Library
Get/Set the name of the codelist that DataElement must get its values from
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListName { get; set; }
Public Property CodeListName As String
    Get
    Set
public:
property String^ CodeListName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Codes Property

Codes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Codes
RDPCrystal EDI Library
Get/Set codes for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> Codes { get; set; }
Public Property Codes As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ Codes {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataType Property

DataType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataType
RDPCrystal EDI Library
Get/Set the type of data
Declaration Syntax
C# Visual Basic Visual C++
public ElementDataType DataType { get; set; }
Public Property DataType As ElementDataType
    Get
    Set
public:
property ElementDataType DataType {
    ElementDataType get ();
    void set (ElementDataType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Description
RDPCrystal EDI Library
Get/Set the description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Elements
RDPCrystal EDI Library
Get/Set the child elements if this is a composite data element
Declaration Syntax
C# Visual Basic Visual C++
public DataElements Elements { get; set; }
Public Property Elements As DataElements
    Get
    Set
public:
property DataElements^ Elements {
    DataElements^ get ();
    void set (DataElements^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FormatCollection Property

FormatCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► FormatCollection
RDPCrystal EDI Library
Get/Set element formats for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementFormat> FormatCollection { get; set; }
Public Property FormatCollection As List(Of ElementFormat)
    Get
    Set
public:
property List<ElementFormat^>^ FormatCollection {
    List<ElementFormat^>^ get ();
    void set (List<ElementFormat^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetAcceptedValues Method

GetAcceptedValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► GetAcceptedValues()()()()
RDPCrystal EDI Library
Returns a list of accepted values for this data element
Declaration Syntax
C# Visual Basic Visual C++
public string GetAcceptedValues()
Public Function GetAcceptedValues As String
public:
String^ GetAcceptedValues()
Return Value
list of accepted values separated by a comma

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HasAcceptedValues Method

HasAcceptedValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► HasAcceptedValues()()()()
RDPCrystal EDI Library
Checks whether this data element has a list of accepted values
Declaration Syntax
C# Visual Basic Visual C++
public bool HasAcceptedValues()
Public Function HasAcceptedValues As Boolean
public:
bool HasAcceptedValues()
Return Value
true if a list exists, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► ImplicitWideningImplicitImplicitImplicit(String to DataElement)
RDPCrystal EDI Library
Overides the asignment operator to directly convert a string to a DataElement
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator DataElement (
    string elementValue
)
Public Shared Widening Operator CType ( _
    elementValue As String _
) As DataElement
static implicit operator DataElement^ (
    String^ elementValue
)
Parameters
elementValue (String)
string to convert to a DataElement
Return Value
a new DataElement with the supplied value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InAcceptedValues Method (value)

InAcceptedValues Method (value)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► InAcceptedValues(String)
RDPCrystal EDI Library
Checks whether the supplied paramater value exists in the DataElement's accepted values list
Declaration Syntax
C# Visual Basic Visual C++
public bool InAcceptedValues(
    string value
)
Public Function InAcceptedValues ( _
    value As String _
) As Boolean
public:
bool InAcceptedValues(
    String^ value
)
Parameters
value (String)
value to check
Return Value
true if the value exists, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaximumLength Property

MaximumLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► MaximumLength
RDPCrystal EDI Library
Get/Set the maximum length of the data value
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumLength { get; set; }
Public Property MaximumLength As Integer
    Get
    Set
public:
property int MaximumLength {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MinimumLength Property

MinimumLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► MinimumLength
RDPCrystal EDI Library
Get/Set the minimum length of the data value
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumLength { get; set; }
Public Property MinimumLength As Integer
    Get
    Set
public:
property int MinimumLength {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Name
RDPCrystal EDI Library
Get/Set the name of DataElement
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PaddingCharacter Property

PaddingCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► PaddingCharacter
RDPCrystal EDI Library
Get/Set the padding character used to meet maximum lengths
Declaration Syntax
C# Visual Basic Visual C++
public char PaddingCharacter { get; set; }
Public Property PaddingCharacter As Char
    Get
    Set
public:
property wchar_t PaddingCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Tag Property

Tag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Tag
RDPCrystal EDI Library
Used for any reason at all
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UniqueValueOnRepetition Property

UniqueValueOnRepetition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► UniqueValueOnRepetition
RDPCrystal EDI Library
Get/Set whether everytime this DataElement repeats a new value must be present
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueValueOnRepetition { get; set; }
Public Property UniqueValueOnRepetition As Boolean
    Get
    Set
public:
property bool UniqueValueOnRepetition {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Usage
RDPCrystal EDI Library
Returns the usage of this dataelement
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElements Class

DataElements Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements
RDPCrystal EDI Library
A collection of DataElement Objects
Declaration Syntax
C# Visual Basic Visual C++
public class DataElements : Collection<DataElement>
Public Class DataElements _
    Inherits Collection(Of DataElement)
public ref class DataElements : public Collection<DataElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataElements()()()() | Creates a new DataElements Collection
 | Add(String) | Creates and adds a new DataElement with a value
 | Add(Int32) | Adds the specified element value.
 | Add(Double) | Adds the specified element value.
 | Add(Decimal) | Adds the specified element value.
 | Add(Single) | Adds the specified element value.
 | Add(Byte) | Adds the specified element value.
 | Add(Char) | Adds the specified element value.
 | Add(array<String>[]()[][]) | Creates and adds a series of data elements
 | Add(String, String) | Creates and adds a new DataElement with a value and description
 | Add(String, Int32) | Creates and adds a new DataElement with a value and element number
 | Add(String, Int32, Int32) | Creates and adds a new DataElement to collection with a value and a minimum and maximum value length
 | Add(String, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Int32, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <(<' DataElement >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <(<' DataElement >)>)>
 |  | DataElements

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataElements Constructor

DataElements Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► DataElements()()()()
RDPCrystal EDI Library
Creates a new DataElements Collection
Declaration Syntax
C# Visual Basic Visual C++
public DataElements()
Public Sub New
public:
DataElements()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method

Add Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Add(String) | Creates and adds a new DataElement with a value
 | Add(Int32) | Adds the specified element value.
 | Add(Double) | Adds the specified element value.
 | Add(Decimal) | Adds the specified element value.
 | Add(Single) | Adds the specified element value.
 | Add(Byte) | Adds the specified element value.
 | Add(Char) | Adds the specified element value.
 | Add(array<String>[]()[][]) | Creates and adds a series of data elements
 | Add(String, String) | Creates and adds a new DataElement with a value and description
 | Add(String, Int32) | Creates and adds a new DataElement with a value and element number
 | Add(String, Int32, Int32) | Creates and adds a new DataElement to collection with a value and a minimum and maximum value length
 | Add(String, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Int32, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Byte)
RDPCrystal EDI Library
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    byte elementValue
)
Public Sub Add ( _
    elementValue As Byte _
)
public:
void Add(
    unsigned char elementValue
)
Parameters
elementValue (Byte)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Char)
RDPCrystal EDI Library
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    char elementValue
)
Public Sub Add ( _
    elementValue As Char _
)
public:
void Add(
    wchar_t elementValue
)
Parameters
elementValue (Char)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Decimal)
RDPCrystal EDI Library
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    decimal elementValue
)
Public Sub Add ( _
    elementValue As Decimal _
)
public:
void Add(
    Decimal elementValue
)
Parameters
elementValue (Decimal)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Double)
RDPCrystal EDI Library
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double elementValue
)
Public Sub Add ( _
    elementValue As Double _
)
public:
void Add(
    double elementValue
)
Parameters
elementValue (Double)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Int32)
RDPCrystal EDI Library
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    int elementValue
)
Public Sub Add ( _
    elementValue As Integer _
)
public:
void Add(
    int elementValue
)
Parameters
elementValue (Int32)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Single)
RDPCrystal EDI Library
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    float elementValue
)
Public Sub Add ( _
    elementValue As Single _
)
public:
void Add(
    float elementValue
)
Parameters
elementValue (Single)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String)
RDPCrystal EDI Library
Creates and adds a new DataElement with a value
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue
)
Public Sub Add ( _
    elementValue As String _
)
public:
void Add(
    String^ elementValue
)
Parameters
elementValue (String)
value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue, elementNumber)

Add Method (elementValue, elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32)
RDPCrystal EDI Library
Creates and adds a new DataElement with a value and element number
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int elementNumber
)
Public Sub Add ( _
    elementValue As String, _
    elementNumber As Integer _
)
public:
void Add(
    String^ elementValue,
    int elementNumber
)
Parameters
elementValue (String)
value
elementNumber (Int32)
element number

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)

Add Method (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Usage, Boolean, array<String>[]()[][])
RDPCrystal EDI Library
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    params string[] acceptedValues
)
Public Sub Add ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    uniqueValueOnRepetition As Boolean, _
    ParamArray acceptedValues As String() _
)
public:
void Add(
    String^ elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of data element
elementNumber (Int32)
element number
usage (Usage)
usage of data element
uniqueValueOnRepetition (Boolean)
whether everytime this DataElement repeats a new value must be present
acceptedValues (array<String>[]()[][])
list of accepted values for this data element

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementName, elementNumber, usage, acceptedValues)

Add Method (elementName, elementNumber, usage, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Usage, array<String>[]()[][])
RDPCrystal EDI Library
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementName,
    int elementNumber,
    Usage usage,
    params string[] acceptedValues
)
Public Sub Add ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    ParamArray acceptedValues As String() _
)
public:
void Add(
    String^ elementName,
    int elementNumber,
    Usage usage,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of data element
elementNumber (Int32)
element number
usage (Usage)
usage of data element
acceptedValues (array<String>[]()[][])
list of accepted values for this data element

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue, min, max)

Add Method (elementValue, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Int32)
RDPCrystal EDI Library
Creates and adds a new DataElement to collection with a value and a minimum and maximum value length
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int min,
    int max
)
Public Sub Add ( _
    elementValue As String, _
    min As Integer, _
    max As Integer _
)
public:
void Add(
    String^ elementValue,
    int min,
    int max
)
Parameters
elementValue (String)
value
min (Int32)
minimum length for value
max (Int32)
maximum length for value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue, elementNumber, minLength, maxLength, description)

Add Method (elementValue, elementNumber, minLength, maxLength, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Int32, Int32, String)
RDPCrystal EDI Library
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int elementNumber,
    int minLength,
    int maxLength,
    string description
)
Public Sub Add ( _
    elementValue As String, _
    elementNumber As Integer, _
    minLength As Integer, _
    maxLength As Integer, _
    description As String _
)
public:
void Add(
    String^ elementValue,
    int elementNumber,
    int minLength,
    int maxLength,
    String^ description
)
Parameters
elementValue (String)
data element value
elementNumber (Int32)
element number
minLength (Int32)
minimum length for value
maxLength (Int32)
maximum length for value
description (String)
description of data element

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue, elementNumber, description)

Add Method (elementValue, elementNumber, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, String)
RDPCrystal EDI Library
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int elementNumber,
    string description
)
Public Sub Add ( _
    elementValue As String, _
    elementNumber As Integer, _
    description As String _
)
public:
void Add(
    String^ elementValue,
    int elementNumber,
    String^ description
)
Parameters
elementValue (String)
data element value
elementNumber (Int32)
element number
description (String)
description

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValue, description)

Add Method (elementValue, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, String)
RDPCrystal EDI Library
Creates and adds a new DataElement with a value and description
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    string description
)
Public Sub Add ( _
    elementValue As String, _
    description As String _
)
public:
void Add(
    String^ elementValue,
    String^ description
)
Parameters
elementValue (String)
value
description (String)
description

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (elementValues)

Add Method (elementValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(array<String>[]()[][])
RDPCrystal EDI Library
Creates and adds a series of data elements
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    params string[] elementValues
)
Public Sub Add ( _
    ParamArray elementValues As String() _
)
public:
void Add(
    ... array<String^>^ elementValues
)
Parameters
elementValues (array<String>[]()[][])
value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataSegment Class

DataSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment
RDPCrystal EDI Library
A DataSegment Object
Declaration Syntax
C# Visual Basic Visual C++
public class DataSegment : LightWeightSegment
Public Class DataSegment _
    Inherits LightWeightSegment
public ref class DataSegment : public LightWeightSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSegment(String, String) | Creates a new DataSegment
 | DataSegment(String, Int32, Int32, Usage, String) | Creates a new DataSegment
 | DataSegment(String) | Creates a new DataSegment
 | ContainsElement(Int32) | Checks whether an element exist in the segment (Overrides LightWeightSegment.ContainsElement(Int32).)
 | CreateDataElement(Boolean) | Creates and add a default DataElement to this DataSegment
 | Description | Get/Set the description for this segment
 | ElementConditionalConstraints | Element Conditional Constraints List
 | ElementExclusionConstraints | Element Exclusion Constraints List
 | ElementListConditionConstraints | Element List Condition Constraints List
 | ElementPairConstraints | Element Pair Constraints List
 | ElementRequiredConstraint | Element Required Constraints List
 | Elements | Get/Set a list of DataElements
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstElement | Returns the first data element in this segment
 | GeneralRules |
 | GeneralSelfRules |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasElementPairConstraints()()()() | Returns whether this DataSegment has any contraints
 | ImplicitWideningImplicitImplicitImplicit(String to DataSegment) | Performs an implicit conversion from String to DataSegment.
 | Item[([( Int32])]) | Gets element values (Inherited from LightWeightSegment.)
 | LastElement | Returns the last data element in this segment
 | LoopValidationIndex | Gets or sets the index of the loop validation. Default is 0
 | MaskNumber | For Rules Reader
 | MaximumOccurrences | Get/Set the maximum amount of times this segment can repeat
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumOccurrences | Get/Set the minimum amount of times this segment can repeat
 | Name | Get/Set the name of this segment (Inherited from LightWeightSegment.)
 | OnlySegmentInLoop | Get/Set if this is the only segment in a loop
 | OrdinalNumber | Get/Set the actual position of this segment in an EDIDocument (Inherited from LightWeightSegment.)
 | OwningLoop | Get/Set the name of the loop that this segment belongs to
 | Populate(array<String>[]()[][]) | Obsolete. Use PopulateElements(params string[] elementValues) instead
 | PopulateElements(array<String>[]()[][]) | Populates the DataElements of this DataSegment from a params array
 | Position | Gets or sets the position.
 | RepeatIndefinite | Get/Set if this segment repeats indefinitely
 | Rules | Get/Set the rules for this segment
 | SegmentID | Use this to store any id necessary
 | SegmentLoop |
 | SelfRules | Get/Set the self rules for this segment
 | Tag | Used for any purpose
 | ToEDIString(Delimiters) | Returns an EDI string of this segment complete with delimiters (Inherited from LightWeightSegment.)
 | ToString()()()() | Returns a string representation of this DataSegment (Overrides LightWeightSegment.ToString()()()().)
 | Usage | Get/Set the usage requirements of segment
Inheritance Hierarchy
Object
 | LightWeightSegment
 |  | DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataSegment Constructor

DataSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | DataSegment(String, String) | Creates a new DataSegment
 | DataSegment(String, Int32, Int32, Usage, String) | Creates a new DataSegment
 | DataSegment(String) | Creates a new DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataSegment Constructor (segmentName)

DataSegment Constructor (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment(String)
RDPCrystal EDI Library
Creates a new DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment(
    string segmentName
)
Public Sub New ( _
    segmentName As String _
)
public:
DataSegment(
    String^ segmentName
)
Parameters
segmentName (String)
segment name

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataSegment Constructor (segmentName, min, max, usage, description)

DataSegment Constructor (segmentName, min, max, usage, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment(String, Int32, Int32, Usage, String)
RDPCrystal EDI Library
Creates a new DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment(
    string segmentName,
    int min,
    int max,
    Usage usage,
    string description
)
Public Sub New ( _
    segmentName As String, _
    min As Integer, _
    max As Integer, _
    usage As Usage, _
    description As String _
)
public:
DataSegment(
    String^ segmentName,
    int min,
    int max,
    Usage usage,
    String^ description
)
Parameters
segmentName (String)
segment name
min (Int32)
minimum amount of time segment should repeat
max (Int32)
maximum amount of time segment should repeat
usage (Usage)
usage for segment
description (String)
description for segment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataSegment Constructor (segmentName, description)

DataSegment Constructor (segmentName, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment(String, String)
RDPCrystal EDI Library
Creates a new DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment(
    string segmentName,
    string description
)
Public Sub New ( _
    segmentName As String, _
    description As String _
)
public:
DataSegment(
    String^ segmentName,
    String^ description
)
Parameters
segmentName (String)
name
description (String)
description for segment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsElement Method (elementIndex)

ContainsElement Method (elementIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ContainsElement(Int32)
RDPCrystal EDI Library
Checks whether an element exist in the segment
Declaration Syntax
C# Visual Basic Visual C++
public override bool ContainsElement(
    int elementIndex
)
Public Overrides Function ContainsElement ( _
    elementIndex As Integer _
) As Boolean
public:
virtual bool ContainsElement(
    int elementIndex
) override
Parameters
elementIndex (Int32)
index of the element
Return Value
true if element exists, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateDataElement Method (composite)

CreateDataElement Method (composite)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► CreateDataElement(Boolean)
RDPCrystal EDI Library
Creates and add a default DataElement to this DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataElement CreateDataElement(
    bool composite
)
Public Function CreateDataElement ( _
    composite As Boolean _
) As DataElement
public:
DataElement^ CreateDataElement(
    bool composite
)
Parameters
composite (Boolean)
specifies whether DataElement should be a composite
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Description
RDPCrystal EDI Library
Get/Set the description for this segment
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementConditionalConstraints Property

ElementConditionalConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementConditionalConstraints
RDPCrystal EDI Library
Element Conditional Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementConditionalConstraint> ElementConditionalConstraints { get; set; }
Public Property ElementConditionalConstraints As List(Of ElementConditionalConstraint)
    Get
    Set
public:
property List<ElementConditionalConstraint^>^ ElementConditionalConstraints {
    List<ElementConditionalConstraint^>^ get ();
    void set (List<ElementConditionalConstraint^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementExclusionConstraints Property

ElementExclusionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementExclusionConstraints
RDPCrystal EDI Library
Element Exclusion Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementExclusionConstraint> ElementExclusionConstraints { get; set; }
Public Property ElementExclusionConstraints As List(Of ElementExclusionConstraint)
    Get
    Set
public:
property List<ElementExclusionConstraint^>^ ElementExclusionConstraints {
    List<ElementExclusionConstraint^>^ get ();
    void set (List<ElementExclusionConstraint^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementListConditionConstraints Property

ElementListConditionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementListConditionConstraints
RDPCrystal EDI Library
Element List Condition Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementListConditionalConstraint> ElementListConditionConstraints { get; set; }
Public Property ElementListConditionConstraints As List(Of ElementListConditionalConstraint)
    Get
    Set
public:
property List<ElementListConditionalConstraint^>^ ElementListConditionConstraints {
    List<ElementListConditionalConstraint^>^ get ();
    void set (List<ElementListConditionalConstraint^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPairConstraints Property

ElementPairConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementPairConstraints
RDPCrystal EDI Library
Element Pair Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementPairConstraint> ElementPairConstraints { get; set; }
Public Property ElementPairConstraints As List(Of ElementPairConstraint)
    Get
    Set
public:
property List<ElementPairConstraint^>^ ElementPairConstraints {
    List<ElementPairConstraint^>^ get ();
    void set (List<ElementPairConstraint^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementRequiredConstraint Property

ElementRequiredConstraint Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementRequiredConstraint
RDPCrystal EDI Library
Element Required Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementRequiredConstraint> ElementRequiredConstraint { get; set; }
Public Property ElementRequiredConstraint As List(Of ElementRequiredConstraint)
    Get
    Set
public:
property List<ElementRequiredConstraint^>^ ElementRequiredConstraint {
    List<ElementRequiredConstraint^>^ get ();
    void set (List<ElementRequiredConstraint^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Elements
RDPCrystal EDI Library
Get/Set a list of DataElements
Declaration Syntax
C# Visual Basic Visual C++
public DataElements Elements { get; set; }
Public Property Elements As DataElements
    Get
    Set
public:
property DataElements^ Elements {
    DataElements^ get ();
    void set (DataElements^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FirstElement Property

FirstElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► FirstElement
RDPCrystal EDI Library
Returns the first data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public DataElement FirstElement { get; }
Public ReadOnly Property FirstElement As DataElement
    Get
public:
property DataElement^ FirstElement {
    DataElement^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralRules Property

GeneralRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► GeneralRules
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<GeneralRule> GeneralRules { get; set; }
Public Property GeneralRules As List(Of GeneralRule)
    Get
    Set
public:
property List<GeneralRule^>^ GeneralRules {
    List<GeneralRule^>^ get ();
    void set (List<GeneralRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralSelfRules Property

GeneralSelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► GeneralSelfRules
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<GeneralSelfRule> GeneralSelfRules { get; set; }
Public Property GeneralSelfRules As List(Of GeneralSelfRule)
    Get
    Set
public:
property List<GeneralSelfRule^>^ GeneralSelfRules {
    List<GeneralSelfRule^>^ get ();
    void set (List<GeneralSelfRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HasElementPairConstraints Method

HasElementPairConstraints Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► HasElementPairConstraints()()()()
RDPCrystal EDI Library
Returns whether this DataSegment has any contraints
Declaration Syntax
C# Visual Basic Visual C++
public bool HasElementPairConstraints()
Public Function HasElementPairConstraints As Boolean
public:
bool HasElementPairConstraints()
Return Value
true if contraints exist, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ImplicitWideningImplicitImplicitImplicit(String to DataSegment)
RDPCrystal EDI Library
Performs an implicit conversion from String to DataSegment.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator DataSegment (
    string segmentName
)
Public Shared Widening Operator CType ( _
    segmentName As String _
) As DataSegment
static implicit operator DataSegment^ (
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
The result of the conversion.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LastElement Property

LastElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► LastElement
RDPCrystal EDI Library
Returns the last data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public DataElement LastElement { get; }
Public ReadOnly Property LastElement As DataElement
    Get
public:
property DataElement^ LastElement {
    DataElement^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopValidationIndex Property

LoopValidationIndex Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► LoopValidationIndex
RDPCrystal EDI Library
Gets or sets the index of the loop validation. Default is 0
Declaration Syntax
C# Visual Basic Visual C++
public int LoopValidationIndex { get; set; }
Public Property LoopValidationIndex As Integer
    Get
    Set
public:
property int LoopValidationIndex {
    int get ();
    void set (int value);
}
Value
The index of the loop validation.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaskNumber Property

MaskNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► MaskNumber
RDPCrystal EDI Library
For Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public int MaskNumber { get; set; }
Public Property MaskNumber As Integer
    Get
    Set
public:
property int MaskNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaximumOccurrences Property

MaximumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► MaximumOccurrences
RDPCrystal EDI Library
Get/Set the maximum amount of times this segment can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumOccurrences { get; set; }
Public Property MaximumOccurrences As Integer
    Get
    Set
public:
property int MaximumOccurrences {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MinimumOccurrences Property

MinimumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► MinimumOccurrences
RDPCrystal EDI Library
Get/Set the minimum amount of times this segment can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumOccurrences { get; set; }
Public Property MinimumOccurrences As Integer
    Get
    Set
public:
property int MinimumOccurrences {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OnlySegmentInLoop Property

OnlySegmentInLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► OnlySegmentInLoop
RDPCrystal EDI Library
Get/Set if this is the only segment in a loop
Declaration Syntax
C# Visual Basic Visual C++
public bool OnlySegmentInLoop { get; set; }
Public Property OnlySegmentInLoop As Boolean
    Get
    Set
public:
property bool OnlySegmentInLoop {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OwningLoop Property

OwningLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► OwningLoop
RDPCrystal EDI Library
Get/Set the name of the loop that this segment belongs to
Declaration Syntax
C# Visual Basic Visual C++
public string OwningLoop { get; set; }
Public Property OwningLoop As String
    Get
    Set
public:
property String^ OwningLoop {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Populate Method (elementValues)

Populate Method (elementValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Populate(array<String>[]()[][])
RDPCrystal EDI Library
Use PopulateElements(params string[] elementValues) instead
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use PopulateElements(params string[] elementValues) instead")]
public void Populate(
    params string[] elementValues
)
<ObsoleteAttribute("Use PopulateElements(params string[] elementValues) instead")> _
Public Sub Populate ( _
    ParamArray elementValues As String() _
)
[ObsoleteAttribute(L"Use PopulateElements(params string[] elementValues) instead")]
public:
void Populate(
    ... array<String^>^ elementValues
)
Parameters
elementValues (array<String>[]()[][])
data values for the new DataElements

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PopulateElements Method (elementValues)

PopulateElements Method (elementValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► PopulateElements(array<String>[]()[][])
RDPCrystal EDI Library
Populates the DataElements of this DataSegment from a params array
Declaration Syntax
C# Visual Basic Visual C++
public void PopulateElements(
    params string[] elementValues
)
Public Sub PopulateElements ( _
    ParamArray elementValues As String() _
)
public:
void PopulateElements(
    ... array<String^>^ elementValues
)
Parameters
elementValues (array<String>[]()[][])
data values for the new DataElements

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Position
RDPCrystal EDI Library
Gets or sets the position.
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
Value
The position.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RepeatIndefinite Property

RepeatIndefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► RepeatIndefinite
RDPCrystal EDI Library
Get/Set if this segment repeats indefinitely
Declaration Syntax
C# Visual Basic Visual C++
public bool RepeatIndefinite { get; set; }
Public Property RepeatIndefinite As Boolean
    Get
    Set
public:
property bool RepeatIndefinite {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Rules
RDPCrystal EDI Library
Get/Set the rules for this segment
Declaration Syntax
C# Visual Basic Visual C++
public List<SemanticRule> Rules { get; set; }
Public Property Rules As List(Of SemanticRule)
    Get
    Set
public:
property List<SemanticRule^>^ Rules {
    List<SemanticRule^>^ get ();
    void set (List<SemanticRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentID Property

SegmentID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► SegmentID
RDPCrystal EDI Library
Use this to store any id necessary
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentID { get; set; }
Public Property SegmentID As String
    Get
    Set
public:
property String^ SegmentID {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentLoop Property

SegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► SegmentLoop
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Loop SegmentLoop { get; set; }
Public Property SegmentLoop As Loop
    Get
    Set
public:
property Loop^ SegmentLoop {
    Loop^ get ();
    void set (Loop^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SelfRules Property

SelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► SelfRules
RDPCrystal EDI Library
Get/Set the self rules for this segment
Declaration Syntax
C# Visual Basic Visual C++
public List<SelfRule> SelfRules { get; set; }
Public Property SelfRules As List(Of SelfRule)
    Get
    Set
public:
property List<SelfRule^>^ SelfRules {
    List<SelfRule^>^ get ();
    void set (List<SelfRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Tag Property

Tag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Tag
RDPCrystal EDI Library
Used for any purpose
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ToString()()()()
RDPCrystal EDI Library
Returns a string representation of this DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Usage
RDPCrystal EDI Library
Get/Set the usage requirements of segment
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Class

Delimiters Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters
RDPCrystal EDI Library
Represents the delimiters of X12 and EDIFACT standards
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Delimiters
<SerializableAttribute> _
Public Class Delimiters
[SerializableAttribute]
public ref class Delimiters
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delimiters()()()() | Creates a new Delimiters object
 | CompositeTerminatorCharacter | Composite element terminator character
 | ElementTerminatorCharacter | Element terminator charactor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(String, String) |
 | ReleaseCharacter | Release character (EDIFACT)
 | RepetitionCharacter | Repetition character
 | SegmentTerminatorCharacter | Segment terminator charactor
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UsingDefault | When false the delimiters for an EDI file could be be determined
Inheritance Hierarchy
Object
Delimiters

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Constructor

Delimiters Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► Delimiters()()()()
RDPCrystal EDI Library
Creates a new Delimiters object
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters()
Public Sub New
public:
Delimiters()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeTerminatorCharacter Property

CompositeTerminatorCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► CompositeTerminatorCharacter
RDPCrystal EDI Library
Composite element terminator character
Declaration Syntax
C# Visual Basic Visual C++
public char CompositeTerminatorCharacter { get; set; }
Public Property CompositeTerminatorCharacter As Char
    Get
    Set
public:
property wchar_t CompositeTerminatorCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementTerminatorCharacter Property

ElementTerminatorCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► ElementTerminatorCharacter
RDPCrystal EDI Library
Element terminator charactor
Declaration Syntax
C# Visual Basic Visual C++
public char ElementTerminatorCharacter { get; set; }
Public Property ElementTerminatorCharacter As Char
    Get
    Set
public:
property wchar_t ElementTerminatorCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parse Method (fileData, trimCharacters)

Parse Method (fileData, trimCharacters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► Parse(String, String)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static Delimiters Parse(
    string fileData,
    string trimCharacters
)
Public Shared Function Parse ( _
    fileData As String, _
    trimCharacters As String _
) As Delimiters
public:
static Delimiters^ Parse(
    String^ fileData,
    String^ trimCharacters
)
Parameters
fileData (String)
trimCharacters (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ReleaseCharacter Property

ReleaseCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► ReleaseCharacter
RDPCrystal EDI Library
Release character (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public char ReleaseCharacter { get; set; }
Public Property ReleaseCharacter As Char
    Get
    Set
public:
property wchar_t ReleaseCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RepetitionCharacter Property

RepetitionCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► RepetitionCharacter
RDPCrystal EDI Library
Repetition character
Declaration Syntax
C# Visual Basic Visual C++
public char RepetitionCharacter { get; set; }
Public Property RepetitionCharacter As Char
    Get
    Set
public:
property wchar_t RepetitionCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentTerminatorCharacter Property

SegmentTerminatorCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► SegmentTerminatorCharacter
RDPCrystal EDI Library
Segment terminator charactor
Declaration Syntax
C# Visual Basic Visual C++
public char SegmentTerminatorCharacter { get; set; }
Public Property SegmentTerminatorCharacter As Char
    Get
    Set
public:
property wchar_t SegmentTerminatorCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UsingDefault Property

UsingDefault Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► UsingDefault
RDPCrystal EDI Library
When false the delimiters for an EDI file could be be determined
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingDefault { get; internal set; }
Public Property UsingDefault As Boolean
    Get
    Friend Set
public:
property bool UsingDefault {
    bool get ();
    internal: void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentCompositeElement Class

DocumentCompositeElement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentCompositeElement
RDPCrystal EDI Library
For Typed Documents
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DocumentCompositeElement
Public MustInherit Class DocumentCompositeElement
public ref class DocumentCompositeElement abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DocumentCompositeElement()()()() | Initializes a new instance of the DocumentCompositeElement class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) |
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) |
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ActionsIndicated
 |  | AdjustmentIdentifier
 |  | AmountQualifyingDescription
 |  | AssuranceTokenParameters
 |  | CertificateLookupInformation
 |  | CompositeDiagnosisCodePointer
 |  | CompositeMedicalProcedureIdentifier
 |  | CompositeQualifierIdentifier
 |  | CompositeTypeOfRealEstateAssetCode
 |  | CompositeUnitOfMeasure
 |  | CompositeUseOfProceeds
 |  | ComputationMethods
 |  | ConditionsIndicated
 |  | EncryptionKeyInformation
 |  | EncryptionServiceInformation
 |  | HealthCareClaimStatus
 |  | HealthCareCodeInformation
 |  | HealthCareServiceLocationInformation
 |  | IndexIdentification
 |  | MedicareStatusCode
 |  | OralCavityDesignation
 |  | PositionInSegment
 |  | ProviderSpecialtyInformation
 |  | ReferenceIdentifier
 |  | RelatedCausesInformation
 |  | SecurityValue
 |  | TaxFieldIdentification
 |  | ToothSurface
 |  | AdjustmentIdentifier
 |  | CompositeDiagnosticCodePointer
 |  | CompositeMedicalProcedureIdentifier
 |  | CompositeUnitOfMeasure
 |  | ContextIndentification
 |  | HealthCareClaimStatus
 |  | HealthCareCodeInformation
 |  | HealthCareServiceLocation
 |  | MedicareStatusCode
 |  | OralCavityDesign
 |  | PositionInSegment
 |  | RaceOrEthnicityInformation
 |  | ReferenceIdentifier
 |  | ReferenceInSegment
 |  | RelatedCausesInformation
 |  | ToothSurface

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentCompositeElement Constructor

DocumentCompositeElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentCompositeElement ► DocumentCompositeElement()()()()
RDPCrystal EDI Library
Initializes a new instance of the DocumentCompositeElement class
Declaration Syntax
C# Visual Basic Visual C++
protected DocumentCompositeElement()
Protected Sub New
protected:
DocumentCompositeElement()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentCompositeElement ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public abstract string GetString(
    char compElemSep
)
Public MustOverride Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) abstract
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Write Method (compElemSep, elements)

Write Method (compElemSep, elements)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentCompositeElement ► Write(Char, List<(Of <<'(String>)>>))
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected string Write(
    char compElemSep,
    List<string> elements
)
Protected Function Write ( _
    compElemSep As Char, _
    elements As List(Of String) _
) As String
protected:
String^ Write(
    wchar_t compElemSep,
    List<String^>^ elements
)
Parameters
compElemSep (Char)
elements (List<(Of <(<'String>)>)>)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentCreator Enumeration

DocumentCreator Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentCreator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public enum DocumentCreator
Public Enumeration DocumentCreator
public enum class DocumentCreator
Members
Member | Description
None |
EDIFileLoader |
EDIValidator |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentLoop Class

DocumentLoop Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop
RDPCrystal EDI Library
Represents a loop in an EDI document. For example, FUNCTIONAL GROUP,ST HEADER,1000B etc
Declaration Syntax
C# Visual Basic Visual C++
public class DocumentLoop
Public Class DocumentLoop
public ref class DocumentLoop
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentLoop(String) | Initializes a new instance of the DocumentLoop class.
 | Add(DocumentSegment) | Adds the specified segment.
 | Add(DocumentLoop) | Adds the specified loop.
 | CreateLoop(String) | Creates a new child loop
 | CreateSegment<(Of <<'(T>)>>)()()()() | Creates a segment in this loop
 | DocumentSegments | Gets the segments in this loop
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLoop(String) | Gets a loop by name. Loop names can also be separated by a forward slash (/) charactor for nested searched
 | GetLoops(String) | Gets the loops by name. Loop names can also be separated by a forward slash (/) charactor for nested search
 | GetSegment(String) | Gets the segment by name
 | GetSegment<(Of <<'(T>)>>)()()()() | Gets the segment.
 | GetSegment<(Of <<'(T>)>>)(String) | Gets the segment.
 | GetSegments(String) | Gets the segments by name
 | GetSegments<(Of <<'(T>)>>)(String) | Gets the segments by name and type
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Loops | Gets the loops
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the loop name
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
DocumentLoop

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentLoop Constructor (name)

DocumentLoop Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► DocumentLoop(String)
RDPCrystal EDI Library
Initializes a new instance of the DocumentLoop class.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop(
    string name
)
Public Sub New ( _
    name As String _
)
public:
DocumentLoop(
    String^ name
)
Parameters
name (String)
Name of the Loop

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method

Add Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► Add()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Add(DocumentSegment) | Adds the specified segment.
 | Add(DocumentLoop) | Adds the specified loop.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (loop)

Add Method (loop)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► Add(DocumentLoop)
RDPCrystal EDI Library
Adds the specified loop.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    DocumentLoop loop
)
Public Sub Add ( _
    loop As DocumentLoop _
)
public:
void Add(
    DocumentLoop^ loop
)
Parameters
loop (DocumentLoop)
The loop.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Add Method (segment)

Add Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► Add(DocumentSegment)
RDPCrystal EDI Library
Adds the specified segment.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    DocumentSegment segment
)
Public Sub Add ( _
    segment As DocumentSegment _
)
public:
void Add(
    DocumentSegment^ segment
)
Parameters
segment (DocumentSegment)
The segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method (name)

CreateLoop Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► CreateLoop(String)
RDPCrystal EDI Library
Creates a new child loop
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop CreateLoop(
    string name
)
Public Function CreateLoop ( _
    name As String _
) As DocumentLoop
public:
DocumentLoop^ CreateLoop(
    String^ name
)
Parameters
name (String)
Name of the child loop
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegment Method

CreateSegment<(Of <(<'T>)>)> Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► CreateSegment<(Of <<'(T>)>>)()()()()
RDPCrystal EDI Library
Creates a segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public T CreateSegment<T>()
where T : new(), DocumentSegment

Public Function CreateSegment(Of T As {New, DocumentSegment}) As T
public:
generic<typename T>
where T : gcnew(), DocumentSegment
T CreateSegment()
Generic Template Parameters
T
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentSegments Property

DocumentSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► DocumentSegments
RDPCrystal EDI Library
Gets the segments in this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentSegment> DocumentSegments { get; }
Public ReadOnly Property DocumentSegments As List(Of DocumentSegment)
    Get
public:
property List<DocumentSegment^>^ DocumentSegments {
    List<DocumentSegment^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLoop Method (name)

GetLoop Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetLoop(String)
RDPCrystal EDI Library
Gets a loop by name. Loop names can also be separated by a forward slash (/) charactor for nested searched
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop GetLoop(
    string name
)
Public Function GetLoop ( _
    name As String _
) As DocumentLoop
public:
DocumentLoop^ GetLoop(
    String^ name
)
Parameters
name (String)
Name of the loop.
Return Value
Examples
CopyC#
DocumentLoop loop2000B = loop.GetLoop("FUNCTIONAL GROUP/ST HEADER/2000A/2000B");

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLoops Method (name)

GetLoops Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetLoops(String)
RDPCrystal EDI Library
Gets the loops by name. Loop names can also be separated by a forward slash (/) charactor for nested search
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentLoop> GetLoops(
    string name
)
Public Function GetLoops ( _
    name As String _
) As List(Of DocumentLoop)
public:
List<DocumentLoop^>^ GetLoops(
    String^ name
)
Parameters
name (String)
Name of the loop.
Return Value
Loops
Examples
CopyC#
var allThe2000BLoops c = loop.GetLoops("FUNCTIONAL GROUP/ST HEADER/2000A/2000B");

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method

GetSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetSegment(String) | Gets the segment by name
 | GetSegment<(Of <<'(T>)>>)()()()() | Gets the segment.
 | GetSegment<(Of <<'(T>)>>)(String) | Gets the segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method

GetSegment<(Of <(<'T>)>)> Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegment<(Of <<'(T>)>>)()()()()
RDPCrystal EDI Library
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public T GetSegment<T>()
where T : DocumentSegment

Public Function GetSegment(Of T As DocumentSegment) As T
public:
generic<typename T>
where T : DocumentSegment
T GetSegment()
Generic Template Parameters
T
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method (name)

GetSegment Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegment(String)
RDPCrystal EDI Library
Gets the segment by name
Declaration Syntax
C# Visual Basic Visual C++
public DocumentSegment GetSegment(
    string name
)
Public Function GetSegment ( _
    name As String _
) As DocumentSegment
public:
DocumentSegment^ GetSegment(
    String^ name
)
Parameters
name (String)
Name of the segment
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method (name)

GetSegment<(Of <(<'T>)>)> Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegment<(Of <<'(T>)>>)(String)
RDPCrystal EDI Library
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public T GetSegment<T>(
    string name
)
where T : DocumentSegment

Public Function GetSegment(Of T As DocumentSegment) ( _
    name As String _
) As T
public:
generic<typename T>
where T : DocumentSegment
T GetSegment(
    String^ name
)
Generic Template Parameters
T
Parameters
name (String)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method

GetSegments Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegments()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetSegments(String) | Gets the segments by name
 | GetSegments<(Of <<'(T>)>>)(String) | Gets the segments by name and type

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method (name)

GetSegments<(Of <(<'T>)>)> Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegments<(Of <<'(T>)>>)(String)
RDPCrystal EDI Library
Gets the segments by name and type
Declaration Syntax
C# Visual Basic Visual C++
public List<T> GetSegments<T>(
    string name
)
where T : DocumentSegment

Public Function GetSegments(Of T As DocumentSegment) ( _
    name As String _
) As List(Of T)
public:
generic<typename T>
where T : DocumentSegment
List<T>^ GetSegments(
    String^ name
)
Generic Template Parameters
T
Parameters
name (String)
Name of the segment.
Return Value
A list of segments

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method (name)

GetSegments Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► GetSegments(String)
RDPCrystal EDI Library
Gets the segments by name
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentSegment> GetSegments(
    string name
)
Public Function GetSegments ( _
    name As String _
) As List(Of DocumentSegment)
public:
List<DocumentSegment^>^ GetSegments(
    String^ name
)
Parameters
name (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► Loops
RDPCrystal EDI Library
Gets the loops
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentLoop> Loops { get; }
Public ReadOnly Property Loops As List(Of DocumentLoop)
    Get
public:
property List<DocumentLoop^>^ Loops {
    List<DocumentLoop^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► Name
RDPCrystal EDI Library
Gets or sets the loop name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; private set; }
Public Property Name As String
    Get
    Private Set
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}
Value
The name.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentLoop ► ToString()()()()
RDPCrystal EDI Library
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentSegment Class

DocumentSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment
RDPCrystal EDI Library
Represents a Segment
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DocumentSegment
Public MustInherit Class DocumentSegment
public ref class DocumentSegment abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentSegment()()()() | Initializes a new instance of the DocumentSegment class.
 | DocumentSegment(String) | Initializes a new instance of the DocumentSegment class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value.
 | Load(LightWeightSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | PadDataValue(Int32, Int32, String, Char) |
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
 | Write(WriteArguments) | Writes the specified write args.
 | WriteToBuffer(WriteArguments) | Writes to buffer.
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AAA
 |  | ACD
 |  | ACK
 |  | ACS
 |  | ACT
 |  | AD1
 |  | ADI
 |  | ADJ
 |  | ADT
 |  | ADV
 |  | ADX
 |  | AEI
 |  | AES
 |  | AIN
 |  | AK1
 |  | AK2
 |  | AK3
 |  | AK4
 |  | AK5
 |  | AK9
 |  | AM1
 |  | AMT
 |  | ANI
 |  | AOC
 |  | AOI
 |  | AOL
 |  | AOR
 |  | AP1
 |  | API
 |  | APR
 |  | ARC
 |  | ARS
 |  | ASI
 |  | ASL
 |  | ASM
 |  | ASO
 |  | AST
 |  | AT1
 |  | AT2
 |  | AT3
 |  | AT4
 |  | AT5
 |  | AT6
 |  | AT7
 |  | AT8
 |  | AT9
 |  | ATA
 |  | ATH
 |  | ATN
 |  | ATR
 |  | ATV
 |  | AVA
 |  | AWD
 |  | AXL
 |  | B1
 |  | B10
 |  | B11
 |  | B12
 |  | B13
 |  | B2
 |  | B2A
 |  | B3
 |  | B3A
 |  | B3B
 |  | B4
 |  | B5
 |  | B9
 |  | B9A
 |  | BA1
 |  | BA2
 |  | BAA
 |  | BAK
 |  | BAL
 |  | BAT
 |  | BAU
 |  | BAX
 |  | BBC
 |  | BC
 |  | BCA
 |  | BCD
 |  | BCH
 |  | BCI
 |  | BCM
 |  | BCO
 |  | BCP
 |  | BCQ
 |  | BCS
 |  | BCT
 |  | BCU
 |  | BDD
 |  | BEG
 |  | BEN
 |  | BEP
 |  | BFR
 |  | BFS
 |  | BGF
 |  | BGN
 |  | BGP
 |  | BHT
 |  | BIA
 |  | BIG
 |  | BIN
 |  | BIX
 |  | BJF
 |  | BL
 |  | BLI
 |  | BLN
 |  | BLR
 |  | BLS
 |  | BMA
 |  | BMG
 |  | BMM
 |  | BMP
 |  | BMS
 |  | BNR
 |  | BNX
 |  | BOL
 |  | BOR
 |  | BOS
 |  | BOX
 |  | BPA
 |  | BPP
 |  | BPR
 |  | BPT
 |  | BQR
 |  | BQT
 |  | BR
 |  | BRA
 |  | BRC
 |  | BRR
 |  | BSC
 |  | BSD
 |  | BSF
 |  | BSI
 |  | BSN
 |  | BSR
 |  | BSS
 |  | BT1
 |  | BTA
 |  | BTC
 |  | BTI
 |  | BTP
 |  | BTR
 |  | BTS
 |  | BUY
 |  | BVA
 |  | BVB
 |  | BVP
 |  | BVS
 |  | BW
 |  | BX
 |  | C2
 |  | C3
 |  | C4
 |  | C8
 |  | C8C
 |  | CA1
 |  | CAD
 |  | CAI
 |  | CAL
 |  | CAS
 |  | CAT
 |  | CB1
 |  | CBS
 |  | CCI
 |  | CD
 |  | CD1
 |  | CD2
 |  | CD3
 |  | CDA
 |  | CDD
 |  | CDI
 |  | CDS
 |  | CED
 |  | CF1
 |  | CF2
 |  | CFT
 |  | CGS
 |  | CHB
 |  | CHR
 |  | CI
 |  | CIC
 |  | CID
 |  | CIV
 |  | CL
 |  | CL1
 |  | CLD
 |  | CLI
 |  | CLM
 |  | CLP
 |  | CLR
 |  | CM
 |  | CMA
 |  | CN1
 |  | COB
 |  | COM
 |  | CON
 |  | CPR
 |  | CR1
 |  | CR2
 |  | CR3
 |  | CR4
 |  | CR5
 |  | CR6
 |  | CR7
 |  | CR8
 |  | CRC
 |  | CRD
 |  | CRI
 |  | CRO
 |  | CRS
 |  | CRT
 |  | CRV
 |  | CS
 |  | CSB
 |  | CSC
 |  | CSD
 |  | CSE
 |  | CSF
 |  | CSH
 |  | CSI
 |  | CSM
 |  | CSS
 |  | CST
 |  | CSU
 |  | CT
 |  | CTB
 |  | CTC
 |  | CTP
 |  | CTT
 |  | CUR
 |  | CV
 |  | CYC
 |  | D9
 |  | DAD
 |  | DAI
 |  | DAM
 |  | DB
 |  | DD
 |  | DDI
 |  | DED
 |  | DEF
 |  | DEG
 |  | DEL
 |  | DEP
 |  | DEX
 |  | DFI
 |  | DH
 |  | DIS
 |  | DK
 |  | DL
 |  | DLV
 |  | DM
 |  | DMA
 |  | DMG
 |  | DMI
 |  | DN
 |  | DN1
 |  | DN2
 |  | DOS
 |  | DP
 |  | DPN
 |  | DR
 |  | DRT
 |  | DSB
 |  | DTM
 |  | DTP
 |  | DVI
 |  | E01
 |  | E03
 |  | E1
 |  | E10
 |  | E13
 |  | E20
 |  | E22
 |  | E24
 |  | E26
 |  | E30
 |  | E34
 |  | E4
 |  | E40
 |  | E5
 |  | E6
 |  | E8
 |  | EA
 |  | EB
 |  | EC
 |  | ED
 |  | EFI
 |  | EI
 |  | EIA
 |  | EM
 |  | EMP
 |  | EMS
 |  | EMT
 |  | ENE
 |  | ENR
 |  | ENT
 |  | EQ
 |  | ER
 |  | ERI
 |  | ERP
 |  | ES
 |  | ESI
 |  | ETD
 |  | EXI
 |  | F01
 |  | F02
 |  | F04
 |  | F05
 |  | F07
 |  | F09
 |  | F10
 |  | F11
 |  | F12
 |  | F13
 |  | F14
 |  | F6X
 |  | F9
 |  | FA1
 |  | FA2
 |  | FAA
 |  | FAC
 |  | FBB
 |  | FC
 |  | FCL
 |  | FDA
 |  | FG
 |  | FGS
 |  | FH
 |  | FIR
 |  | FIS
 |  | FK
 |  | FNA
 |  | FOB
 |  | FOS
 |  | FPT
 |  | FSA
 |  | FST
 |  | FTH
 |  | G01
 |  | G05
 |  | G07
 |  | G08
 |  | G1
 |  | G11
 |  | G12
 |  | G13
 |  | G14
 |  | G15
 |  | G17
 |  | G18
 |  | G19
 |  | G2
 |  | G20
 |  | G21
 |  | G22
 |  | G23
 |  | G24
 |  | G25
 |  | G26
 |  | G27
 |  | G28
 |  | G29
 |  | G3
 |  | G30
 |  | G31
 |  | G32
 |  | G33
 |  | G35
 |  | G36
 |  | G37
 |  | G38
 |  | G39
 |  | G4
 |  | G40
 |  | G42
 |  | G43
 |  | G45
 |  | G46
 |  | G47
 |  | G48
 |  | G49
 |  | G5
 |  | G50
 |  | G51
 |  | G53
 |  | G54
 |  | G55
 |  | G61
 |  | G62
 |  | G63
 |  | G66
 |  | G68
 |  | G69
 |  | G70
 |  | G72
 |  | G73
 |  | G76
 |  | G82
 |  | G83
 |  | G84
 |  | G85
 |  | G86
 |  | G87
 |  | G88
 |  | G89
 |  | G91
 |  | G92
 |  | G93
 |  | G94
 |  | G95
 |  | GA
 |  | GDP
 |  | GE
 |  | GF
 |  | GH
 |  | GID
 |  | GR
 |  | GR2
 |  | GR4
 |  | GR5
 |  | GRI
 |  | GRP
 |  | GS
 |  | GY
 |  | H1
 |  | H2
 |  | H3
 |  | H5
 |  | H6
 |  | HC
 |  | HCP
 |  | HCR
 |  | HD
 |  | HI
 |  | HL
 |  | HLH
 |  | HS
 |  | HSD
 |  | IA
 |  | IC
 |  | ICH
 |  | ICM
 |  | ID
 |  | ID1
 |  | ID2
 |  | ID3
 |  | ID4
 |  | IDB
 |  | IDC
 |  | IEA
 |  | IGI
 |  | IH
 |  | III
 |  | IIS
 |  | IM
 |  | IMA
 |  | IMM
 |  | IMP
 |  | IN1
 |  | IN2
 |  | INC
 |  | IND
 |  | INQ
 |  | INR
 |  | INS
 |  | INT
 |  | INV
 |  | INX
 |  | IRA
 |  | IRP
 |  | IS1
 |  | IS2
 |  | ISA
 |  | ISB
 |  | ISC
 |  | ISD
 |  | ISE
 |  | ISR
 |  | ISS
 |  | IT
 |  | IT1
 |  | IT3
 |  | IT8
 |  | ITA
 |  | ITC
 |  | ITD
 |  | IV1
 |  | JCT
 |  | JID
 |  | JIL
 |  | JIT
 |  | JL
 |  | JS
 |  | K1
 |  | K2
 |  | K3
 |  | L0
 |  | L1
 |  | L10
 |  | L11
 |  | L12
 |  | L13
 |  | L1A
 |  | L3
 |  | L4
 |  | L5
 |  | L7
 |  | L7A
 |  | L8
 |  | L9
 |  | LAD
 |  | LC
 |  | LC1
 |  | LCD
 |  | LCT
 |  | LDT
 |  | LE
 |  | LEP
 |  | LEQ
 |  | LET
 |  | LFG
 |  | LFH
 |  | LFI
 |  | LH
 |  | LH1
 |  | LH2
 |  | LH3
 |  | LH4
 |  | LH6
 |  | LHE
 |  | LHR
 |  | LHT
 |  | LIC
 |  | LID
 |  | LIE
 |  | LIN
 |  | LM
 |  | LN
 |  | LN1
 |  | LN2
 |  | LOC
 |  | LOD
 |  | LP
 |  | LQ
 |  | LRQ
 |  | LS
 |  | LS1
 |  | LT
 |  | LTE
 |  | LTR
 |  | LUC
 |  | LUI
 |  | LV
 |  | LX
 |  | M0
 |  | M1
 |  | M10
 |  | M11
 |  | M12
 |  | M13
 |  | M14
 |  | M15
 |  | M2
 |  | M20
 |  | M21
 |  | M3
 |  | M7
 |  | M7A
 |  | MAN
 |  | MBL
 |  | MC
 |  | MCD
 |  | MCT
 |  | MEA
 |  | MI
 |  | MI1
 |  | MIA
 |  | MIC
 |  | MII
 |  | MIN
 |  | MIR
 |  | MIS
 |  | MIT
 |  | MKS
 |  | MLS
 |  | MNC
 |  | MOA
 |  | MPI
 |  | MPP
 |  | MRC
 |  | MS
 |  | MS1
 |  | MS2
 |  | MS3
 |  | MS4
 |  | MS5
 |  | MS6
 |  | MSG
 |  | MSS
 |  | MTX
 |  | N1
 |  | N10
 |  | N11
 |  | N12
 |  | N2
 |  | N3
 |  | N4
 |  | N5
 |  | N7
 |  | N7A
 |  | N7B
 |  | N8
 |  | N8A
 |  | N9
 |  | NA
 |  | NCA
 |  | NCD
 |  | NM1
 |  | NTE
 |  | NX1
 |  | NX2
 |  | OBI
 |  | OD
 |  | OI
 |  | OID
 |  | OP
 |  | OPS
 |  | OPX
 |  | OQS
 |  | OTI
 |  | P1
 |  | P2
 |  | P4
 |  | P5
 |  | PAD
 |  | PAI
 |  | PAL
 |  | PAM
 |  | PAS
 |  | PAT
 |  | PAY
 |  | PBI
 |  | PCL
 |  | PCR
 |  | PCS
 |  | PCT
 |  | PD
 |  | PDD
 |  | PDE
 |  | PDL
 |  | PDP
 |  | PDR
 |  | PDS
 |  | PEN
 |  | PER
 |  | PEX
 |  | PI
 |  | PID
 |  | PIN
 |  | PKD
 |  | PKG
 |  | PKL
 |  | PL
 |  | PLA
 |  | PLB
 |  | PLC
 |  | PLD
 |  | PLI
 |  | PM
 |  | PO1
 |  | PO3
 |  | PO4
 |  | POC
 |  | POD
 |  | PPA
 |  | PPD
 |  | PPL
 |  | PPY
 |  | PR
 |  | PR1
 |  | PR2
 |  | PRC
 |  | PRD
 |  | PRF
 |  | PRI
 |  | PRJ
 |  | PRM
 |  | PRR
 |  | PRS
 |  | PRT
 |  | PRV
 |  | PS
 |  | PS1
 |  | PSA
 |  | PSC
 |  | PSD
 |  | PT
 |  | PTD
 |  | PTF
 |  | PUN
 |  | PWK
 |  | PYD
 |  | PYM
 |  | PYT
 |  | Q2
 |  | Q3
 |  | Q5
 |  | Q6
 |  | Q7
 |  | Q8
 |  | QTY
 |  | R1
 |  | R2
 |  | R2A
 |  | R2B
 |  | R2C
 |  | R2D
 |  | R3
 |  | R4
 |  | R9
 |  | RA
 |  | RAB
 |  | RAP
 |  | RAT
 |  | RB
 |  | RC
 |  | RCD
 |  | RD
 |  | RDD
 |  | RDI
 |  | RDM
 |  | RDR
 |  | RDT
 |  | RE
 |  | REA
 |  | REC
 |  | RED
 |  | REF
 |  | REL
 |  | REN
 |  | REP
 |  | REQ
 |  | RET
 |  | RH
 |  | RIC
 |  | RLD
 |  | RLT
 |  | RMR
 |  | RMT
 |  | RO
 |  | RP
 |  | RPA
 |  | RQS
 |  | RRA
 |  | RS
 |  | RSC
 |  | RSD
 |  | RST
 |  | RT
 |  | RT1
 |  | RTE
 |  | RTS
 |  | RTT
 |  | RU1
 |  | RU2
 |  | RU3
 |  | RYL
 |  | S1
 |  | S1A
 |  | S1E
 |  | S1S
 |  | S2
 |  | S2A
 |  | S2E
 |  | S2S
 |  | S3A
 |  | S3E
 |  | S3S
 |  | S4A
 |  | S4E
 |  | S4S
 |  | S5
 |  | S9
 |  | SA
 |  | SAC
 |  | SAL
 |  | SB
 |  | SBR
 |  | SBT
 |  | SC
 |  | SCA
 |  | SCD
 |  | SCH
 |  | SCL
 |  | SCM
 |  | SCN
 |  | SCO
 |  | SCP
 |  | SCS
 |  | SCT
 |  | SD1
 |  | SDP
 |  | SDQ
 |  | SE
 |  | SER
 |  | SES
 |  | SFC
 |  | SG
 |  | SHD
 |  | SHP
 |  | SHR
 |  | SI
 |  | SID
 |  | SII
 |  | SIN
 |  | SL1
 |  | SLI
 |  | SLN
 |  | SMA
 |  | SMB
 |  | SMD
 |  | SMO
 |  | SMR
 |  | SMS
 |  | SN1
 |  | SOI
 |  | SOM
 |  | SP
 |  | SPA
 |  | SPI
 |  | SPK
 |  | SPO
 |  | SPR
 |  | SPS
 |  | SPY
 |  | SR
 |  | SRA
 |  | SRD
 |  | SRE
 |  | SRM
 |  | SRT
 |  | SS
 |  | SSC
 |  | SSD
 |  | SSE
 |  | SSS
 |  | SST
 |  | ST
 |  | STA
 |  | STC
 |  | STP
 |  | STS
 |  | SUM
 |  | SUP
 |  | SV
 |  | SV1
 |  | SV2
 |  | SV3
 |  | SV4
 |  | SV5
 |  | SV6
 |  | SV7
 |  | SVA
 |  | SVC
 |  | SVD
 |  | SW
 |  | T1
 |  | T2
 |  | T3
 |  | T6
 |  | T8
 |  | TA1
 |  | TA3
 |  | TAX
 |  | TBA
 |  | TBI
 |  | TC2
 |  | TCD
 |  | TD1
 |  | TD3
 |  | TD4
 |  | TD5
 |  | TDS
 |  | TED
 |  | TEM
 |  | TER
 |  | TF
 |  | TFA
 |  | TFD
 |  | TFM
 |  | TFR
 |  | TFS
 |  | THE
 |  | TI
 |  | TIA
 |  | TID
 |  | TIS
 |  | TLN
 |  | TMD
 |  | TOA
 |  | TOO
 |  | TOV
 |  | TPB
 |  | TPD
 |  | TRF
 |  | TRN
 |  | TRS
 |  | TS
 |  | TS2
 |  | TS3
 |  | TSD
 |  | TSI
 |  | TSP
 |  | TST
 |  | TSU
 |  | TT
 |  | TUD
 |  | TXI
 |  | TXN
 |  | TXP
 |  | UC
 |  | UCS
 |  | UD
 |  | UDA
 |  | UIT
 |  | UM
 |  | UQS
 |  | UR
 |  | USD
 |  | UWI
 |  | V1
 |  | V2
 |  | V3
 |  | V4
 |  | V5
 |  | V9
 |  | VAD
 |  | VAR
 |  | VAT
 |  | VC
 |  | VC1
 |  | VDI
 |  | VEH
 |  | VID
 |  | VR
 |  | VRC
 |  | W01
 |  | W03
 |  | W04
 |  | W05
 |  | W06
 |  | W07
 |  | W08
 |  | W09
 |  | W1
 |  | W10
 |  | W12
 |  | W13
 |  | W14
 |  | W15
 |  | W17
 |  | W18
 |  | W19
 |  | W2
 |  | W20
 |  | W27
 |  | W28
 |  | W3
 |  | W4
 |  | W5
 |  | W6
 |  | W66
 |  | W76
 |  | WGP
 |  | WS
 |  | X01
 |  | X02
 |  | X1
 |  | X2
 |  | X4
 |  | X7
 |  | XD
 |  | XH
 |  | XPO
 |  | XQ
 |  | Y1
 |  | Y2
 |  | Y3
 |  | Y4
 |  | Y5
 |  | Y6
 |  | Y7
 |  | YNQ
 |  | ZA
 |  | ZC1
 |  | ZD
 |  | ZR
 |  | ZT
 |  | AAA
 |  | ACT
 |  | AK1
 |  | AK2
 |  | AK9
 |  | AMT
 |  | BGN
 |  | BHT
 |  | BPR
 |  | CAS
 |  | CL1
 |  | CLM
 |  | CLP
 |  | CN1
 |  | COB
 |  | CR1
 |  | CR2
 |  | CR3
 |  | CR5
 |  | CR6
 |  | CRC
 |  | CTP
 |  | CTX
 |  | CUR
 |  | DMG
 |  | DN1
 |  | DN2
 |  | DSB
 |  | DTM
 |  | DTP
 |  | EB
 |  | EC
 |  | EQ
 |  | FRM
 |  | GE
 |  | GS
 |  | HCP
 |  | HD
 |  | HI
 |  | HL
 |  | HLH
 |  | HSD
 |  | ICM
 |  | IDC
 |  | IEA
 |  | III
 |  | IK3
 |  | IK4
 |  | IK5
 |  | INS
 |  | ISA
 |  | K3
 |  | LE
 |  | LIN
 |  | LQ
 |  | LS
 |  | LUI
 |  | LX
 |  | MEA
 |  | MIA
 |  | MOA
 |  | MPI
 |  | MSG
 |  | N1
 |  | N3
 |  | N4
 |  | NM1
 |  | NTE
 |  | OI
 |  | PAT
 |  | PER
 |  | PLA
 |  | PLB
 |  | PRV
 |  | PS1
 |  | PWK
 |  | QTY
 |  | RDM
 |  | REF
 |  | SBR
 |  | SE
 |  | ST
 |  | STC
 |  | SV1
 |  | SV2
 |  | SV3
 |  | SV5
 |  | SVC
 |  | SVD
 |  | TOO
 |  | TRN
 |  | TS2
 |  | TS3
 |  | UM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentSegment Constructor

DocumentSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► DocumentSegment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | DocumentSegment()()()() | Initializes a new instance of the DocumentSegment class.
 | DocumentSegment(String) | Initializes a new instance of the DocumentSegment class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentSegment Constructor

DocumentSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► DocumentSegment()()()()
RDPCrystal EDI Library
Initializes a new instance of the DocumentSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentSegment()
Public Sub New
public:
DocumentSegment()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DocumentSegment Constructor (name)

DocumentSegment Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► DocumentSegment(String)
RDPCrystal EDI Library
Initializes a new instance of the DocumentSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentSegment(
    string name
)
Public Sub New ( _
    name As String _
)
public:
DocumentSegment(
    String^ name
)
Parameters
name (String)
Name of segment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetValue Method (element)

GetValue Method (element)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► GetValue(LightWeightElement)
RDPCrystal EDI Library
Gets the value.
Declaration Syntax
C# Visual Basic Visual C++
public string GetValue(
    LightWeightElement element
)
Public Function GetValue ( _
    element As LightWeightElement _
) As String
public:
String^ GetValue(
    LightWeightElement^ element
)
Parameters
element (LightWeightElement)
The element.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Load(
    LightWeightSegment segment
)
Public Overridable Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
)
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► Name
RDPCrystal EDI Library
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PadDataValue Method (minLength, maxLength, dataValue, paddingChar)

PadDataValue Method (minLength, maxLength, dataValue, paddingChar)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► PadDataValue(Int32, Int32, String, Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected string PadDataValue(
    int minLength,
    int maxLength,
    string dataValue,
    char paddingChar
)
Protected Function PadDataValue ( _
    minLength As Integer, _
    maxLength As Integer, _
    dataValue As String, _
    paddingChar As Char _
) As String
protected:
String^ PadDataValue(
    int minLength,
    int maxLength,
    String^ dataValue,
    wchar_t paddingChar
)
Parameters
minLength (Int32)
maxLength (Int32)
dataValue (String)
paddingChar (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► ToString()()()()
RDPCrystal EDI Library
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Write Method (writeArgs)

Write Method (writeArgs)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► Write(WriteArguments)
RDPCrystal EDI Library
Writes the specified write args.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Write(
    WriteArguments writeArgs
)
Public Overridable Sub Write ( _
    writeArgs As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ writeArgs
)
Parameters
writeArgs (WriteArguments)
The write args.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


WriteToBuffer Method (w)

WriteToBuffer Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentSegment ► WriteToBuffer(WriteArguments)
RDPCrystal EDI Library
Writes to buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected void WriteToBuffer(
    WriteArguments w
)
Protected Sub WriteToBuffer ( _
    w As WriteArguments _
)
protected:
void WriteToBuffer(
    WriteArguments^ w
)
Parameters
w (WriteArguments)
The w.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocument Class

EDIDocument Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument
RDPCrystal EDI Library
Creates EDI X12 and EDIFACT document files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIDocument : Component
Public NotInheritable Class EDIDocument _
    Inherits Component
public ref class EDIDocument sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIDocument(IContainer) | Creates a new EDIDocument component
 | EDIDocument()()()() | Creates a new EDIDocument component
 | EDIDocument(String) | Creates a new EDIDocument component specifying the path of the output file
 | EDIDocument(FileStream) | Creates a new EDIDocument component specifying the path of the output file
 | AutoPlaceCorrectNumOfGT | Places the correct number of GS Functional Groups in the IEA segment element 1
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
 | AutoPlaceCorrectNumOfST | Places the correct number of ST Headers in the GE segment element 1
 | AutoTrimElements | Trims blank spaces from the beginning and ending of element data
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters | Segment and element delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDocumentFinished | Event raised when EDI document creation process has completed
 | EDIFilePath | Full path including file name of EDI file to create. If the file already exists it is overwritten
 | EDIFileString | A string representation of the EDI file created
 | EDIXMLFileString | A string representation of the EDI XML file created
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBufferSize | Initial file buffer size when generating EDI files
 | FileStream | Optional filestream to save EDI document to
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GenerateEDIData()()()() | Generate EDI Data without writing to a filestream
 | GenerateEDIFile(Boolean) | Generate EDI file. By setting testing to true, a detailed EDI file will be created complete with loop names. This is for debugging purposes only
 | GenerateEDIFile()()()() | Generate EDI file
 | GenerateEDIFile(String) | Generate EDI file
 | GenerateEDIFileWithBatchWrite()()()() | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String, Int32, Char) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Loops | Main EDI loop. All other loops will be added to this loop
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadDataValues | Pad or trims element data to reach mininum and maximum element length requirements
 | SegmentSeparatorString | String to insert between segments for formatting
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | ToXml()()()() | Converts this EDIDocument into an XMLDocument
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDIDocument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDIDocument to Xml
 | TruncateEmptyCompositeElements | Removes empty trailing composites elements
 | TruncateEmptyElements | Removes empty trailing elements
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocument Constructor

EDIDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIDocument(IContainer) | Creates a new EDIDocument component
 | EDIDocument()()()() | Creates a new EDIDocument component
 | EDIDocument(String) | Creates a new EDIDocument component specifying the path of the output file
 | EDIDocument(FileStream) | Creates a new EDIDocument component specifying the path of the output file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocument Constructor

EDIDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument()()()()
RDPCrystal EDI Library
Creates a new EDIDocument component
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument()
Public Sub New
public:
EDIDocument()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocument Constructor (container)

EDIDocument Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument(IContainer)
RDPCrystal EDI Library
Creates a new EDIDocument component
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIDocument(
    IContainer^ container
)
Parameters
container (IContainer)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocument Constructor (fileStream)

EDIDocument Constructor (fileStream)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument(FileStream)
RDPCrystal EDI Library
Creates a new EDIDocument component specifying the path of the output file
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument(
    FileStream fileStream
)
Public Sub New ( _
    fileStream As FileStream _
)
public:
EDIDocument(
    FileStream^ fileStream
)
Parameters
fileStream (FileStream)
stream to write EDI data to

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocument Constructor (outputFileName)

EDIDocument Constructor (outputFileName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument(String)
RDPCrystal EDI Library
Creates a new EDIDocument component specifying the path of the output file
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument(
    string outputFileName
)
Public Sub New ( _
    outputFileName As String _
)
public:
EDIDocument(
    String^ outputFileName
)
Parameters
outputFileName (String)
path of the output file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfGT Property

AutoPlaceCorrectNumOfGT Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoPlaceCorrectNumOfGT
RDPCrystal EDI Library
Places the correct number of GS Functional Groups in the IEA segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfGT { get; set; }
Public Property AutoPlaceCorrectNumOfGT As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfGT {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfSegments Property

AutoPlaceCorrectNumOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoPlaceCorrectNumOfSegments
RDPCrystal EDI Library
Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfSegments { get; set; }
Public Property AutoPlaceCorrectNumOfSegments As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfSegments {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfST Property

AutoPlaceCorrectNumOfST Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoPlaceCorrectNumOfST
RDPCrystal EDI Library
Places the correct number of ST Headers in the GE segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfST { get; set; }
Public Property AutoPlaceCorrectNumOfST As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfST {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoTrimElements Property

AutoTrimElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoTrimElements
RDPCrystal EDI Library
Trims blank spaces from the beginning and ending of element data
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoTrimElements { get; set; }
Public Property AutoTrimElements As Boolean
    Get
    Set
public:
property bool AutoTrimElements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Delimiters
RDPCrystal EDI Library
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocumentFinished Event

EDIDocumentFinished Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocumentFinished
RDPCrystal EDI Library
Event raised when EDI document creation process has completed
Declaration Syntax
C# Visual Basic Visual C++
public event GeneralEvent EDIDocumentFinished
Public Event EDIDocumentFinished As GeneralEvent
public:
 event GeneralEvent^ EDIDocumentFinished {
    void add (GeneralEvent^ value);
    void remove (GeneralEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFilePath Property

EDIFilePath Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIFilePath
RDPCrystal EDI Library
Full path including file name of EDI file to create. If the file already exists it is overwritten
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFilePath { get; set; }
Public Property EDIFilePath As String
    Get
    Set
public:
property String^ EDIFilePath {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileString Property

EDIFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIFileString
RDPCrystal EDI Library
A string representation of the EDI file created
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFileString { get; internal set; }
Public Property EDIFileString As String
    Get
    Friend Set
public:
property String^ EDIFileString {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIXMLFileString Property

EDIXMLFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIXMLFileString
RDPCrystal EDI Library
A string representation of the EDI XML file created
Declaration Syntax
C# Visual Basic Visual C++
public string EDIXMLFileString { get; internal set; }
Public Property EDIXMLFileString As String
    Get
    Friend Set
public:
property String^ EDIXMLFileString {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileBufferSize Property

FileBufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► FileBufferSize
RDPCrystal EDI Library
Initial file buffer size when generating EDI files
Declaration Syntax
C# Visual Basic Visual C++
public int FileBufferSize { get; set; }
Public Property FileBufferSize As Integer
    Get
    Set
public:
property int FileBufferSize {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileStream Property

FileStream Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► FileStream
RDPCrystal EDI Library
Optional filestream to save EDI document to
Declaration Syntax
C# Visual Basic Visual C++
public FileStream FileStream { get; set; }
Public Property FileStream As FileStream
    Get
    Set
public:
property FileStream^ FileStream {
    FileStream^ get ();
    void set (FileStream^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIData Method

GenerateEDIData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIData()()()()
RDPCrystal EDI Library
Generate EDI Data without writing to a filestream
Declaration Syntax
C# Visual Basic Visual C++
public string GenerateEDIData()
Public Function GenerateEDIData As String
public:
String^ GenerateEDIData()
Return Value
EDI data as string

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GenerateEDIFile(Boolean) | Generate EDI file. By setting testing to true, a detailed EDI file will be created complete with loop names. This is for debugging purposes only
 | GenerateEDIFile()()()() | Generate EDI file
 | GenerateEDIFile(String) | Generate EDI file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Generate EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile()
Public Sub GenerateEDIFile
public:
void GenerateEDIFile()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method (testing)

GenerateEDIFile Method (testing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile(Boolean)
RDPCrystal EDI Library
Generate EDI file. By setting testing to true, a detailed EDI file will be created complete with loop names. This is for debugging purposes only
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    bool testing
)
Public Sub GenerateEDIFile ( _
    testing As Boolean _
)
public:
void GenerateEDIFile(
    bool testing
)
Parameters
testing (Boolean)
for debugging purposes true is used, else false

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method (outputFile)

GenerateEDIFile Method (outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile(String)
RDPCrystal EDI Library
Generate EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    string outputFile
)
Public Sub GenerateEDIFile ( _
    outputFile As String _
)
public:
void GenerateEDIFile(
    String^ outputFile
)
Parameters
outputFile (String)
file path (including name of file) of EDI file to create

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFileWithBatchWrite Method

GenerateEDIFileWithBatchWrite Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GenerateEDIFileWithBatchWrite()()()() | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String, Int32, Char) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFileWithBatchWrite Method

GenerateEDIFileWithBatchWrite Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite()()()()
RDPCrystal EDI Library
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite()
Public Sub GenerateEDIFileWithBatchWrite
public:
void GenerateEDIFileWithBatchWrite()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFileWithBatchWrite Method (outputFile)

GenerateEDIFileWithBatchWrite Method (outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite(String)
RDPCrystal EDI Library
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite(
    string outputFile
)
Public Sub GenerateEDIFileWithBatchWrite ( _
    outputFile As String _
)
public:
void GenerateEDIFileWithBatchWrite(
    String^ outputFile
)
Parameters
outputFile (String)
path of outputfile

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFileWithBatchWrite Method (outputFile, insertInterval, insertChar)

GenerateEDIFileWithBatchWrite Method (outputFile, insertInterval, insertChar)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite(String, Int32, Char)
RDPCrystal EDI Library
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite(
    string outputFile,
    int insertInterval,
    char insertChar
)
Public Sub GenerateEDIFileWithBatchWrite ( _
    outputFile As String, _
    insertInterval As Integer, _
    insertChar As Char _
)
public:
void GenerateEDIFileWithBatchWrite(
    String^ outputFile,
    int insertInterval,
    wchar_t insertChar
)
Parameters
outputFile (String)
path of outputfile
insertInterval (Int32)
the insert interval
insertChar (Char)
Char to insert every interval

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Loops
RDPCrystal EDI Library
Main EDI loop. All other loops will be added to this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<Loop> Loops { get; set; }
Public Property Loops As List(Of Loop)
    Get
    Set
public:
property List<Loop^>^ Loops {
    List<Loop^>^ get ();
    void set (List<Loop^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PadDataValues Property

PadDataValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► PadDataValues
RDPCrystal EDI Library
Pad or trims element data to reach mininum and maximum element length requirements
Declaration Syntax
C# Visual Basic Visual C++
public bool PadDataValues { get; set; }
Public Property PadDataValues As Boolean
    Get
    Set
public:
property bool PadDataValues {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSeparatorString Property

SegmentSeparatorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► SegmentSeparatorString
RDPCrystal EDI Library
String to insert between segments for formatting
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSeparatorString { get; set; }
Public Property SegmentSeparatorString As String
    Get
    Set
public:
property String^ SegmentSeparatorString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ToXml()()()() | Converts this EDIDocument into an XMLDocument
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDIDocument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDIDocument to Xml

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml()()()()
RDPCrystal EDI Library
Converts this EDIDocument into an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (options)

ToXml Method (options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml(XmlConfigOptions)
RDPCrystal EDI Library
Converts this EDILightWeightDOcument to an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml(
    XmlConfigOptions options
)
Public Function ToXml ( _
    options As XmlConfigOptions _
) As XmlDocument
public:
XmlDocument^ ToXml(
    XmlConfigOptions^ options
)
Parameters
options (XmlConfigOptions)
Configuration options
Return Value
XmlDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (filename)

ToXml Method (filename)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml(String)
RDPCrystal EDI Library
Converts this EDIDocument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string filename
)
Public Sub ToXml ( _
    filename As String _
)
public:
void ToXml(
    String^ filename
)
Parameters
filename (String)
The file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (file, options)

ToXml Method (file, options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml(String, XmlConfigOptions)
RDPCrystal EDI Library
Converts this EDIDocument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file,
    XmlConfigOptions options
)
Public Sub ToXml ( _
    file As String, _
    options As XmlConfigOptions _
)
public:
void ToXml(
    String^ file,
    XmlConfigOptions^ options
)
Parameters
file (String)
The file.
options (XmlConfigOptions)
Xml options.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TruncateEmptyCompositeElements Property

TruncateEmptyCompositeElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► TruncateEmptyCompositeElements
RDPCrystal EDI Library
Removes empty trailing composites elements
Declaration Syntax
C# Visual Basic Visual C++
public bool TruncateEmptyCompositeElements { get; set; }
Public Property TruncateEmptyCompositeElements As Boolean
    Get
    Set
public:
property bool TruncateEmptyCompositeElements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TruncateEmptyElements Property

TruncateEmptyElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► TruncateEmptyElements
RDPCrystal EDI Library
Removes empty trailing elements
Declaration Syntax
C# Visual Basic Visual C++
public bool TruncateEmptyElements { get; set; }
Public Property TruncateEmptyElements As Boolean
    Get
    Set
public:
property bool TruncateEmptyElements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocumentException Class

EDIDocumentException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocumentException
RDPCrystal EDI Library
Exception thrown when an exception occurred while generating an EDI document
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EDIDocumentException : Exception
<SerializableAttribute> _
Public Class EDIDocumentException _
    Inherits Exception
[SerializableAttribute]
public ref class EDIDocumentException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | EDIDocumentException

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIError Class

EDIError Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError
RDPCrystal EDI Library
Represents a general EDI error. Errors are available after validation
Declaration Syntax
C# Visual Basic Visual C++
public class EDIError
Public Class EDIError
public ref class EDIError
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIError()()()() | Initializes a new instance of the EDIError class
 | EDIError(Int32, String, String, Int32, Int32, EDIValidationMessage, String, LightWeightSegment, LightWeightSegment, String, Int64, DataSegment) | Initializes a new instance of the EDIError class
 | CompositeElementDescription | Description of the composite element that contains the error
 | CompositeElementOrdinal | Get the composite element number that contains the error
 | Description | Get the description of the error
 | ElementDescription | Description of the element that contains the error
 | ElementOrdinal | Get the element number that contains the error
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GSSegment | Gets the GS segment.
 | LineNumber | Get the line number of the error in the EDI file
 | Loop | Get the name of the loop that contains the error
 | LoopDescription | Description of the loop that contains the error
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | General error message type
 | Segment | Get the name of the segment that contains the error
 | SegmentDescription | Description of the segment that contains the error
 | SegmentOrdinal | Get the segment ordinal number that contains the error
 | SegmentPositionInTransaction | Gets or sets the segment position in transaction.
 | SegmentSchema | The schema of the segment that was being validated while the error/warning occurred
 | SetSnipLevel()()()() | Sets the snip level.
 | SnipLevel | Snip level
 | StackTrace | Gets the stack trace if this is an unexpected error
 | STSegment | Gets the ST segment.
 | ToString()()()() | Get a string represenation of the error (Overrides Object.ToString()()()().)
 | ValidatingSegment | The actual segment that was being evaluated while the error/warning occurred
Inheritance Hierarchy
Object
 | EDIError
 |  | EDIWarning

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIError Constructor

EDIError Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► EDIError()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIError()()()() | Initializes a new instance of the EDIError class
 | EDIError(Int32, String, String, Int32, Int32, EDIValidationMessage, String, LightWeightSegment, LightWeightSegment, String, Int64, DataSegment) | Initializes a new instance of the EDIError class

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIError Constructor

EDIError Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► EDIError()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIError class
Declaration Syntax
C# Visual Basic Visual C++
public EDIError()
Public Sub New
public:
EDIError()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIError Constructor (lineNumber, loop, segment, elementOrdinal, compositeElementOrd, message, description, currentSTSegment, currentGSSegment, position, segmentPosition, schemaSeg)

EDIError Constructor (lineNumber, loop, segment, elementOrdinal, compositeElementOrd, message, description, currentSTSegment, currentGSSegment, position, segmentPosition, schemaSeg)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► EDIError(Int32, String, String, Int32, Int32, EDIValidationMessage, String, LightWeightSegment, LightWeightSegment, String, Int64, DataSegment)
RDPCrystal EDI Library
Initializes a new instance of the EDIError class
Declaration Syntax
C# Visual Basic Visual C++
public EDIError(
    int lineNumber,
    string loop,
    string segment,
    int elementOrdinal,
    int compositeElementOrd,
    EDIValidationMessage message,
    string description,
    LightWeightSegment currentSTSegment,
    LightWeightSegment currentGSSegment,
    string position,
    long segmentPosition,
    DataSegment schemaSeg
)
Public Sub New ( _
    lineNumber As Integer, _
    loop As String, _
    segment As String, _
    elementOrdinal As Integer, _
    compositeElementOrd As Integer, _
    message As EDIValidationMessage, _
    description As String, _
    currentSTSegment As LightWeightSegment, _
    currentGSSegment As LightWeightSegment, _
    position As String, _
    segmentPosition As Long, _
    schemaSeg As DataSegment _
)
public:
EDIError(
    int lineNumber,
    String^ loop,
    String^ segment,
    int elementOrdinal,
    int compositeElementOrd,
    EDIValidationMessage message,
    String^ description,
    LightWeightSegment^ currentSTSegment,
    LightWeightSegment^ currentGSSegment,
    String^ position,
    long long segmentPosition,
    DataSegment^ schemaSeg
)
Parameters
lineNumber (Int32)
loop (String)
segment (String)
elementOrdinal (Int32)
compositeElementOrd (Int32)
message (EDIValidationMessage)
description (String)
currentSTSegment (LightWeightSegment)
currentGSSegment (LightWeightSegment)
position (String)
segmentPosition (Int64)
schemaSeg (DataSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementDescription Property

CompositeElementDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► CompositeElementDescription
RDPCrystal EDI Library
Description of the composite element that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string CompositeElementDescription { get; internal set; }
Public Property CompositeElementDescription As String
    Get
    Friend Set
public:
property String^ CompositeElementDescription {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementOrdinal Property

CompositeElementOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► CompositeElementOrdinal
RDPCrystal EDI Library
Get the composite element number that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public int CompositeElementOrdinal { get; internal set; }
Public Property CompositeElementOrdinal As Integer
    Get
    Friend Set
public:
property int CompositeElementOrdinal {
    int get ();
    internal: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Description
RDPCrystal EDI Library
Get the description of the error
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; internal set; }
Public Property Description As String
    Get
    Friend Set
public:
property String^ Description {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementDescription Property

ElementDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ElementDescription
RDPCrystal EDI Library
Description of the element that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string ElementDescription { get; internal set; }
Public Property ElementDescription As String
    Get
    Friend Set
public:
property String^ ElementDescription {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinal Property

ElementOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ElementOrdinal
RDPCrystal EDI Library
Get the element number that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinal { get; internal set; }
Public Property ElementOrdinal As Integer
    Get
    Friend Set
public:
property int ElementOrdinal {
    int get ();
    internal: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GSSegment Property

GSSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► GSSegment
RDPCrystal EDI Library
Gets the GS segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GSSegment { get; internal set; }
Public Property GSSegment As LightWeightSegment
    Get
    Friend Set
public:
property LightWeightSegment^ GSSegment {
    LightWeightSegment^ get ();
    internal: void set (LightWeightSegment^ value);
}
Value
The ST segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LineNumber Property

LineNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► LineNumber
RDPCrystal EDI Library
Get the line number of the error in the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public int LineNumber { get; internal set; }
Public Property LineNumber As Integer
    Get
    Friend Set
public:
property int LineNumber {
    int get ();
    internal: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loop Property

Loop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Loop
RDPCrystal EDI Library
Get the name of the loop that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string Loop { get; internal set; }
Public Property Loop As String
    Get
    Friend Set
public:
property String^ Loop {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopDescription Property

LoopDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► LoopDescription
RDPCrystal EDI Library
Description of the loop that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string LoopDescription { get; internal set; }
Public Property LoopDescription As String
    Get
    Friend Set
public:
property String^ LoopDescription {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Message Property

Message Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Message
RDPCrystal EDI Library
General error message type
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidationMessage Message { get; internal set; }
Public Property Message As EDIValidationMessage
    Get
    Friend Set
public:
property EDIValidationMessage Message {
    EDIValidationMessage get ();
    internal: void set (EDIValidationMessage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segment Property

Segment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Segment
RDPCrystal EDI Library
Get the name of the segment that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string Segment { get; internal set; }
Public Property Segment As String
    Get
    Friend Set
public:
property String^ Segment {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentDescription Property

SegmentDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SegmentDescription
RDPCrystal EDI Library
Description of the segment that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentDescription { get; internal set; }
Public Property SegmentDescription As String
    Get
    Friend Set
public:
property String^ SegmentDescription {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentOrdinal Property

SegmentOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SegmentOrdinal
RDPCrystal EDI Library
Get the segment ordinal number that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinal { get; internal set; }
Public Property SegmentOrdinal As Integer
    Get
    Friend Set
public:
property int SegmentOrdinal {
    int get ();
    internal: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentPositionInTransaction Property

SegmentPositionInTransaction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SegmentPositionInTransaction
RDPCrystal EDI Library
Gets or sets the segment position in transaction.
Declaration Syntax
C# Visual Basic Visual C++
public long SegmentPositionInTransaction { get; internal set; }
Public Property SegmentPositionInTransaction As Long
    Get
    Friend Set
public:
property long long SegmentPositionInTransaction {
    long long get ();
    internal: void set (long long value);
}
Value
The segment position in transaction.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Property

SegmentSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SegmentSchema
RDPCrystal EDI Library
The schema of the segment that was being validated while the error/warning occurred
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment SegmentSchema { get; internal set; }
Public Property SegmentSchema As DataSegment
    Get
    Friend Set
public:
property DataSegment^ SegmentSchema {
    DataSegment^ get ();
    internal: void set (DataSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SetSnipLevel Method

SetSnipLevel Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SetSnipLevel()()()()
RDPCrystal EDI Library
Sets the snip level.
Declaration Syntax
C# Visual Basic Visual C++
protected void SetSnipLevel()
Protected Sub SetSnipLevel
protected:
void SetSnipLevel()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SnipLevel Property

SnipLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SnipLevel
RDPCrystal EDI Library
Snip level
Declaration Syntax
C# Visual Basic Visual C++
public SnipTestLevel SnipLevel { get; internal set; }
Public Property SnipLevel As SnipTestLevel
    Get
    Friend Set
public:
property SnipTestLevel SnipLevel {
    SnipTestLevel get ();
    internal: void set (SnipTestLevel value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


StackTrace Property

StackTrace Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► StackTrace
RDPCrystal EDI Library
Gets the stack trace if this is an unexpected error
Declaration Syntax
C# Visual Basic Visual C++
public string StackTrace { get; internal set; }
Public Property StackTrace As String
    Get
    Friend Set
public:
property String^ StackTrace {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


STSegment Property

STSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► STSegment
RDPCrystal EDI Library
Gets the ST segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment STSegment { get; internal set; }
Public Property STSegment As LightWeightSegment
    Get
    Friend Set
public:
property LightWeightSegment^ STSegment {
    LightWeightSegment^ get ();
    internal: void set (LightWeightSegment^ value);
}
Value
The ST segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ToString()()()()
RDPCrystal EDI Library
Get a string represenation of the error
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidatingSegment Property

ValidatingSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ValidatingSegment
RDPCrystal EDI Library
The actual segment that was being evaluated while the error/warning occurred
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment ValidatingSegment { get; internal set; }
Public Property ValidatingSegment As LightWeightSegment
    Get
    Friend Set
public:
property LightWeightSegment^ ValidatingSegment {
    LightWeightSegment^ get ();
    internal: void set (LightWeightSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileJoiner Class

EDIFileJoiner Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner
RDPCrystal EDI Library
Component used to join EDI files
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFileJoiner : Component
Public Class EDIFileJoiner _
    Inherits Component
public ref class EDIFileJoiner : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileJoiner()()()() | Initializes a new instance of the EDIFileJoiner class.
 | EDIFileJoiner(IContainer) | Initializes a new instance of the EDIFileJoiner class.
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | AutoGenerateSTControlNumber | Gets or sets whether to generate ST control number
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters |
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EachSegmentInNewLine | Gets or sets a value indicating whether each segment should be in a new line.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileJoinLevel | Gets or sets the file join level where file joining should occur, at the Header level(ST) or the Functional Group level (GS)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Join(List<(Of <<'(String>)>>), String) | Joins the specified files.
 | JoinAsync(List<(Of <<'(String>)>>), String, Object) | Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | JoinStrings(List<(Of <<'(String>)>>)) | Join EDI data from strings
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewFileBufferSize | Gets or sets the file buffer size for the output file
 | OnFileOperationCompleted | Raised when file joining operations are completed
 | ReadBlockSize | Gets or sets the size of the block.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | Gets or sets the trim string. Trim string are used to remove formatting characters from edi data
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileJoiner

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileJoiner Constructor

EDIFileJoiner Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EDIFileJoiner()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIFileJoiner()()()() | Initializes a new instance of the EDIFileJoiner class.
 | EDIFileJoiner(IContainer) | Initializes a new instance of the EDIFileJoiner class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileJoiner Constructor

EDIFileJoiner Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EDIFileJoiner()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIFileJoiner class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileJoiner()
Public Sub New
public:
EDIFileJoiner()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileJoiner Constructor (container)

EDIFileJoiner Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EDIFileJoiner(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDIFileJoiner class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileJoiner(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileJoiner(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► AutoDetectDelimiters
RDPCrystal EDI Library
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoGenerateSTControlNumber Property

AutoGenerateSTControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► AutoGenerateSTControlNumber
RDPCrystal EDI Library
Gets or sets whether to generate ST control number
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoGenerateSTControlNumber { get; set; }
Public Property AutoGenerateSTControlNumber As Boolean
    Get
    Set
public:
property bool AutoGenerateSTControlNumber {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Delimiters
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EachSegmentInNewLine Property

EachSegmentInNewLine Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EachSegmentInNewLine
RDPCrystal EDI Library
Gets or sets a value indicating whether each segment should be in a new line.
Declaration Syntax
C# Visual Basic Visual C++
public bool EachSegmentInNewLine { get; set; }
Public Property EachSegmentInNewLine As Boolean
    Get
    Set
public:
property bool EachSegmentInNewLine {
    bool get ();
    void set (bool value);
}
Value
true if [each segment in new line]; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileJoinLevel Property

FileJoinLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► FileJoinLevel
RDPCrystal EDI Library
Gets or sets the file join level where file joining should occur, at the Header level(ST) or the Functional Group level (GS)
Declaration Syntax
C# Visual Basic Visual C++
public FileJoinLevel FileJoinLevel { get; set; }
Public Property FileJoinLevel As FileJoinLevel
    Get
    Set
public:
property FileJoinLevel FileJoinLevel {
    FileJoinLevel get ();
    void set (FileJoinLevel value);
}
Value
The file join level.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Join Method (files, outputFile)

Join Method (files, outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Join(List<(Of <<'(String>)>>), String)
RDPCrystal EDI Library
Joins the specified files.
Declaration Syntax
C# Visual Basic Visual C++
public void Join(
    List<string> files,
    string outputFile
)
Public Sub Join ( _
    files As List(Of String), _
    outputFile As String _
)
public:
void Join(
    List<String^>^ files,
    String^ outputFile
)
Parameters
files (List<(Of <(<'String>)>)>)
The files.
outputFile (String)
The output file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


JoinAsync Method (files, outputFile, state)

JoinAsync Method (files, outputFile, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► JoinAsync(List<(Of <<'(String>)>>), String, Object)
RDPCrystal EDI Library
Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
public void JoinAsync(
    List<string> files,
    string outputFile,
    Object state
)
Public Sub JoinAsync ( _
    files As List(Of String), _
    outputFile As String, _
    state As Object _
)
public:
void JoinAsync(
    List<String^>^ files,
    String^ outputFile,
    Object^ state
)
Parameters
files (List<(Of <(<'String>)>)>)
The files.
outputFile (String)
The new file.
state (Object)
Any state that should be returned in the OnFileOperationCompleted event

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


JoinStrings Method (ediDataStrings)

JoinStrings Method (ediDataStrings)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► JoinStrings(List<(Of <<'(String>)>>))
RDPCrystal EDI Library
Join EDI data from strings
Declaration Syntax
C# Visual Basic Visual C++
public string JoinStrings(
    List<string> ediDataStrings
)
Public Function JoinStrings ( _
    ediDataStrings As List(Of String) _
) As String
public:
String^ JoinStrings(
    List<String^>^ ediDataStrings
)
Parameters
ediDataStrings (List<(Of <(<'String>)>)>)
list of EDI strings to join
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NewFileBufferSize Property

NewFileBufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► NewFileBufferSize
RDPCrystal EDI Library
Gets or sets the file buffer size for the output file
Declaration Syntax
C# Visual Basic Visual C++
public int NewFileBufferSize { get; set; }
Public Property NewFileBufferSize As Integer
    Get
    Set
public:
property int NewFileBufferSize {
    int get ();
    void set (int value);
}
Value
The new size of the file buffer.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OnFileOperationCompleted Event

OnFileOperationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► OnFileOperationCompleted
RDPCrystal EDI Library
Raised when file joining operations are completed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<FileOperationCompletedEventArgs> OnFileOperationCompleted
Public Event OnFileOperationCompleted As EventHandler(Of FileOperationCompletedEventArgs)
public:
 event EventHandler<FileOperationCompletedEventArgs^>^ OnFileOperationCompleted {
    void add (EventHandler<FileOperationCompletedEventArgs^>^ value);
    void remove (EventHandler<FileOperationCompletedEventArgs^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ReadBlockSize Property

ReadBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► ReadBlockSize
RDPCrystal EDI Library
Gets or sets the size of the block.
Declaration Syntax
C# Visual Basic Visual C++
public int ReadBlockSize { get; set; }
Public Property ReadBlockSize As Integer
    Get
    Set
public:
property int ReadBlockSize {
    int get ();
    void set (int value);
}
Value
The size of the block.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► TrimString
RDPCrystal EDI Library
Gets or sets the trim string. Trim string are used to remove formatting characters from edi data
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}
Value
The trim string.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileLoader Class

EDIFileLoader Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader
RDPCrystal EDI Library
Parses and loads EDI files without any rules
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIFileLoader : Component
Public NotInheritable Class EDIFileLoader _
    Inherits Component
public ref class EDIFileLoader sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileLoader()()()() | Initializes a new instance of the EDIFileLoader class.
 | EDIFileLoader(IContainer) | Initializes a new instance of the EDIFileLoader class.
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters | EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDataString | EDI data to load. EDI data can also be specified from a file using the EDIFile property
 | EDIFile | Full path of EDI file to load
 | EDIFileType | Used to specify the type of EDI file to be loaded
 | EDISource | Used to specify if validation is for an in-memory string or a file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorString | Used to report any errors encountered during file load
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBlockSize | File chunk size when validating EDI data from a file
 | FileLoadingCompleted | Event fired when file loading is complete
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FlatStructure | Get/Set whether or not a separate loop is created whenever an ISA segment is encountered
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Load(String) | Loads EDI data from a string
 | Load()()()() | Load EDI File. This is result in only one loop with all DataSegments
 | LoadFile(String) | Load an EDI file without rules. This is result in only one loop with all data segments
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TimeElapsed | Time elapsed in milliseconds while loading
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | String to ignore at between segment delimiters
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileLoader

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileLoader Constructor

EDIFileLoader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIFileLoader()()()() | Initializes a new instance of the EDIFileLoader class.
 | EDIFileLoader(IContainer) | Initializes a new instance of the EDIFileLoader class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileLoader Constructor

EDIFileLoader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIFileLoader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileLoader()
Public Sub New
public:
EDIFileLoader()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileLoader Constructor (container)

EDIFileLoader Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDIFileLoader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileLoader(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileLoader(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► AutoDetectDelimiters
RDPCrystal EDI Library
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Delimiters
RDPCrystal EDI Library
EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDataString Property

EDIDataString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIDataString
RDPCrystal EDI Library
EDI data to load. EDI data can also be specified from a file using the EDIFile property
Declaration Syntax
C# Visual Basic Visual C++
public string EDIDataString { get; set; }
Public Property EDIDataString As String
    Get
    Set
public:
property String^ EDIDataString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFile
RDPCrystal EDI Library
Full path of EDI file to load
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileType
RDPCrystal EDI Library
Used to specify the type of EDI file to be loaded
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDISource Property

EDISource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDISource
RDPCrystal EDI Library
Used to specify if validation is for an in-memory string or a file
Declaration Syntax
C# Visual Basic Visual C++
public EDISource EDISource { get; set; }
Public Property EDISource As EDISource
    Get
    Set
public:
property EDISource EDISource {
    EDISource get ();
    void set (EDISource value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ErrorString Property

ErrorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► ErrorString
RDPCrystal EDI Library
Used to report any errors encountered during file load
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorString { get; }
Public ReadOnly Property ErrorString As String
    Get
public:
property String^ ErrorString {
    String^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileBlockSize Property

FileBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► FileBlockSize
RDPCrystal EDI Library
File chunk size when validating EDI data from a file
Declaration Syntax
C# Visual Basic Visual C++
public int FileBlockSize { get; set; }
Public Property FileBlockSize As Integer
    Get
    Set
public:
property int FileBlockSize {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileLoadingCompleted Event

FileLoadingCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► FileLoadingCompleted
RDPCrystal EDI Library
Event fired when file loading is complete
Declaration Syntax
C# Visual Basic Visual C++
public event EDIFileLoader..::..EDIFileLoadingCompletedEvent FileLoadingCompleted
Public Event FileLoadingCompleted As EDIFileLoader..::..EDIFileLoadingCompletedEvent
public:
 event EDIFileLoader..::..EDIFileLoadingCompletedEvent^ FileLoadingCompleted {
    void add (EDIFileLoader..::..EDIFileLoadingCompletedEvent^ value);
    void remove (EDIFileLoader..::..EDIFileLoadingCompletedEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FlatStructure Property

FlatStructure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► FlatStructure
RDPCrystal EDI Library
Get/Set whether or not a separate loop is created whenever an ISA segment is encountered
Declaration Syntax
C# Visual Basic Visual C++
public bool FlatStructure { get; set; }
Public Property FlatStructure As Boolean
    Get
    Set
public:
property bool FlatStructure {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Load Method

Load Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Load()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Load(String) | Loads EDI data from a string
 | Load()()()() | Load EDI File. This is result in only one loop with all DataSegments

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Load Method

Load Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Load()()()()
RDPCrystal EDI Library
Load EDI File. This is result in only one loop with all DataSegments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Load()
Public Function Load As EDILightWeightDocument
public:
EDILightWeightDocument^ Load()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Load Method (ediData)

Load Method (ediData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Load(String)
RDPCrystal EDI Library
Loads EDI data from a string
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Load(
    string ediData
)
Public Function Load ( _
    ediData As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ Load(
    String^ ediData
)
Parameters
ediData (String)
EDILightWeightDocument
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoadFile Method (ediFilePath)

LoadFile Method (ediFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► LoadFile(String)
RDPCrystal EDI Library
Load an EDI file without rules. This is result in only one loop with all data segments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument LoadFile(
    string ediFilePath
)
Public Function LoadFile ( _
    ediFilePath As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ LoadFile(
    String^ ediFilePath
)
Parameters
ediFilePath (String)
path of EDI file
Return Value
EDILightWeightDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TimeElapsed Property

TimeElapsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► TimeElapsed
RDPCrystal EDI Library
Time elapsed in milliseconds while loading
Declaration Syntax
C# Visual Basic Visual C++
public double TimeElapsed { get; }
Public ReadOnly Property TimeElapsed As Double
    Get
public:
property double TimeElapsed {
    double get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► TrimString
RDPCrystal EDI Library
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileLoader.EDIFileLoadingCompletedEvent Delegate

EDIFileLoader..::..EDIFileLoadingCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader..::..EDIFileLoadingCompletedEvent
RDPCrystal EDI Library
Delegate used for raising and event after EDI file loading has completed
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EDIFileLoadingCompletedEvent(
    Object sender,
    FileLoadingEventArgs e
)
Public Delegate Sub EDIFileLoadingCompletedEvent ( _
    sender As Object, _
    e As FileLoadingEventArgs _
)
public delegate void EDIFileLoadingCompletedEvent(
    Object^ sender,
    FileLoadingEventArgs^ e
)
Parameters
sender (Object)
sender of the event
e (FileLoadingEventArgs)
data relating to file loading

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileParser Class

EDIFileParser Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser
RDPCrystal EDI Library
Responsible for parsing an EDI file line by line
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFileParser
Public Class EDIFileParser
public ref class EDIFileParser
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileParser(String) | Create a new EDI file parser with a specified file path
 | AutoDetectDelimiters | If set to true then delimiters will be autodetected
 | BeginFileLoad()()()() | Start loading the EDI file
 | Delimiters | Get or set the delimiters to use to parse this EDI file. This property is only used in AutoDetectDelimiters is set to false
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Finished()()()() | Checks whether there are more lines to remaining to be parsed
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextLine()()()() | Gets the next line in the EDI file
 | NumberOfSegments | Get the total number of segments parsed in the file
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrimString | Gets or sets the trim string. Trim string are used to remove hidden formatting characters from edi data
Inheritance Hierarchy
Object
EDIFileParser

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileParser Constructor (path)

EDIFileParser Constructor (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► EDIFileParser(String)
RDPCrystal EDI Library
Create a new EDI file parser with a specified file path
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileParser(
    string path
)
Public Sub New ( _
    path As String _
)
public:
EDIFileParser(
    String^ path
)
Parameters
path (String)
path including filename to parse

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► AutoDetectDelimiters
RDPCrystal EDI Library
If set to true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


BeginFileLoad Method

BeginFileLoad Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► BeginFileLoad()()()()
RDPCrystal EDI Library
Start loading the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void BeginFileLoad()
Public Sub BeginFileLoad
public:
void BeginFileLoad()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► Delimiters
RDPCrystal EDI Library
Get or set the delimiters to use to parse this EDI file. This property is only used in AutoDetectDelimiters is set to false
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Finished Method

Finished Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► Finished()()()()
RDPCrystal EDI Library
Checks whether there are more lines to remaining to be parsed
Declaration Syntax
C# Visual Basic Visual C++
public bool Finished()
Public Function Finished As Boolean
public:
bool Finished()
Return Value
true is there are more lines to parse otherwise false

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NextLine Method

NextLine Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► NextLine()()()()
RDPCrystal EDI Library
Gets the next line in the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public string NextLine()
Public Function NextLine As String
public:
String^ NextLine()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberOfSegments Property

NumberOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► NumberOfSegments
RDPCrystal EDI Library
Get the total number of segments parsed in the file
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfSegments { get; }
Public ReadOnly Property NumberOfSegments As Integer
    Get
public:
property int NumberOfSegments {
    int get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► TrimString
RDPCrystal EDI Library
Gets or sets the trim string. Trim string are used to remove hidden formatting characters from edi data
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileScrubber Class

EDIFileScrubber Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber
RDPCrystal EDI Library
Parses and scrubs EDI files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIFileScrubber : Component
Public NotInheritable Class EDIFileScrubber _
    Inherits Component
public ref class EDIFileScrubber sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileScrubber()()()() | Initializes a new instance of the EDIFileScrubber class.
 | EDIFileScrubber(IContainer) | Initializes a new instance of the EDIFileScrubber class.
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters | EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDataString | EDI data to scrub. EDI data can also be specified from a file using the EDIFile property
 | EDIFile | Full path of EDI file to scrub
 | EDIFileType | Used to specify the type of EDI file to be scrubbed
 | EDISource | Used to specify if validation is for an in-memory string or a file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorString | Used to report any errors encountered during file scrubbing
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBlockSize | File chunk size when scrubbing EDI data from a file
 | FileScrubbingCompleted | Event fired when file scrubbing is complete
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scrub(String) | Scrubs EDI data from a string
 | Scrub()()()() | Scrub EDI File. This results in only one loop with all DataSegments
 | ScrubFile(String) | Scrubs an EDI file This is result in only one loop with all data segments
 | ScrubRules | Rules used to scrub a file
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TimeElapsed | Time elapsed in milliseconds while scrubbing
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | String to ignore at between segment delimiters
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileScrubber

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileScrubber Constructor

EDIFileScrubber Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIFileScrubber()()()() | Initializes a new instance of the EDIFileScrubber class.
 | EDIFileScrubber(IContainer) | Initializes a new instance of the EDIFileScrubber class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileScrubber Constructor

EDIFileScrubber Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIFileScrubber class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileScrubber()
Public Sub New
public:
EDIFileScrubber()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileScrubber Constructor (container)

EDIFileScrubber Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDIFileScrubber class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileScrubber(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileScrubber(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► AutoDetectDelimiters
RDPCrystal EDI Library
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Delimiters
RDPCrystal EDI Library
EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDataString Property

EDIDataString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIDataString
RDPCrystal EDI Library
EDI data to scrub. EDI data can also be specified from a file using the EDIFile property
Declaration Syntax
C# Visual Basic Visual C++
public string EDIDataString { get; set; }
Public Property EDIDataString As String
    Get
    Set
public:
property String^ EDIDataString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFile
RDPCrystal EDI Library
Full path of EDI file to scrub
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileType
RDPCrystal EDI Library
Used to specify the type of EDI file to be scrubbed
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDISource Property

EDISource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDISource
RDPCrystal EDI Library
Used to specify if validation is for an in-memory string or a file
Declaration Syntax
C# Visual Basic Visual C++
public EDISource EDISource { get; set; }
Public Property EDISource As EDISource
    Get
    Set
public:
property EDISource EDISource {
    EDISource get ();
    void set (EDISource value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ErrorString Property

ErrorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► ErrorString
RDPCrystal EDI Library
Used to report any errors encountered during file scrubbing
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorString { get; }
Public ReadOnly Property ErrorString As String
    Get
public:
property String^ ErrorString {
    String^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileBlockSize Property

FileBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► FileBlockSize
RDPCrystal EDI Library
File chunk size when scrubbing EDI data from a file
Declaration Syntax
C# Visual Basic Visual C++
public int FileBlockSize { get; set; }
Public Property FileBlockSize As Integer
    Get
    Set
public:
property int FileBlockSize {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileScrubbingCompleted Event

FileScrubbingCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► FileScrubbingCompleted
RDPCrystal EDI Library
Event fired when file scrubbing is complete
Declaration Syntax
C# Visual Basic Visual C++
public event EDIFileScrubber..::..EDIFileScrubbingCompletedEvent FileScrubbingCompleted
Public Event FileScrubbingCompleted As EDIFileScrubber..::..EDIFileScrubbingCompletedEvent
public:
 event EDIFileScrubber..::..EDIFileScrubbingCompletedEvent^ FileScrubbingCompleted {
    void add (EDIFileScrubber..::..EDIFileScrubbingCompletedEvent^ value);
    void remove (EDIFileScrubber..::..EDIFileScrubbingCompletedEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Scrub Method

Scrub Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Scrub()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Scrub(String) | Scrubs EDI data from a string
 | Scrub()()()() | Scrub EDI File. This results in only one loop with all DataSegments

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Scrub Method

Scrub Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Scrub()()()()
RDPCrystal EDI Library
Scrub EDI File. This results in only one loop with all DataSegments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Scrub()
Public Function Scrub As EDILightWeightDocument
public:
EDILightWeightDocument^ Scrub()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Scrub Method (ediData)

Scrub Method (ediData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Scrub(String)
RDPCrystal EDI Library
Scrubs EDI data from a string
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Scrub(
    string ediData
)
Public Function Scrub ( _
    ediData As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ Scrub(
    String^ ediData
)
Parameters
ediData (String)
EDILightWeightDocument
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubFile Method (ediFilePath)

ScrubFile Method (ediFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► ScrubFile(String)
RDPCrystal EDI Library
Scrubs an EDI file This is result in only one loop with all data segments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument ScrubFile(
    string ediFilePath
)
Public Function ScrubFile ( _
    ediFilePath As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ ScrubFile(
    String^ ediFilePath
)
Parameters
ediFilePath (String)
path of EDI file
Return Value
EDILightWeightDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubRules Property

ScrubRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► ScrubRules
RDPCrystal EDI Library
Rules used to scrub a file
Declaration Syntax
C# Visual Basic Visual C++
public List<ScrubRule> ScrubRules { get; }
Public ReadOnly Property ScrubRules As List(Of ScrubRule)
    Get
public:
property List<ScrubRule^>^ ScrubRules {
    List<ScrubRule^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TimeElapsed Property

TimeElapsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► TimeElapsed
RDPCrystal EDI Library
Time elapsed in milliseconds while scrubbing
Declaration Syntax
C# Visual Basic Visual C++
public double TimeElapsed { get; }
Public ReadOnly Property TimeElapsed As Double
    Get
public:
property double TimeElapsed {
    double get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► TrimString
RDPCrystal EDI Library
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileScrubber.EDIFileScrubbingCompletedEvent Delegate

EDIFileScrubber..::..EDIFileScrubbingCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber..::..EDIFileScrubbingCompletedEvent
RDPCrystal EDI Library
Delegate used for raising and event after EDI file scrubbing has completed
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EDIFileScrubbingCompletedEvent(
    Object sender,
    FileLoadingEventArgs e
)
Public Delegate Sub EDIFileScrubbingCompletedEvent ( _
    sender As Object, _
    e As FileLoadingEventArgs _
)
public delegate void EDIFileScrubbingCompletedEvent(
    Object^ sender,
    FileLoadingEventArgs^ e
)
Parameters
sender (Object)
sender of the event
e (FileLoadingEventArgs)
data relating to file scrubbing

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileSplitter Class

EDIFileSplitter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter
RDPCrystal EDI Library
Component used to split EDI files
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFileSplitter : Component
Public Class EDIFileSplitter _
    Inherits Component
public ref class EDIFileSplitter : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileSplitter()()()() | Initializes a new instance of the EDIFileSplitter class.
 | EDIFileSplitter(IContainer) | Initializes a new instance of the EDIFileSplitter class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIFileType | Used to specify the type of EDI file to be split
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileSplitLevel | Gets or sets the file split level
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GeneratePseudoRandomNumberInFilename | Used to specify the type of EDI file to be split
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLineAfterSegment | Whether or not to insert a new line after every segment
 | NumberOfItemsPerFile | Gets or sets the number of ISA Envelopes/ST Headers/GS Functional Groups per file
 | OnFileOperationCompleted | Raised when file splitting operations are completed
 | OutputFilename | Used to specify the name of the output file
 | OutputFilenameFormat | Used to specify the name of the output file
 | ReadBlockSize | Gets or sets the size of the block.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | Split(String, String) | Splits the specified EDI files synchronously.
 | SplitAsync(String, String, Object) | Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | SplitFileExtension | Gets or sets the file extension of the splitted files. The default is .txt
 | SplitString(String) | Splits the specified EDI files synchronously.
 | SplitStringsAsync(String, Object) | Splits EDI strings asynchronously. Fires a OnFileOperationCompleted when completed
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | Gets or sets the trim string.
 | WriteBlockBuffer | Gets or sets the write block buffer when writing data to spit files
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileSplitter

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileSplitter Constructor

EDIFileSplitter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileSplitter()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIFileSplitter()()()() | Initializes a new instance of the EDIFileSplitter class.
 | EDIFileSplitter(IContainer) | Initializes a new instance of the EDIFileSplitter class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileSplitter Constructor

EDIFileSplitter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileSplitter()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIFileSplitter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileSplitter()
Public Sub New
public:
EDIFileSplitter()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileSplitter Constructor (container)

EDIFileSplitter Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileSplitter(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDIFileSplitter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileSplitter(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileSplitter(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileType
RDPCrystal EDI Library
Used to specify the type of EDI file to be split
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileSplitLevel Property

FileSplitLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► FileSplitLevel
RDPCrystal EDI Library
Gets or sets the file split level
Declaration Syntax
C# Visual Basic Visual C++
public FileSplitLevel FileSplitLevel { get; set; }
Public Property FileSplitLevel As FileSplitLevel
    Get
    Set
public:
property FileSplitLevel FileSplitLevel {
    FileSplitLevel get ();
    void set (FileSplitLevel value);
}
Value
The file join level.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneratePseudoRandomNumberInFilename Property

GeneratePseudoRandomNumberInFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► GeneratePseudoRandomNumberInFilename
RDPCrystal EDI Library
Used to specify the type of EDI file to be split
Declaration Syntax
C# Visual Basic Visual C++
public bool GeneratePseudoRandomNumberInFilename { get; set; }
Public Property GeneratePseudoRandomNumberInFilename As Boolean
    Get
    Set
public:
property bool GeneratePseudoRandomNumberInFilename {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NewLineAfterSegment Property

NewLineAfterSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► NewLineAfterSegment
RDPCrystal EDI Library
Whether or not to insert a new line after every segment
Declaration Syntax
C# Visual Basic Visual C++
public bool NewLineAfterSegment { get; set; }
Public Property NewLineAfterSegment As Boolean
    Get
    Set
public:
property bool NewLineAfterSegment {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberOfItemsPerFile Property

NumberOfItemsPerFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► NumberOfItemsPerFile
RDPCrystal EDI Library
Gets or sets the number of ISA Envelopes/ST Headers/GS Functional Groups per file
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfItemsPerFile { get; set; }
Public Property NumberOfItemsPerFile As Integer
    Get
    Set
public:
property int NumberOfItemsPerFile {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OnFileOperationCompleted Event

OnFileOperationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► OnFileOperationCompleted
RDPCrystal EDI Library
Raised when file splitting operations are completed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<FileOperationCompletedEventArgs> OnFileOperationCompleted
Public Event OnFileOperationCompleted As EventHandler(Of FileOperationCompletedEventArgs)
public:
 event EventHandler<FileOperationCompletedEventArgs^>^ OnFileOperationCompleted {
    void add (EventHandler<FileOperationCompletedEventArgs^>^ value);
    void remove (EventHandler<FileOperationCompletedEventArgs^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OutputFilename Property

OutputFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► OutputFilename
RDPCrystal EDI Library
Used to specify the name of the output file
Declaration Syntax
C# Visual Basic Visual C++
public string OutputFilename { get; set; }
Public Property OutputFilename As String
    Get
    Set
public:
property String^ OutputFilename {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OutputFilenameFormat Property

OutputFilenameFormat Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► OutputFilenameFormat
RDPCrystal EDI Library
Used to specify the name of the output file
Declaration Syntax
C# Visual Basic Visual C++
public string OutputFilenameFormat { get; set; }
Public Property OutputFilenameFormat As String
    Get
    Set
public:
property String^ OutputFilenameFormat {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ReadBlockSize Property

ReadBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► ReadBlockSize
RDPCrystal EDI Library
Gets or sets the size of the block.
Declaration Syntax
C# Visual Basic Visual C++
public int ReadBlockSize { get; set; }
Public Property ReadBlockSize As Integer
    Get
    Set
public:
property int ReadBlockSize {
    int get ();
    void set (int value);
}
Value
The size of the block.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Split Method (file, outputDirectory)

Split Method (file, outputDirectory)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Split(String, String)
RDPCrystal EDI Library
Splits the specified EDI files synchronously.
Declaration Syntax
C# Visual Basic Visual C++
public void Split(
    string file,
    string outputDirectory
)
Public Sub Split ( _
    file As String, _
    outputDirectory As String _
)
public:
void Split(
    String^ file,
    String^ outputDirectory
)
Parameters
file (String)
The file.
outputDirectory (String)
The output directory.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SplitAsync Method (file, outputDirectory, state)

SplitAsync Method (file, outputDirectory, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► SplitAsync(String, String, Object)
RDPCrystal EDI Library
Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
public void SplitAsync(
    string file,
    string outputDirectory,
    Object state
)
Public Sub SplitAsync ( _
    file As String, _
    outputDirectory As String, _
    state As Object _
)
public:
void SplitAsync(
    String^ file,
    String^ outputDirectory,
    Object^ state
)
Parameters
file (String)
The file.
outputDirectory (String)
The output directory.
state (Object)
The state.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SplitFileExtension Property

SplitFileExtension Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► SplitFileExtension
RDPCrystal EDI Library
Gets or sets the file extension of the splitted files. The default is .txt
Declaration Syntax
C# Visual Basic Visual C++
public string SplitFileExtension { get; set; }
Public Property SplitFileExtension As String
    Get
    Set
public:
property String^ SplitFileExtension {
    String^ get ();
    void set (String^ value);
}
Value
The split file extension.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SplitString Method (ediData)

SplitString Method (ediData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► SplitString(String)
RDPCrystal EDI Library
Splits the specified EDI files synchronously.
Declaration Syntax
C# Visual Basic Visual C++
public List<string> SplitString(
    string ediData
)
Public Function SplitString ( _
    ediData As String _
) As List(Of String)
public:
List<String^>^ SplitString(
    String^ ediData
)
Parameters
ediData (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SplitStringsAsync Method (ediData, state)

SplitStringsAsync Method (ediData, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► SplitStringsAsync(String, Object)
RDPCrystal EDI Library
Splits EDI strings asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
public void SplitStringsAsync(
    string ediData,
    Object state
)
Public Sub SplitStringsAsync ( _
    ediData As String, _
    state As Object _
)
public:
void SplitStringsAsync(
    String^ ediData,
    Object^ state
)
Parameters
ediData (String)
EDI data to split
state (Object)
The state.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► TrimString
RDPCrystal EDI Library
Gets or sets the trim string.
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}
Value
The trim string.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


WriteBlockBuffer Property

WriteBlockBuffer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► WriteBlockBuffer
RDPCrystal EDI Library
Gets or sets the write block buffer when writing data to spit files
Declaration Syntax
C# Visual Basic Visual C++
public int WriteBlockBuffer { get; set; }
Public Property WriteBlockBuffer As Integer
    Get
    Set
public:
property int WriteBlockBuffer {
    int get ();
    void set (int value);
}
Value
The write block buffer.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDILightWeightDocument Class

EDILightWeightDocument Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument
RDPCrystal EDI Library
A light weight version of the EDIDocument used to creates EDI X12 and EDIFACT document files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDILightWeightDocument : Component
Public NotInheritable Class EDILightWeightDocument _
    Inherits Component
public ref class EDILightWeightDocument sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDILightWeightDocument()()()() | Initializes a new instance of the EDILightWeightDocument class.
 | EDILightWeightDocument(IContainer) | Initializes a new instance of the EDILightWeightDocument class.
 | AutoPlaceCorrectNumOfGT | Places the correct number of GS Functional Groups in the IEA segment element 1
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
 | AutoPlaceCorrectNumOfST | Places the correct number of ST Headers in the GE segment element 1
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Creator |
 | Delimiters | Segment and element delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDocumentFinished | Event raised when EDI document creation process has completed
 | EDIFilePath | Full path including file name of EDI file to create. If the file already exists it is overwritten
 | EDIFileString | A string representation of the EDI file created
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBufferSize | Initial file buffer size when generating EDI files
 | FileStream | Optional filestream to save EDI document to
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GenerateEDIData()()()() | Generate EDI Data without writing to a filestream
 | GenerateEDIFile(FileStream) | Generates the EDI file.
 | GenerateEDIFile(String) | Generates the EDI file.
 | GenerateEDIFile()()()() | Generates the EDI file.
 | GenerateEDIFileWithBatchWrite()()()() | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Loops | Gets or sets the loops.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLineAfterSegment | Whether or not to insert a new line after every segment
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | ToXml()()()() | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDILightWeightDOcument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDILightWeightDocument to Xml
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDILightWeightDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDILightWeightDocument Constructor

EDILightWeightDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDILightWeightDocument()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDILightWeightDocument()()()() | Initializes a new instance of the EDILightWeightDocument class.
 | EDILightWeightDocument(IContainer) | Initializes a new instance of the EDILightWeightDocument class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDILightWeightDocument Constructor

EDILightWeightDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDILightWeightDocument()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDILightWeightDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument()
Public Sub New
public:
EDILightWeightDocument()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDILightWeightDocument Constructor (container)

EDILightWeightDocument Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDILightWeightDocument(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDILightWeightDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDILightWeightDocument(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfGT Property

AutoPlaceCorrectNumOfGT Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► AutoPlaceCorrectNumOfGT
RDPCrystal EDI Library
Places the correct number of GS Functional Groups in the IEA segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfGT { get; set; }
Public Property AutoPlaceCorrectNumOfGT As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfGT {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfSegments Property

AutoPlaceCorrectNumOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► AutoPlaceCorrectNumOfSegments
RDPCrystal EDI Library
Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfSegments { get; set; }
Public Property AutoPlaceCorrectNumOfSegments As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfSegments {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfST Property

AutoPlaceCorrectNumOfST Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► AutoPlaceCorrectNumOfST
RDPCrystal EDI Library
Places the correct number of ST Headers in the GE segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfST { get; set; }
Public Property AutoPlaceCorrectNumOfST As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfST {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Creator Property

Creator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Creator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public DocumentCreator Creator { get; set; }
Public Property Creator As DocumentCreator
    Get
    Set
public:
property DocumentCreator Creator {
    DocumentCreator get ();
    void set (DocumentCreator value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Delimiters
RDPCrystal EDI Library
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDocumentFinished Event

EDIDocumentFinished Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDIDocumentFinished
RDPCrystal EDI Library
Event raised when EDI document creation process has completed
Declaration Syntax
C# Visual Basic Visual C++
public event GeneralEvent EDIDocumentFinished
Public Event EDIDocumentFinished As GeneralEvent
public:
 event GeneralEvent^ EDIDocumentFinished {
    void add (GeneralEvent^ value);
    void remove (GeneralEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFilePath Property

EDIFilePath Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDIFilePath
RDPCrystal EDI Library
Full path including file name of EDI file to create. If the file already exists it is overwritten
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFilePath { get; set; }
Public Property EDIFilePath As String
    Get
    Set
public:
property String^ EDIFilePath {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileString Property

EDIFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDIFileString
RDPCrystal EDI Library
A string representation of the EDI file created
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFileString { get; internal set; }
Public Property EDIFileString As String
    Get
    Friend Set
public:
property String^ EDIFileString {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileBufferSize Property

FileBufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► FileBufferSize
RDPCrystal EDI Library
Initial file buffer size when generating EDI files
Declaration Syntax
C# Visual Basic Visual C++
public int FileBufferSize { get; set; }
Public Property FileBufferSize As Integer
    Get
    Set
public:
property int FileBufferSize {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileStream Property

FileStream Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► FileStream
RDPCrystal EDI Library
Optional filestream to save EDI document to
Declaration Syntax
C# Visual Basic Visual C++
public FileStream FileStream { get; set; }
Public Property FileStream As FileStream
    Get
    Set
public:
property FileStream^ FileStream {
    FileStream^ get ();
    void set (FileStream^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIData Method

GenerateEDIData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIData()()()()
RDPCrystal EDI Library
Generate EDI Data without writing to a filestream
Declaration Syntax
C# Visual Basic Visual C++
public string GenerateEDIData()
Public Function GenerateEDIData As String
public:
String^ GenerateEDIData()
Return Value
EDI data as string

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GenerateEDIFile(FileStream) | Generates the EDI file.
 | GenerateEDIFile(String) | Generates the EDI file.
 | GenerateEDIFile()()()() | Generates the EDI file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Generates the EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile()
Public Sub GenerateEDIFile
public:
void GenerateEDIFile()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method (stream)

GenerateEDIFile Method (stream)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile(FileStream)
RDPCrystal EDI Library
Generates the EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    FileStream stream
)
Public Sub GenerateEDIFile ( _
    stream As FileStream _
)
public:
void GenerateEDIFile(
    FileStream^ stream
)
Parameters
stream (FileStream)
The stream.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method (outputFile)

GenerateEDIFile Method (outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile(String)
RDPCrystal EDI Library
Generates the EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    string outputFile
)
Public Sub GenerateEDIFile ( _
    outputFile As String _
)
public:
void GenerateEDIFile(
    String^ outputFile
)
Parameters
outputFile (String)
path of the output file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFileWithBatchWrite Method

GenerateEDIFileWithBatchWrite Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFileWithBatchWrite()()()()
RDPCrystal EDI Library
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite()
Public Sub GenerateEDIFileWithBatchWrite
public:
void GenerateEDIFileWithBatchWrite()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Loops
RDPCrystal EDI Library
Gets or sets the loops.
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightLoop> Loops { get; set; }
Public Property Loops As List(Of LightWeightLoop)
    Get
    Set
public:
property List<LightWeightLoop^>^ Loops {
    List<LightWeightLoop^>^ get ();
    void set (List<LightWeightLoop^>^ value);
}
Value
The loops.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NewLineAfterSegment Property

NewLineAfterSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► NewLineAfterSegment
RDPCrystal EDI Library
Whether or not to insert a new line after every segment
Declaration Syntax
C# Visual Basic Visual C++
public bool NewLineAfterSegment { get; set; }
Public Property NewLineAfterSegment As Boolean
    Get
    Set
public:
property bool NewLineAfterSegment {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ToXml()()()() | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDILightWeightDOcument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDILightWeightDocument to Xml
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml()()()()
RDPCrystal EDI Library
Converts this EDILightWeightDOcument to an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()
Return Value
XmlDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (options)

ToXml Method (options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml(XmlConfigOptions)
RDPCrystal EDI Library
Converts this EDILightWeightDOcument to an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml(
    XmlConfigOptions options
)
Public Function ToXml ( _
    options As XmlConfigOptions _
) As XmlDocument
public:
XmlDocument^ ToXml(
    XmlConfigOptions^ options
)
Parameters
options (XmlConfigOptions)
Configuration options
Return Value
XmlDocument

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (file)

ToXml Method (file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml(String)
RDPCrystal EDI Library
Converts this EDILightWeightDOcument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file
)
Public Sub ToXml ( _
    file As String _
)
public:
void ToXml(
    String^ file
)
Parameters
file (String)
The file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (file, options)

ToXml Method (file, options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml(String, XmlConfigOptions)
RDPCrystal EDI Library
Converts this EDILightWeightDocument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file,
    XmlConfigOptions options
)
Public Sub ToXml ( _
    file As String, _
    options As XmlConfigOptions _
)
public:
void ToXml(
    String^ file,
    XmlConfigOptions^ options
)
Parameters
file (String)
The file.
options (XmlConfigOptions)
Xml options.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesCreator Class

EDIRulesCreator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator
RDPCrystal EDI Library
Allows EDI Rules to be created
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIRulesCreator : Component
Public NotInheritable Class EDIRulesCreator _
    Inherits Component
public ref class EDIRulesCreator sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIRulesCreator()()()() | Initializes a new instance of the EDIRulesCreator class.
 | EDIRulesCreator(IContainer) | Initializes a new instance of the EDIRulesCreator class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CodeLists | Gets or sets the code lists.
 | CompositeSegments | Gets or sets the composite segments.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateFile()()()() | Creates the file.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIRuleFileData | Gets or sets the EDI rule file data.
 | EDIRuleFilename | Gets or sets the EDI rule filename.
 | ElementCounterDisplays | Gets the element counter displays.
 | ElementEqualities | A collection of all element equality read in from EDI rules file
 | ElementFormats | Gets the element formats.
 | Elements | Gets or sets the elements.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LoadFile()()()() | Loads the file.
 | LoadFile(String) | Loads the file.
 | LoopSchema | Gets or sets the loop schema.
 | MainLoop | Gets or sets the main loop.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rules | A collection of all rules read in from EDI rules file
 | SampleData | Data contained in the SAMPLE DATA section of the EDI File
 | SaveFilename | Gets or sets the save filename.
 | Segments | Gets or sets the segments.
 | SegmentSchemas | Gets or sets the segment schemas.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | Summaries | Gets the summaries.
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIRulesCreator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesCreator Constructor

EDIRulesCreator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRulesCreator()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIRulesCreator()()()() | Initializes a new instance of the EDIRulesCreator class.
 | EDIRulesCreator(IContainer) | Initializes a new instance of the EDIRulesCreator class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesCreator Constructor

EDIRulesCreator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRulesCreator()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIRulesCreator class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesCreator()
Public Sub New
public:
EDIRulesCreator()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesCreator Constructor (container)

EDIRulesCreator Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRulesCreator(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDIRulesCreator class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesCreator(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIRulesCreator(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeLists Property

CodeLists Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► CodeLists
RDPCrystal EDI Library
Gets or sets the code lists.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, CodeList> CodeLists { get; set; }
Public Property CodeLists As Dictionary(Of String, CodeList)
    Get
    Set
public:
property Dictionary<String^, CodeList^>^ CodeLists {
    Dictionary<String^, CodeList^>^ get ();
    void set (Dictionary<String^, CodeList^>^ value);
}
Value
The code lists.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeSegments Property

CompositeSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► CompositeSegments
RDPCrystal EDI Library
Gets or sets the composite segments.
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> CompositeSegments { get; set; }
Public Property CompositeSegments As SortedDictionary(Of String, Segment)
    Get
    Set
public:
property SortedDictionary<String^, Segment^>^ CompositeSegments {
    SortedDictionary<String^, Segment^>^ get ();
    void set (SortedDictionary<String^, Segment^>^ value);
}
Value
The composite segments.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateFile Method

CreateFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► CreateFile()()()()
RDPCrystal EDI Library
Creates the file.
Declaration Syntax
C# Visual Basic Visual C++
public void CreateFile()
Public Sub CreateFile
public:
void CreateFile()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRuleFileData Property

EDIRuleFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRuleFileData
RDPCrystal EDI Library
Gets or sets the EDI rule file data.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> EDIRuleFileData { get; set; }
Public Property EDIRuleFileData As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ EDIRuleFileData {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
Value
The EDI rule file data.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRuleFilename Property

EDIRuleFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRuleFilename
RDPCrystal EDI Library
Gets or sets the EDI rule filename.
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRuleFilename { get; set; }
Public Property EDIRuleFilename As String
    Get
    Set
public:
property String^ EDIRuleFilename {
    String^ get ();
    void set (String^ value);
}
Value
The EDI rule filename.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCounterDisplays Property

ElementCounterDisplays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► ElementCounterDisplays
RDPCrystal EDI Library
Gets the element counter displays.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementCounterDisplay> ElementCounterDisplays { get; }
Public ReadOnly Property ElementCounterDisplays As List(Of ElementCounterDisplay)
    Get
public:
property List<ElementCounterDisplay^>^ ElementCounterDisplays {
    List<ElementCounterDisplay^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementEqualities Property

ElementEqualities Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► ElementEqualities
RDPCrystal EDI Library
A collection of all element equality read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementEqualityDisplay> ElementEqualities { get; }
Public ReadOnly Property ElementEqualities As List(Of ElementEqualityDisplay)
    Get
public:
property List<ElementEqualityDisplay^>^ ElementEqualities {
    List<ElementEqualityDisplay^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormats Property

ElementFormats Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► ElementFormats
RDPCrystal EDI Library
Gets the element formats.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> ElementFormats { get; }
Public ReadOnly Property ElementFormats As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ ElementFormats {
    Dictionary<String^, String^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Elements
RDPCrystal EDI Library
Gets or sets the elements.
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<int, Element> Elements { get; set; }
Public Property Elements As SortedDictionary(Of Integer, Element)
    Get
    Set
public:
property SortedDictionary<int, Element^>^ Elements {
    SortedDictionary<int, Element^>^ get ();
    void set (SortedDictionary<int, Element^>^ value);
}
Value
The elements.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoadFile Method

LoadFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoadFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | LoadFile()()()() | Loads the file.
 | LoadFile(String) | Loads the file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoadFile Method

LoadFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoadFile()()()()
RDPCrystal EDI Library
Loads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadFile()
Public Sub LoadFile
public:
void LoadFile()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoadFile Method (EDIRulesFilename)

LoadFile Method (EDIRulesFilename)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoadFile(String)
RDPCrystal EDI Library
Loads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadFile(
    string EDIRulesFilename
)
Public Sub LoadFile ( _
    EDIRulesFilename As String _
)
public:
void LoadFile(
    String^ EDIRulesFilename
)
Parameters
EDIRulesFilename (String)
The EDI rules filename.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopSchema Property

LoopSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoopSchema
RDPCrystal EDI Library
Gets or sets the loop schema.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema LoopSchema { get; set; }
Public Property LoopSchema As LoopSchema
    Get
    Set
public:
property LoopSchema^ LoopSchema {
    LoopSchema^ get ();
    void set (LoopSchema^ value);
}
Value
The loop schema.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MainLoop Property

MainLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► MainLoop
RDPCrystal EDI Library
Gets or sets the main loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop MainLoop { get; set; }
Public Property MainLoop As Loop
    Get
    Set
public:
property Loop^ MainLoop {
    Loop^ get ();
    void set (Loop^ value);
}
Value
The main loop.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Rules
RDPCrystal EDI Library
A collection of all rules read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<RuleDisplay> Rules { get; }
Public ReadOnly Property Rules As List(Of RuleDisplay)
    Get
public:
property List<RuleDisplay^>^ Rules {
    List<RuleDisplay^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SampleData Property

SampleData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► SampleData
RDPCrystal EDI Library
Data contained in the SAMPLE DATA section of the EDI File
Declaration Syntax
C# Visual Basic Visual C++
public List<string> SampleData { get; set; }
Public Property SampleData As List(Of String)
    Get
    Set
public:
property List<String^>^ SampleData {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SaveFilename Property

SaveFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► SaveFilename
RDPCrystal EDI Library
Gets or sets the save filename.
Declaration Syntax
C# Visual Basic Visual C++
public string SaveFilename { get; set; }
Public Property SaveFilename As String
    Get
    Set
public:
property String^ SaveFilename {
    String^ get ();
    void set (String^ value);
}
Value
The save filename.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Segments
RDPCrystal EDI Library
Gets or sets the segments.
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> Segments { get; set; }
Public Property Segments As SortedDictionary(Of String, Segment)
    Get
    Set
public:
property SortedDictionary<String^, Segment^>^ Segments {
    SortedDictionary<String^, Segment^>^ get ();
    void set (SortedDictionary<String^, Segment^>^ value);
}
Value
The segments.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchemas Property

SegmentSchemas Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► SegmentSchemas
RDPCrystal EDI Library
Gets or sets the segment schemas.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<int, SegmentSchema> SegmentSchemas { get; set; }
Public Property SegmentSchemas As Dictionary(Of Integer, SegmentSchema)
    Get
    Set
public:
property Dictionary<int, SegmentSchema^>^ SegmentSchemas {
    Dictionary<int, SegmentSchema^>^ get ();
    void set (Dictionary<int, SegmentSchema^>^ value);
}
Value
The segment schemas.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Summaries Property

Summaries Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Summaries
RDPCrystal EDI Library
Gets the summaries.
Declaration Syntax
C# Visual Basic Visual C++
public List<SummaryDisplay> Summaries { get; }
Public ReadOnly Property Summaries As List(Of SummaryDisplay)
    Get
public:
property List<SummaryDisplay^>^ Summaries {
    List<SummaryDisplay^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader Class

EDIRulesReader Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader
RDPCrystal EDI Library
Reader that reads and loads EDI rules from an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIRulesReader : Component
Public NotInheritable Class EDIRulesReader _
    Inherits Component
public ref class EDIRulesReader sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIRulesReader(IContainer) | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader()()()() | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader(String) | Initializes a new instance of the EDIRulesReader class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CodeLists | A collection of all codelists read in from EDI rules file
 | CompositesSegments | A collection of all composite segments read in from EDI rules file
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIRulesFile | Gets or sets the EDI rules file stream
 | EDIRulesFileData | Gets or sets the EDI rules file data. Each line must end with a return character
 | EDIRulesFilePath | Gets or sets the EDI rules file path.
 | ElementCodes | A collection of all element codes read in from EDI rules file
 | ElementCounterDisplays | Gets the element counter displays.
 | ElementEqualities | A collection of all element equality read in from EDI rules file
 | ElementFormats | Gets the element formats.
 | Elements | A collection of all elements read in from EDI rules file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileData | A collection of all custom file data
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LoopDescriptions | Gets the descriptions of loops
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberOfLoopsCreated | Gets the number of loops created.
 | OnErrorOccurred | Occurs when [on error occurred].
 | Parse(String) | Parses a rule file and loads its contents
 | Parse()()()() | Parses a rule file and loads its contents
 | Parsed | Gets a value indicating whether this EDIRulesReader is parsed.
 | ProgressChanged | Occurs when [progress changed].
 | Reset()()()() | Resets this instance.
 | RuleFileData | A collection of file property values specified in the rules file
 | Rules | A collection of all rules read in from EDI rules file
 | SampleData | Data contained in the SAMPLE DATA section of the EDI File
 | Schema | The complete schema of the EDI standard read from the EDI rules file
 | Segments | A collection of all segments read in from EDI rules file
 | SegmentSchemas | A collection of all segments schemas read in from EDI rules file
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | Summaries | Gets the summaries.
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIRulesReader

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader Constructor

EDIRulesReader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIRulesReader(IContainer) | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader()()()() | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader(String) | Initializes a new instance of the EDIRulesReader class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader Constructor

EDIRulesReader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIRulesReader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader()
Public Sub New
public:
EDIRulesReader()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader Constructor (container)

EDIRulesReader Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the EDIRulesReader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIRulesReader(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader Constructor (ediRuleFilePath)

EDIRulesReader Constructor (ediRuleFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader(String)
RDPCrystal EDI Library
Initializes a new instance of the EDIRulesReader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader(
    string ediRuleFilePath
)
Public Sub New ( _
    ediRuleFilePath As String _
)
public:
EDIRulesReader(
    String^ ediRuleFilePath
)
Parameters
ediRuleFilePath (String)
The CEF file path.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeLists Property

CodeLists Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► CodeLists
RDPCrystal EDI Library
A collection of all codelists read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, CodeList> CodeLists { get; }
Public ReadOnly Property CodeLists As Dictionary(Of String, CodeList)
    Get
public:
property Dictionary<String^, CodeList^>^ CodeLists {
    Dictionary<String^, CodeList^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositesSegments Property

CompositesSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► CompositesSegments
RDPCrystal EDI Library
A collection of all composite segments read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> CompositesSegments { get; }
Public ReadOnly Property CompositesSegments As SortedDictionary(Of String, Segment)
    Get
public:
property SortedDictionary<String^, Segment^>^ CompositesSegments {
    SortedDictionary<String^, Segment^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesFile Property

EDIRulesFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesFile
RDPCrystal EDI Library
Gets or sets the EDI rules file stream
Declaration Syntax
C# Visual Basic Visual C++
public Stream EDIRulesFile { get; set; }
Public Property EDIRulesFile As Stream
    Get
    Set
public:
property Stream^ EDIRulesFile {
    Stream^ get ();
    void set (Stream^ value);
}
Value
The EDI file file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesFileData Property

EDIRulesFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesFileData
RDPCrystal EDI Library
Gets or sets the EDI rules file data. Each line must end with a return character
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFileData { get; set; }
Public Property EDIRulesFileData As String
    Get
    Set
public:
property String^ EDIRulesFileData {
    String^ get ();
    void set (String^ value);
}
Value
The EDI file data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesFilePath Property

EDIRulesFilePath Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesFilePath
RDPCrystal EDI Library
Gets or sets the EDI rules file path.
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFilePath { get; set; }
Public Property EDIRulesFilePath As String
    Get
    Set
public:
property String^ EDIRulesFilePath {
    String^ get ();
    void set (String^ value);
}
Value
The EDI rules file path.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCodes Property

ElementCodes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementCodes
RDPCrystal EDI Library
A collection of all element codes read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<int, ElementCodeList> ElementCodes { get; }
Public ReadOnly Property ElementCodes As Dictionary(Of Integer, ElementCodeList)
    Get
public:
property Dictionary<int, ElementCodeList^>^ ElementCodes {
    Dictionary<int, ElementCodeList^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCounterDisplays Property

ElementCounterDisplays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementCounterDisplays
RDPCrystal EDI Library
Gets the element counter displays.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementCounterDisplay> ElementCounterDisplays { get; }
Public ReadOnly Property ElementCounterDisplays As List(Of ElementCounterDisplay)
    Get
public:
property List<ElementCounterDisplay^>^ ElementCounterDisplays {
    List<ElementCounterDisplay^>^ get ();
}
Value
The element counter displays.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementEqualities Property

ElementEqualities Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementEqualities
RDPCrystal EDI Library
A collection of all element equality read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementEqualityDisplay> ElementEqualities { get; }
Public ReadOnly Property ElementEqualities As List(Of ElementEqualityDisplay)
    Get
public:
property List<ElementEqualityDisplay^>^ ElementEqualities {
    List<ElementEqualityDisplay^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormats Property

ElementFormats Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementFormats
RDPCrystal EDI Library
Gets the element formats.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> ElementFormats { get; }
Public ReadOnly Property ElementFormats As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ ElementFormats {
    Dictionary<String^, String^>^ get ();
}
Value
The element formats.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Elements
RDPCrystal EDI Library
A collection of all elements read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<int, Element> Elements { get; }
Public ReadOnly Property Elements As SortedDictionary(Of Integer, Element)
    Get
public:
property SortedDictionary<int, Element^>^ Elements {
    SortedDictionary<int, Element^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileData Property

FileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► FileData
RDPCrystal EDI Library
A collection of all custom file data
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> FileData { get; }
Public ReadOnly Property FileData As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ FileData {
    Dictionary<String^, String^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopDescriptions Property

LoopDescriptions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► LoopDescriptions
RDPCrystal EDI Library
Gets the descriptions of loops
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> LoopDescriptions { get; }
Public ReadOnly Property LoopDescriptions As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ LoopDescriptions {
    Dictionary<String^, String^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberOfLoopsCreated Property

NumberOfLoopsCreated Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► NumberOfLoopsCreated
RDPCrystal EDI Library
Gets the number of loops created.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfLoopsCreated { get; }
Public ReadOnly Property NumberOfLoopsCreated As Integer
    Get
public:
property int NumberOfLoopsCreated {
    int get ();
}
Value
The number of loops created.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OnErrorOccurred Event

OnErrorOccurred Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► OnErrorOccurred
RDPCrystal EDI Library
Occurs when [on error occurred].
Declaration Syntax
C# Visual Basic Visual C++
public event EDIRulesReader..::..ErrorEvent OnErrorOccurred
Public Event OnErrorOccurred As EDIRulesReader..::..ErrorEvent
public:
 event EDIRulesReader..::..ErrorEvent^ OnErrorOccurred {
    void add (EDIRulesReader..::..ErrorEvent^ value);
    void remove (EDIRulesReader..::..ErrorEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parse Method

Parse Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parse()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Parse(String) | Parses a rule file and loads its contents
 | Parse()()()() | Parses a rule file and loads its contents

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parse Method

Parse Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parse()()()()
RDPCrystal EDI Library
Parses a rule file and loads its contents
Declaration Syntax
C# Visual Basic Visual C++
public void Parse()
Public Sub Parse
public:
void Parse()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parse Method (rulesFilePath)

Parse Method (rulesFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parse(String)
RDPCrystal EDI Library
Parses a rule file and loads its contents
Declaration Syntax
C# Visual Basic Visual C++
public void Parse(
    string rulesFilePath
)
Public Sub Parse ( _
    rulesFilePath As String _
)
public:
void Parse(
    String^ rulesFilePath
)
Parameters
rulesFilePath (String)
EDI Rules file to parse

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parsed Property

Parsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parsed
RDPCrystal EDI Library
Gets a value indicating whether this EDIRulesReader is parsed.
Declaration Syntax
C# Visual Basic Visual C++
public bool Parsed { get; private set; }
Public Property Parsed As Boolean
    Get
    Private Set
public:
property bool Parsed {
    bool get ();
    private: void set (bool value);
}
Value
true if parsed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ProgressChanged Event

ProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ProgressChanged
RDPCrystal EDI Library
Occurs when [progress changed].
Declaration Syntax
C# Visual Basic Visual C++
public event EDIRulesReader..::..GeneralEvent ProgressChanged
Public Event ProgressChanged As EDIRulesReader..::..GeneralEvent
public:
 event EDIRulesReader..::..GeneralEvent^ ProgressChanged {
    void add (EDIRulesReader..::..GeneralEvent^ value);
    void remove (EDIRulesReader..::..GeneralEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Reset Method

Reset Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Reset()()()()
RDPCrystal EDI Library
Resets this instance.
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
void Reset()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RuleFileData Property

RuleFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► RuleFileData
RDPCrystal EDI Library
A collection of file property values specified in the rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> RuleFileData { get; set; }
Public Property RuleFileData As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ RuleFileData {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Rules
RDPCrystal EDI Library
A collection of all rules read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<RuleDisplay> Rules { get; }
Public ReadOnly Property Rules As List(Of RuleDisplay)
    Get
public:
property List<RuleDisplay^>^ Rules {
    List<RuleDisplay^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SampleData Property

SampleData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► SampleData
RDPCrystal EDI Library
Data contained in the SAMPLE DATA section of the EDI File
Declaration Syntax
C# Visual Basic Visual C++
public List<string> SampleData { get; set; }
Public Property SampleData As List(Of String)
    Get
    Set
public:
property List<String^>^ SampleData {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Schema Property

Schema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Schema
RDPCrystal EDI Library
The complete schema of the EDI standard read from the EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Loop Schema { get; }
Public ReadOnly Property Schema As Loop
    Get
public:
property Loop^ Schema {
    Loop^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Segments
RDPCrystal EDI Library
A collection of all segments read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> Segments { get; }
Public ReadOnly Property Segments As SortedDictionary(Of String, Segment)
    Get
public:
property SortedDictionary<String^, Segment^>^ Segments {
    SortedDictionary<String^, Segment^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchemas Property

SegmentSchemas Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► SegmentSchemas
RDPCrystal EDI Library
A collection of all segments schemas read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<int, SegmentSchema> SegmentSchemas { get; }
Public ReadOnly Property SegmentSchemas As Dictionary(Of Integer, SegmentSchema)
    Get
public:
property Dictionary<int, SegmentSchema^>^ SegmentSchemas {
    Dictionary<int, SegmentSchema^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Summaries Property

Summaries Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Summaries
RDPCrystal EDI Library
Gets the summaries.
Declaration Syntax
C# Visual Basic Visual C++
public List<SummaryDisplay> Summaries { get; }
Public ReadOnly Property Summaries As List(Of SummaryDisplay)
    Get
public:
property List<SummaryDisplay^>^ Summaries {
    List<SummaryDisplay^>^ get ();
}
Value
The summaries.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader.ErrorEvent Delegate

EDIRulesReader..::..ErrorEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader..::..ErrorEvent
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ErrorEvent(
    Object sender,
    EDIRulesReaderEventArg e
)
Public Delegate Sub ErrorEvent ( _
    sender As Object, _
    e As EDIRulesReaderEventArg _
)
public delegate void ErrorEvent(
    Object^ sender,
    EDIRulesReaderEventArg^ e
)
Parameters
sender (Object)
The sender.
e (EDIRulesReaderEventArg)
The e.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader.GeneralEvent Delegate

EDIRulesReader..::..GeneralEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader..::..GeneralEvent
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GeneralEvent(
    int progress
)
Public Delegate Sub GeneralEvent ( _
    progress As Integer _
)
public delegate void GeneralEvent(
    int progress
)
Parameters
progress (Int32)
The progress.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReaderEventArg Class

EDIRulesReaderEventArg Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReaderEventArg
RDPCrystal EDI Library
Represents an general error that may occur while parsing an EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public class EDIRulesReaderEventArg : EventArgs
Public Class EDIRulesReaderEventArg _
    Inherits EventArgs
public ref class EDIRulesReaderEventArg : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LineText | Line in the EDI rules file
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | General error message
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EDIRulesReaderEventArg

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LineText Property

LineText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReaderEventArg ► LineText
RDPCrystal EDI Library
Line in the EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public string LineText { get; }
Public ReadOnly Property LineText As String
    Get
public:
property String^ LineText {
    String^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Message Property

Message Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReaderEventArg ► Message
RDPCrystal EDI Library
General error message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDISource Enumeration

EDISource Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISource
RDPCrystal EDI Library
Represents the source of the EDI data to validate
Declaration Syntax
C# Visual Basic Visual C++
public enum EDISource
Public Enumeration EDISource
public enum class EDISource
Members
Member | Description
DataString | EDI data is coming from an in memory string
File | EDI data is coming from a file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDISpecification Class

EDISpecification Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification
RDPCrystal EDI Library
Reponsible for retrieving EDI message specific data
Declaration Syntax
C# Visual Basic Visual C++
public class EDISpecification
Public Class EDISpecification
public ref class EDISpecification
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDISpecification()()()() | Initializes a new instance of the EDISpecification class
 | Delimiters |
 | EDIFACTControllingAgency |
 | EDIFACTMessageType |
 | EDIFACTMessageVersion |
 | EDIFACTReleaseVersion |
 | EDIFileType | Whether this EDI file/data is X12 or EDIFACT standard
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindFileTypeFromFile(String, Encoding) | Finds the FileType{X12,EDIFACT} from file.
 | FindFileTypeFromString(String) | Finds the FileType{X12,EDIFACT} from a string.
 | FindSpecificationFromFile(String) | Finds the specification from file.
 | FindSpecificationFromFile(String, Encoding) | Finds the specification from file.
 | FindSpecificationFromString(String) | Finds the specification from string.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterchangeReceiverID |
 | InterchangeReceiverIDQualifier |
 | InterchangeSenderID |
 | InterchangeSenderIDQualifier |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrimString | String to ignore between segment delimiters
 | X12TransactionSetCode | For X12, the value in the 1st element of a transaction header (ST)
 | X12Version | For X12, the value in the 8th element of a functional group (GS)
 | X12VersionCode | For X12, the value in the 1st element of a functional group (GS)
Inheritance Hierarchy
Object
EDISpecification

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDISpecification Constructor

EDISpecification Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDISpecification()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDISpecification class
Declaration Syntax
C# Visual Basic Visual C++
public EDISpecification()
Public Sub New
public:
EDISpecification()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► Delimiters
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; private set; }
Public Property Delimiters As Delimiters
    Get
    Private Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    private: void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFACTControllingAgency Property

EDIFACTControllingAgency Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTControllingAgency
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTControllingAgency { get; private set; }
Public Property EDIFACTControllingAgency As String
    Get
    Private Set
public:
property String^ EDIFACTControllingAgency {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFACTMessageType Property

EDIFACTMessageType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTMessageType
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTMessageType { get; private set; }
Public Property EDIFACTMessageType As String
    Get
    Private Set
public:
property String^ EDIFACTMessageType {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFACTMessageVersion Property

EDIFACTMessageVersion Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTMessageVersion
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTMessageVersion { get; private set; }
Public Property EDIFACTMessageVersion As String
    Get
    Private Set
public:
property String^ EDIFACTMessageVersion {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFACTReleaseVersion Property

EDIFACTReleaseVersion Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTReleaseVersion
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTReleaseVersion { get; private set; }
Public Property EDIFACTReleaseVersion As String
    Get
    Private Set
public:
property String^ EDIFACTReleaseVersion {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFileType
RDPCrystal EDI Library
Whether this EDI file/data is X12 or EDIFACT standard
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; private set; }
Public Property EDIFileType As FileType
    Get
    Private Set
public:
property FileType EDIFileType {
    FileType get ();
    private: void set (FileType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FindFileTypeFromFile Method (path, encoding)

FindFileTypeFromFile Method (path, encoding)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindFileTypeFromFile(String, Encoding)
RDPCrystal EDI Library
Finds the FileType{X12,EDIFACT} from file.
Declaration Syntax
C# Visual Basic Visual C++
public static FileType FindFileTypeFromFile(
    string path,
    Encoding encoding
)
Public Shared Function FindFileTypeFromFile ( _
    path As String, _
    encoding As Encoding _
) As FileType
public:
static FileType FindFileTypeFromFile(
    String^ path,
    Encoding^ encoding
)
Parameters
path (String)
The path.
encoding (Encoding)
encoding
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FindFileTypeFromString Method (fileData)

FindFileTypeFromString Method (fileData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindFileTypeFromString(String)
RDPCrystal EDI Library
Finds the FileType{X12,EDIFACT} from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static FileType FindFileTypeFromString(
    string fileData
)
Public Shared Function FindFileTypeFromString ( _
    fileData As String _
) As FileType
public:
static FileType FindFileTypeFromString(
    String^ fileData
)
Parameters
fileData (String)
The path.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FindSpecificationFromFile Method

FindSpecificationFromFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | FindSpecificationFromFile(String) | Finds the specification from file.
 | FindSpecificationFromFile(String, Encoding) | Finds the specification from file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FindSpecificationFromFile Method (path)

FindSpecificationFromFile Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromFile(String)
RDPCrystal EDI Library
Finds the specification from file.
Declaration Syntax
C# Visual Basic Visual C++
public static EDISpecification FindSpecificationFromFile(
    string path
)
Public Shared Function FindSpecificationFromFile ( _
    path As String _
) As EDISpecification
public:
static EDISpecification^ FindSpecificationFromFile(
    String^ path
)
Parameters
path (String)
The path.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FindSpecificationFromFile Method (path, encoding)

FindSpecificationFromFile Method (path, encoding)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromFile(String, Encoding)
RDPCrystal EDI Library
Finds the specification from file.
Declaration Syntax
C# Visual Basic Visual C++
public static EDISpecification FindSpecificationFromFile(
    string path,
    Encoding encoding
)
Public Shared Function FindSpecificationFromFile ( _
    path As String, _
    encoding As Encoding _
) As EDISpecification
public:
static EDISpecification^ FindSpecificationFromFile(
    String^ path,
    Encoding^ encoding
)
Parameters
path (String)
The path
encoding (Encoding)
encoding
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FindSpecificationFromString Method (fileData)

FindSpecificationFromString Method (fileData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromString(String)
RDPCrystal EDI Library
Finds the specification from string.
Declaration Syntax
C# Visual Basic Visual C++
public static EDISpecification FindSpecificationFromString(
    string fileData
)
Public Shared Function FindSpecificationFromString ( _
    fileData As String _
) As EDISpecification
public:
static EDISpecification^ FindSpecificationFromString(
    String^ fileData
)
Parameters
fileData (String)
The file data.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InterchangeReceiverID Property

InterchangeReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeReceiverID
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverID { get; private set; }
Public Property InterchangeReceiverID As String
    Get
    Private Set
public:
property String^ InterchangeReceiverID {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InterchangeReceiverIDQualifier Property

InterchangeReceiverIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeReceiverIDQualifier
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverIDQualifier { get; private set; }
Public Property InterchangeReceiverIDQualifier As String
    Get
    Private Set
public:
property String^ InterchangeReceiverIDQualifier {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InterchangeSenderID Property

InterchangeSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeSenderID
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderID { get; private set; }
Public Property InterchangeSenderID As String
    Get
    Private Set
public:
property String^ InterchangeSenderID {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


InterchangeSenderIDQualifier Property

InterchangeSenderIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeSenderIDQualifier
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderIDQualifier { get; private set; }
Public Property InterchangeSenderIDQualifier As String
    Get
    Private Set
public:
property String^ InterchangeSenderIDQualifier {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Field

TrimString Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► TrimString
RDPCrystal EDI Library
String to ignore between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public static string TrimString
Public Shared TrimString As String
public:
static String^ TrimString

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


X12TransactionSetCode Property

X12TransactionSetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► X12TransactionSetCode
RDPCrystal EDI Library
For X12, the value in the 1st element of a transaction header (ST)
Declaration Syntax
C# Visual Basic Visual C++
public string X12TransactionSetCode { get; private set; }
Public Property X12TransactionSetCode As String
    Get
    Private Set
public:
property String^ X12TransactionSetCode {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


X12Version Property

X12Version Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► X12Version
RDPCrystal EDI Library
For X12, the value in the 8th element of a functional group (GS)
Declaration Syntax
C# Visual Basic Visual C++
public string X12Version { get; private set; }
Public Property X12Version As String
    Get
    Private Set
public:
property String^ X12Version {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


X12VersionCode Property

X12VersionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► X12VersionCode
RDPCrystal EDI Library
For X12, the value in the 1st element of a functional group (GS)
Declaration Syntax
C# Visual Basic Visual C++
public string X12VersionCode { get; private set; }
Public Property X12VersionCode As String
    Get
    Private Set
public:
property String^ X12VersionCode {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidationMessage Enumeration

EDIValidationMessage Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidationMessage
RDPCrystal EDI Library
Represents different EDI messages
Declaration Syntax
C# Visual Basic Visual C++
public enum EDIValidationMessage
Public Enumeration EDIValidationMessage
public enum class EDIValidationMessage
Members
Member | Description
None |
CompositeElementMissing | Required element missing
CompositeElementDataFormatInvalid |
CompositeElementNotUsed | Not Used data element present
CompositeElementRecommended |
CompositeElementNotRecommended |
CompositeElementLessThanMinimumLength | Data Element too short
CompositeElementGreaterThanMaximumLength | Data Element too long
CompositeElementHasWrongValue | Invalid code value
CompositeElementValueAlreadyEntered | Invalid code value
DuplicateSegment |
DuplicateLoop |
ElementHasWrongValue | Code value not used in implementation
InternalElementHasWrongValue | Used internally by RDPCrystal EDI Library
ElementLessThanMinimumLength | Data Element too short
ElementGreaterThanMaximumLength | Data Element too long
ElementValueAlreadyEntered | Invalid code value
ElementDataFormatInvalid | Pattern match failure
ElementNotUsed |
ElementRecommended |
ElementNotRecommended |
ElementMissing | Required element missing
EmptyTrailingElements |
EmptyTrailingCompositeElement |
ExtraElementFound |
ExtraCompositeElementFound |
ExtraDataAtEndOfFile |
LoopMissing |
LoopNotUsed |
LoopNotRecommended |
LoopRecommended |
MalformedSegment |
InvalidIntegerValue | Pattern Match Failure
InvalidDateValue | Invalid Date
InvalidTimeValue | Invalid Time
InvalidAlphabeticValue | Pattern Match Failure
InvalidPositiveNumberValue | Pattern Match Failure
InvalidNegativeNumberValue | Pattern Match Failure
InvalidDecimalValue | Pattern Match Failure
SegmentNotRecommended |
SegmentNotUsed | Not Used segment present
SegmentNotInDictionary | Unrecongized segment
SegmentRecommended |
SegmentMissing | Required Segment Missing/Segment not defined in transaction set
SummaryValueMismatch | Invalid code value
UnrecognizedLoop |
UnrecognizedSegment |
IllegalCharactorInFile |
MalformedEDIFile |
MaximumErrorLimitReached |
UnexpectedError |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator Class

EDIValidator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator
RDPCrystal EDI Library
Validates and loads EDI X12 and EDIFACT files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIValidator : Component
Public NotInheritable Class EDIValidator _
    Inherits Component
public ref class EDIValidator sealed : public Component
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIValidator(IContainer) | Create a new EDI Validator
 | EDIValidator()()()() | Create a new EDI Validator
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CheckDataTypeRequirements | Check that elements values are correct for their specified data types
 | CheckForEmptyTrailingElements | Check for trailing empty elements and trailing empty composite elements
 | CheckMinMaxRequirements | Check that elements are within their minimum and maximum required lengths
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CopyElementNumber | If set to true element numbers are copied from the rules schema to DataElements for the validation output
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DataLoop | Data loaded from the EDI file when property LoadValidatedData is set to true. Available after validation
 | DebugMode | Shows detailed information about the validation process. DEBUGGING PURPOSES ONLY, validation will be a slower
 | Delimiters | EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDataString | EDI data to validate. EDI data can also be specified from a file using the EDIFile property
 | EDIFile | Full path of EDI file to validate
 | EDIFileLines | EDI files lines available after validation. Only available when EDISource = DataString
 | EDIFileType | Used to specify the type of EDI file to be validated
 | EDILightWeightDocument | EDI Lite document available after validation. Validation must pass or this object will be null
 | EDIRulesFile | Full path of the EDI rules file that contains EDI rules used for validation
 | EDIRulesFileData | Gets or sets the EDI rules file data. Each line must end with a return character
 | EDIRulesReader | EDI Rules Reader used to read in EDI rules for validation
 | EDISource | Used to specify if validation is for an in-memory string or a file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCount | Numbers of errors in EDI file. Available after validation
 | Errors | Errors encountered while validating EDI file. Available after validation
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBlockSize | File chunk size when validating EDI data from a file
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LoadRuleFile(String) | Load the rules file to be used for validation
 | LoadValidatedData | Load EDI data while validating. After validation is complete the EDI data can be accessed the the EDIDocument property
 | MaxErrorsBeforeThrowingException | If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberOfLines | Number of lines in the EDI file
 | OnCodeCondition | Event fired to perform a custom code condition check
 | Passed | Check whether the EDI data or file has passed validation. Use this property after calling the Validate() method
 | PreventInfiniteLoopWhileSearching | If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
 | ProgressChanged | Event fired when the progress changes during validation
 | ResetValidation()()()() | Resets all validation variables. This method is automatically everytime the Validate method is called.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TimeElapsed | Time elapsed in milliseconds while validating
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrackDownUnrecognizedLoops | If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
 | TreatWarningsAsErrors | Treat all warnings as errors
 | TrimString | String to ignore at between segment delimiters
 | Validate(EDIDocument) | Validates the contents of an EDI Document
 | Validate(EDILightWeightDocument) | Validates the contents of an EDILightWeightDocument
 | Validate()()()() | Validate the EDI file
 | Validate(String, String) | Validates an EDI file
 | ValidatedTransactions |
 | ValidationCompleted | Event fired when validation is complete
 | ValidationStarted | Event fired when validation has started
 | WarningCount | Numbers of warnings in EDI file. Available after validation
 | Warnings | Warnings encountered while validating EDI file. Available after validation
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIValidator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator Constructor

EDIValidator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIValidator(IContainer) | Create a new EDI Validator
 | EDIValidator()()()() | Create a new EDI Validator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator Constructor

EDIValidator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator()()()()
RDPCrystal EDI Library
Create a new EDI Validator
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidator()
Public Sub New
public:
EDIValidator()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator Constructor (container)

EDIValidator Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator(IContainer)
RDPCrystal EDI Library
Create a new EDI Validator
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidator(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIValidator(
    IContainer^ container
)
Parameters
container (IContainer)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► AutoDetectDelimiters
RDPCrystal EDI Library
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CheckDataTypeRequirements Property

CheckDataTypeRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CheckDataTypeRequirements
RDPCrystal EDI Library
Check that elements values are correct for their specified data types
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckDataTypeRequirements { get; set; }
Public Property CheckDataTypeRequirements As Boolean
    Get
    Set
public:
property bool CheckDataTypeRequirements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CheckForEmptyTrailingElements Property

CheckForEmptyTrailingElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CheckForEmptyTrailingElements
RDPCrystal EDI Library
Check for trailing empty elements and trailing empty composite elements
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckForEmptyTrailingElements { get; set; }
Public Property CheckForEmptyTrailingElements As Boolean
    Get
    Set
public:
property bool CheckForEmptyTrailingElements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CheckMinMaxRequirements Property

CheckMinMaxRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CheckMinMaxRequirements
RDPCrystal EDI Library
Check that elements are within their minimum and maximum required lengths
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckMinMaxRequirements { get; set; }
Public Property CheckMinMaxRequirements As Boolean
    Get
    Set
public:
property bool CheckMinMaxRequirements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CopyElementNumber Property

CopyElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CopyElementNumber
RDPCrystal EDI Library
If set to true element numbers are copied from the rules schema to DataElements for the validation output
Declaration Syntax
C# Visual Basic Visual C++
public bool CopyElementNumber { get; set; }
Public Property CopyElementNumber As Boolean
    Get
    Set
public:
property bool CopyElementNumber {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataLoop Property

DataLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► DataLoop
RDPCrystal EDI Library
Data loaded from the EDI file when property LoadValidatedData is set to true. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop DataLoop { get; }
Public ReadOnly Property DataLoop As LightWeightLoop
    Get
public:
property LightWeightLoop^ DataLoop {
    LightWeightLoop^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DebugMode Property

DebugMode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► DebugMode
RDPCrystal EDI Library
Shows detailed information about the validation process. DEBUGGING PURPOSES ONLY, validation will be a slower
Declaration Syntax
C# Visual Basic Visual C++
public bool DebugMode { get; set; }
Public Property DebugMode As Boolean
    Get
    Set
public:
property bool DebugMode {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Delimiters
RDPCrystal EDI Library
EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIDataString Property

EDIDataString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIDataString
RDPCrystal EDI Library
EDI data to validate. EDI data can also be specified from a file using the EDIFile property
Declaration Syntax
C# Visual Basic Visual C++
public string EDIDataString { get; set; }
Public Property EDIDataString As String
    Get
    Set
public:
property String^ EDIDataString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIFile
RDPCrystal EDI Library
Full path of EDI file to validate
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileLines Property

EDIFileLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIFileLines
RDPCrystal EDI Library
EDI files lines available after validation. Only available when EDISource = DataString
Declaration Syntax
C# Visual Basic Visual C++
public string[] EDIFileLines { get; }
Public ReadOnly Property EDIFileLines As String()
    Get
public:
property array<String^>^ EDIFileLines {
    array<String^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIFileType
RDPCrystal EDI Library
Used to specify the type of EDI file to be validated
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDILightWeightDocument Property

EDILightWeightDocument Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDILightWeightDocument
RDPCrystal EDI Library
EDI Lite document available after validation. Validation must pass or this object will be null
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument EDILightWeightDocument { get; }
Public ReadOnly Property EDILightWeightDocument As EDILightWeightDocument
    Get
public:
property EDILightWeightDocument^ EDILightWeightDocument {
    EDILightWeightDocument^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesFile Property

EDIRulesFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIRulesFile
RDPCrystal EDI Library
Full path of the EDI rules file that contains EDI rules used for validation
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFile { get; set; }
Public Property EDIRulesFile As String
    Get
    Set
public:
property String^ EDIRulesFile {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesFileData Property

EDIRulesFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIRulesFileData
RDPCrystal EDI Library
Gets or sets the EDI rules file data. Each line must end with a return character
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFileData { get; set; }
Public Property EDIRulesFileData As String
    Get
    Set
public:
property String^ EDIRulesFileData {
    String^ get ();
    void set (String^ value);
}
Value
The EDI file data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIRulesReader Property

EDIRulesReader Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIRulesReader
RDPCrystal EDI Library
EDI Rules Reader used to read in EDI rules for validation
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader EDIRulesReader { get; set; }
Public Property EDIRulesReader As EDIRulesReader
    Get
    Set
public:
property EDIRulesReader^ EDIRulesReader {
    EDIRulesReader^ get ();
    void set (EDIRulesReader^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDISource Property

EDISource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDISource
RDPCrystal EDI Library
Used to specify if validation is for an in-memory string or a file
Declaration Syntax
C# Visual Basic Visual C++
public EDISource EDISource { get; set; }
Public Property EDISource As EDISource
    Get
    Set
public:
property EDISource EDISource {
    EDISource get ();
    void set (EDISource value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ErrorCount Property

ErrorCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ErrorCount
RDPCrystal EDI Library
Numbers of errors in EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCount { get; }
Public ReadOnly Property ErrorCount As Integer
    Get
public:
property int ErrorCount {
    int get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Errors Property

Errors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Errors
RDPCrystal EDI Library
Errors encountered while validating EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public Collection<EDIError> Errors { get; }
Public ReadOnly Property Errors As Collection(Of EDIError)
    Get
public:
property Collection<EDIError^>^ Errors {
    Collection<EDIError^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileBlockSize Property

FileBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► FileBlockSize
RDPCrystal EDI Library
File chunk size when validating EDI data from a file
Declaration Syntax
C# Visual Basic Visual C++
public int FileBlockSize { get; set; }
Public Property FileBlockSize As Integer
    Get
    Set
public:
property int FileBlockSize {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoadRuleFile Method (EDIRulesFilePath)

LoadRuleFile Method (EDIRulesFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► LoadRuleFile(String)
RDPCrystal EDI Library
Load the rules file to be used for validation
Declaration Syntax
C# Visual Basic Visual C++
public void LoadRuleFile(
    string EDIRulesFilePath
)
Public Sub LoadRuleFile ( _
    EDIRulesFilePath As String _
)
public:
void LoadRuleFile(
    String^ EDIRulesFilePath
)
Parameters
EDIRulesFilePath (String)
full path of the EDI rules file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoadValidatedData Property

LoadValidatedData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► LoadValidatedData
RDPCrystal EDI Library
Load EDI data while validating. After validation is complete the EDI data can be accessed the the EDIDocument property
Declaration Syntax
C# Visual Basic Visual C++
public bool LoadValidatedData { get; set; }
Public Property LoadValidatedData As Boolean
    Get
    Set
public:
property bool LoadValidatedData {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaxErrorsBeforeThrowingException Property

MaxErrorsBeforeThrowingException Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► MaxErrorsBeforeThrowingException
RDPCrystal EDI Library
If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
Declaration Syntax
C# Visual Basic Visual C++
public long MaxErrorsBeforeThrowingException { get; set; }
Public Property MaxErrorsBeforeThrowingException As Long
    Get
    Set
public:
property long long MaxErrorsBeforeThrowingException {
    long long get ();
    void set (long long value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberOfLines Property

NumberOfLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► NumberOfLines
RDPCrystal EDI Library
Number of lines in the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfLines { get; }
Public ReadOnly Property NumberOfLines As Integer
    Get
public:
property int NumberOfLines {
    int get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OnCodeCondition Event

OnCodeCondition Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► OnCodeCondition
RDPCrystal EDI Library
Event fired to perform a custom code condition check
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..CodeConditionEvent OnCodeCondition
Public Event OnCodeCondition As EDIValidator..::..CodeConditionEvent
public:
 event EDIValidator..::..CodeConditionEvent^ OnCodeCondition {
    void add (EDIValidator..::..CodeConditionEvent^ value);
    void remove (EDIValidator..::..CodeConditionEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Passed Property

Passed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Passed
RDPCrystal EDI Library
Check whether the EDI data or file has passed validation. Use this property after calling the Validate() method
Declaration Syntax
C# Visual Basic Visual C++
public bool Passed { get; }
Public ReadOnly Property Passed As Boolean
    Get
public:
property bool Passed {
    bool get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PreventInfiniteLoopWhileSearching Property

PreventInfiniteLoopWhileSearching Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► PreventInfiniteLoopWhileSearching
RDPCrystal EDI Library
If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
Declaration Syntax
C# Visual Basic Visual C++
public bool PreventInfiniteLoopWhileSearching { get; set; }
Public Property PreventInfiniteLoopWhileSearching As Boolean
    Get
    Set
public:
property bool PreventInfiniteLoopWhileSearching {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ProgressChanged Event

ProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ProgressChanged
RDPCrystal EDI Library
Event fired when the progress changes during validation
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..GeneralEvent ProgressChanged
Public Event ProgressChanged As EDIValidator..::..GeneralEvent
public:
 event EDIValidator..::..GeneralEvent^ ProgressChanged {
    void add (EDIValidator..::..GeneralEvent^ value);
    void remove (EDIValidator..::..GeneralEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ResetValidation Method

ResetValidation Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ResetValidation()()()()
RDPCrystal EDI Library
Resets all validation variables. This method is automatically everytime the Validate method is called.
Declaration Syntax
C# Visual Basic Visual C++
public void ResetValidation()
Public Sub ResetValidation
public:
void ResetValidation()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TimeElapsed Property

TimeElapsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TimeElapsed
RDPCrystal EDI Library
Time elapsed in milliseconds while validating
Declaration Syntax
C# Visual Basic Visual C++
public double TimeElapsed { get; }
Public ReadOnly Property TimeElapsed As Double
    Get
public:
property double TimeElapsed {
    double get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrackDownUnrecognizedLoops Property

TrackDownUnrecognizedLoops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TrackDownUnrecognizedLoops
RDPCrystal EDI Library
If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
Declaration Syntax
C# Visual Basic Visual C++
public bool TrackDownUnrecognizedLoops { get; set; }
Public Property TrackDownUnrecognizedLoops As Boolean
    Get
    Set
public:
property bool TrackDownUnrecognizedLoops {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TreatWarningsAsErrors Property

TreatWarningsAsErrors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TreatWarningsAsErrors
RDPCrystal EDI Library
Treat all warnings as errors
Declaration Syntax
C# Visual Basic Visual C++
public bool TreatWarningsAsErrors { get; set; }
Public Property TreatWarningsAsErrors As Boolean
    Get
    Set
public:
property bool TreatWarningsAsErrors {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TrimString
RDPCrystal EDI Library
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Validate(EDIDocument) | Validates the contents of an EDI Document
 | Validate(EDILightWeightDocument) | Validates the contents of an EDILightWeightDocument
 | Validate()()()() | Validate the EDI file
 | Validate(String, String) | Validates an EDI file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate()()()()
RDPCrystal EDI Library
Validate the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void Validate()
Public Sub Validate
public:
void Validate()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Validate Method (document)

Validate Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate(EDIDocument)
RDPCrystal EDI Library
Validates the contents of an EDI Document
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    EDIDocument document
)
Public Sub Validate ( _
    document As EDIDocument _
)
public:
void Validate(
    EDIDocument^ document
)
Parameters
document (EDIDocument)
document to validate

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Validate Method (document)

Validate Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate(EDILightWeightDocument)
RDPCrystal EDI Library
Validates the contents of an EDILightWeightDocument
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    EDILightWeightDocument document
)
Public Sub Validate ( _
    document As EDILightWeightDocument _
)
public:
void Validate(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
document to validate

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Validate Method (ediFile, ediRuleFile)

Validate Method (ediFile, ediRuleFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate(String, String)
RDPCrystal EDI Library
Validates an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    string ediFile,
    string ediRuleFile
)
Public Sub Validate ( _
    ediFile As String, _
    ediRuleFile As String _
)
public:
void Validate(
    String^ ediFile,
    String^ ediRuleFile
)
Parameters
ediFile (String)
Full path of EDI file to validate
ediRuleFile (String)
Full path of EDI rules file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidatedTransactions Field

ValidatedTransactions Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidatedTransactions
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public readonly List<LightWeightSegment> ValidatedTransactions
Public ReadOnly ValidatedTransactions As List(Of LightWeightSegment)
public:
initonly List<LightWeightSegment^>^ ValidatedTransactions

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationCompleted Event

ValidationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidationCompleted
RDPCrystal EDI Library
Event fired when validation is complete
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..ValidationCompletedEvent ValidationCompleted
Public Event ValidationCompleted As EDIValidator..::..ValidationCompletedEvent
public:
 event EDIValidator..::..ValidationCompletedEvent^ ValidationCompleted {
    void add (EDIValidator..::..ValidationCompletedEvent^ value);
    void remove (EDIValidator..::..ValidationCompletedEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationStarted Event

ValidationStarted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidationStarted
RDPCrystal EDI Library
Event fired when validation has started
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..ValidationStartedEvent ValidationStarted
Public Event ValidationStarted As EDIValidator..::..ValidationStartedEvent
public:
 event EDIValidator..::..ValidationStartedEvent^ ValidationStarted {
    void add (EDIValidator..::..ValidationStartedEvent^ value);
    void remove (EDIValidator..::..ValidationStartedEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


WarningCount Property

WarningCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► WarningCount
RDPCrystal EDI Library
Numbers of warnings in EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public int WarningCount { get; }
Public ReadOnly Property WarningCount As Integer
    Get
public:
property int WarningCount {
    int get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Warnings Property

Warnings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Warnings
RDPCrystal EDI Library
Warnings encountered while validating EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public Collection<EDIWarning> Warnings { get; }
Public ReadOnly Property Warnings As Collection(Of EDIWarning)
    Get
public:
property Collection<EDIWarning^>^ Warnings {
    Collection<EDIWarning^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator.CodeConditionEvent Delegate

EDIValidator..::..CodeConditionEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..CodeConditionEvent
RDPCrystal EDI Library
Delegate used for raising an event to perform a custom code condition check
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CodeConditionEvent(
    Object sender,
    CodeConditionEventArgs e
)
Public Delegate Sub CodeConditionEvent ( _
    sender As Object, _
    e As CodeConditionEventArgs _
)
public delegate void CodeConditionEvent(
    Object^ sender,
    CodeConditionEventArgs^ e
)
Parameters
sender (Object)
sender of the event
e (CodeConditionEventArgs)
current validation context

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator.GeneralEvent Delegate

EDIValidator..::..GeneralEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..GeneralEvent
RDPCrystal EDI Library
Delegate used for raising general events relating to progress
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GeneralEvent(
    int progress
)
Public Delegate Sub GeneralEvent ( _
    progress As Integer _
)
public delegate void GeneralEvent(
    int progress
)
Parameters
progress (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator.ValidationCompletedEvent Delegate

EDIValidator..::..ValidationCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..ValidationCompletedEvent
RDPCrystal EDI Library
Delegate used for raising an event while validation is being performed
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationCompletedEvent(
    Object sender,
    ValidationEventsArgs e
)
Public Delegate Sub ValidationCompletedEvent ( _
    sender As Object, _
    e As ValidationEventsArgs _
)
public delegate void ValidationCompletedEvent(
    Object^ sender,
    ValidationEventsArgs^ e
)
Parameters
sender (Object)
sender of the event
e (ValidationEventsArgs)
data relating to the validation progress

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIValidator.ValidationStartedEvent Delegate

EDIValidator..::..ValidationStartedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..ValidationStartedEvent
RDPCrystal EDI Library
Delegate used for raising an event when validation begins
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationStartedEvent(
    Object sender
)
Public Delegate Sub ValidationStartedEvent ( _
    sender As Object _
)
public delegate void ValidationStartedEvent(
    Object^ sender
)
Parameters
sender (Object)
sender of the event

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIWarning Class

EDIWarning Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIWarning
RDPCrystal EDI Library
Represents a general EDI warning. Warnings are available after validation
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIWarning : EDIError
Public NotInheritable Class EDIWarning _
    Inherits EDIError
public ref class EDIWarning sealed : public EDIError
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIWarning()()()() | Initializes a new instance of the EDIWarning class
 | EDIWarning(Int32, String, String, Int32, Int32, EDIValidationMessage, String, LightWeightSegment, LightWeightSegment, String, Int64, DataSegment) | Initializes a new instance of the EDIWarning class
 | CompositeElementDescription | Description of the composite element that contains the error (Inherited from EDIError.)
 | CompositeElementOrdinal | Get the composite element number that contains the error (Inherited from EDIError.)
 | Description | Get the description of the error (Inherited from EDIError.)
 | ElementDescription | Description of the element that contains the error (Inherited from EDIError.)
 | ElementOrdinal | Get the element number that contains the error (Inherited from EDIError.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GSSegment | Gets the GS segment. (Inherited from EDIError.)
 | LineNumber | Get the line number of the error in the EDI file (Inherited from EDIError.)
 | Loop | Get the name of the loop that contains the error (Inherited from EDIError.)
 | LoopDescription | Description of the loop that contains the error (Inherited from EDIError.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | General error message type (Inherited from EDIError.)
 | Segment | Get the name of the segment that contains the error (Inherited from EDIError.)
 | SegmentDescription | Description of the segment that contains the error (Inherited from EDIError.)
 | SegmentOrdinal | Get the segment ordinal number that contains the error (Inherited from EDIError.)
 | SegmentPositionInTransaction | Gets or sets the segment position in transaction. (Inherited from EDIError.)
 | SegmentSchema | The schema of the segment that was being validated while the error/warning occurred (Inherited from EDIError.)
 | SetSnipLevel()()()() | Sets the snip level. (Inherited from EDIError.)
 | SnipLevel | Snip level (Inherited from EDIError.)
 | StackTrace | Gets the stack trace if this is an unexpected error (Inherited from EDIError.)
 | STSegment | Gets the ST segment. (Inherited from EDIError.)
 | ToString()()()() | Get a string represenation of the error (Inherited from EDIError.)
 | ValidatingSegment | The actual segment that was being evaluated while the error/warning occurred (Inherited from EDIError.)
Inheritance Hierarchy
Object
 | EDIError
 |  | EDIWarning

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIWarning Constructor

EDIWarning Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIWarning ► EDIWarning()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIWarning()()()() | Initializes a new instance of the EDIWarning class
 | EDIWarning(Int32, String, String, Int32, Int32, EDIValidationMessage, String, LightWeightSegment, LightWeightSegment, String, Int64, DataSegment) | Initializes a new instance of the EDIWarning class

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIWarning Constructor

EDIWarning Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIWarning ► EDIWarning()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIWarning class
Declaration Syntax
C# Visual Basic Visual C++
public EDIWarning()
Public Sub New
public:
EDIWarning()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIWarning Constructor (lineNumber, loop, segment, elementOrdinal, compositeElementOrd, message, description, currentSTSegment, currentGSSegment, position, segmentPosition, schemaSeg)

EDIWarning Constructor (lineNumber, loop, segment, elementOrdinal, compositeElementOrd, message, description, currentSTSegment, currentGSSegment, position, segmentPosition, schemaSeg)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIWarning ► EDIWarning(Int32, String, String, Int32, Int32, EDIValidationMessage, String, LightWeightSegment, LightWeightSegment, String, Int64, DataSegment)
RDPCrystal EDI Library
Initializes a new instance of the EDIWarning class
Declaration Syntax
C# Visual Basic Visual C++
public EDIWarning(
    int lineNumber,
    string loop,
    string segment,
    int elementOrdinal,
    int compositeElementOrd,
    EDIValidationMessage message,
    string description,
    LightWeightSegment currentSTSegment,
    LightWeightSegment currentGSSegment,
    string position,
    long segmentPosition,
    DataSegment schemaSeg
)
Public Sub New ( _
    lineNumber As Integer, _
    loop As String, _
    segment As String, _
    elementOrdinal As Integer, _
    compositeElementOrd As Integer, _
    message As EDIValidationMessage, _
    description As String, _
    currentSTSegment As LightWeightSegment, _
    currentGSSegment As LightWeightSegment, _
    position As String, _
    segmentPosition As Long, _
    schemaSeg As DataSegment _
)
public:
EDIWarning(
    int lineNumber,
    String^ loop,
    String^ segment,
    int elementOrdinal,
    int compositeElementOrd,
    EDIValidationMessage message,
    String^ description,
    LightWeightSegment^ currentSTSegment,
    LightWeightSegment^ currentGSSegment,
    String^ position,
    long long segmentPosition,
    DataSegment^ schemaSeg
)
Parameters
lineNumber (Int32)
loop (String)
segment (String)
elementOrdinal (Int32)
compositeElementOrd (Int32)
message (EDIValidationMessage)
description (String)
currentSTSegment (LightWeightSegment)
currentGSSegment (LightWeightSegment)
position (String)
segmentPosition (Int64)
schemaSeg (DataSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIXmlConverter Class

EDIXmlConverter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter
RDPCrystal EDI Library
Class responsible for generating XML data from EDI data
Declaration Syntax
C# Visual Basic Visual C++
public class EDIXmlConverter
Public Class EDIXmlConverter
public ref class EDIXmlConverter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIXmlConverter(EDILightWeightDocument) | Initializes a new instance of the EDIXmlConverter class.
 | EDIXmlConverter(EDIDocument) | Initializes a new instance of the EDIXmlConverter class.
 | BufferSize | Gets or sets the size of the buffer.
 | EDIXMLFileString | Gets the EDI XML file string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | ToXml()()()() | Convert to XML
 | ToXml(String) | Convert to XML and saves to a file
 | XmlConfigOptions | Gets or sets the XML config options.
Inheritance Hierarchy
Object
EDIXmlConverter

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIXmlConverter Constructor

EDIXmlConverter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXmlConverter()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | EDIXmlConverter(EDILightWeightDocument) | Initializes a new instance of the EDIXmlConverter class.
 | EDIXmlConverter(EDIDocument) | Initializes a new instance of the EDIXmlConverter class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIXmlConverter Constructor (ediDocument)

EDIXmlConverter Constructor (ediDocument)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXmlConverter(EDIDocument)
RDPCrystal EDI Library
Initializes a new instance of the EDIXmlConverter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIXmlConverter(
    EDIDocument ediDocument
)
Public Sub New ( _
    ediDocument As EDIDocument _
)
public:
EDIXmlConverter(
    EDIDocument^ ediDocument
)
Parameters
ediDocument (EDIDocument)
The edi document.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIXmlConverter Constructor (ediDocument)

EDIXmlConverter Constructor (ediDocument)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXmlConverter(EDILightWeightDocument)
RDPCrystal EDI Library
Initializes a new instance of the EDIXmlConverter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIXmlConverter(
    EDILightWeightDocument ediDocument
)
Public Sub New ( _
    ediDocument As EDILightWeightDocument _
)
public:
EDIXmlConverter(
    EDILightWeightDocument^ ediDocument
)
Parameters
ediDocument (EDILightWeightDocument)
The edi document.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


BufferSize Property

BufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► BufferSize
RDPCrystal EDI Library
Gets or sets the size of the buffer.
Declaration Syntax
C# Visual Basic Visual C++
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Value
The size of the buffer.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIXMLFileString Property

EDIXMLFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXMLFileString
RDPCrystal EDI Library
Gets the EDI XML file string.
Declaration Syntax
C# Visual Basic Visual C++
public string EDIXMLFileString { get; internal set; }
Public Property EDIXMLFileString As String
    Get
    Friend Set
public:
property String^ EDIXMLFileString {
    String^ get ();
    internal: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► ToXml()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ToXml()()()() | Convert to XML
 | ToXml(String) | Convert to XML and saves to a file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► ToXml()()()()
RDPCrystal EDI Library
Convert to XML
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToXml Method (file)

ToXml Method (file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► ToXml(String)
RDPCrystal EDI Library
Convert to XML and saves to a file
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file
)
Public Sub ToXml ( _
    file As String _
)
public:
void ToXml(
    String^ file
)
Parameters
file (String)
Return Value
file to save XML to

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


XmlConfigOptions Property

XmlConfigOptions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► XmlConfigOptions
RDPCrystal EDI Library
Gets or sets the XML config options.
Declaration Syntax
C# Visual Basic Visual C++
public XmlConfigOptions XmlConfigOptions { get; set; }
Public Property XmlConfigOptions As XmlConfigOptions
    Get
    Set
public:
property XmlConfigOptions^ XmlConfigOptions {
    XmlConfigOptions^ get ();
    void set (XmlConfigOptions^ value);
}
Value
The XML config options.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Element Class

Element Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element
RDPCrystal EDI Library
Basic element used by EDI Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Element
<SerializableAttribute> _
Public Class Element
[SerializableAttribute]
public ref class Element
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Element()()()() | Create a new Element
 | AddCodeValues(String, String) | Adds the code values.
 | Codes | Get/Set the collection of element codes description This is a code value can the element can have and the description of this code
 | DataType | Get/Set the datatype
 | Description | Description of element
 | ElementNumber | Get/Set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Max | Get/Set the maximum string length
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Get/Set the minimum string length
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Element

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Element Constructor

Element Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Element()()()()
RDPCrystal EDI Library
Create a new Element
Declaration Syntax
C# Visual Basic Visual C++
public Element()
Public Sub New
public:
Element()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AddCodeValues Method (key, value)

AddCodeValues Method (key, value)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► AddCodeValues(String, String)
RDPCrystal EDI Library
Adds the code values.
Declaration Syntax
C# Visual Basic Visual C++
public void AddCodeValues(
    string key,
    string value
)
Public Sub AddCodeValues ( _
    key As String, _
    value As String _
)
public:
void AddCodeValues(
    String^ key,
    String^ value
)
Parameters
key (String)
The key.
value (String)
The value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Codes Property

Codes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Codes
RDPCrystal EDI Library
Get/Set the collection of element codes description This is a code value can the element can have and the description of this code
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> Codes { get; private set; }
Public Property Codes As Dictionary(Of String, String)
    Get
    Private Set
public:
property Dictionary<String^, String^>^ Codes {
    Dictionary<String^, String^>^ get ();
    private: void set (Dictionary<String^, String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataType Property

DataType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► DataType
RDPCrystal EDI Library
Get/Set the datatype
Declaration Syntax
C# Visual Basic Visual C++
public ElementDataType DataType { get; set; }
Public Property DataType As ElementDataType
    Get
    Set
public:
property ElementDataType DataType {
    ElementDataType get ();
    void set (ElementDataType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Description
RDPCrystal EDI Library
Description of element
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► ElementNumber
RDPCrystal EDI Library
Get/Set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Max Property

Max Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Max
RDPCrystal EDI Library
Get/Set the maximum string length
Declaration Syntax
C# Visual Basic Visual C++
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set
public:
property int Max {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Min Property

Min Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Min
RDPCrystal EDI Library
Get/Set the minimum string length
Declaration Syntax
C# Visual Basic Visual C++
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set
public:
property int Min {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCodeList Class

ElementCodeList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList
RDPCrystal EDI Library
Represents a list of values that an element can contain
Declaration Syntax
C# Visual Basic Visual C++
public class ElementCodeList
Public Class ElementCodeList
public ref class ElementCodeList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementCodeList()()()() | Creates a new ElementCodeList
 | CodeList | Possible codes that an element can contain
 | ElementNumber | Get/Set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementCodeList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCodeList Constructor

ElementCodeList Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList ► ElementCodeList()()()()
RDPCrystal EDI Library
Creates a new ElementCodeList
Declaration Syntax
C# Visual Basic Visual C++
public ElementCodeList()
Public Sub New
public:
ElementCodeList()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeList Property

CodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList ► CodeList
RDPCrystal EDI Library
Possible codes that an element can contain
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<Tuple<int, int, int>, ElementValueInfo> CodeList { get; set; }
Public Property CodeList As Dictionary(Of Tuple(Of Integer, Integer, Integer), ElementValueInfo)
    Get
    Set
public:
property Dictionary<Tuple<int, int, int>^, ElementValueInfo^>^ CodeList {
    Dictionary<Tuple<int, int, int>^, ElementValueInfo^>^ get ();
    void set (Dictionary<Tuple<int, int, int>^, ElementValueInfo^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList ► ElementNumber
RDPCrystal EDI Library
Get/Set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementConditionalConstraint Class

ElementConditionalConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementConditionalConstraint
RDPCrystal EDI Library
Represents a conditional constraint for a segment
Declaration Syntax
C# Visual Basic Visual C++
public class ElementConditionalConstraint : ElementPairConstraint
Public Class ElementConditionalConstraint _
    Inherits ElementPairConstraint
public ref class ElementConditionalConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementConditionalConstraint()()()() | Initializes a new instance of the ElementConditionalConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementConditionalConstraint

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementConditionalConstraint Constructor

ElementConditionalConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementConditionalConstraint ► ElementConditionalConstraint()()()()
RDPCrystal EDI Library
Initializes a new instance of the ElementConditionalConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementConditionalConstraint()
Public Sub New
public:
ElementConditionalConstraint()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCounterDisplay Class

ElementCounterDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay
RDPCrystal EDI Library
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class ElementCounterDisplay
Public Class ElementCounterDisplay
public ref class ElementCounterDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementCounterDisplay(String, String) | Initializes a new instance of the ElementCounterDisplay class.
 | Element | Gets or sets the element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementCounterDisplay

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementCounterDisplay Constructor (element, rule)

ElementCounterDisplay Constructor (element, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay ► ElementCounterDisplay(String, String)
RDPCrystal EDI Library
Initializes a new instance of the ElementCounterDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public ElementCounterDisplay(
    string element,
    string rule
)
Public Sub New ( _
    element As String, _
    rule As String _
)
public:
ElementCounterDisplay(
    String^ element,
    String^ rule
)
Parameters
element (String)
The element.
rule (String)
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Element Property

Element Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay ► Element
RDPCrystal EDI Library
Gets or sets the element.
Declaration Syntax
C# Visual Basic Visual C++
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
Value
The element.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay ► Rule
RDPCrystal EDI Library
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementDataType Enumeration

ElementDataType Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDataType
RDPCrystal EDI Library
Represents the possible element types
Declaration Syntax
C# Visual Basic Visual C++
public enum ElementDataType
Public Enumeration ElementDataType
public enum class ElementDataType
Members
Member | Description
ALPHABETIC |
IDENTIFIER |
STRING |
NUMERIC |
POSITIVE_NUMERIC |
NEGATIVE_NUMERIC |
DECIMAL |
TIME |
DATETIME |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementDescriptionInfo Class

ElementDescriptionInfo Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionInfo
RDPCrystal EDI Library
Represents a description that an element can have at a certain position
Declaration Syntax
C# Visual Basic Visual C++
public class ElementDescriptionInfo
Public Class ElementDescriptionInfo
public ref class ElementDescriptionInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementDescriptionInfo()()()() | Creates a new ElementDescriptionInfo
 | Description | Gets the description for an element at this specific location
 | ElementOrdinalNumber | Get/set the element ordinal number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentOrdinalNumber | Get/set the segment ordinal number
 | SubElementOrdinalNumber | Get/set the element composite element ordinal number
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementDescriptionInfo

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementDescriptionInfo Constructor

ElementDescriptionInfo Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionInfo ► ElementDescriptionInfo()()()()
RDPCrystal EDI Library
Creates a new ElementDescriptionInfo
Declaration Syntax
C# Visual Basic Visual C++
public ElementDescriptionInfo()
Public Sub New
public:
ElementDescriptionInfo()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionInfo ► Description
RDPCrystal EDI Library
Gets the description for an element at this specific location
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinalNumber Property

ElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionInfo ► ElementOrdinalNumber
RDPCrystal EDI Library
Get/set the element ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalNumber { get; set; }
Public Property ElementOrdinalNumber As Integer
    Get
    Set
public:
property int ElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentOrdinalNumber Property

SegmentOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionInfo ► SegmentOrdinalNumber
RDPCrystal EDI Library
Get/set the segment ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinalNumber { get; set; }
Public Property SegmentOrdinalNumber As Integer
    Get
    Set
public:
property int SegmentOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SubElementOrdinalNumber Property

SubElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionInfo ► SubElementOrdinalNumber
RDPCrystal EDI Library
Get/set the element composite element ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int SubElementOrdinalNumber { get; set; }
Public Property SubElementOrdinalNumber As Integer
    Get
    Set
public:
property int SubElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementDescriptionList Class

ElementDescriptionList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionList
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ElementDescriptionList
Public Class ElementDescriptionList
public ref class ElementDescriptionList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementDescriptionList()()()() | Creates a new ElementCodeList
 | Descriptions | Descriptions that element can have
 | ElementNumber | Get/Set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementDescriptionList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementDescriptionList Constructor

ElementDescriptionList Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionList ► ElementDescriptionList()()()()
RDPCrystal EDI Library
Creates a new ElementCodeList
Declaration Syntax
C# Visual Basic Visual C++
public ElementDescriptionList()
Public Sub New
public:
ElementDescriptionList()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Descriptions Property

Descriptions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionList ► Descriptions
RDPCrystal EDI Library
Descriptions that element can have
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<Tuple<int, int, int>, ElementDescriptionInfo> Descriptions { get; set; }
Public Property Descriptions As Dictionary(Of Tuple(Of Integer, Integer, Integer), ElementDescriptionInfo)
    Get
    Set
public:
property Dictionary<Tuple<int, int, int>^, ElementDescriptionInfo^>^ Descriptions {
    Dictionary<Tuple<int, int, int>^, ElementDescriptionInfo^>^ get ();
    void set (Dictionary<Tuple<int, int, int>^, ElementDescriptionInfo^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDescriptionList ► ElementNumber
RDPCrystal EDI Library
Get/Set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementEqualityDisplay Class

ElementEqualityDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay
RDPCrystal EDI Library
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class ElementEqualityDisplay
Public Class ElementEqualityDisplay
public ref class ElementEqualityDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementEqualityDisplay(String, String) | Initializes a new instance of the ElementEqualityDisplay class.
 | Element | Gets or sets the element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementEqualityDisplay

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementEqualityDisplay Constructor (element, rule)

ElementEqualityDisplay Constructor (element, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay ► ElementEqualityDisplay(String, String)
RDPCrystal EDI Library
Initializes a new instance of the ElementEqualityDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public ElementEqualityDisplay(
    string element,
    string rule
)
Public Sub New ( _
    element As String, _
    rule As String _
)
public:
ElementEqualityDisplay(
    String^ element,
    String^ rule
)
Parameters
element (String)
The element.
rule (String)
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Element Property

Element Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay ► Element
RDPCrystal EDI Library
Gets or sets the element.
Declaration Syntax
C# Visual Basic Visual C++
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
Value
The element.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay ► Rule
RDPCrystal EDI Library
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementExclusionConstraint Class

ElementExclusionConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementExclusionConstraint
RDPCrystal EDI Library
Object that holds a exclusiong constraint for a segment
Declaration Syntax
C# Visual Basic Visual C++
public class ElementExclusionConstraint : ElementPairConstraint
Public Class ElementExclusionConstraint _
    Inherits ElementPairConstraint
public ref class ElementExclusionConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementExclusionConstraint()()()() | Initializes a new instance of the ElementExclusionConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementExclusionConstraint

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementExclusionConstraint Constructor

ElementExclusionConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementExclusionConstraint ► ElementExclusionConstraint()()()()
RDPCrystal EDI Library
Initializes a new instance of the ElementExclusionConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementExclusionConstraint()
Public Sub New
public:
ElementExclusionConstraint()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormat Class

ElementFormat Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat
RDPCrystal EDI Library
Used when creating EDI Rules rules
Declaration Syntax
C# Visual Basic Visual C++
public class ElementFormat
Public Class ElementFormat
public ref class ElementFormat
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementFormat()()()() | Create a new ElementFormat object
 | ElementFormat(Int32, String) | Create a new ElementFormat object
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatCollection | Collection of regular expression formats that data element's value may be compared against
 | GetElementFormats(Char) | Retreives a list of the element formats
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PivotElementOrdinal | Element ordinal that formats must be applied to
 | PivotElementValue | Value that a DataElement must have before formats can be applied
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFormat

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormat Constructor

ElementFormat Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► ElementFormat()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ElementFormat()()()() | Create a new ElementFormat object
 | ElementFormat(Int32, String) | Create a new ElementFormat object

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormat Constructor

ElementFormat Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► ElementFormat()()()()
RDPCrystal EDI Library
Create a new ElementFormat object
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormat()
Public Sub New
public:
ElementFormat()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormat Constructor (pivotElementOridinal, pivotElementValue)

ElementFormat Constructor (pivotElementOridinal, pivotElementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► ElementFormat(Int32, String)
RDPCrystal EDI Library
Create a new ElementFormat object
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormat(
    int pivotElementOridinal,
    string pivotElementValue
)
Public Sub New ( _
    pivotElementOridinal As Integer, _
    pivotElementValue As String _
)
public:
ElementFormat(
    int pivotElementOridinal,
    String^ pivotElementValue
)
Parameters
pivotElementOridinal (Int32)
Element ordinal that formats must be applied to
pivotElementValue (String)
Value that a DataElement must have before formats can be checked

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FormatCollection Property

FormatCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► FormatCollection
RDPCrystal EDI Library
Collection of regular expression formats that data element's value may be compared against
Declaration Syntax
C# Visual Basic Visual C++
public Collection<Format> FormatCollection { get; set; }
Public Property FormatCollection As Collection(Of Format)
    Get
    Set
public:
property Collection<Format^>^ FormatCollection {
    Collection<Format^>^ get ();
    void set (Collection<Format^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetElementFormats Method (separator)

GetElementFormats Method (separator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► GetElementFormats(Char)
RDPCrystal EDI Library
Retreives a list of the element formats
Declaration Syntax
C# Visual Basic Visual C++
public string GetElementFormats(
    char separator
)
Public Function GetElementFormats ( _
    separator As Char _
) As String
public:
String^ GetElementFormats(
    wchar_t separator
)
Parameters
separator (Char)
delimiter between format names
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PivotElementOrdinal Property

PivotElementOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► PivotElementOrdinal
RDPCrystal EDI Library
Element ordinal that formats must be applied to
Declaration Syntax
C# Visual Basic Visual C++
public int PivotElementOrdinal { get; set; }
Public Property PivotElementOrdinal As Integer
    Get
    Set
public:
property int PivotElementOrdinal {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PivotElementValue Property

PivotElementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► PivotElementValue
RDPCrystal EDI Library
Value that a DataElement must have before formats can be applied
Declaration Syntax
C# Visual Basic Visual C++
public string PivotElementValue { get; set; }
Public Property PivotElementValue As String
    Get
    Set
public:
property String^ PivotElementValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormatInfo Class

ElementFormatInfo Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo
RDPCrystal EDI Library
Represents format information for an Element
Declaration Syntax
C# Visual Basic Visual C++
public class ElementFormatInfo
Public Class ElementFormatInfo
public ref class ElementFormatInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementFormatInfo()()()() | Create a new ElementFormatInfo
 | ElementFormat | Get/Set the format for the element
 | ElementOrdinalNumber | Get/Set the element number that the format will apply to
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentOrdinalNumber | Get/Set the segment number that the format will apply to
 | SubElementOrdinalNumber | Get/Set the composite element number that the format will apply to
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFormatInfo

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormatInfo Constructor

ElementFormatInfo Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► ElementFormatInfo()()()()
RDPCrystal EDI Library
Create a new ElementFormatInfo
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormatInfo()
Public Sub New
public:
ElementFormatInfo()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormat Property

ElementFormat Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► ElementFormat
RDPCrystal EDI Library
Get/Set the format for the element
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormat ElementFormat { get; set; }
Public Property ElementFormat As ElementFormat
    Get
    Set
public:
property ElementFormat^ ElementFormat {
    ElementFormat^ get ();
    void set (ElementFormat^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinalNumber Property

ElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► ElementOrdinalNumber
RDPCrystal EDI Library
Get/Set the element number that the format will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalNumber { get; set; }
Public Property ElementOrdinalNumber As Integer
    Get
    Set
public:
property int ElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentOrdinalNumber Property

SegmentOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► SegmentOrdinalNumber
RDPCrystal EDI Library
Get/Set the segment number that the format will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinalNumber { get; set; }
Public Property SegmentOrdinalNumber As Integer
    Get
    Set
public:
property int SegmentOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SubElementOrdinalNumber Property

SubElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► SubElementOrdinalNumber
RDPCrystal EDI Library
Get/Set the composite element number that the format will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int SubElementOrdinalNumber { get; set; }
Public Property SubElementOrdinalNumber As Integer
    Get
    Set
public:
property int SubElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormatting Class

ElementFormatting Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting
RDPCrystal EDI Library
Used by EDI Rules Reader for element formatting
Declaration Syntax
C# Visual Basic Visual C++
public class ElementFormatting
Public Class ElementFormatting
public ref class ElementFormatting
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementFormatting()()()() | Create a new ElementFormatting
 | ElementFormatInfos | Get/set collection of formatting information
 | ElementNumber | Get/Set the element number that the formatting will apply to
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFormatting

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormatting Constructor

ElementFormatting Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting ► ElementFormatting()()()()
RDPCrystal EDI Library
Create a new ElementFormatting
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormatting()
Public Sub New
public:
ElementFormatting()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementFormatInfos Property

ElementFormatInfos Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting ► ElementFormatInfos
RDPCrystal EDI Library
Get/set collection of formatting information
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementFormatInfo> ElementFormatInfos { get; set; }
Public Property ElementFormatInfos As Collection(Of ElementFormatInfo)
    Get
    Set
public:
property Collection<ElementFormatInfo^>^ ElementFormatInfos {
    Collection<ElementFormatInfo^>^ get ();
    void set (Collection<ElementFormatInfo^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting ► ElementNumber
RDPCrystal EDI Library
Get/Set the element number that the formatting will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementListConditionalConstraint Class

ElementListConditionalConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementListConditionalConstraint
RDPCrystal EDI Library
Represents a list conditional contraints
Declaration Syntax
C# Visual Basic Visual C++
public class ElementListConditionalConstraint : ElementPairConstraint
Public Class ElementListConditionalConstraint _
    Inherits ElementPairConstraint
public ref class ElementListConditionalConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementListConditionalConstraint()()()() | Initializes a new instance of the ElementListConditionalConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementListConditionalConstraint

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementListConditionalConstraint Constructor

ElementListConditionalConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementListConditionalConstraint ► ElementListConditionalConstraint()()()()
RDPCrystal EDI Library
Initializes a new instance of the ElementListConditionalConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementListConditionalConstraint()
Public Sub New
public:
ElementListConditionalConstraint()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPairConstraint Class

ElementPairConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint
RDPCrystal EDI Library
Represents a element pair relationship
Declaration Syntax
C# Visual Basic Visual C++
public class ElementPairConstraint
Public Class ElementPairConstraint
public ref class ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementPairConstraint()()()() | Create a new ElementPairConstraint object
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementConditionalConstraint
 |  | ElementExclusionConstraint
 |  | ElementListConditionalConstraint
 |  | ElementRequiredConstraint

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPairConstraint Constructor

ElementPairConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► ElementPairConstraint()()()()
RDPCrystal EDI Library
Create a new ElementPairConstraint object
Declaration Syntax
C# Visual Basic Visual C++
public ElementPairConstraint()
Public Sub New
public:
ElementPairConstraint()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinals Property

ElementOrdinals Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► ElementOrdinals
RDPCrystal EDI Library
Get/set a list of element ordinals involved in the contraint
Declaration Syntax
C# Visual Basic Visual C++
public Collection<int> ElementOrdinals { get; set; }
Public Property ElementOrdinals As Collection(Of Integer)
    Get
    Set
public:
property Collection<int>^ ElementOrdinals {
    Collection<int>^ get ();
    void set (Collection<int>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► GetElementOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► GetElementOrdinalsString()()()()
RDPCrystal EDI Library
Get a list of the element ordinals involved in the contraint as a space delimited list
Declaration Syntax
C# Visual Basic Visual C++
public string GetElementOrdinalsString()
Public Function GetElementOrdinalsString As String
public:
String^ GetElementOrdinalsString()
Return Value
space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method (start)

GetElementOrdinalsString Method (start)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► GetElementOrdinalsString(Int32)
RDPCrystal EDI Library
Get a list of the element ordinals involved in the contraint as a space delimited list
Declaration Syntax
C# Visual Basic Visual C++
public string GetElementOrdinalsString(
    int start
)
Public Function GetElementOrdinalsString ( _
    start As Integer _
) As String
public:
String^ GetElementOrdinalsString(
    int start
)
Parameters
start (Int32)
start position in the collection
Return Value
space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPosition Class

ElementPosition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition
RDPCrystal EDI Library
Represents the position of an element with the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public class ElementPosition
Public Class ElementPosition
public ref class ElementPosition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementPosition()()()() | Creates a new Element Position
 | ElementPosition(Int32, Int32, Int32) | Creates a new Element Position
 | CompositeElementPosition | Get/set composite element position
 | ElementOrdinalPosition | Get/set element ordinal position
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCompositeElementPosition()()()() | Checks if this is a composite element position
 | IsElementPosition()()()() | Checks if this is an element position
 | IsSegmentPosition()()()() | Checks if this is a segment position
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentOridinalPosition | Get/set the segment ordinal position
 | ToString()()()() | Returns a string representation of this object (Overrides Object.ToString()()()().)
 | ToSummaryKey()()()() |
Inheritance Hierarchy
Object
ElementPosition

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPosition Constructor

ElementPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementPosition()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ElementPosition()()()() | Creates a new Element Position
 | ElementPosition(Int32, Int32, Int32) | Creates a new Element Position

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPosition Constructor

ElementPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementPosition()()()()
RDPCrystal EDI Library
Creates a new Element Position
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition()
Public Sub New
public:
ElementPosition()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPosition Constructor (segmentOridinalPosition, elementOrdinalPosition, compositeElementPosition)

ElementPosition Constructor (segmentOridinalPosition, elementOrdinalPosition, compositeElementPosition)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementPosition(Int32, Int32, Int32)
RDPCrystal EDI Library
Creates a new Element Position
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition(
    int segmentOridinalPosition,
    int elementOrdinalPosition,
    int compositeElementPosition
)
Public Sub New ( _
    segmentOridinalPosition As Integer, _
    elementOrdinalPosition As Integer, _
    compositeElementPosition As Integer _
)
public:
ElementPosition(
    int segmentOridinalPosition,
    int elementOrdinalPosition,
    int compositeElementPosition
)
Parameters
segmentOridinalPosition (Int32)
segment ordinal position
elementOrdinalPosition (Int32)
element ordinal position
compositeElementPosition (Int32)
composite ordinal position

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementPosition Property

CompositeElementPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► CompositeElementPosition
RDPCrystal EDI Library
Get/set composite element position
Declaration Syntax
C# Visual Basic Visual C++
public int CompositeElementPosition { get; set; }
Public Property CompositeElementPosition As Integer
    Get
    Set
public:
property int CompositeElementPosition {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinalPosition Property

ElementOrdinalPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementOrdinalPosition
RDPCrystal EDI Library
Get/set element ordinal position
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalPosition { get; set; }
Public Property ElementOrdinalPosition As Integer
    Get
    Set
public:
property int ElementOrdinalPosition {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsCompositeElementPosition Method

IsCompositeElementPosition Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► IsCompositeElementPosition()()()()
RDPCrystal EDI Library
Checks if this is a composite element position
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCompositeElementPosition()
Public Function IsCompositeElementPosition As Boolean
public:
bool IsCompositeElementPosition()
Return Value
true if a composite element, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsElementPosition Method

IsElementPosition Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► IsElementPosition()()()()
RDPCrystal EDI Library
Checks if this is an element position
Declaration Syntax
C# Visual Basic Visual C++
public bool IsElementPosition()
Public Function IsElementPosition As Boolean
public:
bool IsElementPosition()
Return Value
true if a element position, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsSegmentPosition Method

IsSegmentPosition Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► IsSegmentPosition()()()()
RDPCrystal EDI Library
Checks if this is a segment position
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentPosition()
Public Function IsSegmentPosition As Boolean
public:
bool IsSegmentPosition()
Return Value
true if a segment position, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentOridinalPosition Property

SegmentOridinalPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► SegmentOridinalPosition
RDPCrystal EDI Library
Get/set the segment ordinal position
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOridinalPosition { get; set; }
Public Property SegmentOridinalPosition As Integer
    Get
    Set
public:
property int SegmentOridinalPosition {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ToString()()()()
RDPCrystal EDI Library
Returns a string representation of this object
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this object

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToSummaryKey Method

ToSummaryKey Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ToSummaryKey()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToSummaryKey()
Public Function ToSummaryKey As String
public:
String^ ToSummaryKey()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementRequiredConstraint Class

ElementRequiredConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementRequiredConstraint
RDPCrystal EDI Library
Represents a required constraint for a segment
Declaration Syntax
C# Visual Basic Visual C++
public class ElementRequiredConstraint : ElementPairConstraint
Public Class ElementRequiredConstraint _
    Inherits ElementPairConstraint
public ref class ElementRequiredConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementRequiredConstraint()()()() | Initializes a new instance of the ElementRequiredConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementRequiredConstraint

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementRequiredConstraint Constructor

ElementRequiredConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementRequiredConstraint ► ElementRequiredConstraint()()()()
RDPCrystal EDI Library
Initializes a new instance of the ElementRequiredConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementRequiredConstraint()
Public Sub New
public:
ElementRequiredConstraint()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementSchema Class

ElementSchema Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema
RDPCrystal EDI Library
Represents an element schema used by EDI Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ElementSchema
<SerializableAttribute> _
Public Class ElementSchema
[SerializableAttribute]
public ref class ElementSchema
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementSchema()()()() | Creates a new ElementSchema
 | ElementSchema(Int32, Usage) | Creates a new ElementSchema
 | ElementSchema(Int32) | Creates a new ElementSchema
 | Composite | Get/set whether this is a composite element
 | CompositeElement | Get/set the composite element
 | ElementNumber | Get/set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usage | Get/set the usage of this element
Inheritance Hierarchy
Object
ElementSchema

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementSchema Constructor

ElementSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ElementSchema()()()() | Creates a new ElementSchema
 | ElementSchema(Int32, Usage) | Creates a new ElementSchema
 | ElementSchema(Int32) | Creates a new ElementSchema

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementSchema Constructor

ElementSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema()()()()
RDPCrystal EDI Library
Creates a new ElementSchema
Declaration Syntax
C# Visual Basic Visual C++
public ElementSchema()
Public Sub New
public:
ElementSchema()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementSchema Constructor (elementNumber)

ElementSchema Constructor (elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema(Int32)
RDPCrystal EDI Library
Creates a new ElementSchema
Declaration Syntax
C# Visual Basic Visual C++
public ElementSchema(
    int elementNumber
)
Public Sub New ( _
    elementNumber As Integer _
)
public:
ElementSchema(
    int elementNumber
)
Parameters
elementNumber (Int32)
element number

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementSchema Constructor (elementNumber, usage)

ElementSchema Constructor (elementNumber, usage)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema(Int32, Usage)
RDPCrystal EDI Library
Creates a new ElementSchema
Declaration Syntax
C# Visual Basic Visual C++
public ElementSchema(
    int elementNumber,
    Usage usage
)
Public Sub New ( _
    elementNumber As Integer, _
    usage As Usage _
)
public:
ElementSchema(
    int elementNumber,
    Usage usage
)
Parameters
elementNumber (Int32)
element number
usage (Usage)
usage for element

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Composite Property

Composite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► Composite
RDPCrystal EDI Library
Get/set whether this is a composite element
Declaration Syntax
C# Visual Basic Visual C++
public bool Composite { get; set; }
Public Property Composite As Boolean
    Get
    Set
public:
property bool Composite {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElement Property

CompositeElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► CompositeElement
RDPCrystal EDI Library
Get/set the composite element
Declaration Syntax
C# Visual Basic Visual C++
public Segment CompositeElement { get; set; }
Public Property CompositeElement As Segment
    Get
    Set
public:
property Segment^ CompositeElement {
    Segment^ get ();
    void set (Segment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementNumber
RDPCrystal EDI Library
Get/set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► Usage
RDPCrystal EDI Library
Get/set the usage of this element
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementUniqueValueInfo Class

ElementUniqueValueInfo Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValueInfo
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ElementUniqueValueInfo
Public Class ElementUniqueValueInfo
public ref class ElementUniqueValueInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementUniqueValueInfo()()()() | Initializes a new instance of the ElementUniqueValueInfo class
 | ElementOrdinalNumber |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentOrdinalNumber |
 | SubElementOrdinalNumber |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementUniqueValueInfo

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementUniqueValueInfo Constructor

ElementUniqueValueInfo Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValueInfo ► ElementUniqueValueInfo()()()()
RDPCrystal EDI Library
Initializes a new instance of the ElementUniqueValueInfo class
Declaration Syntax
C# Visual Basic Visual C++
public ElementUniqueValueInfo()
Public Sub New
public:
ElementUniqueValueInfo()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinalNumber Property

ElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValueInfo ► ElementOrdinalNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalNumber { get; set; }
Public Property ElementOrdinalNumber As Integer
    Get
    Set
public:
property int ElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentOrdinalNumber Property

SegmentOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValueInfo ► SegmentOrdinalNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinalNumber { get; set; }
Public Property SegmentOrdinalNumber As Integer
    Get
    Set
public:
property int SegmentOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SubElementOrdinalNumber Property

SubElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValueInfo ► SubElementOrdinalNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int SubElementOrdinalNumber { get; set; }
Public Property SubElementOrdinalNumber As Integer
    Get
    Set
public:
property int SubElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementUniqueValues Class

ElementUniqueValues Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValues
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ElementUniqueValues
Public Class ElementUniqueValues
public ref class ElementUniqueValues
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementUniqueValues()()()() | Initializes a new instance of the ElementUniqueValues class
 | ElementNumber |
 | ElementUniqueValueInfo |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementUniqueValues

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementUniqueValues Constructor

ElementUniqueValues Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValues ► ElementUniqueValues()()()()
RDPCrystal EDI Library
Initializes a new instance of the ElementUniqueValues class
Declaration Syntax
C# Visual Basic Visual C++
public ElementUniqueValues()
Public Sub New
public:
ElementUniqueValues()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValues ► ElementNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementUniqueValueInfo Property

ElementUniqueValueInfo Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementUniqueValues ► ElementUniqueValueInfo
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementUniqueValueInfo> ElementUniqueValueInfo { get; set; }
Public Property ElementUniqueValueInfo As Collection(Of ElementUniqueValueInfo)
    Get
    Set
public:
property Collection<ElementUniqueValueInfo^>^ ElementUniqueValueInfo {
    Collection<ElementUniqueValueInfo^>^ get ();
    void set (Collection<ElementUniqueValueInfo^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementValueInfo Class

ElementValueInfo Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo
RDPCrystal EDI Library
Represents an element and its possible values at a specific location
Declaration Syntax
C# Visual Basic Visual C++
public class ElementValueInfo
Public Class ElementValueInfo
public ref class ElementValueInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementValueInfo()()()() | Creates a new ElementValueInfo
 | CodeList |
 | CodeListName | For EDI Rules Reader
 | ElementOrdinalNumber | Get/set the element ordinal number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPossibleValues()()()() | Gets the possible value for an element at this specific location separated by a space character
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PossibleValues | Gets the possible value for an element at this specific location
 | SegmentOrdinalNumber | Get/set the segment ordinal number
 | SubElementOrdinalNumber | Get/set the element composite element ordinal number
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementValueInfo

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementValueInfo Constructor

ElementValueInfo Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► ElementValueInfo()()()()
RDPCrystal EDI Library
Creates a new ElementValueInfo
Declaration Syntax
C# Visual Basic Visual C++
public ElementValueInfo()
Public Sub New
public:
ElementValueInfo()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeList Property

CodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► CodeList
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public CodeList CodeList { get; set; }
Public Property CodeList As CodeList
    Get
    Set
public:
property CodeList^ CodeList {
    CodeList^ get ();
    void set (CodeList^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeListName Property

CodeListName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► CodeListName
RDPCrystal EDI Library
For EDI Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListName { get; set; }
Public Property CodeListName As String
    Get
    Set
public:
property String^ CodeListName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementOrdinalNumber Property

ElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► ElementOrdinalNumber
RDPCrystal EDI Library
Get/set the element ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalNumber { get; set; }
Public Property ElementOrdinalNumber As Integer
    Get
    Set
public:
property int ElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetPossibleValues Method

GetPossibleValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► GetPossibleValues()()()()
RDPCrystal EDI Library
Gets the possible value for an element at this specific location separated by a space character
Declaration Syntax
C# Visual Basic Visual C++
public string GetPossibleValues()
Public Function GetPossibleValues As String
public:
String^ GetPossibleValues()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PossibleValues Property

PossibleValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► PossibleValues
RDPCrystal EDI Library
Gets the possible value for an element at this specific location
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> PossibleValues { get; }
Public ReadOnly Property PossibleValues As HashSet(Of String)
    Get
public:
property HashSet<String^>^ PossibleValues {
    HashSet<String^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentOrdinalNumber Property

SegmentOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► SegmentOrdinalNumber
RDPCrystal EDI Library
Get/set the segment ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinalNumber { get; set; }
Public Property SegmentOrdinalNumber As Integer
    Get
    Set
public:
property int SegmentOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SubElementOrdinalNumber Property

SubElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► SubElementOrdinalNumber
RDPCrystal EDI Library
Get/set the element composite element ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int SubElementOrdinalNumber { get; set; }
Public Property SubElementOrdinalNumber As Integer
    Get
    Set
public:
property int SubElementOrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ExtCodeList Class

ExtCodeList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ExtCodeList
RDPCrystal EDI Library
Contains all the external code lists
Declaration Syntax
C# Visual Basic Visual C++
public static class ExtCodeList
Public NotInheritable Class ExtCodeList
public ref class ExtCodeList abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ContainsList(String) |
 | ContainsListAndValue(String, String) |
 | ExternalCodeLists |
Inheritance Hierarchy
Object
ExtCodeList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsList Method (name)

ContainsList Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ExtCodeList ► ContainsList(String)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static bool ContainsList(
    string name
)
Public Shared Function ContainsList ( _
    name As String _
) As Boolean
public:
static bool ContainsList(
    String^ name
)
Parameters
name (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsListAndValue Method (name, value)

ContainsListAndValue Method (name, value)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ExtCodeList ► ContainsListAndValue(String, String)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static bool ContainsListAndValue(
    string name,
    string value
)
Public Shared Function ContainsListAndValue ( _
    name As String, _
    value As String _
) As Boolean
public:
static bool ContainsListAndValue(
    String^ name,
    String^ value
)
Parameters
name (String)
value (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ExternalCodeLists Field

ExternalCodeLists Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ExtCodeList ► ExternalCodeLists
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static Dictionary<string, CodeList> ExternalCodeLists
Public Shared ExternalCodeLists As Dictionary(Of String, CodeList)
public:
static Dictionary<String^, CodeList^>^ ExternalCodeLists

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileJoinLevel Enumeration

FileJoinLevel Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileJoinLevel
RDPCrystal EDI Library
Enum to specify where file joining should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileJoiner
Declaration Syntax
C# Visual Basic Visual C++
public enum FileJoinLevel
Public Enumeration FileJoinLevel
public enum class FileJoinLevel
Members
Member | Description
FUNCTIONALGROUP | Join file on functional group level
HEADER | Join file on the header level

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileLoadingEventArgs Class

FileLoadingEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingEventArgs
RDPCrystal EDI Library
Represents data pertaining to the time it took to load an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public class FileLoadingEventArgs
Public Class FileLoadingEventArgs
public ref class FileLoadingEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Milliseconds | Get the amount of time passed in milliseconds for the validation process
 | NumberOfSegmentsLoaded | Number of segments loaded
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileLoadingEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Milliseconds Property

Milliseconds Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingEventArgs ► Milliseconds
RDPCrystal EDI Library
Get the amount of time passed in milliseconds for the validation process
Declaration Syntax
C# Visual Basic Visual C++
public double Milliseconds { get; }
Public ReadOnly Property Milliseconds As Double
    Get
public:
property double Milliseconds {
    double get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberOfSegmentsLoaded Property

NumberOfSegmentsLoaded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingEventArgs ► NumberOfSegmentsLoaded
RDPCrystal EDI Library
Number of segments loaded
Declaration Syntax
C# Visual Basic Visual C++
public long NumberOfSegmentsLoaded { get; }
Public ReadOnly Property NumberOfSegmentsLoaded As Long
    Get
public:
property long long NumberOfSegmentsLoaded {
    long long get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileLoadingException Class

FileLoadingException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingException
RDPCrystal EDI Library
An exception that represents an errors that occur while loading an EDI file with the EDIFileLoader component
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileLoadingException : Exception
<SerializableAttribute> _
Public Class FileLoadingException _
    Inherits Exception
[SerializableAttribute]
public ref class FileLoadingException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | FileLoadingException

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileOperationCompletedEventArgs Class

FileOperationCompletedEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs
RDPCrystal EDI Library
FileOperationCompletedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class FileOperationCompletedEventArgs : EventArgs
Public Class FileOperationCompletedEventArgs _
    Inherits EventArgs
public ref class FileOperationCompletedEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception | Gets or sets the exception.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SplitStrings | List of split strings
 | State | Gets or sets the state.
 | Status | Gets or sets the status.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FileOperationCompletedEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Exception Property

Exception Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► Exception
RDPCrystal EDI Library
Gets or sets the exception.
Declaration Syntax
C# Visual Basic Visual C++
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
Value
The exception.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SplitStrings Property

SplitStrings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► SplitStrings
RDPCrystal EDI Library
List of split strings
Declaration Syntax
C# Visual Basic Visual C++
public List<string> SplitStrings { get; set; }
Public Property SplitStrings As List(Of String)
    Get
    Set
public:
property List<String^>^ SplitStrings {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


State Property

State Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► State
RDPCrystal EDI Library
Gets or sets the state.
Declaration Syntax
C# Visual Basic Visual C++
public Object State { get; set; }
Public Property State As Object
    Get
    Set
public:
property Object^ State {
    Object^ get ();
    void set (Object^ value);
}
Value
The state.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Status Property

Status Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► Status
RDPCrystal EDI Library
Gets or sets the status.
Declaration Syntax
C# Visual Basic Visual C++
public FileOperationStatus Status { get; set; }
Public Property Status As FileOperationStatus
    Get
    Set
public:
property FileOperationStatus Status {
    FileOperationStatus get ();
    void set (FileOperationStatus value);
}
Value
The status.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileOperationStatus Enumeration

FileOperationStatus Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationStatus
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public enum FileOperationStatus
Public Enumeration FileOperationStatus
public enum class FileOperationStatus
Members
Member | Description
NotSet |
Success |
Failure |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileSplitLevel Enumeration

FileSplitLevel Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileSplitLevel
RDPCrystal EDI Library
Enum to specify where file splitting should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileSplitter
Declaration Syntax
C# Visual Basic Visual C++
public enum FileSplitLevel
Public Enumeration FileSplitLevel
public enum class FileSplitLevel
Members
Member | Description
FUNCTIONALGROUP | Split file on functional group level
HEADER | Split file on the header level
ENVELOPE | Split file on the envelope level

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileType Enumeration

FileType Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileType
RDPCrystal EDI Library
EDI File Type
Declaration Syntax
C# Visual Basic Visual C++
public enum FileType
Public Enumeration FileType
public enum class FileType
Members
Member | Description
X12 |
EDIFACT |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Format Class

Format Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format
RDPCrystal EDI Library
Represents a regular expression format that a data element's value must conform to
Declaration Syntax
C# Visual Basic Visual C++
public class Format
Public Class Format
public ref class Format
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Format()()()() | Creates a new format pattern
 | Format(String, String) | Create a new format with a name and pattern
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of the pattern
 | Pattern | Regular Expression pattern
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Format

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Format Constructor

Format Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Format()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Format()()()() | Creates a new format pattern
 | Format(String, String) | Create a new format with a name and pattern

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Format Constructor

Format Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Format()()()()
RDPCrystal EDI Library
Creates a new format pattern
Declaration Syntax
C# Visual Basic Visual C++
public Format()
Public Sub New
public:
Format()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Format Constructor (name, pattern)

Format Constructor (name, pattern)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Format(String, String)
RDPCrystal EDI Library
Create a new format with a name and pattern
Declaration Syntax
C# Visual Basic Visual C++
public Format(
    string name,
    string pattern
)
Public Sub New ( _
    name As String, _
    pattern As String _
)
public:
Format(
    String^ name,
    String^ pattern
)
Parameters
name (String)
name of pattern
pattern (String)
regular expression pattern

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Name
RDPCrystal EDI Library
Name of the pattern
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Pattern Property

Pattern Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Pattern
RDPCrystal EDI Library
Regular Expression pattern
Declaration Syntax
C# Visual Basic Visual C++
public string Pattern { get; set; }
Public Property Pattern As String
    Get
    Set
public:
property String^ Pattern {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FoundSegmentCollection Class

FoundSegmentCollection Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class FoundSegmentCollection : Collection<LightWeightSegment>
Public Class FoundSegmentCollection _
    Inherits Collection(Of LightWeightSegment)
public ref class FoundSegmentCollection : public Collection<LightWeightSegment^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FoundSegmentCollection()()()() | Initializes a new instance of the FoundSegmentCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastDataSegment()()()() |
 | GetLastOccurrence(Int32) |
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | RemoveHLSegment(Int32) |
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | RemoveSegment(Int32) |
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection<(Of <(<' LightWeightSegment >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection<(Of <(<' LightWeightSegment >)>)>
 |  | FoundSegmentCollection

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FoundSegmentCollection Constructor

FoundSegmentCollection Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► FoundSegmentCollection()()()()
RDPCrystal EDI Library
Initializes a new instance of the FoundSegmentCollection class
Declaration Syntax
C# Visual Basic Visual C++
public FoundSegmentCollection()
Public Sub New
public:
FoundSegmentCollection()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLastDataSegment Method

GetLastDataSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► GetLastDataSegment()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GetLastDataSegment()
Public Function GetLastDataSegment As LightWeightSegment
public:
LightWeightSegment^ GetLastDataSegment()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLastOccurrence Method (segmentOrdinalNumber)

GetLastOccurrence Method (segmentOrdinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► GetLastOccurrence(Int32)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GetLastOccurrence(
    int segmentOrdinalNumber
)
Public Function GetLastOccurrence ( _
    segmentOrdinalNumber As Integer _
) As LightWeightSegment
public:
LightWeightSegment^ GetLastOccurrence(
    int segmentOrdinalNumber
)
Parameters
segmentOrdinalNumber (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RemoveHLSegment Method (segmentOrdinalNumber)

RemoveHLSegment Method (segmentOrdinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► RemoveHLSegment(Int32)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveHLSegment(
    int segmentOrdinalNumber
)
Public Sub RemoveHLSegment ( _
    segmentOrdinalNumber As Integer _
)
public:
void RemoveHLSegment(
    int segmentOrdinalNumber
)
Parameters
segmentOrdinalNumber (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RemoveSegment Method (segmentOrdinalNumber)

RemoveSegment Method (segmentOrdinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► RemoveSegment(Int32)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveSegment(
    int segmentOrdinalNumber
)
Public Sub RemoveSegment ( _
    segmentOrdinalNumber As Integer _
)
public:
void RemoveSegment(
    int segmentOrdinalNumber
)
Parameters
segmentOrdinalNumber (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralEvent Delegate

GeneralEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEvent
RDPCrystal EDI Library
General event delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GeneralEvent(
    Object sender
)
Public Delegate Sub GeneralEvent ( _
    sender As Object _
)
public delegate void GeneralEvent(
    Object^ sender
)
Parameters
sender (Object)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralEventArgs Class

GeneralEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralEventArgs : EventArgs
Public Class GeneralEventArgs _
    Inherits EventArgs
public ref class GeneralEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeneralEventArgs()()()() | Initializes a new instance of the GeneralEventArgs class.
 | GeneralEventArgs(Exception) | Initializes a new instance of the GeneralEventArgs class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception | Gets the exception.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | GeneralEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralEventArgs Constructor

GeneralEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► GeneralEventArgs()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GeneralEventArgs()()()() | Initializes a new instance of the GeneralEventArgs class.
 | GeneralEventArgs(Exception) | Initializes a new instance of the GeneralEventArgs class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralEventArgs Constructor

GeneralEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► GeneralEventArgs()()()()
RDPCrystal EDI Library
Initializes a new instance of the GeneralEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public GeneralEventArgs()
Public Sub New
public:
GeneralEventArgs()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralEventArgs Constructor (exception)

GeneralEventArgs Constructor (exception)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► GeneralEventArgs(Exception)
RDPCrystal EDI Library
Initializes a new instance of the GeneralEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public GeneralEventArgs(
    Exception exception
)
Public Sub New ( _
    exception As Exception _
)
public:
GeneralEventArgs(
    Exception^ exception
)
Parameters
exception (Exception)
The exception.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Exception Property

Exception Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► Exception
RDPCrystal EDI Library
Gets the exception.
Declaration Syntax
C# Visual Basic Visual C++
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralTypeConverter Class

GeneralTypeConverter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralTypeConverter : TypeConverter
Public Class GeneralTypeConverter _
    Inherits TypeConverter
public ref class GeneralTypeConverter : public TypeConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GeneralTypeConverter()()()() | Initializes a new instance of the GeneralTypeConverter class.
 | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
 | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
 | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
 | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
 | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)
 | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
 | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
 | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
 | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
 | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
 | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetConvertFromException(Object) | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
 | GetConvertToException(Object, Type) | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
 | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
 | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
 | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
 | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter.GetPropertiesSupported(ITypeDescriptorContext).)
 | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
 | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
 | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
 | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
 | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
 | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
 | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
 | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SortProperties(PropertyDescriptorCollection, array<String>[]()[][]) | Sorts a collection of properties. (Inherited from TypeConverter.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeConverter
 |  | GeneralTypeConverter

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralTypeConverter Constructor

GeneralTypeConverter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GeneralTypeConverter()()()()
RDPCrystal EDI Library
Initializes a new instance of the GeneralTypeConverter class.
Declaration Syntax
C# Visual Basic Visual C++
public GeneralTypeConverter()
Public Sub New
public:
GeneralTypeConverter()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CanConvertTo Method (context, destinationType)

CanConvertTo Method (context, destinationType)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CanConvertTo(ITypeDescriptorContext, Type)
RDPCrystal EDI Library
Returns whether this converter can convert the object to the specified type, using the specified context.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
destinationType (Type)
A Type that represents the type you want to convert to.
Return Value
true if this converter can perform the conversion; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ConvertTo Method (context, culture, value, destinationType)

ConvertTo Method (context, culture, value, destinationType)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)
RDPCrystal EDI Library
Converts the given value object to the specified type, using the specified context and culture information.
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
culture (CultureInfo)
A CultureInfo. If null is passed, the current culture is assumed.
value (Object)
The Object to convert.
destinationType (Type)
The Type to convert the value parameter to.
Return Value
An Object that represents the converted value.
Exceptions
Exception | Condition
ArgumentNullException | The destinationType parameter is null.
NotSupportedException | The conversion cannot be performed.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetProperties Method (context, value, attributes)

GetProperties Method (context, value, attributes)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][])
RDPCrystal EDI Library
Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
Declaration Syntax
C# Visual Basic Visual C++
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection
public:
virtual PropertyDescriptorCollection^ GetProperties(
    ITypeDescriptorContext^ context,
    Object^ value,
    array<Attribute^>^ attributes
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
value (Object)
An Object that specifies the type of array for which to get properties.
attributes (array<Attribute>[]()[][])
An array of type Attribute that is used as a filter.
Return Value
A PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetPropertiesSupported Method (context)

GetPropertiesSupported Method (context)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetPropertiesSupported(ITypeDescriptorContext)
RDPCrystal EDI Library
Returns whether this object supports properties, using the specified context.
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
public:
virtual bool GetPropertiesSupported(
    ITypeDescriptorContext^ context
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
Return Value
true if GetProperties(Object) should be called to find the properties of this object; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP Class

HTTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP
RDPCrystal EDI Library
HTTP component
Declaration Syntax
C# Visual Basic Visual C++
public sealed class HTTP : Component
Public NotInheritable Class HTTP _
    Inherits Component
public ref class HTTP sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HTTP()()()() | Initializes a new instance of the HTTP class.
 | HTTP(IContainer) | Initializes a new instance of the HTTP class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Command | Gets or sets the command.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | DownloadFile(String) | Download a file from an HTTP Server
 | DownloadFileAsync(String) | Download a file ansynchronously to from an HTTP Server
 | DownloadFileCompleted |
 | DownloadFileProgressChanged |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileUploadCompleted |
 | FileUploadProgressChanged |
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hostname | Gets or sets the hostname.
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Password | Gets or sets the password.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UploadFile(String) | Upload a file to an HTTP Server
 | UploadFileAsync(String) | Asynchronously upload a file to an HTTP Server
 | Username | Gets or sets the username.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | HTTP

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP Constructor

HTTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | HTTP()()()() | Initializes a new instance of the HTTP class.
 | HTTP(IContainer) | Initializes a new instance of the HTTP class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP Constructor

HTTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP()()()()
RDPCrystal EDI Library
Initializes a new instance of the HTTP class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTP()
Public Sub New
public:
HTTP()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP Constructor (container)

HTTP Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the HTTP class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTP(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
HTTP(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Command Property

Command Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Command
RDPCrystal EDI Library
Gets or sets the command.
Declaration Syntax
C# Visual Basic Visual C++
public string Command { get; set; }
Public Property Command As String
    Get
    Set
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}
Value
The command.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DownloadFile Method (downloadedFilePath)

DownloadFile Method (downloadedFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFile(String)
RDPCrystal EDI Library
Download a file from an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void DownloadFile(
    string downloadedFilePath
)
Public Sub DownloadFile ( _
    downloadedFilePath As String _
)
public:
void DownloadFile(
    String^ downloadedFilePath
)
Parameters
downloadedFilePath (String)
Full path and name of file to download

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DownloadFileAsync Method (downloadedFilePath)

DownloadFileAsync Method (downloadedFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFileAsync(String)
RDPCrystal EDI Library
Download a file ansynchronously to from an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void DownloadFileAsync(
    string downloadedFilePath
)
Public Sub DownloadFileAsync ( _
    downloadedFilePath As String _
)
public:
void DownloadFileAsync(
    String^ downloadedFilePath
)
Parameters
downloadedFilePath (String)
Full path and name of file to download

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DownloadFileCompleted Event

DownloadFileCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFileCompleted
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..DownloadFileCompletedDelegate DownloadFileCompleted
Public Event DownloadFileCompleted As HTTP..::..DownloadFileCompletedDelegate
public:
 event HTTP..::..DownloadFileCompletedDelegate^ DownloadFileCompleted {
    void add (HTTP..::..DownloadFileCompletedDelegate^ value);
    void remove (HTTP..::..DownloadFileCompletedDelegate^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DownloadFileProgressChanged Event

DownloadFileProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFileProgressChanged
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..DownloadFileProgressChangedDelegate DownloadFileProgressChanged
Public Event DownloadFileProgressChanged As HTTP..::..DownloadFileProgressChangedDelegate
public:
 event HTTP..::..DownloadFileProgressChangedDelegate^ DownloadFileProgressChanged {
    void add (HTTP..::..DownloadFileProgressChangedDelegate^ value);
    void remove (HTTP..::..DownloadFileProgressChangedDelegate^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileUploadCompleted Event

FileUploadCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► FileUploadCompleted
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..UploadFileCompletedDelegate FileUploadCompleted
Public Event FileUploadCompleted As HTTP..::..UploadFileCompletedDelegate
public:
 event HTTP..::..UploadFileCompletedDelegate^ FileUploadCompleted {
    void add (HTTP..::..UploadFileCompletedDelegate^ value);
    void remove (HTTP..::..UploadFileCompletedDelegate^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FileUploadProgressChanged Event

FileUploadProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► FileUploadProgressChanged
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..UploadFileProgressChangedDelegate FileUploadProgressChanged
Public Event FileUploadProgressChanged As HTTP..::..UploadFileProgressChangedDelegate
public:
 event HTTP..::..UploadFileProgressChangedDelegate^ FileUploadProgressChanged {
    void add (HTTP..::..UploadFileProgressChangedDelegate^ value);
    void remove (HTTP..::..UploadFileProgressChangedDelegate^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Hostname Property

Hostname Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Hostname
RDPCrystal EDI Library
Gets or sets the hostname.
Declaration Syntax
C# Visual Basic Visual C++
public string Hostname { get; set; }
Public Property Hostname As String
    Get
    Set
public:
property String^ Hostname {
    String^ get ();
    void set (String^ value);
}
Value
The hostname.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Password Property

Password Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Password
RDPCrystal EDI Library
Gets or sets the password.
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
Value
The password.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UploadFile Method (path)

UploadFile Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► UploadFile(String)
RDPCrystal EDI Library
Upload a file to an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void UploadFile(
    string path
)
Public Sub UploadFile ( _
    path As String _
)
public:
void UploadFile(
    String^ path
)
Parameters
path (String)
Full path and name of file to upload

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UploadFileAsync Method (path)

UploadFileAsync Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► UploadFileAsync(String)
RDPCrystal EDI Library
Asynchronously upload a file to an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void UploadFileAsync(
    string path
)
Public Sub UploadFileAsync ( _
    path As String _
)
public:
void UploadFileAsync(
    String^ path
)
Parameters
path (String)
Full path and name of file to upload

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Username Property

Username Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Username
RDPCrystal EDI Library
Gets or sets the username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; set; }
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
Value
The username.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP.DownloadFileCompletedDelegate Delegate

HTTP..::..DownloadFileCompletedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..DownloadFileCompletedDelegate
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DownloadFileCompletedDelegate(
    Object sender,
    AsyncCompletedEventArgs e
)
Public Delegate Sub DownloadFileCompletedDelegate ( _
    sender As Object, _
    e As AsyncCompletedEventArgs _
)
public delegate void DownloadFileCompletedDelegate(
    Object^ sender,
    AsyncCompletedEventArgs^ e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP.DownloadFileProgressChangedDelegate Delegate

HTTP..::..DownloadFileProgressChangedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..DownloadFileProgressChangedDelegate
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DownloadFileProgressChangedDelegate(
    Object sender,
    DownloadProgressChangedEventArgs e
)
Public Delegate Sub DownloadFileProgressChangedDelegate ( _
    sender As Object, _
    e As DownloadProgressChangedEventArgs _
)
public delegate void DownloadFileProgressChangedDelegate(
    Object^ sender,
    DownloadProgressChangedEventArgs^ e
)
Parameters
sender (Object)
e (DownloadProgressChangedEventArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP.UploadFileCompletedDelegate Delegate

HTTP..::..UploadFileCompletedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..UploadFileCompletedDelegate
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UploadFileCompletedDelegate(
    Object sender,
    UploadFileCompletedEventArgs e
)
Public Delegate Sub UploadFileCompletedDelegate ( _
    sender As Object, _
    e As UploadFileCompletedEventArgs _
)
public delegate void UploadFileCompletedDelegate(
    Object^ sender,
    UploadFileCompletedEventArgs^ e
)
Parameters
sender (Object)
e (UploadFileCompletedEventArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTP.UploadFileProgressChangedDelegate Delegate

HTTP..::..UploadFileProgressChangedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..UploadFileProgressChangedDelegate
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UploadFileProgressChangedDelegate(
    Object sender,
    UploadProgressChangedEventArgs e
)
Public Delegate Sub UploadFileProgressChangedDelegate ( _
    sender As Object, _
    e As UploadProgressChangedEventArgs _
)
public delegate void UploadFileProgressChangedDelegate(
    Object^ sender,
    UploadProgressChangedEventArgs^ e
)
Parameters
sender (Object)
e (UploadProgressChangedEventArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTPS Class

HTTPS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS
RDPCrystal EDI Library
HTTPS Component
Declaration Syntax
C# Visual Basic Visual C++
public sealed class HTTPS : Component
Public NotInheritable Class HTTPS _
    Inherits Component
public ref class HTTPS sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HTTPS()()()() | Initializes a new instance of the HTTPS class.
 | HTTPS(IContainer) | Initializes a new instance of the HTTPS class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CertificateValidation |
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | ContentType | Gets or sets the type of the content.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | DownloadFile(String) | Downloads the file.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets or sets the headers.
 | Hostname | Gets or sets the hostname.
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Password | Gets or sets the password.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UploadFile(String) | Uploads the file.
 | Username | Gets or sets the username.
 | X509CertificateFile | Gets or sets the X509 certificate file.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | HTTPS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTPS Constructor

HTTPS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | HTTPS()()()() | Initializes a new instance of the HTTPS class.
 | HTTPS(IContainer) | Initializes a new instance of the HTTPS class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTPS Constructor

HTTPS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS()()()()
RDPCrystal EDI Library
Initializes a new instance of the HTTPS class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTPS()
Public Sub New
public:
HTTPS()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTPS Constructor (container)

HTTPS Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the HTTPS class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTPS(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
HTTPS(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CertificateValidation Event

CertificateValidation Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► CertificateValidation
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public event HTTPS..::..CertificateValidationDelegate CertificateValidation
Public Event CertificateValidation As HTTPS..::..CertificateValidationDelegate
public:
 event HTTPS..::..CertificateValidationDelegate^ CertificateValidation {
    void add (HTTPS..::..CertificateValidationDelegate^ value);
    void remove (HTTPS..::..CertificateValidationDelegate^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContentType Property

ContentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► ContentType
RDPCrystal EDI Library
Gets or sets the type of the content.
Declaration Syntax
C# Visual Basic Visual C++
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}
Value
The type of the content.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DownloadFile Method (downloadedFilePath)

DownloadFile Method (downloadedFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► DownloadFile(String)
RDPCrystal EDI Library
Downloads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void DownloadFile(
    string downloadedFilePath
)
Public Sub DownloadFile ( _
    downloadedFilePath As String _
)
public:
void DownloadFile(
    String^ downloadedFilePath
)
Parameters
downloadedFilePath (String)
The downloaded file path.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Headers Property

Headers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Headers
RDPCrystal EDI Library
Gets or sets the headers.
Declaration Syntax
C# Visual Basic Visual C++
public WebHeaderCollection Headers { get; set; }
Public Property Headers As WebHeaderCollection
    Get
    Set
public:
property WebHeaderCollection^ Headers {
    WebHeaderCollection^ get ();
    void set (WebHeaderCollection^ value);
}
Value
The headers.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Hostname Property

Hostname Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Hostname
RDPCrystal EDI Library
Gets or sets the hostname.
Declaration Syntax
C# Visual Basic Visual C++
public string Hostname { get; set; }
Public Property Hostname As String
    Get
    Set
public:
property String^ Hostname {
    String^ get ();
    void set (String^ value);
}
Value
The hostname.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Password Property

Password Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Password
RDPCrystal EDI Library
Gets or sets the password.
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
Value
The password.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UploadFile Method (path)

UploadFile Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► UploadFile(String)
RDPCrystal EDI Library
Uploads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void UploadFile(
    string path
)
Public Sub UploadFile ( _
    path As String _
)
public:
void UploadFile(
    String^ path
)
Parameters
path (String)
The path.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Username Property

Username Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Username
RDPCrystal EDI Library
Gets or sets the username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; set; }
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
Value
The username.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


X509CertificateFile Property

X509CertificateFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► X509CertificateFile
RDPCrystal EDI Library
Gets or sets the X509 certificate file.
Declaration Syntax
C# Visual Basic Visual C++
public string X509CertificateFile { get; set; }
Public Property X509CertificateFile As String
    Get
    Set
public:
property String^ X509CertificateFile {
    String^ get ();
    void set (String^ value);
}
Value
The X509 certificate file.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HTTPS.CertificateValidationDelegate Delegate

HTTPS..::..CertificateValidationDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS..::..CertificateValidationDelegate
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CertificateValidationDelegate(
    Object sender,
    CertificationEventArgs e
)
Public Delegate Sub CertificateValidationDelegate ( _
    sender As Object, _
    e As CertificationEventArgs _
)
public delegate void CertificateValidationDelegate(
    Object^ sender,
    CertificationEventArgs^ e
)
Parameters
sender (Object)
e (CertificationEventArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LicenseException Class

LicenseException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LicenseException
RDPCrystal EDI Library
Exception thrown when a license is invalid
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LicenseException : Exception
<SerializableAttribute> _
Public Class LicenseException _
    Inherits Exception
[SerializableAttribute]
public ref class LicenseException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | LicenseException

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightElement Class

LightWeightElement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement
RDPCrystal EDI Library
Represents a lightweight data element
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightElement
<SerializableAttribute> _
Public Class LightWeightElement
[SerializableAttribute]
public ref class LightWeightElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightElement()()()() | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(String) | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(Boolean) | Creates a new LightWeigthElement object
 | Composite | Returns whether this is a composite data element
 | ContainsData()()()() | Checks whether there is data in DataElement
 | ContainsNoData()()()() | Checks whether there is data in DataElement
 | DataValue | Get/Set the actual data in DataElement
 | ElementNumber | Get/Set the position of this DataElement in the containing DataSegment
 | Elements | Get/Set the child elements if this is a composite data element
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasRepeatingCompositeElements | Check whether this elements has repeating composite elements
 | HasRepeatingElements | Check whether this elements has repeating elements
 | ImplicitWideningImplicitImplicitImplicit(String to LightWeightElement) | Overides the asignment operator to directly convert a string to a LiteDataElement
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepeatingCompositeElements | Gets or sets the repeating composite elements.
 | RepeatingElementsValues | Gets or sets the repeating elements values. This is only set when this element does not represent a composite element
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightElement
 |  | DataElement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightElement Constructor

LightWeightElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | LightWeightElement()()()() | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(String) | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(Boolean) | Creates a new LightWeigthElement object

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightElement Constructor

LightWeightElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement()()()()
RDPCrystal EDI Library
Initializes a new instance of the LightWeightElement class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement()
Public Sub New
public:
LightWeightElement()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightElement Constructor (composite)

LightWeightElement Constructor (composite)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement(Boolean)
RDPCrystal EDI Library
Creates a new LightWeigthElement object
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement(
    bool composite
)
Public Sub New ( _
    composite As Boolean _
)
public:
LightWeightElement(
    bool composite
)
Parameters
composite (Boolean)
true if this is a composite dataelement, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightElement Constructor (elementValue)

LightWeightElement Constructor (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement(String)
RDPCrystal EDI Library
Initializes a new instance of the LightWeightElement class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement(
    string elementValue
)
Public Sub New ( _
    elementValue As String _
)
public:
LightWeightElement(
    String^ elementValue
)
Parameters
elementValue (String)
The element value.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Composite Property

Composite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► Composite
RDPCrystal EDI Library
Returns whether this is a composite data element
Declaration Syntax
C# Visual Basic Visual C++
public bool Composite { get; set; }
Public Property Composite As Boolean
    Get
    Set
public:
property bool Composite {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsData Method

ContainsData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ContainsData()()()()
RDPCrystal EDI Library
Checks whether there is data in DataElement
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsData()
Public Function ContainsData As Boolean
public:
bool ContainsData()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsNoData Method

ContainsNoData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ContainsNoData()()()()
RDPCrystal EDI Library
Checks whether there is data in DataElement
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsNoData()
Public Function ContainsNoData As Boolean
public:
bool ContainsNoData()
Return Value
true is there is no data, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataValue Property

DataValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► DataValue
RDPCrystal EDI Library
Get/Set the actual data in DataElement
Declaration Syntax
C# Visual Basic Visual C++
public string DataValue { get; set; }
Public Property DataValue As String
    Get
    Set
public:
property String^ DataValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ElementNumber
RDPCrystal EDI Library
Get/Set the position of this DataElement in the containing DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► Elements
RDPCrystal EDI Library
Get/Set the child elements if this is a composite data element
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightElement> Elements { get; set; }
Public Property Elements As List(Of LightWeightElement)
    Get
    Set
public:
property List<LightWeightElement^>^ Elements {
    List<LightWeightElement^>^ get ();
    void set (List<LightWeightElement^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HasRepeatingCompositeElements Property

HasRepeatingCompositeElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► HasRepeatingCompositeElements
RDPCrystal EDI Library
Check whether this elements has repeating composite elements
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasRepeatingCompositeElements { get; }
Public Overridable ReadOnly Property HasRepeatingCompositeElements As Boolean
    Get
public:
virtual property bool HasRepeatingCompositeElements {
    bool get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HasRepeatingElements Property

HasRepeatingElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► HasRepeatingElements
RDPCrystal EDI Library
Check whether this elements has repeating elements
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasRepeatingElements { get; }
Public Overridable ReadOnly Property HasRepeatingElements As Boolean
    Get
public:
virtual property bool HasRepeatingElements {
    bool get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ImplicitWideningImplicitImplicitImplicit(String to LightWeightElement)
RDPCrystal EDI Library
Overides the asignment operator to directly convert a string to a LiteDataElement
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator LightWeightElement (
    string elementValue
)
Public Shared Widening Operator CType ( _
    elementValue As String _
) As LightWeightElement
static implicit operator LightWeightElement^ (
    String^ elementValue
)
Parameters
elementValue (String)
string to convert to a DataElement
Return Value
a new DataElement with the supplied value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RepeatingCompositeElements Property

RepeatingCompositeElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► RepeatingCompositeElements
RDPCrystal EDI Library
Gets or sets the repeating composite elements.
Declaration Syntax
C# Visual Basic Visual C++
public List<List<LightWeightElement>> RepeatingCompositeElements { get; set; }
Public Property RepeatingCompositeElements As List(Of List(Of LightWeightElement))
    Get
    Set
public:
property List<List<LightWeightElement^>^>^ RepeatingCompositeElements {
    List<List<LightWeightElement^>^>^ get ();
    void set (List<List<LightWeightElement^>^>^ value);
}
Value
The repeating composite elements.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RepeatingElementsValues Property

RepeatingElementsValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► RepeatingElementsValues
RDPCrystal EDI Library
Gets or sets the repeating elements values. This is only set when this element does not represent a composite element
Declaration Syntax
C# Visual Basic Visual C++
public List<string> RepeatingElementsValues { get; set; }
Public Property RepeatingElementsValues As List(Of String)
    Get
    Set
public:
property List<String^>^ RepeatingElementsValues {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
The repeating elements values.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ToString()()()()
RDPCrystal EDI Library
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightLoop Class

LightWeightLoop Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop
RDPCrystal EDI Library
A light weight version of the Loop class
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightLoop
<SerializableAttribute> _
Public Class LightWeightLoop
[SerializableAttribute]
public ref class LightWeightLoop
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightLoop()()()() | Initializes a new instance of the Loop class.
 | LightWeightLoop(String) | Initializes a new instance of the Loop class.
 | ContainsSegment(String) | Determines whether this loop contains a segment.
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.
 | CreateSegment(String) | Creates the segment.
 | CreateSegmentLoop(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstSegment | Get the first segment in this loop
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastLoop()()()() | Gets the last loop.
 | GetLoop(String) | Gets the loop.
 | GetLoops(String) | Gets the loop collection.
 | GetSegment(String) | Gets the segment.
 | GetSegments(String) | Gets the segment collection.
 | GetSegments(String, Int32, String) | Gets a segment collection given an element position and value
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImplicitWideningImplicitImplicitImplicit(String to LightWeightLoop) | Performs an implicit conversion from String to Loop.
 | IsSegmentLoop |
 | LastSegment | Get the last segment in this loop
 | Loops | Get/Set the loops contained within this loop
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/Set the name of this loop
 | Parent | Get/Set the parent of this loop:Rules Reader
 | Segments | Get/Set a list of segments in this loop
 | ToEDIString(Delimiters) | Returns all segments in this loop and its sub loops as a string
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightLoop
 |  | Loop

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightLoop Constructor

LightWeightLoop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LightWeightLoop()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | LightWeightLoop()()()() | Initializes a new instance of the Loop class.
 | LightWeightLoop(String) | Initializes a new instance of the Loop class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightLoop Constructor

LightWeightLoop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LightWeightLoop()()()()
RDPCrystal EDI Library
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop()
Public Sub New
public:
LightWeightLoop()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightLoop Constructor (name)

LightWeightLoop Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LightWeightLoop(String)
RDPCrystal EDI Library
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop(
    string name
)
Public Sub New ( _
    name As String _
)
public:
LightWeightLoop(
    String^ name
)
Parameters
name (String)
The name of the new loop

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsSegment Method (segmentName)

ContainsSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ContainsSegment(String)
RDPCrystal EDI Library
Determines whether this loop contains a segment.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsSegment(
    string segmentName
)
Public Function ContainsSegment ( _
    segmentName As String _
) As Boolean
public:
bool ContainsSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
true if the specified loop contains segment; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateLoop()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateLoop()()()()
RDPCrystal EDI Library
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop CreateLoop()
Public Function CreateLoop As LightWeightLoop
public:
LightWeightLoop^ CreateLoop()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method (loopName)

CreateLoop Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateLoop(String)
RDPCrystal EDI Library
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop CreateLoop(
    string loopName
)
Public Function CreateLoop ( _
    loopName As String _
) As LightWeightLoop
public:
LightWeightLoop^ CreateLoop(
    String^ loopName
)
Parameters
loopName (String)
The name.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegment Method (segmentName)

CreateSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateSegment(String)
RDPCrystal EDI Library
Creates the segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment CreateSegment(
    string segmentName
)
Public Function CreateSegment ( _
    segmentName As String _
) As LightWeightSegment
public:
LightWeightSegment^ CreateSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegmentLoop Method (segmentName)

CreateSegmentLoop Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateSegmentLoop(String)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment CreateSegmentLoop(
    string segmentName
)
Public Function CreateSegmentLoop ( _
    segmentName As String _
) As LightWeightSegment
public:
LightWeightSegment^ CreateSegmentLoop(
    String^ segmentName
)
Parameters
segmentName (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FirstSegment Property

FirstSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► FirstSegment
RDPCrystal EDI Library
Get the first segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment FirstSegment { get; }
Public ReadOnly Property FirstSegment As LightWeightSegment
    Get
public:
property LightWeightSegment^ FirstSegment {
    LightWeightSegment^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLastLoop Method

GetLastLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetLastLoop()()()()
RDPCrystal EDI Library
Gets the last loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop GetLastLoop()
Public Function GetLastLoop As LightWeightLoop
public:
LightWeightLoop^ GetLastLoop()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLoop Method (loopName)

GetLoop Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetLoop(String)
RDPCrystal EDI Library
Gets the loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop GetLoop(
    string loopName
)
Public Function GetLoop ( _
    loopName As String _
) As LightWeightLoop
public:
LightWeightLoop^ GetLoop(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value
found loop or null

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLoops Method (loopName)

GetLoops Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetLoops(String)
RDPCrystal EDI Library
Gets the loop collection.
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightLoop> GetLoops(
    string loopName
)
Public Function GetLoops ( _
    loopName As String _
) As List(Of LightWeightLoop)
public:
List<LightWeightLoop^>^ GetLoops(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method (name)

GetSegment Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegment(String)
RDPCrystal EDI Library
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GetSegment(
    string name
)
Public Function GetSegment ( _
    name As String _
) As LightWeightSegment
public:
LightWeightSegment^ GetSegment(
    String^ name
)
Parameters
name (String)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method

GetSegments Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegments()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetSegments(String) | Gets the segment collection.
 | GetSegments(String, Int32, String) | Gets a segment collection given an element position and value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method (name)

GetSegments Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegments(String)
RDPCrystal EDI Library
Gets the segment collection.
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightSegment> GetSegments(
    string name
)
Public Function GetSegments ( _
    name As String _
) As List(Of LightWeightSegment)
public:
List<LightWeightSegment^>^ GetSegments(
    String^ name
)
Parameters
name (String)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method (name, elementPosition, elementValue)

GetSegments Method (name, elementPosition, elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegments(String, Int32, String)
RDPCrystal EDI Library
Gets a segment collection given an element position and value
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightSegment> GetSegments(
    string name,
    int elementPosition,
    string elementValue
)
Public Function GetSegments ( _
    name As String, _
    elementPosition As Integer, _
    elementValue As String _
) As List(Of LightWeightSegment)
public:
List<LightWeightSegment^>^ GetSegments(
    String^ name,
    int elementPosition,
    String^ elementValue
)
Parameters
name (String)
elementPosition (Int32)
Position of the element in the segment
elementValue (String)
Value of the element to compare against
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ImplicitWideningImplicitImplicitImplicit(String to LightWeightLoop)
RDPCrystal EDI Library
Performs an implicit conversion from String to Loop.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator LightWeightLoop (
    string loopName
)
Public Shared Widening Operator CType ( _
    loopName As String _
) As LightWeightLoop
static implicit operator LightWeightLoop^ (
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value
The result of the conversion.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsSegmentLoop Property

IsSegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► IsSegmentLoop
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentLoop { get; set; }
Public Property IsSegmentLoop As Boolean
    Get
    Set
public:
property bool IsSegmentLoop {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LastSegment Property

LastSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LastSegment
RDPCrystal EDI Library
Get the last segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment LastSegment { get; }
Public ReadOnly Property LastSegment As LightWeightSegment
    Get
public:
property LightWeightSegment^ LastSegment {
    LightWeightSegment^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Loops
RDPCrystal EDI Library
Get/Set the loops contained within this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightLoop> Loops { get; set; }
Public Property Loops As List(Of LightWeightLoop)
    Get
    Set
public:
property List<LightWeightLoop^>^ Loops {
    List<LightWeightLoop^>^ get ();
    void set (List<LightWeightLoop^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Name
RDPCrystal EDI Library
Get/Set the name of this loop
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parent Property

Parent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Parent
RDPCrystal EDI Library
Get/Set the parent of this loop:Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop Parent { get; set; }
Public Property Parent As LightWeightLoop
    Get
    Set
public:
property LightWeightLoop^ Parent {
    LightWeightLoop^ get ();
    void set (LightWeightLoop^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Segments
RDPCrystal EDI Library
Get/Set a list of segments in this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightSegment> Segments { get; set; }
Public Property Segments As List(Of LightWeightSegment)
    Get
    Set
public:
property List<LightWeightSegment^>^ Segments {
    List<LightWeightSegment^>^ get ();
    void set (List<LightWeightSegment^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToEDIString Method (delimiters)

ToEDIString Method (delimiters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ToEDIString(Delimiters)
RDPCrystal EDI Library
Returns all segments in this loop and its sub loops as a string
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    Delimiters delimiters
)
Public Function ToEDIString ( _
    delimiters As Delimiters _
) As String
public:
String^ ToEDIString(
    Delimiters^ delimiters
)
Parameters
delimiters (Delimiters)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ToString()()()()
RDPCrystal EDI Library
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightSegment Class

LightWeightSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment
RDPCrystal EDI Library
A DataSegment Object
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightSegment
<SerializableAttribute> _
Public Class LightWeightSegment
[SerializableAttribute]
public ref class LightWeightSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightSegment()()()() | Initializes a new instance of the LightWeightSegment class.
 | LightWeightSegment(String) | Initializes a new instance of the LightWeightSegment class.
 | ContainsElement(Int32) | Checks whether an element exist in the segment
 | Elements | Get/Set a list of DataElements
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstElement | Returns the first data element in this segment
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([( Int32])]) | Gets element values
 | LastElement | Returns the last data element in this segment
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/Set the name of this segment
 | OrdinalNumber | Get/Set the actual position of this segment in an EDIDocument
 | SegmentLoop |
 | ToEDIString(Delimiters) | Returns an EDI string of this segment complete with delimiters
 | ToString()()()() | Returns a string representation of this DataSegment (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightSegment
 |  | DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightSegment Constructor

LightWeightSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LightWeightSegment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | LightWeightSegment()()()() | Initializes a new instance of the LightWeightSegment class.
 | LightWeightSegment(String) | Initializes a new instance of the LightWeightSegment class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightSegment Constructor

LightWeightSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LightWeightSegment()()()()
RDPCrystal EDI Library
Initializes a new instance of the LightWeightSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment()
Public Sub New
public:
LightWeightSegment()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LightWeightSegment Constructor (segmentName)

LightWeightSegment Constructor (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LightWeightSegment(String)
RDPCrystal EDI Library
Initializes a new instance of the LightWeightSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment(
    string segmentName
)
Public Sub New ( _
    segmentName As String _
)
public:
LightWeightSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsElement Method (elementIndex)

ContainsElement Method (elementIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ContainsElement(Int32)
RDPCrystal EDI Library
Checks whether an element exist in the segment
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ContainsElement(
    int elementIndex
)
Public Overridable Function ContainsElement ( _
    elementIndex As Integer _
) As Boolean
public:
virtual bool ContainsElement(
    int elementIndex
)
Parameters
elementIndex (Int32)
index of the element
Return Value
true if element exists, false otherwise

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► Elements
RDPCrystal EDI Library
Get/Set a list of DataElements
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightElement> Elements { get; set; }
Public Property Elements As List(Of LightWeightElement)
    Get
    Set
public:
property List<LightWeightElement^>^ Elements {
    List<LightWeightElement^>^ get ();
    void set (List<LightWeightElement^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FirstElement Property

FirstElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► FirstElement
RDPCrystal EDI Library
Returns the first data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement FirstElement { get; }
Public ReadOnly Property FirstElement As LightWeightElement
    Get
public:
property LightWeightElement^ FirstElement {
    LightWeightElement^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Item Property (index)

Item Property (index)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► Item[([( Int32])])
RDPCrystal EDI Library
Gets element values
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As String
    Get
public:
property String^ default[int index] {
    String^ get (int index);
}
Parameters
index (Int32)
index of element
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LastElement Property

LastElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LastElement
RDPCrystal EDI Library
Returns the last data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement LastElement { get; }
Public ReadOnly Property LastElement As LightWeightElement
    Get
public:
property LightWeightElement^ LastElement {
    LightWeightElement^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► Name
RDPCrystal EDI Library
Get/Set the name of this segment
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OrdinalNumber Property

OrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► OrdinalNumber
RDPCrystal EDI Library
Get/Set the actual position of this segment in an EDIDocument
Declaration Syntax
C# Visual Basic Visual C++
public int OrdinalNumber { get; set; }
Public Property OrdinalNumber As Integer
    Get
    Set
public:
property int OrdinalNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentLoop Property

SegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► SegmentLoop
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop SegmentLoop { get; set; }
Public Property SegmentLoop As LightWeightLoop
    Get
    Set
public:
property LightWeightLoop^ SegmentLoop {
    LightWeightLoop^ get ();
    void set (LightWeightLoop^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToEDIString Method (delimiters)

ToEDIString Method (delimiters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ToEDIString(Delimiters)
RDPCrystal EDI Library
Returns an EDI string of this segment complete with delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    Delimiters delimiters
)
Public Function ToEDIString ( _
    delimiters As Delimiters _
) As String
public:
String^ ToEDIString(
    Delimiters^ delimiters
)
Parameters
delimiters (Delimiters)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ToString()()()()
RDPCrystal EDI Library
Returns a string representation of this DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this DataSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loop Class

Loop Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop
RDPCrystal EDI Library
Summary description for Loop.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Loop : LightWeightLoop
<SerializableAttribute> _
Public Class Loop _
    Inherits LightWeightLoop
[SerializableAttribute]
public ref class Loop : public LightWeightLoop
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Loop()()()() | Initializes a new instance of the Loop class.
 | Loop(String) | Initializes a new instance of the Loop class.
 | Loop(String, String) | Initializes a new instance of the Loop class.
 | ContainsSegment(String) | Determines whether this loop contains a segment.
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.
 | CreateLoop(String, String) | Creates the loop.
 | CreateSegment(String) | Creates the segment.
 | CreateSegment(String, Int32, Int32, Usage, String) | Creates the segment.
 | CreateSegmentLoop(String, Int32, Int32, Usage, String) |
 | CreateSegmentLoop(String) | (Inherited from LightWeightLoop.)
 | Description | Get/Set the description of this loop
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstSegment | Get the first segment in this loop
 | GetChildPosition(Loop) | Gets the child position.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastLoop()()()() | Gets the last loop.
 | GetLoop(String) | Gets the loop.
 | GetLoops(String) | Gets the loop collection.
 | GetNextSegment(Int32) | Gets the next segment.
 | GetSegment(String) | Gets the segment.
 | GetSegment(Int32) | Gets the segment.
 | GetSegmentPosition(DataSegment) | Gets the segment position.
 | GetSegments(String) | Gets the segment collection.
 | GetSegments(String, Int32, String) | Gets a segment collection given an element position and value
 | GetSiblingAbove()()()() | Gets the sibling above.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImplicitWideningImplicitImplicitImplicit(String to Loop) | Performs an implicit conversion from String to Loop.
 | IsSegmentLoop | (Inherited from LightWeightLoop.)
 | LastSegment | Get the last segment in this loop
 | Loops | Get/Set the loops contained within this loop
 | MaximumOccurrences | Get/Set the maximum amount of times this loop can repeat
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumOccurrences | Get/Set the minimum amount of times this loop can repeat
 | Name | Get/Set the name of this loop (Inherited from LightWeightLoop.)
 | Occurred | Get/Set if this loop occurred in an EDI File:Rules Reader
 | Parent | Get/Set the parent of this loop:Rules Reader
 | RepetitionIndefinite | Gets or sets a value indicating whether [repetition indefinite].
 | Segments | Get/Set a list of segments in this loop
 | Tag | Gets or sets the tag.
 | ToEDIString(Delimiters) | Returns all segments in this loop and its sub loops as a string (Inherited from LightWeightLoop.)
 | ToString()()()() | Returns a String that represents this instance. (Overrides LightWeightLoop.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightLoop
 |  | Loop

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loop Constructor

Loop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Loop()()()() | Initializes a new instance of the Loop class.
 | Loop(String) | Initializes a new instance of the Loop class.
 | Loop(String, String) | Initializes a new instance of the Loop class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loop Constructor

Loop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop()()()()
RDPCrystal EDI Library
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public Loop()
Public Sub New
public:
Loop()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loop Constructor (name)

Loop Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop(String)
RDPCrystal EDI Library
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public Loop(
    string name
)
Public Sub New ( _
    name As String _
)
public:
Loop(
    String^ name
)
Parameters
name (String)
The name of the new loop

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loop Constructor (name, description)

Loop Constructor (name, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop(String, String)
RDPCrystal EDI Library
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public Loop(
    string name,
    string description
)
Public Sub New ( _
    name As String, _
    description As String _
)
public:
Loop(
    String^ name,
    String^ description
)
Parameters
name (String)
The name.
description (String)
The description.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ContainsSegment Method (segmentName)

ContainsSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► ContainsSegment(String)
RDPCrystal EDI Library
Determines whether this loop contains a segment.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsSegment(
    string segmentName
)
Public Function ContainsSegment ( _
    segmentName As String _
) As Boolean
public:
bool ContainsSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
true if the specified loop contains segment; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.
 | CreateLoop(String, String) | Creates the loop.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop()()()()
RDPCrystal EDI Library
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop CreateLoop()
Public Function CreateLoop As Loop
public:
Loop^ CreateLoop()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method (name)

CreateLoop Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop(String)
RDPCrystal EDI Library
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop CreateLoop(
    string name
)
Public Function CreateLoop ( _
    name As String _
) As Loop
public:
Loop^ CreateLoop(
    String^ name
)
Parameters
name (String)
The name.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateLoop Method (name, description)

CreateLoop Method (name, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop(String, String)
RDPCrystal EDI Library
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop CreateLoop(
    string name,
    string description
)
Public Function CreateLoop ( _
    name As String, _
    description As String _
) As Loop
public:
Loop^ CreateLoop(
    String^ name,
    String^ description
)
Parameters
name (String)
The name.
description (String)
The description.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegment Method

CreateSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CreateSegment(String) | Creates the segment.
 | CreateSegment(String, Int32, Int32, Usage, String) | Creates the segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegment Method (segmentName)

CreateSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegment(String)
RDPCrystal EDI Library
Creates the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CreateSegment(
    string segmentName
)
Public Function CreateSegment ( _
    segmentName As String _
) As DataSegment
public:
DataSegment^ CreateSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegment Method (segmentName, min, max, usage, description)

CreateSegment Method (segmentName, min, max, usage, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegment(String, Int32, Int32, Usage, String)
RDPCrystal EDI Library
Creates the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CreateSegment(
    string segmentName,
    int min,
    int max,
    Usage usage,
    string description
)
Public Function CreateSegment ( _
    segmentName As String, _
    min As Integer, _
    max As Integer, _
    usage As Usage, _
    description As String _
) As DataSegment
public:
DataSegment^ CreateSegment(
    String^ segmentName,
    int min,
    int max,
    Usage usage,
    String^ description
)
Parameters
segmentName (String)
Name of the segment.
min (Int32)
The min.
max (Int32)
The max.
usage (Usage)
The usage.
description (String)
The description.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegmentLoop Method (segmentName, min, max, usage, description)

CreateSegmentLoop Method (segmentName, min, max, usage, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegmentLoop(String, Int32, Int32, Usage, String)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CreateSegmentLoop(
    string segmentName,
    int min,
    int max,
    Usage usage,
    string description
)
Public Function CreateSegmentLoop ( _
    segmentName As String, _
    min As Integer, _
    max As Integer, _
    usage As Usage, _
    description As String _
) As DataSegment
public:
DataSegment^ CreateSegmentLoop(
    String^ segmentName,
    int min,
    int max,
    Usage usage,
    String^ description
)
Parameters
segmentName (String)
min (Int32)
max (Int32)
usage (Usage)
description (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Description
RDPCrystal EDI Library
Get/Set the description of this loop
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FirstSegment Property

FirstSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► FirstSegment
RDPCrystal EDI Library
Get the first segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment FirstSegment { get; }
Public ReadOnly Property FirstSegment As DataSegment
    Get
public:
property DataSegment^ FirstSegment {
    DataSegment^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetChildPosition Method (childLoop)

GetChildPosition Method (childLoop)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetChildPosition(Loop)
RDPCrystal EDI Library
Gets the child position.
Declaration Syntax
C# Visual Basic Visual C++
public int GetChildPosition(
    Loop childLoop
)
Public Function GetChildPosition ( _
    childLoop As Loop _
) As Integer
public:
int GetChildPosition(
    Loop^ childLoop
)
Parameters
childLoop (Loop)
The child loop.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLastLoop Method

GetLastLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetLastLoop()()()()
RDPCrystal EDI Library
Gets the last loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop GetLastLoop()
Public Function GetLastLoop As Loop
public:
Loop^ GetLastLoop()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLoop Method (loopName)

GetLoop Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetLoop(String)
RDPCrystal EDI Library
Gets the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop GetLoop(
    string loopName
)
Public Function GetLoop ( _
    loopName As String _
) As Loop
public:
Loop^ GetLoop(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetLoops Method (loopName)

GetLoops Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetLoops(String)
RDPCrystal EDI Library
Gets the loop collection.
Declaration Syntax
C# Visual Basic Visual C++
public List<Loop> GetLoops(
    string loopName
)
Public Function GetLoops ( _
    loopName As String _
) As List(Of Loop)
public:
List<Loop^>^ GetLoops(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetNextSegment Method (currentIndex)

GetNextSegment Method (currentIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetNextSegment(Int32)
RDPCrystal EDI Library
Gets the next segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment GetNextSegment(
    int currentIndex
)
Public Function GetNextSegment ( _
    currentIndex As Integer _
) As DataSegment
public:
DataSegment^ GetNextSegment(
    int currentIndex
)
Parameters
currentIndex (Int32)
Index of the current.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method

GetSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetSegment(String) | Gets the segment.
 | GetSegment(Int32) | Gets the segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method (segmentOridinalNumber)

GetSegment Method (segmentOridinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegment(Int32)
RDPCrystal EDI Library
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment GetSegment(
    int segmentOridinalNumber
)
Public Function GetSegment ( _
    segmentOridinalNumber As Integer _
) As DataSegment
public:
DataSegment^ GetSegment(
    int segmentOridinalNumber
)
Parameters
segmentOridinalNumber (Int32)
The segment oridinal number.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegment Method (segmentName)

GetSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegment(String)
RDPCrystal EDI Library
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment GetSegment(
    string segmentName
)
Public Function GetSegment ( _
    segmentName As String _
) As DataSegment
public:
DataSegment^ GetSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegmentPosition Method (segment)

GetSegmentPosition Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegmentPosition(DataSegment)
RDPCrystal EDI Library
Gets the segment position.
Declaration Syntax
C# Visual Basic Visual C++
public int GetSegmentPosition(
    DataSegment segment
)
Public Function GetSegmentPosition ( _
    segment As DataSegment _
) As Integer
public:
int GetSegmentPosition(
    DataSegment^ segment
)
Parameters
segment (DataSegment)
The segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method

GetSegments Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegments()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetSegments(String) | Gets the segment collection.
 | GetSegments(String, Int32, String) | Gets a segment collection given an element position and value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method (segmentName)

GetSegments Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegments(String)
RDPCrystal EDI Library
Gets the segment collection.
Declaration Syntax
C# Visual Basic Visual C++
public List<DataSegment> GetSegments(
    string segmentName
)
Public Function GetSegments ( _
    segmentName As String _
) As List(Of DataSegment)
public:
List<DataSegment^>^ GetSegments(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSegments Method (segmentName, elementPosition, elementValue)

GetSegments Method (segmentName, elementPosition, elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegments(String, Int32, String)
RDPCrystal EDI Library
Gets a segment collection given an element position and value
Declaration Syntax
C# Visual Basic Visual C++
public List<DataSegment> GetSegments(
    string segmentName,
    int elementPosition,
    string elementValue
)
Public Function GetSegments ( _
    segmentName As String, _
    elementPosition As Integer, _
    elementValue As String _
) As List(Of DataSegment)
public:
List<DataSegment^>^ GetSegments(
    String^ segmentName,
    int elementPosition,
    String^ elementValue
)
Parameters
segmentName (String)
Name of the segment
elementPosition (Int32)
Position of the element in the segment
elementValue (String)
Value of the element to compare against
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetSiblingAbove Method

GetSiblingAbove Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSiblingAbove()()()()
RDPCrystal EDI Library
Gets the sibling above.
Declaration Syntax
C# Visual Basic Visual C++
public Loop GetSiblingAbove()
Public Function GetSiblingAbove As Loop
public:
Loop^ GetSiblingAbove()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► ImplicitWideningImplicitImplicitImplicit(String to Loop)
RDPCrystal EDI Library
Performs an implicit conversion from String to Loop.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator Loop (
    string loopName
)
Public Shared Widening Operator CType ( _
    loopName As String _
) As Loop
static implicit operator Loop^ (
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value
The result of the conversion.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LastSegment Property

LastSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► LastSegment
RDPCrystal EDI Library
Get the last segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment LastSegment { get; }
Public ReadOnly Property LastSegment As DataSegment
    Get
public:
property DataSegment^ LastSegment {
    DataSegment^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loops
RDPCrystal EDI Library
Get/Set the loops contained within this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<Loop> Loops { get; set; }
Public Property Loops As List(Of Loop)
    Get
    Set
public:
property List<Loop^>^ Loops {
    List<Loop^>^ get ();
    void set (List<Loop^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaximumOccurrences Property

MaximumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► MaximumOccurrences
RDPCrystal EDI Library
Get/Set the maximum amount of times this loop can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumOccurrences { get; set; }
Public Property MaximumOccurrences As Integer
    Get
    Set
public:
property int MaximumOccurrences {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MinimumOccurrences Property

MinimumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► MinimumOccurrences
RDPCrystal EDI Library
Get/Set the minimum amount of times this loop can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumOccurrences { get; set; }
Public Property MinimumOccurrences As Integer
    Get
    Set
public:
property int MinimumOccurrences {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Occurred Property

Occurred Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Occurred
RDPCrystal EDI Library
Get/Set if this loop occurred in an EDI File:Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public bool Occurred { get; set; }
Public Property Occurred As Boolean
    Get
    Set
public:
property bool Occurred {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parent Property

Parent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Parent
RDPCrystal EDI Library
Get/Set the parent of this loop:Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public Loop Parent { get; set; }
Public Property Parent As Loop
    Get
    Set
public:
property Loop^ Parent {
    Loop^ get ();
    void set (Loop^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RepetitionIndefinite Property

RepetitionIndefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► RepetitionIndefinite
RDPCrystal EDI Library
Gets or sets a value indicating whether [repetition indefinite].
Declaration Syntax
C# Visual Basic Visual C++
public bool RepetitionIndefinite { get; set; }
Public Property RepetitionIndefinite As Boolean
    Get
    Set
public:
property bool RepetitionIndefinite {
    bool get ();
    void set (bool value);
}
Value
true if [repetition indefinite]; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Segments
RDPCrystal EDI Library
Get/Set a list of segments in this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<DataSegment> Segments { get; set; }
Public Property Segments As List(Of DataSegment)
    Get
    Set
public:
property List<DataSegment^>^ Segments {
    List<DataSegment^>^ get ();
    void set (List<DataSegment^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Tag Property

Tag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Tag
RDPCrystal EDI Library
Gets or sets the tag.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
Value
The tag.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► ToString()()()()
RDPCrystal EDI Library
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopSchema Class

LoopSchema Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LoopSchema
<SerializableAttribute> _
Public Class LoopSchema
[SerializableAttribute]
public ref class LoopSchema
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoopSchema()()()() | Initializes a new instance of the LoopSchema class.
 | LoopSchema(String) | Initializes a new instance of the LoopSchema class.
 | Description | Gets or sets the description.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextSegment(Int32) | Gets the next segment.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Indefinite | Gets or sets a value indicating whether this LoopSchema is indefinite.
 | IsSegmentLoop |
 | LastSegment | Gets the last segment.
 | LoopID | Gets or sets the loop ID.
 | Loops | Gets or sets the loops.
 | Max | Gets or sets the max.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Gets or sets the min.
 | Occurred | Gets or sets a value indicating whether this LoopSchema is occurred.
 | Parent | Gets or sets the parent.
 | Segments | Gets or sets the segments.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usage | Gets or sets the usage.
Inheritance Hierarchy
Object
LoopSchema

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopSchema Constructor

LoopSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopSchema()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | LoopSchema()()()() | Initializes a new instance of the LoopSchema class.
 | LoopSchema(String) | Initializes a new instance of the LoopSchema class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopSchema Constructor

LoopSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopSchema()()()()
RDPCrystal EDI Library
Initializes a new instance of the LoopSchema class.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema()
Public Sub New
public:
LoopSchema()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopSchema Constructor (loopID)

LoopSchema Constructor (loopID)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopSchema(String)
RDPCrystal EDI Library
Initializes a new instance of the LoopSchema class.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema(
    string loopID
)
Public Sub New ( _
    loopID As String _
)
public:
LoopSchema(
    String^ loopID
)
Parameters
loopID (String)
The loop ID.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Description
RDPCrystal EDI Library
Gets or sets the description.
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
Value
The description.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetNextSegment Method (currentIndex)

GetNextSegment Method (currentIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► GetNextSegment(Int32)
RDPCrystal EDI Library
Gets the next segment.
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema GetNextSegment(
    int currentIndex
)
Public Function GetNextSegment ( _
    currentIndex As Integer _
) As SegmentSchema
public:
SegmentSchema^ GetNextSegment(
    int currentIndex
)
Parameters
currentIndex (Int32)
Index of the current.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Indefinite Property

Indefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Indefinite
RDPCrystal EDI Library
Gets or sets a value indicating whether this LoopSchema is indefinite.
Declaration Syntax
C# Visual Basic Visual C++
public bool Indefinite { get; set; }
Public Property Indefinite As Boolean
    Get
    Set
public:
property bool Indefinite {
    bool get ();
    void set (bool value);
}
Value
true if indefinite; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsSegmentLoop Property

IsSegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► IsSegmentLoop
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentLoop { get; set; }
Public Property IsSegmentLoop As Boolean
    Get
    Set
public:
property bool IsSegmentLoop {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LastSegment Property

LastSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LastSegment
RDPCrystal EDI Library
Gets the last segment.
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema LastSegment { get; }
Public ReadOnly Property LastSegment As SegmentSchema
    Get
public:
property SegmentSchema^ LastSegment {
    SegmentSchema^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopID Property

LoopID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopID
RDPCrystal EDI Library
Gets or sets the loop ID.
Declaration Syntax
C# Visual Basic Visual C++
public string LoopID { get; set; }
Public Property LoopID As String
    Get
    Set
public:
property String^ LoopID {
    String^ get ();
    void set (String^ value);
}
Value
The loop ID.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Loops
RDPCrystal EDI Library
Gets or sets the loops.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<LoopSchema> Loops { get; set; }
Public Property Loops As Collection(Of LoopSchema)
    Get
    Set
public:
property Collection<LoopSchema^>^ Loops {
    Collection<LoopSchema^>^ get ();
    void set (Collection<LoopSchema^>^ value);
}
Value
The loops.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Max Property

Max Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Max
RDPCrystal EDI Library
Gets or sets the max.
Declaration Syntax
C# Visual Basic Visual C++
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set
public:
property int Max {
    int get ();
    void set (int value);
}
Value
The max.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Min Property

Min Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Min
RDPCrystal EDI Library
Gets or sets the min.
Declaration Syntax
C# Visual Basic Visual C++
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set
public:
property int Min {
    int get ();
    void set (int value);
}
Value
The min.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Occurred Property

Occurred Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Occurred
RDPCrystal EDI Library
Gets or sets a value indicating whether this LoopSchema is occurred.
Declaration Syntax
C# Visual Basic Visual C++
public bool Occurred { get; set; }
Public Property Occurred As Boolean
    Get
    Set
public:
property bool Occurred {
    bool get ();
    void set (bool value);
}
Value
true if occurred; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Parent Property

Parent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Parent
RDPCrystal EDI Library
Gets or sets the parent.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema Parent { get; set; }
Public Property Parent As LoopSchema
    Get
    Set
public:
property LoopSchema^ Parent {
    LoopSchema^ get ();
    void set (LoopSchema^ value);
}
Value
The parent.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Segments
RDPCrystal EDI Library
Gets or sets the segments.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<SegmentSchema> Segments { get; set; }
Public Property Segments As Collection(Of SegmentSchema)
    Get
    Set
public:
property Collection<SegmentSchema^>^ Segments {
    Collection<SegmentSchema^>^ get ();
    void set (Collection<SegmentSchema^>^ value);
}
Value
The segments.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Usage
RDPCrystal EDI Library
Gets or sets the usage.
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}
Value
The usage.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Mask Class

Mask Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask
RDPCrystal EDI Library
Represents a mask that segment's use to decide how their elements are used
Declaration Syntax
C# Visual Basic Visual C++
public class Mask
Public Class Mask
public ref class Mask
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Mask()()()() | Initializes a new instance of the Mask class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MaskData | Get the maskData The number of elements in the Usage collection must equal that of the MaskData collection
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usages | Get the usages. The number of elements in the Usage collection must equal that of the MaskData collection
Inheritance Hierarchy
Object
Mask

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Mask Constructor

Mask Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask ► Mask()()()()
RDPCrystal EDI Library
Initializes a new instance of the Mask class
Declaration Syntax
C# Visual Basic Visual C++
public Mask()
Public Sub New
public:
Mask()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaskData Property

MaskData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask ► MaskData
RDPCrystal EDI Library
Get the maskData The number of elements in the Usage collection must equal that of the MaskData collection
Declaration Syntax
C# Visual Basic Visual C++
public List<string> MaskData { get; }
Public ReadOnly Property MaskData As List(Of String)
    Get
public:
property List<String^>^ MaskData {
    List<String^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usages Property

Usages Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask ► Usages
RDPCrystal EDI Library
Get the usages. The number of elements in the Usage collection must equal that of the MaskData collection
Declaration Syntax
C# Visual Basic Visual C++
public Collection<Usage> Usages { get; }
Public ReadOnly Property Usages As Collection(Of Usage)
    Get
public:
property Collection<Usage>^ Usages {
    Collection<Usage>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaximumErrorLimitReachedException Class

MaximumErrorLimitReachedException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► MaximumErrorLimitReachedException
RDPCrystal EDI Library
Maximum number of errors reached event
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MaximumErrorLimitReachedException : Exception
<SerializableAttribute> _
Public Class MaximumErrorLimitReachedException _
    Inherits Exception
[SerializableAttribute]
public ref class MaximumErrorLimitReachedException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | MaximumErrorLimitReachedException

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PackageLicense Class

PackageLicense Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense
RDPCrystal EDI Library
Responsible for checking that a valid license exist
Declaration Syntax
C# Visual Basic Visual C++
public static class PackageLicense
Public NotInheritable Class PackageLicense
public ref class PackageLicense abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsValidLicense<(Of <<'(T>)>>)(Object) |
 | IsValidLicense()()()() |
 | Key | RDPCrystal EDI Library Key
Inheritance Hierarchy
Object
PackageLicense

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsValidLicense Method

IsValidLicense Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► IsValidLicense()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | IsValidLicense<(Of <<'(T>)>>)(Object) |
 | IsValidLicense()()()() |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsValidLicense Method

IsValidLicense Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► IsValidLicense()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidLicense()
Public Shared Function IsValidLicense As Boolean
public:
static bool IsValidLicense()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsValidLicense Method (instance)

IsValidLicense<(Of <(<'T>)>)> Method (instance)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► IsValidLicense<(Of <<'(T>)>>)(Object)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidLicense<T>(
    Object instance
)

Public Shared Function IsValidLicense(Of T) ( _
    instance As Object _
) As Boolean
public:
generic<typename T>
static bool IsValidLicense(
    Object^ instance
)
Generic Template Parameters
T
Parameters
instance (Object)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Key Field

Key Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► Key
RDPCrystal EDI Library
RDPCrystal EDI Library Key
Declaration Syntax
C# Visual Basic Visual C++
public static string Key
Public Shared Key As String
public:
static String^ Key

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RuleDisplay Class

RuleDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay
RDPCrystal EDI Library
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class RuleDisplay
Public Class RuleDisplay
public ref class RuleDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleDisplay(String, String) | Initializes a new instance of the RuleDisplay class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Gets or sets the position.
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
RuleDisplay

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RuleDisplay Constructor (position, rule)

RuleDisplay Constructor (position, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay ► RuleDisplay(String, String)
RDPCrystal EDI Library
Initializes a new instance of the RuleDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public RuleDisplay(
    string position,
    string rule
)
Public Sub New ( _
    position As String, _
    rule As String _
)
public:
RuleDisplay(
    String^ position,
    String^ rule
)
Parameters
position (String)
The position.
rule (String)
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay ► Position
RDPCrystal EDI Library
Gets or sets the position.
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
Value
The position.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay ► Rule
RDPCrystal EDI Library
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RuleOperator Enumeration

RuleOperator Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleOperator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public enum RuleOperator
Public Enumeration RuleOperator
public enum class RuleOperator
Members
Member | Description
EQ |
NE |
GT |
GE |
LT |
LE |
EXISTS |
NEXIST |
CONTAINS |
NOTCONTAINS |
STARTSWITH |
NOTSTARTSWITH |
ENDSWITH |
NOTENDSWITH |
LENGTHEQUAL |
LENGTHNOTEQUAL |
LENGTHLESSTHAN |
LENGTHGREATERTHAN |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubPosition Class

ScrubPosition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ScrubPosition
Public Class ScrubPosition
public ref class ScrubPosition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrubPosition()()()() | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32) | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32, Int32) | Initializes a new instance of the ScrubPosition class
 | CompositeElementNumber | Gets or sets the composite element number.
 | ElementNumber | Gets or sets the element number.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ScrubPosition

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubPosition Constructor

ScrubPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ScrubPosition()()()() | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32) | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32, Int32) | Initializes a new instance of the ScrubPosition class

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubPosition Constructor

ScrubPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition()()()()
RDPCrystal EDI Library
Initializes a new instance of the ScrubPosition class
Declaration Syntax
C# Visual Basic Visual C++
public ScrubPosition()
Public Sub New
public:
ScrubPosition()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubPosition Constructor (elementNumber)

ScrubPosition Constructor (elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition(Int32)
RDPCrystal EDI Library
Initializes a new instance of the ScrubPosition class
Declaration Syntax
C# Visual Basic Visual C++
public ScrubPosition(
    int elementNumber
)
Public Sub New ( _
    elementNumber As Integer _
)
public:
ScrubPosition(
    int elementNumber
)
Parameters
elementNumber (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubPosition Constructor (compositeElementNumber, elementNumber)

ScrubPosition Constructor (compositeElementNumber, elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition(Int32, Int32)
RDPCrystal EDI Library
Initializes a new instance of the ScrubPosition class
Declaration Syntax
C# Visual Basic Visual C++
public ScrubPosition(
    int compositeElementNumber,
    int elementNumber
)
Public Sub New ( _
    compositeElementNumber As Integer, _
    elementNumber As Integer _
)
public:
ScrubPosition(
    int compositeElementNumber,
    int elementNumber
)
Parameters
compositeElementNumber (Int32)
elementNumber (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementNumber Property

CompositeElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► CompositeElementNumber
RDPCrystal EDI Library
Gets or sets the composite element number.
Declaration Syntax
C# Visual Basic Visual C++
public int CompositeElementNumber { get; set; }
Public Property CompositeElementNumber As Integer
    Get
    Set
public:
property int CompositeElementNumber {
    int get ();
    void set (int value);
}
Value
The composite element number.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ElementNumber
RDPCrystal EDI Library
Gets or sets the element number.
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}
Value
The element number.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubRule Class

ScrubRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ScrubRule
<SerializableAttribute> _
Public Class ScrubRule
[SerializableAttribute]
public ref class ScrubRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrubRule()()()() | Initializes a new instance of the ScrubRule class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReplaceCharacter | Gets or sets the replace character.
 | ScrubPositions |
 | SegmentName | Gets or sets the name of the segment.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ScrubRule

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubRule Constructor

ScrubRule Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► ScrubRule()()()()
RDPCrystal EDI Library
Initializes a new instance of the ScrubRule class.
Declaration Syntax
C# Visual Basic Visual C++
public ScrubRule()
Public Sub New
public:
ScrubRule()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ReplaceCharacter Property

ReplaceCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► ReplaceCharacter
RDPCrystal EDI Library
Gets or sets the replace character.
Declaration Syntax
C# Visual Basic Visual C++
public char ReplaceCharacter { get; set; }
Public Property ReplaceCharacter As Char
    Get
    Set
public:
property wchar_t ReplaceCharacter {
    wchar_t get ();
    void set (wchar_t value);
}
Value
The replace character.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ScrubPositions Property

ScrubPositions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► ScrubPositions
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<ScrubPosition> ScrubPositions { get; }
Public ReadOnly Property ScrubPositions As List(Of ScrubPosition)
    Get
public:
property List<ScrubPosition^>^ ScrubPositions {
    List<ScrubPosition^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentName Property

SegmentName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► SegmentName
RDPCrystal EDI Library
Gets or sets the name of the segment.
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentName { get; set; }
Public Property SegmentName As String
    Get
    Set
public:
property String^ SegmentName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the segment.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segment Class

Segment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Segment
<SerializableAttribute> _
Public Class Segment
[SerializableAttribute]
public ref class Segment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Segment()()()() | Initializes a new instance of the Segment class.
 | Segment(String) | Initializes a new instance of the Segment class.
 | ElementConditionalConstraints |
 | ElementExclusionConstraints | Gets or sets the element exclusion constraints.
 | ElementListConditionConstraints | Gets or sets the element list condition constraints.
 | ElementPairConstraints | Gets or sets the element pair constraints.
 | ElementRequiredConstraints | Gets or sets the element required constraints.
 | ElementSchema | Gets or sets the element schema.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneralSelfRules |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoopValidationIndex | Gets or sets the index of the loop validation.
 | Masks | Gets or sets the masks.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets or sets whether this Segment was modified after load. This property is used by the EDI Rules Creator Studio
 | Name | Gets or sets the name.
 | SelfRules | Gets or sets the self rules.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Segment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segment Constructor

Segment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Segment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Segment()()()() | Initializes a new instance of the Segment class.
 | Segment(String) | Initializes a new instance of the Segment class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segment Constructor

Segment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Segment()()()()
RDPCrystal EDI Library
Initializes a new instance of the Segment class.
Declaration Syntax
C# Visual Basic Visual C++
public Segment()
Public Sub New
public:
Segment()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Segment Constructor (name)

Segment Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Segment(String)
RDPCrystal EDI Library
Initializes a new instance of the Segment class.
Declaration Syntax
C# Visual Basic Visual C++
public Segment(
    string name
)
Public Sub New ( _
    name As String _
)
public:
Segment(
    String^ name
)
Parameters
name (String)
The name.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementConditionalConstraints Property

ElementConditionalConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementConditionalConstraints
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementConditionalConstraint> ElementConditionalConstraints { get; set; }
Public Property ElementConditionalConstraints As List(Of ElementConditionalConstraint)
    Get
    Set
public:
property List<ElementConditionalConstraint^>^ ElementConditionalConstraints {
    List<ElementConditionalConstraint^>^ get ();
    void set (List<ElementConditionalConstraint^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementExclusionConstraints Property

ElementExclusionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementExclusionConstraints
RDPCrystal EDI Library
Gets or sets the element exclusion constraints.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementExclusionConstraint> ElementExclusionConstraints { get; set; }
Public Property ElementExclusionConstraints As List(Of ElementExclusionConstraint)
    Get
    Set
public:
property List<ElementExclusionConstraint^>^ ElementExclusionConstraints {
    List<ElementExclusionConstraint^>^ get ();
    void set (List<ElementExclusionConstraint^>^ value);
}
Value
The element exclusion constraints.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementListConditionConstraints Property

ElementListConditionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementListConditionConstraints
RDPCrystal EDI Library
Gets or sets the element list condition constraints.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementListConditionalConstraint> ElementListConditionConstraints { get; set; }
Public Property ElementListConditionConstraints As List(Of ElementListConditionalConstraint)
    Get
    Set
public:
property List<ElementListConditionalConstraint^>^ ElementListConditionConstraints {
    List<ElementListConditionalConstraint^>^ get ();
    void set (List<ElementListConditionalConstraint^>^ value);
}
Value
The element list condition constraints.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPairConstraints Property

ElementPairConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementPairConstraints
RDPCrystal EDI Library
Gets or sets the element pair constraints.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementPairConstraint> ElementPairConstraints { get; set; }
Public Property ElementPairConstraints As List(Of ElementPairConstraint)
    Get
    Set
public:
property List<ElementPairConstraint^>^ ElementPairConstraints {
    List<ElementPairConstraint^>^ get ();
    void set (List<ElementPairConstraint^>^ value);
}
Value
The element pair constraints.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementRequiredConstraints Property

ElementRequiredConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementRequiredConstraints
RDPCrystal EDI Library
Gets or sets the element required constraints.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementRequiredConstraint> ElementRequiredConstraints { get; set; }
Public Property ElementRequiredConstraints As List(Of ElementRequiredConstraint)
    Get
    Set
public:
property List<ElementRequiredConstraint^>^ ElementRequiredConstraints {
    List<ElementRequiredConstraint^>^ get ();
    void set (List<ElementRequiredConstraint^>^ value);
}
Value
The element required constraints.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementSchema Property

ElementSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementSchema
RDPCrystal EDI Library
Gets or sets the element schema.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementSchema> ElementSchema { get; set; }
Public Property ElementSchema As List(Of ElementSchema)
    Get
    Set
public:
property List<ElementSchema^>^ ElementSchema {
    List<ElementSchema^>^ get ();
    void set (List<ElementSchema^>^ value);
}
Value
The element schema.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralSelfRules Property

GeneralSelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► GeneralSelfRules
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<GeneralSelfRule> GeneralSelfRules { get; set; }
Public Property GeneralSelfRules As List(Of GeneralSelfRule)
    Get
    Set
public:
property List<GeneralSelfRule^>^ GeneralSelfRules {
    List<GeneralSelfRule^>^ get ();
    void set (List<GeneralSelfRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopValidationIndex Property

LoopValidationIndex Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► LoopValidationIndex
RDPCrystal EDI Library
Gets or sets the index of the loop validation.
Declaration Syntax
C# Visual Basic Visual C++
public int LoopValidationIndex { get; set; }
Public Property LoopValidationIndex As Integer
    Get
    Set
public:
property int LoopValidationIndex {
    int get ();
    void set (int value);
}
Value
The index of the loop validation.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Masks Property

Masks Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Masks
RDPCrystal EDI Library
Gets or sets the masks.
Declaration Syntax
C# Visual Basic Visual C++
public List<Mask> Masks { get; set; }
Public Property Masks As List(Of Mask)
    Get
    Set
public:
property List<Mask^>^ Masks {
    List<Mask^>^ get ();
    void set (List<Mask^>^ value);
}
Value
The masks.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Modified Property

Modified Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Modified
RDPCrystal EDI Library
Gets or sets whether this Segment was modified after load. This property is used by the EDI Rules Creator Studio
Declaration Syntax
C# Visual Basic Visual C++
public bool Modified { get; set; }
Public Property Modified As Boolean
    Get
    Set
public:
property bool Modified {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Name
RDPCrystal EDI Library
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SelfRules Property

SelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► SelfRules
RDPCrystal EDI Library
Gets or sets the self rules.
Declaration Syntax
C# Visual Basic Visual C++
public List<SelfRule> SelfRules { get; set; }
Public Property SelfRules As List(Of SelfRule)
    Get
    Set
public:
property List<SelfRule^>^ SelfRules {
    List<SelfRule^>^ get ();
    void set (List<SelfRule^>^ value);
}
Value
The self rules.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Class

SegmentSchema Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema
RDPCrystal EDI Library
Represent basic segment information used by EDIRulesReader and EDIRulesCreator
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SegmentSchema
<SerializableAttribute> _
Public Class SegmentSchema
[SerializableAttribute]
public ref class SegmentSchema
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SegmentSchema()()()() | Creates a new SegmentSchema object
 | SegmentSchema(String) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage, Int32) | Creates a new SegmentSchema object
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneralRules |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSegmentLoop |
 | MaskNumber | Get/set the mask number of the segment
 | MaximumOccurrences | Get/set the maximum amount of times segment will appear in its containing loop
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumOccurrences | Get/set the minimum amount of times segment will appear in its containing loop
 | Name | Get/set the name of segment
 | OnlySegmentInLoop | Get/set whether segment is the only segment in the loop
 | OridinalNumber | Get the orginal number of segment within the EDI rules file
 | Position | Gets or sets the position.
 | RepeatIndefinite | Get/set whether segment repeats indefinitely
 | Rules | Get/set the rules that apply to segment
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usage | Get/set usage of segment within containing loop
Inheritance Hierarchy
Object
SegmentSchema

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Constructor

SegmentSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | SegmentSchema()()()() | Creates a new SegmentSchema object
 | SegmentSchema(String) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage, Int32) | Creates a new SegmentSchema object

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Constructor

SegmentSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema()()()()
RDPCrystal EDI Library
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema()
Public Sub New
public:
SegmentSchema()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Constructor (segmentName)

SegmentSchema Constructor (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema(String)
RDPCrystal EDI Library
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema(
    string segmentName
)
Public Sub New ( _
    segmentName As String _
)
public:
SegmentSchema(
    String^ segmentName
)
Parameters
segmentName (String)
name of segment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Constructor (segmentName, usage)

SegmentSchema Constructor (segmentName, usage)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema(String, Usage)
RDPCrystal EDI Library
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema(
    string segmentName,
    Usage usage
)
Public Sub New ( _
    segmentName As String, _
    usage As Usage _
)
public:
SegmentSchema(
    String^ segmentName,
    Usage usage
)
Parameters
segmentName (String)
name of segment
usage (Usage)
usage of segment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentSchema Constructor (segmentName, usage, maskNumber)

SegmentSchema Constructor (segmentName, usage, maskNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema(String, Usage, Int32)
RDPCrystal EDI Library
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema(
    string segmentName,
    Usage usage,
    int maskNumber
)
Public Sub New ( _
    segmentName As String, _
    usage As Usage, _
    maskNumber As Integer _
)
public:
SegmentSchema(
    String^ segmentName,
    Usage usage,
    int maskNumber
)
Parameters
segmentName (String)
name of segment
usage (Usage)
usage of segment
maskNumber (Int32)
mask number to use

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralRules Property

GeneralRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► GeneralRules
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<GeneralRule> GeneralRules { get; set; }
Public Property GeneralRules As List(Of GeneralRule)
    Get
    Set
public:
property List<GeneralRule^>^ GeneralRules {
    List<GeneralRule^>^ get ();
    void set (List<GeneralRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsSegmentLoop Property

IsSegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► IsSegmentLoop
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentLoop { get; set; }
Public Property IsSegmentLoop As Boolean
    Get
    Set
public:
property bool IsSegmentLoop {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaskNumber Property

MaskNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► MaskNumber
RDPCrystal EDI Library
Get/set the mask number of the segment
Declaration Syntax
C# Visual Basic Visual C++
public int MaskNumber { get; set; }
Public Property MaskNumber As Integer
    Get
    Set
public:
property int MaskNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MaximumOccurrences Property

MaximumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► MaximumOccurrences
RDPCrystal EDI Library
Get/set the maximum amount of times segment will appear in its containing loop
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumOccurrences { get; set; }
Public Property MaximumOccurrences As Integer
    Get
    Set
public:
property int MaximumOccurrences {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MinimumOccurrences Property

MinimumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► MinimumOccurrences
RDPCrystal EDI Library
Get/set the minimum amount of times segment will appear in its containing loop
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumOccurrences { get; set; }
Public Property MinimumOccurrences As Integer
    Get
    Set
public:
property int MinimumOccurrences {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Name
RDPCrystal EDI Library
Get/set the name of segment
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OnlySegmentInLoop Property

OnlySegmentInLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► OnlySegmentInLoop
RDPCrystal EDI Library
Get/set whether segment is the only segment in the loop
Declaration Syntax
C# Visual Basic Visual C++
public bool OnlySegmentInLoop { get; set; }
Public Property OnlySegmentInLoop As Boolean
    Get
    Set
public:
property bool OnlySegmentInLoop {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OridinalNumber Property

OridinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► OridinalNumber
RDPCrystal EDI Library
Get the orginal number of segment within the EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public int OridinalNumber { get; internal set; }
Public Property OridinalNumber As Integer
    Get
    Friend Set
public:
property int OridinalNumber {
    int get ();
    internal: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Position
RDPCrystal EDI Library
Gets or sets the position.
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
Value
The position.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RepeatIndefinite Property

RepeatIndefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► RepeatIndefinite
RDPCrystal EDI Library
Get/set whether segment repeats indefinitely
Declaration Syntax
C# Visual Basic Visual C++
public bool RepeatIndefinite { get; set; }
Public Property RepeatIndefinite As Boolean
    Get
    Set
public:
property bool RepeatIndefinite {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Rules
RDPCrystal EDI Library
Get/set the rules that apply to segment
Declaration Syntax
C# Visual Basic Visual C++
public List<SemanticRule> Rules { get; set; }
Public Property Rules As List(Of SemanticRule)
    Get
    Set
public:
property List<SemanticRule^>^ Rules {
    List<SemanticRule^>^ get ();
    void set (List<SemanticRule^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Usage
RDPCrystal EDI Library
Get/set usage of segment within containing loop
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SelfRule Class

SelfRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule
RDPCrystal EDI Library
Represents a rule that a segment uses to check itself
Declaration Syntax
C# Visual Basic Visual C++
public class SelfRule
Public Class SelfRule
public ref class SelfRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelfRule()()()() | Creates a new SelfRule object
 | ElementNumber | Get/set the element number that the rule will apply to
 | ElementValues | Get/set the possible values that will trigger the rule
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCommaSeparatedElementValues()()()() | Returns a comma separated list of the element values that will trigger the rule
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNotUsedOrdinalsString()()()() | Returns the not used elements as a string with element number delimited by a space
 | GetNotUsedOrdinalsString(Char) | Returns the not used elements as a string with element number delimited by a the separator character
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsedOrdinalsString()()()() | Returns the used elements as a string with element number delimited by a space
 | GetUsedOrdinalsString(Char) | Returns the used elements as a string with element number delimited by a the separator character
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotUsedElementCollection | Get/set the elements that must not be used when the rule is applied
 | RuleOperator | Get/set the rule operator
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UsedElementCollection | Get/set the elements that must be used when the rule is applied
Inheritance Hierarchy
Object
SelfRule

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SelfRule Constructor

SelfRule Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► SelfRule()()()()
RDPCrystal EDI Library
Creates a new SelfRule object
Declaration Syntax
C# Visual Basic Visual C++
public SelfRule()
Public Sub New
public:
SelfRule()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► ElementNumber
RDPCrystal EDI Library
Get/set the element number that the rule will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementValues Property

ElementValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► ElementValues
RDPCrystal EDI Library
Get/set the possible values that will trigger the rule
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> ElementValues { get; set; }
Public Property ElementValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ ElementValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetCommaSeparatedElementValues Method

GetCommaSeparatedElementValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetCommaSeparatedElementValues()()()()
RDPCrystal EDI Library
Returns a comma separated list of the element values that will trigger the rule
Declaration Syntax
C# Visual Basic Visual C++
public string GetCommaSeparatedElementValues()
Public Function GetCommaSeparatedElementValues As String
public:
String^ GetCommaSeparatedElementValues()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetNotUsedOrdinalsString Method

GetNotUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetNotUsedOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetNotUsedOrdinalsString()()()() | Returns the not used elements as a string with element number delimited by a space
 | GetNotUsedOrdinalsString(Char) | Returns the not used elements as a string with element number delimited by a the separator character

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetNotUsedOrdinalsString Method

GetNotUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetNotUsedOrdinalsString()()()()
RDPCrystal EDI Library
Returns the not used elements as a string with element number delimited by a space
Declaration Syntax
C# Visual Basic Visual C++
public string GetNotUsedOrdinalsString()
Public Function GetNotUsedOrdinalsString As String
public:
String^ GetNotUsedOrdinalsString()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetNotUsedOrdinalsString Method (separator)

GetNotUsedOrdinalsString Method (separator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetNotUsedOrdinalsString(Char)
RDPCrystal EDI Library
Returns the not used elements as a string with element number delimited by a the separator character
Declaration Syntax
C# Visual Basic Visual C++
public string GetNotUsedOrdinalsString(
    char separator
)
Public Function GetNotUsedOrdinalsString ( _
    separator As Char _
) As String
public:
String^ GetNotUsedOrdinalsString(
    wchar_t separator
)
Parameters
separator (Char)
Return Value
separator character

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetUsedOrdinalsString Method

GetUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetUsedOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetUsedOrdinalsString()()()() | Returns the used elements as a string with element number delimited by a space
 | GetUsedOrdinalsString(Char) | Returns the used elements as a string with element number delimited by a the separator character

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetUsedOrdinalsString Method

GetUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetUsedOrdinalsString()()()()
RDPCrystal EDI Library
Returns the used elements as a string with element number delimited by a space
Declaration Syntax
C# Visual Basic Visual C++
public string GetUsedOrdinalsString()
Public Function GetUsedOrdinalsString As String
public:
String^ GetUsedOrdinalsString()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetUsedOrdinalsString Method (separator)

GetUsedOrdinalsString Method (separator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetUsedOrdinalsString(Char)
RDPCrystal EDI Library
Returns the used elements as a string with element number delimited by a the separator character
Declaration Syntax
C# Visual Basic Visual C++
public string GetUsedOrdinalsString(
    char separator
)
Public Function GetUsedOrdinalsString ( _
    separator As Char _
) As String
public:
String^ GetUsedOrdinalsString(
    wchar_t separator
)
Parameters
separator (Char)
Return Value
separator character

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NotUsedElementCollection Property

NotUsedElementCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► NotUsedElementCollection
RDPCrystal EDI Library
Get/set the elements that must not be used when the rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public Collection<int> NotUsedElementCollection { get; set; }
Public Property NotUsedElementCollection As Collection(Of Integer)
    Get
    Set
public:
property Collection<int>^ NotUsedElementCollection {
    Collection<int>^ get ();
    void set (Collection<int>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RuleOperator Property

RuleOperator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► RuleOperator
RDPCrystal EDI Library
Get/set the rule operator
Declaration Syntax
C# Visual Basic Visual C++
public RuleOperator RuleOperator { get; set; }
Public Property RuleOperator As RuleOperator
    Get
    Set
public:
property RuleOperator RuleOperator {
    RuleOperator get ();
    void set (RuleOperator value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UsedElementCollection Property

UsedElementCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► UsedElementCollection
RDPCrystal EDI Library
Get/set the elements that must be used when the rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public Collection<int> UsedElementCollection { get; set; }
Public Property UsedElementCollection As Collection(Of Integer)
    Get
    Set
public:
property Collection<int>^ UsedElementCollection {
    Collection<int>^ get ();
    void set (Collection<int>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SemanticRule Class

SemanticRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule
RDPCrystal EDI Library
Represents a rule that a segment or element must conform to
Declaration Syntax
C# Visual Basic Visual C++
public class SemanticRule
Public Class SemanticRule
public ref class SemanticRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SemanticRule()()()() | Creates a new SemanticRule object
 | AcceptedValues | Get/set the accepted values that the base segment's element must contain when rule is applied
 | BaseSegmentPosition | The segment/element position that this rule is based on
 | ConditionalValues | Get/set the conditional values that the base segment's element should have when rule is applied. The conditional values are values that the base segment's element must contain for the rule to be applied
 | DefaultValues | Get/set the default values that the base segment's element must have when rule is applied
 | DependentSegmentPosition | The segment position of the segment/element that this rule is for
 | ElseUsage | Get/set the usage of the segment or element usage when the rule condition evaluates to false
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RuleOperator | Get/Set the rule operator for rule
 | ToString()()()() | Returns a string representation of this object (Overrides Object.ToString()()()().)
 | Usage | Get/set the usage of the segment or element who holds this rule
Inheritance Hierarchy
Object
SemanticRule

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SemanticRule Constructor

SemanticRule Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► SemanticRule()()()()
RDPCrystal EDI Library
Creates a new SemanticRule object
Declaration Syntax
C# Visual Basic Visual C++
public SemanticRule()
Public Sub New
public:
SemanticRule()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AcceptedValues Property

AcceptedValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► AcceptedValues
RDPCrystal EDI Library
Get/set the accepted values that the base segment's element must contain when rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> AcceptedValues { get; set; }
Public Property AcceptedValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ AcceptedValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


BaseSegmentPosition Property

BaseSegmentPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► BaseSegmentPosition
RDPCrystal EDI Library
The segment/element position that this rule is based on
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition BaseSegmentPosition { get; set; }
Public Property BaseSegmentPosition As ElementPosition
    Get
    Set
public:
property ElementPosition^ BaseSegmentPosition {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ConditionalValues Property

ConditionalValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► ConditionalValues
RDPCrystal EDI Library
Get/set the conditional values that the base segment's element should have when rule is applied. The conditional values are values that the base segment's element must contain for the rule to be applied
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> ConditionalValues { get; set; }
Public Property ConditionalValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ ConditionalValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DefaultValues Property

DefaultValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► DefaultValues
RDPCrystal EDI Library
Get/set the default values that the base segment's element must have when rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> DefaultValues { get; set; }
Public Property DefaultValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ DefaultValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DependentSegmentPosition Property

DependentSegmentPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► DependentSegmentPosition
RDPCrystal EDI Library
The segment position of the segment/element that this rule is for
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition DependentSegmentPosition { get; set; }
Public Property DependentSegmentPosition As ElementPosition
    Get
    Set
public:
property ElementPosition^ DependentSegmentPosition {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElseUsage Property

ElseUsage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► ElseUsage
RDPCrystal EDI Library
Get/set the usage of the segment or element usage when the rule condition evaluates to false
Declaration Syntax
C# Visual Basic Visual C++
public Usage ElseUsage { get; set; }
Public Property ElseUsage As Usage
    Get
    Set
public:
property Usage ElseUsage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RuleOperator Property

RuleOperator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► RuleOperator
RDPCrystal EDI Library
Get/Set the rule operator for rule
Declaration Syntax
C# Visual Basic Visual C++
public RuleOperator RuleOperator { get; set; }
Public Property RuleOperator As RuleOperator
    Get
    Set
public:
property RuleOperator RuleOperator {
    RuleOperator get ();
    void set (RuleOperator value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► ToString()()()()
RDPCrystal EDI Library
Returns a string representation of this object
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this object

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► Usage
RDPCrystal EDI Library
Get/set the usage of the segment or element who holds this rule
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SemanticsProcessor Class

SemanticsProcessor Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticsProcessor
RDPCrystal EDI Library
This class is resonsible for taking a string and extracting the rules from it
Declaration Syntax
C# Visual Basic Visual C++
public static class SemanticsProcessor
Public NotInheritable Class SemanticsProcessor
public ref class SemanticsProcessor abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExtractSemanticRule(String, Dictionary<(Of <<'(String, CodeList>)>>)) |
Inheritance Hierarchy
Object
SemanticsProcessor

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ExtractSemanticRule Method (ruleString, codeLists)

ExtractSemanticRule Method (ruleString, codeLists)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticsProcessor ► ExtractSemanticRule(String, Dictionary<(Of <<'(String, CodeList>)>>))
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static SemanticRule ExtractSemanticRule(
    string ruleString,
    Dictionary<string, CodeList> codeLists
)
Public Shared Function ExtractSemanticRule ( _
    ruleString As String, _
    codeLists As Dictionary(Of String, CodeList) _
) As SemanticRule
public:
static SemanticRule^ ExtractSemanticRule(
    String^ ruleString,
    Dictionary<String^, CodeList^>^ codeLists
)
Parameters
ruleString (String)
codeLists (Dictionary<(Of <(<'String, CodeList >)>)>)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SnipTestLevel Enumeration

SnipTestLevel Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SnipTestLevel
RDPCrystal EDI Library
Snip Levels
Declaration Syntax
C# Visual Basic Visual C++
public enum SnipTestLevel
Public Enumeration SnipTestLevel
public enum class SnipTestLevel
Members
Member | Description
DoesNotApply | Snip Level does not apply
Integrity | Testing for valid EDI syntax for each type of transaction
Requirement | Testing for HIPAA specific syntax. This tests that the transaction sets adhereto the HIPAA implementation guides
Balance | Testing of the transaction for balanced field totals, financial balancing of claims or remittance advice and balancing of summary fields.
Situational | Testing of specific inter-segment situations as defined in the implementation guide, where if A occurs, then B must be populated
CodeSet | Testing correct use of external code sets. Tests that only valid values of external data elements are used

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SummaryDisplay Class

SummaryDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay
RDPCrystal EDI Library
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class SummaryDisplay
Public Class SummaryDisplay
public ref class SummaryDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SummaryDisplay(String, String) | Initializes a new instance of the SummaryDisplay class.
 | Element | Gets or sets the element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SummaryDisplay

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SummaryDisplay Constructor (element, rule)

SummaryDisplay Constructor (element, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay ► SummaryDisplay(String, String)
RDPCrystal EDI Library
Initializes a new instance of the SummaryDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public SummaryDisplay(
    string element,
    string rule
)
Public Sub New ( _
    element As String, _
    rule As String _
)
public:
SummaryDisplay(
    String^ element,
    String^ rule
)
Parameters
element (String)
The element.
rule (String)
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Element Property

Element Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay ► Element
RDPCrystal EDI Library
Gets or sets the element.
Declaration Syntax
C# Visual Basic Visual C++
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
Value
The element.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay ► Rule
RDPCrystal EDI Library
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TypedDocument Class

TypedDocument Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument
RDPCrystal EDI Library
Base class of all Typed EDI Document. Subclass this class if you need to create your own typed document that we don't support
Declaration Syntax
C# Visual Basic Visual C++
public abstract class TypedDocument
Public MustInherit Class TypedDocument
public ref class TypedDocument abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypedDocument()()()() | Initializes a new instance of the TypedDocument class.
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT)
 | AutoPlaceNumOfFunctionalGroups | Places the correct number of functional groups in the IEA segment Element 1(X12)
 | AutoPlaceNumOfTransactions | Places the correct number of transaction in the GE segment Element 1(X12)
 | CreateSection(LightWeightLoop) | Overridden in edge case scenarios when a custom loop structure is needed
 | DestroySegmentsAfter | Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document
 | GetDocumentSegment(String) | Gets the document segment when this document is being loading from an EDILightweightDocument
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(EDILightWeightDocument) | Loads the specified light weight document.
 | MainSection | Gets or sets the main section of the TypedDocument
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadISAElementValues | Pads or trims the ISA elements to conform to HIPAA
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypedDocument
 |  | Typed4010Document
 |  | Typed5010Document

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TypedDocument Constructor

TypedDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► TypedDocument()()()()
RDPCrystal EDI Library
Initializes a new instance of the TypedDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public TypedDocument()
Public Sub New
public:
TypedDocument()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceCorrectNumOfSegments Property

AutoPlaceCorrectNumOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► AutoPlaceCorrectNumOfSegments
RDPCrystal EDI Library
Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfSegments { get; set; }
Public Property AutoPlaceCorrectNumOfSegments As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfSegments {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceNumOfFunctionalGroups Property

AutoPlaceNumOfFunctionalGroups Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► AutoPlaceNumOfFunctionalGroups
RDPCrystal EDI Library
Places the correct number of functional groups in the IEA segment Element 1(X12)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfFunctionalGroups { get; set; }
Public Property AutoPlaceNumOfFunctionalGroups As Boolean
    Get
    Set
public:
property bool AutoPlaceNumOfFunctionalGroups {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceNumOfTransactions Property

AutoPlaceNumOfTransactions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► AutoPlaceNumOfTransactions
RDPCrystal EDI Library
Places the correct number of transaction in the GE segment Element 1(X12)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfTransactions { get; set; }
Public Property AutoPlaceNumOfTransactions As Boolean
    Get
    Set
public:
property bool AutoPlaceNumOfTransactions {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSection Method (loop)

CreateSection Method (loop)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► CreateSection(LightWeightLoop)
RDPCrystal EDI Library
Overridden in edge case scenarios when a custom loop structure is needed
Declaration Syntax
C# Visual Basic Visual C++
protected void CreateSection(
    LightWeightLoop loop
)
Protected Sub CreateSection ( _
    loop As LightWeightLoop _
)
protected:
void CreateSection(
    LightWeightLoop^ loop
)
Parameters
loop (LightWeightLoop)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DestroySegmentsAfter Property

DestroySegmentsAfter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► DestroySegmentsAfter
RDPCrystal EDI Library
Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument
Declaration Syntax
C# Visual Basic Visual C++
public bool DestroySegmentsAfter { get; set; }
Public Property DestroySegmentsAfter As Boolean
    Get
    Set
public:
property bool DestroySegmentsAfter {
    bool get ();
    void set (bool value);
}
Value
true if destroy segments after; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method (delimiters, file)

GenerateEDIFile Method (delimiters, file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► GenerateEDIFile(Delimiters, String)
RDPCrystal EDI Library
Generate EDI data from the underlying document and writes it to a file
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    Delimiters delimiters,
    string file
)
Public Sub GenerateEDIFile ( _
    delimiters As Delimiters, _
    file As String _
)
public:
void GenerateEDIFile(
    Delimiters^ delimiters,
    String^ file
)
Parameters
delimiters (Delimiters)
delimiters
file (String)
filename
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method (writeArguments, file)

GenerateEDIFile Method (writeArguments, file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► GenerateEDIFile(WriteArguments, String)
RDPCrystal EDI Library
Generate EDI data from the underlying document
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    WriteArguments writeArguments,
    string file
)
Public Sub GenerateEDIFile ( _
    writeArguments As WriteArguments, _
    file As String _
)
public:
void GenerateEDIFile(
    WriteArguments^ writeArguments,
    String^ file
)
Parameters
writeArguments (WriteArguments)
writeArguments
file (String)
filename

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetDocumentSegment Method (segmentName)

GetDocumentSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► GetDocumentSegment(String)
RDPCrystal EDI Library
Gets the document segment when this document is being loading from an EDILightweightDocument
Declaration Syntax
C# Visual Basic Visual C++
protected virtual DocumentSegment GetDocumentSegment(
    string segmentName
)
Protected Overridable Function GetDocumentSegment ( _
    segmentName As String _
) As DocumentSegment
protected:
virtual DocumentSegment^ GetDocumentSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Load Method (lightWeightDocument)

Load Method (lightWeightDocument)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► Load(EDILightWeightDocument)
RDPCrystal EDI Library
Loads the specified light weight document.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Load(
    EDILightWeightDocument lightWeightDocument
)
Public Overridable Sub Load ( _
    lightWeightDocument As EDILightWeightDocument _
)
public:
virtual void Load(
    EDILightWeightDocument^ lightWeightDocument
)
Parameters
lightWeightDocument (EDILightWeightDocument)
The light weight document.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MainSection Property

MainSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► MainSection
RDPCrystal EDI Library
Gets or sets the main section of the TypedDocument
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop MainSection { get; set; }
Public Property MainSection As DocumentLoop
    Get
    Set
public:
property DocumentLoop^ MainSection {
    DocumentLoop^ get ();
    void set (DocumentLoop^ value);
}
Value
The main section.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PadISAElementValues Property

PadISAElementValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► PadISAElementValues
RDPCrystal EDI Library
Pads or trims the ISA elements to conform to HIPAA
Declaration Syntax
C# Visual Basic Visual C++
public bool PadISAElementValues { get; set; }
Public Property PadISAElementValues As Boolean
    Get
    Set
public:
property bool PadISAElementValues {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToEDIString Method

ToEDIString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► ToEDIString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToEDIString Method (delimiters)

ToEDIString Method (delimiters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► ToEDIString(Delimiters)
RDPCrystal EDI Library
Generate EDI data from the underlying document
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    Delimiters delimiters
)
Public Function ToEDIString ( _
    delimiters As Delimiters _
) As String
public:
String^ ToEDIString(
    Delimiters^ delimiters
)
Parameters
delimiters (Delimiters)
delimiters
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToEDIString Method (args)

ToEDIString Method (args)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TypedDocument ► ToEDIString(WriteArguments)
RDPCrystal EDI Library
Generate EDI data from the underlying document
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    WriteArguments args
)
Public Function ToEDIString ( _
    args As WriteArguments _
) As String
public:
String^ ToEDIString(
    WriteArguments^ args
)
Parameters
args (WriteArguments)
Write Arguments
Return Value
an EDI string

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Enumeration

Usage Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Usage
RDPCrystal EDI Library
Represents how a segment/element usage requirements
Declaration Syntax
C# Visual Basic Visual C++
public enum Usage
Public Enumeration Usage
public enum class Usage
Members
Member | Description
NOTUSED |
REQUIRED |
RECOMMENDED |
NOTRECOMMENDED |
OPTIONAL |
DEPENDENT |
LOCALCODE |
USE_DEFAULT |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationEventsArgs Class

ValidationEventsArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs
RDPCrystal EDI Library
Represents data pertaining to the time it took to validate a file and if the file has passed validation
Declaration Syntax
C# Visual Basic Visual C++
public class ValidationEventsArgs : EventArgs
Public Class ValidationEventsArgs _
    Inherits EventArgs
public ref class ValidationEventsArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationEventsArgs()()()() | Initializes a new instance of the ValidationEventsArgs class
 | ValidationEventsArgs(Boolean, Double) | Initializes a new instance of the ValidationEventsArgs class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Milliseconds | Get the amount of time passed in milliseconds for the validation process
 | Passed | Check whether a file was successfully validated
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ValidationEventsArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationEventsArgs Constructor

ValidationEventsArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► ValidationEventsArgs()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ValidationEventsArgs()()()() | Initializes a new instance of the ValidationEventsArgs class
 | ValidationEventsArgs(Boolean, Double) | Initializes a new instance of the ValidationEventsArgs class

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationEventsArgs Constructor

ValidationEventsArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► ValidationEventsArgs()()()()
RDPCrystal EDI Library
Initializes a new instance of the ValidationEventsArgs class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationEventsArgs()
Public Sub New
public:
ValidationEventsArgs()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationEventsArgs Constructor (passed, milliseconds)

ValidationEventsArgs Constructor (passed, milliseconds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► ValidationEventsArgs(Boolean, Double)
RDPCrystal EDI Library
Initializes a new instance of the ValidationEventsArgs class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationEventsArgs(
    bool passed,
    double milliseconds
)
Public Sub New ( _
    passed As Boolean, _
    milliseconds As Double _
)
public:
ValidationEventsArgs(
    bool passed,
    double milliseconds
)
Parameters
passed (Boolean)
milliseconds (Double)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Milliseconds Property

Milliseconds Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► Milliseconds
RDPCrystal EDI Library
Get the amount of time passed in milliseconds for the validation process
Declaration Syntax
C# Visual Basic Visual C++
public double Milliseconds { get; }
Public ReadOnly Property Milliseconds As Double
    Get
public:
property double Milliseconds {
    double get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Passed Property

Passed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► Passed
RDPCrystal EDI Library
Check whether a file was successfully validated
Declaration Syntax
C# Visual Basic Visual C++
public bool Passed { get; }
Public ReadOnly Property Passed As Boolean
    Get
public:
property bool Passed {
    bool get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidationException Class

ValidationException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationException
RDPCrystal EDI Library
An exception that represents an errors that occur while validation is taking place
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ValidationException : Exception
<SerializableAttribute> _
Public Class ValidationException _
    Inherits Exception
[SerializableAttribute]
public ref class ValidationException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ValidationException

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


WriteArguments Class

WriteArguments Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments
RDPCrystal EDI Library
Arguments to pass in for EDI file creation
Declaration Syntax
C# Visual Basic Visual C++
public class WriteArguments
Public Class WriteArguments
public ref class WriteArguments
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WriteArguments()()()() | Initializes a new instance of the WriteArguments class
 | AutoPlaceNumOfFunctionalGroups |
 | AutoPlaceNumOfSegments |
 | AutoPlaceNumOfTransactions |
 | Delimiters |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLineAfterSegment | Whether or not to insert a new line after every segment
 | NumberFunctionalGroupsCreated |
 | NumberInterchangeCreated |
 | NumberSegmentsCreated |
 | NumberTransactionsCreated |
 | PadISAElementValues |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Values |
Inheritance Hierarchy
Object
WriteArguments

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


WriteArguments Constructor

WriteArguments Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► WriteArguments()()()()
RDPCrystal EDI Library
Initializes a new instance of the WriteArguments class
Declaration Syntax
C# Visual Basic Visual C++
public WriteArguments()
Public Sub New
public:
WriteArguments()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceNumOfFunctionalGroups Field

AutoPlaceNumOfFunctionalGroups Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► AutoPlaceNumOfFunctionalGroups
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfFunctionalGroups
Public AutoPlaceNumOfFunctionalGroups As Boolean
public:
bool AutoPlaceNumOfFunctionalGroups

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceNumOfSegments Field

AutoPlaceNumOfSegments Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► AutoPlaceNumOfSegments
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfSegments
Public AutoPlaceNumOfSegments As Boolean
public:
bool AutoPlaceNumOfSegments

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AutoPlaceNumOfTransactions Field

AutoPlaceNumOfTransactions Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► AutoPlaceNumOfTransactions
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfTransactions
Public AutoPlaceNumOfTransactions As Boolean
public:
bool AutoPlaceNumOfTransactions

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Delimiters Field

Delimiters Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► Delimiters
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters
Public Delimiters As Delimiters
public:
Delimiters^ Delimiters

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NewLineAfterSegment Field

NewLineAfterSegment Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► NewLineAfterSegment
RDPCrystal EDI Library
Whether or not to insert a new line after every segment
Declaration Syntax
C# Visual Basic Visual C++
public bool NewLineAfterSegment
Public NewLineAfterSegment As Boolean
public:
bool NewLineAfterSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberFunctionalGroupsCreated Field

NumberFunctionalGroupsCreated Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► NumberFunctionalGroupsCreated
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int NumberFunctionalGroupsCreated
Public NumberFunctionalGroupsCreated As Integer
public:
int NumberFunctionalGroupsCreated

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberInterchangeCreated Field

NumberInterchangeCreated Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► NumberInterchangeCreated
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int NumberInterchangeCreated
Public NumberInterchangeCreated As Integer
public:
int NumberInterchangeCreated

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberSegmentsCreated Field

NumberSegmentsCreated Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► NumberSegmentsCreated
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int NumberSegmentsCreated
Public NumberSegmentsCreated As Integer
public:
int NumberSegmentsCreated

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NumberTransactionsCreated Field

NumberTransactionsCreated Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► NumberTransactionsCreated
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int NumberTransactionsCreated
Public NumberTransactionsCreated As Integer
public:
int NumberTransactionsCreated

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PadISAElementValues Field

PadISAElementValues Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► PadISAElementValues
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool PadISAElementValues
Public PadISAElementValues As Boolean
public:
bool PadISAElementValues

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► WriteArguments ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Values
Public Values As List(Of String)
public:
List<String^>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


XmlConfigOptions Class

XmlConfigOptions Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions
RDPCrystal EDI Library
Xml Configuration Options
Declaration Syntax
C# Visual Basic Visual C++
public class XmlConfigOptions
Public Class XmlConfigOptions
public ref class XmlConfigOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlConfigOptions()()()() | Initializes a new instance of the XmlConfigOptions class
 | CompositeElementNodeName | Gets or sets the name of the composite element node.
 | ElementNodeName | Gets or sets the name of the element node.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderNode |
 | Indent | Gets or sets a value indicating whether indentation occurs
 | LoopNodeName | Gets or sets the name of the loop node.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentNodeName | Gets or sets the name of the segment node.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlConfigOptions

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


XmlConfigOptions Constructor

XmlConfigOptions Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► XmlConfigOptions()()()()
RDPCrystal EDI Library
Initializes a new instance of the XmlConfigOptions class
Declaration Syntax
C# Visual Basic Visual C++
public XmlConfigOptions()
Public Sub New
public:
XmlConfigOptions()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementNodeName Property

CompositeElementNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► CompositeElementNodeName
RDPCrystal EDI Library
Gets or sets the name of the composite element node.
Declaration Syntax
C# Visual Basic Visual C++
public string CompositeElementNodeName { get; set; }
Public Property CompositeElementNodeName As String
    Get
    Set
public:
property String^ CompositeElementNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the composite element node.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNodeName Property

ElementNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► ElementNodeName
RDPCrystal EDI Library
Gets or sets the name of the element node.
Declaration Syntax
C# Visual Basic Visual C++
public string ElementNodeName { get; set; }
Public Property ElementNodeName As String
    Get
    Set
public:
property String^ ElementNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the element node.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


HeaderNode Property

HeaderNode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► HeaderNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string HeaderNode { get; set; }
Public Property HeaderNode As String
    Get
    Set
public:
property String^ HeaderNode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Indent Property

Indent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► Indent
RDPCrystal EDI Library
Gets or sets a value indicating whether indentation occurs
Declaration Syntax
C# Visual Basic Visual C++
public bool Indent { get; set; }
Public Property Indent As Boolean
    Get
    Set
public:
property bool Indent {
    bool get ();
    void set (bool value);
}
Value
true if indent; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LoopNodeName Property

LoopNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► LoopNodeName
RDPCrystal EDI Library
Gets or sets the name of the loop node.
Declaration Syntax
C# Visual Basic Visual C++
public string LoopNodeName { get; set; }
Public Property LoopNodeName As String
    Get
    Set
public:
property String^ LoopNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the loop node.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentNodeName Property

SegmentNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► SegmentNodeName
RDPCrystal EDI Library
Gets or sets the name of the segment node.
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentNodeName { get; set; }
Public Property SegmentNodeName As String
    Get
    Set
public:
property String^ SegmentNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the segment node.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RDPCrystalEDILibrary.Docs.x4010 Namespace

RDPCrystalEDILibrary.Docs.x4010 Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Docs.x4010
Namespace RDPCrystalEDILibrary.Docs.x4010
namespace RDPCrystalEDILibrary.Docs.x4010
Types
All Types Classes
Icon | Type | Description
 | AAA | Request Validation
 | ACD | Account Description
 | ACK | Line Item Acknowledgment
 | ACS | Ancillary Charges
 | ACT | Account Identification
 | ActionsIndicated | C002
 | AD1 | Adjustment Amount
 | ADI | Animal Disposition
 | ADJ | Adjustments to Balances or Services
 | AdjustmentIdentifier | C042
 | ADT | Animal Parturition Status
 | ADV | Advertising Demographic Information
 | ADX | Adjustment
 | AEI | Equipment Information Summary
 | AES | Automatic Equipment Identification Site Information
 | AIN | Income
 | AK1 | Functional Group Response Header
 | AK2 | Transaction Set Response Header
 | AK3 | Data Segment Note
 | AK4 | Data Element Note
 | AK5 | Transaction Set Response Trailer
 | AK9 | Functional Group Response Trailer
 | AM1 | Informational Values
 | AmountQualifyingDescription | C007 - Amount Qualifying Description
 | AMT | Monetary Amount
 | ANI | Animal Identification
 | AOC | Animal Offspring Counts
 | AOI | Animal Offspring/Fetus Identification
 | AOL | Animal Observation Location
 | AOR | Animal Observation Result
 | AP1 | Alternate Parts
 | API | Activity or Process Information
 | APR | Association of American Railroads Pool Code Restrictions
 | ARC | Animal Results Counts
 | ARS | Applicant Residence Specifics
 | ASI | Action or Status Indicator
 | ASL | Asset Liability
 | ASM | Amount and Settlement Method
 | ASO | Asset Ownership
 | AssuranceTokenParameters | C028
 | AST | Animal Reproductive Status
 | AT1 | Bill of Lading Line Item Number
 | AT2 | Bill of Lading Line Item Detail
 | AT3 | Bill of Lading Rates and Charges
 | AT4 | Bill of Lading Description
 | AT5 | Bill of Lading Handling Requirements
 | AT6 | International Manifest Information
 | AT7 | Shipment Status Details
 | AT8 | Shipment Weight, Packaging and Quantity Data
 | AT9 | Trailer or Container Dimension and Weight
 | ATA | Beginning Segment for Motor Carrier Delivery Trailer Manifest
 | ATH | Resource Authorization
 | ATN | Attendance
 | ATR | Animal Test Result
 | ATV | Student Activities and Awards
 | AVA | Funds Availability
 | AWD | Amount with Description
 | AXL | Vehicle Axle Measurements
 | B1 | Beginning Segment for Booking or Pick-up/Delivery
 | B10 | Beginning Segment for Transportation Carrier Shipment Status Message
 | B11 | Beginning Segment for Shipment Status Inquiry
 | B12 | Beginning Segment for Consolidation of Goods In Container
 | B13 | Beginning Segment for Appointment Schedule
 | B2 | Beginning Segment for Shipment Information Transaction
 | B2A | Set Purpose
 | B3 | Beginning Segment for Carrier’s Invoice
 | B3A | Invoice Type
 | B3B | Beginning Segment for Carrier’s Invoice
 | B4 | Beginning Segment for Inquiry or Reply
 | B5 | Beginning Segment for Acceptance/Rejection
 | B9 | Beginning Segment for Logistics Services
 | B9A | Service Request
 | BA1 | Export Shipment Identifying Information
 | BA2 | Beginning Segment for Cargo Terminal Information
 | BAA | Beginning Segment for Product Transfer Account Adjustment
 | BAK | Beginning Segment for Purchase Order Acknowledgment
 | BAL | Balance Detail
 | BAT | Batch
 | BAU | Beginning Segment for the Debit Authorization
 | BAX | Beginning Segment for Advance Consist and Transportation Automatic Equipment ID
 | BBC | Legal Claims
 | BC | Beginning Segment for Contract Completion Status
 | BCA | Beginning Segment for Purchase Order Change Acknowledgment
 | BCD | Beginning Credit/Debit Adjustment
 | BCH | Beginning Segment for Purchase Order Change
 | BCI | Basic Claim Information
 | BCM | Beginning Segment for Contractor Cost Data Reporting
 | BCO | Beginning Segment for Procurement Notices
 | BCP | Beginning Segment for Contract Pricing Proposal
 | BCQ | Beginning Segment for Shipper’s Car Order
 | BCS | Beginning Segment for Project Cost Reporting
 | BCT | Beginning Segment for Price/Sales Catalog
 | BCU | Legal Claim Updates
 | BDD | Beginning Segment for Shipment Delivery Discrepancy Information
 | BEG | Beginning Segment for Purchase Order
 | BEN | Beneficiary or Owner Information
 | BEP | Borrower Education Program
 | BFR | Beginning Segment for Planning Schedule
 | BFS | Borrower Financial Summary
 | BGF | Beginning Segment for File Transfer Information
 | BGN | Beginning Segment
 | BGP | Beginning Segment for Problem Log Inquiry or Advice
 | BHT | Beginning of Hierarchical Transaction
 | BIA | Beginning Segment for Inventory Inquiry/Advice
 | BIG | Beginning Segment for Invoice
 | BIN | Binary Data
 | BIX | Beginning Segment for Automotive Inspection
 | BJF | Beginning Segment Railroad Junctions and Interchanges Update Activity
 | BL | Billing Information
 | BLI | Baseline Item Data
 | BLN | Balance Information
 | BLR | Transportation Carrier Identification
 | BLS | Beginning Segment for Asset Schedule
 | BMA | Beginning Segment for Market Development Fund Allocation
 | BMG | Beginning Segment For Text Message
 | BMM | Beginning Segment for Multilevel Railcar Load Details Transaction
 | BMP | Beginning Segment for Market Development Fund Settlement
 | BMS | Beginning Segment For Material Safety Data Sheet
 | BNR | Beginning Segment For Nonconformance Report
 | BNX | Rail Shipment Information
 | BOL | Beginning Segment for the Motor Carrier Bill of Lading
 | BOR | Beginning of Report
 | BOS | Beginning Segment for the Operating Expense Statement
 | BOX | Box Office Detail
 | BPA | Beginning Segment for Price Authorization Acknowledgment/Status
 | BPP | Beginning Segment for Project Schedule Reporting
 | BPR | Beginning Segment for Payment Order/Remittance Advice
 | BPT | Beginning Segment for Product Transfer and Resale
 | BQR | Beginning Segment for Response to Request for Quotation
 | BQT | Beginning Segment for Request for Quotation
 | BR | Beginning Segment for Material Management
 | BRA | Beginning Segment for Receiving Advice or Acceptance Certificate
 | BRC |
 | BRR |
 | BSC | Beginning Segment for Commission Sales Report
 | BSD | Breakdown Structure Description
 | BSF | Business Function
 | BSI | Beginning Segment for Order Status Inquiry
 | BSN | Beginning Segment for Ship Notice
 | BSR | Beginning Segment for Order Status Report
 | BSS | Beginning Segment for Shipping Schedule/Production Sequence
 | BT1 | Batch Totals
 | BTA | Beginning Tax Acknowledgment
 | BTC | Beginning Segment for Parameter Trace Registration
 | BTI | Beginning Tax Information
 | BTP | Beginning Segment For Trading Partner Profile
 | BTR | Beginning Segment for Test Results
 | BTS | Beginning Segment for Train Sheets
 | BUY | Loan Buydown
 | BVA | Beginning Vehicle Advice
 | BVB | Beginning Segment for Vehicle Baying Order
 | BVP | Beginning Segment for Vehicle Shipping Order
 | BVS | Beginning Segment for Vehicle Service
 | BW | Beginning Segment for Weight Message Set
 | BX | General Shipment Information
 | C2 | Bank ID
 | C3 | Currency
 | C4 | Alternate Amount Due
 | C8 | Certifications and Clauses
 | C8C | Certifications Clauses Continuation
 | CA1 | Rate Request Identifier
 | CAD | Carrier Detail
 | CAI | Civil Action Income
 | CAL | Calendar
 | CAS | Claims Adjustment
 | CAT | Category of Patient Information Service
 | CB1 | Contract and Cost Accounting Standards Data
 | CBS | Cost Breakdown Structure
 | CCI | Credit Counseling Information
 | CD | Shipment Conditions
 | CD1 | Cargo Detail
 | CD2 | Multi-Valued Characteristics
 | CD3 | Carton (Package) Detail
 | CDA | Consumer Credit Account
 | CDD | Credit/Debit Adjustment Detail
 | CDI | Change Detail Information
 | CDS | Case Description
 | CED | Administration of Justice Event Description
 | CertificateLookupInformation | C050
 | CF1 | Beginning Segment for Summary Freight Bill Manifest
 | CF2 | Summary Freight Bill Detail
 | CFT | Cost Reporting Format Type
 | CGS | Charge
 | CHB | Chargeback Information
 | CHR | Car Hire Rates
 | CI | Carrier Interchange Agreement
 | CIC | Car Information Control
 | CID | Characteristic/Class ID
 | CIV | Civil Action Liability
 | CL | Class
 | CL1 | Claim Codes
 | CLD | Load Detail
 | CLI | Cost Line Item
 | CLM | Health Claim
 | CLP | Claim Level Data
 | CLR | Car Location Routing Request
 | CM | Cargo Manifest
 | CMA | Cooperative Market Agreement
 | CN1 | Contract Information
 | COB | Coordination of Benefits
 | COM | Communication Contact Information
 | CompositeDiagnosisCodePointer | C004
 | CompositeMedicalProcedureIdentifier | C003
 | CompositeQualifierIdentifier | C046
 | CompositeTypeOfRealEstateAssetCode | C047
 | CompositeUnitOfMeasure | C001
 | CompositeUseOfProceeds | C048
 | ComputationMethods | C034
 | CON | Contract Number Detail
 | ConditionsIndicated | C045
 | CPR | Commodity Price Reference
 | CR1 | Ambulance Certification
 | CR2 | Chiropractic Certification
 | CR3 | Durable Medical Equipment Certification
 | CR4 | Enteral or Parenteral Therapy Certification
 | CR5 | Oxygen Therapy Certification
 | CR6 | Home Health Care Certification
 | CR7 | Home Health Treatment Plan Certification
 | CR8 | Pacemaker Certification
 | CRC | Conditions Indicator
 | CRD | Content Reporting Detail
 | CRI | Claim Report Information
 | CRO | Credit Report Order Details
 | CRS | Course Record
 | CRT | Contractor Report Type
 | CRV | Product Origin Reference
 | CS | Contract Summary
 | CSB | Cryptographic Service Message Body
 | CSC | Cryptographic Service Message Certificates and Keys
 | CSD | Consolidated Shipment Invoice Data
 | CSE | Educational Course Information
 | CSF | Conditional Sampling Frequency
 | CSH | Sales Requirements
 | CSI | Claim Status Information
 | CSM | Cryptographic Service Message Header
 | CSS | Conditional Sampling Sequence
 | CST | Cost Analysis
 | CSU | Supplemental Course Data
 | CT | Car Type
 | CTB | Restrictions/Conditions
 | CTC | Car Hire Transaction Control
 | CTP | Pricing Information
 | CTT | Transaction Totals
 | CUR | Currency
 | CV | Cycle/Summary Value
 | CYC | Car Hire Cycle
 | D9 | Destination Station
 | DAD | Debit Authorization Detail
 | DAI | Appendix Information
 | DAM | Damage Information
 | DB | Disbursement Information
 | DD | Demand Detail
 | DDI | Description
 | DED | Deductions
 | DEF | Delayed Repayment
 | DEG | Degree Record
 | DEL | Delivery
 | DEP | Deposit
 | DEX | Delivery Execution Information
 | DFI | Default Information
 | DH | Dealer Hours
 | DIS | Discount Detail
 | DK | Docket Header
 | DL | Auto Claim Detail - Labor
 | DLV | Deliverable Information
 | DM | Demurrage/Detention/ Storage Rate
 | DMA | Additional Demographic Information
 | DMG | Demographic Information
 | DMI | Data Maintenance Information
 | DN | Dealer Effectivity
 | DN1 | Orthodontic Information
 | DN2 | Tooth Summary
 | DOS | Definition of Share
 | DP | Auto Claim Detail - Parts
 | DPN | Dependent Information
 | DR | Docket Range
 | DRT | Deprescription Rate Detail
 | DSB | Disability Information
 | DTM | Date/Time Reference
 | DTP | Date or Time or Period
 | DVI | Dynamic Vehicle Information
 | E01 | Electronic Form Main Heading
 | E03 | Interchange Order of Segments
 | E1 | Empty Car Disposition - Pended Destination Consignee
 | E10 | Transaction Set Grouping
 | E13 | Segment Order in Transaction Set
 | E20 | Segment Header Information
 | E22 | Data Element Relationships in a Segment
 | E24 | Data Element Sequence in a Segment
 | E26 | Element Sequence in Composite
 | E30 | Data Element Attributes
 | E34 | Code List Values for a Data Element
 | E4 | Empty Car Disposition - Pended Destination City
 | E40 | EDI Standards Note Reference
 | E5 | Empty Car Disposition - Pended Destination Route
 | E6 | Advance Car Disposition
 | E8 | Blocking and Response Information
 | EA | Equipment Attributes
 | EB | Eligibility or Benefit Information
 | EC | Employment Class
 | ED | Equipment Description
 | EFI | Electronic Format Identification
 | EI | Automatic Equipmen Identification
 | EIA | Beginning Segment for Equipment Inquiry or Advice
 | EM | Equipment Characteristics
 | EMP | Employer
 | EMS | Employment Position
 | EMT | Employment
 | EncryptionKeyInformation | C031
 | EncryptionServiceInformation | C032
 | ENE | Electronic Systems Environment
 | ENR | School Enrollment Information
 | ENT | Entity
 | EQ | Eligibility or Benefit Inquiry
 | ER | Rail Event Reporting
 | ERI | Entity Relationship
 | ERP | Educational Record Purpose
 | ES | Equipment Status
 | ESI | Employment Status Information
 | ETD | Excess Transportation Detail
 | EXI | Excavation Ticket Information
 | F01 | Identification of Claim (Claimant Originated)
 | F02 | Identification of Shipment
 | F04 | Weight/Volume Loss
 | F05 | Allowance/Charge (Claim)
 | F07 | Auto Claim Detail
 | F09 | Detail - Supporting Evidence for Claim
 | F10 | Identification of Claim (Tracer)
 | F11 | Status
 | F12 | Basic Claim Information - Automotive
 | F13 | Payment Information
 | F14 | Line Item Reject
 | F6X | Identification (Automotive)
 | F9 | Origin Station
 | FA1 | Type of Financial Accounting Data
 | FA2 | Accounting Data
 | FAA | Financial Asset Account
 | FAC | Facing Direction
 | FBB | Foreign and Industry Business
 | FC | Financial Contribution
 | FCL | Foreclosure
 | FDA | Facility Description
 | FG | Docket Group Terminator
 | FGS | Form Group
 | FH | Family History
 | FIR | Financial Information
 | FIS | Mortgage Loan Fiscal Data
 | FK | Factor
 | FNA | Financial Status Information
 | FOB | F.O.B. Related Instructions
 | FOS | Field of Study
 | FPT | Financial Participation
 | FSA | Flexible Spending Account
 | FST | Forecast Schedule
 | FTH | First Time Home Buyer
 | G01 | Invoice Identification
 | G05 | Total Shipment Information
 | G07 | Carrier Information
 | G08 | Pallet Information
 | G1 | Shipment Type Information
 | G11 | Coupon Reporting Specifications
 | G12 | Coupon Physical Characteristics
 | G13 | Store Size Attributes
 | G14 | Coupon Special Processing
 | G15 | Coupon Distribution
 | G17 | Item Detail - Invoice
 | G18 | Store Category Size
 | G19 | Line Item Detail - Quantity/Unit of Measure/Price Differences
 | G2 | Beyond Routing
 | G20 | Item Packing Detail
 | G21 | Product Information
 | G22 | Pricing Information
 | G23 | Terms of Sale
 | G24 | Promotion Reference
 | G25 | F.O.B. Information
 | G26 | Pricing Conditions
 | G27 | Carrier Detail
 | G28 | Line Item Numbers
 | G29 | Store Display Information
 | G3 | Compensation Information
 | G30 | Retail Account Marketing Types
 | G31 | Total Invoice Quantity
 | G32 | Survey Question Response
 | G33 | Total Dollars Summary
 | G35 | Advertising Feature Information
 | G36 | Price List Reference
 | G37 | Labor Activity
 | G38 | Claim Payment Information
 | G39 | Item Characteristics - Vendor’s Selling Unit
 | G4 | Scale Identification
 | G40 | Bracket Price
 | G42 | Promotion Announcement Identification
 | G43 | Promotion/Price List Area
 | G45 | Line Item Detail - Promotion
 | G46 | Promotion Allowance/Charge
 | G47 | Statement Identification
 | G48 | Statement/Invoice Identification
 | G49 | Statement Total
 | G5 | Weight Information
 | G50 | Purchase Order Identification
 | G51 | Free Goods/Product Condition
 | G53 | Maintenance Type
 | G54 | Module Description
 | G55 | Item Characteristics - Consumer Unit
 | G61 | Contact
 | G62 | Date/Time
 | G63 | Period
 | G66 | Transportation Instructions
 | G68 | Line Item Detail - Product
 | G69 | Line Item Detail - Description
 | G70 | Line Item Detail - Miscellaneous
 | G72 | Allowance or Charge
 | G73 | Allowance or Charge Description
 | G76 | Total Purchase Order
 | G82 | Delivery/Return Base Record Identifier
 | G83 | Line Item Detail/Direct Store Delivery
 | G84 | Delivery/Return Record of Totals
 | G85 | Record Integrity Check
 | G86 | Signature
 | G87 | Delivery/Return Adjustment Identification
 | G88 | Delivery/Return Identification Adjustment
 | G89 | Line-Item Detail Adjustment
 | G91 | Price Change Status
 | G92 | Purchase Order Change Type
 | G93 | Price Bracket Identification
 | G94 | Promotion Conditions
 | G95 | Performance Requirements
 | GA | Canadian Grain Information
 | GDP | General Dosing Parameters
 | GE | Functional Group Trailer
 | GF | Furnished Goods and Services
 | GH | Group Header
 | GID | Group Identification
 | GR | Guarantee Result Detail
 | GR2 | Train Data
 | GR4 | Loading Cluster
 | GR5 | Loading Details
 | GRI | Statistical Government Information
 | GRP | Group Dosage Parameters
 | GS | Functional Group Header
 | GY | Geography
 | H1 | Hazardous Material
 | H2 | Additional Hazardous Material Description
 | H3 | Special Handling Instructions
 | H5 | Car Service Order
 | H6 | Special Services
 | HC | Health Condition
 | HCP | Health Care Pricing
 | HCR | Health Care Services Review
 | HD | Health Coverage
 | HealthCareClaimStatus | C043
 | HealthCareCodeInformation | C022
 | HealthCareServiceLocationInformation | C023
 | HI | Health Care Information Codes
 | HL | Hierarchical Level
 | HLH | Health Information
 | HS | Health Screening
 | HSD | Health Care Services Delivery
 | IA | Interconnect Mailbag Acknowledgment
 | IC | Intermodal Chassis Equipment
 | ICH | Individual Characteristics
 | ICM | Individual Income
 | ID | Inspection Detail Segment
 | ID1 | Item Detail Dimensions
 | ID2 | Item Image Detail
 | ID3 | Dimensions Detail
 | ID4 | Load Details
 | IDB | Indebtedness for Student Loans
 | IDC | Identification Card
 | IEA | Interchange Control Trailer
 | IGI | Insurer or Guarantor Information
 | IH | Interconnect Mailbag Header
 | III | Information
 | IIS | Interchange Identification Segment
 | IM | Intermodal Movement Information
 | IMA | Interchange Move Authority
 | IMM | Immunization Status Code
 | IMP | Impairment Detail
 | IN1 | Individual Identification
 | IN2 | Individual Name Structure Components
 | INC | Installment Information
 | IND | Additional Individual Demographic Information
 | IndexIdentification | C036
 | INQ | Credit Inquiry Details
 | INR | Information Request
 | INS | Insured Benefit
 | INT | Interest
 | INV | Investment Vehicle Selection
 | INX | Index Detail
 | IRA | Investor Reporting Action Code
 | IRP | Report Selection Segment
 | IS1 | Estimated Time of Arrival and Car Scheduling
 | IS2 | Scheduled Events
 | ISA | Interchange Control Header
 | ISB | Grade of Service Request Segment
 | ISC | Interline Service Commitment Detail
 | ISD | Railroad Interline Service Definition Detail
 | ISE | Deferred Delivery Request Segment
 | ISR | Item Status Report
 | ISS | Invoice Shipment Summary
 | IT | Interconnect Mailbag Trailer
 | IT1 | Baseline Item Data (Invoice)
 | IT3 | Additional Item Data
 | IT8 | Conditions of Sale
 | ITA | Allowance, Charge or Service
 | ITC | Information Type and Comment Results
 | ITD | Terms of Sale/Deferred Terms of Sale
 | IV1 | Lane Estimates
 | JCT | Railroad Junction Information
 | JID | Equipment Detail
 | JIL | Line Item Detail for the Operating Expense Statement
 | JIT | Just-In-Time Schedule
 | JL | Journal Identification
 | JS | Rail Junction Settlement Role Information
 | K1 | Remarks
 | K2 | Administrative Message
 | K3 | File Information
 | L0 | Line Item - Quantity and Weight
 | L1 | Rate and Charges
 | L10 | Weight
 | L11 | Business Instructions and Reference Number
 | L12 | Alternate Lading Description
 | L13 | Commodity Details
 | L1A | Billing Identification
 | L3 | Total Weight and Charges
 | L4 | Measurement
 | L5 | Description, Marks and Numbers
 | L7 | Tariff Reference
 | L7A | Contract Reference Identifier
 | L8 | Line Item Subtotal
 | L9 | Charge Detail
 | LAD | Lading Detail
 | LC | Life Coverage
 | LC1 | Lane Commitments
 | LCD | Place/Location Description
 | LCT | Logistics Container Tracking Information
 | LDT | Lead Time
 | LE | Loop Trailer
 | LEP | EPA Required Data
 | LEQ | Leased Equipment Information
 | LET | Load and Equipment Type
 | LFG | Hazardous Information, Finished Goods
 | LFH | Freeform Hazardous Material Information
 | LFI | Beginning Segment for Locomotive Information
 | LH | Mixed Hazardous Commodities
 | LH1 | Hazardous Identification Information
 | LH2 | Hazardous Classification Information
 | LH3 | Hazardous Material Shipping Name
 | LH4 | Canadian Dangerous Requirements
 | LH6 | Hazardous Certification
 | LHE | Empty Equipment Hazardous Material Information
 | LHR | Hazardous Material Identifying Reference Numbers
 | LHT | Transborder Hazardous Requirements
 | LIC | License Information
 | LID | Loss Information Description
 | LIE | Individual or Event Location
 | LIN | Item Identification
 | LM | Code Source Information
 | LN | Loan Information
 | LN1 | Loan Specific Data
 | LN2 | Existing Real Estate Loan Specific Data
 | LOC | Location
 | LOD | Location Description
 | LP | Load Planning
 | LQ | Industry Code
 | LRQ | Mortgage Characteristics Requested
 | LS | Loop Header
 | LS1 | Asset Item Identification
 | LT | Letter of Recommendation
 | LTE | Letter of Recommendation Evaluation
 | LTR | Laboratory Test Results
 | LUC | Loan Underwriting
 | LUI | Language Use
 | LV | Loan Verification
 | LX | Assigned Number
 | M0 | Assigned Number
 | M1 | Insurance
 | M10 | Manifest Identifying Information
 | M11 | Manifest Bill of Lading Details
 | M12 | In-bond Identifying Information
 | M13 | Manifest Amendment Details
 | M14 | General Order Status Information
 | M15 | U.S. Customs Events Advisory Details
 | M2 | Sales/Delivery Terms
 | M20 | Permit to Transfer Request Details
 | M21 | Supplementary In-Bond Information
 | M3 | Release
 | M7 | Seal Numbers
 | M7A | Seal Number Replacement
 | MAN | Marks and Numbers
 | MBL | Bill of Lading
 | MC | Miscellaneous and Accessorial Charges
 | MCD | Mortgage Closing Data
 | MCT | Tariff Accessorial Charges
 | MEA | Measurements
 | MedicareStatusCode |
 | MI | Media Information
 | MI1 | Mileage Source
 | MIA | Medicare Inpatient Adjudication
 | MIC | Mortgage Insurance Coverage
 | MII | Mortgage Insurance Information
 | MIN | Minimum Detail
 | MIR | Mortgage Insurance Response
 | MIS | Mortgagee Information Status
 | MIT | Message Identification
 | MKS | Marks Awarded
 | MLS | Milestone
 | MNC | Mortgage Note Characteristics
 | MOA | Medicare Outpatient Adjudication
 | MPI | Military Personnel Information
 | MPP | Mortgage Pool Program
 | MRC | Mortgagor Response Characteristics
 | MS | Miscellaneous Services
 | MS1 | Equipment, Shipment, or Real Property Location
 | MS2 | Equipment or Container Owner and Type
 | MS3 | Interline Information
 | MS4 | Shipment or Package Dimensions
 | MS5 | Shipment Rates and Charges
 | MS6 | Shipment Quantity and Weight
 | MSG | Message Text
 | MSS | Material Safety Data Sheet Section Information
 | MTX | Text
 | N1 | Name
 | N10 | Quantity and Description
 | N11 | Store Number
 | N12 | Equipment Environment
 | N2 | Additional Name Information
 | N3 | Address Information
 | N4 | Geographic Location
 | N5 | Equipment Ordered
 | N7 | Equipment Details
 | N7A | Accessorial Equipment Details
 | N7B | Additional Equipment Details
 | N8 | Waybill Reference
 | N8A | Additional Reference Information
 | N9 | Reference Identification
 | NA | Cross-Reference Equipment
 | NCA | Nonconformance Action
 | NCD | Nonconformance Description
 | NM1 | Individual or Organizational Name
 | NTE | Note/Special Instruction
 | NX1 | Property or Entity Identification
 | NX2 | Location ID Component
 | OBI | Obligation Information
 | OD | Origin and Destination
 | OI | Other Health Insurance Information
 | OID | Order Identification Detail
 | OP | Other Programs and Services
 | OPS | Program Subject Area and Eligibility
 | OPX | Placement Criteria
 | OQS | Order Quantity Sequence
 | OralCavityDesignation |
 | OTI | Original Transaction Identification
 | P1 | Pick-up
 | P2 | Delivery
 | P4 | U.S. Port Information
 | P5 | Port Information
 | PAD | Product Adjustment Detail
 | PAI | Print Advertisement Information
 | PAL | Pallet Information
 | PAM | Period Amount
 | PAS | Property Appraisal Summary
 | PAT | Patient Information
 | PAY | Adjustable Payment Description
 | PBI | Problem Identification
 | PCL | Previous College
 | PCR | Payment Cancellation Request
 | PCS | Product Claim Status
 | PCT | Percent Amounts
 | PD | Pricing Data
 | PDD | Pricing Data Detail
 | PDE | Property Metes and Bounds Description
 | PDL | Payment Details
 | PDP | Property Description - Personal
 | PDR | Property Description - Real
 | PDS | Property Description/Legal Description
 | PEN | Pension Information
 | PER | Administrative Communications Contact
 | PEX | Property or Housing Expense
 | PI | Price Authority Identification
 | PID | Product/Item Description
 | PIN | Previous Incident
 | PKD | Packaging Description
 | PKG | Marking, Packaging, Loading
 | PKL | Multi-Pack Configuration
 | PL | Proposal Cost Logic
 | PLA | Place or Location
 | PLB | Provider Level Adjustment
 | PLC | Equipment Placement Information
 | PLD | Pallet Information
 | PLI | Previous Loan Information
 | PM | Electronic Funds Transfer Information
 | PO1 | Baseline Item Data
 | PO3 | Additional Item Detail
 | PO4 | Item Physical Details
 | POC | Line Item Change
 | POD | Proof of Delivery
 | PositionInSegment | C030
 | PPA | Property Location
 | PPD | Payment Pattern Details
 | PPL | Price Support Data
 | PPY | Personal Property Description
 | PR | Product (Commodity)
 | PR1 | Price Request Parameter List 1
 | PR2 | Price Request Parameter List 2
 | PRC | Payment Rate Change
 | PRD | Mortgage Loan Product Description
 | PRF | Purchase Order Reference
 | PRI | External Reference Identifier
 | PRJ | Multifamily Housing Project
 | PRM | Basic Trace Parameters
 | ProviderSpecialtyInformation | C035
 | PRR | Problem Report
 | PRS | Part Release Status
 | PRT | Part Disposition
 | PRV | Provider Information
 | PS | Protective Service Instructions
 | PS1 | Purchase Service
 | PSA | Partner Share Accounting
 | PSC | Product Service Contract
 | PSD | Physical Sample Description
 | PT | Patron
 | PTD | Product Transfer and Resale Detail
 | PTF | Property Transaction Financials
 | PUN | Beginning Segment for Motor Carrier Pick-up Notification
 | PWK | Paperwork
 | PYD | Payroll Deduction
 | PYM | Payment Manner and Percentage
 | PYT | Historical Payment Terms
 | Q2 | Status Details (Ocean)
 | Q3 | Arrival Details
 | Q5 | Status Details
 | Q6 | Shipment Details
 | Q7 | Lading Exception Code
 | Q8 | Detail Delivery Exception Information
 | QTY | Quantity
 | R1 | Route Information (Air)
 | R2 | Route Information
 | R2A | Route Information with Preference
 | R2B | Junctions and Proportions
 | R2C | Division Basis
 | R2D | Miscellaneous Charge
 | R3 | Route Information - Motor
 | R4 | Port or Terminal
 | R9 | Route Code
 | RA | Rate Header
 | RAB | Rate or Minimum Qualifiers
 | RAP | Requirement, Attribute, and Proficiency
 | RAT | Adjustable Rate Description
 | RB | Rate/Minimum Detail
 | RC | Root Cause
 | RCD | Receiving Conditions
 | RD | Rate Data
 | RDD | Route Description Detail
 | RDI | Retail Account Demographic Information
 | RDM | Remittance Delivery Method
 | RDR | Return Disposition Reason
 | RDT | Revision Date/Time
 | RE | Rebill At Interchange
 | REA | Real Estate Property Information
 | REC | Real Estate Condition
 | RED | Related Data
 | REF | Reference Identification
 | ReferenceIdentifier | C040
 | REL | Relationship
 | RelatedCausesInformation | C024
 | REN | Rate Request Information
 | REP | Repair Action
 | REQ | Request Information
 | RET | Real Estate Transaction
 | RH | Personal Property Rate
 | RIC | Financial Return
 | RLD | Down Payment Data
 | RLT | Real Estate Loan Type
 | RMR | Remittance Advice Accounts Receivable Open Item Reference
 | RMT | Remittance Advice
 | RO | Public Record or Obligation
 | RP | Retirement Product
 | RPA | Rate Amounts or Percents
 | RQS | Request for Information
 | RRA | Required Response
 | RS | Rate Subset
 | RSC | Resource
 | RSD | Residency Information
 | RST | Carrier Restriction
 | RT | Rate Destination
 | RT1 | Rate Detail
 | RTE | Rate Information
 | RTS | Tariff Rates
 | RTT | Freight Rate
 | RU1 | Retirement Board Detail
 | RU2 | Employing Carrier Response
 | RU3 | Employing Carrier Claim Profile
 | RYL | Royalty Payment
 | S1 | Stop-off Name
 | S1A | Assurance Level 1
 | S1E | Security Trailer Level 1
 | S1S | Security Header Level 1
 | S2 | Stop-off Address
 | S2A | Assurance Level 2
 | S2E | Security Trailer Level 2
 | S2S | Security Header Level 2
 | S3A | Assurance Header Level 1
 | S3E | Security Trailer Level 1
 | S3S | Security Header Level 1
 | S4A | Assurance Header Level 2
 | S4E | Security Trailer Level 2
 | S4S | Security Header Level 2
 | S5 | Stop Off Details
 | S9 | Stop-off Station
 | SA | Status Action
 | SAC | Service, Promotion, Allowance, or Charge Information
 | SAL | Salary Information
 | SB | Docket Level
 | SBR | Subscriber Information
 | SBT | Subtest
 | SC | Docket Sub-level
 | SCA | Statistical Category Analysis
 | SCD | Sales Commission Employee Detail
 | SCH | Line Item Schedule
 | SCL | Rate Basis/Scales
 | SCM | Credit Score Model
 | SCN | Beginning Segment for Cartage Work Assignment
 | SCO | Shipper’s Car Ordered
 | SCP | Beginning Segment for a Cartage Work Assignment Response
 | SCS | Credit Score
 | SCT | School Type
 | SD1 | Safety Data
 | SDP | Ship/Delivery Pattern
 | SDQ | Destination Quantity
 | SE | Transaction Set Trailer
 | SecurityValue | C033
 | SER | Service Charges
 | SES | Academic Session Header
 | SFC | Storage Facility Characteristics
 | SG | Shipment Status
 | SHD | Shipment Detail
 | SHP | Shipped/Received Information
 | SHR | Railroad Interline Service Special Handling Restrictions
 | SI | Service Characteristic Identification
 | SID | Standard Transportation Commodity Code Identification
 | SII | Sales Item Information
 | SIN | Substance Use
 | SL1 | Tariff Reference
 | SLI | Specific Loan Information
 | SLN | Subline Item Detail
 | SMA | Station Address
 | SMB | Beginning Segment for Railroad Station Master File
 | SMD | Consolidated Shipment Manifest Data
 | SMO | Operational Services
 | SMR | Cross Reference
 | SMS | Station Codes Segment
 | SN1 | Item Detail (Shipment)
 | SOI | Source of Income
 | SOM | Status of Mortgage
 | SP | Special Program
 | SPA | Status of Product or Activity
 | SPI | Specification Identifier
 | SPK | Specimen Kit Information
 | SPO | Shipment Purchase Order Detail
 | SPR | Supplier Rating
 | SPS | Sampling Parameters for Summary Statistics
 | SPY | Scope of Power of Attorney
 | SR | Requested Service Schedule
 | SRA | Traffic Evaluation Factors
 | SRD | Scale Rate Detail
 | SRE | Test Scores
 | SRM | Scale Rates
 | SRT | Scale Rate Header
 | SS | Docket Control Status
 | SSC | Beginning Segment for Service Commitment Advice
 | SSD | Shipment Sort Segregate Data
 | SSE | Entry and Exit Information
 | SSS | Special Services
 | SST | Student Academic Status
 | ST | Transaction Set Header
 | STA | Statistics
 | STC | Status Information
 | STP | Study Parameters
 | STS | Interchange Status Segment
 | SUM | Academic Summary
 | SUP | Supplementary Information
 | SV | Service Description
 | SV1 | Professional Service
 | SV2 | Institutional Service
 | SV3 | Dental Service
 | SV4 | Drug Service
 | SV5 | Durable Medical Equipment Service
 | SV6 | Anesthesia Service
 | SV7 | Drug Adjudication
 | SVA | Security Value
 | SVC | Service Information
 | SVD | Service Line Adjudication
 | SW | Switching Charges
 | T1 | Transit Inbound Origin
 | T2 | Transit Inbound Lading
 | T3 | Transit Inbound Route
 | T6 | Transit Inbound Rates
 | T8 | Free-form Transit Data
 | TA1 | Interchange Acknowledgment
 | TA3 | Interchange Delivery Notice Segment
 | TAX | Tax Reference
 | TaxFieldIdentification | C037
 | TBA | Temporary Buydown Adjustment
 | TBI | Trade Line Bureau Identifier
 | TC2 | Commodity
 | TCD | Itemized Call Detail
 | TD1 | Carrier Details (Quantity and Weight)
 | TD3 | Carrier Details (Equipment)
 | TD4 | Carrier Details (Special Handling, or Hazardous Materials, or Both)
 | TD5 | Carrier Details (Routing Sequence/Transit Time)
 | TDS | Total Monetary Value Summary
 | TED | Technical Error Description
 | TEM | Pick-up Totals
 | TER | Territory
 | TF | Tariff Information
 | TFA | Tariff Adjustments
 | TFD | Tariff Adjustments Minimum Charge
 | TFM | Tariff Minimum Rates
 | TFR | Tariff Restrictions
 | TFS | Tax Form
 | THE | Screen Theater Identification
 | TI | Transport Information
 | TIA | Tax Information and Amount
 | TID | Task Identification
 | TIS | Title Insurance Services
 | TLN | Tradeline
 | TMD | Test Method
 | TOA | Type of Activity
 | TOO | Tooth Identification
 | ToothSurface | C005
 | TOV | Vehicle Use Information
 | TPB | Business Professional Title
 | TPD | Trading Partner Detail
 | TRF | Rating Factors
 | TRN | Trace
 | TRS | Tax Rate
 | TS | Tariff Section
 | TS2 | Transaction Supplemental Statistics
 | TS3 | Transaction Statistics
 | TSD | Trailer Shipment Details
 | TSI | Automatic Equipment Tag Status Information
 | TSP | Test Period or Interval
 | TST | Test Score Record
 | TSU | Transaction Summary
 | TT | Term Text
 | TUD | Trade Union Data
 | TXI | Tax Information
 | TXN | Transaction Capabilities
 | TXP | Tax Payment
 | Typed4010Document | Represents an X12 4010 Document
 | UC | Underwriting Category
 | UCS | Underwriting Considerations
 | UD | Underwriting Status
 | UDA | Underwriting Condition
 | UIT | Unit Detail
 | UM | Health Care Services Review Information
 | UQS | Underwriting Question
 | UR | Peer Review Organization or Utilization Review
 | USD | Usage-Sensitive Detail
 | UWI | Underwriting Information
 | V1 | Vessel Identification
 | V2 | Vessel Information
 | V3 | Vessel Schedule
 | V4 | Cargo Location Reference
 | V5 | Vessel Code
 | V9 | Event Detail
 | VAD | Vehicle Advice Detail
 | VAR | Credit File Variation
 | VAT | Vehicle Attribute
 | VC | Motor Vehicle Control
 | VC1 | Vehicle Detail
 | VDI | Value Description or Information
 | VEH | Vehicle Information
 | VID | Conveyance Identification
 | VR | Rate Origin
 | VRC |
 | W01 | Line Item Detail - Warehouse
 | W03 | Total Shipment Information
 | W04 | Item Detail Total
 | W05 | Shipping Order Identification
 | W06 | Warehouse Shipment Identification
 | W07 | Item Detail For Stock Receipt
 | W08 | Receipt Carrier Information
 | W09 | Equipment and Temperature
 | W1 | Block Identification
 | W10 | Warehouse Additional Carrier Information
 | W12 | Warehouse Item Detail
 | W13 | Item Detail Exception
 | W14 | Total Receipt Information
 | W15 | Warehouse Adjustment Identification
 | W17 | Warehouse Receipt Identification
 | W18 | Probe Temperatures
 | W19 | Warehouse Adjustment Item Detail
 | W2 | Equipment Identification
 | W20 | Line-Item Detail - Miscellaneous
 | W27 | Carrier Detail
 | W28 | Consolidation Information
 | W3 | Consignee Information
 | W4 | Consignor Information
 | W5 | Route Information
 | W6 | Special Handling Information
 | W66 | Warehouse Carrier Information
 | W76 | Total Shipping Order
 | WGP | Tariff Weight Group
 | WS | Work Schedule
 | X01 | Automated Manifest Archive Status Details
 | X02 | Automated Manifest Bills Eligible/Overdue Archive Details
 | X1 | Export License
 | X2 | Import License
 | X4 | Customs Release Information
 | X7 | Customs Information
 | XD | Placement/Pull Data
 | XH | Pro Forma - B13 Information
 | XPO | Preassigned Purchase Order Numbers
 | XQ | Reporting Date/Action
 | Y1 | Space Reservation Request
 | Y2 | Container Details
 | Y3 | Space Confirmation
 | Y4 | Container Release
 | Y5 | Space Booking Cancellation
 | Y6 | Authentication
 | Y7 | Priority
 | YNQ | Yes/No Question
 | ZA | Product Activity Reporting
 | ZC1 | Beginning Segment For Data Correction Or Change
 | ZD | Transaction Set Deletion - ID, Reason, and Source
 | ZR | Waybill Reference Identification
 | ZT | Waybill Request Information


AAA Class

AAA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA
RDPCrystal EDI Library
Request Validation
Declaration Syntax
C# Visual Basic Visual C++
public class AAA : DocumentSegment
Public Class AAA _
    Inherits DocumentSegment
public ref class AAA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AAA()()()() | Initializes a new instance of the AAA class
 | AgencyQualifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FollowupActionCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RejectReasonCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AAA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x4010 (Module: RDPCrystalEDILibrary.Docs.x4010) Version: 9.6.0.0 (9.6.0.0)


AAA Constructor

AAA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► AAA()()()()
RDPCrystal EDI Library
Initializes a new instance of the AAA class
Declaration Syntax
C# Visual Basic Visual C++
public AAA()
Public Sub New
public:
AAA()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► AgencyQualifierCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


FollowupActionCode Property

FollowupActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► FollowupActionCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string FollowupActionCode { get; set; }
Public Property FollowupActionCode As String
    Get
    Set
public:
property String^ FollowupActionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► RejectReasonCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AAA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


ACD Class

ACD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD
RDPCrystal EDI Library
Account Description
Declaration Syntax
C# Visual Basic Visual C++
public class ACD : DocumentSegment
Public Class ACD _
    Inherits DocumentSegment
public ref class ACD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ACD()()()() | Initializes a new instance of the ACD class
 | AccountRelationshipCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanTypeCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RatingRemarksCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ACD


ACD Constructor

ACD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD ► ACD()()()()
RDPCrystal EDI Library
Initializes a new instance of the ACD class
Declaration Syntax
C# Visual Basic Visual C++
public ACD()
Public Sub New
public:
ACD()


AccountRelationshipCode Property

AccountRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD ► AccountRelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountRelationshipCode { get; set; }
Public Property AccountRelationshipCode As String
    Get
    Set
public:
property String^ AccountRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD ► LoanTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


RatingRemarksCode Property

RatingRemarksCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD ► RatingRemarksCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RatingRemarksCode { get; set; }
Public Property RatingRemarksCode As String
    Get
    Set
public:
property String^ RatingRemarksCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ACK Class

ACK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK
RDPCrystal EDI Library
Line Item Acknowledgment
Declaration Syntax
C# Visual Basic Visual C++
public class ACK : DocumentSegment
Public Class ACK _
    Inherits DocumentSegment
public ref class ACK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ACK()()()() | Initializes a new instance of the ACK class
 | AgencyQualifierCode | Element 27
 | Date | Element 5
 | DateTimeQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 29
 | LineItemStatusCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 8
 | ProductServiceID1 | Element 10
 | ProductServiceID2 | Element 12
 | ProductServiceID3 | Element 14
 | ProductServiceID4 | Element 16
 | ProductServiceID5 | Element 18
 | ProductServiceID6 | Element 20
 | ProductServiceID7 | Element 22
 | ProductServiceID8 | Element 24
 | ProductServiceID9 | Element 26
 | ProductServiceIDQualifier | Element 7
 | ProductServiceIDQualifier1 | Element 9
 | ProductServiceIDQualifier2 | Element 11
 | ProductServiceIDQualifier3 | Element 13
 | ProductServiceIDQualifier4 | Element 15
 | ProductServiceIDQualifier5 | Element 17
 | ProductServiceIDQualifier6 | Element 19
 | ProductServiceIDQualifier7 | Element 21
 | ProductServiceIDQualifier8 | Element 23
 | ProductServiceIDQualifier9 | Element 25
 | Quantity | Element 2
 | RequestReferenceNumber | Element 6
 | SourceSubqualifier | Element 28
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ACK


ACK Constructor

ACK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ACK()()()()
RDPCrystal EDI Library
Initializes a new instance of the ACK class
Declaration Syntax
C# Visual Basic Visual C++
public ACK()
Public Sub New
public:
ACK()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► AgencyQualifierCode
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► DateTimeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► IndustryCode
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


LineItemStatusCode Property

LineItemStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► LineItemStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LineItemStatusCode { get; set; }
Public Property LineItemStatusCode As String
    Get
    Set
public:
property String^ LineItemStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID5
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID6
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID7
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID8
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceID9
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RequestReferenceNumber Property

RequestReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► RequestReferenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RequestReferenceNumber { get; set; }
Public Property RequestReferenceNumber As String
    Get
    Set
public:
property String^ RequestReferenceNumber {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► SourceSubqualifier
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ACS Class

ACS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS
RDPCrystal EDI Library
Ancillary Charges
Declaration Syntax
C# Visual Basic Visual C++
public class ACS : DocumentSegment
Public Class ACS _
    Inherits DocumentSegment
public ref class ACS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ACS()()()() | Initializes a new instance of the ACS class
 | Amount | Element 1
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentMethodOfPayment | Element 4
 | SpecialChargeOrAllowanceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ACS


ACS Constructor

ACS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► ACS()()()()
RDPCrystal EDI Library
Initializes a new instance of the ACS class
Declaration Syntax
C# Visual Basic Visual C++
public ACS()
Public Sub New
public:
ACS()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► Amount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ACT Class

ACT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT
RDPCrystal EDI Library
Account Identification
Declaration Syntax
C# Visual Basic Visual C++
public class ACT : DocumentSegment
Public Class ACT _
    Inherits DocumentSegment
public ref class ACT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ACT()()()() | Initializes a new instance of the ACT class
 | AccountNumber | Element 1
 | AccountNumber1 | Element 6
 | AccountNumberQualifier | Element 5
 | BenefitStatusCode | Element 9
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ACT


ACT Constructor

ACT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► ACT()()()()
RDPCrystal EDI Library
Initializes a new instance of the ACT class
Declaration Syntax
C# Visual Basic Visual C++
public ACT()
Public Sub New
public:
ACT()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► AccountNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► AccountNumber1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► AccountNumberQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


BenefitStatusCode Property

BenefitStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► BenefitStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string BenefitStatusCode { get; set; }
Public Property BenefitStatusCode As String
    Get
    Set
public:
property String^ BenefitStatusCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► PaymentMethodCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ACT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ActionsIndicated Class

ActionsIndicated Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated
RDPCrystal EDI Library
C002
Declaration Syntax
C# Visual Basic Visual C++
public class ActionsIndicated : DocumentCompositeElement
Public Class ActionsIndicated _
    Inherits DocumentCompositeElement
public ref class ActionsIndicated : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ActionsIndicated()()()() | Initializes a new instance of the ActionsIndicated class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaperworkReportActionCode | Element 1
 | PaperworkReportActionCode1 | Element 2
 | PaperworkReportActionCode2 | Element 3
 | PaperworkReportActionCode3 | Element 4
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ActionsIndicated


ActionsIndicated Constructor

ActionsIndicated Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► ActionsIndicated()()()()
RDPCrystal EDI Library
Initializes a new instance of the ActionsIndicated class
Declaration Syntax
C# Visual Basic Visual C++
public ActionsIndicated()
Public Sub New
public:
ActionsIndicated()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


PaperworkReportActionCode Property

PaperworkReportActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► PaperworkReportActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PaperworkReportActionCode { get; set; }
Public Property PaperworkReportActionCode As String
    Get
    Set
public:
property String^ PaperworkReportActionCode {
    String^ get ();
    void set (String^ value);
}


PaperworkReportActionCode1 Property

PaperworkReportActionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► PaperworkReportActionCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PaperworkReportActionCode1 { get; set; }
Public Property PaperworkReportActionCode1 As String
    Get
    Set
public:
property String^ PaperworkReportActionCode1 {
    String^ get ();
    void set (String^ value);
}


PaperworkReportActionCode2 Property

PaperworkReportActionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► PaperworkReportActionCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PaperworkReportActionCode2 { get; set; }
Public Property PaperworkReportActionCode2 As String
    Get
    Set
public:
property String^ PaperworkReportActionCode2 {
    String^ get ();
    void set (String^ value);
}


PaperworkReportActionCode3 Property

PaperworkReportActionCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ActionsIndicated ► PaperworkReportActionCode3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PaperworkReportActionCode3 { get; set; }
Public Property PaperworkReportActionCode3 As String
    Get
    Set
public:
property String^ PaperworkReportActionCode3 {
    String^ get ();
    void set (String^ value);
}


AD1 Class

AD1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1
RDPCrystal EDI Library
Adjustment Amount
Declaration Syntax
C# Visual Basic Visual C++
public class AD1 : DocumentSegment
Public Class AD1 _
    Inherits DocumentSegment
public ref class AD1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AD1()()()() | Initializes a new instance of the AD1 class
 | AdjustmentReasonCode | Element 1
 | AdjustmentReasonCodeCharacteristic | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LateReasonCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AD1


AD1 Constructor

AD1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► AD1()()()()
RDPCrystal EDI Library
Initializes a new instance of the AD1 class
Declaration Syntax
C# Visual Basic Visual C++
public AD1()
Public Sub New
public:
AD1()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► AdjustmentReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


AdjustmentReasonCodeCharacteristic Property

AdjustmentReasonCodeCharacteristic Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► AdjustmentReasonCodeCharacteristic
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCodeCharacteristic { get; set; }
Public Property AdjustmentReasonCodeCharacteristic As String
    Get
    Set
public:
property String^ AdjustmentReasonCodeCharacteristic {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► FrequencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


LateReasonCode Property

LateReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► LateReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LateReasonCode { get; set; }
Public Property LateReasonCode As String
    Get
    Set
public:
property String^ LateReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AD1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ADI Class

ADI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI
RDPCrystal EDI Library
Animal Disposition
Declaration Syntax
C# Visual Basic Visual C++
public class ADI : DocumentSegment
Public Class ADI _
    Inherits DocumentSegment
public ref class ADI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ADI()()()() | Initializes a new instance of the ADI class
 | AnimalDispositionCode | Element 1
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TestPeriodOrIntervalValue | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ADI


ADI Constructor

ADI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► ADI()()()()
RDPCrystal EDI Library
Initializes a new instance of the ADI class
Declaration Syntax
C# Visual Basic Visual C++
public ADI()
Public Sub New
public:
ADI()


AnimalDispositionCode Property

AnimalDispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► AnimalDispositionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AnimalDispositionCode { get; set; }
Public Property AnimalDispositionCode As String
    Get
    Set
public:
property String^ AnimalDispositionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ADJ Class

ADJ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ
RDPCrystal EDI Library
Adjustments to Balances or Services
Declaration Syntax
C# Visual Basic Visual C++
public class ADJ : DocumentSegment
Public Class ADJ _
    Inherits DocumentSegment
public ref class ADJ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ADJ()()()() | Initializes a new instance of the ADJ class
 | AdjustmentApplicationCode | Element 1
 | Amount | Element 10
 | Amount1 | Element 11
 | Amount2 | Element 12
 | Date | Element 4
 | Date1 | Element 5
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 9
 | ProductServiceIDQualifier | Element 8
 | Quantity | Element 13
 | Quantity1 | Element 14
 | Quantity2 | Element 15
 | ReferenceIdentification | Element 17
 | ReferenceIdentificationQualifier | Element 16
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ADJ


ADJ Constructor

ADJ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► ADJ()()()()
RDPCrystal EDI Library
Initializes a new instance of the ADJ class
Declaration Syntax
C# Visual Basic Visual C++
public ADJ()
Public Sub New
public:
ADJ()


AdjustmentApplicationCode Property

AdjustmentApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► AdjustmentApplicationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentApplicationCode { get; set; }
Public Property AdjustmentApplicationCode As String
    Get
    Set
public:
property String^ AdjustmentApplicationCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Amount
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Amount1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Amount2 Property

Amount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Amount2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Amount2 { get; set; }
Public Property Amount2 As String
    Get
    Set
public:
property String^ Amount2 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Number
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► ProductServiceID
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Quantity
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Quantity1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Quantity2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► ReferenceIdentification
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADJ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AdjustmentIdentifier Class

AdjustmentIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AdjustmentIdentifier
RDPCrystal EDI Library
C042
Declaration Syntax
C# Visual Basic Visual C++
public class AdjustmentIdentifier : DocumentCompositeElement
Public Class AdjustmentIdentifier _
    Inherits DocumentCompositeElement
public ref class AdjustmentIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdjustmentIdentifier()()()() | Initializes a new instance of the AdjustmentIdentifier class
 | AdjustmentReasonCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferenceIdentification |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | AdjustmentIdentifier


AdjustmentIdentifier Constructor

AdjustmentIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AdjustmentIdentifier ► AdjustmentIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the AdjustmentIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier()
Public Sub New
public:
AdjustmentIdentifier()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AdjustmentIdentifier ► AdjustmentReasonCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AdjustmentIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AdjustmentIdentifier ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AdjustmentIdentifier ► ReferenceIdentification
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ADT Class

ADT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT
RDPCrystal EDI Library
Animal Parturition Status
Declaration Syntax
C# Visual Basic Visual C++
public class ADT : DocumentSegment
Public Class ADT _
    Inherits DocumentSegment
public ref class ADT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ADT()()()() | Initializes a new instance of the ADT class
 | Date | Element 2
 | Date1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ParturitionStatusCode | Element 1
 | TestPeriodOrIntervalValue | Element 3
 | TestPeriodOrIntervalValue1 | Element 6
 | TestPeriodOrIntervalValue2 | Element 9
 | Time | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 4
 | UnitOfTimePeriodOrInterval1 | Element 7
 | UnitOfTimePeriodOrInterval2 | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ADT


ADT Constructor

ADT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► ADT()()()()
RDPCrystal EDI Library
Initializes a new instance of the ADT class
Declaration Syntax
C# Visual Basic Visual C++
public ADT()
Public Sub New
public:
ADT()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ParturitionStatusCode Property

ParturitionStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► ParturitionStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ParturitionStatusCode { get; set; }
Public Property ParturitionStatusCode As String
    Get
    Set
public:
property String^ ParturitionStatusCode {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue1 Property

TestPeriodOrIntervalValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► TestPeriodOrIntervalValue1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue1 { get; set; }
Public Property TestPeriodOrIntervalValue1 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue1 {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue2 Property

TestPeriodOrIntervalValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► TestPeriodOrIntervalValue2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue2 { get; set; }
Public Property TestPeriodOrIntervalValue2 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue2 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► Time
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval1 Property

UnitOfTimePeriodOrInterval1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► UnitOfTimePeriodOrInterval1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval1 { get; set; }
Public Property UnitOfTimePeriodOrInterval1 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval2 Property

UnitOfTimePeriodOrInterval2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► UnitOfTimePeriodOrInterval2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval2 { get; set; }
Public Property UnitOfTimePeriodOrInterval2 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ADV Class

ADV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV
RDPCrystal EDI Library
Advertising Demographic Information
Declaration Syntax
C# Visual Basic Visual C++
public class ADV : DocumentSegment
Public Class ADV _
    Inherits DocumentSegment
public ref class ADV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ADV()()()() | Initializes a new instance of the ADV class
 | AgencyQualifierCode | Element 1
 | Category | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 4
 | RangeMinimum | Element 3
 | ServiceCharacteristicsQualifier | Element 2
 | ServiceCharacteristicsQualifier1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ADV


ADV Constructor

ADV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► ADV()()()()
RDPCrystal EDI Library
Initializes a new instance of the ADV class
Declaration Syntax
C# Visual Basic Visual C++
public ADV()
Public Sub New
public:
ADV()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► AgencyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Category Property

Category Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► Category
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► MeasurementValue
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► RangeMaximum
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► RangeMinimum
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier Property

ServiceCharacteristicsQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► ServiceCharacteristicsQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier { get; set; }
Public Property ServiceCharacteristicsQualifier As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier1 Property

ServiceCharacteristicsQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► ServiceCharacteristicsQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier1 { get; set; }
Public Property ServiceCharacteristicsQualifier1 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ADX Class

ADX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX
RDPCrystal EDI Library
Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class ADX : DocumentSegment
Public Class ADX _
    Inherits DocumentSegment
public ref class ADX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ADX()()()() | Initializes a new instance of the ADX class
 | AdjustmentReasonCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ADX


ADX Constructor

ADX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► ADX()()()()
RDPCrystal EDI Library
Initializes a new instance of the ADX class
Declaration Syntax
C# Visual Basic Visual C++
public ADX()
Public Sub New
public:
ADX()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► AdjustmentReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ADX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AEI Class

AEI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI
RDPCrystal EDI Library
Equipment Information Summary
Declaration Syntax
C# Visual Basic Visual C++
public class AEI : DocumentSegment
Public Class AEI _
    Inherits DocumentSegment
public ref class AEI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AEI()()()() | Initializes a new instance of the AEI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AEI


AEI Constructor

AEI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI ► AEI()()()()
RDPCrystal EDI Library
Initializes a new instance of the AEI class
Declaration Syntax
C# Visual Basic Visual C++
public AEI()
Public Sub New
public:
AEI()


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AEI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


AES Class

AES Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES
RDPCrystal EDI Library
Automatic Equipment Identification Site Information
Declaration Syntax
C# Visual Basic Visual C++
public class AES : DocumentSegment
Public Class AES _
    Inherits DocumentSegment
public ref class AES : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AES()()()() | Initializes a new instance of the AES class
 | AutomaticEquipmentIdentificationCode | Element 4
 | AutomaticEquipmentIdentificationSiteStatusCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MovementTypeCode | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TrainTerminationStatusCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AES


AES Constructor

AES Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► AES()()()()
RDPCrystal EDI Library
Initializes a new instance of the AES class
Declaration Syntax
C# Visual Basic Visual C++
public AES()
Public Sub New
public:
AES()


AutomaticEquipmentIdentificationCode Property

AutomaticEquipmentIdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► AutomaticEquipmentIdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AutomaticEquipmentIdentificationCode { get; set; }
Public Property AutomaticEquipmentIdentificationCode As String
    Get
    Set
public:
property String^ AutomaticEquipmentIdentificationCode {
    String^ get ();
    void set (String^ value);
}


AutomaticEquipmentIdentificationSiteStatusCode Property

AutomaticEquipmentIdentificationSiteStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► AutomaticEquipmentIdentificationSiteStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AutomaticEquipmentIdentificationSiteStatusCode { get; set; }
Public Property AutomaticEquipmentIdentificationSiteStatusCode As String
    Get
    Set
public:
property String^ AutomaticEquipmentIdentificationSiteStatusCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► IndustryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MovementTypeCode Property

MovementTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► MovementTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MovementTypeCode { get; set; }
Public Property MovementTypeCode As String
    Get
    Set
public:
property String^ MovementTypeCode {
    String^ get ();
    void set (String^ value);
}


TrainTerminationStatusCode Property

TrainTerminationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► TrainTerminationStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TrainTerminationStatusCode { get; set; }
Public Property TrainTerminationStatusCode As String
    Get
    Set
public:
property String^ TrainTerminationStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AES ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AIN Class

AIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN
RDPCrystal EDI Library
Income
Declaration Syntax
C# Visual Basic Visual C++
public class AIN : DocumentSegment
Public Class AIN _
    Inherits DocumentSegment
public ref class AIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AIN()()()() | Initializes a new instance of the AIN class
 | AmountQualifierCode | Element 7
 | EarningsRateOfPay | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 11
 | ReferenceIdentification | Element 6
 | TaxTreatmentCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfIncomeCode | Element 1
 | UnitOrBasisForMeasurementCode | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AIN


AIN Constructor

AIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► AIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the AIN class
Declaration Syntax
C# Visual Basic Visual C++
public AIN()
Public Sub New
public:
AIN()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► AmountQualifierCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


EarningsRateOfPay Property

EarningsRateOfPay Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► EarningsRateOfPay
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EarningsRateOfPay { get; set; }
Public Property EarningsRateOfPay As String
    Get
    Set
public:
property String^ EarningsRateOfPay {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► FrequencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► IndustryCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► Quantity1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TaxTreatmentCode Property

TaxTreatmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► TaxTreatmentCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TaxTreatmentCode { get; set; }
Public Property TaxTreatmentCode As String
    Get
    Set
public:
property String^ TaxTreatmentCode {
    String^ get ();
    void set (String^ value);
}


TypeOfIncomeCode Property

TypeOfIncomeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► TypeOfIncomeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfIncomeCode { get; set; }
Public Property TypeOfIncomeCode As String
    Get
    Set
public:
property String^ TypeOfIncomeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AIN ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


AK1 Class

AK1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK1
RDPCrystal EDI Library
Functional Group Response Header
Declaration Syntax
C# Visual Basic Visual C++
public class AK1 : DocumentSegment
Public Class AK1 _
    Inherits DocumentSegment
public ref class AK1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK1()()()() | Initializes a new instance of the AK1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK1


AK1 Constructor

AK1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK1 ► AK1()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK1 class
Declaration Syntax
C# Visual Basic Visual C++
public AK1()
Public Sub New
public:
AK1()


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK1 ► FunctionalIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK1 ► GroupControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AK2 Class

AK2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK2
RDPCrystal EDI Library
Transaction Set Response Header
Declaration Syntax
C# Visual Basic Visual C++
public class AK2 : DocumentSegment
Public Class AK2 _
    Inherits DocumentSegment
public ref class AK2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK2()()()() | Initializes a new instance of the AK2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber |
 | TransactionSetIdentifierCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK2


AK2 Constructor

AK2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK2 ► AK2()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK2 class
Declaration Syntax
C# Visual Basic Visual C++
public AK2()
Public Sub New
public:
AK2()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK2 ► TransactionSetControlNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK2 ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AK3 Class

AK3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3
RDPCrystal EDI Library
Data Segment Note
Declaration Syntax
C# Visual Basic Visual C++
public class AK3 : DocumentSegment
Public Class AK3 _
    Inherits DocumentSegment
public ref class AK3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK3()()()() | Initializes a new instance of the AK3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SegmentIDCode | Element 1
 | SegmentPositionInTransactionSet | Element 2
 | SegmentSyntaxErrorCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK3


AK3 Constructor

AK3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► AK3()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK3 class
Declaration Syntax
C# Visual Basic Visual C++
public AK3()
Public Sub New
public:
AK3()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► LoopIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► SegmentIDCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}


SegmentPositionInTransactionSet Property

SegmentPositionInTransactionSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► SegmentPositionInTransactionSet
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentPositionInTransactionSet { get; set; }
Public Property SegmentPositionInTransactionSet As String
    Get
    Set
public:
property String^ SegmentPositionInTransactionSet {
    String^ get ();
    void set (String^ value);
}


SegmentSyntaxErrorCode Property

SegmentSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► SegmentSyntaxErrorCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSyntaxErrorCode { get; set; }
Public Property SegmentSyntaxErrorCode As String
    Get
    Set
public:
property String^ SegmentSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AK4 Class

AK4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4
RDPCrystal EDI Library
Data Element Note
Declaration Syntax
C# Visual Basic Visual C++
public class AK4 : DocumentSegment
Public Class AK4 _
    Inherits DocumentSegment
public ref class AK4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK4()()()() | Initializes a new instance of the AK4 class
 | CopyOfBadDataElement | Element 4
 | DataElementReferenceNumber | Element 2
 | DataElementSyntaxErrorCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK4


AK4 Constructor

AK4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► AK4()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK4 class
Declaration Syntax
C# Visual Basic Visual C++
public AK4()
Public Sub New
public:
AK4()


CopyOfBadDataElement Property

CopyOfBadDataElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► CopyOfBadDataElement
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CopyOfBadDataElement { get; set; }
Public Property CopyOfBadDataElement As String
    Get
    Set
public:
property String^ CopyOfBadDataElement {
    String^ get ();
    void set (String^ value);
}


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► DataElementReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}


DataElementSyntaxErrorCode Property

DataElementSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► DataElementSyntaxErrorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementSyntaxErrorCode { get; set; }
Public Property DataElementSyntaxErrorCode As String
    Get
    Set
public:
property String^ DataElementSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► PositionInSegment
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment PositionInSegment { get; set; }
Public Property PositionInSegment As PositionInSegment
    Get
    Set
public:
property PositionInSegment^ PositionInSegment {
    PositionInSegment^ get ();
    void set (PositionInSegment^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AK5 Class

AK5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5
RDPCrystal EDI Library
Transaction Set Response Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class AK5 : DocumentSegment
Public Class AK5 _
    Inherits DocumentSegment
public ref class AK5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK5()()()() | Initializes a new instance of the AK5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetAcknowledgmentCode | Element 1
 | TransactionSetSyntaxErrorCode | Element 2
 | TransactionSetSyntaxErrorCode1 | Element 3
 | TransactionSetSyntaxErrorCode2 | Element 4
 | TransactionSetSyntaxErrorCode3 | Element 5
 | TransactionSetSyntaxErrorCode4 | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK5


AK5 Constructor

AK5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► AK5()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK5 class
Declaration Syntax
C# Visual Basic Visual C++
public AK5()
Public Sub New
public:
AK5()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetAcknowledgmentCode Property

TransactionSetAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► TransactionSetAcknowledgmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetAcknowledgmentCode { get; set; }
Public Property TransactionSetAcknowledgmentCode As String
    Get
    Set
public:
property String^ TransactionSetAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetSyntaxErrorCode Property

TransactionSetSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► TransactionSetSyntaxErrorCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetSyntaxErrorCode { get; set; }
Public Property TransactionSetSyntaxErrorCode As String
    Get
    Set
public:
property String^ TransactionSetSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetSyntaxErrorCode1 Property

TransactionSetSyntaxErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► TransactionSetSyntaxErrorCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetSyntaxErrorCode1 { get; set; }
Public Property TransactionSetSyntaxErrorCode1 As String
    Get
    Set
public:
property String^ TransactionSetSyntaxErrorCode1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetSyntaxErrorCode2 Property

TransactionSetSyntaxErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► TransactionSetSyntaxErrorCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetSyntaxErrorCode2 { get; set; }
Public Property TransactionSetSyntaxErrorCode2 As String
    Get
    Set
public:
property String^ TransactionSetSyntaxErrorCode2 {
    String^ get ();
    void set (String^ value);
}


TransactionSetSyntaxErrorCode3 Property

TransactionSetSyntaxErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► TransactionSetSyntaxErrorCode3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetSyntaxErrorCode3 { get; set; }
Public Property TransactionSetSyntaxErrorCode3 As String
    Get
    Set
public:
property String^ TransactionSetSyntaxErrorCode3 {
    String^ get ();
    void set (String^ value);
}


TransactionSetSyntaxErrorCode4 Property

TransactionSetSyntaxErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► TransactionSetSyntaxErrorCode4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetSyntaxErrorCode4 { get; set; }
Public Property TransactionSetSyntaxErrorCode4 As String
    Get
    Set
public:
property String^ TransactionSetSyntaxErrorCode4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AK9 Class

AK9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9
RDPCrystal EDI Library
Functional Group Response Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class AK9 : DocumentSegment
Public Class AK9 _
    Inherits DocumentSegment
public ref class AK9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK9()()()() | Initializes a new instance of the AK9 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalGroupAcknowledgmentCode | Element 1
 | FunctionalGroupSyntaxErrorCode1 | Element 5
 | FunctionalGroupSyntaxErrorCode2 | Element 6
 | FunctionalGroupSyntaxErrorCode3 | Element 7
 | FunctionalGroupSyntaxErrorCode4 | Element 8
 | FunctionalGroupSyntaxErrorCode5 | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfAcceptedTransactionSets | Element 4
 | NumberOfReceivedTransactionSets | Element 3
 | NumberOfTransactionSetsIncluded | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK9


AK9 Constructor

AK9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► AK9()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK9 class
Declaration Syntax
C# Visual Basic Visual C++
public AK9()
Public Sub New
public:
AK9()


FunctionalGroupAcknowledgmentCode Property

FunctionalGroupAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► FunctionalGroupAcknowledgmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupAcknowledgmentCode { get; set; }
Public Property FunctionalGroupAcknowledgmentCode As String
    Get
    Set
public:
property String^ FunctionalGroupAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}


FunctionalGroupSyntaxErrorCode1 Property

FunctionalGroupSyntaxErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► FunctionalGroupSyntaxErrorCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode1 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode1 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode1 {
    String^ get ();
    void set (String^ value);
}


FunctionalGroupSyntaxErrorCode2 Property

FunctionalGroupSyntaxErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► FunctionalGroupSyntaxErrorCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode2 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode2 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode2 {
    String^ get ();
    void set (String^ value);
}


FunctionalGroupSyntaxErrorCode3 Property

FunctionalGroupSyntaxErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► FunctionalGroupSyntaxErrorCode3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode3 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode3 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode3 {
    String^ get ();
    void set (String^ value);
}


FunctionalGroupSyntaxErrorCode4 Property

FunctionalGroupSyntaxErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► FunctionalGroupSyntaxErrorCode4
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode4 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode4 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode4 {
    String^ get ();
    void set (String^ value);
}


FunctionalGroupSyntaxErrorCode5 Property

FunctionalGroupSyntaxErrorCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► FunctionalGroupSyntaxErrorCode5
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode5 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode5 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode5 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfAcceptedTransactionSets Property

NumberOfAcceptedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► NumberOfAcceptedTransactionSets
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfAcceptedTransactionSets { get; set; }
Public Property NumberOfAcceptedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfAcceptedTransactionSets {
    String^ get ();
    void set (String^ value);
}


NumberOfReceivedTransactionSets Property

NumberOfReceivedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► NumberOfReceivedTransactionSets
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfReceivedTransactionSets { get; set; }
Public Property NumberOfReceivedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfReceivedTransactionSets {
    String^ get ();
    void set (String^ value);
}


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► NumberOfTransactionSetsIncluded
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AK9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AM1 Class

AM1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1
RDPCrystal EDI Library
Informational Values
Declaration Syntax
C# Visual Basic Visual C++
public class AM1 : DocumentSegment
Public Class AM1 _
    Inherits DocumentSegment
public ref class AM1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AM1()()()() | Initializes a new instance of the AM1 class
 | CodeCategory | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 6
 | ProductServiceID | Element 3
 | ProductServiceIDQualifier | Element 2
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AM1


AM1 Constructor

AM1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► AM1()()()()
RDPCrystal EDI Library
Initializes a new instance of the AM1 class
Declaration Syntax
C# Visual Basic Visual C++
public AM1()
Public Sub New
public:
AM1()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► Percent
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AM1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AmountQualifyingDescription Class

AmountQualifyingDescription Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription
RDPCrystal EDI Library
C007 - Amount Qualifying Description
Declaration Syntax
C# Visual Basic Visual C++
public class AmountQualifyingDescription : DocumentCompositeElement
Public Class AmountQualifyingDescription _
    Inherits DocumentCompositeElement
public ref class AmountQualifyingDescription : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AmountQualifyingDescription()()()() | Initializes a new instance of the AmountQualifyingDescription class
 | AmountQualifierCode | Element 1
 | AmountQualifierCode1 | Element 2
 | Description | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MeasurementSignificanceCode | Element 4
 | MeasurementSignificanceCode1 | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetGrossCode | Element 6
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnitOfTimePeriodOrInterval | Element 5
 | ValueDetailCode | Element 3
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | AmountQualifyingDescription


AmountQualifyingDescription Constructor

AmountQualifyingDescription Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► AmountQualifyingDescription()()()()
RDPCrystal EDI Library
Initializes a new instance of the AmountQualifyingDescription class
Declaration Syntax
C# Visual Basic Visual C++
public AmountQualifyingDescription()
Public Sub New
public:
AmountQualifyingDescription()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► AmountQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode1 Property

AmountQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► AmountQualifierCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode1 { get; set; }
Public Property AmountQualifierCode1 As String
    Get
    Set
public:
property String^ AmountQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► Description
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


MeasurementSignificanceCode Property

MeasurementSignificanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► MeasurementSignificanceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementSignificanceCode { get; set; }
Public Property MeasurementSignificanceCode As String
    Get
    Set
public:
property String^ MeasurementSignificanceCode {
    String^ get ();
    void set (String^ value);
}


MeasurementSignificanceCode1 Property

MeasurementSignificanceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► MeasurementSignificanceCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementSignificanceCode1 { get; set; }
Public Property MeasurementSignificanceCode1 As String
    Get
    Set
public:
property String^ MeasurementSignificanceCode1 {
    String^ get ();
    void set (String^ value);
}


NetGrossCode Property

NetGrossCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► NetGrossCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NetGrossCode { get; set; }
Public Property NetGrossCode As String
    Get
    Set
public:
property String^ NetGrossCode {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


ValueDetailCode Property

ValueDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AmountQualifyingDescription ► ValueDetailCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ValueDetailCode { get; set; }
Public Property ValueDetailCode As String
    Get
    Set
public:
property String^ ValueDetailCode {
    String^ get ();
    void set (String^ value);
}


AMT Class

AMT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT
RDPCrystal EDI Library
Monetary Amount
Declaration Syntax
C# Visual Basic Visual C++
public class AMT : DocumentSegment
Public Class AMT _
    Inherits DocumentSegment
public ref class AMT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AMT()()()() | Initializes a new instance of the AMT class
 | AmountQualifierCode | Element 1
 | CreditDebitFlagCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AMT


AMT Constructor

AMT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT ► AMT()()()()
RDPCrystal EDI Library
Initializes a new instance of the AMT class
Declaration Syntax
C# Visual Basic Visual C++
public AMT()
Public Sub New
public:
AMT()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT ► AmountQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AMT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ANI Class

ANI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI
RDPCrystal EDI Library
Animal Identification
Declaration Syntax
C# Visual Basic Visual C++
public class ANI : DocumentSegment
Public Class ANI _
    Inherits DocumentSegment
public ref class ANI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ANI()()()() | Initializes a new instance of the ANI class
 | Date | Element 2
 | Date1 | Element 3
 | Date2 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 6
 | ReferenceIdentification2 | Element 7
 | ReferenceIdentification3 | Element 9
 | TestPeriodOrIntervalValue | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ANI


ANI Constructor

ANI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► ANI()()()()
RDPCrystal EDI Library
Initializes a new instance of the ANI class
Declaration Syntax
C# Visual Basic Visual C++
public ANI()
Public Sub New
public:
ANI()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► Date2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► ReferenceIdentification2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► ReferenceIdentification3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ANI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AOC Class

AOC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC
RDPCrystal EDI Library
Animal Offspring Counts
Declaration Syntax
C# Visual Basic Visual C++
public class AOC : DocumentSegment
Public Class AOC _
    Inherits DocumentSegment
public ref class AOC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AOC()()()() | Initializes a new instance of the AOC class
 | Count | Element 2
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OffspringCountCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TestPeriodOrIntervalValue | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AOC


AOC Constructor

AOC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► AOC()()()()
RDPCrystal EDI Library
Initializes a new instance of the AOC class
Declaration Syntax
C# Visual Basic Visual C++
public AOC()
Public Sub New
public:
AOC()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► Count
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OffspringCountCode Property

OffspringCountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► OffspringCountCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OffspringCountCode { get; set; }
Public Property OffspringCountCode As String
    Get
    Set
public:
property String^ OffspringCountCode {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AOI Class

AOI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI
RDPCrystal EDI Library
Animal Offspring/Fetus Identification
Declaration Syntax
C# Visual Basic Visual C++
public class AOI : DocumentSegment
Public Class AOI _
    Inherits DocumentSegment
public ref class AOI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AOI()()()() | Initializes a new instance of the AOI class
 | AnimalDispositionCode | Element 7
 | Date | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OffspringFetusStatusCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 10
 | TestPeriodOrIntervalValue | Element 5
 | TestPeriodOrIntervalValue1 | Element 8
 | TestPeriodOrIntervalValue2 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 6
 | UnitOfTimePeriodOrInterval1 | Element 9
 | UnitOfTimePeriodOrInterval2 | Element 13
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AOI


AOI Constructor

AOI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► AOI()()()()
RDPCrystal EDI Library
Initializes a new instance of the AOI class
Declaration Syntax
C# Visual Basic Visual C++
public AOI()
Public Sub New
public:
AOI()


AnimalDispositionCode Property

AnimalDispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► AnimalDispositionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AnimalDispositionCode { get; set; }
Public Property AnimalDispositionCode As String
    Get
    Set
public:
property String^ AnimalDispositionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► Date
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► GenderCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OffspringFetusStatusCode Property

OffspringFetusStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► OffspringFetusStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string OffspringFetusStatusCode { get; set; }
Public Property OffspringFetusStatusCode As String
    Get
    Set
public:
property String^ OffspringFetusStatusCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► ReferenceIdentification1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue1 Property

TestPeriodOrIntervalValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► TestPeriodOrIntervalValue1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue1 { get; set; }
Public Property TestPeriodOrIntervalValue1 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue1 {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue2 Property

TestPeriodOrIntervalValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► TestPeriodOrIntervalValue2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue2 { get; set; }
Public Property TestPeriodOrIntervalValue2 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue2 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval1 Property

UnitOfTimePeriodOrInterval1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► UnitOfTimePeriodOrInterval1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval1 { get; set; }
Public Property UnitOfTimePeriodOrInterval1 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval2 Property

UnitOfTimePeriodOrInterval2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► UnitOfTimePeriodOrInterval2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval2 { get; set; }
Public Property UnitOfTimePeriodOrInterval2 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


AOL Class

AOL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL
RDPCrystal EDI Library
Animal Observation Location
Declaration Syntax
C# Visual Basic Visual C++
public class AOL : DocumentSegment
Public Class AOL _
    Inherits DocumentSegment
public ref class AOL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AOL()()()() | Initializes a new instance of the AOL class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | ObservationTypeCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SubLocation | Element 5
 | SubLocation1 | Element 6
 | SubLocation2 | Element 7
 | SurfaceLayerPositionCode | Element 8
 | TissueOrSpecimenDispositionCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AOL


AOL Constructor

AOL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► AOL()()()()
RDPCrystal EDI Library
Initializes a new instance of the AOL class
Declaration Syntax
C# Visual Basic Visual C++
public AOL()
Public Sub New
public:
AOL()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ObservationTypeCode Property

ObservationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► ObservationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ObservationTypeCode { get; set; }
Public Property ObservationTypeCode As String
    Get
    Set
public:
property String^ ObservationTypeCode {
    String^ get ();
    void set (String^ value);
}


SubLocation Property

SubLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► SubLocation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SubLocation { get; set; }
Public Property SubLocation As String
    Get
    Set
public:
property String^ SubLocation {
    String^ get ();
    void set (String^ value);
}


SubLocation1 Property

SubLocation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► SubLocation1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SubLocation1 { get; set; }
Public Property SubLocation1 As String
    Get
    Set
public:
property String^ SubLocation1 {
    String^ get ();
    void set (String^ value);
}


SubLocation2 Property

SubLocation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► SubLocation2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SubLocation2 { get; set; }
Public Property SubLocation2 As String
    Get
    Set
public:
property String^ SubLocation2 {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


TissueOrSpecimenDispositionCode Property

TissueOrSpecimenDispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► TissueOrSpecimenDispositionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TissueOrSpecimenDispositionCode { get; set; }
Public Property TissueOrSpecimenDispositionCode As String
    Get
    Set
public:
property String^ TissueOrSpecimenDispositionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOL ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


AOR Class

AOR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR
RDPCrystal EDI Library
Animal Observation Result
Declaration Syntax
C# Visual Basic Visual C++
public class AOR : DocumentSegment
Public Class AOR _
    Inherits DocumentSegment
public ref class AOR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AOR()()()() | Initializes a new instance of the AOR class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LinkageIdentifier | Element 5
 | LinkageIdentifier1 | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NeoplasmCode | Element 3
 | ObservationDistribution | Element 1
 | ObservationSeverity | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TestPeriodOrIntervalValue | Element 8
 | TestPeriodOrIntervalValue1 | Element 10
 | TestPeriodOrIntervalValue2 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 9
 | UnitOfTimePeriodOrInterval1 | Element 11
 | UnitOfTimePeriodOrInterval2 | Element 13
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
 | YesNoConditionOrResponseCode1 | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AOR


AOR Constructor

AOR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► AOR()()()()
RDPCrystal EDI Library
Initializes a new instance of the AOR class
Declaration Syntax
C# Visual Basic Visual C++
public AOR()
Public Sub New
public:
AOR()


LinkageIdentifier Property

LinkageIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► LinkageIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LinkageIdentifier { get; set; }
Public Property LinkageIdentifier As String
    Get
    Set
public:
property String^ LinkageIdentifier {
    String^ get ();
    void set (String^ value);
}


LinkageIdentifier1 Property

LinkageIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► LinkageIdentifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LinkageIdentifier1 { get; set; }
Public Property LinkageIdentifier1 As String
    Get
    Set
public:
property String^ LinkageIdentifier1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NeoplasmCode Property

NeoplasmCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► NeoplasmCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NeoplasmCode { get; set; }
Public Property NeoplasmCode As String
    Get
    Set
public:
property String^ NeoplasmCode {
    String^ get ();
    void set (String^ value);
}


ObservationDistribution Property

ObservationDistribution Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► ObservationDistribution
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ObservationDistribution { get; set; }
Public Property ObservationDistribution As String
    Get
    Set
public:
property String^ ObservationDistribution {
    String^ get ();
    void set (String^ value);
}


ObservationSeverity Property

ObservationSeverity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► ObservationSeverity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ObservationSeverity { get; set; }
Public Property ObservationSeverity As String
    Get
    Set
public:
property String^ ObservationSeverity {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue1 Property

TestPeriodOrIntervalValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► TestPeriodOrIntervalValue1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue1 { get; set; }
Public Property TestPeriodOrIntervalValue1 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue1 {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue2 Property

TestPeriodOrIntervalValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► TestPeriodOrIntervalValue2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue2 { get; set; }
Public Property TestPeriodOrIntervalValue2 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue2 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval1 Property

UnitOfTimePeriodOrInterval1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► UnitOfTimePeriodOrInterval1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval1 { get; set; }
Public Property UnitOfTimePeriodOrInterval1 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval2 Property

UnitOfTimePeriodOrInterval2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► UnitOfTimePeriodOrInterval2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval2 { get; set; }
Public Property UnitOfTimePeriodOrInterval2 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AOR ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


AP1 Class

AP1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1
RDPCrystal EDI Library
Alternate Parts
Declaration Syntax
C# Visual Basic Visual C++
public class AP1 : DocumentSegment
Public Class AP1 _
    Inherits DocumentSegment
public ref class AP1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AP1()()()() | Initializes a new instance of the AP1 class
 | ConditionIndicator | Element 1
 | Description | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 11
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | PostalCode | Element 6
 | PostalCode1 | Element 7
 | PriceIdentifierCode | Element 3
 | PrintOptionCode | Element 8
 | ProductServiceID | Element 12
 | Quantity | Element 10
 | StateOrProvinceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AP1


AP1 Constructor

AP1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► AP1()()()()
RDPCrystal EDI Library
Initializes a new instance of the AP1 class
Declaration Syntax
C# Visual Basic Visual C++
public AP1()
Public Sub New
public:
AP1()


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► ConditionIndicator
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► Description
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► FreeFormMessage
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► Number
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► PostalCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


PostalCode1 Property

PostalCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► PostalCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode1 { get; set; }
Public Property PostalCode1 As String
    Get
    Set
public:
property String^ PostalCode1 {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► PriceIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


PrintOptionCode Property

PrintOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► PrintOptionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PrintOptionCode { get; set; }
Public Property PrintOptionCode As String
    Get
    Set
public:
property String^ PrintOptionCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► ProductServiceID
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AP1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


API Class

API Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API
RDPCrystal EDI Library
Activity or Process Information
Declaration Syntax
C# Visual Basic Visual C++
public class API : DocumentSegment
Public Class API _
    Inherits DocumentSegment
public ref class API : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | API()()()() | Initializes a new instance of the API class
 | ActionCode | Element 2
 | AffectedAreaOrSectionCode | Element 5
 | CodeCategory | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode | Element 8
 | InsuranceTypeCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanTypeCode | Element 7
 | MaintenanceTypeCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | API


API Constructor

API Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► API()()()()
RDPCrystal EDI Library
Initializes a new instance of the API class
Declaration Syntax
C# Visual Basic Visual C++
public API()
Public Sub New
public:
API()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AffectedAreaOrSectionCode Property

AffectedAreaOrSectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► AffectedAreaOrSectionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AffectedAreaOrSectionCode { get; set; }
Public Property AffectedAreaOrSectionCode As String
    Get
    Set
public:
property String^ AffectedAreaOrSectionCode {
    String^ get ();
    void set (String^ value);
}


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► InformationStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► InsuranceTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► LoanTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► StatusReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► API ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


APR Class

APR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR
RDPCrystal EDI Library
Association of American Railroads Pool Code Restrictions
Declaration Syntax
C# Visual Basic Visual C++
public class APR : DocumentSegment
Public Class APR _
    Inherits DocumentSegment
public ref class APR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | APR()()()() | Initializes a new instance of the APR class
 | AARPoolCode | Element 2
 | AARPoolCode1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | APR


APR Constructor

APR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR ► APR()()()()
RDPCrystal EDI Library
Initializes a new instance of the APR class
Declaration Syntax
C# Visual Basic Visual C++
public APR()
Public Sub New
public:
APR()


AARPoolCode Property

AARPoolCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR ► AARPoolCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AARPoolCode { get; set; }
Public Property AARPoolCode As String
    Get
    Set
public:
property String^ AARPoolCode {
    String^ get ();
    void set (String^ value);
}


AARPoolCode1 Property

AARPoolCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR ► AARPoolCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AARPoolCode1 { get; set; }
Public Property AARPoolCode1 As String
    Get
    Set
public:
property String^ AARPoolCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► APR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


ARC Class

ARC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC
RDPCrystal EDI Library
Animal Results Counts
Declaration Syntax
C# Visual Basic Visual C++
public class ARC : DocumentSegment
Public Class ARC _
    Inherits DocumentSegment
public ref class ARC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ARC()()()() | Initializes a new instance of the ARC class
 | Count | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | ObservationTypeCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TestTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ARC


ARC Constructor

ARC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC ► ARC()()()()
RDPCrystal EDI Library
Initializes a new instance of the ARC class
Declaration Syntax
C# Visual Basic Visual C++
public ARC()
Public Sub New
public:
ARC()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC ► Count
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ObservationTypeCode Property

ObservationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC ► ObservationTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ObservationTypeCode { get; set; }
Public Property ObservationTypeCode As String
    Get
    Set
public:
property String^ ObservationTypeCode {
    String^ get ();
    void set (String^ value);
}


TestTypeCode Property

TestTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC ► TestTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TestTypeCode { get; set; }
Public Property TestTypeCode As String
    Get
    Set
public:
property String^ TestTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ARS Class

ARS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS
RDPCrystal EDI Library
Applicant Residence Specifics
Declaration Syntax
C# Visual Basic Visual C++
public class ARS : DocumentSegment
Public Class ARS _
    Inherits DocumentSegment
public ref class ARS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ARS()()()() | Initializes a new instance of the ARS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PropertyOwnershipRightsCode | Element 2
 | RateValueQualifier | Element 3
 | ReferenceIdentification | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfResidenceCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ARS


ARS Constructor

ARS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► ARS()()()()
RDPCrystal EDI Library
Initializes a new instance of the ARS class
Declaration Syntax
C# Visual Basic Visual C++
public ARS()
Public Sub New
public:
ARS()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


PropertyOwnershipRightsCode Property

PropertyOwnershipRightsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► PropertyOwnershipRightsCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyOwnershipRightsCode { get; set; }
Public Property PropertyOwnershipRightsCode As String
    Get
    Set
public:
property String^ PropertyOwnershipRightsCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► RateValueQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TypeOfResidenceCode Property

TypeOfResidenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► TypeOfResidenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfResidenceCode { get; set; }
Public Property TypeOfResidenceCode As String
    Get
    Set
public:
property String^ TypeOfResidenceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ARS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ASI Class

ASI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI
RDPCrystal EDI Library
Action or Status Indicator
Declaration Syntax
C# Visual Basic Visual C++
public class ASI : DocumentSegment
Public Class ASI _
    Inherits DocumentSegment
public ref class ASI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ASI()()()() | Initializes a new instance of the ASI class
 | ActionCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceTypeCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ASI


ASI Constructor

ASI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI ► ASI()()()()
RDPCrystal EDI Library
Initializes a new instance of the ASI class
Declaration Syntax
C# Visual Basic Visual C++
public ASI()
Public Sub New
public:
ASI()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI ► StatusReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ASL Class

ASL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL
RDPCrystal EDI Library
Asset Liability
Declaration Syntax
C# Visual Basic Visual C++
public class ASL : DocumentSegment
Public Class ASL _
    Inherits DocumentSegment
public ref class ASL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ASL()()()() | Initializes a new instance of the ASL class
 | AmountQualifierCode | Element 1
 | AssetLiabilityTypeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ASL


ASL Constructor

ASL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► ASL()()()()
RDPCrystal EDI Library
Initializes a new instance of the ASL class
Declaration Syntax
C# Visual Basic Visual C++
public ASL()
Public Sub New
public:
ASL()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► AmountQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


AssetLiabilityTypeCode Property

AssetLiabilityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► AssetLiabilityTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AssetLiabilityTypeCode { get; set; }
Public Property AssetLiabilityTypeCode As String
    Get
    Set
public:
property String^ AssetLiabilityTypeCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► FrequencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ASM Class

ASM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM
RDPCrystal EDI Library
Amount and Settlement Method
Declaration Syntax
C# Visual Basic Visual C++
public class ASM : DocumentSegment
Public Class ASM _
    Inherits DocumentSegment
public ref class ASM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ASM()()()() | Initializes a new instance of the ASM class
 | Amount | Element 1
 | AmountQualifierCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ASM


ASM Constructor

ASM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM ► ASM()()()()
RDPCrystal EDI Library
Initializes a new instance of the ASM class
Declaration Syntax
C# Visual Basic Visual C++
public ASM()
Public Sub New
public:
ASM()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM ► Amount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM ► AmountQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM ► PaymentMethodCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ASO Class

ASO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO
RDPCrystal EDI Library
Asset Ownership
Declaration Syntax
C# Visual Basic Visual C++
public class ASO : DocumentSegment
Public Class ASO _
    Inherits DocumentSegment
public ref class ASO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ASO()()()() | Initializes a new instance of the ASO class
 | AmountQualifyingDescription | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 4
 | GeneralPropertyOwnershipCode | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 8
 | PropertyOwnershipRightsCode | Element 1
 | Quantity | Element 9
 | ReferenceIdentification | Element 11
 | ReferenceIdentificationQualifier | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfPersonalOrBusinessAssetCode | Element 2
 | TypeOfPersonalOrBusinessAssetCode1 | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ASO


ASO Constructor

ASO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► ASO()()()()
RDPCrystal EDI Library
Initializes a new instance of the ASO class
Declaration Syntax
C# Visual Basic Visual C++
public ASO()
Public Sub New
public:
ASO()


AmountQualifyingDescription Property

AmountQualifyingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► AmountQualifyingDescription
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public AmountQualifyingDescription AmountQualifyingDescription { get; set; }
Public Property AmountQualifyingDescription As AmountQualifyingDescription
    Get
    Set
public:
property AmountQualifyingDescription^ AmountQualifyingDescription {
    AmountQualifyingDescription^ get ();
    void set (AmountQualifyingDescription^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► FreeFormMessageText
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


GeneralPropertyOwnershipCode Property

GeneralPropertyOwnershipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► GeneralPropertyOwnershipCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string GeneralPropertyOwnershipCode { get; set; }
Public Property GeneralPropertyOwnershipCode As String
    Get
    Set
public:
property String^ GeneralPropertyOwnershipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► Percent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PropertyOwnershipRightsCode Property

PropertyOwnershipRightsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► PropertyOwnershipRightsCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyOwnershipRightsCode { get; set; }
Public Property PropertyOwnershipRightsCode As String
    Get
    Set
public:
property String^ PropertyOwnershipRightsCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► Quantity
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► ReferenceIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TypeOfPersonalOrBusinessAssetCode Property

TypeOfPersonalOrBusinessAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► TypeOfPersonalOrBusinessAssetCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfPersonalOrBusinessAssetCode { get; set; }
Public Property TypeOfPersonalOrBusinessAssetCode As String
    Get
    Set
public:
property String^ TypeOfPersonalOrBusinessAssetCode {
    String^ get ();
    void set (String^ value);
}


TypeOfPersonalOrBusinessAssetCode1 Property

TypeOfPersonalOrBusinessAssetCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► TypeOfPersonalOrBusinessAssetCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfPersonalOrBusinessAssetCode1 { get; set; }
Public Property TypeOfPersonalOrBusinessAssetCode1 As String
    Get
    Set
public:
property String^ TypeOfPersonalOrBusinessAssetCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ASO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AssuranceTokenParameters Class

AssuranceTokenParameters Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters
RDPCrystal EDI Library
C028
Declaration Syntax
C# Visual Basic Visual C++
public class AssuranceTokenParameters : DocumentCompositeElement
Public Class AssuranceTokenParameters _
    Inherits DocumentCompositeElement
public ref class AssuranceTokenParameters : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssuranceTokenParameters()()()() | Initializes a new instance of the AssuranceTokenParameters class
 | AssuranceTokenParameterCode | Element 1
 | AssuranceTokenParameterCode1 | Element 3
 | AssuranceTokenParameterCode2 | Element 5
 | AssuranceTokenParameterCode3 | Element 7
 | AssuranceTokenParameterCode4 | Element 9
 | AssuranceTokenParameterCode5 | Element 11
 | AssuranceTokenParameterCode6 | Element 13
 | AssuranceTokenParameterCode7 | Element 15
 | AssuranceTokenParameterCode8 | Element 17
 | AssuranceTokenParameterCode9 | Element 19
 | AssuranceTokenParameterValue | Element 2
 | AssuranceTokenParameterValue1 | Element 4
 | AssuranceTokenParameterValue2 | Element 6
 | AssuranceTokenParameterValue3 | Element 8
 | AssuranceTokenParameterValue4 | Element 10
 | AssuranceTokenParameterValue5 | Element 12
 | AssuranceTokenParameterValue6 | Element 14
 | AssuranceTokenParameterValue7 | Element 16
 | AssuranceTokenParameterValue8 | Element 18
 | AssuranceTokenParameterValue9 | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | AssuranceTokenParameters


AssuranceTokenParameters Constructor

AssuranceTokenParameters Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameters()()()()
RDPCrystal EDI Library
Initializes a new instance of the AssuranceTokenParameters class
Declaration Syntax
C# Visual Basic Visual C++
public AssuranceTokenParameters()
Public Sub New
public:
AssuranceTokenParameters()


AssuranceTokenParameterCode Property

AssuranceTokenParameterCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode { get; set; }
Public Property AssuranceTokenParameterCode As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode1 Property

AssuranceTokenParameterCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode1 { get; set; }
Public Property AssuranceTokenParameterCode1 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode1 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode2 Property

AssuranceTokenParameterCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode2 { get; set; }
Public Property AssuranceTokenParameterCode2 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode2 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode3 Property

AssuranceTokenParameterCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode3 { get; set; }
Public Property AssuranceTokenParameterCode3 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode3 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode4 Property

AssuranceTokenParameterCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode4 { get; set; }
Public Property AssuranceTokenParameterCode4 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode4 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode5 Property

AssuranceTokenParameterCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode5
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode5 { get; set; }
Public Property AssuranceTokenParameterCode5 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode5 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode6 Property

AssuranceTokenParameterCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode6
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode6 { get; set; }
Public Property AssuranceTokenParameterCode6 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode6 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode7 Property

AssuranceTokenParameterCode7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode7
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode7 { get; set; }
Public Property AssuranceTokenParameterCode7 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode7 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode8 Property

AssuranceTokenParameterCode8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode8
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode8 { get; set; }
Public Property AssuranceTokenParameterCode8 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode8 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterCode9 Property

AssuranceTokenParameterCode9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterCode9
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterCode9 { get; set; }
Public Property AssuranceTokenParameterCode9 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterCode9 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue Property

AssuranceTokenParameterValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue { get; set; }
Public Property AssuranceTokenParameterValue As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue1 Property

AssuranceTokenParameterValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue1 { get; set; }
Public Property AssuranceTokenParameterValue1 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue1 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue2 Property

AssuranceTokenParameterValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue2 { get; set; }
Public Property AssuranceTokenParameterValue2 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue2 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue3 Property

AssuranceTokenParameterValue3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue3 { get; set; }
Public Property AssuranceTokenParameterValue3 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue3 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue4 Property

AssuranceTokenParameterValue4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue4 { get; set; }
Public Property AssuranceTokenParameterValue4 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue4 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue5 Property

AssuranceTokenParameterValue5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue5
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue5 { get; set; }
Public Property AssuranceTokenParameterValue5 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue5 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue6 Property

AssuranceTokenParameterValue6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue6 { get; set; }
Public Property AssuranceTokenParameterValue6 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue6 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue7 Property

AssuranceTokenParameterValue7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue7
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue7 { get; set; }
Public Property AssuranceTokenParameterValue7 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue7 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue8 Property

AssuranceTokenParameterValue8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue8
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue8 { get; set; }
Public Property AssuranceTokenParameterValue8 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue8 {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameterValue9 Property

AssuranceTokenParameterValue9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► AssuranceTokenParameterValue9
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceTokenParameterValue9 { get; set; }
Public Property AssuranceTokenParameterValue9 As String
    Get
    Set
public:
property String^ AssuranceTokenParameterValue9 {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AssuranceTokenParameters ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


AST Class

AST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST
RDPCrystal EDI Library
Animal Reproductive Status
Declaration Syntax
C# Visual Basic Visual C++
public class AST : DocumentSegment
Public Class AST _
    Inherits DocumentSegment
public ref class AST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AST()()()() | Initializes a new instance of the AST class
 | Date | Element 3
 | Date1 | Element 6
 | Date2 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | TestPeriodOrIntervalValue | Element 4
 | TestPeriodOrIntervalValue1 | Element 7
 | TestPeriodOrIntervalValue2 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 5
 | UnitOfTimePeriodOrInterval1 | Element 8
 | UnitOfTimePeriodOrInterval2 | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AST


AST Constructor

AST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► AST()()()()
RDPCrystal EDI Library
Initializes a new instance of the AST class
Declaration Syntax
C# Visual Basic Visual C++
public AST()
Public Sub New
public:
AST()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► Date2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue1 Property

TestPeriodOrIntervalValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► TestPeriodOrIntervalValue1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue1 { get; set; }
Public Property TestPeriodOrIntervalValue1 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue1 {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue2 Property

TestPeriodOrIntervalValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► TestPeriodOrIntervalValue2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue2 { get; set; }
Public Property TestPeriodOrIntervalValue2 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue2 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval1 Property

UnitOfTimePeriodOrInterval1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► UnitOfTimePeriodOrInterval1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval1 { get; set; }
Public Property UnitOfTimePeriodOrInterval1 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval2 Property

UnitOfTimePeriodOrInterval2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► UnitOfTimePeriodOrInterval2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval2 { get; set; }
Public Property UnitOfTimePeriodOrInterval2 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AST ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


AT1 Class

AT1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT1
RDPCrystal EDI Library
Bill of Lading Line Item Number
Declaration Syntax
C# Visual Basic Visual C++
public class AT1 : DocumentSegment
Public Class AT1 _
    Inherits DocumentSegment
public ref class AT1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT1()()()() | Initializes a new instance of the AT1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingLineItemNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT1


AT1 Constructor

AT1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT1 ► AT1()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT1 class
Declaration Syntax
C# Visual Basic Visual C++
public AT1()
Public Sub New
public:
AT1()


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT1 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT2 Class

AT2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2
RDPCrystal EDI Library
Bill of Lading Line Item Detail
Declaration Syntax
C# Visual Basic Visual C++
public class AT2 : DocumentSegment
Public Class AT2 _
    Inherits DocumentSegment
public ref class AT2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT2()()()() | Initializes a new instance of the AT2 class
 | CommodityCode | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightClassCode | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 1
 | LadingQuantity1 | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingFormCode | Element 2
 | PackagingFormCode1 | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 5
 | WeightQualifier | Element 3
 | WeightUnitCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT2


AT2 Constructor

AT2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► AT2()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT2 class
Declaration Syntax
C# Visual Basic Visual C++
public AT2()
Public Sub New
public:
AT2()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► CommodityCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


FreightClassCode Property

FreightClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► FreightClassCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreightClassCode { get; set; }
Public Property FreightClassCode As String
    Get
    Set
public:
property String^ FreightClassCode {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► LadingQuantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


LadingQuantity1 Property

LadingQuantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► LadingQuantity1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity1 { get; set; }
Public Property LadingQuantity1 As String
    Get
    Set
public:
property String^ LadingQuantity1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► PackagingFormCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


PackagingFormCode1 Property

PackagingFormCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► PackagingFormCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode1 { get; set; }
Public Property PackagingFormCode1 As String
    Get
    Set
public:
property String^ PackagingFormCode1 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► Weight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► WeightQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► WeightUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT2 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


AT3 Class

AT3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3
RDPCrystal EDI Library
Bill of Lading Rates and Charges
Declaration Syntax
C# Visual Basic Visual C++
public class AT3 : DocumentSegment
Public Class AT3 _
    Inherits DocumentSegment
public ref class AT3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT3()()()() | Initializes a new instance of the AT3 class
 | BillOfLadingChargeCode | Element 6
 | Charge | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | FreightRateQualifier | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | Quantity | Element 5
 | RatedAsQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT3


AT3 Constructor

AT3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► AT3()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT3 class
Declaration Syntax
C# Visual Basic Visual C++
public AT3()
Public Sub New
public:
AT3()


BillOfLadingChargeCode Property

BillOfLadingChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► BillOfLadingChargeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingChargeCode { get; set; }
Public Property BillOfLadingChargeCode As String
    Get
    Set
public:
property String^ BillOfLadingChargeCode {
    String^ get ();
    void set (String^ value);
}


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► Charge
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRateQualifier Property

FreightRateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► FreightRateQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRateQualifier { get; set; }
Public Property FreightRateQualifier As String
    Get
    Set
public:
property String^ FreightRateQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RatedAsQualifier Property

RatedAsQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► RatedAsQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RatedAsQualifier { get; set; }
Public Property RatedAsQualifier As String
    Get
    Set
public:
property String^ RatedAsQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT4 Class

AT4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT4
RDPCrystal EDI Library
Bill of Lading Description
Declaration Syntax
C# Visual Basic Visual C++
public class AT4 : DocumentSegment
Public Class AT4 _
    Inherits DocumentSegment
public ref class AT4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT4()()()() | Initializes a new instance of the AT4 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT4


AT4 Constructor

AT4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT4 ► AT4()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT4 class
Declaration Syntax
C# Visual Basic Visual C++
public AT4()
Public Sub New
public:
AT4()


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT4 ► LadingDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT5 Class

AT5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5
RDPCrystal EDI Library
Bill of Lading Handling Requirements
Declaration Syntax
C# Visual Basic Visual C++
public class AT5 : DocumentSegment
Public Class AT5 _
    Inherits DocumentSegment
public ref class AT5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT5()()()() | Initializes a new instance of the AT5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 1
 | SpecialHandlingDescription | Element 3
 | SpecialServicesCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT5


AT5 Constructor

AT5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5 ► AT5()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT5 class
Declaration Syntax
C# Visual Basic Visual C++
public AT5()
Public Sub New
public:
AT5()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingDescription Property

SpecialHandlingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5 ► SpecialHandlingDescription
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingDescription { get; set; }
Public Property SpecialHandlingDescription As String
    Get
    Set
public:
property String^ SpecialHandlingDescription {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5 ► SpecialServicesCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT6 Class

AT6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6
RDPCrystal EDI Library
International Manifest Information
Declaration Syntax
C# Visual Basic Visual C++
public class AT6 : DocumentSegment
Public Class AT6 _
    Inherits DocumentSegment
public ref class AT6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT6()()()() | Initializes a new instance of the AT6 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImportExportCode | Element 2
 | InternationalDutiableStatusCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationTermsCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT6


AT6 Constructor

AT6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6 ► AT6()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT6 class
Declaration Syntax
C# Visual Basic Visual C++
public AT6()
Public Sub New
public:
AT6()


ImportExportCode Property

ImportExportCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6 ► ImportExportCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ImportExportCode { get; set; }
Public Property ImportExportCode As String
    Get
    Set
public:
property String^ ImportExportCode {
    String^ get ();
    void set (String^ value);
}


InternationalDutiableStatusCode Property

InternationalDutiableStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6 ► InternationalDutiableStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalDutiableStatusCode { get; set; }
Public Property InternationalDutiableStatusCode As String
    Get
    Set
public:
property String^ InternationalDutiableStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransportationTermsCode Property

TransportationTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6 ► TransportationTermsCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationTermsCode { get; set; }
Public Property TransportationTermsCode As String
    Get
    Set
public:
property String^ TransportationTermsCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT7 Class

AT7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7
RDPCrystal EDI Library
Shipment Status Details
Declaration Syntax
C# Visual Basic Visual C++
public class AT7 : DocumentSegment
Public Class AT7 _
    Inherits DocumentSegment
public ref class AT7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT7()()()() | Initializes a new instance of the AT7 class
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentAppointmentStatusCode | Element 3
 | ShipmentStatusCode | Element 1
 | ShipmentStatusOrAppointmentReasonCode | Element 2
 | ShipmentStatusOrAppointmentReasonCode1 | Element 4
 | Time | Element 6
 | TimeCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT7


AT7 Constructor

AT7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► AT7()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT7 class
Declaration Syntax
C# Visual Basic Visual C++
public AT7()
Public Sub New
public:
AT7()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentAppointmentStatusCode Property

ShipmentAppointmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► ShipmentAppointmentStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentAppointmentStatusCode { get; set; }
Public Property ShipmentAppointmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentAppointmentStatusCode {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusCode Property

ShipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► ShipmentStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusCode { get; set; }
Public Property ShipmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusOrAppointmentReasonCode Property

ShipmentStatusOrAppointmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► ShipmentStatusOrAppointmentReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusOrAppointmentReasonCode { get; set; }
Public Property ShipmentStatusOrAppointmentReasonCode As String
    Get
    Set
public:
property String^ ShipmentStatusOrAppointmentReasonCode {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusOrAppointmentReasonCode1 Property

ShipmentStatusOrAppointmentReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► ShipmentStatusOrAppointmentReasonCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusOrAppointmentReasonCode1 { get; set; }
Public Property ShipmentStatusOrAppointmentReasonCode1 As String
    Get
    Set
public:
property String^ ShipmentStatusOrAppointmentReasonCode1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► TimeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT8 Class

AT8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8
RDPCrystal EDI Library
Shipment Weight, Packaging and Quantity Data
Declaration Syntax
C# Visual Basic Visual C++
public class AT8 : DocumentSegment
Public Class AT8 _
    Inherits DocumentSegment
public ref class AT8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT8()()()() | Initializes a new instance of the AT8 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 4
 | LadingQuantity1 | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 7
 | VolumeUnitQualifier | Element 6
 | Weight | Element 3
 | WeightQualifier | Element 1
 | WeightUnitCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT8


AT8 Constructor

AT8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► AT8()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT8 class
Declaration Syntax
C# Visual Basic Visual C++
public AT8()
Public Sub New
public:
AT8()


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► LadingQuantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


LadingQuantity1 Property

LadingQuantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► LadingQuantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity1 { get; set; }
Public Property LadingQuantity1 As String
    Get
    Set
public:
property String^ LadingQuantity1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► Volume
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► WeightQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► WeightUnitCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AT9 Class

AT9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9
RDPCrystal EDI Library
Trailer or Container Dimension and Weight
Declaration Syntax
C# Visual Basic Visual C++
public class AT9 : DocumentSegment
Public Class AT9 _
    Inherits DocumentSegment
public ref class AT9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AT9()()()() | Initializes a new instance of the AT9 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentLength | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 8
 | VolumeUnitQualifier | Element 7
 | Weight | Element 6
 | WeightQualifier | Element 4
 | WeightUnitCode | Element 5
 | Width | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AT9


AT9 Constructor

AT9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► AT9()()()()
RDPCrystal EDI Library
Initializes a new instance of the AT9 class
Declaration Syntax
C# Visual Basic Visual C++
public AT9()
Public Sub New
public:
AT9()


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► EquipmentLength
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► Height
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► Volume
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► Weight
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► WeightQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► WeightUnitCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► Width
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AT9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ATA Class

ATA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA
RDPCrystal EDI Library
Beginning Segment for Motor Carrier Delivery Trailer Manifest
Declaration Syntax
C# Visual Basic Visual C++
public class ATA : DocumentSegment
Public Class ATA _
    Inherits DocumentSegment
public ref class ATA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ATA()()()() | Initializes a new instance of the ATA class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ATA


ATA Constructor

ATA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA ► ATA()()()()
RDPCrystal EDI Library
Initializes a new instance of the ATA class
Declaration Syntax
C# Visual Basic Visual C++
public ATA()
Public Sub New
public:
ATA()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ATH Class

ATH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH
RDPCrystal EDI Library
Resource Authorization
Declaration Syntax
C# Visual Basic Visual C++
public class ATH : DocumentSegment
Public Class ATH _
    Inherits DocumentSegment
public ref class ATH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ATH()()()() | Initializes a new instance of the ATH class
 | Date | Element 2
 | Date1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | Quantity1 | Element 4
 | ResourceAuthorizationCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ATH


ATH Constructor

ATH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► ATH()()()()
RDPCrystal EDI Library
Initializes a new instance of the ATH class
Declaration Syntax
C# Visual Basic Visual C++
public ATH()
Public Sub New
public:
ATH()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ResourceAuthorizationCode Property

ResourceAuthorizationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► ResourceAuthorizationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ResourceAuthorizationCode { get; set; }
Public Property ResourceAuthorizationCode As String
    Get
    Set
public:
property String^ ResourceAuthorizationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ATN Class

ATN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN
RDPCrystal EDI Library
Attendance
Declaration Syntax
C# Visual Basic Visual C++
public class ATN : DocumentSegment
Public Class ATN _
    Inherits DocumentSegment
public ref class ATN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ATN()()()() | Initializes a new instance of the ATN class
 | AttendanceTypeCode | Element 5
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | QuantityQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ATN


ATN Constructor

ATN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► ATN()()()()
RDPCrystal EDI Library
Initializes a new instance of the ATN class
Declaration Syntax
C# Visual Basic Visual C++
public ATN()
Public Sub New
public:
ATN()


AttendanceTypeCode Property

AttendanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► AttendanceTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AttendanceTypeCode { get; set; }
Public Property AttendanceTypeCode As String
    Get
    Set
public:
property String^ AttendanceTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► FrequencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► QuantityQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ATR Class

ATR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR
RDPCrystal EDI Library
Animal Test Result
Declaration Syntax
C# Visual Basic Visual C++
public class ATR : DocumentSegment
Public Class ATR _
    Inherits DocumentSegment
public ref class ATR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ATR()()()() | Initializes a new instance of the ATR class
 | CompositeUnitOfMeasure | Element 5
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonNumericTestValue | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SurfaceLayerPositionCode | Element 9
 | TestPeriodOrIntervalValue | Element 2
 | TestTypeCode | Element 1
 | Time | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ATR


ATR Constructor

ATR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► ATR()()()()
RDPCrystal EDI Library
Initializes a new instance of the ATR class
Declaration Syntax
C# Visual Basic Visual C++
public ATR()
Public Sub New
public:
ATR()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► MeasurementValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


NonNumericTestValue Property

NonNumericTestValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► NonNumericTestValue
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NonNumericTestValue { get; set; }
Public Property NonNumericTestValue As String
    Get
    Set
public:
property String^ NonNumericTestValue {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


TestTypeCode Property

TestTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► TestTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TestTypeCode { get; set; }
Public Property TestTypeCode As String
    Get
    Set
public:
property String^ TestTypeCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► Time
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


ATV Class

ATV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV
RDPCrystal EDI Library
Student Activities and Awards
Declaration Syntax
C# Visual Basic Visual C++
public class ATV : DocumentSegment
Public Class ATV _
    Inherits DocumentSegment
public ref class ATV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ATV()()()() | Initializes a new instance of the ATV class
 | CodeListQualifierCode | Element 1
 | CompositeUnitOfMeasure | Element 6
 | EntityTitle | Element 3
 | EntityTitle1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | LevelOfIndividualTestOrCourseCode | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
 | YesNoConditionOrResponseCode1 | Element 9
 | YesNoConditionOrResponseCode2 | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ATV


ATV Constructor

ATV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► ATV()()()()
RDPCrystal EDI Library
Initializes a new instance of the ATV class
Declaration Syntax
C# Visual Basic Visual C++
public ATV()
Public Sub New
public:
ATV()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


EntityTitle Property

EntityTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► EntityTitle
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTitle { get; set; }
Public Property EntityTitle As String
    Get
    Set
public:
property String^ EntityTitle {
    String^ get ();
    void set (String^ value);
}


EntityTitle1 Property

EntityTitle1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► EntityTitle1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTitle1 { get; set; }
Public Property EntityTitle1 As String
    Get
    Set
public:
property String^ EntityTitle1 {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ATV ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


AVA Class

AVA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AVA
RDPCrystal EDI Library
Funds Availability
Declaration Syntax
C# Visual Basic Visual C++
public class AVA : DocumentSegment
Public Class AVA _
    Inherits DocumentSegment
public ref class AVA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AVA()()()() | Initializes a new instance of the AVA class
 | Availability | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AVA


AVA Constructor

AVA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AVA ► AVA()()()()
RDPCrystal EDI Library
Initializes a new instance of the AVA class
Declaration Syntax
C# Visual Basic Visual C++
public AVA()
Public Sub New
public:
AVA()


Availability Property

Availability Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AVA ► Availability
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Availability { get; set; }
Public Property Availability As String
    Get
    Set
public:
property String^ Availability {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AVA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AVA ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AVA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AWD Class

AWD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD
RDPCrystal EDI Library
Amount with Description
Declaration Syntax
C# Visual Basic Visual C++
public class AWD : DocumentSegment
Public Class AWD _
    Inherits DocumentSegment
public ref class AWD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AWD()()()() | Initializes a new instance of the AWD class
 | AmountQualifyingDescription | Element 1
 | CurrencyCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AWD


AWD Constructor

AWD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► AWD()()()()
RDPCrystal EDI Library
Initializes a new instance of the AWD class
Declaration Syntax
C# Visual Basic Visual C++
public AWD()
Public Sub New
public:
AWD()


AmountQualifyingDescription Property

AmountQualifyingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► AmountQualifyingDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public AmountQualifyingDescription AmountQualifyingDescription { get; set; }
Public Property AmountQualifyingDescription As AmountQualifyingDescription
    Get
    Set
public:
property AmountQualifyingDescription^ AmountQualifyingDescription {
    AmountQualifyingDescription^ get ();
    void set (AmountQualifyingDescription^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► CurrencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► FreeFormMessage
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AWD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


AXL Class

AXL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL
RDPCrystal EDI Library
Vehicle Axle Measurements
Declaration Syntax
C# Visual Basic Visual C++
public class AXL : DocumentSegment
Public Class AXL _
    Inherits DocumentSegment
public ref class AXL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AXL()()()() | Initializes a new instance of the AXL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Length | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementUnitQualifier | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | ReferenceIdentification | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 7
 | WeightQualifier | Element 6
 | Width | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AXL


AXL Constructor

AXL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► AXL()()()()
RDPCrystal EDI Library
Initializes a new instance of the AXL class
Declaration Syntax
C# Visual Basic Visual C++
public AXL()
Public Sub New
public:
AXL()


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► Length
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementUnitQualifier Property

MeasurementUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► MeasurementUnitQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementUnitQualifier { get; set; }
Public Property MeasurementUnitQualifier As String
    Get
    Set
public:
property String^ MeasurementUnitQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► Weight
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► WeightQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► Width
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► AXL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B1 Class

B1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1
RDPCrystal EDI Library
Beginning Segment for Booking or Pick-up/Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class B1 : DocumentSegment
Public Class B1 _
    Inherits DocumentSegment
public ref class B1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B1()()()() | Initializes a new instance of the B1 class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReservationActionCode | Element 4
 | ShipmentIdentificationNumber | Element 2
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B1


B1 Constructor

B1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► B1()()()()
RDPCrystal EDI Library
Initializes a new instance of the B1 class
Declaration Syntax
C# Visual Basic Visual C++
public B1()
Public Sub New
public:
B1()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReservationActionCode Property

ReservationActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► ReservationActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReservationActionCode { get; set; }
Public Property ReservationActionCode As String
    Get
    Set
public:
property String^ ReservationActionCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B10 Class

B10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10
RDPCrystal EDI Library
Beginning Segment for Transportation Carrier Shipment Status Message
Declaration Syntax
C# Visual Basic Visual C++
public class B10 : DocumentSegment
Public Class B10 _
    Inherits DocumentSegment
public ref class B10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B10()()()() | Initializes a new instance of the B10 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InquiryRequestNumber | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 6
 | ReferenceIdentificationQualifier | Element 5
 | ShipmentIdentificationNumber | Element 2
 | StandardCarrierAlphaCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B10


B10 Constructor

B10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► B10()()()()
RDPCrystal EDI Library
Initializes a new instance of the B10 class
Declaration Syntax
C# Visual Basic Visual C++
public B10()
Public Sub New
public:
B10()


InquiryRequestNumber Property

InquiryRequestNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► InquiryRequestNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InquiryRequestNumber { get; set; }
Public Property InquiryRequestNumber As String
    Get
    Set
public:
property String^ InquiryRequestNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B10 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


B11 Class

B11 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11
RDPCrystal EDI Library
Beginning Segment for Shipment Status Inquiry
Declaration Syntax
C# Visual Basic Visual C++
public class B11 : DocumentSegment
Public Class B11 _
    Inherits DocumentSegment
public ref class B11 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B11()()()() | Initializes a new instance of the B11 class
 | AmountQualifierCode | Element 6
 | Date | Element 3
 | Description | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | ItemDescriptionType | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | ReportTransmissionCode | Element 11
 | ServiceLevelCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B11


B11 Constructor

B11 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► B11()()()()
RDPCrystal EDI Library
Initializes a new instance of the B11 class
Declaration Syntax
C# Visual Basic Visual C++
public B11()
Public Sub New
public:
B11()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► AmountQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


ItemDescriptionType Property

ItemDescriptionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► ItemDescriptionType
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDescriptionType { get; set; }
Public Property ItemDescriptionType As String
    Get
    Set
public:
property String^ ItemDescriptionType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► ReportTransmissionCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► ServiceLevelCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B11 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B12 Class

B12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12
RDPCrystal EDI Library
Beginning Segment for Consolidation of Goods In Container
Declaration Syntax
C# Visual Basic Visual C++
public class B12 : DocumentSegment
Public Class B12 _
    Inherits DocumentSegment
public ref class B12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B12()()()() | Initializes a new instance of the B12 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | EquipmentType | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B12


B12 Constructor

B12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12 ► B12()()()()
RDPCrystal EDI Library
Initializes a new instance of the B12 class
Declaration Syntax
C# Visual Basic Visual C++
public B12()
Public Sub New
public:
B12()


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12 ► EquipmentType
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B13 Class

B13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B13
RDPCrystal EDI Library
Beginning Segment for Appointment Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class B13 : DocumentSegment
Public Class B13 _
    Inherits DocumentSegment
public ref class B13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B13()()()() | Initializes a new instance of the B13 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B13


B13 Constructor

B13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B13 ► B13()()()()
RDPCrystal EDI Library
Initializes a new instance of the B13 class
Declaration Syntax
C# Visual Basic Visual C++
public B13()
Public Sub New
public:
B13()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B13 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B13 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B2 Class

B2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2
RDPCrystal EDI Library
Beginning Segment for Shipment Information Transaction
Declaration Syntax
C# Visual Basic Visual C++
public class B2 : DocumentSegment
Public Class B2 _
    Inherits DocumentSegment
public ref class B2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B2()()()() | Initializes a new instance of the B2 class
 | CustomsDocumentationHandlingCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 12
 | ShipmentIdentificationNumber | Element 4
 | ShipmentMethodOfPayment | Element 6
 | ShipmentQualifier | Element 7
 | ShipmentWeightCode | Element 9
 | StandardCarrierAlphaCode | Element 2
 | StandardPointLocationCode | Element 3
 | TariffServiceCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalEquipment | Element 8
 | TransportationTermsCode | Element 11
 | WeightUnitCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B2


B2 Constructor

B2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► B2()()()()
RDPCrystal EDI Library
Initializes a new instance of the B2 class
Declaration Syntax
C# Visual Basic Visual C++
public B2()
Public Sub New
public:
B2()


CustomsDocumentationHandlingCode Property

CustomsDocumentationHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► CustomsDocumentationHandlingCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsDocumentationHandlingCode { get; set; }
Public Property CustomsDocumentationHandlingCode As String
    Get
    Set
public:
property String^ CustomsDocumentationHandlingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► PaymentMethodCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


ShipmentQualifier Property

ShipmentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► ShipmentQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentQualifier { get; set; }
Public Property ShipmentQualifier As String
    Get
    Set
public:
property String^ ShipmentQualifier {
    String^ get ();
    void set (String^ value);
}


ShipmentWeightCode Property

ShipmentWeightCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► ShipmentWeightCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentWeightCode { get; set; }
Public Property ShipmentWeightCode As String
    Get
    Set
public:
property String^ ShipmentWeightCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


TariffServiceCode Property

TariffServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► TariffServiceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TariffServiceCode { get; set; }
Public Property TariffServiceCode As String
    Get
    Set
public:
property String^ TariffServiceCode {
    String^ get ();
    void set (String^ value);
}


TotalEquipment Property

TotalEquipment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► TotalEquipment
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TotalEquipment { get; set; }
Public Property TotalEquipment As String
    Get
    Set
public:
property String^ TotalEquipment {
    String^ get ();
    void set (String^ value);
}


TransportationTermsCode Property

TransportationTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► TransportationTermsCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationTermsCode { get; set; }
Public Property TransportationTermsCode As String
    Get
    Set
public:
property String^ TransportationTermsCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► WeightUnitCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B2A Class

B2A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2A
RDPCrystal EDI Library
Set Purpose
Declaration Syntax
C# Visual Basic Visual C++
public class B2A : DocumentSegment
Public Class B2A _
    Inherits DocumentSegment
public ref class B2A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B2A()()()() | Initializes a new instance of the B2A class
 | ApplicationType | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B2A


B2A Constructor

B2A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2A ► B2A()()()()
RDPCrystal EDI Library
Initializes a new instance of the B2A class
Declaration Syntax
C# Visual Basic Visual C++
public B2A()
Public Sub New
public:
B2A()


ApplicationType Property

ApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2A ► ApplicationType
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationType { get; set; }
Public Property ApplicationType As String
    Get
    Set
public:
property String^ ApplicationType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2A ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B2A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B3 Class

B3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3
RDPCrystal EDI Library
Beginning Segment for Carrier’s Invoice
Declaration Syntax
C# Visual Basic Visual C++
public class B3 : DocumentSegment
Public Class B3 _
    Inherits DocumentSegment
public ref class B3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B3()()()() | Initializes a new instance of the B3 class
 | CorrectionIndicator | Element 8
 | Date | Element 6
 | Date1 | Element 12
 | DateTimeQualifier | Element 10
 | DeliveryDate | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetAmountDue | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 3
 | ShipmentMethodOfPayment | Element 4
 | ShipmentQualifier | Element 1
 | StandardCarrierAlphaCode | Element 11
 | TariffServiceCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationTermsCode | Element 14
 | WeightUnitCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B3


B3 Constructor

B3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► B3()()()()
RDPCrystal EDI Library
Initializes a new instance of the B3 class
Declaration Syntax
C# Visual Basic Visual C++
public B3()
Public Sub New
public:
B3()


CorrectionIndicator Property

CorrectionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► CorrectionIndicator
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CorrectionIndicator { get; set; }
Public Property CorrectionIndicator As String
    Get
    Set
public:
property String^ CorrectionIndicator {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► Date1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► DateTimeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DeliveryDate Property

DeliveryDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► DeliveryDate
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryDate { get; set; }
Public Property DeliveryDate As String
    Get
    Set
public:
property String^ DeliveryDate {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► InvoiceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetAmountDue Property

NetAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► NetAmountDue
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NetAmountDue { get; set; }
Public Property NetAmountDue As String
    Get
    Set
public:
property String^ NetAmountDue {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


ShipmentQualifier Property

ShipmentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► ShipmentQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentQualifier { get; set; }
Public Property ShipmentQualifier As String
    Get
    Set
public:
property String^ ShipmentQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TariffServiceCode Property

TariffServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► TariffServiceCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TariffServiceCode { get; set; }
Public Property TariffServiceCode As String
    Get
    Set
public:
property String^ TariffServiceCode {
    String^ get ();
    void set (String^ value);
}


TransportationTermsCode Property

TransportationTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► TransportationTermsCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationTermsCode { get; set; }
Public Property TransportationTermsCode As String
    Get
    Set
public:
property String^ TransportationTermsCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► WeightUnitCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B3A Class

B3A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3A
RDPCrystal EDI Library
Invoice Type
Declaration Syntax
C# Visual Basic Visual C++
public class B3A : DocumentSegment
Public Class B3A _
    Inherits DocumentSegment
public ref class B3A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B3A()()()() | Initializes a new instance of the B3A class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfShipments | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B3A


B3A Constructor

B3A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3A ► B3A()()()()
RDPCrystal EDI Library
Initializes a new instance of the B3A class
Declaration Syntax
C# Visual Basic Visual C++
public B3A()
Public Sub New
public:
B3A()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfShipments Property

NumberOfShipments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3A ► NumberOfShipments
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfShipments { get; set; }
Public Property NumberOfShipments As String
    Get
    Set
public:
property String^ NumberOfShipments {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3A ► TransactionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B3B Class

B3B Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B
RDPCrystal EDI Library
Beginning Segment for Carrier’s Invoice
Declaration Syntax
C# Visual Basic Visual C++
public class B3B : DocumentSegment
Public Class B3B _
    Inherits DocumentSegment
public ref class B3B : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B3B()()()() | Initializes a new instance of the B3B class
 | CorrectionIndicator | Element 10
 | CurrencyCode | Element 11
 | Date | Element 3
 | Date1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetAmountDue | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 8
 | ShipmentMethodOfPayment | Element 2
 | StandardCarrierAlphaCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 7
 | WeightUnitCode | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B3B


B3B Constructor

B3B Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► B3B()()()()
RDPCrystal EDI Library
Initializes a new instance of the B3B class
Declaration Syntax
C# Visual Basic Visual C++
public B3B()
Public Sub New
public:
B3B()


CorrectionIndicator Property

CorrectionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► CorrectionIndicator
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CorrectionIndicator { get; set; }
Public Property CorrectionIndicator As String
    Get
    Set
public:
property String^ CorrectionIndicator {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► CurrencyCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► InvoiceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetAmountDue Property

NetAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► NetAmountDue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NetAmountDue { get; set; }
Public Property NetAmountDue As String
    Get
    Set
public:
property String^ NetAmountDue {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► WeightUnitCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B3B ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B4 Class

B4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4
RDPCrystal EDI Library
Beginning Segment for Inquiry or Reply
Declaration Syntax
C# Visual Basic Visual C++
public class B4 : DocumentSegment
Public Class B4 _
    Inherits DocumentSegment
public ref class B4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B4()()()() | Initializes a new instance of the B4 class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 7
 | EquipmentNumber | Element 8
 | EquipmentNumberCheckDigit | Element 13
 | EquipmentStatusCode | Element 9
 | EquipmentType | Element 10
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InquiryRequestNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 11
 | LocationQualifier | Element 12
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentStatusCode | Element 3
 | SpecialHandlingCode | Element 1
 | StatusLocation | Element 6
 | StatusTime | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B4


B4 Constructor

B4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► B4()()()()
RDPCrystal EDI Library
Initializes a new instance of the B4 class
Declaration Syntax
C# Visual Basic Visual C++
public B4()
Public Sub New
public:
B4()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► EquipmentInitial
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► EquipmentNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentNumberCheckDigit Property

EquipmentNumberCheckDigit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► EquipmentNumberCheckDigit
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumberCheckDigit { get; set; }
Public Property EquipmentNumberCheckDigit As String
    Get
    Set
public:
property String^ EquipmentNumberCheckDigit {
    String^ get ();
    void set (String^ value);
}


EquipmentStatusCode Property

EquipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► EquipmentStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode { get; set; }
Public Property EquipmentStatusCode As String
    Get
    Set
public:
property String^ EquipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► EquipmentType
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


InquiryRequestNumber Property

InquiryRequestNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► InquiryRequestNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InquiryRequestNumber { get; set; }
Public Property InquiryRequestNumber As String
    Get
    Set
public:
property String^ InquiryRequestNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► LocationIdentifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► LocationQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusCode Property

ShipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► ShipmentStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusCode { get; set; }
Public Property ShipmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


StatusLocation Property

StatusLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► StatusLocation
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StatusLocation { get; set; }
Public Property StatusLocation As String
    Get
    Set
public:
property String^ StatusLocation {
    String^ get ();
    void set (String^ value);
}


StatusTime Property

StatusTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► StatusTime
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StatusTime { get; set; }
Public Property StatusTime As String
    Get
    Set
public:
property String^ StatusTime {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B5 Class

B5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5
RDPCrystal EDI Library
Beginning Segment for Acceptance/Rejection
Declaration Syntax
C# Visual Basic Visual C++
public class B5 : DocumentSegment
Public Class B5 _
    Inherits DocumentSegment
public ref class B5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B5()()()() | Initializes a new instance of the B5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfAcceptedTransactionSets | Element 2
 | NumberOfReceivedTransactionSets | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B5


B5 Constructor

B5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► B5()()()()
RDPCrystal EDI Library
Initializes a new instance of the B5 class
Declaration Syntax
C# Visual Basic Visual C++
public B5()
Public Sub New
public:
B5()


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► GroupControlNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfAcceptedTransactionSets Property

NumberOfAcceptedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► NumberOfAcceptedTransactionSets
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfAcceptedTransactionSets { get; set; }
Public Property NumberOfAcceptedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfAcceptedTransactionSets {
    String^ get ();
    void set (String^ value);
}


NumberOfReceivedTransactionSets Property

NumberOfReceivedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► NumberOfReceivedTransactionSets
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfReceivedTransactionSets { get; set; }
Public Property NumberOfReceivedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfReceivedTransactionSets {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B9 Class

B9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9
RDPCrystal EDI Library
Beginning Segment for Logistics Services
Declaration Syntax
C# Visual Basic Visual C++
public class B9 : DocumentSegment
Public Class B9 _
    Inherits DocumentSegment
public ref class B9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B9()()()() | Initializes a new instance of the B9 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ShipmentMethodOfPayment | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B9


B9 Constructor

B9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9 ► B9()()()()
RDPCrystal EDI Library
Initializes a new instance of the B9 class
Declaration Syntax
C# Visual Basic Visual C++
public B9()
Public Sub New
public:
B9()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9 ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


B9A Class

B9A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9A
RDPCrystal EDI Library
Service Request
Declaration Syntax
C# Visual Basic Visual C++
public class B9A : DocumentSegment
Public Class B9A _
    Inherits DocumentSegment
public ref class B9A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | B9A()()()() | Initializes a new instance of the B9A class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceRequestCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | B9A


B9A Constructor

B9A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9A ► B9A()()()()
RDPCrystal EDI Library
Initializes a new instance of the B9A class
Declaration Syntax
C# Visual Basic Visual C++
public B9A()
Public Sub New
public:
B9A()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServiceRequestCode Property

ServiceRequestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9A ► ServiceRequestCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceRequestCode { get; set; }
Public Property ServiceRequestCode As String
    Get
    Set
public:
property String^ ServiceRequestCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► B9A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BA1 Class

BA1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1
RDPCrystal EDI Library
Export Shipment Identifying Information
Declaration Syntax
C# Visual Basic Visual C++
public class BA1 : DocumentSegment
Public Class BA1 _
    Inherits DocumentSegment
public ref class BA1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BA1()()()() | Initializes a new instance of the BA1 class
 | ActionCode | Element 2
 | Authority | Element 9
 | CountryCode | Element 4
 | CountryCode1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 6
 | ReferenceIdentification | Element 5
 | RelatedCompanyIndicationCode | Element 1
 | StandardCarrierAlphaCode | Element 10
 | StateOrProvinceCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 3
 | VesselName | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BA1


BA1 Constructor

BA1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► BA1()()()()
RDPCrystal EDI Library
Initializes a new instance of the BA1 class
Declaration Syntax
C# Visual Basic Visual C++
public BA1()
Public Sub New
public:
BA1()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Authority Property

Authority Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► Authority
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Authority { get; set; }
Public Property Authority As String
    Get
    Set
public:
property String^ Authority {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountryCode1 Property

CountryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► CountryCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode1 { get; set; }
Public Property CountryCode1 As String
    Get
    Set
public:
property String^ CountryCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► LocationIdentifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► PostalCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


RelatedCompanyIndicationCode Property

RelatedCompanyIndicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► RelatedCompanyIndicationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCompanyIndicationCode { get; set; }
Public Property RelatedCompanyIndicationCode As String
    Get
    Set
public:
property String^ RelatedCompanyIndicationCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► VesselName
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BA2 Class

BA2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2
RDPCrystal EDI Library
Beginning Segment for Cargo Terminal Information
Declaration Syntax
C# Visual Basic Visual C++
public class BA2 : DocumentSegment
Public Class BA2 _
    Inherits DocumentSegment
public ref class BA2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BA2()()()() | Initializes a new instance of the BA2 class
 | Date | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PierName | Element 7
 | PierNumber | Element 6
 | PortName | Element 9
 | PortOrTerminalFunctionCode | Element 8
 | ReferenceIdentification | Element 4
 | ReferenceIdentification1 | Element 5
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VesselCode | Element 2
 | VesselCodeQualifier | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BA2


BA2 Constructor

BA2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► BA2()()()()
RDPCrystal EDI Library
Initializes a new instance of the BA2 class
Declaration Syntax
C# Visual Basic Visual C++
public BA2()
Public Sub New
public:
BA2()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► Date
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► FlightVoyageNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PierName Property

PierName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► PierName
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PierName { get; set; }
Public Property PierName As String
    Get
    Set
public:
property String^ PierName {
    String^ get ();
    void set (String^ value);
}


PierNumber Property

PierNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► PierNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PierNumber { get; set; }
Public Property PierNumber As String
    Get
    Set
public:
property String^ PierNumber {
    String^ get ();
    void set (String^ value);
}


PortName Property

PortName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► PortName
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PortName { get; set; }
Public Property PortName As String
    Get
    Set
public:
property String^ PortName {
    String^ get ();
    void set (String^ value);
}


PortOrTerminalFunctionCode Property

PortOrTerminalFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► PortOrTerminalFunctionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PortOrTerminalFunctionCode { get; set; }
Public Property PortOrTerminalFunctionCode As String
    Get
    Set
public:
property String^ PortOrTerminalFunctionCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► VesselCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselCodeQualifier Property

VesselCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► VesselCodeQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCodeQualifier { get; set; }
Public Property VesselCodeQualifier As String
    Get
    Set
public:
property String^ VesselCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BA2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BAA Class

BAA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA
RDPCrystal EDI Library
Beginning Segment for Product Transfer Account Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class BAA : DocumentSegment
Public Class BAA _
    Inherits DocumentSegment
public ref class BAA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BAA()()()() | Initializes a new instance of the BAA class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | Time | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BAA


BAA Constructor

BAA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► BAA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BAA class
Declaration Syntax
C# Visual Basic Visual C++
public BAA()
Public Sub New
public:
BAA()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► TransactionTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BAK Class

BAK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK
RDPCrystal EDI Library
Beginning Segment for Purchase Order Acknowledgment
Declaration Syntax
C# Visual Basic Visual C++
public class BAK : DocumentSegment
Public Class BAK _
    Inherits DocumentSegment
public ref class BAK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BAK()()()() | Initializes a new instance of the BAK class
 | AcknowledgmentType | Element 2
 | ContractNumber | Element 7
 | Date | Element 4
 | Date1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 3
 | ReferenceIdentification | Element 8
 | ReleaseNumber | Element 5
 | RequestReferenceNumber | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BAK


BAK Constructor

BAK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► BAK()()()()
RDPCrystal EDI Library
Initializes a new instance of the BAK class
Declaration Syntax
C# Visual Basic Visual C++
public BAK()
Public Sub New
public:
BAK()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► AcknowledgmentType
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► ContractNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► Date1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► ReleaseNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


RequestReferenceNumber Property

RequestReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► RequestReferenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RequestReferenceNumber { get; set; }
Public Property RequestReferenceNumber As String
    Get
    Set
public:
property String^ RequestReferenceNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► TransactionTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BAL Class

BAL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL
RDPCrystal EDI Library
Balance Detail
Declaration Syntax
C# Visual Basic Visual C++
public class BAL : DocumentSegment
Public Class BAL _
    Inherits DocumentSegment
public ref class BAL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BAL()()()() | Initializes a new instance of the BAL class
 | AmountQualifierCode | Element 2
 | BalanceTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BAL


BAL Constructor

BAL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL ► BAL()()()()
RDPCrystal EDI Library
Initializes a new instance of the BAL class
Declaration Syntax
C# Visual Basic Visual C++
public BAL()
Public Sub New
public:
BAL()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


BalanceTypeCode Property

BalanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL ► BalanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BalanceTypeCode { get; set; }
Public Property BalanceTypeCode As String
    Get
    Set
public:
property String^ BalanceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BAT Class

BAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT
RDPCrystal EDI Library
Batch
Declaration Syntax
C# Visual Basic Visual C++
public class BAT : DocumentSegment
Public Class BAT _
    Inherits DocumentSegment
public ref class BAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BAT()()()() | Initializes a new instance of the BAT class
 | BatchTypeCode | Element 4
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | Time | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BAT


BAT Constructor

BAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► BAT()()()()
RDPCrystal EDI Library
Initializes a new instance of the BAT class
Declaration Syntax
C# Visual Basic Visual C++
public BAT()
Public Sub New
public:
BAT()


BatchTypeCode Property

BatchTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► BatchTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BatchTypeCode { get; set; }
Public Property BatchTypeCode As String
    Get
    Set
public:
property String^ BatchTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► Time
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BAU Class

BAU Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU
RDPCrystal EDI Library
Beginning Segment for the Debit Authorization
Declaration Syntax
C# Visual Basic Visual C++
public class BAU : DocumentSegment
Public Class BAU _
    Inherits DocumentSegment
public ref class BAU : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BAU()()()() | Initializes a new instance of the BAU class
 | AccountNumber | Element 5
 | DFIIdentificationNumber | Element 4
 | DFIIDNumberQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 2
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BAU


BAU Constructor

BAU Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► BAU()()()()
RDPCrystal EDI Library
Initializes a new instance of the BAU class
Declaration Syntax
C# Visual Basic Visual C++
public BAU()
Public Sub New
public:
BAU()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► AccountNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► Name1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► PaymentMethodCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAU ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BAX Class

BAX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX
RDPCrystal EDI Library
Beginning Segment for Advance Consist and Transportation Automatic Equipment ID
Declaration Syntax
C# Visual Basic Visual C++
public class BAX : DocumentSegment
Public Class BAX _
    Inherits DocumentSegment
public ref class BAX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BAX()()()() | Initializes a new instance of the BAX class
 | Date | Element 4
 | Date1 | Element 10
 | DateTimeQualifier | Element 3
 | DirectionIdentifierCode | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 8
 | ServiceLevelCode | Element 14
 | StandardPointLocationCode | Element 1
 | StandardPointLocationCode1 | Element 7
 | Time | Element 5
 | Time1 | Element 11
 | TimeCode | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 13
 | TypeOfConsistCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BAX


BAX Constructor

BAX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► BAX()()()()
RDPCrystal EDI Library
Initializes a new instance of the BAX class
Declaration Syntax
C# Visual Basic Visual C++
public BAX()
Public Sub New
public:
BAX()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► Date1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DirectionIdentifierCode Property

DirectionIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► DirectionIdentifierCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode { get; set; }
Public Property DirectionIdentifierCode As String
    Get
    Set
public:
property String^ DirectionIdentifierCode {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► ServiceLevelCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► StandardPointLocationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► Time1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► TimeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TypeOfConsistCode Property

TypeOfConsistCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► TypeOfConsistCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfConsistCode { get; set; }
Public Property TypeOfConsistCode As String
    Get
    Set
public:
property String^ TypeOfConsistCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BAX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BBC Class

BBC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BBC
RDPCrystal EDI Library
Legal Claims
Declaration Syntax
C# Visual Basic Visual C++
public class BBC : DocumentSegment
Public Class BBC _
    Inherits DocumentSegment
public ref class BBC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BBC()()()() | Initializes a new instance of the BBC class
 | ClaimTypeCode | Element 1
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BBC


BBC Constructor

BBC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BBC ► BBC()()()()
RDPCrystal EDI Library
Initializes a new instance of the BBC class
Declaration Syntax
C# Visual Basic Visual C++
public BBC()
Public Sub New
public:
BBC()


ClaimTypeCode Property

ClaimTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BBC ► ClaimTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimTypeCode { get; set; }
Public Property ClaimTypeCode As String
    Get
    Set
public:
property String^ ClaimTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BBC ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BBC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BBC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BC Class

BC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC
RDPCrystal EDI Library
Beginning Segment for Contract Completion Status
Declaration Syntax
C# Visual Basic Visual C++
public class BC : DocumentSegment
Public Class BC _
    Inherits DocumentSegment
public ref class BC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BC()()()() | Initializes a new instance of the BC class
 | ActionCode | Element 7
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentification1 | Element 5
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BC


BC Constructor

BC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► BC()()()()
RDPCrystal EDI Library
Initializes a new instance of the BC class
Declaration Syntax
C# Visual Basic Visual C++
public BC()
Public Sub New
public:
BC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► ActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► ReferenceIdentification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCA Class

BCA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA
RDPCrystal EDI Library
Beginning Segment for Purchase Order Change Acknowledgment
Declaration Syntax
C# Visual Basic Visual C++
public class BCA : DocumentSegment
Public Class BCA _
    Inherits DocumentSegment
public ref class BCA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCA()()()() | Initializes a new instance of the BCA class
 | AcknowledgmentType | Element 2
 | ChangeOrderSequenceNumber | Element 5
 | ContractNumber | Element 8
 | Date | Element 6
 | Date1 | Element 10
 | Date2 | Element 11
 | Date3 | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 3
 | PurchaseOrderTypeCode | Element 13
 | ReferenceIdentification | Element 9
 | ReleaseNumber | Element 4
 | RequestReferenceNumber | Element 7
 | SecurityLevelCode | Element 14
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCA


BCA Constructor

BCA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► BCA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCA class
Declaration Syntax
C# Visual Basic Visual C++
public BCA()
Public Sub New
public:
BCA()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► AcknowledgmentType
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► ContractNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► Date1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► Date2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► Date3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderTypeCode Property

PurchaseOrderTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► PurchaseOrderTypeCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderTypeCode { get; set; }
Public Property PurchaseOrderTypeCode As String
    Get
    Set
public:
property String^ PurchaseOrderTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► ReleaseNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


RequestReferenceNumber Property

RequestReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► RequestReferenceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RequestReferenceNumber { get; set; }
Public Property RequestReferenceNumber As String
    Get
    Set
public:
property String^ RequestReferenceNumber {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► SecurityLevelCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► TransactionTypeCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCD Class

BCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD
RDPCrystal EDI Library
Beginning Credit/Debit Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class BCD : DocumentSegment
Public Class BCD _
    Inherits DocumentSegment
public ref class BCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCD()()()() | Initializes a new instance of the BCD class
 | ActionCode | Element 15
 | Amount | Element 4
 | CreditDebitAdjustmentNumber | Element 2
 | CreditDebitFlagCode | Element 5
 | Date | Element 1
 | Date1 | Element 6
 | Date2 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 10
 | ReferenceIdentification | Element 14
 | ReferenceIdentificationQualifier | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 3
 | TransactionSetPurposeCode | Element 11
 | TransactionTypeCode | Element 12
 | VendorOrderNumber | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCD


BCD Constructor

BCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► BCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCD class
Declaration Syntax
C# Visual Basic Visual C++
public BCD()
Public Sub New
public:
BCD()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► ActionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CreditDebitAdjustmentNumber Property

CreditDebitAdjustmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► CreditDebitAdjustmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitAdjustmentNumber { get; set; }
Public Property CreditDebitAdjustmentNumber As String
    Get
    Set
public:
property String^ CreditDebitAdjustmentNumber {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► Date2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► InvoiceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► ReferenceIdentification
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► TransactionHandlingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► TransactionTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


VendorOrderNumber Property

VendorOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► VendorOrderNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VendorOrderNumber { get; set; }
Public Property VendorOrderNumber As String
    Get
    Set
public:
property String^ VendorOrderNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCH Class

BCH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH
RDPCrystal EDI Library
Beginning Segment for Purchase Order Change
Declaration Syntax
C# Visual Basic Visual C++
public class BCH : DocumentSegment
Public Class BCH _
    Inherits DocumentSegment
public ref class BCH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCH()()()() | Initializes a new instance of the BCH class
 | AcknowledgmentType | Element 14
 | ChangeOrderSequenceNumber | Element 5
 | ContractNumber | Element 8
 | ContractTypeCode | Element 12
 | Date | Element 6
 | Date1 | Element 10
 | Date2 | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseCategory | Element 16
 | PurchaseOrderNumber | Element 3
 | PurchaseOrderTypeCode | Element 2
 | ReferenceIdentification | Element 9
 | ReleaseNumber | Element 4
 | RequestReferenceNumber | Element 7
 | SecurityLevelCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCH


BCH Constructor

BCH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► BCH()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCH class
Declaration Syntax
C# Visual Basic Visual C++
public BCH()
Public Sub New
public:
BCH()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► AcknowledgmentType
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► ContractNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► ContractTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► Date1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► Date2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseCategory Property

PurchaseCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► PurchaseCategory
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseCategory { get; set; }
Public Property PurchaseCategory As String
    Get
    Set
public:
property String^ PurchaseCategory {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderTypeCode Property

PurchaseOrderTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► PurchaseOrderTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderTypeCode { get; set; }
Public Property PurchaseOrderTypeCode As String
    Get
    Set
public:
property String^ PurchaseOrderTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► ReleaseNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


RequestReferenceNumber Property

RequestReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► RequestReferenceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RequestReferenceNumber { get; set; }
Public Property RequestReferenceNumber As String
    Get
    Set
public:
property String^ RequestReferenceNumber {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► SecurityLevelCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► TransactionTypeCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCI Class

BCI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI
RDPCrystal EDI Library
Basic Claim Information
Declaration Syntax
C# Visual Basic Visual C++
public class BCI : DocumentSegment
Public Class BCI _
    Inherits DocumentSegment
public ref class BCI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCI()()()() | Initializes a new instance of the BCI class
 | CurrencyCode | Element 8
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 1
 | InsuranceTypeCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReportTypeCode | Element 7
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCI


BCI Constructor

BCI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► BCI()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCI class
Declaration Syntax
C# Visual Basic Visual C++
public BCI()
Public Sub New
public:
BCI()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► CurrencyCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► IndustryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► InsuranceTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► ReportTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCM Class

BCM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM
RDPCrystal EDI Library
Beginning Segment for Contractor Cost Data Reporting
Declaration Syntax
C# Visual Basic Visual C++
public class BCM : DocumentSegment
Public Class BCM _
    Inherits DocumentSegment
public ref class BCM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCM()()()() | Initializes a new instance of the BCM class
 | ContractActionCode | Element 6
 | ContractingFundingCode | Element 9
 | ContractNumber | Element 4
 | ContractTypeCode | Element 10
 | CurrencyCode | Element 12
 | Date | Element 2
 | Date1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 5
 | FreeformDescription1 | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramTypeCode | Element 7
 | SecurityLevelCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCM


BCM Constructor

BCM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► BCM()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCM class
Declaration Syntax
C# Visual Basic Visual C++
public BCM()
Public Sub New
public:
BCM()


ContractActionCode Property

ContractActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► ContractActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractActionCode { get; set; }
Public Property ContractActionCode As String
    Get
    Set
public:
property String^ ContractActionCode {
    String^ get ();
    void set (String^ value);
}


ContractingFundingCode Property

ContractingFundingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► ContractingFundingCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ContractingFundingCode { get; set; }
Public Property ContractingFundingCode As String
    Get
    Set
public:
property String^ ContractingFundingCode {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► ContractNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► ContractTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► CurrencyCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► FreeformDescription
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


FreeformDescription1 Property

FreeformDescription1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► FreeformDescription1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription1 { get; set; }
Public Property FreeformDescription1 As String
    Get
    Set
public:
property String^ FreeformDescription1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProgramTypeCode Property

ProgramTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► ProgramTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramTypeCode { get; set; }
Public Property ProgramTypeCode As String
    Get
    Set
public:
property String^ ProgramTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► SecurityLevelCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCO Class

BCO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO
RDPCrystal EDI Library
Beginning Segment for Procurement Notices
Declaration Syntax
C# Visual Basic Visual C++
public class BCO : DocumentSegment
Public Class BCO _
    Inherits DocumentSegment
public ref class BCO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCO()()()() | Initializes a new instance of the BCO class
 | AcknowledgmentType | Element 8
 | ActionCode | Element 12
 | ContractStatusCode | Element 5
 | Date | Element 3
 | Date1 | Element 6
 | Date2 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentification1 | Element 10
 | ReferenceIdentificationQualifier | Element 9
 | RequestForQuoteReferenceNumber | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCO


BCO Constructor

BCO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► BCO()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCO class
Declaration Syntax
C# Visual Basic Visual C++
public BCO()
Public Sub New
public:
BCO()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► AcknowledgmentType
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► ActionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ContractStatusCode Property

ContractStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► ContractStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ContractStatusCode { get; set; }
Public Property ContractStatusCode As String
    Get
    Set
public:
property String^ ContractStatusCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► Date2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► ReferenceIdentification1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


RequestForQuoteReferenceNumber Property

RequestForQuoteReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► RequestForQuoteReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RequestForQuoteReferenceNumber { get; set; }
Public Property RequestForQuoteReferenceNumber As String
    Get
    Set
public:
property String^ RequestForQuoteReferenceNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► TransactionTypeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCP Class

BCP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP
RDPCrystal EDI Library
Beginning Segment for Contract Pricing Proposal
Declaration Syntax
C# Visual Basic Visual C++
public class BCP : DocumentSegment
Public Class BCP _
    Inherits DocumentSegment
public ref class BCP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCP()()()() | Initializes a new instance of the BCP class
 | ChangeOrderSequenceNumber | Element 9
 | ContractActionCode | Element 5
 | ContractTypeCode | Element 6
 | Date | Element 4
 | Date1 | Element 7
 | Description | Element 12
 | Description1 | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 10
 | ReferenceIdentification2 | Element 11
 | ReferenceIdentificationQualifier | Element 2
 | Time | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCP


BCP Constructor

BCP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► BCP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCP class
Declaration Syntax
C# Visual Basic Visual C++
public BCP()
Public Sub New
public:
BCP()


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


ContractActionCode Property

ContractActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ContractActionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ContractActionCode { get; set; }
Public Property ContractActionCode As String
    Get
    Set
public:
property String^ ContractActionCode {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ContractTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Description
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Description1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ReferenceIdentification2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Time
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCQ Class

BCQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ
RDPCrystal EDI Library
Beginning Segment for Shipper’s Car Order
Declaration Syntax
C# Visual Basic Visual C++
public class BCQ : DocumentSegment
Public Class BCQ _
    Inherits DocumentSegment
public ref class BCQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCQ()()()() | Initializes a new instance of the BCQ class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | StandardCarrierAlphaCode | Element 6
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCQ


BCQ Constructor

BCQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► BCQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCQ class
Declaration Syntax
C# Visual Basic Visual C++
public BCQ()
Public Sub New
public:
BCQ()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCS Class

BCS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS
RDPCrystal EDI Library
Beginning Segment for Project Cost Reporting
Declaration Syntax
C# Visual Basic Visual C++
public class BCS : DocumentSegment
Public Class BCS _
    Inherits DocumentSegment
public ref class BCS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCS()()()() | Initializes a new instance of the BCS class
 | CompositeUnitOfMeasure | Element 12
 | ContractNumber | Element 3
 | ContractTypeCode | Element 5
 | Date | Element 2
 | Date1 | Element 4
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 10
 | Percent1 | Element 11
 | ProgramTypeCode | Element 8
 | ReferenceIdentification | Element 7
 | SecurityLevelCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCS


BCS Constructor

BCS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► BCS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCS class
Declaration Syntax
C# Visual Basic Visual C++
public BCS()
Public Sub New
public:
BCS()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► ContractNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► ContractTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Percent
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Percent1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


ProgramTypeCode Property

ProgramTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► ProgramTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramTypeCode { get; set; }
Public Property ProgramTypeCode As String
    Get
    Set
public:
property String^ ProgramTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► SecurityLevelCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCT Class

BCT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT
RDPCrystal EDI Library
Beginning Segment for Price/Sales Catalog
Declaration Syntax
C# Visual Basic Visual C++
public class BCT : DocumentSegment
Public Class BCT _
    Inherits DocumentSegment
public ref class BCT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCT()()()() | Initializes a new instance of the BCT class
 | CatalogNumber | Element 2
 | CatalogNumber1 | Element 6
 | CatalogPurposeCode | Element 1
 | CatalogRevisionNumber | Element 4
 | CatalogRevisionNumber1 | Element 8
 | CatalogVersionNumber | Element 3
 | CatalogVersionNumber1 | Element 7
 | Description | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 10
 | UnitOrBasisForMeasurementCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCT


BCT Constructor

BCT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► BCT()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCT class
Declaration Syntax
C# Visual Basic Visual C++
public BCT()
Public Sub New
public:
BCT()


CatalogNumber Property

CatalogNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogNumber { get; set; }
Public Property CatalogNumber As String
    Get
    Set
public:
property String^ CatalogNumber {
    String^ get ();
    void set (String^ value);
}


CatalogNumber1 Property

CatalogNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogNumber1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogNumber1 { get; set; }
Public Property CatalogNumber1 As String
    Get
    Set
public:
property String^ CatalogNumber1 {
    String^ get ();
    void set (String^ value);
}


CatalogPurposeCode Property

CatalogPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogPurposeCode { get; set; }
Public Property CatalogPurposeCode As String
    Get
    Set
public:
property String^ CatalogPurposeCode {
    String^ get ();
    void set (String^ value);
}


CatalogRevisionNumber Property

CatalogRevisionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogRevisionNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogRevisionNumber { get; set; }
Public Property CatalogRevisionNumber As String
    Get
    Set
public:
property String^ CatalogRevisionNumber {
    String^ get ();
    void set (String^ value);
}


CatalogRevisionNumber1 Property

CatalogRevisionNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogRevisionNumber1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogRevisionNumber1 { get; set; }
Public Property CatalogRevisionNumber1 As String
    Get
    Set
public:
property String^ CatalogRevisionNumber1 {
    String^ get ();
    void set (String^ value);
}


CatalogVersionNumber Property

CatalogVersionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogVersionNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogVersionNumber { get; set; }
Public Property CatalogVersionNumber As String
    Get
    Set
public:
property String^ CatalogVersionNumber {
    String^ get ();
    void set (String^ value);
}


CatalogVersionNumber1 Property

CatalogVersionNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► CatalogVersionNumber1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CatalogVersionNumber1 { get; set; }
Public Property CatalogVersionNumber1 As String
    Get
    Set
public:
property String^ CatalogVersionNumber1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BCU Class

BCU Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU
RDPCrystal EDI Library
Legal Claim Updates
Declaration Syntax
C# Visual Basic Visual C++
public class BCU : DocumentSegment
Public Class BCU _
    Inherits DocumentSegment
public ref class BCU : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BCU()()()() | Initializes a new instance of the BCU class
 | ActionCode | Element 5
 | Date | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
 | YesNoConditionOrResponseCode1 | Element 2
 | YesNoConditionOrResponseCode2 | Element 3
 | YesNoConditionOrResponseCode3 | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BCU


BCU Constructor

BCU Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► BCU()()()()
RDPCrystal EDI Library
Initializes a new instance of the BCU class
Declaration Syntax
C# Visual Basic Visual C++
public BCU()
Public Sub New
public:
BCU()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► ActionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BCU ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}


BDD Class

BDD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD
RDPCrystal EDI Library
Beginning Segment for Shipment Delivery Discrepancy Information
Declaration Syntax
C# Visual Basic Visual C++
public class BDD : DocumentSegment
Public Class BDD _
    Inherits DocumentSegment
public ref class BDD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BDD()()()() | Initializes a new instance of the BDD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 3
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BDD


BDD Constructor

BDD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD ► BDD()()()()
RDPCrystal EDI Library
Initializes a new instance of the BDD class
Declaration Syntax
C# Visual Basic Visual C++
public BDD()
Public Sub New
public:
BDD()


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD ► InvoiceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BDD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BEG Class

BEG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG
RDPCrystal EDI Library
Beginning Segment for Purchase Order
Declaration Syntax
C# Visual Basic Visual C++
public class BEG : DocumentSegment
Public Class BEG _
    Inherits DocumentSegment
public ref class BEG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BEG()()()() | Initializes a new instance of the BEG class
 | AcknowledgmentType | Element 7
 | ContractNumber | Element 6
 | ContractTypeCode | Element 9
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceTypeCode | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseCategory | Element 10
 | PurchaseOrderNumber | Element 3
 | PurchaseOrderTypeCode | Element 2
 | ReleaseNumber | Element 4
 | SecurityLevelCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BEG


BEG Constructor

BEG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► BEG()()()()
RDPCrystal EDI Library
Initializes a new instance of the BEG class
Declaration Syntax
C# Visual Basic Visual C++
public BEG()
Public Sub New
public:
BEG()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► AcknowledgmentType
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► ContractNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► ContractTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


InvoiceTypeCode Property

InvoiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► InvoiceTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceTypeCode { get; set; }
Public Property InvoiceTypeCode As String
    Get
    Set
public:
property String^ InvoiceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseCategory Property

PurchaseCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► PurchaseCategory
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseCategory { get; set; }
Public Property PurchaseCategory As String
    Get
    Set
public:
property String^ PurchaseCategory {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderTypeCode Property

PurchaseOrderTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► PurchaseOrderTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderTypeCode { get; set; }
Public Property PurchaseOrderTypeCode As String
    Get
    Set
public:
property String^ PurchaseOrderTypeCode {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► ReleaseNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► SecurityLevelCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► TransactionTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BEN Class

BEN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN
RDPCrystal EDI Library
Beneficiary or Owner Information
Declaration Syntax
C# Visual Basic Visual C++
public class BEN : DocumentSegment
Public Class BEN _
    Inherits DocumentSegment
public ref class BEN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BEN()()()() | Initializes a new instance of the BEN class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | PrimaryOrContingentCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
 | YesNoConditionOrResponseCode1 | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BEN


BEN Constructor

BEN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► BEN()()()()
RDPCrystal EDI Library
Initializes a new instance of the BEN class
Declaration Syntax
C# Visual Basic Visual C++
public BEN()
Public Sub New
public:
BEN()


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PrimaryOrContingentCode Property

PrimaryOrContingentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► PrimaryOrContingentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PrimaryOrContingentCode { get; set; }
Public Property PrimaryOrContingentCode As String
    Get
    Set
public:
property String^ PrimaryOrContingentCode {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► TypeOfAccountCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEN ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


BEP Class

BEP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEP
RDPCrystal EDI Library
Borrower Education Program
Declaration Syntax
C# Visual Basic Visual C++
public class BEP : DocumentSegment
Public Class BEP _
    Inherits DocumentSegment
public ref class BEP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BEP()()()() | Initializes a new instance of the BEP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InstructionalSettingCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramParticipationAndServicesCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BEP


BEP Constructor

BEP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEP ► BEP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BEP class
Declaration Syntax
C# Visual Basic Visual C++
public BEP()
Public Sub New
public:
BEP()


InstructionalSettingCode Property

InstructionalSettingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEP ► InstructionalSettingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InstructionalSettingCode { get; set; }
Public Property InstructionalSettingCode As String
    Get
    Set
public:
property String^ InstructionalSettingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProgramParticipationAndServicesCode Property

ProgramParticipationAndServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEP ► ProgramParticipationAndServicesCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramParticipationAndServicesCode { get; set; }
Public Property ProgramParticipationAndServicesCode As String
    Get
    Set
public:
property String^ ProgramParticipationAndServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BEP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BFR Class

BFR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR
RDPCrystal EDI Library
Beginning Segment for Planning Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class BFR : DocumentSegment
Public Class BFR _
    Inherits DocumentSegment
public ref class BFR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BFR()()()() | Initializes a new instance of the BFR class
 | ActionCode | Element 13
 | ContractNumber | Element 10
 | Date | Element 6
 | Date1 | Element 7
 | Date2 | Element 8
 | Date3 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanningScheduleTypeCode | Element 12
 | PurchaseOrderNumber | Element 11
 | ReferenceIdentification | Element 2
 | ReleaseNumber | Element 3
 | ScheduleQuantityQualifier | Element 5
 | ScheduleTypeQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BFR


BFR Constructor

BFR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► BFR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BFR class
Declaration Syntax
C# Visual Basic Visual C++
public BFR()
Public Sub New
public:
BFR()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► ActionCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► ContractNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► Date2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► Date3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PlanningScheduleTypeCode Property

PlanningScheduleTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► PlanningScheduleTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PlanningScheduleTypeCode { get; set; }
Public Property PlanningScheduleTypeCode As String
    Get
    Set
public:
property String^ PlanningScheduleTypeCode {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► ReleaseNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


ScheduleQuantityQualifier Property

ScheduleQuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► ScheduleQuantityQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ScheduleQuantityQualifier { get; set; }
Public Property ScheduleQuantityQualifier As String
    Get
    Set
public:
property String^ ScheduleQuantityQualifier {
    String^ get ();
    void set (String^ value);
}


ScheduleTypeQualifier Property

ScheduleTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► ScheduleTypeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ScheduleTypeQualifier { get; set; }
Public Property ScheduleTypeQualifier As String
    Get
    Set
public:
property String^ ScheduleTypeQualifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BFS Class

BFS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS
RDPCrystal EDI Library
Borrower Financial Summary
Declaration Syntax
C# Visual Basic Visual C++
public class BFS : DocumentSegment
Public Class BFS _
    Inherits DocumentSegment
public ref class BFS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BFS()()()() | Initializes a new instance of the BFS class
 | Date | Element 5
 | Date1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 1
 | RateValueQualifier1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfIncomeCode | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BFS


BFS Constructor

BFS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► BFS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BFS class
Declaration Syntax
C# Visual Basic Visual C++
public BFS()
Public Sub New
public:
BFS()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► MonetaryAmount3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► RateValueQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


TypeOfIncomeCode Property

TypeOfIncomeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► TypeOfIncomeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfIncomeCode { get; set; }
Public Property TypeOfIncomeCode As String
    Get
    Set
public:
property String^ TypeOfIncomeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BFS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


BGF Class

BGF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF
RDPCrystal EDI Library
Beginning Segment for File Transfer Information
Declaration Syntax
C# Visual Basic Visual C++
public class BGF : DocumentSegment
Public Class BGF _
    Inherits DocumentSegment
public ref class BGF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BGF()()()() | Initializes a new instance of the BGF class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BGF


BGF Constructor

BGF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF ► BGF()()()()
RDPCrystal EDI Library
Initializes a new instance of the BGF class
Declaration Syntax
C# Visual Basic Visual C++
public BGF()
Public Sub New
public:
BGF()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BGN Class

BGN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN
RDPCrystal EDI Library
Beginning Segment
Declaration Syntax
C# Visual Basic Visual C++
public class BGN : DocumentSegment
Public Class BGN _
    Inherits DocumentSegment
public ref class BGN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BGN()()()() | Initializes a new instance of the BGN class
 | ActionCode | Element 8
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 6
 | SecurityLevelCode | Element 9
 | Time | Element 4
 | TimeCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BGN


BGN Constructor

BGN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► BGN()()()()
RDPCrystal EDI Library
Initializes a new instance of the BGN class
Declaration Syntax
C# Visual Basic Visual C++
public BGN()
Public Sub New
public:
BGN()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► ActionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► SecurityLevelCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► TimeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► TransactionTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BGP Class

BGP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP
RDPCrystal EDI Library
Beginning Segment for Problem Log Inquiry or Advice
Declaration Syntax
C# Visual Basic Visual C++
public class BGP : DocumentSegment
Public Class BGP _
    Inherits DocumentSegment
public ref class BGP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BGP()()()() | Initializes a new instance of the BGP class
 | DateTimePeriod | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 5
 | EquipmentNumber | Element 6
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProblemLogReasonCode | Element 2
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | StandardPointLocationCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BGP


BGP Constructor

BGP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► BGP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BGP class
Declaration Syntax
C# Visual Basic Visual C++
public BGP()
Public Sub New
public:
BGP()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► EquipmentInitial
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► EquipmentNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProblemLogReasonCode Property

ProblemLogReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► ProblemLogReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProblemLogReasonCode { get; set; }
Public Property ProblemLogReasonCode As String
    Get
    Set
public:
property String^ ProblemLogReasonCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► StandardPointLocationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BGP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BHT Class

BHT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT
RDPCrystal EDI Library
Beginning of Hierarchical Transaction
Declaration Syntax
C# Visual Basic Visual C++
public class BHT : DocumentSegment
Public Class BHT _
    Inherits DocumentSegment
public ref class BHT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BHT()()()() | Initializes a new instance of the BHT class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalStructureCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 2
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BHT


BHT Constructor

BHT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► BHT()()()()
RDPCrystal EDI Library
Initializes a new instance of the BHT class
Declaration Syntax
C# Visual Basic Visual C++
public BHT()
Public Sub New
public:
BHT()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


HierarchicalStructureCode Property

HierarchicalStructureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► HierarchicalStructureCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalStructureCode { get; set; }
Public Property HierarchicalStructureCode As String
    Get
    Set
public:
property String^ HierarchicalStructureCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BHT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BIA Class

BIA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA
RDPCrystal EDI Library
Beginning Segment for Inventory Inquiry/Advice
Declaration Syntax
C# Visual Basic Visual C++
public class BIA : DocumentSegment
Public Class BIA _
    Inherits DocumentSegment
public ref class BIA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BIA()()()() | Initializes a new instance of the BIA class
 | ActionCode | Element 6
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReportTypeCode | Element 2
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BIA


BIA Constructor

BIA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► BIA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BIA class
Declaration Syntax
C# Visual Basic Visual C++
public BIA()
Public Sub New
public:
BIA()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► ActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► ReportTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BIG Class

BIG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG
RDPCrystal EDI Library
Beginning Segment for Invoice
Declaration Syntax
C# Visual Basic Visual C++
public class BIG : DocumentSegment
Public Class BIG _
    Inherits DocumentSegment
public ref class BIG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BIG()()()() | Initializes a new instance of the BIG class
 | ActionCode | Element 9
 | ChangeOrderSequenceNumber | Element 6
 | Date | Element 1
 | Date1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 2
 | InvoiceNumber1 | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 4
 | ReleaseNumber | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 8
 | TransactionTypeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BIG


BIG Constructor

BIG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► BIG()()()()
RDPCrystal EDI Library
Initializes a new instance of the BIG class
Declaration Syntax
C# Visual Basic Visual C++
public BIG()
Public Sub New
public:
BIG()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► ActionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► InvoiceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber1 Property

InvoiceNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► InvoiceNumber1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber1 { get; set; }
Public Property InvoiceNumber1 As String
    Get
    Set
public:
property String^ InvoiceNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► ReleaseNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► TransactionTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BIN Class

BIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIN
RDPCrystal EDI Library
Binary Data
Declaration Syntax
C# Visual Basic Visual C++
public class BIN : DocumentSegment
Public Class BIN _
    Inherits DocumentSegment
public ref class BIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BIN()()()() | Initializes a new instance of the BIN class
 | BinaryData | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LengthOfBinaryData | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BIN


BIN Constructor

BIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIN ► BIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the BIN class
Declaration Syntax
C# Visual Basic Visual C++
public BIN()
Public Sub New
public:
BIN()


BinaryData Property

BinaryData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIN ► BinaryData
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BinaryData { get; set; }
Public Property BinaryData As String
    Get
    Set
public:
property String^ BinaryData {
    String^ get ();
    void set (String^ value);
}


LengthOfBinaryData Property

LengthOfBinaryData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIN ► LengthOfBinaryData
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LengthOfBinaryData { get; set; }
Public Property LengthOfBinaryData As String
    Get
    Set
public:
property String^ LengthOfBinaryData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BIX Class

BIX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX
RDPCrystal EDI Library
Beginning Segment for Automotive Inspection
Declaration Syntax
C# Visual Basic Visual C++
public class BIX : DocumentSegment
Public Class BIX _
    Inherits DocumentSegment
public ref class BIX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BIX()()()() | Initializes a new instance of the BIX class
 | CityName | Element 6
 | DamageCodeQualifier | Element 9
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 11
 | IdentificationCodeQualifier | Element 10
 | InspectionLocationTypeCode | Element 4
 | InspectorIdentityCode | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RampIdentification | Element 5
 | StandardCarrierAlphaCode | Element 2
 | StateOrProvinceCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BIX


BIX Constructor

BIX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► BIX()()()()
RDPCrystal EDI Library
Initializes a new instance of the BIX class
Declaration Syntax
C# Visual Basic Visual C++
public BIX()
Public Sub New
public:
BIX()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► CityName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


DamageCodeQualifier Property

DamageCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► DamageCodeQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DamageCodeQualifier { get; set; }
Public Property DamageCodeQualifier As String
    Get
    Set
public:
property String^ DamageCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► IdentificationCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


InspectionLocationTypeCode Property

InspectionLocationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► InspectionLocationTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InspectionLocationTypeCode { get; set; }
Public Property InspectionLocationTypeCode As String
    Get
    Set
public:
property String^ InspectionLocationTypeCode {
    String^ get ();
    void set (String^ value);
}


InspectorIdentityCode Property

InspectorIdentityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► InspectorIdentityCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InspectorIdentityCode { get; set; }
Public Property InspectorIdentityCode As String
    Get
    Set
public:
property String^ InspectorIdentityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RampIdentification Property

RampIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► RampIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RampIdentification { get; set; }
Public Property RampIdentification As String
    Get
    Set
public:
property String^ RampIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BIX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BJF Class

BJF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF
RDPCrystal EDI Library
Beginning Segment Railroad Junctions and Interchanges Update Activity
Declaration Syntax
C# Visual Basic Visual C++
public class BJF : DocumentSegment
Public Class BJF _
    Inherits DocumentSegment
public ref class BJF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BJF()()()() | Initializes a new instance of the BJF class
 | CityName | Element 5
 | CountryCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rule260JunctionCode | Element 3
 | StandardPointLocationCode | Element 4
 | StateOrProvinceCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BJF


BJF Constructor

BJF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► BJF()()()()
RDPCrystal EDI Library
Initializes a new instance of the BJF class
Declaration Syntax
C# Visual Basic Visual C++
public BJF()
Public Sub New
public:
BJF()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► CityName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► Rule260JunctionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► StateOrProvinceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► TransactionTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BJF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BL Class

BL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL
RDPCrystal EDI Library
Billing Information
Declaration Syntax
C# Visual Basic Visual C++
public class BL : DocumentSegment
Public Class BL _
    Inherits DocumentSegment
public ref class BL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BL()()()() | Initializes a new instance of the BL class
 | CityName | Element 5
 | CityName1 | Element 9
 | CountryCode | Element 7
 | CountryCode1 | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 2
 | FreightStationAccountingCode1 | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RebillReasonCode | Element 1
 | StandardCarrierAlphaCode | Element 12
 | StandardCarrierAlphaCode1 | Element 13
 | StandardCarrierAlphaCode2 | Element 14
 | StandardCarrierAlphaCode3 | Element 15
 | StandardCarrierAlphaCode4 | Element 16
 | StandardCarrierAlphaCode5 | Element 17
 | StandardPointLocationCode | Element 4
 | StandardPointLocationCode1 | Element 8
 | StateOrProvinceCode | Element 6
 | StateOrProvinceCode1 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BL


BL Constructor

BL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► BL()()()()
RDPCrystal EDI Library
Initializes a new instance of the BL class
Declaration Syntax
C# Visual Basic Visual C++
public BL()
Public Sub New
public:
BL()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► CityName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► CityName1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountryCode1 Property

CountryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► CountryCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode1 { get; set; }
Public Property CountryCode1 As String
    Get
    Set
public:
property String^ CountryCode1 {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode1 Property

FreightStationAccountingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► FreightStationAccountingCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode1 { get; set; }
Public Property FreightStationAccountingCode1 As String
    Get
    Set
public:
property String^ FreightStationAccountingCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RebillReasonCode Property

RebillReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► RebillReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RebillReasonCode { get; set; }
Public Property RebillReasonCode As String
    Get
    Set
public:
property String^ RebillReasonCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode3 Property

StandardCarrierAlphaCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardCarrierAlphaCode3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode3 { get; set; }
Public Property StandardCarrierAlphaCode3 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode3 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode4 Property

StandardCarrierAlphaCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardCarrierAlphaCode4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode4 { get; set; }
Public Property StandardCarrierAlphaCode4 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode4 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode5 Property

StandardCarrierAlphaCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardCarrierAlphaCode5
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode5 { get; set; }
Public Property StandardCarrierAlphaCode5 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode5 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StateOrProvinceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BLI Class

BLI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI
RDPCrystal EDI Library
Baseline Item Data
Declaration Syntax
C# Visual Basic Visual C++
public class BLI : DocumentSegment
Public Class BLI _
    Inherits DocumentSegment
public ref class BLI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BLI()()()() | Initializes a new instance of the BLI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 18
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceIdentifierCode | Element 5
 | ProductOptionCode | Element 14
 | ProductOptionCode1 | Element 15
 | ProductOptionCode2 | Element 16
 | ProductOptionCode3 | Element 17
 | ProductServiceID | Element 2
 | ProductServiceID1 | Element 9
 | ProductServiceID2 | Element 11
 | ProductServiceID3 | Element 13
 | ProductServiceIDQualifier | Element 1
 | ProductServiceIDQualifier1 | Element 8
 | ProductServiceIDQualifier2 | Element 10
 | ProductServiceIDQualifier3 | Element 12
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | UnitOrBasisForMeasurementCode1 | Element 7
 | UnitPrice | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BLI


BLI Constructor

BLI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► BLI()()()()
RDPCrystal EDI Library
Initializes a new instance of the BLI class
Declaration Syntax
C# Visual Basic Visual C++
public BLI()
Public Sub New
public:
BLI()


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► FrequencyCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► PriceIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode Property

ProductOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductOptionCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode { get; set; }
Public Property ProductOptionCode As String
    Get
    Set
public:
property String^ ProductOptionCode {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode1 Property

ProductOptionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductOptionCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode1 { get; set; }
Public Property ProductOptionCode1 As String
    Get
    Set
public:
property String^ ProductOptionCode1 {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode2 Property

ProductOptionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductOptionCode2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode2 { get; set; }
Public Property ProductOptionCode2 As String
    Get
    Set
public:
property String^ ProductOptionCode2 {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode3 Property

ProductOptionCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductOptionCode3
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode3 { get; set; }
Public Property ProductOptionCode3 As String
    Get
    Set
public:
property String^ ProductOptionCode3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceID1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceID2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceID3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► UnitPrice
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BLN Class

BLN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN
RDPCrystal EDI Library
Balance Information
Declaration Syntax
C# Visual Basic Visual C++
public class BLN : DocumentSegment
Public Class BLN _
    Inherits DocumentSegment
public ref class BLN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BLN()()()() | Initializes a new instance of the BLN class
 | CodeListQualifierCode | Element 1
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 5
 | TimeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BLN


BLN Constructor

BLN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► BLN()()()()
RDPCrystal EDI Library
Initializes a new instance of the BLN class
Declaration Syntax
C# Visual Basic Visual C++
public BLN()
Public Sub New
public:
BLN()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► TimeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BLR Class

BLR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLR
RDPCrystal EDI Library
Transportation Carrier Identification
Declaration Syntax
C# Visual Basic Visual C++
public class BLR : DocumentSegment
Public Class BLR _
    Inherits DocumentSegment
public ref class BLR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BLR()()()() | Initializes a new instance of the BLR class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BLR


BLR Constructor

BLR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLR ► BLR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BLR class
Declaration Syntax
C# Visual Basic Visual C++
public BLR()
Public Sub New
public:
BLR()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLR ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLR ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BLS Class

BLS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS
RDPCrystal EDI Library
Beginning Segment for Asset Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class BLS : DocumentSegment
Public Class BLS _
    Inherits DocumentSegment
public ref class BLS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BLS()()()() | Initializes a new instance of the BLS class
 | AcknowledgmentType | Element 6
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BLS


BLS Constructor

BLS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► BLS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BLS class
Declaration Syntax
C# Visual Basic Visual C++
public BLS()
Public Sub New
public:
BLS()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► AcknowledgmentType
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► TransactionTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BLS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BMA Class

BMA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA
RDPCrystal EDI Library
Beginning Segment for Market Development Fund Allocation
Declaration Syntax
C# Visual Basic Visual C++
public class BMA : DocumentSegment
Public Class BMA _
    Inherits DocumentSegment
public ref class BMA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BMA()()()() | Initializes a new instance of the BMA class
 | AllowanceOrChargeMethodOfHandlingCode | Element 3
 | Date | Element 4
 | Date1 | Element 5
 | Description | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BMA


BMA Constructor

BMA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► BMA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BMA class
Declaration Syntax
C# Visual Basic Visual C++
public BMA()
Public Sub New
public:
BMA()


AllowanceOrChargeMethodOfHandlingCode Property

AllowanceOrChargeMethodOfHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► AllowanceOrChargeMethodOfHandlingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeMethodOfHandlingCode { get; set; }
Public Property AllowanceOrChargeMethodOfHandlingCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeMethodOfHandlingCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► Description
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BMG Class

BMG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG
RDPCrystal EDI Library
Beginning Segment For Text Message
Declaration Syntax
C# Visual Basic Visual C++
public class BMG : DocumentSegment
Public Class BMG _
    Inherits DocumentSegment
public ref class BMG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BMG()()()() | Initializes a new instance of the BMG class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BMG


BMG Constructor

BMG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG ► BMG()()()()
RDPCrystal EDI Library
Initializes a new instance of the BMG class
Declaration Syntax
C# Visual Basic Visual C++
public BMG()
Public Sub New
public:
BMG()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG ► TransactionTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BMM Class

BMM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM
RDPCrystal EDI Library
Beginning Segment for Multilevel Railcar Load Details Transaction
Declaration Syntax
C# Visual Basic Visual C++
public class BMM : DocumentSegment
Public Class BMM _
    Inherits DocumentSegment
public ref class BMM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BMM()()()() | Initializes a new instance of the BMM class
 | AccountNumber | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | ReferenceIdentification | Element 9
 | ShipmentIdentificationNumber | Element 6
 | StandardCarrierAlphaCode | Element 1
 | StandardPointLocationCode | Element 2
 | StandardPointLocationCode1 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 10
 | VehicleStatus | Element 7
 | WaybillNumber | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BMM


BMM Constructor

BMM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► BMM()()()()
RDPCrystal EDI Library
Initializes a new instance of the BMM class
Declaration Syntax
C# Visual Basic Visual C++
public BMM()
Public Sub New
public:
BMM()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► AccountNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► StandardPointLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


VehicleStatus Property

VehicleStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► VehicleStatus
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleStatus { get; set; }
Public Property VehicleStatus As String
    Get
    Set
public:
property String^ VehicleStatus {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► WaybillNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BMP Class

BMP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP
RDPCrystal EDI Library
Beginning Segment for Market Development Fund Settlement
Declaration Syntax
C# Visual Basic Visual C++
public class BMP : DocumentSegment
Public Class BMP _
    Inherits DocumentSegment
public ref class BMP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BMP()()()() | Initializes a new instance of the BMP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 3
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BMP


BMP Constructor

BMP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► BMP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BMP class
Declaration Syntax
C# Visual Basic Visual C++
public BMP()
Public Sub New
public:
BMP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► PaymentMethodCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► TransactionHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BMS Class

BMS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS
RDPCrystal EDI Library
Beginning Segment For Material Safety Data Sheet
Declaration Syntax
C# Visual Basic Visual C++
public class BMS : DocumentSegment
Public Class BMS _
    Inherits DocumentSegment
public ref class BMS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BMS()()()() | Initializes a new instance of the BMS class
 | CountryCode | Element 9
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LanguageCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentification1 | Element 6
 | RevisionValue | Element 5
 | RevisionValue1 | Element 7
 | StateOrProvinceCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BMS


BMS Constructor

BMS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► BMS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BMS class
Declaration Syntax
C# Visual Basic Visual C++
public BMS()
Public Sub New
public:
BMS()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► CountryCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► LanguageCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


RevisionValue Property

RevisionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► RevisionValue
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionValue { get; set; }
Public Property RevisionValue As String
    Get
    Set
public:
property String^ RevisionValue {
    String^ get ();
    void set (String^ value);
}


RevisionValue1 Property

RevisionValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► RevisionValue1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionValue1 { get; set; }
Public Property RevisionValue1 As String
    Get
    Set
public:
property String^ RevisionValue1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► StateOrProvinceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BMS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BNR Class

BNR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR
RDPCrystal EDI Library
Beginning Segment For Nonconformance Report
Declaration Syntax
C# Visual Basic Visual C++
public class BNR : DocumentSegment
Public Class BNR _
    Inherits DocumentSegment
public ref class BNR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BNR()()()() | Initializes a new instance of the BNR class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonconformanceReportStatusCode | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BNR


BNR Constructor

BNR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► BNR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BNR class
Declaration Syntax
C# Visual Basic Visual C++
public BNR()
Public Sub New
public:
BNR()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NonconformanceReportStatusCode Property

NonconformanceReportStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► NonconformanceReportStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NonconformanceReportStatusCode { get; set; }
Public Property NonconformanceReportStatusCode As String
    Get
    Set
public:
property String^ NonconformanceReportStatusCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BNX Class

BNX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX
RDPCrystal EDI Library
Rail Shipment Information
Declaration Syntax
C# Visual Basic Visual C++
public class BNX : DocumentSegment
Public Class BNX _
    Inherits DocumentSegment
public ref class BNX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BNX()()()() | Initializes a new instance of the BNX class
 | BillingCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferencedPatternIdentifier | Element 2
 | RepetitivePatternNumber | Element 4
 | ShipmentWeightCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BNX


BNX Constructor

BNX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► BNX()()()()
RDPCrystal EDI Library
Initializes a new instance of the BNX class
Declaration Syntax
C# Visual Basic Visual C++
public BNX()
Public Sub New
public:
BNX()


BillingCode Property

BillingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► BillingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string BillingCode { get; set; }
Public Property BillingCode As String
    Get
    Set
public:
property String^ BillingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferencedPatternIdentifier Property

ReferencedPatternIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► ReferencedPatternIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferencedPatternIdentifier { get; set; }
Public Property ReferencedPatternIdentifier As String
    Get
    Set
public:
property String^ ReferencedPatternIdentifier {
    String^ get ();
    void set (String^ value);
}


RepetitivePatternNumber Property

RepetitivePatternNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► RepetitivePatternNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RepetitivePatternNumber { get; set; }
Public Property RepetitivePatternNumber As String
    Get
    Set
public:
property String^ RepetitivePatternNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentWeightCode Property

ShipmentWeightCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► ShipmentWeightCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentWeightCode { get; set; }
Public Property ShipmentWeightCode As String
    Get
    Set
public:
property String^ ShipmentWeightCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BNX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BOL Class

BOL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL
RDPCrystal EDI Library
Beginning Segment for the Motor Carrier Bill of Lading
Declaration Syntax
C# Visual Basic Visual C++
public class BOL : DocumentSegment
Public Class BOL _
    Inherits DocumentSegment
public ref class BOL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BOL()()()() | Initializes a new instance of the BOL class
 | CurrencyCode | Element 11
 | CustomsDocumentationHandlingCode | Element 9
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 6
 | SectionSevenCode | Element 8
 | ShipmentIdentificationNumber | Element 3
 | ShipmentMethodOfPayment | Element 2
 | ShipmentMethodOfPayment1 | Element 10
 | StandardCarrierAlphaCode | Element 1
 | StatusReportRequestCode | Element 7
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BOL


BOL Constructor

BOL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► BOL()()()()
RDPCrystal EDI Library
Initializes a new instance of the BOL class
Declaration Syntax
C# Visual Basic Visual C++
public BOL()
Public Sub New
public:
BOL()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► CurrencyCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


CustomsDocumentationHandlingCode Property

CustomsDocumentationHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► CustomsDocumentationHandlingCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsDocumentationHandlingCode { get; set; }
Public Property CustomsDocumentationHandlingCode As String
    Get
    Set
public:
property String^ CustomsDocumentationHandlingCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


SectionSevenCode Property

SectionSevenCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► SectionSevenCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SectionSevenCode { get; set; }
Public Property SectionSevenCode As String
    Get
    Set
public:
property String^ SectionSevenCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment1 Property

ShipmentMethodOfPayment1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► ShipmentMethodOfPayment1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment1 { get; set; }
Public Property ShipmentMethodOfPayment1 As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StatusReportRequestCode Property

StatusReportRequestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► StatusReportRequestCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReportRequestCode { get; set; }
Public Property StatusReportRequestCode As String
    Get
    Set
public:
property String^ StatusReportRequestCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BOR Class

BOR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR
RDPCrystal EDI Library
Beginning of Report
Declaration Syntax
C# Visual Basic Visual C++
public class BOR : DocumentSegment
Public Class BOR _
    Inherits DocumentSegment
public ref class BOR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BOR()()()() | Initializes a new instance of the BOR class
 | ActionCode | Element 8
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LanguageCode | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 3
 | ReferenceIdentification2 | Element 4
 | ReportTypeCode | Element 1
 | StatusReasonCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BOR


BOR Constructor

BOR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► BOR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BOR class
Declaration Syntax
C# Visual Basic Visual C++
public BOR()
Public Sub New
public:
BOR()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► ActionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► LanguageCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► ReferenceIdentification2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► StatusReasonCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BOS Class

BOS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS
RDPCrystal EDI Library
Beginning Segment for the Operating Expense Statement
Declaration Syntax
C# Visual Basic Visual C++
public class BOS : DocumentSegment
Public Class BOS _
    Inherits DocumentSegment
public ref class BOS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BOS()()()() | Initializes a new instance of the BOS class
 | AgencyQualifierCode | Element 3
 | Date | Element 2
 | Date1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatementFormatCode | Element 4
 | StatementNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BOS


BOS Constructor

BOS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► BOS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BOS class
Declaration Syntax
C# Visual Basic Visual C++
public BOS()
Public Sub New
public:
BOS()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatementFormatCode Property

StatementFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► StatementFormatCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StatementFormatCode { get; set; }
Public Property StatementFormatCode As String
    Get
    Set
public:
property String^ StatementFormatCode {
    String^ get ();
    void set (String^ value);
}


StatementNumber Property

StatementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► StatementNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatementNumber { get; set; }
Public Property StatementNumber As String
    Get
    Set
public:
property String^ StatementNumber {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► TransactionTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BOX Class

BOX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX
RDPCrystal EDI Library
Box Office Detail
Declaration Syntax
C# Visual Basic Visual C++
public class BOX : DocumentSegment
Public Class BOX _
    Inherits DocumentSegment
public ref class BOX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BOX()()()() | Initializes a new instance of the BOX class
 | CurrencyCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | MonetaryAmount1 | Element 6
 | MonetaryAmount2 | Element 11
 | MonetaryAmount3 | Element 13
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 7
 | Quantity1 | Element 8
 | Quantity2 | Element 9
 | Quantity3 | Element 10
 | ReferenceIdentification | Element 14
 | ReferenceIdentification1 | Element 15
 | ShowCode | Element 2
 | TicketCategoryCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BOX


BOX Constructor

BOX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► BOX()()()()
RDPCrystal EDI Library
Initializes a new instance of the BOX class
Declaration Syntax
C# Visual Basic Visual C++
public BOX()
Public Sub New
public:
BOX()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► CurrencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► FrequencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► MonetaryAmount2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► MonetaryAmount3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► Quantity1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► Quantity2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► Quantity3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► ReferenceIdentification
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► ReferenceIdentification1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ShowCode Property

ShowCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► ShowCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShowCode { get; set; }
Public Property ShowCode As String
    Get
    Set
public:
property String^ ShowCode {
    String^ get ();
    void set (String^ value);
}


TicketCategoryCode Property

TicketCategoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► TicketCategoryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TicketCategoryCode { get; set; }
Public Property TicketCategoryCode As String
    Get
    Set
public:
property String^ TicketCategoryCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► UnitPrice
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BOX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BPA Class

BPA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA
RDPCrystal EDI Library
Beginning Segment for Price Authorization Acknowledgment/Status
Declaration Syntax
C# Visual Basic Visual C++
public class BPA : DocumentSegment
Public Class BPA _
    Inherits DocumentSegment
public ref class BPA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BPA()()()() | Initializes a new instance of the BPA class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BPA


BPA Constructor

BPA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► BPA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BPA class
Declaration Syntax
C# Visual Basic Visual C++
public BPA()
Public Sub New
public:
BPA()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BPP Class

BPP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP
RDPCrystal EDI Library
Beginning Segment for Project Schedule Reporting
Declaration Syntax
C# Visual Basic Visual C++
public class BPP : DocumentSegment
Public Class BPP _
    Inherits DocumentSegment
public ref class BPP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BPP()()()() | Initializes a new instance of the BPP class
 | ContractNumber | Element 4
 | Date | Element 2
 | Date1 | Element 7
 | Date2 | Element 11
 | Description | Element 5
 | Description1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetworkOrScheduleDataType | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 6
 | ReferenceIdentification1 | Element 9
 | ReferenceIdentification2 | Element 12
 | ReportTypeCode | Element 8
 | SecurityLevelCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | VersionIdentifier | Element 14
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BPP


BPP Constructor

BPP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► BPP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BPP class
Declaration Syntax
C# Visual Basic Visual C++
public BPP()
Public Sub New
public:
BPP()


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► ContractNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Date2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Description1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetworkOrScheduleDataType Property

NetworkOrScheduleDataType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► NetworkOrScheduleDataType
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkOrScheduleDataType { get; set; }
Public Property NetworkOrScheduleDataType As String
    Get
    Set
public:
property String^ NetworkOrScheduleDataType {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► ReferenceIdentification2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► ReportTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► SecurityLevelCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► VersionIdentifier
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BPR Class

BPR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR
RDPCrystal EDI Library
Beginning Segment for Payment Order/Remittance Advice
Declaration Syntax
C# Visual Basic Visual C++
public class BPR : DocumentSegment
Public Class BPR _
    Inherits DocumentSegment
public ref class BPR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BPR()()()() | Initializes a new instance of the BPR class
 | AccountNumber | Element 9
 | AccountNumber1 | Element 15
 | AccountNumber2 | Element 21
 | AccountNumberQualifier | Element 8
 | AccountNumberQualifier1 | Element 14
 | AccountNumberQualifier2 | Element 20
 | BusinessFunctionCode | Element 17
 | CreditDebitFlagCode | Element 3
 | Date | Element 16
 | DFIIdentificationNumber | Element 7
 | DFIIdentificationNumber1 | Element 13
 | DFIIdentificationNumber2 | Element 19
 | DFIIDNumberQualifier | Element 6
 | DFIIDNumberQualifier1 | Element 12
 | DFIIDNumberQualifier2 | Element 18
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginatingCompanyIdentifier | Element 10
 | OriginatingCompanySupplementalCode | Element 11
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentFormatCode | Element 5
 | PaymentMethodCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BPR


BPR Constructor

BPR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► BPR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BPR class
Declaration Syntax
C# Visual Basic Visual C++
public BPR()
Public Sub New
public:
BPR()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► AccountNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► AccountNumber1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}


AccountNumber2 Property

AccountNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► AccountNumber2
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber2 { get; set; }
Public Property AccountNumber2 As String
    Get
    Set
public:
property String^ AccountNumber2 {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► AccountNumberQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier1 Property

AccountNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► AccountNumberQualifier1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier1 { get; set; }
Public Property AccountNumberQualifier1 As String
    Get
    Set
public:
property String^ AccountNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier2 Property

AccountNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► AccountNumberQualifier2
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier2 { get; set; }
Public Property AccountNumberQualifier2 As String
    Get
    Set
public:
property String^ AccountNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}


BusinessFunctionCode Property

BusinessFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► BusinessFunctionCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessFunctionCode { get; set; }
Public Property BusinessFunctionCode As String
    Get
    Set
public:
property String^ BusinessFunctionCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► Date
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber1 Property

DFIIdentificationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► DFIIdentificationNumber1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber1 { get; set; }
Public Property DFIIdentificationNumber1 As String
    Get
    Set
public:
property String^ DFIIdentificationNumber1 {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber2 Property

DFIIdentificationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► DFIIdentificationNumber2
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber2 { get; set; }
Public Property DFIIdentificationNumber2 As String
    Get
    Set
public:
property String^ DFIIdentificationNumber2 {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier1 Property

DFIIDNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► DFIIDNumberQualifier1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier1 { get; set; }
Public Property DFIIDNumberQualifier1 As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier2 Property

DFIIDNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► DFIIDNumberQualifier2
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier2 { get; set; }
Public Property DFIIDNumberQualifier2 As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► OriginatingCompanyIdentifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}


OriginatingCompanySupplementalCode Property

OriginatingCompanySupplementalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► OriginatingCompanySupplementalCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanySupplementalCode { get; set; }
Public Property OriginatingCompanySupplementalCode As String
    Get
    Set
public:
property String^ OriginatingCompanySupplementalCode {
    String^ get ();
    void set (String^ value);
}


PaymentFormatCode Property

PaymentFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► PaymentFormatCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentFormatCode { get; set; }
Public Property PaymentFormatCode As String
    Get
    Set
public:
property String^ PaymentFormatCode {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► PaymentMethodCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► TransactionHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BPT Class

BPT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT
RDPCrystal EDI Library
Beginning Segment for Product Transfer and Resale
Declaration Syntax
C# Visual Basic Visual C++
public class BPT : DocumentSegment
Public Class BPT _
    Inherits DocumentSegment
public ref class BPT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BPT()()()() | Initializes a new instance of the BPT class
 | ActionCode | Element 7
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceMultiplierQualifier | Element 5
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 9
 | ReportTypeCode | Element 4
 | SecurityLevelCode | Element 10
 | Time | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BPT


BPT Constructor

BPT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► BPT()()()()
RDPCrystal EDI Library
Initializes a new instance of the BPT class
Declaration Syntax
C# Visual Basic Visual C++
public BPT()
Public Sub New
public:
BPT()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► ActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► Multiplier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


PriceMultiplierQualifier Property

PriceMultiplierQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► PriceMultiplierQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PriceMultiplierQualifier { get; set; }
Public Property PriceMultiplierQualifier As String
    Get
    Set
public:
property String^ PriceMultiplierQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► ReferenceIdentification1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► ReportTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► SecurityLevelCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► Time
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BPT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BQR Class

BQR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR
RDPCrystal EDI Library
Beginning Segment for Response to Request for Quotation
Declaration Syntax
C# Visual Basic Visual C++
public class BQR : DocumentSegment
Public Class BQR _
    Inherits DocumentSegment
public ref class BQR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BQR()()()() | Initializes a new instance of the BQR class
 | BidTypeResponseCode | Element 6
 | ChangeOrderSequenceNumber | Element 8
 | Date | Element 3
 | Date1 | Element 5
 | DateTimeQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RequestForQuoteReferenceNumber | Element 2
 | SecurityLevelCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BQR


BQR Constructor

BQR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► BQR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BQR class
Declaration Syntax
C# Visual Basic Visual C++
public BQR()
Public Sub New
public:
BQR()


BidTypeResponseCode Property

BidTypeResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► BidTypeResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string BidTypeResponseCode { get; set; }
Public Property BidTypeResponseCode As String
    Get
    Set
public:
property String^ BidTypeResponseCode {
    String^ get ();
    void set (String^ value);
}


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► DateTimeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RequestForQuoteReferenceNumber Property

RequestForQuoteReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► RequestForQuoteReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RequestForQuoteReferenceNumber { get; set; }
Public Property RequestForQuoteReferenceNumber As String
    Get
    Set
public:
property String^ RequestForQuoteReferenceNumber {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► SecurityLevelCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BQT Class

BQT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT
RDPCrystal EDI Library
Beginning Segment for Request for Quotation
Declaration Syntax
C# Visual Basic Visual C++
public class BQT : DocumentSegment
Public Class BQT _
    Inherits DocumentSegment
public ref class BQT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BQT()()()() | Initializes a new instance of the BQT class
 | ChangeOrderSequenceNumber | Element 11
 | ContractTypeCode | Element 8
 | Date | Element 3
 | Date1 | Element 5
 | DateTimeQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseCategory | Element 10
 | PurchaseOrderTypeCode | Element 6
 | RequestForQuoteReferenceNumber | Element 2
 | RequestForQuoteTypeCode | Element 7
 | SecurityLevelCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BQT


BQT Constructor

BQT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► BQT()()()()
RDPCrystal EDI Library
Initializes a new instance of the BQT class
Declaration Syntax
C# Visual Basic Visual C++
public BQT()
Public Sub New
public:
BQT()


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► ContractTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► DateTimeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseCategory Property

PurchaseCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► PurchaseCategory
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseCategory { get; set; }
Public Property PurchaseCategory As String
    Get
    Set
public:
property String^ PurchaseCategory {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderTypeCode Property

PurchaseOrderTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► PurchaseOrderTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderTypeCode { get; set; }
Public Property PurchaseOrderTypeCode As String
    Get
    Set
public:
property String^ PurchaseOrderTypeCode {
    String^ get ();
    void set (String^ value);
}


RequestForQuoteReferenceNumber Property

RequestForQuoteReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► RequestForQuoteReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RequestForQuoteReferenceNumber { get; set; }
Public Property RequestForQuoteReferenceNumber As String
    Get
    Set
public:
property String^ RequestForQuoteReferenceNumber {
    String^ get ();
    void set (String^ value);
}


RequestForQuoteTypeCode Property

RequestForQuoteTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► RequestForQuoteTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RequestForQuoteTypeCode { get; set; }
Public Property RequestForQuoteTypeCode As String
    Get
    Set
public:
property String^ RequestForQuoteTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► SecurityLevelCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BQT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BR Class

BR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR
RDPCrystal EDI Library
Beginning Segment for Material Management
Declaration Syntax
C# Visual Basic Visual C++
public class BR : DocumentSegment
Public Class BR _
    Inherits DocumentSegment
public ref class BR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BR()()()() | Initializes a new instance of the BR class
 | ActionCode | Element 6
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 8
 | ReferenceIdentification1 | Element 11
 | ReferenceIdentificationQualifier | Element 7
 | ReferenceIdentificationQualifier1 | Element 10
 | Time | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BR


BR Constructor

BR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► BR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BR class
Declaration Syntax
C# Visual Basic Visual C++
public BR()
Public Sub New
public:
BR()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► ActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► ReferenceIdentification1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► Time
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► TransactionTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BRA Class

BRA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA
RDPCrystal EDI Library
Beginning Segment for Receiving Advice or Acceptance Certificate
Declaration Syntax
C# Visual Basic Visual C++
public class BRA : DocumentSegment
Public Class BRA _
    Inherits DocumentSegment
public ref class BRA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BRA()()()() | Initializes a new instance of the BRA class
 | ActionCode | Element 6
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReceivingAdviceOrAcceptanceCertificateTypeCode | Element 3
 | ReceivingConditionCode | Element 5
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BRA


BRA Constructor

BRA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► BRA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BRA class
Declaration Syntax
C# Visual Basic Visual C++
public BRA()
Public Sub New
public:
BRA()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► ActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReceivingAdviceOrAcceptanceCertificateTypeCode Property

ReceivingAdviceOrAcceptanceCertificateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► ReceivingAdviceOrAcceptanceCertificateTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingAdviceOrAcceptanceCertificateTypeCode { get; set; }
Public Property ReceivingAdviceOrAcceptanceCertificateTypeCode As String
    Get
    Set
public:
property String^ ReceivingAdviceOrAcceptanceCertificateTypeCode {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode Property

ReceivingConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► ReceivingConditionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode { get; set; }
Public Property ReceivingConditionCode As String
    Get
    Set
public:
property String^ ReceivingConditionCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BRC Class

BRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class BRC : DocumentSegment
Public Class BRC _
    Inherits DocumentSegment
public ref class BRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BRC()()()() | Initializes a new instance of the BRC class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BRC


BRC Constructor

BRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► BRC()()()()
RDPCrystal EDI Library
Initializes a new instance of the BRC class
Declaration Syntax
C# Visual Basic Visual C++
public BRC()
Public Sub New
public:
BRC()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BRR Class

BRR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class BRR : DocumentSegment
Public Class BRR _
    Inherits DocumentSegment
public ref class BRR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BRR()()()() | Initializes a new instance of the BRR class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 2
 | StandardCarrierAlphaCode1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
 | YesNoConditionOrResponseCode1 | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BRR


BRR Constructor

BRR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► BRR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BRR class
Declaration Syntax
C# Visual Basic Visual C++
public BRR()
Public Sub New
public:
BRR()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BRR ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


BSC Class

BSC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC
RDPCrystal EDI Library
Beginning Segment for Commission Sales Report
Declaration Syntax
C# Visual Basic Visual C++
public class BSC : DocumentSegment
Public Class BSC _
    Inherits DocumentSegment
public ref class BSC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSC()()()() | Initializes a new instance of the BSC class
 | Date | Element 2
 | Date1 | Element 3
 | Date2 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSC


BSC Constructor

BSC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► BSC()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSC class
Declaration Syntax
C# Visual Basic Visual C++
public BSC()
Public Sub New
public:
BSC()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► Date2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BSD Class

BSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD
RDPCrystal EDI Library
Breakdown Structure Description
Declaration Syntax
C# Visual Basic Visual C++
public class BSD : DocumentSegment
Public Class BSD _
    Inherits DocumentSegment
public ref class BSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSD()()()() | Initializes a new instance of the BSD class
 | BreakdownStructureDetailCode | Element 6
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Level | Element 4
 | Level1 | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 5
 | ReferenceIdentificationQualifier | Element 1
 | SecurityLevelCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSD


BSD Constructor

BSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► BSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSD class
Declaration Syntax
C# Visual Basic Visual C++
public BSD()
Public Sub New
public:
BSD()


BreakdownStructureDetailCode Property

BreakdownStructureDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► BreakdownStructureDetailCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string BreakdownStructureDetailCode { get; set; }
Public Property BreakdownStructureDetailCode As String
    Get
    Set
public:
property String^ BreakdownStructureDetailCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Level Property

Level Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► Level
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Level { get; set; }
Public Property Level As String
    Get
    Set
public:
property String^ Level {
    String^ get ();
    void set (String^ value);
}


Level1 Property

Level1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► Level1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Level1 { get; set; }
Public Property Level1 As String
    Get
    Set
public:
property String^ Level1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► ReferenceIdentification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► SecurityLevelCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BSF Class

BSF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF
RDPCrystal EDI Library
Business Function
Declaration Syntax
C# Visual Basic Visual C++
public class BSF : DocumentSegment
Public Class BSF _
    Inherits DocumentSegment
public ref class BSF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSF()()()() | Initializes a new instance of the BSF class
 | ClassOfTradeCode | Element 1
 | CodeListQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSF


BSF Constructor

BSF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF ► BSF()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSF class
Declaration Syntax
C# Visual Basic Visual C++
public BSF()
Public Sub New
public:
BSF()


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF ► ClassOfTradeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF ► CodeListQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF ► IndustryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BSI Class

BSI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI
RDPCrystal EDI Library
Beginning Segment for Order Status Inquiry
Declaration Syntax
C# Visual Basic Visual C++
public class BSI : DocumentSegment
Public Class BSI _
    Inherits DocumentSegment
public ref class BSI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSI()()()() | Initializes a new instance of the BSI class
 | ActionCode | Element 9
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderItemCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDateCode | Element 4
 | ReferenceIdentification | Element 1
 | Time | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 7
 | TransactionTypeCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSI


BSI Constructor

BSI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► BSI()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSI class
Declaration Syntax
C# Visual Basic Visual C++
public BSI()
Public Sub New
public:
BSI()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► ActionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationCode Property

LocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► LocationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationCode { get; set; }
Public Property LocationCode As String
    Get
    Set
public:
property String^ LocationCode {
    String^ get ();
    void set (String^ value);
}


OrderItemCode Property

OrderItemCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► OrderItemCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OrderItemCode { get; set; }
Public Property OrderItemCode As String
    Get
    Set
public:
property String^ OrderItemCode {
    String^ get ();
    void set (String^ value);
}


ProductDateCode Property

ProductDateCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► ProductDateCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDateCode { get; set; }
Public Property ProductDateCode As String
    Get
    Set
public:
property String^ ProductDateCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► TransactionTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BSN Class

BSN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN
RDPCrystal EDI Library
Beginning Segment for Ship Notice
Declaration Syntax
C# Visual Basic Visual C++
public class BSN : DocumentSegment
Public Class BSN _
    Inherits DocumentSegment
public ref class BSN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSN()()()() | Initializes a new instance of the BSN class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalStructureCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentification | Element 2
 | StatusReasonCode | Element 7
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSN


BSN Constructor

BSN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► BSN()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSN class
Declaration Syntax
C# Visual Basic Visual C++
public BSN()
Public Sub New
public:
BSN()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


HierarchicalStructureCode Property

HierarchicalStructureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► HierarchicalStructureCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalStructureCode { get; set; }
Public Property HierarchicalStructureCode As String
    Get
    Set
public:
property String^ HierarchicalStructureCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentIdentification Property

ShipmentIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► ShipmentIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentification { get; set; }
Public Property ShipmentIdentification As String
    Get
    Set
public:
property String^ ShipmentIdentification {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► StatusReasonCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BSR Class

BSR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR
RDPCrystal EDI Library
Beginning Segment for Order Status Report
Declaration Syntax
C# Visual Basic Visual C++
public class BSR : DocumentSegment
Public Class BSR _
    Inherits DocumentSegment
public ref class BSR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSR()()()() | Initializes a new instance of the BSR class
 | ActionCode | Element 12
 | Date | Element 4
 | Date1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationCode | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderItemCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDateCode | Element 5
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 8
 | StatusReportCode | Element 1
 | Time | Element 7
 | Time1 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSR


BSR Constructor

BSR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► BSR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSR class
Declaration Syntax
C# Visual Basic Visual C++
public BSR()
Public Sub New
public:
BSR()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► ActionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► Date1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationCode Property

LocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► LocationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationCode { get; set; }
Public Property LocationCode As String
    Get
    Set
public:
property String^ LocationCode {
    String^ get ();
    void set (String^ value);
}


OrderItemCode Property

OrderItemCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► OrderItemCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string OrderItemCode { get; set; }
Public Property OrderItemCode As String
    Get
    Set
public:
property String^ OrderItemCode {
    String^ get ();
    void set (String^ value);
}


ProductDateCode Property

ProductDateCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► ProductDateCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDateCode { get; set; }
Public Property ProductDateCode As String
    Get
    Set
public:
property String^ ProductDateCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StatusReportCode Property

StatusReportCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► StatusReportCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReportCode { get; set; }
Public Property StatusReportCode As String
    Get
    Set
public:
property String^ StatusReportCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► Time
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► Time1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BSS Class

BSS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS
RDPCrystal EDI Library
Beginning Segment for Shipping Schedule/Production Sequence
Declaration Syntax
C# Visual Basic Visual C++
public class BSS : DocumentSegment
Public Class BSS _
    Inherits DocumentSegment
public ref class BSS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BSS()()()() | Initializes a new instance of the BSS class
 | ContractNumber | Element 9
 | Date | Element 3
 | Date1 | Element 5
 | Date2 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 10
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 8
 | ReleaseNumber | Element 7
 | ScheduleQuantityQualifier | Element 11
 | ScheduleTypeQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BSS


BSS Constructor

BSS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► BSS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BSS class
Declaration Syntax
C# Visual Basic Visual C++
public BSS()
Public Sub New
public:
BSS()


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► ContractNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► Date2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► ReleaseNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


ScheduleQuantityQualifier Property

ScheduleQuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► ScheduleQuantityQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ScheduleQuantityQualifier { get; set; }
Public Property ScheduleQuantityQualifier As String
    Get
    Set
public:
property String^ ScheduleQuantityQualifier {
    String^ get ();
    void set (String^ value);
}


ScheduleTypeQualifier Property

ScheduleTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► ScheduleTypeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ScheduleTypeQualifier { get; set; }
Public Property ScheduleTypeQualifier As String
    Get
    Set
public:
property String^ ScheduleTypeQualifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BSS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BT1 Class

BT1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1
RDPCrystal EDI Library
Batch Totals
Declaration Syntax
C# Visual Basic Visual C++
public class BT1 : DocumentSegment
Public Class BT1 _
    Inherits DocumentSegment
public ref class BT1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BT1()()()() | Initializes a new instance of the BT1 class
 | DataElementTotaled | Element 4
 | DataElementTotaled1 | Element 7
 | DataElementTotaled2 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfTransactionSetsTotaled | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Total | Element 5
 | Total1 | Element 8
 | Total2 | Element 11
 | TotalQualifier | Element 3
 | TotalQualifier1 | Element 6
 | TotalQualifier2 | Element 9
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BT1


BT1 Constructor

BT1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► BT1()()()()
RDPCrystal EDI Library
Initializes a new instance of the BT1 class
Declaration Syntax
C# Visual Basic Visual C++
public BT1()
Public Sub New
public:
BT1()


DataElementTotaled Property

DataElementTotaled Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► DataElementTotaled
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementTotaled { get; set; }
Public Property DataElementTotaled As String
    Get
    Set
public:
property String^ DataElementTotaled {
    String^ get ();
    void set (String^ value);
}


DataElementTotaled1 Property

DataElementTotaled1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► DataElementTotaled1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementTotaled1 { get; set; }
Public Property DataElementTotaled1 As String
    Get
    Set
public:
property String^ DataElementTotaled1 {
    String^ get ();
    void set (String^ value);
}


DataElementTotaled2 Property

DataElementTotaled2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► DataElementTotaled2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementTotaled2 { get; set; }
Public Property DataElementTotaled2 As String
    Get
    Set
public:
property String^ DataElementTotaled2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfTransactionSetsTotaled Property

NumberOfTransactionSetsTotaled Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► NumberOfTransactionSetsTotaled
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsTotaled { get; set; }
Public Property NumberOfTransactionSetsTotaled As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsTotaled {
    String^ get ();
    void set (String^ value);
}


Total Property

Total Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► Total
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Total { get; set; }
Public Property Total As String
    Get
    Set
public:
property String^ Total {
    String^ get ();
    void set (String^ value);
}


Total1 Property

Total1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► Total1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Total1 { get; set; }
Public Property Total1 As String
    Get
    Set
public:
property String^ Total1 {
    String^ get ();
    void set (String^ value);
}


Total2 Property

Total2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► Total2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Total2 { get; set; }
Public Property Total2 As String
    Get
    Set
public:
property String^ Total2 {
    String^ get ();
    void set (String^ value);
}


TotalQualifier Property

TotalQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► TotalQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TotalQualifier { get; set; }
Public Property TotalQualifier As String
    Get
    Set
public:
property String^ TotalQualifier {
    String^ get ();
    void set (String^ value);
}


TotalQualifier1 Property

TotalQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► TotalQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TotalQualifier1 { get; set; }
Public Property TotalQualifier1 As String
    Get
    Set
public:
property String^ TotalQualifier1 {
    String^ get ();
    void set (String^ value);
}


TotalQualifier2 Property

TotalQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► TotalQualifier2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TotalQualifier2 { get; set; }
Public Property TotalQualifier2 As String
    Get
    Set
public:
property String^ TotalQualifier2 {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BT1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BTA Class

BTA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA
RDPCrystal EDI Library
Beginning Tax Acknowledgment
Declaration Syntax
C# Visual Basic Visual C++
public class BTA : DocumentSegment
Public Class BTA _
    Inherits DocumentSegment
public ref class BTA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BTA()()()() | Initializes a new instance of the BTA class
 | AcknowledgmentType | Element 1
 | AmountQualifierCode | Element 3
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BTA


BTA Constructor

BTA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► BTA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BTA class
Declaration Syntax
C# Visual Basic Visual C++
public BTA()
Public Sub New
public:
BTA()


AcknowledgmentType Property

AcknowledgmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► AcknowledgmentType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentType { get; set; }
Public Property AcknowledgmentType As String
    Get
    Set
public:
property String^ AcknowledgmentType {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► AmountQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BTC Class

BTC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC
RDPCrystal EDI Library
Beginning Segment for Parameter Trace Registration
Declaration Syntax
C# Visual Basic Visual C++
public class BTC : DocumentSegment
Public Class BTC _
    Inherits DocumentSegment
public ref class BTC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BTC()()()() | Initializes a new instance of the BTC class
 | AAR | Element 11
 | Count | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 10
 | IndustryCode | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OutputEventSelectionCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ParameterTraceRegistrationTypeCode | Element 2
 | ParameterTraceTypeCode | Element 3
 | ReferenceIdentification | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 7
 | YesNoConditionOrResponseCode2 | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BTC


BTC Constructor

BTC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► BTC()()()()
RDPCrystal EDI Library
Initializes a new instance of the BTC class
Declaration Syntax
C# Visual Basic Visual C++
public BTC()
Public Sub New
public:
BTC()


AAR Property

AAR Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► AAR
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string AAR { get; set; }
Public Property AAR As String
    Get
    Set
public:
property String^ AAR {
    String^ get ();
    void set (String^ value);
}


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► Count
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► IdentificationCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► IndustryCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OutputEventSelectionCode Property

OutputEventSelectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► OutputEventSelectionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string OutputEventSelectionCode { get; set; }
Public Property OutputEventSelectionCode As String
    Get
    Set
public:
property String^ OutputEventSelectionCode {
    String^ get ();
    void set (String^ value);
}


ParameterTraceRegistrationTypeCode Property

ParameterTraceRegistrationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► ParameterTraceRegistrationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ParameterTraceRegistrationTypeCode { get; set; }
Public Property ParameterTraceRegistrationTypeCode As String
    Get
    Set
public:
property String^ ParameterTraceRegistrationTypeCode {
    String^ get ();
    void set (String^ value);
}


ParameterTraceTypeCode Property

ParameterTraceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► ParameterTraceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ParameterTraceTypeCode { get; set; }
Public Property ParameterTraceTypeCode As String
    Get
    Set
public:
property String^ ParameterTraceTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTC ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


BTI Class

BTI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI
RDPCrystal EDI Library
Beginning Tax Information
Declaration Syntax
C# Visual Basic Visual C++
public class BTI : DocumentSegment
Public Class BTI _
    Inherits DocumentSegment
public ref class BTI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BTI()()()() | Initializes a new instance of the BTI class
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCode1 | Element 8
 | IdentificationCode2 | Element 10
 | IdentificationCode3 | Element 12
 | IdentificationCodeQualifier | Element 3
 | IdentificationCodeQualifier1 | Element 7
 | IdentificationCodeQualifier2 | Element 9
 | IdentificationCodeQualifier3 | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameControlIdentifier | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 13
 | TransactionTypeCode | Element 14
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BTI


BTI Constructor

BTI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► BTI()()()()
RDPCrystal EDI Library
Initializes a new instance of the BTI class
Declaration Syntax
C# Visual Basic Visual C++
public BTI()
Public Sub New
public:
BTI()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode2 Property

IdentificationCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode2 { get; set; }
Public Property IdentificationCode2 As String
    Get
    Set
public:
property String^ IdentificationCode2 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode3 Property

IdentificationCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCode3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode3 { get; set; }
Public Property IdentificationCode3 As String
    Get
    Set
public:
property String^ IdentificationCode3 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier2 Property

IdentificationCodeQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCodeQualifier2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier2 { get; set; }
Public Property IdentificationCodeQualifier2 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier2 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier3 Property

IdentificationCodeQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► IdentificationCodeQualifier3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier3 { get; set; }
Public Property IdentificationCodeQualifier3 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier3 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NameControlIdentifier Property

NameControlIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► NameControlIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NameControlIdentifier { get; set; }
Public Property NameControlIdentifier As String
    Get
    Set
public:
property String^ NameControlIdentifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► TransactionTypeCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BTP Class

BTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP
RDPCrystal EDI Library
Beginning Segment For Trading Partner Profile
Declaration Syntax
C# Visual Basic Visual C++
public class BTP : DocumentSegment
Public Class BTP _
    Inherits DocumentSegment
public ref class BTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BTP()()()() | Initializes a new instance of the BTP class
 | Date | Element 3
 | Date1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 10
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 7
 | Time | Element 4
 | Time1 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionSetPurposeCode1 | Element 6
 | TransactionTypeCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BTP


BTP Constructor

BTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► BTP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BTP class
Declaration Syntax
C# Visual Basic Visual C++
public BTP()
Public Sub New
public:
BTP()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► PaymentMethodCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► Time1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode1 Property

TransactionSetPurposeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► TransactionSetPurposeCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode1 { get; set; }
Public Property TransactionSetPurposeCode1 As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode1 {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► TransactionTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BTR Class

BTR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR
RDPCrystal EDI Library
Beginning Segment for Test Results
Declaration Syntax
C# Visual Basic Visual C++
public class BTR : DocumentSegment
Public Class BTR _
    Inherits DocumentSegment
public ref class BTR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BTR()()()() | Initializes a new instance of the BTR class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 6
 | ReportTypeCode | Element 4
 | SecurityLevelCode | Element 7
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BTR


BTR Constructor

BTR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► BTR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BTR class
Declaration Syntax
C# Visual Basic Visual C++
public BTR()
Public Sub New
public:
BTR()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► ReportTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► SecurityLevelCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BTS Class

BTS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS
RDPCrystal EDI Library
Beginning Segment for Train Sheets
Declaration Syntax
C# Visual Basic Visual C++
public class BTS : DocumentSegment
Public Class BTS _
    Inherits DocumentSegment
public ref class BTS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BTS()()()() | Initializes a new instance of the BTS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentStatusCode | Element 3
 | EquipmentStatusCode1 | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Horsepower | Element 8
 | InterchangeTrainIdentification | Element 1
 | Length | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceLevelCode | Element 11
 | StandardCarrierAlphaCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalEquipment | Element 2
 | TotalEquipment1 | Element 4
 | TransactionSetPurposeCode | Element 10
 | Weight | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BTS


BTS Constructor

BTS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► BTS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BTS class
Declaration Syntax
C# Visual Basic Visual C++
public BTS()
Public Sub New
public:
BTS()


EquipmentStatusCode Property

EquipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► EquipmentStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode { get; set; }
Public Property EquipmentStatusCode As String
    Get
    Set
public:
property String^ EquipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


EquipmentStatusCode1 Property

EquipmentStatusCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► EquipmentStatusCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode1 { get; set; }
Public Property EquipmentStatusCode1 As String
    Get
    Set
public:
property String^ EquipmentStatusCode1 {
    String^ get ();
    void set (String^ value);
}


Horsepower Property

Horsepower Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► Horsepower
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Horsepower { get; set; }
Public Property Horsepower As String
    Get
    Set
public:
property String^ Horsepower {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► Length
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► ServiceLevelCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TotalEquipment Property

TotalEquipment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► TotalEquipment
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TotalEquipment { get; set; }
Public Property TotalEquipment As String
    Get
    Set
public:
property String^ TotalEquipment {
    String^ get ();
    void set (String^ value);
}


TotalEquipment1 Property

TotalEquipment1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► TotalEquipment1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TotalEquipment1 { get; set; }
Public Property TotalEquipment1 As String
    Get
    Set
public:
property String^ TotalEquipment1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► Weight
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BTS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


BUY Class

BUY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY
RDPCrystal EDI Library
Loan Buydown
Declaration Syntax
C# Visual Basic Visual C++
public class BUY : DocumentSegment
Public Class BUY _
    Inherits DocumentSegment
public ref class BUY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BUY()()()() | Initializes a new instance of the BUY class
 | BuydownSourceCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanBuydownTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | Percent1 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BUY


BUY Constructor

BUY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► BUY()()()()
RDPCrystal EDI Library
Initializes a new instance of the BUY class
Declaration Syntax
C# Visual Basic Visual C++
public BUY()
Public Sub New
public:
BUY()


BuydownSourceCode Property

BuydownSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► BuydownSourceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BuydownSourceCode { get; set; }
Public Property BuydownSourceCode As String
    Get
    Set
public:
property String^ BuydownSourceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanBuydownTypeCode Property

LoanBuydownTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► LoanBuydownTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanBuydownTypeCode { get; set; }
Public Property LoanBuydownTypeCode As String
    Get
    Set
public:
property String^ LoanBuydownTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► Percent1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BUY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BVA Class

BVA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA
RDPCrystal EDI Library
Beginning Vehicle Advice
Declaration Syntax
C# Visual Basic Visual C++
public class BVA : DocumentSegment
Public Class BVA _
    Inherits DocumentSegment
public ref class BVA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BVA()()()() | Initializes a new instance of the BVA class
 | CheckNumber | Element 17
 | CurrencyCode | Element 12
 | Date | Element 5
 | Date1 | Element 14
 | Date2 | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 20
 | EquipmentInitial | Element 18
 | EquipmentNumber | Element 19
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 23
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCode1 | Element 8
 | IdentificationCode2 | Element 11
 | IdentificationCodeQualifier | Element 3
 | IdentificationCodeQualifier1 | Element 7
 | IdentificationCodeQualifier2 | Element 10
 | InvoiceNumber | Element 6
 | LadingDescriptionQualifier | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentTypeCode | Element 1
 | Quantity | Element 21
 | ReferenceIdentification | Element 15
 | ShipmentIdentificationNumber | Element 22
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 25
 | VehicleServiceCode | Element 9
 | VehicleStatus | Element 24
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BVA


BVA Constructor

BVA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► BVA()()()()
RDPCrystal EDI Library
Initializes a new instance of the BVA class
Declaration Syntax
C# Visual Basic Visual C++
public BVA()
Public Sub New
public:
BVA()


CheckNumber Property

CheckNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► CheckNumber
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string CheckNumber { get; set; }
Public Property CheckNumber As String
    Get
    Set
public:
property String^ CheckNumber {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► CurrencyCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► Date1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► Date2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► EquipmentInitial
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► EquipmentNumber
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► FlightVoyageNumber
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► IdentificationCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode2 Property

IdentificationCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► IdentificationCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode2 { get; set; }
Public Property IdentificationCode2 As String
    Get
    Set
public:
property String^ IdentificationCode2 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier2 Property

IdentificationCodeQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► IdentificationCodeQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier2 { get; set; }
Public Property IdentificationCodeQualifier2 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier2 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► InvoiceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


LadingDescriptionQualifier Property

LadingDescriptionQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► LadingDescriptionQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescriptionQualifier { get; set; }
Public Property LadingDescriptionQualifier As String
    Get
    Set
public:
property String^ LadingDescriptionQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentTypeCode Property

PaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► PaymentTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentTypeCode { get; set; }
Public Property PaymentTypeCode As String
    Get
    Set
public:
property String^ PaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► Quantity
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► ReferenceIdentification
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


VehicleServiceCode Property

VehicleServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► VehicleServiceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleServiceCode { get; set; }
Public Property VehicleServiceCode As String
    Get
    Set
public:
property String^ VehicleServiceCode {
    String^ get ();
    void set (String^ value);
}


VehicleStatus Property

VehicleStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► VehicleStatus
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleStatus { get; set; }
Public Property VehicleStatus As String
    Get
    Set
public:
property String^ VehicleStatus {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BVB Class

BVB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB
RDPCrystal EDI Library
Beginning Segment for Vehicle Baying Order
Declaration Syntax
C# Visual Basic Visual C++
public class BVB : DocumentSegment
Public Class BVB _
    Inherits DocumentSegment
public ref class BVB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BVB()()()() | Initializes a new instance of the BVB class
 | BayTypeCode | Element 4
 | CapacityQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BVB


BVB Constructor

BVB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► BVB()()()()
RDPCrystal EDI Library
Initializes a new instance of the BVB class
Declaration Syntax
C# Visual Basic Visual C++
public BVB()
Public Sub New
public:
BVB()


BayTypeCode Property

BayTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► BayTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BayTypeCode { get; set; }
Public Property BayTypeCode As String
    Get
    Set
public:
property String^ BayTypeCode {
    String^ get ();
    void set (String^ value);
}


CapacityQualifier Property

CapacityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► CapacityQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CapacityQualifier { get; set; }
Public Property CapacityQualifier As String
    Get
    Set
public:
property String^ CapacityQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BVP Class

BVP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP
RDPCrystal EDI Library
Beginning Segment for Vehicle Shipping Order
Declaration Syntax
C# Visual Basic Visual C++
public class BVP : DocumentSegment
Public Class BVP _
    Inherits DocumentSegment
public ref class BVP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BVP()()()() | Initializes a new instance of the BVP class
 | Date | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCode1 | Element 5
 | IdentificationCodeQualifier | Element 2
 | IdentificationCodeQualifier1 | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 9
 | StandardCarrierAlphaCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 11
 | VehicleProductionStatus | Element 1
 | VehicleServiceCode | Element 6
 | VehicleStatus | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BVP


BVP Constructor

BVP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► BVP()()()()
RDPCrystal EDI Library
Initializes a new instance of the BVP class
Declaration Syntax
C# Visual Basic Visual C++
public BVP()
Public Sub New
public:
BVP()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► Date
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► IdentificationCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


VehicleProductionStatus Property

VehicleProductionStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► VehicleProductionStatus
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleProductionStatus { get; set; }
Public Property VehicleProductionStatus As String
    Get
    Set
public:
property String^ VehicleProductionStatus {
    String^ get ();
    void set (String^ value);
}


VehicleServiceCode Property

VehicleServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► VehicleServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleServiceCode { get; set; }
Public Property VehicleServiceCode As String
    Get
    Set
public:
property String^ VehicleServiceCode {
    String^ get ();
    void set (String^ value);
}


VehicleStatus Property

VehicleStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► VehicleStatus
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleStatus { get; set; }
Public Property VehicleStatus As String
    Get
    Set
public:
property String^ VehicleStatus {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BVS Class

BVS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS
RDPCrystal EDI Library
Beginning Segment for Vehicle Service
Declaration Syntax
C# Visual Basic Visual C++
public class BVS : DocumentSegment
Public Class BVS _
    Inherits DocumentSegment
public ref class BVS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BVS()()()() | Initializes a new instance of the BVS class
 | AccountNumber | Element 11
 | BillOfLadingWaybillNumber | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCode1 | Element 9
 | IdentificationCodeQualifier | Element 2
 | IdentificationCodeQualifier1 | Element 8
 | InvoiceNumber | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | ReferenceIdentification | Element 12
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleServiceCode | Element 5
 | VehicleStatus | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BVS


BVS Constructor

BVS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► BVS()()()()
RDPCrystal EDI Library
Initializes a new instance of the BVS class
Declaration Syntax
C# Visual Basic Visual C++
public BVS()
Public Sub New
public:
BVS()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► AccountNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► IdentificationCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► InvoiceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► ReferenceIdentification
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


VehicleServiceCode Property

VehicleServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► VehicleServiceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleServiceCode { get; set; }
Public Property VehicleServiceCode As String
    Get
    Set
public:
property String^ VehicleServiceCode {
    String^ get ();
    void set (String^ value);
}


VehicleStatus Property

VehicleStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► VehicleStatus
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleStatus { get; set; }
Public Property VehicleStatus As String
    Get
    Set
public:
property String^ VehicleStatus {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BVS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BW Class

BW Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW
RDPCrystal EDI Library
Beginning Segment for Weight Message Set
Declaration Syntax
C# Visual Basic Visual C++
public class BW : DocumentSegment
Public Class BW _
    Inherits DocumentSegment
public ref class BW : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BW()()()() | Initializes a new instance of the BW class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginEDICarrierCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WeightUnitCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BW


BW Constructor

BW Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW ► BW()()()()
RDPCrystal EDI Library
Initializes a new instance of the BW class
Declaration Syntax
C# Visual Basic Visual C++
public BW()
Public Sub New
public:
BW()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OriginEDICarrierCode Property

OriginEDICarrierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW ► OriginEDICarrierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OriginEDICarrierCode { get; set; }
Public Property OriginEDICarrierCode As String
    Get
    Set
public:
property String^ OriginEDICarrierCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW ► WeightUnitCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BW ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


BX Class

BX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX
RDPCrystal EDI Library
General Shipment Information
Declaration Syntax
C# Visual Basic Visual C++
public class BX : DocumentSegment
Public Class BX _
    Inherits DocumentSegment
public ref class BX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BX()()()() | Initializes a new instance of the BX class
 | ApplicationType | Element 14
 | CapacityLoadCode | Element 9
 | ConfidentialBillingRequestCode | Element 12
 | CustomsDocumentationHandlingCode | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GoodsAndServicesTaxReasonCode | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SectionSevenCode | Element 8
 | ShipmentIdentificationNumber | Element 4
 | ShipmentMethodOfPayment | Element 3
 | ShipmentQualifier | Element 7
 | StandardCarrierAlphaCode | Element 5
 | StatusReportRequestCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransportationMethodTypeCode | Element 2
 | WeightUnitCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BX


BX Constructor

BX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► BX()()()()
RDPCrystal EDI Library
Initializes a new instance of the BX class
Declaration Syntax
C# Visual Basic Visual C++
public BX()
Public Sub New
public:
BX()


ApplicationType Property

ApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► ApplicationType
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationType { get; set; }
Public Property ApplicationType As String
    Get
    Set
public:
property String^ ApplicationType {
    String^ get ();
    void set (String^ value);
}


CapacityLoadCode Property

CapacityLoadCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► CapacityLoadCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CapacityLoadCode { get; set; }
Public Property CapacityLoadCode As String
    Get
    Set
public:
property String^ CapacityLoadCode {
    String^ get ();
    void set (String^ value);
}


ConfidentialBillingRequestCode Property

ConfidentialBillingRequestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► ConfidentialBillingRequestCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ConfidentialBillingRequestCode { get; set; }
Public Property ConfidentialBillingRequestCode As String
    Get
    Set
public:
property String^ ConfidentialBillingRequestCode {
    String^ get ();
    void set (String^ value);
}


CustomsDocumentationHandlingCode Property

CustomsDocumentationHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► CustomsDocumentationHandlingCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsDocumentationHandlingCode { get; set; }
Public Property CustomsDocumentationHandlingCode As String
    Get
    Set
public:
property String^ CustomsDocumentationHandlingCode {
    String^ get ();
    void set (String^ value);
}


GoodsAndServicesTaxReasonCode Property

GoodsAndServicesTaxReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► GoodsAndServicesTaxReasonCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string GoodsAndServicesTaxReasonCode { get; set; }
Public Property GoodsAndServicesTaxReasonCode As String
    Get
    Set
public:
property String^ GoodsAndServicesTaxReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SectionSevenCode Property

SectionSevenCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► SectionSevenCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SectionSevenCode { get; set; }
Public Property SectionSevenCode As String
    Get
    Set
public:
property String^ SectionSevenCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


ShipmentQualifier Property

ShipmentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► ShipmentQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentQualifier { get; set; }
Public Property ShipmentQualifier As String
    Get
    Set
public:
property String^ ShipmentQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StatusReportRequestCode Property

StatusReportRequestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► StatusReportRequestCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReportRequestCode { get; set; }
Public Property StatusReportRequestCode As String
    Get
    Set
public:
property String^ StatusReportRequestCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► WeightUnitCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► BX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


C2 Class

C2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2
RDPCrystal EDI Library
Bank ID
Declaration Syntax
C# Visual Basic Visual C++
public class C2 : DocumentSegment
Public Class C2 _
    Inherits DocumentSegment
public ref class C2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | C2()()()() | Initializes a new instance of the C2 class
 | BankAccountNumber | Element 5
 | BankClientCode | Element 1
 | ClientBankNumber | Element 4
 | Date | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | C2


C2 Constructor

C2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► C2()()()()
RDPCrystal EDI Library
Initializes a new instance of the C2 class
Declaration Syntax
C# Visual Basic Visual C++
public C2()
Public Sub New
public:
C2()


BankAccountNumber Property

BankAccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► BankAccountNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BankAccountNumber { get; set; }
Public Property BankAccountNumber As String
    Get
    Set
public:
property String^ BankAccountNumber {
    String^ get ();
    void set (String^ value);
}


BankClientCode Property

BankClientCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► BankClientCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BankClientCode { get; set; }
Public Property BankClientCode As String
    Get
    Set
public:
property String^ BankClientCode {
    String^ get ();
    void set (String^ value);
}


ClientBankNumber Property

ClientBankNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► ClientBankNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ClientBankNumber { get; set; }
Public Property ClientBankNumber As String
    Get
    Set
public:
property String^ ClientBankNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► PaymentMethodCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


C3 Class

C3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3
RDPCrystal EDI Library
Currency
Declaration Syntax
C# Visual Basic Visual C++
public class C3 : DocumentSegment
Public Class C3 _
    Inherits DocumentSegment
public ref class C3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | C3()()()() | Initializes a new instance of the C3 class
 | CurrencyCode | Element 1
 | CurrencyCode1 | Element 3
 | CurrencyCode2 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExchangeRate | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | C3


C3 Constructor

C3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► C3()()()()
RDPCrystal EDI Library
Initializes a new instance of the C3 class
Declaration Syntax
C# Visual Basic Visual C++
public C3()
Public Sub New
public:
C3()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► CurrencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


CurrencyCode1 Property

CurrencyCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► CurrencyCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode1 { get; set; }
Public Property CurrencyCode1 As String
    Get
    Set
public:
property String^ CurrencyCode1 {
    String^ get ();
    void set (String^ value);
}


CurrencyCode2 Property

CurrencyCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► CurrencyCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode2 { get; set; }
Public Property CurrencyCode2 As String
    Get
    Set
public:
property String^ CurrencyCode2 {
    String^ get ();
    void set (String^ value);
}


ExchangeRate Property

ExchangeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► ExchangeRate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ExchangeRate { get; set; }
Public Property ExchangeRate As String
    Get
    Set
public:
property String^ ExchangeRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


C4 Class

C4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C4
RDPCrystal EDI Library
Alternate Amount Due
Declaration Syntax
C# Visual Basic Visual C++
public class C4 : DocumentSegment
Public Class C4 _
    Inherits DocumentSegment
public ref class C4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | C4()()()() | Initializes a new instance of the C4 class
 | CurrencyCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetAmountDue | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | C4


C4 Constructor

C4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C4 ► C4()()()()
RDPCrystal EDI Library
Initializes a new instance of the C4 class
Declaration Syntax
C# Visual Basic Visual C++
public C4()
Public Sub New
public:
C4()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C4 ► CurrencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetAmountDue Property

NetAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C4 ► NetAmountDue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NetAmountDue { get; set; }
Public Property NetAmountDue As String
    Get
    Set
public:
property String^ NetAmountDue {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


C8 Class

C8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8
RDPCrystal EDI Library
Certifications and Clauses
Declaration Syntax
C# Visual Basic Visual C++
public class C8 : DocumentSegment
Public Class C8 _
    Inherits DocumentSegment
public ref class C8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | C8()()()() | Initializes a new instance of the C8 class
 | CertificationClauseCode | Element 2
 | CertificationClauseText | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingLineItemNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShippersExportDeclarationRequirements | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | C8


C8 Constructor

C8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► C8()()()()
RDPCrystal EDI Library
Initializes a new instance of the C8 class
Declaration Syntax
C# Visual Basic Visual C++
public C8()
Public Sub New
public:
C8()


CertificationClauseCode Property

CertificationClauseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► CertificationClauseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseCode { get; set; }
Public Property CertificationClauseCode As String
    Get
    Set
public:
property String^ CertificationClauseCode {
    String^ get ();
    void set (String^ value);
}


CertificationClauseText Property

CertificationClauseText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► CertificationClauseText
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseText { get; set; }
Public Property CertificationClauseText As String
    Get
    Set
public:
property String^ CertificationClauseText {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShippersExportDeclarationRequirements Property

ShippersExportDeclarationRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► ShippersExportDeclarationRequirements
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShippersExportDeclarationRequirements { get; set; }
Public Property ShippersExportDeclarationRequirements As String
    Get
    Set
public:
property String^ ShippersExportDeclarationRequirements {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


C8C Class

C8C Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C
RDPCrystal EDI Library
Certifications Clauses Continuation
Declaration Syntax
C# Visual Basic Visual C++
public class C8C : DocumentSegment
Public Class C8C _
    Inherits DocumentSegment
public ref class C8C : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | C8C()()()() | Initializes a new instance of the C8C class
 | CertificationClauseText | Element 1
 | CertificationClauseText1 | Element 2
 | CertificationClauseText2 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | C8C


C8C Constructor

C8C Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C ► C8C()()()()
RDPCrystal EDI Library
Initializes a new instance of the C8C class
Declaration Syntax
C# Visual Basic Visual C++
public C8C()
Public Sub New
public:
C8C()


CertificationClauseText Property

CertificationClauseText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C ► CertificationClauseText
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseText { get; set; }
Public Property CertificationClauseText As String
    Get
    Set
public:
property String^ CertificationClauseText {
    String^ get ();
    void set (String^ value);
}


CertificationClauseText1 Property

CertificationClauseText1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C ► CertificationClauseText1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseText1 { get; set; }
Public Property CertificationClauseText1 As String
    Get
    Set
public:
property String^ CertificationClauseText1 {
    String^ get ();
    void set (String^ value);
}


CertificationClauseText2 Property

CertificationClauseText2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C ► CertificationClauseText2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseText2 { get; set; }
Public Property CertificationClauseText2 As String
    Get
    Set
public:
property String^ CertificationClauseText2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► C8C ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CA1 Class

CA1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CA1
RDPCrystal EDI Library
Rate Request Identifier
Declaration Syntax
C# Visual Basic Visual C++
public class CA1 : DocumentSegment
Public Class CA1 _
    Inherits DocumentSegment
public ref class CA1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CA1()()()() | Initializes a new instance of the CA1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateRequestID | Element 1
 | RateResponseSuffix | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CA1


CA1 Constructor

CA1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CA1 ► CA1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CA1 class
Declaration Syntax
C# Visual Basic Visual C++
public CA1()
Public Sub New
public:
CA1()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CA1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateRequestID Property

RateRequestID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CA1 ► RateRequestID
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateRequestID { get; set; }
Public Property RateRequestID As String
    Get
    Set
public:
property String^ RateRequestID {
    String^ get ();
    void set (String^ value);
}


RateResponseSuffix Property

RateResponseSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CA1 ► RateResponseSuffix
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateResponseSuffix { get; set; }
Public Property RateResponseSuffix As String
    Get
    Set
public:
property String^ RateResponseSuffix {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CA1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CAD Class

CAD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD
RDPCrystal EDI Library
Carrier Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CAD : DocumentSegment
Public Class CAD _
    Inherits DocumentSegment
public ref class CAD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAD()()()() | Initializes a new instance of the CAD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 8
 | ReferenceIdentificationQualifier | Element 7
 | Routing | Element 5
 | ServiceLevelCode | Element 9
 | ShipmentOrderStatusCode | Element 6
 | StandardCarrierAlphaCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAD


CAD Constructor

CAD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► CAD()()()()
RDPCrystal EDI Library
Initializes a new instance of the CAD class
Declaration Syntax
C# Visual Basic Visual C++
public CAD()
Public Sub New
public:
CAD()


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► Routing
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► ServiceLevelCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CAI Class

CAI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI
RDPCrystal EDI Library
Civil Action Income
Declaration Syntax
C# Visual Basic Visual C++
public class CAI : DocumentSegment
Public Class CAI _
    Inherits DocumentSegment
public ref class CAI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAI()()()() | Initializes a new instance of the CAI class
 | AmountQualifierCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | Name2 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PublicRecordOrObligationCode | Element 1
 | RateValueQualifier | Element 6
 | ReferenceIdentification | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAI


CAI Constructor

CAI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► CAI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CAI class
Declaration Syntax
C# Visual Basic Visual C++
public CAI()
Public Sub New
public:
CAI()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► AmountQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► Name2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


PublicRecordOrObligationCode Property

PublicRecordOrObligationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► PublicRecordOrObligationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PublicRecordOrObligationCode { get; set; }
Public Property PublicRecordOrObligationCode As String
    Get
    Set
public:
property String^ PublicRecordOrObligationCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► RateValueQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CAL Class

CAL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL
RDPCrystal EDI Library
Calendar
Declaration Syntax
C# Visual Basic Visual C++
public class CAL : DocumentSegment
Public Class CAL _
    Inherits DocumentSegment
public ref class CAL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAL()()()() | Initializes a new instance of the CAL class
 | Date | Element 5
 | Date1 | Element 10
 | DateTimeQualifier | Element 4
 | DateTimeQualifier1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 16
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 15
 | QuantityQualifier | Element 14
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ShipDeliveryOrCalendarPatternCode | Element 8
 | ShipDeliveryOrCalendarPatternCode1 | Element 13
 | Time | Element 6
 | Time1 | Element 11
 | TimeCode | Element 7
 | TimeCode1 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAL


CAL Constructor

CAL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► CAL()()()()
RDPCrystal EDI Library
Initializes a new instance of the CAL class
Declaration Syntax
C# Visual Basic Visual C++
public CAL()
Public Sub New
public:
CAL()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Date1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► DateTimeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier1 Property

DateTimeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► DateTimeQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier1 { get; set; }
Public Property DateTimeQualifier1 As String
    Get
    Set
public:
property String^ DateTimeQualifier1 {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► FreeformDescription
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Quantity
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► QuantityQualifier
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode1 Property

ShipDeliveryOrCalendarPatternCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► ShipDeliveryOrCalendarPatternCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode1 { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode1 As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Time1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► TimeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


TimeCode1 Property

TimeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► TimeCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode1 { get; set; }
Public Property TimeCode1 As String
    Get
    Set
public:
property String^ TimeCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CAS Class

CAS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS
RDPCrystal EDI Library
Claims Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class CAS : DocumentSegment
Public Class CAS _
    Inherits DocumentSegment
public ref class CAS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAS()()()() | Initializes a new instance of the CAS class
 | ClaimAdjustmentGroupCode | Element 1
 | ClaimAdjustmentReasonCode1 | Element 2
 | ClaimAdjustmentReasonCode2 | Element 5
 | ClaimAdjustmentReasonCode3 | Element 8
 | ClaimAdjustmentReasonCode4 | Element 11
 | ClaimAdjustmentReasonCode5 | Element 14
 | ClaimAdjustmentReasonCode6 | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 9
 | MonetaryAmount4 | Element 12
 | MonetaryAmount5 | Element 15
 | MonetaryAmount6 | Element 18
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 4
 | Quantity2 | Element 7
 | Quantity3 | Element 10
 | Quantity4 | Element 13
 | Quantity5 | Element 16
 | Quantity6 | Element 19
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAS


CAS Constructor

CAS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► CAS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CAS class
Declaration Syntax
C# Visual Basic Visual C++
public CAS()
Public Sub New
public:
CAS()


ClaimAdjustmentGroupCode Property

ClaimAdjustmentGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentGroupCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentGroupCode { get; set; }
Public Property ClaimAdjustmentGroupCode As String
    Get
    Set
public:
property String^ ClaimAdjustmentGroupCode {
    String^ get ();
    void set (String^ value);
}


ClaimAdjustmentReasonCode1 Property

ClaimAdjustmentReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentReasonCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode1 { get; set; }
Public Property ClaimAdjustmentReasonCode1 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode1 {
    String^ get ();
    void set (String^ value);
}


ClaimAdjustmentReasonCode2 Property

ClaimAdjustmentReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentReasonCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode2 { get; set; }
Public Property ClaimAdjustmentReasonCode2 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode2 {
    String^ get ();
    void set (String^ value);
}


ClaimAdjustmentReasonCode3 Property

ClaimAdjustmentReasonCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentReasonCode3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode3 { get; set; }
Public Property ClaimAdjustmentReasonCode3 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode3 {
    String^ get ();
    void set (String^ value);
}


ClaimAdjustmentReasonCode4 Property

ClaimAdjustmentReasonCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentReasonCode4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode4 { get; set; }
Public Property ClaimAdjustmentReasonCode4 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode4 {
    String^ get ();
    void set (String^ value);
}


ClaimAdjustmentReasonCode5 Property

ClaimAdjustmentReasonCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentReasonCode5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode5 { get; set; }
Public Property ClaimAdjustmentReasonCode5 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode5 {
    String^ get ();
    void set (String^ value);
}


ClaimAdjustmentReasonCode6 Property

ClaimAdjustmentReasonCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► ClaimAdjustmentReasonCode6
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode6 { get; set; }
Public Property ClaimAdjustmentReasonCode6 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode6 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► MonetaryAmount3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► MonetaryAmount4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► MonetaryAmount5
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► MonetaryAmount6
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Quantity2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Quantity3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Quantity4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Quantity5
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Quantity6
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CAT Class

CAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT
RDPCrystal EDI Library
Category of Patient Information Service
Declaration Syntax
C# Visual Basic Visual C++
public class CAT : DocumentSegment
Public Class CAT _
    Inherits DocumentSegment
public ref class CAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAT()()()() | Initializes a new instance of the CAT class
 | CodeListQualifierCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 5
 | IndustryCode1 | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportTransmissionCode | Element 2
 | ReportTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier | Element 3
 | VersionIdentifier1 | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAT


CAT Constructor

CAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► CAT()()()()
RDPCrystal EDI Library
Initializes a new instance of the CAT class
Declaration Syntax
C# Visual Basic Visual C++
public CAT()
Public Sub New
public:
CAT()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► CodeListQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► IndustryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► IndustryCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► ReportTransmissionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► VersionIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier1 Property

VersionIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► VersionIdentifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier1 { get; set; }
Public Property VersionIdentifier1 As String
    Get
    Set
public:
property String^ VersionIdentifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CAT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CB1 Class

CB1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CB1
RDPCrystal EDI Library
Contract and Cost Accounting Standards Data
Declaration Syntax
C# Visual Basic Visual C++
public class CB1 : DocumentSegment
Public Class CB1 _
    Inherits DocumentSegment
public ref class CB1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CB1()()()() | Initializes a new instance of the CB1 class
 | AcquisitionDataCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FinancingTypeCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CB1


CB1 Constructor

CB1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CB1 ► CB1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CB1 class
Declaration Syntax
C# Visual Basic Visual C++
public CB1()
Public Sub New
public:
CB1()


AcquisitionDataCode Property

AcquisitionDataCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CB1 ► AcquisitionDataCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcquisitionDataCode { get; set; }
Public Property AcquisitionDataCode As String
    Get
    Set
public:
property String^ AcquisitionDataCode {
    String^ get ();
    void set (String^ value);
}


FinancingTypeCode Property

FinancingTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CB1 ► FinancingTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FinancingTypeCode { get; set; }
Public Property FinancingTypeCode As String
    Get
    Set
public:
property String^ FinancingTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CB1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CB1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CBS Class

CBS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS
RDPCrystal EDI Library
Cost Breakdown Structure
Declaration Syntax
C# Visual Basic Visual C++
public class CBS : DocumentSegment
Public Class CBS _
    Inherits DocumentSegment
public ref class CBS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CBS()()()() | Initializes a new instance of the CBS class
 | AssignedIdentification | Element 1
 | CompositeUnitOfMeasure | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CBS


CBS Constructor

CBS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS ► CBS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CBS class
Declaration Syntax
C# Visual Basic Visual C++
public CBS()
Public Sub New
public:
CBS()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CBS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CCI Class

CCI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI
RDPCrystal EDI Library
Credit Counseling Information
Declaration Syntax
C# Visual Basic Visual C++
public class CCI : DocumentSegment
Public Class CCI _
    Inherits DocumentSegment
public ref class CCI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CCI()()()() | Initializes a new instance of the CCI class
 | CounselingStatusCode | Element 10
 | DateTimePeriod | Element 6
 | DateTimePeriod1 | Element 7
 | DateTimePeriod2 | Element 8
 | DateTimePeriodFormatQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 9
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CCI


CCI Constructor

CCI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► CCI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CCI class
Declaration Syntax
C# Visual Basic Visual C++
public CCI()
Public Sub New
public:
CCI()


CounselingStatusCode Property

CounselingStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► CounselingStatusCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CounselingStatusCode { get; set; }
Public Property CounselingStatusCode As String
    Get
    Set
public:
property String^ CounselingStatusCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► DateTimePeriod1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► DateTimePeriod2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► IdentificationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► MonetaryAmount
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CCI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CD Class

CD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD
RDPCrystal EDI Library
Shipment Conditions
Declaration Syntax
C# Visual Basic Visual C++
public class CD : DocumentSegment
Public Class CD _
    Inherits DocumentSegment
public ref class CD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CD()()()() | Initializes a new instance of the CD class
 | AssignedNumber | Element 6
 | ChangeTypeCode | Element 7
 | ConditionCode | Element 2
 | ConditionSegmentLogicalConnector | Element 1
 | ConditionValue | Element 3
 | ConditionValue1 | Element 4
 | ConditionValue2 | Element 5
 | DocketControlNumber | Element 9
 | DocketIdentification | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupTitle | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CD


CD Constructor

CD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► CD()()()()
RDPCrystal EDI Library
Initializes a new instance of the CD class
Declaration Syntax
C# Visual Basic Visual C++
public CD()
Public Sub New
public:
CD()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► AssignedNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► ChangeTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


ConditionCode Property

ConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► ConditionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionCode { get; set; }
Public Property ConditionCode As String
    Get
    Set
public:
property String^ ConditionCode {
    String^ get ();
    void set (String^ value);
}


ConditionSegmentLogicalConnector Property

ConditionSegmentLogicalConnector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► ConditionSegmentLogicalConnector
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionSegmentLogicalConnector { get; set; }
Public Property ConditionSegmentLogicalConnector As String
    Get
    Set
public:
property String^ ConditionSegmentLogicalConnector {
    String^ get ();
    void set (String^ value);
}


ConditionValue Property

ConditionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► ConditionValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue { get; set; }
Public Property ConditionValue As String
    Get
    Set
public:
property String^ ConditionValue {
    String^ get ();
    void set (String^ value);
}


ConditionValue1 Property

ConditionValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► ConditionValue1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue1 { get; set; }
Public Property ConditionValue1 As String
    Get
    Set
public:
property String^ ConditionValue1 {
    String^ get ();
    void set (String^ value);
}


ConditionValue2 Property

ConditionValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► ConditionValue2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue2 { get; set; }
Public Property ConditionValue2 As String
    Get
    Set
public:
property String^ ConditionValue2 {
    String^ get ();
    void set (String^ value);
}


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► DocketControlNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► DocketIdentification
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


GroupTitle Property

GroupTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► GroupTitle
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string GroupTitle { get; set; }
Public Property GroupTitle As String
    Get
    Set
public:
property String^ GroupTitle {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CD1 Class

CD1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1
RDPCrystal EDI Library
Cargo Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CD1 : DocumentSegment
Public Class CD1 _
    Inherits DocumentSegment
public ref class CD1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CD1()()()() | Initializes a new instance of the CD1 class
 | BillOfLadingWaybillNumber | Element 4
 | Date | Element 8
 | Date1 | Element 25
 | DateTimeQualifier | Element 24
 | DispositionCode | Element 12
 | DispositionCode1 | Element 13
 | DispositionCode2 | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | EquipmentType | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialClassCode | Element 7
 | HazardousMaterialCodeQualifier | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingCode | Element 11
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 10
 | Rate | Element 17
 | Rate1 | Element 20
 | Rate2 | Element 23
 | RateClassCode | Element 15
 | RateClassCode1 | Element 18
 | RateClassCode2 | Element 21
 | RateValueQualifier | Element 16
 | RateValueQualifier1 | Element 19
 | RateValueQualifier2 | Element 22
 | ReferenceIdentification | Element 29
 | ReferenceIdentification1 | Element 31
 | ReferenceIdentificationQualifier | Element 28
 | ReferenceIdentificationQualifier1 | Element 30
 | ShipmentStatusCode | Element 26
 | StandardCarrierAlphaCode | Element 27
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CD1


CD1 Constructor

CD1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► CD1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CD1 class
Declaration Syntax
C# Visual Basic Visual C++
public CD1()
Public Sub New
public:
CD1()


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Date1
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► DateTimeQualifier
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► DispositionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


DispositionCode1 Property

DispositionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► DispositionCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode1 { get; set; }
Public Property DispositionCode1 As String
    Get
    Set
public:
property String^ DispositionCode1 {
    String^ get ();
    void set (String^ value);
}


DispositionCode2 Property

DispositionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► DispositionCode2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode2 { get; set; }
Public Property DispositionCode2 As String
    Get
    Set
public:
property String^ DispositionCode2 {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► EquipmentType
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialClassCode Property

HazardousMaterialClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► HazardousMaterialClassCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialClassCode { get; set; }
Public Property HazardousMaterialClassCode As String
    Get
    Set
public:
property String^ HazardousMaterialClassCode {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialCodeQualifier Property

HazardousMaterialCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► HazardousMaterialCodeQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialCodeQualifier { get; set; }
Public Property HazardousMaterialCodeQualifier As String
    Get
    Set
public:
property String^ HazardousMaterialCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► LocationIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► PackagingCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Rate
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


Rate1 Property

Rate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Rate1
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Rate1 { get; set; }
Public Property Rate1 As String
    Get
    Set
public:
property String^ Rate1 {
    String^ get ();
    void set (String^ value);
}


Rate2 Property

Rate2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Rate2
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string Rate2 { get; set; }
Public Property Rate2 As String
    Get
    Set
public:
property String^ Rate2 {
    String^ get ();
    void set (String^ value);
}


RateClassCode Property

RateClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► RateClassCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RateClassCode { get; set; }
Public Property RateClassCode As String
    Get
    Set
public:
property String^ RateClassCode {
    String^ get ();
    void set (String^ value);
}


RateClassCode1 Property

RateClassCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► RateClassCode1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string RateClassCode1 { get; set; }
Public Property RateClassCode1 As String
    Get
    Set
public:
property String^ RateClassCode1 {
    String^ get ();
    void set (String^ value);
}


RateClassCode2 Property

RateClassCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► RateClassCode2
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string RateClassCode2 { get; set; }
Public Property RateClassCode2 As String
    Get
    Set
public:
property String^ RateClassCode2 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► RateValueQualifier
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► RateValueQualifier1
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier2 Property

RateValueQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► RateValueQualifier2
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier2 { get; set; }
Public Property RateValueQualifier2 As String
    Get
    Set
public:
property String^ RateValueQualifier2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 31
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 30
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusCode Property

ShipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► ShipmentStatusCode
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusCode { get; set; }
Public Property ShipmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► TypeOfServiceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CD2 Class

CD2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2
RDPCrystal EDI Library
Multi-Valued Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class CD2 : DocumentSegment
Public Class CD2 _
    Inherits DocumentSegment
public ref class CD2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CD2()()()() | Initializes a new instance of the CD2 class
 | CodeCategory | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalCodeValue | Element 3
 | MedicalCodeValue1 | Element 4
 | MedicalCodeValue2 | Element 5
 | MedicalCodeValue3 | Element 6
 | MedicalCodeValue4 | Element 7
 | MedicalCodeValue5 | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceIDQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CD2


CD2 Constructor

CD2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► CD2()()()()
RDPCrystal EDI Library
Initializes a new instance of the CD2 class
Declaration Syntax
C# Visual Basic Visual C++
public CD2()
Public Sub New
public:
CD2()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MedicalCodeValue Property

MedicalCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► MedicalCodeValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue { get; set; }
Public Property MedicalCodeValue As String
    Get
    Set
public:
property String^ MedicalCodeValue {
    String^ get ();
    void set (String^ value);
}


MedicalCodeValue1 Property

MedicalCodeValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► MedicalCodeValue1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue1 { get; set; }
Public Property MedicalCodeValue1 As String
    Get
    Set
public:
property String^ MedicalCodeValue1 {
    String^ get ();
    void set (String^ value);
}


MedicalCodeValue2 Property

MedicalCodeValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► MedicalCodeValue2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue2 { get; set; }
Public Property MedicalCodeValue2 As String
    Get
    Set
public:
property String^ MedicalCodeValue2 {
    String^ get ();
    void set (String^ value);
}


MedicalCodeValue3 Property

MedicalCodeValue3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► MedicalCodeValue3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue3 { get; set; }
Public Property MedicalCodeValue3 As String
    Get
    Set
public:
property String^ MedicalCodeValue3 {
    String^ get ();
    void set (String^ value);
}


MedicalCodeValue4 Property

MedicalCodeValue4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► MedicalCodeValue4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue4 { get; set; }
Public Property MedicalCodeValue4 As String
    Get
    Set
public:
property String^ MedicalCodeValue4 {
    String^ get ();
    void set (String^ value);
}


MedicalCodeValue5 Property

MedicalCodeValue5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► MedicalCodeValue5
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue5 { get; set; }
Public Property MedicalCodeValue5 As String
    Get
    Set
public:
property String^ MedicalCodeValue5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CD3 Class

CD3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3
RDPCrystal EDI Library
Carton (Package) Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CD3 : DocumentSegment
Public Class CD3 _
    Inherits DocumentSegment
public ref class CD3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CD3()()()() | Initializes a new instance of the CD3 class
 | Charge | Element 8
 | Charge1 | Element 10
 | CountryCode | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 13
 | PickupOrDeliveryCode | Element 6
 | RateValueQualifier | Element 7
 | RateValueQualifier1 | Element 9
 | ServiceLevelCode | Element 5
 | ServiceLevelCode1 | Element 11
 | ServiceLevelCode2 | Element 12
 | ServiceStandard | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 2
 | WeightQualifier | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | Zone | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CD3


CD3 Constructor

CD3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► CD3()()()()
RDPCrystal EDI Library
Initializes a new instance of the CD3 class
Declaration Syntax
C# Visual Basic Visual C++
public CD3()
Public Sub New
public:
CD3()


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► Charge
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


Charge1 Property

Charge1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► Charge1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Charge1 { get; set; }
Public Property Charge1 As String
    Get
    Set
public:
property String^ Charge1 {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► CountryCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► PaymentMethodCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► RateValueQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► RateValueQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► ServiceLevelCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode1 Property

ServiceLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► ServiceLevelCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode1 { get; set; }
Public Property ServiceLevelCode1 As String
    Get
    Set
public:
property String^ ServiceLevelCode1 {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode2 Property

ServiceLevelCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► ServiceLevelCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode2 { get; set; }
Public Property ServiceLevelCode2 As String
    Get
    Set
public:
property String^ ServiceLevelCode2 {
    String^ get ();
    void set (String^ value);
}


ServiceStandard Property

ServiceStandard Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► ServiceStandard
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceStandard { get; set; }
Public Property ServiceStandard As String
    Get
    Set
public:
property String^ ServiceStandard {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► WeightQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Zone Property

Zone Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CD3 ► Zone
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Zone { get; set; }
Public Property Zone As String
    Get
    Set
public:
property String^ Zone {
    String^ get ();
    void set (String^ value);
}


CDA Class

CDA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA
RDPCrystal EDI Library
Consumer Credit Account
Declaration Syntax
C# Visual Basic Visual C++
public class CDA : DocumentSegment
Public Class CDA _
    Inherits DocumentSegment
public ref class CDA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CDA()()()() | Initializes a new instance of the CDA class
 | AccountNumber | Element 1
 | DateTimePeriod | Element 11
 | DateTimePeriod1 | Element 12
 | DateTimePeriod2 | Element 13
 | DateTimePeriod3 | Element 14
 | DateTimePeriod4 | Element 15
 | DateTimePeriodFormatQualifier | Element 10
 | Description | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 19
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanTypeCode | Element 18
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 4
 | MonetaryAmount3 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 8
 | Quantity1 | Element 9
 | ReferenceIdentification | Element 17
 | ReferenceIdentification1 | Element 20
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 6
 | TypeOfCreditAccountCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CDA


CDA Constructor

CDA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► CDA()()()()
RDPCrystal EDI Library
Initializes a new instance of the CDA class
Declaration Syntax
C# Visual Basic Visual C++
public CDA()
Public Sub New
public:
CDA()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► AccountNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► DateTimePeriod
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► DateTimePeriod1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► DateTimePeriod2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod3 Property

DateTimePeriod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► DateTimePeriod3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod3 { get; set; }
Public Property DateTimePeriod3 As String
    Get
    Set
public:
property String^ DateTimePeriod3 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod4 Property

DateTimePeriod4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► DateTimePeriod4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod4 { get; set; }
Public Property DateTimePeriod4 As String
    Get
    Set
public:
property String^ DateTimePeriod4 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► Description
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► FrequencyCode
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► LoanTypeCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► MonetaryAmount2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► MonetaryAmount3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► Quantity1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► ReferenceIdentification
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► TypeOfAccountCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


TypeOfCreditAccountCode Property

TypeOfCreditAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► TypeOfCreditAccountCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfCreditAccountCode { get; set; }
Public Property TypeOfCreditAccountCode As String
    Get
    Set
public:
property String^ TypeOfCreditAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CDD Class

CDD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD
RDPCrystal EDI Library
Credit/Debit Adjustment Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CDD : DocumentSegment
Public Class CDD _
    Inherits DocumentSegment
public ref class CDD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CDD()()()() | Initializes a new instance of the CDD class
 | AdjustmentReasonCode | Element 1
 | Amount | Element 4
 | AssignedIdentification | Element 3
 | CreditDebitFlagCode | Element 2
 | CreditDebitQuantity | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceBracketIdentifier | Element 6
 | PriceIdentifierCode | Element 10
 | PriceIdentifierCode1 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 8
 | UnitPrice | Element 11
 | UnitPrice1 | Element 13
 | UnitPriceDifference | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CDD


CDD Constructor

CDD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► CDD()()()()
RDPCrystal EDI Library
Initializes a new instance of the CDD class
Declaration Syntax
C# Visual Basic Visual C++
public CDD()
Public Sub New
public:
CDD()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► AdjustmentReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► AssignedIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitQuantity Property

CreditDebitQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► CreditDebitQuantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitQuantity { get; set; }
Public Property CreditDebitQuantity As String
    Get
    Set
public:
property String^ CreditDebitQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► PriceIdentifierCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode1 Property

PriceIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► PriceIdentifierCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode1 { get; set; }
Public Property PriceIdentifierCode1 As String
    Get
    Set
public:
property String^ PriceIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► UnitPrice
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


UnitPrice1 Property

UnitPrice1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► UnitPrice1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice1 { get; set; }
Public Property UnitPrice1 As String
    Get
    Set
public:
property String^ UnitPrice1 {
    String^ get ();
    void set (String^ value);
}


UnitPriceDifference Property

UnitPriceDifference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► UnitPriceDifference
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPriceDifference { get; set; }
Public Property UnitPriceDifference As String
    Get
    Set
public:
property String^ UnitPriceDifference {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDD ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CDI Class

CDI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI
RDPCrystal EDI Library
Change Detail Information
Declaration Syntax
C# Visual Basic Visual C++
public class CDI : DocumentSegment
Public Class CDI _
    Inherits DocumentSegment
public ref class CDI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CDI()()()() | Initializes a new instance of the CDI class
 | ConditionsIndicated | Element 2
 | ConvertibilityRateTypeCode | Element 3
 | Description | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndexIdentityCode | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 7
 | Number1 | Element 8
 | OptionTypeCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrimarySourceOfIndexCode | Element 10
 | Quantity | Element 6
 | RateValueQualifier | Element 5
 | StatusReasonCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CDI


CDI Constructor

CDI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► CDI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CDI class
Declaration Syntax
C# Visual Basic Visual C++
public CDI()
Public Sub New
public:
CDI()


ConditionsIndicated Property

ConditionsIndicated Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► ConditionsIndicated
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public ConditionsIndicated ConditionsIndicated { get; set; }
Public Property ConditionsIndicated As ConditionsIndicated
    Get
    Set
public:
property ConditionsIndicated^ ConditionsIndicated {
    ConditionsIndicated^ get ();
    void set (ConditionsIndicated^ value);
}


ConvertibilityRateTypeCode Property

ConvertibilityRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► ConvertibilityRateTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ConvertibilityRateTypeCode { get; set; }
Public Property ConvertibilityRateTypeCode As String
    Get
    Set
public:
property String^ ConvertibilityRateTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► Description
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IndexIdentityCode Property

IndexIdentityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► IndexIdentityCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IndexIdentityCode { get; set; }
Public Property IndexIdentityCode As String
    Get
    Set
public:
property String^ IndexIdentityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► Number
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► Number1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


OptionTypeCode Property

OptionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► OptionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OptionTypeCode { get; set; }
Public Property OptionTypeCode As String
    Get
    Set
public:
property String^ OptionTypeCode {
    String^ get ();
    void set (String^ value);
}


PrimarySourceOfIndexCode Property

PrimarySourceOfIndexCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► PrimarySourceOfIndexCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PrimarySourceOfIndexCode { get; set; }
Public Property PrimarySourceOfIndexCode As String
    Get
    Set
public:
property String^ PrimarySourceOfIndexCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► RateValueQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► StatusReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CDS Class

CDS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS
RDPCrystal EDI Library
Case Description
Declaration Syntax
C# Visual Basic Visual C++
public class CDS : DocumentSegment
Public Class CDS _
    Inherits DocumentSegment
public ref class CDS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CDS()()()() | Initializes a new instance of the CDS class
 | AdministrationOfJusticeOrganizationTypeCode | Element 2
 | CaseTypeCode | Element 1
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 7
 | IdentificationCode1 | Element 9
 | IdentificationCode2 | Element 11
 | IdentificationCodeQualifier | Element 6
 | IdentificationCodeQualifier1 | Element 8
 | IdentificationCodeQualifier2 | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CDS


CDS Constructor

CDS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► CDS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CDS class
Declaration Syntax
C# Visual Basic Visual C++
public CDS()
Public Sub New
public:
CDS()


AdministrationOfJusticeOrganizationTypeCode Property

AdministrationOfJusticeOrganizationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► AdministrationOfJusticeOrganizationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AdministrationOfJusticeOrganizationTypeCode { get; set; }
Public Property AdministrationOfJusticeOrganizationTypeCode As String
    Get
    Set
public:
property String^ AdministrationOfJusticeOrganizationTypeCode {
    String^ get ();
    void set (String^ value);
}


CaseTypeCode Property

CaseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► CaseTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CaseTypeCode { get; set; }
Public Property CaseTypeCode As String
    Get
    Set
public:
property String^ CaseTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► IdentificationCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► IdentificationCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode2 Property

IdentificationCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► IdentificationCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode2 { get; set; }
Public Property IdentificationCode2 As String
    Get
    Set
public:
property String^ IdentificationCode2 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier2 Property

IdentificationCodeQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► IdentificationCodeQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier2 { get; set; }
Public Property IdentificationCodeQualifier2 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CDS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CED Class

CED Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED
RDPCrystal EDI Library
Administration of Justice Event Description
Declaration Syntax
C# Visual Basic Visual C++
public class CED : DocumentSegment
Public Class CED _
    Inherits DocumentSegment
public ref class CED : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CED()()()() | Initializes a new instance of the CED class
 | ActionCode | Element 2
 | AdministrationOfJusticeEventTypeCode | Element 1
 | CaseTypeCode | Element 4
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoticeTypeCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CED


CED Constructor

CED Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► CED()()()()
RDPCrystal EDI Library
Initializes a new instance of the CED class
Declaration Syntax
C# Visual Basic Visual C++
public CED()
Public Sub New
public:
CED()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AdministrationOfJusticeEventTypeCode Property

AdministrationOfJusticeEventTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► AdministrationOfJusticeEventTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AdministrationOfJusticeEventTypeCode { get; set; }
Public Property AdministrationOfJusticeEventTypeCode As String
    Get
    Set
public:
property String^ AdministrationOfJusticeEventTypeCode {
    String^ get ();
    void set (String^ value);
}


CaseTypeCode Property

CaseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► CaseTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CaseTypeCode { get; set; }
Public Property CaseTypeCode As String
    Get
    Set
public:
property String^ CaseTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NoticeTypeCode Property

NoticeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► NoticeTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NoticeTypeCode { get; set; }
Public Property NoticeTypeCode As String
    Get
    Set
public:
property String^ NoticeTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CED ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CertificateLookupInformation Class

CertificateLookupInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation
RDPCrystal EDI Library
C050
Declaration Syntax
C# Visual Basic Visual C++
public class CertificateLookupInformation : DocumentCompositeElement
Public Class CertificateLookupInformation _
    Inherits DocumentCompositeElement
public ref class CertificateLookupInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CertificateLookupInformation()()()() | Initializes a new instance of the CertificateLookupInformation class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterIDCode | Element 2
 | FilterIDCode1 | Element 6
 | FilterIDCode2 | Element 10
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | LookupValue | Element 4
 | LookupValue1 | Element 8
 | LookupValue2 | Element 12
 | LookupValueProtocolCode | Element 1
 | LookupValueProtocolCode1 | Element 5
 | LookupValueProtocolCode2 | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | VersionIdentifier | Element 3
 | VersionIdentifier1 | Element 7
 | VersionIdentifier2 | Element 11
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CertificateLookupInformation


CertificateLookupInformation Constructor

CertificateLookupInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► CertificateLookupInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the CertificateLookupInformation class
Declaration Syntax
C# Visual Basic Visual C++
public CertificateLookupInformation()
Public Sub New
public:
CertificateLookupInformation()


FilterIDCode Property

FilterIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► FilterIDCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode { get; set; }
Public Property FilterIDCode As String
    Get
    Set
public:
property String^ FilterIDCode {
    String^ get ();
    void set (String^ value);
}


FilterIDCode1 Property

FilterIDCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► FilterIDCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode1 { get; set; }
Public Property FilterIDCode1 As String
    Get
    Set
public:
property String^ FilterIDCode1 {
    String^ get ();
    void set (String^ value);
}


FilterIDCode2 Property

FilterIDCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► FilterIDCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode2 { get; set; }
Public Property FilterIDCode2 As String
    Get
    Set
public:
property String^ FilterIDCode2 {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


LookupValue Property

LookupValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► LookupValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LookupValue { get; set; }
Public Property LookupValue As String
    Get
    Set
public:
property String^ LookupValue {
    String^ get ();
    void set (String^ value);
}


LookupValue1 Property

LookupValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► LookupValue1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LookupValue1 { get; set; }
Public Property LookupValue1 As String
    Get
    Set
public:
property String^ LookupValue1 {
    String^ get ();
    void set (String^ value);
}


LookupValue2 Property

LookupValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► LookupValue2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LookupValue2 { get; set; }
Public Property LookupValue2 As String
    Get
    Set
public:
property String^ LookupValue2 {
    String^ get ();
    void set (String^ value);
}


LookupValueProtocolCode Property

LookupValueProtocolCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► LookupValueProtocolCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LookupValueProtocolCode { get; set; }
Public Property LookupValueProtocolCode As String
    Get
    Set
public:
property String^ LookupValueProtocolCode {
    String^ get ();
    void set (String^ value);
}


LookupValueProtocolCode1 Property

LookupValueProtocolCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► LookupValueProtocolCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LookupValueProtocolCode1 { get; set; }
Public Property LookupValueProtocolCode1 As String
    Get
    Set
public:
property String^ LookupValueProtocolCode1 {
    String^ get ();
    void set (String^ value);
}


LookupValueProtocolCode2 Property

LookupValueProtocolCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► LookupValueProtocolCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LookupValueProtocolCode2 { get; set; }
Public Property LookupValueProtocolCode2 As String
    Get
    Set
public:
property String^ LookupValueProtocolCode2 {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► VersionIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier1 Property

VersionIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► VersionIdentifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier1 { get; set; }
Public Property VersionIdentifier1 As String
    Get
    Set
public:
property String^ VersionIdentifier1 {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier2 Property

VersionIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CertificateLookupInformation ► VersionIdentifier2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier2 { get; set; }
Public Property VersionIdentifier2 As String
    Get
    Set
public:
property String^ VersionIdentifier2 {
    String^ get ();
    void set (String^ value);
}


CF1 Class

CF1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1
RDPCrystal EDI Library
Beginning Segment for Summary Freight Bill Manifest
Declaration Syntax
C# Visual Basic Visual C++
public class CF1 : DocumentSegment
Public Class CF1 _
    Inherits DocumentSegment
public ref class CF1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CF1()()()() | Initializes a new instance of the CF1 class
 | Amount | Element 5
 | Count | Element 4
 | Date | Element 3
 | Date1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MasterReferenceLinkNumber | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CF1


CF1 Constructor

CF1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► CF1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CF1 class
Declaration Syntax
C# Visual Basic Visual C++
public CF1()
Public Sub New
public:
CF1()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► Count
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MasterReferenceLinkNumber Property

MasterReferenceLinkNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► MasterReferenceLinkNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MasterReferenceLinkNumber { get; set; }
Public Property MasterReferenceLinkNumber As String
    Get
    Set
public:
property String^ MasterReferenceLinkNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CF2 Class

CF2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2
RDPCrystal EDI Library
Summary Freight Bill Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CF2 : DocumentSegment
Public Class CF2 _
    Inherits DocumentSegment
public ref class CF2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CF2()()()() | Initializes a new instance of the CF2 class
 | Date | Element 5
 | Date1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetAmountDue | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 3
 | ShipmentMethodOfPayment | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 10
 | Weight | Element 9
 | WeightQualifier | Element 7
 | WeightUnitCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CF2


CF2 Constructor

CF2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► CF2()()()()
RDPCrystal EDI Library
Initializes a new instance of the CF2 class
Declaration Syntax
C# Visual Basic Visual C++
public CF2()
Public Sub New
public:
CF2()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► InvoiceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetAmountDue Property

NetAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► NetAmountDue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NetAmountDue { get; set; }
Public Property NetAmountDue As String
    Get
    Set
public:
property String^ NetAmountDue {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► TransactionTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► Weight
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► WeightQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► WeightUnitCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CF2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CFT Class

CFT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT
RDPCrystal EDI Library
Cost Reporting Format Type
Declaration Syntax
C# Visual Basic Visual C++
public class CFT : DocumentSegment
Public Class CFT _
    Inherits DocumentSegment
public ref class CFT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CFT()()()() | Initializes a new instance of the CFT class
 | AppropriationCode | Element 8
 | CompositeUnitOfMeasure | Element 2
 | ContractingFundingCode | Element 3
 | Date | Element 5
 | Date1 | Element 7
 | DateTimeQualifier | Element 4
 | DateTimeQualifier1 | Element 6a
 | Description | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CFT


CFT Constructor

CFT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► CFT()()()()
RDPCrystal EDI Library
Initializes a new instance of the CFT class
Declaration Syntax
C# Visual Basic Visual C++
public CFT()
Public Sub New
public:
CFT()


AppropriationCode Property

AppropriationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► AppropriationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AppropriationCode { get; set; }
Public Property AppropriationCode As String
    Get
    Set
public:
property String^ AppropriationCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ContractingFundingCode Property

ContractingFundingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► ContractingFundingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ContractingFundingCode { get; set; }
Public Property ContractingFundingCode As String
    Get
    Set
public:
property String^ ContractingFundingCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► DateTimeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier1 Property

DateTimeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► DateTimeQualifier1
RDPCrystal EDI Library
Element 6a
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier1 { get; set; }
Public Property DateTimeQualifier1 As String
    Get
    Set
public:
property String^ DateTimeQualifier1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CFT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CGS Class

CGS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS
RDPCrystal EDI Library
Charge
Declaration Syntax
C# Visual Basic Visual C++
public class CGS : DocumentSegment
Public Class CGS _
    Inherits DocumentSegment
public ref class CGS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CGS()()()() | Initializes a new instance of the CGS class
 | Charge | Element 1
 | CurrencyCode | Element 2
 | Date | Element 4
 | DateTimeQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialChargeOrAllowanceCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CGS


CGS Constructor

CGS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► CGS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CGS class
Declaration Syntax
C# Visual Basic Visual C++
public CGS()
Public Sub New
public:
CGS()


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► Charge
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► CurrencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CGS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CHB Class

CHB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB
RDPCrystal EDI Library
Chargeback Information
Declaration Syntax
C# Visual Basic Visual C++
public class CHB : DocumentSegment
Public Class CHB _
    Inherits DocumentSegment
public ref class CHB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CHB()()()() | Initializes a new instance of the CHB class
 | AllowanceOrChargeIndicator | Element 9
 | ClaimStatusCode | Element 5
 | ClaimTypeCode | Element 4
 | CreditDebitFlagCode | Element 7
 | EntityIdentifierCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 2
 | LocationQualifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReasonStoppedWorkCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CHB


CHB Constructor

CHB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► CHB()()()()
RDPCrystal EDI Library
Initializes a new instance of the CHB class
Declaration Syntax
C# Visual Basic Visual C++
public CHB()
Public Sub New
public:
CHB()


AllowanceOrChargeIndicator Property

AllowanceOrChargeIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► AllowanceOrChargeIndicator
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeIndicator { get; set; }
Public Property AllowanceOrChargeIndicator As String
    Get
    Set
public:
property String^ AllowanceOrChargeIndicator {
    String^ get ();
    void set (String^ value);
}


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► ClaimStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}


ClaimTypeCode Property

ClaimTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► ClaimTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimTypeCode { get; set; }
Public Property ClaimTypeCode As String
    Get
    Set
public:
property String^ ClaimTypeCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► EntityIdentifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► IndustryCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► LocationIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► LocationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


ReasonStoppedWorkCode Property

ReasonStoppedWorkCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► ReasonStoppedWorkCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReasonStoppedWorkCode { get; set; }
Public Property ReasonStoppedWorkCode As String
    Get
    Set
public:
property String^ ReasonStoppedWorkCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CHR Class

CHR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR
RDPCrystal EDI Library
Car Hire Rates
Declaration Syntax
C# Visual Basic Visual C++
public class CHR : DocumentSegment
Public Class CHR _
    Inherits DocumentSegment
public ref class CHR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CHR()()()() | Initializes a new instance of the CHR class
 | BilledRatedAsQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateSource | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CHR


CHR Constructor

CHR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR ► CHR()()()()
RDPCrystal EDI Library
Initializes a new instance of the CHR class
Declaration Syntax
C# Visual Basic Visual C++
public CHR()
Public Sub New
public:
CHR()


BilledRatedAsQualifier Property

BilledRatedAsQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR ► BilledRatedAsQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedAsQualifier { get; set; }
Public Property BilledRatedAsQualifier As String
    Get
    Set
public:
property String^ BilledRatedAsQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR ► Multiplier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


RateSource Property

RateSource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR ► RateSource
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateSource { get; set; }
Public Property RateSource As String
    Get
    Set
public:
property String^ RateSource {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CHR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CI Class

CI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI
RDPCrystal EDI Library
Carrier Interchange Agreement
Declaration Syntax
C# Visual Basic Visual C++
public class CI : DocumentSegment
Public Class CI _
    Inherits DocumentSegment
public ref class CI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CI()()()() | Initializes a new instance of the CI class
 | Date | Element 9
 | Date1 | Element 11
 | DateTimeQualifier | Element 8
 | DateTimeQualifier1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCode1 | Element 6
 | IdentificationCodeQualifier | Element 3
 | IdentificationCodeQualifier1 | Element 5
 | InterchangeAgreementStatusCode | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | Name2 | Element 12
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 14
 | ReferenceIdentificationQualifier | Element 13
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CI


CI Constructor

CI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► CI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CI class
Declaration Syntax
C# Visual Basic Visual C++
public CI()
Public Sub New
public:
CI()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► Date
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► Date1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► DateTimeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier1 Property

DateTimeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► DateTimeQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier1 { get; set; }
Public Property DateTimeQualifier1 As String
    Get
    Set
public:
property String^ DateTimeQualifier1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► IdentificationCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


InterchangeAgreementStatusCode Property

InterchangeAgreementStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► InterchangeAgreementStatusCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeAgreementStatusCode { get; set; }
Public Property InterchangeAgreementStatusCode As String
    Get
    Set
public:
property String^ InterchangeAgreementStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► Name2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► ReferenceIdentification
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CIC Class

CIC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC
RDPCrystal EDI Library
Car Information Control
Declaration Syntax
C# Visual Basic Visual C++
public class CIC : DocumentSegment
Public Class CIC _
    Inherits DocumentSegment
public ref class CIC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CIC()()()() | Initializes a new instance of the CIC class
 | CarTypeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | EquipmentNumber1 | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MechanicalCarCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CIC


CIC Constructor

CIC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► CIC()()()()
RDPCrystal EDI Library
Initializes a new instance of the CIC class
Declaration Syntax
C# Visual Basic Visual C++
public CIC()
Public Sub New
public:
CIC()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► CarTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber1 Property

EquipmentNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► EquipmentNumber1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber1 { get; set; }
Public Property EquipmentNumber1 As String
    Get
    Set
public:
property String^ EquipmentNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MechanicalCarCode Property

MechanicalCarCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► MechanicalCarCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MechanicalCarCode { get; set; }
Public Property MechanicalCarCode As String
    Get
    Set
public:
property String^ MechanicalCarCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CID Class

CID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID
RDPCrystal EDI Library
Characteristic/Class ID
Declaration Syntax
C# Visual Basic Visual C++
public class CID : DocumentSegment
Public Class CID _
    Inherits DocumentSegment
public ref class CID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CID()()()() | Initializes a new instance of the CID class
 | AgencyQualifierCode | Element 3
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementQualifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 4
 | ProductProcessCharacteristicCode | Element 2
 | SourceSubqualifier | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CID


CID Constructor

CID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► CID()()()()
RDPCrystal EDI Library
Initializes a new instance of the CID class
Declaration Syntax
C# Visual Basic Visual C++
public CID()
Public Sub New
public:
CID()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementQualifier Property

MeasurementQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► MeasurementQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementQualifier { get; set; }
Public Property MeasurementQualifier As String
    Get
    Set
public:
property String^ MeasurementQualifier {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► ProductDescriptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► SourceSubqualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CID ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CIV Class

CIV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV
RDPCrystal EDI Library
Civil Action Liability
Declaration Syntax
C# Visual Basic Visual C++
public class CIV : DocumentSegment
Public Class CIV _
    Inherits DocumentSegment
public ref class CIV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CIV()()()() | Initializes a new instance of the CIV class
 | AmountQualifierCode | Element 2
 | CityName | Element 9
 | CountyDesignator | Element 10
 | DateTimePeriod | Element 13
 | DateTimePeriod1 | Element 16
 | DateTimePeriodFormatQualifier | Element 12
 | DateTimePeriodFormatQualifier1 | Element 15
 | DateTimeQualifier | Element 14
 | Description | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 5
 | Name2 | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PublicRecordOrObligationCode | Element 1
 | RateValueQualifier | Element 4
 | ReferenceIdentification | Element 8
 | ReferenceIdentification1 | Element 18
 | ReferenceIdentificationQualifier | Element 7
 | StateOrProvinceCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CIV


CIV Constructor

CIV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► CIV()()()()
RDPCrystal EDI Library
Initializes a new instance of the CIV class
Declaration Syntax
C# Visual Basic Visual C++
public CIV()
Public Sub New
public:
CIV()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► CityName
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountyDesignator Property

CountyDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► CountyDesignator
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CountyDesignator { get; set; }
Public Property CountyDesignator As String
    Get
    Set
public:
property String^ CountyDesignator {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► DateTimePeriod
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► DateTimePeriod1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► DateTimeQualifier
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► Description
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► Name1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► Name2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


PublicRecordOrObligationCode Property

PublicRecordOrObligationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► PublicRecordOrObligationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PublicRecordOrObligationCode { get; set; }
Public Property PublicRecordOrObligationCode As String
    Get
    Set
public:
property String^ PublicRecordOrObligationCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► RateValueQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► ReferenceIdentification1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► StateOrProvinceCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CIV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CL Class

CL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL
RDPCrystal EDI Library
Class
Declaration Syntax
C# Visual Basic Visual C++
public class CL : DocumentSegment
Public Class CL _
    Inherits DocumentSegment
public ref class CL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CL()()()() | Initializes a new instance of the CL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightClassCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CL


CL Constructor

CL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL ► CL()()()()
RDPCrystal EDI Library
Initializes a new instance of the CL class
Declaration Syntax
C# Visual Basic Visual C++
public CL()
Public Sub New
public:
CL()


FreightClassCode Property

FreightClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL ► FreightClassCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreightClassCode { get; set; }
Public Property FreightClassCode As String
    Get
    Set
public:
property String^ FreightClassCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CL1 Class

CL1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1
RDPCrystal EDI Library
Claim Codes
Declaration Syntax
C# Visual Basic Visual C++
public class CL1 : DocumentSegment
Public Class CL1 _
    Inherits DocumentSegment
public ref class CL1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CL1()()()() | Initializes a new instance of the CL1 class
 | AdmissionSourceCode | Element 2
 | AdmissionTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NursingHomeResidentialStatuCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientStatusCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CL1


CL1 Constructor

CL1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► CL1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CL1 class
Declaration Syntax
C# Visual Basic Visual C++
public CL1()
Public Sub New
public:
CL1()


AdmissionSourceCode Property

AdmissionSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► AdmissionSourceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AdmissionSourceCode { get; set; }
Public Property AdmissionSourceCode As String
    Get
    Set
public:
property String^ AdmissionSourceCode {
    String^ get ();
    void set (String^ value);
}


AdmissionTypeCode Property

AdmissionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► AdmissionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AdmissionTypeCode { get; set; }
Public Property AdmissionTypeCode As String
    Get
    Set
public:
property String^ AdmissionTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NursingHomeResidentialStatuCode Property

NursingHomeResidentialStatuCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► NursingHomeResidentialStatuCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NursingHomeResidentialStatuCode { get; set; }
Public Property NursingHomeResidentialStatuCode As String
    Get
    Set
public:
property String^ NursingHomeResidentialStatuCode {
    String^ get ();
    void set (String^ value);
}


PatientStatusCode Property

PatientStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► PatientStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PatientStatusCode { get; set; }
Public Property PatientStatusCode As String
    Get
    Set
public:
property String^ PatientStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CL1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CLD Class

CLD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD
RDPCrystal EDI Library
Load Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CLD : DocumentSegment
Public Class CLD _
    Inherits DocumentSegment
public ref class CLD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLD()()()() | Initializes a new instance of the CLD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfLoads | Element 1
 | NumberOfUnitsShipped | Element 2
 | PackagingCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Size | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLD


CLD Constructor

CLD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► CLD()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLD class
Declaration Syntax
C# Visual Basic Visual C++
public CLD()
Public Sub New
public:
CLD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfLoads Property

NumberOfLoads Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► NumberOfLoads
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfLoads { get; set; }
Public Property NumberOfLoads As String
    Get
    Set
public:
property String^ NumberOfLoads {
    String^ get ();
    void set (String^ value);
}


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► PackagingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► Size
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CLI Class

CLI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI
RDPCrystal EDI Library
Cost Line Item
Declaration Syntax
C# Visual Basic Visual C++
public class CLI : DocumentSegment
Public Class CLI _
    Inherits DocumentSegment
public ref class CLI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLI()()()() | Initializes a new instance of the CLI class
 | AssignedIdentification | Element 3
 | BreakdownStructureDetailCode | Element 2
 | ContractTypeCode | Element 6
 | EntityIdentifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateOrValueTypeCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLI


CLI Constructor

CLI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► CLI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLI class
Declaration Syntax
C# Visual Basic Visual C++
public CLI()
Public Sub New
public:
CLI()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► AssignedIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


BreakdownStructureDetailCode Property

BreakdownStructureDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► BreakdownStructureDetailCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BreakdownStructureDetailCode { get; set; }
Public Property BreakdownStructureDetailCode As String
    Get
    Set
public:
property String^ BreakdownStructureDetailCode {
    String^ get ();
    void set (String^ value);
}


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► ContractTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► FreeformDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateOrValueTypeCode Property

RateOrValueTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► RateOrValueTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateOrValueTypeCode { get; set; }
Public Property RateOrValueTypeCode As String
    Get
    Set
public:
property String^ RateOrValueTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CLM Class

CLM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM
RDPCrystal EDI Library
Health Claim
Declaration Syntax
C# Visual Basic Visual C++
public class CLM : DocumentSegment
Public Class CLM _
    Inherits DocumentSegment
public ref class CLM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLM()()()() | Initializes a new instance of the CLM class
 | AssignmentOrPlanParticipationCode | Element 7
 | ClaimFilingIndicatorCode | Element 3
 | ClaimStatusCode | Element 17
 | ClaimStatusReasonCode | Element 19
 | ClaimSubmitterIdentifier | Element 1
 | DelayReasonCode | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareServiceLocation | Element 5
 | LevelOfServiceCode | Element 14
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonInstitutionalClaimTypeCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientSignatureSourceCode | Element 10
 | ProviderAgreementCode | Element 16
 | RelatedCausesInformation | Element 11
 | ReleaseOfInformationCode | Element 9
 | SpecialProgramCode | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 6
 | YesNoConditionOrResponseCode2 | Element 8
 | YesNoConditionOrResponseCode3 | Element 13
 | YesNoConditionOrResponseCode4 | Element 15
 | YesNoConditionOrResponseCode5 | Element 18
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLM


CLM Constructor

CLM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► CLM()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLM class
Declaration Syntax
C# Visual Basic Visual C++
public CLM()
Public Sub New
public:
CLM()


AssignmentOrPlanParticipationCode Property

AssignmentOrPlanParticipationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► AssignmentOrPlanParticipationCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssignmentOrPlanParticipationCode { get; set; }
Public Property AssignmentOrPlanParticipationCode As String
    Get
    Set
public:
property String^ AssignmentOrPlanParticipationCode {
    String^ get ();
    void set (String^ value);
}


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► ClaimStatusCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}


ClaimStatusReasonCode Property

ClaimStatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► ClaimStatusReasonCode
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusReasonCode { get; set; }
Public Property ClaimStatusReasonCode As String
    Get
    Set
public:
property String^ ClaimStatusReasonCode {
    String^ get ();
    void set (String^ value);
}


ClaimSubmitterIdentifier Property

ClaimSubmitterIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► ClaimSubmitterIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmitterIdentifier { get; set; }
Public Property ClaimSubmitterIdentifier As String
    Get
    Set
public:
property String^ ClaimSubmitterIdentifier {
    String^ get ();
    void set (String^ value);
}


DelayReasonCode Property

DelayReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► DelayReasonCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string DelayReasonCode { get; set; }
Public Property DelayReasonCode As String
    Get
    Set
public:
property String^ DelayReasonCode {
    String^ get ();
    void set (String^ value);
}


HealthCareServiceLocation Property

HealthCareServiceLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► HealthCareServiceLocation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocationInformation HealthCareServiceLocation { get; set; }
Public Property HealthCareServiceLocation As HealthCareServiceLocationInformation
    Get
    Set
public:
property HealthCareServiceLocationInformation^ HealthCareServiceLocation {
    HealthCareServiceLocationInformation^ get ();
    void set (HealthCareServiceLocationInformation^ value);
}


LevelOfServiceCode Property

LevelOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► LevelOfServiceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfServiceCode { get; set; }
Public Property LevelOfServiceCode As String
    Get
    Set
public:
property String^ LevelOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


NonInstitutionalClaimTypeCode Property

NonInstitutionalClaimTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► NonInstitutionalClaimTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NonInstitutionalClaimTypeCode { get; set; }
Public Property NonInstitutionalClaimTypeCode As String
    Get
    Set
public:
property String^ NonInstitutionalClaimTypeCode {
    String^ get ();
    void set (String^ value);
}


PatientSignatureSourceCode Property

PatientSignatureSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► PatientSignatureSourceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PatientSignatureSourceCode { get; set; }
Public Property PatientSignatureSourceCode As String
    Get
    Set
public:
property String^ PatientSignatureSourceCode {
    String^ get ();
    void set (String^ value);
}


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► ProviderAgreementCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}


RelatedCausesInformation Property

RelatedCausesInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► RelatedCausesInformation
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation RelatedCausesInformation { get; set; }
Public Property RelatedCausesInformation As RelatedCausesInformation
    Get
    Set
public:
property RelatedCausesInformation^ RelatedCausesInformation {
    RelatedCausesInformation^ get ();
    void set (RelatedCausesInformation^ value);
}


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► ReleaseOfInformationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}


SpecialProgramCode Property

SpecialProgramCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► SpecialProgramCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialProgramCode { get; set; }
Public Property SpecialProgramCode As String
    Get
    Set
public:
property String^ SpecialProgramCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► YesNoConditionOrResponseCode4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode5 Property

YesNoConditionOrResponseCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLM ► YesNoConditionOrResponseCode5
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode5 { get; set; }
Public Property YesNoConditionOrResponseCode5 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode5 {
    String^ get ();
    void set (String^ value);
}


CLP Class

CLP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP
RDPCrystal EDI Library
Claim Level Data
Declaration Syntax
C# Visual Basic Visual C++
public class CLP : DocumentSegment
Public Class CLP _
    Inherits DocumentSegment
public ref class CLP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLP()()()() | Initializes a new instance of the CLP class
 | ClaimFilingIndicatorCode | Element 6
 | ClaimFrequencyTypeCode | Element 9
 | ClaimStatusCode | Element 2
 | ClaimSubmitterIdentifier | Element 1
 | DiagnosisRelatedGroupDRGCode | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 8
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientStatusCode | Element 10
 | Percent | Element 13
 | Quantity | Element 12
 | ReferenceIdentification | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLP


CLP Constructor

CLP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► CLP()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLP class
Declaration Syntax
C# Visual Basic Visual C++
public CLP()
Public Sub New
public:
CLP()


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}


ClaimFrequencyTypeCode Property

ClaimFrequencyTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► ClaimFrequencyTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFrequencyTypeCode { get; set; }
Public Property ClaimFrequencyTypeCode As String
    Get
    Set
public:
property String^ ClaimFrequencyTypeCode {
    String^ get ();
    void set (String^ value);
}


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► ClaimStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}


ClaimSubmitterIdentifier Property

ClaimSubmitterIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► ClaimSubmitterIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmitterIdentifier { get; set; }
Public Property ClaimSubmitterIdentifier As String
    Get
    Set
public:
property String^ ClaimSubmitterIdentifier {
    String^ get ();
    void set (String^ value);
}


DiagnosisRelatedGroupDRGCode Property

DiagnosisRelatedGroupDRGCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► DiagnosisRelatedGroupDRGCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisRelatedGroupDRGCode { get; set; }
Public Property DiagnosisRelatedGroupDRGCode As String
    Get
    Set
public:
property String^ DiagnosisRelatedGroupDRGCode {
    String^ get ();
    void set (String^ value);
}


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► FacilityCodeValue
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


PatientStatusCode Property

PatientStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► PatientStatusCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PatientStatusCode { get; set; }
Public Property PatientStatusCode As String
    Get
    Set
public:
property String^ PatientStatusCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► Percent
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► Quantity
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CLR Class

CLR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR
RDPCrystal EDI Library
Car Location Routing Request
Declaration Syntax
C# Visual Basic Visual C++
public class CLR : DocumentSegment
Public Class CLR _
    Inherits DocumentSegment
public ref class CLR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLR()()()() | Initializes a new instance of the CLR class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | IndustryCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLR


CLR Constructor

CLR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► CLR()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLR class
Declaration Syntax
C# Visual Basic Visual C++
public CLR()
Public Sub New
public:
CLR()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► IndustryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CLR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CM Class

CM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM
RDPCrystal EDI Library
Cargo Manifest
Declaration Syntax
C# Visual Basic Visual C++
public class CM : DocumentSegment
Public Class CM _
    Inherits DocumentSegment
public ref class CM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CM()()()() | Initializes a new instance of the CM class
 | BookingNumber | Element 5
 | CorrectionIndicator | Element 16
 | CountryCode | Element 14
 | Date | Element 4
 | Date1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PierName | Element 11
 | PierNumber | Element 10
 | PortName | Element 3
 | PortOrTerminalFunctionCode | Element 2
 | ReferenceIdentification | Element 15
 | StandardCarrierAlphaCode | Element 6
 | StandardCarrierAlphaCode1 | Element 7
 | StateOrProvinceCode | Element 13
 | TerminalName | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 17
 | VesselName | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CM


CM Constructor

CM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► CM()()()()
RDPCrystal EDI Library
Initializes a new instance of the CM class
Declaration Syntax
C# Visual Basic Visual C++
public CM()
Public Sub New
public:
CM()


BookingNumber Property

BookingNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► BookingNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BookingNumber { get; set; }
Public Property BookingNumber As String
    Get
    Set
public:
property String^ BookingNumber {
    String^ get ();
    void set (String^ value);
}


CorrectionIndicator Property

CorrectionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► CorrectionIndicator
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string CorrectionIndicator { get; set; }
Public Property CorrectionIndicator As String
    Get
    Set
public:
property String^ CorrectionIndicator {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► CountryCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► FlightVoyageNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PierName Property

PierName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► PierName
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PierName { get; set; }
Public Property PierName As String
    Get
    Set
public:
property String^ PierName {
    String^ get ();
    void set (String^ value);
}


PierNumber Property

PierNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► PierNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PierNumber { get; set; }
Public Property PierNumber As String
    Get
    Set
public:
property String^ PierNumber {
    String^ get ();
    void set (String^ value);
}


PortName Property

PortName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► PortName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PortName { get; set; }
Public Property PortName As String
    Get
    Set
public:
property String^ PortName {
    String^ get ();
    void set (String^ value);
}


PortOrTerminalFunctionCode Property

PortOrTerminalFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► PortOrTerminalFunctionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PortOrTerminalFunctionCode { get; set; }
Public Property PortOrTerminalFunctionCode As String
    Get
    Set
public:
property String^ PortOrTerminalFunctionCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► ReferenceIdentification
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► StateOrProvinceCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TerminalName Property

TerminalName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► TerminalName
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TerminalName { get; set; }
Public Property TerminalName As String
    Get
    Set
public:
property String^ TerminalName {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► VesselName
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CMA Class

CMA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA
RDPCrystal EDI Library
Cooperative Market Agreement
Declaration Syntax
C# Visual Basic Visual C++
public class CMA : DocumentSegment
Public Class CMA _
    Inherits DocumentSegment
public ref class CMA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CMA()()()() | Initializes a new instance of the CMA class
 | ContractNumber | Element 10
 | CurrencyCode | Element 8
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarketAreaCodeIdentifier | Element 7
 | MarketAreaCodeQualifier | Element 6
 | MarketProfile | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 11
 | TransactionTypeCode | Element 1
 | Week | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CMA


CMA Constructor

CMA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► CMA()()()()
RDPCrystal EDI Library
Initializes a new instance of the CMA class
Declaration Syntax
C# Visual Basic Visual C++
public CMA()
Public Sub New
public:
CMA()


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► ContractNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► CurrencyCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarketAreaCodeIdentifier Property

MarketAreaCodeIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► MarketAreaCodeIdentifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MarketAreaCodeIdentifier { get; set; }
Public Property MarketAreaCodeIdentifier As String
    Get
    Set
public:
property String^ MarketAreaCodeIdentifier {
    String^ get ();
    void set (String^ value);
}


MarketAreaCodeQualifier Property

MarketAreaCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► MarketAreaCodeQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MarketAreaCodeQualifier { get; set; }
Public Property MarketAreaCodeQualifier As String
    Get
    Set
public:
property String^ MarketAreaCodeQualifier {
    String^ get ();
    void set (String^ value);
}


MarketProfile Property

MarketProfile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► MarketProfile
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MarketProfile { get; set; }
Public Property MarketProfile As String
    Get
    Set
public:
property String^ MarketProfile {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► TransactionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Week Property

Week Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► Week
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Week { get; set; }
Public Property Week As String
    Get
    Set
public:
property String^ Week {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CMA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CN1 Class

CN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1
RDPCrystal EDI Library
Contract Information
Declaration Syntax
C# Visual Basic Visual C++
public class CN1 : DocumentSegment
Public Class CN1 _
    Inherits DocumentSegment
public ref class CN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CN1()()()() | Initializes a new instance of the CN1 class
 | ContractTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | ReferenceIdentification | Element 4
 | TermsDiscountPercent | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CN1


CN1 Constructor

CN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► CN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CN1 class
Declaration Syntax
C# Visual Basic Visual C++
public CN1()
Public Sub New
public:
CN1()


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► ContractTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TermsDiscountPercent Property

TermsDiscountPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► TermsDiscountPercent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent { get; set; }
Public Property TermsDiscountPercent As String
    Get
    Set
public:
property String^ TermsDiscountPercent {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► VersionIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


COB Class

COB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB
RDPCrystal EDI Library
Coordination of Benefits
Declaration Syntax
C# Visual Basic Visual C++
public class COB : DocumentSegment
Public Class COB _
    Inherits DocumentSegment
public ref class COB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | COB()()()() | Initializes a new instance of the COB class
 | CoordinationOfBenefitsCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode | Element 1
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | COB


COB Constructor

COB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB ► COB()()()()
RDPCrystal EDI Library
Initializes a new instance of the COB class
Declaration Syntax
C# Visual Basic Visual C++
public COB()
Public Sub New
public:
COB()


CoordinationOfBenefitsCode Property

CoordinationOfBenefitsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB ► CoordinationOfBenefitsCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CoordinationOfBenefitsCode { get; set; }
Public Property CoordinationOfBenefitsCode As String
    Get
    Set
public:
property String^ CoordinationOfBenefitsCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB ► PayerResponsibilitySequenceNumberCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


COM Class

COM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COM
RDPCrystal EDI Library
Communication Contact Information
Declaration Syntax
C# Visual Basic Visual C++
public class COM : DocumentSegment
Public Class COM _
    Inherits DocumentSegment
public ref class COM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | COM()()()() | Initializes a new instance of the COM class
 | CommunicationNumber | Element 2
 | CommunicationNumberQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | COM


COM Constructor

COM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COM ► COM()()()()
RDPCrystal EDI Library
Initializes a new instance of the COM class
Declaration Syntax
C# Visual Basic Visual C++
public COM()
Public Sub New
public:
COM()


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COM ► CommunicationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier Property

CommunicationNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COM ► CommunicationNumberQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier { get; set; }
Public Property CommunicationNumberQualifier As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► COM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CompositeDiagnosisCodePointer Class

CompositeDiagnosisCodePointer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer
RDPCrystal EDI Library
C004
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeDiagnosisCodePointer : DocumentCompositeElement
Public Class CompositeDiagnosisCodePointer _
    Inherits DocumentCompositeElement
public ref class CompositeDiagnosisCodePointer : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeDiagnosisCodePointer()()()() | Initializes a new instance of the CompositeDiagnosisCodePointer class
 | DiagnosisCodePointer | Element 1
 | DiagnosisCodePointer1 | Element 2
 | DiagnosisCodePointer2 | Element 3
 | DiagnosisCodePointer3 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeDiagnosisCodePointer


CompositeDiagnosisCodePointer Constructor

CompositeDiagnosisCodePointer Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► CompositeDiagnosisCodePointer()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeDiagnosisCodePointer class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosisCodePointer()
Public Sub New
public:
CompositeDiagnosisCodePointer()


DiagnosisCodePointer Property

DiagnosisCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► DiagnosisCodePointer
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer { get; set; }
Public Property DiagnosisCodePointer As String
    Get
    Set
public:
property String^ DiagnosisCodePointer {
    String^ get ();
    void set (String^ value);
}


DiagnosisCodePointer1 Property

DiagnosisCodePointer1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► DiagnosisCodePointer1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer1 { get; set; }
Public Property DiagnosisCodePointer1 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer1 {
    String^ get ();
    void set (String^ value);
}


DiagnosisCodePointer2 Property

DiagnosisCodePointer2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► DiagnosisCodePointer2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer2 { get; set; }
Public Property DiagnosisCodePointer2 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer2 {
    String^ get ();
    void set (String^ value);
}


DiagnosisCodePointer3 Property

DiagnosisCodePointer3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► DiagnosisCodePointer3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer3 { get; set; }
Public Property DiagnosisCodePointer3 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer3 {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeDiagnosisCodePointer ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


CompositeMedicalProcedureIdentifier Class

CompositeMedicalProcedureIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
C003
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeMedicalProcedureIdentifier : DocumentCompositeElement
Public Class CompositeMedicalProcedureIdentifier _
    Inherits DocumentCompositeElement
public ref class CompositeMedicalProcedureIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeMedicalProcedureIdentifier()()()() | Initializes a new instance of the CompositeMedicalProcedureIdentifier class
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcedureModifier | Element 3
 | ProcedureModifier1 | Element 4
 | ProcedureModifier2 | Element 5
 | ProcedureModifier3 | Element 6
 | ProductServiceID | Element 2
 | ProductServiceID1 | Element 8
 | ProductServiceIDQualifier | Element 1
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeMedicalProcedureIdentifier


CompositeMedicalProcedureIdentifier Constructor

CompositeMedicalProcedureIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► CompositeMedicalProcedureIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeMedicalProcedureIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier()
Public Sub New
public:
CompositeMedicalProcedureIdentifier()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


ProcedureModifier Property

ProcedureModifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier { get; set; }
Public Property ProcedureModifier As String
    Get
    Set
public:
property String^ ProcedureModifier {
    String^ get ();
    void set (String^ value);
}


ProcedureModifier1 Property

ProcedureModifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier1 { get; set; }
Public Property ProcedureModifier1 As String
    Get
    Set
public:
property String^ ProcedureModifier1 {
    String^ get ();
    void set (String^ value);
}


ProcedureModifier2 Property

ProcedureModifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier2 { get; set; }
Public Property ProcedureModifier2 As String
    Get
    Set
public:
property String^ ProcedureModifier2 {
    String^ get ();
    void set (String^ value);
}


ProcedureModifier3 Property

ProcedureModifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier3 { get; set; }
Public Property ProcedureModifier3 As String
    Get
    Set
public:
property String^ ProcedureModifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProductServiceID1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeMedicalProcedureIdentifier ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


CompositeQualifierIdentifier Class

CompositeQualifierIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier
RDPCrystal EDI Library
C046
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeQualifierIdentifier : DocumentCompositeElement
Public Class CompositeQualifierIdentifier _
    Inherits DocumentCompositeElement
public ref class CompositeQualifierIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeQualifierIdentifier()()()() | Initializes a new instance of the CompositeQualifierIdentifier class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RateValueQualifier | Element 1
 | RateValueQualifier1 | Element 2
 | RateValueQualifier2 | Element 3
 | RateValueQualifier3 | Element 4
 | RateValueQualifier4 | Element 5
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeQualifierIdentifier


CompositeQualifierIdentifier Constructor

CompositeQualifierIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► CompositeQualifierIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeQualifierIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeQualifierIdentifier()
Public Sub New
public:
CompositeQualifierIdentifier()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► RateValueQualifier1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier2 Property

RateValueQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► RateValueQualifier2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier2 { get; set; }
Public Property RateValueQualifier2 As String
    Get
    Set
public:
property String^ RateValueQualifier2 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier3 Property

RateValueQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► RateValueQualifier3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier3 { get; set; }
Public Property RateValueQualifier3 As String
    Get
    Set
public:
property String^ RateValueQualifier3 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier4 Property

RateValueQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeQualifierIdentifier ► RateValueQualifier4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier4 { get; set; }
Public Property RateValueQualifier4 As String
    Get
    Set
public:
property String^ RateValueQualifier4 {
    String^ get ();
    void set (String^ value);
}


CompositeTypeOfRealEstateAssetCode Class

CompositeTypeOfRealEstateAssetCode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode
RDPCrystal EDI Library
C047
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeTypeOfRealEstateAssetCode : DocumentCompositeElement
Public Class CompositeTypeOfRealEstateAssetCode _
    Inherits DocumentCompositeElement
public ref class CompositeTypeOfRealEstateAssetCode : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeTypeOfRealEstateAssetCode()()()() | Initializes a new instance of the CompositeTypeOfRealEstateAssetCode class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TypeOfRealEstateAssetCode | Element 1
 | TypeOfRealEstateAssetCode1 | Element 2
 | TypeOfRealEstateAssetCode2 | Element 3
 | TypeOfRealEstateAssetCode3 | Element 4
 | TypeOfRealEstateAssetCode4 | Element 5
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeTypeOfRealEstateAssetCode


CompositeTypeOfRealEstateAssetCode Constructor

CompositeTypeOfRealEstateAssetCode Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► CompositeTypeOfRealEstateAssetCode()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeTypeOfRealEstateAssetCode class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeTypeOfRealEstateAssetCode()
Public Sub New
public:
CompositeTypeOfRealEstateAssetCode()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


TypeOfRealEstateAssetCode Property

TypeOfRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► TypeOfRealEstateAssetCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode { get; set; }
Public Property TypeOfRealEstateAssetCode As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode1 Property

TypeOfRealEstateAssetCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► TypeOfRealEstateAssetCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode1 { get; set; }
Public Property TypeOfRealEstateAssetCode1 As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode1 {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode2 Property

TypeOfRealEstateAssetCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► TypeOfRealEstateAssetCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode2 { get; set; }
Public Property TypeOfRealEstateAssetCode2 As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode2 {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode3 Property

TypeOfRealEstateAssetCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► TypeOfRealEstateAssetCode3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode3 { get; set; }
Public Property TypeOfRealEstateAssetCode3 As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode3 {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode4 Property

TypeOfRealEstateAssetCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeTypeOfRealEstateAssetCode ► TypeOfRealEstateAssetCode4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode4 { get; set; }
Public Property TypeOfRealEstateAssetCode4 As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode4 {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Class

CompositeUnitOfMeasure Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure
RDPCrystal EDI Library
C001
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeUnitOfMeasure : DocumentCompositeElement
Public Class CompositeUnitOfMeasure _
    Inherits DocumentCompositeElement
public ref class CompositeUnitOfMeasure : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeUnitOfMeasure()()()() | Initializes a new instance of the CompositeUnitOfMeasure class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exponent | Element 2
 | Exponent1 | Element 5
 | Exponent2 | Element 8
 | Exponent3 | Element 11
 | Exponent4 | Element 14
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Element 3
 | Multiplier1 | Element 6
 | Multiplier2 | Element 9
 | Multiplier3 | Element 12
 | Multiplier4 | Element 15
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnitOrBasisForMeasurementCode | Element 1
 | UnitOrBasisForMeasurementCode1 | Element 4
 | UnitOrBasisForMeasurementCode2 | Element 7
 | UnitOrBasisForMeasurementCode3 | Element 10
 | UnitOrBasisForMeasurementCode4 | Element 13
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeUnitOfMeasure


CompositeUnitOfMeasure Constructor

CompositeUnitOfMeasure Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► CompositeUnitOfMeasure()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeUnitOfMeasure class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure()
Public Sub New
public:
CompositeUnitOfMeasure()


Exponent Property

Exponent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Exponent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent { get; set; }
Public Property Exponent As String
    Get
    Set
public:
property String^ Exponent {
    String^ get ();
    void set (String^ value);
}


Exponent1 Property

Exponent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Exponent1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent1 { get; set; }
Public Property Exponent1 As String
    Get
    Set
public:
property String^ Exponent1 {
    String^ get ();
    void set (String^ value);
}


Exponent2 Property

Exponent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Exponent2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent2 { get; set; }
Public Property Exponent2 As String
    Get
    Set
public:
property String^ Exponent2 {
    String^ get ();
    void set (String^ value);
}


Exponent3 Property

Exponent3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Exponent3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent3 { get; set; }
Public Property Exponent3 As String
    Get
    Set
public:
property String^ Exponent3 {
    String^ get ();
    void set (String^ value);
}


Exponent4 Property

Exponent4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Exponent4
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent4 { get; set; }
Public Property Exponent4 As String
    Get
    Set
public:
property String^ Exponent4 {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Multiplier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


Multiplier1 Property

Multiplier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Multiplier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier1 { get; set; }
Public Property Multiplier1 As String
    Get
    Set
public:
property String^ Multiplier1 {
    String^ get ();
    void set (String^ value);
}


Multiplier2 Property

Multiplier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Multiplier2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier2 { get; set; }
Public Property Multiplier2 As String
    Get
    Set
public:
property String^ Multiplier2 {
    String^ get ();
    void set (String^ value);
}


Multiplier3 Property

Multiplier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Multiplier3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier3 { get; set; }
Public Property Multiplier3 As String
    Get
    Set
public:
property String^ Multiplier3 {
    String^ get ();
    void set (String^ value);
}


Multiplier4 Property

Multiplier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► Multiplier4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier4 { get; set; }
Public Property Multiplier4 As String
    Get
    Set
public:
property String^ Multiplier4 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}


CompositeUseOfProceeds Class

CompositeUseOfProceeds Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds
RDPCrystal EDI Library
C048
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeUseOfProceeds : DocumentCompositeElement
Public Class CompositeUseOfProceeds _
    Inherits DocumentCompositeElement
public ref class CompositeUseOfProceeds : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeUseOfProceeds()()()() | Initializes a new instance of the CompositeUseOfProceeds class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RefinanceTypeCode | Element 2
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UseOfProceedsCode | Element 1
 | UseOfProceedsCode1 | Element 3
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeUseOfProceeds


CompositeUseOfProceeds Constructor

CompositeUseOfProceeds Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds ► CompositeUseOfProceeds()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeUseOfProceeds class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUseOfProceeds()
Public Sub New
public:
CompositeUseOfProceeds()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


RefinanceTypeCode Property

RefinanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds ► RefinanceTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RefinanceTypeCode { get; set; }
Public Property RefinanceTypeCode As String
    Get
    Set
public:
property String^ RefinanceTypeCode {
    String^ get ();
    void set (String^ value);
}


UseOfProceedsCode Property

UseOfProceedsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds ► UseOfProceedsCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UseOfProceedsCode { get; set; }
Public Property UseOfProceedsCode As String
    Get
    Set
public:
property String^ UseOfProceedsCode {
    String^ get ();
    void set (String^ value);
}


UseOfProceedsCode1 Property

UseOfProceedsCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CompositeUseOfProceeds ► UseOfProceedsCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UseOfProceedsCode1 { get; set; }
Public Property UseOfProceedsCode1 As String
    Get
    Set
public:
property String^ UseOfProceedsCode1 {
    String^ get ();
    void set (String^ value);
}


ComputationMethods Class

ComputationMethods Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ComputationMethods
RDPCrystal EDI Library
C034
Declaration Syntax
C# Visual Basic Visual C++
public class ComputationMethods : DocumentCompositeElement
Public Class ComputationMethods _
    Inherits DocumentCompositeElement
public ref class ComputationMethods : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComputationMethods()()()() | Initializes a new instance of the ComputationMethods class
 | AssuranceAlgorithm | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HashingAlgorithm | Element 2
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ComputationMethods


ComputationMethods Constructor

ComputationMethods Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ComputationMethods ► ComputationMethods()()()()
RDPCrystal EDI Library
Initializes a new instance of the ComputationMethods class
Declaration Syntax
C# Visual Basic Visual C++
public ComputationMethods()
Public Sub New
public:
ComputationMethods()


AssuranceAlgorithm Property

AssuranceAlgorithm Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ComputationMethods ► AssuranceAlgorithm
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceAlgorithm { get; set; }
Public Property AssuranceAlgorithm As String
    Get
    Set
public:
property String^ AssuranceAlgorithm {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ComputationMethods ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


HashingAlgorithm Property

HashingAlgorithm Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ComputationMethods ► HashingAlgorithm
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HashingAlgorithm { get; set; }
Public Property HashingAlgorithm As String
    Get
    Set
public:
property String^ HashingAlgorithm {
    String^ get ();
    void set (String^ value);
}


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ComputationMethods ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


CON Class

CON Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON
RDPCrystal EDI Library
Contract Number Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CON : DocumentSegment
Public Class CON _
    Inherits DocumentSegment
public ref class CON : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CON()()()() | Initializes a new instance of the CON class
 | ContractStatusCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CON


CON Constructor

CON Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON ► CON()()()()
RDPCrystal EDI Library
Initializes a new instance of the CON class
Declaration Syntax
C# Visual Basic Visual C++
public CON()
Public Sub New
public:
CON()


ContractStatusCode Property

ContractStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON ► ContractStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ContractStatusCode { get; set; }
Public Property ContractStatusCode As String
    Get
    Set
public:
property String^ ContractStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CON ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ConditionsIndicated Class

ConditionsIndicated Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated
RDPCrystal EDI Library
C045
Declaration Syntax
C# Visual Basic Visual C++
public class ConditionsIndicated : DocumentCompositeElement
Public Class ConditionsIndicated _
    Inherits DocumentCompositeElement
public ref class ConditionsIndicated : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionsIndicated()()()() | Initializes a new instance of the ConditionsIndicated class
 | ConditionIndicator |
 | ConditionIndicator1 |
 | ConditionIndicator2 |
 | ConditionIndicator3 |
 | ConditionIndicator4 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ConditionsIndicated


ConditionsIndicated Constructor

ConditionsIndicated Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► ConditionsIndicated()()()()
RDPCrystal EDI Library
Initializes a new instance of the ConditionsIndicated class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionsIndicated()
Public Sub New
public:
ConditionsIndicated()


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► ConditionIndicator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator1 Property

ConditionIndicator1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► ConditionIndicator1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator1 { get; set; }
Public Property ConditionIndicator1 As String
    Get
    Set
public:
property String^ ConditionIndicator1 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator2 Property

ConditionIndicator2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► ConditionIndicator2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator2 { get; set; }
Public Property ConditionIndicator2 As String
    Get
    Set
public:
property String^ ConditionIndicator2 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator3 Property

ConditionIndicator3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► ConditionIndicator3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator3 { get; set; }
Public Property ConditionIndicator3 As String
    Get
    Set
public:
property String^ ConditionIndicator3 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator4 Property

ConditionIndicator4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► ConditionIndicator4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator4 { get; set; }
Public Property ConditionIndicator4 As String
    Get
    Set
public:
property String^ ConditionIndicator4 {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ConditionsIndicated ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


CPR Class

CPR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR
RDPCrystal EDI Library
Commodity Price Reference
Declaration Syntax
C# Visual Basic Visual C++
public class CPR : DocumentSegment
Public Class CPR _
    Inherits DocumentSegment
public ref class CPR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CPR()()()() | Initializes a new instance of the CPR class
 | CommodityIdentification | Element 4
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarketExchangeIdentifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CPR


CPR Constructor

CPR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► CPR()()()()
RDPCrystal EDI Library
Initializes a new instance of the CPR class
Declaration Syntax
C# Visual Basic Visual C++
public CPR()
Public Sub New
public:
CPR()


CommodityIdentification Property

CommodityIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► CommodityIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityIdentification { get; set; }
Public Property CommodityIdentification As String
    Get
    Set
public:
property String^ CommodityIdentification {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarketExchangeIdentifier Property

MarketExchangeIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► MarketExchangeIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MarketExchangeIdentifier { get; set; }
Public Property MarketExchangeIdentifier As String
    Get
    Set
public:
property String^ MarketExchangeIdentifier {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► UnitPrice
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CPR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CR1 Class

CR1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1
RDPCrystal EDI Library
Ambulance Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR1 : DocumentSegment
Public Class CR1 _
    Inherits DocumentSegment
public ref class CR1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR1()()()() | Initializes a new instance of the CR1 class
 | Address | Element 7
 | Address1 | Element 8
 | AmbulanceTransportCode | Element 3
 | AmbulanceTransportReasonCode | Element 4
 | Description | Element 9
 | Description1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 1
 | UnitOrBasisForMeasurementCode1 | Element 5
 | Weight | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR1


CR1 Constructor

CR1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► CR1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR1 class
Declaration Syntax
C# Visual Basic Visual C++
public CR1()
Public Sub New
public:
CR1()


Address Property

Address Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Address
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}


Address1 Property

Address1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Address1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}


AmbulanceTransportCode Property

AmbulanceTransportCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► AmbulanceTransportCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmbulanceTransportCode { get; set; }
Public Property AmbulanceTransportCode As String
    Get
    Set
public:
property String^ AmbulanceTransportCode {
    String^ get ();
    void set (String^ value);
}


AmbulanceTransportReasonCode Property

AmbulanceTransportReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► AmbulanceTransportReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmbulanceTransportReasonCode { get; set; }
Public Property AmbulanceTransportReasonCode As String
    Get
    Set
public:
property String^ AmbulanceTransportReasonCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Description1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CR2 Class

CR2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2
RDPCrystal EDI Library
Chiropractic Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR2 : DocumentSegment
Public Class CR2 _
    Inherits DocumentSegment
public ref class CR2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR2()()()() | Initializes a new instance of the CR2 class
 | Count | Element 1
 | Description | Element 10
 | Description1 | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NatureOfConditionCode | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | Quantity1 | Element 6
 | Quantity2 | Element 7
 | SubluxationLevelCode | Element 3
 | SubluxationLevelCode1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisFor | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCode1 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR2


CR2 Constructor

CR2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► CR2()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR2 class
Declaration Syntax
C# Visual Basic Visual C++
public CR2()
Public Sub New
public:
CR2()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Count
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Description1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NatureOfConditionCode Property

NatureOfConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► NatureOfConditionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string NatureOfConditionCode { get; set; }
Public Property NatureOfConditionCode As String
    Get
    Set
public:
property String^ NatureOfConditionCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Quantity1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Quantity2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


SubluxationLevelCode Property

SubluxationLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► SubluxationLevelCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SubluxationLevelCode { get; set; }
Public Property SubluxationLevelCode As String
    Get
    Set
public:
property String^ SubluxationLevelCode {
    String^ get ();
    void set (String^ value);
}


SubluxationLevelCode1 Property

SubluxationLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► SubluxationLevelCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SubluxationLevelCode1 { get; set; }
Public Property SubluxationLevelCode1 As String
    Get
    Set
public:
property String^ SubluxationLevelCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisFor Property

UnitOrBasisFor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► UnitOrBasisFor
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisFor { get; set; }
Public Property UnitOrBasisFor As String
    Get
    Set
public:
property String^ UnitOrBasisFor {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR2 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


CR3 Class

CR3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3
RDPCrystal EDI Library
Durable Medical Equipment Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR3 : DocumentSegment
Public Class CR3 _
    Inherits DocumentSegment
public ref class CR3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR3()()()() | Initializes a new instance of the CR3 class
 | CertificationTypeCode | Element 1
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsulinDependentCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR3


CR3 Constructor

CR3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► CR3()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR3 class
Declaration Syntax
C# Visual Basic Visual C++
public CR3()
Public Sub New
public:
CR3()


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► CertificationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


InsulinDependentCode Property

InsulinDependentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► InsulinDependentCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InsulinDependentCode { get; set; }
Public Property InsulinDependentCode As String
    Get
    Set
public:
property String^ InsulinDependentCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CR4 Class

CR4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4
RDPCrystal EDI Library
Enteral or Parenteral Therapy Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR4 : DocumentSegment
Public Class CR4 _
    Inherits DocumentSegment
public ref class CR4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR4()()()() | Initializes a new instance of the CR4 class
 | CertificationTypeCode | Element 2
 | Description | Element 15
 | Description1 | Element 20
 | Description2 | Element 29
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonVisitCode | Element 7
 | NutrientAdministrationMethodCode | Element 16
 | NutrientAdministrationTechniqueCode | Element 17
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 22
 | Percent1 | Element 25
 | Percent2 | Element 27
 | Quantity | Element 4
 | Quantity1 | Element 6
 | Quantity10 | Element 28
 | Quantity2 | Element 9
 | Quantity3 | Element 14
 | Quantity4 | Element 18
 | Quantity5 | Element 19
 | Quantity6 | Element 21
 | Quantity7 | Element 23
 | Quantity8 | Element 24
 | Quantity9 | Element 26
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 5
 | UnitOrBasisForMeasurementCode2 | Element 8
 | UnitOrBasisForMeasurementCode3 | Element 10
 | UnitOrBasisForMeasurementCode4 | Element 12
 | Weight | Element 13
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR4


CR4 Constructor

CR4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► CR4()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR4 class
Declaration Syntax
C# Visual Basic Visual C++
public CR4()
Public Sub New
public:
CR4()


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► CertificationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Description
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Description1
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Description2
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Height
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NonVisitCode Property

NonVisitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► NonVisitCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NonVisitCode { get; set; }
Public Property NonVisitCode As String
    Get
    Set
public:
property String^ NonVisitCode {
    String^ get ();
    void set (String^ value);
}


NutrientAdministrationMethodCode Property

NutrientAdministrationMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► NutrientAdministrationMethodCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string NutrientAdministrationMethodCode { get; set; }
Public Property NutrientAdministrationMethodCode As String
    Get
    Set
public:
property String^ NutrientAdministrationMethodCode {
    String^ get ();
    void set (String^ value);
}


NutrientAdministrationTechniqueCode Property

NutrientAdministrationTechniqueCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► NutrientAdministrationTechniqueCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string NutrientAdministrationTechniqueCode { get; set; }
Public Property NutrientAdministrationTechniqueCode As String
    Get
    Set
public:
property String^ NutrientAdministrationTechniqueCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Percent
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Percent1
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Percent2 Property

Percent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Percent2
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string Percent2 { get; set; }
Public Property Percent2 As String
    Get
    Set
public:
property String^ Percent2 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity10 Property

Quantity10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity10
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity10 { get; set; }
Public Property Quantity10 As String
    Get
    Set
public:
property String^ Quantity10 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity4
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity5
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity6
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}


Quantity7 Property

Quantity7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity7
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity7 { get; set; }
Public Property Quantity7 As String
    Get
    Set
public:
property String^ Quantity7 {
    String^ get ();
    void set (String^ value);
}


Quantity8 Property

Quantity8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity8
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity8 { get; set; }
Public Property Quantity8 As String
    Get
    Set
public:
property String^ Quantity8 {
    String^ get ();
    void set (String^ value);
}


Quantity9 Property

Quantity9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Quantity9
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity9 { get; set; }
Public Property Quantity9 As String
    Get
    Set
public:
property String^ Quantity9 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Weight
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR4 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CR5 Class

CR5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5
RDPCrystal EDI Library
Oxygen Therapy Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR5 : DocumentSegment
Public Class CR5 _
    Inherits DocumentSegment
public ref class CR5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR5()()()() | Initializes a new instance of the CR5 class
 | CertificationTypeCode | Element 1
 | Description | Element 5
 | Description1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OxygenDeliverySystemCode | Element 17
 | OxygenEquipmentTypeCode | Element 3
 | OxygenEquipmentTypeCode1 | Element 4
 | OxygenEquipmentTypeCode2 | Element 18
 | OxygenTestConditionCode | Element 12
 | OxygenTestFindingsCode | Element 13
 | OxygenTestFindingsCode1 | Element 14
 | OxygenTestFindingsCode2 | Element 15
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | Quantity1 | Element 6
 | Quantity2 | Element 7
 | Quantity3 | Element 8
 | Quantity4 | Element 10
 | Quantity5 | Element 11
 | Quantity6 | Element 16
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR5


CR5 Constructor

CR5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► CR5()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR5 class
Declaration Syntax
C# Visual Basic Visual C++
public CR5()
Public Sub New
public:
CR5()


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► CertificationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Description1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OxygenDeliverySystemCode Property

OxygenDeliverySystemCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenDeliverySystemCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenDeliverySystemCode { get; set; }
Public Property OxygenDeliverySystemCode As String
    Get
    Set
public:
property String^ OxygenDeliverySystemCode {
    String^ get ();
    void set (String^ value);
}


OxygenEquipmentTypeCode Property

OxygenEquipmentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenEquipmentTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenEquipmentTypeCode { get; set; }
Public Property OxygenEquipmentTypeCode As String
    Get
    Set
public:
property String^ OxygenEquipmentTypeCode {
    String^ get ();
    void set (String^ value);
}


OxygenEquipmentTypeCode1 Property

OxygenEquipmentTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenEquipmentTypeCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenEquipmentTypeCode1 { get; set; }
Public Property OxygenEquipmentTypeCode1 As String
    Get
    Set
public:
property String^ OxygenEquipmentTypeCode1 {
    String^ get ();
    void set (String^ value);
}


OxygenEquipmentTypeCode2 Property

OxygenEquipmentTypeCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenEquipmentTypeCode2
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenEquipmentTypeCode2 { get; set; }
Public Property OxygenEquipmentTypeCode2 As String
    Get
    Set
public:
property String^ OxygenEquipmentTypeCode2 {
    String^ get ();
    void set (String^ value);
}


OxygenTestConditionCode Property

OxygenTestConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenTestConditionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestConditionCode { get; set; }
Public Property OxygenTestConditionCode As String
    Get
    Set
public:
property String^ OxygenTestConditionCode {
    String^ get ();
    void set (String^ value);
}


OxygenTestFindingsCode Property

OxygenTestFindingsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenTestFindingsCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestFindingsCode { get; set; }
Public Property OxygenTestFindingsCode As String
    Get
    Set
public:
property String^ OxygenTestFindingsCode {
    String^ get ();
    void set (String^ value);
}


OxygenTestFindingsCode1 Property

OxygenTestFindingsCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenTestFindingsCode1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestFindingsCode1 { get; set; }
Public Property OxygenTestFindingsCode1 As String
    Get
    Set
public:
property String^ OxygenTestFindingsCode1 {
    String^ get ();
    void set (String^ value);
}


OxygenTestFindingsCode2 Property

OxygenTestFindingsCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► OxygenTestFindingsCode2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestFindingsCode2 { get; set; }
Public Property OxygenTestFindingsCode2 As String
    Get
    Set
public:
property String^ OxygenTestFindingsCode2 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity5
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Quantity6
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CR6 Class

CR6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6
RDPCrystal EDI Library
Home Health Care Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR6 : DocumentSegment
Public Class CR6 _
    Inherits DocumentSegment
public ref class CR6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR6()()()() | Initializes a new instance of the CR6 class
 | CertificationTypeCode | Element 8
 | Date | Element 2
 | Date1 | Element 5
 | Date2 | Element 9
 | Date3 | Element 12
 | Date4 | Element 13
 | Date5 | Element 14
 | Date6 | Element 18
 | Date7 | Element 19
 | Date8 | Element 20
 | Date9 | Element 21
 | DateTimePeriod | Element 4
 | DateTimePeriod1 | Element 16
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimePeriodFormatQualifier1 | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalCodeValue | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientLocationCode | Element 17
 | ProductServiceIDQualifier | Element 10
 | PrognosisCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR6


CR6 Constructor

CR6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► CR6()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR6 class
Declaration Syntax
C# Visual Basic Visual C++
public CR6()
Public Sub New
public:
CR6()


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► CertificationTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


Date4 Property

Date4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Date4 { get; set; }
Public Property Date4 As String
    Get
    Set
public:
property String^ Date4 {
    String^ get ();
    void set (String^ value);
}


Date5 Property

Date5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Date5 { get; set; }
Public Property Date5 As String
    Get
    Set
public:
property String^ Date5 {
    String^ get ();
    void set (String^ value);
}


Date6 Property

Date6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date6
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Date6 { get; set; }
Public Property Date6 As String
    Get
    Set
public:
property String^ Date6 {
    String^ get ();
    void set (String^ value);
}


Date7 Property

Date7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date7
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Date7 { get; set; }
Public Property Date7 As String
    Get
    Set
public:
property String^ Date7 {
    String^ get ();
    void set (String^ value);
}


Date8 Property

Date8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date8
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Date8 { get; set; }
Public Property Date8 As String
    Get
    Set
public:
property String^ Date8 {
    String^ get ();
    void set (String^ value);
}


Date9 Property

Date9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Date9
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Date9 { get; set; }
Public Property Date9 As String
    Get
    Set
public:
property String^ Date9 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► DateTimePeriod1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MedicalCodeValue Property

MedicalCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► MedicalCodeValue
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue { get; set; }
Public Property MedicalCodeValue As String
    Get
    Set
public:
property String^ MedicalCodeValue {
    String^ get ();
    void set (String^ value);
}


PatientLocationCode Property

PatientLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► PatientLocationCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string PatientLocationCode { get; set; }
Public Property PatientLocationCode As String
    Get
    Set
public:
property String^ PatientLocationCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► PrognosisCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR6 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


CR7 Class

CR7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7
RDPCrystal EDI Library
Home Health Treatment Plan Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR7 : DocumentSegment
Public Class CR7 _
    Inherits DocumentSegment
public ref class CR7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR7()()()() | Initializes a new instance of the CR7 class
 | DisciplineTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 2
 | Number1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR7


CR7 Constructor

CR7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7 ► CR7()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR7 class
Declaration Syntax
C# Visual Basic Visual C++
public CR7()
Public Sub New
public:
CR7()


DisciplineTypeCode Property

DisciplineTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7 ► DisciplineTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DisciplineTypeCode { get; set; }
Public Property DisciplineTypeCode As String
    Get
    Set
public:
property String^ DisciplineTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7 ► Number
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7 ► Number1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CR8 Class

CR8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8
RDPCrystal EDI Library
Pacemaker Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR8 : DocumentSegment
Public Class CR8 _
    Inherits DocumentSegment
public ref class CR8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR8()()()() | Initializes a new instance of the CR8 class
 | Date | Element 3
 | Date1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplantStatusCode | Element 2
 | ImplantTypeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 6
 | ReferenceIdentification2 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
 | YesNoConditionOrResponseCode1 | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR8


CR8 Constructor

CR8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► CR8()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR8 class
Declaration Syntax
C# Visual Basic Visual C++
public CR8()
Public Sub New
public:
CR8()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


ImplantStatusCode Property

ImplantStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► ImplantStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ImplantStatusCode { get; set; }
Public Property ImplantStatusCode As String
    Get
    Set
public:
property String^ ImplantStatusCode {
    String^ get ();
    void set (String^ value);
}


ImplantTypeCode Property

ImplantTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► ImplantTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ImplantTypeCode { get; set; }
Public Property ImplantTypeCode As String
    Get
    Set
public:
property String^ ImplantTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► ReferenceIdentification2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CR8 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


CRC Class

CRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC
RDPCrystal EDI Library
Conditions Indicator
Declaration Syntax
C# Visual Basic Visual C++
public class CRC : DocumentSegment
Public Class CRC _
    Inherits DocumentSegment
public ref class CRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRC()()()() | Initializes a new instance of the CRC class
 | CodeCategory | Element 1
 | ConditionIndicator | Element 3
 | ConditionIndicator1 | Element 4
 | ConditionIndicator2 | Element 5
 | ConditionIndicator3 | Element 6
 | ConditionIndicator4 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRC


CRC Constructor

CRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► CRC()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRC class
Declaration Syntax
C# Visual Basic Visual C++
public CRC()
Public Sub New
public:
CRC()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► ConditionIndicator
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator1 Property

ConditionIndicator1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► ConditionIndicator1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator1 { get; set; }
Public Property ConditionIndicator1 As String
    Get
    Set
public:
property String^ ConditionIndicator1 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator2 Property

ConditionIndicator2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► ConditionIndicator2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator2 { get; set; }
Public Property ConditionIndicator2 As String
    Get
    Set
public:
property String^ ConditionIndicator2 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator3 Property

ConditionIndicator3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► ConditionIndicator3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator3 { get; set; }
Public Property ConditionIndicator3 As String
    Get
    Set
public:
property String^ ConditionIndicator3 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator4 Property

ConditionIndicator4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► ConditionIndicator4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator4 { get; set; }
Public Property ConditionIndicator4 As String
    Get
    Set
public:
property String^ ConditionIndicator4 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CRD Class

CRD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD
RDPCrystal EDI Library
Content Reporting Detail
Declaration Syntax
C# Visual Basic Visual C++
public class CRD : DocumentSegment
Public Class CRD _
    Inherits DocumentSegment
public ref class CRD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRD()()()() | Initializes a new instance of the CRD class
 | AmountQualifierCode | Element 2
 | CountryCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRD


CRD Constructor

CRD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► CRD()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRD class
Declaration Syntax
C# Visual Basic Visual C++
public CRD()
Public Sub New
public:
CRD()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► CountryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CRI Class

CRI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI
RDPCrystal EDI Library
Claim Report Information
Declaration Syntax
C# Visual Basic Visual C++
public class CRI : DocumentSegment
Public Class CRI _
    Inherits DocumentSegment
public ref class CRI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRI()()()() | Initializes a new instance of the CRI class
 | AdjustmentReasonCodeCharacteristic | Element 9
 | ClaimFilingIndicatorCode | Element 6
 | ClaimStatusCode | Element 2
 | DateTimePeriod | Element 8
 | DateTimePeriodFormatQualifier | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LateReasonCode | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 3
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRI


CRI Constructor

CRI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► CRI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRI class
Declaration Syntax
C# Visual Basic Visual C++
public CRI()
Public Sub New
public:
CRI()


AdjustmentReasonCodeCharacteristic Property

AdjustmentReasonCodeCharacteristic Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► AdjustmentReasonCodeCharacteristic
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCodeCharacteristic { get; set; }
Public Property AdjustmentReasonCodeCharacteristic As String
    Get
    Set
public:
property String^ AdjustmentReasonCodeCharacteristic {
    String^ get ();
    void set (String^ value);
}


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► ClaimStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► DateTimePeriod
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► FrequencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


LateReasonCode Property

LateReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► LateReasonCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LateReasonCode { get; set; }
Public Property LateReasonCode As String
    Get
    Set
public:
property String^ LateReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CRO Class

CRO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO
RDPCrystal EDI Library
Credit Report Order Details
Declaration Syntax
C# Visual Basic Visual C++
public class CRO : DocumentSegment
Public Class CRO _
    Inherits DocumentSegment
public ref class CRO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRO()()()() | Initializes a new instance of the CRO class
 | ActionCode | Element 5
 | CreditReportMergeTypeCode | Element 6
 | DateTimePeriod | Element 2
 | DateTimePeriodFormatQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | ProductServiceIDQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRO


CRO Constructor

CRO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► CRO()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRO class
Declaration Syntax
C# Visual Basic Visual C++
public CRO()
Public Sub New
public:
CRO()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► ActionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


CreditReportMergeTypeCode Property

CreditReportMergeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► CreditReportMergeTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CreditReportMergeTypeCode { get; set; }
Public Property CreditReportMergeTypeCode As String
    Get
    Set
public:
property String^ CreditReportMergeTypeCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► DateTimePeriod
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CRS Class

CRS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS
RDPCrystal EDI Library
Course Record
Declaration Syntax
C# Visual Basic Visual C++
public class CRS : DocumentSegment
Public Class CRS _
    Inherits DocumentSegment
public ref class CRS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRS()()()() | Initializes a new instance of the CRS class
 | AcademicCreditTypeCode | Element 2
 | AcademicGrade | Element 6
 | AcademicGradeOrCourseLevelCode | Element 8
 | AcademicGradeQualifier | Element 5
 | BasisForAcademicCreditCode | Element 1
 | CourseRepeatOrNoCountIndicatorCode | Element 9
 | Date | Element 19
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 11
 | IdentificationCodeQualifier | Element 10
 | LevelOfIndividualTestOrCourseCode | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 14
 | Name2 | Element 16
 | OverrideAcademicCourseSourceCode | Element 20
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | Quantity1 | Element 4
 | Quantity2 | Element 12
 | Quantity3 | Element 17
 | Quantity4 | Element 18
 | ReferenceIdentification | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRS


CRS Constructor

CRS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► CRS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRS class
Declaration Syntax
C# Visual Basic Visual C++
public CRS()
Public Sub New
public:
CRS()


AcademicCreditTypeCode Property

AcademicCreditTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► AcademicCreditTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicCreditTypeCode { get; set; }
Public Property AcademicCreditTypeCode As String
    Get
    Set
public:
property String^ AcademicCreditTypeCode {
    String^ get ();
    void set (String^ value);
}


AcademicGrade Property

AcademicGrade Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► AcademicGrade
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGrade { get; set; }
Public Property AcademicGrade As String
    Get
    Set
public:
property String^ AcademicGrade {
    String^ get ();
    void set (String^ value);
}


AcademicGradeOrCourseLevelCode Property

AcademicGradeOrCourseLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► AcademicGradeOrCourseLevelCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradeOrCourseLevelCode { get; set; }
Public Property AcademicGradeOrCourseLevelCode As String
    Get
    Set
public:
property String^ AcademicGradeOrCourseLevelCode {
    String^ get ();
    void set (String^ value);
}


AcademicGradeQualifier Property

AcademicGradeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► AcademicGradeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradeQualifier { get; set; }
Public Property AcademicGradeQualifier As String
    Get
    Set
public:
property String^ AcademicGradeQualifier {
    String^ get ();
    void set (String^ value);
}


BasisForAcademicCreditCode Property

BasisForAcademicCreditCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► BasisForAcademicCreditCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BasisForAcademicCreditCode { get; set; }
Public Property BasisForAcademicCreditCode As String
    Get
    Set
public:
property String^ BasisForAcademicCreditCode {
    String^ get ();
    void set (String^ value);
}


CourseRepeatOrNoCountIndicatorCode Property

CourseRepeatOrNoCountIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► CourseRepeatOrNoCountIndicatorCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CourseRepeatOrNoCountIndicatorCode { get; set; }
Public Property CourseRepeatOrNoCountIndicatorCode As String
    Get
    Set
public:
property String^ CourseRepeatOrNoCountIndicatorCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Date
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► IdentificationCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Name1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Name2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


OverrideAcademicCourseSourceCode Property

OverrideAcademicCourseSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► OverrideAcademicCourseSourceCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string OverrideAcademicCourseSourceCode { get; set; }
Public Property OverrideAcademicCourseSourceCode As String
    Get
    Set
public:
property String^ OverrideAcademicCourseSourceCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Quantity2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Quantity3
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Quantity4
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► ReferenceIdentification
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CRT Class

CRT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT
RDPCrystal EDI Library
Contractor Report Type
Declaration Syntax
C# Visual Basic Visual C++
public class CRT : DocumentSegment
Public Class CRT _
    Inherits DocumentSegment
public ref class CRT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRT()()()() | Initializes a new instance of the CRT class
 | ActionCode | Element 5
 | BreakdownStructureDetailCode | Element 4
 | CompositeUnitOfMeasure | Element 2
 | CompositeUnitOfMeasure1 | Element 3
 | ContractActionCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramTypeCode | Element 8
 | RateOrValueTypeCode | Element 6
 | ReportTypeCode | Element 1
 | SecurityLevelCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRT


CRT Constructor

CRT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► CRT()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRT class
Declaration Syntax
C# Visual Basic Visual C++
public CRT()
Public Sub New
public:
CRT()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► ActionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


BreakdownStructureDetailCode Property

BreakdownStructureDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► BreakdownStructureDetailCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BreakdownStructureDetailCode { get; set; }
Public Property BreakdownStructureDetailCode As String
    Get
    Set
public:
property String^ BreakdownStructureDetailCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ContractActionCode Property

ContractActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► ContractActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ContractActionCode { get; set; }
Public Property ContractActionCode As String
    Get
    Set
public:
property String^ ContractActionCode {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► FreeformDescription
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProgramTypeCode Property

ProgramTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► ProgramTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramTypeCode { get; set; }
Public Property ProgramTypeCode As String
    Get
    Set
public:
property String^ ProgramTypeCode {
    String^ get ();
    void set (String^ value);
}


RateOrValueTypeCode Property

RateOrValueTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► RateOrValueTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RateOrValueTypeCode { get; set; }
Public Property RateOrValueTypeCode As String
    Get
    Set
public:
property String^ RateOrValueTypeCode {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► SecurityLevelCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CRV Class

CRV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV
RDPCrystal EDI Library
Product Origin Reference
Declaration Syntax
C# Visual Basic Visual C++
public class CRV : DocumentSegment
Public Class CRV _
    Inherits DocumentSegment
public ref class CRV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRV()()()() | Initializes a new instance of the CRV class
 | Amount | Element 2
 | CertificationClauseCode | Element 6
 | CountryCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetCostCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | PreferentialDutyCriteriaCode | Element 7
 | ProductProcess | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRV


CRV Constructor

CRV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► CRV()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRV class
Declaration Syntax
C# Visual Basic Visual C++
public CRV()
Public Sub New
public:
CRV()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► Amount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CertificationClauseCode Property

CertificationClauseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► CertificationClauseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseCode { get; set; }
Public Property CertificationClauseCode As String
    Get
    Set
public:
property String^ CertificationClauseCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► CountryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetCostCode Property

NetCostCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► NetCostCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NetCostCode { get; set; }
Public Property NetCostCode As String
    Get
    Set
public:
property String^ NetCostCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PreferentialDutyCriteriaCode Property

PreferentialDutyCriteriaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► PreferentialDutyCriteriaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PreferentialDutyCriteriaCode { get; set; }
Public Property PreferentialDutyCriteriaCode As String
    Get
    Set
public:
property String^ PreferentialDutyCriteriaCode {
    String^ get ();
    void set (String^ value);
}


ProductProcess Property

ProductProcess Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► ProductProcess
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcess { get; set; }
Public Property ProductProcess As String
    Get
    Set
public:
property String^ ProductProcess {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CRV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CS Class

CS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS
RDPCrystal EDI Library
Contract Summary
Declaration Syntax
C# Visual Basic Visual C++
public class CS : DocumentSegment
Public Class CS _
    Inherits DocumentSegment
public ref class CS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CS()()()() | Initializes a new instance of the CS class
 | ChangeOrderSequenceNumber | Element 2
 | ContractNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FOBPointCode | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 11
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 9
 | Percent1 | Element 10
 | PurchaseOrderNumber | Element 6
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | ReleaseNumber | Element 3
 | SpecialServicesCode | Element 7
 | SpecialServicesCode1 | Element 13
 | TermsTypeCode | Element 12
 | TermsTypeCode1 | Element 16
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 14
 | UnitPrice | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 17
 | YesNoConditionOrResponseCode1 | Element 18
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CS


CS Constructor

CS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► CS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CS class
Declaration Syntax
C# Visual Basic Visual C++
public CS()
Public Sub New
public:
CS()


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► ContractNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


FOBPointCode Property

FOBPointCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► FOBPointCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPointCode { get; set; }
Public Property FOBPointCode As String
    Get
    Set
public:
property String^ FOBPointCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► MonetaryAmount
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► Percent
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► Percent1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► ReleaseNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► SpecialServicesCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode1 Property

SpecialServicesCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► SpecialServicesCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode1 { get; set; }
Public Property SpecialServicesCode1 As String
    Get
    Set
public:
property String^ SpecialServicesCode1 {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode Property

TermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► TermsTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode { get; set; }
Public Property TermsTypeCode As String
    Get
    Set
public:
property String^ TermsTypeCode {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode1 Property

TermsTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► TermsTypeCode1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode1 { get; set; }
Public Property TermsTypeCode1 As String
    Get
    Set
public:
property String^ TermsTypeCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► UnitPrice
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CS ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


CSB Class

CSB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSB
RDPCrystal EDI Library
Cryptographic Service Message Body
Declaration Syntax
C# Visual Basic Visual C++
public class CSB : DocumentSegment
Public Class CSB _
    Inherits DocumentSegment
public ref class CSB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSB()()()() | Initializes a new instance of the CSB class
 | CSMFieldContents | Element 2
 | CSMFieldTag | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSB


CSB Constructor

CSB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSB ► CSB()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSB class
Declaration Syntax
C# Visual Basic Visual C++
public CSB()
Public Sub New
public:
CSB()


CSMFieldContents Property

CSMFieldContents Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSB ► CSMFieldContents
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CSMFieldContents { get; set; }
Public Property CSMFieldContents As String
    Get
    Set
public:
property String^ CSMFieldContents {
    String^ get ();
    void set (String^ value);
}


CSMFieldTag Property

CSMFieldTag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSB ► CSMFieldTag
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CSMFieldTag { get; set; }
Public Property CSMFieldTag As String
    Get
    Set
public:
property String^ CSMFieldTag {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSC Class

CSC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC
RDPCrystal EDI Library
Cryptographic Service Message Certificates and Keys
Declaration Syntax
C# Visual Basic Visual C++
public class CSC : DocumentSegment
Public Class CSC _
    Inherits DocumentSegment
public ref class CSC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSC()()()() | Initializes a new instance of the CSC class
 | CertificateLookupInformation | Element 4
 | CryptographicManagementPurpose | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterIDCode | Element 6
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LengthOfData | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentifier | Element 5
 | SecurityOriginatorName | Element 2
 | SecurityRecipientName | Element 3
 | SecurityValue | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSC


CSC Constructor

CSC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► CSC()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSC class
Declaration Syntax
C# Visual Basic Visual C++
public CSC()
Public Sub New
public:
CSC()


CertificateLookupInformation Property

CertificateLookupInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► CertificateLookupInformation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CertificateLookupInformation CertificateLookupInformation { get; set; }
Public Property CertificateLookupInformation As CertificateLookupInformation
    Get
    Set
public:
property CertificateLookupInformation^ CertificateLookupInformation {
    CertificateLookupInformation^ get ();
    void set (CertificateLookupInformation^ value);
}


CryptographicManagementPurpose Property

CryptographicManagementPurpose Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► CryptographicManagementPurpose
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CryptographicManagementPurpose { get; set; }
Public Property CryptographicManagementPurpose As String
    Get
    Set
public:
property String^ CryptographicManagementPurpose {
    String^ get ();
    void set (String^ value);
}


FilterIDCode Property

FilterIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► FilterIDCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode { get; set; }
Public Property FilterIDCode As String
    Get
    Set
public:
property String^ FilterIDCode {
    String^ get ();
    void set (String^ value);
}


LengthOfData Property

LengthOfData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► LengthOfData
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LengthOfData { get; set; }
Public Property LengthOfData As String
    Get
    Set
public:
property String^ LengthOfData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► ReferenceIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


SecurityOriginatorName Property

SecurityOriginatorName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► SecurityOriginatorName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityOriginatorName { get; set; }
Public Property SecurityOriginatorName As String
    Get
    Set
public:
property String^ SecurityOriginatorName {
    String^ get ();
    void set (String^ value);
}


SecurityRecipientName Property

SecurityRecipientName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► SecurityRecipientName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityRecipientName { get; set; }
Public Property SecurityRecipientName As String
    Get
    Set
public:
property String^ SecurityRecipientName {
    String^ get ();
    void set (String^ value);
}


SecurityValue Property

SecurityValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► SecurityValue
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public SecurityValue SecurityValue { get; set; }
Public Property SecurityValue As SecurityValue
    Get
    Set
public:
property SecurityValue^ SecurityValue {
    SecurityValue^ get ();
    void set (SecurityValue^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► VersionIdentifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSD Class

CSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD
RDPCrystal EDI Library
Consolidated Shipment Invoice Data
Declaration Syntax
C# Visual Basic Visual C++
public class CSD : DocumentSegment
Public Class CSD _
    Inherits DocumentSegment
public ref class CSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSD()()()() | Initializes a new instance of the CSD class
 | Charge | Element 7
 | Date | Element 5
 | Date1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 9
 | ReferenceIdentificationQualifier | Element 2
 | ShipmentMethodOfPayment | Element 4
 | SpecialHandlingCode | Element 1
 | StandardCarrierAlphaCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSD


CSD Constructor

CSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► CSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSD class
Declaration Syntax
C# Visual Basic Visual C++
public CSD()
Public Sub New
public:
CSD()


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► Charge
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► ReferenceIdentification1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSE Class

CSE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE
RDPCrystal EDI Library
Educational Course Information
Declaration Syntax
C# Visual Basic Visual C++
public class CSE : DocumentSegment
Public Class CSE _
    Inherits DocumentSegment
public ref class CSE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSE()()()() | Initializes a new instance of the CSE class
 | AcademicCreditTypeCode | Element 3
 | AcademicGradeOrCourseLevelCode | Element 7
 | EntityTitle | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 9
 | IdentificationCodeQualifier | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 5
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 11
 | YesNoConditionOrResponseCode2 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSE


CSE Constructor

CSE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► CSE()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSE class
Declaration Syntax
C# Visual Basic Visual C++
public CSE()
Public Sub New
public:
CSE()


AcademicCreditTypeCode Property

AcademicCreditTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► AcademicCreditTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicCreditTypeCode { get; set; }
Public Property AcademicCreditTypeCode As String
    Get
    Set
public:
property String^ AcademicCreditTypeCode {
    String^ get ();
    void set (String^ value);
}


AcademicGradeOrCourseLevelCode Property

AcademicGradeOrCourseLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► AcademicGradeOrCourseLevelCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradeOrCourseLevelCode { get; set; }
Public Property AcademicGradeOrCourseLevelCode As String
    Get
    Set
public:
property String^ AcademicGradeOrCourseLevelCode {
    String^ get ();
    void set (String^ value);
}


EntityTitle Property

EntityTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► EntityTitle
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTitle { get; set; }
Public Property EntityTitle As String
    Get
    Set
public:
property String^ EntityTitle {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► IdentificationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSE ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


CSF Class

CSF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF
RDPCrystal EDI Library
Conditional Sampling Frequency
Declaration Syntax
C# Visual Basic Visual C++
public class CSF : DocumentSegment
Public Class CSF _
    Inherits DocumentSegment
public ref class CSF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSF()()()() | Initializes a new instance of the CSF class
 | CompositeUnitOfMeasure | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SampleFrequency | Element 3
 | SampleSelectionModulus | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSF


CSF Constructor

CSF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF ► CSF()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSF class
Declaration Syntax
C# Visual Basic Visual C++
public CSF()
Public Sub New
public:
CSF()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SampleFrequency Property

SampleFrequency Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF ► SampleFrequency
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SampleFrequency { get; set; }
Public Property SampleFrequency As String
    Get
    Set
public:
property String^ SampleFrequency {
    String^ get ();
    void set (String^ value);
}


SampleSelectionModulus Property

SampleSelectionModulus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF ► SampleSelectionModulus
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SampleSelectionModulus { get; set; }
Public Property SampleSelectionModulus As String
    Get
    Set
public:
property String^ SampleSelectionModulus {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSH Class

CSH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH
RDPCrystal EDI Library
Sales Requirements
Declaration Syntax
C# Visual Basic Visual C++
public class CSH : DocumentSegment
Public Class CSH _
    Inherits DocumentSegment
public ref class CSH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSH()()()() | Initializes a new instance of the CSH class
 | AccountNumber | Element 4
 | ActionCode | Element 2
 | AgencyQualifierCode | Element 6
 | Amount | Element 3
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 9
 | PercentQualifier | Element 10
 | ProductServiceSubstitutionCode | Element 8
 | SalesRequirementCode | Element 1
 | SpecialServicesCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSH


CSH Constructor

CSH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► CSH()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSH class
Declaration Syntax
C# Visual Basic Visual C++
public CSH()
Public Sub New
public:
CSH()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► AccountNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► AgencyQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► Percent
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PercentQualifier Property

PercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► PercentQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier { get; set; }
Public Property PercentQualifier As String
    Get
    Set
public:
property String^ PercentQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceSubstitutionCode Property

ProductServiceSubstitutionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► ProductServiceSubstitutionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceSubstitutionCode { get; set; }
Public Property ProductServiceSubstitutionCode As String
    Get
    Set
public:
property String^ ProductServiceSubstitutionCode {
    String^ get ();
    void set (String^ value);
}


SalesRequirementCode Property

SalesRequirementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► SalesRequirementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SalesRequirementCode { get; set; }
Public Property SalesRequirementCode As String
    Get
    Set
public:
property String^ SalesRequirementCode {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► SpecialServicesCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSI Class

CSI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI
RDPCrystal EDI Library
Claim Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class CSI : DocumentSegment
Public Class CSI _
    Inherits DocumentSegment
public ref class CSI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSI()()()() | Initializes a new instance of the CSI class
 | ClaimSubmissionReasonCode | Element 1
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSI


CSI Constructor

CSI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► CSI()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSI class
Declaration Syntax
C# Visual Basic Visual C++
public CSI()
Public Sub New
public:
CSI()


ClaimSubmissionReasonCode Property

ClaimSubmissionReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► ClaimSubmissionReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmissionReasonCode { get; set; }
Public Property ClaimSubmissionReasonCode As String
    Get
    Set
public:
property String^ ClaimSubmissionReasonCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► DateTimeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSM Class

CSM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM
RDPCrystal EDI Library
Cryptographic Service Message Header
Declaration Syntax
C# Visual Basic Visual C++
public class CSM : DocumentSegment
Public Class CSM _
    Inherits DocumentSegment
public ref class CSM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSM()()()() | Initializes a new instance of the CSM class
 | CSMMessageClassCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityOriginatorName | Element 2
 | SecurityRecipientName | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSM


CSM Constructor

CSM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM ► CSM()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSM class
Declaration Syntax
C# Visual Basic Visual C++
public CSM()
Public Sub New
public:
CSM()


CSMMessageClassCode Property

CSMMessageClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM ► CSMMessageClassCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CSMMessageClassCode { get; set; }
Public Property CSMMessageClassCode As String
    Get
    Set
public:
property String^ CSMMessageClassCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityOriginatorName Property

SecurityOriginatorName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM ► SecurityOriginatorName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityOriginatorName { get; set; }
Public Property SecurityOriginatorName As String
    Get
    Set
public:
property String^ SecurityOriginatorName {
    String^ get ();
    void set (String^ value);
}


SecurityRecipientName Property

SecurityRecipientName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM ► SecurityRecipientName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityRecipientName { get; set; }
Public Property SecurityRecipientName As String
    Get
    Set
public:
property String^ SecurityRecipientName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSS Class

CSS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS
RDPCrystal EDI Library
Conditional Sampling Sequence
Declaration Syntax
C# Visual Basic Visual C++
public class CSS : DocumentSegment
Public Class CSS _
    Inherits DocumentSegment
public ref class CSS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSS()()()() | Initializes a new instance of the CSS class
 | CompositeUnitOfMeasure | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SamplingSequenceQualifier | Element 1
 | SamplingSequenceValue | Element 3
 | SamplingSequenceValue1 | Element 4
 | SamplingSequenceValue2 | Element 5
 | SamplingSequenceValue3 | Element 6
 | SamplingSequenceValue4 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSS


CSS Constructor

CSS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► CSS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSS class
Declaration Syntax
C# Visual Basic Visual C++
public CSS()
Public Sub New
public:
CSS()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SamplingSequenceQualifier Property

SamplingSequenceQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► SamplingSequenceQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SamplingSequenceQualifier { get; set; }
Public Property SamplingSequenceQualifier As String
    Get
    Set
public:
property String^ SamplingSequenceQualifier {
    String^ get ();
    void set (String^ value);
}


SamplingSequenceValue Property

SamplingSequenceValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► SamplingSequenceValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SamplingSequenceValue { get; set; }
Public Property SamplingSequenceValue As String
    Get
    Set
public:
property String^ SamplingSequenceValue {
    String^ get ();
    void set (String^ value);
}


SamplingSequenceValue1 Property

SamplingSequenceValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► SamplingSequenceValue1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SamplingSequenceValue1 { get; set; }
Public Property SamplingSequenceValue1 As String
    Get
    Set
public:
property String^ SamplingSequenceValue1 {
    String^ get ();
    void set (String^ value);
}


SamplingSequenceValue2 Property

SamplingSequenceValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► SamplingSequenceValue2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SamplingSequenceValue2 { get; set; }
Public Property SamplingSequenceValue2 As String
    Get
    Set
public:
property String^ SamplingSequenceValue2 {
    String^ get ();
    void set (String^ value);
}


SamplingSequenceValue3 Property

SamplingSequenceValue3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► SamplingSequenceValue3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SamplingSequenceValue3 { get; set; }
Public Property SamplingSequenceValue3 As String
    Get
    Set
public:
property String^ SamplingSequenceValue3 {
    String^ get ();
    void set (String^ value);
}


SamplingSequenceValue4 Property

SamplingSequenceValue4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► SamplingSequenceValue4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SamplingSequenceValue4 { get; set; }
Public Property SamplingSequenceValue4 As String
    Get
    Set
public:
property String^ SamplingSequenceValue4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CST Class

CST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST
RDPCrystal EDI Library
Cost Analysis
Declaration Syntax
C# Visual Basic Visual C++
public class CST : DocumentSegment
Public Class CST _
    Inherits DocumentSegment
public ref class CST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CST()()()() | Initializes a new instance of the CST class
 | CompositeUnitOfMeasure | Element 3
 | CostCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CST


CST Constructor

CST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► CST()()()()
RDPCrystal EDI Library
Initializes a new instance of the CST class
Declaration Syntax
C# Visual Basic Visual C++
public CST()
Public Sub New
public:
CST()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CostCode Property

CostCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► CostCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CostCode { get; set; }
Public Property CostCode As String
    Get
    Set
public:
property String^ CostCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CSU Class

CSU Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU
RDPCrystal EDI Library
Supplemental Course Data
Declaration Syntax
C# Visual Basic Visual C++
public class CSU : DocumentSegment
Public Class CSU _
    Inherits DocumentSegment
public ref class CSU : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CSU()()()() | Initializes a new instance of the CSU class
 | AcademicCreditTypeCode | Element 8
 | CompositeUnitOfMeasure | Element 10
 | DateTimePeriod | Element 4
 | DateTimePeriod1 | Element 6
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimePeriodFormatQualifier1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InstructionalSettingCode | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 9
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CSU


CSU Constructor

CSU Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► CSU()()()()
RDPCrystal EDI Library
Initializes a new instance of the CSU class
Declaration Syntax
C# Visual Basic Visual C++
public CSU()
Public Sub New
public:
CSU()


AcademicCreditTypeCode Property

AcademicCreditTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► AcademicCreditTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicCreditTypeCode { get; set; }
Public Property AcademicCreditTypeCode As String
    Get
    Set
public:
property String^ AcademicCreditTypeCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► DateTimePeriod1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


InstructionalSettingCode Property

InstructionalSettingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► InstructionalSettingCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InstructionalSettingCode { get; set; }
Public Property InstructionalSettingCode As String
    Get
    Set
public:
property String^ InstructionalSettingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► Quantity
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CSU ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CT Class

CT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT
RDPCrystal EDI Library
Car Type
Declaration Syntax
C# Visual Basic Visual C++
public class CT : DocumentSegment
Public Class CT _
    Inherits DocumentSegment
public ref class CT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CT()()()() | Initializes a new instance of the CT class
 | CarTypeCode | Element 2
 | CarTypeCode1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CT


CT Constructor

CT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT ► CT()()()()
RDPCrystal EDI Library
Initializes a new instance of the CT class
Declaration Syntax
C# Visual Basic Visual C++
public CT()
Public Sub New
public:
CT()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT ► CarTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


CarTypeCode1 Property

CarTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT ► CarTypeCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode1 { get; set; }
Public Property CarTypeCode1 As String
    Get
    Set
public:
property String^ CarTypeCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


CTB Class

CTB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB
RDPCrystal EDI Library
Restrictions/Conditions
Declaration Syntax
C# Visual Basic Visual C++
public class CTB : DocumentSegment
Public Class CTB _
    Inherits DocumentSegment
public ref class CTB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTB()()()() | Initializes a new instance of the CTB class
 | Amount | Element 6
 | AmountQualifierCode | Element 5
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | QuantityQualifier | Element 3
 | RestrictionsConditionsQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTB


CTB Constructor

CTB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► CTB()()()()
RDPCrystal EDI Library
Initializes a new instance of the CTB class
Declaration Syntax
C# Visual Basic Visual C++
public CTB()
Public Sub New
public:
CTB()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► Amount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► AmountQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► QuantityQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


RestrictionsConditionsQualifier Property

RestrictionsConditionsQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► RestrictionsConditionsQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RestrictionsConditionsQualifier { get; set; }
Public Property RestrictionsConditionsQualifier As String
    Get
    Set
public:
property String^ RestrictionsConditionsQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CTC Class

CTC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC
RDPCrystal EDI Library
Car Hire Transaction Control
Declaration Syntax
C# Visual Basic Visual C++
public class CTC : DocumentSegment
Public Class CTC _
    Inherits DocumentSegment
public ref class CTC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTC()()()() | Initializes a new instance of the CTC class
 | AccountDescriptionCode | Element 10
 | AccountTypeCode | Element 4
 | CarHireDetailSummaryCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonthOfTheYearCode | Element 7
 | MonthOfTheYearCode1 | Element 9
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | Year | Element 6
 | Year1 | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTC


CTC Constructor

CTC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► CTC()()()()
RDPCrystal EDI Library
Initializes a new instance of the CTC class
Declaration Syntax
C# Visual Basic Visual C++
public CTC()
Public Sub New
public:
CTC()


AccountDescriptionCode Property

AccountDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► AccountDescriptionCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AccountDescriptionCode { get; set; }
Public Property AccountDescriptionCode As String
    Get
    Set
public:
property String^ AccountDescriptionCode {
    String^ get ();
    void set (String^ value);
}


AccountTypeCode Property

AccountTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► AccountTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AccountTypeCode { get; set; }
Public Property AccountTypeCode As String
    Get
    Set
public:
property String^ AccountTypeCode {
    String^ get ();
    void set (String^ value);
}


CarHireDetailSummaryCode Property

CarHireDetailSummaryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► CarHireDetailSummaryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CarHireDetailSummaryCode { get; set; }
Public Property CarHireDetailSummaryCode As String
    Get
    Set
public:
property String^ CarHireDetailSummaryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonthOfTheYearCode Property

MonthOfTheYearCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► MonthOfTheYearCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonthOfTheYearCode { get; set; }
Public Property MonthOfTheYearCode As String
    Get
    Set
public:
property String^ MonthOfTheYearCode {
    String^ get ();
    void set (String^ value);
}


MonthOfTheYearCode1 Property

MonthOfTheYearCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► MonthOfTheYearCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonthOfTheYearCode1 { get; set; }
Public Property MonthOfTheYearCode1 As String
    Get
    Set
public:
property String^ MonthOfTheYearCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Year Property

Year Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► Year
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Year { get; set; }
Public Property Year As String
    Get
    Set
public:
property String^ Year {
    String^ get ();
    void set (String^ value);
}


Year1 Property

Year1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTC ► Year1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Year1 { get; set; }
Public Property Year1 As String
    Get
    Set
public:
property String^ Year1 {
    String^ get ();
    void set (String^ value);
}


CTP Class

CTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP
RDPCrystal EDI Library
Pricing Information
Declaration Syntax
C# Visual Basic Visual C++
public class CTP : DocumentSegment
Public Class CTP _
    Inherits DocumentSegment
public ref class CTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTP()()()() | Initializes a new instance of the CTP class
 | BasisOfUnitPriceCode | Element 9
 | ClassOfTradeCode | Element 1
 | CompositeUnitOfMeasure | Element 5
 | ConditionValue | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | MultiplePriceQuantity | Element 11
 | Multiplier | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceIdentifierCode | Element 2
 | PriceMultiplierQualifier | Element 6
 | Quantity | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTP


CTP Constructor

CTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► CTP()()()()
RDPCrystal EDI Library
Initializes a new instance of the CTP class
Declaration Syntax
C# Visual Basic Visual C++
public CTP()
Public Sub New
public:
CTP()


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► ClassOfTradeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ConditionValue Property

ConditionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► ConditionValue
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue { get; set; }
Public Property ConditionValue As String
    Get
    Set
public:
property String^ ConditionValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MultiplePriceQuantity Property

MultiplePriceQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► MultiplePriceQuantity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MultiplePriceQuantity { get; set; }
Public Property MultiplePriceQuantity As String
    Get
    Set
public:
property String^ MultiplePriceQuantity {
    String^ get ();
    void set (String^ value);
}


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► Multiplier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► PriceIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


PriceMultiplierQualifier Property

PriceMultiplierQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► PriceMultiplierQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PriceMultiplierQualifier { get; set; }
Public Property PriceMultiplierQualifier As String
    Get
    Set
public:
property String^ PriceMultiplierQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► UnitPrice
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CTT Class

CTT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT
RDPCrystal EDI Library
Transaction Totals
Declaration Syntax
C# Visual Basic Visual C++
public class CTT : DocumentSegment
Public Class CTT _
    Inherits DocumentSegment
public ref class CTT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTT()()()() | Initializes a new instance of the CTT class
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HashTotal | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfLineItems | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | UnitOrBasisForMeasurementCode1 | Element 6
 | Volume | Element 5
 | Weight | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTT


CTT Constructor

CTT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► CTT()()()()
RDPCrystal EDI Library
Initializes a new instance of the CTT class
Declaration Syntax
C# Visual Basic Visual C++
public CTT()
Public Sub New
public:
CTT()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


HashTotal Property

HashTotal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► HashTotal
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HashTotal { get; set; }
Public Property HashTotal As String
    Get
    Set
public:
property String^ HashTotal {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfLineItems Property

NumberOfLineItems Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► NumberOfLineItems
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfLineItems { get; set; }
Public Property NumberOfLineItems As String
    Get
    Set
public:
property String^ NumberOfLineItems {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► Volume
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CTT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CUR Class

CUR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR
RDPCrystal EDI Library
Currency
Declaration Syntax
C# Visual Basic Visual C++
public class CUR : DocumentSegment
Public Class CUR _
    Inherits DocumentSegment
public ref class CUR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CUR()()()() | Initializes a new instance of the CUR class
 | CurrencyCode | Element 2
 | CurrencyCode1 | Element 5
 | CurrencyMarketExchangeCode | Element 6
 | Date | Element 8
 | Date1 | Element 11
 | Date2 | Element 14
 | Date3 | Element 17
 | Date4 | Element 20
 | DateTimeQualifier | Element 7
 | DateTimeQualifier1 | Element 10
 | DateTimeQualifier2 | Element 13
 | DateTimeQualifier3 | Element 16
 | DateTimeQualifier4 | Element 19
 | EntityIdentifierCode | Element 1
 | EntityIdentifierCode1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExchangeRate | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 9
 | Time1 | Element 12
 | Time2 | Element 15
 | Time3 | Element 18
 | Time4 | Element 21
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CUR


CUR Constructor

CUR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► CUR()()()()
RDPCrystal EDI Library
Initializes a new instance of the CUR class
Declaration Syntax
C# Visual Basic Visual C++
public CUR()
Public Sub New
public:
CUR()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► CurrencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


CurrencyCode1 Property

CurrencyCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► CurrencyCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode1 { get; set; }
Public Property CurrencyCode1 As String
    Get
    Set
public:
property String^ CurrencyCode1 {
    String^ get ();
    void set (String^ value);
}


CurrencyMarketExchangeCode Property

CurrencyMarketExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► CurrencyMarketExchangeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyMarketExchangeCode { get; set; }
Public Property CurrencyMarketExchangeCode As String
    Get
    Set
public:
property String^ CurrencyMarketExchangeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Date1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Date2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Date3
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


Date4 Property

Date4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Date4
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Date4 { get; set; }
Public Property Date4 As String
    Get
    Set
public:
property String^ Date4 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► DateTimeQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier1 Property

DateTimeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► DateTimeQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier1 { get; set; }
Public Property DateTimeQualifier1 As String
    Get
    Set
public:
property String^ DateTimeQualifier1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier2 Property

DateTimeQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► DateTimeQualifier2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier2 { get; set; }
Public Property DateTimeQualifier2 As String
    Get
    Set
public:
property String^ DateTimeQualifier2 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier3 Property

DateTimeQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► DateTimeQualifier3
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier3 { get; set; }
Public Property DateTimeQualifier3 As String
    Get
    Set
public:
property String^ DateTimeQualifier3 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier4 Property

DateTimeQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► DateTimeQualifier4
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier4 { get; set; }
Public Property DateTimeQualifier4 As String
    Get
    Set
public:
property String^ DateTimeQualifier4 {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► EntityIdentifierCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


ExchangeRate Property

ExchangeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► ExchangeRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ExchangeRate { get; set; }
Public Property ExchangeRate As String
    Get
    Set
public:
property String^ ExchangeRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Time
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Time1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


Time2 Property

Time2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Time2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Time2 { get; set; }
Public Property Time2 As String
    Get
    Set
public:
property String^ Time2 {
    String^ get ();
    void set (String^ value);
}


Time3 Property

Time3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Time3
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Time3 { get; set; }
Public Property Time3 As String
    Get
    Set
public:
property String^ Time3 {
    String^ get ();
    void set (String^ value);
}


Time4 Property

Time4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Time4
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Time4 { get; set; }
Public Property Time4 As String
    Get
    Set
public:
property String^ Time4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CUR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CV Class

CV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV
RDPCrystal EDI Library
Cycle/Summary Value
Declaration Syntax
C# Visual Basic Visual C++
public class CV : DocumentSegment
Public Class CV _
    Inherits DocumentSegment
public ref class CV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CV()()()() | Initializes a new instance of the CV class
 | CarTypeGroupCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MileageSettlementCode | Element 6
 | MonetaryAmount | Element 9
 | MonetaryAmount1 | Element 10
 | MonetaryAmount2 | Element 11
 | MonetaryAmount3 | Element 12
 | MonetaryAmount4 | Element 13
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentActionCode | Element 2
 | PenaltyCode | Element 14
 | Quantity | Element 5
 | Quantity1 | Element 7
 | Quantity2 | Element 8
 | TimePeriodQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CV


CV Constructor

CV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► CV()()()()
RDPCrystal EDI Library
Initializes a new instance of the CV class
Declaration Syntax
C# Visual Basic Visual C++
public CV()
Public Sub New
public:
CV()


CarTypeGroupCode Property

CarTypeGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► CarTypeGroupCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeGroupCode { get; set; }
Public Property CarTypeGroupCode As String
    Get
    Set
public:
property String^ CarTypeGroupCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


MileageSettlementCode Property

MileageSettlementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► MileageSettlementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MileageSettlementCode { get; set; }
Public Property MileageSettlementCode As String
    Get
    Set
public:
property String^ MileageSettlementCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► MonetaryAmount
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► MonetaryAmount1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► MonetaryAmount2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► MonetaryAmount3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► MonetaryAmount4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


PaymentActionCode Property

PaymentActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► PaymentActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentActionCode { get; set; }
Public Property PaymentActionCode As String
    Get
    Set
public:
property String^ PaymentActionCode {
    String^ get ();
    void set (String^ value);
}


PenaltyCode Property

PenaltyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► PenaltyCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PenaltyCode { get; set; }
Public Property PenaltyCode As String
    Get
    Set
public:
property String^ PenaltyCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► Quantity2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► TimePeriodQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


CYC Class

CYC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC
RDPCrystal EDI Library
Car Hire Cycle
Declaration Syntax
C# Visual Basic Visual C++
public class CYC : DocumentSegment
Public Class CYC _
    Inherits DocumentSegment
public ref class CYC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CYC()()()() | Initializes a new instance of the CYC class
 | AARPoolCode | Element 6
 | CycleMonthHours | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonthOfTheYearCode | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 5
 | StandardPointLocationCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | Year | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CYC


CYC Constructor

CYC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► CYC()()()()
RDPCrystal EDI Library
Initializes a new instance of the CYC class
Declaration Syntax
C# Visual Basic Visual C++
public CYC()
Public Sub New
public:
CYC()


AARPoolCode Property

AARPoolCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► AARPoolCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AARPoolCode { get; set; }
Public Property AARPoolCode As String
    Get
    Set
public:
property String^ AARPoolCode {
    String^ get ();
    void set (String^ value);
}


CycleMonthHours Property

CycleMonthHours Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► CycleMonthHours
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CycleMonthHours { get; set; }
Public Property CycleMonthHours As String
    Get
    Set
public:
property String^ CycleMonthHours {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonthOfTheYearCode Property

MonthOfTheYearCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► MonthOfTheYearCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonthOfTheYearCode { get; set; }
Public Property MonthOfTheYearCode As String
    Get
    Set
public:
property String^ MonthOfTheYearCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Year Property

Year Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► CYC ► Year
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Year { get; set; }
Public Property Year As String
    Get
    Set
public:
property String^ Year {
    String^ get ();
    void set (String^ value);
}


D9 Class

D9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9
RDPCrystal EDI Library
Destination Station
Declaration Syntax
C# Visual Basic Visual C++
public class D9 : DocumentSegment
Public Class D9 _
    Inherits DocumentSegment
public ref class D9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | D9()()()() | Initializes a new instance of the D9 class
 | CityName | Element 2
 | CityName1 | Element 6
 | CountryCode | Element 4
 | CountryCode1 | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 1
 | FreightStationAccountingCode1 | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 9
 | PostalCode1 | Element 11
 | StandardPointLocationCode | Element 8
 | StandardPointLocationCode1 | Element 10
 | StateOrProvinceCode | Element 3
 | StateOrProvinceCode1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | D9


D9 Constructor

D9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► D9()()()()
RDPCrystal EDI Library
Initializes a new instance of the D9 class
Declaration Syntax
C# Visual Basic Visual C++
public D9()
Public Sub New
public:
D9()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► CityName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► CityName1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountryCode1 Property

CountryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► CountryCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode1 { get; set; }
Public Property CountryCode1 As String
    Get
    Set
public:
property String^ CountryCode1 {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode1 Property

FreightStationAccountingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► FreightStationAccountingCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode1 { get; set; }
Public Property FreightStationAccountingCode1 As String
    Get
    Set
public:
property String^ FreightStationAccountingCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► PostalCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


PostalCode1 Property

PostalCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► PostalCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode1 { get; set; }
Public Property PostalCode1 As String
    Get
    Set
public:
property String^ PostalCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► D9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DAD Class

DAD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD
RDPCrystal EDI Library
Debit Authorization Detail
Declaration Syntax
C# Visual Basic Visual C++
public class DAD : DocumentSegment
Public Class DAD _
    Inherits DocumentSegment
public ref class DAD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DAD()()()() | Initializes a new instance of the DAD class
 | AccountNumber | Element 13
 | ActionCode | Element 1
 | AmountQualifierCode | Element 7
 | Date | Element 3
 | Date1 | Element 4
 | DFIIdentificationNumber | Element 12
 | DFIIDNumberQualifier | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 15
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 14
 | OriginatingCompanyIdentifier | Element 5
 | OriginatingCompanySupplementalCode | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 9
 | ReferenceIdentification1 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DAD


DAD Constructor

DAD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► DAD()()()()
RDPCrystal EDI Library
Initializes a new instance of the DAD class
Declaration Syntax
C# Visual Basic Visual C++
public DAD()
Public Sub New
public:
DAD()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► AccountNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► AmountQualifierCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► FrequencyCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► Number
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► OriginatingCompanyIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}


OriginatingCompanySupplementalCode Property

OriginatingCompanySupplementalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► OriginatingCompanySupplementalCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanySupplementalCode { get; set; }
Public Property OriginatingCompanySupplementalCode As String
    Get
    Set
public:
property String^ OriginatingCompanySupplementalCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► ReferenceIdentification1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► TransactionHandlingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DAI Class

DAI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI
RDPCrystal EDI Library
Appendix Information
Declaration Syntax
C# Visual Basic Visual C++
public class DAI : DocumentSegment
Public Class DAI _
    Inherits DocumentSegment
public ref class DAI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DAI()()()() | Initializes a new instance of the DAI class
 | CodeListReference | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DAI


DAI Constructor

DAI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI ► DAI()()()()
RDPCrystal EDI Library
Initializes a new instance of the DAI class
Declaration Syntax
C# Visual Basic Visual C++
public DAI()
Public Sub New
public:
DAI()


CodeListReference Property

CodeListReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI ► CodeListReference
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListReference { get; set; }
Public Property CodeListReference As String
    Get
    Set
public:
property String^ CodeListReference {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DAM Class

DAM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM
RDPCrystal EDI Library
Damage Information
Declaration Syntax
C# Visual Basic Visual C++
public class DAM : DocumentSegment
Public Class DAM _
    Inherits DocumentSegment
public ref class DAM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DAM()()()() | Initializes a new instance of the DAM class
 | Amount | Element 3
 | Amount1 | Element 7
 | Amount2 | Element 10
 | Amount3 | Element 13
 | Amount4 | Element 16
 | CurrencyCode | Element 4
 | DamageAreaCode | Element 2
 | DamageAreaCode1 | Element 6
 | DamageAreaCode2 | Element 9
 | DamageAreaCode3 | Element 12
 | DamageAreaCode4 | Element 15
 | DamageStatusCode | Element 1
 | DamageStatusCode1 | Element 5
 | DamageStatusCode2 | Element 8
 | DamageStatusCode3 | Element 11
 | DamageStatusCode4 | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DAM


DAM Constructor

DAM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DAM()()()()
RDPCrystal EDI Library
Initializes a new instance of the DAM class
Declaration Syntax
C# Visual Basic Visual C++
public DAM()
Public Sub New
public:
DAM()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Amount1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Amount2 Property

Amount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Amount2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Amount2 { get; set; }
Public Property Amount2 As String
    Get
    Set
public:
property String^ Amount2 {
    String^ get ();
    void set (String^ value);
}


Amount3 Property

Amount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Amount3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Amount3 { get; set; }
Public Property Amount3 As String
    Get
    Set
public:
property String^ Amount3 {
    String^ get ();
    void set (String^ value);
}


Amount4 Property

Amount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Amount4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Amount4 { get; set; }
Public Property Amount4 As String
    Get
    Set
public:
property String^ Amount4 {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► CurrencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode Property

DamageAreaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageAreaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode { get; set; }
Public Property DamageAreaCode As String
    Get
    Set
public:
property String^ DamageAreaCode {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode1 Property

DamageAreaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageAreaCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode1 { get; set; }
Public Property DamageAreaCode1 As String
    Get
    Set
public:
property String^ DamageAreaCode1 {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode2 Property

DamageAreaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageAreaCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode2 { get; set; }
Public Property DamageAreaCode2 As String
    Get
    Set
public:
property String^ DamageAreaCode2 {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode3 Property

DamageAreaCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageAreaCode3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode3 { get; set; }
Public Property DamageAreaCode3 As String
    Get
    Set
public:
property String^ DamageAreaCode3 {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode4 Property

DamageAreaCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageAreaCode4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode4 { get; set; }
Public Property DamageAreaCode4 As String
    Get
    Set
public:
property String^ DamageAreaCode4 {
    String^ get ();
    void set (String^ value);
}


DamageStatusCode Property

DamageStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DamageStatusCode { get; set; }
Public Property DamageStatusCode As String
    Get
    Set
public:
property String^ DamageStatusCode {
    String^ get ();
    void set (String^ value);
}


DamageStatusCode1 Property

DamageStatusCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageStatusCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DamageStatusCode1 { get; set; }
Public Property DamageStatusCode1 As String
    Get
    Set
public:
property String^ DamageStatusCode1 {
    String^ get ();
    void set (String^ value);
}


DamageStatusCode2 Property

DamageStatusCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageStatusCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DamageStatusCode2 { get; set; }
Public Property DamageStatusCode2 As String
    Get
    Set
public:
property String^ DamageStatusCode2 {
    String^ get ();
    void set (String^ value);
}


DamageStatusCode3 Property

DamageStatusCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageStatusCode3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DamageStatusCode3 { get; set; }
Public Property DamageStatusCode3 As String
    Get
    Set
public:
property String^ DamageStatusCode3 {
    String^ get ();
    void set (String^ value);
}


DamageStatusCode4 Property

DamageStatusCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► DamageStatusCode4
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DamageStatusCode4 { get; set; }
Public Property DamageStatusCode4 As String
    Get
    Set
public:
property String^ DamageStatusCode4 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DAM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DB Class

DB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB
RDPCrystal EDI Library
Disbursement Information
Declaration Syntax
C# Visual Basic Visual C++
public class DB : DocumentSegment
Public Class DB _
    Inherits DocumentSegment
public ref class DB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DB()()()() | Initializes a new instance of the DB class
 | DateTimePeriod | Element 2
 | DateTimePeriodFormatQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DB


DB Constructor

DB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► DB()()()()
RDPCrystal EDI Library
Initializes a new instance of the DB class
Declaration Syntax
C# Visual Basic Visual C++
public DB()
Public Sub New
public:
DB()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► DateTimePeriod
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DB ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


DD Class

DD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD
RDPCrystal EDI Library
Demand Detail
Declaration Syntax
C# Visual Basic Visual C++
public class DD : DocumentSegment
Public Class DD _
    Inherits DocumentSegment
public ref class DD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DD()()()() | Initializes a new instance of the DD class
 | CodeListQualifierCode | Element 2
 | CodeListQualifierCode1 | Element 6
 | CodeListQualifierCode2 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 1
 | IndustryCode1 | Element 5
 | IndustryCode2 | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 7
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DD


DD Constructor

DD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► DD()()()()
RDPCrystal EDI Library
Initializes a new instance of the DD class
Declaration Syntax
C# Visual Basic Visual C++
public DD()
Public Sub New
public:
DD()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► CodeListQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


CodeListQualifierCode1 Property

CodeListQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► CodeListQualifierCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode1 { get; set; }
Public Property CodeListQualifierCode1 As String
    Get
    Set
public:
property String^ CodeListQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


CodeListQualifierCode2 Property

CodeListQualifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► CodeListQualifierCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode2 { get; set; }
Public Property CodeListQualifierCode2 As String
    Get
    Set
public:
property String^ CodeListQualifierCode2 {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► IndustryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► IndustryCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► IndustryCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DD ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


DDI Class

DDI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DDI
RDPCrystal EDI Library
Description
Declaration Syntax
C# Visual Basic Visual C++
public class DDI : DocumentSegment
Public Class DDI _
    Inherits DocumentSegment
public ref class DDI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DDI()()()() | Initializes a new instance of the DDI class
 | Description | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DDI


DDI Constructor

DDI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DDI ► DDI()()()()
RDPCrystal EDI Library
Initializes a new instance of the DDI class
Declaration Syntax
C# Visual Basic Visual C++
public DDI()
Public Sub New
public:
DDI()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DDI ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DDI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DDI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DED Class

DED Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED
RDPCrystal EDI Library
Deductions
Declaration Syntax
C# Visual Basic Visual C++
public class DED : DocumentSegment
Public Class DED _
    Inherits DocumentSegment
public ref class DED : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DED()()()() | Initializes a new instance of the DED class
 | Amount | Element 4
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 5
 | ReferenceIdentification2 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfDeduction | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DED


DED Constructor

DED Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► DED()()()()
RDPCrystal EDI Library
Initializes a new instance of the DED class
Declaration Syntax
C# Visual Basic Visual C++
public DED()
Public Sub New
public:
DED()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► Name1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► ReferenceIdentification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► ReferenceIdentification2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


TypeOfDeduction Property

TypeOfDeduction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► TypeOfDeduction
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfDeduction { get; set; }
Public Property TypeOfDeduction As String
    Get
    Set
public:
property String^ TypeOfDeduction {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DED ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


DEF Class

DEF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF
RDPCrystal EDI Library
Delayed Repayment
Declaration Syntax
C# Visual Basic Visual C++
public class DEF : DocumentSegment
Public Class DEF _
    Inherits DocumentSegment
public ref class DEF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DEF()()()() | Initializes a new instance of the DEF class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | DelayedRepaymentQualifierCode | Element 1
 | DelayedRepaymentReasonCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestPaymentCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DEF


DEF Constructor

DEF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► DEF()()()()
RDPCrystal EDI Library
Initializes a new instance of the DEF class
Declaration Syntax
C# Visual Basic Visual C++
public DEF()
Public Sub New
public:
DEF()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DelayedRepaymentQualifierCode Property

DelayedRepaymentQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► DelayedRepaymentQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DelayedRepaymentQualifierCode { get; set; }
Public Property DelayedRepaymentQualifierCode As String
    Get
    Set
public:
property String^ DelayedRepaymentQualifierCode {
    String^ get ();
    void set (String^ value);
}


DelayedRepaymentReasonCode Property

DelayedRepaymentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► DelayedRepaymentReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DelayedRepaymentReasonCode { get; set; }
Public Property DelayedRepaymentReasonCode As String
    Get
    Set
public:
property String^ DelayedRepaymentReasonCode {
    String^ get ();
    void set (String^ value);
}


InterestPaymentCode Property

InterestPaymentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► InterestPaymentCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterestPaymentCode { get; set; }
Public Property InterestPaymentCode As String
    Get
    Set
public:
property String^ InterestPaymentCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DEG Class

DEG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG
RDPCrystal EDI Library
Degree Record
Declaration Syntax
C# Visual Basic Visual C++
public class DEG : DocumentSegment
Public Class DEG _
    Inherits DocumentSegment
public ref class DEG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DEG()()()() | Initializes a new instance of the DEG class
 | AcademicDegreeCode | Element 1
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DEG


DEG Constructor

DEG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► DEG()()()()
RDPCrystal EDI Library
Initializes a new instance of the DEG class
Declaration Syntax
C# Visual Basic Visual C++
public DEG()
Public Sub New
public:
DEG()


AcademicDegreeCode Property

AcademicDegreeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► AcademicDegreeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicDegreeCode { get; set; }
Public Property AcademicDegreeCode As String
    Get
    Set
public:
property String^ AcademicDegreeCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► StatusReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DEL Class

DEL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL
RDPCrystal EDI Library
Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class DEL : DocumentSegment
Public Class DEL _
    Inherits DocumentSegment
public ref class DEL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DEL()()()() | Initializes a new instance of the DEL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | InvoiceNumber | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTypeCode | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DEL


DEL Constructor

DEL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► DEL()()()()
RDPCrystal EDI Library
Initializes a new instance of the DEL class
Declaration Syntax
C# Visual Basic Visual C++
public DEL()
Public Sub New
public:
DEL()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► InvoiceNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MoveTypeCode Property

MoveTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► MoveTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MoveTypeCode { get; set; }
Public Property MoveTypeCode As String
    Get
    Set
public:
property String^ MoveTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DEP Class

DEP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP
RDPCrystal EDI Library
Deposit
Declaration Syntax
C# Visual Basic Visual C++
public class DEP : DocumentSegment
Public Class DEP _
    Inherits DocumentSegment
public ref class DEP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DEP()()()() | Initializes a new instance of the DEP class
 | AccountNumber | Element 8
 | AccountNumberQualifier | Element 7
 | Date | Element 2
 | DFIIdentificationNumber | Element 6
 | DFIIDNumberQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 4
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DEP


DEP Constructor

DEP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► DEP()()()()
RDPCrystal EDI Library
Initializes a new instance of the DEP class
Declaration Syntax
C# Visual Basic Visual C++
public DEP()
Public Sub New
public:
DEP()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► AccountNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► AccountNumberQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DEX Class

DEX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX
RDPCrystal EDI Library
Delivery Execution Information
Declaration Syntax
C# Visual Basic Visual C++
public class DEX : DocumentSegment
Public Class DEX _
    Inherits DocumentSegment
public ref class DEX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DEX()()()() | Initializes a new instance of the DEX class
 | CodeListQualifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 6
 | InvestorOwnershipTypeCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RemittanceTypeCode | Element 2
 | SalesTermsCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DEX


DEX Constructor

DEX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► DEX()()()()
RDPCrystal EDI Library
Initializes a new instance of the DEX class
Declaration Syntax
C# Visual Basic Visual C++
public DEX()
Public Sub New
public:
DEX()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► CodeListQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► IndustryCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


InvestorOwnershipTypeCode Property

InvestorOwnershipTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► InvestorOwnershipTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InvestorOwnershipTypeCode { get; set; }
Public Property InvestorOwnershipTypeCode As String
    Get
    Set
public:
property String^ InvestorOwnershipTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► Number
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


RemittanceTypeCode Property

RemittanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► RemittanceTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RemittanceTypeCode { get; set; }
Public Property RemittanceTypeCode As String
    Get
    Set
public:
property String^ RemittanceTypeCode {
    String^ get ();
    void set (String^ value);
}


SalesTermsCode Property

SalesTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► SalesTermsCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SalesTermsCode { get; set; }
Public Property SalesTermsCode As String
    Get
    Set
public:
property String^ SalesTermsCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DEX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DFI Class

DFI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI
RDPCrystal EDI Library
Default Information
Declaration Syntax
C# Visual Basic Visual C++
public class DFI : DocumentSegment
Public Class DFI _
    Inherits DocumentSegment
public ref class DFI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DFI()()()() | Initializes a new instance of the DFI class
 | ClaimFilingIndicatorCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
 | YesNoConditionOrResponseCode1 | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DFI


DFI Constructor

DFI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► DFI()()()()
RDPCrystal EDI Library
Initializes a new instance of the DFI class
Declaration Syntax
C# Visual Basic Visual C++
public DFI()
Public Sub New
public:
DFI()


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► StatusReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DFI ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


DH Class

DH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH
RDPCrystal EDI Library
Dealer Hours
Declaration Syntax
C# Visual Basic Visual C++
public class DH : DocumentSegment
Public Class DH _
    Inherits DocumentSegment
public ref class DH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DH()()()() | Initializes a new instance of the DH class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipDeliveryOrCalendarPatternCode | Element 1
 | Time | Element 2
 | Time1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DH


DH Constructor

DH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH ► DH()()()()
RDPCrystal EDI Library
Initializes a new instance of the DH class
Declaration Syntax
C# Visual Basic Visual C++
public DH()
Public Sub New
public:
DH()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH ► Time
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH ► Time1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DIS Class

DIS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS
RDPCrystal EDI Library
Discount Detail
Declaration Syntax
C# Visual Basic Visual C++
public class DIS : DocumentSegment
Public Class DIS _
    Inherits DocumentSegment
public ref class DIS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DIS()()()() | Initializes a new instance of the DIS class
 | DiscountBaseQualifier | Element 2
 | DiscountBaseValue | Element 3
 | DiscountControlLimit | Element 5
 | DiscountControlLimit1 | Element 6
 | DiscountControlLimitQualifier | Element 4
 | DiscountTermsTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DIS


DIS Constructor

DIS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DIS()()()()
RDPCrystal EDI Library
Initializes a new instance of the DIS class
Declaration Syntax
C# Visual Basic Visual C++
public DIS()
Public Sub New
public:
DIS()


DiscountBaseQualifier Property

DiscountBaseQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DiscountBaseQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountBaseQualifier { get; set; }
Public Property DiscountBaseQualifier As String
    Get
    Set
public:
property String^ DiscountBaseQualifier {
    String^ get ();
    void set (String^ value);
}


DiscountBaseValue Property

DiscountBaseValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DiscountBaseValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountBaseValue { get; set; }
Public Property DiscountBaseValue As String
    Get
    Set
public:
property String^ DiscountBaseValue {
    String^ get ();
    void set (String^ value);
}


DiscountControlLimit Property

DiscountControlLimit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DiscountControlLimit
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountControlLimit { get; set; }
Public Property DiscountControlLimit As String
    Get
    Set
public:
property String^ DiscountControlLimit {
    String^ get ();
    void set (String^ value);
}


DiscountControlLimit1 Property

DiscountControlLimit1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DiscountControlLimit1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountControlLimit1 { get; set; }
Public Property DiscountControlLimit1 As String
    Get
    Set
public:
property String^ DiscountControlLimit1 {
    String^ get ();
    void set (String^ value);
}


DiscountControlLimitQualifier Property

DiscountControlLimitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DiscountControlLimitQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountControlLimitQualifier { get; set; }
Public Property DiscountControlLimitQualifier As String
    Get
    Set
public:
property String^ DiscountControlLimitQualifier {
    String^ get ();
    void set (String^ value);
}


DiscountTermsTypeCode Property

DiscountTermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► DiscountTermsTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountTermsTypeCode { get; set; }
Public Property DiscountTermsTypeCode As String
    Get
    Set
public:
property String^ DiscountTermsTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DIS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DK Class

DK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK
RDPCrystal EDI Library
Docket Header
Declaration Syntax
C# Visual Basic Visual C++
public class DK : DocumentSegment
Public Class DK _
    Inherits DocumentSegment
public ref class DK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DK()()()() | Initializes a new instance of the DK class
 | ApplicationType | Element 9
 | ConveyanceCode | Element 5
 | Date | Element 7
 | Date1 | Element 8
 | DocketControlNumber | Element 2
 | DocketIdentification | Element 3
 | DocketTypeCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupTitle | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RevisionNumber | Element 4
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DK


DK Constructor

DK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► DK()()()()
RDPCrystal EDI Library
Initializes a new instance of the DK class
Declaration Syntax
C# Visual Basic Visual C++
public DK()
Public Sub New
public:
DK()


ApplicationType Property

ApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► ApplicationType
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationType { get; set; }
Public Property ApplicationType As String
    Get
    Set
public:
property String^ ApplicationType {
    String^ get ();
    void set (String^ value);
}


ConveyanceCode Property

ConveyanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► ConveyanceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ConveyanceCode { get; set; }
Public Property ConveyanceCode As String
    Get
    Set
public:
property String^ ConveyanceCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► DocketControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► DocketIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


DocketTypeCode Property

DocketTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► DocketTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DocketTypeCode { get; set; }
Public Property DocketTypeCode As String
    Get
    Set
public:
property String^ DocketTypeCode {
    String^ get ();
    void set (String^ value);
}


GroupTitle Property

GroupTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► GroupTitle
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string GroupTitle { get; set; }
Public Property GroupTitle As String
    Get
    Set
public:
property String^ GroupTitle {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RevisionNumber Property

RevisionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► RevisionNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; set; }
Public Property RevisionNumber As String
    Get
    Set
public:
property String^ RevisionNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DL Class

DL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL
RDPCrystal EDI Library
Auto Claim Detail - Labor
Declaration Syntax
C# Visual Basic Visual C++
public class DL : DocumentSegment
Public Class DL _
    Inherits DocumentSegment
public ref class DL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DL()()()() | Initializes a new instance of the DL class
 | ActionCode | Element 1
 | Amount | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LaborHours | Element 2
 | LaborHours1 | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 6
 | Number1 | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
 | YesNoConditionOrResponseCode1 | Element 8
 | YesNoConditionOrResponseCode2 | Element 9
 | YesNoConditionOrResponseCode3 | Element 10
 | YesNoConditionOrResponseCode4 | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DL


DL Constructor

DL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► DL()()()()
RDPCrystal EDI Library
Initializes a new instance of the DL class
Declaration Syntax
C# Visual Basic Visual C++
public DL()
Public Sub New
public:
DL()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


LaborHours Property

LaborHours Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► LaborHours
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LaborHours { get; set; }
Public Property LaborHours As String
    Get
    Set
public:
property String^ LaborHours {
    String^ get ();
    void set (String^ value);
}


LaborHours1 Property

LaborHours1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► LaborHours1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LaborHours1 { get; set; }
Public Property LaborHours1 As String
    Get
    Set
public:
property String^ LaborHours1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► Number
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► Number1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DL ► YesNoConditionOrResponseCode4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}


DLV Class

DLV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV
RDPCrystal EDI Library
Deliverable Information
Declaration Syntax
C# Visual Basic Visual C++
public class DLV : DocumentSegment
Public Class DLV _
    Inherits DocumentSegment
public ref class DLV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DLV()()()() | Initializes a new instance of the DLV class
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceIDQualifier | Element 2
 | ProgramTypeCode | Element 4
 | QuantityOrdered | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DLV


DLV Constructor

DLV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► DLV()()()()
RDPCrystal EDI Library
Initializes a new instance of the DLV class
Declaration Syntax
C# Visual Basic Visual C++
public DLV()
Public Sub New
public:
DLV()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProgramTypeCode Property

ProgramTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► ProgramTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramTypeCode { get; set; }
Public Property ProgramTypeCode As String
    Get
    Set
public:
property String^ ProgramTypeCode {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► QuantityOrdered
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DLV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DM Class

DM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM
RDPCrystal EDI Library
Demurrage/Detention/ Storage Rate
Declaration Syntax
C# Visual Basic Visual C++
public class DM : DocumentSegment
Public Class DM _
    Inherits DocumentSegment
public ref class DM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DM()()()() | Initializes a new instance of the DM class
 | BillingCode | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeographyQualifierCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermodalServiceCode | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 5
 | NumberOfPeriods1 | Element 7
 | NumberOfPeriods2 | Element 13
 | NumberOfPeriods3 | Element 14
 | NumberOfPeriods4 | Element 16
 | NumberOfPeriods5 | Element 18
 | NumberOfPeriods6 | Element 20
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rate | Element 8
 | Rate1 | Element 15
 | Rate2 | Element 17
 | Rate3 | Element 19
 | Rate4 | Element 21
 | RateValueQualifier | Element 2
 | TariffApplicationCode | Element 10
 | Time | Element 4
 | TimePeriodQualifier | Element 6
 | TimePeriodQualifier1 | Element 12
 | TimeQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DM


DM Constructor

DM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► DM()()()()
RDPCrystal EDI Library
Initializes a new instance of the DM class
Declaration Syntax
C# Visual Basic Visual C++
public DM()
Public Sub New
public:
DM()


BillingCode Property

BillingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► BillingCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string BillingCode { get; set; }
Public Property BillingCode As String
    Get
    Set
public:
property String^ BillingCode {
    String^ get ();
    void set (String^ value);
}


GeographyQualifierCode Property

GeographyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► GeographyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string GeographyQualifierCode { get; set; }
Public Property GeographyQualifierCode As String
    Get
    Set
public:
property String^ GeographyQualifierCode {
    String^ get ();
    void set (String^ value);
}


IntermodalServiceCode Property

IntermodalServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► IntermodalServiceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalServiceCode { get; set; }
Public Property IntermodalServiceCode As String
    Get
    Set
public:
property String^ IntermodalServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods1 Property

NumberOfPeriods1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods1 { get; set; }
Public Property NumberOfPeriods1 As String
    Get
    Set
public:
property String^ NumberOfPeriods1 {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods2 Property

NumberOfPeriods2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods2 { get; set; }
Public Property NumberOfPeriods2 As String
    Get
    Set
public:
property String^ NumberOfPeriods2 {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods3 Property

NumberOfPeriods3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods3 { get; set; }
Public Property NumberOfPeriods3 As String
    Get
    Set
public:
property String^ NumberOfPeriods3 {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods4 Property

NumberOfPeriods4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods4 { get; set; }
Public Property NumberOfPeriods4 As String
    Get
    Set
public:
property String^ NumberOfPeriods4 {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods5 Property

NumberOfPeriods5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods5
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods5 { get; set; }
Public Property NumberOfPeriods5 As String
    Get
    Set
public:
property String^ NumberOfPeriods5 {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods6 Property

NumberOfPeriods6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► NumberOfPeriods6
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods6 { get; set; }
Public Property NumberOfPeriods6 As String
    Get
    Set
public:
property String^ NumberOfPeriods6 {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Rate
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


Rate1 Property

Rate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Rate1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Rate1 { get; set; }
Public Property Rate1 As String
    Get
    Set
public:
property String^ Rate1 {
    String^ get ();
    void set (String^ value);
}


Rate2 Property

Rate2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Rate2
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Rate2 { get; set; }
Public Property Rate2 As String
    Get
    Set
public:
property String^ Rate2 {
    String^ get ();
    void set (String^ value);
}


Rate3 Property

Rate3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Rate3
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Rate3 { get; set; }
Public Property Rate3 As String
    Get
    Set
public:
property String^ Rate3 {
    String^ get ();
    void set (String^ value);
}


Rate4 Property

Rate4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Rate4
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Rate4 { get; set; }
Public Property Rate4 As String
    Get
    Set
public:
property String^ Rate4 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode Property

TariffApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► TariffApplicationCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode { get; set; }
Public Property TariffApplicationCode As String
    Get
    Set
public:
property String^ TariffApplicationCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► TimePeriodQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier1 Property

TimePeriodQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► TimePeriodQualifier1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier1 { get; set; }
Public Property TimePeriodQualifier1 As String
    Get
    Set
public:
property String^ TimePeriodQualifier1 {
    String^ get ();
    void set (String^ value);
}


TimeQualifier Property

TimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► TimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TimeQualifier { get; set; }
Public Property TimeQualifier As String
    Get
    Set
public:
property String^ TimeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DMA Class

DMA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA
RDPCrystal EDI Library
Additional Demographic Information
Declaration Syntax
C# Visual Basic Visual C++
public class DMA : DocumentSegment
Public Class DMA _
    Inherits DocumentSegment
public ref class DMA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DMA()()()() | Initializes a new instance of the DMA class
 | ApplicantTypeCode | Element 5
 | CountryCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LanguageCode | Element 8
 | LicensingAgencyCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 3
 | StateOrProvinceCode | Element 2
 | StateOrProvinceCode1 | Element 4
 | StatusCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DMA


DMA Constructor

DMA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► DMA()()()()
RDPCrystal EDI Library
Initializes a new instance of the DMA class
Declaration Syntax
C# Visual Basic Visual C++
public DMA()
Public Sub New
public:
DMA()


ApplicantTypeCode Property

ApplicantTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► ApplicantTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicantTypeCode { get; set; }
Public Property ApplicantTypeCode As String
    Get
    Set
public:
property String^ ApplicantTypeCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► LanguageCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


LicensingAgencyCode Property

LicensingAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► LicensingAgencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LicensingAgencyCode { get; set; }
Public Property LicensingAgencyCode As String
    Get
    Set
public:
property String^ LicensingAgencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► StatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DMG Class

DMG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG
RDPCrystal EDI Library
Demographic Information
Declaration Syntax
C# Visual Basic Visual C++
public class DMG : DocumentSegment
Public Class DMG _
    Inherits DocumentSegment
public ref class DMG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DMG()()()() | Initializes a new instance of the DMG class
 | BasisOfVerificationCode | Element 8
 | CitizenshipStatusCode | Element 6
 | CountryCode | Element 7
 | DateTimePeriod | Element 2
 | DateTimePeriodFormatQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaritalStatusCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 9
 | RaceOrEthnicityCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DMG


DMG Constructor

DMG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► DMG()()()()
RDPCrystal EDI Library
Initializes a new instance of the DMG class
Declaration Syntax
C# Visual Basic Visual C++
public DMG()
Public Sub New
public:
DMG()


BasisOfVerificationCode Property

BasisOfVerificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► BasisOfVerificationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfVerificationCode { get; set; }
Public Property BasisOfVerificationCode As String
    Get
    Set
public:
property String^ BasisOfVerificationCode {
    String^ get ();
    void set (String^ value);
}


CitizenshipStatusCode Property

CitizenshipStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► CitizenshipStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CitizenshipStatusCode { get; set; }
Public Property CitizenshipStatusCode As String
    Get
    Set
public:
property String^ CitizenshipStatusCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► DateTimePeriod
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► GenderCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaritalStatusCode Property

MaritalStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► MaritalStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MaritalStatusCode { get; set; }
Public Property MaritalStatusCode As String
    Get
    Set
public:
property String^ MaritalStatusCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► Quantity
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RaceOrEthnicityCode Property

RaceOrEthnicityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► RaceOrEthnicityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RaceOrEthnicityCode { get; set; }
Public Property RaceOrEthnicityCode As String
    Get
    Set
public:
property String^ RaceOrEthnicityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DMI Class

DMI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI
RDPCrystal EDI Library
Data Maintenance Information
Declaration Syntax
C# Visual Basic Visual C++
public class DMI : DocumentSegment
Public Class DMI _
    Inherits DocumentSegment
public ref class DMI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DMI()()()() | Initializes a new instance of the DMI class
 | AddressInformation | Element 4
 | AddressInformation1 | Element 5
 | CityName | Element 6
 | CommunicationNumber | Element 11
 | CommunicationNumberQualifier | Element 10
 | CountryCode | Element 9
 | DataMaintenanceNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | NoteIdentificationNumber | Element 12
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 8
 | StateOrProvinceCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DMI


DMI Constructor

DMI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► DMI()()()()
RDPCrystal EDI Library
Initializes a new instance of the DMI class
Declaration Syntax
C# Visual Basic Visual C++
public DMI()
Public Sub New
public:
DMI()


AddressInformation Property

AddressInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► AddressInformation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation { get; set; }
Public Property AddressInformation As String
    Get
    Set
public:
property String^ AddressInformation {
    String^ get ();
    void set (String^ value);
}


AddressInformation1 Property

AddressInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► AddressInformation1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation1 { get; set; }
Public Property AddressInformation1 As String
    Get
    Set
public:
property String^ AddressInformation1 {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► CityName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► CommunicationNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier Property

CommunicationNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► CommunicationNumberQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier { get; set; }
Public Property CommunicationNumberQualifier As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► CountryCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


DataMaintenanceNumber Property

DataMaintenanceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► DataMaintenanceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DataMaintenanceNumber { get; set; }
Public Property DataMaintenanceNumber As String
    Get
    Set
public:
property String^ DataMaintenanceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► PostalCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DMI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DN Class

DN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN
RDPCrystal EDI Library
Dealer Effectivity
Declaration Syntax
C# Visual Basic Visual C++
public class DN : DocumentSegment
Public Class DN _
    Inherits DocumentSegment
public ref class DN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN()()()() | Initializes a new instance of the DN class
 | Date | Element 2
 | DateQualifier | Element 1
 | DemandArea | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FinancialStatus | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN


DN Constructor

DN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► DN()()()()
RDPCrystal EDI Library
Initializes a new instance of the DN class
Declaration Syntax
C# Visual Basic Visual C++
public DN()
Public Sub New
public:
DN()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateQualifier Property

DateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► DateQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateQualifier { get; set; }
Public Property DateQualifier As String
    Get
    Set
public:
property String^ DateQualifier {
    String^ get ();
    void set (String^ value);
}


DemandArea Property

DemandArea Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► DemandArea
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DemandArea { get; set; }
Public Property DemandArea As String
    Get
    Set
public:
property String^ DemandArea {
    String^ get ();
    void set (String^ value);
}


FinancialStatus Property

FinancialStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► FinancialStatus
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FinancialStatus { get; set; }
Public Property FinancialStatus As String
    Get
    Set
public:
property String^ FinancialStatus {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DN1 Class

DN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1
RDPCrystal EDI Library
Orthodontic Information
Declaration Syntax
C# Visual Basic Visual C++
public class DN1 : DocumentSegment
Public Class DN1 _
    Inherits DocumentSegment
public ref class DN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN1()()()() | Initializes a new instance of the DN1 class
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | Quantity1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN1


DN1 Constructor

DN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► DN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the DN1 class
Declaration Syntax
C# Visual Basic Visual C++
public DN1()
Public Sub New
public:
DN1()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► Quantity1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN1 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


DN2 Class

DN2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2
RDPCrystal EDI Library
Tooth Summary
Declaration Syntax
C# Visual Basic Visual C++
public class DN2 : DocumentSegment
Public Class DN2 _
    Inherits DocumentSegment
public ref class DN2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN2()()()() | Initializes a new instance of the DN2 class
 | DateTimePeriod | Element 5
 | DateTimePeriodFormatQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | ReferenceIdentification | Element 1
 | ToothStatusCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN2


DN2 Constructor

DN2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► DN2()()()()
RDPCrystal EDI Library
Initializes a new instance of the DN2 class
Declaration Syntax
C# Visual Basic Visual C++
public DN2()
Public Sub New
public:
DN2()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► DateTimePeriod
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ToothStatusCode Property

ToothStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► ToothStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ToothStatusCode { get; set; }
Public Property ToothStatusCode As String
    Get
    Set
public:
property String^ ToothStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DN2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DOS Class

DOS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS
RDPCrystal EDI Library
Definition of Share
Declaration Syntax
C# Visual Basic Visual C++
public class DOS : DocumentSegment
Public Class DOS _
    Inherits DocumentSegment
public ref class DOS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DOS()()()() | Initializes a new instance of the DOS class
 | ContractTypeCode | Element 1
 | Description | Element 7
 | EntityIdentifierCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | Percent1 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DOS


DOS Constructor

DOS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► DOS()()()()
RDPCrystal EDI Library
Initializes a new instance of the DOS class
Declaration Syntax
C# Visual Basic Visual C++
public DOS()
Public Sub New
public:
DOS()


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► ContractTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► EntityIdentifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► Percent1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DOS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DP Class

DP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP
RDPCrystal EDI Library
Auto Claim Detail - Parts
Declaration Syntax
C# Visual Basic Visual C++
public class DP : DocumentSegment
Public Class DP _
    Inherits DocumentSegment
public ref class DP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DP()()()() | Initializes a new instance of the DP class
 | ActionCode | Element 1
 | AllowanceOrChargeTotalAmount | Element 15
 | Amount | Element 3
 | Amount1 | Element 4
 | ConditionIndicator | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 13
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 14
 | ProductServiceID | Element 2
 | ProductServiceID1 | Element 12
 | Quantity | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
 | YesNoConditionOrResponseCode1 | Element 7
 | YesNoConditionOrResponseCode2 | Element 8
 | YesNoConditionOrResponseCode3 | Element 9
 | YesNoConditionOrResponseCode4 | Element 10
 | YesNoConditionOrResponseCode5 | Element 16
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DP


DP Constructor

DP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► DP()()()()
RDPCrystal EDI Library
Initializes a new instance of the DP class
Declaration Syntax
C# Visual Basic Visual C++
public DP()
Public Sub New
public:
DP()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeTotalAmount Property

AllowanceOrChargeTotalAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► AllowanceOrChargeTotalAmount
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeTotalAmount { get; set; }
Public Property AllowanceOrChargeTotalAmount As String
    Get
    Set
public:
property String^ AllowanceOrChargeTotalAmount {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► Amount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► ConditionIndicator
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► FreeformDescription
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► Percent
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► ProductServiceID1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► Quantity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► YesNoConditionOrResponseCode4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode5 Property

YesNoConditionOrResponseCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DP ► YesNoConditionOrResponseCode5
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode5 { get; set; }
Public Property YesNoConditionOrResponseCode5 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode5 {
    String^ get ();
    void set (String^ value);
}


DPN Class

DPN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN
RDPCrystal EDI Library
Dependent Information
Declaration Syntax
C# Visual Basic Visual C++
public class DPN : DocumentSegment
Public Class DPN _
    Inherits DocumentSegment
public ref class DPN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DPN()()()() | Initializes a new instance of the DPN class
 | EmploymentStatusCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaritalStatusCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 1
 | Number1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DPN


DPN Constructor

DPN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► DPN()()()()
RDPCrystal EDI Library
Initializes a new instance of the DPN class
Declaration Syntax
C# Visual Basic Visual C++
public DPN()
Public Sub New
public:
DPN()


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► EmploymentStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaritalStatusCode Property

MaritalStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► MaritalStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MaritalStatusCode { get; set; }
Public Property MaritalStatusCode As String
    Get
    Set
public:
property String^ MaritalStatusCode {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► Number
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► Number1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DPN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DR Class

DR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR
RDPCrystal EDI Library
Docket Range
Declaration Syntax
C# Visual Basic Visual C++
public class DR : DocumentSegment
Public Class DR _
    Inherits DocumentSegment
public ref class DR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DR()()()() | Initializes a new instance of the DR class
 | Date | Element 1
 | DocketControlNumber | Element 3
 | DocketIdentification | Element 4
 | DocketIdentification1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RevisionNumber | Element 5
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DR


DR Constructor

DR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► DR()()()()
RDPCrystal EDI Library
Initializes a new instance of the DR class
Declaration Syntax
C# Visual Basic Visual C++
public DR()
Public Sub New
public:
DR()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► DocketControlNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► DocketIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


DocketIdentification1 Property

DocketIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► DocketIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification1 { get; set; }
Public Property DocketIdentification1 As String
    Get
    Set
public:
property String^ DocketIdentification1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RevisionNumber Property

RevisionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► RevisionNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; set; }
Public Property RevisionNumber As String
    Get
    Set
public:
property String^ RevisionNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DRT Class

DRT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT
RDPCrystal EDI Library
Deprescription Rate Detail
Declaration Syntax
C# Visual Basic Visual C++
public class DRT : DocumentSegment
Public Class DRT _
    Inherits DocumentSegment
public ref class DRT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DRT()()()() | Initializes a new instance of the DRT class
 | BilledRatedasQualifier | Element 2
 | ChangeTypeCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DRT


DRT Constructor

DRT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► DRT()()()()
RDPCrystal EDI Library
Initializes a new instance of the DRT class
Declaration Syntax
C# Visual Basic Visual C++
public DRT()
Public Sub New
public:
DRT()


BilledRatedasQualifier Property

BilledRatedasQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► BilledRatedasQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQualifier { get; set; }
Public Property BilledRatedasQualifier As String
    Get
    Set
public:
property String^ BilledRatedasQualifier {
    String^ get ();
    void set (String^ value);
}


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► ChangeTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DRT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


DSB Class

DSB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB
RDPCrystal EDI Library
Disability Information
Declaration Syntax
C# Visual Basic Visual C++
public class DSB : DocumentSegment
Public Class DSB _
    Inherits DocumentSegment
public ref class DSB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSB()()()() | Initializes a new instance of the DSB class
 | DisabilityTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalCodeValue | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductOptionCode | Element 5
 | ProductServiceIDQualifier | Element 7
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WorkIntensityCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DSB


DSB Constructor

DSB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► DSB()()()()
RDPCrystal EDI Library
Initializes a new instance of the DSB class
Declaration Syntax
C# Visual Basic Visual C++
public DSB()
Public Sub New
public:
DSB()


DisabilityTypeCode Property

DisabilityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► DisabilityTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DisabilityTypeCode { get; set; }
Public Property DisabilityTypeCode As String
    Get
    Set
public:
property String^ DisabilityTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MedicalCodeValue Property

MedicalCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► MedicalCodeValue
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue { get; set; }
Public Property MedicalCodeValue As String
    Get
    Set
public:
property String^ MedicalCodeValue {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► MonetaryAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► OccupationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode Property

ProductOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► ProductOptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode { get; set; }
Public Property ProductOptionCode As String
    Get
    Set
public:
property String^ ProductOptionCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


WorkIntensityCode Property

WorkIntensityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► WorkIntensityCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WorkIntensityCode { get; set; }
Public Property WorkIntensityCode As String
    Get
    Set
public:
property String^ WorkIntensityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DSB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DTM Class

DTM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM
RDPCrystal EDI Library
Date/Time Reference
Declaration Syntax
C# Visual Basic Visual C++
public class DTM : DocumentSegment
Public Class DTM _
    Inherits DocumentSegment
public ref class DTM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DTM()()()() | Initializes a new instance of the DTM class
 | Date | Element 2
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | DateTimeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 3
 | TimeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DTM


DTM Constructor

DTM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► DTM()()()()
RDPCrystal EDI Library
Initializes a new instance of the DTM class
Declaration Syntax
C# Visual Basic Visual C++
public DTM()
Public Sub New
public:
DTM()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► DateTimeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► TimeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DTP Class

DTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP
RDPCrystal EDI Library
Date or Time or Period
Declaration Syntax
C# Visual Basic Visual C++
public class DTP : DocumentSegment
Public Class DTP _
    Inherits DocumentSegment
public ref class DTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DTP()()()() | Initializes a new instance of the DTP class
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | DateTimeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DTP


DTP Constructor

DTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP ► DTP()()()()
RDPCrystal EDI Library
Initializes a new instance of the DTP class
Declaration Syntax
C# Visual Basic Visual C++
public DTP()
Public Sub New
public:
DTP()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP ► DateTimeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DTP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


DVI Class

DVI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI
RDPCrystal EDI Library
Dynamic Vehicle Information
Declaration Syntax
C# Visual Basic Visual C++
public class DVI : DocumentSegment
Public Class DVI _
    Inherits DocumentSegment
public ref class DVI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DVI()()()() | Initializes a new instance of the DVI class
 | CurrencyCode | Element 3
 | DateTimePeriod | Element 5
 | DateTimePeriod1 | Element 11
 | DateTimePeriodFormatQualifier | Element 4
 | DateTimePeriodFormatQualifier1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LicensePlateType | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceIdentifierCode | Element 1
 | Quantity | Element 7
 | ReferenceIdentification | Element 8
 | StateOrProvinceCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 13
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DVI


DVI Constructor

DVI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► DVI()()()()
RDPCrystal EDI Library
Initializes a new instance of the DVI class
Declaration Syntax
C# Visual Basic Visual C++
public DVI()
Public Sub New
public:
DVI()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► CurrencyCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► DateTimePeriod
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► DateTimePeriod1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


LicensePlateType Property

LicensePlateType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► LicensePlateType
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LicensePlateType { get; set; }
Public Property LicensePlateType As String
    Get
    Set
public:
property String^ LicensePlateType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► Name1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► PriceIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► StateOrProvinceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► UnitPrice
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► DVI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


E01 Class

E01 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01
RDPCrystal EDI Library
Electronic Form Main Heading
Declaration Syntax
C# Visual Basic Visual C++
public class E01 : DocumentSegment
Public Class E01 _
    Inherits DocumentSegment
public ref class E01 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E01()()()() | Initializes a new instance of the E01 class
 | ElectronicFormStandardsTypeCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FullOrPartialIndicator | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionReleaseIndustryIdentifierCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E01


E01 Constructor

E01 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► E01()()()()
RDPCrystal EDI Library
Initializes a new instance of the E01 class
Declaration Syntax
C# Visual Basic Visual C++
public E01()
Public Sub New
public:
E01()


ElectronicFormStandardsTypeCode Property

ElectronicFormStandardsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► ElectronicFormStandardsTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ElectronicFormStandardsTypeCode { get; set; }
Public Property ElectronicFormStandardsTypeCode As String
    Get
    Set
public:
property String^ ElectronicFormStandardsTypeCode {
    String^ get ();
    void set (String^ value);
}


FullOrPartialIndicator Property

FullOrPartialIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► FullOrPartialIndicator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FullOrPartialIndicator { get; set; }
Public Property FullOrPartialIndicator As String
    Get
    Set
public:
property String^ FullOrPartialIndicator {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► VersionReleaseIndustryIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E01 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E03 Class

E03 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03
RDPCrystal EDI Library
Interchange Order of Segments
Declaration Syntax
C# Visual Basic Visual C++
public class E03 : DocumentSegment
Public Class E03 _
    Inherits DocumentSegment
public ref class E03 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E03()()()() | Initializes a new instance of the E03 class
 | EnvelopeIndicator | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MaximumUse | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RequirementDesignator | Element 5
 | SegmentIDCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E03


E03 Constructor

E03 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► E03()()()()
RDPCrystal EDI Library
Initializes a new instance of the E03 class
Declaration Syntax
C# Visual Basic Visual C++
public E03()
Public Sub New
public:
E03()


EnvelopeIndicator Property

EnvelopeIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► EnvelopeIndicator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EnvelopeIndicator { get; set; }
Public Property EnvelopeIndicator As String
    Get
    Set
public:
property String^ EnvelopeIndicator {
    String^ get ();
    void set (String^ value);
}


LevelNumber Property

LevelNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► LevelNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LevelNumber { get; set; }
Public Property LevelNumber As String
    Get
    Set
public:
property String^ LevelNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


MaximumUse Property

MaximumUse Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► MaximumUse
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MaximumUse { get; set; }
Public Property MaximumUse As String
    Get
    Set
public:
property String^ MaximumUse {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


RequirementDesignator Property

RequirementDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► RequirementDesignator
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RequirementDesignator { get; set; }
Public Property RequirementDesignator As String
    Get
    Set
public:
property String^ RequirementDesignator {
    String^ get ();
    void set (String^ value);
}


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► SegmentIDCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E03 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E1 Class

E1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1
RDPCrystal EDI Library
Empty Car Disposition - Pended Destination Consignee
Declaration Syntax
C# Visual Basic Visual C++
public class E1 : DocumentSegment
Public Class E1 _
    Inherits DocumentSegment
public ref class E1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E1()()()() | Initializes a new instance of the E1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E1


E1 Constructor

E1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1 ► E1()()()()
RDPCrystal EDI Library
Initializes a new instance of the E1 class
Declaration Syntax
C# Visual Basic Visual C++
public E1()
Public Sub New
public:
E1()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1 ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1 ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E10 Class

E10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10
RDPCrystal EDI Library
Transaction Set Grouping
Declaration Syntax
C# Visual Basic Visual C++
public class E10 : DocumentSegment
Public Class E10 _
    Inherits DocumentSegment
public ref class E10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E10()()()() | Initializes a new instance of the E10 class
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetIdentifierCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E10


E10 Constructor

E10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► E10()()()()
RDPCrystal EDI Library
Initializes a new instance of the E10 class
Declaration Syntax
C# Visual Basic Visual C++
public E10()
Public Sub New
public:
E10()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► FunctionalIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E13 Class

E13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13
RDPCrystal EDI Library
Segment Order in Transaction Set
Declaration Syntax
C# Visual Basic Visual C++
public class E13 : DocumentSegment
Public Class E13 _
    Inherits DocumentSegment
public ref class E13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E13()()()() | Initializes a new instance of the E13 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopLevelNumber | Element 9
 | LoopName | Element 7
 | LoopRepeatCount | Element 8
 | MaintenanceOperationCode | Element 1
 | MaximumUse | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 10
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSet | Element 2
 | RequirementDesignator | Element 5
 | SectionDesignator | Element 3
 | SegmentIDCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E13


E13 Constructor

E13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► E13()()()()
RDPCrystal EDI Library
Initializes a new instance of the E13 class
Declaration Syntax
C# Visual Basic Visual C++
public E13()
Public Sub New
public:
E13()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoopLevelNumber Property

LoopLevelNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► LoopLevelNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LoopLevelNumber { get; set; }
Public Property LoopLevelNumber As String
    Get
    Set
public:
property String^ LoopLevelNumber {
    String^ get ();
    void set (String^ value);
}


LoopName Property

LoopName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► LoopName
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LoopName { get; set; }
Public Property LoopName As String
    Get
    Set
public:
property String^ LoopName {
    String^ get ();
    void set (String^ value);
}


LoopRepeatCount Property

LoopRepeatCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► LoopRepeatCount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LoopRepeatCount { get; set; }
Public Property LoopRepeatCount As String
    Get
    Set
public:
property String^ LoopRepeatCount {
    String^ get ();
    void set (String^ value);
}


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


MaximumUse Property

MaximumUse Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► MaximumUse
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MaximumUse { get; set; }
Public Property MaximumUse As String
    Get
    Set
public:
property String^ MaximumUse {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


PositionInSet Property

PositionInSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► PositionInSet
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSet { get; set; }
Public Property PositionInSet As String
    Get
    Set
public:
property String^ PositionInSet {
    String^ get ();
    void set (String^ value);
}


RequirementDesignator Property

RequirementDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► RequirementDesignator
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RequirementDesignator { get; set; }
Public Property RequirementDesignator As String
    Get
    Set
public:
property String^ RequirementDesignator {
    String^ get ();
    void set (String^ value);
}


SectionDesignator Property

SectionDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► SectionDesignator
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SectionDesignator { get; set; }
Public Property SectionDesignator As String
    Get
    Set
public:
property String^ SectionDesignator {
    String^ get ();
    void set (String^ value);
}


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► SegmentIDCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E20 Class

E20 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20
RDPCrystal EDI Library
Segment Header Information
Declaration Syntax
C# Visual Basic Visual C++
public class E20 : DocumentSegment
Public Class E20 _
    Inherits DocumentSegment
public ref class E20 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E20()()()() | Initializes a new instance of the E20 class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SegmentIDCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E20


E20 Constructor

E20 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► E20()()()()
RDPCrystal EDI Library
Initializes a new instance of the E20 class
Declaration Syntax
C# Visual Basic Visual C++
public E20()
Public Sub New
public:
E20()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► SegmentIDCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E20 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E22 Class

E22 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22
RDPCrystal EDI Library
Data Element Relationships in a Segment
Declaration Syntax
C# Visual Basic Visual C++
public class E22 : DocumentSegment
Public Class E22 _
    Inherits DocumentSegment
public ref class E22 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E22()()()() | Initializes a new instance of the E22 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment | Element 3
 | PositionInSegment1 | Element 4
 | PositionInSegment2 | Element 5
 | PositionInSegment3 | Element 6
 | PositionInSegment4 | Element 7
 | PositionInSegment5 | Element 8
 | PositionInSegment6 | Element 9
 | PositionInSegment7 | Element 10
 | PositionInSegment8 | Element 11
 | PositionInSegment9 | Element 12
 | RelationCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E22


E22 Constructor

E22 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► E22()()()()
RDPCrystal EDI Library
Initializes a new instance of the E22 class
Declaration Syntax
C# Visual Basic Visual C++
public E22()
Public Sub New
public:
E22()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment { get; set; }
Public Property PositionInSegment As String
    Get
    Set
public:
property String^ PositionInSegment {
    String^ get ();
    void set (String^ value);
}


PositionInSegment1 Property

PositionInSegment1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment1 { get; set; }
Public Property PositionInSegment1 As String
    Get
    Set
public:
property String^ PositionInSegment1 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment2 Property

PositionInSegment2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment2 { get; set; }
Public Property PositionInSegment2 As String
    Get
    Set
public:
property String^ PositionInSegment2 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment3 Property

PositionInSegment3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment3 { get; set; }
Public Property PositionInSegment3 As String
    Get
    Set
public:
property String^ PositionInSegment3 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment4 Property

PositionInSegment4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment4 { get; set; }
Public Property PositionInSegment4 As String
    Get
    Set
public:
property String^ PositionInSegment4 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment5 Property

PositionInSegment5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment5
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment5 { get; set; }
Public Property PositionInSegment5 As String
    Get
    Set
public:
property String^ PositionInSegment5 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment6 Property

PositionInSegment6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment6
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment6 { get; set; }
Public Property PositionInSegment6 As String
    Get
    Set
public:
property String^ PositionInSegment6 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment7 Property

PositionInSegment7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment7
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment7 { get; set; }
Public Property PositionInSegment7 As String
    Get
    Set
public:
property String^ PositionInSegment7 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment8 Property

PositionInSegment8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment8
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment8 { get; set; }
Public Property PositionInSegment8 As String
    Get
    Set
public:
property String^ PositionInSegment8 {
    String^ get ();
    void set (String^ value);
}


PositionInSegment9 Property

PositionInSegment9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► PositionInSegment9
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment9 { get; set; }
Public Property PositionInSegment9 As String
    Get
    Set
public:
property String^ PositionInSegment9 {
    String^ get ();
    void set (String^ value);
}


RelationCode Property

RelationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► RelationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RelationCode { get; set; }
Public Property RelationCode As String
    Get
    Set
public:
property String^ RelationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E22 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E24 Class

E24 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24
RDPCrystal EDI Library
Data Element Sequence in a Segment
Declaration Syntax
C# Visual Basic Visual C++
public class E24 : DocumentSegment
Public Class E24 _
    Inherits DocumentSegment
public ref class E24 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E24()()()() | Initializes a new instance of the E24 class
 | DataElementReferenceNumber | Element 3
 | DataElementType | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment | Element 2
 | RequirementDesignator | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E24


E24 Constructor

E24 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► E24()()()()
RDPCrystal EDI Library
Initializes a new instance of the E24 class
Declaration Syntax
C# Visual Basic Visual C++
public E24()
Public Sub New
public:
E24()


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► DataElementReferenceNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}


DataElementType Property

DataElementType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► DataElementType
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementType { get; set; }
Public Property DataElementType As String
    Get
    Set
public:
property String^ DataElementType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► PositionInSegment
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInSegment { get; set; }
Public Property PositionInSegment As String
    Get
    Set
public:
property String^ PositionInSegment {
    String^ get ();
    void set (String^ value);
}


RequirementDesignator Property

RequirementDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► RequirementDesignator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RequirementDesignator { get; set; }
Public Property RequirementDesignator As String
    Get
    Set
public:
property String^ RequirementDesignator {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E24 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E26 Class

E26 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26
RDPCrystal EDI Library
Element Sequence in Composite
Declaration Syntax
C# Visual Basic Visual C++
public class E26 : DocumentSegment
Public Class E26 _
    Inherits DocumentSegment
public ref class E26 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E26()()()() | Initializes a new instance of the E26 class
 | DataElementReferenceNumber | Element 3
 | DataElementType | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInComposite | Element 2
 | RequirementDesignator | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E26


E26 Constructor

E26 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► E26()()()()
RDPCrystal EDI Library
Initializes a new instance of the E26 class
Declaration Syntax
C# Visual Basic Visual C++
public E26()
Public Sub New
public:
E26()


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► DataElementReferenceNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}


DataElementType Property

DataElementType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► DataElementType
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementType { get; set; }
Public Property DataElementType As String
    Get
    Set
public:
property String^ DataElementType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


PositionInComposite Property

PositionInComposite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► PositionInComposite
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PositionInComposite { get; set; }
Public Property PositionInComposite As String
    Get
    Set
public:
property String^ PositionInComposite {
    String^ get ();
    void set (String^ value);
}


RequirementDesignator Property

RequirementDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► RequirementDesignator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RequirementDesignator { get; set; }
Public Property RequirementDesignator As String
    Get
    Set
public:
property String^ RequirementDesignator {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E26 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E30 Class

E30 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30
RDPCrystal EDI Library
Data Element Attributes
Declaration Syntax
C# Visual Basic Visual C++
public class E30 : DocumentSegment
Public Class E30 _
    Inherits DocumentSegment
public ref class E30 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E30()()()() | Initializes a new instance of the E30 class
 | CodeListReference | Element 9
 | DataElementReferenceNumber | Element 2
 | DataElementReferenceNumber1 | Element 8
 | DataElementType | Element 3
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MaximumLength | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumLength | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E30


E30 Constructor

E30 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► E30()()()()
RDPCrystal EDI Library
Initializes a new instance of the E30 class
Declaration Syntax
C# Visual Basic Visual C++
public E30()
Public Sub New
public:
E30()


CodeListReference Property

CodeListReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► CodeListReference
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListReference { get; set; }
Public Property CodeListReference As String
    Get
    Set
public:
property String^ CodeListReference {
    String^ get ();
    void set (String^ value);
}


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► DataElementReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}


DataElementReferenceNumber1 Property

DataElementReferenceNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► DataElementReferenceNumber1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber1 { get; set; }
Public Property DataElementReferenceNumber1 As String
    Get
    Set
public:
property String^ DataElementReferenceNumber1 {
    String^ get ();
    void set (String^ value);
}


DataElementType Property

DataElementType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► DataElementType
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementType { get; set; }
Public Property DataElementType As String
    Get
    Set
public:
property String^ DataElementType {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


MaximumLength Property

MaximumLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► MaximumLength
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MaximumLength { get; set; }
Public Property MaximumLength As String
    Get
    Set
public:
property String^ MaximumLength {
    String^ get ();
    void set (String^ value);
}


MinimumLength Property

MinimumLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► MinimumLength
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MinimumLength { get; set; }
Public Property MinimumLength As String
    Get
    Set
public:
property String^ MinimumLength {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E30 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E34 Class

E34 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34
RDPCrystal EDI Library
Code List Values for a Data Element
Declaration Syntax
C# Visual Basic Visual C++
public class E34 : DocumentSegment
Public Class E34 _
    Inherits DocumentSegment
public ref class E34 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E34()()()() | Initializes a new instance of the E34 class
 | CodeValue | Element 2
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PartitionIndicator | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E34


E34 Constructor

E34 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► E34()()()()
RDPCrystal EDI Library
Initializes a new instance of the E34 class
Declaration Syntax
C# Visual Basic Visual C++
public E34()
Public Sub New
public:
E34()


CodeValue Property

CodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► CodeValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeValue { get; set; }
Public Property CodeValue As String
    Get
    Set
public:
property String^ CodeValue {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


PartitionIndicator Property

PartitionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► PartitionIndicator
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PartitionIndicator { get; set; }
Public Property PartitionIndicator As String
    Get
    Set
public:
property String^ PartitionIndicator {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E34 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E4 Class

E4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4
RDPCrystal EDI Library
Empty Car Disposition - Pended Destination City
Declaration Syntax
C# Visual Basic Visual C++
public class E4 : DocumentSegment
Public Class E4 _
    Inherits DocumentSegment
public ref class E4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E4()()()() | Initializes a new instance of the E4 class
 | CityName | Element 1
 | CountryCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 3
 | StateOrProvinceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E4


E4 Constructor

E4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► E4()()()()
RDPCrystal EDI Library
Initializes a new instance of the E4 class
Declaration Syntax
C# Visual Basic Visual C++
public E4()
Public Sub New
public:
E4()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► CityName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► PostalCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E40 Class

E40 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40
RDPCrystal EDI Library
EDI Standards Note Reference
Declaration Syntax
C# Visual Basic Visual C++
public class E40 : DocumentSegment
Public Class E40 _
    Inherits DocumentSegment
public ref class E40 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E40()()()() | Initializes a new instance of the E40 class
 | AssignedIdentification | Element 4
 | ElectronicFormNoteReferenceCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceOperationCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteIdentificationNumber | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E40


E40 Constructor

E40 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► E40()()()()
RDPCrystal EDI Library
Initializes a new instance of the E40 class
Declaration Syntax
C# Visual Basic Visual C++
public E40()
Public Sub New
public:
E40()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► AssignedIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


ElectronicFormNoteReferenceCode Property

ElectronicFormNoteReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► ElectronicFormNoteReferenceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ElectronicFormNoteReferenceCode { get; set; }
Public Property ElectronicFormNoteReferenceCode As String
    Get
    Set
public:
property String^ ElectronicFormNoteReferenceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceOperationCode Property

MaintenanceOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► MaintenanceOperationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceOperationCode { get; set; }
Public Property MaintenanceOperationCode As String
    Get
    Set
public:
property String^ MaintenanceOperationCode {
    String^ get ();
    void set (String^ value);
}


NoteIdentificationNumber Property

NoteIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► NoteIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NoteIdentificationNumber { get; set; }
Public Property NoteIdentificationNumber As String
    Get
    Set
public:
property String^ NoteIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E40 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E5 Class

E5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5
RDPCrystal EDI Library
Empty Car Disposition - Pended Destination Route
Declaration Syntax
C# Visual Basic Visual C++
public class E5 : DocumentSegment
Public Class E5 _
    Inherits DocumentSegment
public ref class E5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E5()()()() | Initializes a new instance of the E5 class
 | CityName | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RoutingSequenceCode | Element 2
 | StandardCarrierAlphaCode | Element 1
 | StandardPointLocationCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E5


E5 Constructor

E5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► E5()()()()
RDPCrystal EDI Library
Initializes a new instance of the E5 class
Declaration Syntax
C# Visual Basic Visual C++
public E5()
Public Sub New
public:
E5()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► RoutingSequenceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E6 Class

E6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6
RDPCrystal EDI Library
Advance Car Disposition
Declaration Syntax
C# Visual Basic Visual C++
public class E6 : DocumentSegment
Public Class E6 _
    Inherits DocumentSegment
public ref class E6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E6()()()() | Initializes a new instance of the E6 class
 | CarTypeCode | Element 8
 | CityName | Element 3
 | CommodityCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | EquipmentStatusCode | Element 9
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermediateSwitchCarrier | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 5
 | StandardPointLocationCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E6


E6 Constructor

E6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► E6()()()()
RDPCrystal EDI Library
Initializes a new instance of the E6 class
Declaration Syntax
C# Visual Basic Visual C++
public E6()
Public Sub New
public:
E6()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► CarTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► CommodityCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentStatusCode Property

EquipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► EquipmentStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode { get; set; }
Public Property EquipmentStatusCode As String
    Get
    Set
public:
property String^ EquipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


IntermediateSwitchCarrier Property

IntermediateSwitchCarrier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► IntermediateSwitchCarrier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IntermediateSwitchCarrier { get; set; }
Public Property IntermediateSwitchCarrier As String
    Get
    Set
public:
property String^ IntermediateSwitchCarrier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


E8 Class

E8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E8
RDPCrystal EDI Library
Blocking and Response Information
Declaration Syntax
C# Visual Basic Visual C++
public class E8 : DocumentSegment
Public Class E8 _
    Inherits DocumentSegment
public ref class E8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | E8()()()() | Initializes a new instance of the E8 class
 | BlockIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MovementAuthorityCode | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | E8


E8 Constructor

E8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E8 ► E8()()()()
RDPCrystal EDI Library
Initializes a new instance of the E8 class
Declaration Syntax
C# Visual Basic Visual C++
public E8()
Public Sub New
public:
E8()


BlockIdentification Property

BlockIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E8 ► BlockIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BlockIdentification { get; set; }
Public Property BlockIdentification As String
    Get
    Set
public:
property String^ BlockIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MovementAuthorityCode Property

MovementAuthorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E8 ► MovementAuthorityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MovementAuthorityCode { get; set; }
Public Property MovementAuthorityCode As String
    Get
    Set
public:
property String^ MovementAuthorityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► E8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EA Class

EA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA
RDPCrystal EDI Library
Equipment Attributes
Declaration Syntax
C# Visual Basic Visual C++
public class EA : DocumentSegment
Public Class EA _
    Inherits DocumentSegment
public ref class EA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EA()()()() | Initializes a new instance of the EA class
 | CompositeUnitOfMeasure | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentAttributeCode | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EA


EA Constructor

EA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA ► EA()()()()
RDPCrystal EDI Library
Initializes a new instance of the EA class
Declaration Syntax
C# Visual Basic Visual C++
public EA()
Public Sub New
public:
EA()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


EquipmentAttributeCode Property

EquipmentAttributeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA ► EquipmentAttributeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentAttributeCode { get; set; }
Public Property EquipmentAttributeCode As String
    Get
    Set
public:
property String^ EquipmentAttributeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EB Class

EB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB
RDPCrystal EDI Library
Eligibility or Benefit Information
Declaration Syntax
C# Visual Basic Visual C++
public class EB : DocumentSegment
Public Class EB _
    Inherits DocumentSegment
public ref class EB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EB()()()() | Initializes a new instance of the EB class
 | CompositeMedicalProcedureIdentifier | Element 13
 | CoverageLevelCode | Element 2
 | EligibilityOrBenefitInformation | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceTypeCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 8
 | PlanCoverageDescription | Element 5
 | Quantity | Element 10
 | QuantityQualifier | Element 9
 | ServiceTypeCode | Element 3
 | TimePeriodQualifier | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 11
 | YesNoConditionOrResponseCode1 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EB


EB Constructor

EB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► EB()()()()
RDPCrystal EDI Library
Initializes a new instance of the EB class
Declaration Syntax
C# Visual Basic Visual C++
public EB()
Public Sub New
public:
EB()


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► CoverageLevelCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}


EligibilityOrBenefitInformation Property

EligibilityOrBenefitInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► EligibilityOrBenefitInformation
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityOrBenefitInformation { get; set; }
Public Property EligibilityOrBenefitInformation As String
    Get
    Set
public:
property String^ EligibilityOrBenefitInformation {
    String^ get ();
    void set (String^ value);
}


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► InsuranceTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► Percent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► PlanCoverageDescription
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► QuantityQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► ServiceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► TimePeriodQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EB ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


EC Class

EC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC
RDPCrystal EDI Library
Employment Class
Declaration Syntax
C# Visual Basic Visual C++
public class EC : DocumentSegment
Public Class EC _
    Inherits DocumentSegment
public ref class EC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EC()()()() | Initializes a new instance of the EC class
 | EmploymentClassCode | Element 1
 | EmploymentClassCode1 | Element 2
 | EmploymentClassCode2 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EC


EC Constructor

EC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► EC()()()()
RDPCrystal EDI Library
Initializes a new instance of the EC class
Declaration Syntax
C# Visual Basic Visual C++
public EC()
Public Sub New
public:
EC()


EmploymentClassCode Property

EmploymentClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► EmploymentClassCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode { get; set; }
Public Property EmploymentClassCode As String
    Get
    Set
public:
property String^ EmploymentClassCode {
    String^ get ();
    void set (String^ value);
}


EmploymentClassCode1 Property

EmploymentClassCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► EmploymentClassCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode1 { get; set; }
Public Property EmploymentClassCode1 As String
    Get
    Set
public:
property String^ EmploymentClassCode1 {
    String^ get ();
    void set (String^ value);
}


EmploymentClassCode2 Property

EmploymentClassCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► EmploymentClassCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode2 { get; set; }
Public Property EmploymentClassCode2 As String
    Get
    Set
public:
property String^ EmploymentClassCode2 {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► InformationStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► OccupationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ED Class

ED Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED
RDPCrystal EDI Library
Equipment Description
Declaration Syntax
C# Visual Basic Visual C++
public class ED : DocumentSegment
Public Class ED _
    Inherits DocumentSegment
public ref class ED : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ED()()()() | Initializes a new instance of the ED class
 | CommodityCode | Element 4
 | Date | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | EquipmentNumber1 | Element 7
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillNumber | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ED


ED Constructor

ED Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► ED()()()()
RDPCrystal EDI Library
Initializes a new instance of the ED class
Declaration Syntax
C# Visual Basic Visual C++
public ED()
Public Sub New
public:
ED()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► CommodityCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber1 Property

EquipmentNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► EquipmentNumber1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber1 { get; set; }
Public Property EquipmentNumber1 As String
    Get
    Set
public:
property String^ EquipmentNumber1 {
    String^ get ();
    void set (String^ value);
}


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► LadingDescription
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► WaybillNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ED ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EFI Class

EFI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI
RDPCrystal EDI Library
Electronic Format Identification
Declaration Syntax
C# Visual Basic Visual C++
public class EFI : DocumentSegment
Public Class EFI _
    Inherits DocumentSegment
public ref class EFI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EFI()()()() | Initializes a new instance of the EFI class
 | BlockLength | Element 13
 | BlockType | Element 11
 | CompressionTechnique | Element 8
 | DrawingSheetSizeCode | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | Element 10
 | FilterIDCode | Element 15
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeFormat | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramIdentifier | Element 4
 | RecordLength | Element 12
 | SecurityTechniqueCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier | Element 3
 | VersionIdentifier1 | Element 5
 | VersionIdentifier2 | Element 7
 | VersionIdentifier3 | Element 14
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EFI


EFI Constructor

EFI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► EFI()()()()
RDPCrystal EDI Library
Initializes a new instance of the EFI class
Declaration Syntax
C# Visual Basic Visual C++
public EFI()
Public Sub New
public:
EFI()


BlockLength Property

BlockLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► BlockLength
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string BlockLength { get; set; }
Public Property BlockLength As String
    Get
    Set
public:
property String^ BlockLength {
    String^ get ();
    void set (String^ value);
}


BlockType Property

BlockType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► BlockType
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string BlockType { get; set; }
Public Property BlockType As String
    Get
    Set
public:
property String^ BlockType {
    String^ get ();
    void set (String^ value);
}


CompressionTechnique Property

CompressionTechnique Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► CompressionTechnique
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CompressionTechnique { get; set; }
Public Property CompressionTechnique As String
    Get
    Set
public:
property String^ CompressionTechnique {
    String^ get ();
    void set (String^ value);
}


DrawingSheetSizeCode Property

DrawingSheetSizeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► DrawingSheetSizeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DrawingSheetSizeCode { get; set; }
Public Property DrawingSheetSizeCode As String
    Get
    Set
public:
property String^ DrawingSheetSizeCode {
    String^ get ();
    void set (String^ value);
}


FileName Property

FileName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► FileName
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


FilterIDCode Property

FilterIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► FilterIDCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode { get; set; }
Public Property FilterIDCode As String
    Get
    Set
public:
property String^ FilterIDCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► FreeFormMessageText
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


InterchangeFormat Property

InterchangeFormat Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► InterchangeFormat
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeFormat { get; set; }
Public Property InterchangeFormat As String
    Get
    Set
public:
property String^ InterchangeFormat {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProgramIdentifier Property

ProgramIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► ProgramIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramIdentifier { get; set; }
Public Property ProgramIdentifier As String
    Get
    Set
public:
property String^ ProgramIdentifier {
    String^ get ();
    void set (String^ value);
}


RecordLength Property

RecordLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► RecordLength
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string RecordLength { get; set; }
Public Property RecordLength As String
    Get
    Set
public:
property String^ RecordLength {
    String^ get ();
    void set (String^ value);
}


SecurityTechniqueCode Property

SecurityTechniqueCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► SecurityTechniqueCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityTechniqueCode { get; set; }
Public Property SecurityTechniqueCode As String
    Get
    Set
public:
property String^ SecurityTechniqueCode {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► VersionIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier1 Property

VersionIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► VersionIdentifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier1 { get; set; }
Public Property VersionIdentifier1 As String
    Get
    Set
public:
property String^ VersionIdentifier1 {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier2 Property

VersionIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► VersionIdentifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier2 { get; set; }
Public Property VersionIdentifier2 As String
    Get
    Set
public:
property String^ VersionIdentifier2 {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier3 Property

VersionIdentifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► VersionIdentifier3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier3 { get; set; }
Public Property VersionIdentifier3 As String
    Get
    Set
public:
property String^ VersionIdentifier3 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EFI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EI Class

EI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI
RDPCrystal EDI Library
Automatic Equipmen Identification
Declaration Syntax
C# Visual Basic Visual C++
public class EI : DocumentSegment
Public Class EI _
    Inherits DocumentSegment
public ref class EI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EI()()()() | Initializes a new instance of the EI class
 | Count | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | EquipmentOrientationCode | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Position | Element 5
 | TagStatusCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EI


EI Constructor

EI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► EI()()()()
RDPCrystal EDI Library
Initializes a new instance of the EI class
Declaration Syntax
C# Visual Basic Visual C++
public EI()
Public Sub New
public:
EI()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► Count
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentOrientationCode Property

EquipmentOrientationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► EquipmentOrientationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentOrientationCode { get; set; }
Public Property EquipmentOrientationCode As String
    Get
    Set
public:
property String^ EquipmentOrientationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► Position
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}


TagStatusCode Property

TagStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► TagStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TagStatusCode { get; set; }
Public Property TagStatusCode As String
    Get
    Set
public:
property String^ TagStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EIA Class

EIA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA
RDPCrystal EDI Library
Beginning Segment for Equipment Inquiry or Advice
Declaration Syntax
C# Visual Basic Visual C++
public class EIA : DocumentSegment
Public Class EIA _
    Inherits DocumentSegment
public ref class EIA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EIA()()()() | Initializes a new instance of the EIA class
 | Count | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
 | YesNoConditionOrResponseCode1 | Element 3
 | YesNoConditionOrResponseCode2 | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EIA


EIA Constructor

EIA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► EIA()()()()
RDPCrystal EDI Library
Initializes a new instance of the EIA class
Declaration Syntax
C# Visual Basic Visual C++
public EIA()
Public Sub New
public:
EIA()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► Count
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EIA ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


EM Class

EM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM
RDPCrystal EDI Library
Equipment Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class EM : DocumentSegment
Public Class EM _
    Inherits DocumentSegment
public ref class EM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EM()()()() | Initializes a new instance of the EM class
 | ConstructionType | Element 6
 | CountryCode | Element 5
 | Date | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 4
 | VolumeUnitQualifier | Element 3
 | Weight | Element 2
 | WeightUnitCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EM


EM Constructor

EM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► EM()()()()
RDPCrystal EDI Library
Initializes a new instance of the EM class
Declaration Syntax
C# Visual Basic Visual C++
public EM()
Public Sub New
public:
EM()


ConstructionType Property

ConstructionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► ConstructionType
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ConstructionType { get; set; }
Public Property ConstructionType As String
    Get
    Set
public:
property String^ ConstructionType {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► CountryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► Volume
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► WeightUnitCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EMP Class

EMP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP
RDPCrystal EDI Library
Employer
Declaration Syntax
C# Visual Basic Visual C++
public class EMP : DocumentSegment
Public Class EMP _
    Inherits DocumentSegment
public ref class EMP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EMP()()()() | Initializes a new instance of the EMP class
 | Description | Element 1
 | Description1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceIDQualifier | Element 2
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 10
 | ReferenceIdentificationQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 8
 | YesNoConditionOrResponseCode2 | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EMP


EMP Constructor

EMP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► EMP()()()()
RDPCrystal EDI Library
Initializes a new instance of the EMP class
Declaration Syntax
C# Visual Basic Visual C++
public EMP()
Public Sub New
public:
EMP()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► Description1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMP ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


EMS Class

EMS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS
RDPCrystal EDI Library
Employment Position
Declaration Syntax
C# Visual Basic Visual C++
public class EMS : DocumentSegment
Public Class EMS _
    Inherits DocumentSegment
public ref class EMS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EMS()()()() | Initializes a new instance of the EMS class
 | Description | Element 1
 | EmploymentClassCode | Element 2
 | EmploymentStatusCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 6
 | ReferenceIdentification1 | Element 7
 | ReferenceIdentificationQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EMS


EMS Constructor

EMS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► EMS()()()()
RDPCrystal EDI Library
Initializes a new instance of the EMS class
Declaration Syntax
C# Visual Basic Visual C++
public EMS()
Public Sub New
public:
EMS()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EmploymentClassCode Property

EmploymentClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► EmploymentClassCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode { get; set; }
Public Property EmploymentClassCode As String
    Get
    Set
public:
property String^ EmploymentClassCode {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► EmploymentStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► OccupationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► ReferenceIdentification1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EMT Class

EMT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT
RDPCrystal EDI Library
Employment
Declaration Syntax
C# Visual Basic Visual C++
public class EMT : DocumentSegment
Public Class EMT _
    Inherits DocumentSegment
public ref class EMT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EMT()()()() | Initializes a new instance of the EMT class
 | CodeListQualifierCode | Element 1
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 7
 | YesNoConditionOrResponseCode2 | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EMT


EMT Constructor

EMT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► EMT()()()()
RDPCrystal EDI Library
Initializes a new instance of the EMT class
Declaration Syntax
C# Visual Basic Visual C++
public EMT()
Public Sub New
public:
EMT()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EMT ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


EncryptionKeyInformation Class

EncryptionKeyInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation
RDPCrystal EDI Library
C031
Declaration Syntax
C# Visual Basic Visual C++
public class EncryptionKeyInformation : DocumentCompositeElement
Public Class EncryptionKeyInformation _
    Inherits DocumentCompositeElement
public ref class EncryptionKeyInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EncryptionKeyInformation()()()() | Initializes a new instance of the EncryptionKeyInformation class
 | EncryptionKeyName | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | KeyingMaterial | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnetimeEncryptionKey | Element 4
 | ProtocolID | Element 2
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | EncryptionKeyInformation


EncryptionKeyInformation Constructor

EncryptionKeyInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► EncryptionKeyInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the EncryptionKeyInformation class
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionKeyInformation()
Public Sub New
public:
EncryptionKeyInformation()


EncryptionKeyName Property

EncryptionKeyName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► EncryptionKeyName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EncryptionKeyName { get; set; }
Public Property EncryptionKeyName As String
    Get
    Set
public:
property String^ EncryptionKeyName {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


KeyingMaterial Property

KeyingMaterial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► KeyingMaterial
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string KeyingMaterial { get; set; }
Public Property KeyingMaterial As String
    Get
    Set
public:
property String^ KeyingMaterial {
    String^ get ();
    void set (String^ value);
}


OnetimeEncryptionKey Property

OnetimeEncryptionKey Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► OnetimeEncryptionKey
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string OnetimeEncryptionKey { get; set; }
Public Property OnetimeEncryptionKey As String
    Get
    Set
public:
property String^ OnetimeEncryptionKey {
    String^ get ();
    void set (String^ value);
}


ProtocolID Property

ProtocolID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionKeyInformation ► ProtocolID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProtocolID { get; set; }
Public Property ProtocolID As String
    Get
    Set
public:
property String^ ProtocolID {
    String^ get ();
    void set (String^ value);
}


EncryptionServiceInformation Class

EncryptionServiceInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation
RDPCrystal EDI Library
C032
Declaration Syntax
C# Visual Basic Visual C++
public class EncryptionServiceInformation : DocumentCompositeElement
Public Class EncryptionServiceInformation _
    Inherits DocumentCompositeElement
public ref class EncryptionServiceInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EncryptionServiceInformation()()()() | Initializes a new instance of the EncryptionServiceInformation class
 | AlgorithmID | Element 2
 | AlgorithmModeOfOperation | Element 3
 | CompressionID | Element 6
 | EncryptionServiceCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterIDCode | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | VersionIdentifier | Element 5
 | VersionIdentifier1 | Element 7
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | EncryptionServiceInformation


EncryptionServiceInformation Constructor

EncryptionServiceInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► EncryptionServiceInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the EncryptionServiceInformation class
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionServiceInformation()
Public Sub New
public:
EncryptionServiceInformation()


AlgorithmID Property

AlgorithmID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► AlgorithmID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AlgorithmID { get; set; }
Public Property AlgorithmID As String
    Get
    Set
public:
property String^ AlgorithmID {
    String^ get ();
    void set (String^ value);
}


AlgorithmModeOfOperation Property

AlgorithmModeOfOperation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► AlgorithmModeOfOperation
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AlgorithmModeOfOperation { get; set; }
Public Property AlgorithmModeOfOperation As String
    Get
    Set
public:
property String^ AlgorithmModeOfOperation {
    String^ get ();
    void set (String^ value);
}


CompressionID Property

CompressionID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► CompressionID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CompressionID { get; set; }
Public Property CompressionID As String
    Get
    Set
public:
property String^ CompressionID {
    String^ get ();
    void set (String^ value);
}


EncryptionServiceCode Property

EncryptionServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► EncryptionServiceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EncryptionServiceCode { get; set; }
Public Property EncryptionServiceCode As String
    Get
    Set
public:
property String^ EncryptionServiceCode {
    String^ get ();
    void set (String^ value);
}


FilterIDCode Property

FilterIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► FilterIDCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode { get; set; }
Public Property FilterIDCode As String
    Get
    Set
public:
property String^ FilterIDCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► VersionIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier1 Property

VersionIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EncryptionServiceInformation ► VersionIdentifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier1 { get; set; }
Public Property VersionIdentifier1 As String
    Get
    Set
public:
property String^ VersionIdentifier1 {
    String^ get ();
    void set (String^ value);
}


ENE Class

ENE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE
RDPCrystal EDI Library
Electronic Systems Environment
Declaration Syntax
C# Visual Basic Visual C++
public class ENE : DocumentSegment
Public Class ENE _
    Inherits DocumentSegment
public ref class ENE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ENE()()()() | Initializes a new instance of the ENE class
 | CommunicationNumber | Element 3
 | CommunicationNumberQualifier | Element 2
 | CommunicationsEnvironmentCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 5
 | IdentificationCodeQualifier | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ENE


ENE Constructor

ENE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► ENE()()()()
RDPCrystal EDI Library
Initializes a new instance of the ENE class
Declaration Syntax
C# Visual Basic Visual C++
public ENE()
Public Sub New
public:
ENE()


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► CommunicationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier Property

CommunicationNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► CommunicationNumberQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier { get; set; }
Public Property CommunicationNumberQualifier As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier {
    String^ get ();
    void set (String^ value);
}


CommunicationsEnvironmentCode Property

CommunicationsEnvironmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► CommunicationsEnvironmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationsEnvironmentCode { get; set; }
Public Property CommunicationsEnvironmentCode As String
    Get
    Set
public:
property String^ CommunicationsEnvironmentCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ENR Class

ENR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR
RDPCrystal EDI Library
School Enrollment Information
Declaration Syntax
C# Visual Basic Visual C++
public class ENR : DocumentSegment
Public Class ENR _
    Inherits DocumentSegment
public ref class ENR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ENR()()()() | Initializes a new instance of the ENR class
 | AcademicGradePointAverage | Element 8
 | DateTimePeriod | Element 4
 | DateTimePeriod1 | Element 13
 | DateTimePeriod2 | Element 16
 | DateTimePeriod3 | Element 18
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimePeriodFormatQualifier1 | Element 12
 | DateTimePeriodFormatQualifier2 | Element 15
 | DateTimePeriodFormatQualifier3 | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelOfIndividualTestOrCourseCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MajorCourseOfStudy | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 7
 | RangeMinimum | Element 6
 | StatusReasonCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCode1 | Element 10
 | YesNoConditionOrResponseCode2 | Element 11
 | YesNoConditionOrResponseCode3 | Element 14
 | YesNoConditionOrResponseCode4 | Element 19
 | YesNoConditionOrResponseCode5 | Element 20
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ENR


ENR Constructor

ENR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► ENR()()()()
RDPCrystal EDI Library
Initializes a new instance of the ENR class
Declaration Syntax
C# Visual Basic Visual C++
public ENR()
Public Sub New
public:
ENR()


AcademicGradePointAverage Property

AcademicGradePointAverage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► AcademicGradePointAverage
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradePointAverage { get; set; }
Public Property AcademicGradePointAverage As String
    Get
    Set
public:
property String^ AcademicGradePointAverage {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriod1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriod2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod3 Property

DateTimePeriod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriod3
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod3 { get; set; }
Public Property DateTimePeriod3 As String
    Get
    Set
public:
property String^ DateTimePeriod3 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier2 Property

DateTimePeriodFormatQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriodFormatQualifier2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier2 { get; set; }
Public Property DateTimePeriodFormatQualifier2 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier3 Property

DateTimePeriodFormatQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► DateTimePeriodFormatQualifier3
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier3 { get; set; }
Public Property DateTimePeriodFormatQualifier3 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier3 {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MajorCourseOfStudy Property

MajorCourseOfStudy Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► MajorCourseOfStudy
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MajorCourseOfStudy { get; set; }
Public Property MajorCourseOfStudy As String
    Get
    Set
public:
property String^ MajorCourseOfStudy {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► RangeMaximum
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► RangeMinimum
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► StatusReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► YesNoConditionOrResponseCode4
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode5 Property

YesNoConditionOrResponseCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENR ► YesNoConditionOrResponseCode5
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode5 { get; set; }
Public Property YesNoConditionOrResponseCode5 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode5 {
    String^ get ();
    void set (String^ value);
}


ENT Class

ENT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT
RDPCrystal EDI Library
Entity
Declaration Syntax
C# Visual Basic Visual C++
public class ENT : DocumentSegment
Public Class ENT _
    Inherits DocumentSegment
public ref class ENT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ENT()()()() | Initializes a new instance of the ENT class
 | AssignedNumber | Element 1
 | EntityIdentifierCode | Element 2
 | EntityIdentifierCode1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCode1 | Element 7
 | IdentificationCodeQualifier | Element 3
 | IdentificationCodeQualifier1 | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 9
 | ReferenceIdentificationQualifier | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ENT


ENT Constructor

ENT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► ENT()()()()
RDPCrystal EDI Library
Initializes a new instance of the ENT class
Declaration Syntax
C# Visual Basic Visual C++
public ENT()
Public Sub New
public:
ENT()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► EntityIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► EntityIdentifierCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► IdentificationCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ENT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EQ Class

EQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ
RDPCrystal EDI Library
Eligibility or Benefit Inquiry
Declaration Syntax
C# Visual Basic Visual C++
public class EQ : DocumentSegment
Public Class EQ _
    Inherits DocumentSegment
public ref class EQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EQ()()()() | Initializes a new instance of the EQ class
 | CompositeMedicalProcedureIdentifier | Element 2
 | CoverageLevelCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceTypeCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EQ


EQ Constructor

EQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► EQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the EQ class
Declaration Syntax
C# Visual Basic Visual C++
public EQ()
Public Sub New
public:
EQ()


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► CoverageLevelCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► InsuranceTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► ServiceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ER Class

ER Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER
RDPCrystal EDI Library
Rail Event Reporting
Declaration Syntax
C# Visual Basic Visual C++
public class ER : DocumentSegment
Public Class ER _
    Inherits DocumentSegment
public ref class ER : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ER()()()() | Initializes a new instance of the ER class
 | ActionCode | Element 1
 | Date | Element 10
 | DateTimePeriod | Element 7
 | DateTimePeriodFormatQualifier | Element 6
 | DateTimeQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventCode | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 2
 | StandardCarrierAlphaCode1 | Element 8
 | StandardPointLocationCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ER


ER Constructor

ER Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► ER()()()()
RDPCrystal EDI Library
Initializes a new instance of the ER class
Declaration Syntax
C# Visual Basic Visual C++
public ER()
Public Sub New
public:
ER()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► Date
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► DateTimeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


EventCode Property

EventCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► EventCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EventCode { get; set; }
Public Property EventCode As String
    Get
    Set
public:
property String^ EventCode {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ER ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ERI Class

ERI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI
RDPCrystal EDI Library
Entity Relationship
Declaration Syntax
C# Visual Basic Visual C++
public class ERI : DocumentSegment
Public Class ERI _
    Inherits DocumentSegment
public ref class ERI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ERI()()()() | Initializes a new instance of the ERI class
 | EntityRelationshipCode | Element 3
 | EntityRelationshipCode1 | Element 6
 | EntityRelationshipCode2 | Element 7
 | EntityRelationshipCode3 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchyCode | Element 9
 | IdentificationCode | Element 2
 | IdentificationCode1 | Element 5
 | IdentificationCodeQualifier | Element 1
 | IdentificationCodeQualifier1 | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ERI


ERI Constructor

ERI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► ERI()()()()
RDPCrystal EDI Library
Initializes a new instance of the ERI class
Declaration Syntax
C# Visual Basic Visual C++
public ERI()
Public Sub New
public:
ERI()


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► EntityRelationshipCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}


EntityRelationshipCode1 Property

EntityRelationshipCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► EntityRelationshipCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode1 { get; set; }
Public Property EntityRelationshipCode1 As String
    Get
    Set
public:
property String^ EntityRelationshipCode1 {
    String^ get ();
    void set (String^ value);
}


EntityRelationshipCode2 Property

EntityRelationshipCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► EntityRelationshipCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode2 { get; set; }
Public Property EntityRelationshipCode2 As String
    Get
    Set
public:
property String^ EntityRelationshipCode2 {
    String^ get ();
    void set (String^ value);
}


EntityRelationshipCode3 Property

EntityRelationshipCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► EntityRelationshipCode3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode3 { get; set; }
Public Property EntityRelationshipCode3 As String
    Get
    Set
public:
property String^ EntityRelationshipCode3 {
    String^ get ();
    void set (String^ value);
}


HierarchyCode Property

HierarchyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► HierarchyCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchyCode { get; set; }
Public Property HierarchyCode As String
    Get
    Set
public:
property String^ HierarchyCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► IdentificationCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ERP Class

ERP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP
RDPCrystal EDI Library
Educational Record Purpose
Declaration Syntax
C# Visual Basic Visual C++
public class ERP : DocumentSegment
Public Class ERP _
    Inherits DocumentSegment
public ref class ERP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ERP()()()() | Initializes a new instance of the ERP class
 | ActionCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ERP


ERP Constructor

ERP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP ► ERP()()()()
RDPCrystal EDI Library
Initializes a new instance of the ERP class
Declaration Syntax
C# Visual Basic Visual C++
public ERP()
Public Sub New
public:
ERP()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP ► ActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP ► StatusReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP ► TransactionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ERP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ES Class

ES Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES
RDPCrystal EDI Library
Equipment Status
Declaration Syntax
C# Visual Basic Visual C++
public class ES : DocumentSegment
Public Class ES _
    Inherits DocumentSegment
public ref class ES : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ES()()()() | Initializes a new instance of the ES class
 | AssociationOfAmericanRailroadsCarGradeCode | Element 3
 | BadOrderReasonCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HoldReasonCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | SwitchTypeCode | Element 6
 | TimePeriodQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ES


ES Constructor

ES Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► ES()()()()
RDPCrystal EDI Library
Initializes a new instance of the ES class
Declaration Syntax
C# Visual Basic Visual C++
public ES()
Public Sub New
public:
ES()


AssociationOfAmericanRailroadsCarGradeCode Property

AssociationOfAmericanRailroadsCarGradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► AssociationOfAmericanRailroadsCarGradeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AssociationOfAmericanRailroadsCarGradeCode { get; set; }
Public Property AssociationOfAmericanRailroadsCarGradeCode As String
    Get
    Set
public:
property String^ AssociationOfAmericanRailroadsCarGradeCode {
    String^ get ();
    void set (String^ value);
}


BadOrderReasonCode Property

BadOrderReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► BadOrderReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BadOrderReasonCode { get; set; }
Public Property BadOrderReasonCode As String
    Get
    Set
public:
property String^ BadOrderReasonCode {
    String^ get ();
    void set (String^ value);
}


HoldReasonCode Property

HoldReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► HoldReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HoldReasonCode { get; set; }
Public Property HoldReasonCode As String
    Get
    Set
public:
property String^ HoldReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


SwitchTypeCode Property

SwitchTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► SwitchTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SwitchTypeCode { get; set; }
Public Property SwitchTypeCode As String
    Get
    Set
public:
property String^ SwitchTypeCode {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► TimePeriodQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ES ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ESI Class

ESI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI
RDPCrystal EDI Library
Employment Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class ESI : DocumentSegment
Public Class ESI _
    Inherits DocumentSegment
public ref class ESI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ESI()()()() | Initializes a new instance of the ESI class
 | EmploymentStatusCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | ReasonStoppedWorkCode | Element 8
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WorkIntensityCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
 | YesNoConditionOrResponseCode1 | Element 2
 | YesNoConditionOrResponseCode2 | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ESI


ESI Constructor

ESI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► ESI()()()()
RDPCrystal EDI Library
Initializes a new instance of the ESI class
Declaration Syntax
C# Visual Basic Visual C++
public ESI()
Public Sub New
public:
ESI()


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► EmploymentStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReasonStoppedWorkCode Property

ReasonStoppedWorkCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► ReasonStoppedWorkCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReasonStoppedWorkCode { get; set; }
Public Property ReasonStoppedWorkCode As String
    Get
    Set
public:
property String^ ReasonStoppedWorkCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


WorkIntensityCode Property

WorkIntensityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► WorkIntensityCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string WorkIntensityCode { get; set; }
Public Property WorkIntensityCode As String
    Get
    Set
public:
property String^ WorkIntensityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ESI ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


ETD Class

ETD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD
RDPCrystal EDI Library
Excess Transportation Detail
Declaration Syntax
C# Visual Basic Visual C++
public class ETD : DocumentSegment
Public Class ETD _
    Inherits DocumentSegment
public ref class ETD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ETD()()()() | Initializes a new instance of the ETD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcessTransportationReasonCode | Element 1
 | ExcessTransportationResponsibilityCode | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | ReturnableContainerFreightPaymentResponsibilityCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ETD


ETD Constructor

ETD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► ETD()()()()
RDPCrystal EDI Library
Initializes a new instance of the ETD class
Declaration Syntax
C# Visual Basic Visual C++
public ETD()
Public Sub New
public:
ETD()


ExcessTransportationReasonCode Property

ExcessTransportationReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► ExcessTransportationReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ExcessTransportationReasonCode { get; set; }
Public Property ExcessTransportationReasonCode As String
    Get
    Set
public:
property String^ ExcessTransportationReasonCode {
    String^ get ();
    void set (String^ value);
}


ExcessTransportationResponsibilityCode Property

ExcessTransportationResponsibilityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► ExcessTransportationResponsibilityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ExcessTransportationResponsibilityCode { get; set; }
Public Property ExcessTransportationResponsibilityCode As String
    Get
    Set
public:
property String^ ExcessTransportationResponsibilityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReturnableContainerFreightPaymentResponsibilityCode Property

ReturnableContainerFreightPaymentResponsibilityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► ReturnableContainerFreightPaymentResponsibilityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnableContainerFreightPaymentResponsibilityCode { get; set; }
Public Property ReturnableContainerFreightPaymentResponsibilityCode As String
    Get
    Set
public:
property String^ ReturnableContainerFreightPaymentResponsibilityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ETD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


EXI Class

EXI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI
RDPCrystal EDI Library
Excavation Ticket Information
Declaration Syntax
C# Visual Basic Visual C++
public class EXI : DocumentSegment
Public Class EXI _
    Inherits DocumentSegment
public ref class EXI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EXI()()()() | Initializes a new instance of the EXI class
 | ActionCode | Element 8
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Priority | Element 2
 | Quantity | Element 6
 | ReferenceIdentifier | Element 1
 | TimePeriodQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EXI


EXI Constructor

EXI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► EXI()()()()
RDPCrystal EDI Library
Initializes a new instance of the EXI class
Declaration Syntax
C# Visual Basic Visual C++
public EXI()
Public Sub New
public:
EXI()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► ActionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Priority Property

Priority Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► Priority
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Priority { get; set; }
Public Property Priority As String
    Get
    Set
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► ReferenceIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► TimePeriodQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► EXI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F01 Class

F01 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01
RDPCrystal EDI Library
Identification of Claim (Claimant Originated)
Declaration Syntax
C# Visual Basic Visual C++
public class F01 : DocumentSegment
Public Class F01 _
    Inherits DocumentSegment
public ref class F01 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F01()()()() | Initializes a new instance of the F01 class
 | Amount | Element 3
 | CurrencyCode | Element 6
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExchangeRate | Element 7
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 9
 | IdentificationCodeQualifier | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | StandardCarrierAlphaCode | Element 4
 | SupportingEvidenceCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F01


F01 Constructor

F01 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► F01()()()()
RDPCrystal EDI Library
Initializes a new instance of the F01 class
Declaration Syntax
C# Visual Basic Visual C++
public F01()
Public Sub New
public:
F01()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► CurrencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


ExchangeRate Property

ExchangeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► ExchangeRate
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ExchangeRate { get; set; }
Public Property ExchangeRate As String
    Get
    Set
public:
property String^ ExchangeRate {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► IdentificationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


SupportingEvidenceCode Property

SupportingEvidenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► SupportingEvidenceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SupportingEvidenceCode { get; set; }
Public Property SupportingEvidenceCode As String
    Get
    Set
public:
property String^ SupportingEvidenceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F01 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F02 Class

F02 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02
RDPCrystal EDI Library
Identification of Shipment
Declaration Syntax
C# Visual Basic Visual C++
public class F02 : DocumentSegment
Public Class F02 _
    Inherits DocumentSegment
public ref class F02 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F02()()()() | Initializes a new instance of the F02 class
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 7
 | ReferenceIdentificationQualifier | Element 4
 | ReferenceIdentificationQualifier1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VesselCode | Element 8
 | VesselName | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F02


F02 Constructor

F02 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► F02()()()()
RDPCrystal EDI Library
Initializes a new instance of the F02 class
Declaration Syntax
C# Visual Basic Visual C++
public F02()
Public Sub New
public:
F02()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► VesselCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► VesselName
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F02 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F04 Class

F04 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04
RDPCrystal EDI Library
Weight/Volume Loss
Declaration Syntax
C# Visual Basic Visual C++
public class F04 : DocumentSegment
Public Class F04 _
    Inherits DocumentSegment
public ref class F04 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F04()()()() | Initializes a new instance of the F04 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 7
 | Volume1 | Element 9
 | VolumeUnitQualifier | Element 8
 | VolumeUnitQualifier1 | Element 10
 | Weight | Element 1
 | Weight1 | Element 4
 | WeightQualifier | Element 3
 | WeightQualifier1 | Element 6
 | WeightUnitCode | Element 2
 | WeightUnitCode1 | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F04


F04 Constructor

F04 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► F04()()()()
RDPCrystal EDI Library
Initializes a new instance of the F04 class
Declaration Syntax
C# Visual Basic Visual C++
public F04()
Public Sub New
public:
F04()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► Volume
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Volume1 Property

Volume1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► Volume1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Volume1 { get; set; }
Public Property Volume1 As String
    Get
    Set
public:
property String^ Volume1 {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier1 Property

VolumeUnitQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► VolumeUnitQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier1 { get; set; }
Public Property VolumeUnitQualifier1 As String
    Get
    Set
public:
property String^ VolumeUnitQualifier1 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► Weight
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► Weight1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► WeightQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightQualifier1 Property

WeightQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► WeightQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier1 { get; set; }
Public Property WeightQualifier1 As String
    Get
    Set
public:
property String^ WeightQualifier1 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► WeightUnitCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode1 Property

WeightUnitCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► WeightUnitCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode1 { get; set; }
Public Property WeightUnitCode1 As String
    Get
    Set
public:
property String^ WeightUnitCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F04 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F05 Class

F05 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05
RDPCrystal EDI Library
Allowance/Charge (Claim)
Declaration Syntax
C# Visual Basic Visual C++
public class F05 : DocumentSegment
Public Class F05 _
    Inherits DocumentSegment
public ref class F05 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F05()()()() | Initializes a new instance of the F05 class
 | Amount | Element 2
 | ChargeAllowanceQualifier | Element 1
 | CreditDebitFlagCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F05


F05 Constructor

F05 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05 ► F05()()()()
RDPCrystal EDI Library
Initializes a new instance of the F05 class
Declaration Syntax
C# Visual Basic Visual C++
public F05()
Public Sub New
public:
F05()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05 ► Amount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


ChargeAllowanceQualifier Property

ChargeAllowanceQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05 ► ChargeAllowanceQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ChargeAllowanceQualifier { get; set; }
Public Property ChargeAllowanceQualifier As String
    Get
    Set
public:
property String^ ChargeAllowanceQualifier {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05 ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F05 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F07 Class

F07 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07
RDPCrystal EDI Library
Auto Claim Detail
Declaration Syntax
C# Visual Basic Visual C++
public class F07 : DocumentSegment
Public Class F07 _
    Inherits DocumentSegment
public ref class F07 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F07()()()() | Initializes a new instance of the F07 class
 | Amount | Element 5
 | AssignedNumber | Element 1
 | AuthorizationIdentification | Element 16
 | ChargeAllowanceQualifier | Element 22
 | DamageAreaCode | Element 6
 | DamageAreaCode1 | Element 18
 | DamageSeverityCode | Element 8
 | DamageSeverityCode1 | Element 20
 | DamageTypeCode | Element 7
 | DamageTypeCode1 | Element 19
 | DeclineAmendReasonCode | Element 21
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InspectionLocationTypeCode | Element 17
 | LaborHours | Element 11
 | LaborHours1 | Element 12
 | LaborOperationIdentifier | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PartName | Element 4
 | ProductServiceID | Element 3
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalLaborCost | Element 13
 | TotalMiscellaneousCosts | Element 14
 | TotalRepairCost | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F07


F07 Constructor

F07 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► F07()()()()
RDPCrystal EDI Library
Initializes a new instance of the F07 class
Declaration Syntax
C# Visual Basic Visual C++
public F07()
Public Sub New
public:
F07()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


AuthorizationIdentification Property

AuthorizationIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► AuthorizationIdentification
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationIdentification { get; set; }
Public Property AuthorizationIdentification As String
    Get
    Set
public:
property String^ AuthorizationIdentification {
    String^ get ();
    void set (String^ value);
}


ChargeAllowanceQualifier Property

ChargeAllowanceQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► ChargeAllowanceQualifier
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ChargeAllowanceQualifier { get; set; }
Public Property ChargeAllowanceQualifier As String
    Get
    Set
public:
property String^ ChargeAllowanceQualifier {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode Property

DamageAreaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DamageAreaCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode { get; set; }
Public Property DamageAreaCode As String
    Get
    Set
public:
property String^ DamageAreaCode {
    String^ get ();
    void set (String^ value);
}


DamageAreaCode1 Property

DamageAreaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DamageAreaCode1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode1 { get; set; }
Public Property DamageAreaCode1 As String
    Get
    Set
public:
property String^ DamageAreaCode1 {
    String^ get ();
    void set (String^ value);
}


DamageSeverityCode Property

DamageSeverityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DamageSeverityCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DamageSeverityCode { get; set; }
Public Property DamageSeverityCode As String
    Get
    Set
public:
property String^ DamageSeverityCode {
    String^ get ();
    void set (String^ value);
}


DamageSeverityCode1 Property

DamageSeverityCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DamageSeverityCode1
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string DamageSeverityCode1 { get; set; }
Public Property DamageSeverityCode1 As String
    Get
    Set
public:
property String^ DamageSeverityCode1 {
    String^ get ();
    void set (String^ value);
}


DamageTypeCode Property

DamageTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DamageTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DamageTypeCode { get; set; }
Public Property DamageTypeCode As String
    Get
    Set
public:
property String^ DamageTypeCode {
    String^ get ();
    void set (String^ value);
}


DamageTypeCode1 Property

DamageTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DamageTypeCode1
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DamageTypeCode1 { get; set; }
Public Property DamageTypeCode1 As String
    Get
    Set
public:
property String^ DamageTypeCode1 {
    String^ get ();
    void set (String^ value);
}


DeclineAmendReasonCode Property

DeclineAmendReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► DeclineAmendReasonCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string DeclineAmendReasonCode { get; set; }
Public Property DeclineAmendReasonCode As String
    Get
    Set
public:
property String^ DeclineAmendReasonCode {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► FreeformDescription
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


InspectionLocationTypeCode Property

InspectionLocationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► InspectionLocationTypeCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string InspectionLocationTypeCode { get; set; }
Public Property InspectionLocationTypeCode As String
    Get
    Set
public:
property String^ InspectionLocationTypeCode {
    String^ get ();
    void set (String^ value);
}


LaborHours Property

LaborHours Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► LaborHours
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LaborHours { get; set; }
Public Property LaborHours As String
    Get
    Set
public:
property String^ LaborHours {
    String^ get ();
    void set (String^ value);
}


LaborHours1 Property

LaborHours1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► LaborHours1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LaborHours1 { get; set; }
Public Property LaborHours1 As String
    Get
    Set
public:
property String^ LaborHours1 {
    String^ get ();
    void set (String^ value);
}


LaborOperationIdentifier Property

LaborOperationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► LaborOperationIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LaborOperationIdentifier { get; set; }
Public Property LaborOperationIdentifier As String
    Get
    Set
public:
property String^ LaborOperationIdentifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PartName Property

PartName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► PartName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PartName { get; set; }
Public Property PartName As String
    Get
    Set
public:
property String^ PartName {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TotalLaborCost Property

TotalLaborCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► TotalLaborCost
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TotalLaborCost { get; set; }
Public Property TotalLaborCost As String
    Get
    Set
public:
property String^ TotalLaborCost {
    String^ get ();
    void set (String^ value);
}


TotalMiscellaneousCosts Property

TotalMiscellaneousCosts Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► TotalMiscellaneousCosts
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string TotalMiscellaneousCosts { get; set; }
Public Property TotalMiscellaneousCosts As String
    Get
    Set
public:
property String^ TotalMiscellaneousCosts {
    String^ get ();
    void set (String^ value);
}


TotalRepairCost Property

TotalRepairCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► TotalRepairCost
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string TotalRepairCost { get; set; }
Public Property TotalRepairCost As String
    Get
    Set
public:
property String^ TotalRepairCost {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F07 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F09 Class

F09 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09
RDPCrystal EDI Library
Detail - Supporting Evidence for Claim
Declaration Syntax
C# Visual Basic Visual C++
public class F09 : DocumentSegment
Public Class F09 _
    Inherits DocumentSegment
public ref class F09 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F09()()()() | Initializes a new instance of the F09 class
 | Amount | Element 4
 | Amount1 | Element 5
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 7
 | LadingLineItemNumber | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NatureOfClaimCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ReferenceIdentification | Element 9
 | ReferenceIdentification1 | Element 11
 | ReferenceIdentificationQualifier | Element 8
 | ReferenceIdentificationQualifier1 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F09


F09 Constructor

F09 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► F09()()()()
RDPCrystal EDI Library
Initializes a new instance of the F09 class
Declaration Syntax
C# Visual Basic Visual C++
public F09()
Public Sub New
public:
F09()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► Amount1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► LadingDescription
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NatureOfClaimCode Property

NatureOfClaimCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► NatureOfClaimCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NatureOfClaimCode { get; set; }
Public Property NatureOfClaimCode As String
    Get
    Set
public:
property String^ NatureOfClaimCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F09 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F10 Class

F10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10
RDPCrystal EDI Library
Identification of Claim (Tracer)
Declaration Syntax
C# Visual Basic Visual C++
public class F10 : DocumentSegment
Public Class F10 _
    Inherits DocumentSegment
public ref class F10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F10()()()() | Initializes a new instance of the F10 class
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 3
 | ReferenceIdentificationQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F10


F10 Constructor

F10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► F10()()()()
RDPCrystal EDI Library
Initializes a new instance of the F10 class
Declaration Syntax
C# Visual Basic Visual C++
public F10()
Public Sub New
public:
F10()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F11 Class

F11 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11
RDPCrystal EDI Library
Status
Declaration Syntax
C# Visual Basic Visual C++
public class F11 : DocumentSegment
Public Class F11 _
    Inherits DocumentSegment
public ref class F11 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F11()()()() | Initializes a new instance of the F11 class
 | Amount | Element 4
 | Amount1 | Element 5
 | CurrencyCode | Element 9
 | Date | Element 1
 | Date1 | Element 7
 | DeclineAmendReasonCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 3
 | ReferenceIdentificationQualifier | Element 10
 | StatusCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F11


F11 Constructor

F11 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► F11()()()()
RDPCrystal EDI Library
Initializes a new instance of the F11 class
Declaration Syntax
C# Visual Basic Visual C++
public F11()
Public Sub New
public:
F11()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► Amount1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► CurrencyCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DeclineAmendReasonCode Property

DeclineAmendReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► DeclineAmendReasonCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DeclineAmendReasonCode { get; set; }
Public Property DeclineAmendReasonCode As String
    Get
    Set
public:
property String^ DeclineAmendReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► StatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F11 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F12 Class

F12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12
RDPCrystal EDI Library
Basic Claim Information - Automotive
Declaration Syntax
C# Visual Basic Visual C++
public class F12 : DocumentSegment
Public Class F12 _
    Inherits DocumentSegment
public ref class F12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F12()()()() | Initializes a new instance of the F12 class
 | CreditDebitAdjustmentNumber | Element 4
 | DamageCodeQualifier | Element 8
 | Date | Element 3
 | Date1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LaborRate | Element 6
 | LaborRate1 | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F12


F12 Constructor

F12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► F12()()()()
RDPCrystal EDI Library
Initializes a new instance of the F12 class
Declaration Syntax
C# Visual Basic Visual C++
public F12()
Public Sub New
public:
F12()


CreditDebitAdjustmentNumber Property

CreditDebitAdjustmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► CreditDebitAdjustmentNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitAdjustmentNumber { get; set; }
Public Property CreditDebitAdjustmentNumber As String
    Get
    Set
public:
property String^ CreditDebitAdjustmentNumber {
    String^ get ();
    void set (String^ value);
}


DamageCodeQualifier Property

DamageCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► DamageCodeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DamageCodeQualifier { get; set; }
Public Property DamageCodeQualifier As String
    Get
    Set
public:
property String^ DamageCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


LaborRate Property

LaborRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► LaborRate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LaborRate { get; set; }
Public Property LaborRate As String
    Get
    Set
public:
property String^ LaborRate {
    String^ get ();
    void set (String^ value);
}


LaborRate1 Property

LaborRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► LaborRate1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LaborRate1 { get; set; }
Public Property LaborRate1 As String
    Get
    Set
public:
property String^ LaborRate1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F13 Class

F13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13
RDPCrystal EDI Library
Payment Information
Declaration Syntax
C# Visual Basic Visual C++
public class F13 : DocumentSegment
Public Class F13 _
    Inherits DocumentSegment
public ref class F13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F13()()()() | Initializes a new instance of the F13 class
 | Amount | Element 3
 | CheckNumber | Element 1
 | CurrencyCode | Element 6
 | Date | Element 2
 | Date1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MICRNumber | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F13


F13 Constructor

F13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► F13()()()()
RDPCrystal EDI Library
Initializes a new instance of the F13 class
Declaration Syntax
C# Visual Basic Visual C++
public F13()
Public Sub New
public:
F13()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CheckNumber Property

CheckNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► CheckNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CheckNumber { get; set; }
Public Property CheckNumber As String
    Get
    Set
public:
property String^ CheckNumber {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► CurrencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MICRNumber Property

MICRNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► MICRNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MICRNumber { get; set; }
Public Property MICRNumber As String
    Get
    Set
public:
property String^ MICRNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F14 Class

F14 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F14
RDPCrystal EDI Library
Line Item Reject
Declaration Syntax
C# Visual Basic Visual C++
public class F14 : DocumentSegment
Public Class F14 _
    Inherits DocumentSegment
public ref class F14 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F14()()()() | Initializes a new instance of the F14 class
 | AssignedNumber | Element 1
 | DeclineAmendReasonCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F14


F14 Constructor

F14 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F14 ► F14()()()()
RDPCrystal EDI Library
Initializes a new instance of the F14 class
Declaration Syntax
C# Visual Basic Visual C++
public F14()
Public Sub New
public:
F14()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F14 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


DeclineAmendReasonCode Property

DeclineAmendReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F14 ► DeclineAmendReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DeclineAmendReasonCode { get; set; }
Public Property DeclineAmendReasonCode As String
    Get
    Set
public:
property String^ DeclineAmendReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F14 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F14 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F6X Class

F6X Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X
RDPCrystal EDI Library
Identification (Automotive)
Declaration Syntax
C# Visual Basic Visual C++
public class F6X : DocumentSegment
Public Class F6X _
    Inherits DocumentSegment
public ref class F6X : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F6X()()()() | Initializes a new instance of the F6X class
 | AutomotiveManufacturersCode | Element 2
 | Date | Element 7
 | Date1 | Element 8
 | DealerCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 5
 | IdentificationCodeQualifier | Element 4
 | InvoiceNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleIdentificationNumber | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F6X


F6X Constructor

F6X Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► F6X()()()()
RDPCrystal EDI Library
Initializes a new instance of the F6X class
Declaration Syntax
C# Visual Basic Visual C++
public F6X()
Public Sub New
public:
F6X()


AutomotiveManufacturersCode Property

AutomotiveManufacturersCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► AutomotiveManufacturersCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AutomotiveManufacturersCode { get; set; }
Public Property AutomotiveManufacturersCode As String
    Get
    Set
public:
property String^ AutomotiveManufacturersCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DealerCode Property

DealerCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► DealerCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DealerCode { get; set; }
Public Property DealerCode As String
    Get
    Set
public:
property String^ DealerCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► InvoiceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


VehicleIdentificationNumber Property

VehicleIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► VehicleIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleIdentificationNumber { get; set; }
Public Property VehicleIdentificationNumber As String
    Get
    Set
public:
property String^ VehicleIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F6X ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


F9 Class

F9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9
RDPCrystal EDI Library
Origin Station
Declaration Syntax
C# Visual Basic Visual C++
public class F9 : DocumentSegment
Public Class F9 _
    Inherits DocumentSegment
public ref class F9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | F9()()()() | Initializes a new instance of the F9 class
 | CityName | Element 2
 | CityName1 | Element 6
 | CountryCode | Element 4
 | CountryCode1 | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 1
 | FreightStationAccountingCode1 | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 9
 | PostalCode1 | Element 11
 | StandardPointLocationCode | Element 8
 | StandardPointLocationCode1 | Element 10
 | StateOrProvinceCode | Element 3
 | StateOrProvinceCode1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | F9


F9 Constructor

F9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► F9()()()()
RDPCrystal EDI Library
Initializes a new instance of the F9 class
Declaration Syntax
C# Visual Basic Visual C++
public F9()
Public Sub New
public:
F9()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► CityName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► CityName1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountryCode1 Property

CountryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► CountryCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode1 { get; set; }
Public Property CountryCode1 As String
    Get
    Set
public:
property String^ CountryCode1 {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode1 Property

FreightStationAccountingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► FreightStationAccountingCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode1 { get; set; }
Public Property FreightStationAccountingCode1 As String
    Get
    Set
public:
property String^ FreightStationAccountingCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► PostalCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


PostalCode1 Property

PostalCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► PostalCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode1 { get; set; }
Public Property PostalCode1 As String
    Get
    Set
public:
property String^ PostalCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► F9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FA1 Class

FA1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1
RDPCrystal EDI Library
Type of Financial Accounting Data
Declaration Syntax
C# Visual Basic Visual C++
public class FA1 : DocumentSegment
Public Class FA1 _
    Inherits DocumentSegment
public ref class FA1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FA1()()()() | Initializes a new instance of the FA1 class
 | AgencyQualifierCode | Element 1
 | AllowanceOrChargeIndicator | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServicePromotionAllowanceOrChargeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FA1


FA1 Constructor

FA1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1 ► FA1()()()()
RDPCrystal EDI Library
Initializes a new instance of the FA1 class
Declaration Syntax
C# Visual Basic Visual C++
public FA1()
Public Sub New
public:
FA1()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1 ► AgencyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeIndicator Property

AllowanceOrChargeIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1 ► AllowanceOrChargeIndicator
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeIndicator { get; set; }
Public Property AllowanceOrChargeIndicator As String
    Get
    Set
public:
property String^ AllowanceOrChargeIndicator {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServicePromotionAllowanceOrChargeCode Property

ServicePromotionAllowanceOrChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1 ► ServicePromotionAllowanceOrChargeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServicePromotionAllowanceOrChargeCode { get; set; }
Public Property ServicePromotionAllowanceOrChargeCode As String
    Get
    Set
public:
property String^ ServicePromotionAllowanceOrChargeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FA2 Class

FA2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA2
RDPCrystal EDI Library
Accounting Data
Declaration Syntax
C# Visual Basic Visual C++
public class FA2 : DocumentSegment
Public Class FA2 _
    Inherits DocumentSegment
public ref class FA2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FA2()()()() | Initializes a new instance of the FA2 class
 | BreakdownStructureDetailCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FinancialInformationCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FA2


FA2 Constructor

FA2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA2 ► FA2()()()()
RDPCrystal EDI Library
Initializes a new instance of the FA2 class
Declaration Syntax
C# Visual Basic Visual C++
public FA2()
Public Sub New
public:
FA2()


BreakdownStructureDetailCode Property

BreakdownStructureDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA2 ► BreakdownStructureDetailCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BreakdownStructureDetailCode { get; set; }
Public Property BreakdownStructureDetailCode As String
    Get
    Set
public:
property String^ BreakdownStructureDetailCode {
    String^ get ();
    void set (String^ value);
}


FinancialInformationCode Property

FinancialInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA2 ► FinancialInformationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FinancialInformationCode { get; set; }
Public Property FinancialInformationCode As String
    Get
    Set
public:
property String^ FinancialInformationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FA2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FAA Class

FAA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA
RDPCrystal EDI Library
Financial Asset Account
Declaration Syntax
C# Visual Basic Visual C++
public class FAA : DocumentSegment
Public Class FAA _
    Inherits DocumentSegment
public ref class FAA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FAA()()()() | Initializes a new instance of the FAA class
 | AccountNumber | Element 2
 | AccountNumberQualifier | Element 1
 | CompositeUnitOfMeasure | Element 7
 | Date | Element 3
 | DateTimePeriod | Element 11
 | DateTimePeriodFormatQualifier | Element 10
 | DateTimeQualifier | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | MonetaryAmount1 | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 8
 | ReferenceIdentification | Element 13
 | ReferenceIdentification1 | Element 14
 | ReferenceIdentificationQualifier | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FAA


FAA Constructor

FAA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► FAA()()()()
RDPCrystal EDI Library
Initializes a new instance of the FAA class
Declaration Syntax
C# Visual Basic Visual C++
public FAA()
Public Sub New
public:
FAA()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► AccountNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► AccountNumberQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► DateTimePeriod
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► DateTimeQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► ReferenceIdentification
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► TypeOfAccountCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FAC Class

FAC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC
RDPCrystal EDI Library
Facing Direction
Declaration Syntax
C# Visual Basic Visual C++
public class FAC : DocumentSegment
Public Class FAC _
    Inherits DocumentSegment
public ref class FAC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FAC()()()() | Initializes a new instance of the FAC class
 | DirectionFacing | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 3
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | EquipmentStatusCode | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FAC


FAC Constructor

FAC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► FAC()()()()
RDPCrystal EDI Library
Initializes a new instance of the FAC class
Declaration Syntax
C# Visual Basic Visual C++
public FAC()
Public Sub New
public:
FAC()


DirectionFacing Property

DirectionFacing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► DirectionFacing
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionFacing { get; set; }
Public Property DirectionFacing As String
    Get
    Set
public:
property String^ DirectionFacing {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentStatusCode Property

EquipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► EquipmentStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode { get; set; }
Public Property EquipmentStatusCode As String
    Get
    Set
public:
property String^ EquipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FAC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


FBB Class

FBB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB
RDPCrystal EDI Library
Foreign and Industry Business
Declaration Syntax
C# Visual Basic Visual C++
public class FBB : DocumentSegment
Public Class FBB _
    Inherits DocumentSegment
public ref class FBB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FBB()()()() | Initializes a new instance of the FBB class
 | CountryCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 5
 | IdentificationCodeQualifier | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | Percent1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FBB


FBB Constructor

FBB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► FBB()()()()
RDPCrystal EDI Library
Initializes a new instance of the FBB class
Declaration Syntax
C# Visual Basic Visual C++
public FBB()
Public Sub New
public:
FBB()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► CountryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► Percent1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FBB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FC Class

FC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC
RDPCrystal EDI Library
Financial Contribution
Declaration Syntax
C# Visual Basic Visual C++
public class FC : DocumentSegment
Public Class FC _
    Inherits DocumentSegment
public ref class FC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FC()()()() | Initializes a new instance of the FC class
 | ContributionCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FC


FC Constructor

FC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► FC()()()()
RDPCrystal EDI Library
Initializes a new instance of the FC class
Declaration Syntax
C# Visual Basic Visual C++
public FC()
Public Sub New
public:
FC()


ContributionCode Property

ContributionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► ContributionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContributionCode { get; set; }
Public Property ContributionCode As String
    Get
    Set
public:
property String^ ContributionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► Number
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


FCL Class

FCL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL
RDPCrystal EDI Library
Foreclosure
Declaration Syntax
C# Visual Basic Visual C++
public class FCL : DocumentSegment
Public Class FCL _
    Inherits DocumentSegment
public ref class FCL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FCL()()()() | Initializes a new instance of the FCL class
 | AdjustmentReasonCode | Element 5
 | AmountQualifierCode | Element 3
 | DeficiencyJudgmentCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FCL


FCL Constructor

FCL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► FCL()()()()
RDPCrystal EDI Library
Initializes a new instance of the FCL class
Declaration Syntax
C# Visual Basic Visual C++
public FCL()
Public Sub New
public:
FCL()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► AdjustmentReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► AmountQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


DeficiencyJudgmentCode Property

DeficiencyJudgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► DeficiencyJudgmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DeficiencyJudgmentCode { get; set; }
Public Property DeficiencyJudgmentCode As String
    Get
    Set
public:
property String^ DeficiencyJudgmentCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FCL ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


FDA Class

FDA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA
RDPCrystal EDI Library
Facility Description
Declaration Syntax
C# Visual Basic Visual C++
public class FDA : DocumentSegment
Public Class FDA _
    Inherits DocumentSegment
public ref class FDA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FDA()()()() | Initializes a new instance of the FDA class
 | ConstructionType | Element 7
 | ConstructionType1 | Element 8
 | Description | Element 2
 | Description1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PropertyOwnershipRightsCode | Element 1
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfRealEstateAssetCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FDA


FDA Constructor

FDA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► FDA()()()()
RDPCrystal EDI Library
Initializes a new instance of the FDA class
Declaration Syntax
C# Visual Basic Visual C++
public FDA()
Public Sub New
public:
FDA()


ConstructionType Property

ConstructionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► ConstructionType
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ConstructionType { get; set; }
Public Property ConstructionType As String
    Get
    Set
public:
property String^ ConstructionType {
    String^ get ();
    void set (String^ value);
}


ConstructionType1 Property

ConstructionType1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► ConstructionType1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ConstructionType1 { get; set; }
Public Property ConstructionType1 As String
    Get
    Set
public:
property String^ ConstructionType1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► Description1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► FreeFormMessage
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PropertyOwnershipRightsCode Property

PropertyOwnershipRightsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► PropertyOwnershipRightsCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyOwnershipRightsCode { get; set; }
Public Property PropertyOwnershipRightsCode As String
    Get
    Set
public:
property String^ PropertyOwnershipRightsCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode Property

TypeOfRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► TypeOfRealEstateAssetCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode { get; set; }
Public Property TypeOfRealEstateAssetCode As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FDA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


FG Class

FG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG
RDPCrystal EDI Library
Docket Group Terminator
Declaration Syntax
C# Visual Basic Visual C++
public class FG : DocumentSegment
Public Class FG _
    Inherits DocumentSegment
public ref class FG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FG()()()() | Initializes a new instance of the FG class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfTransactionSetsIncluded | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TerminatorTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FG


FG Constructor

FG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG ► FG()()()()
RDPCrystal EDI Library
Initializes a new instance of the FG class
Declaration Syntax
C# Visual Basic Visual C++
public FG()
Public Sub New
public:
FG()


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG ► GroupControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG ► NumberOfTransactionSetsIncluded
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}


TerminatorTypeCode Property

TerminatorTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG ► TerminatorTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TerminatorTypeCode { get; set; }
Public Property TerminatorTypeCode As String
    Get
    Set
public:
property String^ TerminatorTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FGS Class

FGS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS
RDPCrystal EDI Library
Form Group
Declaration Syntax
C# Visual Basic Visual C++
public class FGS : DocumentSegment
Public Class FGS _
    Inherits DocumentSegment
public ref class FGS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FGS()()()() | Initializes a new instance of the FGS class
 | AssignedIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FGS


FGS Constructor

FGS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS ► FGS()()()()
RDPCrystal EDI Library
Initializes a new instance of the FGS class
Declaration Syntax
C# Visual Basic Visual C++
public FGS()
Public Sub New
public:
FGS()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FGS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FH Class

FH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH
RDPCrystal EDI Library
Family History
Declaration Syntax
C# Visual Basic Visual C++
public class FH : DocumentSegment
Public Class FH _
    Inherits DocumentSegment
public ref class FH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FH()()()() | Initializes a new instance of the FH class
 | CurrentHealthConditionCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | QuantityQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FH


FH Constructor

FH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► FH()()()()
RDPCrystal EDI Library
Initializes a new instance of the FH class
Declaration Syntax
C# Visual Basic Visual C++
public FH()
Public Sub New
public:
FH()


CurrentHealthConditionCode Property

CurrentHealthConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► CurrentHealthConditionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentHealthConditionCode { get; set; }
Public Property CurrentHealthConditionCode As String
    Get
    Set
public:
property String^ CurrentHealthConditionCode {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► QuantityQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FIR Class

FIR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR
RDPCrystal EDI Library
Financial Information
Declaration Syntax
C# Visual Basic Visual C++
public class FIR : DocumentSegment
Public Class FIR _
    Inherits DocumentSegment
public ref class FIR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FIR()()()() | Initializes a new instance of the FIR class
 | CodeListQualifierCode | Element 1
 | CreditDebitFlagCode | Element 9
 | CurrencyCode | Element 11
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FinancialTransactionStatusCode | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 12
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 7
 | Quantity1 | Element 8
 | Time | Element 5
 | TimeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FIR


FIR Constructor

FIR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► FIR()()()()
RDPCrystal EDI Library
Initializes a new instance of the FIR class
Declaration Syntax
C# Visual Basic Visual C++
public FIR()
Public Sub New
public:
FIR()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► CurrencyCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FinancialTransactionStatusCode Property

FinancialTransactionStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► FinancialTransactionStatusCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FinancialTransactionStatusCode { get; set; }
Public Property FinancialTransactionStatusCode As String
    Get
    Set
public:
property String^ FinancialTransactionStatusCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► MonetaryAmount1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► Quantity1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► TimeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FIS Class

FIS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS
RDPCrystal EDI Library
Mortgage Loan Fiscal Data
Declaration Syntax
C# Visual Basic Visual C++
public class FIS : DocumentSegment
Public Class FIS _
    Inherits DocumentSegment
public ref class FIS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FIS()()()() | Initializes a new instance of the FIS class
 | AmountQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FIS


FIS Constructor

FIS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► FIS()()()()
RDPCrystal EDI Library
Initializes a new instance of the FIS class
Declaration Syntax
C# Visual Basic Visual C++
public FIS()
Public Sub New
public:
FIS()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► AmountQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► MonetaryAmount2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FIS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FK Class

FK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK
RDPCrystal EDI Library
Factor
Declaration Syntax
C# Visual Basic Visual C++
public class FK : DocumentSegment
Public Class FK _
    Inherits DocumentSegment
public ref class FK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FK()()()() | Initializes a new instance of the FK class
 | CityName | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FactorAmount | Element 7
 | FactorAmount1 | Element 8
 | FactorAmount2 | Element 9
 | FactorAmount3 | Element 10
 | FactorAmount4 | Element 11
 | FactorAmount5 | Element 12
 | FactorAmount6 | Element 13
 | FactorAmount7 | Element 14
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PercentageDivision | Element 6
 | Rule260JunctionCode | Element 5
 | StandardCarrierAlphaCode | Element 1
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FK


FK Constructor

FK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FK()()()()
RDPCrystal EDI Library
Initializes a new instance of the FK class
Declaration Syntax
C# Visual Basic Visual C++
public FK()
Public Sub New
public:
FK()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


FactorAmount Property

FactorAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount { get; set; }
Public Property FactorAmount As String
    Get
    Set
public:
property String^ FactorAmount {
    String^ get ();
    void set (String^ value);
}


FactorAmount1 Property

FactorAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount1 { get; set; }
Public Property FactorAmount1 As String
    Get
    Set
public:
property String^ FactorAmount1 {
    String^ get ();
    void set (String^ value);
}


FactorAmount2 Property

FactorAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount2 { get; set; }
Public Property FactorAmount2 As String
    Get
    Set
public:
property String^ FactorAmount2 {
    String^ get ();
    void set (String^ value);
}


FactorAmount3 Property

FactorAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount3 { get; set; }
Public Property FactorAmount3 As String
    Get
    Set
public:
property String^ FactorAmount3 {
    String^ get ();
    void set (String^ value);
}


FactorAmount4 Property

FactorAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount4 { get; set; }
Public Property FactorAmount4 As String
    Get
    Set
public:
property String^ FactorAmount4 {
    String^ get ();
    void set (String^ value);
}


FactorAmount5 Property

FactorAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount5
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount5 { get; set; }
Public Property FactorAmount5 As String
    Get
    Set
public:
property String^ FactorAmount5 {
    String^ get ();
    void set (String^ value);
}


FactorAmount6 Property

FactorAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount6
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount6 { get; set; }
Public Property FactorAmount6 As String
    Get
    Set
public:
property String^ FactorAmount6 {
    String^ get ();
    void set (String^ value);
}


FactorAmount7 Property

FactorAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► FactorAmount7
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount7 { get; set; }
Public Property FactorAmount7 As String
    Get
    Set
public:
property String^ FactorAmount7 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PercentageDivision Property

PercentageDivision Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► PercentageDivision
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PercentageDivision { get; set; }
Public Property PercentageDivision As String
    Get
    Set
public:
property String^ PercentageDivision {
    String^ get ();
    void set (String^ value);
}


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► Rule260JunctionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FNA Class

FNA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA
RDPCrystal EDI Library
Financial Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class FNA : DocumentSegment
Public Class FNA _
    Inherits DocumentSegment
public ref class FNA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FNA()()()() | Initializes a new instance of the FNA class
 | DependencyStatusCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
 | YesNoConditionOrResponseCode1 | Element 2
 | YesNoConditionOrResponseCode2 | Element 3
 | YesNoConditionOrResponseCode3 | Element 5
 | YesNoConditionOrResponseCode4 | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FNA


FNA Constructor

FNA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► FNA()()()()
RDPCrystal EDI Library
Initializes a new instance of the FNA class
Declaration Syntax
C# Visual Basic Visual C++
public FNA()
Public Sub New
public:
FNA()


DependencyStatusCode Property

DependencyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► DependencyStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DependencyStatusCode { get; set; }
Public Property DependencyStatusCode As String
    Get
    Set
public:
property String^ DependencyStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FNA ► YesNoConditionOrResponseCode4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}


FOB Class

FOB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB
RDPCrystal EDI Library
F.O.B. Related Instructions
Declaration Syntax
C# Visual Basic Visual C++
public class FOB : DocumentSegment
Public Class FOB _
    Inherits DocumentSegment
public ref class FOB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FOB()()()() | Initializes a new instance of the FOB class
 | Description | Element 3
 | Description1 | Element 7
 | Description2 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationQualifier | Element 2
 | LocationQualifier1 | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RiskOfLossCode | Element 8
 | ShipmentMethodOfPayment | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationTermsCode | Element 5
 | TransportationTermsQualifierCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FOB


FOB Constructor

FOB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► FOB()()()()
RDPCrystal EDI Library
Initializes a new instance of the FOB class
Declaration Syntax
C# Visual Basic Visual C++
public FOB()
Public Sub New
public:
FOB()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► Description1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► Description2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► LocationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier1 Property

LocationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► LocationQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier1 { get; set; }
Public Property LocationQualifier1 As String
    Get
    Set
public:
property String^ LocationQualifier1 {
    String^ get ();
    void set (String^ value);
}


RiskOfLossCode Property

RiskOfLossCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► RiskOfLossCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RiskOfLossCode { get; set; }
Public Property RiskOfLossCode As String
    Get
    Set
public:
property String^ RiskOfLossCode {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


TransportationTermsCode Property

TransportationTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► TransportationTermsCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationTermsCode { get; set; }
Public Property TransportationTermsCode As String
    Get
    Set
public:
property String^ TransportationTermsCode {
    String^ get ();
    void set (String^ value);
}


TransportationTermsQualifierCode Property

TransportationTermsQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► TransportationTermsQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationTermsQualifierCode { get; set; }
Public Property TransportationTermsQualifierCode As String
    Get
    Set
public:
property String^ TransportationTermsQualifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FOS Class

FOS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS
RDPCrystal EDI Library
Field of Study
Declaration Syntax
C# Visual Basic Visual C++
public class FOS : DocumentSegment
Public Class FOS _
    Inherits DocumentSegment
public ref class FOS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FOS()()()() | Initializes a new instance of the FOS class
 | AcademicFieldOfStudyLevelOrTypeCode | Element 1
 | Description | Element 4
 | Description1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | Quantity1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FOS


FOS Constructor

FOS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► FOS()()()()
RDPCrystal EDI Library
Initializes a new instance of the FOS class
Declaration Syntax
C# Visual Basic Visual C++
public FOS()
Public Sub New
public:
FOS()


AcademicFieldOfStudyLevelOrTypeCode Property

AcademicFieldOfStudyLevelOrTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► AcademicFieldOfStudyLevelOrTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicFieldOfStudyLevelOrTypeCode { get; set; }
Public Property AcademicFieldOfStudyLevelOrTypeCode As String
    Get
    Set
public:
property String^ AcademicFieldOfStudyLevelOrTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► Description1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FOS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FPT Class

FPT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FPT
RDPCrystal EDI Library
Financial Participation
Declaration Syntax
C# Visual Basic Visual C++
public class FPT : DocumentSegment
Public Class FPT _
    Inherits DocumentSegment
public ref class FPT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FPT()()()() | Initializes a new instance of the FPT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FPT


FPT Constructor

FPT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FPT ► FPT()()()()
RDPCrystal EDI Library
Initializes a new instance of the FPT class
Declaration Syntax
C# Visual Basic Visual C++
public FPT()
Public Sub New
public:
FPT()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FPT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FPT ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FPT ► TypeOfAccountCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FPT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FSA Class

FSA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA
RDPCrystal EDI Library
Flexible Spending Account
Declaration Syntax
C# Visual Basic Visual C++
public class FSA : DocumentSegment
Public Class FSA _
    Inherits DocumentSegment
public ref class FSA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FSA()()()() | Initializes a new instance of the FSA class
 | AccountNumber | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlexibleSpendingAccountSelectionCode | Element 2
 | FrequencyCode | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 3
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription | Element 6
 | ProductOptionCode | Element 7
 | ProductOptionCode1 | Element 8
 | ProductOptionCode2 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FSA


FSA Constructor

FSA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► FSA()()()()
RDPCrystal EDI Library
Initializes a new instance of the FSA class
Declaration Syntax
C# Visual Basic Visual C++
public FSA()
Public Sub New
public:
FSA()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► AccountNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


FlexibleSpendingAccountSelectionCode Property

FlexibleSpendingAccountSelectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► FlexibleSpendingAccountSelectionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FlexibleSpendingAccountSelectionCode { get; set; }
Public Property FlexibleSpendingAccountSelectionCode As String
    Get
    Set
public:
property String^ FlexibleSpendingAccountSelectionCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► FrequencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► PlanCoverageDescription
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode Property

ProductOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► ProductOptionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode { get; set; }
Public Property ProductOptionCode As String
    Get
    Set
public:
property String^ ProductOptionCode {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode1 Property

ProductOptionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► ProductOptionCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode1 { get; set; }
Public Property ProductOptionCode1 As String
    Get
    Set
public:
property String^ ProductOptionCode1 {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode2 Property

ProductOptionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► ProductOptionCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode2 { get; set; }
Public Property ProductOptionCode2 As String
    Get
    Set
public:
property String^ ProductOptionCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FSA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FST Class

FST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST
RDPCrystal EDI Library
Forecast Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class FST : DocumentSegment
Public Class FST _
    Inherits DocumentSegment
public ref class FST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FST()()()() | Initializes a new instance of the FST class
 | Date | Element 4
 | Date1 | Element 5
 | DateTimeQualifier | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | ForecastQualifier | Element 2
 | ForecastTimingQualifier | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanningScheduleTypeCode | Element 10
 | Quantity | Element 1
 | ReferenceIdentification | Element 9
 | ReferenceIdentificationQualifier | Element 8
 | Time | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FST


FST Constructor

FST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► FST()()()()
RDPCrystal EDI Library
Initializes a new instance of the FST class
Declaration Syntax
C# Visual Basic Visual C++
public FST()
Public Sub New
public:
FST()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► DateTimeQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


ForecastQualifier Property

ForecastQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► ForecastQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ForecastQualifier { get; set; }
Public Property ForecastQualifier As String
    Get
    Set
public:
property String^ ForecastQualifier {
    String^ get ();
    void set (String^ value);
}


ForecastTimingQualifier Property

ForecastTimingQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► ForecastTimingQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ForecastTimingQualifier { get; set; }
Public Property ForecastTimingQualifier As String
    Get
    Set
public:
property String^ ForecastTimingQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PlanningScheduleTypeCode Property

PlanningScheduleTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► PlanningScheduleTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PlanningScheduleTypeCode { get; set; }
Public Property PlanningScheduleTypeCode As String
    Get
    Set
public:
property String^ PlanningScheduleTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► Time
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


FTH Class

FTH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH
RDPCrystal EDI Library
First Time Home Buyer
Declaration Syntax
C# Visual Basic Visual C++
public class FTH : DocumentSegment
Public Class FTH _
    Inherits DocumentSegment
public ref class FTH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTH()()()() | Initializes a new instance of the FTH class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 4
 | TypeOfResidenceCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
 | YesNoConditionOrResponseCode1 | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FTH


FTH Constructor

FTH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► FTH()()()()
RDPCrystal EDI Library
Initializes a new instance of the FTH class
Declaration Syntax
C# Visual Basic Visual C++
public FTH()
Public Sub New
public:
FTH()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► TypeOfAccountCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


TypeOfResidenceCode Property

TypeOfResidenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► TypeOfResidenceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfResidenceCode { get; set; }
Public Property TypeOfResidenceCode As String
    Get
    Set
public:
property String^ TypeOfResidenceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► FTH ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


G01 Class

G01 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01
RDPCrystal EDI Library
Invoice Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G01 : DocumentSegment
Public Class G01 _
    Inherits DocumentSegment
public ref class G01 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G01()()()() | Initializes a new instance of the G01 class
 | Date | Element 1
 | Date1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 2
 | LinkSequenceNumber | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MasterReferenceLinkNumber | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 8
 | VendorOrderNumber | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G01


G01 Constructor

G01 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► G01()()()()
RDPCrystal EDI Library
Initializes a new instance of the G01 class
Declaration Syntax
C# Visual Basic Visual C++
public G01()
Public Sub New
public:
G01()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► InvoiceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


LinkSequenceNumber Property

LinkSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► LinkSequenceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LinkSequenceNumber { get; set; }
Public Property LinkSequenceNumber As String
    Get
    Set
public:
property String^ LinkSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MasterReferenceLinkNumber Property

MasterReferenceLinkNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► MasterReferenceLinkNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MasterReferenceLinkNumber { get; set; }
Public Property MasterReferenceLinkNumber As String
    Get
    Set
public:
property String^ MasterReferenceLinkNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► TransactionTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


VendorOrderNumber Property

VendorOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► VendorOrderNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VendorOrderNumber { get; set; }
Public Property VendorOrderNumber As String
    Get
    Set
public:
property String^ VendorOrderNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G01 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G05 Class

G05 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05
RDPCrystal EDI Library
Total Shipment Information
Declaration Syntax
C# Visual Basic Visual C++
public class G05 : DocumentSegment
Public Class G05 _
    Inherits DocumentSegment
public ref class G05 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G05()()()() | Initializes a new instance of the G05 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 4
 | UnitOrBasisForMeasurementCode2 | Element 6
 | UnitOrBasisForMeasurementCode3 | Element 8
 | Volume | Element 5
 | Weight | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G05


G05 Constructor

G05 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► G05()()()()
RDPCrystal EDI Library
Initializes a new instance of the G05 class
Declaration Syntax
C# Visual Basic Visual C++
public G05()
Public Sub New
public:
G05()


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► LadingQuantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► Volume
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G05 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G07 Class

G07 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07
RDPCrystal EDI Library
Carrier Information
Declaration Syntax
C# Visual Basic Visual C++
public class G07 : DocumentSegment
Public Class G07 _
    Inherits DocumentSegment
public ref class G07 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G07()()()() | Initializes a new instance of the G07 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SealNumber | Element 3
 | SealNumber1 | Element 4
 | SealStatusCode | Element 5
 | Temperature | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G07


G07 Constructor

G07 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► G07()()()()
RDPCrystal EDI Library
Initializes a new instance of the G07 class
Declaration Syntax
C# Visual Basic Visual C++
public G07()
Public Sub New
public:
G07()


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► SealNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealNumber1 Property

SealNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► SealNumber1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber1 { get; set; }
Public Property SealNumber1 As String
    Get
    Set
public:
property String^ SealNumber1 {
    String^ get ();
    void set (String^ value);
}


SealStatusCode Property

SealStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► SealStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SealStatusCode { get; set; }
Public Property SealStatusCode As String
    Get
    Set
public:
property String^ SealStatusCode {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► Temperature
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G07 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G08 Class

G08 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08
RDPCrystal EDI Library
Pallet Information
Declaration Syntax
C# Visual Basic Visual C++
public class G08 : DocumentSegment
Public Class G08 _
    Inherits DocumentSegment
public ref class G08 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G08()()()() | Initializes a new instance of the G08 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | QuantityContested | Element 3
 | QuantityOfPalletsReceived | Element 1
 | QuantityOfPalletsReturned | Element 2
 | ReceivingConditionCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G08


G08 Constructor

G08 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► G08()()()()
RDPCrystal EDI Library
Initializes a new instance of the G08 class
Declaration Syntax
C# Visual Basic Visual C++
public G08()
Public Sub New
public:
G08()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


QuantityContested Property

QuantityContested Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► QuantityContested
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityContested { get; set; }
Public Property QuantityContested As String
    Get
    Set
public:
property String^ QuantityContested {
    String^ get ();
    void set (String^ value);
}


QuantityOfPalletsReceived Property

QuantityOfPalletsReceived Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► QuantityOfPalletsReceived
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOfPalletsReceived { get; set; }
Public Property QuantityOfPalletsReceived As String
    Get
    Set
public:
property String^ QuantityOfPalletsReceived {
    String^ get ();
    void set (String^ value);
}


QuantityOfPalletsReturned Property

QuantityOfPalletsReturned Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► QuantityOfPalletsReturned
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOfPalletsReturned { get; set; }
Public Property QuantityOfPalletsReturned As String
    Get
    Set
public:
property String^ QuantityOfPalletsReturned {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode Property

ReceivingConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► ReceivingConditionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode { get; set; }
Public Property ReceivingConditionCode As String
    Get
    Set
public:
property String^ ReceivingConditionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G08 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G1 Class

G1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1
RDPCrystal EDI Library
Shipment Type Information
Declaration Syntax
C# Visual Basic Visual C++
public class G1 : DocumentSegment
Public Class G1 _
    Inherits DocumentSegment
public ref class G1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G1()()()() | Initializes a new instance of the G1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentTypeCode | Element 1
 | SpecialIndicatorCode | Element 2
 | SpecialIndicatorCode1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G1


G1 Constructor

G1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1 ► G1()()()()
RDPCrystal EDI Library
Initializes a new instance of the G1 class
Declaration Syntax
C# Visual Basic Visual C++
public G1()
Public Sub New
public:
G1()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentTypeCode Property

ShipmentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1 ► ShipmentTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentTypeCode { get; set; }
Public Property ShipmentTypeCode As String
    Get
    Set
public:
property String^ ShipmentTypeCode {
    String^ get ();
    void set (String^ value);
}


SpecialIndicatorCode Property

SpecialIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1 ► SpecialIndicatorCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialIndicatorCode { get; set; }
Public Property SpecialIndicatorCode As String
    Get
    Set
public:
property String^ SpecialIndicatorCode {
    String^ get ();
    void set (String^ value);
}


SpecialIndicatorCode1 Property

SpecialIndicatorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1 ► SpecialIndicatorCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialIndicatorCode1 { get; set; }
Public Property SpecialIndicatorCode1 As String
    Get
    Set
public:
property String^ SpecialIndicatorCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G11 Class

G11 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11
RDPCrystal EDI Library
Coupon Reporting Specifications
Declaration Syntax
C# Visual Basic Visual C++
public class G11 : DocumentSegment
Public Class G11 _
    Inherits DocumentSegment
public ref class G11 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G11()()()() | Initializes a new instance of the G11 class
 | Category | Element 2
 | Category1 | Element 3
 | Category2 | Element 4
 | Category3 | Element 5
 | Category4 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Level | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 8
 | ReferenceIdentificationQualifier | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G11


G11 Constructor

G11 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► G11()()()()
RDPCrystal EDI Library
Initializes a new instance of the G11 class
Declaration Syntax
C# Visual Basic Visual C++
public G11()
Public Sub New
public:
G11()


Category Property

Category Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Category
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}


Category1 Property

Category1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Category1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Category1 { get; set; }
Public Property Category1 As String
    Get
    Set
public:
property String^ Category1 {
    String^ get ();
    void set (String^ value);
}


Category2 Property

Category2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Category2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Category2 { get; set; }
Public Property Category2 As String
    Get
    Set
public:
property String^ Category2 {
    String^ get ();
    void set (String^ value);
}


Category3 Property

Category3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Category3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Category3 { get; set; }
Public Property Category3 As String
    Get
    Set
public:
property String^ Category3 {
    String^ get ();
    void set (String^ value);
}


Category4 Property

Category4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Category4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Category4 { get; set; }
Public Property Category4 As String
    Get
    Set
public:
property String^ Category4 {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► FreeformDescription
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Level Property

Level Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Level
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Level { get; set; }
Public Property Level As String
    Get
    Set
public:
property String^ Level {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G11 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


G12 Class

G12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12
RDPCrystal EDI Library
Coupon Physical Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class G12 : DocumentSegment
Public Class G12 _
    Inherits DocumentSegment
public ref class G12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G12()()()() | Initializes a new instance of the G12 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Length | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionCode | Element 6
 | PositionCode1 | Element 7
 | PromotionConditionCode | Element 5
 | Quantity | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Width | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G12


G12 Constructor

G12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► G12()()()()
RDPCrystal EDI Library
Initializes a new instance of the G12 class
Declaration Syntax
C# Visual Basic Visual C++
public G12()
Public Sub New
public:
G12()


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► Length
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PositionCode Property

PositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► PositionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PositionCode { get; set; }
Public Property PositionCode As String
    Get
    Set
public:
property String^ PositionCode {
    String^ get ();
    void set (String^ value);
}


PositionCode1 Property

PositionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► PositionCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PositionCode1 { get; set; }
Public Property PositionCode1 As String
    Get
    Set
public:
property String^ PositionCode1 {
    String^ get ();
    void set (String^ value);
}


PromotionConditionCode Property

PromotionConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► PromotionConditionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PromotionConditionCode { get; set; }
Public Property PromotionConditionCode As String
    Get
    Set
public:
property String^ PromotionConditionCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► Width
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G13 Class

G13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13
RDPCrystal EDI Library
Store Size Attributes
Declaration Syntax
C# Visual Basic Visual C++
public class G13 : DocumentSegment
Public Class G13 _
    Inherits DocumentSegment
public ref class G13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G13()()()() | Initializes a new instance of the G13 class
 | AmountQualifierCode | Element 6
 | ClassOfTradeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G13


G13 Constructor

G13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► G13()()()()
RDPCrystal EDI Library
Initializes a new instance of the G13 class
Declaration Syntax
C# Visual Basic Visual C++
public G13()
Public Sub New
public:
G13()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► AmountQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► ClassOfTradeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► Number
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G14 Class

G14 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G14
RDPCrystal EDI Library
Coupon Special Processing
Declaration Syntax
C# Visual Basic Visual C++
public class G14 : DocumentSegment
Public Class G14 _
    Inherits DocumentSegment
public ref class G14 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G14()()()() | Initializes a new instance of the G14 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServicePromotionAllowanceOrCharge | Element 1
 | ServicePromotionAllowanceOrChargeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G14


G14 Constructor

G14 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G14 ► G14()()()()
RDPCrystal EDI Library
Initializes a new instance of the G14 class
Declaration Syntax
C# Visual Basic Visual C++
public G14()
Public Sub New
public:
G14()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G14 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServicePromotionAllowanceOrCharge Property

ServicePromotionAllowanceOrCharge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G14 ► ServicePromotionAllowanceOrCharge
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServicePromotionAllowanceOrCharge { get; set; }
Public Property ServicePromotionAllowanceOrCharge As String
    Get
    Set
public:
property String^ ServicePromotionAllowanceOrCharge {
    String^ get ();
    void set (String^ value);
}


ServicePromotionAllowanceOrChargeCode Property

ServicePromotionAllowanceOrChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G14 ► ServicePromotionAllowanceOrChargeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServicePromotionAllowanceOrChargeCode { get; set; }
Public Property ServicePromotionAllowanceOrChargeCode As String
    Get
    Set
public:
property String^ ServicePromotionAllowanceOrChargeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G14 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G15 Class

G15 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15
RDPCrystal EDI Library
Coupon Distribution
Declaration Syntax
C# Visual Basic Visual C++
public class G15 : DocumentSegment
Public Class G15 _
    Inherits DocumentSegment
public ref class G15 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G15()()()() | Initializes a new instance of the G15 class
 | CouponDistributionMediaCode | Element 2
 | CouponTypeCode | Element 3
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G15


G15 Constructor

G15 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► G15()()()()
RDPCrystal EDI Library
Initializes a new instance of the G15 class
Declaration Syntax
C# Visual Basic Visual C++
public G15()
Public Sub New
public:
G15()


CouponDistributionMediaCode Property

CouponDistributionMediaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► CouponDistributionMediaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CouponDistributionMediaCode { get; set; }
Public Property CouponDistributionMediaCode As String
    Get
    Set
public:
property String^ CouponDistributionMediaCode {
    String^ get ();
    void set (String^ value);
}


CouponTypeCode Property

CouponTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► CouponTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CouponTypeCode { get; set; }
Public Property CouponTypeCode As String
    Get
    Set
public:
property String^ CouponTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G15 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G17 Class

G17 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17
RDPCrystal EDI Library
Item Detail - Invoice
Declaration Syntax
C# Visual Basic Visual C++
public class G17 : DocumentSegment
Public Class G17 _
    Inherits DocumentSegment
public ref class G17 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G17()()()() | Initializes a new instance of the G17 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemListCost | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 14
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 10
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceBracketIdentifier | Element 9
 | PriceListIssueNumber | Element 13
 | PriceListNumber | Element 12
 | ProductServiceID | Element 6
 | ProductServiceID1 | Element 8
 | ProductServiceIDQualifier | Element 5
 | ProductServiceIDQualifier1 | Element 7
 | QuantityInvoiced | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 11
 | UPCCaseCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G17


G17 Constructor

G17 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► G17()()()()
RDPCrystal EDI Library
Initializes a new instance of the G17 class
Declaration Syntax
C# Visual Basic Visual C++
public G17()
Public Sub New
public:
G17()


ItemListCost Property

ItemListCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► ItemListCost
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ItemListCost { get; set; }
Public Property ItemListCost As String
    Get
    Set
public:
property String^ ItemListCost {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► MonetaryAmount
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


PriceListIssueNumber Property

PriceListIssueNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► PriceListIssueNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string PriceListIssueNumber { get; set; }
Public Property PriceListIssueNumber As String
    Get
    Set
public:
property String^ PriceListIssueNumber {
    String^ get ();
    void set (String^ value);
}


PriceListNumber Property

PriceListNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► PriceListNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PriceListNumber { get; set; }
Public Property PriceListNumber As String
    Get
    Set
public:
property String^ PriceListNumber {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► ProductServiceID1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


QuantityInvoiced Property

QuantityInvoiced Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► QuantityInvoiced
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInvoiced { get; set; }
Public Property QuantityInvoiced As String
    Get
    Set
public:
property String^ QuantityInvoiced {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► UPCCaseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G17 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G18 Class

G18 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18
RDPCrystal EDI Library
Store Category Size
Declaration Syntax
C# Visual Basic Visual C++
public class G18 : DocumentSegment
Public Class G18 _
    Inherits DocumentSegment
public ref class G18 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G18()()()() | Initializes a new instance of the G18 class
 | EntityIdentifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Length | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G18


G18 Constructor

G18 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► G18()()()()
RDPCrystal EDI Library
Initializes a new instance of the G18 class
Declaration Syntax
C# Visual Basic Visual C++
public G18()
Public Sub New
public:
G18()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► Length
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G18 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G19 Class

G19 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19
RDPCrystal EDI Library
Line Item Detail - Quantity/Unit of Measure/Price Differences
Declaration Syntax
C# Visual Basic Visual C++
public class G19 : DocumentSegment
Public Class G19 _
    Inherits DocumentSegment
public ref class G19 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G19()()()() | Initializes a new instance of the G19 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceReasonCode | Element 5
 | ProductServiceID | Element 9
 | ProductServiceIDQualifier | Element 8
 | QuantityDifference | Element 3
 | ShipmentOrderStatusCode | Element 4
 | TermsExceptionCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UPCCaseCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G19


G19 Constructor

G19 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► G19()()()()
RDPCrystal EDI Library
Initializes a new instance of the G19 class
Declaration Syntax
C# Visual Basic Visual C++
public G19()
Public Sub New
public:
G19()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


PriceReasonCode Property

PriceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► PriceReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PriceReasonCode { get; set; }
Public Property PriceReasonCode As String
    Get
    Set
public:
property String^ PriceReasonCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► ProductServiceID
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


QuantityDifference Property

QuantityDifference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► QuantityDifference
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityDifference { get; set; }
Public Property QuantityDifference As String
    Get
    Set
public:
property String^ QuantityDifference {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


TermsExceptionCode Property

TermsExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► TermsExceptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TermsExceptionCode { get; set; }
Public Property TermsExceptionCode As String
    Get
    Set
public:
property String^ TermsExceptionCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► UPCCaseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G19 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G2 Class

G2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G2
RDPCrystal EDI Library
Beyond Routing
Declaration Syntax
C# Visual Basic Visual C++
public class G2 : DocumentSegment
Public Class G2 _
    Inherits DocumentSegment
public ref class G2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G2()()()() | Initializes a new instance of the G2 class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialIndicatorCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G2


G2 Constructor

G2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G2 ► G2()()()()
RDPCrystal EDI Library
Initializes a new instance of the G2 class
Declaration Syntax
C# Visual Basic Visual C++
public G2()
Public Sub New
public:
G2()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G2 ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialIndicatorCode Property

SpecialIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G2 ► SpecialIndicatorCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialIndicatorCode { get; set; }
Public Property SpecialIndicatorCode As String
    Get
    Set
public:
property String^ SpecialIndicatorCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G20 Class

G20 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20
RDPCrystal EDI Library
Item Packing Detail
Declaration Syntax
C# Visual Basic Visual C++
public class G20 : DocumentSegment
Public Class G20 _
    Inherits DocumentSegment
public ref class G20 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G20()()()() | Initializes a new instance of the G20 class
 | Color | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InnerPack | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Size | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 5
 | UnitOrBasisForMeasurementCode2 | Element 7
 | Volume | Element 6
 | Weight | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G20


G20 Constructor

G20 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► G20()()()()
RDPCrystal EDI Library
Initializes a new instance of the G20 class
Declaration Syntax
C# Visual Basic Visual C++
public G20()
Public Sub New
public:
G20()


Color Property

Color Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Color
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Color { get; set; }
Public Property Color As String
    Get
    Set
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► InnerPack
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Pack
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Size
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Volume
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G20 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G21 Class

G21 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21
RDPCrystal EDI Library
Product Information
Declaration Syntax
C# Visual Basic Visual C++
public class G21 : DocumentSegment
Public Class G21 _
    Inherits DocumentSegment
public ref class G21 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G21()()()() | Initializes a new instance of the G21 class
 | AuthorizeDeAuthorizeCode | Element 1
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InnerPack | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 8
 | ProductServiceIDQualifier | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 6
 | UPCCaseCode | Element 4
 | UPCEANConsumerPackageCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G21


G21 Constructor

G21 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► G21()()()()
RDPCrystal EDI Library
Initializes a new instance of the G21 class
Declaration Syntax
C# Visual Basic Visual C++
public G21()
Public Sub New
public:
G21()


AuthorizeDeAuthorizeCode Property

AuthorizeDeAuthorizeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► AuthorizeDeAuthorizeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizeDeAuthorizeCode { get; set; }
Public Property AuthorizeDeAuthorizeCode As String
    Get
    Set
public:
property String^ AuthorizeDeAuthorizeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► InnerPack
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► Pack
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► ProductServiceID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► UnitPrice
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► UPCCaseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G21 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G22 Class

G22 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22
RDPCrystal EDI Library
Pricing Information
Declaration Syntax
C# Visual Basic Visual C++
public class G22 : DocumentSegment
Public Class G22 _
    Inherits DocumentSegment
public ref class G22 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G22()()()() | Initializes a new instance of the G22 class
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultiplePriceQuantity | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrepricedOptionCode | Element 1
 | PriceNewSuggestedRetail | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G22


G22 Constructor

G22 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► G22()()()()
RDPCrystal EDI Library
Initializes a new instance of the G22 class
Declaration Syntax
C# Visual Basic Visual C++
public G22()
Public Sub New
public:
G22()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► FreeFormMessage
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MultiplePriceQuantity Property

MultiplePriceQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► MultiplePriceQuantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MultiplePriceQuantity { get; set; }
Public Property MultiplePriceQuantity As String
    Get
    Set
public:
property String^ MultiplePriceQuantity {
    String^ get ();
    void set (String^ value);
}


PrepricedOptionCode Property

PrepricedOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► PrepricedOptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PrepricedOptionCode { get; set; }
Public Property PrepricedOptionCode As String
    Get
    Set
public:
property String^ PrepricedOptionCode {
    String^ get ();
    void set (String^ value);
}


PriceNewSuggestedRetail Property

PriceNewSuggestedRetail Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► PriceNewSuggestedRetail
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PriceNewSuggestedRetail { get; set; }
Public Property PriceNewSuggestedRetail As String
    Get
    Set
public:
property String^ PriceNewSuggestedRetail {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G22 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G23 Class

G23 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23
RDPCrystal EDI Library
Terms of Sale
Declaration Syntax
C# Visual Basic Visual C++
public class G23 : DocumentSegment
Public Class G23 _
    Inherits DocumentSegment
public ref class G23 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G23()()()() | Initializes a new instance of the G23 class
 | AmountSubjectToTermsDiscount | Element 12
 | DiscountedAmountDue | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 15
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InstallmentGroupIndicator | Element 16
 | InstallmentTotalInvoiceAmountDue | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PercentOfInvoicePayable | Element 14
 | TermsBasisDateCode | Element 2
 | TermsDiscountAmount | Element 10
 | TermsDiscountDaysDue | Element 7
 | TermsDiscountDueDate | Element 6
 | TermsDiscountPercent | Element 5
 | TermsDueDateQualifier | Element 4
 | TermsNetDays | Element 9
 | TermsNetDueDate | Element 8
 | TermsStartDate | Element 3
 | TermsTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G23


G23 Constructor

G23 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► G23()()()()
RDPCrystal EDI Library
Initializes a new instance of the G23 class
Declaration Syntax
C# Visual Basic Visual C++
public G23()
Public Sub New
public:
G23()


AmountSubjectToTermsDiscount Property

AmountSubjectToTermsDiscount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► AmountSubjectToTermsDiscount
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AmountSubjectToTermsDiscount { get; set; }
Public Property AmountSubjectToTermsDiscount As String
    Get
    Set
public:
property String^ AmountSubjectToTermsDiscount {
    String^ get ();
    void set (String^ value);
}


DiscountedAmountDue Property

DiscountedAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► DiscountedAmountDue
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountedAmountDue { get; set; }
Public Property DiscountedAmountDue As String
    Get
    Set
public:
property String^ DiscountedAmountDue {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► FreeFormMessage
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


InstallmentGroupIndicator Property

InstallmentGroupIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► InstallmentGroupIndicator
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string InstallmentGroupIndicator { get; set; }
Public Property InstallmentGroupIndicator As String
    Get
    Set
public:
property String^ InstallmentGroupIndicator {
    String^ get ();
    void set (String^ value);
}


InstallmentTotalInvoiceAmountDue Property

InstallmentTotalInvoiceAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► InstallmentTotalInvoiceAmountDue
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string InstallmentTotalInvoiceAmountDue { get; set; }
Public Property InstallmentTotalInvoiceAmountDue As String
    Get
    Set
public:
property String^ InstallmentTotalInvoiceAmountDue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PercentOfInvoicePayable Property

PercentOfInvoicePayable Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► PercentOfInvoicePayable
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PercentOfInvoicePayable { get; set; }
Public Property PercentOfInvoicePayable As String
    Get
    Set
public:
property String^ PercentOfInvoicePayable {
    String^ get ();
    void set (String^ value);
}


TermsBasisDateCode Property

TermsBasisDateCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsBasisDateCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TermsBasisDateCode { get; set; }
Public Property TermsBasisDateCode As String
    Get
    Set
public:
property String^ TermsBasisDateCode {
    String^ get ();
    void set (String^ value);
}


TermsDiscountAmount Property

TermsDiscountAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsDiscountAmount
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountAmount { get; set; }
Public Property TermsDiscountAmount As String
    Get
    Set
public:
property String^ TermsDiscountAmount {
    String^ get ();
    void set (String^ value);
}


TermsDiscountDaysDue Property

TermsDiscountDaysDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsDiscountDaysDue
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountDaysDue { get; set; }
Public Property TermsDiscountDaysDue As String
    Get
    Set
public:
property String^ TermsDiscountDaysDue {
    String^ get ();
    void set (String^ value);
}


TermsDiscountDueDate Property

TermsDiscountDueDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsDiscountDueDate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountDueDate { get; set; }
Public Property TermsDiscountDueDate As String
    Get
    Set
public:
property String^ TermsDiscountDueDate {
    String^ get ();
    void set (String^ value);
}


TermsDiscountPercent Property

TermsDiscountPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsDiscountPercent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent { get; set; }
Public Property TermsDiscountPercent As String
    Get
    Set
public:
property String^ TermsDiscountPercent {
    String^ get ();
    void set (String^ value);
}


TermsDueDateQualifier Property

TermsDueDateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsDueDateQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDueDateQualifier { get; set; }
Public Property TermsDueDateQualifier As String
    Get
    Set
public:
property String^ TermsDueDateQualifier {
    String^ get ();
    void set (String^ value);
}


TermsNetDays Property

TermsNetDays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsNetDays
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TermsNetDays { get; set; }
Public Property TermsNetDays As String
    Get
    Set
public:
property String^ TermsNetDays {
    String^ get ();
    void set (String^ value);
}


TermsNetDueDate Property

TermsNetDueDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsNetDueDate
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TermsNetDueDate { get; set; }
Public Property TermsNetDueDate As String
    Get
    Set
public:
property String^ TermsNetDueDate {
    String^ get ();
    void set (String^ value);
}


TermsStartDate Property

TermsStartDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsStartDate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TermsStartDate { get; set; }
Public Property TermsStartDate As String
    Get
    Set
public:
property String^ TermsStartDate {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode Property

TermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► TermsTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode { get; set; }
Public Property TermsTypeCode As String
    Get
    Set
public:
property String^ TermsTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G23 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G24 Class

G24 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G24
RDPCrystal EDI Library
Promotion Reference
Declaration Syntax
C# Visual Basic Visual C++
public class G24 : DocumentSegment
Public Class G24 _
    Inherits DocumentSegment
public ref class G24 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G24()()()() | Initializes a new instance of the G24 class
 | AllowanceOrChargeNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G24


G24 Constructor

G24 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G24 ► G24()()()()
RDPCrystal EDI Library
Initializes a new instance of the G24 class
Declaration Syntax
C# Visual Basic Visual C++
public G24()
Public Sub New
public:
G24()


AllowanceOrChargeNumber Property

AllowanceOrChargeNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G24 ► AllowanceOrChargeNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeNumber { get; set; }
Public Property AllowanceOrChargeNumber As String
    Get
    Set
public:
property String^ AllowanceOrChargeNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G24 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G24 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G25 Class

G25 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25
RDPCrystal EDI Library
F.O.B. Information
Declaration Syntax
C# Visual Basic Visual C++
public class G25 : DocumentSegment
Public Class G25 _
    Inherits DocumentSegment
public ref class G25 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G25()()()() | Initializes a new instance of the G25 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FOBPoint | Element 3
 | FOBPointCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentMethodOfPayment | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G25


G25 Constructor

G25 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25 ► G25()()()()
RDPCrystal EDI Library
Initializes a new instance of the G25 class
Declaration Syntax
C# Visual Basic Visual C++
public G25()
Public Sub New
public:
G25()


FOBPoint Property

FOBPoint Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25 ► FOBPoint
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPoint { get; set; }
Public Property FOBPoint As String
    Get
    Set
public:
property String^ FOBPoint {
    String^ get ();
    void set (String^ value);
}


FOBPointCode Property

FOBPointCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25 ► FOBPointCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPointCode { get; set; }
Public Property FOBPointCode As String
    Get
    Set
public:
property String^ FOBPointCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G25 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G26 Class

G26 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26
RDPCrystal EDI Library
Pricing Conditions
Declaration Syntax
C# Visual Basic Visual C++
public class G26 : DocumentSegment
Public Class G26 _
    Inherits DocumentSegment
public ref class G26 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G26()()()() | Initializes a new instance of the G26 class
 | Date | Element 3
 | DateQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceConditionCode | Element 1
 | Quantity | Element 5
 | QuantityBasis | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G26


G26 Constructor

G26 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► G26()()()()
RDPCrystal EDI Library
Initializes a new instance of the G26 class
Declaration Syntax
C# Visual Basic Visual C++
public G26()
Public Sub New
public:
G26()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateQualifier Property

DateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► DateQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateQualifier { get; set; }
Public Property DateQualifier As String
    Get
    Set
public:
property String^ DateQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PriceConditionCode Property

PriceConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► PriceConditionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PriceConditionCode { get; set; }
Public Property PriceConditionCode As String
    Get
    Set
public:
property String^ PriceConditionCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityBasis Property

QuantityBasis Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► QuantityBasis
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityBasis { get; set; }
Public Property QuantityBasis As String
    Get
    Set
public:
property String^ QuantityBasis {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G26 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G27 Class

G27 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27
RDPCrystal EDI Library
Carrier Detail
Declaration Syntax
C# Visual Basic Visual C++
public class G27 : DocumentSegment
Public Class G27 _
    Inherits DocumentSegment
public ref class G27 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G27()()()() | Initializes a new instance of the G27 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Routing | Element 5
 | ShipmentOrderStatusCode | Element 6
 | StandardCarrierAlphaCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G27


G27 Constructor

G27 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► G27()()()()
RDPCrystal EDI Library
Initializes a new instance of the G27 class
Declaration Syntax
C# Visual Basic Visual C++
public G27()
Public Sub New
public:
G27()


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► Routing
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G27 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G28 Class

G28 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28
RDPCrystal EDI Library
Line Item Numbers
Declaration Syntax
C# Visual Basic Visual C++
public class G28 : DocumentSegment
Public Class G28 _
    Inherits DocumentSegment
public ref class G28 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G28()()()() | Initializes a new instance of the G28 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | ProductServiceID1 | Element 6
 | ProductServiceIDQualifier | Element 3
 | ProductServiceIDQualifier1 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UPCCaseCode | Element 1
 | UPCEANConsumerPackageCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G28


G28 Constructor

G28 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► G28()()()()
RDPCrystal EDI Library
Initializes a new instance of the G28 class
Declaration Syntax
C# Visual Basic Visual C++
public G28()
Public Sub New
public:
G28()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► ProductServiceID1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► UPCCaseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G28 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G29 Class

G29 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29
RDPCrystal EDI Library
Store Display Information
Declaration Syntax
C# Visual Basic Visual C++
public class G29 : DocumentSegment
Public Class G29 _
    Inherits DocumentSegment
public ref class G29 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G29()()()() | Initializes a new instance of the G29 class
 | DisplayTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G29


G29 Constructor

G29 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29 ► G29()()()()
RDPCrystal EDI Library
Initializes a new instance of the G29 class
Declaration Syntax
C# Visual Basic Visual C++
public G29()
Public Sub New
public:
G29()


DisplayTypeCode Property

DisplayTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29 ► DisplayTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayTypeCode { get; set; }
Public Property DisplayTypeCode As String
    Get
    Set
public:
property String^ DisplayTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G29 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G3 Class

G3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3
RDPCrystal EDI Library
Compensation Information
Declaration Syntax
C# Visual Basic Visual C++
public class G3 : DocumentSegment
Public Class G3 _
    Inherits DocumentSegment
public ref class G3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G3()()()() | Initializes a new instance of the G3 class
 | BusinessTransactionStatus | Element 4
 | CompensationPaid | Element 1
 | CompensationQualifier | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalCompensationAmount | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G3


G3 Constructor

G3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► G3()()()()
RDPCrystal EDI Library
Initializes a new instance of the G3 class
Declaration Syntax
C# Visual Basic Visual C++
public G3()
Public Sub New
public:
G3()


BusinessTransactionStatus Property

BusinessTransactionStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► BusinessTransactionStatus
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessTransactionStatus { get; set; }
Public Property BusinessTransactionStatus As String
    Get
    Set
public:
property String^ BusinessTransactionStatus {
    String^ get ();
    void set (String^ value);
}


CompensationPaid Property

CompensationPaid Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► CompensationPaid
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CompensationPaid { get; set; }
Public Property CompensationPaid As String
    Get
    Set
public:
property String^ CompensationPaid {
    String^ get ();
    void set (String^ value);
}


CompensationQualifier Property

CompensationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► CompensationQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CompensationQualifier { get; set; }
Public Property CompensationQualifier As String
    Get
    Set
public:
property String^ CompensationQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


TotalCompensationAmount Property

TotalCompensationAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► TotalCompensationAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TotalCompensationAmount { get; set; }
Public Property TotalCompensationAmount As String
    Get
    Set
public:
property String^ TotalCompensationAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G30 Class

G30 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G30
RDPCrystal EDI Library
Retail Account Marketing Types
Declaration Syntax
C# Visual Basic Visual C++
public class G30 : DocumentSegment
Public Class G30 _
    Inherits DocumentSegment
public ref class G30 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G30()()()() | Initializes a new instance of the G30 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarketingTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G30


G30 Constructor

G30 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G30 ► G30()()()()
RDPCrystal EDI Library
Initializes a new instance of the G30 class
Declaration Syntax
C# Visual Basic Visual C++
public G30()
Public Sub New
public:
G30()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G30 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarketingTypeCode Property

MarketingTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G30 ► MarketingTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MarketingTypeCode { get; set; }
Public Property MarketingTypeCode As String
    Get
    Set
public:
property String^ MarketingTypeCode {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G30 ► Number
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G30 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G31 Class

G31 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31
RDPCrystal EDI Library
Total Invoice Quantity
Declaration Syntax
C# Visual Basic Visual C++
public class G31 : DocumentSegment
Public Class G31 _
    Inherits DocumentSegment
public ref class G31 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G31()()()() | Initializes a new instance of the G31 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | OrderSizingFactor | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 9
 | PriceBracketIdentifier | Element 8
 | Quantity | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 4
 | UnitOrBasisForMeasurementCode2 | Element 6
 | Volume | Element 5
 | Weight | Element 3
 | Weight1 | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G31


G31 Constructor

G31 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► G31()()()()
RDPCrystal EDI Library
Initializes a new instance of the G31 class
Declaration Syntax
C# Visual Basic Visual C++
public G31()
Public Sub New
public:
G31()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


OrderSizingFactor Property

OrderSizingFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► OrderSizingFactor
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string OrderSizingFactor { get; set; }
Public Property OrderSizingFactor As String
    Get
    Set
public:
property String^ OrderSizingFactor {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► PaymentMethodCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► Volume
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► Weight1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G31 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G32 Class

G32 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32
RDPCrystal EDI Library
Survey Question Response
Declaration Syntax
C# Visual Basic Visual C++
public class G32 : DocumentSegment
Public Class G32 _
    Inherits DocumentSegment
public ref class G32 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G32()()()() | Initializes a new instance of the G32 class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G32


G32 Constructor

G32 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► G32()()()()
RDPCrystal EDI Library
Initializes a new instance of the G32 class
Declaration Syntax
C# Visual Basic Visual C++
public G32()
Public Sub New
public:
G32()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► Number
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G32 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


G33 Class

G33 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G33
RDPCrystal EDI Library
Total Dollars Summary
Declaration Syntax
C# Visual Basic Visual C++
public class G33 : DocumentSegment
Public Class G33 _
    Inherits DocumentSegment
public ref class G33 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G33()()()() | Initializes a new instance of the G33 class
 | Amount | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G33


G33 Constructor

G33 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G33 ► G33()()()()
RDPCrystal EDI Library
Initializes a new instance of the G33 class
Declaration Syntax
C# Visual Basic Visual C++
public G33()
Public Sub New
public:
G33()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G33 ► Amount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G33 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G33 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G35 Class

G35 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35
RDPCrystal EDI Library
Advertising Feature Information
Declaration Syntax
C# Visual Basic Visual C++
public class G35 : DocumentSegment
Public Class G35 _
    Inherits DocumentSegment
public ref class G35 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G35()()()() | Initializes a new instance of the G35 class
 | CouponTypeCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PromotionConditionCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G35


G35 Constructor

G35 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35 ► G35()()()()
RDPCrystal EDI Library
Initializes a new instance of the G35 class
Declaration Syntax
C# Visual Basic Visual C++
public G35()
Public Sub New
public:
G35()


CouponTypeCode Property

CouponTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35 ► CouponTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CouponTypeCode { get; set; }
Public Property CouponTypeCode As String
    Get
    Set
public:
property String^ CouponTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35 ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


PromotionConditionCode Property

PromotionConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35 ► PromotionConditionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PromotionConditionCode { get; set; }
Public Property PromotionConditionCode As String
    Get
    Set
public:
property String^ PromotionConditionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G35 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G36 Class

G36 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36
RDPCrystal EDI Library
Price List Reference
Declaration Syntax
C# Visual Basic Visual C++
public class G36 : DocumentSegment
Public Class G36 _
    Inherits DocumentSegment
public ref class G36 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G36()()()() | Initializes a new instance of the G36 class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceConditionAppliesCode | Element 4
 | PriceListIssueNumber | Element 2
 | PriceListNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G36


G36 Constructor

G36 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► G36()()()()
RDPCrystal EDI Library
Initializes a new instance of the G36 class
Declaration Syntax
C# Visual Basic Visual C++
public G36()
Public Sub New
public:
G36()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PriceConditionAppliesCode Property

PriceConditionAppliesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► PriceConditionAppliesCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PriceConditionAppliesCode { get; set; }
Public Property PriceConditionAppliesCode As String
    Get
    Set
public:
property String^ PriceConditionAppliesCode {
    String^ get ();
    void set (String^ value);
}


PriceListIssueNumber Property

PriceListIssueNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► PriceListIssueNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PriceListIssueNumber { get; set; }
Public Property PriceListIssueNumber As String
    Get
    Set
public:
property String^ PriceListIssueNumber {
    String^ get ();
    void set (String^ value);
}


PriceListNumber Property

PriceListNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► PriceListNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PriceListNumber { get; set; }
Public Property PriceListNumber As String
    Get
    Set
public:
property String^ PriceListNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G36 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G37 Class

G37 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37
RDPCrystal EDI Library
Labor Activity
Declaration Syntax
C# Visual Basic Visual C++
public class G37 : DocumentSegment
Public Class G37 _
    Inherits DocumentSegment
public ref class G37 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G37()()()() | Initializes a new instance of the G37 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LaborActivityCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 2
 | Time1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G37


G37 Constructor

G37 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37 ► G37()()()()
RDPCrystal EDI Library
Initializes a new instance of the G37 class
Declaration Syntax
C# Visual Basic Visual C++
public G37()
Public Sub New
public:
G37()


LaborActivityCode Property

LaborActivityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37 ► LaborActivityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LaborActivityCode { get; set; }
Public Property LaborActivityCode As String
    Get
    Set
public:
property String^ LaborActivityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37 ► Time
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37 ► Time1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G37 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G38 Class

G38 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38
RDPCrystal EDI Library
Claim Payment Information
Declaration Syntax
C# Visual Basic Visual C++
public class G38 : DocumentSegment
Public Class G38 _
    Inherits DocumentSegment
public ref class G38 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G38()()()() | Initializes a new instance of the G38 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 2
 | ReturnsDispositionCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G38


G38 Constructor

G38 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38 ► G38()()()()
RDPCrystal EDI Library
Initializes a new instance of the G38 class
Declaration Syntax
C# Visual Basic Visual C++
public G38()
Public Sub New
public:
G38()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38 ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38 ► PaymentMethodCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


ReturnsDispositionCode Property

ReturnsDispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38 ► ReturnsDispositionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsDispositionCode { get; set; }
Public Property ReturnsDispositionCode As String
    Get
    Set
public:
property String^ ReturnsDispositionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G38 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G39 Class

G39 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39
RDPCrystal EDI Library
Item Characteristics - Vendor’s Selling Unit
Declaration Syntax
C# Visual Basic Visual C++
public class G39 : DocumentSegment
Public Class G39 _
    Inherits DocumentSegment
public ref class G39 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G39()()()() | Initializes a new instance of the G39 class
 | AlternateTiersPerPallet | Element 22
 | Color | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 8
 | InnerPack | Element 27
 | Length | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderSizingFactor | Element 21
 | Pack | Element 17
 | PackagingCode | Element 28
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletBlockAndTiers | Element 16
 | ProductServiceID | Element 3
 | ProductServiceID1 | Element 24
 | ProductServiceIDQualifier | Element 2
 | ProductServiceIDQualifier1 | Element 23
 | Size | Element 18
 | SpecialHandlingCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 9
 | UnitOrBasisForMeasurementCode1 | Element 11
 | UnitOrBasisForMeasurementCode2 | Element 13
 | UnitOrBasisForMeasurementCode3 | Element 15
 | UnitOrBasisForMeasurementCode4 | Element 19
 | UnitWeight | Element 5
 | UnitWeight1 | Element 26
 | UPCCaseCode | Element 1
 | Volume | Element 14
 | WeightQualifier | Element 6
 | WeightQualifier1 | Element 25
 | WeightUnitCode | Element 7
 | Width | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G39


G39 Constructor

G39 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► G39()()()()
RDPCrystal EDI Library
Initializes a new instance of the G39 class
Declaration Syntax
C# Visual Basic Visual C++
public G39()
Public Sub New
public:
G39()


AlternateTiersPerPallet Property

AlternateTiersPerPallet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► AlternateTiersPerPallet
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string AlternateTiersPerPallet { get; set; }
Public Property AlternateTiersPerPallet As String
    Get
    Set
public:
property String^ AlternateTiersPerPallet {
    String^ get ();
    void set (String^ value);
}


Color Property

Color Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Color
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Color { get; set; }
Public Property Color As String
    Get
    Set
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Height
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► InnerPack
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Length
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OrderSizingFactor Property

OrderSizingFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► OrderSizingFactor
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string OrderSizingFactor { get; set; }
Public Property OrderSizingFactor As String
    Get
    Set
public:
property String^ OrderSizingFactor {
    String^ get ();
    void set (String^ value);
}


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Pack
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► PackagingCode
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


PalletBlockAndTiers Property

PalletBlockAndTiers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► PalletBlockAndTiers
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string PalletBlockAndTiers { get; set; }
Public Property PalletBlockAndTiers As String
    Get
    Set
public:
property String^ PalletBlockAndTiers {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► ProductServiceID1
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Size
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}


UnitWeight Property

UnitWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitWeight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight { get; set; }
Public Property UnitWeight As String
    Get
    Set
public:
property String^ UnitWeight {
    String^ get ();
    void set (String^ value);
}


UnitWeight1 Property

UnitWeight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UnitWeight1
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight1 { get; set; }
Public Property UnitWeight1 As String
    Get
    Set
public:
property String^ UnitWeight1 {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► UPCCaseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Volume
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► WeightQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightQualifier1 Property

WeightQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► WeightQualifier1
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier1 { get; set; }
Public Property WeightQualifier1 As String
    Get
    Set
public:
property String^ WeightQualifier1 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► WeightUnitCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Width
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G39 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G4 Class

G4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4
RDPCrystal EDI Library
Scale Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G4 : DocumentSegment
Public Class G4 _
    Inherits DocumentSegment
public ref class G4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G4()()()() | Initializes a new instance of the G4 class
 | CityName | Element 1
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ScaleTypeCode | Element 6
 | StateOrProvinceCode | Element 2
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G4


G4 Constructor

G4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► G4()()()()
RDPCrystal EDI Library
Initializes a new instance of the G4 class
Declaration Syntax
C# Visual Basic Visual C++
public G4()
Public Sub New
public:
G4()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► CityName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ScaleTypeCode Property

ScaleTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► ScaleTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ScaleTypeCode { get; set; }
Public Property ScaleTypeCode As String
    Get
    Set
public:
property String^ ScaleTypeCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G40 Class

G40 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40
RDPCrystal EDI Library
Bracket Price
Declaration Syntax
C# Visual Basic Visual C++
public class G40 : DocumentSegment
Public Class G40 _
    Inherits DocumentSegment
public ref class G40 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G40()()()() | Initializes a new instance of the G40 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemListCostNew | Element 2
 | ItemListCostOld | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceBracketIdentifier | Element 1
 | PriceIdentifierCode | Element 8
 | PriceNewSuggestedRetail | Element 5
 | PriceOldSuggestedRetail | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G40


G40 Constructor

G40 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► G40()()()()
RDPCrystal EDI Library
Initializes a new instance of the G40 class
Declaration Syntax
C# Visual Basic Visual C++
public G40()
Public Sub New
public:
G40()


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► FreeformDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


ItemListCostNew Property

ItemListCostNew Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► ItemListCostNew
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ItemListCostNew { get; set; }
Public Property ItemListCostNew As String
    Get
    Set
public:
property String^ ItemListCostNew {
    String^ get ();
    void set (String^ value);
}


ItemListCostOld Property

ItemListCostOld Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► ItemListCostOld
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ItemListCostOld { get; set; }
Public Property ItemListCostOld As String
    Get
    Set
public:
property String^ ItemListCostOld {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► Number
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► PriceIdentifierCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


PriceNewSuggestedRetail Property

PriceNewSuggestedRetail Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► PriceNewSuggestedRetail
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PriceNewSuggestedRetail { get; set; }
Public Property PriceNewSuggestedRetail As String
    Get
    Set
public:
property String^ PriceNewSuggestedRetail {
    String^ get ();
    void set (String^ value);
}


PriceOldSuggestedRetail Property

PriceOldSuggestedRetail Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► PriceOldSuggestedRetail
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PriceOldSuggestedRetail { get; set; }
Public Property PriceOldSuggestedRetail As String
    Get
    Set
public:
property String^ PriceOldSuggestedRetail {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G40 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G42 Class

G42 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42
RDPCrystal EDI Library
Promotion Announcement Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G42 : DocumentSegment
Public Class G42 _
    Inherits DocumentSegment
public ref class G42 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G42()()()() | Initializes a new instance of the G42 class
 | AllowanceOrChargeNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PromotionStatusCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G42


G42 Constructor

G42 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42 ► G42()()()()
RDPCrystal EDI Library
Initializes a new instance of the G42 class
Declaration Syntax
C# Visual Basic Visual C++
public G42()
Public Sub New
public:
G42()


AllowanceOrChargeNumber Property

AllowanceOrChargeNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42 ► AllowanceOrChargeNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeNumber { get; set; }
Public Property AllowanceOrChargeNumber As String
    Get
    Set
public:
property String^ AllowanceOrChargeNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PromotionStatusCode Property

PromotionStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42 ► PromotionStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PromotionStatusCode { get; set; }
Public Property PromotionStatusCode As String
    Get
    Set
public:
property String^ PromotionStatusCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42 ► TransactionTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G42 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G43 Class

G43 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43
RDPCrystal EDI Library
Promotion/Price List Area
Declaration Syntax
C# Visual Basic Visual C++
public class G43 : DocumentSegment
Public Class G43 _
    Inherits DocumentSegment
public ref class G43 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G43()()()() | Initializes a new instance of the G43 class
 | ClassOfTradeCode | Element 4
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarketAreaCodeIdentifier | Element 2
 | MarketAreaCodeQualifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G43


G43 Constructor

G43 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► G43()()()()
RDPCrystal EDI Library
Initializes a new instance of the G43 class
Declaration Syntax
C# Visual Basic Visual C++
public G43()
Public Sub New
public:
G43()


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► ClassOfTradeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarketAreaCodeIdentifier Property

MarketAreaCodeIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► MarketAreaCodeIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MarketAreaCodeIdentifier { get; set; }
Public Property MarketAreaCodeIdentifier As String
    Get
    Set
public:
property String^ MarketAreaCodeIdentifier {
    String^ get ();
    void set (String^ value);
}


MarketAreaCodeQualifier Property

MarketAreaCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► MarketAreaCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MarketAreaCodeQualifier { get; set; }
Public Property MarketAreaCodeQualifier As String
    Get
    Set
public:
property String^ MarketAreaCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G43 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G45 Class

G45 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45
RDPCrystal EDI Library
Line Item Detail - Promotion
Declaration Syntax
C# Visual Basic Visual C++
public class G45 : DocumentSegment
Public Class G45 _
    Inherits DocumentSegment
public ref class G45 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G45()()()() | Initializes a new instance of the G45 class
 | AllowanceOrChargeNumber | Element 3
 | AllowanceOrChargeRate | Element 13
 | Date | Element 11
 | DateQualifier | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionNumber | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InnerPack | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 6
 | ProductServiceIDQualifier | Element 5
 | Size | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 9
 | UPCCaseCode | Element 1
 | UPCEANConsumerPackageCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G45


G45 Constructor

G45 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► G45()()()()
RDPCrystal EDI Library
Initializes a new instance of the G45 class
Declaration Syntax
C# Visual Basic Visual C++
public G45()
Public Sub New
public:
G45()


AllowanceOrChargeNumber Property

AllowanceOrChargeNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► AllowanceOrChargeNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeNumber { get; set; }
Public Property AllowanceOrChargeNumber As String
    Get
    Set
public:
property String^ AllowanceOrChargeNumber {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeRate Property

AllowanceOrChargeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► AllowanceOrChargeRate
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeRate { get; set; }
Public Property AllowanceOrChargeRate As String
    Get
    Set
public:
property String^ AllowanceOrChargeRate {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► Date
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateQualifier Property

DateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► DateQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateQualifier { get; set; }
Public Property DateQualifier As String
    Get
    Set
public:
property String^ DateQualifier {
    String^ get ();
    void set (String^ value);
}


ExceptionNumber Property

ExceptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► ExceptionNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ExceptionNumber { get; set; }
Public Property ExceptionNumber As String
    Get
    Set
public:
property String^ ExceptionNumber {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► InnerPack
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► Pack
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► Size
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► UPCCaseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G45 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G46 Class

G46 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46
RDPCrystal EDI Library
Promotion Allowance/Charge
Declaration Syntax
C# Visual Basic Visual C++
public class G46 : DocumentSegment
Public Class G46 _
    Inherits DocumentSegment
public ref class G46 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G46()()()() | Initializes a new instance of the G46 class
 | AllowanceChargePercentQualifier | Element 6
 | AllowanceOrChargeCode | Element 1
 | AllowanceOrChargeMethodOfHandlingCode | Element 2
 | AllowanceOrChargeRate | Element 3
 | Amount | Element 5
 | Description | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionNumber | Element 8
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 12
 | OptionNumber | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | PriceIdentifierCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G46


G46 Constructor

G46 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► G46()()()()
RDPCrystal EDI Library
Initializes a new instance of the G46 class
Declaration Syntax
C# Visual Basic Visual C++
public G46()
Public Sub New
public:
G46()


AllowanceChargePercentQualifier Property

AllowanceChargePercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► AllowanceChargePercentQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceChargePercentQualifier { get; set; }
Public Property AllowanceChargePercentQualifier As String
    Get
    Set
public:
property String^ AllowanceChargePercentQualifier {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeCode Property

AllowanceOrChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► AllowanceOrChargeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeCode { get; set; }
Public Property AllowanceOrChargeCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeMethodOfHandlingCode Property

AllowanceOrChargeMethodOfHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► AllowanceOrChargeMethodOfHandlingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeMethodOfHandlingCode { get; set; }
Public Property AllowanceOrChargeMethodOfHandlingCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeMethodOfHandlingCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeRate Property

AllowanceOrChargeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► AllowanceOrChargeRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeRate { get; set; }
Public Property AllowanceOrChargeRate As String
    Get
    Set
public:
property String^ AllowanceOrChargeRate {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ExceptionNumber Property

ExceptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► ExceptionNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ExceptionNumber { get; set; }
Public Property ExceptionNumber As String
    Get
    Set
public:
property String^ ExceptionNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► Number
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


OptionNumber Property

OptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► OptionNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string OptionNumber { get; set; }
Public Property OptionNumber As String
    Get
    Set
public:
property String^ OptionNumber {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► PriceIdentifierCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G46 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G47 Class

G47 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G47
RDPCrystal EDI Library
Statement Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G47 : DocumentSegment
Public Class G47 _
    Inherits DocumentSegment
public ref class G47 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G47()()()() | Initializes a new instance of the G47 class
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatementNumber | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G47


G47 Constructor

G47 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G47 ► G47()()()()
RDPCrystal EDI Library
Initializes a new instance of the G47 class
Declaration Syntax
C# Visual Basic Visual C++
public G47()
Public Sub New
public:
G47()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G47 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G47 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatementNumber Property

StatementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G47 ► StatementNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StatementNumber { get; set; }
Public Property StatementNumber As String
    Get
    Set
public:
property String^ StatementNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G47 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G48 Class

G48 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48
RDPCrystal EDI Library
Statement/Invoice Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G48 : DocumentSegment
Public Class G48 _
    Inherits DocumentSegment
public ref class G48 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G48()()()() | Initializes a new instance of the G48 class
 | Date | Element 2
 | Date1 | Element 4
 | Date2 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 5
 | ReferenceIdentification | Element 8
 | ReferenceIdentificationQualifier | Element 7
 | StoreNumber | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VendorOrderNumber | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G48


G48 Constructor

G48 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► G48()()()()
RDPCrystal EDI Library
Initializes a new instance of the G48 class
Declaration Syntax
C# Visual Basic Visual C++
public G48()
Public Sub New
public:
G48()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► Date2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► InvoiceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StoreNumber Property

StoreNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► StoreNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StoreNumber { get; set; }
Public Property StoreNumber As String
    Get
    Set
public:
property String^ StoreNumber {
    String^ get ();
    void set (String^ value);
}


VendorOrderNumber Property

VendorOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► VendorOrderNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VendorOrderNumber { get; set; }
Public Property VendorOrderNumber As String
    Get
    Set
public:
property String^ VendorOrderNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G48 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G49 Class

G49 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49
RDPCrystal EDI Library
Statement Total
Declaration Syntax
C# Visual Basic Visual C++
public class G49 : DocumentSegment
Public Class G49 _
    Inherits DocumentSegment
public ref class G49 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G49()()()() | Initializes a new instance of the G49 class
 | Amount | Element 1
 | Amount1 | Element 2
 | Amount2 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G49


G49 Constructor

G49 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49 ► G49()()()()
RDPCrystal EDI Library
Initializes a new instance of the G49 class
Declaration Syntax
C# Visual Basic Visual C++
public G49()
Public Sub New
public:
G49()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49 ► Amount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49 ► Amount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Amount2 Property

Amount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49 ► Amount2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount2 { get; set; }
Public Property Amount2 As String
    Get
    Set
public:
property String^ Amount2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G49 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G5 Class

G5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5
RDPCrystal EDI Library
Weight Information
Declaration Syntax
C# Visual Basic Visual C++
public class G5 : DocumentSegment
Public Class G5 _
    Inherits DocumentSegment
public ref class G5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G5()()()() | Initializes a new instance of the G5 class
 | CommodityCode | Element 14
 | Date | Element 4
 | Date1 | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentNumber | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 11
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 12
 | ReferenceIdentification | Element 16
 | ReferenceIdentificationQualifier | Element 15
 | TareQualifierCode | Element 8
 | TareWeight | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillNumber | Element 3
 | Weight | Element 5
 | WeightAllowance | Element 9
 | WeightAllowanceTypeCode | Element 10
 | WeightQualifier | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G5


G5 Constructor

G5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► G5()()()()
RDPCrystal EDI Library
Initializes a new instance of the G5 class
Declaration Syntax
C# Visual Basic Visual C++
public G5()
Public Sub New
public:
G5()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► CommodityCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► Date1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► FreightRate
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► RateValueQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► ReferenceIdentification
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TareQualifierCode Property

TareQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► TareQualifierCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TareQualifierCode { get; set; }
Public Property TareQualifierCode As String
    Get
    Set
public:
property String^ TareQualifierCode {
    String^ get ();
    void set (String^ value);
}


TareWeight Property

TareWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► TareWeight
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TareWeight { get; set; }
Public Property TareWeight As String
    Get
    Set
public:
property String^ TareWeight {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► WaybillNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► Weight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightAllowance Property

WeightAllowance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► WeightAllowance
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string WeightAllowance { get; set; }
Public Property WeightAllowance As String
    Get
    Set
public:
property String^ WeightAllowance {
    String^ get ();
    void set (String^ value);
}


WeightAllowanceTypeCode Property

WeightAllowanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► WeightAllowanceTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string WeightAllowanceTypeCode { get; set; }
Public Property WeightAllowanceTypeCode As String
    Get
    Set
public:
property String^ WeightAllowanceTypeCode {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► WeightQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G50 Class

G50 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50
RDPCrystal EDI Library
Purchase Order Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G50 : DocumentSegment
Public Class G50 _
    Inherits DocumentSegment
public ref class G50 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G50()()()() | Initializes a new instance of the G50 class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LinkSequenceNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MasterReferenceLinkNumber | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderStatusCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 3
 | PurchaseOrderTypeCode | Element 7
 | TaxExemptCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G50


G50 Constructor

G50 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► G50()()()()
RDPCrystal EDI Library
Initializes a new instance of the G50 class
Declaration Syntax
C# Visual Basic Visual C++
public G50()
Public Sub New
public:
G50()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


LinkSequenceNumber Property

LinkSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► LinkSequenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LinkSequenceNumber { get; set; }
Public Property LinkSequenceNumber As String
    Get
    Set
public:
property String^ LinkSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MasterReferenceLinkNumber Property

MasterReferenceLinkNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► MasterReferenceLinkNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MasterReferenceLinkNumber { get; set; }
Public Property MasterReferenceLinkNumber As String
    Get
    Set
public:
property String^ MasterReferenceLinkNumber {
    String^ get ();
    void set (String^ value);
}


OrderStatusCode Property

OrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► OrderStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OrderStatusCode { get; set; }
Public Property OrderStatusCode As String
    Get
    Set
public:
property String^ OrderStatusCode {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderTypeCode Property

PurchaseOrderTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► PurchaseOrderTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderTypeCode { get; set; }
Public Property PurchaseOrderTypeCode As String
    Get
    Set
public:
property String^ PurchaseOrderTypeCode {
    String^ get ();
    void set (String^ value);
}


TaxExemptCode Property

TaxExemptCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► TaxExemptCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TaxExemptCode { get; set; }
Public Property TaxExemptCode As String
    Get
    Set
public:
property String^ TaxExemptCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G50 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G51 Class

G51 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51
RDPCrystal EDI Library
Free Goods/Product Condition
Declaration Syntax
C# Visual Basic Visual C++
public class G51 : DocumentSegment
Public Class G51 _
    Inherits DocumentSegment
public ref class G51 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G51()()()() | Initializes a new instance of the G51 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 8
 | ProductServiceIDQualifier | Element 7
 | QuantityFree | Element 1
 | QuantityMustPurchase | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 4
 | UPCCaseCode | Element 5
 | UPCEANConsumerPackageCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G51


G51 Constructor

G51 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► G51()()()()
RDPCrystal EDI Library
Initializes a new instance of the G51 class
Declaration Syntax
C# Visual Basic Visual C++
public G51()
Public Sub New
public:
G51()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► ProductServiceID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


QuantityFree Property

QuantityFree Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► QuantityFree
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityFree { get; set; }
Public Property QuantityFree As String
    Get
    Set
public:
property String^ QuantityFree {
    String^ get ();
    void set (String^ value);
}


QuantityMustPurchase Property

QuantityMustPurchase Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► QuantityMustPurchase
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityMustPurchase { get; set; }
Public Property QuantityMustPurchase As String
    Get
    Set
public:
property String^ QuantityMustPurchase {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► UPCCaseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G51 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G53 Class

G53 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G53
RDPCrystal EDI Library
Maintenance Type
Declaration Syntax
C# Visual Basic Visual C++
public class G53 : DocumentSegment
Public Class G53 _
    Inherits DocumentSegment
public ref class G53 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G53()()()() | Initializes a new instance of the G53 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G53


G53 Constructor

G53 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G53 ► G53()()()()
RDPCrystal EDI Library
Initializes a new instance of the G53 class
Declaration Syntax
C# Visual Basic Visual C++
public G53()
Public Sub New
public:
G53()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G53 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G53 ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G53 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G54 Class

G54 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54
RDPCrystal EDI Library
Module Description
Declaration Syntax
C# Visual Basic Visual C++
public class G54 : DocumentSegment
Public Class G54 _
    Inherits DocumentSegment
public ref class G54 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G54()()()() | Initializes a new instance of the G54 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 5
 | ProductServiceIDQualifier | Element 4
 | Quantity | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UPCCaseCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G54


G54 Constructor

G54 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► G54()()()()
RDPCrystal EDI Library
Initializes a new instance of the G54 class
Declaration Syntax
C# Visual Basic Visual C++
public G54()
Public Sub New
public:
G54()


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► FreeformDescription
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► ProductServiceID
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► UPCCaseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G54 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G55 Class

G55 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55
RDPCrystal EDI Library
Item Characteristics - Consumer Unit
Declaration Syntax
C# Visual Basic Visual C++
public class G55 : DocumentSegment
Public Class G55 _
    Inherits DocumentSegment
public ref class G55 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G55()()()() | Initializes a new instance of the G55 class
 | CashRegisterItemDescription | Element 16
 | CashRegisterItemDescription1 | Element 17
 | Color | Element 22
 | CouponFamilyCode | Element 18
 | DatedProductNumberOfDays | Element 19
 | DepositValue | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 31
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 5
 | InnerPack | Element 32
 | Length | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 13
 | PackagingCode | Element 33
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 2
 | ProductServiceID1 | Element 4
 | ProductServiceID2 | Element 30
 | ProductServiceIDQualifier | Element 1
 | ProductServiceIDQualifier1 | Element 3
 | ProductServiceIDQualifier2 | Element 29
 | Size | Element 14
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | UnitOrBasisForMeasurementCode1 | Element 8
 | UnitOrBasisForMeasurementCode2 | Element 10
 | UnitOrBasisForMeasurementCode3 | Element 12
 | UnitOrBasisForMeasurementCode4 | Element 15
 | UnitWeight | Element 23
 | UnitWeight1 | Element 26
 | Volume | Element 11
 | WeightQualifier | Element 24
 | WeightQualifier1 | Element 27
 | WeightUnitCode | Element 25
 | WeightUnitCode1 | Element 28
 | Width | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 21
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G55


G55 Constructor

G55 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► G55()()()()
RDPCrystal EDI Library
Initializes a new instance of the G55 class
Declaration Syntax
C# Visual Basic Visual C++
public G55()
Public Sub New
public:
G55()


CashRegisterItemDescription Property

CashRegisterItemDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► CashRegisterItemDescription
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string CashRegisterItemDescription { get; set; }
Public Property CashRegisterItemDescription As String
    Get
    Set
public:
property String^ CashRegisterItemDescription {
    String^ get ();
    void set (String^ value);
}


CashRegisterItemDescription1 Property

CashRegisterItemDescription1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► CashRegisterItemDescription1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string CashRegisterItemDescription1 { get; set; }
Public Property CashRegisterItemDescription1 As String
    Get
    Set
public:
property String^ CashRegisterItemDescription1 {
    String^ get ();
    void set (String^ value);
}


Color Property

Color Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Color
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string Color { get; set; }
Public Property Color As String
    Get
    Set
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}


CouponFamilyCode Property

CouponFamilyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► CouponFamilyCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string CouponFamilyCode { get; set; }
Public Property CouponFamilyCode As String
    Get
    Set
public:
property String^ CouponFamilyCode {
    String^ get ();
    void set (String^ value);
}


DatedProductNumberOfDays Property

DatedProductNumberOfDays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► DatedProductNumberOfDays
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DatedProductNumberOfDays { get; set; }
Public Property DatedProductNumberOfDays As String
    Get
    Set
public:
property String^ DatedProductNumberOfDays {
    String^ get ();
    void set (String^ value);
}


DepositValue Property

DepositValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► DepositValue
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string DepositValue { get; set; }
Public Property DepositValue As String
    Get
    Set
public:
property String^ DepositValue {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► FreeformDescription
RDPCrystal EDI Library
Element 31
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Height
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► InnerPack
RDPCrystal EDI Library
Element 32
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Length
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Pack
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► PackagingCode
RDPCrystal EDI Library
Element 33
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► ProductServiceID1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► ProductServiceID2
RDPCrystal EDI Library
Element 30
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Size
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}


UnitWeight Property

UnitWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitWeight
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight { get; set; }
Public Property UnitWeight As String
    Get
    Set
public:
property String^ UnitWeight {
    String^ get ();
    void set (String^ value);
}


UnitWeight1 Property

UnitWeight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► UnitWeight1
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight1 { get; set; }
Public Property UnitWeight1 As String
    Get
    Set
public:
property String^ UnitWeight1 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Volume
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► WeightQualifier
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightQualifier1 Property

WeightQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► WeightQualifier1
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier1 { get; set; }
Public Property WeightQualifier1 As String
    Get
    Set
public:
property String^ WeightQualifier1 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► WeightUnitCode
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode1 Property

WeightUnitCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► WeightUnitCode1
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode1 { get; set; }
Public Property WeightUnitCode1 As String
    Get
    Set
public:
property String^ WeightUnitCode1 {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Width
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G55 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


G61 Class

G61 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61
RDPCrystal EDI Library
Contact
Declaration Syntax
C# Visual Basic Visual C++
public class G61 : DocumentSegment
Public Class G61 _
    Inherits DocumentSegment
public ref class G61 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G61()()()() | Initializes a new instance of the G61 class
 | CommunicationNumber | Element 4
 | CommunicationNumberQualifier | Element 3
 | ContactFunctionCode | Element 1
 | ContactInquiryReference | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G61


G61 Constructor

G61 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► G61()()()()
RDPCrystal EDI Library
Initializes a new instance of the G61 class
Declaration Syntax
C# Visual Basic Visual C++
public G61()
Public Sub New
public:
G61()


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► CommunicationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier Property

CommunicationNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► CommunicationNumberQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier { get; set; }
Public Property CommunicationNumberQualifier As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier {
    String^ get ();
    void set (String^ value);
}


ContactFunctionCode Property

ContactFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► ContactFunctionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContactFunctionCode { get; set; }
Public Property ContactFunctionCode As String
    Get
    Set
public:
property String^ ContactFunctionCode {
    String^ get ();
    void set (String^ value);
}


ContactInquiryReference Property

ContactInquiryReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► ContactInquiryReference
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ContactInquiryReference { get; set; }
Public Property ContactInquiryReference As String
    Get
    Set
public:
property String^ ContactInquiryReference {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G61 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G62 Class

G62 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62
RDPCrystal EDI Library
Date/Time
Declaration Syntax
C# Visual Basic Visual C++
public class G62 : DocumentSegment
Public Class G62 _
    Inherits DocumentSegment
public ref class G62 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G62()()()() | Initializes a new instance of the G62 class
 | Date | Element 2
 | DateQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 4
 | TimeCode | Element 5
 | TimeQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G62


G62 Constructor

G62 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► G62()()()()
RDPCrystal EDI Library
Initializes a new instance of the G62 class
Declaration Syntax
C# Visual Basic Visual C++
public G62()
Public Sub New
public:
G62()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateQualifier Property

DateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► DateQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateQualifier { get; set; }
Public Property DateQualifier As String
    Get
    Set
public:
property String^ DateQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► TimeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


TimeQualifier Property

TimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► TimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TimeQualifier { get; set; }
Public Property TimeQualifier As String
    Get
    Set
public:
property String^ TimeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G62 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G63 Class

G63 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63
RDPCrystal EDI Library
Period
Declaration Syntax
C# Visual Basic Visual C++
public class G63 : DocumentSegment
Public Class G63 _
    Inherits DocumentSegment
public ref class G63 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G63()()()() | Initializes a new instance of the G63 class
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TariffApplicationCode | Element 3
 | TimePeriodQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G63


G63 Constructor

G63 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► G63()()()()
RDPCrystal EDI Library
Initializes a new instance of the G63 class
Declaration Syntax
C# Visual Basic Visual C++
public G63()
Public Sub New
public:
G63()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► NumberOfPeriods
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode Property

TariffApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► TariffApplicationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode { get; set; }
Public Property TariffApplicationCode As String
    Get
    Set
public:
property String^ TariffApplicationCode {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► TimePeriodQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G63 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G66 Class

G66 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66
RDPCrystal EDI Library
Transportation Instructions
Declaration Syntax
C# Visual Basic Visual C++
public class G66 : DocumentSegment
Public Class G66 _
    Inherits DocumentSegment
public ref class G66 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G66()()()() | Initializes a new instance of the G66 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FOBPoint | Element 7
 | FOBPointCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletExchangeCode | Element 3
 | Routing | Element 5
 | ShipmentMethodOfPayment | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 2
 | UnitLoadOptionCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G66


G66 Constructor

G66 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► G66()()()()
RDPCrystal EDI Library
Initializes a new instance of the G66 class
Declaration Syntax
C# Visual Basic Visual C++
public G66()
Public Sub New
public:
G66()


FOBPoint Property

FOBPoint Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► FOBPoint
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPoint { get; set; }
Public Property FOBPoint As String
    Get
    Set
public:
property String^ FOBPoint {
    String^ get ();
    void set (String^ value);
}


FOBPointCode Property

FOBPointCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► FOBPointCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPointCode { get; set; }
Public Property FOBPointCode As String
    Get
    Set
public:
property String^ FOBPointCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► PalletExchangeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► Routing
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitLoadOptionCode Property

UnitLoadOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► UnitLoadOptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitLoadOptionCode { get; set; }
Public Property UnitLoadOptionCode As String
    Get
    Set
public:
property String^ UnitLoadOptionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G66 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G68 Class

G68 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68
RDPCrystal EDI Library
Line Item Detail - Product
Declaration Syntax
C# Visual Basic Visual C++
public class G68 : DocumentSegment
Public Class G68 _
    Inherits DocumentSegment
public ref class G68 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G68()()()() | Initializes a new instance of the G68 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemListCost | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrePriceQuantityDesignator | Element 14
 | PriceBracketIdentifier | Element 9
 | PriceListIssueNumber | Element 13
 | PriceListNumber | Element 12
 | ProductServiceID | Element 6
 | ProductServiceID1 | Element 8
 | ProductServiceIDQualifier | Element 5
 | ProductServiceIDQualifier1 | Element 7
 | QuantityCost | Element 10
 | QuantityOrdered | Element 1
 | RetailPrePrice | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 11
 | UPCCaseCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G68


G68 Constructor

G68 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► G68()()()()
RDPCrystal EDI Library
Initializes a new instance of the G68 class
Declaration Syntax
C# Visual Basic Visual C++
public G68()
Public Sub New
public:
G68()


ItemListCost Property

ItemListCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► ItemListCost
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ItemListCost { get; set; }
Public Property ItemListCost As String
    Get
    Set
public:
property String^ ItemListCost {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrePriceQuantityDesignator Property

PrePriceQuantityDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► PrePriceQuantityDesignator
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PrePriceQuantityDesignator { get; set; }
Public Property PrePriceQuantityDesignator As String
    Get
    Set
public:
property String^ PrePriceQuantityDesignator {
    String^ get ();
    void set (String^ value);
}


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


PriceListIssueNumber Property

PriceListIssueNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► PriceListIssueNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string PriceListIssueNumber { get; set; }
Public Property PriceListIssueNumber As String
    Get
    Set
public:
property String^ PriceListIssueNumber {
    String^ get ();
    void set (String^ value);
}


PriceListNumber Property

PriceListNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► PriceListNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PriceListNumber { get; set; }
Public Property PriceListNumber As String
    Get
    Set
public:
property String^ PriceListNumber {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► ProductServiceID1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


QuantityCost Property

QuantityCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► QuantityCost
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityCost { get; set; }
Public Property QuantityCost As String
    Get
    Set
public:
property String^ QuantityCost {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► QuantityOrdered
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


RetailPrePrice Property

RetailPrePrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► RetailPrePrice
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RetailPrePrice { get; set; }
Public Property RetailPrePrice As String
    Get
    Set
public:
property String^ RetailPrePrice {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► UPCCaseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G68 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G69 Class

G69 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G69
RDPCrystal EDI Library
Line Item Detail - Description
Declaration Syntax
C# Visual Basic Visual C++
public class G69 : DocumentSegment
Public Class G69 _
    Inherits DocumentSegment
public ref class G69 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G69()()()() | Initializes a new instance of the G69 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G69


G69 Constructor

G69 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G69 ► G69()()()()
RDPCrystal EDI Library
Initializes a new instance of the G69 class
Declaration Syntax
C# Visual Basic Visual C++
public G69()
Public Sub New
public:
G69()


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G69 ► FreeformDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G69 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G69 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G70 Class

G70 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70
RDPCrystal EDI Library
Line Item Detail - Miscellaneous
Declaration Syntax
C# Visual Basic Visual C++
public class G70 : DocumentSegment
Public Class G70 _
    Inherits DocumentSegment
public ref class G70 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G70()()()() | Initializes a new instance of the G70 class
 | Color | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InnerPack | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletBlockAndTiers | Element 9
 | PriceReasonCode | Element 5
 | PurchaseOrderInstructionCode | Element 4
 | Size | Element 2
 | TaxExemptCode | Element 7
 | TermsExceptionCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G70


G70 Constructor

G70 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► G70()()()()
RDPCrystal EDI Library
Initializes a new instance of the G70 class
Declaration Syntax
C# Visual Basic Visual C++
public G70()
Public Sub New
public:
G70()


Color Property

Color Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► Color
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Color { get; set; }
Public Property Color As String
    Get
    Set
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► InnerPack
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► Pack
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


PalletBlockAndTiers Property

PalletBlockAndTiers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► PalletBlockAndTiers
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PalletBlockAndTiers { get; set; }
Public Property PalletBlockAndTiers As String
    Get
    Set
public:
property String^ PalletBlockAndTiers {
    String^ get ();
    void set (String^ value);
}


PriceReasonCode Property

PriceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► PriceReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PriceReasonCode { get; set; }
Public Property PriceReasonCode As String
    Get
    Set
public:
property String^ PriceReasonCode {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderInstructionCode Property

PurchaseOrderInstructionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► PurchaseOrderInstructionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderInstructionCode { get; set; }
Public Property PurchaseOrderInstructionCode As String
    Get
    Set
public:
property String^ PurchaseOrderInstructionCode {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► Size
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


TaxExemptCode Property

TaxExemptCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► TaxExemptCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TaxExemptCode { get; set; }
Public Property TaxExemptCode As String
    Get
    Set
public:
property String^ TaxExemptCode {
    String^ get ();
    void set (String^ value);
}


TermsExceptionCode Property

TermsExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► TermsExceptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TermsExceptionCode { get; set; }
Public Property TermsExceptionCode As String
    Get
    Set
public:
property String^ TermsExceptionCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G70 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G72 Class

G72 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72
RDPCrystal EDI Library
Allowance or Charge
Declaration Syntax
C# Visual Basic Visual C++
public class G72 : DocumentSegment
Public Class G72 _
    Inherits DocumentSegment
public ref class G72 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G72()()()() | Initializes a new instance of the G72 class
 | AllowanceOrChargeCode | Element 1
 | AllowanceOrChargeMethodOfHandlingCode | Element 2
 | AllowanceOrChargeNumber | Element 3
 | AllowanceOrChargeQuantity | Element 6
 | AllowanceOrChargeRate | Element 5
 | AllowanceOrChargeTotalAmount | Element 8
 | DollarBasisForPercent | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionNumber | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OptionNumber | Element 11
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G72


G72 Constructor

G72 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► G72()()()()
RDPCrystal EDI Library
Initializes a new instance of the G72 class
Declaration Syntax
C# Visual Basic Visual C++
public G72()
Public Sub New
public:
G72()


AllowanceOrChargeCode Property

AllowanceOrChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► AllowanceOrChargeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeCode { get; set; }
Public Property AllowanceOrChargeCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeMethodOfHandlingCode Property

AllowanceOrChargeMethodOfHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► AllowanceOrChargeMethodOfHandlingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeMethodOfHandlingCode { get; set; }
Public Property AllowanceOrChargeMethodOfHandlingCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeMethodOfHandlingCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeNumber Property

AllowanceOrChargeNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► AllowanceOrChargeNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeNumber { get; set; }
Public Property AllowanceOrChargeNumber As String
    Get
    Set
public:
property String^ AllowanceOrChargeNumber {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeQuantity Property

AllowanceOrChargeQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► AllowanceOrChargeQuantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeQuantity { get; set; }
Public Property AllowanceOrChargeQuantity As String
    Get
    Set
public:
property String^ AllowanceOrChargeQuantity {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeRate Property

AllowanceOrChargeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► AllowanceOrChargeRate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeRate { get; set; }
Public Property AllowanceOrChargeRate As String
    Get
    Set
public:
property String^ AllowanceOrChargeRate {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeTotalAmount Property

AllowanceOrChargeTotalAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► AllowanceOrChargeTotalAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeTotalAmount { get; set; }
Public Property AllowanceOrChargeTotalAmount As String
    Get
    Set
public:
property String^ AllowanceOrChargeTotalAmount {
    String^ get ();
    void set (String^ value);
}


DollarBasisForPercent Property

DollarBasisForPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► DollarBasisForPercent
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DollarBasisForPercent { get; set; }
Public Property DollarBasisForPercent As String
    Get
    Set
public:
property String^ DollarBasisForPercent {
    String^ get ();
    void set (String^ value);
}


ExceptionNumber Property

ExceptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► ExceptionNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ExceptionNumber { get; set; }
Public Property ExceptionNumber As String
    Get
    Set
public:
property String^ ExceptionNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OptionNumber Property

OptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► OptionNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string OptionNumber { get; set; }
Public Property OptionNumber As String
    Get
    Set
public:
property String^ OptionNumber {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► Percent
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G72 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G73 Class

G73 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G73
RDPCrystal EDI Library
Allowance or Charge Description
Declaration Syntax
C# Visual Basic Visual C++
public class G73 : DocumentSegment
Public Class G73 _
    Inherits DocumentSegment
public ref class G73 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G73()()()() | Initializes a new instance of the G73 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G73


G73 Constructor

G73 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G73 ► G73()()()()
RDPCrystal EDI Library
Initializes a new instance of the G73 class
Declaration Syntax
C# Visual Basic Visual C++
public G73()
Public Sub New
public:
G73()


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G73 ► FreeformDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G73 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G73 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G76 Class

G76 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76
RDPCrystal EDI Library
Total Purchase Order
Declaration Syntax
C# Visual Basic Visual C++
public class G76 : DocumentSegment
Public Class G76 _
    Inherits DocumentSegment
public ref class G76 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G76()()()() | Initializes a new instance of the G76 class
 | Amount | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderSizingFactor | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 10
 | PriceBracketIdentifier | Element 9
 | QuantityOrdered | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 4
 | UnitOrBasisForMeasurementCode2 | Element 6
 | Volume | Element 5
 | Weight | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G76


G76 Constructor

G76 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► G76()()()()
RDPCrystal EDI Library
Initializes a new instance of the G76 class
Declaration Syntax
C# Visual Basic Visual C++
public G76()
Public Sub New
public:
G76()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► Amount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OrderSizingFactor Property

OrderSizingFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► OrderSizingFactor
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string OrderSizingFactor { get; set; }
Public Property OrderSizingFactor As String
    Get
    Set
public:
property String^ OrderSizingFactor {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► PaymentMethodCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► QuantityOrdered
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► Volume
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G76 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G82 Class

G82 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82
RDPCrystal EDI Library
Delivery/Return Base Record Identifier
Declaration Syntax
C# Visual Basic Visual C++
public class G82 : DocumentSegment
Public Class G82 _
    Inherits DocumentSegment
public ref class G82 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G82()()()() | Initializes a new instance of the G82 class
 | CODMethodOfPaymentCode | Element 12
 | CreditDebitFlagCode | Element 1
 | DUNSNumber | Element 3
 | DUNSNumber1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PhysicalDeliveryOrReturnDate | Element 7
 | ProductOwnershipTransferDate | Element 8
 | PurchaseOrderDate | Element 10
 | PurchaseOrderNumber | Element 9
 | ReceiverLocationNumber | Element 4
 | ShipmentMethodOfPayment | Element 11
 | SupplierDeliveryReturnNumber | Element 2
 | SupplierLocationNumber | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G82


G82 Constructor

G82 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► G82()()()()
RDPCrystal EDI Library
Initializes a new instance of the G82 class
Declaration Syntax
C# Visual Basic Visual C++
public G82()
Public Sub New
public:
G82()


CODMethodOfPaymentCode Property

CODMethodOfPaymentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► CODMethodOfPaymentCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CODMethodOfPaymentCode { get; set; }
Public Property CODMethodOfPaymentCode As String
    Get
    Set
public:
property String^ CODMethodOfPaymentCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


DUNSNumber Property

DUNSNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► DUNSNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DUNSNumber { get; set; }
Public Property DUNSNumber As String
    Get
    Set
public:
property String^ DUNSNumber {
    String^ get ();
    void set (String^ value);
}


DUNSNumber1 Property

DUNSNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► DUNSNumber1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DUNSNumber1 { get; set; }
Public Property DUNSNumber1 As String
    Get
    Set
public:
property String^ DUNSNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PhysicalDeliveryOrReturnDate Property

PhysicalDeliveryOrReturnDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► PhysicalDeliveryOrReturnDate
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PhysicalDeliveryOrReturnDate { get; set; }
Public Property PhysicalDeliveryOrReturnDate As String
    Get
    Set
public:
property String^ PhysicalDeliveryOrReturnDate {
    String^ get ();
    void set (String^ value);
}


ProductOwnershipTransferDate Property

ProductOwnershipTransferDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► ProductOwnershipTransferDate
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOwnershipTransferDate { get; set; }
Public Property ProductOwnershipTransferDate As String
    Get
    Set
public:
property String^ ProductOwnershipTransferDate {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderDate Property

PurchaseOrderDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► PurchaseOrderDate
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderDate { get; set; }
Public Property PurchaseOrderDate As String
    Get
    Set
public:
property String^ PurchaseOrderDate {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReceiverLocationNumber Property

ReceiverLocationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► ReceiverLocationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReceiverLocationNumber { get; set; }
Public Property ReceiverLocationNumber As String
    Get
    Set
public:
property String^ ReceiverLocationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


SupplierDeliveryReturnNumber Property

SupplierDeliveryReturnNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► SupplierDeliveryReturnNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SupplierDeliveryReturnNumber { get; set; }
Public Property SupplierDeliveryReturnNumber As String
    Get
    Set
public:
property String^ SupplierDeliveryReturnNumber {
    String^ get ();
    void set (String^ value);
}


SupplierLocationNumber Property

SupplierLocationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► SupplierLocationNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SupplierLocationNumber { get; set; }
Public Property SupplierLocationNumber As String
    Get
    Set
public:
property String^ SupplierLocationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G82 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G83 Class

G83 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83
RDPCrystal EDI Library
Line Item Detail/Direct Store Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class G83 : DocumentSegment
Public Class G83 _
    Inherits DocumentSegment
public ref class G83 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G83()()()() | Initializes a new instance of the G83 class
 | CashRegisterItemDescription | Element 10
 | DirectStoreDeliverySequenceNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InnerPack | Element 13
 | ItemListCost | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 6
 | ProductServiceID1 | Element 12
 | ProductServiceIDQualifier | Element 5
 | ProductServiceIDQualifier1 | Element 11
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UPCCaseCode | Element 7
 | UPCEANConsumerPackageCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G83


G83 Constructor

G83 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► G83()()()()
RDPCrystal EDI Library
Initializes a new instance of the G83 class
Declaration Syntax
C# Visual Basic Visual C++
public G83()
Public Sub New
public:
G83()


CashRegisterItemDescription Property

CashRegisterItemDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► CashRegisterItemDescription
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CashRegisterItemDescription { get; set; }
Public Property CashRegisterItemDescription As String
    Get
    Set
public:
property String^ CashRegisterItemDescription {
    String^ get ();
    void set (String^ value);
}


DirectStoreDeliverySequenceNumber Property

DirectStoreDeliverySequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► DirectStoreDeliverySequenceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DirectStoreDeliverySequenceNumber { get; set; }
Public Property DirectStoreDeliverySequenceNumber As String
    Get
    Set
public:
property String^ DirectStoreDeliverySequenceNumber {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► InnerPack
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


ItemListCost Property

ItemListCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► ItemListCost
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ItemListCost { get; set; }
Public Property ItemListCost As String
    Get
    Set
public:
property String^ ItemListCost {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► Pack
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► ProductServiceID1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► UPCCaseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G83 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G84 Class

G84 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84
RDPCrystal EDI Library
Delivery/Return Record of Totals
Declaration Syntax
C# Visual Basic Visual C++
public class G84 : DocumentSegment
Public Class G84 _
    Inherits DocumentSegment
public ref class G84 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G84()()()() | Initializes a new instance of the G84 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalDepositDollarAmount | Element 3
 | TotalInvoiceAmount | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G84


G84 Constructor

G84 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84 ► G84()()()()
RDPCrystal EDI Library
Initializes a new instance of the G84 class
Declaration Syntax
C# Visual Basic Visual C++
public G84()
Public Sub New
public:
G84()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TotalDepositDollarAmount Property

TotalDepositDollarAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84 ► TotalDepositDollarAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TotalDepositDollarAmount { get; set; }
Public Property TotalDepositDollarAmount As String
    Get
    Set
public:
property String^ TotalDepositDollarAmount {
    String^ get ();
    void set (String^ value);
}


TotalInvoiceAmount Property

TotalInvoiceAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84 ► TotalInvoiceAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TotalInvoiceAmount { get; set; }
Public Property TotalInvoiceAmount As String
    Get
    Set
public:
property String^ TotalInvoiceAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G84 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G85 Class

G85 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G85
RDPCrystal EDI Library
Record Integrity Check
Declaration Syntax
C# Visual Basic Visual C++
public class G85 : DocumentSegment
Public Class G85 _
    Inherits DocumentSegment
public ref class G85 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G85()()()() | Initializes a new instance of the G85 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntegrityCheckValue | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G85


G85 Constructor

G85 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G85 ► G85()()()()
RDPCrystal EDI Library
Initializes a new instance of the G85 class
Declaration Syntax
C# Visual Basic Visual C++
public G85()
Public Sub New
public:
G85()


IntegrityCheckValue Property

IntegrityCheckValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G85 ► IntegrityCheckValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IntegrityCheckValue { get; set; }
Public Property IntegrityCheckValue As String
    Get
    Set
public:
property String^ IntegrityCheckValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G85 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G85 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G86 Class

G86 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G86
RDPCrystal EDI Library
Signature
Declaration Syntax
C# Visual Basic Visual C++
public class G86 : DocumentSegment
Public Class G86 _
    Inherits DocumentSegment
public ref class G86 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G86()()()() | Initializes a new instance of the G86 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Signature | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G86


G86 Constructor

G86 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G86 ► G86()()()()
RDPCrystal EDI Library
Initializes a new instance of the G86 class
Declaration Syntax
C# Visual Basic Visual C++
public G86()
Public Sub New
public:
G86()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G86 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G86 ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Signature Property

Signature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G86 ► Signature
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Signature { get; set; }
Public Property Signature As String
    Get
    Set
public:
property String^ Signature {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G86 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G87 Class

G87 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87
RDPCrystal EDI Library
Delivery/Return Adjustment Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G87 : DocumentSegment
Public Class G87 _
    Inherits DocumentSegment
public ref class G87 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G87()()()() | Initializes a new instance of the G87 class
 | AdjustmentNumber | Element 5
 | CreditDebitFlagCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InitiatorCode | Element 1
 | IntegrityCheckValue | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReceiverDeliveryReturnNumber | Element 6
 | SupplierDeliveryReturnNumber | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G87


G87 Constructor

G87 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► G87()()()()
RDPCrystal EDI Library
Initializes a new instance of the G87 class
Declaration Syntax
C# Visual Basic Visual C++
public G87()
Public Sub New
public:
G87()


AdjustmentNumber Property

AdjustmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► AdjustmentNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentNumber { get; set; }
Public Property AdjustmentNumber As String
    Get
    Set
public:
property String^ AdjustmentNumber {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


InitiatorCode Property

InitiatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► InitiatorCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InitiatorCode { get; set; }
Public Property InitiatorCode As String
    Get
    Set
public:
property String^ InitiatorCode {
    String^ get ();
    void set (String^ value);
}


IntegrityCheckValue Property

IntegrityCheckValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► IntegrityCheckValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IntegrityCheckValue { get; set; }
Public Property IntegrityCheckValue As String
    Get
    Set
public:
property String^ IntegrityCheckValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReceiverDeliveryReturnNumber Property

ReceiverDeliveryReturnNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► ReceiverDeliveryReturnNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReceiverDeliveryReturnNumber { get; set; }
Public Property ReceiverDeliveryReturnNumber As String
    Get
    Set
public:
property String^ ReceiverDeliveryReturnNumber {
    String^ get ();
    void set (String^ value);
}


SupplierDeliveryReturnNumber Property

SupplierDeliveryReturnNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► SupplierDeliveryReturnNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SupplierDeliveryReturnNumber { get; set; }
Public Property SupplierDeliveryReturnNumber As String
    Get
    Set
public:
property String^ SupplierDeliveryReturnNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G87 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G88 Class

G88 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88
RDPCrystal EDI Library
Delivery/Return Identification Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class G88 : DocumentSegment
Public Class G88 _
    Inherits DocumentSegment
public ref class G88 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G88()()()() | Initializes a new instance of the G88 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PhysicalDeliveryOrReturnDate | Element 1
 | ProductOwnershipTransferDate | Element 2
 | PurchaseOrderDate | Element 4
 | PurchaseOrderNumber | Element 3
 | ReceiverLocationNumber | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G88


G88 Constructor

G88 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► G88()()()()
RDPCrystal EDI Library
Initializes a new instance of the G88 class
Declaration Syntax
C# Visual Basic Visual C++
public G88()
Public Sub New
public:
G88()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PhysicalDeliveryOrReturnDate Property

PhysicalDeliveryOrReturnDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► PhysicalDeliveryOrReturnDate
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PhysicalDeliveryOrReturnDate { get; set; }
Public Property PhysicalDeliveryOrReturnDate As String
    Get
    Set
public:
property String^ PhysicalDeliveryOrReturnDate {
    String^ get ();
    void set (String^ value);
}


ProductOwnershipTransferDate Property

ProductOwnershipTransferDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► ProductOwnershipTransferDate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOwnershipTransferDate { get; set; }
Public Property ProductOwnershipTransferDate As String
    Get
    Set
public:
property String^ ProductOwnershipTransferDate {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderDate Property

PurchaseOrderDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► PurchaseOrderDate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderDate { get; set; }
Public Property PurchaseOrderDate As String
    Get
    Set
public:
property String^ PurchaseOrderDate {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReceiverLocationNumber Property

ReceiverLocationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► ReceiverLocationNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReceiverLocationNumber { get; set; }
Public Property ReceiverLocationNumber As String
    Get
    Set
public:
property String^ ReceiverLocationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G88 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G89 Class

G89 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89
RDPCrystal EDI Library
Line-Item Detail Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class G89 : DocumentSegment
Public Class G89 _
    Inherits DocumentSegment
public ref class G89 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G89()()()() | Initializes a new instance of the G89 class
 | DirectStoreDeliverySequenceNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InnerPack | Element 10
 | ItemListCost | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 6
 | ProductServiceIDQualifier | Element 5
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UPCCaseCode | Element 7
 | UPCEANConsumerPackageCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G89


G89 Constructor

G89 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► G89()()()()
RDPCrystal EDI Library
Initializes a new instance of the G89 class
Declaration Syntax
C# Visual Basic Visual C++
public G89()
Public Sub New
public:
G89()


DirectStoreDeliverySequenceNumber Property

DirectStoreDeliverySequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► DirectStoreDeliverySequenceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DirectStoreDeliverySequenceNumber { get; set; }
Public Property DirectStoreDeliverySequenceNumber As String
    Get
    Set
public:
property String^ DirectStoreDeliverySequenceNumber {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► InnerPack
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


ItemListCost Property

ItemListCost Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► ItemListCost
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ItemListCost { get; set; }
Public Property ItemListCost As String
    Get
    Set
public:
property String^ ItemListCost {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► Pack
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► UPCCaseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G89 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G91 Class

G91 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G91
RDPCrystal EDI Library
Price Change Status
Declaration Syntax
C# Visual Basic Visual C++
public class G91 : DocumentSegment
Public Class G91 _
    Inherits DocumentSegment
public ref class G91 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G91()()()() | Initializes a new instance of the G91 class
 | ChangeTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G91


G91 Constructor

G91 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G91 ► G91()()()()
RDPCrystal EDI Library
Initializes a new instance of the G91 class
Declaration Syntax
C# Visual Basic Visual C++
public G91()
Public Sub New
public:
G91()


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G91 ► ChangeTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G91 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G91 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G92 Class

G92 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92
RDPCrystal EDI Library
Purchase Order Change Type
Declaration Syntax
C# Visual Basic Visual C++
public class G92 : DocumentSegment
Public Class G92 _
    Inherits DocumentSegment
public ref class G92 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G92()()()() | Initializes a new instance of the G92 class
 | ChangeOrResponseTypeCode | Element 1
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G92


G92 Constructor

G92 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92 ► G92()()()()
RDPCrystal EDI Library
Initializes a new instance of the G92 class
Declaration Syntax
C# Visual Basic Visual C++
public G92()
Public Sub New
public:
G92()


ChangeOrResponseTypeCode Property

ChangeOrResponseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92 ► ChangeOrResponseTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrResponseTypeCode { get; set; }
Public Property ChangeOrResponseTypeCode As String
    Get
    Set
public:
property String^ ChangeOrResponseTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G92 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G93 Class

G93 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93
RDPCrystal EDI Library
Price Bracket Identification
Declaration Syntax
C# Visual Basic Visual C++
public class G93 : DocumentSegment
Public Class G93 _
    Inherits DocumentSegment
public ref class G93 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G93()()()() | Initializes a new instance of the G93 class
 | ActionCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceBracketIdentifier | Element 1
 | PriceIdentifierCode | Element 6
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 5
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G93


G93 Constructor

G93 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► G93()()()()
RDPCrystal EDI Library
Initializes a new instance of the G93 class
Declaration Syntax
C# Visual Basic Visual C++
public G93()
Public Sub New
public:
G93()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► ActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► FreeformDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► PriceIdentifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G93 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


G94 Class

G94 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G94
RDPCrystal EDI Library
Promotion Conditions
Declaration Syntax
C# Visual Basic Visual C++
public class G94 : DocumentSegment
Public Class G94 _
    Inherits DocumentSegment
public ref class G94 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G94()()()() | Initializes a new instance of the G94 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OptionNumber | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PromotionConditionQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G94


G94 Constructor

G94 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G94 ► G94()()()()
RDPCrystal EDI Library
Initializes a new instance of the G94 class
Declaration Syntax
C# Visual Basic Visual C++
public G94()
Public Sub New
public:
G94()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G94 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OptionNumber Property

OptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G94 ► OptionNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string OptionNumber { get; set; }
Public Property OptionNumber As String
    Get
    Set
public:
property String^ OptionNumber {
    String^ get ();
    void set (String^ value);
}


PromotionConditionQualifier Property

PromotionConditionQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G94 ► PromotionConditionQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PromotionConditionQualifier { get; set; }
Public Property PromotionConditionQualifier As String
    Get
    Set
public:
property String^ PromotionConditionQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G94 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


G95 Class

G95 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95
RDPCrystal EDI Library
Performance Requirements
Declaration Syntax
C# Visual Basic Visual C++
public class G95 : DocumentSegment
Public Class G95 _
    Inherits DocumentSegment
public ref class G95 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | G95()()()() | Initializes a new instance of the G95 class
 | AssignedNumber | Element 2
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PromotionConditionCode | Element 1
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | G95


G95 Constructor

G95 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► G95()()()()
RDPCrystal EDI Library
Initializes a new instance of the G95 class
Declaration Syntax
C# Visual Basic Visual C++
public G95()
Public Sub New
public:
G95()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► AssignedNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► Number
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


PromotionConditionCode Property

PromotionConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► PromotionConditionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PromotionConditionCode { get; set; }
Public Property PromotionConditionCode As String
    Get
    Set
public:
property String^ PromotionConditionCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► G95 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GA Class

GA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA
RDPCrystal EDI Library
Canadian Grain Information
Declaration Syntax
C# Visual Basic Visual C++
public class GA : DocumentSegment
Public Class GA _
    Inherits DocumentSegment
public ref class GA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GA()()()() | Initializes a new instance of the GA class
 | CommodityCode | Element 2
 | CWBMarketingClass | Element 11
 | CWBMarketingClassTypeCode | Element 12
 | Date | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FumigatedCleanedIndicator | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InspectedWeighedIndicatorCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 14
 | MachineSeparableIndicatorCode | Element 10
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 17
 | PercentQualifier | Element 16
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | StateOrProvinceCode | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnloadTerminalElevatorCode | Element 7
 | Week | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 13
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GA


GA Constructor

GA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► GA()()()()
RDPCrystal EDI Library
Initializes a new instance of the GA class
Declaration Syntax
C# Visual Basic Visual C++
public GA()
Public Sub New
public:
GA()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► CommodityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CWBMarketingClass Property

CWBMarketingClass Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► CWBMarketingClass
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CWBMarketingClass { get; set; }
Public Property CWBMarketingClass As String
    Get
    Set
public:
property String^ CWBMarketingClass {
    String^ get ();
    void set (String^ value);
}


CWBMarketingClassTypeCode Property

CWBMarketingClassTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► CWBMarketingClassTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CWBMarketingClassTypeCode { get; set; }
Public Property CWBMarketingClassTypeCode As String
    Get
    Set
public:
property String^ CWBMarketingClassTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FumigatedCleanedIndicator Property

FumigatedCleanedIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► FumigatedCleanedIndicator
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FumigatedCleanedIndicator { get; set; }
Public Property FumigatedCleanedIndicator As String
    Get
    Set
public:
property String^ FumigatedCleanedIndicator {
    String^ get ();
    void set (String^ value);
}


InspectedWeighedIndicatorCode Property

InspectedWeighedIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► InspectedWeighedIndicatorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InspectedWeighedIndicatorCode { get; set; }
Public Property InspectedWeighedIndicatorCode As String
    Get
    Set
public:
property String^ InspectedWeighedIndicatorCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► LocationIdentifier
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


MachineSeparableIndicatorCode Property

MachineSeparableIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► MachineSeparableIndicatorCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MachineSeparableIndicatorCode { get; set; }
Public Property MachineSeparableIndicatorCode As String
    Get
    Set
public:
property String^ MachineSeparableIndicatorCode {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► Number
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► Percent
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PercentQualifier Property

PercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► PercentQualifier
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier { get; set; }
Public Property PercentQualifier As String
    Get
    Set
public:
property String^ PercentQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► StateOrProvinceCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


UnloadTerminalElevatorCode Property

UnloadTerminalElevatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► UnloadTerminalElevatorCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnloadTerminalElevatorCode { get; set; }
Public Property UnloadTerminalElevatorCode As String
    Get
    Set
public:
property String^ UnloadTerminalElevatorCode {
    String^ get ();
    void set (String^ value);
}


Week Property

Week Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► Week
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Week { get; set; }
Public Property Week As String
    Get
    Set
public:
property String^ Week {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


GDP Class

GDP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP
RDPCrystal EDI Library
General Dosing Parameters
Declaration Syntax
C# Visual Basic Visual C++
public class GDP : DocumentSegment
Public Class GDP _
    Inherits DocumentSegment
public ref class GDP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GDP()()()() | Initializes a new instance of the GDP class
 | CompositeUnit | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RouteOfAdministration | Element 3
 | TestPeriodOrIntervalValue | Element 4
 | TestPeriodOrIntervalValue1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 5
 | UnitOfTimePeriodOrInterval1 | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GDP


GDP Constructor

GDP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► GDP()()()()
RDPCrystal EDI Library
Initializes a new instance of the GDP class
Declaration Syntax
C# Visual Basic Visual C++
public GDP()
Public Sub New
public:
GDP()


CompositeUnit Property

CompositeUnit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► CompositeUnit
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CompositeUnit { get; set; }
Public Property CompositeUnit As String
    Get
    Set
public:
property String^ CompositeUnit {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► MeasurementValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


RouteOfAdministration Property

RouteOfAdministration Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► RouteOfAdministration
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RouteOfAdministration { get; set; }
Public Property RouteOfAdministration As String
    Get
    Set
public:
property String^ RouteOfAdministration {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue1 Property

TestPeriodOrIntervalValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► TestPeriodOrIntervalValue1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue1 { get; set; }
Public Property TestPeriodOrIntervalValue1 As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval1 Property

UnitOfTimePeriodOrInterval1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► UnitOfTimePeriodOrInterval1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval1 { get; set; }
Public Property UnitOfTimePeriodOrInterval1 As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GDP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GE Class

GE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GE
RDPCrystal EDI Library
Functional Group Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class GE : DocumentSegment
Public Class GE _
    Inherits DocumentSegment
public ref class GE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GE()()()() | Initializes a new instance of the GE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfTransactionSetsIncluded |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GE


GE Constructor

GE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GE ► GE()()()()
RDPCrystal EDI Library
Initializes a new instance of the GE class
Declaration Syntax
C# Visual Basic Visual C++
public GE()
Public Sub New
public:
GE()


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GE ► GroupControlNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GE ► NumberOfTransactionSetsIncluded
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GF Class

GF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF
RDPCrystal EDI Library
Furnished Goods and Services
Declaration Syntax
C# Visual Basic Visual C++
public class GF : DocumentSegment
Public Class GF _
    Inherits DocumentSegment
public ref class GF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GF()()()() | Initializes a new instance of the GF class
 | ContractNumber | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 6
 | ReferenceIdentification2 | Element 9
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentificationQualifier1 | Element 5
 | ReferenceIdentificationQualifier2 | Element 8
 | ReleaseNumber | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GF


GF Constructor

GF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► GF()()()()
RDPCrystal EDI Library
Initializes a new instance of the GF class
Declaration Syntax
C# Visual Basic Visual C++
public GF()
Public Sub New
public:
GF()


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ContractNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReferenceIdentification2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier2 Property

ReferenceIdentificationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReferenceIdentificationQualifier2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier2 { get; set; }
Public Property ReferenceIdentificationQualifier2 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier2 {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► ReleaseNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GH Class

GH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH
RDPCrystal EDI Library
Group Header
Declaration Syntax
C# Visual Basic Visual C++
public class GH : DocumentSegment
Public Class GH _
    Inherits DocumentSegment
public ref class GH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GH()()()() | Initializes a new instance of the GH class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfLineItems | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RevisionNumber | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GH


GH Constructor

GH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► GH()()()()
RDPCrystal EDI Library
Initializes a new instance of the GH class
Declaration Syntax
C# Visual Basic Visual C++
public GH()
Public Sub New
public:
GH()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfLineItems Property

NumberOfLineItems Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► NumberOfLineItems
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfLineItems { get; set; }
Public Property NumberOfLineItems As String
    Get
    Set
public:
property String^ NumberOfLineItems {
    String^ get ();
    void set (String^ value);
}


RevisionNumber Property

RevisionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► RevisionNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; set; }
Public Property RevisionNumber As String
    Get
    Set
public:
property String^ RevisionNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GID Class

GID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID
RDPCrystal EDI Library
Group Identification
Declaration Syntax
C# Visual Basic Visual C++
public class GID : DocumentSegment
Public Class GID _
    Inherits DocumentSegment
public ref class GID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GID()()()() | Initializes a new instance of the GID class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | Name2 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GID


GID Constructor

GID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID ► GID()()()()
RDPCrystal EDI Library
Initializes a new instance of the GID class
Declaration Syntax
C# Visual Basic Visual C++
public GID()
Public Sub New
public:
GID()


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID ► GenderCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID ► Name2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GR Class

GR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR
RDPCrystal EDI Library
Guarantee Result Detail
Declaration Syntax
C# Visual Basic Visual C++
public class GR : DocumentSegment
Public Class GR _
    Inherits DocumentSegment
public ref class GR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GR()()()() | Initializes a new instance of the GR class
 | DateTimePeriod | Element 4
 | DateTimePeriod1 | Element 6
 | DateTimePeriod2 | Element 8
 | DateTimePeriod3 | Element 16
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimePeriodFormatQualifier1 | Element 5
 | DateTimePeriodFormatQualifier2 | Element 7
 | DateTimePeriodFormatQualifier3 | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 10
 | InterestRate1 | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanRateTypeCode | Element 11
 | LoanStatusCode | Element 2
 | LoanTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 9
 | MonetaryAmount1 | Element 17
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 20
 | ReferenceIdentification | Element 14
 | ReferenceIdentification1 | Element 18
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 13
 | YesNoConditionOrResponseCode1 | Element 19
 | YesNoConditionOrResponseCode2 | Element 21
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GR


GR Constructor

GR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► GR()()()()
RDPCrystal EDI Library
Initializes a new instance of the GR class
Declaration Syntax
C# Visual Basic Visual C++
public GR()
Public Sub New
public:
GR()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriod1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriod2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod3 Property

DateTimePeriod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriod3
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod3 { get; set; }
Public Property DateTimePeriod3 As String
    Get
    Set
public:
property String^ DateTimePeriod3 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier2 Property

DateTimePeriodFormatQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriodFormatQualifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier2 { get; set; }
Public Property DateTimePeriodFormatQualifier2 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier3 Property

DateTimePeriodFormatQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► DateTimePeriodFormatQualifier3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier3 { get; set; }
Public Property DateTimePeriodFormatQualifier3 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier3 {
    String^ get ();
    void set (String^ value);
}


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► InterestRate
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


InterestRate1 Property

InterestRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► InterestRate1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate1 { get; set; }
Public Property InterestRate1 As String
    Get
    Set
public:
property String^ InterestRate1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► LoanRateTypeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanStatusCode Property

LoanStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► LoanStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LoanStatusCode { get; set; }
Public Property LoanStatusCode As String
    Get
    Set
public:
property String^ LoanStatusCode {
    String^ get ();
    void set (String^ value);
}


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► LoanTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► MonetaryAmount
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► MonetaryAmount1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► Quantity
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► ReferenceIdentification
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► ReferenceIdentification1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


GR2 Class

GR2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2
RDPCrystal EDI Library
Train Data
Declaration Syntax
C# Visual Basic Visual C++
public class GR2 : DocumentSegment
Public Class GR2 _
    Inherits DocumentSegment
public ref class GR2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GR2()()()() | Initializes a new instance of the GR2 class
 | CityName | Element 4
 | CountryCode | Element 6
 | Date | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 7
 | InterchangeTrainIdentification1 | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 3
 | LocationQualifier | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 10
 | StandardCarrierAlphaCode2 | Element 11
 | StateOrProvinceCode | Element 5
 | Time | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GR2


GR2 Constructor

GR2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► GR2()()()()
RDPCrystal EDI Library
Initializes a new instance of the GR2 class
Declaration Syntax
C# Visual Basic Visual C++
public GR2()
Public Sub New
public:
GR2()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► CountryCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification1 Property

InterchangeTrainIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► InterchangeTrainIdentification1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification1 { get; set; }
Public Property InterchangeTrainIdentification1 As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► LocationIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► LocationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► Time
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GR4 Class

GR4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4
RDPCrystal EDI Library
Loading Cluster
Declaration Syntax
C# Visual Basic Visual C++
public class GR4 : DocumentSegment
Public Class GR4 _
    Inherits DocumentSegment
public ref class GR4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GR4()()()() | Initializes a new instance of the GR4 class
 | CityName | Element 9
 | ConfigurationTypeCode | Element 1
 | CountryCode | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 2
 | EquipmentInitial | Element 5
 | EquipmentNumber | Element 6
 | EquipmentUseCode | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 8
 | LocationQualifier | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | StateOrProvinceCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GR4


GR4 Constructor

GR4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► GR4()()()()
RDPCrystal EDI Library
Initializes a new instance of the GR4 class
Declaration Syntax
C# Visual Basic Visual C++
public GR4()
Public Sub New
public:
GR4()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► CityName
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


ConfigurationTypeCode Property

ConfigurationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► ConfigurationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigurationTypeCode { get; set; }
Public Property ConfigurationTypeCode As String
    Get
    Set
public:
property String^ ConfigurationTypeCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► CountryCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► EquipmentInitial
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► EquipmentNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentUseCode Property

EquipmentUseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► EquipmentUseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentUseCode { get; set; }
Public Property EquipmentUseCode As String
    Get
    Set
public:
property String^ EquipmentUseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► LocationIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► LocationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GR5 Class

GR5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5
RDPCrystal EDI Library
Loading Details
Declaration Syntax
C# Visual Basic Visual C++
public class GR5 : DocumentSegment
Public Class GR5 _
    Inherits DocumentSegment
public ref class GR5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GR5()()()() | Initializes a new instance of the GR5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 1
 | StatusReasonCode | Element 5
 | SurfaceLayerPositionCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GR5


GR5 Constructor

GR5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► GR5()()()()
RDPCrystal EDI Library
Initializes a new instance of the GR5 class
Declaration Syntax
C# Visual Basic Visual C++
public GR5()
Public Sub New
public:
GR5()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► MeasurementValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► StatusReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GR5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GRI Class

GRI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI
RDPCrystal EDI Library
Statistical Government Information
Declaration Syntax
C# Visual Basic Visual C++
public class GRI : DocumentSegment
Public Class GRI _
    Inherits DocumentSegment
public ref class GRI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GRI()()()() | Initializes a new instance of the GRI class
 | AmountQualifierCode | Element 4
 | Date | Element 9
 | DateTimeQualifier | Element 8
 | Description | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | PercentQualifier | Element 6
 | Quantity | Element 3
 | QuantityQualifier | Element 2
 | ReportedDataResponse | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GRI


GRI Constructor

GRI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► GRI()()()()
RDPCrystal EDI Library
Initializes a new instance of the GRI class
Declaration Syntax
C# Visual Basic Visual C++
public GRI()
Public Sub New
public:
GRI()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► AmountQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► Date
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► DateTimeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PercentQualifier Property

PercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► PercentQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier { get; set; }
Public Property PercentQualifier As String
    Get
    Set
public:
property String^ PercentQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► QuantityQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


ReportedDataResponse Property

ReportedDataResponse Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► ReportedDataResponse
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedDataResponse { get; set; }
Public Property ReportedDataResponse As String
    Get
    Set
public:
property String^ ReportedDataResponse {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GRP Class

GRP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP
RDPCrystal EDI Library
Group Dosage Parameters
Declaration Syntax
C# Visual Basic Visual C++
public class GRP : DocumentSegment
Public Class GRP _
    Inherits DocumentSegment
public ref class GRP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GRP()()()() | Initializes a new instance of the GRP class
 | Date | Element 3
 | Date1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitDoseCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GRP


GRP Constructor

GRP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► GRP()()()()
RDPCrystal EDI Library
Initializes a new instance of the GRP class
Declaration Syntax
C# Visual Basic Visual C++
public GRP()
Public Sub New
public:
GRP()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► Number
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


UnitDoseCode Property

UnitDoseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► UnitDoseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitDoseCode { get; set; }
Public Property UnitDoseCode As String
    Get
    Set
public:
property String^ UnitDoseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GRP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GS Class

GS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS
RDPCrystal EDI Library
Functional Group Header
Declaration Syntax
C# Visual Basic Visual C++
public class GS : DocumentSegment
Public Class GS _
    Inherits DocumentSegment
public ref class GS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GS()()()() | Initializes a new instance of the GS class
 | ApplicationReceiverCode | Element 3
 | ApplicationSenderCode | Element 2
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ResponsibleAgencyCode | Element 7
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionReleaseIndustryIdentifierCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GS


GS Constructor

GS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► GS()()()()
RDPCrystal EDI Library
Initializes a new instance of the GS class
Declaration Syntax
C# Visual Basic Visual C++
public GS()
Public Sub New
public:
GS()


ApplicationReceiverCode Property

ApplicationReceiverCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► ApplicationReceiverCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationReceiverCode { get; set; }
Public Property ApplicationReceiverCode As String
    Get
    Set
public:
property String^ ApplicationReceiverCode {
    String^ get ();
    void set (String^ value);
}


ApplicationSenderCode Property

ApplicationSenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► ApplicationSenderCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationSenderCode { get; set; }
Public Property ApplicationSenderCode As String
    Get
    Set
public:
property String^ ApplicationSenderCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► FunctionalIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► GroupControlNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ResponsibleAgencyCode Property

ResponsibleAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► ResponsibleAgencyCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ResponsibleAgencyCode { get; set; }
Public Property ResponsibleAgencyCode As String
    Get
    Set
public:
property String^ ResponsibleAgencyCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► VersionReleaseIndustryIdentifierCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


GY Class

GY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY
RDPCrystal EDI Library
Geography
Declaration Syntax
C# Visual Basic Visual C++
public class GY : DocumentSegment
Public Class GY _
    Inherits DocumentSegment
public ref class GY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GY()()()() | Initializes a new instance of the GY class
 | ChangeTypeCode | Element 8
 | CityName | Element 14
 | CommodityGeographicLogicalConnectorCode | Element 2
 | DocketControlNumber | Element 10
 | DocketIdentification | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeographyQualifierCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupTitle | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 5
 | LocationIdentifier1 | Element 6
 | LocationQualifier | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 7
 | StandardCarrierAlphaCode1 | Element 9
 | StateOrProvinceCode | Element 4
 | StateOrProvinceCode1 | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 15
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GY


GY Constructor

GY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► GY()()()()
RDPCrystal EDI Library
Initializes a new instance of the GY class
Declaration Syntax
C# Visual Basic Visual C++
public GY()
Public Sub New
public:
GY()


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► ChangeTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► CityName
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CommodityGeographicLogicalConnectorCode Property

CommodityGeographicLogicalConnectorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► CommodityGeographicLogicalConnectorCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityGeographicLogicalConnectorCode { get; set; }
Public Property CommodityGeographicLogicalConnectorCode As String
    Get
    Set
public:
property String^ CommodityGeographicLogicalConnectorCode {
    String^ get ();
    void set (String^ value);
}


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► DocketControlNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► DocketIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


GeographyQualifierCode Property

GeographyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► GeographyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string GeographyQualifierCode { get; set; }
Public Property GeographyQualifierCode As String
    Get
    Set
public:
property String^ GeographyQualifierCode {
    String^ get ();
    void set (String^ value);
}


GroupTitle Property

GroupTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► GroupTitle
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string GroupTitle { get; set; }
Public Property GroupTitle As String
    Get
    Set
public:
property String^ GroupTitle {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► LocationIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► LocationIdentifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► LocationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► GY ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


H1 Class

H1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1
RDPCrystal EDI Library
Hazardous Material
Declaration Syntax
C# Visual Basic Visual C++
public class H1 : DocumentSegment
Public Class H1 _
    Inherits DocumentSegment
public ref class H1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | H1()()()() | Initializes a new instance of the H1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlashpointTemperature | Element 7
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialClassCode | Element 2
 | HazardousMaterialCode | Element 1
 | HazardousMaterialCodeQualifier | Element 3
 | HazardousMaterialContact | Element 5
 | HazardousMaterialDescription | Element 4
 | HazardousMaterialsPage | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackingGroupCode | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | H1


H1 Constructor

H1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► H1()()()()
RDPCrystal EDI Library
Initializes a new instance of the H1 class
Declaration Syntax
C# Visual Basic Visual C++
public H1()
Public Sub New
public:
H1()


FlashpointTemperature Property

FlashpointTemperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► FlashpointTemperature
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FlashpointTemperature { get; set; }
Public Property FlashpointTemperature As String
    Get
    Set
public:
property String^ FlashpointTemperature {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialClassCode Property

HazardousMaterialClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► HazardousMaterialClassCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialClassCode { get; set; }
Public Property HazardousMaterialClassCode As String
    Get
    Set
public:
property String^ HazardousMaterialClassCode {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialCode Property

HazardousMaterialCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► HazardousMaterialCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialCode { get; set; }
Public Property HazardousMaterialCode As String
    Get
    Set
public:
property String^ HazardousMaterialCode {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialCodeQualifier Property

HazardousMaterialCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► HazardousMaterialCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialCodeQualifier { get; set; }
Public Property HazardousMaterialCodeQualifier As String
    Get
    Set
public:
property String^ HazardousMaterialCodeQualifier {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialContact Property

HazardousMaterialContact Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► HazardousMaterialContact
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialContact { get; set; }
Public Property HazardousMaterialContact As String
    Get
    Set
public:
property String^ HazardousMaterialContact {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialDescription Property

HazardousMaterialDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► HazardousMaterialDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialDescription { get; set; }
Public Property HazardousMaterialDescription As String
    Get
    Set
public:
property String^ HazardousMaterialDescription {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialsPage Property

HazardousMaterialsPage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► HazardousMaterialsPage
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialsPage { get; set; }
Public Property HazardousMaterialsPage As String
    Get
    Set
public:
property String^ HazardousMaterialsPage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackingGroupCode Property

PackingGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► PackingGroupCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PackingGroupCode { get; set; }
Public Property PackingGroupCode As String
    Get
    Set
public:
property String^ PackingGroupCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


H2 Class

H2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H2
RDPCrystal EDI Library
Additional Hazardous Material Description
Declaration Syntax
C# Visual Basic Visual C++
public class H2 : DocumentSegment
Public Class H2 _
    Inherits DocumentSegment
public ref class H2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | H2()()()() | Initializes a new instance of the H2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialClassification | Element 2
 | HazardousMaterialDescription | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | H2


H2 Constructor

H2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H2 ► H2()()()()
RDPCrystal EDI Library
Initializes a new instance of the H2 class
Declaration Syntax
C# Visual Basic Visual C++
public H2()
Public Sub New
public:
H2()


HazardousMaterialClassification Property

HazardousMaterialClassification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H2 ► HazardousMaterialClassification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialClassification { get; set; }
Public Property HazardousMaterialClassification As String
    Get
    Set
public:
property String^ HazardousMaterialClassification {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialDescription Property

HazardousMaterialDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H2 ► HazardousMaterialDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialDescription { get; set; }
Public Property HazardousMaterialDescription As String
    Get
    Set
public:
property String^ HazardousMaterialDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


H3 Class

H3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3
RDPCrystal EDI Library
Special Handling Instructions
Declaration Syntax
C# Visual Basic Visual C++
public class H3 : DocumentSegment
Public Class H3 _
    Inherits DocumentSegment
public ref class H3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | H3()()()() | Initializes a new instance of the H3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProtectiveServiceCode | Element 3
 | SpecialHandlingCode | Element 1
 | SpecialHandlingDescription | Element 2
 | TariffApplicationCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VentInstructionCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | H3


H3 Constructor

H3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► H3()()()()
RDPCrystal EDI Library
Initializes a new instance of the H3 class
Declaration Syntax
C# Visual Basic Visual C++
public H3()
Public Sub New
public:
H3()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProtectiveServiceCode Property

ProtectiveServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► ProtectiveServiceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProtectiveServiceCode { get; set; }
Public Property ProtectiveServiceCode As String
    Get
    Set
public:
property String^ ProtectiveServiceCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingDescription Property

SpecialHandlingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► SpecialHandlingDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingDescription { get; set; }
Public Property SpecialHandlingDescription As String
    Get
    Set
public:
property String^ SpecialHandlingDescription {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode Property

TariffApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► TariffApplicationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode { get; set; }
Public Property TariffApplicationCode As String
    Get
    Set
public:
property String^ TariffApplicationCode {
    String^ get ();
    void set (String^ value);
}


VentInstructionCode Property

VentInstructionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► VentInstructionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string VentInstructionCode { get; set; }
Public Property VentInstructionCode As String
    Get
    Set
public:
property String^ VentInstructionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


H5 Class

H5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5
RDPCrystal EDI Library
Car Service Order
Declaration Syntax
C# Visual Basic Visual C++
public class H5 : DocumentSegment
Public Class H5 _
    Inherits DocumentSegment
public ref class H5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | H5()()()() | Initializes a new instance of the H5 class
 | CarServiceOrderCode | Element 1
 | CityName | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | H5


H5 Constructor

H5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5 ► H5()()()()
RDPCrystal EDI Library
Initializes a new instance of the H5 class
Declaration Syntax
C# Visual Basic Visual C++
public H5()
Public Sub New
public:
H5()


CarServiceOrderCode Property

CarServiceOrderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5 ► CarServiceOrderCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CarServiceOrderCode { get; set; }
Public Property CarServiceOrderCode As String
    Get
    Set
public:
property String^ CarServiceOrderCode {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5 ► CityName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


H6 Class

H6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6
RDPCrystal EDI Library
Special Services
Declaration Syntax
C# Visual Basic Visual C++
public class H6 : DocumentSegment
Public Class H6 _
    Inherits DocumentSegment
public ref class H6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | H6()()()() | Initializes a new instance of the H6 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletExchangeCode | Element 4
 | PickupOrDeliveryCode | Element 7
 | QuantityOfPalletsShipped | Element 3
 | SpecialServicesCode | Element 1
 | SpecialServicesCode1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 5
 | WeightUnitCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | H6


H6 Constructor

H6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► H6()()()()
RDPCrystal EDI Library
Initializes a new instance of the H6 class
Declaration Syntax
C# Visual Basic Visual C++
public H6()
Public Sub New
public:
H6()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► PalletExchangeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


QuantityOfPalletsShipped Property

QuantityOfPalletsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► QuantityOfPalletsShipped
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOfPalletsShipped { get; set; }
Public Property QuantityOfPalletsShipped As String
    Get
    Set
public:
property String^ QuantityOfPalletsShipped {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► SpecialServicesCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode1 Property

SpecialServicesCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► SpecialServicesCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode1 { get; set; }
Public Property SpecialServicesCode1 As String
    Get
    Set
public:
property String^ SpecialServicesCode1 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► Weight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► WeightUnitCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► H6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


HC Class

HC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC
RDPCrystal EDI Library
Health Condition
Declaration Syntax
C# Visual Basic Visual C++
public class HC : DocumentSegment
Public Class HC _
    Inherits DocumentSegment
public ref class HC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HC()()()() | Initializes a new instance of the HC class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | DiseaseConditionTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalTreatmentTypeCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HC


HC Constructor

HC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► HC()()()()
RDPCrystal EDI Library
Initializes a new instance of the HC class
Declaration Syntax
C# Visual Basic Visual C++
public HC()
Public Sub New
public:
HC()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DiseaseConditionTypeCode Property

DiseaseConditionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► DiseaseConditionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DiseaseConditionTypeCode { get; set; }
Public Property DiseaseConditionTypeCode As String
    Get
    Set
public:
property String^ DiseaseConditionTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MedicalTreatmentTypeCode Property

MedicalTreatmentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► MedicalTreatmentTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalTreatmentTypeCode { get; set; }
Public Property MedicalTreatmentTypeCode As String
    Get
    Set
public:
property String^ MedicalTreatmentTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


HCP Class

HCP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP
RDPCrystal EDI Library
Health Care Pricing
Declaration Syntax
C# Visual Basic Visual C++
public class HCP : DocumentSegment
Public Class HCP _
    Inherits DocumentSegment
public ref class HCP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HCP()()()() | Initializes a new instance of the HCP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionCode | Element 15
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PolicyComplianceCode | Element 14
 | PricingMethodology | Element 1
 | ProductServiceID | Element 8
 | ProductServiceID1 | Element 10
 | ProductServiceIDQualifier | Element 9
 | Quantity | Element 12
 | Rate | Element 5
 | ReferenceIdentification | Element 4
 | ReferenceIdentification1 | Element 6
 | RejectReasonCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HCP


HCP Constructor

HCP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► HCP()()()()
RDPCrystal EDI Library
Initializes a new instance of the HCP class
Declaration Syntax
C# Visual Basic Visual C++
public HCP()
Public Sub New
public:
HCP()


ExceptionCode Property

ExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► ExceptionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ExceptionCode { get; set; }
Public Property ExceptionCode As String
    Get
    Set
public:
property String^ ExceptionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► MonetaryAmount2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


PolicyComplianceCode Property

PolicyComplianceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► PolicyComplianceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PolicyComplianceCode { get; set; }
Public Property PolicyComplianceCode As String
    Get
    Set
public:
property String^ PolicyComplianceCode {
    String^ get ();
    void set (String^ value);
}


PricingMethodology Property

PricingMethodology Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► PricingMethodology
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PricingMethodology { get; set; }
Public Property PricingMethodology As String
    Get
    Set
public:
property String^ PricingMethodology {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► ProductServiceID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► ProductServiceID1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► Quantity
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► Rate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► RejectReasonCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


HCR Class

HCR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR
RDPCrystal EDI Library
Health Care Services Review
Declaration Syntax
C# Visual Basic Visual C++
public class HCR : DocumentSegment
Public Class HCR _
    Inherits DocumentSegment
public ref class HCR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HCR()()()() | Initializes a new instance of the HCR class
 | ActionCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | RejectReasonCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HCR


HCR Constructor

HCR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► HCR()()()()
RDPCrystal EDI Library
Initializes a new instance of the HCR class
Declaration Syntax
C# Visual Basic Visual C++
public HCR()
Public Sub New
public:
HCR()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► RejectReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HCR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


HD Class

HD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD
RDPCrystal EDI Library
Health Coverage
Declaration Syntax
C# Visual Basic Visual C++
public class HD : DocumentSegment
Public Class HD _
    Inherits DocumentSegment
public ref class HD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HD()()()() | Initializes a new instance of the HD class
 | Count | Element 6
 | Count1 | Element 7
 | CoverageLevelCode | Element 5
 | DrugHouseCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceLineCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 2
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnderwritingDecisionCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCode1 | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HD


HD Constructor

HD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► HD()()()()
RDPCrystal EDI Library
Initializes a new instance of the HD class
Declaration Syntax
C# Visual Basic Visual C++
public HD()
Public Sub New
public:
HD()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► Count
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Count1 Property

Count1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► Count1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Count1 { get; set; }
Public Property Count1 As String
    Get
    Set
public:
property String^ Count1 {
    String^ get ();
    void set (String^ value);
}


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► CoverageLevelCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}


DrugHouseCode Property

DrugHouseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► DrugHouseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DrugHouseCode { get; set; }
Public Property DrugHouseCode As String
    Get
    Set
public:
property String^ DrugHouseCode {
    String^ get ();
    void set (String^ value);
}


InsuranceLineCode Property

InsuranceLineCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► InsuranceLineCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceLineCode { get; set; }
Public Property InsuranceLineCode As String
    Get
    Set
public:
property String^ InsuranceLineCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► PlanCoverageDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}


UnderwritingDecisionCode Property

UnderwritingDecisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► UnderwritingDecisionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnderwritingDecisionCode { get; set; }
Public Property UnderwritingDecisionCode As String
    Get
    Set
public:
property String^ UnderwritingDecisionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HD ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


HealthCareClaimStatus Class

HealthCareClaimStatus Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus
RDPCrystal EDI Library
C043
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareClaimStatus : DocumentCompositeElement
Public Class HealthCareClaimStatus _
    Inherits DocumentCompositeElement
public ref class HealthCareClaimStatus : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareClaimStatus()()()() | Initializes a new instance of the HealthCareClaimStatus class
 | EntityIdentifierCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode1 | Element 1
 | IndustryCode2 | Element 2
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | HealthCareClaimStatus


HealthCareClaimStatus Constructor

HealthCareClaimStatus Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus ► HealthCareClaimStatus()()()()
RDPCrystal EDI Library
Initializes a new instance of the HealthCareClaimStatus class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus()
Public Sub New
public:
HealthCareClaimStatus()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus ► EntityIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus ► IndustryCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus ► IndustryCode2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareClaimStatus ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


HealthCareCodeInformation Class

HealthCareCodeInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation
RDPCrystal EDI Library
C022
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareCodeInformation : DocumentCompositeElement
Public Class HealthCareCodeInformation _
    Inherits DocumentCompositeElement
public ref class HealthCareCodeInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareCodeInformation()()()() | Initializes a new instance of the HealthCareCodeInformation class
 | CodeListQualifierCode | Element 1
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode1 | Element 2
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Quantity | Element 6
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | VersionIdentifier | Element 7
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | HealthCareCodeInformation


HealthCareCodeInformation Constructor

HealthCareCodeInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► HealthCareCodeInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the HealthCareCodeInformation class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation()
Public Sub New
public:
HealthCareCodeInformation()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► IndustryCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareCodeInformation ► VersionIdentifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


HealthCareServiceLocationInformation Class

HealthCareServiceLocationInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation
RDPCrystal EDI Library
C023
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareServiceLocationInformation : DocumentCompositeElement
Public Class HealthCareServiceLocationInformation _
    Inherits DocumentCompositeElement
public ref class HealthCareServiceLocationInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareServiceLocationInformation()()()() | Initializes a new instance of the HealthCareServiceLocationInformation class
 | ClaimFrequencyTypeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeQualifier | Element 2
 | FacilityCodeValue | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | HealthCareServiceLocationInformation


HealthCareServiceLocationInformation Constructor

HealthCareServiceLocationInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation ► HealthCareServiceLocationInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the HealthCareServiceLocationInformation class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocationInformation()
Public Sub New
public:
HealthCareServiceLocationInformation()


ClaimFrequencyTypeCode Property

ClaimFrequencyTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation ► ClaimFrequencyTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFrequencyTypeCode { get; set; }
Public Property ClaimFrequencyTypeCode As String
    Get
    Set
public:
property String^ ClaimFrequencyTypeCode {
    String^ get ();
    void set (String^ value);
}


FacilityCodeQualifier Property

FacilityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation ► FacilityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeQualifier { get; set; }
Public Property FacilityCodeQualifier As String
    Get
    Set
public:
property String^ FacilityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation ► FacilityCodeValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HealthCareServiceLocationInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


HI Class

HI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI
RDPCrystal EDI Library
Health Care Information Codes
Declaration Syntax
C# Visual Basic Visual C++
public class HI : DocumentSegment
Public Class HI _
    Inherits DocumentSegment
public ref class HI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HI()()()() | Initializes a new instance of the HI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareCodeInformation | Element 1
 | HealthCareCodeInformation1 | Element 2
 | HealthCareCodeInformation10 | Element 11
 | HealthCareCodeInformation11 | Element 12
 | HealthCareCodeInformation2 | Element 3
 | HealthCareCodeInformation3 | Element 4
 | HealthCareCodeInformation4 | Element 5
 | HealthCareCodeInformation5 | Element 6
 | HealthCareCodeInformation6 | Element 7
 | HealthCareCodeInformation7 | Element 8
 | HealthCareCodeInformation8 | Element 9
 | HealthCareCodeInformation9 | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HI


HI Constructor

HI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HI()()()()
RDPCrystal EDI Library
Initializes a new instance of the HI class
Declaration Syntax
C# Visual Basic Visual C++
public HI()
Public Sub New
public:
HI()


HealthCareCodeInformation Property

HealthCareCodeInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation { get; set; }
Public Property HealthCareCodeInformation As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation1 Property

HealthCareCodeInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation1 { get; set; }
Public Property HealthCareCodeInformation1 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation1 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation10 Property

HealthCareCodeInformation10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation10
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation10 { get; set; }
Public Property HealthCareCodeInformation10 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation10 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation11 Property

HealthCareCodeInformation11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation11
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation11 { get; set; }
Public Property HealthCareCodeInformation11 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation11 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation2 Property

HealthCareCodeInformation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation2 { get; set; }
Public Property HealthCareCodeInformation2 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation2 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation3 Property

HealthCareCodeInformation3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation3 { get; set; }
Public Property HealthCareCodeInformation3 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation3 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation4 Property

HealthCareCodeInformation4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation4 { get; set; }
Public Property HealthCareCodeInformation4 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation4 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation5 Property

HealthCareCodeInformation5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation5
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation5 { get; set; }
Public Property HealthCareCodeInformation5 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation5 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation6 Property

HealthCareCodeInformation6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation6
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation6 { get; set; }
Public Property HealthCareCodeInformation6 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation6 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation7 Property

HealthCareCodeInformation7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation7
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation7 { get; set; }
Public Property HealthCareCodeInformation7 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation7 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation8 Property

HealthCareCodeInformation8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation8
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation8 { get; set; }
Public Property HealthCareCodeInformation8 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation8 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


HealthCareCodeInformation9 Property

HealthCareCodeInformation9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► HealthCareCodeInformation9
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation9 { get; set; }
Public Property HealthCareCodeInformation9 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation9 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


HL Class

HL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL
RDPCrystal EDI Library
Hierarchical Level
Declaration Syntax
C# Visual Basic Visual C++
public class HL : DocumentSegment
Public Class HL _
    Inherits DocumentSegment
public ref class HL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HL()()()() | Initializes a new instance of the HL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalChildCode | Element 4
 | HierarchicalIDNumber | Element 1
 | HierarchicalLevelCode | Element 3
 | HierarchicalParentIDNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HL


HL Constructor

HL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► HL()()()()
RDPCrystal EDI Library
Initializes a new instance of the HL class
Declaration Syntax
C# Visual Basic Visual C++
public HL()
Public Sub New
public:
HL()


HierarchicalChildCode Property

HierarchicalChildCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► HierarchicalChildCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalChildCode { get; set; }
Public Property HierarchicalChildCode As String
    Get
    Set
public:
property String^ HierarchicalChildCode {
    String^ get ();
    void set (String^ value);
}


HierarchicalIDNumber Property

HierarchicalIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► HierarchicalIDNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalIDNumber { get; set; }
Public Property HierarchicalIDNumber As String
    Get
    Set
public:
property String^ HierarchicalIDNumber {
    String^ get ();
    void set (String^ value);
}


HierarchicalLevelCode Property

HierarchicalLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► HierarchicalLevelCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalLevelCode { get; set; }
Public Property HierarchicalLevelCode As String
    Get
    Set
public:
property String^ HierarchicalLevelCode {
    String^ get ();
    void set (String^ value);
}


HierarchicalParentIDNumber Property

HierarchicalParentIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► HierarchicalParentIDNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalParentIDNumber { get; set; }
Public Property HierarchicalParentIDNumber As String
    Get
    Set
public:
property String^ HierarchicalParentIDNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


HLH Class

HLH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH
RDPCrystal EDI Library
Health Information
Declaration Syntax
C# Visual Basic Visual C++
public class HLH : DocumentSegment
Public Class HLH _
    Inherits DocumentSegment
public ref class HLH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HLH()()()() | Initializes a new instance of the HLH class
 | CurrentHealthConditionCode | Element 6
 | Description | Element 5
 | Description1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthRelatedCode | Element 1
 | Height | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 3
 | Weight1 | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HLH


HLH Constructor

HLH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► HLH()()()()
RDPCrystal EDI Library
Initializes a new instance of the HLH class
Declaration Syntax
C# Visual Basic Visual C++
public HLH()
Public Sub New
public:
HLH()


CurrentHealthConditionCode Property

CurrentHealthConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► CurrentHealthConditionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentHealthConditionCode { get; set; }
Public Property CurrentHealthConditionCode As String
    Get
    Set
public:
property String^ CurrentHealthConditionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Description1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


HealthRelatedCode Property

HealthRelatedCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► HealthRelatedCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HealthRelatedCode { get; set; }
Public Property HealthRelatedCode As String
    Get
    Set
public:
property String^ HealthRelatedCode {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Height
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Weight1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HLH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


HS Class

HS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS
RDPCrystal EDI Library
Health Screening
Declaration Syntax
C# Visual Basic Visual C++
public class HS : DocumentSegment
Public Class HS _
    Inherits DocumentSegment
public ref class HS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HS()()()() | Initializes a new instance of the HS class
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthScreeningTypeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HS


HS Constructor

HS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► HS()()()()
RDPCrystal EDI Library
Initializes a new instance of the HS class
Declaration Syntax
C# Visual Basic Visual C++
public HS()
Public Sub New
public:
HS()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


HealthScreeningTypeCode Property

HealthScreeningTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► HealthScreeningTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HealthScreeningTypeCode { get; set; }
Public Property HealthScreeningTypeCode As String
    Get
    Set
public:
property String^ HealthScreeningTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► StatusReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


HSD Class

HSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD
RDPCrystal EDI Library
Health Care Services Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class HSD : DocumentSegment
Public Class HSD _
    Inherits DocumentSegment
public ref class HSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HSD()()()() | Initializes a new instance of the HSD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | QuantityQualifier | Element 1
 | SampleSelectionModulus | Element 4
 | ShipDeliveryOrCalendarPatternCode | Element 7
 | ShipDeliveryPatternTimeCode | Element 8
 | TimePeriodQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HSD


HSD Constructor

HSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► HSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the HSD class
Declaration Syntax
C# Visual Basic Visual C++
public HSD()
Public Sub New
public:
HSD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► NumberOfPeriods
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


SampleSelectionModulus Property

SampleSelectionModulus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► SampleSelectionModulus
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SampleSelectionModulus { get; set; }
Public Property SampleSelectionModulus As String
    Get
    Set
public:
property String^ SampleSelectionModulus {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryPatternTimeCode Property

ShipDeliveryPatternTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► ShipDeliveryPatternTimeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode { get; set; }
Public Property ShipDeliveryPatternTimeCode As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► TimePeriodQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► HSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IA Class

IA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA
RDPCrystal EDI Library
Interconnect Mailbag Acknowledgment
Declaration Syntax
C# Visual Basic Visual C++
public class IA : DocumentSegment
Public Class IA _
    Inherits DocumentSegment
public ref class IA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IA()()()() | Initializes a new instance of the IA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterconnectMailbagAcknowledgmentActionCode | Element 2
 | InterconnectMailbagControlNumber | Element 1
 | InterconnectMailbagErrorCode | Element 3
 | InterconnectMailbagErrorCode1 | Element 4
 | InterconnectMailbagErrorCode2 | Element 5
 | InterconnectMailbagErrorCode3 | Element 6
 | InterconnectMailbagErrorCode4 | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IA


IA Constructor

IA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► IA()()()()
RDPCrystal EDI Library
Initializes a new instance of the IA class
Declaration Syntax
C# Visual Basic Visual C++
public IA()
Public Sub New
public:
IA()


InterconnectMailbagAcknowledgmentActionCode Property

InterconnectMailbagAcknowledgmentActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagAcknowledgmentActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagAcknowledgmentActionCode { get; set; }
Public Property InterconnectMailbagAcknowledgmentActionCode As String
    Get
    Set
public:
property String^ InterconnectMailbagAcknowledgmentActionCode {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagControlNumber Property

InterconnectMailbagControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagControlNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagControlNumber { get; set; }
Public Property InterconnectMailbagControlNumber As String
    Get
    Set
public:
property String^ InterconnectMailbagControlNumber {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagErrorCode Property

InterconnectMailbagErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagErrorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagErrorCode { get; set; }
Public Property InterconnectMailbagErrorCode As String
    Get
    Set
public:
property String^ InterconnectMailbagErrorCode {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagErrorCode1 Property

InterconnectMailbagErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagErrorCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagErrorCode1 { get; set; }
Public Property InterconnectMailbagErrorCode1 As String
    Get
    Set
public:
property String^ InterconnectMailbagErrorCode1 {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagErrorCode2 Property

InterconnectMailbagErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagErrorCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagErrorCode2 { get; set; }
Public Property InterconnectMailbagErrorCode2 As String
    Get
    Set
public:
property String^ InterconnectMailbagErrorCode2 {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagErrorCode3 Property

InterconnectMailbagErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagErrorCode3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagErrorCode3 { get; set; }
Public Property InterconnectMailbagErrorCode3 As String
    Get
    Set
public:
property String^ InterconnectMailbagErrorCode3 {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagErrorCode4 Property

InterconnectMailbagErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► InterconnectMailbagErrorCode4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagErrorCode4 { get; set; }
Public Property InterconnectMailbagErrorCode4 As String
    Get
    Set
public:
property String^ InterconnectMailbagErrorCode4 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IC Class

IC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC
RDPCrystal EDI Library
Intermodal Chassis Equipment
Declaration Syntax
C# Visual Basic Visual C++
public class IC : DocumentSegment
Public Class IC _
    Inherits DocumentSegment
public ref class IC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IC()()()() | Initializes a new instance of the IC class
 | ChassisType | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 1
 | EquipmentLength | Element 6
 | EquipmentNumber | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 5
 | StandardCarrierAlphaCode1 | Element 7
 | TareQualifierCode | Element 4
 | TareWeight | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IC


IC Constructor

IC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► IC()()()()
RDPCrystal EDI Library
Initializes a new instance of the IC class
Declaration Syntax
C# Visual Basic Visual C++
public IC()
Public Sub New
public:
IC()


ChassisType Property

ChassisType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► ChassisType
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ChassisType { get; set; }
Public Property ChassisType As String
    Get
    Set
public:
property String^ ChassisType {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► EquipmentLength
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


TareQualifierCode Property

TareQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► TareQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TareQualifierCode { get; set; }
Public Property TareQualifierCode As String
    Get
    Set
public:
property String^ TareQualifierCode {
    String^ get ();
    void set (String^ value);
}


TareWeight Property

TareWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► TareWeight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TareWeight { get; set; }
Public Property TareWeight As String
    Get
    Set
public:
property String^ TareWeight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ICH Class

ICH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH
RDPCrystal EDI Library
Individual Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class ICH : DocumentSegment
Public Class ICH _
    Inherits DocumentSegment
public ref class ICH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ICH()()()() | Initializes a new instance of the ICH class
 | Count | Element 1
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Description | Element 10
 | Description1 | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PoliticalPartyAffiliationCode | Element 12
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 6
 | StateOrProvinceCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ICH


ICH Constructor

ICH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► ICH()()()()
RDPCrystal EDI Library
Initializes a new instance of the ICH class
Declaration Syntax
C# Visual Basic Visual C++
public ICH()
Public Sub New
public:
ICH()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► Count
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► Description1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► GenderCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► OccupationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}


PoliticalPartyAffiliationCode Property

PoliticalPartyAffiliationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► PoliticalPartyAffiliationCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PoliticalPartyAffiliationCode { get; set; }
Public Property PoliticalPartyAffiliationCode As String
    Get
    Set
public:
property String^ PoliticalPartyAffiliationCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ICM Class

ICM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM
RDPCrystal EDI Library
Individual Income
Declaration Syntax
C# Visual Basic Visual C++
public class ICM : DocumentSegment
Public Class ICM _
    Inherits DocumentSegment
public ref class ICM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ICM()()()() | Initializes a new instance of the ICM class
 | CurrencyCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | SalaryGrade | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ICM


ICM Constructor

ICM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► ICM()()()()
RDPCrystal EDI Library
Initializes a new instance of the ICM class
Declaration Syntax
C# Visual Basic Visual C++
public ICM()
Public Sub New
public:
ICM()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► CurrencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► FrequencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► LocationIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


SalaryGrade Property

SalaryGrade Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► SalaryGrade
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SalaryGrade { get; set; }
Public Property SalaryGrade As String
    Get
    Set
public:
property String^ SalaryGrade {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ICM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ID Class

ID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID
RDPCrystal EDI Library
Inspection Detail Segment
Declaration Syntax
C# Visual Basic Visual C++
public class ID : DocumentSegment
Public Class ID _
    Inherits DocumentSegment
public ref class ID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ID()()()() | Initializes a new instance of the ID class
 | DamageAreaCode | Element 1
 | DamageSeverityCode | Element 3
 | DamageTypeCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ID


ID Constructor

ID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID ► ID()()()()
RDPCrystal EDI Library
Initializes a new instance of the ID class
Declaration Syntax
C# Visual Basic Visual C++
public ID()
Public Sub New
public:
ID()


DamageAreaCode Property

DamageAreaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID ► DamageAreaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DamageAreaCode { get; set; }
Public Property DamageAreaCode As String
    Get
    Set
public:
property String^ DamageAreaCode {
    String^ get ();
    void set (String^ value);
}


DamageSeverityCode Property

DamageSeverityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID ► DamageSeverityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DamageSeverityCode { get; set; }
Public Property DamageSeverityCode As String
    Get
    Set
public:
property String^ DamageSeverityCode {
    String^ get ();
    void set (String^ value);
}


DamageTypeCode Property

DamageTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID ► DamageTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DamageTypeCode { get; set; }
Public Property DamageTypeCode As String
    Get
    Set
public:
property String^ DamageTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ID1 Class

ID1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1
RDPCrystal EDI Library
Item Detail Dimensions
Declaration Syntax
C# Visual Basic Visual C++
public class ID1 : DocumentSegment
Public Class ID1 _
    Inherits DocumentSegment
public ref class ID1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ID1()()()() | Initializes a new instance of the ID1 class
 | Category | Element 14
 | CategoryReferenceCode | Element 13
 | Date | Element 20
 | DateQualifier | Element 19
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 7
 | InnerPack | Element 18
 | ItemDepth | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Nesting | Element 22
 | NestingCode | Element 21
 | Pack | Element 17
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PegCode | Element 24
 | ProductServiceID | Element 3
 | ProductServiceIDQualifier | Element 2
 | ReferenceIdentification | Element 26
 | ReferenceIdentification1 | Element 29
 | ReferenceIdentification2 | Element 32
 | Size | Element 5
 | Subcategory | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | UnitOrBasisForMeasurementCode1 | Element 10
 | UnitOrBasisForMeasurementCode2 | Element 12
 | UnitOrBasisForMeasurementCode3 | Element 16
 | UnitOrBasisForMeasurementCode4 | Element 23
 | UnitOrBasisForMeasurementCode5 | Element 25
 | UPCEANConsumerPackageCode | Element 1
 | Weight | Element 11
 | Width | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | XPeg | Element 27
 | XPeg1 | Element 30
 | XPeg2 | Element 33
 | YPeg | Element 28
 | YPeg1 | Element 31
 | YPeg2 | Element 34
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ID1


ID1 Constructor

ID1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ID1()()()()
RDPCrystal EDI Library
Initializes a new instance of the ID1 class
Declaration Syntax
C# Visual Basic Visual C++
public ID1()
Public Sub New
public:
ID1()


Category Property

Category Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Category
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}


CategoryReferenceCode Property

CategoryReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► CategoryReferenceCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryReferenceCode { get; set; }
Public Property CategoryReferenceCode As String
    Get
    Set
public:
property String^ CategoryReferenceCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Date
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateQualifier Property

DateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► DateQualifier
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DateQualifier { get; set; }
Public Property DateQualifier As String
    Get
    Set
public:
property String^ DateQualifier {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► FreeformDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Height
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► InnerPack
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


ItemDepth Property

ItemDepth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ItemDepth
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDepth { get; set; }
Public Property ItemDepth As String
    Get
    Set
public:
property String^ ItemDepth {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Nesting Property

Nesting Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Nesting
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string Nesting { get; set; }
Public Property Nesting As String
    Get
    Set
public:
property String^ Nesting {
    String^ get ();
    void set (String^ value);
}


NestingCode Property

NestingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► NestingCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string NestingCode { get; set; }
Public Property NestingCode As String
    Get
    Set
public:
property String^ NestingCode {
    String^ get ();
    void set (String^ value);
}


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Pack
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


PegCode Property

PegCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► PegCode
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string PegCode { get; set; }
Public Property PegCode As String
    Get
    Set
public:
property String^ PegCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► ReferenceIdentification2
RDPCrystal EDI Library
Element 32
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Size
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


Subcategory Property

Subcategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Subcategory
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Subcategory { get; set; }
Public Property Subcategory As String
    Get
    Set
public:
property String^ Subcategory {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode5 Property

UnitOrBasisForMeasurementCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UnitOrBasisForMeasurementCode5
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode5 { get; set; }
Public Property UnitOrBasisForMeasurementCode5 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode5 {
    String^ get ();
    void set (String^ value);
}


UPCEANConsumerPackageCode Property

UPCEANConsumerPackageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► UPCEANConsumerPackageCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UPCEANConsumerPackageCode { get; set; }
Public Property UPCEANConsumerPackageCode As String
    Get
    Set
public:
property String^ UPCEANConsumerPackageCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Weight
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Width
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


XPeg Property

XPeg Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► XPeg
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string XPeg { get; set; }
Public Property XPeg As String
    Get
    Set
public:
property String^ XPeg {
    String^ get ();
    void set (String^ value);
}


XPeg1 Property

XPeg1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► XPeg1
RDPCrystal EDI Library
Element 30
Declaration Syntax
C# Visual Basic Visual C++
public string XPeg1 { get; set; }
Public Property XPeg1 As String
    Get
    Set
public:
property String^ XPeg1 {
    String^ get ();
    void set (String^ value);
}


XPeg2 Property

XPeg2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► XPeg2
RDPCrystal EDI Library
Element 33
Declaration Syntax
C# Visual Basic Visual C++
public string XPeg2 { get; set; }
Public Property XPeg2 As String
    Get
    Set
public:
property String^ XPeg2 {
    String^ get ();
    void set (String^ value);
}


YPeg Property

YPeg Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► YPeg
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string YPeg { get; set; }
Public Property YPeg As String
    Get
    Set
public:
property String^ YPeg {
    String^ get ();
    void set (String^ value);
}


YPeg1 Property

YPeg1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► YPeg1
RDPCrystal EDI Library
Element 31
Declaration Syntax
C# Visual Basic Visual C++
public string YPeg1 { get; set; }
Public Property YPeg1 As String
    Get
    Set
public:
property String^ YPeg1 {
    String^ get ();
    void set (String^ value);
}


YPeg2 Property

YPeg2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID1 ► YPeg2
RDPCrystal EDI Library
Element 34
Declaration Syntax
C# Visual Basic Visual C++
public string YPeg2 { get; set; }
Public Property YPeg2 As String
    Get
    Set
public:
property String^ YPeg2 {
    String^ get ();
    void set (String^ value);
}


ID2 Class

ID2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2
RDPCrystal EDI Library
Item Image Detail
Declaration Syntax
C# Visual Basic Visual C++
public class ID2 : DocumentSegment
Public Class ID2 _
    Inherits DocumentSegment
public ref class ID2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ID2()()()() | Initializes a new instance of the ID2 class
 | CashRegisterItemDescription | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | Name2 | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 7
 | SpaceManagementReferenceCode | Element 2
 | SpaceManagementReferenceCode1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ID2


ID2 Constructor

ID2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► ID2()()()()
RDPCrystal EDI Library
Initializes a new instance of the ID2 class
Declaration Syntax
C# Visual Basic Visual C++
public ID2()
Public Sub New
public:
ID2()


CashRegisterItemDescription Property

CashRegisterItemDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► CashRegisterItemDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CashRegisterItemDescription { get; set; }
Public Property CashRegisterItemDescription As String
    Get
    Set
public:
property String^ CashRegisterItemDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► Name2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


SpaceManagementReferenceCode Property

SpaceManagementReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► SpaceManagementReferenceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpaceManagementReferenceCode { get; set; }
Public Property SpaceManagementReferenceCode As String
    Get
    Set
public:
property String^ SpaceManagementReferenceCode {
    String^ get ();
    void set (String^ value);
}


SpaceManagementReferenceCode1 Property

SpaceManagementReferenceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► SpaceManagementReferenceCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SpaceManagementReferenceCode1 { get; set; }
Public Property SpaceManagementReferenceCode1 As String
    Get
    Set
public:
property String^ SpaceManagementReferenceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ID3 Class

ID3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3
RDPCrystal EDI Library
Dimensions Detail
Declaration Syntax
C# Visual Basic Visual C++
public class ID3 : DocumentSegment
Public Class ID3 _
    Inherits DocumentSegment
public ref class ID3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ID3()()()() | Initializes a new instance of the ID3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 6
 | Height1 | Element 15
 | InnerPack | Element 5
 | ItemDepth | Element 8
 | ItemDepth1 | Element 17
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Nesting | Element 20
 | NestingCode | Element 19
 | Pack | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceIDQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TrayCount | Element 14
 | UnitOrBasisForMeasurementCode | Element 9
 | UnitOrBasisForMeasurementCode1 | Element 11
 | UnitOrBasisForMeasurementCode2 | Element 13
 | UnitOrBasisForMeasurementCode3 | Element 18
 | UnitOrBasisForMeasurementCode4 | Element 21
 | UPCCaseCode | Element 1
 | Volume | Element 12
 | Weight | Element 10
 | Width | Element 7
 | Width1 | Element 16
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ID3


ID3 Constructor

ID3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► ID3()()()()
RDPCrystal EDI Library
Initializes a new instance of the ID3 class
Declaration Syntax
C# Visual Basic Visual C++
public ID3()
Public Sub New
public:
ID3()


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Height
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Height1 Property

Height1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Height1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Height1 { get; set; }
Public Property Height1 As String
    Get
    Set
public:
property String^ Height1 {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► InnerPack
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


ItemDepth Property

ItemDepth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► ItemDepth
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDepth { get; set; }
Public Property ItemDepth As String
    Get
    Set
public:
property String^ ItemDepth {
    String^ get ();
    void set (String^ value);
}


ItemDepth1 Property

ItemDepth1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► ItemDepth1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDepth1 { get; set; }
Public Property ItemDepth1 As String
    Get
    Set
public:
property String^ ItemDepth1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Nesting Property

Nesting Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Nesting
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Nesting { get; set; }
Public Property Nesting As String
    Get
    Set
public:
property String^ Nesting {
    String^ get ();
    void set (String^ value);
}


NestingCode Property

NestingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► NestingCode
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string NestingCode { get; set; }
Public Property NestingCode As String
    Get
    Set
public:
property String^ NestingCode {
    String^ get ();
    void set (String^ value);
}


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Pack
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


TrayCount Property

TrayCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► TrayCount
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string TrayCount { get; set; }
Public Property TrayCount As String
    Get
    Set
public:
property String^ TrayCount {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► UPCCaseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Volume
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Weight
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Width
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Width1 Property

Width1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Width1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Width1 { get; set; }
Public Property Width1 As String
    Get
    Set
public:
property String^ Width1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ID4 Class

ID4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4
RDPCrystal EDI Library
Load Details
Declaration Syntax
C# Visual Basic Visual C++
public class ID4 : DocumentSegment
Public Class ID4 _
    Inherits DocumentSegment
public ref class ID4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ID4()()()() | Initializes a new instance of the ID4 class
 | DeclaredValue | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PickupOrDeliveryCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 6
 | VolumeUnitQualifier | Element 5
 | Weight | Element 4
 | WeightQualifier | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCodeOZ | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ID4


ID4 Constructor

ID4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► ID4()()()()
RDPCrystal EDI Library
Initializes a new instance of the ID4 class
Declaration Syntax
C# Visual Basic Visual C++
public ID4()
Public Sub New
public:
ID4()


DeclaredValue Property

DeclaredValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► DeclaredValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DeclaredValue { get; set; }
Public Property DeclaredValue As String
    Get
    Set
public:
property String^ DeclaredValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► Number
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► Volume
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► WeightQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCodeOZ Property

YesNoConditionOrResponseCodeOZ Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ID4 ► YesNoConditionOrResponseCodeOZ
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCodeOZ { get; set; }
Public Property YesNoConditionOrResponseCodeOZ As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCodeOZ {
    String^ get ();
    void set (String^ value);
}


IDB Class

IDB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB
RDPCrystal EDI Library
Indebtedness for Student Loans
Declaration Syntax
C# Visual Basic Visual C++
public class IDB : DocumentSegment
Public Class IDB _
    Inherits DocumentSegment
public ref class IDB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDB()()()() | Initializes a new instance of the IDB class
 | AmountQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanRateTypeCode | Element 5
 | LoanTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IDB


IDB Constructor

IDB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► IDB()()()()
RDPCrystal EDI Library
Initializes a new instance of the IDB class
Declaration Syntax
C# Visual Basic Visual C++
public IDB()
Public Sub New
public:
IDB()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► InterestRate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► LoanRateTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► LoanTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IDC Class

IDC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC
RDPCrystal EDI Library
Identification Card
Declaration Syntax
C# Visual Basic Visual C++
public class IDC : DocumentSegment
Public Class IDC _
    Inherits DocumentSegment
public ref class IDC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDC()()()() | Initializes a new instance of the IDC class
 | ActionCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCardTypeCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription | Element 1
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IDC


IDC Constructor

IDC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► IDC()()()()
RDPCrystal EDI Library
Initializes a new instance of the IDC class
Declaration Syntax
C# Visual Basic Visual C++
public IDC()
Public Sub New
public:
IDC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► ActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCardTypeCode Property

IdentificationCardTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► IdentificationCardTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCardTypeCode { get; set; }
Public Property IdentificationCardTypeCode As String
    Get
    Set
public:
property String^ IdentificationCardTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► PlanCoverageDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IDC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IEA Class

IEA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IEA
RDPCrystal EDI Library
Interchange Control Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class IEA : DocumentSegment
Public Class IEA _
    Inherits DocumentSegment
public ref class IEA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IEA()()()() | Initializes a new instance of the IEA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeControlNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfIncludedFunctionalGroups | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IEA


IEA Constructor

IEA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IEA ► IEA()()()()
RDPCrystal EDI Library
Initializes a new instance of the IEA class
Declaration Syntax
C# Visual Basic Visual C++
public IEA()
Public Sub New
public:
IEA()


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IEA ► InterchangeControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IEA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfIncludedFunctionalGroups Property

NumberOfIncludedFunctionalGroups Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IEA ► NumberOfIncludedFunctionalGroups
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfIncludedFunctionalGroups { get; set; }
Public Property NumberOfIncludedFunctionalGroups As String
    Get
    Set
public:
property String^ NumberOfIncludedFunctionalGroups {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IEA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IGI Class

IGI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI
RDPCrystal EDI Library
Insurer or Guarantor Information
Declaration Syntax
C# Visual Basic Visual C++
public class IGI : DocumentSegment
Public Class IGI _
    Inherits DocumentSegment
public ref class IGI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IGI()()()() | Initializes a new instance of the IGI class
 | CodeListQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 3
 | InsurerCoverageIndicatorCode | Element 5
 | InsurerGuarantorTypeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MortgageInsuranceCoverageTypeCode | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IGI


IGI Constructor

IGI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► IGI()()()()
RDPCrystal EDI Library
Initializes a new instance of the IGI class
Declaration Syntax
C# Visual Basic Visual C++
public IGI()
Public Sub New
public:
IGI()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► CodeListQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► IndustryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


InsurerCoverageIndicatorCode Property

InsurerCoverageIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► InsurerCoverageIndicatorCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InsurerCoverageIndicatorCode { get; set; }
Public Property InsurerCoverageIndicatorCode As String
    Get
    Set
public:
property String^ InsurerCoverageIndicatorCode {
    String^ get ();
    void set (String^ value);
}


InsurerGuarantorTypeCode Property

InsurerGuarantorTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► InsurerGuarantorTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InsurerGuarantorTypeCode { get; set; }
Public Property InsurerGuarantorTypeCode As String
    Get
    Set
public:
property String^ InsurerGuarantorTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MortgageInsuranceCoverageTypeCode Property

MortgageInsuranceCoverageTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► MortgageInsuranceCoverageTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceCoverageTypeCode { get; set; }
Public Property MortgageInsuranceCoverageTypeCode As String
    Get
    Set
public:
property String^ MortgageInsuranceCoverageTypeCode {
    String^ get ();
    void set (String^ value);
}


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► PayerResponsibilitySequenceNumberCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IGI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IH Class

IH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH
RDPCrystal EDI Library
Interconnect Mailbag Header
Declaration Syntax
C# Visual Basic Visual C++
public class IH : DocumentSegment
Public Class IH _
    Inherits DocumentSegment
public ref class IH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IH()()()() | Initializes a new instance of the IH class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterconnectMailbagControlNumber | Element 11
 | InterconnectMailbagDate | Element 8
 | InterconnectMailbagIDQualifierCode | Element 4
 | InterconnectMailbagIDQualifierCode1 | Element 6
 | InterconnectMailbagLogonID | Element 2
 | InterconnectMailbagPassword | Element 3
 | InterconnectMailbagReceiverID | Element 7
 | InterconnectMailbagSenderID | Element 5
 | InterconnectMailbagTestIndicator | Element 12
 | InterconnectMailbagTime | Element 9
 | InterconnectMailbagTimeCode | Element 10
 | InterconnectMailbagVersionNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IH


IH Constructor

IH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► IH()()()()
RDPCrystal EDI Library
Initializes a new instance of the IH class
Declaration Syntax
C# Visual Basic Visual C++
public IH()
Public Sub New
public:
IH()


InterconnectMailbagControlNumber Property

InterconnectMailbagControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagControlNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagControlNumber { get; set; }
Public Property InterconnectMailbagControlNumber As String
    Get
    Set
public:
property String^ InterconnectMailbagControlNumber {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagDate Property

InterconnectMailbagDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagDate
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagDate { get; set; }
Public Property InterconnectMailbagDate As String
    Get
    Set
public:
property String^ InterconnectMailbagDate {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagIDQualifierCode Property

InterconnectMailbagIDQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagIDQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagIDQualifierCode { get; set; }
Public Property InterconnectMailbagIDQualifierCode As String
    Get
    Set
public:
property String^ InterconnectMailbagIDQualifierCode {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagIDQualifierCode1 Property

InterconnectMailbagIDQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagIDQualifierCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagIDQualifierCode1 { get; set; }
Public Property InterconnectMailbagIDQualifierCode1 As String
    Get
    Set
public:
property String^ InterconnectMailbagIDQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagLogonID Property

InterconnectMailbagLogonID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagLogonID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagLogonID { get; set; }
Public Property InterconnectMailbagLogonID As String
    Get
    Set
public:
property String^ InterconnectMailbagLogonID {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagPassword Property

InterconnectMailbagPassword Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagPassword
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagPassword { get; set; }
Public Property InterconnectMailbagPassword As String
    Get
    Set
public:
property String^ InterconnectMailbagPassword {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagReceiverID Property

InterconnectMailbagReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagReceiverID
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagReceiverID { get; set; }
Public Property InterconnectMailbagReceiverID As String
    Get
    Set
public:
property String^ InterconnectMailbagReceiverID {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagSenderID Property

InterconnectMailbagSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagSenderID
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagSenderID { get; set; }
Public Property InterconnectMailbagSenderID As String
    Get
    Set
public:
property String^ InterconnectMailbagSenderID {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagTestIndicator Property

InterconnectMailbagTestIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagTestIndicator
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagTestIndicator { get; set; }
Public Property InterconnectMailbagTestIndicator As String
    Get
    Set
public:
property String^ InterconnectMailbagTestIndicator {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagTime Property

InterconnectMailbagTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagTime
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagTime { get; set; }
Public Property InterconnectMailbagTime As String
    Get
    Set
public:
property String^ InterconnectMailbagTime {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagTimeCode Property

InterconnectMailbagTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagTimeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagTimeCode { get; set; }
Public Property InterconnectMailbagTimeCode As String
    Get
    Set
public:
property String^ InterconnectMailbagTimeCode {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagVersionNumber Property

InterconnectMailbagVersionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► InterconnectMailbagVersionNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagVersionNumber { get; set; }
Public Property InterconnectMailbagVersionNumber As String
    Get
    Set
public:
property String^ InterconnectMailbagVersionNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


III Class

III Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III
RDPCrystal EDI Library
Information
Declaration Syntax
C# Visual Basic Visual C++
public class III : DocumentSegment
Public Class III _
    Inherits DocumentSegment
public ref class III : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | III()()()() | Initializes a new instance of the III class
 | CodeCategory | Element 3
 | CodeListQualifierCode | Element 1
 | CompositeUnitOfMeasure | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | SurfaceLayerPositionCode | Element 7
 | SurfaceLayerPositionCode1 | Element 8
 | SurfaceLayerPositionCode2 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | III


III Constructor

III Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► III()()()()
RDPCrystal EDI Library
Initializes a new instance of the III class
Declaration Syntax
C# Visual Basic Visual C++
public III()
Public Sub New
public:
III()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► CodeCategory
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► FreeFormMessageText
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode1 Property

SurfaceLayerPositionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► SurfaceLayerPositionCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode1 { get; set; }
Public Property SurfaceLayerPositionCode1 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode1 {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode2 Property

SurfaceLayerPositionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► SurfaceLayerPositionCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode2 { get; set; }
Public Property SurfaceLayerPositionCode2 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► III ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IIS Class

IIS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS
RDPCrystal EDI Library
Interchange Identification Segment
Declaration Syntax
C# Visual Basic Visual C++
public class IIS : DocumentSegment
Public Class IIS _
    Inherits DocumentSegment
public ref class IIS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IIS()()()() | Initializes a new instance of the IIS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstReferenceID | Element 10
 | FirstReferenceIDQualifier | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageDirectionCode | Element 13
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportedControlNumber | Element 2
 | ReportedDate | Element 3
 | ReportedGroupOrTransactionIdentifier | Element 14
 | ReportedInterchangeReceiverIDQualifier | Element 7
 | ReportedInterchangeSenderIDQualifier | Element 5
 | ReportedReceiverID | Element 8
 | ReportedSenderID | Element 6
 | ReportedStartSegmentID | Element 1
 | ReportedTime | Element 4
 | SecondReferenceID | Element 12
 | SecondReferenceIDQualifier | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IIS


IIS Constructor

IIS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► IIS()()()()
RDPCrystal EDI Library
Initializes a new instance of the IIS class
Declaration Syntax
C# Visual Basic Visual C++
public IIS()
Public Sub New
public:
IIS()


FirstReferenceID Property

FirstReferenceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► FirstReferenceID
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FirstReferenceID { get; set; }
Public Property FirstReferenceID As String
    Get
    Set
public:
property String^ FirstReferenceID {
    String^ get ();
    void set (String^ value);
}


FirstReferenceIDQualifier Property

FirstReferenceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► FirstReferenceIDQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FirstReferenceIDQualifier { get; set; }
Public Property FirstReferenceIDQualifier As String
    Get
    Set
public:
property String^ FirstReferenceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MessageDirectionCode Property

MessageDirectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► MessageDirectionCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MessageDirectionCode { get; set; }
Public Property MessageDirectionCode As String
    Get
    Set
public:
property String^ MessageDirectionCode {
    String^ get ();
    void set (String^ value);
}


ReportedControlNumber Property

ReportedControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedControlNumber { get; set; }
Public Property ReportedControlNumber As String
    Get
    Set
public:
property String^ ReportedControlNumber {
    String^ get ();
    void set (String^ value);
}


ReportedDate Property

ReportedDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedDate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedDate { get; set; }
Public Property ReportedDate As String
    Get
    Set
public:
property String^ ReportedDate {
    String^ get ();
    void set (String^ value);
}


ReportedGroupOrTransactionIdentifier Property

ReportedGroupOrTransactionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedGroupOrTransactionIdentifier
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedGroupOrTransactionIdentifier { get; set; }
Public Property ReportedGroupOrTransactionIdentifier As String
    Get
    Set
public:
property String^ ReportedGroupOrTransactionIdentifier {
    String^ get ();
    void set (String^ value);
}


ReportedInterchangeReceiverIDQualifier Property

ReportedInterchangeReceiverIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedInterchangeReceiverIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedInterchangeReceiverIDQualifier { get; set; }
Public Property ReportedInterchangeReceiverIDQualifier As String
    Get
    Set
public:
property String^ ReportedInterchangeReceiverIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReportedInterchangeSenderIDQualifier Property

ReportedInterchangeSenderIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedInterchangeSenderIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedInterchangeSenderIDQualifier { get; set; }
Public Property ReportedInterchangeSenderIDQualifier As String
    Get
    Set
public:
property String^ ReportedInterchangeSenderIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReportedReceiverID Property

ReportedReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedReceiverID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedReceiverID { get; set; }
Public Property ReportedReceiverID As String
    Get
    Set
public:
property String^ ReportedReceiverID {
    String^ get ();
    void set (String^ value);
}


ReportedSenderID Property

ReportedSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedSenderID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedSenderID { get; set; }
Public Property ReportedSenderID As String
    Get
    Set
public:
property String^ ReportedSenderID {
    String^ get ();
    void set (String^ value);
}


ReportedStartSegmentID Property

ReportedStartSegmentID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedStartSegmentID
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedStartSegmentID { get; set; }
Public Property ReportedStartSegmentID As String
    Get
    Set
public:
property String^ ReportedStartSegmentID {
    String^ get ();
    void set (String^ value);
}


ReportedTime Property

ReportedTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► ReportedTime
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedTime { get; set; }
Public Property ReportedTime As String
    Get
    Set
public:
property String^ ReportedTime {
    String^ get ();
    void set (String^ value);
}


SecondReferenceID Property

SecondReferenceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► SecondReferenceID
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string SecondReferenceID { get; set; }
Public Property SecondReferenceID As String
    Get
    Set
public:
property String^ SecondReferenceID {
    String^ get ();
    void set (String^ value);
}


SecondReferenceIDQualifier Property

SecondReferenceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► SecondReferenceIDQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SecondReferenceIDQualifier { get; set; }
Public Property SecondReferenceIDQualifier As String
    Get
    Set
public:
property String^ SecondReferenceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IIS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IM Class

IM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM
RDPCrystal EDI Library
Intermodal Movement Information
Declaration Syntax
C# Visual Basic Visual C++
public class IM : DocumentSegment
Public Class IM _
    Inherits DocumentSegment
public ref class IM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IM()()()() | Initializes a new instance of the IM class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InlandTransportationCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaterMovementCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IM


IM Constructor

IM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM ► IM()()()()
RDPCrystal EDI Library
Initializes a new instance of the IM class
Declaration Syntax
C# Visual Basic Visual C++
public IM()
Public Sub New
public:
IM()


InlandTransportationCode Property

InlandTransportationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM ► InlandTransportationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InlandTransportationCode { get; set; }
Public Property InlandTransportationCode As String
    Get
    Set
public:
property String^ InlandTransportationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM ► SpecialHandlingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


WaterMovementCode Property

WaterMovementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM ► WaterMovementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WaterMovementCode { get; set; }
Public Property WaterMovementCode As String
    Get
    Set
public:
property String^ WaterMovementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IMA Class

IMA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA
RDPCrystal EDI Library
Interchange Move Authority
Declaration Syntax
C# Visual Basic Visual C++
public class IMA : DocumentSegment
Public Class IMA _
    Inherits DocumentSegment
public ref class IMA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IMA()()()() | Initializes a new instance of the IMA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MovementAuthorityCode | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingDescription | Element 2
 | StandardCarrierAlphaCode | Element 3
 | TariffApplicationCode | Element 4
 | TariffApplicationCode1 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IMA


IMA Constructor

IMA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► IMA()()()()
RDPCrystal EDI Library
Initializes a new instance of the IMA class
Declaration Syntax
C# Visual Basic Visual C++
public IMA()
Public Sub New
public:
IMA()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MovementAuthorityCode Property

MovementAuthorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► MovementAuthorityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MovementAuthorityCode { get; set; }
Public Property MovementAuthorityCode As String
    Get
    Set
public:
property String^ MovementAuthorityCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingDescription Property

SpecialHandlingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► SpecialHandlingDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingDescription { get; set; }
Public Property SpecialHandlingDescription As String
    Get
    Set
public:
property String^ SpecialHandlingDescription {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode Property

TariffApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► TariffApplicationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode { get; set; }
Public Property TariffApplicationCode As String
    Get
    Set
public:
property String^ TariffApplicationCode {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode1 Property

TariffApplicationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► TariffApplicationCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode1 { get; set; }
Public Property TariffApplicationCode1 As String
    Get
    Set
public:
property String^ TariffApplicationCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IMM Class

IMM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM
RDPCrystal EDI Library
Immunization Status Code
Declaration Syntax
C# Visual Basic Visual C++
public class IMM : DocumentSegment
Public Class IMM _
    Inherits DocumentSegment
public ref class IMM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IMM()()()() | Initializes a new instance of the IMM class
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImmunizationStatusCode | Element 4
 | ImmunizationTypeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportTypeCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IMM


IMM Constructor

IMM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► IMM()()()()
RDPCrystal EDI Library
Initializes a new instance of the IMM class
Declaration Syntax
C# Visual Basic Visual C++
public IMM()
Public Sub New
public:
IMM()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


ImmunizationStatusCode Property

ImmunizationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► ImmunizationStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ImmunizationStatusCode { get; set; }
Public Property ImmunizationStatusCode As String
    Get
    Set
public:
property String^ ImmunizationStatusCode {
    String^ get ();
    void set (String^ value);
}


ImmunizationTypeCode Property

ImmunizationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► ImmunizationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ImmunizationTypeCode { get; set; }
Public Property ImmunizationTypeCode As String
    Get
    Set
public:
property String^ ImmunizationTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► ReportTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IMP Class

IMP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMP
RDPCrystal EDI Library
Impairment Detail
Declaration Syntax
C# Visual Basic Visual C++
public class IMP : DocumentSegment
Public Class IMP _
    Inherits DocumentSegment
public ref class IMP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IMP()()()() | Initializes a new instance of the IMP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PartOfBodyCode | Element 1
 | Percent | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IMP


IMP Constructor

IMP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMP ► IMP()()()()
RDPCrystal EDI Library
Initializes a new instance of the IMP class
Declaration Syntax
C# Visual Basic Visual C++
public IMP()
Public Sub New
public:
IMP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PartOfBodyCode Property

PartOfBodyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMP ► PartOfBodyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PartOfBodyCode { get; set; }
Public Property PartOfBodyCode As String
    Get
    Set
public:
property String^ PartOfBodyCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMP ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IMP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IN1 Class

IN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1
RDPCrystal EDI Library
Individual Identification
Declaration Syntax
C# Visual Basic Visual C++
public class IN1 : DocumentSegment
Public Class IN1 _
    Inherits DocumentSegment
public ref class IN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IN1()()()() | Initializes a new instance of the IN1 class
 | EntityIdentifierCode | Element 3
 | EntityTypeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 6
 | LevelOfIndividualTestOrCourseCod | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameTypeCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IN1


IN1 Constructor

IN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► IN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the IN1 class
Declaration Syntax
C# Visual Basic Visual C++
public IN1()
Public Sub New
public:
IN1()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityTypeQualifier Property

EntityTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► EntityTypeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTypeQualifier { get; set; }
Public Property EntityTypeQualifier As String
    Get
    Set
public:
property String^ EntityTypeQualifier {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCod Property

LevelOfIndividualTestOrCourseCod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► LevelOfIndividualTestOrCourseCod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCod { get; set; }
Public Property LevelOfIndividualTestOrCourseCod As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCod {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NameTypeCode Property

NameTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► NameTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NameTypeCode { get; set; }
Public Property NameTypeCode As String
    Get
    Set
public:
property String^ NameTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IN2 Class

IN2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN2
RDPCrystal EDI Library
Individual Name Structure Components
Declaration Syntax
C# Visual Basic Visual C++
public class IN2 : DocumentSegment
Public Class IN2 _
    Inherits DocumentSegment
public ref class IN2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IN2()()()() | Initializes a new instance of the IN2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | NameComponentQualifier | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IN2


IN2 Constructor

IN2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN2 ► IN2()()()()
RDPCrystal EDI Library
Initializes a new instance of the IN2 class
Declaration Syntax
C# Visual Basic Visual C++
public IN2()
Public Sub New
public:
IN2()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN2 ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


NameComponentQualifier Property

NameComponentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN2 ► NameComponentQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NameComponentQualifier { get; set; }
Public Property NameComponentQualifier As String
    Get
    Set
public:
property String^ NameComponentQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IN2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


INC Class

INC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC
RDPCrystal EDI Library
Installment Information
Declaration Syntax
C# Visual Basic Visual C++
public class INC : DocumentSegment
Public Class INC _
    Inherits DocumentSegment
public ref class INC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INC()()()() | Initializes a new instance of the INC class
 | CompositeUnitOfMeasure | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | Quantity1 | Element 4
 | TermsTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INC


INC Constructor

INC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► INC()()()()
RDPCrystal EDI Library
Initializes a new instance of the INC class
Declaration Syntax
C# Visual Basic Visual C++
public INC()
Public Sub New
public:
INC()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode Property

TermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► TermsTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode { get; set; }
Public Property TermsTypeCode As String
    Get
    Set
public:
property String^ TermsTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IND Class

IND Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND
RDPCrystal EDI Library
Additional Individual Demographic Information
Declaration Syntax
C# Visual Basic Visual C++
public class IND : DocumentSegment
Public Class IND _
    Inherits DocumentSegment
public ref class IND : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IND()()()() | Initializes a new instance of the IND class
 | CityName | Element 4
 | CountryCode | Element 1
 | CountyDesignator | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 10
 | IdentificationCode1 | Element 12
 | IdentificationCodeQualifier | Element 9
 | IdentificationCodeQualifier1 | Element 11
 | LanguageCode | Element 5
 | LanguageCode1 | Element 7
 | LanguageCode2 | Element 8
 | LanguageProficiencyIndicator | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IND


IND Constructor

IND Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► IND()()()()
RDPCrystal EDI Library
Initializes a new instance of the IND class
Declaration Syntax
C# Visual Basic Visual C++
public IND()
Public Sub New
public:
IND()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► CountryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountyDesignator Property

CountyDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► CountyDesignator
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountyDesignator { get; set; }
Public Property CountyDesignator As String
    Get
    Set
public:
property String^ CountyDesignator {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► IdentificationCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► IdentificationCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier1 Property

IdentificationCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► IdentificationCodeQualifier1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier1 { get; set; }
Public Property IdentificationCodeQualifier1 As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► LanguageCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


LanguageCode1 Property

LanguageCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► LanguageCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode1 { get; set; }
Public Property LanguageCode1 As String
    Get
    Set
public:
property String^ LanguageCode1 {
    String^ get ();
    void set (String^ value);
}


LanguageCode2 Property

LanguageCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► LanguageCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode2 { get; set; }
Public Property LanguageCode2 As String
    Get
    Set
public:
property String^ LanguageCode2 {
    String^ get ();
    void set (String^ value);
}


LanguageProficiencyIndicator Property

LanguageProficiencyIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► LanguageProficiencyIndicator
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageProficiencyIndicator { get; set; }
Public Property LanguageProficiencyIndicator As String
    Get
    Set
public:
property String^ LanguageProficiencyIndicator {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IND ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IndexIdentification Class

IndexIdentification Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification
RDPCrystal EDI Library
C036
Declaration Syntax
C# Visual Basic Visual C++
public class IndexIdentification : DocumentCompositeElement
Public Class IndexIdentification _
    Inherits DocumentCompositeElement
public ref class IndexIdentification : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexIdentification()()()() | Initializes a new instance of the IndexIdentification class
 | ConfigurationTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 3
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
 | XPeg | Element 4
 | YPeg | Element 5
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | IndexIdentification


IndexIdentification Constructor

IndexIdentification Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► IndexIdentification()()()()
RDPCrystal EDI Library
Initializes a new instance of the IndexIdentification class
Declaration Syntax
C# Visual Basic Visual C++
public IndexIdentification()
Public Sub New
public:
IndexIdentification()


ConfigurationTypeCode Property

ConfigurationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► ConfigurationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigurationTypeCode { get; set; }
Public Property ConfigurationTypeCode As String
    Get
    Set
public:
property String^ ConfigurationTypeCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


XPeg Property

XPeg Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► XPeg
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string XPeg { get; set; }
Public Property XPeg As String
    Get
    Set
public:
property String^ XPeg {
    String^ get ();
    void set (String^ value);
}


YPeg Property

YPeg Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IndexIdentification ► YPeg
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YPeg { get; set; }
Public Property YPeg As String
    Get
    Set
public:
property String^ YPeg {
    String^ get ();
    void set (String^ value);
}


INQ Class

INQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INQ
RDPCrystal EDI Library
Credit Inquiry Details
Declaration Syntax
C# Visual Basic Visual C++
public class INQ : DocumentSegment
Public Class INQ _
    Inherits DocumentSegment
public ref class INQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INQ()()()() | Initializes a new instance of the INQ class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ResultsCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INQ


INQ Constructor

INQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INQ ► INQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the INQ class
Declaration Syntax
C# Visual Basic Visual C++
public INQ()
Public Sub New
public:
INQ()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ResultsCode Property

ResultsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INQ ► ResultsCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ResultsCode { get; set; }
Public Property ResultsCode As String
    Get
    Set
public:
property String^ ResultsCode {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INQ ► TypeOfAccountCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


INR Class

INR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR
RDPCrystal EDI Library
Information Request
Declaration Syntax
C# Visual Basic Visual C++
public class INR : DocumentSegment
Public Class INR _
    Inherits DocumentSegment
public ref class INR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INR()()()() | Initializes a new instance of the INR class
 | CodeCategory | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode | Element 3
 | InformationType | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INR


INR Constructor

INR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR ► INR()()()()
RDPCrystal EDI Library
Initializes a new instance of the INR class
Declaration Syntax
C# Visual Basic Visual C++
public INR()
Public Sub New
public:
INR()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR ► InformationStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


InformationType Property

InformationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR ► InformationType
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InformationType { get; set; }
Public Property InformationType As String
    Get
    Set
public:
property String^ InformationType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


INS Class

INS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS
RDPCrystal EDI Library
Insured Benefit
Declaration Syntax
C# Visual Basic Visual C++
public class INS : DocumentSegment
Public Class INS _
    Inherits DocumentSegment
public ref class INS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INS()()()() | Initializes a new instance of the INS class
 | BenefitStatusCode | Element 5
 | CityName | Element 14
 | COBRAQualifyingEventCode | Element 7
 | ConfidentialityCode | Element 13
 | CountryCode | Element 16
 | DateTimePeriod | Element 12
 | DateTimePeriodFormatQualifier | Element 11
 | EmploymentStatusCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 4
 | MaintenanceTypeCode | Element 3
 | MedicarePlanCode | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 17
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 15
 | StudentStatusCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
 | YesNoConditionOrResponseCode1 | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INS


INS Constructor

INS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► INS()()()()
RDPCrystal EDI Library
Initializes a new instance of the INS class
Declaration Syntax
C# Visual Basic Visual C++
public INS()
Public Sub New
public:
INS()


BenefitStatusCode Property

BenefitStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► BenefitStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BenefitStatusCode { get; set; }
Public Property BenefitStatusCode As String
    Get
    Set
public:
property String^ BenefitStatusCode {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► CityName
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


COBRAQualifyingEventCode Property

COBRAQualifyingEventCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► COBRAQualifyingEventCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string COBRAQualifyingEventCode { get; set; }
Public Property COBRAQualifyingEventCode As String
    Get
    Set
public:
property String^ COBRAQualifyingEventCode {
    String^ get ();
    void set (String^ value);
}


ConfidentialityCode Property

ConfidentialityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► ConfidentialityCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ConfidentialityCode { get; set; }
Public Property ConfidentialityCode As String
    Get
    Set
public:
property String^ ConfidentialityCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► CountryCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► DateTimePeriod
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► EmploymentStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


MedicarePlanCode Property

MedicarePlanCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► MedicarePlanCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MedicarePlanCode { get; set; }
Public Property MedicarePlanCode As String
    Get
    Set
public:
property String^ MedicarePlanCode {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► Number
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► StateOrProvinceCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StudentStatusCode Property

StudentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► StudentStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StudentStatusCode { get; set; }
Public Property StudentStatusCode As String
    Get
    Set
public:
property String^ StudentStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INS ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


INT Class

INT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT
RDPCrystal EDI Library
Interest
Declaration Syntax
C# Visual Basic Visual C++
public class INT : DocumentSegment
Public Class INT _
    Inherits DocumentSegment
public ref class INT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INT()()()() | Initializes a new instance of the INT class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 2
 | InterestTypeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INT


INT Constructor

INT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► INT()()()()
RDPCrystal EDI Library
Initializes a new instance of the INT class
Declaration Syntax
C# Visual Basic Visual C++
public INT()
Public Sub New
public:
INT()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► InterestRate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


InterestTypeCode Property

InterestTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► InterestTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InterestTypeCode { get; set; }
Public Property InterestTypeCode As String
    Get
    Set
public:
property String^ InterestTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


INV Class

INV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV
RDPCrystal EDI Library
Investment Vehicle Selection
Declaration Syntax
C# Visual Basic Visual C++
public class INV : DocumentSegment
Public Class INV _
    Inherits DocumentSegment
public ref class INV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INV()()()() | Initializes a new instance of the INV class
 | Description | Element 1
 | Description1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | Quantity | Element 4
 | StateOrProvinceCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INV


INV Constructor

INV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► INV()()()()
RDPCrystal EDI Library
Initializes a new instance of the INV class
Declaration Syntax
C# Visual Basic Visual C++
public INV()
Public Sub New
public:
INV()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► Description1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► MonetaryAmount1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► StateOrProvinceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


INX Class

INX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INX
RDPCrystal EDI Library
Index Detail
Declaration Syntax
C# Visual Basic Visual C++
public class INX : DocumentSegment
Public Class INX _
    Inherits DocumentSegment
public ref class INX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INX()()()() | Initializes a new instance of the INX class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndexIdentification | Element 2
 | IndexQualifier | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INX


INX Constructor

INX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INX ► INX()()()()
RDPCrystal EDI Library
Initializes a new instance of the INX class
Declaration Syntax
C# Visual Basic Visual C++
public INX()
Public Sub New
public:
INX()


IndexIdentification Property

IndexIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INX ► IndexIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public IndexIdentification IndexIdentification { get; set; }
Public Property IndexIdentification As IndexIdentification
    Get
    Set
public:
property IndexIdentification^ IndexIdentification {
    IndexIdentification^ get ();
    void set (IndexIdentification^ value);
}


IndexQualifier Property

IndexQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INX ► IndexQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndexQualifier { get; set; }
Public Property IndexQualifier As String
    Get
    Set
public:
property String^ IndexQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► INX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IRA Class

IRA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA
RDPCrystal EDI Library
Investor Reporting Action Code
Declaration Syntax
C# Visual Basic Visual C++
public class IRA : DocumentSegment
Public Class IRA _
    Inherits DocumentSegment
public ref class IRA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IRA()()()() | Initializes a new instance of the IRA class
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvestorReportingActionCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IRA


IRA Constructor

IRA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA ► IRA()()()()
RDPCrystal EDI Library
Initializes a new instance of the IRA class
Declaration Syntax
C# Visual Basic Visual C++
public IRA()
Public Sub New
public:
IRA()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


InvestorReportingActionCode Property

InvestorReportingActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA ► InvestorReportingActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InvestorReportingActionCode { get; set; }
Public Property InvestorReportingActionCode As String
    Get
    Set
public:
property String^ InvestorReportingActionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IRP Class

IRP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP
RDPCrystal EDI Library
Report Selection Segment
Declaration Syntax
C# Visual Basic Visual C++
public class IRP : DocumentSegment
Public Class IRP _
    Inherits DocumentSegment
public ref class IRP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IRP()()()() | Initializes a new instance of the IRP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageDirectionCode | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportIdentifier | Element 2
 | ReportIncrementalIndicatorCode | Element 3
 | ReportLevelOfDetailCode | Element 6
 | ReportStatusLevelCode | Element 5
 | ReportTypeCode | Element 1
 | ShipDeliveryOrCalendarPatternCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IRP


IRP Constructor

IRP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► IRP()()()()
RDPCrystal EDI Library
Initializes a new instance of the IRP class
Declaration Syntax
C# Visual Basic Visual C++
public IRP()
Public Sub New
public:
IRP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MessageDirectionCode Property

MessageDirectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► MessageDirectionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MessageDirectionCode { get; set; }
Public Property MessageDirectionCode As String
    Get
    Set
public:
property String^ MessageDirectionCode {
    String^ get ();
    void set (String^ value);
}


ReportIdentifier Property

ReportIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► ReportIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReportIdentifier { get; set; }
Public Property ReportIdentifier As String
    Get
    Set
public:
property String^ ReportIdentifier {
    String^ get ();
    void set (String^ value);
}


ReportIncrementalIndicatorCode Property

ReportIncrementalIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► ReportIncrementalIndicatorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReportIncrementalIndicatorCode { get; set; }
Public Property ReportIncrementalIndicatorCode As String
    Get
    Set
public:
property String^ ReportIncrementalIndicatorCode {
    String^ get ();
    void set (String^ value);
}


ReportLevelOfDetailCode Property

ReportLevelOfDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► ReportLevelOfDetailCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReportLevelOfDetailCode { get; set; }
Public Property ReportLevelOfDetailCode As String
    Get
    Set
public:
property String^ ReportLevelOfDetailCode {
    String^ get ();
    void set (String^ value);
}


ReportStatusLevelCode Property

ReportStatusLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► ReportStatusLevelCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportStatusLevelCode { get; set; }
Public Property ReportStatusLevelCode As String
    Get
    Set
public:
property String^ ReportStatusLevelCode {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IRP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IS1 Class

IS1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1
RDPCrystal EDI Library
Estimated Time of Arrival and Car Scheduling
Declaration Syntax
C# Visual Basic Visual C++
public class IS1 : DocumentSegment
Public Class IS1 _
    Inherits DocumentSegment
public ref class IS1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IS1()()()() | Initializes a new instance of the IS1 class
 | CarTypeCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RetripReasonCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IS1


IS1 Constructor

IS1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► IS1()()()()
RDPCrystal EDI Library
Initializes a new instance of the IS1 class
Declaration Syntax
C# Visual Basic Visual C++
public IS1()
Public Sub New
public:
IS1()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► CarTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► IndustryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


RetripReasonCode Property

RetripReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► RetripReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RetripReasonCode { get; set; }
Public Property RetripReasonCode As String
    Get
    Set
public:
property String^ RetripReasonCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IS2 Class

IS2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2
RDPCrystal EDI Library
Scheduled Events
Declaration Syntax
C# Visual Basic Visual C++
public class IS2 : DocumentSegment
Public Class IS2 _
    Inherits DocumentSegment
public ref class IS2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IS2()()()() | Initializes a new instance of the IS2 class
 | AccomplishCode | Element 3
 | BlockIdentification | Element 11
 | CityName | Element 16
 | Date | Element 5
 | Date1 | Element 10
 | Date2 | Element 12
 | Date3 | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventCode | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 8
 | StandardPointLocationCode | Element 4
 | StateOrProvinceCode | Element 17
 | Time | Element 6
 | Time1 | Element 13
 | Time2 | Element 15
 | TimeCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IS2


IS2 Constructor

IS2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► IS2()()()()
RDPCrystal EDI Library
Initializes a new instance of the IS2 class
Declaration Syntax
C# Visual Basic Visual C++
public IS2()
Public Sub New
public:
IS2()


AccomplishCode Property

AccomplishCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► AccomplishCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AccomplishCode { get; set; }
Public Property AccomplishCode As String
    Get
    Set
public:
property String^ AccomplishCode {
    String^ get ();
    void set (String^ value);
}


BlockIdentification Property

BlockIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► BlockIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string BlockIdentification { get; set; }
Public Property BlockIdentification As String
    Get
    Set
public:
property String^ BlockIdentification {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► CityName
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Date1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Date2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Date3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


EventCode Property

EventCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► EventCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EventCode { get; set; }
Public Property EventCode As String
    Get
    Set
public:
property String^ EventCode {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Time1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


Time2 Property

Time2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Time2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Time2 { get; set; }
Public Property Time2 As String
    Get
    Set
public:
property String^ Time2 {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► TimeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IS2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISA Class

ISA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA
RDPCrystal EDI Library
Interchange Control Header
Declaration Syntax
C# Visual Basic Visual C++
public class ISA : DocumentSegment
Public Class ISA _
    Inherits DocumentSegment
public ref class ISA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISA()()()() | Initializes a new instance of the ISA class
 | AcknowledgmentRequested | Element 14
 | AuthorizationInformation | Element 2
 | AuthorizationInformationQualifier | Element 1
 | ComponentElementSeparator | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeControlNumber | Element 13
 | InterchangeControlStandardsIdentifier | Element 11
 | InterchangeControlVersionNumber | Element 12
 | InterchangeDate | Element 9
 | InterchangeIDQualifier1 | Element 5
 | InterchangeIDQualifier2 | Element 7
 | InterchangeReceiverID | Element 8
 | InterchangeSenderID | Element 6
 | InterchangeTime | Element 10
 | InterchangeUsageIndicator | Element 15
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityInformation | Element 4
 | SecurityInformationQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISA


ISA Constructor

ISA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► ISA()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISA class
Declaration Syntax
C# Visual Basic Visual C++
public ISA()
Public Sub New
public:
ISA()


AcknowledgmentRequested Property

AcknowledgmentRequested Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► AcknowledgmentRequested
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentRequested { get; set; }
Public Property AcknowledgmentRequested As String
    Get
    Set
public:
property String^ AcknowledgmentRequested {
    String^ get ();
    void set (String^ value);
}


AuthorizationInformation Property

AuthorizationInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► AuthorizationInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationInformation { get; set; }
Public Property AuthorizationInformation As String
    Get
    Set
public:
property String^ AuthorizationInformation {
    String^ get ();
    void set (String^ value);
}


AuthorizationInformationQualifier Property

AuthorizationInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► AuthorizationInformationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationInformationQualifier { get; set; }
Public Property AuthorizationInformationQualifier As String
    Get
    Set
public:
property String^ AuthorizationInformationQualifier {
    String^ get ();
    void set (String^ value);
}


ComponentElementSeparator Property

ComponentElementSeparator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► ComponentElementSeparator
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentElementSeparator { get; set; }
Public Property ComponentElementSeparator As String
    Get
    Set
public:
property String^ ComponentElementSeparator {
    String^ get ();
    void set (String^ value);
}


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeControlNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}


InterchangeControlStandardsIdentifier Property

InterchangeControlStandardsIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeControlStandardsIdentifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlStandardsIdentifier { get; set; }
Public Property InterchangeControlStandardsIdentifier As String
    Get
    Set
public:
property String^ InterchangeControlStandardsIdentifier {
    String^ get ();
    void set (String^ value);
}


InterchangeControlVersionNumber Property

InterchangeControlVersionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeControlVersionNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlVersionNumber { get; set; }
Public Property InterchangeControlVersionNumber As String
    Get
    Set
public:
property String^ InterchangeControlVersionNumber {
    String^ get ();
    void set (String^ value);
}


InterchangeDate Property

InterchangeDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeDate
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeDate { get; set; }
Public Property InterchangeDate As String
    Get
    Set
public:
property String^ InterchangeDate {
    String^ get ();
    void set (String^ value);
}


InterchangeIDQualifier1 Property

InterchangeIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeIDQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeIDQualifier1 { get; set; }
Public Property InterchangeIDQualifier1 As String
    Get
    Set
public:
property String^ InterchangeIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


InterchangeIDQualifier2 Property

InterchangeIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeIDQualifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeIDQualifier2 { get; set; }
Public Property InterchangeIDQualifier2 As String
    Get
    Set
public:
property String^ InterchangeIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


InterchangeReceiverID Property

InterchangeReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeReceiverID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverID { get; set; }
Public Property InterchangeReceiverID As String
    Get
    Set
public:
property String^ InterchangeReceiverID {
    String^ get ();
    void set (String^ value);
}


InterchangeSenderID Property

InterchangeSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeSenderID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderID { get; set; }
Public Property InterchangeSenderID As String
    Get
    Set
public:
property String^ InterchangeSenderID {
    String^ get ();
    void set (String^ value);
}


InterchangeTime Property

InterchangeTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeTime
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTime { get; set; }
Public Property InterchangeTime As String
    Get
    Set
public:
property String^ InterchangeTime {
    String^ get ();
    void set (String^ value);
}


InterchangeUsageIndicator Property

InterchangeUsageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► InterchangeUsageIndicator
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeUsageIndicator { get; set; }
Public Property InterchangeUsageIndicator As String
    Get
    Set
public:
property String^ InterchangeUsageIndicator {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityInformation Property

SecurityInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► SecurityInformation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityInformation { get; set; }
Public Property SecurityInformation As String
    Get
    Set
public:
property String^ SecurityInformation {
    String^ get ();
    void set (String^ value);
}


SecurityInformationQualifier Property

SecurityInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► SecurityInformationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityInformationQualifier { get; set; }
Public Property SecurityInformationQualifier As String
    Get
    Set
public:
property String^ SecurityInformationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISB Class

ISB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISB
RDPCrystal EDI Library
Grade of Service Request Segment
Declaration Syntax
C# Visual Basic Visual C++
public class ISB : DocumentSegment
Public Class ISB _
    Inherits DocumentSegment
public ref class ISB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISB()()()() | Initializes a new instance of the ISB class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GradeOfServiceCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISB


ISB Constructor

ISB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISB ► ISB()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISB class
Declaration Syntax
C# Visual Basic Visual C++
public ISB()
Public Sub New
public:
ISB()


GradeOfServiceCode Property

GradeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISB ► GradeOfServiceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string GradeOfServiceCode { get; set; }
Public Property GradeOfServiceCode As String
    Get
    Set
public:
property String^ GradeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISC Class

ISC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC
RDPCrystal EDI Library
Interline Service Commitment Detail
Declaration Syntax
C# Visual Basic Visual C++
public class ISC : DocumentSegment
Public Class ISC _
    Inherits DocumentSegment
public ref class ISC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISC()()()() | Initializes a new instance of the ISC class
 | BlockIdentification | Element 10
 | DateTimePeriod | Element 5
 | DateTimePeriodFormatQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventCode | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTrainIdentification | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfDays | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 8
 | StandardPointLocationCode | Element 2
 | Time | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISC


ISC Constructor

ISC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► ISC()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISC class
Declaration Syntax
C# Visual Basic Visual C++
public ISC()
Public Sub New
public:
ISC()


BlockIdentification Property

BlockIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► BlockIdentification
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string BlockIdentification { get; set; }
Public Property BlockIdentification As String
    Get
    Set
public:
property String^ BlockIdentification {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► DateTimePeriod
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


EventCode Property

EventCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► EventCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EventCode { get; set; }
Public Property EventCode As String
    Get
    Set
public:
property String^ EventCode {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfDays Property

NumberOfDays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► NumberOfDays
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfDays { get; set; }
Public Property NumberOfDays As String
    Get
    Set
public:
property String^ NumberOfDays {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► StandardPointLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISD Class

ISD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD
RDPCrystal EDI Library
Railroad Interline Service Definition Detail
Declaration Syntax
C# Visual Basic Visual C++
public class ISD : DocumentSegment
Public Class ISD _
    Inherits DocumentSegment
public ref class ISD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISD()()()() | Initializes a new instance of the ISD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventCode | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardPointLocationCode | Element 2
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISD


ISD Constructor

ISD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► ISD()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISD class
Declaration Syntax
C# Visual Basic Visual C++
public ISD()
Public Sub New
public:
ISD()


EventCode Property

EventCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► EventCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EventCode { get; set; }
Public Property EventCode As String
    Get
    Set
public:
property String^ EventCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► StandardPointLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISE Class

ISE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE
RDPCrystal EDI Library
Deferred Delivery Request Segment
Declaration Syntax
C# Visual Basic Visual C++
public class ISE : DocumentSegment
Public Class ISE _
    Inherits DocumentSegment
public ref class ISE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISE()()()() | Initializes a new instance of the ISE class
 | DeliveryDate | Element 1
 | DeliveryTime | Element 2
 | DeliveryTimeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISE


ISE Constructor

ISE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE ► ISE()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISE class
Declaration Syntax
C# Visual Basic Visual C++
public ISE()
Public Sub New
public:
ISE()


DeliveryDate Property

DeliveryDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE ► DeliveryDate
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryDate { get; set; }
Public Property DeliveryDate As String
    Get
    Set
public:
property String^ DeliveryDate {
    String^ get ();
    void set (String^ value);
}


DeliveryTime Property

DeliveryTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE ► DeliveryTime
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryTime { get; set; }
Public Property DeliveryTime As String
    Get
    Set
public:
property String^ DeliveryTime {
    String^ get ();
    void set (String^ value);
}


DeliveryTimeCode Property

DeliveryTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE ► DeliveryTimeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryTimeCode { get; set; }
Public Property DeliveryTimeCode As String
    Get
    Set
public:
property String^ DeliveryTimeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISR Class

ISR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR
RDPCrystal EDI Library
Item Status Report
Declaration Syntax
C# Visual Basic Visual C++
public class ISR : DocumentSegment
Public Class ISR _
    Inherits DocumentSegment
public ref class ISR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISR()()()() | Initializes a new instance of the ISR class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentOrderStatusCode | Element 1
 | StatusReasonCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISR


ISR Constructor

ISR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR ► ISR()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISR class
Declaration Syntax
C# Visual Basic Visual C++
public ISR()
Public Sub New
public:
ISR()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR ► StatusReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ISS Class

ISS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS
RDPCrystal EDI Library
Invoice Shipment Summary
Declaration Syntax
C# Visual Basic Visual C++
public class ISS : DocumentSegment
Public Class ISS _
    Inherits DocumentSegment
public ref class ISS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISS()()()() | Initializes a new instance of the ISS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UnitOrBasisForMeasurementCode1 | Element 4
 | UnitOrBasisForMeasurementCode2 | Element 6
 | Volume | Element 5
 | Weight | Element 3
 | Weight1 | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISS


ISS Constructor

ISS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► ISS()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISS class
Declaration Syntax
C# Visual Basic Visual C++
public ISS()
Public Sub New
public:
ISS()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► Volume
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► Weight1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ISS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IT Class

IT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT
RDPCrystal EDI Library
Interconnect Mailbag Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class IT : DocumentSegment
Public Class IT _
    Inherits DocumentSegment
public ref class IT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IT()()()() | Initializes a new instance of the IT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterconnectMailbagAcknowledgmentCount | Element 2
 | InterconnectMailbagControlNumber | Element 1
 | InterconnectMailbagInterchangeCount | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IT


IT Constructor

IT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT ► IT()()()()
RDPCrystal EDI Library
Initializes a new instance of the IT class
Declaration Syntax
C# Visual Basic Visual C++
public IT()
Public Sub New
public:
IT()


InterconnectMailbagAcknowledgmentCount Property

InterconnectMailbagAcknowledgmentCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT ► InterconnectMailbagAcknowledgmentCount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagAcknowledgmentCount { get; set; }
Public Property InterconnectMailbagAcknowledgmentCount As String
    Get
    Set
public:
property String^ InterconnectMailbagAcknowledgmentCount {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagControlNumber Property

InterconnectMailbagControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT ► InterconnectMailbagControlNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagControlNumber { get; set; }
Public Property InterconnectMailbagControlNumber As String
    Get
    Set
public:
property String^ InterconnectMailbagControlNumber {
    String^ get ();
    void set (String^ value);
}


InterconnectMailbagInterchangeCount Property

InterconnectMailbagInterchangeCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT ► InterconnectMailbagInterchangeCount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InterconnectMailbagInterchangeCount { get; set; }
Public Property InterconnectMailbagInterchangeCount As String
    Get
    Set
public:
property String^ InterconnectMailbagInterchangeCount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IT1 Class

IT1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1
RDPCrystal EDI Library
Baseline Item Data (Invoice)
Declaration Syntax
C# Visual Basic Visual C++
public class IT1 : DocumentSegment
Public Class IT1 _
    Inherits DocumentSegment
public ref class IT1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IT1()()()() | Initializes a new instance of the IT1 class
 | AssignedIdentification | Element 1
 | BasisOfUnitPriceCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 7
 | ProductServiceID1 | Element 9
 | ProductServiceID2 | Element 11
 | ProductServiceID3 | Element 13
 | ProductServiceID4 | Element 15
 | ProductServiceID5 | Element 17
 | ProductServiceID6 | Element 19
 | ProductServiceID7 | Element 21
 | ProductServiceID8 | Element 23
 | ProductServiceID9 | Element 25
 | ProductServiceIDQualifier | Element 6
 | ProductServiceIDQualifier1 | Element 8
 | ProductServiceIDQualifier2 | Element 10
 | ProductServiceIDQualifier3 | Element 12
 | ProductServiceIDQualifier4 | Element 14
 | ProductServiceIDQualifier5 | Element 16
 | ProductServiceIDQualifier6 | Element 18
 | ProductServiceIDQualifier7 | Element 20
 | ProductServiceIDQualifier8 | Element 22
 | ProductServiceIDQualifier9 | Element 24
 | QuantityInvoiced | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitPrice | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IT1


IT1 Constructor

IT1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► IT1()()()()
RDPCrystal EDI Library
Initializes a new instance of the IT1 class
Declaration Syntax
C# Visual Basic Visual C++
public IT1()
Public Sub New
public:
IT1()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID5
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID6
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID7
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID8
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceID9
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


QuantityInvoiced Property

QuantityInvoiced Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► QuantityInvoiced
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInvoiced { get; set; }
Public Property QuantityInvoiced As String
    Get
    Set
public:
property String^ QuantityInvoiced {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► UnitPrice
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IT3 Class

IT3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3
RDPCrystal EDI Library
Additional Item Data
Declaration Syntax
C# Visual Basic Visual C++
public class IT3 : DocumentSegment
Public Class IT3 _
    Inherits DocumentSegment
public ref class IT3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IT3()()()() | Initializes a new instance of the IT3 class
 | ChangeReasonCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | QuantityDifference | Element 4
 | ShipmentOrderStatusCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IT3


IT3 Constructor

IT3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► IT3()()()()
RDPCrystal EDI Library
Initializes a new instance of the IT3 class
Declaration Syntax
C# Visual Basic Visual C++
public IT3()
Public Sub New
public:
IT3()


ChangeReasonCode Property

ChangeReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► ChangeReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeReasonCode { get; set; }
Public Property ChangeReasonCode As String
    Get
    Set
public:
property String^ ChangeReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


QuantityDifference Property

QuantityDifference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► QuantityDifference
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityDifference { get; set; }
Public Property QuantityDifference As String
    Get
    Set
public:
property String^ QuantityDifference {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IT8 Class

IT8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8
RDPCrystal EDI Library
Conditions of Sale
Declaration Syntax
C# Visual Basic Visual C++
public class IT8 : DocumentSegment
Public Class IT8 _
    Inherits DocumentSegment
public ref class IT8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IT8()()()() | Initializes a new instance of the IT8 class
 | AccountNumber | Element 4
 | ActionCode | Element 2
 | AgencyQualifierCode | Element 6
 | Amount | Element 3
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 9
 | ProductServiceID1 | Element 11
 | ProductServiceID2 | Element 13
 | ProductServiceID3 | Element 15
 | ProductServiceID4 | Element 17
 | ProductServiceID5 | Element 19
 | ProductServiceID6 | Element 21
 | ProductServiceID7 | Element 23
 | ProductServiceID8 | Element 25
 | ProductServiceID9 | Element 27
 | ProductServiceIDQualifier | Element 8
 | ProductServiceIDQualifier1 | Element 10
 | ProductServiceIDQualifier2 | Element 12
 | ProductServiceIDQualifier3 | Element 14
 | ProductServiceIDQualifier4 | Element 16
 | ProductServiceIDQualifier5 | Element 18
 | ProductServiceIDQualifier6 | Element 20
 | ProductServiceIDQualifier7 | Element 22
 | ProductServiceIDQualifier8 | Element 24
 | ProductServiceIDQualifier9 | Element 26
 | ProductServiceSubstitutionCode | Element 7
 | SalesRequirementCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IT8


IT8 Constructor

IT8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► IT8()()()()
RDPCrystal EDI Library
Initializes a new instance of the IT8 class
Declaration Syntax
C# Visual Basic Visual C++
public IT8()
Public Sub New
public:
IT8()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► AccountNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► AgencyQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID4
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID5
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID6
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID7
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID8
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceID9
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceSubstitutionCode Property

ProductServiceSubstitutionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► ProductServiceSubstitutionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceSubstitutionCode { get; set; }
Public Property ProductServiceSubstitutionCode As String
    Get
    Set
public:
property String^ ProductServiceSubstitutionCode {
    String^ get ();
    void set (String^ value);
}


SalesRequirementCode Property

SalesRequirementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► SalesRequirementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SalesRequirementCode { get; set; }
Public Property SalesRequirementCode As String
    Get
    Set
public:
property String^ SalesRequirementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IT8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ITA Class

ITA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA
RDPCrystal EDI Library
Allowance, Charge or Service
Declaration Syntax
C# Visual Basic Visual C++
public class ITA : DocumentSegment
Public Class ITA _
    Inherits DocumentSegment
public ref class ITA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ITA()()()() | Initializes a new instance of the ITA class
 | AgencyQualifierCode | Element 2
 | AllowanceChargePercentQualifier | Element 8
 | AllowanceOrChargeIndicator | Element 1
 | AllowanceOrChargeMethodOfHandlingCode | Element 4
 | AllowanceOrChargeNumber | Element 5
 | AllowanceOrChargeRate | Element 6
 | AllowanceOrChargeTotalAmount | Element 7
 | Description | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 9
 | Quantity | Element 10
 | Quantity1 | Element 12
 | RelationshipCode | Element 16
 | SourceSubqualifier | Element 15
 | SpecialChargeOrAllowanceCode | Element 14
 | SpecialServicesCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 11
 | UnitOrBasisForMeasurementCode1 | Element 17
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ITA


ITA Constructor

ITA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► ITA()()()()
RDPCrystal EDI Library
Initializes a new instance of the ITA class
Declaration Syntax
C# Visual Basic Visual C++
public ITA()
Public Sub New
public:
ITA()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AllowanceChargePercentQualifier Property

AllowanceChargePercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AllowanceChargePercentQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceChargePercentQualifier { get; set; }
Public Property AllowanceChargePercentQualifier As String
    Get
    Set
public:
property String^ AllowanceChargePercentQualifier {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeIndicator Property

AllowanceOrChargeIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AllowanceOrChargeIndicator
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeIndicator { get; set; }
Public Property AllowanceOrChargeIndicator As String
    Get
    Set
public:
property String^ AllowanceOrChargeIndicator {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeMethodOfHandlingCode Property

AllowanceOrChargeMethodOfHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AllowanceOrChargeMethodOfHandlingCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeMethodOfHandlingCode { get; set; }
Public Property AllowanceOrChargeMethodOfHandlingCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeMethodOfHandlingCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeNumber Property

AllowanceOrChargeNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AllowanceOrChargeNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeNumber { get; set; }
Public Property AllowanceOrChargeNumber As String
    Get
    Set
public:
property String^ AllowanceOrChargeNumber {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeRate Property

AllowanceOrChargeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AllowanceOrChargeRate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeRate { get; set; }
Public Property AllowanceOrChargeRate As String
    Get
    Set
public:
property String^ AllowanceOrChargeRate {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeTotalAmount Property

AllowanceOrChargeTotalAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► AllowanceOrChargeTotalAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeTotalAmount { get; set; }
Public Property AllowanceOrChargeTotalAmount As String
    Get
    Set
public:
property String^ AllowanceOrChargeTotalAmount {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► Description
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► Percent
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► Quantity1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


RelationshipCode Property

RelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► RelationshipCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipCode { get; set; }
Public Property RelationshipCode As String
    Get
    Set
public:
property String^ RelationshipCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► SourceSubqualifier
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► SpecialServicesCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ITC Class

ITC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC
RDPCrystal EDI Library
Information Type and Comment Results
Declaration Syntax
C# Visual Basic Visual C++
public class ITC : DocumentSegment
Public Class ITC _
    Inherits DocumentSegment
public ref class ITC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ITC()()()() | Initializes a new instance of the ITC class
 | ActionCode | Element 4
 | ConditionIndicator | Element 7
 | ConsolidationCode | Element 6
 | Description | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FinancialInformationTypeCode | Element 5
 | FinancialStatementFormatCode | Element 8
 | FreeFormMessage | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationRequestResultCode | Element 1
 | InformationStatusCode | Element 3
 | InformationType | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceOfDisclosureCode | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ITC


ITC Constructor

ITC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► ITC()()()()
RDPCrystal EDI Library
Initializes a new instance of the ITC class
Declaration Syntax
C# Visual Basic Visual C++
public ITC()
Public Sub New
public:
ITC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► ActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► ConditionIndicator
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


ConsolidationCode Property

ConsolidationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► ConsolidationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ConsolidationCode { get; set; }
Public Property ConsolidationCode As String
    Get
    Set
public:
property String^ ConsolidationCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► Description
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FinancialInformationTypeCode Property

FinancialInformationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► FinancialInformationTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FinancialInformationTypeCode { get; set; }
Public Property FinancialInformationTypeCode As String
    Get
    Set
public:
property String^ FinancialInformationTypeCode {
    String^ get ();
    void set (String^ value);
}


FinancialStatementFormatCode Property

FinancialStatementFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► FinancialStatementFormatCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FinancialStatementFormatCode { get; set; }
Public Property FinancialStatementFormatCode As String
    Get
    Set
public:
property String^ FinancialStatementFormatCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► FreeFormMessage
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


InformationRequestResultCode Property

InformationRequestResultCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► InformationRequestResultCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InformationRequestResultCode { get; set; }
Public Property InformationRequestResultCode As String
    Get
    Set
public:
property String^ InformationRequestResultCode {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► InformationStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


InformationType Property

InformationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► InformationType
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InformationType { get; set; }
Public Property InformationType As String
    Get
    Set
public:
property String^ InformationType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SourceOfDisclosureCode Property

SourceOfDisclosureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► SourceOfDisclosureCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string SourceOfDisclosureCode { get; set; }
Public Property SourceOfDisclosureCode As String
    Get
    Set
public:
property String^ SourceOfDisclosureCode {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ITD Class

ITD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD
RDPCrystal EDI Library
Terms of Sale/Deferred Terms of Sale
Declaration Syntax
C# Visual Basic Visual C++
public class ITD : DocumentSegment
Public Class ITD _
    Inherits DocumentSegment
public ref class ITD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ITD()()()() | Initializes a new instance of the ITD class
 | DayOfMonth | Element 13
 | DeferredAmountDue | Element 10
 | Description | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 14
 | Percent | Element 15
 | PercentOfInvoicePayable | Element 11
 | TermsBasisDateCode | Element 2
 | TermsDeferredDueDate | Element 9
 | TermsDiscountAmount | Element 8
 | TermsDiscountDaysDue | Element 5
 | TermsDiscountDueDate | Element 4
 | TermsDiscountPercent | Element 3
 | TermsNetDays | Element 7
 | TermsNetDueDate | Element 6
 | TermsTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ITD


ITD Constructor

ITD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► ITD()()()()
RDPCrystal EDI Library
Initializes a new instance of the ITD class
Declaration Syntax
C# Visual Basic Visual C++
public ITD()
Public Sub New
public:
ITD()


DayOfMonth Property

DayOfMonth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► DayOfMonth
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DayOfMonth { get; set; }
Public Property DayOfMonth As String
    Get
    Set
public:
property String^ DayOfMonth {
    String^ get ();
    void set (String^ value);
}


DeferredAmountDue Property

DeferredAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► DeferredAmountDue
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DeferredAmountDue { get; set; }
Public Property DeferredAmountDue As String
    Get
    Set
public:
property String^ DeferredAmountDue {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► Description
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► PaymentMethodCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► Percent
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PercentOfInvoicePayable Property

PercentOfInvoicePayable Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► PercentOfInvoicePayable
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PercentOfInvoicePayable { get; set; }
Public Property PercentOfInvoicePayable As String
    Get
    Set
public:
property String^ PercentOfInvoicePayable {
    String^ get ();
    void set (String^ value);
}


TermsBasisDateCode Property

TermsBasisDateCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsBasisDateCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TermsBasisDateCode { get; set; }
Public Property TermsBasisDateCode As String
    Get
    Set
public:
property String^ TermsBasisDateCode {
    String^ get ();
    void set (String^ value);
}


TermsDeferredDueDate Property

TermsDeferredDueDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsDeferredDueDate
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDeferredDueDate { get; set; }
Public Property TermsDeferredDueDate As String
    Get
    Set
public:
property String^ TermsDeferredDueDate {
    String^ get ();
    void set (String^ value);
}


TermsDiscountAmount Property

TermsDiscountAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsDiscountAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountAmount { get; set; }
Public Property TermsDiscountAmount As String
    Get
    Set
public:
property String^ TermsDiscountAmount {
    String^ get ();
    void set (String^ value);
}


TermsDiscountDaysDue Property

TermsDiscountDaysDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsDiscountDaysDue
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountDaysDue { get; set; }
Public Property TermsDiscountDaysDue As String
    Get
    Set
public:
property String^ TermsDiscountDaysDue {
    String^ get ();
    void set (String^ value);
}


TermsDiscountDueDate Property

TermsDiscountDueDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsDiscountDueDate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountDueDate { get; set; }
Public Property TermsDiscountDueDate As String
    Get
    Set
public:
property String^ TermsDiscountDueDate {
    String^ get ();
    void set (String^ value);
}


TermsDiscountPercent Property

TermsDiscountPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsDiscountPercent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent { get; set; }
Public Property TermsDiscountPercent As String
    Get
    Set
public:
property String^ TermsDiscountPercent {
    String^ get ();
    void set (String^ value);
}


TermsNetDays Property

TermsNetDays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsNetDays
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TermsNetDays { get; set; }
Public Property TermsNetDays As String
    Get
    Set
public:
property String^ TermsNetDays {
    String^ get ();
    void set (String^ value);
}


TermsNetDueDate Property

TermsNetDueDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsNetDueDate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TermsNetDueDate { get; set; }
Public Property TermsNetDueDate As String
    Get
    Set
public:
property String^ TermsNetDueDate {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode Property

TermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► TermsTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode { get; set; }
Public Property TermsTypeCode As String
    Get
    Set
public:
property String^ TermsTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ITD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


IV1 Class

IV1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1
RDPCrystal EDI Library
Lane Estimates
Declaration Syntax
C# Visual Basic Visual C++
public class IV1 : DocumentSegment
Public Class IV1 _
    Inherits DocumentSegment
public ref class IV1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IV1()()()() | Initializes a new instance of the IV1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 4
 | UnitOfTimePeriodOrInterval | Element 5
 | Volume | Element 2
 | VolumeUnitQualifier | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IV1


IV1 Constructor

IV1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► IV1()()()()
RDPCrystal EDI Library
Initializes a new instance of the IV1 class
Declaration Syntax
C# Visual Basic Visual C++
public IV1()
Public Sub New
public:
IV1()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► Number
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► Volume
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► IV1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


JCT Class

JCT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT
RDPCrystal EDI Library
Railroad Junction Information
Declaration Syntax
C# Visual Basic Visual C++
public class JCT : DocumentSegment
Public Class JCT _
    Inherits DocumentSegment
public ref class JCT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JCT()()()() | Initializes a new instance of the JCT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 3
 | FreightStationAccountingCode1 | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeTypeCode | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 2
 | StandardCarrierAlphaCode2 | Element 5
 | StandardCarrierAlphaCode3 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
 | YesNoConditionOrResponseCode1 | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | JCT


JCT Constructor

JCT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► JCT()()()()
RDPCrystal EDI Library
Initializes a new instance of the JCT class
Declaration Syntax
C# Visual Basic Visual C++
public JCT()
Public Sub New
public:
JCT()


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode1 Property

FreightStationAccountingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► FreightStationAccountingCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode1 { get; set; }
Public Property FreightStationAccountingCode1 As String
    Get
    Set
public:
property String^ FreightStationAccountingCode1 {
    String^ get ();
    void set (String^ value);
}


InterchangeTypeCode Property

InterchangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► InterchangeTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTypeCode { get; set; }
Public Property InterchangeTypeCode As String
    Get
    Set
public:
property String^ InterchangeTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode3 Property

StandardCarrierAlphaCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► StandardCarrierAlphaCode3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode3 { get; set; }
Public Property StandardCarrierAlphaCode3 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode3 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JCT ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


JID Class

JID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID
RDPCrystal EDI Library
Equipment Detail
Declaration Syntax
C# Visual Basic Visual C++
public class JID : DocumentSegment
Public Class JID _
    Inherits DocumentSegment
public ref class JID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JID()()()() | Initializes a new instance of the JID class
 | CompositeUnitOfMeasure | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceConditionCode | Element 5
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | JID


JID Constructor

JID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► JID()()()()
RDPCrystal EDI Library
Initializes a new instance of the JID class
Declaration Syntax
C# Visual Basic Visual C++
public JID()
Public Sub New
public:
JID()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► MonetaryAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ProductServiceConditionCode Property

ProductServiceConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► ProductServiceConditionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceConditionCode { get; set; }
Public Property ProductServiceConditionCode As String
    Get
    Set
public:
property String^ ProductServiceConditionCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


JIL Class

JIL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL
RDPCrystal EDI Library
Line Item Detail for the Operating Expense Statement
Declaration Syntax
C# Visual Basic Visual C++
public class JIL : DocumentSegment
Public Class JIL _
    Inherits DocumentSegment
public ref class JIL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JIL()()()() | Initializes a new instance of the JIL class
 | AmountQualifierCode | Element 7
 | Date | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | JIL


JIL Constructor

JIL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► JIL()()()()
RDPCrystal EDI Library
Initializes a new instance of the JIL class
Declaration Syntax
C# Visual Basic Visual C++
public JIL()
Public Sub New
public:
JIL()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► AmountQualifierCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


JIT Class

JIT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIT
RDPCrystal EDI Library
Just-In-Time Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class JIT : DocumentSegment
Public Class JIT _
    Inherits DocumentSegment
public ref class JIT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JIT()()()() | Initializes a new instance of the JIT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | Time | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | JIT


JIT Constructor

JIT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIT ► JIT()()()()
RDPCrystal EDI Library
Initializes a new instance of the JIT class
Declaration Syntax
C# Visual Basic Visual C++
public JIT()
Public Sub New
public:
JIT()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIT ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIT ► Time
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JIT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


JL Class

JL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL
RDPCrystal EDI Library
Journal Identification
Declaration Syntax
C# Visual Basic Visual C++
public class JL : DocumentSegment
Public Class JL _
    Inherits DocumentSegment
public ref class JL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JL()()()() | Initializes a new instance of the JL class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | JL


JL Constructor

JL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► JL()()()()
RDPCrystal EDI Library
Initializes a new instance of the JL class
Declaration Syntax
C# Visual Basic Visual C++
public JL()
Public Sub New
public:
JL()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


JS Class

JS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS
RDPCrystal EDI Library
Rail Junction Settlement Role Information
Declaration Syntax
C# Visual Basic Visual C++
public class JS : DocumentSegment
Public Class JS _
    Inherits DocumentSegment
public ref class JS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JS()()()() | Initializes a new instance of the JS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RailJunctionSettlementRoleCode | Element 2
 | RailJunctionSettlementRoleCode1 | Element 4
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | JS


JS Constructor

JS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► JS()()()()
RDPCrystal EDI Library
Initializes a new instance of the JS class
Declaration Syntax
C# Visual Basic Visual C++
public JS()
Public Sub New
public:
JS()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RailJunctionSettlementRoleCode Property

RailJunctionSettlementRoleCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► RailJunctionSettlementRoleCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RailJunctionSettlementRoleCode { get; set; }
Public Property RailJunctionSettlementRoleCode As String
    Get
    Set
public:
property String^ RailJunctionSettlementRoleCode {
    String^ get ();
    void set (String^ value);
}


RailJunctionSettlementRoleCode1 Property

RailJunctionSettlementRoleCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► RailJunctionSettlementRoleCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RailJunctionSettlementRoleCode1 { get; set; }
Public Property RailJunctionSettlementRoleCode1 As String
    Get
    Set
public:
property String^ RailJunctionSettlementRoleCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► JS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


K1 Class

K1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K1
RDPCrystal EDI Library
Remarks
Declaration Syntax
C# Visual Basic Visual C++
public class K1 : DocumentSegment
Public Class K1 _
    Inherits DocumentSegment
public ref class K1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | K1()()()() | Initializes a new instance of the K1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 1
 | FreeFormMessage1 | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | K1


K1 Constructor

K1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K1 ► K1()()()()
RDPCrystal EDI Library
Initializes a new instance of the K1 class
Declaration Syntax
C# Visual Basic Visual C++
public K1()
Public Sub New
public:
K1()


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K1 ► FreeFormMessage
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage1 Property

FreeFormMessage1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K1 ► FreeFormMessage1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage1 { get; set; }
Public Property FreeFormMessage1 As String
    Get
    Set
public:
property String^ FreeFormMessage1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


K2 Class

K2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K2
RDPCrystal EDI Library
Administrative Message
Declaration Syntax
C# Visual Basic Visual C++
public class K2 : DocumentSegment
Public Class K2 _
    Inherits DocumentSegment
public ref class K2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | K2()()()() | Initializes a new instance of the K2 class
 | Description | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | K2


K2 Constructor

K2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K2 ► K2()()()()
RDPCrystal EDI Library
Initializes a new instance of the K2 class
Declaration Syntax
C# Visual Basic Visual C++
public K2()
Public Sub New
public:
K2()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K2 ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


K3 Class

K3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3
RDPCrystal EDI Library
File Information
Declaration Syntax
C# Visual Basic Visual C++
public class K3 : DocumentSegment
Public Class K3 _
    Inherits DocumentSegment
public ref class K3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | K3()()()() | Initializes a new instance of the K3 class
 | CompositeUnitOfMeasure | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixedFormatInformation | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RecordFormatCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | K3


K3 Constructor

K3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3 ► K3()()()()
RDPCrystal EDI Library
Initializes a new instance of the K3 class
Declaration Syntax
C# Visual Basic Visual C++
public K3()
Public Sub New
public:
K3()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3 ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


FixedFormatInformation Property

FixedFormatInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3 ► FixedFormatInformation
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation { get; set; }
Public Property FixedFormatInformation As String
    Get
    Set
public:
property String^ FixedFormatInformation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RecordFormatCode Property

RecordFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3 ► RecordFormatCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RecordFormatCode { get; set; }
Public Property RecordFormatCode As String
    Get
    Set
public:
property String^ RecordFormatCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► K3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L0 Class

L0 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0
RDPCrystal EDI Library
Line Item - Quantity and Weight
Declaration Syntax
C# Visual Basic Visual C++
public class L0 : DocumentSegment
Public Class L0 _
    Inherits DocumentSegment
public ref class L0 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L0()()()() | Initializes a new instance of the L0 class
 | BilledRatedasQualifier | Element 3
 | BilledRatedasQuantity | Element 2
 | DunnageDescription | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingLineItemNumber | Element 1
 | LadingQuantity | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingFormCode | Element 9
 | PackagingFormCode1 | Element 14
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceCode | Element 12
 | Volume | Element 6
 | VolumeUnitQualifier | Element 7
 | Weight | Element 4
 | WeightQualifier | Element 5
 | WeightUnitCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 15
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L0


L0 Constructor

L0 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► L0()()()()
RDPCrystal EDI Library
Initializes a new instance of the L0 class
Declaration Syntax
C# Visual Basic Visual C++
public L0()
Public Sub New
public:
L0()


BilledRatedasQualifier Property

BilledRatedasQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► BilledRatedasQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQualifier { get; set; }
Public Property BilledRatedasQualifier As String
    Get
    Set
public:
property String^ BilledRatedasQualifier {
    String^ get ();
    void set (String^ value);
}


BilledRatedasQuantity Property

BilledRatedasQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► BilledRatedasQuantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQuantity { get; set; }
Public Property BilledRatedasQuantity As String
    Get
    Set
public:
property String^ BilledRatedasQuantity {
    String^ get ();
    void set (String^ value);
}


DunnageDescription Property

DunnageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► DunnageDescription
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DunnageDescription { get; set; }
Public Property DunnageDescription As String
    Get
    Set
public:
property String^ DunnageDescription {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► LadingQuantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► PackagingFormCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


PackagingFormCode1 Property

PackagingFormCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► PackagingFormCode1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode1 { get; set; }
Public Property PackagingFormCode1 As String
    Get
    Set
public:
property String^ PackagingFormCode1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► Quantity
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► TypeOfServiceCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► Volume
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► WeightQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► WeightUnitCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L0 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


L1 Class

L1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1
RDPCrystal EDI Library
Rate and Charges
Declaration Syntax
C# Visual Basic Visual C++
public class L1 : DocumentSegment
Public Class L1 _
    Inherits DocumentSegment
public ref class L1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L1()()()() | Initializes a new instance of the L1 class
 | Advances | Element 5
 | Amount | Element 21
 | BilledRatedasQualifier | Element 18
 | BilledRatedasQuantity | Element 17
 | Charge | Element 4
 | ChargeMethodOfPayment | Element 11
 | CurrencyCode | Element 20
 | DeclaredValue | Element 14
 | EntitlementCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingLiabilityCode | Element 16
 | LadingLineItemNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 19
 | PrepaidAmount | Element 6
 | RateClassCode | Element 9
 | RateCombinationPointCode | Element 7
 | RateValueQualifier | Element 3
 | RateValueQualifier1 | Element 15
 | SpecialChargeDescription | Element 12
 | SpecialChargeOrAllowanceCode | Element 8
 | TariffApplicationCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L1


L1 Constructor

L1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► L1()()()()
RDPCrystal EDI Library
Initializes a new instance of the L1 class
Declaration Syntax
C# Visual Basic Visual C++
public L1()
Public Sub New
public:
L1()


Advances Property

Advances Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► Advances
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Advances { get; set; }
Public Property Advances As String
    Get
    Set
public:
property String^ Advances {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► Amount
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


BilledRatedasQualifier Property

BilledRatedasQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► BilledRatedasQualifier
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQualifier { get; set; }
Public Property BilledRatedasQualifier As String
    Get
    Set
public:
property String^ BilledRatedasQualifier {
    String^ get ();
    void set (String^ value);
}


BilledRatedasQuantity Property

BilledRatedasQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► BilledRatedasQuantity
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQuantity { get; set; }
Public Property BilledRatedasQuantity As String
    Get
    Set
public:
property String^ BilledRatedasQuantity {
    String^ get ();
    void set (String^ value);
}


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► Charge
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


ChargeMethodOfPayment Property

ChargeMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► ChargeMethodOfPayment
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ChargeMethodOfPayment { get; set; }
Public Property ChargeMethodOfPayment As String
    Get
    Set
public:
property String^ ChargeMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► CurrencyCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


DeclaredValue Property

DeclaredValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► DeclaredValue
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DeclaredValue { get; set; }
Public Property DeclaredValue As String
    Get
    Set
public:
property String^ DeclaredValue {
    String^ get ();
    void set (String^ value);
}


EntitlementCode Property

EntitlementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► EntitlementCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EntitlementCode { get; set; }
Public Property EntitlementCode As String
    Get
    Set
public:
property String^ EntitlementCode {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► FreightRate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


LadingLiabilityCode Property

LadingLiabilityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► LadingLiabilityCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLiabilityCode { get; set; }
Public Property LadingLiabilityCode As String
    Get
    Set
public:
property String^ LadingLiabilityCode {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► Percent
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PrepaidAmount Property

PrepaidAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► PrepaidAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PrepaidAmount { get; set; }
Public Property PrepaidAmount As String
    Get
    Set
public:
property String^ PrepaidAmount {
    String^ get ();
    void set (String^ value);
}


RateClassCode Property

RateClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► RateClassCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RateClassCode { get; set; }
Public Property RateClassCode As String
    Get
    Set
public:
property String^ RateClassCode {
    String^ get ();
    void set (String^ value);
}


RateCombinationPointCode Property

RateCombinationPointCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► RateCombinationPointCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RateCombinationPointCode { get; set; }
Public Property RateCombinationPointCode As String
    Get
    Set
public:
property String^ RateCombinationPointCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► RateValueQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► RateValueQualifier1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


SpecialChargeDescription Property

SpecialChargeDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► SpecialChargeDescription
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeDescription { get; set; }
Public Property SpecialChargeDescription As String
    Get
    Set
public:
property String^ SpecialChargeDescription {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode Property

TariffApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► TariffApplicationCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode { get; set; }
Public Property TariffApplicationCode As String
    Get
    Set
public:
property String^ TariffApplicationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L10 Class

L10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10
RDPCrystal EDI Library
Weight
Declaration Syntax
C# Visual Basic Visual C++
public class L10 : DocumentSegment
Public Class L10 _
    Inherits DocumentSegment
public ref class L10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L10()()()() | Initializes a new instance of the L10 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 1
 | WeightQualifier | Element 2
 | WeightUnitCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L10


L10 Constructor

L10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10 ► L10()()()()
RDPCrystal EDI Library
Initializes a new instance of the L10 class
Declaration Syntax
C# Visual Basic Visual C++
public L10()
Public Sub New
public:
L10()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10 ► Weight
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10 ► WeightQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10 ► WeightUnitCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L11 Class

L11 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11
RDPCrystal EDI Library
Business Instructions and Reference Number
Declaration Syntax
C# Visual Basic Visual C++
public class L11 : DocumentSegment
Public Class L11 _
    Inherits DocumentSegment
public ref class L11 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L11()()()() | Initializes a new instance of the L11 class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentificationQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L11


L11 Constructor

L11 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11 ► L11()()()()
RDPCrystal EDI Library
Initializes a new instance of the L11 class
Declaration Syntax
C# Visual Basic Visual C++
public L11()
Public Sub New
public:
L11()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11 ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L11 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L12 Class

L12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L12
RDPCrystal EDI Library
Alternate Lading Description
Declaration Syntax
C# Visual Basic Visual C++
public class L12 : DocumentSegment
Public Class L12 _
    Inherits DocumentSegment
public ref class L12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L12()()()() | Initializes a new instance of the L12 class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescriptionQualifier | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L12


L12 Constructor

L12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L12 ► L12()()()()
RDPCrystal EDI Library
Initializes a new instance of the L12 class
Declaration Syntax
C# Visual Basic Visual C++
public L12()
Public Sub New
public:
L12()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L12 ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


LadingDescriptionQualifier Property

LadingDescriptionQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L12 ► LadingDescriptionQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescriptionQualifier { get; set; }
Public Property LadingDescriptionQualifier As String
    Get
    Set
public:
property String^ LadingDescriptionQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L13 Class

L13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13
RDPCrystal EDI Library
Commodity Details
Declaration Syntax
C# Visual Basic Visual C++
public class L13 : DocumentSegment
Public Class L13 _
    Inherits DocumentSegment
public ref class L13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L13()()()() | Initializes a new instance of the L13 class
 | ActionCode | Element 14
 | Amount | Element 16
 | AmountQualifierCode | Element 5
 | AssignedNumber | Element 7
 | CommodityCode | Element 2
 | CommodityCodeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportExceptionCode | Element 13
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 12
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HMFExemptionCode | Element 15
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 8
 | Weight | Element 11
 | WeightUnitCode | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L13


L13 Constructor

L13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► L13()()()()
RDPCrystal EDI Library
Initializes a new instance of the L13 class
Declaration Syntax
C# Visual Basic Visual C++
public L13()
Public Sub New
public:
L13()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► ActionCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► Amount
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► AmountQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► AssignedNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► CommodityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


ExportExceptionCode Property

ExportExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► ExportExceptionCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ExportExceptionCode { get; set; }
Public Property ExportExceptionCode As String
    Get
    Set
public:
property String^ ExportExceptionCode {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► FreeformDescription
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


HMFExemptionCode Property

HMFExemptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► HMFExemptionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string HMFExemptionCode { get; set; }
Public Property HMFExemptionCode As String
    Get
    Set
public:
property String^ HMFExemptionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► MonetaryAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► Quantity1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► Weight
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► WeightUnitCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L1A Class

L1A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1A
RDPCrystal EDI Library
Billing Identification
Declaration Syntax
C# Visual Basic Visual C++
public class L1A : DocumentSegment
Public Class L1A _
    Inherits DocumentSegment
public ref class L1A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L1A()()()() | Initializes a new instance of the L1A class
 | Amount | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L1A


L1A Constructor

L1A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1A ► L1A()()()()
RDPCrystal EDI Library
Initializes a new instance of the L1A class
Declaration Syntax
C# Visual Basic Visual C++
public L1A()
Public Sub New
public:
L1A()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1A ► Amount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1A ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L1A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L3 Class

L3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3
RDPCrystal EDI Library
Total Weight and Charges
Declaration Syntax
C# Visual Basic Visual C++
public class L3 : DocumentSegment
Public Class L3 _
    Inherits DocumentSegment
public ref class L3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L3()()()() | Initializes a new instance of the L3 class
 | Advances | Element 6
 | Charge | Element 5
 | DeclaredValue | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrepaidAmount | Element 7
 | RateValueQualifier | Element 4
 | RateValueQualifier1 | Element 15
 | SpecialChargeOrAllowanceCode | Element 8
 | TariffNumber | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 9
 | VolumeUnitQualifier | Element 10
 | Weight | Element 1
 | WeightQualifier | Element 2
 | WeightUnitCode | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L3


L3 Constructor

L3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► L3()()()()
RDPCrystal EDI Library
Initializes a new instance of the L3 class
Declaration Syntax
C# Visual Basic Visual C++
public L3()
Public Sub New
public:
L3()


Advances Property

Advances Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► Advances
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Advances { get; set; }
Public Property Advances As String
    Get
    Set
public:
property String^ Advances {
    String^ get ();
    void set (String^ value);
}


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► Charge
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


DeclaredValue Property

DeclaredValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► DeclaredValue
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DeclaredValue { get; set; }
Public Property DeclaredValue As String
    Get
    Set
public:
property String^ DeclaredValue {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► LadingQuantity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrepaidAmount Property

PrepaidAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► PrepaidAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PrepaidAmount { get; set; }
Public Property PrepaidAmount As String
    Get
    Set
public:
property String^ PrepaidAmount {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► RateValueQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► RateValueQualifier1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


TariffNumber Property

TariffNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► TariffNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumber { get; set; }
Public Property TariffNumber As String
    Get
    Set
public:
property String^ TariffNumber {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► Volume
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► Weight
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► WeightQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► WeightUnitCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L4 Class

L4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4
RDPCrystal EDI Library
Measurement
Declaration Syntax
C# Visual Basic Visual C++
public class L4 : DocumentSegment
Public Class L4 _
    Inherits DocumentSegment
public ref class L4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L4()()()() | Initializes a new instance of the L4 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 3
 | IndustryCode | Element 6
 | Length | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementUnitQualifier | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Width | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L4


L4 Constructor

L4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► L4()()()()
RDPCrystal EDI Library
Initializes a new instance of the L4 class
Declaration Syntax
C# Visual Basic Visual C++
public L4()
Public Sub New
public:
L4()


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► Height
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► IndustryCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► Length
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementUnitQualifier Property

MeasurementUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► MeasurementUnitQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementUnitQualifier { get; set; }
Public Property MeasurementUnitQualifier As String
    Get
    Set
public:
property String^ MeasurementUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► Width
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L5 Class

L5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5
RDPCrystal EDI Library
Description, Marks and Numbers
Declaration Syntax
C# Visual Basic Visual C++
public class L5 : DocumentSegment
Public Class L5 _
    Inherits DocumentSegment
public ref class L5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L5()()()() | Initializes a new instance of the L5 class
 | CommodityCode | Element 3
 | CommodityCode1 | Element 9
 | CommodityCodeQualifier | Element 4
 | CommodityCodeQualifier1 | Element 8
 | CompartmentIDCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 2
 | LadingLineItemNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarksAndNumbers | Element 6
 | MarksAndNumbersQualifier | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingCode | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L5


L5 Constructor

L5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► L5()()()()
RDPCrystal EDI Library
Initializes a new instance of the L5 class
Declaration Syntax
C# Visual Basic Visual C++
public L5()
Public Sub New
public:
L5()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCode1 Property

CommodityCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► CommodityCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode1 { get; set; }
Public Property CommodityCode1 As String
    Get
    Set
public:
property String^ CommodityCode1 {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier1 Property

CommodityCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► CommodityCodeQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier1 { get; set; }
Public Property CommodityCodeQualifier1 As String
    Get
    Set
public:
property String^ CommodityCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


CompartmentIDCode Property

CompartmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► CompartmentIDCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CompartmentIDCode { get; set; }
Public Property CompartmentIDCode As String
    Get
    Set
public:
property String^ CompartmentIDCode {
    String^ get ();
    void set (String^ value);
}


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► LadingDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarksAndNumbers Property

MarksAndNumbers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► MarksAndNumbers
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbers { get; set; }
Public Property MarksAndNumbers As String
    Get
    Set
public:
property String^ MarksAndNumbers {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbersQualifier Property

MarksAndNumbersQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► MarksAndNumbersQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbersQualifier { get; set; }
Public Property MarksAndNumbersQualifier As String
    Get
    Set
public:
property String^ MarksAndNumbersQualifier {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► PackagingCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L7 Class

L7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7
RDPCrystal EDI Library
Tariff Reference
Declaration Syntax
C# Visual Basic Visual C++
public class L7 : DocumentSegment
Public Class L7 _
    Inherits DocumentSegment
public ref class L7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L7()()()() | Initializes a new instance of the L7 class
 | CityName | Element 15
 | Date | Element 10
 | DistanceQualifier | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExParte | Element 9
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightClassCode | Element 7
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingLineItemNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateBasisNumber | Element 11
 | StateOrProvinceCode | Element 16
 | TariffAgencyCode | Element 2
 | TariffColumn | Element 12
 | TariffDistance | Element 13
 | TariffItemNumber | Element 5
 | TariffItemPart | Element 6
 | TariffNumber | Element 3
 | TariffSection | Element 4
 | TariffSupplementIdentifier | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L7


L7 Constructor

L7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► L7()()()()
RDPCrystal EDI Library
Initializes a new instance of the L7 class
Declaration Syntax
C# Visual Basic Visual C++
public L7()
Public Sub New
public:
L7()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► CityName
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► Date
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DistanceQualifier Property

DistanceQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► DistanceQualifier
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DistanceQualifier { get; set; }
Public Property DistanceQualifier As String
    Get
    Set
public:
property String^ DistanceQualifier {
    String^ get ();
    void set (String^ value);
}


ExParte Property

ExParte Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► ExParte
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ExParte { get; set; }
Public Property ExParte As String
    Get
    Set
public:
property String^ ExParte {
    String^ get ();
    void set (String^ value);
}


FreightClassCode Property

FreightClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► FreightClassCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FreightClassCode { get; set; }
Public Property FreightClassCode As String
    Get
    Set
public:
property String^ FreightClassCode {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateBasisNumber Property

RateBasisNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► RateBasisNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string RateBasisNumber { get; set; }
Public Property RateBasisNumber As String
    Get
    Set
public:
property String^ RateBasisNumber {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TariffAgencyCode Property

TariffAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffAgencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAgencyCode { get; set; }
Public Property TariffAgencyCode As String
    Get
    Set
public:
property String^ TariffAgencyCode {
    String^ get ();
    void set (String^ value);
}


TariffColumn Property

TariffColumn Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffColumn
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TariffColumn { get; set; }
Public Property TariffColumn As String
    Get
    Set
public:
property String^ TariffColumn {
    String^ get ();
    void set (String^ value);
}


TariffDistance Property

TariffDistance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffDistance
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TariffDistance { get; set; }
Public Property TariffDistance As String
    Get
    Set
public:
property String^ TariffDistance {
    String^ get ();
    void set (String^ value);
}


TariffItemNumber Property

TariffItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffItemNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemNumber { get; set; }
Public Property TariffItemNumber As String
    Get
    Set
public:
property String^ TariffItemNumber {
    String^ get ();
    void set (String^ value);
}


TariffItemPart Property

TariffItemPart Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffItemPart
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemPart { get; set; }
Public Property TariffItemPart As String
    Get
    Set
public:
property String^ TariffItemPart {
    String^ get ();
    void set (String^ value);
}


TariffNumber Property

TariffNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumber { get; set; }
Public Property TariffNumber As String
    Get
    Set
public:
property String^ TariffNumber {
    String^ get ();
    void set (String^ value);
}


TariffSection Property

TariffSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffSection
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSection { get; set; }
Public Property TariffSection As String
    Get
    Set
public:
property String^ TariffSection {
    String^ get ();
    void set (String^ value);
}


TariffSupplementIdentifier Property

TariffSupplementIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► TariffSupplementIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSupplementIdentifier { get; set; }
Public Property TariffSupplementIdentifier As String
    Get
    Set
public:
property String^ TariffSupplementIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L7A Class

L7A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A
RDPCrystal EDI Library
Contract Reference Identifier
Declaration Syntax
C# Visual Basic Visual C++
public class L7A : DocumentSegment
Public Class L7A _
    Inherits DocumentSegment
public ref class L7A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L7A()()()() | Initializes a new instance of the L7A class
 | ContractNumber | Element 5
 | ContractSuffix | Element 6
 | Date | Element 7
 | Date1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IssuingCarrierIdentifier | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentificationQualifier | Element 1
 | RegulatoryAgencyCode | Element 2
 | StandardCarrierAlphaCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L7A


L7A Constructor

L7A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► L7A()()()()
RDPCrystal EDI Library
Initializes a new instance of the L7A class
Declaration Syntax
C# Visual Basic Visual C++
public L7A()
Public Sub New
public:
L7A()


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► ContractNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


ContractSuffix Property

ContractSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► ContractSuffix
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractSuffix { get; set; }
Public Property ContractSuffix As String
    Get
    Set
public:
property String^ ContractSuffix {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


IssuingCarrierIdentifier Property

IssuingCarrierIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► IssuingCarrierIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IssuingCarrierIdentifier { get; set; }
Public Property IssuingCarrierIdentifier As String
    Get
    Set
public:
property String^ IssuingCarrierIdentifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


RegulatoryAgencyCode Property

RegulatoryAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► RegulatoryAgencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RegulatoryAgencyCode { get; set; }
Public Property RegulatoryAgencyCode As String
    Get
    Set
public:
property String^ RegulatoryAgencyCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L7A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L8 Class

L8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8
RDPCrystal EDI Library
Line Item Subtotal
Declaration Syntax
C# Visual Basic Visual C++
public class L8 : DocumentSegment
Public Class L8 _
    Inherits DocumentSegment
public ref class L8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L8()()()() | Initializes a new instance of the L8 class
 | Amount | Element 8
 | BilledRatedasQualifier | Element 2
 | BilledRatedasQuantity | Element 1
 | ChargeMethodOfPayment | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 7
 | SpecialChargeDescription | Element 10
 | SpecialChargeOrAllowanceCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 3
 | WeightQualifier | Element 5
 | WeightUnitCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L8


L8 Constructor

L8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► L8()()()()
RDPCrystal EDI Library
Initializes a new instance of the L8 class
Declaration Syntax
C# Visual Basic Visual C++
public L8()
Public Sub New
public:
L8()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► Amount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


BilledRatedasQualifier Property

BilledRatedasQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► BilledRatedasQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQualifier { get; set; }
Public Property BilledRatedasQualifier As String
    Get
    Set
public:
property String^ BilledRatedasQualifier {
    String^ get ();
    void set (String^ value);
}


BilledRatedasQuantity Property

BilledRatedasQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► BilledRatedasQuantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BilledRatedasQuantity { get; set; }
Public Property BilledRatedasQuantity As String
    Get
    Set
public:
property String^ BilledRatedasQuantity {
    String^ get ();
    void set (String^ value);
}


ChargeMethodOfPayment Property

ChargeMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► ChargeMethodOfPayment
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ChargeMethodOfPayment { get; set; }
Public Property ChargeMethodOfPayment As String
    Get
    Set
public:
property String^ ChargeMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► FreightRate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► RateValueQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


SpecialChargeDescription Property

SpecialChargeDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► SpecialChargeDescription
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeDescription { get; set; }
Public Property SpecialChargeDescription As String
    Get
    Set
public:
property String^ SpecialChargeDescription {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► WeightQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► WeightUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


L9 Class

L9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L9
RDPCrystal EDI Library
Charge Detail
Declaration Syntax
C# Visual Basic Visual C++
public class L9 : DocumentSegment
Public Class L9 _
    Inherits DocumentSegment
public ref class L9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | L9()()()() | Initializes a new instance of the L9 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialChargeOrAllowanceCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | L9


L9 Constructor

L9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L9 ► L9()()()()
RDPCrystal EDI Library
Initializes a new instance of the L9 class
Declaration Syntax
C# Visual Basic Visual C++
public L9()
Public Sub New
public:
L9()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L9 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L9 ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► L9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LAD Class

LAD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD
RDPCrystal EDI Library
Lading Detail
Declaration Syntax
C# Visual Basic Visual C++
public class LAD : DocumentSegment
Public Class LAD _
    Inherits DocumentSegment
public ref class LAD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LAD()()()() | Initializes a new instance of the LAD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 13
 | LadingQuantity | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingFormCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 8
 | ProductServiceID1 | Element 10
 | ProductServiceID2 | Element 12
 | ProductServiceIDQualifier | Element 7
 | ProductServiceIDQualifier1 | Element 9
 | ProductServiceIDQualifier2 | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitWeight | Element 4
 | Weight | Element 6
 | WeightUnitCode | Element 3
 | WeightUnitCode1 | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LAD


LAD Constructor

LAD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► LAD()()()()
RDPCrystal EDI Library
Initializes a new instance of the LAD class
Declaration Syntax
C# Visual Basic Visual C++
public LAD()
Public Sub New
public:
LAD()


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► LadingDescription
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► LadingQuantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► PackagingFormCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► ProductServiceID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► ProductServiceID1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► ProductServiceID2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


UnitWeight Property

UnitWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► UnitWeight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight { get; set; }
Public Property UnitWeight As String
    Get
    Set
public:
property String^ UnitWeight {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► Weight
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► WeightUnitCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode1 Property

WeightUnitCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► WeightUnitCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode1 { get; set; }
Public Property WeightUnitCode1 As String
    Get
    Set
public:
property String^ WeightUnitCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LAD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LC Class

LC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC
RDPCrystal EDI Library
Life Coverage
Declaration Syntax
C# Visual Basic Visual C++
public class LC : DocumentSegment
Public Class LC _
    Inherits DocumentSegment
public ref class LC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LC()()()() | Initializes a new instance of the LC class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceLineCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 2
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription | Element 4
 | ProductOptionCode | Element 6
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LC


LC Constructor

LC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► LC()()()()
RDPCrystal EDI Library
Initializes a new instance of the LC class
Declaration Syntax
C# Visual Basic Visual C++
public LC()
Public Sub New
public:
LC()


InsuranceLineCode Property

InsuranceLineCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► InsuranceLineCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceLineCode { get; set; }
Public Property InsuranceLineCode As String
    Get
    Set
public:
property String^ InsuranceLineCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► PlanCoverageDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}


ProductOptionCode Property

ProductOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► ProductOptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode { get; set; }
Public Property ProductOptionCode As String
    Get
    Set
public:
property String^ ProductOptionCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LC1 Class

LC1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1
RDPCrystal EDI Library
Lane Commitments
Declaration Syntax
C# Visual Basic Visual C++
public class LC1 : DocumentSegment
Public Class LC1 _
    Inherits DocumentSegment
public ref class LC1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LC1()()()() | Initializes a new instance of the LC1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 9
 | FreightRate1 | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LaneRanking | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 3
 | NumberOfShipments | Element 1
 | NumberOfShipments1 | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 11
 | StandardCarrierAlphaCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 4
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
 | YesNoConditionOrResponseCode1 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LC1


LC1 Constructor

LC1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► LC1()()()()
RDPCrystal EDI Library
Initializes a new instance of the LC1 class
Declaration Syntax
C# Visual Basic Visual C++
public LC1()
Public Sub New
public:
LC1()


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► FreightRate
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRate1 Property

FreightRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► FreightRate1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate1 { get; set; }
Public Property FreightRate1 As String
    Get
    Set
public:
property String^ FreightRate1 {
    String^ get ();
    void set (String^ value);
}


LaneRanking Property

LaneRanking Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► LaneRanking
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LaneRanking { get; set; }
Public Property LaneRanking As String
    Get
    Set
public:
property String^ LaneRanking {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► Number
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


NumberOfShipments Property

NumberOfShipments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► NumberOfShipments
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfShipments { get; set; }
Public Property NumberOfShipments As String
    Get
    Set
public:
property String^ NumberOfShipments {
    String^ get ();
    void set (String^ value);
}


NumberOfShipments1 Property

NumberOfShipments1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► NumberOfShipments1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfShipments1 { get; set; }
Public Property NumberOfShipments1 As String
    Get
    Set
public:
property String^ NumberOfShipments1 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► RateValueQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LC1 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


LCD Class

LCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD
RDPCrystal EDI Library
Place/Location Description
Declaration Syntax
C# Visual Basic Visual C++
public class LCD : DocumentSegment
Public Class LCD _
    Inherits DocumentSegment
public ref class LCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LCD()()()() | Initializes a new instance of the LCD class
 | ActionCode | Element 3
 | AssignedIdentification | Element 1
 | Date | Element 4
 | EntityIdentifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 6
 | IdentificationCodeQualifier | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LCD


LCD Constructor

LCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► LCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the LCD class
Declaration Syntax
C# Visual Basic Visual C++
public LCD()
Public Sub New
public:
LCD()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► ActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► EntityIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► IdentificationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LCT Class

LCT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT
RDPCrystal EDI Library
Logistics Container Tracking Information
Declaration Syntax
C# Visual Basic Visual C++
public class LCT : DocumentSegment
Public Class LCT _
    Inherits DocumentSegment
public ref class LCT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LCT()()()() | Initializes a new instance of the LCT class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 9
 | Length | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementUnitQualifier | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingFormCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletExchangeCode | Element 12
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitWeight | Element 5
 | Volume | Element 11
 | VolumeUnitQualifier | Element 10
 | WeightUnitCode | Element 4
 | Width | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LCT


LCT Constructor

LCT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► LCT()()()()
RDPCrystal EDI Library
Initializes a new instance of the LCT class
Declaration Syntax
C# Visual Basic Visual C++
public LCT()
Public Sub New
public:
LCT()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Height
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Length
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementUnitQualifier Property

MeasurementUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► MeasurementUnitQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementUnitQualifier { get; set; }
Public Property MeasurementUnitQualifier As String
    Get
    Set
public:
property String^ MeasurementUnitQualifier {
    String^ get ();
    void set (String^ value);
}


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► PackagingFormCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► PalletExchangeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


UnitWeight Property

UnitWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► UnitWeight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight { get; set; }
Public Property UnitWeight As String
    Get
    Set
public:
property String^ UnitWeight {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Volume
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► WeightUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Width
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LCT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LDT Class

LDT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT
RDPCrystal EDI Library
Lead Time
Declaration Syntax
C# Visual Basic Visual C++
public class LDT : DocumentSegment
Public Class LDT _
    Inherits DocumentSegment
public ref class LDT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LDT()()()() | Initializes a new instance of the LDT class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LeadTimeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LDT


LDT Constructor

LDT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► LDT()()()()
RDPCrystal EDI Library
Initializes a new instance of the LDT class
Declaration Syntax
C# Visual Basic Visual C++
public LDT()
Public Sub New
public:
LDT()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


LeadTimeCode Property

LeadTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► LeadTimeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LeadTimeCode { get; set; }
Public Property LeadTimeCode As String
    Get
    Set
public:
property String^ LeadTimeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LDT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LE Class

LE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LE
RDPCrystal EDI Library
Loop Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class LE : DocumentSegment
Public Class LE _
    Inherits DocumentSegment
public ref class LE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LE()()()() | Initializes a new instance of the LE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LE


LE Constructor

LE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LE ► LE()()()()
RDPCrystal EDI Library
Initializes a new instance of the LE class
Declaration Syntax
C# Visual Basic Visual C++
public LE()
Public Sub New
public:
LE()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LE ► LoopIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LEP Class

LEP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP
RDPCrystal EDI Library
EPA Required Data
Declaration Syntax
C# Visual Basic Visual C++
public class LEP : DocumentSegment
Public Class LEP _
    Inherits DocumentSegment
public ref class LEP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LEP()()()() | Initializes a new instance of the LEP class
 | EPAWasteStreamNumberCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WasteCharacteristicsCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LEP


LEP Constructor

LEP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► LEP()()()()
RDPCrystal EDI Library
Initializes a new instance of the LEP class
Declaration Syntax
C# Visual Basic Visual C++
public LEP()
Public Sub New
public:
LEP()


EPAWasteStreamNumberCode Property

EPAWasteStreamNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► EPAWasteStreamNumberCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EPAWasteStreamNumberCode { get; set; }
Public Property EPAWasteStreamNumberCode As String
    Get
    Set
public:
property String^ EPAWasteStreamNumberCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


WasteCharacteristicsCode Property

WasteCharacteristicsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► WasteCharacteristicsCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WasteCharacteristicsCode { get; set; }
Public Property WasteCharacteristicsCode As String
    Get
    Set
public:
property String^ WasteCharacteristicsCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LEQ Class

LEQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ
RDPCrystal EDI Library
Leased Equipment Information
Declaration Syntax
C# Visual Basic Visual C++
public class LEQ : DocumentSegment
Public Class LEQ _
    Inherits DocumentSegment
public ref class LEQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LEQ()()()() | Initializes a new instance of the LEQ class
 | Date | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExchangeRate | Element 9
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | MonthOfTheYearCode | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 6
 | ReferenceIdentificationQualifier | Element 1
 | StandardCarrierAlphaCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | Year | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LEQ


LEQ Constructor

LEQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► LEQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the LEQ class
Declaration Syntax
C# Visual Basic Visual C++
public LEQ()
Public Sub New
public:
LEQ()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


ExchangeRate Property

ExchangeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► ExchangeRate
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ExchangeRate { get; set; }
Public Property ExchangeRate As String
    Get
    Set
public:
property String^ ExchangeRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonthOfTheYearCode Property

MonthOfTheYearCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► MonthOfTheYearCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonthOfTheYearCode { get; set; }
Public Property MonthOfTheYearCode As String
    Get
    Set
public:
property String^ MonthOfTheYearCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Year Property

Year Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LEQ ► Year
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Year { get; set; }
Public Property Year As String
    Get
    Set
public:
property String^ Year {
    String^ get ();
    void set (String^ value);
}


LET Class

LET Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET
RDPCrystal EDI Library
Load and Equipment Type
Declaration Syntax
C# Visual Basic Visual C++
public class LET : DocumentSegment
Public Class LET _
    Inherits DocumentSegment
public ref class LET : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LET()()()() | Initializes a new instance of the LET class
 | CarTypeCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShapeCode | Element 3
 | SurfaceLayerPositionCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LET


LET Constructor

LET Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► LET()()()()
RDPCrystal EDI Library
Initializes a new instance of the LET class
Declaration Syntax
C# Visual Basic Visual C++
public LET()
Public Sub New
public:
LET()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► CarTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShapeCode Property

ShapeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► ShapeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShapeCode { get; set; }
Public Property ShapeCode As String
    Get
    Set
public:
property String^ ShapeCode {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LET ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LFG Class

LFG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG
RDPCrystal EDI Library
Hazardous Information, Finished Goods
Declaration Syntax
C# Visual Basic Visual C++
public class LFG : DocumentSegment
Public Class LFG _
    Inherits DocumentSegment
public ref class LFG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LFG()()()() | Initializes a new instance of the LFG class
 | Description | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousClassification | Element 2
 | HazardousMaterialRegulationsExceptionCode | Element 6
 | HazardousPlacardNotation | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackingGroupCode | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UNNAIdentificationCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LFG


LFG Constructor

LFG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► LFG()()()()
RDPCrystal EDI Library
Initializes a new instance of the LFG class
Declaration Syntax
C# Visual Basic Visual C++
public LFG()
Public Sub New
public:
LFG()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


HazardousClassification Property

HazardousClassification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► HazardousClassification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousClassification { get; set; }
Public Property HazardousClassification As String
    Get
    Set
public:
property String^ HazardousClassification {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialRegulationsExceptionCode Property

HazardousMaterialRegulationsExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► HazardousMaterialRegulationsExceptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialRegulationsExceptionCode { get; set; }
Public Property HazardousMaterialRegulationsExceptionCode As String
    Get
    Set
public:
property String^ HazardousMaterialRegulationsExceptionCode {
    String^ get ();
    void set (String^ value);
}


HazardousPlacardNotation Property

HazardousPlacardNotation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► HazardousPlacardNotation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousPlacardNotation { get; set; }
Public Property HazardousPlacardNotation As String
    Get
    Set
public:
property String^ HazardousPlacardNotation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackingGroupCode Property

PackingGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► PackingGroupCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PackingGroupCode { get; set; }
Public Property PackingGroupCode As String
    Get
    Set
public:
property String^ PackingGroupCode {
    String^ get ();
    void set (String^ value);
}


UNNAIdentificationCode Property

UNNAIdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► UNNAIdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UNNAIdentificationCode { get; set; }
Public Property UNNAIdentificationCode As String
    Get
    Set
public:
property String^ UNNAIdentificationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LFH Class

LFH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH
RDPCrystal EDI Library
Freeform Hazardous Material Information
Declaration Syntax
C# Visual Basic Visual C++
public class LFH : DocumentSegment
Public Class LFH _
    Inherits DocumentSegment
public ref class LFH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LFH()()()() | Initializes a new instance of the LFH class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialShipmentInformation | Element 2
 | HazardousMaterialShipmentInformation1 | Element 3
 | HazardousMaterialShipmentInformationQualifier | Element 1
 | HazardZoneCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | Quantity1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LFH


LFH Constructor

LFH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► LFH()()()()
RDPCrystal EDI Library
Initializes a new instance of the LFH class
Declaration Syntax
C# Visual Basic Visual C++
public LFH()
Public Sub New
public:
LFH()


HazardousMaterialShipmentInformation Property

HazardousMaterialShipmentInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► HazardousMaterialShipmentInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialShipmentInformation { get; set; }
Public Property HazardousMaterialShipmentInformation As String
    Get
    Set
public:
property String^ HazardousMaterialShipmentInformation {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialShipmentInformation1 Property

HazardousMaterialShipmentInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► HazardousMaterialShipmentInformation1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialShipmentInformation1 { get; set; }
Public Property HazardousMaterialShipmentInformation1 As String
    Get
    Set
public:
property String^ HazardousMaterialShipmentInformation1 {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialShipmentInformationQualifier Property

HazardousMaterialShipmentInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► HazardousMaterialShipmentInformationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialShipmentInformationQualifier { get; set; }
Public Property HazardousMaterialShipmentInformationQualifier As String
    Get
    Set
public:
property String^ HazardousMaterialShipmentInformationQualifier {
    String^ get ();
    void set (String^ value);
}


HazardZoneCode Property

HazardZoneCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► HazardZoneCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HazardZoneCode { get; set; }
Public Property HazardZoneCode As String
    Get
    Set
public:
property String^ HazardZoneCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LFI Class

LFI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI
RDPCrystal EDI Library
Beginning Segment for Locomotive Information
Declaration Syntax
C# Visual Basic Visual C++
public class LFI : DocumentSegment
Public Class LFI _
    Inherits DocumentSegment
public ref class LFI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LFI()()()() | Initializes a new instance of the LFI class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentStatusCode | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 5
 | IndustryCode1 | Element 6
 | IndustryCode2 | Element 7
 | InterchangeTrainIdentification | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardPointLocationCode | Element 1
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LFI


LFI Constructor

LFI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► LFI()()()()
RDPCrystal EDI Library
Initializes a new instance of the LFI class
Declaration Syntax
C# Visual Basic Visual C++
public LFI()
Public Sub New
public:
LFI()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentStatusCode Property

EquipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► EquipmentStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode { get; set; }
Public Property EquipmentStatusCode As String
    Get
    Set
public:
property String^ EquipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► IndustryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► IndustryCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► IndustryCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}


InterchangeTrainIdentification Property

InterchangeTrainIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► InterchangeTrainIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTrainIdentification { get; set; }
Public Property InterchangeTrainIdentification As String
    Get
    Set
public:
property String^ InterchangeTrainIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► StandardPointLocationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LFI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LH Class

LH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH
RDPCrystal EDI Library
Mixed Hazardous Commodities
Declaration Syntax
C# Visual Basic Visual C++
public class LH : DocumentSegment
Public Class LH _
    Inherits DocumentSegment
public ref class LH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LH()()()() | Initializes a new instance of the LH class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMnemonicCode | Element 2
 | LadingLineItemNumber | Element 1
 | LimitedQuantityIndicationCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 4
 | ReportableQuantityCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LH


LH Constructor

LH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► LH()()()()
RDPCrystal EDI Library
Initializes a new instance of the LH class
Declaration Syntax
C# Visual Basic Visual C++
public LH()
Public Sub New
public:
LH()


HazardousMnemonicCode Property

HazardousMnemonicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► HazardousMnemonicCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMnemonicCode { get; set; }
Public Property HazardousMnemonicCode As String
    Get
    Set
public:
property String^ HazardousMnemonicCode {
    String^ get ();
    void set (String^ value);
}


LadingLineItemNumber Property

LadingLineItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► LadingLineItemNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingLineItemNumber { get; set; }
Public Property LadingLineItemNumber As String
    Get
    Set
public:
property String^ LadingLineItemNumber {
    String^ get ();
    void set (String^ value);
}


LimitedQuantityIndicationCode Property

LimitedQuantityIndicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► LimitedQuantityIndicationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LimitedQuantityIndicationCode { get; set; }
Public Property LimitedQuantityIndicationCode As String
    Get
    Set
public:
property String^ LimitedQuantityIndicationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReportableQuantityCode Property

ReportableQuantityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► ReportableQuantityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportableQuantityCode { get; set; }
Public Property ReportableQuantityCode As String
    Get
    Set
public:
property String^ ReportableQuantityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LH1 Class

LH1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1
RDPCrystal EDI Library
Hazardous Identification Information
Declaration Syntax
C# Visual Basic Visual C++
public class LH1 : DocumentSegment
Public Class LH1 _
    Inherits DocumentSegment
public ref class LH1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LH1()()()() | Initializes a new instance of the LH1 class
 | CommodityCode | Element 5
 | CompartmentIDCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialsPage | Element 4
 | InterimHazardousMaterialRegulatoryNumber | Element 11
 | LadingQuantity | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackingGroupCode | Element 10
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 7
 | ResidueIndicatorCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 1
 | UnitOrBasisForMeasurementCode1 | Element 6
 | UNNAIdentificationCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LH1


LH1 Constructor

LH1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► LH1()()()()
RDPCrystal EDI Library
Initializes a new instance of the LH1 class
Declaration Syntax
C# Visual Basic Visual C++
public LH1()
Public Sub New
public:
LH1()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► CommodityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CompartmentIDCode Property

CompartmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► CompartmentIDCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CompartmentIDCode { get; set; }
Public Property CompartmentIDCode As String
    Get
    Set
public:
property String^ CompartmentIDCode {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialsPage Property

HazardousMaterialsPage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► HazardousMaterialsPage
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialsPage { get; set; }
Public Property HazardousMaterialsPage As String
    Get
    Set
public:
property String^ HazardousMaterialsPage {
    String^ get ();
    void set (String^ value);
}


InterimHazardousMaterialRegulatoryNumber Property

InterimHazardousMaterialRegulatoryNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► InterimHazardousMaterialRegulatoryNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string InterimHazardousMaterialRegulatoryNumber { get; set; }
Public Property InterimHazardousMaterialRegulatoryNumber As String
    Get
    Set
public:
property String^ InterimHazardousMaterialRegulatoryNumber {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► LadingQuantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackingGroupCode Property

PackingGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► PackingGroupCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PackingGroupCode { get; set; }
Public Property PackingGroupCode As String
    Get
    Set
public:
property String^ PackingGroupCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ResidueIndicatorCode Property

ResidueIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► ResidueIndicatorCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ResidueIndicatorCode { get; set; }
Public Property ResidueIndicatorCode As String
    Get
    Set
public:
property String^ ResidueIndicatorCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UNNAIdentificationCode Property

UNNAIdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► UNNAIdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UNNAIdentificationCode { get; set; }
Public Property UNNAIdentificationCode As String
    Get
    Set
public:
property String^ UNNAIdentificationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LH2 Class

LH2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2
RDPCrystal EDI Library
Hazardous Classification Information
Declaration Syntax
C# Visual Basic Visual C++
public class LH2 : DocumentSegment
Public Class LH2 _
    Inherits DocumentSegment
public ref class LH2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LH2()()()() | Initializes a new instance of the LH2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousClassification | Element 1
 | HazardousClassQualifier | Element 2
 | HazardousEndorsement | Element 4
 | HazardousPlacardNotation | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportableQuantityCode | Element 5
 | Temperature | Element 7
 | Temperature1 | Element 9
 | Temperature2 | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | UnitOrBasisForMeasurementCode1 | Element 8
 | UnitOrBasisForMeasurementCode2 | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LH2


LH2 Constructor

LH2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► LH2()()()()
RDPCrystal EDI Library
Initializes a new instance of the LH2 class
Declaration Syntax
C# Visual Basic Visual C++
public LH2()
Public Sub New
public:
LH2()


HazardousClassification Property

HazardousClassification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► HazardousClassification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousClassification { get; set; }
Public Property HazardousClassification As String
    Get
    Set
public:
property String^ HazardousClassification {
    String^ get ();
    void set (String^ value);
}


HazardousClassQualifier Property

HazardousClassQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► HazardousClassQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousClassQualifier { get; set; }
Public Property HazardousClassQualifier As String
    Get
    Set
public:
property String^ HazardousClassQualifier {
    String^ get ();
    void set (String^ value);
}


HazardousEndorsement Property

HazardousEndorsement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► HazardousEndorsement
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousEndorsement { get; set; }
Public Property HazardousEndorsement As String
    Get
    Set
public:
property String^ HazardousEndorsement {
    String^ get ();
    void set (String^ value);
}


HazardousPlacardNotation Property

HazardousPlacardNotation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► HazardousPlacardNotation
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousPlacardNotation { get; set; }
Public Property HazardousPlacardNotation As String
    Get
    Set
public:
property String^ HazardousPlacardNotation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReportableQuantityCode Property

ReportableQuantityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► ReportableQuantityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportableQuantityCode { get; set; }
Public Property ReportableQuantityCode As String
    Get
    Set
public:
property String^ ReportableQuantityCode {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► Temperature
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


Temperature1 Property

Temperature1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► Temperature1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature1 { get; set; }
Public Property Temperature1 As String
    Get
    Set
public:
property String^ Temperature1 {
    String^ get ();
    void set (String^ value);
}


Temperature2 Property

Temperature2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► Temperature2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature2 { get; set; }
Public Property Temperature2 As String
    Get
    Set
public:
property String^ Temperature2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LH3 Class

LH3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3
RDPCrystal EDI Library
Hazardous Material Shipping Name
Declaration Syntax
C# Visual Basic Visual C++
public class LH3 : DocumentSegment
Public Class LH3 _
    Inherits DocumentSegment
public ref class LH3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LH3()()()() | Initializes a new instance of the LH3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialShippingName | Element 1
 | HazardousMaterialShippingNameQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NOSIndicatorCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LH3


LH3 Constructor

LH3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► LH3()()()()
RDPCrystal EDI Library
Initializes a new instance of the LH3 class
Declaration Syntax
C# Visual Basic Visual C++
public LH3()
Public Sub New
public:
LH3()


HazardousMaterialShippingName Property

HazardousMaterialShippingName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► HazardousMaterialShippingName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialShippingName { get; set; }
Public Property HazardousMaterialShippingName As String
    Get
    Set
public:
property String^ HazardousMaterialShippingName {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialShippingNameQualifier Property

HazardousMaterialShippingNameQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► HazardousMaterialShippingNameQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialShippingNameQualifier { get; set; }
Public Property HazardousMaterialShippingNameQualifier As String
    Get
    Set
public:
property String^ HazardousMaterialShippingNameQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NOSIndicatorCode Property

NOSIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► NOSIndicatorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NOSIndicatorCode { get; set; }
Public Property NOSIndicatorCode As String
    Get
    Set
public:
property String^ NOSIndicatorCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH3 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LH4 Class

LH4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4
RDPCrystal EDI Library
Canadian Dangerous Requirements
Declaration Syntax
C# Visual Basic Visual C++
public class LH4 : DocumentSegment
Public Class LH4 _
    Inherits DocumentSegment
public ref class LH4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LH4()()()() | Initializes a new instance of the LH4 class
 | CanadianHazardousNotation | Element 9
 | CommunicationNumber | Element 2
 | CommunicationNumber1 | Element 11
 | EmergencyResponsePlanNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetExplosiveQuantity | Element 8
 | PackingGroupCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialCommodityIndicatorCode | Element 10
 | SubsidiaryClassification | Element 4
 | SubsidiaryClassification1 | Element 5
 | SubsidiaryClassification2 | Element 6
 | SubsidiaryRiskIndicator | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LH4


LH4 Constructor

LH4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► LH4()()()()
RDPCrystal EDI Library
Initializes a new instance of the LH4 class
Declaration Syntax
C# Visual Basic Visual C++
public LH4()
Public Sub New
public:
LH4()


CanadianHazardousNotation Property

CanadianHazardousNotation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► CanadianHazardousNotation
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CanadianHazardousNotation { get; set; }
Public Property CanadianHazardousNotation As String
    Get
    Set
public:
property String^ CanadianHazardousNotation {
    String^ get ();
    void set (String^ value);
}


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► CommunicationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


CommunicationNumber1 Property

CommunicationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► CommunicationNumber1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber1 { get; set; }
Public Property CommunicationNumber1 As String
    Get
    Set
public:
property String^ CommunicationNumber1 {
    String^ get ();
    void set (String^ value);
}


EmergencyResponsePlanNumber Property

EmergencyResponsePlanNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► EmergencyResponsePlanNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EmergencyResponsePlanNumber { get; set; }
Public Property EmergencyResponsePlanNumber As String
    Get
    Set
public:
property String^ EmergencyResponsePlanNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetExplosiveQuantity Property

NetExplosiveQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► NetExplosiveQuantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string NetExplosiveQuantity { get; set; }
Public Property NetExplosiveQuantity As String
    Get
    Set
public:
property String^ NetExplosiveQuantity {
    String^ get ();
    void set (String^ value);
}


PackingGroupCode Property

PackingGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► PackingGroupCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PackingGroupCode { get; set; }
Public Property PackingGroupCode As String
    Get
    Set
public:
property String^ PackingGroupCode {
    String^ get ();
    void set (String^ value);
}


SpecialCommodityIndicatorCode Property

SpecialCommodityIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► SpecialCommodityIndicatorCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialCommodityIndicatorCode { get; set; }
Public Property SpecialCommodityIndicatorCode As String
    Get
    Set
public:
property String^ SpecialCommodityIndicatorCode {
    String^ get ();
    void set (String^ value);
}


SubsidiaryClassification Property

SubsidiaryClassification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► SubsidiaryClassification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SubsidiaryClassification { get; set; }
Public Property SubsidiaryClassification As String
    Get
    Set
public:
property String^ SubsidiaryClassification {
    String^ get ();
    void set (String^ value);
}


SubsidiaryClassification1 Property

SubsidiaryClassification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► SubsidiaryClassification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SubsidiaryClassification1 { get; set; }
Public Property SubsidiaryClassification1 As String
    Get
    Set
public:
property String^ SubsidiaryClassification1 {
    String^ get ();
    void set (String^ value);
}


SubsidiaryClassification2 Property

SubsidiaryClassification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► SubsidiaryClassification2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SubsidiaryClassification2 { get; set; }
Public Property SubsidiaryClassification2 As String
    Get
    Set
public:
property String^ SubsidiaryClassification2 {
    String^ get ();
    void set (String^ value);
}


SubsidiaryRiskIndicator Property

SubsidiaryRiskIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► SubsidiaryRiskIndicator
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SubsidiaryRiskIndicator { get; set; }
Public Property SubsidiaryRiskIndicator As String
    Get
    Set
public:
property String^ SubsidiaryRiskIndicator {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LH6 Class

LH6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6
RDPCrystal EDI Library
Hazardous Certification
Declaration Syntax
C# Visual Basic Visual C++
public class LH6 : DocumentSegment
Public Class LH6 _
    Inherits DocumentSegment
public ref class LH6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LH6()()()() | Initializes a new instance of the LH6 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousCertificationCode | Element 2
 | HazardousCertificationDeclaration | Element 3
 | HazardousCertificationDeclaration1 | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LH6


LH6 Constructor

LH6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► LH6()()()()
RDPCrystal EDI Library
Initializes a new instance of the LH6 class
Declaration Syntax
C# Visual Basic Visual C++
public LH6()
Public Sub New
public:
LH6()


HazardousCertificationCode Property

HazardousCertificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► HazardousCertificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousCertificationCode { get; set; }
Public Property HazardousCertificationCode As String
    Get
    Set
public:
property String^ HazardousCertificationCode {
    String^ get ();
    void set (String^ value);
}


HazardousCertificationDeclaration Property

HazardousCertificationDeclaration Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► HazardousCertificationDeclaration
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousCertificationDeclaration { get; set; }
Public Property HazardousCertificationDeclaration As String
    Get
    Set
public:
property String^ HazardousCertificationDeclaration {
    String^ get ();
    void set (String^ value);
}


HazardousCertificationDeclaration1 Property

HazardousCertificationDeclaration1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► HazardousCertificationDeclaration1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousCertificationDeclaration1 { get; set; }
Public Property HazardousCertificationDeclaration1 As String
    Get
    Set
public:
property String^ HazardousCertificationDeclaration1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LH6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LHE Class

LHE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE
RDPCrystal EDI Library
Empty Equipment Hazardous Material Information
Declaration Syntax
C# Visual Basic Visual C++
public class LHE : DocumentSegment
Public Class LHE _
    Inherits DocumentSegment
public ref class LHE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LHE()()()() | Initializes a new instance of the LHE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialShippingName | Element 1
 | HazardousPlacardNotation | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ReferenceIdentificationQualifier | Element 3
 | ReportableQuantityCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LHE


LHE Constructor

LHE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► LHE()()()()
RDPCrystal EDI Library
Initializes a new instance of the LHE class
Declaration Syntax
C# Visual Basic Visual C++
public LHE()
Public Sub New
public:
LHE()


HazardousMaterialShippingName Property

HazardousMaterialShippingName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► HazardousMaterialShippingName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialShippingName { get; set; }
Public Property HazardousMaterialShippingName As String
    Get
    Set
public:
property String^ HazardousMaterialShippingName {
    String^ get ();
    void set (String^ value);
}


HazardousPlacardNotation Property

HazardousPlacardNotation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► HazardousPlacardNotation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousPlacardNotation { get; set; }
Public Property HazardousPlacardNotation As String
    Get
    Set
public:
property String^ HazardousPlacardNotation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReportableQuantityCode Property

ReportableQuantityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► ReportableQuantityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportableQuantityCode { get; set; }
Public Property ReportableQuantityCode As String
    Get
    Set
public:
property String^ ReportableQuantityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LHR Class

LHR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR
RDPCrystal EDI Library
Hazardous Material Identifying Reference Numbers
Declaration Syntax
C# Visual Basic Visual C++
public class LHR : DocumentSegment
Public Class LHR _
    Inherits DocumentSegment
public ref class LHR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LHR()()()() | Initializes a new instance of the LHR class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LHR


LHR Constructor

LHR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR ► LHR()()()()
RDPCrystal EDI Library
Initializes a new instance of the LHR class
Declaration Syntax
C# Visual Basic Visual C++
public LHR()
Public Sub New
public:
LHR()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LHT Class

LHT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT
RDPCrystal EDI Library
Transborder Hazardous Requirements
Declaration Syntax
C# Visual Basic Visual C++
public class LHT : DocumentSegment
Public Class LHT _
    Inherits DocumentSegment
public ref class LHT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LHT()()()() | Initializes a new instance of the LHT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousClassification | Element 1
 | HazardousEndorsement | Element 3
 | HazardousPlacardNotation | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LHT


LHT Constructor

LHT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT ► LHT()()()()
RDPCrystal EDI Library
Initializes a new instance of the LHT class
Declaration Syntax
C# Visual Basic Visual C++
public LHT()
Public Sub New
public:
LHT()


HazardousClassification Property

HazardousClassification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT ► HazardousClassification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousClassification { get; set; }
Public Property HazardousClassification As String
    Get
    Set
public:
property String^ HazardousClassification {
    String^ get ();
    void set (String^ value);
}


HazardousEndorsement Property

HazardousEndorsement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT ► HazardousEndorsement
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousEndorsement { get; set; }
Public Property HazardousEndorsement As String
    Get
    Set
public:
property String^ HazardousEndorsement {
    String^ get ();
    void set (String^ value);
}


HazardousPlacardNotation Property

HazardousPlacardNotation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT ► HazardousPlacardNotation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousPlacardNotation { get; set; }
Public Property HazardousPlacardNotation As String
    Get
    Set
public:
property String^ HazardousPlacardNotation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LHT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LIC Class

LIC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC
RDPCrystal EDI Library
License Information
Declaration Syntax
C# Visual Basic Visual C++
public class LIC : DocumentSegment
Public Class LIC _
    Inherits DocumentSegment
public ref class LIC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LIC()()()() | Initializes a new instance of the LIC class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceIDQualifier | Element 2
 | ReferenceIdentification | Element 6
 | ReferenceIdentification1 | Element 8
 | StateOrProvinceCode | Element 1
 | StateOrProvinceCode1 | Element 7
 | StatusCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LIC


LIC Constructor

LIC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► LIC()()()()
RDPCrystal EDI Library
Initializes a new instance of the LIC class
Declaration Syntax
C# Visual Basic Visual C++
public LIC()
Public Sub New
public:
LIC()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► StateOrProvinceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► StatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LID Class

LID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID
RDPCrystal EDI Library
Loss Information Description
Declaration Syntax
C# Visual Basic Visual C++
public class LID : DocumentSegment
Public Class LID _
    Inherits DocumentSegment
public ref class LID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LID()()()() | Initializes a new instance of the LID class
 | DateTimePeriod | Element 2
 | DateTimePeriodFormatQualifier | Element 1
 | Description | Element 5
 | Description1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 3
 | IndustryCode1 | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
 | YesNoConditionOrResponseCode1 | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LID


LID Constructor

LID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► LID()()()()
RDPCrystal EDI Library
Initializes a new instance of the LID class
Declaration Syntax
C# Visual Basic Visual C++
public LID()
Public Sub New
public:
LID()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► DateTimePeriod
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► Description1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► IndustryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► IndustryCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LID ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


LIE Class

LIE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE
RDPCrystal EDI Library
Individual or Event Location
Declaration Syntax
C# Visual Basic Visual C++
public class LIE : DocumentSegment
Public Class LIE _
    Inherits DocumentSegment
public ref class LIE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LIE()()()() | Initializes a new instance of the LIE class
 | Description | Element 3
 | EntityIdentifierCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProximityCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LIE


LIE Constructor

LIE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► LIE()()()()
RDPCrystal EDI Library
Initializes a new instance of the LIE class
Declaration Syntax
C# Visual Basic Visual C++
public LIE()
Public Sub New
public:
LIE()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► EntityIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationTypeCode Property

LocationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► LocationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationTypeCode { get; set; }
Public Property LocationTypeCode As String
    Get
    Set
public:
property String^ LocationTypeCode {
    String^ get ();
    void set (String^ value);
}


ProximityCode Property

ProximityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► ProximityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProximityCode { get; set; }
Public Property ProximityCode As String
    Get
    Set
public:
property String^ ProximityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LIN Class

LIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN
RDPCrystal EDI Library
Item Identification
Declaration Syntax
C# Visual Basic Visual C++
public class LIN : DocumentSegment
Public Class LIN _
    Inherits DocumentSegment
public ref class LIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LIN()()()() | Initializes a new instance of the LIN class
 | AssignedIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceID1 | Element 5
 | ProductServiceID10 | Element 23
 | ProductServiceID11 | Element 25
 | ProductServiceID12 | Element 27
 | ProductServiceID13 | Element 29
 | ProductServiceID14 | Element 31
 | ProductServiceID2 | Element 7
 | ProductServiceID3 | Element 9
 | ProductServiceID4 | Element 11
 | ProductServiceID5 | Element 13
 | ProductServiceID6 | Element 15
 | ProductServiceID7 | Element 17
 | ProductServiceID8 | Element 19
 | ProductServiceID9 | Element 21
 | ProductServiceIDQualifier | Element 2
 | ProductServiceIDQualifier1 | Element 4
 | ProductServiceIDQualifier10 | Element 22
 | ProductServiceIDQualifier11 | Element 24
 | ProductServiceIDQualifier12 | Element 26
 | ProductServiceIDQualifier13 | Element 28
 | ProductServiceIDQualifier14 | Element 30
 | ProductServiceIDQualifier2 | Element 6
 | ProductServiceIDQualifier3 | Element 8
 | ProductServiceIDQualifier4 | Element 10
 | ProductServiceIDQualifier5 | Element 12
 | ProductServiceIDQualifier6 | Element 14
 | ProductServiceIDQualifier7 | Element 16
 | ProductServiceIDQualifier8 | Element 18
 | ProductServiceIDQualifier9 | Element 20
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LIN


LIN Constructor

LIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► LIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the LIN class
Declaration Syntax
C# Visual Basic Visual C++
public LIN()
Public Sub New
public:
LIN()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID10 Property

ProductServiceID10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID10
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID10 { get; set; }
Public Property ProductServiceID10 As String
    Get
    Set
public:
property String^ ProductServiceID10 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID11 Property

ProductServiceID11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID11
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID11 { get; set; }
Public Property ProductServiceID11 As String
    Get
    Set
public:
property String^ ProductServiceID11 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID12 Property

ProductServiceID12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID12
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID12 { get; set; }
Public Property ProductServiceID12 As String
    Get
    Set
public:
property String^ ProductServiceID12 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID13 Property

ProductServiceID13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID13
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID13 { get; set; }
Public Property ProductServiceID13 As String
    Get
    Set
public:
property String^ ProductServiceID13 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID14 Property

ProductServiceID14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID14
RDPCrystal EDI Library
Element 31
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID14 { get; set; }
Public Property ProductServiceID14 As String
    Get
    Set
public:
property String^ ProductServiceID14 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID6
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID7
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID8
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceID9
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier10 Property

ProductServiceIDQualifier10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier10
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier10 { get; set; }
Public Property ProductServiceIDQualifier10 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier10 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier11 Property

ProductServiceIDQualifier11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier11
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier11 { get; set; }
Public Property ProductServiceIDQualifier11 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier11 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier12 Property

ProductServiceIDQualifier12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier12
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier12 { get; set; }
Public Property ProductServiceIDQualifier12 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier12 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier13 Property

ProductServiceIDQualifier13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier13
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier13 { get; set; }
Public Property ProductServiceIDQualifier13 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier13 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier14 Property

ProductServiceIDQualifier14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier14
RDPCrystal EDI Library
Element 30
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier14 { get; set; }
Public Property ProductServiceIDQualifier14 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier14 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LM Class

LM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LM
RDPCrystal EDI Library
Code Source Information
Declaration Syntax
C# Visual Basic Visual C++
public class LM : DocumentSegment
Public Class LM _
    Inherits DocumentSegment
public ref class LM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LM()()()() | Initializes a new instance of the LM class
 | AgencyQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceSubqualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LM


LM Constructor

LM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LM ► LM()()()()
RDPCrystal EDI Library
Initializes a new instance of the LM class
Declaration Syntax
C# Visual Basic Visual C++
public LM()
Public Sub New
public:
LM()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LM ► AgencyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LM ► SourceSubqualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LN Class

LN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN
RDPCrystal EDI Library
Loan Information
Declaration Syntax
C# Visual Basic Visual C++
public class LN : DocumentSegment
Public Class LN _
    Inherits DocumentSegment
public ref class LN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LN()()()() | Initializes a new instance of the LN class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 10
 | LoanPurposeCode | Element 9
 | LoanRateTypeCode | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LN


LN Constructor

LN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► LN()()()()
RDPCrystal EDI Library
Initializes a new instance of the LN class
Declaration Syntax
C# Visual Basic Visual C++
public LN()
Public Sub New
public:
LN()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► FrequencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanPurposeCode Property

LoanPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► LoanPurposeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPurposeCode { get; set; }
Public Property LoanPurposeCode As String
    Get
    Set
public:
property String^ LoanPurposeCode {
    String^ get ();
    void set (String^ value);
}


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► LoanRateTypeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LN1 Class

LN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1
RDPCrystal EDI Library
Loan Specific Data
Declaration Syntax
C# Visual Basic Visual C++
public class LN1 : DocumentSegment
Public Class LN1 _
    Inherits DocumentSegment
public ref class LN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LN1()()()() | Initializes a new instance of the LN1 class
 | AccountNumber | Element 13
 | DateTimePeriod | Element 17
 | DateTimePeriod1 | Element 18
 | DateTimePeriod2 | Element 19
 | DateTimePeriod3 | Element 20
 | DateTimePeriod4 | Element 21
 | DateTimePeriodFormatQualifier | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LienPriorityCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanDocumentationTypeCode | Element 10
 | LoanRateTypeCode | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 8
 | MonetaryAmount3 | Element 22
 | MonetaryAmount4 | Element 23
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | Percent1 | Element 6
 | Percent2 | Element 14
 | Percent3 | Element 15
 | RateValueQualifier | Element 7
 | RealEstateLoanSecurityInstrumentCode | Element 9
 | RealEstateLoanTypeCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LN1


LN1 Constructor

LN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► LN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the LN1 class
Declaration Syntax
C# Visual Basic Visual C++
public LN1()
Public Sub New
public:
LN1()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► AccountNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► DateTimePeriod
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► DateTimePeriod1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► DateTimePeriod2
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod3 Property

DateTimePeriod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► DateTimePeriod3
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod3 { get; set; }
Public Property DateTimePeriod3 As String
    Get
    Set
public:
property String^ DateTimePeriod3 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod4 Property

DateTimePeriod4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► DateTimePeriod4
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod4 { get; set; }
Public Property DateTimePeriod4 As String
    Get
    Set
public:
property String^ DateTimePeriod4 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


LienPriorityCode Property

LienPriorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► LienPriorityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LienPriorityCode { get; set; }
Public Property LienPriorityCode As String
    Get
    Set
public:
property String^ LienPriorityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanDocumentationTypeCode Property

LoanDocumentationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► LoanDocumentationTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LoanDocumentationTypeCode { get; set; }
Public Property LoanDocumentationTypeCode As String
    Get
    Set
public:
property String^ LoanDocumentationTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► LoanRateTypeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► MonetaryAmount2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► MonetaryAmount3
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► MonetaryAmount4
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► Percent1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Percent2 Property

Percent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► Percent2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Percent2 { get; set; }
Public Property Percent2 As String
    Get
    Set
public:
property String^ Percent2 {
    String^ get ();
    void set (String^ value);
}


Percent3 Property

Percent3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► Percent3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Percent3 { get; set; }
Public Property Percent3 As String
    Get
    Set
public:
property String^ Percent3 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► RateValueQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanSecurityInstrumentCode Property

RealEstateLoanSecurityInstrumentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► RealEstateLoanSecurityInstrumentCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanSecurityInstrumentCode { get; set; }
Public Property RealEstateLoanSecurityInstrumentCode As String
    Get
    Set
public:
property String^ RealEstateLoanSecurityInstrumentCode {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanTypeCode Property

RealEstateLoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► RealEstateLoanTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanTypeCode { get; set; }
Public Property RealEstateLoanTypeCode As String
    Get
    Set
public:
property String^ RealEstateLoanTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN1 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LN2 Class

LN2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2
RDPCrystal EDI Library
Existing Real Estate Loan Specific Data
Declaration Syntax
C# Visual Basic Visual C++
public class LN2 : DocumentSegment
Public Class LN2 _
    Inherits DocumentSegment
public ref class LN2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LN2()()()() | Initializes a new instance of the LN2 class
 | AssumptionTermsCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LienPriorityCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | Quantity | Element 11
 | Quantity1 | Element 12
 | QuantityQualifier | Element 10
 | RealEstateLoanTypeCode | Element 2
 | ReferenceIdentifier | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LN2


LN2 Constructor

LN2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► LN2()()()()
RDPCrystal EDI Library
Initializes a new instance of the LN2 class
Declaration Syntax
C# Visual Basic Visual C++
public LN2()
Public Sub New
public:
LN2()


AssumptionTermsCode Property

AssumptionTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► AssumptionTermsCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssumptionTermsCode { get; set; }
Public Property AssumptionTermsCode As String
    Get
    Set
public:
property String^ AssumptionTermsCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► FrequencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


LienPriorityCode Property

LienPriorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► LienPriorityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LienPriorityCode { get; set; }
Public Property LienPriorityCode As String
    Get
    Set
public:
property String^ LienPriorityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► Name1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► Quantity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► Quantity1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► QuantityQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanTypeCode Property

RealEstateLoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► RealEstateLoanTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanTypeCode { get; set; }
Public Property RealEstateLoanTypeCode As String
    Get
    Set
public:
property String^ RealEstateLoanTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► ReferenceIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LN2 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LOC Class

LOC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC
RDPCrystal EDI Library
Location
Declaration Syntax
C# Visual Basic Visual C++
public class LOC : DocumentSegment
Public Class LOC _
    Inherits DocumentSegment
public ref class LOC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LOC()()()() | Initializes a new instance of the LOC class
 | Category | Element 5
 | CompositeUnitOfMeasure | Element 11
 | CompositeUnitOfMeasure1 | Element 13
 | CompositeUnitOfMeasure2 | Element 15
 | CompositeUnitOfMeasure3 | Element 17
 | CompositeUnitOfMeasure4 | Element 19
 | CompositeUnitOfMeasure5 | Element 21
 | Description | Element 3
 | Description1 | Element 8
 | Description2 | Element 24
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 10
 | MeasurementValue1 | Element 12
 | MeasurementValue2 | Element 14
 | MeasurementValue3 | Element 16
 | MeasurementValue4 | Element 18
 | MeasurementValue5 | Element 20
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentification2 | Element 7
 | ReferenceIdentification3 | Element 9
 | ReferenceIdentification4 | Element 23
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentificationQualifier1 | Element 6
 | ReferenceIdentificationQualifier2 | Element 22
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LOC


LOC Constructor

LOC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► LOC()()()()
RDPCrystal EDI Library
Initializes a new instance of the LOC class
Declaration Syntax
C# Visual Basic Visual C++
public LOC()
Public Sub New
public:
LOC()


Category Property

Category Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► Category
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure2 Property

CompositeUnitOfMeasure2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► CompositeUnitOfMeasure2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure2 { get; set; }
Public Property CompositeUnitOfMeasure2 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure2 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure3 Property

CompositeUnitOfMeasure3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► CompositeUnitOfMeasure3
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure3 { get; set; }
Public Property CompositeUnitOfMeasure3 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure3 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure4 Property

CompositeUnitOfMeasure4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► CompositeUnitOfMeasure4
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure4 { get; set; }
Public Property CompositeUnitOfMeasure4 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure4 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure5 Property

CompositeUnitOfMeasure5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► CompositeUnitOfMeasure5
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure5 { get; set; }
Public Property CompositeUnitOfMeasure5 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure5 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► Description1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► Description2
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► MeasurementValue
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


MeasurementValue1 Property

MeasurementValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► MeasurementValue1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue1 { get; set; }
Public Property MeasurementValue1 As String
    Get
    Set
public:
property String^ MeasurementValue1 {
    String^ get ();
    void set (String^ value);
}


MeasurementValue2 Property

MeasurementValue2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► MeasurementValue2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue2 { get; set; }
Public Property MeasurementValue2 As String
    Get
    Set
public:
property String^ MeasurementValue2 {
    String^ get ();
    void set (String^ value);
}


MeasurementValue3 Property

MeasurementValue3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► MeasurementValue3
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue3 { get; set; }
Public Property MeasurementValue3 As String
    Get
    Set
public:
property String^ MeasurementValue3 {
    String^ get ();
    void set (String^ value);
}


MeasurementValue4 Property

MeasurementValue4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► MeasurementValue4
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue4 { get; set; }
Public Property MeasurementValue4 As String
    Get
    Set
public:
property String^ MeasurementValue4 {
    String^ get ();
    void set (String^ value);
}


MeasurementValue5 Property

MeasurementValue5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► MeasurementValue5
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue5 { get; set; }
Public Property MeasurementValue5 As String
    Get
    Set
public:
property String^ MeasurementValue5 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentification2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentification3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentification4
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier2 Property

ReferenceIdentificationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► ReferenceIdentificationQualifier2
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier2 { get; set; }
Public Property ReferenceIdentificationQualifier2 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LOD Class

LOD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD
RDPCrystal EDI Library
Location Description
Declaration Syntax
C# Visual Basic Visual C++
public class LOD : DocumentSegment
Public Class LOD _
    Inherits DocumentSegment
public ref class LOD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LOD()()()() | Initializes a new instance of the LOD class
 | ConditionIndicator | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 3
 | FreeFormMessage1 | Element 6
 | GeneralTerritoryCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ThoroughfareTypeCode | Element 5
 | ThoroughfareTypeQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LOD


LOD Constructor

LOD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► LOD()()()()
RDPCrystal EDI Library
Initializes a new instance of the LOD class
Declaration Syntax
C# Visual Basic Visual C++
public LOD()
Public Sub New
public:
LOD()


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► ConditionIndicator
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► FreeFormMessage
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage1 Property

FreeFormMessage1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► FreeFormMessage1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage1 { get; set; }
Public Property FreeFormMessage1 As String
    Get
    Set
public:
property String^ FreeFormMessage1 {
    String^ get ();
    void set (String^ value);
}


GeneralTerritoryCode Property

GeneralTerritoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► GeneralTerritoryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string GeneralTerritoryCode { get; set; }
Public Property GeneralTerritoryCode As String
    Get
    Set
public:
property String^ GeneralTerritoryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ThoroughfareTypeCode Property

ThoroughfareTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► ThoroughfareTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ThoroughfareTypeCode { get; set; }
Public Property ThoroughfareTypeCode As String
    Get
    Set
public:
property String^ ThoroughfareTypeCode {
    String^ get ();
    void set (String^ value);
}


ThoroughfareTypeQualifier Property

ThoroughfareTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► ThoroughfareTypeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ThoroughfareTypeQualifier { get; set; }
Public Property ThoroughfareTypeQualifier As String
    Get
    Set
public:
property String^ ThoroughfareTypeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LOD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LP Class

LP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP
RDPCrystal EDI Library
Load Planning
Declaration Syntax
C# Visual Basic Visual C++
public class LP : DocumentSegment
Public Class LP _
    Inherits DocumentSegment
public ref class LP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LP()()()() | Initializes a new instance of the LP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentNumber | Element 5
 | EquipmentType | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 6
 | Number1 | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 2
 | ShipmentIdentificationNumber1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VentInstructionCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LP


LP Constructor

LP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► LP()()()()
RDPCrystal EDI Library
Initializes a new instance of the LP class
Declaration Syntax
C# Visual Basic Visual C++
public LP()
Public Sub New
public:
LP()


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► EquipmentNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► EquipmentType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► Number
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► Number1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber1 Property

ShipmentIdentificationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► ShipmentIdentificationNumber1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber1 { get; set; }
Public Property ShipmentIdentificationNumber1 As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber1 {
    String^ get ();
    void set (String^ value);
}


VentInstructionCode Property

VentInstructionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► VentInstructionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string VentInstructionCode { get; set; }
Public Property VentInstructionCode As String
    Get
    Set
public:
property String^ VentInstructionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LQ Class

LQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LQ
RDPCrystal EDI Library
Industry Code
Declaration Syntax
C# Visual Basic Visual C++
public class LQ : DocumentSegment
Public Class LQ _
    Inherits DocumentSegment
public ref class LQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LQ()()()() | Initializes a new instance of the LQ class
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LQ


LQ Constructor

LQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LQ ► LQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the LQ class
Declaration Syntax
C# Visual Basic Visual C++
public LQ()
Public Sub New
public:
LQ()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LQ ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LQ ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LRQ Class

LRQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ
RDPCrystal EDI Library
Mortgage Characteristics Requested
Declaration Syntax
C# Visual Basic Visual C++
public class LRQ : DocumentSegment
Public Class LRQ _
    Inherits DocumentSegment
public ref class LRQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LRQ()()()() | Initializes a new instance of the LRQ class
 | AssumptionTermsCode | Element 8
 | CompositeUseOfProceeds | Element 10
 | ContactMethodCode | Element 6
 | Description | Element 13
 | Description1 | Element 14
 | Description2 | Element 16
 | Description3 | Element 18
 | Description4 | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 17
 | LoanPurposeCode | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 11
 | MonetaryAmount3 | Element 12
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 19
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | RateValueQualifier | Element 3
 | RealEstateLoanTypeCode | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfResidenceCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LRQ


LRQ Constructor

LRQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► LRQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the LRQ class
Declaration Syntax
C# Visual Basic Visual C++
public LRQ()
Public Sub New
public:
LRQ()


AssumptionTermsCode Property

AssumptionTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► AssumptionTermsCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AssumptionTermsCode { get; set; }
Public Property AssumptionTermsCode As String
    Get
    Set
public:
property String^ AssumptionTermsCode {
    String^ get ();
    void set (String^ value);
}


CompositeUseOfProceeds Property

CompositeUseOfProceeds Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► CompositeUseOfProceeds
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUseOfProceeds CompositeUseOfProceeds { get; set; }
Public Property CompositeUseOfProceeds As CompositeUseOfProceeds
    Get
    Set
public:
property CompositeUseOfProceeds^ CompositeUseOfProceeds {
    CompositeUseOfProceeds^ get ();
    void set (CompositeUseOfProceeds^ value);
}


ContactMethodCode Property

ContactMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► ContactMethodCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContactMethodCode { get; set; }
Public Property ContactMethodCode As String
    Get
    Set
public:
property String^ ContactMethodCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Description
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Description1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Description2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}


Description3 Property

Description3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Description3
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Description3 { get; set; }
Public Property Description3 As String
    Get
    Set
public:
property String^ Description3 {
    String^ get ();
    void set (String^ value);
}


Description4 Property

Description4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Description4
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Description4 { get; set; }
Public Property Description4 As String
    Get
    Set
public:
property String^ Description4 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanPurposeCode Property

LoanPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► LoanPurposeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPurposeCode { get; set; }
Public Property LoanPurposeCode As String
    Get
    Set
public:
property String^ LoanPurposeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► MonetaryAmount2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► MonetaryAmount3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Number
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► RateValueQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanTypeCode Property

RealEstateLoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► RealEstateLoanTypeCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanTypeCode { get; set; }
Public Property RealEstateLoanTypeCode As String
    Get
    Set
public:
property String^ RealEstateLoanTypeCode {
    String^ get ();
    void set (String^ value);
}


TypeOfResidenceCode Property

TypeOfResidenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► TypeOfResidenceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfResidenceCode { get; set; }
Public Property TypeOfResidenceCode As String
    Get
    Set
public:
property String^ TypeOfResidenceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LRQ ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


LS Class

LS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS
RDPCrystal EDI Library
Loop Header
Declaration Syntax
C# Visual Basic Visual C++
public class LS : DocumentSegment
Public Class LS _
    Inherits DocumentSegment
public ref class LS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LS()()()() | Initializes a new instance of the LS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LS


LS Constructor

LS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS ► LS()()()()
RDPCrystal EDI Library
Initializes a new instance of the LS class
Declaration Syntax
C# Visual Basic Visual C++
public LS()
Public Sub New
public:
LS()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS ► LoopIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LS1 Class

LS1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1
RDPCrystal EDI Library
Asset Item Identification
Declaration Syntax
C# Visual Basic Visual C++
public class LS1 : DocumentSegment
Public Class LS1 _
    Inherits DocumentSegment
public ref class LS1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LS1()()()() | Initializes a new instance of the LS1 class
 | AssignedIdentification | Element 2
 | ChangeOrResponseTypeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | ProductServiceID1 | Element 5
 | ProductServiceID2 | Element 6
 | ProductServiceID3 | Element 7
 | Quantity | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LS1


LS1 Constructor

LS1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► LS1()()()()
RDPCrystal EDI Library
Initializes a new instance of the LS1 class
Declaration Syntax
C# Visual Basic Visual C++
public LS1()
Public Sub New
public:
LS1()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► AssignedIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


ChangeOrResponseTypeCode Property

ChangeOrResponseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► ChangeOrResponseTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrResponseTypeCode { get; set; }
Public Property ChangeOrResponseTypeCode As String
    Get
    Set
public:
property String^ ChangeOrResponseTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► ProductServiceID1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► ProductServiceID2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► ProductServiceID3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LS1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LT Class

LT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT
RDPCrystal EDI Library
Letter of Recommendation
Declaration Syntax
C# Visual Basic Visual C++
public class LT : DocumentSegment
Public Class LT _
    Inherits DocumentSegment
public ref class LT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LT()()()() | Initializes a new instance of the LT class
 | Description | Element 2
 | Description1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LT


LT Constructor

LT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► LT()()()()
RDPCrystal EDI Library
Initializes a new instance of the LT class
Declaration Syntax
C# Visual Basic Visual C++
public LT()
Public Sub New
public:
LT()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► Description1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LTE Class

LTE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE
RDPCrystal EDI Library
Letter of Recommendation Evaluation
Declaration Syntax
C# Visual Basic Visual C++
public class LTE : DocumentSegment
Public Class LTE _
    Inherits DocumentSegment
public ref class LTE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LTE()()()() | Initializes a new instance of the LTE class
 | CodeListQualifierCode | Element 1
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RatingSummaryValueCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LTE


LTE Constructor

LTE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► LTE()()()()
RDPCrystal EDI Library
Initializes a new instance of the LTE class
Declaration Syntax
C# Visual Basic Visual C++
public LTE()
Public Sub New
public:
LTE()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RatingSummaryValueCode Property

RatingSummaryValueCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► RatingSummaryValueCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RatingSummaryValueCode { get; set; }
Public Property RatingSummaryValueCode As String
    Get
    Set
public:
property String^ RatingSummaryValueCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LTR Class

LTR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR
RDPCrystal EDI Library
Laboratory Test Results
Declaration Syntax
C# Visual Basic Visual C++
public class LTR : DocumentSegment
Public Class LTR _
    Inherits DocumentSegment
public ref class LTR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LTR()()()() | Initializes a new instance of the LTR class
 | CodeListQualifierCode | Element 1
 | CodeListQualifierCode1 | Element 5
 | CompositeUnitOfMeasure | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | IndustryCode1 | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 9
 | RangeMaximum1 | Element 12
 | RangeMinimum | Element 8
 | RangeMinimum1 | Element 11
 | ShipmentStatusCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LTR


LTR Constructor

LTR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► LTR()()()()
RDPCrystal EDI Library
Initializes a new instance of the LTR class
Declaration Syntax
C# Visual Basic Visual C++
public LTR()
Public Sub New
public:
LTR()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


CodeListQualifierCode1 Property

CodeListQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► CodeListQualifierCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode1 { get; set; }
Public Property CodeListQualifierCode1 As String
    Get
    Set
public:
property String^ CodeListQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► GenderCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► IndustryCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► MeasurementValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► RangeMaximum
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMaximum1 Property

RangeMaximum1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► RangeMaximum1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum1 { get; set; }
Public Property RangeMaximum1 As String
    Get
    Set
public:
property String^ RangeMaximum1 {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► RangeMinimum
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum1 Property

RangeMinimum1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► RangeMinimum1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum1 { get; set; }
Public Property RangeMinimum1 As String
    Get
    Set
public:
property String^ RangeMinimum1 {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusCode Property

ShipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► ShipmentStatusCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusCode { get; set; }
Public Property ShipmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LTR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LUC Class

LUC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC
RDPCrystal EDI Library
Loan Underwriting
Declaration Syntax
C# Visual Basic Visual C++
public class LUC : DocumentSegment
Public Class LUC _
    Inherits DocumentSegment
public ref class LUC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LUC()()()() | Initializes a new instance of the LUC class
 | CompositeUseOfProceeds | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanDocumentationTypeCode | Element 1
 | LoanPurposeCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RiskOfLossCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LUC


LUC Constructor

LUC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► LUC()()()()
RDPCrystal EDI Library
Initializes a new instance of the LUC class
Declaration Syntax
C# Visual Basic Visual C++
public LUC()
Public Sub New
public:
LUC()


CompositeUseOfProceeds Property

CompositeUseOfProceeds Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► CompositeUseOfProceeds
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUseOfProceeds CompositeUseOfProceeds { get; set; }
Public Property CompositeUseOfProceeds As CompositeUseOfProceeds
    Get
    Set
public:
property CompositeUseOfProceeds^ CompositeUseOfProceeds {
    CompositeUseOfProceeds^ get ();
    void set (CompositeUseOfProceeds^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanDocumentationTypeCode Property

LoanDocumentationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► LoanDocumentationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanDocumentationTypeCode { get; set; }
Public Property LoanDocumentationTypeCode As String
    Get
    Set
public:
property String^ LoanDocumentationTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanPurposeCode Property

LoanPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► LoanPurposeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPurposeCode { get; set; }
Public Property LoanPurposeCode As String
    Get
    Set
public:
property String^ LoanPurposeCode {
    String^ get ();
    void set (String^ value);
}


RiskOfLossCode Property

RiskOfLossCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► RiskOfLossCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RiskOfLossCode { get; set; }
Public Property RiskOfLossCode As String
    Get
    Set
public:
property String^ RiskOfLossCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LUI Class

LUI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI
RDPCrystal EDI Library
Language Use
Declaration Syntax
C# Visual Basic Visual C++
public class LUI : DocumentSegment
Public Class LUI _
    Inherits DocumentSegment
public ref class LUI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LUI()()()() | Initializes a new instance of the LUI class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | LanguageProficiencyIndicator | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UseOfLanguageIndicator | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LUI


LUI Constructor

LUI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► LUI()()()()
RDPCrystal EDI Library
Initializes a new instance of the LUI class
Declaration Syntax
C# Visual Basic Visual C++
public LUI()
Public Sub New
public:
LUI()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


LanguageProficiencyIndicator Property

LanguageProficiencyIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► LanguageProficiencyIndicator
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageProficiencyIndicator { get; set; }
Public Property LanguageProficiencyIndicator As String
    Get
    Set
public:
property String^ LanguageProficiencyIndicator {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


UseOfLanguageIndicator Property

UseOfLanguageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► UseOfLanguageIndicator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UseOfLanguageIndicator { get; set; }
Public Property UseOfLanguageIndicator As String
    Get
    Set
public:
property String^ UseOfLanguageIndicator {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LUI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LV Class

LV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LV
RDPCrystal EDI Library
Loan Verification
Declaration Syntax
C# Visual Basic Visual C++
public class LV : DocumentSegment
Public Class LV _
    Inherits DocumentSegment
public ref class LV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LV()()()() | Initializes a new instance of the LV class
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanVerificationCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LV


LV Constructor

LV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LV ► LV()()()()
RDPCrystal EDI Library
Initializes a new instance of the LV class
Declaration Syntax
C# Visual Basic Visual C++
public LV()
Public Sub New
public:
LV()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LV ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanVerificationCode Property

LoanVerificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LV ► LoanVerificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LoanVerificationCode { get; set; }
Public Property LoanVerificationCode As String
    Get
    Set
public:
property String^ LoanVerificationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


LX Class

LX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LX
RDPCrystal EDI Library
Assigned Number
Declaration Syntax
C# Visual Basic Visual C++
public class LX : DocumentSegment
Public Class LX _
    Inherits DocumentSegment
public ref class LX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LX()()()() | Initializes a new instance of the LX class
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LX


LX Constructor

LX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LX ► LX()()()()
RDPCrystal EDI Library
Initializes a new instance of the LX class
Declaration Syntax
C# Visual Basic Visual C++
public LX()
Public Sub New
public:
LX()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LX ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► LX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M0 Class

M0 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0
RDPCrystal EDI Library
Assigned Number
Declaration Syntax
C# Visual Basic Visual C++
public class M0 : DocumentSegment
Public Class M0 _
    Inherits DocumentSegment
public ref class M0 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M0()()()() | Initializes a new instance of the M0 class
 | Date | Element 2
 | Date1 | Element 3
 | Date2 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LetterOfCreditNumber | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M0


M0 Constructor

M0 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► M0()()()()
RDPCrystal EDI Library
Initializes a new instance of the M0 class
Declaration Syntax
C# Visual Basic Visual C++
public M0()
Public Sub New
public:
M0()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► Date2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


LetterOfCreditNumber Property

LetterOfCreditNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► LetterOfCreditNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LetterOfCreditNumber { get; set; }
Public Property LetterOfCreditNumber As String
    Get
    Set
public:
property String^ LetterOfCreditNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M0 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M1 Class

M1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1
RDPCrystal EDI Library
Insurance
Declaration Syntax
C# Visual Basic Visual C++
public class M1 : DocumentSegment
Public Class M1 _
    Inherits DocumentSegment
public ref class M1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M1()()()() | Initializes a new instance of the M1 class
 | CarriageValue | Element 2
 | CountryCode | Element 1
 | DeclaredValue | Element 3
 | EntityIdentifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 10
 | Percent1 | Element 12
 | PercentQualifier | Element 9
 | PercentQualifier1 | Element 11
 | RateValueQualifier | Element 4
 | RateValueQualifier1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M1


M1 Constructor

M1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► M1()()()()
RDPCrystal EDI Library
Initializes a new instance of the M1 class
Declaration Syntax
C# Visual Basic Visual C++
public M1()
Public Sub New
public:
M1()


CarriageValue Property

CarriageValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► CarriageValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CarriageValue { get; set; }
Public Property CarriageValue As String
    Get
    Set
public:
property String^ CarriageValue {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► CountryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


DeclaredValue Property

DeclaredValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► DeclaredValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DeclaredValue { get; set; }
Public Property DeclaredValue As String
    Get
    Set
public:
property String^ DeclaredValue {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► FreeFormMessage
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► Percent
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► Percent1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


PercentQualifier Property

PercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► PercentQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier { get; set; }
Public Property PercentQualifier As String
    Get
    Set
public:
property String^ PercentQualifier {
    String^ get ();
    void set (String^ value);
}


PercentQualifier1 Property

PercentQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► PercentQualifier1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier1 { get; set; }
Public Property PercentQualifier1 As String
    Get
    Set
public:
property String^ PercentQualifier1 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► RateValueQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► RateValueQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M10 Class

M10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10
RDPCrystal EDI Library
Manifest Identifying Information
Declaration Syntax
C# Visual Basic Visual C++
public class M10 : DocumentSegment
Public Class M10 _
    Inherits DocumentSegment
public ref class M10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M10()()()() | Initializes a new instance of the M10 class
 | CountryCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | ManifestTypeCode | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 8
 | ReferenceIdentification | Element 7
 | ReferenceIdentification1 | Element 12
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 2
 | VesselCode | Element 4
 | VesselCodeQualifier | Element 10
 | VesselName | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M10


M10 Constructor

M10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► M10()()()()
RDPCrystal EDI Library
Initializes a new instance of the M10 class
Declaration Syntax
C# Visual Basic Visual C++
public M10()
Public Sub New
public:
M10()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► CountryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► FlightVoyageNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ManifestTypeCode Property

ManifestTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► ManifestTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ManifestTypeCode { get; set; }
Public Property ManifestTypeCode As String
    Get
    Set
public:
property String^ ManifestTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► VesselCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselCodeQualifier Property

VesselCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► VesselCodeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCodeQualifier { get; set; }
Public Property VesselCodeQualifier As String
    Get
    Set
public:
property String^ VesselCodeQualifier {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► VesselName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M10 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


M11 Class

M11 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11
RDPCrystal EDI Library
Manifest Bill of Lading Details
Declaration Syntax
C# Visual Basic Visual C++
public class M11 : DocumentSegment
Public Class M11 _
    Inherits DocumentSegment
public ref class M11 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M11()()()() | Initializes a new instance of the M11 class
 | BillOfLadingTypeCode | Element 9
 | BillOfLadingWaybillNumber | Element 1
 | BillOfLadingWaybillNumber1 | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportExceptionCode | Element 17
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 2
 | ManifestUnitCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlaceOfReceiptByPrecarrier | Element 10
 | Quantity | Element 3
 | ShipperExportDeclarationRequirements | Element 16
 | StandardCarrierAlphaCode | Element 12
 | StandardCarrierAlphaCode1 | Element 13
 | StandardCarrierAlphaCode2 | Element 14
 | StandardCarrierAlphaCode3 | Element 15
 | StandardCarrierAlphaCode4 | Element 18
 | StandardCarrierAlphaCode5 | Element 19
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Volume | Element 7
 | VolumeUnitQualifier | Element 8
 | Weight | Element 5
 | WeightUnitCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M11


M11 Constructor

M11 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► M11()()()()
RDPCrystal EDI Library
Initializes a new instance of the M11 class
Declaration Syntax
C# Visual Basic Visual C++
public M11()
Public Sub New
public:
M11()


BillOfLadingTypeCode Property

BillOfLadingTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► BillOfLadingTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingTypeCode { get; set; }
Public Property BillOfLadingTypeCode As String
    Get
    Set
public:
property String^ BillOfLadingTypeCode {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber1 Property

BillOfLadingWaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► BillOfLadingWaybillNumber1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber1 { get; set; }
Public Property BillOfLadingWaybillNumber1 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


ExportExceptionCode Property

ExportExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► ExportExceptionCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ExportExceptionCode { get; set; }
Public Property ExportExceptionCode As String
    Get
    Set
public:
property String^ ExportExceptionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► LocationIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


ManifestUnitCode Property

ManifestUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► ManifestUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ManifestUnitCode { get; set; }
Public Property ManifestUnitCode As String
    Get
    Set
public:
property String^ ManifestUnitCode {
    String^ get ();
    void set (String^ value);
}


PlaceOfReceiptByPrecarrier Property

PlaceOfReceiptByPrecarrier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► PlaceOfReceiptByPrecarrier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PlaceOfReceiptByPrecarrier { get; set; }
Public Property PlaceOfReceiptByPrecarrier As String
    Get
    Set
public:
property String^ PlaceOfReceiptByPrecarrier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ShipperExportDeclarationRequirements Property

ShipperExportDeclarationRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► ShipperExportDeclarationRequirements
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ShipperExportDeclarationRequirements { get; set; }
Public Property ShipperExportDeclarationRequirements As String
    Get
    Set
public:
property String^ ShipperExportDeclarationRequirements {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode3 Property

StandardCarrierAlphaCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► StandardCarrierAlphaCode3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode3 { get; set; }
Public Property StandardCarrierAlphaCode3 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode3 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode4 Property

StandardCarrierAlphaCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► StandardCarrierAlphaCode4
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode4 { get; set; }
Public Property StandardCarrierAlphaCode4 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode4 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode5 Property

StandardCarrierAlphaCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► StandardCarrierAlphaCode5
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode5 { get; set; }
Public Property StandardCarrierAlphaCode5 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode5 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► Volume
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► Weight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► WeightUnitCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M11 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M12 Class

M12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12
RDPCrystal EDI Library
In-bond Identifying Information
Declaration Syntax
C# Visual Basic Visual C++
public class M12 : DocumentSegment
Public Class M12 _
    Inherits DocumentSegment
public ref class M12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M12()()()() | Initializes a new instance of the M12 class
 | CustomsEntryNumber | Element 2
 | CustomsEntryTypeCode | Element 1
 | CustomsShipmentValue | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InbondControlNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 3
 | LocationIdentifier1 | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 9
 | ReferenceIdentificationQualifier | Element 8
 | StandardCarrierAlphaCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 10
 | VesselName | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M12


M12 Constructor

M12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► M12()()()()
RDPCrystal EDI Library
Initializes a new instance of the M12 class
Declaration Syntax
C# Visual Basic Visual C++
public M12()
Public Sub New
public:
M12()


CustomsEntryNumber Property

CustomsEntryNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► CustomsEntryNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryNumber { get; set; }
Public Property CustomsEntryNumber As String
    Get
    Set
public:
property String^ CustomsEntryNumber {
    String^ get ();
    void set (String^ value);
}


CustomsEntryTypeCode Property

CustomsEntryTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► CustomsEntryTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryTypeCode { get; set; }
Public Property CustomsEntryTypeCode As String
    Get
    Set
public:
property String^ CustomsEntryTypeCode {
    String^ get ();
    void set (String^ value);
}


CustomsShipmentValue Property

CustomsShipmentValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► CustomsShipmentValue
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsShipmentValue { get; set; }
Public Property CustomsShipmentValue As String
    Get
    Set
public:
property String^ CustomsShipmentValue {
    String^ get ();
    void set (String^ value);
}


InbondControlNumber Property

InbondControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► InbondControlNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InbondControlNumber { get; set; }
Public Property InbondControlNumber As String
    Get
    Set
public:
property String^ InbondControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► LocationIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► LocationIdentifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► VesselName
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M13 Class

M13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13
RDPCrystal EDI Library
Manifest Amendment Details
Declaration Syntax
C# Visual Basic Visual C++
public class M13 : DocumentSegment
Public Class M13 _
    Inherits DocumentSegment
public ref class M13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M13()()()() | Initializes a new instance of the M13 class
 | ActionCode | Element 7
 | AmendmentCode | Element 6
 | AmendmentTypeCode | Element 3
 | BillOfLadingWaybillNumber | Element 4
 | BillOfLadingWaybillNumber1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 9
 | StandardCarrierAlphaCode2 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M13


M13 Constructor

M13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► M13()()()()
RDPCrystal EDI Library
Initializes a new instance of the M13 class
Declaration Syntax
C# Visual Basic Visual C++
public M13()
Public Sub New
public:
M13()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► ActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AmendmentCode Property

AmendmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► AmendmentCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AmendmentCode { get; set; }
Public Property AmendmentCode As String
    Get
    Set
public:
property String^ AmendmentCode {
    String^ get ();
    void set (String^ value);
}


AmendmentTypeCode Property

AmendmentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► AmendmentTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmendmentTypeCode { get; set; }
Public Property AmendmentTypeCode As String
    Get
    Set
public:
property String^ AmendmentTypeCode {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber1 Property

BillOfLadingWaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► BillOfLadingWaybillNumber1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber1 { get; set; }
Public Property BillOfLadingWaybillNumber1 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► LocationIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M14 Class

M14 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14
RDPCrystal EDI Library
General Order Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class M14 : DocumentSegment
Public Class M14 _
    Inherits DocumentSegment
public ref class M14 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M14()()()() | Initializes a new instance of the M14 class
 | BillOfLadingStatusCode | Element 2
 | BillOfLadingWaybillNumber | Element 1
 | BillOfLadingWaybillNumber1 | Element 6
 | CustomsEntryNumber | Element 3
 | CustomsEntryTypeCode | Element 4
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 9
 | ReferenceIdentification | Element 10
 | StandardCarrierAlphaCode | Element 7
 | StandardCarrierAlphaCode1 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M14


M14 Constructor

M14 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► M14()()()()
RDPCrystal EDI Library
Initializes a new instance of the M14 class
Declaration Syntax
C# Visual Basic Visual C++
public M14()
Public Sub New
public:
M14()


BillOfLadingStatusCode Property

BillOfLadingStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► BillOfLadingStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingStatusCode { get; set; }
Public Property BillOfLadingStatusCode As String
    Get
    Set
public:
property String^ BillOfLadingStatusCode {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber1 Property

BillOfLadingWaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► BillOfLadingWaybillNumber1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber1 { get; set; }
Public Property BillOfLadingWaybillNumber1 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


CustomsEntryNumber Property

CustomsEntryNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► CustomsEntryNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryNumber { get; set; }
Public Property CustomsEntryNumber As String
    Get
    Set
public:
property String^ CustomsEntryNumber {
    String^ get ();
    void set (String^ value);
}


CustomsEntryTypeCode Property

CustomsEntryTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► CustomsEntryTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryTypeCode { get; set; }
Public Property CustomsEntryTypeCode As String
    Get
    Set
public:
property String^ CustomsEntryTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► LocationIdentifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► Quantity
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► ReferenceIdentification
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M14 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M15 Class

M15 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15
RDPCrystal EDI Library
U.S. Customs Events Advisory Details
Declaration Syntax
C# Visual Basic Visual C++
public class M15 : DocumentSegment
Public Class M15 _
    Inherits DocumentSegment
public ref class M15 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M15()()()() | Initializes a new instance of the M15 class
 | CityName | Element 10
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NotificationEntityQualifier | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 8
 | SealNumber | Element 7
 | StandardCarrierAlphaCode | Element 5
 | StandardCarrierAlphaCode1 | Element 9
 | StateOrProvinceCode | Element 11
 | Time | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M15


M15 Constructor

M15 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► M15()()()()
RDPCrystal EDI Library
Initializes a new instance of the M15 class
Declaration Syntax
C# Visual Basic Visual C++
public M15()
Public Sub New
public:
M15()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► CityName
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► LocationIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


NotificationEntityQualifier Property

NotificationEntityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► NotificationEntityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NotificationEntityQualifier { get; set; }
Public Property NotificationEntityQualifier As String
    Get
    Set
public:
property String^ NotificationEntityQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► SealNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M15 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


M2 Class

M2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2
RDPCrystal EDI Library
Sales/Delivery Terms
Declaration Syntax
C# Visual Basic Visual C++
public class M2 : DocumentSegment
Public Class M2 _
    Inherits DocumentSegment
public ref class M2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M2()()()() | Initializes a new instance of the M2 class
 | DeliveryDate | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 8
 | LocationQualifier | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SalesComment | Element 5
 | SalesReferenceDate | Element 3
 | SalesReferenceNumber | Element 2
 | SalesTermsCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationTermsCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M2


M2 Constructor

M2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► M2()()()()
RDPCrystal EDI Library
Initializes a new instance of the M2 class
Declaration Syntax
C# Visual Basic Visual C++
public M2()
Public Sub New
public:
M2()


DeliveryDate Property

DeliveryDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► DeliveryDate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryDate { get; set; }
Public Property DeliveryDate As String
    Get
    Set
public:
property String^ DeliveryDate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► LocationIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► LocationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


SalesComment Property

SalesComment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► SalesComment
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SalesComment { get; set; }
Public Property SalesComment As String
    Get
    Set
public:
property String^ SalesComment {
    String^ get ();
    void set (String^ value);
}


SalesReferenceDate Property

SalesReferenceDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► SalesReferenceDate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SalesReferenceDate { get; set; }
Public Property SalesReferenceDate As String
    Get
    Set
public:
property String^ SalesReferenceDate {
    String^ get ();
    void set (String^ value);
}


SalesReferenceNumber Property

SalesReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► SalesReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SalesReferenceNumber { get; set; }
Public Property SalesReferenceNumber As String
    Get
    Set
public:
property String^ SalesReferenceNumber {
    String^ get ();
    void set (String^ value);
}


SalesTermsCode Property

SalesTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► SalesTermsCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SalesTermsCode { get; set; }
Public Property SalesTermsCode As String
    Get
    Set
public:
property String^ SalesTermsCode {
    String^ get ();
    void set (String^ value);
}


TransportationTermsCode Property

TransportationTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► TransportationTermsCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationTermsCode { get; set; }
Public Property TransportationTermsCode As String
    Get
    Set
public:
property String^ TransportationTermsCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M20 Class

M20 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20
RDPCrystal EDI Library
Permit to Transfer Request Details
Declaration Syntax
C# Visual Basic Visual C++
public class M20 : DocumentSegment
Public Class M20 _
    Inherits DocumentSegment
public ref class M20 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M20()()()() | Initializes a new instance of the M20 class
 | BillOfLadingWaybillNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 3
 | EquipmentNumber | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 6
 | LocationQualifier | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 8
 | ReferenceIdentificationQualifier | Element 7
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M20


M20 Constructor

M20 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► M20()()()()
RDPCrystal EDI Library
Initializes a new instance of the M20 class
Declaration Syntax
C# Visual Basic Visual C++
public M20()
Public Sub New
public:
M20()


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► EquipmentInitial
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► EquipmentNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► FreeformDescription
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► LocationIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► LocationQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M20 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M21 Class

M21 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21
RDPCrystal EDI Library
Supplementary In-Bond Information
Declaration Syntax
C# Visual Basic Visual C++
public class M21 : DocumentSegment
Public Class M21 _
    Inherits DocumentSegment
public ref class M21 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M21()()()() | Initializes a new instance of the M21 class
 | BillOfLadingWaybillNumber | Element 4
 | BillOfLadingWaybillNumber1 | Element 8
 | BillOfLadingWaybillNumber2 | Element 10
 | CustomsEntryTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InbondControlNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 2
 | MasterInbondTypeCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 13
 | StandardCarrierAlphaCode | Element 3
 | StandardCarrierAlphaCode1 | Element 7
 | StandardCarrierAlphaCode2 | Element 9
 | StandardCarrierAlphaCode3 | Element 11
 | StandardCarrierAlphaCode4 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M21


M21 Constructor

M21 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► M21()()()()
RDPCrystal EDI Library
Initializes a new instance of the M21 class
Declaration Syntax
C# Visual Basic Visual C++
public M21()
Public Sub New
public:
M21()


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber1 Property

BillOfLadingWaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► BillOfLadingWaybillNumber1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber1 { get; set; }
Public Property BillOfLadingWaybillNumber1 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber2 Property

BillOfLadingWaybillNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► BillOfLadingWaybillNumber2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber2 { get; set; }
Public Property BillOfLadingWaybillNumber2 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber2 {
    String^ get ();
    void set (String^ value);
}


CustomsEntryTypeCode Property

CustomsEntryTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► CustomsEntryTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryTypeCode { get; set; }
Public Property CustomsEntryTypeCode As String
    Get
    Set
public:
property String^ CustomsEntryTypeCode {
    String^ get ();
    void set (String^ value);
}


InbondControlNumber Property

InbondControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► InbondControlNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InbondControlNumber { get; set; }
Public Property InbondControlNumber As String
    Get
    Set
public:
property String^ InbondControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► LocationIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


MasterInbondTypeCode Property

MasterInbondTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► MasterInbondTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MasterInbondTypeCode { get; set; }
Public Property MasterInbondTypeCode As String
    Get
    Set
public:
property String^ MasterInbondTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► Quantity
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode3 Property

StandardCarrierAlphaCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► StandardCarrierAlphaCode3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode3 { get; set; }
Public Property StandardCarrierAlphaCode3 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode3 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode4 Property

StandardCarrierAlphaCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► StandardCarrierAlphaCode4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode4 { get; set; }
Public Property StandardCarrierAlphaCode4 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M21 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M3 Class

M3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3
RDPCrystal EDI Library
Release
Declaration Syntax
C# Visual Basic Visual C++
public class M3 : DocumentSegment
Public Class M3 _
    Inherits DocumentSegment
public ref class M3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M3()()()() | Initializes a new instance of the M3 class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReleaseCode | Element 1
 | Time | Element 3
 | TimeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M3


M3 Constructor

M3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► M3()()()()
RDPCrystal EDI Library
Initializes a new instance of the M3 class
Declaration Syntax
C# Visual Basic Visual C++
public M3()
Public Sub New
public:
M3()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReleaseCode Property

ReleaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► ReleaseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseCode { get; set; }
Public Property ReleaseCode As String
    Get
    Set
public:
property String^ ReleaseCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► TimeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M7 Class

M7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7
RDPCrystal EDI Library
Seal Numbers
Declaration Syntax
C# Visual Basic Visual C++
public class M7 : DocumentSegment
Public Class M7 _
    Inherits DocumentSegment
public ref class M7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M7()()()() | Initializes a new instance of the M7 class
 | EntityIdentifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SealNumber | Element 1
 | SealNumber1 | Element 2
 | SealNumber2 | Element 3
 | SealNumber3 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M7


M7 Constructor

M7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► M7()()()()
RDPCrystal EDI Library
Initializes a new instance of the M7 class
Declaration Syntax
C# Visual Basic Visual C++
public M7()
Public Sub New
public:
M7()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► SealNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealNumber1 Property

SealNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► SealNumber1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber1 { get; set; }
Public Property SealNumber1 As String
    Get
    Set
public:
property String^ SealNumber1 {
    String^ get ();
    void set (String^ value);
}


SealNumber2 Property

SealNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► SealNumber2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber2 { get; set; }
Public Property SealNumber2 As String
    Get
    Set
public:
property String^ SealNumber2 {
    String^ get ();
    void set (String^ value);
}


SealNumber3 Property

SealNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► SealNumber3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber3 { get; set; }
Public Property SealNumber3 As String
    Get
    Set
public:
property String^ SealNumber3 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


M7A Class

M7A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A
RDPCrystal EDI Library
Seal Number Replacement
Declaration Syntax
C# Visual Basic Visual C++
public class M7A : DocumentSegment
Public Class M7A _
    Inherits DocumentSegment
public ref class M7A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | M7A()()()() | Initializes a new instance of the M7A class
 | Date | Element 3
 | Description | Element 6
 | EntityIdentifierCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SealNumber | Element 1
 | SealNumber1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | M7A


M7A Constructor

M7A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► M7A()()()()
RDPCrystal EDI Library
Initializes a new instance of the M7A class
Declaration Syntax
C# Visual Basic Visual C++
public M7A()
Public Sub New
public:
M7A()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► EntityIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► Name1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► SealNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealNumber1 Property

SealNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► SealNumber1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber1 { get; set; }
Public Property SealNumber1 As String
    Get
    Set
public:
property String^ SealNumber1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► M7A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MAN Class

MAN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN
RDPCrystal EDI Library
Marks and Numbers
Declaration Syntax
C# Visual Basic Visual C++
public class MAN : DocumentSegment
Public Class MAN _
    Inherits DocumentSegment
public ref class MAN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MAN()()()() | Initializes a new instance of the MAN class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarksAndNumbers | Element 2
 | MarksAndNumbers1 | Element 3
 | MarksAndNumbers2 | Element 5
 | MarksAndNumbers3 | Element 6
 | MarksAndNumbersQualifier | Element 1
 | MarksAndNumbersQualifier1 | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MAN


MAN Constructor

MAN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MAN()()()()
RDPCrystal EDI Library
Initializes a new instance of the MAN class
Declaration Syntax
C# Visual Basic Visual C++
public MAN()
Public Sub New
public:
MAN()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarksAndNumbers Property

MarksAndNumbers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MarksAndNumbers
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbers { get; set; }
Public Property MarksAndNumbers As String
    Get
    Set
public:
property String^ MarksAndNumbers {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbers1 Property

MarksAndNumbers1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MarksAndNumbers1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbers1 { get; set; }
Public Property MarksAndNumbers1 As String
    Get
    Set
public:
property String^ MarksAndNumbers1 {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbers2 Property

MarksAndNumbers2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MarksAndNumbers2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbers2 { get; set; }
Public Property MarksAndNumbers2 As String
    Get
    Set
public:
property String^ MarksAndNumbers2 {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbers3 Property

MarksAndNumbers3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MarksAndNumbers3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbers3 { get; set; }
Public Property MarksAndNumbers3 As String
    Get
    Set
public:
property String^ MarksAndNumbers3 {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbersQualifier Property

MarksAndNumbersQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MarksAndNumbersQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbersQualifier { get; set; }
Public Property MarksAndNumbersQualifier As String
    Get
    Set
public:
property String^ MarksAndNumbersQualifier {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbersQualifier1 Property

MarksAndNumbersQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► MarksAndNumbersQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbersQualifier1 { get; set; }
Public Property MarksAndNumbersQualifier1 As String
    Get
    Set
public:
property String^ MarksAndNumbersQualifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MAN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MBL Class

MBL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL
RDPCrystal EDI Library
Bill of Lading
Declaration Syntax
C# Visual Basic Visual C++
public class MBL : DocumentSegment
Public Class MBL _
    Inherits DocumentSegment
public ref class MBL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MBL()()()() | Initializes a new instance of the MBL class
 | ActionCode | Element 3
 | BillOfLadingWaybillNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MBL


MBL Constructor

MBL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► MBL()()()()
RDPCrystal EDI Library
Initializes a new instance of the MBL class
Declaration Syntax
C# Visual Basic Visual C++
public MBL()
Public Sub New
public:
MBL()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► ActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► TypeOfServiceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MBL ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


MC Class

MC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC
RDPCrystal EDI Library
Miscellaneous and Accessorial Charges
Declaration Syntax
C# Visual Basic Visual C++
public class MC : DocumentSegment
Public Class MC _
    Inherits DocumentSegment
public ref class MC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MC()()()() | Initializes a new instance of the MC class
 | AssignedNumber | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rate | Element 3
 | RateValueQualifier | Element 2
 | SpecialChargeDescription | Element 4
 | SpecialChargeOrAllowanceCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MC


MC Constructor

MC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► MC()()()()
RDPCrystal EDI Library
Initializes a new instance of the MC class
Declaration Syntax
C# Visual Basic Visual C++
public MC()
Public Sub New
public:
MC()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► AssignedNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► Rate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


SpecialChargeDescription Property

SpecialChargeDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► SpecialChargeDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeDescription { get; set; }
Public Property SpecialChargeDescription As String
    Get
    Set
public:
property String^ SpecialChargeDescription {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MCD Class

MCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD
RDPCrystal EDI Library
Mortgage Closing Data
Declaration Syntax
C# Visual Basic Visual C++
public class MCD : DocumentSegment
Public Class MCD _
    Inherits DocumentSegment
public ref class MCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MCD()()()() | Initializes a new instance of the MCD class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | MonetaryAmount1 | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MCD


MCD Constructor

MCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► MCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the MCD class
Declaration Syntax
C# Visual Basic Visual C++
public MCD()
Public Sub New
public:
MCD()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MCT Class

MCT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT
RDPCrystal EDI Library
Tariff Accessorial Charges
Declaration Syntax
C# Visual Basic Visual C++
public class MCT : DocumentSegment
Public Class MCT _
    Inherits DocumentSegment
public ref class MCT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MCT()()()() | Initializes a new instance of the MCT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 4
 | RangeMinimum | Element 3
 | Rate | Element 6
 | RateValueQualifier | Element 5
 | SpecialChargeDescription | Element 8
 | SpecialChargeOrAllowanceCode | Element 1
 | TariffReferenceFlag | Element 7
 | TariffValueCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MCT


MCT Constructor

MCT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► MCT()()()()
RDPCrystal EDI Library
Initializes a new instance of the MCT class
Declaration Syntax
C# Visual Basic Visual C++
public MCT()
Public Sub New
public:
MCT()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► RangeMaximum
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► RangeMinimum
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► Rate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► RateValueQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


SpecialChargeDescription Property

SpecialChargeDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► SpecialChargeDescription
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeDescription { get; set; }
Public Property SpecialChargeDescription As String
    Get
    Set
public:
property String^ SpecialChargeDescription {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


TariffReferenceFlag Property

TariffReferenceFlag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► TariffReferenceFlag
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TariffReferenceFlag { get; set; }
Public Property TariffReferenceFlag As String
    Get
    Set
public:
property String^ TariffReferenceFlag {
    String^ get ();
    void set (String^ value);
}


TariffValueCode Property

TariffValueCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► TariffValueCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffValueCode { get; set; }
Public Property TariffValueCode As String
    Get
    Set
public:
property String^ TariffValueCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MCT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MEA Class

MEA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA
RDPCrystal EDI Library
Measurements
Declaration Syntax
C# Visual Basic Visual C++
public class MEA : DocumentSegment
Public Class MEA _
    Inherits DocumentSegment
public ref class MEA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MEA()()()() | Initializes a new instance of the MEA class
 | CompositeUnitOfMeasure | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementAttributeCode | Element 8
 | MeasurementMethodOrDevice | Element 10
 | MeasurementQualifier | Element 2
 | MeasurementReferenceIDCode | Element 1
 | MeasurementSignificanceCode | Element 7
 | MeasurementValue | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 6
 | RangeMinimum | Element 5
 | SurfaceLayerPositionCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MEA


MEA Constructor

MEA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MEA()()()()
RDPCrystal EDI Library
Initializes a new instance of the MEA class
Declaration Syntax
C# Visual Basic Visual C++
public MEA()
Public Sub New
public:
MEA()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementAttributeCode Property

MeasurementAttributeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MeasurementAttributeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementAttributeCode { get; set; }
Public Property MeasurementAttributeCode As String
    Get
    Set
public:
property String^ MeasurementAttributeCode {
    String^ get ();
    void set (String^ value);
}


MeasurementMethodOrDevice Property

MeasurementMethodOrDevice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MeasurementMethodOrDevice
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementMethodOrDevice { get; set; }
Public Property MeasurementMethodOrDevice As String
    Get
    Set
public:
property String^ MeasurementMethodOrDevice {
    String^ get ();
    void set (String^ value);
}


MeasurementQualifier Property

MeasurementQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MeasurementQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementQualifier { get; set; }
Public Property MeasurementQualifier As String
    Get
    Set
public:
property String^ MeasurementQualifier {
    String^ get ();
    void set (String^ value);
}


MeasurementReferenceIDCode Property

MeasurementReferenceIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MeasurementReferenceIDCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementReferenceIDCode { get; set; }
Public Property MeasurementReferenceIDCode As String
    Get
    Set
public:
property String^ MeasurementReferenceIDCode {
    String^ get ();
    void set (String^ value);
}


MeasurementSignificanceCode Property

MeasurementSignificanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MeasurementSignificanceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementSignificanceCode { get; set; }
Public Property MeasurementSignificanceCode As String
    Get
    Set
public:
property String^ MeasurementSignificanceCode {
    String^ get ();
    void set (String^ value);
}


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► MeasurementValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► RangeMaximum
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► RangeMinimum
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MEA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MedicareStatusCode Class

MedicareStatusCode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class MedicareStatusCode : DocumentCompositeElement
Public Class MedicareStatusCode _
    Inherits DocumentCompositeElement
public ref class MedicareStatusCode : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MedicareStatusCode()()()() | Initializes a new instance of the MedicareStatusCode class
 | EligibilityReasonCode1 |
 | EligibilityReasonCode2 |
 | EligibilityReasonCode3 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MedicarePlanCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | MedicareStatusCode


MedicareStatusCode Constructor

MedicareStatusCode Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode ► MedicareStatusCode()()()()
RDPCrystal EDI Library
Initializes a new instance of the MedicareStatusCode class
Declaration Syntax
C# Visual Basic Visual C++
public MedicareStatusCode()
Public Sub New
public:
MedicareStatusCode()


EligibilityReasonCode1 Property

EligibilityReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode ► EligibilityReasonCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityReasonCode1 { get; set; }
Public Property EligibilityReasonCode1 As String
    Get
    Set
public:
property String^ EligibilityReasonCode1 {
    String^ get ();
    void set (String^ value);
}


EligibilityReasonCode2 Property

EligibilityReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode ► EligibilityReasonCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityReasonCode2 { get; set; }
Public Property EligibilityReasonCode2 As String
    Get
    Set
public:
property String^ EligibilityReasonCode2 {
    String^ get ();
    void set (String^ value);
}


EligibilityReasonCode3 Property

EligibilityReasonCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode ► EligibilityReasonCode3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityReasonCode3 { get; set; }
Public Property EligibilityReasonCode3 As String
    Get
    Set
public:
property String^ EligibilityReasonCode3 {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


MedicarePlanCode Property

MedicarePlanCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MedicareStatusCode ► MedicarePlanCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string MedicarePlanCode { get; set; }
Public Property MedicarePlanCode As String
    Get
    Set
public:
property String^ MedicarePlanCode {
    String^ get ();
    void set (String^ value);
}


MI Class

MI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI
RDPCrystal EDI Library
Media Information
Declaration Syntax
C# Visual Basic Visual C++
public class MI : DocumentSegment
Public Class MI _
    Inherits DocumentSegment
public ref class MI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MI()()()() | Initializes a new instance of the MI class
 | Amount | Element 2
 | Amount1 | Element 3
 | Amount2 | Element 4
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MediaTypeIdentifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MI


MI Constructor

MI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► MI()()()()
RDPCrystal EDI Library
Initializes a new instance of the MI class
Declaration Syntax
C# Visual Basic Visual C++
public MI()
Public Sub New
public:
MI()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► Amount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► Amount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Amount2 Property

Amount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► Amount2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount2 { get; set; }
Public Property Amount2 As String
    Get
    Set
public:
property String^ Amount2 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MediaTypeIdentifier Property

MediaTypeIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► MediaTypeIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MediaTypeIdentifier { get; set; }
Public Property MediaTypeIdentifier As String
    Get
    Set
public:
property String^ MediaTypeIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MI1 Class

MI1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1
RDPCrystal EDI Library
Mileage Source
Declaration Syntax
C# Visual Basic Visual C++
public class MI1 : DocumentSegment
Public Class MI1 _
    Inherits DocumentSegment
public ref class MI1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MI1()()()() | Initializes a new instance of the MI1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MI1


MI1 Constructor

MI1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1 ► MI1()()()()
RDPCrystal EDI Library
Initializes a new instance of the MI1 class
Declaration Syntax
C# Visual Basic Visual C++
public MI1()
Public Sub New
public:
MI1()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1 ► Number
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


SourceCode Property

SourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1 ► SourceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SourceCode { get; set; }
Public Property SourceCode As String
    Get
    Set
public:
property String^ SourceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MI1 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


MIA Class

MIA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA
RDPCrystal EDI Library
Medicare Inpatient Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class MIA : DocumentSegment
Public Class MIA _
    Inherits DocumentSegment
public ref class MIA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIA()()()() | Initializes a new instance of the MIA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | MonetaryAmount1 | Element 6
 | MonetaryAmount10 | Element 16
 | MonetaryAmount11 | Element 17
 | MonetaryAmount12 | Element 18
 | MonetaryAmount13 | Element 19
 | MonetaryAmount14 | Element 24
 | MonetaryAmount2 | Element 7
 | MonetaryAmount3 | Element 8
 | MonetaryAmount4 | Element 9
 | MonetaryAmount5 | Element 10
 | MonetaryAmount6 | Element 11
 | MonetaryAmount7 | Element 12
 | MonetaryAmount8 | Element 13
 | MonetaryAmount9 | Element 14
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | Quantity1 | Element 2
 | Quantity2 | Element 3
 | Quantity3 | Element 15
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 20
 | ReferenceIdentification2 | Element 21
 | ReferenceIdentification3 | Element 22
 | ReferenceIdentification4 | Element 23
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIA


MIA Constructor

MIA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MIA()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIA class
Declaration Syntax
C# Visual Basic Visual C++
public MIA()
Public Sub New
public:
MIA()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount10
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount11
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount12
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount13 Property

MonetaryAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount13
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount13 { get; set; }
Public Property MonetaryAmount13 As String
    Get
    Set
public:
property String^ MonetaryAmount13 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount14 Property

MonetaryAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount14
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount14 { get; set; }
Public Property MonetaryAmount14 As String
    Get
    Set
public:
property String^ MonetaryAmount14 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount5
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount6
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount7
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount8
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► MonetaryAmount9
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► Quantity1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► Quantity2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► Quantity3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► ReferenceIdentification2
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► ReferenceIdentification3
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► ReferenceIdentification4
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MIC Class

MIC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC
RDPCrystal EDI Library
Mortgage Insurance Coverage
Declaration Syntax
C# Visual Basic Visual C++
public class MIC : DocumentSegment
Public Class MIC _
    Inherits DocumentSegment
public ref class MIC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIC()()()() | Initializes a new instance of the MIC class
 | Amount | Element 13
 | CompositeUnitOfMeasure | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MortgageInsuranceApplicationType | Element 1
 | MortgageInsuranceCertificateTypeCode | Element 3
 | MortgageInsuranceCoverageTypeCode | Element 2
 | MortgageInsuranceDurationCode | Element 6
 | MortgageInsurancePremiumTypeCode | Element 12
 | MortgageInsuranceRenewalOptionCode | Element 9
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | PremiumRatePatternCode | Element 5
 | PremiumSourceEntityCode | Element 14
 | ProductServiceID | Element 16
 | Quantity | Element 8
 | TermsTypeCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 10
 | YesNoConditionOrResponseCode1 | Element 15
 | YesNoConditionOrResponseCode2 | Element 17
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIC


MIC Constructor

MIC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MIC()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIC class
Declaration Syntax
C# Visual Basic Visual C++
public MIC()
Public Sub New
public:
MIC()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► Amount
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MortgageInsuranceApplicationType Property

MortgageInsuranceApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MortgageInsuranceApplicationType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceApplicationType { get; set; }
Public Property MortgageInsuranceApplicationType As String
    Get
    Set
public:
property String^ MortgageInsuranceApplicationType {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceCertificateTypeCode Property

MortgageInsuranceCertificateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MortgageInsuranceCertificateTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceCertificateTypeCode { get; set; }
Public Property MortgageInsuranceCertificateTypeCode As String
    Get
    Set
public:
property String^ MortgageInsuranceCertificateTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceCoverageTypeCode Property

MortgageInsuranceCoverageTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MortgageInsuranceCoverageTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceCoverageTypeCode { get; set; }
Public Property MortgageInsuranceCoverageTypeCode As String
    Get
    Set
public:
property String^ MortgageInsuranceCoverageTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceDurationCode Property

MortgageInsuranceDurationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MortgageInsuranceDurationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceDurationCode { get; set; }
Public Property MortgageInsuranceDurationCode As String
    Get
    Set
public:
property String^ MortgageInsuranceDurationCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsurancePremiumTypeCode Property

MortgageInsurancePremiumTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MortgageInsurancePremiumTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsurancePremiumTypeCode { get; set; }
Public Property MortgageInsurancePremiumTypeCode As String
    Get
    Set
public:
property String^ MortgageInsurancePremiumTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceRenewalOptionCode Property

MortgageInsuranceRenewalOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► MortgageInsuranceRenewalOptionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceRenewalOptionCode { get; set; }
Public Property MortgageInsuranceRenewalOptionCode As String
    Get
    Set
public:
property String^ MortgageInsuranceRenewalOptionCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PremiumRatePatternCode Property

PremiumRatePatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► PremiumRatePatternCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PremiumRatePatternCode { get; set; }
Public Property PremiumRatePatternCode As String
    Get
    Set
public:
property String^ PremiumRatePatternCode {
    String^ get ();
    void set (String^ value);
}


PremiumSourceEntityCode Property

PremiumSourceEntityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► PremiumSourceEntityCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PremiumSourceEntityCode { get; set; }
Public Property PremiumSourceEntityCode As String
    Get
    Set
public:
property String^ PremiumSourceEntityCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► ProductServiceID
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode Property

TermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► TermsTypeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode { get; set; }
Public Property TermsTypeCode As String
    Get
    Set
public:
property String^ TermsTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIC ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


MII Class

MII Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII
RDPCrystal EDI Library
Mortgage Insurance Information
Declaration Syntax
C# Visual Basic Visual C++
public class MII : DocumentSegment
Public Class MII _
    Inherits DocumentSegment
public ref class MII : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MII()()()() | Initializes a new instance of the MII class
 | CompositeUnitOfMeasure | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | MortgageInsuranceApplicationType | Element 1
 | MortgageInsuranceCertificateTypeCode | Element 4
 | MortgageInsuranceCoverageTypeCode | Element 5
 | MortgageInsuranceDurationCode | Element 6
 | MortgageInsurancePremiumTypeCode | Element 2
 | MortgageInsuranceRenewalOptionCode | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 13
 | ProductServiceID | Element 12
 | ProductServiceIDQualifier | Element 11
 | Quantity | Element 15
 | ReferenceIdentification | Element 10
 | ReferenceIdentificationQualifier | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MII


MII Constructor

MII Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MII()()()()
RDPCrystal EDI Library
Initializes a new instance of the MII class
Declaration Syntax
C# Visual Basic Visual C++
public MII()
Public Sub New
public:
MII()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceApplicationType Property

MortgageInsuranceApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MortgageInsuranceApplicationType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceApplicationType { get; set; }
Public Property MortgageInsuranceApplicationType As String
    Get
    Set
public:
property String^ MortgageInsuranceApplicationType {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceCertificateTypeCode Property

MortgageInsuranceCertificateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MortgageInsuranceCertificateTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceCertificateTypeCode { get; set; }
Public Property MortgageInsuranceCertificateTypeCode As String
    Get
    Set
public:
property String^ MortgageInsuranceCertificateTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceCoverageTypeCode Property

MortgageInsuranceCoverageTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MortgageInsuranceCoverageTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceCoverageTypeCode { get; set; }
Public Property MortgageInsuranceCoverageTypeCode As String
    Get
    Set
public:
property String^ MortgageInsuranceCoverageTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceDurationCode Property

MortgageInsuranceDurationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MortgageInsuranceDurationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceDurationCode { get; set; }
Public Property MortgageInsuranceDurationCode As String
    Get
    Set
public:
property String^ MortgageInsuranceDurationCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsurancePremiumTypeCode Property

MortgageInsurancePremiumTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MortgageInsurancePremiumTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsurancePremiumTypeCode { get; set; }
Public Property MortgageInsurancePremiumTypeCode As String
    Get
    Set
public:
property String^ MortgageInsurancePremiumTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceRenewalOptionCode Property

MortgageInsuranceRenewalOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► MortgageInsuranceRenewalOptionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceRenewalOptionCode { get; set; }
Public Property MortgageInsuranceRenewalOptionCode As String
    Get
    Set
public:
property String^ MortgageInsuranceRenewalOptionCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► Percent
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► ProductServiceID
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► Quantity
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► ReferenceIdentification
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MII ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


MIN Class

MIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN
RDPCrystal EDI Library
Minimum Detail
Declaration Syntax
C# Visual Basic Visual C++
public class MIN : DocumentSegment
Public Class MIN _
    Inherits DocumentSegment
public ref class MIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIN()()()() | Initializes a new instance of the MIN class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadingRestriction | Element 1
 | LoadingRestriction1 | Element 2
 | LoadingRestriction10 | Element 11
 | LoadingRestriction11 | Element 12
 | LoadingRestriction12 | Element 13
 | LoadingRestriction13 | Element 14
 | LoadingRestriction14 | Element 15
 | LoadingRestriction15 | Element 16
 | LoadingRestriction2 | Element 3
 | LoadingRestriction3 | Element 4
 | LoadingRestriction4 | Element 5
 | LoadingRestriction5 | Element 6
 | LoadingRestriction6 | Element 7
 | LoadingRestriction7 | Element 8
 | LoadingRestriction8 | Element 9
 | LoadingRestriction9 | Element 10
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIN


MIN Constructor

MIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► MIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIN class
Declaration Syntax
C# Visual Basic Visual C++
public MIN()
Public Sub New
public:
MIN()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadingRestriction Property

LoadingRestriction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction { get; set; }
Public Property LoadingRestriction As String
    Get
    Set
public:
property String^ LoadingRestriction {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction1 Property

LoadingRestriction1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction1 { get; set; }
Public Property LoadingRestriction1 As String
    Get
    Set
public:
property String^ LoadingRestriction1 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction10 Property

LoadingRestriction10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction10
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction10 { get; set; }
Public Property LoadingRestriction10 As String
    Get
    Set
public:
property String^ LoadingRestriction10 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction11 Property

LoadingRestriction11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction11
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction11 { get; set; }
Public Property LoadingRestriction11 As String
    Get
    Set
public:
property String^ LoadingRestriction11 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction12 Property

LoadingRestriction12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction12
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction12 { get; set; }
Public Property LoadingRestriction12 As String
    Get
    Set
public:
property String^ LoadingRestriction12 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction13 Property

LoadingRestriction13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction13
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction13 { get; set; }
Public Property LoadingRestriction13 As String
    Get
    Set
public:
property String^ LoadingRestriction13 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction14 Property

LoadingRestriction14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction14
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction14 { get; set; }
Public Property LoadingRestriction14 As String
    Get
    Set
public:
property String^ LoadingRestriction14 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction15 Property

LoadingRestriction15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction15
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction15 { get; set; }
Public Property LoadingRestriction15 As String
    Get
    Set
public:
property String^ LoadingRestriction15 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction2 Property

LoadingRestriction2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction2 { get; set; }
Public Property LoadingRestriction2 As String
    Get
    Set
public:
property String^ LoadingRestriction2 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction3 Property

LoadingRestriction3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction3 { get; set; }
Public Property LoadingRestriction3 As String
    Get
    Set
public:
property String^ LoadingRestriction3 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction4 Property

LoadingRestriction4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction4 { get; set; }
Public Property LoadingRestriction4 As String
    Get
    Set
public:
property String^ LoadingRestriction4 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction5 Property

LoadingRestriction5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction5
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction5 { get; set; }
Public Property LoadingRestriction5 As String
    Get
    Set
public:
property String^ LoadingRestriction5 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction6 Property

LoadingRestriction6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction6
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction6 { get; set; }
Public Property LoadingRestriction6 As String
    Get
    Set
public:
property String^ LoadingRestriction6 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction7 Property

LoadingRestriction7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction7
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction7 { get; set; }
Public Property LoadingRestriction7 As String
    Get
    Set
public:
property String^ LoadingRestriction7 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction8 Property

LoadingRestriction8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction8
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction8 { get; set; }
Public Property LoadingRestriction8 As String
    Get
    Set
public:
property String^ LoadingRestriction8 {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction9 Property

LoadingRestriction9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► LoadingRestriction9
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction9 { get; set; }
Public Property LoadingRestriction9 As String
    Get
    Set
public:
property String^ LoadingRestriction9 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MIR Class

MIR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR
RDPCrystal EDI Library
Mortgage Insurance Response
Declaration Syntax
C# Visual Basic Visual C++
public class MIR : DocumentSegment
Public Class MIR _
    Inherits DocumentSegment
public ref class MIR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIR()()()() | Initializes a new instance of the MIR class
 | Amount | Element 6
 | CompositeUnitOfMeasure | Element 7
 | Date | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MortgageInsuranceApplicationType | Element 1
 | MortgageInsuranceCertificateTypeCode | Element 3
 | MortgageInsuranceRenewalOptionCode | Element 11
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | Percent1 | Element 9
 | Percent2 | Element 10
 | Quantity | Element 8
 | ReferenceIdentification | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnderwritingDecisionCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIR


MIR Constructor

MIR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► MIR()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIR class
Declaration Syntax
C# Visual Basic Visual C++
public MIR()
Public Sub New
public:
MIR()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Amount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Date
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MortgageInsuranceApplicationType Property

MortgageInsuranceApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► MortgageInsuranceApplicationType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceApplicationType { get; set; }
Public Property MortgageInsuranceApplicationType As String
    Get
    Set
public:
property String^ MortgageInsuranceApplicationType {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceCertificateTypeCode Property

MortgageInsuranceCertificateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► MortgageInsuranceCertificateTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceCertificateTypeCode { get; set; }
Public Property MortgageInsuranceCertificateTypeCode As String
    Get
    Set
public:
property String^ MortgageInsuranceCertificateTypeCode {
    String^ get ();
    void set (String^ value);
}


MortgageInsuranceRenewalOptionCode Property

MortgageInsuranceRenewalOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► MortgageInsuranceRenewalOptionCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageInsuranceRenewalOptionCode { get; set; }
Public Property MortgageInsuranceRenewalOptionCode As String
    Get
    Set
public:
property String^ MortgageInsuranceRenewalOptionCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Percent1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Percent2 Property

Percent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Percent2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Percent2 { get; set; }
Public Property Percent2 As String
    Get
    Set
public:
property String^ Percent2 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


UnderwritingDecisionCode Property

UnderwritingDecisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► UnderwritingDecisionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnderwritingDecisionCode { get; set; }
Public Property UnderwritingDecisionCode As String
    Get
    Set
public:
property String^ UnderwritingDecisionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MIS Class

MIS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS
RDPCrystal EDI Library
Mortgagee Information Status
Declaration Syntax
C# Visual Basic Visual C++
public class MIS : DocumentSegment
Public Class MIS _
    Inherits DocumentSegment
public ref class MIS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIS()()()() | Initializes a new instance of the MIS class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | JurisdictionCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MortgageeInformationStatusCode | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIS


MIS Constructor

MIS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► MIS()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIS class
Declaration Syntax
C# Visual Basic Visual C++
public MIS()
Public Sub New
public:
MIS()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► DateTimeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


JurisdictionCode Property

JurisdictionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► JurisdictionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string JurisdictionCode { get; set; }
Public Property JurisdictionCode As String
    Get
    Set
public:
property String^ JurisdictionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MortgageeInformationStatusCode Property

MortgageeInformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► MortgageeInformationStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MortgageeInformationStatusCode { get; set; }
Public Property MortgageeInformationStatusCode As String
    Get
    Set
public:
property String^ MortgageeInformationStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MIT Class

MIT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT
RDPCrystal EDI Library
Message Identification
Declaration Syntax
C# Visual Basic Visual C++
public class MIT : DocumentSegment
Public Class MIT _
    Inherits DocumentSegment
public ref class MIT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIT()()()() | Initializes a new instance of the MIT class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PageLengthLines | Element 4
 | PageWidth | Element 3
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIT


MIT Constructor

MIT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► MIT()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIT class
Declaration Syntax
C# Visual Basic Visual C++
public MIT()
Public Sub New
public:
MIT()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PageLengthLines Property

PageLengthLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► PageLengthLines
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PageLengthLines { get; set; }
Public Property PageLengthLines As String
    Get
    Set
public:
property String^ PageLengthLines {
    String^ get ();
    void set (String^ value);
}


PageWidth Property

PageWidth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► PageWidth
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PageWidth { get; set; }
Public Property PageWidth As String
    Get
    Set
public:
property String^ PageWidth {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MIT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MKS Class

MKS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS
RDPCrystal EDI Library
Marks Awarded
Declaration Syntax
C# Visual Basic Visual C++
public class MKS : DocumentSegment
Public Class MKS _
    Inherits DocumentSegment
public ref class MKS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MKS()()()() | Initializes a new instance of the MKS class
 | AcademicGrade | Element 3
 | AcademicGradeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MarkCodeType | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MKS


MKS Constructor

MKS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS ► MKS()()()()
RDPCrystal EDI Library
Initializes a new instance of the MKS class
Declaration Syntax
C# Visual Basic Visual C++
public MKS()
Public Sub New
public:
MKS()


AcademicGrade Property

AcademicGrade Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS ► AcademicGrade
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGrade { get; set; }
Public Property AcademicGrade As String
    Get
    Set
public:
property String^ AcademicGrade {
    String^ get ();
    void set (String^ value);
}


AcademicGradeQualifier Property

AcademicGradeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS ► AcademicGradeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradeQualifier { get; set; }
Public Property AcademicGradeQualifier As String
    Get
    Set
public:
property String^ AcademicGradeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MarkCodeType Property

MarkCodeType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS ► MarkCodeType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MarkCodeType { get; set; }
Public Property MarkCodeType As String
    Get
    Set
public:
property String^ MarkCodeType {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MKS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MLS Class

MLS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS
RDPCrystal EDI Library
Milestone
Declaration Syntax
C# Visual Basic Visual C++
public class MLS : DocumentSegment
Public Class MLS _
    Inherits DocumentSegment
public ref class MLS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MLS()()()() | Initializes a new instance of the MLS class
 | ActionCode | Element 4
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MilestoneNumberIdentification | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WorkStatusCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MLS


MLS Constructor

MLS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► MLS()()()()
RDPCrystal EDI Library
Initializes a new instance of the MLS class
Declaration Syntax
C# Visual Basic Visual C++
public MLS()
Public Sub New
public:
MLS()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► ActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MilestoneNumberIdentification Property

MilestoneNumberIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► MilestoneNumberIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MilestoneNumberIdentification { get; set; }
Public Property MilestoneNumberIdentification As String
    Get
    Set
public:
property String^ MilestoneNumberIdentification {
    String^ get ();
    void set (String^ value);
}


WorkStatusCode Property

WorkStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► WorkStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WorkStatusCode { get; set; }
Public Property WorkStatusCode As String
    Get
    Set
public:
property String^ WorkStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MLS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MNC Class

MNC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC
RDPCrystal EDI Library
Mortgage Note Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class MNC : DocumentSegment
Public Class MNC _
    Inherits DocumentSegment
public ref class MNC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MNC()()()() | Initializes a new instance of the MNC class
 | CodeCategory | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestPaymentCode | Element 11
 | InterestRateCalculationMethodCode | Element 7
 | LienPriorityCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 4
 | LoanRateTypeCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 8
 | Number1 | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 10
 | ProductDescriptionCode | Element 15
 | ProductProcessCharacteristicCode | Element 14
 | ProductServiceID | Element 13
 | ProductServiceIDQualifier | Element 12
 | RealEstateLoanSecurityInstrumentCode | Element 17
 | RealEstateLoanTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfRealEstateAssetCode | Element 16
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MNC


MNC Constructor

MNC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► MNC()()()()
RDPCrystal EDI Library
Initializes a new instance of the MNC class
Declaration Syntax
C# Visual Basic Visual C++
public MNC()
Public Sub New
public:
MNC()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► FrequencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


InterestPaymentCode Property

InterestPaymentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► InterestPaymentCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string InterestPaymentCode { get; set; }
Public Property InterestPaymentCode As String
    Get
    Set
public:
property String^ InterestPaymentCode {
    String^ get ();
    void set (String^ value);
}


InterestRateCalculationMethodCode Property

InterestRateCalculationMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► InterestRateCalculationMethodCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRateCalculationMethodCode { get; set; }
Public Property InterestRateCalculationMethodCode As String
    Get
    Set
public:
property String^ InterestRateCalculationMethodCode {
    String^ get ();
    void set (String^ value);
}


LienPriorityCode Property

LienPriorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► LienPriorityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LienPriorityCode { get; set; }
Public Property LienPriorityCode As String
    Get
    Set
public:
property String^ LienPriorityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► LoanRateTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► Number
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► Number1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► PaymentMethodCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► ProductDescriptionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► ProductServiceID
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanSecurityInstrumentCode Property

RealEstateLoanSecurityInstrumentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► RealEstateLoanSecurityInstrumentCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanSecurityInstrumentCode { get; set; }
Public Property RealEstateLoanSecurityInstrumentCode As String
    Get
    Set
public:
property String^ RealEstateLoanSecurityInstrumentCode {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanTypeCode Property

RealEstateLoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► RealEstateLoanTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanTypeCode { get; set; }
Public Property RealEstateLoanTypeCode As String
    Get
    Set
public:
property String^ RealEstateLoanTypeCode {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode Property

TypeOfRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► TypeOfRealEstateAssetCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode { get; set; }
Public Property TypeOfRealEstateAssetCode As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MNC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MOA Class

MOA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA
RDPCrystal EDI Library
Medicare Outpatient Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class MOA : DocumentSegment
Public Class MOA _
    Inherits DocumentSegment
public ref class MOA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MOA()()()() | Initializes a new instance of the MOA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 8
 | MonetaryAmount2 | Element 9
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 1
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentification2 | Element 5
 | ReferenceIdentification3 | Element 6
 | ReferenceIdentification4 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MOA


MOA Constructor

MOA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► MOA()()()()
RDPCrystal EDI Library
Initializes a new instance of the MOA class
Declaration Syntax
C# Visual Basic Visual C++
public MOA()
Public Sub New
public:
MOA()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► MonetaryAmount1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► MonetaryAmount2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► Percent
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► ReferenceIdentification2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► ReferenceIdentification3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► ReferenceIdentification4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MOA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MPI Class

MPI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI
RDPCrystal EDI Library
Military Personnel Information
Declaration Syntax
C# Visual Basic Visual C++
public class MPI : DocumentSegment
Public Class MPI _
    Inherits DocumentSegment
public ref class MPI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MPI()()()() | Initializes a new instance of the MPI class
 | DateTimePeriod | Element 7
 | DateTimePeriodFormatQualifier | Element 6
 | Description | Element 4
 | EmploymentStatusCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GovernmentServiceAffiliationCode | Element 3
 | InformationStatusCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MilitaryServiceRankCode | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MPI


MPI Constructor

MPI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► MPI()()()()
RDPCrystal EDI Library
Initializes a new instance of the MPI class
Declaration Syntax
C# Visual Basic Visual C++
public MPI()
Public Sub New
public:
MPI()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► EmploymentStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


GovernmentServiceAffiliationCode Property

GovernmentServiceAffiliationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► GovernmentServiceAffiliationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string GovernmentServiceAffiliationCode { get; set; }
Public Property GovernmentServiceAffiliationCode As String
    Get
    Set
public:
property String^ GovernmentServiceAffiliationCode {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► InformationStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MilitaryServiceRankCode Property

MilitaryServiceRankCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► MilitaryServiceRankCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MilitaryServiceRankCode { get; set; }
Public Property MilitaryServiceRankCode As String
    Get
    Set
public:
property String^ MilitaryServiceRankCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MPP Class

MPP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP
RDPCrystal EDI Library
Mortgage Pool Program
Declaration Syntax
C# Visual Basic Visual C++
public class MPP : DocumentSegment
Public Class MPP _
    Inherits DocumentSegment
public ref class MPP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MPP()()()() | Initializes a new instance of the MPP class
 | AccrualRateMethodCode | Element 7
 | CertificationTypeCode | Element 8
 | CodeCategory | Element 1
 | DateTimePeriod | Element 5
 | DateTimePeriodFormatQualifier | Element 4
 | DateTimeQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MPP


MPP Constructor

MPP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► MPP()()()()
RDPCrystal EDI Library
Initializes a new instance of the MPP class
Declaration Syntax
C# Visual Basic Visual C++
public MPP()
Public Sub New
public:
MPP()


AccrualRateMethodCode Property

AccrualRateMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► AccrualRateMethodCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AccrualRateMethodCode { get; set; }
Public Property AccrualRateMethodCode As String
    Get
    Set
public:
property String^ AccrualRateMethodCode {
    String^ get ();
    void set (String^ value);
}


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► CertificationTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► DateTimePeriod
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► MonetaryAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ProgramTypeCode Property

ProgramTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► ProgramTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramTypeCode { get; set; }
Public Property ProgramTypeCode As String
    Get
    Set
public:
property String^ ProgramTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MPP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MRC Class

MRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC
RDPCrystal EDI Library
Mortgagor Response Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class MRC : DocumentSegment
Public Class MRC _
    Inherits DocumentSegment
public ref class MRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MRC()()()() | Initializes a new instance of the MRC class
 | ContactMethodCode | Element 3
 | ContactMethodCode1 | Element 6
 | ContactMethodCode2 | Element 8
 | DateTimePeriod | Element 5
 | EntityIdentifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MortgagorResponseCode | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 7
 | Quantity2 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MRC


MRC Constructor

MRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► MRC()()()()
RDPCrystal EDI Library
Initializes a new instance of the MRC class
Declaration Syntax
C# Visual Basic Visual C++
public MRC()
Public Sub New
public:
MRC()


ContactMethodCode Property

ContactMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► ContactMethodCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ContactMethodCode { get; set; }
Public Property ContactMethodCode As String
    Get
    Set
public:
property String^ ContactMethodCode {
    String^ get ();
    void set (String^ value);
}


ContactMethodCode1 Property

ContactMethodCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► ContactMethodCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContactMethodCode1 { get; set; }
Public Property ContactMethodCode1 As String
    Get
    Set
public:
property String^ ContactMethodCode1 {
    String^ get ();
    void set (String^ value);
}


ContactMethodCode2 Property

ContactMethodCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► ContactMethodCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ContactMethodCode2 { get; set; }
Public Property ContactMethodCode2 As String
    Get
    Set
public:
property String^ ContactMethodCode2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► DateTimePeriod
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MortgagorResponseCode Property

MortgagorResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► MortgagorResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MortgagorResponseCode { get; set; }
Public Property MortgagorResponseCode As String
    Get
    Set
public:
property String^ MortgagorResponseCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► Quantity2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MRC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS Class

MS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS
RDPCrystal EDI Library
Miscellaneous Services
Declaration Syntax
C# Visual Basic Visual C++
public class MS : DocumentSegment
Public Class MS _
    Inherits DocumentSegment
public ref class MS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS()()()() | Initializes a new instance of the MS class
 | AgencyQualifierCode | Element 1
 | AssignedNumber | Element 6
 | Charge | Element 3
 | Charge1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 4
 | SpecialServicesCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS


MS Constructor

MS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► MS()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS class
Declaration Syntax
C# Visual Basic Visual C++
public MS()
Public Sub New
public:
MS()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► AgencyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► AssignedNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Charge Property

Charge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► Charge
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Charge { get; set; }
Public Property Charge As String
    Get
    Set
public:
property String^ Charge {
    String^ get ();
    void set (String^ value);
}


Charge1 Property

Charge1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► Charge1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Charge1 { get; set; }
Public Property Charge1 As String
    Get
    Set
public:
property String^ Charge1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► RateValueQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► SpecialServicesCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS1 Class

MS1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1
RDPCrystal EDI Library
Equipment, Shipment, or Real Property Location
Declaration Syntax
C# Visual Basic Visual C++
public class MS1 : DocumentSegment
Public Class MS1 _
    Inherits DocumentSegment
public ref class MS1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS1()()()() | Initializes a new instance of the MS1 class
 | CityName | Element 1
 | CountryCode | Element 3
 | DirectionIdentifierCode | Element 6
 | DirectionIdentifierCode1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LatitudeCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LongitudeCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS1


MS1 Constructor

MS1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► MS1()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS1 class
Declaration Syntax
C# Visual Basic Visual C++
public MS1()
Public Sub New
public:
MS1()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► CityName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► CountryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


DirectionIdentifierCode Property

DirectionIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► DirectionIdentifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode { get; set; }
Public Property DirectionIdentifierCode As String
    Get
    Set
public:
property String^ DirectionIdentifierCode {
    String^ get ();
    void set (String^ value);
}


DirectionIdentifierCode1 Property

DirectionIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► DirectionIdentifierCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode1 { get; set; }
Public Property DirectionIdentifierCode1 As String
    Get
    Set
public:
property String^ DirectionIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


LatitudeCode Property

LatitudeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► LatitudeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LatitudeCode { get; set; }
Public Property LatitudeCode As String
    Get
    Set
public:
property String^ LatitudeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LongitudeCode Property

LongitudeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► LongitudeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LongitudeCode { get; set; }
Public Property LongitudeCode As String
    Get
    Set
public:
property String^ LongitudeCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS2 Class

MS2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2
RDPCrystal EDI Library
Equipment or Container Owner and Type
Declaration Syntax
C# Visual Basic Visual C++
public class MS2 : DocumentSegment
Public Class MS2 _
    Inherits DocumentSegment
public ref class MS2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS2()()()() | Initializes a new instance of the MS2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 3
 | EquipmentNumber | Element 2
 | EquipmentNumberCheckDigit | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS2


MS2 Constructor

MS2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► MS2()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS2 class
Declaration Syntax
C# Visual Basic Visual C++
public MS2()
Public Sub New
public:
MS2()


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentNumberCheckDigit Property

EquipmentNumberCheckDigit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► EquipmentNumberCheckDigit
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumberCheckDigit { get; set; }
Public Property EquipmentNumberCheckDigit As String
    Get
    Set
public:
property String^ EquipmentNumberCheckDigit {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS3 Class

MS3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3
RDPCrystal EDI Library
Interline Information
Declaration Syntax
C# Visual Basic Visual C++
public class MS3 : DocumentSegment
Public Class MS3 _
    Inherits DocumentSegment
public ref class MS3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS3()()()() | Initializes a new instance of the MS3 class
 | CityName | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RoutingSequenceCode | Element 2
 | StandardCarrierAlphaCode | Element 1
 | StateOrProvinceCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS3


MS3 Constructor

MS3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► MS3()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS3 class
Declaration Syntax
C# Visual Basic Visual C++
public MS3()
Public Sub New
public:
MS3()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► RoutingSequenceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS4 Class

MS4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4
RDPCrystal EDI Library
Shipment or Package Dimensions
Declaration Syntax
C# Visual Basic Visual C++
public class MS4 : DocumentSegment
Public Class MS4 _
    Inherits DocumentSegment
public ref class MS4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS4()()()() | Initializes a new instance of the MS4 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 3
 | Length | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementUnitQualifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Width | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS4


MS4 Constructor

MS4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► MS4()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS4 class
Declaration Syntax
C# Visual Basic Visual C++
public MS4()
Public Sub New
public:
MS4()


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► Height
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► Length
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementUnitQualifier Property

MeasurementUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► MeasurementUnitQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementUnitQualifier { get; set; }
Public Property MeasurementUnitQualifier As String
    Get
    Set
public:
property String^ MeasurementUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► Width
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS5 Class

MS5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5
RDPCrystal EDI Library
Shipment Rates and Charges
Declaration Syntax
C# Visual Basic Visual C++
public class MS5 : DocumentSegment
Public Class MS5 _
    Inherits DocumentSegment
public ref class MS5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS5()()()() | Initializes a new instance of the MS5 class
 | CurrencyCode | Element 5
 | DeclaredValue | Element 1
 | DeclaredValue1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS5


MS5 Constructor

MS5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► MS5()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS5 class
Declaration Syntax
C# Visual Basic Visual C++
public MS5()
Public Sub New
public:
MS5()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► CurrencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


DeclaredValue Property

DeclaredValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► DeclaredValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DeclaredValue { get; set; }
Public Property DeclaredValue As String
    Get
    Set
public:
property String^ DeclaredValue {
    String^ get ();
    void set (String^ value);
}


DeclaredValue1 Property

DeclaredValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► DeclaredValue1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DeclaredValue1 { get; set; }
Public Property DeclaredValue1 As String
    Get
    Set
public:
property String^ DeclaredValue1 {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MS6 Class

MS6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6
RDPCrystal EDI Library
Shipment Quantity and Weight
Declaration Syntax
C# Visual Basic Visual C++
public class MS6 : DocumentSegment
Public Class MS6 _
    Inherits DocumentSegment
public ref class MS6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MS6()()()() | Initializes a new instance of the MS6 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 3
 | WeightQualifier | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MS6


MS6 Constructor

MS6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6 ► MS6()()()()
RDPCrystal EDI Library
Initializes a new instance of the MS6 class
Declaration Syntax
C# Visual Basic Visual C++
public MS6()
Public Sub New
public:
MS6()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6 ► WeightQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MS6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MSG Class

MSG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG
RDPCrystal EDI Library
Message Text
Declaration Syntax
C# Visual Basic Visual C++
public class MSG : DocumentSegment
Public Class MSG _
    Inherits DocumentSegment
public ref class MSG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSG()()()() | Initializes a new instance of the MSG class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrinterCarriageControlCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MSG


MSG Constructor

MSG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG ► MSG()()()()
RDPCrystal EDI Library
Initializes a new instance of the MSG class
Declaration Syntax
C# Visual Basic Visual C++
public MSG()
Public Sub New
public:
MSG()


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG ► FreeFormMessageText
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG ► Number
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


PrinterCarriageControlCode Property

PrinterCarriageControlCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG ► PrinterCarriageControlCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PrinterCarriageControlCode { get; set; }
Public Property PrinterCarriageControlCode As String
    Get
    Set
public:
property String^ PrinterCarriageControlCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MSS Class

MSS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS
RDPCrystal EDI Library
Material Safety Data Sheet Section Information
Declaration Syntax
C# Visual Basic Visual C++
public class MSS : DocumentSegment
Public Class MSS _
    Inherits DocumentSegment
public ref class MSS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSS()()()() | Initializes a new instance of the MSS class
 | ChangeTypeCode | Element 5
 | CountryCode | Element 4
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportSectionNameCode | Element 1
 | ReportSectionNumber | Element 6
 | SafetyCharacteristicHazardCode | Element 7
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MSS


MSS Constructor

MSS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► MSS()()()()
RDPCrystal EDI Library
Initializes a new instance of the MSS class
Declaration Syntax
C# Visual Basic Visual C++
public MSS()
Public Sub New
public:
MSS()


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► ChangeTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReportSectionNameCode Property

ReportSectionNameCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► ReportSectionNameCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportSectionNameCode { get; set; }
Public Property ReportSectionNameCode As String
    Get
    Set
public:
property String^ ReportSectionNameCode {
    String^ get ();
    void set (String^ value);
}


ReportSectionNumber Property

ReportSectionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► ReportSectionNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReportSectionNumber { get; set; }
Public Property ReportSectionNumber As String
    Get
    Set
public:
property String^ ReportSectionNumber {
    String^ get ();
    void set (String^ value);
}


SafetyCharacteristicHazardCode Property

SafetyCharacteristicHazardCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► SafetyCharacteristicHazardCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SafetyCharacteristicHazardCode { get; set; }
Public Property SafetyCharacteristicHazardCode As String
    Get
    Set
public:
property String^ SafetyCharacteristicHazardCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MSS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


MTX Class

MTX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX
RDPCrystal EDI Library
Text
Declaration Syntax
C# Visual Basic Visual C++
public class MTX : DocumentSegment
Public Class MTX _
    Inherits DocumentSegment
public ref class MTX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MTX()()()() | Initializes a new instance of the MTX class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageText | Element 2
 | MessageText1 | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteReferenceCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrinterCarriageControlCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MTX


MTX Constructor

MTX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► MTX()()()()
RDPCrystal EDI Library
Initializes a new instance of the MTX class
Declaration Syntax
C# Visual Basic Visual C++
public MTX()
Public Sub New
public:
MTX()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MessageText Property

MessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► MessageText
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MessageText { get; set; }
Public Property MessageText As String
    Get
    Set
public:
property String^ MessageText {
    String^ get ();
    void set (String^ value);
}


MessageText1 Property

MessageText1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► MessageText1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MessageText1 { get; set; }
Public Property MessageText1 As String
    Get
    Set
public:
property String^ MessageText1 {
    String^ get ();
    void set (String^ value);
}


NoteReferenceCode Property

NoteReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► NoteReferenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NoteReferenceCode { get; set; }
Public Property NoteReferenceCode As String
    Get
    Set
public:
property String^ NoteReferenceCode {
    String^ get ();
    void set (String^ value);
}


PrinterCarriageControlCode Property

PrinterCarriageControlCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► PrinterCarriageControlCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PrinterCarriageControlCode { get; set; }
Public Property PrinterCarriageControlCode As String
    Get
    Set
public:
property String^ PrinterCarriageControlCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► MTX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N1 Class

N1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1
RDPCrystal EDI Library
Name
Declaration Syntax
C# Visual Basic Visual C++
public class N1 : DocumentSegment
Public Class N1 _
    Inherits DocumentSegment
public ref class N1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N1()()()() | Initializes a new instance of the N1 class
 | EntityIdentifierCode | Element 1
 | EntityIdentifierCode1 | Element 6
 | EntityRelationshipCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N1


N1 Constructor

N1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► N1()()()()
RDPCrystal EDI Library
Initializes a new instance of the N1 class
Declaration Syntax
C# Visual Basic Visual C++
public N1()
Public Sub New
public:
N1()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► EntityIdentifierCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► EntityRelationshipCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N10 Class

N10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10
RDPCrystal EDI Library
Quantity and Description
Declaration Syntax
C# Visual Basic Visual C++
public class N10 : DocumentSegment
Public Class N10 _
    Inherits DocumentSegment
public ref class N10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N10()()()() | Initializes a new instance of the N10 class
 | CommodityCode | Element 5
 | CommodityCodeQualifier | Element 4
 | CountryCode | Element 11
 | CountryCode1 | Element 12
 | CurrencyCode | Element 13
 | CustomsShipmentValue | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | ManifestUnitCode | Element 10
 | MarksAndNumbers | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ReferenceIdentification | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 8
 | WeightUnitCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N10


N10 Constructor

N10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► N10()()()()
RDPCrystal EDI Library
Initializes a new instance of the N10 class
Declaration Syntax
C# Visual Basic Visual C++
public N10()
Public Sub New
public:
N10()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► CommodityCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► CountryCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountryCode1 Property

CountryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► CountryCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode1 { get; set; }
Public Property CountryCode1 As String
    Get
    Set
public:
property String^ CountryCode1 {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► CurrencyCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


CustomsShipmentValue Property

CustomsShipmentValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► CustomsShipmentValue
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsShipmentValue { get; set; }
Public Property CustomsShipmentValue As String
    Get
    Set
public:
property String^ CustomsShipmentValue {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► FreeformDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ManifestUnitCode Property

ManifestUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► ManifestUnitCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ManifestUnitCode { get; set; }
Public Property ManifestUnitCode As String
    Get
    Set
public:
property String^ ManifestUnitCode {
    String^ get ();
    void set (String^ value);
}


MarksAndNumbers Property

MarksAndNumbers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► MarksAndNumbers
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MarksAndNumbers { get; set; }
Public Property MarksAndNumbers As String
    Get
    Set
public:
property String^ MarksAndNumbers {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► Weight
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► WeightUnitCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N11 Class

N11 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11
RDPCrystal EDI Library
Store Number
Declaration Syntax
C# Visual Basic Visual C++
public class N11 : DocumentSegment
Public Class N11 _
    Inherits DocumentSegment
public ref class N11 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N11()()()() | Initializes a new instance of the N11 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | StoreNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N11


N11 Constructor

N11 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11 ► N11()()()()
RDPCrystal EDI Library
Initializes a new instance of the N11 class
Declaration Syntax
C# Visual Basic Visual C++
public N11()
Public Sub New
public:
N11()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11 ► LocationIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11 ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StoreNumber Property

StoreNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11 ► StoreNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StoreNumber { get; set; }
Public Property StoreNumber As String
    Get
    Set
public:
property String^ StoreNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N11 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N12 Class

N12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N12
RDPCrystal EDI Library
Equipment Environment
Declaration Syntax
C# Visual Basic Visual C++
public class N12 : DocumentSegment
Public Class N12 _
    Inherits DocumentSegment
public ref class N12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N12()()()() | Initializes a new instance of the N12 class
 | CompositeUnitOfMeasure | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FuelType | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N12


N12 Constructor

N12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N12 ► N12()()()()
RDPCrystal EDI Library
Initializes a new instance of the N12 class
Declaration Syntax
C# Visual Basic Visual C++
public N12()
Public Sub New
public:
N12()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N12 ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


FuelType Property

FuelType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N12 ► FuelType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FuelType { get; set; }
Public Property FuelType As String
    Get
    Set
public:
property String^ FuelType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N2 Class

N2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N2
RDPCrystal EDI Library
Additional Name Information
Declaration Syntax
C# Visual Basic Visual C++
public class N2 : DocumentSegment
Public Class N2 _
    Inherits DocumentSegment
public ref class N2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N2()()()() | Initializes a new instance of the N2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | Name2 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N2


N2 Constructor

N2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N2 ► N2()()()()
RDPCrystal EDI Library
Initializes a new instance of the N2 class
Declaration Syntax
C# Visual Basic Visual C++
public N2()
Public Sub New
public:
N2()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N2 ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N2 ► Name2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N3 Class

N3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N3
RDPCrystal EDI Library
Address Information
Declaration Syntax
C# Visual Basic Visual C++
public class N3 : DocumentSegment
Public Class N3 _
    Inherits DocumentSegment
public ref class N3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N3()()()() | Initializes a new instance of the N3 class
 | AddressInformation1 | Element 1
 | AddressInformation2 | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N3


N3 Constructor

N3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N3 ► N3()()()()
RDPCrystal EDI Library
Initializes a new instance of the N3 class
Declaration Syntax
C# Visual Basic Visual C++
public N3()
Public Sub New
public:
N3()


AddressInformation1 Property

AddressInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N3 ► AddressInformation1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation1 { get; set; }
Public Property AddressInformation1 As String
    Get
    Set
public:
property String^ AddressInformation1 {
    String^ get ();
    void set (String^ value);
}


AddressInformation2 Property

AddressInformation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N3 ► AddressInformation2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation2 { get; set; }
Public Property AddressInformation2 As String
    Get
    Set
public:
property String^ AddressInformation2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N4 Class

N4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4
RDPCrystal EDI Library
Geographic Location
Declaration Syntax
C# Visual Basic Visual C++
public class N4 : DocumentSegment
Public Class N4 _
    Inherits DocumentSegment
public ref class N4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N4()()()() | Initializes a new instance of the N4 class
 | CityName | Element 1
 | CountryCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 6
 | LocationQualifier | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 3
 | StateOrProvinceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N4


N4 Constructor

N4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► N4()()()()
RDPCrystal EDI Library
Initializes a new instance of the N4 class
Declaration Syntax
C# Visual Basic Visual C++
public N4()
Public Sub New
public:
N4()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► CityName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► LocationIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► LocationQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► PostalCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N5 Class

N5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5
RDPCrystal EDI Library
Equipment Ordered
Declaration Syntax
C# Visual Basic Visual C++
public class N5 : DocumentSegment
Public Class N5 _
    Inherits DocumentSegment
public ref class N5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N5()()()() | Initializes a new instance of the N5 class
 | CarTypeCode | Element 4
 | CubicCapacity | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 9
 | EquipmentLength | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 6
 | LadingPercentage | Element 7
 | LadingPercentQualifier | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetricQualifier | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WeightCapacity | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N5


N5 Constructor

N5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► N5()()()()
RDPCrystal EDI Library
Initializes a new instance of the N5 class
Declaration Syntax
C# Visual Basic Visual C++
public N5()
Public Sub New
public:
N5()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► CarTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


CubicCapacity Property

CubicCapacity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► CubicCapacity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CubicCapacity { get; set; }
Public Property CubicCapacity As String
    Get
    Set
public:
property String^ CubicCapacity {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► EquipmentLength
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► Height
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


LadingPercentage Property

LadingPercentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► LadingPercentage
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LadingPercentage { get; set; }
Public Property LadingPercentage As String
    Get
    Set
public:
property String^ LadingPercentage {
    String^ get ();
    void set (String^ value);
}


LadingPercentQualifier Property

LadingPercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► LadingPercentQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LadingPercentQualifier { get; set; }
Public Property LadingPercentQualifier As String
    Get
    Set
public:
property String^ LadingPercentQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MetricQualifier Property

MetricQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► MetricQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MetricQualifier { get; set; }
Public Property MetricQualifier As String
    Get
    Set
public:
property String^ MetricQualifier {
    String^ get ();
    void set (String^ value);
}


WeightCapacity Property

WeightCapacity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► WeightCapacity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightCapacity { get; set; }
Public Property WeightCapacity As String
    Get
    Set
public:
property String^ WeightCapacity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N7 Class

N7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7
RDPCrystal EDI Library
Equipment Details
Declaration Syntax
C# Visual Basic Visual C++
public class N7 : DocumentSegment
Public Class N7 _
    Inherits DocumentSegment
public ref class N7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N7()()()() | Initializes a new instance of the N7 class
 | CarTypeCode | Element 24
 | Dunnage | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 11
 | EquipmentInitial | Element 1
 | EquipmentLength | Element 15
 | EquipmentNumber | Element 2
 | EquipmentNumberCheckDigit | Element 18
 | EquipmentType | Element 22
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 20
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OwnershipCode | Element 10
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Position | Element 14
 | StandardCarrierAlphaCode | Element 12
 | StandardCarrierAlphaCode1 | Element 23
 | TareQualifierCode | Element 16
 | TareWeight | Element 5
 | TemperatureControl | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceCode | Element 19
 | Volume | Element 8
 | VolumeUnitQualifier | Element 9
 | Weight | Element 3
 | WeightAllowance | Element 6
 | WeightQualifier | Element 4
 | WeightUnitCode | Element 17
 | Width | Element 21
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N7


N7 Constructor

N7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► N7()()()()
RDPCrystal EDI Library
Initializes a new instance of the N7 class
Declaration Syntax
C# Visual Basic Visual C++
public N7()
Public Sub New
public:
N7()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► CarTypeCode
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


Dunnage Property

Dunnage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Dunnage
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Dunnage { get; set; }
Public Property Dunnage As String
    Get
    Set
public:
property String^ Dunnage {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► EquipmentLength
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentNumberCheckDigit Property

EquipmentNumberCheckDigit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► EquipmentNumberCheckDigit
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumberCheckDigit { get; set; }
Public Property EquipmentNumberCheckDigit As String
    Get
    Set
public:
property String^ EquipmentNumberCheckDigit {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► EquipmentType
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Height
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OwnershipCode Property

OwnershipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► OwnershipCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string OwnershipCode { get; set; }
Public Property OwnershipCode As String
    Get
    Set
public:
property String^ OwnershipCode {
    String^ get ();
    void set (String^ value);
}


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Position
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


TareQualifierCode Property

TareQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► TareQualifierCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string TareQualifierCode { get; set; }
Public Property TareQualifierCode As String
    Get
    Set
public:
property String^ TareQualifierCode {
    String^ get ();
    void set (String^ value);
}


TareWeight Property

TareWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► TareWeight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TareWeight { get; set; }
Public Property TareWeight As String
    Get
    Set
public:
property String^ TareWeight {
    String^ get ();
    void set (String^ value);
}


TemperatureControl Property

TemperatureControl Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► TemperatureControl
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TemperatureControl { get; set; }
Public Property TemperatureControl As String
    Get
    Set
public:
property String^ TemperatureControl {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► TypeOfServiceCode
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Volume
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightAllowance Property

WeightAllowance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► WeightAllowance
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightAllowance { get; set; }
Public Property WeightAllowance As String
    Get
    Set
public:
property String^ WeightAllowance {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► WeightQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► WeightUnitCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Width
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N7A Class

N7A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A
RDPCrystal EDI Library
Accessorial Equipment Details
Declaration Syntax
C# Visual Basic Visual C++
public class N7A : DocumentSegment
Public Class N7A _
    Inherits DocumentSegment
public ref class N7A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N7A()()()() | Initializes a new instance of the N7A class
 | Diameter | Element 3
 | Diameter1 | Element 5
 | Diameter2 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HoseTypeCode | Element 4
 | InletOrOutletFittingTypeCode | Element 8
 | InletOrOutletMaterialTypeCode | Element 7
 | Length | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadOrDeviceCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MiscellaneousEquipmentCode | Element 9
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N7A


N7A Constructor

N7A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► N7A()()()()
RDPCrystal EDI Library
Initializes a new instance of the N7A class
Declaration Syntax
C# Visual Basic Visual C++
public N7A()
Public Sub New
public:
N7A()


Diameter Property

Diameter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► Diameter
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Diameter { get; set; }
Public Property Diameter As String
    Get
    Set
public:
property String^ Diameter {
    String^ get ();
    void set (String^ value);
}


Diameter1 Property

Diameter1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► Diameter1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Diameter1 { get; set; }
Public Property Diameter1 As String
    Get
    Set
public:
property String^ Diameter1 {
    String^ get ();
    void set (String^ value);
}


Diameter2 Property

Diameter2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► Diameter2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Diameter2 { get; set; }
Public Property Diameter2 As String
    Get
    Set
public:
property String^ Diameter2 {
    String^ get ();
    void set (String^ value);
}


HoseTypeCode Property

HoseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► HoseTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HoseTypeCode { get; set; }
Public Property HoseTypeCode As String
    Get
    Set
public:
property String^ HoseTypeCode {
    String^ get ();
    void set (String^ value);
}


InletOrOutletFittingTypeCode Property

InletOrOutletFittingTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► InletOrOutletFittingTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InletOrOutletFittingTypeCode { get; set; }
Public Property InletOrOutletFittingTypeCode As String
    Get
    Set
public:
property String^ InletOrOutletFittingTypeCode {
    String^ get ();
    void set (String^ value);
}


InletOrOutletMaterialTypeCode Property

InletOrOutletMaterialTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► InletOrOutletMaterialTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InletOrOutletMaterialTypeCode { get; set; }
Public Property InletOrOutletMaterialTypeCode As String
    Get
    Set
public:
property String^ InletOrOutletMaterialTypeCode {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► Length
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadOrDeviceCode Property

LoadOrDeviceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► LoadOrDeviceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoadOrDeviceCode { get; set; }
Public Property LoadOrDeviceCode As String
    Get
    Set
public:
property String^ LoadOrDeviceCode {
    String^ get ();
    void set (String^ value);
}


MiscellaneousEquipmentCode Property

MiscellaneousEquipmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► MiscellaneousEquipmentCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MiscellaneousEquipmentCode { get; set; }
Public Property MiscellaneousEquipmentCode As String
    Get
    Set
public:
property String^ MiscellaneousEquipmentCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N7B Class

N7B Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B
RDPCrystal EDI Library
Additional Equipment Details
Declaration Syntax
C# Visual Basic Visual C++
public class N7B : DocumentSegment
Public Class N7B _
    Inherits DocumentSegment
public ref class N7B : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N7B()()()() | Initializes a new instance of the N7B class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GasketTypeCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadingOrDischargeLocationCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfTankCompartments | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TrailerLiningTypeCode | Element 5
 | VesselMaterialCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N7B


N7B Constructor

N7B Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► N7B()()()()
RDPCrystal EDI Library
Initializes a new instance of the N7B class
Declaration Syntax
C# Visual Basic Visual C++
public N7B()
Public Sub New
public:
N7B()


GasketTypeCode Property

GasketTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► GasketTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string GasketTypeCode { get; set; }
Public Property GasketTypeCode As String
    Get
    Set
public:
property String^ GasketTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadingOrDischargeLocationCode Property

LoadingOrDischargeLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► LoadingOrDischargeLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingOrDischargeLocationCode { get; set; }
Public Property LoadingOrDischargeLocationCode As String
    Get
    Set
public:
property String^ LoadingOrDischargeLocationCode {
    String^ get ();
    void set (String^ value);
}


NumberOfTankCompartments Property

NumberOfTankCompartments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► NumberOfTankCompartments
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTankCompartments { get; set; }
Public Property NumberOfTankCompartments As String
    Get
    Set
public:
property String^ NumberOfTankCompartments {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TrailerLiningTypeCode Property

TrailerLiningTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► TrailerLiningTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TrailerLiningTypeCode { get; set; }
Public Property TrailerLiningTypeCode As String
    Get
    Set
public:
property String^ TrailerLiningTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselMaterialCode Property

VesselMaterialCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► VesselMaterialCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VesselMaterialCode { get; set; }
Public Property VesselMaterialCode As String
    Get
    Set
public:
property String^ VesselMaterialCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N7B ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N8 Class

N8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8
RDPCrystal EDI Library
Waybill Reference
Declaration Syntax
C# Visual Basic Visual C++
public class N8 : DocumentSegment
Public Class N8 _
    Inherits DocumentSegment
public ref class N8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N8()()()() | Initializes a new instance of the N8 class
 | CityName | Element 8
 | CrossReferenceTypeCode | Element 3
 | Date | Element 2
 | Date1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 4
 | EquipmentNumber | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 11
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 10
 | StateOrProvinceCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillNumber | Element 1
 | WaybillNumber1 | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N8


N8 Constructor

N8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► N8()()()()
RDPCrystal EDI Library
Initializes a new instance of the N8 class
Declaration Syntax
C# Visual Basic Visual C++
public N8()
Public Sub New
public:
N8()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► CityName
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CrossReferenceTypeCode Property

CrossReferenceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► CrossReferenceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CrossReferenceTypeCode { get; set; }
Public Property CrossReferenceTypeCode As String
    Get
    Set
public:
property String^ CrossReferenceTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► EquipmentInitial
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► EquipmentNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► WaybillNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


WaybillNumber1 Property

WaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► WaybillNumber1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber1 { get; set; }
Public Property WaybillNumber1 As String
    Get
    Set
public:
property String^ WaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N8A Class

N8A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A
RDPCrystal EDI Library
Additional Reference Information
Declaration Syntax
C# Visual Basic Visual C++
public class N8A : DocumentSegment
Public Class N8A _
    Inherits DocumentSegment
public ref class N8A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N8A()()()() | Initializes a new instance of the N8A class
 | CityName | Element 5
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 9
 | EquipmentNumber | Element 10
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | StandardCarrierAlphaCode | Element 7
 | StateOrProvinceCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillCrossReferenceCode | Element 1
 | WaybillNumber | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N8A


N8A Constructor

N8A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► N8A()()()()
RDPCrystal EDI Library
Initializes a new instance of the N8A class
Declaration Syntax
C# Visual Basic Visual C++
public N8A()
Public Sub New
public:
N8A()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► CityName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► EquipmentInitial
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► EquipmentNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► StateOrProvinceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


WaybillCrossReferenceCode Property

WaybillCrossReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► WaybillCrossReferenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillCrossReferenceCode { get; set; }
Public Property WaybillCrossReferenceCode As String
    Get
    Set
public:
property String^ WaybillCrossReferenceCode {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► WaybillNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N8A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


N9 Class

N9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9
RDPCrystal EDI Library
Reference Identification
Declaration Syntax
C# Visual Basic Visual C++
public class N9 : DocumentSegment
Public Class N9 _
    Inherits DocumentSegment
public ref class N9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N9()()()() | Initializes a new instance of the N9 class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentifier | Element 7
 | Time | Element 5
 | TimeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N9


N9 Constructor

N9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► N9()()()()
RDPCrystal EDI Library
Initializes a new instance of the N9 class
Declaration Syntax
C# Visual Basic Visual C++
public N9()
Public Sub New
public:
N9()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► FreeformDescription
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► ReferenceIdentifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► TimeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► N9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


NA Class

NA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA
RDPCrystal EDI Library
Cross-Reference Equipment
Declaration Syntax
C# Visual Basic Visual C++
public class NA : DocumentSegment
Public Class NA _
    Inherits DocumentSegment
public ref class NA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NA()()()() | Initializes a new instance of the NA class
 | ChassisType | Element 10
 | CrossReferenceTypeCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 3
 | EquipmentLength | Element 8
 | EquipmentNumber | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Position | Element 6
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | StandardCarrierAlphaCode | Element 7
 | StandardCarrierAlphaCode1 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NA


NA Constructor

NA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► NA()()()()
RDPCrystal EDI Library
Initializes a new instance of the NA class
Declaration Syntax
C# Visual Basic Visual C++
public NA()
Public Sub New
public:
NA()


ChassisType Property

ChassisType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► ChassisType
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ChassisType { get; set; }
Public Property ChassisType As String
    Get
    Set
public:
property String^ ChassisType {
    String^ get ();
    void set (String^ value);
}


CrossReferenceTypeCode Property

CrossReferenceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► CrossReferenceTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CrossReferenceTypeCode { get; set; }
Public Property CrossReferenceTypeCode As String
    Get
    Set
public:
property String^ CrossReferenceTypeCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► EquipmentInitial
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► EquipmentLength
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► EquipmentNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► Position
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


NCA Class

NCA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA
RDPCrystal EDI Library
Nonconformance Action
Declaration Syntax
C# Visual Basic Visual C++
public class NCA : DocumentSegment
Public Class NCA _
    Inherits DocumentSegment
public ref class NCA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NCA()()()() | Initializes a new instance of the NCA class
 | AssignedIdentification | Element 1
 | CompositeUnitOfMeasure | Element 5
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonconformanceResultantResponseCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NCA


NCA Constructor

NCA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► NCA()()()()
RDPCrystal EDI Library
Initializes a new instance of the NCA class
Declaration Syntax
C# Visual Basic Visual C++
public NCA()
Public Sub New
public:
NCA()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NonconformanceResultantResponseCode Property

NonconformanceResultantResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► NonconformanceResultantResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NonconformanceResultantResponseCode { get; set; }
Public Property NonconformanceResultantResponseCode As String
    Get
    Set
public:
property String^ NonconformanceResultantResponseCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


NCD Class

NCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD
RDPCrystal EDI Library
Nonconformance Description
Declaration Syntax
C# Visual Basic Visual C++
public class NCD : DocumentSegment
Public Class NCD _
    Inherits DocumentSegment
public ref class NCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NCD()()()() | Initializes a new instance of the NCD class
 | AgencyQualifierCode | Element 5
 | AssignedIdentification | Element 3
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementAttributeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonconformanceDeterminationCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 6
 | ProductProcessCharacteristicCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NCD


NCD Constructor

NCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► NCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the NCD class
Declaration Syntax
C# Visual Basic Visual C++
public NCD()
Public Sub New
public:
NCD()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► AgencyQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► AssignedIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementAttributeCode Property

MeasurementAttributeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► MeasurementAttributeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementAttributeCode { get; set; }
Public Property MeasurementAttributeCode As String
    Get
    Set
public:
property String^ MeasurementAttributeCode {
    String^ get ();
    void set (String^ value);
}


NonconformanceDeterminationCode Property

NonconformanceDeterminationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► NonconformanceDeterminationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NonconformanceDeterminationCode { get; set; }
Public Property NonconformanceDeterminationCode As String
    Get
    Set
public:
property String^ NonconformanceDeterminationCode {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► ProductDescriptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


NM1 Class

NM1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1
RDPCrystal EDI Library
Individual or Organizational Name
Declaration Syntax
C# Visual Basic Visual C++
public class NM1 : DocumentSegment
Public Class NM1 _
    Inherits DocumentSegment
public ref class NM1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NM1()()()() | Initializes a new instance of the NM1 class
 | EntityIdentifierCode | Element 1
 | EntityIdentifierCode1 | Element 11
 | EntityRelationshipCode | Element 10
 | EntityTypeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 9
 | IdentificationCodeQualifier | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameFirst | Element 4
 | NameLastOrOrganizationName | Element 3
 | NameMiddle | Element 5
 | NamePrefix | Element 6
 | NameSuffix | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NM1


NM1 Constructor

NM1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► NM1()()()()
RDPCrystal EDI Library
Initializes a new instance of the NM1 class
Declaration Syntax
C# Visual Basic Visual C++
public NM1()
Public Sub New
public:
NM1()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► EntityIdentifierCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► EntityRelationshipCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}


EntityTypeQualifier Property

EntityTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► EntityTypeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTypeQualifier { get; set; }
Public Property EntityTypeQualifier As String
    Get
    Set
public:
property String^ EntityTypeQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► IdentificationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NameFirst Property

NameFirst Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► NameFirst
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NameFirst { get; set; }
Public Property NameFirst As String
    Get
    Set
public:
property String^ NameFirst {
    String^ get ();
    void set (String^ value);
}


NameLastOrOrganizationName Property

NameLastOrOrganizationName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► NameLastOrOrganizationName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NameLastOrOrganizationName { get; set; }
Public Property NameLastOrOrganizationName As String
    Get
    Set
public:
property String^ NameLastOrOrganizationName {
    String^ get ();
    void set (String^ value);
}


NameMiddle Property

NameMiddle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► NameMiddle
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NameMiddle { get; set; }
Public Property NameMiddle As String
    Get
    Set
public:
property String^ NameMiddle {
    String^ get ();
    void set (String^ value);
}


NamePrefix Property

NamePrefix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► NamePrefix
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NamePrefix { get; set; }
Public Property NamePrefix As String
    Get
    Set
public:
property String^ NamePrefix {
    String^ get ();
    void set (String^ value);
}


NameSuffix Property

NameSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► NameSuffix
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NameSuffix { get; set; }
Public Property NameSuffix As String
    Get
    Set
public:
property String^ NameSuffix {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NM1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


NTE Class

NTE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NTE
RDPCrystal EDI Library
Note/Special Instruction
Declaration Syntax
C# Visual Basic Visual C++
public class NTE : DocumentSegment
Public Class NTE _
    Inherits DocumentSegment
public ref class NTE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NTE()()()() | Initializes a new instance of the NTE class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteReferenceCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NTE


NTE Constructor

NTE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NTE ► NTE()()()()
RDPCrystal EDI Library
Initializes a new instance of the NTE class
Declaration Syntax
C# Visual Basic Visual C++
public NTE()
Public Sub New
public:
NTE()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NTE ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NTE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NoteReferenceCode Property

NoteReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NTE ► NoteReferenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NoteReferenceCode { get; set; }
Public Property NoteReferenceCode As String
    Get
    Set
public:
property String^ NoteReferenceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NTE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


NX1 Class

NX1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1
RDPCrystal EDI Library
Property or Entity Identification
Declaration Syntax
C# Visual Basic Visual C++
public class NX1 : DocumentSegment
Public Class NX1 _
    Inherits DocumentSegment
public ref class NX1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NX1()()()() | Initializes a new instance of the NX1 class
 | EntityIdentifierCode | Element 1
 | EntityIdentifierCode1 | Element 2
 | EntityIdentifierCode2 | Element 3
 | EntityIdentifierCode3 | Element 4
 | EntityIdentifierCode4 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NX1


NX1 Constructor

NX1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► NX1()()()()
RDPCrystal EDI Library
Initializes a new instance of the NX1 class
Declaration Syntax
C# Visual Basic Visual C++
public NX1()
Public Sub New
public:
NX1()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► EntityIdentifierCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode2 Property

EntityIdentifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► EntityIdentifierCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode2 { get; set; }
Public Property EntityIdentifierCode2 As String
    Get
    Set
public:
property String^ EntityIdentifierCode2 {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode3 Property

EntityIdentifierCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► EntityIdentifierCode3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode3 { get; set; }
Public Property EntityIdentifierCode3 As String
    Get
    Set
public:
property String^ EntityIdentifierCode3 {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode4 Property

EntityIdentifierCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► EntityIdentifierCode4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode4 { get; set; }
Public Property EntityIdentifierCode4 As String
    Get
    Set
public:
property String^ EntityIdentifierCode4 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


NX2 Class

NX2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2
RDPCrystal EDI Library
Location ID Component
Declaration Syntax
C# Visual Basic Visual C++
public class NX2 : DocumentSegment
Public Class NX2 _
    Inherits DocumentSegment
public ref class NX2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NX2()()()() | Initializes a new instance of the NX2 class
 | AddressComponentQualifier | Element 1
 | AddressInformation | Element 2
 | CountyDesignator | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NX2


NX2 Constructor

NX2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2 ► NX2()()()()
RDPCrystal EDI Library
Initializes a new instance of the NX2 class
Declaration Syntax
C# Visual Basic Visual C++
public NX2()
Public Sub New
public:
NX2()


AddressComponentQualifier Property

AddressComponentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2 ► AddressComponentQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AddressComponentQualifier { get; set; }
Public Property AddressComponentQualifier As String
    Get
    Set
public:
property String^ AddressComponentQualifier {
    String^ get ();
    void set (String^ value);
}


AddressInformation Property

AddressInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2 ► AddressInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation { get; set; }
Public Property AddressInformation As String
    Get
    Set
public:
property String^ AddressInformation {
    String^ get ();
    void set (String^ value);
}


CountyDesignator Property

CountyDesignator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2 ► CountyDesignator
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountyDesignator { get; set; }
Public Property CountyDesignator As String
    Get
    Set
public:
property String^ CountyDesignator {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► NX2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


OBI Class

OBI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI
RDPCrystal EDI Library
Obligation Information
Declaration Syntax
C# Visual Basic Visual C++
public class OBI : DocumentSegment
Public Class OBI _
    Inherits DocumentSegment
public ref class OBI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OBI()()()() | Initializes a new instance of the OBI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | ObligationTypeCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OBI


OBI Constructor

OBI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► OBI()()()()
RDPCrystal EDI Library
Initializes a new instance of the OBI class
Declaration Syntax
C# Visual Basic Visual C++
public OBI()
Public Sub New
public:
OBI()


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► FrequencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ObligationTypeCode Property

ObligationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► ObligationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ObligationTypeCode { get; set; }
Public Property ObligationTypeCode As String
    Get
    Set
public:
property String^ ObligationTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OBI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


OD Class

OD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD
RDPCrystal EDI Library
Origin and Destination
Declaration Syntax
C# Visual Basic Visual C++
public class OD : DocumentSegment
Public Class OD _
    Inherits DocumentSegment
public ref class OD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OD()()()() | Initializes a new instance of the OD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 3
 | StandardCarrierAlphaCode1 | Element 4
 | StandardPointLocationCode | Element 1
 | StandardPointLocationCode1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OD


OD Constructor

OD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► OD()()()()
RDPCrystal EDI Library
Initializes a new instance of the OD class
Declaration Syntax
C# Visual Basic Visual C++
public OD()
Public Sub New
public:
OD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► StandardPointLocationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


OI Class

OI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI
RDPCrystal EDI Library
Other Health Insurance Information
Declaration Syntax
C# Visual Basic Visual C++
public class OI : DocumentSegment
Public Class OI _
    Inherits DocumentSegment
public ref class OI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OI()()()() | Initializes a new instance of the OI class
 | ClaimFilingIndicatorCode | Element 1
 | ClaimSubmissionReasonCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientSignatureSourceCode | Element 4
 | ProviderAgreementCode | Element 5
 | ReleaseOfInformationCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OI


OI Constructor

OI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► OI()()()()
RDPCrystal EDI Library
Initializes a new instance of the OI class
Declaration Syntax
C# Visual Basic Visual C++
public OI()
Public Sub New
public:
OI()


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}


ClaimSubmissionReasonCode Property

ClaimSubmissionReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► ClaimSubmissionReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmissionReasonCode { get; set; }
Public Property ClaimSubmissionReasonCode As String
    Get
    Set
public:
property String^ ClaimSubmissionReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PatientSignatureSourceCode Property

PatientSignatureSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► PatientSignatureSourceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PatientSignatureSourceCode { get; set; }
Public Property PatientSignatureSourceCode As String
    Get
    Set
public:
property String^ PatientSignatureSourceCode {
    String^ get ();
    void set (String^ value);
}


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► ProviderAgreementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► ReleaseOfInformationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


OID Class

OID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID
RDPCrystal EDI Library
Order Identification Detail
Declaration Syntax
C# Visual Basic Visual C++
public class OID : DocumentSegment
Public Class OID _
    Inherits DocumentSegment
public ref class OID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OID()()()() | Initializes a new instance of the OID class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 2
 | Quantity | Element 5
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | Volume | Element 9
 | VolumeUnitQualifier | Element 8
 | Weight | Element 7
 | WeightUnitCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OID


OID Constructor

OID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► OID()()()()
RDPCrystal EDI Library
Initializes a new instance of the OID class
Declaration Syntax
C# Visual Basic Visual C++
public OID()
Public Sub New
public:
OID()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► Volume
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► Weight
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► WeightUnitCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


OP Class

OP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP
RDPCrystal EDI Library
Other Programs and Services
Declaration Syntax
C# Visual Basic Visual C++
public class OP : DocumentSegment
Public Class OP _
    Inherits DocumentSegment
public ref class OP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OP()()()() | Initializes a new instance of the OP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramAndServicesFundingSourceCode | Element 2
 | ProgramParticipationAndServicesCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OP


OP Constructor

OP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP ► OP()()()()
RDPCrystal EDI Library
Initializes a new instance of the OP class
Declaration Syntax
C# Visual Basic Visual C++
public OP()
Public Sub New
public:
OP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ProgramAndServicesFundingSourceCode Property

ProgramAndServicesFundingSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP ► ProgramAndServicesFundingSourceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramAndServicesFundingSourceCode { get; set; }
Public Property ProgramAndServicesFundingSourceCode As String
    Get
    Set
public:
property String^ ProgramAndServicesFundingSourceCode {
    String^ get ();
    void set (String^ value);
}


ProgramParticipationAndServicesCode Property

ProgramParticipationAndServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP ► ProgramParticipationAndServicesCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramParticipationAndServicesCode { get; set; }
Public Property ProgramParticipationAndServicesCode As String
    Get
    Set
public:
property String^ ProgramParticipationAndServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


OPS Class

OPS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS
RDPCrystal EDI Library
Program Subject Area and Eligibility
Declaration Syntax
C# Visual Basic Visual C++
public class OPS : DocumentSegment
Public Class OPS _
    Inherits DocumentSegment
public ref class OPS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OPS()()()() | Initializes a new instance of the OPS class
 | CompositeUnitOfMeasure | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | InstructionalSettingCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OPS


OPS Constructor

OPS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► OPS()()()()
RDPCrystal EDI Library
Initializes a new instance of the OPS class
Declaration Syntax
C# Visual Basic Visual C++
public OPS()
Public Sub New
public:
OPS()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


InstructionalSettingCode Property

InstructionalSettingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► InstructionalSettingCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InstructionalSettingCode { get; set; }
Public Property InstructionalSettingCode As String
    Get
    Set
public:
property String^ InstructionalSettingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


OPX Class

OPX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX
RDPCrystal EDI Library
Placement Criteria
Declaration Syntax
C# Visual Basic Visual C++
public class OPX : DocumentSegment
Public Class OPX _
    Inherits DocumentSegment
public ref class OPX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OPX()()()() | Initializes a new instance of the OPX class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlacementCriteriaCode | Element 2
 | StatusReasonCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OPX


OPX Constructor

OPX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX ► OPX()()()()
RDPCrystal EDI Library
Initializes a new instance of the OPX class
Declaration Syntax
C# Visual Basic Visual C++
public OPX()
Public Sub New
public:
OPX()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PlacementCriteriaCode Property

PlacementCriteriaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX ► PlacementCriteriaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PlacementCriteriaCode { get; set; }
Public Property PlacementCriteriaCode As String
    Get
    Set
public:
property String^ PlacementCriteriaCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX ► StatusReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OPX ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


OQS Class

OQS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OQS
RDPCrystal EDI Library
Order Quantity Sequence
Declaration Syntax
C# Visual Basic Visual C++
public class OQS : DocumentSegment
Public Class OQS _
    Inherits DocumentSegment
public ref class OQS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OQS()()()() | Initializes a new instance of the OQS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | QuantityOrdered | Element 2
 | SequenceValue | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OQS


OQS Constructor

OQS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OQS ► OQS()()()()
RDPCrystal EDI Library
Initializes a new instance of the OQS class
Declaration Syntax
C# Visual Basic Visual C++
public OQS()
Public Sub New
public:
OQS()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OQS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OQS ► QuantityOrdered
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


SequenceValue Property

SequenceValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OQS ► SequenceValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SequenceValue { get; set; }
Public Property SequenceValue As String
    Get
    Set
public:
property String^ SequenceValue {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OQS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


OralCavityDesignation Class

OralCavityDesignation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class OralCavityDesignation : DocumentCompositeElement
Public Class OralCavityDesignation _
    Inherits DocumentCompositeElement
public ref class OralCavityDesignation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OralCavityDesignation()()()() | Initializes a new instance of the OralCavityDesignation class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OralCavityDesignCode |
 | OralCavityDesignCode1 |
 | OralCavityDesignCode2 |
 | OralCavityDesignCode3 |
 | OralCavityDesignCode4 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | OralCavityDesignation


OralCavityDesignation Constructor

OralCavityDesignation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► OralCavityDesignation()()()()
RDPCrystal EDI Library
Initializes a new instance of the OralCavityDesignation class
Declaration Syntax
C# Visual Basic Visual C++
public OralCavityDesignation()
Public Sub New
public:
OralCavityDesignation()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


OralCavityDesignCode Property

OralCavityDesignCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► OralCavityDesignCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode { get; set; }
Public Property OralCavityDesignCode As String
    Get
    Set
public:
property String^ OralCavityDesignCode {
    String^ get ();
    void set (String^ value);
}


OralCavityDesignCode1 Property

OralCavityDesignCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► OralCavityDesignCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode1 { get; set; }
Public Property OralCavityDesignCode1 As String
    Get
    Set
public:
property String^ OralCavityDesignCode1 {
    String^ get ();
    void set (String^ value);
}


OralCavityDesignCode2 Property

OralCavityDesignCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► OralCavityDesignCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode2 { get; set; }
Public Property OralCavityDesignCode2 As String
    Get
    Set
public:
property String^ OralCavityDesignCode2 {
    String^ get ();
    void set (String^ value);
}


OralCavityDesignCode3 Property

OralCavityDesignCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► OralCavityDesignCode3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode3 { get; set; }
Public Property OralCavityDesignCode3 As String
    Get
    Set
public:
property String^ OralCavityDesignCode3 {
    String^ get ();
    void set (String^ value);
}


OralCavityDesignCode4 Property

OralCavityDesignCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OralCavityDesignation ► OralCavityDesignCode4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode4 { get; set; }
Public Property OralCavityDesignCode4 As String
    Get
    Set
public:
property String^ OralCavityDesignCode4 {
    String^ get ();
    void set (String^ value);
}


OTI Class

OTI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI
RDPCrystal EDI Library
Original Transaction Identification
Declaration Syntax
C# Visual Basic Visual C++
public class OTI : DocumentSegment
Public Class OTI _
    Inherits DocumentSegment
public ref class OTI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OTI()()()() | Initializes a new instance of the OTI class
 | ActionCode | Element 15
 | ApplicationAcknowledgmentCode | Element 1
 | ApplicationReceiverCode | Element 5
 | ApplicationSendeCode | Element 4
 | ApplicationType | Element 14
 | Date | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | StatusReasonCode | Element 17
 | Time | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 16
 | TransactionSetControlNumber | Element 9
 | TransactionSetIdentifierCode | Element 10
 | TransactionSetPurposeCode | Element 12
 | TransactionTypeCode | Element 13
 | VersionReleaseIndustryIdentifierCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OTI


OTI Constructor

OTI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► OTI()()()()
RDPCrystal EDI Library
Initializes a new instance of the OTI class
Declaration Syntax
C# Visual Basic Visual C++
public OTI()
Public Sub New
public:
OTI()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ActionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ApplicationAcknowledgmentCode Property

ApplicationAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ApplicationAcknowledgmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationAcknowledgmentCode { get; set; }
Public Property ApplicationAcknowledgmentCode As String
    Get
    Set
public:
property String^ ApplicationAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}


ApplicationReceiverCode Property

ApplicationReceiverCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ApplicationReceiverCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationReceiverCode { get; set; }
Public Property ApplicationReceiverCode As String
    Get
    Set
public:
property String^ ApplicationReceiverCode {
    String^ get ();
    void set (String^ value);
}


ApplicationSendeCode Property

ApplicationSendeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ApplicationSendeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationSendeCode { get; set; }
Public Property ApplicationSendeCode As String
    Get
    Set
public:
property String^ ApplicationSendeCode {
    String^ get ();
    void set (String^ value);
}


ApplicationType Property

ApplicationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ApplicationType
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationType { get; set; }
Public Property ApplicationType As String
    Get
    Set
public:
property String^ ApplicationType {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► GroupControlNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► StatusReasonCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► Time
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► TransactionHandlingCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► TransactionSetControlNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► TransactionTypeCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► VersionReleaseIndustryIdentifierCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► OTI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


P1 Class

P1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1
RDPCrystal EDI Library
Pick-up
Declaration Syntax
C# Visual Basic Visual C++
public class P1 : DocumentSegment
Public Class P1 _
    Inherits DocumentSegment
public ref class P1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | P1()()()() | Initializes a new instance of the P1 class
 | DateTimeQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 5
 | EquipmentNumber | Element 6
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfShipments | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PickupDate | Element 2
 | PickupOrDeliveryCode | Element 1
 | PickupTime | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | P1


P1 Constructor

P1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► P1()()()()
RDPCrystal EDI Library
Initializes a new instance of the P1 class
Declaration Syntax
C# Visual Basic Visual C++
public P1()
Public Sub New
public:
P1()


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► EquipmentInitial
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► EquipmentNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfShipments Property

NumberOfShipments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► NumberOfShipments
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfShipments { get; set; }
Public Property NumberOfShipments As String
    Get
    Set
public:
property String^ NumberOfShipments {
    String^ get ();
    void set (String^ value);
}


PickupDate Property

PickupDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► PickupDate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PickupDate { get; set; }
Public Property PickupDate As String
    Get
    Set
public:
property String^ PickupDate {
    String^ get ();
    void set (String^ value);
}


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


PickupTime Property

PickupTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► PickupTime
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PickupTime { get; set; }
Public Property PickupTime As String
    Get
    Set
public:
property String^ PickupTime {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


P2 Class

P2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2
RDPCrystal EDI Library
Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class P2 : DocumentSegment
Public Class P2 _
    Inherits DocumentSegment
public ref class P2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | P2()()()() | Initializes a new instance of the P2 class
 | DateTimeQualifier | Element 3
 | DeliveryDate | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PickupOrDeliveryCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | P2


P2 Constructor

P2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2 ► P2()()()()
RDPCrystal EDI Library
Initializes a new instance of the P2 class
Declaration Syntax
C# Visual Basic Visual C++
public P2()
Public Sub New
public:
P2()


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2 ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DeliveryDate Property

DeliveryDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2 ► DeliveryDate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryDate { get; set; }
Public Property DeliveryDate As String
    Get
    Set
public:
property String^ DeliveryDate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2 ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


P4 Class

P4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4
RDPCrystal EDI Library
U.S. Port Information
Declaration Syntax
C# Visual Basic Visual C++
public class P4 : DocumentSegment
Public Class P4 _
    Inherits DocumentSegment
public ref class P4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | P4()()()() | Initializes a new instance of the P4 class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 1
 | LocationIdentifier1 | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | P4


P4 Constructor

P4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► P4()()()()
RDPCrystal EDI Library
Initializes a new instance of the P4 class
Declaration Syntax
C# Visual Basic Visual C++
public P4()
Public Sub New
public:
P4()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► LocationIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► LocationIdentifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


P5 Class

P5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5
RDPCrystal EDI Library
Port Information
Declaration Syntax
C# Visual Basic Visual C++
public class P5 : DocumentSegment
Public Class P5 _
    Inherits DocumentSegment
public ref class P5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | P5()()()() | Initializes a new instance of the P5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 3
 | LocationQualifier | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PortOrTerminalFunctionCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | P5


P5 Constructor

P5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5 ► P5()()()()
RDPCrystal EDI Library
Initializes a new instance of the P5 class
Declaration Syntax
C# Visual Basic Visual C++
public P5()
Public Sub New
public:
P5()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5 ► LocationIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5 ► LocationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


PortOrTerminalFunctionCode Property

PortOrTerminalFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5 ► PortOrTerminalFunctionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PortOrTerminalFunctionCode { get; set; }
Public Property PortOrTerminalFunctionCode As String
    Get
    Set
public:
property String^ PortOrTerminalFunctionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► P5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PAD Class

PAD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD
RDPCrystal EDI Library
Product Adjustment Detail
Declaration Syntax
C# Visual Basic Visual C++
public class PAD : DocumentSegment
Public Class PAD _
    Inherits DocumentSegment
public ref class PAD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAD()()()() | Initializes a new instance of the PAD class
 | AssignedIdentification | Element 1
 | ChangeOrResponseTypeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceMultiplierQualifier | Element 4
 | ProductTransferTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAD


PAD Constructor

PAD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► PAD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAD class
Declaration Syntax
C# Visual Basic Visual C++
public PAD()
Public Sub New
public:
PAD()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


ChangeOrResponseTypeCode Property

ChangeOrResponseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► ChangeOrResponseTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrResponseTypeCode { get; set; }
Public Property ChangeOrResponseTypeCode As String
    Get
    Set
public:
property String^ ChangeOrResponseTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► Multiplier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


PriceMultiplierQualifier Property

PriceMultiplierQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► PriceMultiplierQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PriceMultiplierQualifier { get; set; }
Public Property PriceMultiplierQualifier As String
    Get
    Set
public:
property String^ PriceMultiplierQualifier {
    String^ get ();
    void set (String^ value);
}


ProductTransferTypeCode Property

ProductTransferTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► ProductTransferTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductTransferTypeCode { get; set; }
Public Property ProductTransferTypeCode As String
    Get
    Set
public:
property String^ ProductTransferTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PAI Class

PAI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI
RDPCrystal EDI Library
Print Advertisement Information
Declaration Syntax
C# Visual Basic Visual C++
public class PAI : DocumentSegment
Public Class PAI _
    Inherits DocumentSegment
public ref class PAI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAI()()()() | Initializes a new instance of the PAI class
 | Amount | Element 4
 | Amount1 | Element 5
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAI


PAI Constructor

PAI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► PAI()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAI class
Declaration Syntax
C# Visual Basic Visual C++
public PAI()
Public Sub New
public:
PAI()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► Amount1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► MeasurementValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PAL Class

PAL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL
RDPCrystal EDI Library
Pallet Information
Declaration Syntax
C# Visual Basic Visual C++
public class PAL : DocumentSegment
Public Class PAL _
    Inherits DocumentSegment
public ref class PAL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAL()()()() | Initializes a new instance of the PAL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GrossVolumePerPack | Element 13
 | GrossWeightPerPack | Element 11
 | Height | Element 9
 | InnerPack | Element 16
 | Length | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletBlocks | Element 3
 | PalletExchangeCode | Element 15
 | PalletTiers | Element 2
 | PalletTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | UnitOrBasisForMeasurementCode1 | Element 10
 | UnitOrBasisForMeasurementCode2 | Element 12
 | UnitOrBasisForMeasurementCode3 | Element 14
 | UnitWeight | Element 5
 | Width | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAL


PAL Constructor

PAL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► PAL()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAL class
Declaration Syntax
C# Visual Basic Visual C++
public PAL()
Public Sub New
public:
PAL()


GrossVolumePerPack Property

GrossVolumePerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► GrossVolumePerPack
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string GrossVolumePerPack { get; set; }
Public Property GrossVolumePerPack As String
    Get
    Set
public:
property String^ GrossVolumePerPack {
    String^ get ();
    void set (String^ value);
}


GrossWeightPerPack Property

GrossWeightPerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► GrossWeightPerPack
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string GrossWeightPerPack { get; set; }
Public Property GrossWeightPerPack As String
    Get
    Set
public:
property String^ GrossWeightPerPack {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► Height
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► InnerPack
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► Length
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► Pack
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


PalletBlocks Property

PalletBlocks Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► PalletBlocks
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PalletBlocks { get; set; }
Public Property PalletBlocks As String
    Get
    Set
public:
property String^ PalletBlocks {
    String^ get ();
    void set (String^ value);
}


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► PalletExchangeCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


PalletTiers Property

PalletTiers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► PalletTiers
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PalletTiers { get; set; }
Public Property PalletTiers As String
    Get
    Set
public:
property String^ PalletTiers {
    String^ get ();
    void set (String^ value);
}


PalletTypeCode Property

PalletTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► PalletTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PalletTypeCode { get; set; }
Public Property PalletTypeCode As String
    Get
    Set
public:
property String^ PalletTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


UnitWeight Property

UnitWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► UnitWeight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight { get; set; }
Public Property UnitWeight As String
    Get
    Set
public:
property String^ UnitWeight {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► Width
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PAM Class

PAM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM
RDPCrystal EDI Library
Period Amount
Declaration Syntax
C# Visual Basic Visual C++
public class PAM : DocumentSegment
Public Class PAM _
    Inherits DocumentSegment
public ref class PAM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAM()()()() | Initializes a new instance of the PAM class
 | AmountQualifierCode | Element 4
 | CompositeUnitOfMeasure | Element 3
 | Date | Element 8
 | Date1 | Element 11
 | DateTimeQualifier | Element 7
 | DateTimeQualifier1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 14
 | PercentQualifier | Element 13
 | Quantity | Element 2
 | QuantityQualifier | Element 1
 | Time | Element 9
 | Time1 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 15
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAM


PAM Constructor

PAM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► PAM()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAM class
Declaration Syntax
C# Visual Basic Visual C++
public PAM()
Public Sub New
public:
PAM()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► AmountQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Date1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► DateTimeQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier1 Property

DateTimeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► DateTimeQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier1 { get; set; }
Public Property DateTimeQualifier1 As String
    Get
    Set
public:
property String^ DateTimeQualifier1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Percent
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PercentQualifier Property

PercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► PercentQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier { get; set; }
Public Property PercentQualifier As String
    Get
    Set
public:
property String^ PercentQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Time
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Time1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAM ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PAS Class

PAS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS
RDPCrystal EDI Library
Property Appraisal Summary
Declaration Syntax
C# Visual Basic Visual C++
public class PAS : DocumentSegment
Public Class PAS _
    Inherits DocumentSegment
public ref class PAS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAS()()()() | Initializes a new instance of the PAS class
 | AmountQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImprovementStatusCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PropertyValueEstimateTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAS


PAS Constructor

PAS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► PAS()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAS class
Declaration Syntax
C# Visual Basic Visual C++
public PAS()
Public Sub New
public:
PAS()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


ImprovementStatusCode Property

ImprovementStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► ImprovementStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ImprovementStatusCode { get; set; }
Public Property ImprovementStatusCode As String
    Get
    Set
public:
property String^ ImprovementStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


PropertyValueEstimateTypeCode Property

PropertyValueEstimateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► PropertyValueEstimateTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyValueEstimateTypeCode { get; set; }
Public Property PropertyValueEstimateTypeCode As String
    Get
    Set
public:
property String^ PropertyValueEstimateTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PAT Class

PAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT
RDPCrystal EDI Library
Patient Information
Declaration Syntax
C# Visual Basic Visual C++
public class PAT : DocumentSegment
Public Class PAT _
    Inherits DocumentSegment
public ref class PAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAT()()()() | Initializes a new instance of the PAT class
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | EmploymentStatusCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientLocationCode | Element 2
 | StudentStatusCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 7
 | Weight | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoCondition | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAT


PAT Constructor

PAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► PAT()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAT class
Declaration Syntax
C# Visual Basic Visual C++
public PAT()
Public Sub New
public:
PAT()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► EmploymentStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PatientLocationCode Property

PatientLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► PatientLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PatientLocationCode { get; set; }
Public Property PatientLocationCode As String
    Get
    Set
public:
property String^ PatientLocationCode {
    String^ get ();
    void set (String^ value);
}


StudentStatusCode Property

StudentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► StudentStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StudentStatusCode { get; set; }
Public Property StudentStatusCode As String
    Get
    Set
public:
property String^ StudentStatusCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► Weight
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoCondition Property

YesNoCondition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAT ► YesNoCondition
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoCondition { get; set; }
Public Property YesNoCondition As String
    Get
    Set
public:
property String^ YesNoCondition {
    String^ get ();
    void set (String^ value);
}


PAY Class

PAY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY
RDPCrystal EDI Library
Adjustable Payment Description
Declaration Syntax
C# Visual Basic Visual C++
public class PAY : DocumentSegment
Public Class PAY _
    Inherits DocumentSegment
public ref class PAY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAY()()()() | Initializes a new instance of the PAY class
 | CompositeUnitOfMeasure | Element 7
 | CompositeUnitOfMeasure1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 13
 | MonetaryAmount4 | Element 17
 | MonetaryAmount5 | Element 20
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NegativeAmortizationCapSourceCode | Element 21
 | NegativeAmortizationQualifier | Element 18
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentAdjustmentCode | Element 1
 | Percent | Element 3
 | Percent1 | Element 5
 | Percent2 | Element 11
 | Percent3 | Element 12
 | Percent4 | Element 16
 | Percent5 | Element 19
 | Quantity | Element 8
 | Quantity1 | Element 10
 | Quantity2 | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 14
 | YesNoConditionOrResponseCode1 | Element 22
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAY


PAY Constructor

PAY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► PAY()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAY class
Declaration Syntax
C# Visual Basic Visual C++
public PAY()
Public Sub New
public:
PAY()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► MonetaryAmount3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► MonetaryAmount4
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► MonetaryAmount5
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


NegativeAmortizationCapSourceCode Property

NegativeAmortizationCapSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► NegativeAmortizationCapSourceCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string NegativeAmortizationCapSourceCode { get; set; }
Public Property NegativeAmortizationCapSourceCode As String
    Get
    Set
public:
property String^ NegativeAmortizationCapSourceCode {
    String^ get ();
    void set (String^ value);
}


NegativeAmortizationQualifier Property

NegativeAmortizationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► NegativeAmortizationQualifier
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string NegativeAmortizationQualifier { get; set; }
Public Property NegativeAmortizationQualifier As String
    Get
    Set
public:
property String^ NegativeAmortizationQualifier {
    String^ get ();
    void set (String^ value);
}


PaymentAdjustmentCode Property

PaymentAdjustmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► PaymentAdjustmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentAdjustmentCode { get; set; }
Public Property PaymentAdjustmentCode As String
    Get
    Set
public:
property String^ PaymentAdjustmentCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Percent1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Percent2 Property

Percent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Percent2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Percent2 { get; set; }
Public Property Percent2 As String
    Get
    Set
public:
property String^ Percent2 {
    String^ get ();
    void set (String^ value);
}


Percent3 Property

Percent3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Percent3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Percent3 { get; set; }
Public Property Percent3 As String
    Get
    Set
public:
property String^ Percent3 {
    String^ get ();
    void set (String^ value);
}


Percent4 Property

Percent4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Percent4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Percent4 { get; set; }
Public Property Percent4 As String
    Get
    Set
public:
property String^ Percent4 {
    String^ get ();
    void set (String^ value);
}


Percent5 Property

Percent5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Percent5
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Percent5 { get; set; }
Public Property Percent5 As String
    Get
    Set
public:
property String^ Percent5 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Quantity1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Quantity2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PAY ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


PBI Class

PBI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI
RDPCrystal EDI Library
Problem Identification
Declaration Syntax
C# Visual Basic Visual C++
public class PBI : DocumentSegment
Public Class PBI _
    Inherits DocumentSegment
public ref class PBI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PBI()()()() | Initializes a new instance of the PBI class
 | ActionCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixedFormatInformation | Element 6
 | FixedFormatInformation1 | Element 8
 | FreeFormMessageText | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | Quantity1 | Element 7
 | ReferenceIdentification | Element 1
 | TaxInformationIdentificationNumber | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PBI


PBI Constructor

PBI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► PBI()()()()
RDPCrystal EDI Library
Initializes a new instance of the PBI class
Declaration Syntax
C# Visual Basic Visual C++
public PBI()
Public Sub New
public:
PBI()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


FixedFormatInformation Property

FixedFormatInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► FixedFormatInformation
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation { get; set; }
Public Property FixedFormatInformation As String
    Get
    Set
public:
property String^ FixedFormatInformation {
    String^ get ();
    void set (String^ value);
}


FixedFormatInformation1 Property

FixedFormatInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► FixedFormatInformation1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation1 { get; set; }
Public Property FixedFormatInformation1 As String
    Get
    Set
public:
property String^ FixedFormatInformation1 {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► FreeFormMessageText
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TaxInformationIdentificationNumber Property

TaxInformationIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► TaxInformationIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TaxInformationIdentificationNumber { get; set; }
Public Property TaxInformationIdentificationNumber As String
    Get
    Set
public:
property String^ TaxInformationIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PBI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PCL Class

PCL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL
RDPCrystal EDI Library
Previous College
Declaration Syntax
C# Visual Basic Visual C++
public class PCL : DocumentSegment
Public Class PCL _
    Inherits DocumentSegment
public ref class PCL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PCL()()()() | Initializes a new instance of the PCL class
 | AcademicDegreeCode | Element 5
 | DateTimePeriod | Element 4
 | DateTimePeriod1 | Element 6
 | DateTimePeriodFormatQualifier | Element 3
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PCL


PCL Constructor

PCL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► PCL()()()()
RDPCrystal EDI Library
Initializes a new instance of the PCL class
Declaration Syntax
C# Visual Basic Visual C++
public PCL()
Public Sub New
public:
PCL()


AcademicDegreeCode Property

AcademicDegreeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► AcademicDegreeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicDegreeCode { get; set; }
Public Property AcademicDegreeCode As String
    Get
    Set
public:
property String^ AcademicDegreeCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► DateTimePeriod1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PCR Class

PCR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCR
RDPCrystal EDI Library
Payment Cancellation Request
Declaration Syntax
C# Visual Basic Visual C++
public class PCR : DocumentSegment
Public Class PCR _
    Inherits DocumentSegment
public ref class PCR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PCR()()()() | Initializes a new instance of the PCR class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentCancellationType | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PCR


PCR Constructor

PCR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCR ► PCR()()()()
RDPCrystal EDI Library
Initializes a new instance of the PCR class
Declaration Syntax
C# Visual Basic Visual C++
public PCR()
Public Sub New
public:
PCR()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCR ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


PaymentCancellationType Property

PaymentCancellationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCR ► PaymentCancellationType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentCancellationType { get; set; }
Public Property PaymentCancellationType As String
    Get
    Set
public:
property String^ PaymentCancellationType {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PCS Class

PCS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS
RDPCrystal EDI Library
Product Claim Status
Declaration Syntax
C# Visual Basic Visual C++
public class PCS : DocumentSegment
Public Class PCS _
    Inherits DocumentSegment
public ref class PCS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PCS()()()() | Initializes a new instance of the PCS class
 | AgencyQualifierCode | Element 2
 | AgencyQualifierCode1 | Element 7
 | AuthorizationIdentification | Element 11
 | ClaimResponseReasonCode | Element 4
 | ClaimStatusCode | Element 1
 | Description | Element 10
 | DispositionCode | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FollowupActionCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceSubqualifier | Element 3
 | SourceSubqualifier1 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PCS


PCS Constructor

PCS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► PCS()()()()
RDPCrystal EDI Library
Initializes a new instance of the PCS class
Declaration Syntax
C# Visual Basic Visual C++
public PCS()
Public Sub New
public:
PCS()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode1 Property

AgencyQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► AgencyQualifierCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode1 { get; set; }
Public Property AgencyQualifierCode1 As String
    Get
    Set
public:
property String^ AgencyQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


AuthorizationIdentification Property

AuthorizationIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► AuthorizationIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationIdentification { get; set; }
Public Property AuthorizationIdentification As String
    Get
    Set
public:
property String^ AuthorizationIdentification {
    String^ get ();
    void set (String^ value);
}


ClaimResponseReasonCode Property

ClaimResponseReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► ClaimResponseReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimResponseReasonCode { get; set; }
Public Property ClaimResponseReasonCode As String
    Get
    Set
public:
property String^ ClaimResponseReasonCode {
    String^ get ();
    void set (String^ value);
}


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► ClaimStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► DispositionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


FollowupActionCode Property

FollowupActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► FollowupActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FollowupActionCode { get; set; }
Public Property FollowupActionCode As String
    Get
    Set
public:
property String^ FollowupActionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► SourceSubqualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier1 Property

SourceSubqualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► SourceSubqualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier1 { get; set; }
Public Property SourceSubqualifier1 As String
    Get
    Set
public:
property String^ SourceSubqualifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PCT Class

PCT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCT
RDPCrystal EDI Library
Percent Amounts
Declaration Syntax
C# Visual Basic Visual C++
public class PCT : DocumentSegment
Public Class PCT _
    Inherits DocumentSegment
public ref class PCT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PCT()()()() | Initializes a new instance of the PCT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | PercentQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PCT


PCT Constructor

PCT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCT ► PCT()()()()
RDPCrystal EDI Library
Initializes a new instance of the PCT class
Declaration Syntax
C# Visual Basic Visual C++
public PCT()
Public Sub New
public:
PCT()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCT ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PercentQualifier Property

PercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCT ► PercentQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PercentQualifier { get; set; }
Public Property PercentQualifier As String
    Get
    Set
public:
property String^ PercentQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PCT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PD Class

PD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD
RDPCrystal EDI Library
Pricing Data
Declaration Syntax
C# Visual Basic Visual C++
public class PD : DocumentSegment
Public Class PD _
    Inherits DocumentSegment
public ref class PD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PD()()()() | Initializes a new instance of the PD class
 | BreakdownStructureDetailCode | Element 7
 | CompositeUnitOfMeasure | Element 3
 | Date | Element 2
 | Description | Element 6
 | Description1 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProposalDataDetailIdentifierCode | Element 10
 | Quantity | Element 4
 | ReferenceIdentification | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PD


PD Constructor

PD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► PD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PD class
Declaration Syntax
C# Visual Basic Visual C++
public PD()
Public Sub New
public:
PD()


BreakdownStructureDetailCode Property

BreakdownStructureDetailCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► BreakdownStructureDetailCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string BreakdownStructureDetailCode { get; set; }
Public Property BreakdownStructureDetailCode As String
    Get
    Set
public:
property String^ BreakdownStructureDetailCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Description1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Name1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ProposalDataDetailIdentifierCode Property

ProposalDataDetailIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► ProposalDataDetailIdentifierCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProposalDataDetailIdentifierCode { get; set; }
Public Property ProposalDataDetailIdentifierCode As String
    Get
    Set
public:
property String^ ProposalDataDetailIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PDD Class

PDD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD
RDPCrystal EDI Library
Pricing Data Detail
Declaration Syntax
C# Visual Basic Visual C++
public class PDD : DocumentSegment
Public Class PDD _
    Inherits DocumentSegment
public ref class PDD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDD()()()() | Initializes a new instance of the PDD class
 | AssignedIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | ProposalDataDetailIdentifierCode | Element 5
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PDD


PDD Constructor

PDD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► PDD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PDD class
Declaration Syntax
C# Visual Basic Visual C++
public PDD()
Public Sub New
public:
PDD()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ProposalDataDetailIdentifierCode Property

ProposalDataDetailIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► ProposalDataDetailIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProposalDataDetailIdentifierCode { get; set; }
Public Property ProposalDataDetailIdentifierCode As String
    Get
    Set
public:
property String^ ProposalDataDetailIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PDE Class

PDE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE
RDPCrystal EDI Library
Property Metes and Bounds Description
Declaration Syntax
C# Visual Basic Visual C++
public class PDE : DocumentSegment
Public Class PDE _
    Inherits DocumentSegment
public ref class PDE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDE()()()() | Initializes a new instance of the PDE class
 | CompositeUnitOfMeasure | Element 3
 | DirectionIdentifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PDE


PDE Constructor

PDE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► PDE()()()()
RDPCrystal EDI Library
Initializes a new instance of the PDE class
Declaration Syntax
C# Visual Basic Visual C++
public PDE()
Public Sub New
public:
PDE()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


DirectionIdentifierCode Property

DirectionIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► DirectionIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode { get; set; }
Public Property DirectionIdentifierCode As String
    Get
    Set
public:
property String^ DirectionIdentifierCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► FreeFormMessageText
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► MeasurementValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PDL Class

PDL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL
RDPCrystal EDI Library
Payment Details
Declaration Syntax
C# Visual Basic Visual C++
public class PDL : DocumentSegment
Public Class PDL _
    Inherits DocumentSegment
public ref class PDL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDL()()()() | Initializes a new instance of the PDL class
 | AccountNumber | Element 10
 | AccountNumberQualifier | Element 9
 | AmountQualifierCode | Element 2
 | CreditDebitFlagCode | Element 5
 | DateTimePeriod | Element 12
 | DateTimePeriodFormatQualifier | Element 11
 | DFIIdentificationNumber | Element 8
 | DFIIDNumberQualifier | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 1
 | Percent | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PDL


PDL Constructor

PDL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► PDL()()()()
RDPCrystal EDI Library
Initializes a new instance of the PDL class
Declaration Syntax
C# Visual Basic Visual C++
public PDL()
Public Sub New
public:
PDL()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► AccountNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► AccountNumberQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► DateTimePeriod
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► FrequencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► PaymentMethodCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PDP Class

PDP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP
RDPCrystal EDI Library
Property Description - Personal
Declaration Syntax
C# Visual Basic Visual C++
public class PDP : DocumentSegment
Public Class PDP _
    Inherits DocumentSegment
public ref class PDP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDP()()()() | Initializes a new instance of the PDP class
 | CommodityCode | Element 3
 | CommodityCodeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfPersonalOrBusinessAssetCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PDP


PDP Constructor

PDP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP ► PDP()()()()
RDPCrystal EDI Library
Initializes a new instance of the PDP class
Declaration Syntax
C# Visual Basic Visual C++
public PDP()
Public Sub New
public:
PDP()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TypeOfPersonalOrBusinessAssetCode Property

TypeOfPersonalOrBusinessAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP ► TypeOfPersonalOrBusinessAssetCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfPersonalOrBusinessAssetCode { get; set; }
Public Property TypeOfPersonalOrBusinessAssetCode As String
    Get
    Set
public:
property String^ TypeOfPersonalOrBusinessAssetCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PDR Class

PDR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR
RDPCrystal EDI Library
Property Description - Real
Declaration Syntax
C# Visual Basic Visual C++
public class PDR : DocumentSegment
Public Class PDR _
    Inherits DocumentSegment
public ref class PDR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDR()()()() | Initializes a new instance of the PDR class
 | CodeListQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupancyCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfRealEstateAssetCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PDR


PDR Constructor

PDR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► PDR()()()()
RDPCrystal EDI Library
Initializes a new instance of the PDR class
Declaration Syntax
C# Visual Basic Visual C++
public PDR()
Public Sub New
public:
PDR()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► CodeListQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► IndustryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OccupancyCode Property

OccupancyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► OccupancyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string OccupancyCode { get; set; }
Public Property OccupancyCode As String
    Get
    Set
public:
property String^ OccupancyCode {
    String^ get ();
    void set (String^ value);
}


TypeOfRealEstateAssetCode Property

TypeOfRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► TypeOfRealEstateAssetCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRealEstateAssetCode { get; set; }
Public Property TypeOfRealEstateAssetCode As String
    Get
    Set
public:
property String^ TypeOfRealEstateAssetCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PDS Class

PDS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS
RDPCrystal EDI Library
Property Description/Legal Description
Declaration Syntax
C# Visual Basic Visual C++
public class PDS : DocumentSegment
Public Class PDS _
    Inherits DocumentSegment
public ref class PDS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PDS()()()() | Initializes a new instance of the PDS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PropertyDescriptionQualifier | Element 1
 | ReferenceIdentifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PDS


PDS Constructor

PDS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS ► PDS()()()()
RDPCrystal EDI Library
Initializes a new instance of the PDS class
Declaration Syntax
C# Visual Basic Visual C++
public PDS()
Public Sub New
public:
PDS()


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS ► FreeFormMessageText
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PropertyDescriptionQualifier Property

PropertyDescriptionQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS ► PropertyDescriptionQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyDescriptionQualifier { get; set; }
Public Property PropertyDescriptionQualifier As String
    Get
    Set
public:
property String^ PropertyDescriptionQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS ► ReferenceIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PDS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PEN Class

PEN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN
RDPCrystal EDI Library
Pension Information
Declaration Syntax
C# Visual Basic Visual C++
public class PEN : DocumentSegment
Public Class PEN _
    Inherits DocumentSegment
public ref class PEN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PEN()()()() | Initializes a new instance of the PEN class
 | ContributionCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanTypeCode | Element 8
 | MaintenanceTypeCode | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | ReferenceIdentification | Element 6
 | SpecialProcessingType | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PEN


PEN Constructor

PEN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► PEN()()()()
RDPCrystal EDI Library
Initializes a new instance of the PEN class
Declaration Syntax
C# Visual Basic Visual C++
public PEN()
Public Sub New
public:
PEN()


ContributionCode Property

ContributionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► ContributionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ContributionCode { get; set; }
Public Property ContributionCode As String
    Get
    Set
public:
property String^ ContributionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► LoanTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► Number
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


SpecialProcessingType Property

SpecialProcessingType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► SpecialProcessingType
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialProcessingType { get; set; }
Public Property SpecialProcessingType As String
    Get
    Set
public:
property String^ SpecialProcessingType {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► TransactionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PER Class

PER Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER
RDPCrystal EDI Library
Administrative Communications Contact
Declaration Syntax
C# Visual Basic Visual C++
public class PER : DocumentSegment
Public Class PER _
    Inherits DocumentSegment
public ref class PER : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PER()()()() | Initializes a new instance of the PER class
 | CommunicationNumber | Element 4
 | CommunicationNumber1 | Element 6
 | CommunicationNumber2 | Element 8
 | CommunicationNumberQualifier | Element 3
 | CommunicationNumberQualifier1 | Element 5
 | CommunicationNumberQualifier2 | Element 7
 | ContactFunctionCode | Element 1
 | ContactInquiryReference | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PER


PER Constructor

PER Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► PER()()()()
RDPCrystal EDI Library
Initializes a new instance of the PER class
Declaration Syntax
C# Visual Basic Visual C++
public PER()
Public Sub New
public:
PER()


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► CommunicationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


CommunicationNumber1 Property

CommunicationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► CommunicationNumber1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber1 { get; set; }
Public Property CommunicationNumber1 As String
    Get
    Set
public:
property String^ CommunicationNumber1 {
    String^ get ();
    void set (String^ value);
}


CommunicationNumber2 Property

CommunicationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► CommunicationNumber2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber2 { get; set; }
Public Property CommunicationNumber2 As String
    Get
    Set
public:
property String^ CommunicationNumber2 {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier Property

CommunicationNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► CommunicationNumberQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier { get; set; }
Public Property CommunicationNumberQualifier As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier1 Property

CommunicationNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► CommunicationNumberQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier1 { get; set; }
Public Property CommunicationNumberQualifier1 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}


CommunicationNumberQualifier2 Property

CommunicationNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► CommunicationNumberQualifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier2 { get; set; }
Public Property CommunicationNumberQualifier2 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}


ContactFunctionCode Property

ContactFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► ContactFunctionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContactFunctionCode { get; set; }
Public Property ContactFunctionCode As String
    Get
    Set
public:
property String^ ContactFunctionCode {
    String^ get ();
    void set (String^ value);
}


ContactInquiryReference Property

ContactInquiryReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► ContactInquiryReference
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ContactInquiryReference { get; set; }
Public Property ContactInquiryReference As String
    Get
    Set
public:
property String^ ContactInquiryReference {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PER ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PEX Class

PEX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX
RDPCrystal EDI Library
Property or Housing Expense
Declaration Syntax
C# Visual Basic Visual C++
public class PEX : DocumentSegment
Public Class PEX _
    Inherits DocumentSegment
public ref class PEX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PEX()()()() | Initializes a new instance of the PEX class
 | CompositeUnitOfMeasure | Element 8
 | EntityIdentifierCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneralExpenseQualifier | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 2
 | TaxExemptCode | Element 7
 | TaxTypeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PEX


PEX Constructor

PEX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► PEX()()()()
RDPCrystal EDI Library
Initializes a new instance of the PEX class
Declaration Syntax
C# Visual Basic Visual C++
public PEX()
Public Sub New
public:
PEX()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► EntityIdentifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


GeneralExpenseQualifier Property

GeneralExpenseQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► GeneralExpenseQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string GeneralExpenseQualifier { get; set; }
Public Property GeneralExpenseQualifier As String
    Get
    Set
public:
property String^ GeneralExpenseQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


TaxExemptCode Property

TaxExemptCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► TaxExemptCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TaxExemptCode { get; set; }
Public Property TaxExemptCode As String
    Get
    Set
public:
property String^ TaxExemptCode {
    String^ get ();
    void set (String^ value);
}


TaxTypeCode Property

TaxTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► TaxTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TaxTypeCode { get; set; }
Public Property TaxTypeCode As String
    Get
    Set
public:
property String^ TaxTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PEX ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PI Class

PI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI
RDPCrystal EDI Library
Price Authority Identification
Declaration Syntax
C# Visual Basic Visual C++
public class PI : DocumentSegment
Public Class PI _
    Inherits DocumentSegment
public ref class PI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PI()()()() | Initializes a new instance of the PI class
 | AlternationPrecedenceCode | Element 14
 | AlternationPrecedenceCode1 | Element 15
 | ContractSuffix | Element 7
 | ContractSuffix1 | Element 11
 | Date | Element 12
 | Date1 | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IssuingCarrierIdentifier | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrimaryPublicationAuthorityCode | Element 3
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | RegulatoryAgencyCode | Element 4
 | TariffAgencyCode | Element 5
 | TariffItemNumber | Element 8
 | TariffSection | Element 10
 | TariffSupplementIdentifier | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PI


PI Constructor

PI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► PI()()()()
RDPCrystal EDI Library
Initializes a new instance of the PI class
Declaration Syntax
C# Visual Basic Visual C++
public PI()
Public Sub New
public:
PI()


AlternationPrecedenceCode Property

AlternationPrecedenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► AlternationPrecedenceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AlternationPrecedenceCode { get; set; }
Public Property AlternationPrecedenceCode As String
    Get
    Set
public:
property String^ AlternationPrecedenceCode {
    String^ get ();
    void set (String^ value);
}


AlternationPrecedenceCode1 Property

AlternationPrecedenceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► AlternationPrecedenceCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string AlternationPrecedenceCode1 { get; set; }
Public Property AlternationPrecedenceCode1 As String
    Get
    Set
public:
property String^ AlternationPrecedenceCode1 {
    String^ get ();
    void set (String^ value);
}


ContractSuffix Property

ContractSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► ContractSuffix
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ContractSuffix { get; set; }
Public Property ContractSuffix As String
    Get
    Set
public:
property String^ ContractSuffix {
    String^ get ();
    void set (String^ value);
}


ContractSuffix1 Property

ContractSuffix1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► ContractSuffix1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ContractSuffix1 { get; set; }
Public Property ContractSuffix1 As String
    Get
    Set
public:
property String^ ContractSuffix1 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► Date
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► Date1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


IssuingCarrierIdentifier Property

IssuingCarrierIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► IssuingCarrierIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IssuingCarrierIdentifier { get; set; }
Public Property IssuingCarrierIdentifier As String
    Get
    Set
public:
property String^ IssuingCarrierIdentifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrimaryPublicationAuthorityCode Property

PrimaryPublicationAuthorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► PrimaryPublicationAuthorityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PrimaryPublicationAuthorityCode { get; set; }
Public Property PrimaryPublicationAuthorityCode As String
    Get
    Set
public:
property String^ PrimaryPublicationAuthorityCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


RegulatoryAgencyCode Property

RegulatoryAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► RegulatoryAgencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RegulatoryAgencyCode { get; set; }
Public Property RegulatoryAgencyCode As String
    Get
    Set
public:
property String^ RegulatoryAgencyCode {
    String^ get ();
    void set (String^ value);
}


TariffAgencyCode Property

TariffAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► TariffAgencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAgencyCode { get; set; }
Public Property TariffAgencyCode As String
    Get
    Set
public:
property String^ TariffAgencyCode {
    String^ get ();
    void set (String^ value);
}


TariffItemNumber Property

TariffItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► TariffItemNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemNumber { get; set; }
Public Property TariffItemNumber As String
    Get
    Set
public:
property String^ TariffItemNumber {
    String^ get ();
    void set (String^ value);
}


TariffSection Property

TariffSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► TariffSection
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSection { get; set; }
Public Property TariffSection As String
    Get
    Set
public:
property String^ TariffSection {
    String^ get ();
    void set (String^ value);
}


TariffSupplementIdentifier Property

TariffSupplementIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► TariffSupplementIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSupplementIdentifier { get; set; }
Public Property TariffSupplementIdentifier As String
    Get
    Set
public:
property String^ TariffSupplementIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PID Class

PID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID
RDPCrystal EDI Library
Product/Item Description
Declaration Syntax
C# Visual Basic Visual C++
public class PID : DocumentSegment
Public Class PID _
    Inherits DocumentSegment
public ref class PID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PID()()()() | Initializes a new instance of the PID class
 | AgencyQualifierCode | Element 3
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemDescriptionType | Element 1
 | LanguageCode | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 4
 | ProductProcessCharacteristicCode | Element 2
 | SourceSubqualifier | Element 7
 | SurfaceLayerPositionCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PID


PID Constructor

PID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► PID()()()()
RDPCrystal EDI Library
Initializes a new instance of the PID class
Declaration Syntax
C# Visual Basic Visual C++
public PID()
Public Sub New
public:
PID()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ItemDescriptionType Property

ItemDescriptionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► ItemDescriptionType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDescriptionType { get; set; }
Public Property ItemDescriptionType As String
    Get
    Set
public:
property String^ ItemDescriptionType {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► LanguageCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► ProductDescriptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► SourceSubqualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PID ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PIN Class

PIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN
RDPCrystal EDI Library
Previous Incident
Declaration Syntax
C# Visual Basic Visual C++
public class PIN : DocumentSegment
Public Class PIN _
    Inherits DocumentSegment
public ref class PIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PIN()()()() | Initializes a new instance of the PIN class
 | AssignedNumber | Element 1
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PIN


PIN Constructor

PIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► PIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the PIN class
Declaration Syntax
C# Visual Basic Visual C++
public PIN()
Public Sub New
public:
PIN()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► IndustryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PIN ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PKD Class

PKD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD
RDPCrystal EDI Library
Packaging Description
Declaration Syntax
C# Visual Basic Visual C++
public class PKD : DocumentSegment
Public Class PKD _
    Inherits DocumentSegment
public ref class PKD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PKD()()()() | Initializes a new instance of the PKD class
 | AgencyQualifierCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OwnershipCode | Element 5
 | PackagingCode | Element 1
 | PackagingDescriptionCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceSubqualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PKD


PKD Constructor

PKD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► PKD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PKD class
Declaration Syntax
C# Visual Basic Visual C++
public PKD()
Public Sub New
public:
PKD()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OwnershipCode Property

OwnershipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► OwnershipCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string OwnershipCode { get; set; }
Public Property OwnershipCode As String
    Get
    Set
public:
property String^ OwnershipCode {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► PackagingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


PackagingDescriptionCode Property

PackagingDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► PackagingDescriptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingDescriptionCode { get; set; }
Public Property PackagingDescriptionCode As String
    Get
    Set
public:
property String^ PackagingDescriptionCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► SourceSubqualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PKG Class

PKG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG
RDPCrystal EDI Library
Marking, Packaging, Loading
Declaration Syntax
C# Visual Basic Visual C++
public class PKG : DocumentSegment
Public Class PKG _
    Inherits DocumentSegment
public ref class PKG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PKG()()()() | Initializes a new instance of the PKG class
 | AgencyQualifierCode | Element 3
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemDescriptionType | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingCharacteristicCode | Element 2
 | PackagingDescriptionCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitLoadOptionCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PKG


PKG Constructor

PKG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► PKG()()()()
RDPCrystal EDI Library
Initializes a new instance of the PKG class
Declaration Syntax
C# Visual Basic Visual C++
public PKG()
Public Sub New
public:
PKG()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ItemDescriptionType Property

ItemDescriptionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► ItemDescriptionType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDescriptionType { get; set; }
Public Property ItemDescriptionType As String
    Get
    Set
public:
property String^ ItemDescriptionType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingCharacteristicCode Property

PackagingCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► PackagingCharacteristicCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCharacteristicCode { get; set; }
Public Property PackagingCharacteristicCode As String
    Get
    Set
public:
property String^ PackagingCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


PackagingDescriptionCode Property

PackagingDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► PackagingDescriptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingDescriptionCode { get; set; }
Public Property PackagingDescriptionCode As String
    Get
    Set
public:
property String^ PackagingDescriptionCode {
    String^ get ();
    void set (String^ value);
}


UnitLoadOptionCode Property

UnitLoadOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► UnitLoadOptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitLoadOptionCode { get; set; }
Public Property UnitLoadOptionCode As String
    Get
    Set
public:
property String^ UnitLoadOptionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PKL Class

PKL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL
RDPCrystal EDI Library
Multi-Pack Configuration
Declaration Syntax
C# Visual Basic Visual C++
public class PKL : DocumentSegment
Public Class PKL _
    Inherits DocumentSegment
public ref class PKL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PKL()()()() | Initializes a new instance of the PKL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GrossVolumePerPack | Element 11
 | GrossWeightPerPack | Element 9
 | Height | Element 5
 | ItemDepth | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | Quantity | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 8
 | UnitOrBasisForMeasurementCode2 | Element 10
 | UnitOrBasisForMeasurementCode3 | Element 12
 | Width | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 13
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PKL


PKL Constructor

PKL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► PKL()()()()
RDPCrystal EDI Library
Initializes a new instance of the PKL class
Declaration Syntax
C# Visual Basic Visual C++
public PKL()
Public Sub New
public:
PKL()


GrossVolumePerPack Property

GrossVolumePerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► GrossVolumePerPack
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string GrossVolumePerPack { get; set; }
Public Property GrossVolumePerPack As String
    Get
    Set
public:
property String^ GrossVolumePerPack {
    String^ get ();
    void set (String^ value);
}


GrossWeightPerPack Property

GrossWeightPerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► GrossWeightPerPack
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string GrossWeightPerPack { get; set; }
Public Property GrossWeightPerPack As String
    Get
    Set
public:
property String^ GrossWeightPerPack {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► Height
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


ItemDepth Property

ItemDepth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► ItemDepth
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDepth { get; set; }
Public Property ItemDepth As String
    Get
    Set
public:
property String^ ItemDepth {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► Width
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PKL ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PL Class

PL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL
RDPCrystal EDI Library
Proposal Cost Logic
Declaration Syntax
C# Visual Basic Visual C++
public class PL : DocumentSegment
Public Class PL _
    Inherits DocumentSegment
public ref class PL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PL()()()() | Initializes a new instance of the PL class
 | AssignedNumber | Element 1
 | CalculationOperationCode | Element 4
 | CompositeUnitOfMeasure | Element 2
 | Count | Element 6
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PL


PL Constructor

PL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► PL()()()()
RDPCrystal EDI Library
Initializes a new instance of the PL class
Declaration Syntax
C# Visual Basic Visual C++
public PL()
Public Sub New
public:
PL()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CalculationOperationCode Property

CalculationOperationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► CalculationOperationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CalculationOperationCode { get; set; }
Public Property CalculationOperationCode As String
    Get
    Set
public:
property String^ CalculationOperationCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► Count
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PLA Class

PLA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA
RDPCrystal EDI Library
Place or Location
Declaration Syntax
C# Visual Basic Visual C++
public class PLA : DocumentSegment
Public Class PLA _
    Inherits DocumentSegment
public ref class PLA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLA()()()() | Initializes a new instance of the PLA class
 | ActionCode | Element 1
 | Date | Element 3
 | EntityIdentifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLA


PLA Constructor

PLA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► PLA()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLA class
Declaration Syntax
C# Visual Basic Visual C++
public PLA()
Public Sub New
public:
PLA()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► EntityIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PLB Class

PLB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB
RDPCrystal EDI Library
Provider Level Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class PLB : DocumentSegment
Public Class PLB _
    Inherits DocumentSegment
public ref class PLB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLB()()()() | Initializes a new instance of the PLB class
 | AdjustmentIdentifier | Element 3
 | AdjustmentIdentifier1 | Element 5
 | AdjustmentIdentifier2 | Element 7
 | AdjustmentIdentifier3 | Element 9
 | AdjustmentIdentifier4 | Element 11
 | AdjustmentIdentifier5 | Element 13
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | MonetaryAmount1 | Element 6
 | MonetaryAmount2 | Element 8
 | MonetaryAmount3 | Element 10
 | MonetaryAmount4 | Element 12
 | MonetaryAmount5 | Element 14
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLB


PLB Constructor

PLB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► PLB()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLB class
Declaration Syntax
C# Visual Basic Visual C++
public PLB()
Public Sub New
public:
PLB()


AdjustmentIdentifier Property

AdjustmentIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► AdjustmentIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier { get; set; }
Public Property AdjustmentIdentifier As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}


AdjustmentIdentifier1 Property

AdjustmentIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► AdjustmentIdentifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier1 { get; set; }
Public Property AdjustmentIdentifier1 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier1 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}


AdjustmentIdentifier2 Property

AdjustmentIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► AdjustmentIdentifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier2 { get; set; }
Public Property AdjustmentIdentifier2 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier2 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}


AdjustmentIdentifier3 Property

AdjustmentIdentifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► AdjustmentIdentifier3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier3 { get; set; }
Public Property AdjustmentIdentifier3 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier3 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}


AdjustmentIdentifier4 Property

AdjustmentIdentifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► AdjustmentIdentifier4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier4 { get; set; }
Public Property AdjustmentIdentifier4 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier4 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}


AdjustmentIdentifier5 Property

AdjustmentIdentifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► AdjustmentIdentifier5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier5 { get; set; }
Public Property AdjustmentIdentifier5 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier5 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► MonetaryAmount2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► MonetaryAmount3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► MonetaryAmount4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► MonetaryAmount5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PLC Class

PLC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLC
RDPCrystal EDI Library
Equipment Placement Information
Declaration Syntax
C# Visual Basic Visual C++
public class PLC : DocumentSegment
Public Class PLC _
    Inherits DocumentSegment
public ref class PLC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLC()()()() | Initializes a new instance of the PLC class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLC


PLC Constructor

PLC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLC ► PLC()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLC class
Declaration Syntax
C# Visual Basic Visual C++
public PLC()
Public Sub New
public:
PLC()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLC ► Number
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLC ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PLD Class

PLD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD
RDPCrystal EDI Library
Pallet Information
Declaration Syntax
C# Visual Basic Visual C++
public class PLD : DocumentSegment
Public Class PLD _
    Inherits DocumentSegment
public ref class PLD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLD()()()() | Initializes a new instance of the PLD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletExchangeCode | Element 2
 | QuantityOfPalletsShipped | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 4
 | WeightUnitCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLD


PLD Constructor

PLD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► PLD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLD class
Declaration Syntax
C# Visual Basic Visual C++
public PLD()
Public Sub New
public:
PLD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► PalletExchangeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


QuantityOfPalletsShipped Property

QuantityOfPalletsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► QuantityOfPalletsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOfPalletsShipped { get; set; }
Public Property QuantityOfPalletsShipped As String
    Get
    Set
public:
property String^ QuantityOfPalletsShipped {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► WeightUnitCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PLI Class

PLI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI
RDPCrystal EDI Library
Previous Loan Information
Declaration Syntax
C# Visual Basic Visual C++
public class PLI : DocumentSegment
Public Class PLI _
    Inherits DocumentSegment
public ref class PLI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLI()()()() | Initializes a new instance of the PLI class
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 3
 | LevelOfIndividualTestOrCourseCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanRateTypeCode | Element 9
 | LoanTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLI


PLI Constructor

PLI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► PLI()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLI class
Declaration Syntax
C# Visual Basic Visual C++
public PLI()
Public Sub New
public:
PLI()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► InterestRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► LoanRateTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► LoanTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► MonetaryAmount1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PLI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PM Class

PM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM
RDPCrystal EDI Library
Electronic Funds Transfer Information
Declaration Syntax
C# Visual Basic Visual C++
public class PM : DocumentSegment
Public Class PM _
    Inherits DocumentSegment
public ref class PM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PM()()()() | Initializes a new instance of the PM class
 | AccountNumber | Element 2
 | AccountNumberQualifier | Element 5
 | DFIIdentificationNumber | Element 1
 | DFIIDNumberQualifier | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
 | YesNoConditionOrResponseCode1 | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PM


PM Constructor

PM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► PM()()()()
RDPCrystal EDI Library
Initializes a new instance of the PM class
Declaration Syntax
C# Visual Basic Visual C++
public PM()
Public Sub New
public:
PM()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► AccountNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► AccountNumberQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PM ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


PO1 Class

PO1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1
RDPCrystal EDI Library
Baseline Item Data
Declaration Syntax
C# Visual Basic Visual C++
public class PO1 : DocumentSegment
Public Class PO1 _
    Inherits DocumentSegment
public ref class PO1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PO1()()()() | Initializes a new instance of the PO1 class
 | AssignedIdentification | Element 1
 | BasisOfUnitPriceCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 7
 | ProductServiceID1 | Element 9
 | ProductServiceID2 | Element 11
 | ProductServiceID3 | Element 13
 | ProductServiceID4 | Element 15
 | ProductServiceID5 | Element 17
 | ProductServiceID6 | Element 19
 | ProductServiceID7 | Element 21
 | ProductServiceID8 | Element 23
 | ProductServiceID9 | Element 25
 | ProductServiceIDQualifier | Element 6
 | ProductServiceIDQualifier1 | Element 8
 | ProductServiceIDQualifier2 | Element 10
 | ProductServiceIDQualifier3 | Element 12
 | ProductServiceIDQualifier4 | Element 14
 | ProductServiceIDQualifier5 | Element 16
 | ProductServiceIDQualifier6 | Element 18
 | ProductServiceIDQualifier7 | Element 20
 | ProductServiceIDQualifier8 | Element 22
 | ProductServiceIDQualifier9 | Element 24
 | QuantityOrdered | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitPrice | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PO1


PO1 Constructor

PO1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► PO1()()()()
RDPCrystal EDI Library
Initializes a new instance of the PO1 class
Declaration Syntax
C# Visual Basic Visual C++
public PO1()
Public Sub New
public:
PO1()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID5
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID6
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID7
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID8
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceID9
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► QuantityOrdered
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► UnitPrice
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PO3 Class

PO3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3
RDPCrystal EDI Library
Additional Item Detail
Declaration Syntax
C# Visual Basic Visual C++
public class PO3 : DocumentSegment
Public Class PO3 _
    Inherits DocumentSegment
public ref class PO3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PO3()()()() | Initializes a new instance of the PO3 class
 | BasisOfUnitPriceCode | Element 5
 | ChangeReasonCode | Element 1
 | Date | Element 2
 | Description | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceIdentifierCode | Element 3
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 7
 | UnitPrice | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PO3


PO3 Constructor

PO3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► PO3()()()()
RDPCrystal EDI Library
Initializes a new instance of the PO3 class
Declaration Syntax
C# Visual Basic Visual C++
public PO3()
Public Sub New
public:
PO3()


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}


ChangeReasonCode Property

ChangeReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► ChangeReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeReasonCode { get; set; }
Public Property ChangeReasonCode As String
    Get
    Set
public:
property String^ ChangeReasonCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► Description
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► PriceIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► UnitPrice
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PO4 Class

PO4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4
RDPCrystal EDI Library
Item Physical Details
Declaration Syntax
C# Visual Basic Visual C++
public class PO4 : DocumentSegment
Public Class PO4 _
    Inherits DocumentSegment
public ref class PO4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PO4()()()() | Initializes a new instance of the PO4 class
 | AssignedIdentification | Element 16
 | AssignedIdentification1 | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GrossVolumePerPack | Element 8
 | GrossWeightPerPack | Element 6
 | Height | Element 12
 | InnerPack | Element 14
 | Length | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 18
 | Pack | Element 1
 | PackagingCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Size | Element 2
 | SurfaceLayerPositionCode | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 7
 | UnitOrBasisForMeasurementCode2 | Element 9
 | UnitOrBasisForMeasurementCode3 | Element 13
 | WeightQualifier | Element 5
 | Width | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PO4


PO4 Constructor

PO4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► PO4()()()()
RDPCrystal EDI Library
Initializes a new instance of the PO4 class
Declaration Syntax
C# Visual Basic Visual C++
public PO4()
Public Sub New
public:
PO4()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► AssignedIdentification
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification1 Property

AssignedIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► AssignedIdentification1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification1 { get; set; }
Public Property AssignedIdentification1 As String
    Get
    Set
public:
property String^ AssignedIdentification1 {
    String^ get ();
    void set (String^ value);
}


GrossVolumePerPack Property

GrossVolumePerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► GrossVolumePerPack
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string GrossVolumePerPack { get; set; }
Public Property GrossVolumePerPack As String
    Get
    Set
public:
property String^ GrossVolumePerPack {
    String^ get ();
    void set (String^ value);
}


GrossWeightPerPack Property

GrossWeightPerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► GrossWeightPerPack
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string GrossWeightPerPack { get; set; }
Public Property GrossWeightPerPack As String
    Get
    Set
public:
property String^ GrossWeightPerPack {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Height
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


InnerPack Property

InnerPack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► InnerPack
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string InnerPack { get; set; }
Public Property InnerPack As String
    Get
    Set
public:
property String^ InnerPack {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Length
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Number
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Pack
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► PackagingCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Size
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


SurfaceLayerPositionCode Property

SurfaceLayerPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► SurfaceLayerPositionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode { get; set; }
Public Property SurfaceLayerPositionCode As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► WeightQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Width
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PO4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


POC Class

POC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC
RDPCrystal EDI Library
Line Item Change
Declaration Syntax
C# Visual Basic Visual C++
public class POC : DocumentSegment
Public Class POC _
    Inherits DocumentSegment
public ref class POC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | POC()()()() | Initializes a new instance of the POC class
 | AssignedIdentification | Element 1
 | BasisOfUnitPriceCode | Element 7
 | ChangeOrResponseTypeCode | Element 2
 | CompositeUnitOfMeasure | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 9
 | ProductServiceID1 | Element 11
 | ProductServiceID2 | Element 13
 | ProductServiceID3 | Element 15
 | ProductServiceID4 | Element 17
 | ProductServiceID5 | Element 19
 | ProductServiceID6 | Element 21
 | ProductServiceID7 | Element 23
 | ProductServiceID8 | Element 25
 | ProductServiceID9 | Element 27
 | ProductServiceIDQualifier | Element 8
 | ProductServiceIDQualifier1 | Element 10
 | ProductServiceIDQualifier2 | Element 12
 | ProductServiceIDQualifier3 | Element 14
 | ProductServiceIDQualifier4 | Element 16
 | ProductServiceIDQualifier5 | Element 18
 | ProductServiceIDQualifier6 | Element 20
 | ProductServiceIDQualifier7 | Element 22
 | ProductServiceIDQualifier8 | Element 24
 | ProductServiceIDQualifier9 | Element 26
 | QuantityLeftToReceive | Element 4
 | QuantityOrdered | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | POC


POC Constructor

POC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► POC()()()()
RDPCrystal EDI Library
Initializes a new instance of the POC class
Declaration Syntax
C# Visual Basic Visual C++
public POC()
Public Sub New
public:
POC()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}


ChangeOrResponseTypeCode Property

ChangeOrResponseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ChangeOrResponseTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrResponseTypeCode { get; set; }
Public Property ChangeOrResponseTypeCode As String
    Get
    Set
public:
property String^ ChangeOrResponseTypeCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID4
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID5
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID6
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID7
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID8
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceID9
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


QuantityLeftToReceive Property

QuantityLeftToReceive Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► QuantityLeftToReceive
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityLeftToReceive { get; set; }
Public Property QuantityLeftToReceive As String
    Get
    Set
public:
property String^ QuantityLeftToReceive {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► QuantityOrdered
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► UnitPrice
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


POD Class

POD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD
RDPCrystal EDI Library
Proof of Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class POD : DocumentSegment
Public Class POD _
    Inherits DocumentSegment
public ref class POD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | POD()()()() | Initializes a new instance of the POD class
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | POD


POD Constructor

POD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD ► POD()()()()
RDPCrystal EDI Library
Initializes a new instance of the POD class
Declaration Syntax
C# Visual Basic Visual C++
public POD()
Public Sub New
public:
POD()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD ► Time
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► POD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PositionInSegment Class

PositionInSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PositionInSegment
RDPCrystal EDI Library
C030
Declaration Syntax
C# Visual Basic Visual C++
public class PositionInSegment : DocumentCompositeElement
Public Class PositionInSegment _
    Inherits DocumentCompositeElement
public ref class PositionInSegment : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PositionInSegment()()()() | Initializes a new instance of the PositionInSegment class
 | ComponentDataElementPositionInComposite |
 | ElementPositionInSegment |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | PositionInSegment


PositionInSegment Constructor

PositionInSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PositionInSegment ► PositionInSegment()()()()
RDPCrystal EDI Library
Initializes a new instance of the PositionInSegment class
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment()
Public Sub New
public:
PositionInSegment()


ComponentDataElementPositionInComposite Property

ComponentDataElementPositionInComposite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PositionInSegment ► ComponentDataElementPositionInComposite
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentDataElementPositionInComposite { get; set; }
Public Property ComponentDataElementPositionInComposite As String
    Get
    Set
public:
property String^ ComponentDataElementPositionInComposite {
    String^ get ();
    void set (String^ value);
}


ElementPositionInSegment Property

ElementPositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PositionInSegment ► ElementPositionInSegment
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ElementPositionInSegment { get; set; }
Public Property ElementPositionInSegment As String
    Get
    Set
public:
property String^ ElementPositionInSegment {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PositionInSegment ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


PPA Class

PPA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA
RDPCrystal EDI Library
Property Location
Declaration Syntax
C# Visual Basic Visual C++
public class PPA : DocumentSegment
Public Class PPA _
    Inherits DocumentSegment
public ref class PPA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PPA()()()() | Initializes a new instance of the PPA class
 | DirectionIdentifierCode | Element 4
 | DirectionIdentifierCode1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LatitudeCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 2
 | LocationQualifier | Element 1
 | LongitudeCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PPA


PPA Constructor

PPA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► PPA()()()()
RDPCrystal EDI Library
Initializes a new instance of the PPA class
Declaration Syntax
C# Visual Basic Visual C++
public PPA()
Public Sub New
public:
PPA()


DirectionIdentifierCode Property

DirectionIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► DirectionIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode { get; set; }
Public Property DirectionIdentifierCode As String
    Get
    Set
public:
property String^ DirectionIdentifierCode {
    String^ get ();
    void set (String^ value);
}


DirectionIdentifierCode1 Property

DirectionIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► DirectionIdentifierCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode1 { get; set; }
Public Property DirectionIdentifierCode1 As String
    Get
    Set
public:
property String^ DirectionIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


LatitudeCode Property

LatitudeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► LatitudeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LatitudeCode { get; set; }
Public Property LatitudeCode As String
    Get
    Set
public:
property String^ LatitudeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► LocationIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► LocationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


LongitudeCode Property

LongitudeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► LongitudeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LongitudeCode { get; set; }
Public Property LongitudeCode As String
    Get
    Set
public:
property String^ LongitudeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PPD Class

PPD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD
RDPCrystal EDI Library
Payment Pattern Details
Declaration Syntax
C# Visual Basic Visual C++
public class PPD : DocumentSegment
Public Class PPD _
    Inherits DocumentSegment
public ref class PPD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PPD()()()() | Initializes a new instance of the PPD class
 | DateTimePeriod | Element 3
 | DateTimePeriod1 | Element 7
 | DateTimePeriodFormatQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 8
 | Number1 | Element 9
 | Number2 | Element 10
 | Number3 | Element 11
 | Number4 | Element 12
 | Number5 | Element 13
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentPattern | Element 1
 | RatingCode | Element 6
 | ReferenceIdentification | Element 4
 | ReferenceIdentification1 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PPD


PPD Constructor

PPD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► PPD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PPD class
Declaration Syntax
C# Visual Basic Visual C++
public PPD()
Public Sub New
public:
PPD()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► DateTimePeriod1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Number
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Number1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


Number2 Property

Number2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Number2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Number2 { get; set; }
Public Property Number2 As String
    Get
    Set
public:
property String^ Number2 {
    String^ get ();
    void set (String^ value);
}


Number3 Property

Number3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Number3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Number3 { get; set; }
Public Property Number3 As String
    Get
    Set
public:
property String^ Number3 {
    String^ get ();
    void set (String^ value);
}


Number4 Property

Number4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Number4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Number4 { get; set; }
Public Property Number4 As String
    Get
    Set
public:
property String^ Number4 {
    String^ get ();
    void set (String^ value);
}


Number5 Property

Number5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Number5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Number5 { get; set; }
Public Property Number5 As String
    Get
    Set
public:
property String^ Number5 {
    String^ get ();
    void set (String^ value);
}


PaymentPattern Property

PaymentPattern Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► PaymentPattern
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentPattern { get; set; }
Public Property PaymentPattern As String
    Get
    Set
public:
property String^ PaymentPattern {
    String^ get ();
    void set (String^ value);
}


RatingCode Property

RatingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► RatingCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RatingCode { get; set; }
Public Property RatingCode As String
    Get
    Set
public:
property String^ RatingCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► ReferenceIdentification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PPL Class

PPL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL
RDPCrystal EDI Library
Price Support Data
Declaration Syntax
C# Visual Basic Visual C++
public class PPL : DocumentSegment
Public Class PPL _
    Inherits DocumentSegment
public ref class PPL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PPL()()()() | Initializes a new instance of the PPL class
 | AcquisitionDataCode | Element 1
 | Date | Element 2
 | Date1 | Element 3
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProposalDataDetailIdentifierCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PPL


PPL Constructor

PPL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► PPL()()()()
RDPCrystal EDI Library
Initializes a new instance of the PPL class
Declaration Syntax
C# Visual Basic Visual C++
public PPL()
Public Sub New
public:
PPL()


AcquisitionDataCode Property

AcquisitionDataCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► AcquisitionDataCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcquisitionDataCode { get; set; }
Public Property AcquisitionDataCode As String
    Get
    Set
public:
property String^ AcquisitionDataCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProposalDataDetailIdentifierCode Property

ProposalDataDetailIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► ProposalDataDetailIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProposalDataDetailIdentifierCode { get; set; }
Public Property ProposalDataDetailIdentifierCode As String
    Get
    Set
public:
property String^ ProposalDataDetailIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PPY Class

PPY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY
RDPCrystal EDI Library
Personal Property Description
Declaration Syntax
C# Visual Basic Visual C++
public class PPY : DocumentSegment
Public Class PPY _
    Inherits DocumentSegment
public ref class PPY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PPY()()()() | Initializes a new instance of the PPY class
 | DateTimePeriod | Element 7
 | DateTimePeriodFormatQualifier | Element 6
 | Description | Element 3
 | Description1 | Element 4
 | Description2 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfPersonalOrBusinessAssetCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PPY


PPY Constructor

PPY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► PPY()()()()
RDPCrystal EDI Library
Initializes a new instance of the PPY class
Declaration Syntax
C# Visual Basic Visual C++
public PPY()
Public Sub New
public:
PPY()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► Description1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► Description2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


TypeOfPersonalOrBusinessAssetCode Property

TypeOfPersonalOrBusinessAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► TypeOfPersonalOrBusinessAssetCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfPersonalOrBusinessAssetCode { get; set; }
Public Property TypeOfPersonalOrBusinessAssetCode As String
    Get
    Set
public:
property String^ TypeOfPersonalOrBusinessAssetCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PPY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PR Class

PR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR
RDPCrystal EDI Library
Product (Commodity)
Declaration Syntax
C# Visual Basic Visual C++
public class PR : DocumentSegment
Public Class PR _
    Inherits DocumentSegment
public ref class PR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PR()()()() | Initializes a new instance of the PR class
 | ChangeTypeCode | Element 5
 | CommodityCode | Element 3
 | CommodityCode1 | Element 4
 | CommodityCodeQualifier | Element 2
 | CommodityGeographicLogicalConnectorCode | Element 1
 | DocketControlNumber | Element 7
 | DocketIdentification | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupTitle | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PR


PR Constructor

PR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► PR()()()()
RDPCrystal EDI Library
Initializes a new instance of the PR class
Declaration Syntax
C# Visual Basic Visual C++
public PR()
Public Sub New
public:
PR()


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► ChangeTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCode1 Property

CommodityCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► CommodityCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode1 { get; set; }
Public Property CommodityCode1 As String
    Get
    Set
public:
property String^ CommodityCode1 {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


CommodityGeographicLogicalConnectorCode Property

CommodityGeographicLogicalConnectorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► CommodityGeographicLogicalConnectorCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityGeographicLogicalConnectorCode { get; set; }
Public Property CommodityGeographicLogicalConnectorCode As String
    Get
    Set
public:
property String^ CommodityGeographicLogicalConnectorCode {
    String^ get ();
    void set (String^ value);
}


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► DocketControlNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► DocketIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


GroupTitle Property

GroupTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► GroupTitle
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string GroupTitle { get; set; }
Public Property GroupTitle As String
    Get
    Set
public:
property String^ GroupTitle {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PR1 Class

PR1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1
RDPCrystal EDI Library
Price Request Parameter List 1
Declaration Syntax
C# Visual Basic Visual C++
public class PR1 : DocumentSegment
Public Class PR1 _
    Inherits DocumentSegment
public ref class PR1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PR1()()()() | Initializes a new instance of the PR1 class
 | CommodityCode | Element 2
 | CommodityCode1 | Element 3
 | CommodityCodeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 5
 | LocationIdentifier1 | Element 6
 | LocationIdentifier2 | Element 10
 | LocationIdentifier3 | Element 11
 | LocationQualifier | Element 4
 | LocationQualifier1 | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 8
 | StandardCarrierAlphaCode1 | Element 13
 | StateOrProvinceCode | Element 7
 | StateOrProvinceCode1 | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PR1


PR1 Constructor

PR1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► PR1()()()()
RDPCrystal EDI Library
Initializes a new instance of the PR1 class
Declaration Syntax
C# Visual Basic Visual C++
public PR1()
Public Sub New
public:
PR1()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► CommodityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCode1 Property

CommodityCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► CommodityCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode1 { get; set; }
Public Property CommodityCode1 As String
    Get
    Set
public:
property String^ CommodityCode1 {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► LocationIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► LocationIdentifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier2 Property

LocationIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► LocationIdentifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier2 { get; set; }
Public Property LocationIdentifier2 As String
    Get
    Set
public:
property String^ LocationIdentifier2 {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier3 Property

LocationIdentifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► LocationIdentifier3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier3 { get; set; }
Public Property LocationIdentifier3 As String
    Get
    Set
public:
property String^ LocationIdentifier3 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► LocationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier1 Property

LocationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► LocationQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier1 { get; set; }
Public Property LocationQualifier1 As String
    Get
    Set
public:
property String^ LocationQualifier1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PR2 Class

PR2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2
RDPCrystal EDI Library
Price Request Parameter List 2
Declaration Syntax
C# Visual Basic Visual C++
public class PR2 : DocumentSegment
Public Class PR2 _
    Inherits DocumentSegment
public ref class PR2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PR2()()()() | Initializes a new instance of the PR2 class
 | CarTypeCode | Element 4
 | ConveyanceCode | Element 8
 | Date | Element 1
 | Date1 | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 6
 | IdentificationCodeQualifier | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 7
 | ReferenceIdentification1 | Element 9
 | RouteCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PR2


PR2 Constructor

PR2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► PR2()()()()
RDPCrystal EDI Library
Initializes a new instance of the PR2 class
Declaration Syntax
C# Visual Basic Visual C++
public PR2()
Public Sub New
public:
PR2()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► CarTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


ConveyanceCode Property

ConveyanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► ConveyanceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ConveyanceCode { get; set; }
Public Property ConveyanceCode As String
    Get
    Set
public:
property String^ ConveyanceCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► Date1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► IdentificationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


RouteCode Property

RouteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► RouteCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RouteCode { get; set; }
Public Property RouteCode As String
    Get
    Set
public:
property String^ RouteCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PR2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PRC Class

PRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC
RDPCrystal EDI Library
Payment Rate Change
Declaration Syntax
C# Visual Basic Visual C++
public class PRC : DocumentSegment
Public Class PRC _
    Inherits DocumentSegment
public ref class PRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRC()()()() | Initializes a new instance of the PRC class
 | AmountQualifierCode | Element 7
 | CompositeUnitOfMeasure | Element 12
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | DateTimeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 4
 | InterestRate1 | Element 5
 | InterestRate2 | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 11
 | QuantityQualifier | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRC


PRC Constructor

PRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► PRC()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRC class
Declaration Syntax
C# Visual Basic Visual C++
public PRC()
Public Sub New
public:
PRC()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► AmountQualifierCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► DateTimeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► InterestRate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


InterestRate1 Property

InterestRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► InterestRate1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate1 { get; set; }
Public Property InterestRate1 As String
    Get
    Set
public:
property String^ InterestRate1 {
    String^ get ();
    void set (String^ value);
}


InterestRate2 Property

InterestRate2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► InterestRate2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate2 { get; set; }
Public Property InterestRate2 As String
    Get
    Set
public:
property String^ InterestRate2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► Quantity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► QuantityQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PRD Class

PRD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD
RDPCrystal EDI Library
Mortgage Loan Product Description
Declaration Syntax
C# Visual Basic Visual C++
public class PRD : DocumentSegment
Public Class PRD _
    Inherits DocumentSegment
public ref class PRD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRD()()()() | Initializes a new instance of the PRD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 1
 | LoanRateTypeCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 11
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | Quantity | Element 2
 | Quantity1 | Element 6
 | Quantity2 | Element 7
 | Quantity3 | Element 10
 | RateValueQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
 | YesNoConditionOrResponseCode1 | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRD


PRD Constructor

PRD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► PRD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRD class
Declaration Syntax
C# Visual Basic Visual C++
public PRD()
Public Sub New
public:
PRD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► LoanRateTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► MonetaryAmount
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Quantity1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Quantity2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Quantity3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► RateValueQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRD ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


PRF Class

PRF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF
RDPCrystal EDI Library
Purchase Order Reference
Declaration Syntax
C# Visual Basic Visual C++
public class PRF : DocumentSegment
Public Class PRF _
    Inherits DocumentSegment
public ref class PRF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRF()()()() | Initializes a new instance of the PRF class
 | AssignedIdentification | Element 5
 | ChangeOrderSequenceNumber | Element 3
 | ContractNumber | Element 6
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 1
 | PurchaseOrderTypeCode | Element 7
 | ReleaseNumber | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRF


PRF Constructor

PRF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► PRF()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRF class
Declaration Syntax
C# Visual Basic Visual C++
public PRF()
Public Sub New
public:
PRF()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► AssignedIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


ChangeOrderSequenceNumber Property

ChangeOrderSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► ChangeOrderSequenceNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeOrderSequenceNumber { get; set; }
Public Property ChangeOrderSequenceNumber As String
    Get
    Set
public:
property String^ ChangeOrderSequenceNumber {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► ContractNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderTypeCode Property

PurchaseOrderTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► PurchaseOrderTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderTypeCode { get; set; }
Public Property PurchaseOrderTypeCode As String
    Get
    Set
public:
property String^ PurchaseOrderTypeCode {
    String^ get ();
    void set (String^ value);
}


ReleaseNumber Property

ReleaseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► ReleaseNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseNumber { get; set; }
Public Property ReleaseNumber As String
    Get
    Set
public:
property String^ ReleaseNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PRI Class

PRI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI
RDPCrystal EDI Library
External Reference Identifier
Declaration Syntax
C# Visual Basic Visual C++
public class PRI : DocumentSegment
Public Class PRI _
    Inherits DocumentSegment
public ref class PRI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRI()()()() | Initializes a new instance of the PRI class
 | DocketControlNumber | Element 11
 | DocketIdentification | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupTitle | Element 14
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrimaryPublicationAuthorityCode | Element 1
 | ReferenceIdentification | Element 9
 | ReferenceIdentificationQualifier | Element 8
 | RevisionNumber | Element 13
 | StandardCarrierAlphaCode | Element 10
 | TariffAgencyCode | Element 2
 | TariffItemNumber | Element 7
 | TariffNumber | Element 3
 | TariffNumberSuffix | Element 4
 | TariffSection | Element 6
 | TariffSupplementIdentifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRI


PRI Constructor

PRI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► PRI()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRI class
Declaration Syntax
C# Visual Basic Visual C++
public PRI()
Public Sub New
public:
PRI()


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► DocketControlNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► DocketIdentification
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


GroupTitle Property

GroupTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► GroupTitle
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string GroupTitle { get; set; }
Public Property GroupTitle As String
    Get
    Set
public:
property String^ GroupTitle {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrimaryPublicationAuthorityCode Property

PrimaryPublicationAuthorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► PrimaryPublicationAuthorityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PrimaryPublicationAuthorityCode { get; set; }
Public Property PrimaryPublicationAuthorityCode As String
    Get
    Set
public:
property String^ PrimaryPublicationAuthorityCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


RevisionNumber Property

RevisionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► RevisionNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; set; }
Public Property RevisionNumber As String
    Get
    Set
public:
property String^ RevisionNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TariffAgencyCode Property

TariffAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► TariffAgencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAgencyCode { get; set; }
Public Property TariffAgencyCode As String
    Get
    Set
public:
property String^ TariffAgencyCode {
    String^ get ();
    void set (String^ value);
}


TariffItemNumber Property

TariffItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► TariffItemNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemNumber { get; set; }
Public Property TariffItemNumber As String
    Get
    Set
public:
property String^ TariffItemNumber {
    String^ get ();
    void set (String^ value);
}


TariffNumber Property

TariffNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► TariffNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumber { get; set; }
Public Property TariffNumber As String
    Get
    Set
public:
property String^ TariffNumber {
    String^ get ();
    void set (String^ value);
}


TariffNumberSuffix Property

TariffNumberSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► TariffNumberSuffix
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumberSuffix { get; set; }
Public Property TariffNumberSuffix As String
    Get
    Set
public:
property String^ TariffNumberSuffix {
    String^ get ();
    void set (String^ value);
}


TariffSection Property

TariffSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► TariffSection
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSection { get; set; }
Public Property TariffSection As String
    Get
    Set
public:
property String^ TariffSection {
    String^ get ();
    void set (String^ value);
}


TariffSupplementIdentifier Property

TariffSupplementIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► TariffSupplementIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSupplementIdentifier { get; set; }
Public Property TariffSupplementIdentifier As String
    Get
    Set
public:
property String^ TariffSupplementIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PRJ Class

PRJ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ
RDPCrystal EDI Library
Multifamily Housing Project
Declaration Syntax
C# Visual Basic Visual C++
public class PRJ : DocumentSegment
Public Class PRJ _
    Inherits DocumentSegment
public ref class PRJ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRJ()()()() | Initializes a new instance of the PRJ class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRJ


PRJ Constructor

PRJ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► PRJ()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRJ class
Declaration Syntax
C# Visual Basic Visual C++
public PRJ()
Public Sub New
public:
PRJ()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► Name1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRJ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PRM Class

PRM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM
RDPCrystal EDI Library
Basic Trace Parameters
Declaration Syntax
C# Visual Basic Visual C++
public class PRM : DocumentSegment
Public Class PRM _
    Inherits DocumentSegment
public ref class PRM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRM()()()() | Initializes a new instance of the PRM class
 | AssociationOfAmericanRailroadsCarGradeCode | Element 12
 | CarTypeCode | Element 1
 | CommodityCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermodalServiceCode | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 3
 | StandardCarrierAlphaCode1 | Element 7
 | StandardCarrierAlphaCode2 | Element 8
 | StandardCarrierAlphaCode3 | Element 10
 | StandardPointLocationCode | Element 4
 | StandardPointLocationCode1 | Element 5
 | StandardPointLocationCode2 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationConditionCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRM


PRM Constructor

PRM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► PRM()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRM class
Declaration Syntax
C# Visual Basic Visual C++
public PRM()
Public Sub New
public:
PRM()


AssociationOfAmericanRailroadsCarGradeCode Property

AssociationOfAmericanRailroadsCarGradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► AssociationOfAmericanRailroadsCarGradeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AssociationOfAmericanRailroadsCarGradeCode { get; set; }
Public Property AssociationOfAmericanRailroadsCarGradeCode As String
    Get
    Set
public:
property String^ AssociationOfAmericanRailroadsCarGradeCode {
    String^ get ();
    void set (String^ value);
}


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► CarTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► CommodityCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


IntermodalServiceCode Property

IntermodalServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► IntermodalServiceCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalServiceCode { get; set; }
Public Property IntermodalServiceCode As String
    Get
    Set
public:
property String^ IntermodalServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode3 Property

StandardCarrierAlphaCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardCarrierAlphaCode3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode3 { get; set; }
Public Property StandardCarrierAlphaCode3 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode3 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode2 Property

StandardPointLocationCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► StandardPointLocationCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode2 { get; set; }
Public Property StandardPointLocationCode2 As String
    Get
    Set
public:
property String^ StandardPointLocationCode2 {
    String^ get ();
    void set (String^ value);
}


TransportationConditionCode Property

TransportationConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► TransportationConditionCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationConditionCode { get; set; }
Public Property TransportationConditionCode As String
    Get
    Set
public:
property String^ TransportationConditionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ProviderSpecialtyInformation Class

ProviderSpecialtyInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation
RDPCrystal EDI Library
C035
Declaration Syntax
C# Visual Basic Visual C++
public class ProviderSpecialtyInformation : DocumentCompositeElement
Public Class ProviderSpecialtyInformation _
    Inherits DocumentCompositeElement
public ref class ProviderSpecialtyInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProviderSpecialtyInformation()()()() | Initializes a new instance of the ProviderSpecialtyInformation class
 | AgencyQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProviderSpecialtyCode | Element 1
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ProviderSpecialtyInformation


ProviderSpecialtyInformation Constructor

ProviderSpecialtyInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation ► ProviderSpecialtyInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the ProviderSpecialtyInformation class
Declaration Syntax
C# Visual Basic Visual C++
public ProviderSpecialtyInformation()
Public Sub New
public:
ProviderSpecialtyInformation()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


ProviderSpecialtyCode Property

ProviderSpecialtyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation ► ProviderSpecialtyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderSpecialtyCode { get; set; }
Public Property ProviderSpecialtyCode As String
    Get
    Set
public:
property String^ ProviderSpecialtyCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ProviderSpecialtyInformation ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PRR Class

PRR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR
RDPCrystal EDI Library
Problem Report
Declaration Syntax
C# Visual Basic Visual C++
public class PRR : DocumentSegment
Public Class PRR _
    Inherits DocumentSegment
public ref class PRR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRR()()()() | Initializes a new instance of the PRR class
 | AgencyQualifierCode | Element 2
 | AgencyQualifierCode1 | Element 6
 | AgencyQualifierCode2 | Element 9
 | AssignedIdentification | Element 1
 | ComplaintCode | Element 4
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceClassificationCode | Element 8
 | SeverityConditionCode | Element 11
 | SourceSubqualifier | Element 3
 | SourceSubqualifier1 | Element 7
 | SourceSubqualifier2 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRR


PRR Constructor

PRR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► PRR()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRR class
Declaration Syntax
C# Visual Basic Visual C++
public PRR()
Public Sub New
public:
PRR()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode1 Property

AgencyQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► AgencyQualifierCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode1 { get; set; }
Public Property AgencyQualifierCode1 As String
    Get
    Set
public:
property String^ AgencyQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode2 Property

AgencyQualifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► AgencyQualifierCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode2 { get; set; }
Public Property AgencyQualifierCode2 As String
    Get
    Set
public:
property String^ AgencyQualifierCode2 {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


ComplaintCode Property

ComplaintCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► ComplaintCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ComplaintCode { get; set; }
Public Property ComplaintCode As String
    Get
    Set
public:
property String^ ComplaintCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServiceClassificationCode Property

ServiceClassificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► ServiceClassificationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceClassificationCode { get; set; }
Public Property ServiceClassificationCode As String
    Get
    Set
public:
property String^ ServiceClassificationCode {
    String^ get ();
    void set (String^ value);
}


SeverityConditionCode Property

SeverityConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► SeverityConditionCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SeverityConditionCode { get; set; }
Public Property SeverityConditionCode As String
    Get
    Set
public:
property String^ SeverityConditionCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► SourceSubqualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier1 Property

SourceSubqualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► SourceSubqualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier1 { get; set; }
Public Property SourceSubqualifier1 As String
    Get
    Set
public:
property String^ SourceSubqualifier1 {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier2 Property

SourceSubqualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► SourceSubqualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier2 { get; set; }
Public Property SourceSubqualifier2 As String
    Get
    Set
public:
property String^ SourceSubqualifier2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PRS Class

PRS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRS
RDPCrystal EDI Library
Part Release Status
Declaration Syntax
C# Visual Basic Visual C++
public class PRS : DocumentSegment
Public Class PRS _
    Inherits DocumentSegment
public ref class PRS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRS()()()() | Initializes a new instance of the PRS class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PartReleaseStatusCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRS


PRS Constructor

PRS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRS ► PRS()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRS class
Declaration Syntax
C# Visual Basic Visual C++
public PRS()
Public Sub New
public:
PRS()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRS ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PartReleaseStatusCode Property

PartReleaseStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRS ► PartReleaseStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PartReleaseStatusCode { get; set; }
Public Property PartReleaseStatusCode As String
    Get
    Set
public:
property String^ PartReleaseStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PRT Class

PRT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT
RDPCrystal EDI Library
Part Disposition
Declaration Syntax
C# Visual Basic Visual C++
public class PRT : DocumentSegment
Public Class PRT _
    Inherits DocumentSegment
public ref class PRT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRT()()()() | Initializes a new instance of the PRT class
 | AgencyQualifierCode | Element 2
 | DispositionCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceSubqualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRT


PRT Constructor

PRT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► PRT()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRT class
Declaration Syntax
C# Visual Basic Visual C++
public PRT()
Public Sub New
public:
PRT()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► DispositionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► SourceSubqualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PRV Class

PRV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV
RDPCrystal EDI Library
Provider Information
Declaration Syntax
C# Visual Basic Visual C++
public class PRV : DocumentSegment
Public Class PRV _
    Inherits DocumentSegment
public ref class PRV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRV()()()() | Initializes a new instance of the PRV class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProviderCode | Element 1
 | ProviderOrganizationCode | Element 6
 | ProviderSpecialtyInformation | Element 5
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRV


PRV Constructor

PRV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► PRV()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRV class
Declaration Syntax
C# Visual Basic Visual C++
public PRV()
Public Sub New
public:
PRV()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProviderCode Property

ProviderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► ProviderCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderCode { get; set; }
Public Property ProviderCode As String
    Get
    Set
public:
property String^ ProviderCode {
    String^ get ();
    void set (String^ value);
}


ProviderOrganizationCode Property

ProviderOrganizationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► ProviderOrganizationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderOrganizationCode { get; set; }
Public Property ProviderOrganizationCode As String
    Get
    Set
public:
property String^ ProviderOrganizationCode {
    String^ get ();
    void set (String^ value);
}


ProviderSpecialtyInformation Property

ProviderSpecialtyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► ProviderSpecialtyInformation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public ProviderSpecialtyInformation ProviderSpecialtyInformation { get; set; }
Public Property ProviderSpecialtyInformation As ProviderSpecialtyInformation
    Get
    Set
public:
property ProviderSpecialtyInformation^ ProviderSpecialtyInformation {
    ProviderSpecialtyInformation^ get ();
    void set (ProviderSpecialtyInformation^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PRV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PS Class

PS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS
RDPCrystal EDI Library
Protective Service Instructions
Declaration Syntax
C# Visual Basic Visual C++
public class PS : DocumentSegment
Public Class PS _
    Inherits DocumentSegment
public ref class PS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PS()()()() | Initializes a new instance of the PS class
 | CityName | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PreCooledCode | Element 10
 | ProtectiveServiceCode | Element 2
 | ProtectiveServiceRuleCode | Element 1
 | StandardCarrierAlphaCode | Element 5
 | StateOrProvinceCode | Element 8
 | Temperature | Element 4
 | Temperature1 | Element 14
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Weight | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 11
 | YesNoConditionOrResponseCode1 | Element 12
 | YesNoConditionOrResponseCode2 | Element 13
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PS


PS Constructor

PS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► PS()()()()
RDPCrystal EDI Library
Initializes a new instance of the PS class
Declaration Syntax
C# Visual Basic Visual C++
public PS()
Public Sub New
public:
PS()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► CityName
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PreCooledCode Property

PreCooledCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► PreCooledCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PreCooledCode { get; set; }
Public Property PreCooledCode As String
    Get
    Set
public:
property String^ PreCooledCode {
    String^ get ();
    void set (String^ value);
}


ProtectiveServiceCode Property

ProtectiveServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► ProtectiveServiceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProtectiveServiceCode { get; set; }
Public Property ProtectiveServiceCode As String
    Get
    Set
public:
property String^ ProtectiveServiceCode {
    String^ get ();
    void set (String^ value);
}


ProtectiveServiceRuleCode Property

ProtectiveServiceRuleCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► ProtectiveServiceRuleCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProtectiveServiceRuleCode { get; set; }
Public Property ProtectiveServiceRuleCode As String
    Get
    Set
public:
property String^ ProtectiveServiceRuleCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► StateOrProvinceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► Temperature
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


Temperature1 Property

Temperature1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► Temperature1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature1 { get; set; }
Public Property Temperature1 As String
    Get
    Set
public:
property String^ Temperature1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► Weight
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


PS1 Class

PS1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1
RDPCrystal EDI Library
Purchase Service
Declaration Syntax
C# Visual Basic Visual C++
public class PS1 : DocumentSegment
Public Class PS1 _
    Inherits DocumentSegment
public ref class PS1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PS1()()()() | Initializes a new instance of the PS1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PS1


PS1 Constructor

PS1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1 ► PS1()()()()
RDPCrystal EDI Library
Initializes a new instance of the PS1 class
Declaration Syntax
C# Visual Basic Visual C++
public PS1()
Public Sub New
public:
PS1()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PS1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PSA Class

PSA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA
RDPCrystal EDI Library
Partner Share Accounting
Declaration Syntax
C# Visual Basic Visual C++
public class PSA : DocumentSegment
Public Class PSA _
    Inherits DocumentSegment
public ref class PSA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PSA()()()() | Initializes a new instance of the PSA class
 | AmountQualifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OwnersShare | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PSA


PSA Constructor

PSA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► PSA()()()()
RDPCrystal EDI Library
Initializes a new instance of the PSA class
Declaration Syntax
C# Visual Basic Visual C++
public PSA()
Public Sub New
public:
PSA()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► AmountQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


OwnersShare Property

OwnersShare Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► OwnersShare
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OwnersShare { get; set; }
Public Property OwnersShare As String
    Get
    Set
public:
property String^ OwnersShare {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PSC Class

PSC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC
RDPCrystal EDI Library
Product Service Contract
Declaration Syntax
C# Visual Basic Visual C++
public class PSC : DocumentSegment
Public Class PSC _
    Inherits DocumentSegment
public ref class PSC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PSC()()()() | Initializes a new instance of the PSC class
 | ActionCode | Element 16
 | AgencyQualifierCode | Element 18
 | CompositeUnitOfMeasure | Element 7
 | CompositeUnitOfMeasure1 | Element 12
 | ContactMethodCode | Element 25
 | ContractNumber | Element 6
 | ContractStatusCode | Element 1
 | Count | Element 8
 | Date | Element 10
 | Date1 | Element 11
 | DateTimeQualifier | Element 9
 | Description | Element 22
 | EntityIdentifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 15
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OperationEnvironmentCode | Element 20
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 17
 | RangeMaximum | Element 13
 | RangeMinimum | Element 14
 | ReferenceIdentification | Element 4
 | SourceSubqualifier | Element 19
 | SpecialServicesCode | Element 21
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfProductServiceCode | Element 2
 | TypeOfProductServiceCode1 | Element 3
 | UnitPrice | Element 23
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 24
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PSC


PSC Constructor

PSC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► PSC()()()()
RDPCrystal EDI Library
Initializes a new instance of the PSC class
Declaration Syntax
C# Visual Basic Visual C++
public PSC()
Public Sub New
public:
PSC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► ActionCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► AgencyQualifierCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ContactMethodCode Property

ContactMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► ContactMethodCode
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ContactMethodCode { get; set; }
Public Property ContactMethodCode As String
    Get
    Set
public:
property String^ ContactMethodCode {
    String^ get ();
    void set (String^ value);
}


ContractNumber Property

ContractNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► ContractNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ContractNumber { get; set; }
Public Property ContractNumber As String
    Get
    Set
public:
property String^ ContractNumber {
    String^ get ();
    void set (String^ value);
}


ContractStatusCode Property

ContractStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► ContractStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContractStatusCode { get; set; }
Public Property ContractStatusCode As String
    Get
    Set
public:
property String^ ContractStatusCode {
    String^ get ();
    void set (String^ value);
}


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Count
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Date
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Date1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► DateTimeQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Description
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► EntityIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► MeasurementValue
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


OperationEnvironmentCode Property

OperationEnvironmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► OperationEnvironmentCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string OperationEnvironmentCode { get; set; }
Public Property OperationEnvironmentCode As String
    Get
    Set
public:
property String^ OperationEnvironmentCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Percent
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► RangeMaximum
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► RangeMinimum
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► SourceSubqualifier
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► SpecialServicesCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


TypeOfProductServiceCode Property

TypeOfProductServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► TypeOfProductServiceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfProductServiceCode { get; set; }
Public Property TypeOfProductServiceCode As String
    Get
    Set
public:
property String^ TypeOfProductServiceCode {
    String^ get ();
    void set (String^ value);
}


TypeOfProductServiceCode1 Property

TypeOfProductServiceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► TypeOfProductServiceCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfProductServiceCode1 { get; set; }
Public Property TypeOfProductServiceCode1 As String
    Get
    Set
public:
property String^ TypeOfProductServiceCode1 {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► UnitPrice
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


PSD Class

PSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD
RDPCrystal EDI Library
Physical Sample Description
Declaration Syntax
C# Visual Basic Visual C++
public class PSD : DocumentSegment
Public Class PSD _
    Inherits DocumentSegment
public ref class PSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PSD()()()() | Initializes a new instance of the PSD class
 | CompositeUnitOfMeasure | Element 4
 | Description | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionCode | Element 7
 | SampleDescriptionCode | Element 5
 | SampleDirectionCode | Element 6
 | SampleFrequencyValuePerUnitOfMeasurementCode | Element 3
 | SampleProcessStatusCode | Element 1
 | SampleSelectionMethodCode | Element 2
 | SampleSelectionModulus | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PSD


PSD Constructor

PSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► PSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PSD class
Declaration Syntax
C# Visual Basic Visual C++
public PSD()
Public Sub New
public:
PSD()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► Description
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PositionCode Property

PositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► PositionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PositionCode { get; set; }
Public Property PositionCode As String
    Get
    Set
public:
property String^ PositionCode {
    String^ get ();
    void set (String^ value);
}


SampleDescriptionCode Property

SampleDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► SampleDescriptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SampleDescriptionCode { get; set; }
Public Property SampleDescriptionCode As String
    Get
    Set
public:
property String^ SampleDescriptionCode {
    String^ get ();
    void set (String^ value);
}


SampleDirectionCode Property

SampleDirectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► SampleDirectionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SampleDirectionCode { get; set; }
Public Property SampleDirectionCode As String
    Get
    Set
public:
property String^ SampleDirectionCode {
    String^ get ();
    void set (String^ value);
}


SampleFrequencyValuePerUnitOfMeasurementCode Property

SampleFrequencyValuePerUnitOfMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► SampleFrequencyValuePerUnitOfMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SampleFrequencyValuePerUnitOfMeasurementCode { get; set; }
Public Property SampleFrequencyValuePerUnitOfMeasurementCode As String
    Get
    Set
public:
property String^ SampleFrequencyValuePerUnitOfMeasurementCode {
    String^ get ();
    void set (String^ value);
}


SampleProcessStatusCode Property

SampleProcessStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► SampleProcessStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SampleProcessStatusCode { get; set; }
Public Property SampleProcessStatusCode As String
    Get
    Set
public:
property String^ SampleProcessStatusCode {
    String^ get ();
    void set (String^ value);
}


SampleSelectionMethodCode Property

SampleSelectionMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► SampleSelectionMethodCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SampleSelectionMethodCode { get; set; }
Public Property SampleSelectionMethodCode As String
    Get
    Set
public:
property String^ SampleSelectionMethodCode {
    String^ get ();
    void set (String^ value);
}


SampleSelectionModulus Property

SampleSelectionModulus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► SampleSelectionModulus
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SampleSelectionModulus { get; set; }
Public Property SampleSelectionModulus As String
    Get
    Set
public:
property String^ SampleSelectionModulus {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PT Class

PT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT
RDPCrystal EDI Library
Patron
Declaration Syntax
C# Visual Basic Visual C++
public class PT : DocumentSegment
Public Class PT _
    Inherits DocumentSegment
public ref class PT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PT()()()() | Initializes a new instance of the PT class
 | ChangeTypeCode | Element 6
 | ConditionSegmentLogicalConnector | Element 1
 | DocketControlNumber | Element 8
 | DocketIdentification | Element 9
 | EntityIdentifierCode | Element 2
 | EntityRelationshipCode | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupTitle | Element 10
 | IdentificationCode | Element 5
 | IdentificationCodeQualifier | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PT


PT Constructor

PT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► PT()()()()
RDPCrystal EDI Library
Initializes a new instance of the PT class
Declaration Syntax
C# Visual Basic Visual C++
public PT()
Public Sub New
public:
PT()


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► ChangeTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


ConditionSegmentLogicalConnector Property

ConditionSegmentLogicalConnector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► ConditionSegmentLogicalConnector
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionSegmentLogicalConnector { get; set; }
Public Property ConditionSegmentLogicalConnector As String
    Get
    Set
public:
property String^ ConditionSegmentLogicalConnector {
    String^ get ();
    void set (String^ value);
}


DocketControlNumber Property

DocketControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► DocketControlNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DocketControlNumber { get; set; }
Public Property DocketControlNumber As String
    Get
    Set
public:
property String^ DocketControlNumber {
    String^ get ();
    void set (String^ value);
}


DocketIdentification Property

DocketIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► DocketIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DocketIdentification { get; set; }
Public Property DocketIdentification As String
    Get
    Set
public:
property String^ DocketIdentification {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► EntityIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► EntityRelationshipCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}


GroupTitle Property

GroupTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► GroupTitle
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string GroupTitle { get; set; }
Public Property GroupTitle As String
    Get
    Set
public:
property String^ GroupTitle {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PTD Class

PTD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD
RDPCrystal EDI Library
Product Transfer and Resale Detail
Declaration Syntax
C# Visual Basic Visual C++
public class PTD : DocumentSegment
Public Class PTD _
    Inherits DocumentSegment
public ref class PTD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PTD()()()() | Initializes a new instance of the PTD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceMultiplierQualifier | Element 2
 | ProductTransferMovementTypeCode | Element 6
 | ProductTransferTypeCode | Element 1
 | ReferenceIdentification | Element 5
 | ReferenceIdentificationQualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PTD


PTD Constructor

PTD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► PTD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PTD class
Declaration Syntax
C# Visual Basic Visual C++
public PTD()
Public Sub New
public:
PTD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► Multiplier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


PriceMultiplierQualifier Property

PriceMultiplierQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► PriceMultiplierQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PriceMultiplierQualifier { get; set; }
Public Property PriceMultiplierQualifier As String
    Get
    Set
public:
property String^ PriceMultiplierQualifier {
    String^ get ();
    void set (String^ value);
}


ProductTransferMovementTypeCode Property

ProductTransferMovementTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► ProductTransferMovementTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductTransferMovementTypeCode { get; set; }
Public Property ProductTransferMovementTypeCode As String
    Get
    Set
public:
property String^ ProductTransferMovementTypeCode {
    String^ get ();
    void set (String^ value);
}


ProductTransferTypeCode Property

ProductTransferTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► ProductTransferTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductTransferTypeCode { get; set; }
Public Property ProductTransferTypeCode As String
    Get
    Set
public:
property String^ ProductTransferTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PTF Class

PTF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF
RDPCrystal EDI Library
Property Transaction Financials
Declaration Syntax
C# Visual Basic Visual C++
public class PTF : DocumentSegment
Public Class PTF _
    Inherits DocumentSegment
public ref class PTF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PTF()()()() | Initializes a new instance of the PTF class
 | AmountQualifierCode | Element 1
 | CompositeUnitOfMeasure | Element 4
 | EntityIdentifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TaxExemptCode | Element 7
 | TaxTypeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PTF


PTF Constructor

PTF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► PTF()()()()
RDPCrystal EDI Library
Initializes a new instance of the PTF class
Declaration Syntax
C# Visual Basic Visual C++
public PTF()
Public Sub New
public:
PTF()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► AmountQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► EntityIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► FrequencyCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


TaxExemptCode Property

TaxExemptCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► TaxExemptCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TaxExemptCode { get; set; }
Public Property TaxExemptCode As String
    Get
    Set
public:
property String^ TaxExemptCode {
    String^ get ();
    void set (String^ value);
}


TaxTypeCode Property

TaxTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► TaxTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TaxTypeCode { get; set; }
Public Property TaxTypeCode As String
    Get
    Set
public:
property String^ TaxTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PTF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PUN Class

PUN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN
RDPCrystal EDI Library
Beginning Segment for Motor Carrier Pick-up Notification
Declaration Syntax
C# Visual Basic Visual C++
public class PUN : DocumentSegment
Public Class PUN _
    Inherits DocumentSegment
public ref class PUN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PUN()()()() | Initializes a new instance of the PUN class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | StandardCarrierAlphaCode | Element 1
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PUN


PUN Constructor

PUN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► PUN()()()()
RDPCrystal EDI Library
Initializes a new instance of the PUN class
Declaration Syntax
C# Visual Basic Visual C++
public PUN()
Public Sub New
public:
PUN()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PUN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PWK Class

PWK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK
RDPCrystal EDI Library
Paperwork
Declaration Syntax
C# Visual Basic Visual C++
public class PWK : DocumentSegment
Public Class PWK _
    Inherits DocumentSegment
public ref class PWK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PWK()()()() | Initializes a new instance of the PWK class
 | ActionsIndicated | Element 8
 | Description | Element 7
 | EntityIdentifierCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 6
 | IdentificationCodeQualifier | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportCopiesNeeded | Element 3
 | ReportTransmissionCode | Element 2
 | ReportTypeCode | Element 1
 | RequestCategoryCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PWK


PWK Constructor

PWK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► PWK()()()()
RDPCrystal EDI Library
Initializes a new instance of the PWK class
Declaration Syntax
C# Visual Basic Visual C++
public PWK()
Public Sub New
public:
PWK()


ActionsIndicated Property

ActionsIndicated Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► ActionsIndicated
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public ActionsIndicated ActionsIndicated { get; set; }
Public Property ActionsIndicated As ActionsIndicated
    Get
    Set
public:
property ActionsIndicated^ ActionsIndicated {
    ActionsIndicated^ get ();
    void set (ActionsIndicated^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► EntityIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► IdentificationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReportCopiesNeeded Property

ReportCopiesNeeded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► ReportCopiesNeeded
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReportCopiesNeeded { get; set; }
Public Property ReportCopiesNeeded As String
    Get
    Set
public:
property String^ ReportCopiesNeeded {
    String^ get ();
    void set (String^ value);
}


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► ReportTransmissionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


RequestCategoryCode Property

RequestCategoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► RequestCategoryCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RequestCategoryCode { get; set; }
Public Property RequestCategoryCode As String
    Get
    Set
public:
property String^ RequestCategoryCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PWK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PYD Class

PYD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD
RDPCrystal EDI Library
Payroll Deduction
Declaration Syntax
C# Visual Basic Visual C++
public class PYD : DocumentSegment
Public Class PYD _
    Inherits DocumentSegment
public ref class PYD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PYD()()()() | Initializes a new instance of the PYD class
 | DeductionTypeCode | Element 4
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TaxTreatmentCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PYD


PYD Constructor

PYD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► PYD()()()()
RDPCrystal EDI Library
Initializes a new instance of the PYD class
Declaration Syntax
C# Visual Basic Visual C++
public PYD()
Public Sub New
public:
PYD()


DeductionTypeCode Property

DeductionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► DeductionTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DeductionTypeCode { get; set; }
Public Property DeductionTypeCode As String
    Get
    Set
public:
property String^ DeductionTypeCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► FrequencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


TaxTreatmentCode Property

TaxTreatmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► TaxTreatmentCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TaxTreatmentCode { get; set; }
Public Property TaxTreatmentCode As String
    Get
    Set
public:
property String^ TaxTreatmentCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PYM Class

PYM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM
RDPCrystal EDI Library
Payment Manner and Percentage
Declaration Syntax
C# Visual Basic Visual C++
public class PYM : DocumentSegment
Public Class PYM _
    Inherits DocumentSegment
public ref class PYM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PYM()()()() | Initializes a new instance of the PYM class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 3
 | NumberOfPeriods1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | RatingCode | Element 1
 | RatingRemarksCode | Element 6
 | TimePeriodQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PYM


PYM Constructor

PYM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► PYM()()()()
RDPCrystal EDI Library
Initializes a new instance of the PYM class
Declaration Syntax
C# Visual Basic Visual C++
public PYM()
Public Sub New
public:
PYM()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► NumberOfPeriods
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}


NumberOfPeriods1 Property

NumberOfPeriods1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► NumberOfPeriods1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods1 { get; set; }
Public Property NumberOfPeriods1 As String
    Get
    Set
public:
property String^ NumberOfPeriods1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RatingCode Property

RatingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► RatingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RatingCode { get; set; }
Public Property RatingCode As String
    Get
    Set
public:
property String^ RatingCode {
    String^ get ();
    void set (String^ value);
}


RatingRemarksCode Property

RatingRemarksCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► RatingRemarksCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RatingRemarksCode { get; set; }
Public Property RatingRemarksCode As String
    Get
    Set
public:
property String^ RatingRemarksCode {
    String^ get ();
    void set (String^ value);
}


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► TimePeriodQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


PYT Class

PYT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT
RDPCrystal EDI Library
Historical Payment Terms
Declaration Syntax
C# Visual Basic Visual C++
public class PYT : DocumentSegment
Public Class PYT _
    Inherits DocumentSegment
public ref class PYT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PYT()()()() | Initializes a new instance of the PYT class
 | DayOfMonth | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TermsDiscountDaysDue | Element 7
 | TermsDiscountDaysDue1 | Element 8
 | TermsDiscountPercent | Element 4
 | TermsDiscountPercent1 | Element 5
 | TermsNetDays | Element 1
 | TermsTypeCode | Element 2
 | TermsTypeCode1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PYT


PYT Constructor

PYT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► PYT()()()()
RDPCrystal EDI Library
Initializes a new instance of the PYT class
Declaration Syntax
C# Visual Basic Visual C++
public PYT()
Public Sub New
public:
PYT()


DayOfMonth Property

DayOfMonth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► DayOfMonth
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DayOfMonth { get; set; }
Public Property DayOfMonth As String
    Get
    Set
public:
property String^ DayOfMonth {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TermsDiscountDaysDue Property

TermsDiscountDaysDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsDiscountDaysDue
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountDaysDue { get; set; }
Public Property TermsDiscountDaysDue As String
    Get
    Set
public:
property String^ TermsDiscountDaysDue {
    String^ get ();
    void set (String^ value);
}


TermsDiscountDaysDue1 Property

TermsDiscountDaysDue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsDiscountDaysDue1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountDaysDue1 { get; set; }
Public Property TermsDiscountDaysDue1 As String
    Get
    Set
public:
property String^ TermsDiscountDaysDue1 {
    String^ get ();
    void set (String^ value);
}


TermsDiscountPercent Property

TermsDiscountPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsDiscountPercent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent { get; set; }
Public Property TermsDiscountPercent As String
    Get
    Set
public:
property String^ TermsDiscountPercent {
    String^ get ();
    void set (String^ value);
}


TermsDiscountPercent1 Property

TermsDiscountPercent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsDiscountPercent1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent1 { get; set; }
Public Property TermsDiscountPercent1 As String
    Get
    Set
public:
property String^ TermsDiscountPercent1 {
    String^ get ();
    void set (String^ value);
}


TermsNetDays Property

TermsNetDays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsNetDays
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TermsNetDays { get; set; }
Public Property TermsNetDays As String
    Get
    Set
public:
property String^ TermsNetDays {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode Property

TermsTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode { get; set; }
Public Property TermsTypeCode As String
    Get
    Set
public:
property String^ TermsTypeCode {
    String^ get ();
    void set (String^ value);
}


TermsTypeCode1 Property

TermsTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► TermsTypeCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TermsTypeCode1 { get; set; }
Public Property TermsTypeCode1 As String
    Get
    Set
public:
property String^ TermsTypeCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► PYT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Q2 Class

Q2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2
RDPCrystal EDI Library
Status Details (Ocean)
Declaration Syntax
C# Visual Basic Visual C++
public class Q2 : DocumentSegment
Public Class Q2 _
    Inherits DocumentSegment
public ref class Q2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Q2()()()() | Initializes a new instance of the Q2 class
 | CountryCode | Element 2
 | Date | Element 3
 | Date1 | Element 4
 | Date2 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 11
 | ReferenceIdentificationQualifier | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VesselCode | Element 1
 | VesselCodeQualifier | Element 12
 | VesselName | Element 13
 | Volume | Element 14
 | VolumeUnitQualifier | Element 15
 | Weight | Element 7
 | WeightQualifier | Element 8
 | WeightUnitCode | Element 16
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Q2


Q2 Constructor

Q2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Q2()()()()
RDPCrystal EDI Library
Initializes a new instance of the Q2 class
Declaration Syntax
C# Visual Basic Visual C++
public Q2()
Public Sub New
public:
Q2()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► CountryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Date2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► FlightVoyageNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► LadingQuantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► VesselCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselCodeQualifier Property

VesselCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► VesselCodeQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCodeQualifier { get; set; }
Public Property VesselCodeQualifier As String
    Get
    Set
public:
property String^ VesselCodeQualifier {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► VesselName
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Volume
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Weight
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► WeightQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► WeightUnitCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Q3 Class

Q3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q3
RDPCrystal EDI Library
Arrival Details
Declaration Syntax
C# Visual Basic Visual C++
public class Q3 : DocumentSegment
Public Class Q3 _
    Inherits DocumentSegment
public ref class Q3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Q3()()()() | Initializes a new instance of the Q3 class
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentMethodOfPayment | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Q3


Q3 Constructor

Q3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q3 ► Q3()()()()
RDPCrystal EDI Library
Initializes a new instance of the Q3 class
Declaration Syntax
C# Visual Basic Visual C++
public Q3()
Public Sub New
public:
Q3()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q3 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q3 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Q5 Class

Q5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5
RDPCrystal EDI Library
Status Details
Declaration Syntax
C# Visual Basic Visual C++
public class Q5 : DocumentSegment
Public Class Q5 _
    Inherits DocumentSegment
public ref class Q5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Q5()()()() | Initializes a new instance of the Q5 class
 | CityName | Element 6
 | CountryCode | Element 8
 | Date | Element 2
 | DirectionIdentifierCode | Element 13
 | DirectionIdentifierCode1 | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 9
 | EquipmentNumber | Element 10
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 17
 | PickupOrDeliveryCode | Element 18
 | ReferenceIdentification | Element 12
 | ReferenceIdentification1 | Element 15
 | ReferenceIdentificationQualifier | Element 11
 | ReferenceIdentificationQualifier1 | Element 14
 | ShipmentStatusCode | Element 1
 | StateOrProvinceCode | Element 7
 | StatusReasonCode | Element 5
 | Time | Element 3
 | TimeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Q5


Q5 Constructor

Q5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► Q5()()()()
RDPCrystal EDI Library
Initializes a new instance of the Q5 class
Declaration Syntax
C# Visual Basic Visual C++
public Q5()
Public Sub New
public:
Q5()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► CityName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► CountryCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DirectionIdentifierCode Property

DirectionIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► DirectionIdentifierCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode { get; set; }
Public Property DirectionIdentifierCode As String
    Get
    Set
public:
property String^ DirectionIdentifierCode {
    String^ get ();
    void set (String^ value);
}


DirectionIdentifierCode1 Property

DirectionIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► DirectionIdentifierCode1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DirectionIdentifierCode1 { get; set; }
Public Property DirectionIdentifierCode1 As String
    Get
    Set
public:
property String^ DirectionIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► EquipmentInitial
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► EquipmentNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► Percent
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► ReferenceIdentification
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


ShipmentStatusCode Property

ShipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► ShipmentStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusCode { get; set; }
Public Property ShipmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► StatusReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► TimeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Q6 Class

Q6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6
RDPCrystal EDI Library
Shipment Details
Declaration Syntax
C# Visual Basic Visual C++
public class Q6 : DocumentSegment
Public Class Q6 _
    Inherits DocumentSegment
public ref class Q6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Q6()()()() | Initializes a new instance of the Q6 class
 | CurrencyCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetAmountDue | Element 7
 | PackagingFormCode | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceLevelCode | Element 11
 | ServiceLevelCode1 | Element 12
 | ServiceStandard | Element 10
 | ShipmentMethodOfPayment | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 9
 | Weight | Element 1
 | WeightQualifier | Element 3
 | WeightUnitCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Q6


Q6 Constructor

Q6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► Q6()()()()
RDPCrystal EDI Library
Initializes a new instance of the Q6 class
Declaration Syntax
C# Visual Basic Visual C++
public Q6()
Public Sub New
public:
Q6()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► CurrencyCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► LadingQuantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetAmountDue Property

NetAmountDue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► NetAmountDue
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NetAmountDue { get; set; }
Public Property NetAmountDue As String
    Get
    Set
public:
property String^ NetAmountDue {
    String^ get ();
    void set (String^ value);
}


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► PackagingFormCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► ServiceLevelCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode1 Property

ServiceLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► ServiceLevelCode1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode1 { get; set; }
Public Property ServiceLevelCode1 As String
    Get
    Set
public:
property String^ ServiceLevelCode1 {
    String^ get ();
    void set (String^ value);
}


ServiceStandard Property

ServiceStandard Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► ServiceStandard
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceStandard { get; set; }
Public Property ServiceStandard As String
    Get
    Set
public:
property String^ ServiceStandard {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► Weight
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► WeightQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► WeightUnitCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Q7 Class

Q7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7
RDPCrystal EDI Library
Lading Exception Code
Declaration Syntax
C# Visual Basic Visual C++
public class Q7 : DocumentSegment
Public Class Q7 _
    Inherits DocumentSegment
public ref class Q7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Q7()()()() | Initializes a new instance of the Q7 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingExceptionCode | Element 1
 | LadingQuantity | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingFormCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Q7


Q7 Constructor

Q7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7 ► Q7()()()()
RDPCrystal EDI Library
Initializes a new instance of the Q7 class
Declaration Syntax
C# Visual Basic Visual C++
public Q7()
Public Sub New
public:
Q7()


LadingExceptionCode Property

LadingExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7 ► LadingExceptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingExceptionCode { get; set; }
Public Property LadingExceptionCode As String
    Get
    Set
public:
property String^ LadingExceptionCode {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7 ► LadingQuantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7 ► PackagingFormCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Q8 Class

Q8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8
RDPCrystal EDI Library
Detail Delivery Exception Information
Declaration Syntax
C# Visual Basic Visual C++
public class Q8 : DocumentSegment
Public Class Q8 _
    Inherits DocumentSegment
public ref class Q8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Q8()()()() | Initializes a new instance of the Q8 class
 | ActionCode | Element 8
 | DamageReasonCode | Element 7
 | Description | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 6
 | LadingExceptionCode | Element 1
 | LadingQuantity | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingFormCode | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 5
 | ProductServiceIDQualifier | Element 4
 | ReferenceIdentification | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Q8


Q8 Constructor

Q8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► Q8()()()()
RDPCrystal EDI Library
Initializes a new instance of the Q8 class
Declaration Syntax
C# Visual Basic Visual C++
public Q8()
Public Sub New
public:
Q8()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► ActionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


DamageReasonCode Property

DamageReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► DamageReasonCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DamageReasonCode { get; set; }
Public Property DamageReasonCode As String
    Get
    Set
public:
property String^ DamageReasonCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► LadingDescription
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


LadingExceptionCode Property

LadingExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► LadingExceptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LadingExceptionCode { get; set; }
Public Property LadingExceptionCode As String
    Get
    Set
public:
property String^ LadingExceptionCode {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► LadingQuantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingFormCode Property

PackagingFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► PackagingFormCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingFormCode { get; set; }
Public Property PackagingFormCode As String
    Get
    Set
public:
property String^ PackagingFormCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► ProductServiceID
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Q8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


QTY Class

QTY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY
RDPCrystal EDI Library
Quantity
Declaration Syntax
C# Visual Basic Visual C++
public class QTY : DocumentSegment
Public Class QTY _
    Inherits DocumentSegment
public ref class QTY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QTY()()()() | Initializes a new instance of the QTY class
 | CompositeUnitOfMeasure | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | QuantityQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | QTY


QTY Constructor

QTY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► QTY()()()()
RDPCrystal EDI Library
Initializes a new instance of the QTY class
Declaration Syntax
C# Visual Basic Visual C++
public QTY()
Public Sub New
public:
QTY()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► FreeFormMessage
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► QTY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R1 Class

R1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1
RDPCrystal EDI Library
Route Information (Air)
Declaration Syntax
C# Visual Basic Visual C++
public class R1 : DocumentSegment
Public Class R1 _
    Inherits DocumentSegment
public ref class R1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R1()()()() | Initializes a new instance of the R1 class
 | AirCarrierCode | Element 4
 | AirCarrierCode1 | Element 6
 | AirCarrierCode2 | Element 8
 | AirCarrierCode3 | Element 10
 | AirCarrierCode4 | Element 12
 | AirportCode | Element 3
 | AirportCode1 | Element 5
 | AirportCode2 | Element 7
 | AirportCode3 | Element 9
 | AirportCode4 | Element 11
 | AirportCode5 | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R1


R1 Constructor

R1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► R1()()()()
RDPCrystal EDI Library
Initializes a new instance of the R1 class
Declaration Syntax
C# Visual Basic Visual C++
public R1()
Public Sub New
public:
R1()


AirCarrierCode Property

AirCarrierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirCarrierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AirCarrierCode { get; set; }
Public Property AirCarrierCode As String
    Get
    Set
public:
property String^ AirCarrierCode {
    String^ get ();
    void set (String^ value);
}


AirCarrierCode1 Property

AirCarrierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirCarrierCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AirCarrierCode1 { get; set; }
Public Property AirCarrierCode1 As String
    Get
    Set
public:
property String^ AirCarrierCode1 {
    String^ get ();
    void set (String^ value);
}


AirCarrierCode2 Property

AirCarrierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirCarrierCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AirCarrierCode2 { get; set; }
Public Property AirCarrierCode2 As String
    Get
    Set
public:
property String^ AirCarrierCode2 {
    String^ get ();
    void set (String^ value);
}


AirCarrierCode3 Property

AirCarrierCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirCarrierCode3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AirCarrierCode3 { get; set; }
Public Property AirCarrierCode3 As String
    Get
    Set
public:
property String^ AirCarrierCode3 {
    String^ get ();
    void set (String^ value);
}


AirCarrierCode4 Property

AirCarrierCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirCarrierCode4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AirCarrierCode4 { get; set; }
Public Property AirCarrierCode4 As String
    Get
    Set
public:
property String^ AirCarrierCode4 {
    String^ get ();
    void set (String^ value);
}


AirportCode Property

AirportCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirportCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AirportCode { get; set; }
Public Property AirportCode As String
    Get
    Set
public:
property String^ AirportCode {
    String^ get ();
    void set (String^ value);
}


AirportCode1 Property

AirportCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirportCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AirportCode1 { get; set; }
Public Property AirportCode1 As String
    Get
    Set
public:
property String^ AirportCode1 {
    String^ get ();
    void set (String^ value);
}


AirportCode2 Property

AirportCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirportCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AirportCode2 { get; set; }
Public Property AirportCode2 As String
    Get
    Set
public:
property String^ AirportCode2 {
    String^ get ();
    void set (String^ value);
}


AirportCode3 Property

AirportCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirportCode3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AirportCode3 { get; set; }
Public Property AirportCode3 As String
    Get
    Set
public:
property String^ AirportCode3 {
    String^ get ();
    void set (String^ value);
}


AirportCode4 Property

AirportCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirportCode4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string AirportCode4 { get; set; }
Public Property AirportCode4 As String
    Get
    Set
public:
property String^ AirportCode4 {
    String^ get ();
    void set (String^ value);
}


AirportCode5 Property

AirportCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► AirportCode5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string AirportCode5 { get; set; }
Public Property AirportCode5 As String
    Get
    Set
public:
property String^ AirportCode5 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R2 Class

R2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2
RDPCrystal EDI Library
Route Information
Declaration Syntax
C# Visual Basic Visual C++
public class R2 : DocumentSegment
Public Class R2 _
    Inherits DocumentSegment
public ref class R2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R2()()()() | Initializes a new instance of the R2 class
 | CityName | Element 3
 | Date | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 11
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermediateSwitchCarrier | Element 7
 | IntermediateSwitchCarrier1 | Element 8
 | IntermodalServiceCode | Element 5
 | InvoiceNumber | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RouteDescription | Element 13
 | RoutingSequenceCode | Element 2
 | StandardCarrierAlphaCode | Element 1
 | StandardPointLocationCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 6
 | TypeOfServiceCode | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R2


R2 Constructor

R2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► R2()()()()
RDPCrystal EDI Library
Initializes a new instance of the R2 class
Declaration Syntax
C# Visual Basic Visual C++
public R2()
Public Sub New
public:
R2()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► Date
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► FreeformDescription
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


IntermediateSwitchCarrier Property

IntermediateSwitchCarrier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► IntermediateSwitchCarrier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IntermediateSwitchCarrier { get; set; }
Public Property IntermediateSwitchCarrier As String
    Get
    Set
public:
property String^ IntermediateSwitchCarrier {
    String^ get ();
    void set (String^ value);
}


IntermediateSwitchCarrier1 Property

IntermediateSwitchCarrier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► IntermediateSwitchCarrier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IntermediateSwitchCarrier1 { get; set; }
Public Property IntermediateSwitchCarrier1 As String
    Get
    Set
public:
property String^ IntermediateSwitchCarrier1 {
    String^ get ();
    void set (String^ value);
}


IntermodalServiceCode Property

IntermodalServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► IntermodalServiceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalServiceCode { get; set; }
Public Property IntermodalServiceCode As String
    Get
    Set
public:
property String^ IntermodalServiceCode {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► InvoiceNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RouteDescription Property

RouteDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► RouteDescription
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string RouteDescription { get; set; }
Public Property RouteDescription As String
    Get
    Set
public:
property String^ RouteDescription {
    String^ get ();
    void set (String^ value);
}


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► RoutingSequenceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► TypeOfServiceCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R2A Class

R2A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A
RDPCrystal EDI Library
Route Information with Preference
Declaration Syntax
C# Visual Basic Visual C++
public class R2A : DocumentSegment
Public Class R2A _
    Inherits DocumentSegment
public ref class R2A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R2A()()()() | Initializes a new instance of the R2A class
 | EntityIdentifierCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 6
 | LocationQualifier | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Preference | Element 2
 | RouteCode | Element 8
 | RouteDescription | Element 9
 | RoutingSequenceCode | Element 1
 | StandardCarrierAlphaCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 3
 | TypeOfServiceCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R2A


R2A Constructor

R2A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► R2A()()()()
RDPCrystal EDI Library
Initializes a new instance of the R2A class
Declaration Syntax
C# Visual Basic Visual C++
public R2A()
Public Sub New
public:
R2A()


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► EntityIdentifierCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► LocationIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► LocationQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


Preference Property

Preference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► Preference
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Preference { get; set; }
Public Property Preference As String
    Get
    Set
public:
property String^ Preference {
    String^ get ();
    void set (String^ value);
}


RouteCode Property

RouteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► RouteCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RouteCode { get; set; }
Public Property RouteCode As String
    Get
    Set
public:
property String^ RouteCode {
    String^ get ();
    void set (String^ value);
}


RouteDescription Property

RouteDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► RouteDescription
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RouteDescription { get; set; }
Public Property RouteDescription As String
    Get
    Set
public:
property String^ RouteDescription {
    String^ get ();
    void set (String^ value);
}


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► RoutingSequenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► TypeOfServiceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R2B Class

R2B Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B
RDPCrystal EDI Library
Junctions and Proportions
Declaration Syntax
C# Visual Basic Visual C++
public class R2B : DocumentSegment
Public Class R2B _
    Inherits DocumentSegment
public ref class R2B : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R2B()()()() | Initializes a new instance of the R2B class
 | Amount | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rule260JunctionCode | Element 2
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R2B


R2B Constructor

R2B Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B ► R2B()()()()
RDPCrystal EDI Library
Initializes a new instance of the R2B class
Declaration Syntax
C# Visual Basic Visual C++
public R2B()
Public Sub New
public:
R2B()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B ► Rule260JunctionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2B ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R2C Class

R2C Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C
RDPCrystal EDI Library
Division Basis
Declaration Syntax
C# Visual Basic Visual C++
public class R2C : DocumentSegment
Public Class R2C _
    Inherits DocumentSegment
public ref class R2C : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R2C()()()() | Initializes a new instance of the R2C class
 | DivisionTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FactorAmount | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R2C


R2C Constructor

R2C Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C ► R2C()()()()
RDPCrystal EDI Library
Initializes a new instance of the R2C class
Declaration Syntax
C# Visual Basic Visual C++
public R2C()
Public Sub New
public:
R2C()


DivisionTypeCode Property

DivisionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C ► DivisionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DivisionTypeCode { get; set; }
Public Property DivisionTypeCode As String
    Get
    Set
public:
property String^ DivisionTypeCode {
    String^ get ();
    void set (String^ value);
}


FactorAmount Property

FactorAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C ► FactorAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FactorAmount { get; set; }
Public Property FactorAmount As String
    Get
    Set
public:
property String^ FactorAmount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2C ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R2D Class

R2D Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2D
RDPCrystal EDI Library
Miscellaneous Charge
Declaration Syntax
C# Visual Basic Visual C++
public class R2D : DocumentSegment
Public Class R2D _
    Inherits DocumentSegment
public ref class R2D : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R2D()()()() | Initializes a new instance of the R2D class
 | Amount | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialChargeOrAllowanceCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R2D


R2D Constructor

R2D Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2D ► R2D()()()()
RDPCrystal EDI Library
Initializes a new instance of the R2D class
Declaration Syntax
C# Visual Basic Visual C++
public R2D()
Public Sub New
public:
R2D()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2D ► Amount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2D ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2D ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R2D ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R3 Class

R3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3
RDPCrystal EDI Library
Route Information - Motor
Declaration Syntax
C# Visual Basic Visual C++
public class R3 : DocumentSegment
Public Class R3 _
    Inherits DocumentSegment
public ref class R3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R3()()()() | Initializes a new instance of the R3 class
 | Amount | Element 8
 | CityName | Element 3
 | Date | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RoutingSequenceCode | Element 2
 | ServiceLevelCode | Element 10
 | ServiceLevelCode1 | Element 11
 | ServiceLevelCode2 | Element 12
 | StandardCarrierAlphaCode | Element 1
 | StandardPointLocationCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R3


R3 Constructor

R3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► R3()()()()
RDPCrystal EDI Library
Initializes a new instance of the R3 class
Declaration Syntax
C# Visual Basic Visual C++
public R3()
Public Sub New
public:
R3()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► Amount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► FreeformDescription
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► InvoiceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► RoutingSequenceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► ServiceLevelCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode1 Property

ServiceLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► ServiceLevelCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode1 { get; set; }
Public Property ServiceLevelCode1 As String
    Get
    Set
public:
property String^ ServiceLevelCode1 {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode2 Property

ServiceLevelCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► ServiceLevelCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode2 { get; set; }
Public Property ServiceLevelCode2 As String
    Get
    Set
public:
property String^ ServiceLevelCode2 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R4 Class

R4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4
RDPCrystal EDI Library
Port or Terminal
Declaration Syntax
C# Visual Basic Visual C++
public class R4 : DocumentSegment
Public Class R4 _
    Inherits DocumentSegment
public ref class R4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R4()()()() | Initializes a new instance of the R4 class
 | CountryCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 3
 | LocationQualifier | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PierNumber | Element 7
 | PortName | Element 4
 | PortOrTerminalFunctionCode | Element 1
 | StateOrProvinceCode | Element 8
 | TerminalName | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R4


R4 Constructor

R4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► R4()()()()
RDPCrystal EDI Library
Initializes a new instance of the R4 class
Declaration Syntax
C# Visual Basic Visual C++
public R4()
Public Sub New
public:
R4()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► CountryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► LocationIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► LocationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


PierNumber Property

PierNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► PierNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PierNumber { get; set; }
Public Property PierNumber As String
    Get
    Set
public:
property String^ PierNumber {
    String^ get ();
    void set (String^ value);
}


PortName Property

PortName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► PortName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PortName { get; set; }
Public Property PortName As String
    Get
    Set
public:
property String^ PortName {
    String^ get ();
    void set (String^ value);
}


PortOrTerminalFunctionCode Property

PortOrTerminalFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► PortOrTerminalFunctionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PortOrTerminalFunctionCode { get; set; }
Public Property PortOrTerminalFunctionCode As String
    Get
    Set
public:
property String^ PortOrTerminalFunctionCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TerminalName Property

TerminalName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► TerminalName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TerminalName { get; set; }
Public Property TerminalName As String
    Get
    Set
public:
property String^ TerminalName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


R9 Class

R9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9
RDPCrystal EDI Library
Route Code
Declaration Syntax
C# Visual Basic Visual C++
public class R9 : DocumentSegment
Public Class R9 _
    Inherits DocumentSegment
public ref class R9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | R9()()()() | Initializes a new instance of the R9 class
 | ActionCode | Element 5
 | AgentShipperRoutingCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermodalServiceCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RouteCode | Element 1
 | StandardCarrierAlphaCode | Element 4
 | StandardCarrierAlphaCode1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
 | YesNoConditionOrResponseCode1 | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | R9


R9 Constructor

R9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► R9()()()()
RDPCrystal EDI Library
Initializes a new instance of the R9 class
Declaration Syntax
C# Visual Basic Visual C++
public R9()
Public Sub New
public:
R9()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► ActionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AgentShipperRoutingCode Property

AgentShipperRoutingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► AgentShipperRoutingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgentShipperRoutingCode { get; set; }
Public Property AgentShipperRoutingCode As String
    Get
    Set
public:
property String^ AgentShipperRoutingCode {
    String^ get ();
    void set (String^ value);
}


IntermodalServiceCode Property

IntermodalServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► IntermodalServiceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalServiceCode { get; set; }
Public Property IntermodalServiceCode As String
    Get
    Set
public:
property String^ IntermodalServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RouteCode Property

RouteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► RouteCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RouteCode { get; set; }
Public Property RouteCode As String
    Get
    Set
public:
property String^ RouteCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► R9 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


RA Class

RA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA
RDPCrystal EDI Library
Rate Header
Declaration Syntax
C# Visual Basic Visual C++
public class RA : DocumentSegment
Public Class RA _
    Inherits DocumentSegment
public ref class RA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RA()()()() | Initializes a new instance of the RA class
 | AlternationPrecedenceCode | Element 4
 | Date | Element 9
 | Date1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfRates | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateLevel | Element 8
 | RateLevelQualifierCode | Element 7
 | RateValueQualifier | Element 2
 | RateValueQualifier1 | Element 3
 | RouteCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitConversionFactor | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RA


RA Constructor

RA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► RA()()()()
RDPCrystal EDI Library
Initializes a new instance of the RA class
Declaration Syntax
C# Visual Basic Visual C++
public RA()
Public Sub New
public:
RA()


AlternationPrecedenceCode Property

AlternationPrecedenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► AlternationPrecedenceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AlternationPrecedenceCode { get; set; }
Public Property AlternationPrecedenceCode As String
    Get
    Set
public:
property String^ AlternationPrecedenceCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► Date
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► Date1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfRates Property

NumberOfRates Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► NumberOfRates
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfRates { get; set; }
Public Property NumberOfRates As String
    Get
    Set
public:
property String^ NumberOfRates {
    String^ get ();
    void set (String^ value);
}


RateLevel Property

RateLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► RateLevel
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RateLevel { get; set; }
Public Property RateLevel As String
    Get
    Set
public:
property String^ RateLevel {
    String^ get ();
    void set (String^ value);
}


RateLevelQualifierCode Property

RateLevelQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► RateLevelQualifierCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RateLevelQualifierCode { get; set; }
Public Property RateLevelQualifierCode As String
    Get
    Set
public:
property String^ RateLevelQualifierCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► RateValueQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


RouteCode Property

RouteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► RouteCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RouteCode { get; set; }
Public Property RouteCode As String
    Get
    Set
public:
property String^ RouteCode {
    String^ get ();
    void set (String^ value);
}


UnitConversionFactor Property

UnitConversionFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► UnitConversionFactor
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitConversionFactor { get; set; }
Public Property UnitConversionFactor As String
    Get
    Set
public:
property String^ UnitConversionFactor {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RAB Class

RAB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB
RDPCrystal EDI Library
Rate or Minimum Qualifiers
Declaration Syntax
C# Visual Basic Visual C++
public class RAB : DocumentSegment
Public Class RAB _
    Inherits DocumentSegment
public ref class RAB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RAB()()()() | Initializes a new instance of the RAB class
 | AlternationPrecedenceCode | Element 3
 | AssignedNumber | Element 2
 | AssignedNumber1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadingRestriction | Element 6
 | LoadingRestriction1 | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumWeightLogic | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 8
 | RateValueQualifier | Element 1
 | RateValueQualifier1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitConversionFactor | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RAB


RAB Constructor

RAB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► RAB()()()()
RDPCrystal EDI Library
Initializes a new instance of the RAB class
Declaration Syntax
C# Visual Basic Visual C++
public RAB()
Public Sub New
public:
RAB()


AlternationPrecedenceCode Property

AlternationPrecedenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► AlternationPrecedenceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AlternationPrecedenceCode { get; set; }
Public Property AlternationPrecedenceCode As String
    Get
    Set
public:
property String^ AlternationPrecedenceCode {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► AssignedNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


AssignedNumber1 Property

AssignedNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► AssignedNumber1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber1 { get; set; }
Public Property AssignedNumber1 As String
    Get
    Set
public:
property String^ AssignedNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadingRestriction Property

LoadingRestriction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► LoadingRestriction
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction { get; set; }
Public Property LoadingRestriction As String
    Get
    Set
public:
property String^ LoadingRestriction {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction1 Property

LoadingRestriction1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► LoadingRestriction1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction1 { get; set; }
Public Property LoadingRestriction1 As String
    Get
    Set
public:
property String^ LoadingRestriction1 {
    String^ get ();
    void set (String^ value);
}


MinimumWeightLogic Property

MinimumWeightLogic Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► MinimumWeightLogic
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MinimumWeightLogic { get; set; }
Public Property MinimumWeightLogic As String
    Get
    Set
public:
property String^ MinimumWeightLogic {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► Percent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► RateValueQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


UnitConversionFactor Property

UnitConversionFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► UnitConversionFactor
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitConversionFactor { get; set; }
Public Property UnitConversionFactor As String
    Get
    Set
public:
property String^ UnitConversionFactor {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RAP Class

RAP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP
RDPCrystal EDI Library
Requirement, Attribute, and Proficiency
Declaration Syntax
C# Visual Basic Visual C++
public class RAP : DocumentSegment
Public Class RAP _
    Inherits DocumentSegment
public ref class RAP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RAP()()()() | Initializes a new instance of the RAP class
 | DateTimePeriod | Element 7
 | DateTimePeriodFormatQualifier | Element 6
 | EducationalTestOrRequirementCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | Name2 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UsageIndicator | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RAP


RAP Constructor

RAP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► RAP()()()()
RDPCrystal EDI Library
Initializes a new instance of the RAP class
Declaration Syntax
C# Visual Basic Visual C++
public RAP()
Public Sub New
public:
RAP()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


EducationalTestOrRequirementCode Property

EducationalTestOrRequirementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► EducationalTestOrRequirementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EducationalTestOrRequirementCode { get; set; }
Public Property EducationalTestOrRequirementCode As String
    Get
    Set
public:
property String^ EducationalTestOrRequirementCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► Name2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


UsageIndicator Property

UsageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► UsageIndicator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UsageIndicator { get; set; }
Public Property UsageIndicator As String
    Get
    Set
public:
property String^ UsageIndicator {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAP ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RAT Class

RAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT
RDPCrystal EDI Library
Adjustable Rate Description
Declaration Syntax
C# Visual Basic Visual C++
public class RAT : DocumentSegment
Public Class RAT _
    Inherits DocumentSegment
public ref class RAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RAT()()()() | Initializes a new instance of the RAT class
 | CompositeUnitOfMeasure | Element 1
 | CompositeUnitOfMeasure1 | Element 7
 | CompositeUnitOfMeasure2 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndexIdentityCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | Percent1 | Element 5
 | Percent2 | Element 6
 | Percent3 | Element 12
 | Percent4 | Element 13
 | Percent5 | Element 14
 | Percent6 | Element 17
 | Quantity | Element 2
 | Quantity1 | Element 8
 | Quantity2 | Element 10
 | RateLifeCapSourceCode | Element 16
 | RoundingSystemCode | Element 15
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RAT


RAT Constructor

RAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► RAT()()()()
RDPCrystal EDI Library
Initializes a new instance of the RAT class
Declaration Syntax
C# Visual Basic Visual C++
public RAT()
Public Sub New
public:
RAT()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure2 Property

CompositeUnitOfMeasure2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► CompositeUnitOfMeasure2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure2 { get; set; }
Public Property CompositeUnitOfMeasure2 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure2 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


IndexIdentityCode Property

IndexIdentityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► IndexIdentityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndexIdentityCode { get; set; }
Public Property IndexIdentityCode As String
    Get
    Set
public:
property String^ IndexIdentityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Percent1 Property

Percent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent1 { get; set; }
Public Property Percent1 As String
    Get
    Set
public:
property String^ Percent1 {
    String^ get ();
    void set (String^ value);
}


Percent2 Property

Percent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Percent2 { get; set; }
Public Property Percent2 As String
    Get
    Set
public:
property String^ Percent2 {
    String^ get ();
    void set (String^ value);
}


Percent3 Property

Percent3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Percent3 { get; set; }
Public Property Percent3 As String
    Get
    Set
public:
property String^ Percent3 {
    String^ get ();
    void set (String^ value);
}


Percent4 Property

Percent4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Percent4 { get; set; }
Public Property Percent4 As String
    Get
    Set
public:
property String^ Percent4 {
    String^ get ();
    void set (String^ value);
}


Percent5 Property

Percent5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Percent5 { get; set; }
Public Property Percent5 As String
    Get
    Set
public:
property String^ Percent5 {
    String^ get ();
    void set (String^ value);
}


Percent6 Property

Percent6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Percent6
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Percent6 { get; set; }
Public Property Percent6 As String
    Get
    Set
public:
property String^ Percent6 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Quantity1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Quantity2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


RateLifeCapSourceCode Property

RateLifeCapSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► RateLifeCapSourceCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string RateLifeCapSourceCode { get; set; }
Public Property RateLifeCapSourceCode As String
    Get
    Set
public:
property String^ RateLifeCapSourceCode {
    String^ get ();
    void set (String^ value);
}


RoundingSystemCode Property

RoundingSystemCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► RoundingSystemCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RoundingSystemCode { get; set; }
Public Property RoundingSystemCode As String
    Get
    Set
public:
property String^ RoundingSystemCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RAT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RB Class

RB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB
RDPCrystal EDI Library
Rate/Minimum Detail
Declaration Syntax
C# Visual Basic Visual C++
public class RB : DocumentSegment
Public Class RB _
    Inherits DocumentSegment
public ref class RB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RB()()()() | Initializes a new instance of the RB class
 | AssignedNumber | Element 1
 | ChangeTypeCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadingRestriction | Element 5
 | LoadingRestriction1 | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumWeightLogic | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | RateApplicationTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RB


RB Constructor

RB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► RB()()()()
RDPCrystal EDI Library
Initializes a new instance of the RB class
Declaration Syntax
C# Visual Basic Visual C++
public RB()
Public Sub New
public:
RB()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► ChangeTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadingRestriction Property

LoadingRestriction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► LoadingRestriction
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction { get; set; }
Public Property LoadingRestriction As String
    Get
    Set
public:
property String^ LoadingRestriction {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction1 Property

LoadingRestriction1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► LoadingRestriction1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction1 { get; set; }
Public Property LoadingRestriction1 As String
    Get
    Set
public:
property String^ LoadingRestriction1 {
    String^ get ();
    void set (String^ value);
}


MinimumWeightLogic Property

MinimumWeightLogic Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► MinimumWeightLogic
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MinimumWeightLogic { get; set; }
Public Property MinimumWeightLogic As String
    Get
    Set
public:
property String^ MinimumWeightLogic {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RateApplicationTypeCode Property

RateApplicationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► RateApplicationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateApplicationTypeCode { get; set; }
Public Property RateApplicationTypeCode As String
    Get
    Set
public:
property String^ RateApplicationTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RC Class

RC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC
RDPCrystal EDI Library
Root Cause
Declaration Syntax
C# Visual Basic Visual C++
public class RC : DocumentSegment
Public Class RC _
    Inherits DocumentSegment
public ref class RC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RC()()()() | Initializes a new instance of the RC class
 | AgencyQualifierCode | Element 4
 | CasualPartConditionCode | Element 6
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | SourceSubqualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RC


RC Constructor

RC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► RC()()()()
RDPCrystal EDI Library
Initializes a new instance of the RC class
Declaration Syntax
C# Visual Basic Visual C++
public RC()
Public Sub New
public:
RC()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► AgencyQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


CasualPartConditionCode Property

CasualPartConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► CasualPartConditionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CasualPartConditionCode { get; set; }
Public Property CasualPartConditionCode As String
    Get
    Set
public:
property String^ CasualPartConditionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► FreeFormMessageText
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► SourceSubqualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RCD Class

RCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD
RDPCrystal EDI Library
Receiving Conditions
Declaration Syntax
C# Visual Basic Visual C++
public class RCD : DocumentSegment
Public Class RCD _
    Inherits DocumentSegment
public ref class RCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RCD()()()() | Initializes a new instance of the RCD class
 | AssignedIdentification | Element 1
 | CompositeUnitOfMeasure | Element 3
 | CompositeUnitOfMeasure1 | Element 5
 | CompositeUnitOfMeasure2 | Element 7
 | CompositeUnitOfMeasure3 | Element 10
 | CompositeUnitOfMeasure4 | Element 13
 | CompositeUnitOfMeasure5 | Element 16
 | CompositeUnitOfMeasure6 | Element 19
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 21
 | QuantityInQuestion | Element 6
 | QuantityInQuestion1 | Element 9
 | QuantityInQuestion2 | Element 12
 | QuantityInQuestion3 | Element 15
 | QuantityInQuestion4 | Element 18
 | QuantityUnitsReceivedOrAccepted | Element 2
 | QuantityUnitsReturned | Element 4
 | ReceivingConditionCode | Element 8
 | ReceivingConditionCode1 | Element 11
 | ReceivingConditionCode2 | Element 14
 | ReceivingConditionCode3 | Element 17
 | ReceivingConditionCode4 | Element 20
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RCD


RCD Constructor

RCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► RCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the RCD class
Declaration Syntax
C# Visual Basic Visual C++
public RCD()
Public Sub New
public:
RCD()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure2 Property

CompositeUnitOfMeasure2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure2 { get; set; }
Public Property CompositeUnitOfMeasure2 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure2 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure3 Property

CompositeUnitOfMeasure3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure3 { get; set; }
Public Property CompositeUnitOfMeasure3 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure3 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure4 Property

CompositeUnitOfMeasure4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure4 { get; set; }
Public Property CompositeUnitOfMeasure4 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure4 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure5 Property

CompositeUnitOfMeasure5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure5
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure5 { get; set; }
Public Property CompositeUnitOfMeasure5 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure5 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure6 Property

CompositeUnitOfMeasure6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► CompositeUnitOfMeasure6
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure6 { get; set; }
Public Property CompositeUnitOfMeasure6 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure6 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► Quantity
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityInQuestion Property

QuantityInQuestion Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityInQuestion
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInQuestion { get; set; }
Public Property QuantityInQuestion As String
    Get
    Set
public:
property String^ QuantityInQuestion {
    String^ get ();
    void set (String^ value);
}


QuantityInQuestion1 Property

QuantityInQuestion1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityInQuestion1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInQuestion1 { get; set; }
Public Property QuantityInQuestion1 As String
    Get
    Set
public:
property String^ QuantityInQuestion1 {
    String^ get ();
    void set (String^ value);
}


QuantityInQuestion2 Property

QuantityInQuestion2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityInQuestion2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInQuestion2 { get; set; }
Public Property QuantityInQuestion2 As String
    Get
    Set
public:
property String^ QuantityInQuestion2 {
    String^ get ();
    void set (String^ value);
}


QuantityInQuestion3 Property

QuantityInQuestion3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityInQuestion3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInQuestion3 { get; set; }
Public Property QuantityInQuestion3 As String
    Get
    Set
public:
property String^ QuantityInQuestion3 {
    String^ get ();
    void set (String^ value);
}


QuantityInQuestion4 Property

QuantityInQuestion4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityInQuestion4
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityInQuestion4 { get; set; }
Public Property QuantityInQuestion4 As String
    Get
    Set
public:
property String^ QuantityInQuestion4 {
    String^ get ();
    void set (String^ value);
}


QuantityUnitsReceivedOrAccepted Property

QuantityUnitsReceivedOrAccepted Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityUnitsReceivedOrAccepted
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityUnitsReceivedOrAccepted { get; set; }
Public Property QuantityUnitsReceivedOrAccepted As String
    Get
    Set
public:
property String^ QuantityUnitsReceivedOrAccepted {
    String^ get ();
    void set (String^ value);
}


QuantityUnitsReturned Property

QuantityUnitsReturned Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► QuantityUnitsReturned
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityUnitsReturned { get; set; }
Public Property QuantityUnitsReturned As String
    Get
    Set
public:
property String^ QuantityUnitsReturned {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode Property

ReceivingConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► ReceivingConditionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode { get; set; }
Public Property ReceivingConditionCode As String
    Get
    Set
public:
property String^ ReceivingConditionCode {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode1 Property

ReceivingConditionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► ReceivingConditionCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode1 { get; set; }
Public Property ReceivingConditionCode1 As String
    Get
    Set
public:
property String^ ReceivingConditionCode1 {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode2 Property

ReceivingConditionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► ReceivingConditionCode2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode2 { get; set; }
Public Property ReceivingConditionCode2 As String
    Get
    Set
public:
property String^ ReceivingConditionCode2 {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode3 Property

ReceivingConditionCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► ReceivingConditionCode3
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode3 { get; set; }
Public Property ReceivingConditionCode3 As String
    Get
    Set
public:
property String^ ReceivingConditionCode3 {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode4 Property

ReceivingConditionCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► ReceivingConditionCode4
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode4 { get; set; }
Public Property ReceivingConditionCode4 As String
    Get
    Set
public:
property String^ ReceivingConditionCode4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RD Class

RD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD
RDPCrystal EDI Library
Rate Data
Declaration Syntax
C# Visual Basic Visual C++
public class RD : DocumentSegment
Public Class RD _
    Inherits DocumentSegment
public ref class RD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RD()()()() | Initializes a new instance of the RD class
 | AssignedNumber | Element 1
 | ChangeTypeCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateApplicationTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RD


RD Constructor

RD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► RD()()()()
RDPCrystal EDI Library
Initializes a new instance of the RD class
Declaration Syntax
C# Visual Basic Visual C++
public RD()
Public Sub New
public:
RD()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► ChangeTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateApplicationTypeCode Property

RateApplicationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► RateApplicationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateApplicationTypeCode { get; set; }
Public Property RateApplicationTypeCode As String
    Get
    Set
public:
property String^ RateApplicationTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RDD Class

RDD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD
RDPCrystal EDI Library
Route Description Detail
Declaration Syntax
C# Visual Basic Visual C++
public class RDD : DocumentSegment
Public Class RDD _
    Inherits DocumentSegment
public ref class RDD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDD()()()() | Initializes a new instance of the RDD class
 | AssignedNumber | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rule260JunctionCode | Element 2
 | Rule260JunctionCode1 | Element 4
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDD


RDD Constructor

RDD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► RDD()()()()
RDPCrystal EDI Library
Initializes a new instance of the RDD class
Declaration Syntax
C# Visual Basic Visual C++
public RDD()
Public Sub New
public:
RDD()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► AssignedNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► Rule260JunctionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


Rule260JunctionCode1 Property

Rule260JunctionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► Rule260JunctionCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode1 { get; set; }
Public Property Rule260JunctionCode1 As String
    Get
    Set
public:
property String^ Rule260JunctionCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RDI Class

RDI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI
RDPCrystal EDI Library
Retail Account Demographic Information
Declaration Syntax
C# Visual Basic Visual C++
public class RDI : DocumentSegment
Public Class RDI _
    Inherits DocumentSegment
public ref class RDI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDI()()()() | Initializes a new instance of the RDI class
 | Amount | Element 4
 | AmountQualifierCode | Element 3
 | CountryCode | Element 2
 | Description | Element 5
 | EntityIdentifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDI


RDI Constructor

RDI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► RDI()()()()
RDPCrystal EDI Library
Initializes a new instance of the RDI class
Declaration Syntax
C# Visual Basic Visual C++
public RDI()
Public Sub New
public:
RDI()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► AmountQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► CountryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RDM Class

RDM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM
RDPCrystal EDI Library
Remittance Delivery Method
Declaration Syntax
C# Visual Basic Visual C++
public class RDM : DocumentSegment
Public Class RDM _
    Inherits DocumentSegment
public ref class RDM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDM()()()() | Initializes a new instance of the RDM class
 | CommunicationNumber | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentifier | Element 4
 | ReferenceIdentifier1 | Element 5
 | ReportTransmissionCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDM


RDM Constructor

RDM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► RDM()()()()
RDPCrystal EDI Library
Initializes a new instance of the RDM class
Declaration Syntax
C# Visual Basic Visual C++
public RDM()
Public Sub New
public:
RDM()


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► CommunicationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► ReferenceIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


ReferenceIdentifier1 Property

ReferenceIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► ReferenceIdentifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier1 { get; set; }
Public Property ReferenceIdentifier1 As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier1 {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► ReportTransmissionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RDR Class

RDR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR
RDPCrystal EDI Library
Return Disposition Reason
Declaration Syntax
C# Visual Basic Visual C++
public class RDR : DocumentSegment
Public Class RDR _
    Inherits DocumentSegment
public ref class RDR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDR()()()() | Initializes a new instance of the RDR class
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReturnRequestReasonCode | Element 2
 | ReturnResponseReasonCode | Element 3
 | ReturnsDispositionCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDR


RDR Constructor

RDR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► RDR()()()()
RDPCrystal EDI Library
Initializes a new instance of the RDR class
Declaration Syntax
C# Visual Basic Visual C++
public RDR()
Public Sub New
public:
RDR()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReturnRequestReasonCode Property

ReturnRequestReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► ReturnRequestReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnRequestReasonCode { get; set; }
Public Property ReturnRequestReasonCode As String
    Get
    Set
public:
property String^ ReturnRequestReasonCode {
    String^ get ();
    void set (String^ value);
}


ReturnResponseReasonCode Property

ReturnResponseReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► ReturnResponseReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnResponseReasonCode { get; set; }
Public Property ReturnResponseReasonCode As String
    Get
    Set
public:
property String^ ReturnResponseReasonCode {
    String^ get ();
    void set (String^ value);
}


ReturnsDispositionCode Property

ReturnsDispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► ReturnsDispositionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsDispositionCode { get; set; }
Public Property ReturnsDispositionCode As String
    Get
    Set
public:
property String^ ReturnsDispositionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RDT Class

RDT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT
RDPCrystal EDI Library
Revision Date/Time
Declaration Syntax
C# Visual Basic Visual C++
public class RDT : DocumentSegment
Public Class RDT _
    Inherits DocumentSegment
public ref class RDT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDT()()()() | Initializes a new instance of the RDT class
 | Date | Element 4
 | DateTimeQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RevisionLevelCode | Element 1
 | RevisionValue | Element 2
 | Time | Element 5
 | TimeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDT


RDT Constructor

RDT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► RDT()()()()
RDPCrystal EDI Library
Initializes a new instance of the RDT class
Declaration Syntax
C# Visual Basic Visual C++
public RDT()
Public Sub New
public:
RDT()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RevisionLevelCode Property

RevisionLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► RevisionLevelCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionLevelCode { get; set; }
Public Property RevisionLevelCode As String
    Get
    Set
public:
property String^ RevisionLevelCode {
    String^ get ();
    void set (String^ value);
}


RevisionValue Property

RevisionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► RevisionValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionValue { get; set; }
Public Property RevisionValue As String
    Get
    Set
public:
property String^ RevisionValue {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► TimeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RDT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RE Class

RE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE
RDPCrystal EDI Library
Rebill At Interchange
Declaration Syntax
C# Visual Basic Visual C++
public class RE : DocumentSegment
Public Class RE _
    Inherits DocumentSegment
public ref class RE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RE()()()() | Initializes a new instance of the RE class
 | CityName | Element 2
 | CityName1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RebillReasonCode | Element 1
 | ShipmentMethodOfPayment | Element 5
 | StandardCarrierAlphaCode | Element 4
 | StateOrProvinceCode | Element 3
 | StateOrProvinceCode1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RE


RE Constructor

RE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► RE()()()()
RDPCrystal EDI Library
Initializes a new instance of the RE class
Declaration Syntax
C# Visual Basic Visual C++
public RE()
Public Sub New
public:
RE()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► CityName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► CityName1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RebillReasonCode Property

RebillReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► RebillReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RebillReasonCode { get; set; }
Public Property RebillReasonCode As String
    Get
    Set
public:
property String^ RebillReasonCode {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


REA Class

REA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA
RDPCrystal EDI Library
Real Estate Property Information
Declaration Syntax
C# Visual Basic Visual C++
public class REA : DocumentSegment
Public Class REA _
    Inherits DocumentSegment
public ref class REA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REA()()()() | Initializes a new instance of the REA class
 | CompositeTypeOfRealEstateAssetCode | Element 1
 | CompositeUnitOfMeasure | Element 9
 | Date | Element 3
 | Date1 | Element 5
 | DateTimePeriod | Element 8
 | DateTimePeriodFormatQualifier | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationQualifier | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PropertyOwnershipRightsCode | Element 4
 | Quantity | Element 2
 | Quantity1 | Element 10
 | ReferenceIdentification | Element 12
 | StatusOfPlansForRealEstateAssetCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfResidenceCode | Element 13
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REA


REA Constructor

REA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► REA()()()()
RDPCrystal EDI Library
Initializes a new instance of the REA class
Declaration Syntax
C# Visual Basic Visual C++
public REA()
Public Sub New
public:
REA()


CompositeTypeOfRealEstateAssetCode Property

CompositeTypeOfRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► CompositeTypeOfRealEstateAssetCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeTypeOfRealEstateAssetCode CompositeTypeOfRealEstateAssetCode { get; set; }
Public Property CompositeTypeOfRealEstateAssetCode As CompositeTypeOfRealEstateAssetCode
    Get
    Set
public:
property CompositeTypeOfRealEstateAssetCode^ CompositeTypeOfRealEstateAssetCode {
    CompositeTypeOfRealEstateAssetCode^ get ();
    void set (CompositeTypeOfRealEstateAssetCode^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► DateTimePeriod
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► LocationQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


PropertyOwnershipRightsCode Property

PropertyOwnershipRightsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► PropertyOwnershipRightsCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyOwnershipRightsCode { get; set; }
Public Property PropertyOwnershipRightsCode As String
    Get
    Set
public:
property String^ PropertyOwnershipRightsCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► Quantity1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► ReferenceIdentification
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StatusOfPlansForRealEstateAssetCode Property

StatusOfPlansForRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► StatusOfPlansForRealEstateAssetCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StatusOfPlansForRealEstateAssetCode { get; set; }
Public Property StatusOfPlansForRealEstateAssetCode As String
    Get
    Set
public:
property String^ StatusOfPlansForRealEstateAssetCode {
    String^ get ();
    void set (String^ value);
}


TypeOfResidenceCode Property

TypeOfResidenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► TypeOfResidenceCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfResidenceCode { get; set; }
Public Property TypeOfResidenceCode As String
    Get
    Set
public:
property String^ TypeOfResidenceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


REC Class

REC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC
RDPCrystal EDI Library
Real Estate Condition
Declaration Syntax
C# Visual Basic Visual C++
public class REC : DocumentSegment
Public Class REC _
    Inherits DocumentSegment
public ref class REC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REC()()()() | Initializes a new instance of the REC class
 | ActionCode | Element 7
 | CompositeUnitOfMeasure | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 13
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteReferenceCode | Element 12
 | OccupancyCode | Element 1
 | OccupancyVerificationCode | Element 11
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PropertyDamageCode | Element 3
 | PropertyInspectionQualifier | Element 6
 | Quantity | Element 5
 | Quantity1 | Element 9
 | QuantityQualifier | Element 8
 | RealEstatePropertyConditionCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REC


REC Constructor

REC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► REC()()()()
RDPCrystal EDI Library
Initializes a new instance of the REC class
Declaration Syntax
C# Visual Basic Visual C++
public REC()
Public Sub New
public:
REC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► ActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► FreeFormMessage
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NoteReferenceCode Property

NoteReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► NoteReferenceCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string NoteReferenceCode { get; set; }
Public Property NoteReferenceCode As String
    Get
    Set
public:
property String^ NoteReferenceCode {
    String^ get ();
    void set (String^ value);
}


OccupancyCode Property

OccupancyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► OccupancyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OccupancyCode { get; set; }
Public Property OccupancyCode As String
    Get
    Set
public:
property String^ OccupancyCode {
    String^ get ();
    void set (String^ value);
}


OccupancyVerificationCode Property

OccupancyVerificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► OccupancyVerificationCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string OccupancyVerificationCode { get; set; }
Public Property OccupancyVerificationCode As String
    Get
    Set
public:
property String^ OccupancyVerificationCode {
    String^ get ();
    void set (String^ value);
}


PropertyDamageCode Property

PropertyDamageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► PropertyDamageCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyDamageCode { get; set; }
Public Property PropertyDamageCode As String
    Get
    Set
public:
property String^ PropertyDamageCode {
    String^ get ();
    void set (String^ value);
}


PropertyInspectionQualifier Property

PropertyInspectionQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► PropertyInspectionQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PropertyInspectionQualifier { get; set; }
Public Property PropertyInspectionQualifier As String
    Get
    Set
public:
property String^ PropertyInspectionQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► Quantity1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► QuantityQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


RealEstatePropertyConditionCode Property

RealEstatePropertyConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► RealEstatePropertyConditionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstatePropertyConditionCode { get; set; }
Public Property RealEstatePropertyConditionCode As String
    Get
    Set
public:
property String^ RealEstatePropertyConditionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RED Class

RED Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED
RDPCrystal EDI Library
Related Data
Declaration Syntax
C# Visual Basic Visual C++
public class RED : DocumentSegment
Public Class RED _
    Inherits DocumentSegment
public ref class RED : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RED()()()() | Initializes a new instance of the RED class
 | AgencyQualifierCode | Element 3
 | CodeListQualifierCode | Element 5
 | Description | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RelatedDataIdentificationCode | Element 2
 | SourceSubqualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RED


RED Constructor

RED Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► RED()()()()
RDPCrystal EDI Library
Initializes a new instance of the RED class
Declaration Syntax
C# Visual Basic Visual C++
public RED()
Public Sub New
public:
RED()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► CodeListQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► Description
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► IndustryCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RelatedDataIdentificationCode Property

RelatedDataIdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► RelatedDataIdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedDataIdentificationCode { get; set; }
Public Property RelatedDataIdentificationCode As String
    Get
    Set
public:
property String^ RelatedDataIdentificationCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► SourceSubqualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RED ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


REF Class

REF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF
RDPCrystal EDI Library
Reference Identification
Declaration Syntax
C# Visual Basic Visual C++
public class REF : DocumentSegment
Public Class REF _
    Inherits DocumentSegment
public ref class REF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REF()()()() | Initializes a new instance of the REF class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REF


REF Constructor

REF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► REF()()()()
RDPCrystal EDI Library
Initializes a new instance of the REF class
Declaration Syntax
C# Visual Basic Visual C++
public REF()
Public Sub New
public:
REF()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► ReferenceIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ReferenceIdentifier Class

ReferenceIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier
RDPCrystal EDI Library
C040
Declaration Syntax
C# Visual Basic Visual C++
public class ReferenceIdentifier : DocumentCompositeElement
Public Class ReferenceIdentifier _
    Inherits DocumentCompositeElement
public ref class ReferenceIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferenceIdentifier()()()() | Initializes a new instance of the ReferenceIdentifier class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferenceIdentification |
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | ReferenceIdentificationQualifier |
 | ReferenceIdentificationQualifier1 |
 | ReferenceIdentificationQualifier2 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ReferenceIdentifier


ReferenceIdentifier Constructor

ReferenceIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the ReferenceIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier()
Public Sub New
public:
ReferenceIdentifier()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentification
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentification1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentification2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier2 Property

ReferenceIdentificationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ReferenceIdentifier ► ReferenceIdentificationQualifier2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier2 { get; set; }
Public Property ReferenceIdentificationQualifier2 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier2 {
    String^ get ();
    void set (String^ value);
}


REL Class

REL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REL
RDPCrystal EDI Library
Relationship
Declaration Syntax
C# Visual Basic Visual C++
public class REL : DocumentSegment
Public Class REL _
    Inherits DocumentSegment
public ref class REL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REL()()()() | Initializes a new instance of the REL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REL


REL Constructor

REL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REL ► REL()()()()
RDPCrystal EDI Library
Initializes a new instance of the REL class
Declaration Syntax
C# Visual Basic Visual C++
public REL()
Public Sub New
public:
REL()


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REL ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REL ► Number
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RelatedCausesInformation Class

RelatedCausesInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation
RDPCrystal EDI Library
C024
Declaration Syntax
C# Visual Basic Visual C++
public class RelatedCausesInformation : DocumentCompositeElement
Public Class RelatedCausesInformation _
    Inherits DocumentCompositeElement
public ref class RelatedCausesInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelatedCausesInformation()()()() | Initializes a new instance of the RelatedCausesInformation class
 | CountryCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RelatedCausesCode | Element 1
 | RelatedCausesCode1 | Element 2
 | RelatedCausesCode2 | Element 3
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | RelatedCausesInformation


RelatedCausesInformation Constructor

RelatedCausesInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► RelatedCausesInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the RelatedCausesInformation class
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation()
Public Sub New
public:
RelatedCausesInformation()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► CountryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


RelatedCausesCode Property

RelatedCausesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► RelatedCausesCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode { get; set; }
Public Property RelatedCausesCode As String
    Get
    Set
public:
property String^ RelatedCausesCode {
    String^ get ();
    void set (String^ value);
}


RelatedCausesCode1 Property

RelatedCausesCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► RelatedCausesCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode1 { get; set; }
Public Property RelatedCausesCode1 As String
    Get
    Set
public:
property String^ RelatedCausesCode1 {
    String^ get ();
    void set (String^ value);
}


RelatedCausesCode2 Property

RelatedCausesCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► RelatedCausesCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode2 { get; set; }
Public Property RelatedCausesCode2 As String
    Get
    Set
public:
property String^ RelatedCausesCode2 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RelatedCausesInformation ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


REN Class

REN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN
RDPCrystal EDI Library
Rate Request Information
Declaration Syntax
C# Visual Basic Visual C++
public class REN : DocumentSegment
Public Class REN _
    Inherits DocumentSegment
public ref class REN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REN()()()() | Initializes a new instance of the REN class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateRequestResponseCode | Element 1
 | RateRequestResponseCode1 | Element 5
 | StandardCarrierAlphaCode | Element 2
 | StandardCarrierAlphaCode1 | Element 4
 | StandardCarrierAlphaCode2 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REN


REN Constructor

REN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► REN()()()()
RDPCrystal EDI Library
Initializes a new instance of the REN class
Declaration Syntax
C# Visual Basic Visual C++
public REN()
Public Sub New
public:
REN()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateRequestResponseCode Property

RateRequestResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► RateRequestResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateRequestResponseCode { get; set; }
Public Property RateRequestResponseCode As String
    Get
    Set
public:
property String^ RateRequestResponseCode {
    String^ get ();
    void set (String^ value);
}


RateRequestResponseCode1 Property

RateRequestResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► RateRequestResponseCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateRequestResponseCode1 { get; set; }
Public Property RateRequestResponseCode1 As String
    Get
    Set
public:
property String^ RateRequestResponseCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REN ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


REP Class

REP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP
RDPCrystal EDI Library
Repair Action
Declaration Syntax
C# Visual Basic Visual C++
public class REP : DocumentSegment
Public Class REP _
    Inherits DocumentSegment
public ref class REP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REP()()()() | Initializes a new instance of the REP class
 | AgencyQualifierCode | Element 6
 | AgencyQualifierCode1 | Element 10
 | AgencyQualifierCode2 | Element 17
 | AssignedIdentification | Element 1
 | AuthorizationIdentification | Element 20
 | Description | Element 9
 | Description1 | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceID1 | Element 5
 | ProductServiceID2 | Element 14
 | ProductServiceIDQualifier | Element 2
 | ProductServiceIDQualifier1 | Element 4
 | ProductServiceIDQualifier2 | Element 13
 | ReferenceIdentification | Element 19
 | RepairActionCode | Element 8
 | RepairActionCode1 | Element 15
 | RepairComplexityCode | Element 12
 | SourceSubqualifier | Element 7
 | SourceSubqualifier1 | Element 11
 | SourceSubqualifier2 | Element 18
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REP


REP Constructor

REP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► REP()()()()
RDPCrystal EDI Library
Initializes a new instance of the REP class
Declaration Syntax
C# Visual Basic Visual C++
public REP()
Public Sub New
public:
REP()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► AgencyQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode1 Property

AgencyQualifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► AgencyQualifierCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode1 { get; set; }
Public Property AgencyQualifierCode1 As String
    Get
    Set
public:
property String^ AgencyQualifierCode1 {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode2 Property

AgencyQualifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► AgencyQualifierCode2
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode2 { get; set; }
Public Property AgencyQualifierCode2 As String
    Get
    Set
public:
property String^ AgencyQualifierCode2 {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


AuthorizationIdentification Property

AuthorizationIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► AuthorizationIdentification
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationIdentification { get; set; }
Public Property AuthorizationIdentification As String
    Get
    Set
public:
property String^ AuthorizationIdentification {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► Description1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ProductServiceID1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ProductServiceID2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► ReferenceIdentification
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


RepairActionCode Property

RepairActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► RepairActionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RepairActionCode { get; set; }
Public Property RepairActionCode As String
    Get
    Set
public:
property String^ RepairActionCode {
    String^ get ();
    void set (String^ value);
}


RepairActionCode1 Property

RepairActionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► RepairActionCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RepairActionCode1 { get; set; }
Public Property RepairActionCode1 As String
    Get
    Set
public:
property String^ RepairActionCode1 {
    String^ get ();
    void set (String^ value);
}


RepairComplexityCode Property

RepairComplexityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► RepairComplexityCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string RepairComplexityCode { get; set; }
Public Property RepairComplexityCode As String
    Get
    Set
public:
property String^ RepairComplexityCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► SourceSubqualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier1 Property

SourceSubqualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► SourceSubqualifier1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier1 { get; set; }
Public Property SourceSubqualifier1 As String
    Get
    Set
public:
property String^ SourceSubqualifier1 {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier2 Property

SourceSubqualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► SourceSubqualifier2
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier2 { get; set; }
Public Property SourceSubqualifier2 As String
    Get
    Set
public:
property String^ SourceSubqualifier2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


REQ Class

REQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REQ
RDPCrystal EDI Library
Request Information
Declaration Syntax
C# Visual Basic Visual C++
public class REQ : DocumentSegment
Public Class REQ _
    Inherits DocumentSegment
public ref class REQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REQ()()()() | Initializes a new instance of the REQ class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InquiryResponseCode | Element 1
 | InquirySelectionCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REQ


REQ Constructor

REQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REQ ► REQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the REQ class
Declaration Syntax
C# Visual Basic Visual C++
public REQ()
Public Sub New
public:
REQ()


InquiryResponseCode Property

InquiryResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REQ ► InquiryResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InquiryResponseCode { get; set; }
Public Property InquiryResponseCode As String
    Get
    Set
public:
property String^ InquiryResponseCode {
    String^ get ();
    void set (String^ value);
}


InquirySelectionCode Property

InquirySelectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REQ ► InquirySelectionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InquirySelectionCode { get; set; }
Public Property InquirySelectionCode As String
    Get
    Set
public:
property String^ InquirySelectionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► REQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RET Class

RET Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET
RDPCrystal EDI Library
Real Estate Transaction
Declaration Syntax
C# Visual Basic Visual C++
public class RET : DocumentSegment
Public Class RET _
    Inherits DocumentSegment
public ref class RET : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RET()()()() | Initializes a new instance of the RET class
 | ContractTypeCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusCode | Element 3
 | StatusOfPlansForRealEstateAssetCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RET


RET Constructor

RET Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► RET()()()()
RDPCrystal EDI Library
Initializes a new instance of the RET class
Declaration Syntax
C# Visual Basic Visual C++
public RET()
Public Sub New
public:
RET()


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► ContractTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► InformationStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► StatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


StatusOfPlansForRealEstateAssetCode Property

StatusOfPlansForRealEstateAssetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► StatusOfPlansForRealEstateAssetCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StatusOfPlansForRealEstateAssetCode { get; set; }
Public Property StatusOfPlansForRealEstateAssetCode As String
    Get
    Set
public:
property String^ StatusOfPlansForRealEstateAssetCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► TransactionTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RET ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RH Class

RH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH
RDPCrystal EDI Library
Personal Property Rate
Declaration Syntax
C# Visual Basic Visual C++
public class RH : DocumentSegment
Public Class RH _
    Inherits DocumentSegment
public ref class RH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RH()()()() | Initializes a new instance of the RH class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 2
 | TariffServiceCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RH


RH Constructor

RH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH ► RH()()()()
RDPCrystal EDI Library
Initializes a new instance of the RH class
Declaration Syntax
C# Visual Basic Visual C++
public RH()
Public Sub New
public:
RH()


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH ► RateValueQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


TariffServiceCode Property

TariffServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH ► TariffServiceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TariffServiceCode { get; set; }
Public Property TariffServiceCode As String
    Get
    Set
public:
property String^ TariffServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RIC Class

RIC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC
RDPCrystal EDI Library
Financial Return
Declaration Syntax
C# Visual Basic Visual C++
public class RIC : DocumentSegment
Public Class RIC _
    Inherits DocumentSegment
public ref class RIC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RIC()()()() | Initializes a new instance of the RIC class
 | AccountNumber | Element 4
 | AccountNumber1 | Element 8
 | AccountNumber2 | Element 12
 | AccountNumberQualifier | Element 5
 | AccountNumberQualifier1 | Element 9
 | AccountNumberQualifier2 | Element 13
 | ApplicationErrorConditionCode | Element 1
 | CreditDebitFlagCode | Element 3
 | DFIIdentificationNumber | Element 7
 | DFIIdentificationNumber1 | Element 11
 | DFIIdentificationNumber2 | Element 15
 | DFIIDNumberQualifier | Element 6
 | DFIIDNumberQualifier1 | Element 10
 | DFIIDNumberQualifier2 | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RIC


RIC Constructor

RIC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► RIC()()()()
RDPCrystal EDI Library
Initializes a new instance of the RIC class
Declaration Syntax
C# Visual Basic Visual C++
public RIC()
Public Sub New
public:
RIC()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► AccountNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► AccountNumber1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}


AccountNumber2 Property

AccountNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► AccountNumber2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber2 { get; set; }
Public Property AccountNumber2 As String
    Get
    Set
public:
property String^ AccountNumber2 {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► AccountNumberQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier1 Property

AccountNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► AccountNumberQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier1 { get; set; }
Public Property AccountNumberQualifier1 As String
    Get
    Set
public:
property String^ AccountNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}


AccountNumberQualifier2 Property

AccountNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► AccountNumberQualifier2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier2 { get; set; }
Public Property AccountNumberQualifier2 As String
    Get
    Set
public:
property String^ AccountNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}


ApplicationErrorConditionCode Property

ApplicationErrorConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► ApplicationErrorConditionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode { get; set; }
Public Property ApplicationErrorConditionCode As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode {
    String^ get ();
    void set (String^ value);
}


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber Property

DFIIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► DFIIdentificationNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber { get; set; }
Public Property DFIIdentificationNumber As String
    Get
    Set
public:
property String^ DFIIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber1 Property

DFIIdentificationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► DFIIdentificationNumber1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber1 { get; set; }
Public Property DFIIdentificationNumber1 As String
    Get
    Set
public:
property String^ DFIIdentificationNumber1 {
    String^ get ();
    void set (String^ value);
}


DFIIdentificationNumber2 Property

DFIIdentificationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► DFIIdentificationNumber2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIdentificationNumber2 { get; set; }
Public Property DFIIdentificationNumber2 As String
    Get
    Set
public:
property String^ DFIIdentificationNumber2 {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier Property

DFIIDNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► DFIIDNumberQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier { get; set; }
Public Property DFIIDNumberQualifier As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier1 Property

DFIIDNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► DFIIDNumberQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier1 { get; set; }
Public Property DFIIDNumberQualifier1 As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}


DFIIDNumberQualifier2 Property

DFIIDNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► DFIIDNumberQualifier2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DFIIDNumberQualifier2 { get; set; }
Public Property DFIIDNumberQualifier2 As String
    Get
    Set
public:
property String^ DFIIDNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RIC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RLD Class

RLD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD
RDPCrystal EDI Library
Down Payment Data
Declaration Syntax
C# Visual Basic Visual C++
public class RLD : DocumentSegment
Public Class RLD _
    Inherits DocumentSegment
public ref class RLD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RLD()()()() | Initializes a new instance of the RLD class
 | AmountQualifierCode | Element 4
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfDownpaymentCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RLD


RLD Constructor

RLD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► RLD()()()()
RDPCrystal EDI Library
Initializes a new instance of the RLD class
Declaration Syntax
C# Visual Basic Visual C++
public RLD()
Public Sub New
public:
RLD()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► AmountQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


TypeOfDownpaymentCode Property

TypeOfDownpaymentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► TypeOfDownpaymentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfDownpaymentCode { get; set; }
Public Property TypeOfDownpaymentCode As String
    Get
    Set
public:
property String^ TypeOfDownpaymentCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RLT Class

RLT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT
RDPCrystal EDI Library
Real Estate Loan Type
Declaration Syntax
C# Visual Basic Visual C++
public class RLT : DocumentSegment
Public Class RLT _
    Inherits DocumentSegment
public ref class RLT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RLT()()()() | Initializes a new instance of the RLT class
 | CompositeUnitOfMeasure | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProgramTypeCode | Element 12
 | Quantity | Element 8
 | QuantityQualifier | Element 7
 | RealEstateLoanTypeCode | Element 5
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentification2 | Element 11
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentificationQualifier1 | Element 3
 | ReferenceIdentificationQualifier2 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RLT


RLT Constructor

RLT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► RLT()()()()
RDPCrystal EDI Library
Initializes a new instance of the RLT class
Declaration Syntax
C# Visual Basic Visual C++
public RLT()
Public Sub New
public:
RLT()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


ProgramTypeCode Property

ProgramTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ProgramTypeCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramTypeCode { get; set; }
Public Property ProgramTypeCode As String
    Get
    Set
public:
property String^ ProgramTypeCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► QuantityQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


RealEstateLoanTypeCode Property

RealEstateLoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► RealEstateLoanTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RealEstateLoanTypeCode { get; set; }
Public Property RealEstateLoanTypeCode As String
    Get
    Set
public:
property String^ RealEstateLoanTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ReferenceIdentification2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier2 Property

ReferenceIdentificationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► ReferenceIdentificationQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier2 { get; set; }
Public Property ReferenceIdentificationQualifier2 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RLT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RMR Class

RMR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR
RDPCrystal EDI Library
Remittance Advice Accounts Receivable Open Item Reference
Declaration Syntax
C# Visual Basic Visual C++
public class RMR : DocumentSegment
Public Class RMR _
    Inherits DocumentSegment
public ref class RMR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RMR()()()() | Initializes a new instance of the RMR class
 | AdjustmentReasonCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | MonetaryAmount1 | Element 5
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentActionCode | Element 3
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RMR


RMR Constructor

RMR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► RMR()()()()
RDPCrystal EDI Library
Initializes a new instance of the RMR class
Declaration Syntax
C# Visual Basic Visual C++
public RMR()
Public Sub New
public:
RMR()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► AdjustmentReasonCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► MonetaryAmount1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► MonetaryAmount3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


PaymentActionCode Property

PaymentActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► PaymentActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentActionCode { get; set; }
Public Property PaymentActionCode As String
    Get
    Set
public:
property String^ PaymentActionCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RMT Class

RMT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT
RDPCrystal EDI Library
Remittance Advice
Declaration Syntax
C# Visual Basic Visual C++
public class RMT : DocumentSegment
Public Class RMT _
    Inherits DocumentSegment
public ref class RMT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RMT()()()() | Initializes a new instance of the RMT class
 | AdjustmentReasonCode | Element 9
 | Description | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | MonetaryAmount3 | Element 6
 | MonetaryAmount4 | Element 7
 | MonetaryAmount5 | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RMT


RMT Constructor

RMT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► RMT()()()()
RDPCrystal EDI Library
Initializes a new instance of the RMT class
Declaration Syntax
C# Visual Basic Visual C++
public RMT()
Public Sub New
public:
RMT()


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► AdjustmentReasonCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► Description
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► MonetaryAmount3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► MonetaryAmount4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► MonetaryAmount5
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RMT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RO Class

RO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO
RDPCrystal EDI Library
Public Record or Obligation
Declaration Syntax
C# Visual Basic Visual C++
public class RO : DocumentSegment
Public Class RO _
    Inherits DocumentSegment
public ref class RO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RO()()()() | Initializes a new instance of the RO class
 | AmountQualifierCode | Element 4
 | DispositionCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PublicRecordOrObligationCode | Element 1
 | RateValueQualifier | Element 6
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 8
 | ReferenceIdentificationQualifier | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RO


RO Constructor

RO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► RO()()()()
RDPCrystal EDI Library
Initializes a new instance of the RO class
Declaration Syntax
C# Visual Basic Visual C++
public RO()
Public Sub New
public:
RO()


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► AmountQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► DispositionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


PublicRecordOrObligationCode Property

PublicRecordOrObligationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► PublicRecordOrObligationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PublicRecordOrObligationCode { get; set; }
Public Property PublicRecordOrObligationCode As String
    Get
    Set
public:
property String^ PublicRecordOrObligationCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► RateValueQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► TypeOfAccountCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RP Class

RP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP
RDPCrystal EDI Library
Retirement Product
Declaration Syntax
C# Visual Basic Visual C++
public class RP : DocumentSegment
Public Class RP _
    Inherits DocumentSegment
public ref class RP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RP()()()() | Initializes a new instance of the RP class
 | Authority | Element 8
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceLineCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 3
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ParticipantStatusCode | Element 5
 | PlanCoverageDescription | Element 9
 | SpecialProcessingType | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RP


RP Constructor

RP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► RP()()()()
RDPCrystal EDI Library
Initializes a new instance of the RP class
Declaration Syntax
C# Visual Basic Visual C++
public RP()
Public Sub New
public:
RP()


Authority Property

Authority Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► Authority
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Authority { get; set; }
Public Property Authority As String
    Get
    Set
public:
property String^ Authority {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


InsuranceLineCode Property

InsuranceLineCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► InsuranceLineCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceLineCode { get; set; }
Public Property InsuranceLineCode As String
    Get
    Set
public:
property String^ InsuranceLineCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}


ParticipantStatusCode Property

ParticipantStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► ParticipantStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ParticipantStatusCode { get; set; }
Public Property ParticipantStatusCode As String
    Get
    Set
public:
property String^ ParticipantStatusCode {
    String^ get ();
    void set (String^ value);
}


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► PlanCoverageDescription
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}


SpecialProcessingType Property

SpecialProcessingType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► SpecialProcessingType
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialProcessingType { get; set; }
Public Property SpecialProcessingType As String
    Get
    Set
public:
property String^ SpecialProcessingType {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RP ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RPA Class

RPA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA
RDPCrystal EDI Library
Rate Amounts or Percents
Declaration Syntax
C# Visual Basic Visual C++
public class RPA : DocumentSegment
Public Class RPA _
    Inherits DocumentSegment
public ref class RPA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RPA()()()() | Initializes a new instance of the RPA class
 | CompositeUnitOfMeasure | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | Rate | Element 3
 | RateOrValueTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RPA


RPA Constructor

RPA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► RPA()()()()
RDPCrystal EDI Library
Initializes a new instance of the RPA class
Declaration Syntax
C# Visual Basic Visual C++
public RPA()
Public Sub New
public:
RPA()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► Rate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


RateOrValueTypeCode Property

RateOrValueTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► RateOrValueTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateOrValueTypeCode { get; set; }
Public Property RateOrValueTypeCode As String
    Get
    Set
public:
property String^ RateOrValueTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RPA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RQS Class

RQS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS
RDPCrystal EDI Library
Request for Information
Declaration Syntax
C# Visual Basic Visual C++
public class RQS : DocumentSegment
Public Class RQS _
    Inherits DocumentSegment
public ref class RQS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RQS()()()() | Initializes a new instance of the RQS class
 | CodeListQualifierCode | Element 1
 | Description | Element 3
 | Description1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RQS


RQS Constructor

RQS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► RQS()()()()
RDPCrystal EDI Library
Initializes a new instance of the RQS class
Declaration Syntax
C# Visual Basic Visual C++
public RQS()
Public Sub New
public:
RQS()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► Description1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RQS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


RRA Class

RRA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RRA
RDPCrystal EDI Library
Required Response
Declaration Syntax
C# Visual Basic Visual C++
public class RRA : DocumentSegment
Public Class RRA _
    Inherits DocumentSegment
public ref class RRA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RRA()()()() | Initializes a new instance of the RRA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationType | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RRA


RRA Constructor

RRA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RRA ► RRA()()()()
RDPCrystal EDI Library
Initializes a new instance of the RRA class
Declaration Syntax
C# Visual Basic Visual C++
public RRA()
Public Sub New
public:
RRA()


InformationType Property

InformationType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RRA ► InformationType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InformationType { get; set; }
Public Property InformationType As String
    Get
    Set
public:
property String^ InformationType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RRA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RRA ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RRA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RS Class

RS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS
RDPCrystal EDI Library
Rate Subset
Declaration Syntax
C# Visual Basic Visual C++
public class RS : DocumentSegment
Public Class RS _
    Inherits DocumentSegment
public ref class RS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RS()()()() | Initializes a new instance of the RS class
 | AssignedNumber | Element 1
 | Date | Element 5
 | Date1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateLevel | Element 4
 | RateLevelQualifierCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RS


RS Constructor

RS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► RS()()()()
RDPCrystal EDI Library
Initializes a new instance of the RS class
Declaration Syntax
C# Visual Basic Visual C++
public RS()
Public Sub New
public:
RS()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► Number
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


RateLevel Property

RateLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► RateLevel
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateLevel { get; set; }
Public Property RateLevel As String
    Get
    Set
public:
property String^ RateLevel {
    String^ get ();
    void set (String^ value);
}


RateLevelQualifierCode Property

RateLevelQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► RateLevelQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateLevelQualifierCode { get; set; }
Public Property RateLevelQualifierCode As String
    Get
    Set
public:
property String^ RateLevelQualifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RSC Class

RSC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC
RDPCrystal EDI Library
Resource
Declaration Syntax
C# Visual Basic Visual C++
public class RSC : DocumentSegment
Public Class RSC _
    Inherits DocumentSegment
public ref class RSC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSC()()()() | Initializes a new instance of the RSC class
 | ActionCode | Element 4
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ResourceCodeOrIdentifier | Element 1
 | ResourceType | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RSC


RSC Constructor

RSC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► RSC()()()()
RDPCrystal EDI Library
Initializes a new instance of the RSC class
Declaration Syntax
C# Visual Basic Visual C++
public RSC()
Public Sub New
public:
RSC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► ActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ResourceCodeOrIdentifier Property

ResourceCodeOrIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► ResourceCodeOrIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ResourceCodeOrIdentifier { get; set; }
Public Property ResourceCodeOrIdentifier As String
    Get
    Set
public:
property String^ ResourceCodeOrIdentifier {
    String^ get ();
    void set (String^ value);
}


ResourceType Property

ResourceType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► ResourceType
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ResourceType { get; set; }
Public Property ResourceType As String
    Get
    Set
public:
property String^ ResourceType {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RSD Class

RSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD
RDPCrystal EDI Library
Residency Information
Declaration Syntax
C# Visual Basic Visual C++
public class RSD : DocumentSegment
Public Class RSD _
    Inherits DocumentSegment
public ref class RSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSD()()()() | Initializes a new instance of the RSD class
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 3
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RSD


RSD Constructor

RSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD ► RSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the RSD class
Declaration Syntax
C# Visual Basic Visual C++
public RSD()
Public Sub New
public:
RSD()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RST Class

RST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RST
RDPCrystal EDI Library
Carrier Restriction
Declaration Syntax
C# Visual Basic Visual C++
public class RST : DocumentSegment
Public Class RST _
    Inherits DocumentSegment
public ref class RST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RST()()()() | Initializes a new instance of the RST class
 | CarrierRestrictionCode | Element 1
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RST


RST Constructor

RST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RST ► RST()()()()
RDPCrystal EDI Library
Initializes a new instance of the RST class
Declaration Syntax
C# Visual Basic Visual C++
public RST()
Public Sub New
public:
RST()


CarrierRestrictionCode Property

CarrierRestrictionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RST ► CarrierRestrictionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CarrierRestrictionCode { get; set; }
Public Property CarrierRestrictionCode As String
    Get
    Set
public:
property String^ CarrierRestrictionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RST ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RT Class

RT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT
RDPCrystal EDI Library
Rate Destination
Declaration Syntax
C# Visual Basic Visual C++
public class RT : DocumentSegment
Public Class RT _
    Inherits DocumentSegment
public ref class RT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RT()()()() | Initializes a new instance of the RT class
 | AddressInformation | Element 10
 | DealerCode | Element 3
 | DistanceQualifier | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 11
 | IdentificationCodeQualifier | Element 12
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 9
 | NationalMotorFreightTransportationAssociationLocationName | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 1
 | StandardPointLocationCode | Element 2
 | StateOrProvinceCode | Element 8
 | TariffDistance | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleServiceCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RT


RT Constructor

RT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► RT()()()()
RDPCrystal EDI Library
Initializes a new instance of the RT class
Declaration Syntax
C# Visual Basic Visual C++
public RT()
Public Sub New
public:
RT()


AddressInformation Property

AddressInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► AddressInformation
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation { get; set; }
Public Property AddressInformation As String
    Get
    Set
public:
property String^ AddressInformation {
    String^ get ();
    void set (String^ value);
}


DealerCode Property

DealerCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► DealerCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DealerCode { get; set; }
Public Property DealerCode As String
    Get
    Set
public:
property String^ DealerCode {
    String^ get ();
    void set (String^ value);
}


DistanceQualifier Property

DistanceQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► DistanceQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DistanceQualifier { get; set; }
Public Property DistanceQualifier As String
    Get
    Set
public:
property String^ DistanceQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► IdentificationCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► Name1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


NationalMotorFreightTransportationAssociationLocationName Property

NationalMotorFreightTransportationAssociationLocationName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► NationalMotorFreightTransportationAssociationLocationName
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NationalMotorFreightTransportationAssociationLocationName { get; set; }
Public Property NationalMotorFreightTransportationAssociationLocationName As String
    Get
    Set
public:
property String^ NationalMotorFreightTransportationAssociationLocationName {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► StandardPointLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► StateOrProvinceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TariffDistance Property

TariffDistance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► TariffDistance
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TariffDistance { get; set; }
Public Property TariffDistance As String
    Get
    Set
public:
property String^ TariffDistance {
    String^ get ();
    void set (String^ value);
}


VehicleServiceCode Property

VehicleServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► VehicleServiceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleServiceCode { get; set; }
Public Property VehicleServiceCode As String
    Get
    Set
public:
property String^ VehicleServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RT1 Class

RT1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1
RDPCrystal EDI Library
Rate Detail
Declaration Syntax
C# Visual Basic Visual C++
public class RT1 : DocumentSegment
Public Class RT1 _
    Inherits DocumentSegment
public ref class RT1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RT1()()()() | Initializes a new instance of the RT1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 6
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RoundingRuleCode | Element 4
 | SpecialRateCode | Element 8
 | TariffItemNumber | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 1
 | VehicleTypeCode | Element 2
 | VINPlantCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RT1


RT1 Constructor

RT1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► RT1()()()()
RDPCrystal EDI Library
Initializes a new instance of the RT1 class
Declaration Syntax
C# Visual Basic Visual C++
public RT1()
Public Sub New
public:
RT1()


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► FreightRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RoundingRuleCode Property

RoundingRuleCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► RoundingRuleCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RoundingRuleCode { get; set; }
Public Property RoundingRuleCode As String
    Get
    Set
public:
property String^ RoundingRuleCode {
    String^ get ();
    void set (String^ value);
}


SpecialRateCode Property

SpecialRateCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► SpecialRateCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialRateCode { get; set; }
Public Property SpecialRateCode As String
    Get
    Set
public:
property String^ SpecialRateCode {
    String^ get ();
    void set (String^ value);
}


TariffItemNumber Property

TariffItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► TariffItemNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemNumber { get; set; }
Public Property TariffItemNumber As String
    Get
    Set
public:
property String^ TariffItemNumber {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


VehicleTypeCode Property

VehicleTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► VehicleTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleTypeCode { get; set; }
Public Property VehicleTypeCode As String
    Get
    Set
public:
property String^ VehicleTypeCode {
    String^ get ();
    void set (String^ value);
}


VINPlantCode Property

VINPlantCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► VINPlantCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VINPlantCode { get; set; }
Public Property VINPlantCode As String
    Get
    Set
public:
property String^ VINPlantCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RT1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RTE Class

RTE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE
RDPCrystal EDI Library
Rate Information
Declaration Syntax
C# Visual Basic Visual C++
public class RTE : DocumentSegment
Public Class RTE _
    Inherits DocumentSegment
public ref class RTE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RTE()()()() | Initializes a new instance of the RTE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 4
 | Number1 | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RTE


RTE Constructor

RTE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► RTE()()()()
RDPCrystal EDI Library
Initializes a new instance of the RTE class
Declaration Syntax
C# Visual Basic Visual C++
public RTE()
Public Sub New
public:
RTE()


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► InterestRate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► Number
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► Number1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


RateQualifier Property

RateQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► RateQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateQualifier { get; set; }
Public Property RateQualifier As String
    Get
    Set
public:
property String^ RateQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RTS Class

RTS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS
RDPCrystal EDI Library
Tariff Rates
Declaration Syntax
C# Visual Basic Visual C++
public class RTS : DocumentSegment
Public Class RTS _
    Inherits DocumentSegment
public ref class RTS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RTS()()()() | Initializes a new instance of the RTS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 1
 | FreightRate1 | Element 2
 | FreightRate10 | Element 11
 | FreightRate11 | Element 12
 | FreightRate12 | Element 13
 | FreightRate13 | Element 14
 | FreightRate14 | Element 15
 | FreightRate15 | Element 16
 | FreightRate2 | Element 3
 | FreightRate3 | Element 4
 | FreightRate4 | Element 5
 | FreightRate5 | Element 6
 | FreightRate6 | Element 7
 | FreightRate7 | Element 8
 | FreightRate8 | Element 9
 | FreightRate9 | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RTS


RTS Constructor

RTS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► RTS()()()()
RDPCrystal EDI Library
Initializes a new instance of the RTS class
Declaration Syntax
C# Visual Basic Visual C++
public RTS()
Public Sub New
public:
RTS()


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRate1 Property

FreightRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate1 { get; set; }
Public Property FreightRate1 As String
    Get
    Set
public:
property String^ FreightRate1 {
    String^ get ();
    void set (String^ value);
}


FreightRate10 Property

FreightRate10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate10
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate10 { get; set; }
Public Property FreightRate10 As String
    Get
    Set
public:
property String^ FreightRate10 {
    String^ get ();
    void set (String^ value);
}


FreightRate11 Property

FreightRate11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate11
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate11 { get; set; }
Public Property FreightRate11 As String
    Get
    Set
public:
property String^ FreightRate11 {
    String^ get ();
    void set (String^ value);
}


FreightRate12 Property

FreightRate12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate12
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate12 { get; set; }
Public Property FreightRate12 As String
    Get
    Set
public:
property String^ FreightRate12 {
    String^ get ();
    void set (String^ value);
}


FreightRate13 Property

FreightRate13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate13
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate13 { get; set; }
Public Property FreightRate13 As String
    Get
    Set
public:
property String^ FreightRate13 {
    String^ get ();
    void set (String^ value);
}


FreightRate14 Property

FreightRate14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate14
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate14 { get; set; }
Public Property FreightRate14 As String
    Get
    Set
public:
property String^ FreightRate14 {
    String^ get ();
    void set (String^ value);
}


FreightRate15 Property

FreightRate15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate15
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate15 { get; set; }
Public Property FreightRate15 As String
    Get
    Set
public:
property String^ FreightRate15 {
    String^ get ();
    void set (String^ value);
}


FreightRate2 Property

FreightRate2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate2 { get; set; }
Public Property FreightRate2 As String
    Get
    Set
public:
property String^ FreightRate2 {
    String^ get ();
    void set (String^ value);
}


FreightRate3 Property

FreightRate3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate3 { get; set; }
Public Property FreightRate3 As String
    Get
    Set
public:
property String^ FreightRate3 {
    String^ get ();
    void set (String^ value);
}


FreightRate4 Property

FreightRate4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate4 { get; set; }
Public Property FreightRate4 As String
    Get
    Set
public:
property String^ FreightRate4 {
    String^ get ();
    void set (String^ value);
}


FreightRate5 Property

FreightRate5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate5
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate5 { get; set; }
Public Property FreightRate5 As String
    Get
    Set
public:
property String^ FreightRate5 {
    String^ get ();
    void set (String^ value);
}


FreightRate6 Property

FreightRate6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate6
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate6 { get; set; }
Public Property FreightRate6 As String
    Get
    Set
public:
property String^ FreightRate6 {
    String^ get ();
    void set (String^ value);
}


FreightRate7 Property

FreightRate7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate7
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate7 { get; set; }
Public Property FreightRate7 As String
    Get
    Set
public:
property String^ FreightRate7 {
    String^ get ();
    void set (String^ value);
}


FreightRate8 Property

FreightRate8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate8
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate8 { get; set; }
Public Property FreightRate8 As String
    Get
    Set
public:
property String^ FreightRate8 {
    String^ get ();
    void set (String^ value);
}


FreightRate9 Property

FreightRate9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► FreightRate9
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate9 { get; set; }
Public Property FreightRate9 As String
    Get
    Set
public:
property String^ FreightRate9 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RTT Class

RTT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTT
RDPCrystal EDI Library
Freight Rate
Declaration Syntax
C# Visual Basic Visual C++
public class RTT : DocumentSegment
Public Class RTT _
    Inherits DocumentSegment
public ref class RTT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RTT()()()() | Initializes a new instance of the RTT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RTT


RTT Constructor

RTT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTT ► RTT()()()()
RDPCrystal EDI Library
Initializes a new instance of the RTT class
Declaration Syntax
C# Visual Basic Visual C++
public RTT()
Public Sub New
public:
RTT()


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTT ► FreightRate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTT ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RTT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RU1 Class

RU1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1
RDPCrystal EDI Library
Retirement Board Detail
Declaration Syntax
C# Visual Basic Visual C++
public class RU1 : DocumentSegment
Public Class RU1 _
    Inherits DocumentSegment
public ref class RU1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RU1()()()() | Initializes a new instance of the RU1 class
 | ClaimProfile | Element 9
 | Date | Element 5
 | Date1 | Element 8
 | EmploymentCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RailRetirementActivityCode | Element 1
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnemployedReasonCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RU1


RU1 Constructor

RU1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► RU1()()()()
RDPCrystal EDI Library
Initializes a new instance of the RU1 class
Declaration Syntax
C# Visual Basic Visual C++
public RU1()
Public Sub New
public:
RU1()


ClaimProfile Property

ClaimProfile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► ClaimProfile
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimProfile { get; set; }
Public Property ClaimProfile As String
    Get
    Set
public:
property String^ ClaimProfile {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


EmploymentCode Property

EmploymentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► EmploymentCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentCode { get; set; }
Public Property EmploymentCode As String
    Get
    Set
public:
property String^ EmploymentCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► Name1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


RailRetirementActivityCode Property

RailRetirementActivityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► RailRetirementActivityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RailRetirementActivityCode { get; set; }
Public Property RailRetirementActivityCode As String
    Get
    Set
public:
property String^ RailRetirementActivityCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


UnemployedReasonCode Property

UnemployedReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► UnemployedReasonCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnemployedReasonCode { get; set; }
Public Property UnemployedReasonCode As String
    Get
    Set
public:
property String^ UnemployedReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RU2 Class

RU2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2
RDPCrystal EDI Library
Employing Carrier Response
Declaration Syntax
C# Visual Basic Visual C++
public class RU2 : DocumentSegment
Public Class RU2 _
    Inherits DocumentSegment
public ref class RU2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RU2()()()() | Initializes a new instance of the RU2 class
 | Amount | Element 5
 | Date | Element 3
 | Date1 | Element 7
 | Date2 | Element 8
 | EmploymentStatusCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RailRetirementActivityCode | Element 1
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RU2


RU2 Constructor

RU2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► RU2()()()()
RDPCrystal EDI Library
Initializes a new instance of the RU2 class
Declaration Syntax
C# Visual Basic Visual C++
public RU2()
Public Sub New
public:
RU2()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► Date2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► EmploymentStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► FrequencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RailRetirementActivityCode Property

RailRetirementActivityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► RailRetirementActivityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RailRetirementActivityCode { get; set; }
Public Property RailRetirementActivityCode As String
    Get
    Set
public:
property String^ RailRetirementActivityCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RU3 Class

RU3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3
RDPCrystal EDI Library
Employing Carrier Claim Profile
Declaration Syntax
C# Visual Basic Visual C++
public class RU3 : DocumentSegment
Public Class RU3 _
    Inherits DocumentSegment
public ref class RU3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RU3()()()() | Initializes a new instance of the RU3 class
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayrollStatusCode | Element 2
 | PayrollStatusCode1 | Element 4
 | PayrollStatusCode10 | Element 22
 | PayrollStatusCode11 | Element 24
 | PayrollStatusCode12 | Element 26
 | PayrollStatusCode13 | Element 28
 | PayrollStatusCode2 | Element 6
 | PayrollStatusCode3 | Element 8
 | PayrollStatusCode4 | Element 10
 | PayrollStatusCode5 | Element 12
 | PayrollStatusCode6 | Element 14
 | PayrollStatusCode7 | Element 16
 | PayrollStatusCode8 | Element 18
 | PayrollStatusCode9 | Element 20
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WagesPaidCode | Element 3
 | WagesPaidCode1 | Element 5
 | WagesPaidCode10 | Element 23
 | WagesPaidCode11 | Element 25
 | WagesPaidCode12 | Element 27
 | WagesPaidCode13 | Element 29
 | WagesPaidCode2 | Element 7
 | WagesPaidCode3 | Element 9
 | WagesPaidCode4 | Element 11
 | WagesPaidCode5 | Element 13
 | WagesPaidCode6 | Element 15
 | WagesPaidCode7 | Element 17
 | WagesPaidCode8 | Element 19
 | WagesPaidCode9 | Element 21
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RU3


RU3 Constructor

RU3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► RU3()()()()
RDPCrystal EDI Library
Initializes a new instance of the RU3 class
Declaration Syntax
C# Visual Basic Visual C++
public RU3()
Public Sub New
public:
RU3()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PayrollStatusCode Property

PayrollStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode { get; set; }
Public Property PayrollStatusCode As String
    Get
    Set
public:
property String^ PayrollStatusCode {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode1 Property

PayrollStatusCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode1 { get; set; }
Public Property PayrollStatusCode1 As String
    Get
    Set
public:
property String^ PayrollStatusCode1 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode10 Property

PayrollStatusCode10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode10
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode10 { get; set; }
Public Property PayrollStatusCode10 As String
    Get
    Set
public:
property String^ PayrollStatusCode10 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode11 Property

PayrollStatusCode11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode11
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode11 { get; set; }
Public Property PayrollStatusCode11 As String
    Get
    Set
public:
property String^ PayrollStatusCode11 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode12 Property

PayrollStatusCode12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode12
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode12 { get; set; }
Public Property PayrollStatusCode12 As String
    Get
    Set
public:
property String^ PayrollStatusCode12 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode13 Property

PayrollStatusCode13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode13
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode13 { get; set; }
Public Property PayrollStatusCode13 As String
    Get
    Set
public:
property String^ PayrollStatusCode13 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode2 Property

PayrollStatusCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode2 { get; set; }
Public Property PayrollStatusCode2 As String
    Get
    Set
public:
property String^ PayrollStatusCode2 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode3 Property

PayrollStatusCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode3 { get; set; }
Public Property PayrollStatusCode3 As String
    Get
    Set
public:
property String^ PayrollStatusCode3 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode4 Property

PayrollStatusCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode4 { get; set; }
Public Property PayrollStatusCode4 As String
    Get
    Set
public:
property String^ PayrollStatusCode4 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode5 Property

PayrollStatusCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode5
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode5 { get; set; }
Public Property PayrollStatusCode5 As String
    Get
    Set
public:
property String^ PayrollStatusCode5 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode6 Property

PayrollStatusCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode6 { get; set; }
Public Property PayrollStatusCode6 As String
    Get
    Set
public:
property String^ PayrollStatusCode6 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode7 Property

PayrollStatusCode7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode7
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode7 { get; set; }
Public Property PayrollStatusCode7 As String
    Get
    Set
public:
property String^ PayrollStatusCode7 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode8 Property

PayrollStatusCode8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode8
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode8 { get; set; }
Public Property PayrollStatusCode8 As String
    Get
    Set
public:
property String^ PayrollStatusCode8 {
    String^ get ();
    void set (String^ value);
}


PayrollStatusCode9 Property

PayrollStatusCode9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► PayrollStatusCode9
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string PayrollStatusCode9 { get; set; }
Public Property PayrollStatusCode9 As String
    Get
    Set
public:
property String^ PayrollStatusCode9 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode Property

WagesPaidCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode { get; set; }
Public Property WagesPaidCode As String
    Get
    Set
public:
property String^ WagesPaidCode {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode1 Property

WagesPaidCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode1 { get; set; }
Public Property WagesPaidCode1 As String
    Get
    Set
public:
property String^ WagesPaidCode1 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode10 Property

WagesPaidCode10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode10
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode10 { get; set; }
Public Property WagesPaidCode10 As String
    Get
    Set
public:
property String^ WagesPaidCode10 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode11 Property

WagesPaidCode11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode11
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode11 { get; set; }
Public Property WagesPaidCode11 As String
    Get
    Set
public:
property String^ WagesPaidCode11 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode12 Property

WagesPaidCode12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode12
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode12 { get; set; }
Public Property WagesPaidCode12 As String
    Get
    Set
public:
property String^ WagesPaidCode12 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode13 Property

WagesPaidCode13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode13
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode13 { get; set; }
Public Property WagesPaidCode13 As String
    Get
    Set
public:
property String^ WagesPaidCode13 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode2 Property

WagesPaidCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode2 { get; set; }
Public Property WagesPaidCode2 As String
    Get
    Set
public:
property String^ WagesPaidCode2 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode3 Property

WagesPaidCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode3 { get; set; }
Public Property WagesPaidCode3 As String
    Get
    Set
public:
property String^ WagesPaidCode3 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode4 Property

WagesPaidCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode4 { get; set; }
Public Property WagesPaidCode4 As String
    Get
    Set
public:
property String^ WagesPaidCode4 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode5 Property

WagesPaidCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode5 { get; set; }
Public Property WagesPaidCode5 As String
    Get
    Set
public:
property String^ WagesPaidCode5 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode6 Property

WagesPaidCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode6
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode6 { get; set; }
Public Property WagesPaidCode6 As String
    Get
    Set
public:
property String^ WagesPaidCode6 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode7 Property

WagesPaidCode7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode7
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode7 { get; set; }
Public Property WagesPaidCode7 As String
    Get
    Set
public:
property String^ WagesPaidCode7 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode8 Property

WagesPaidCode8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode8
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode8 { get; set; }
Public Property WagesPaidCode8 As String
    Get
    Set
public:
property String^ WagesPaidCode8 {
    String^ get ();
    void set (String^ value);
}


WagesPaidCode9 Property

WagesPaidCode9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► WagesPaidCode9
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string WagesPaidCode9 { get; set; }
Public Property WagesPaidCode9 As String
    Get
    Set
public:
property String^ WagesPaidCode9 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RU3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RYL Class

RYL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL
RDPCrystal EDI Library
Royalty Payment
Declaration Syntax
C# Visual Basic Visual C++
public class RYL : DocumentSegment
Public Class RYL _
    Inherits DocumentSegment
public ref class RYL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RYL()()()() | Initializes a new instance of the RYL class
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameLastOrOrganizationName | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RYL


RYL Constructor

RYL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► RYL()()()()
RDPCrystal EDI Library
Initializes a new instance of the RYL class
Declaration Syntax
C# Visual Basic Visual C++
public RYL()
Public Sub New
public:
RYL()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NameLastOrOrganizationName Property

NameLastOrOrganizationName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► NameLastOrOrganizationName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NameLastOrOrganizationName { get; set; }
Public Property NameLastOrOrganizationName As String
    Get
    Set
public:
property String^ NameLastOrOrganizationName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► RYL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S1 Class

S1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1
RDPCrystal EDI Library
Stop-off Name
Declaration Syntax
C# Visual Basic Visual C++
public class S1 : DocumentSegment
Public Class S1 _
    Inherits DocumentSegment
public ref class S1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S1()()()() | Initializes a new instance of the S1 class
 | AccomplishCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 5
 | StopSequenceNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S1


S1 Constructor

S1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► S1()()()()
RDPCrystal EDI Library
Initializes a new instance of the S1 class
Declaration Syntax
C# Visual Basic Visual C++
public S1()
Public Sub New
public:
S1()


AccomplishCode Property

AccomplishCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► AccomplishCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AccomplishCode { get; set; }
Public Property AccomplishCode As String
    Get
    Set
public:
property String^ AccomplishCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StopSequenceNumber Property

StopSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► StopSequenceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StopSequenceNumber { get; set; }
Public Property StopSequenceNumber As String
    Get
    Set
public:
property String^ StopSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S1A Class

S1A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A
RDPCrystal EDI Library
Assurance Level 1
Declaration Syntax
C# Visual Basic Visual C++
public class S1A : DocumentSegment
Public Class S1A _
    Inherits DocumentSegment
public ref class S1A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S1A()()()() | Initializes a new instance of the S1A class
 | AssuranceDigest | Element 10
 | AssuranceOriginator | Element 4
 | AssuranceRecipient | Element 5
 | AssuranceReferenceNumber | Element 6
 | AssuranceText | Element 8
 | AssuranceTokenParameters | Element 9
 | BusinessPurposeOfAssurance | Element 1
 | ComputationMethods | Element 2
 | DateTimeReference | Element 7
 | DomainOfComputationOfAssurance | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S1A


S1A Constructor

S1A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► S1A()()()()
RDPCrystal EDI Library
Initializes a new instance of the S1A class
Declaration Syntax
C# Visual Basic Visual C++
public S1A()
Public Sub New
public:
S1A()


AssuranceDigest Property

AssuranceDigest Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► AssuranceDigest
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceDigest { get; set; }
Public Property AssuranceDigest As String
    Get
    Set
public:
property String^ AssuranceDigest {
    String^ get ();
    void set (String^ value);
}


AssuranceOriginator Property

AssuranceOriginator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► AssuranceOriginator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceOriginator { get; set; }
Public Property AssuranceOriginator As String
    Get
    Set
public:
property String^ AssuranceOriginator {
    String^ get ();
    void set (String^ value);
}


AssuranceRecipient Property

AssuranceRecipient Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► AssuranceRecipient
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceRecipient { get; set; }
Public Property AssuranceRecipient As String
    Get
    Set
public:
property String^ AssuranceRecipient {
    String^ get ();
    void set (String^ value);
}


AssuranceReferenceNumber Property

AssuranceReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► AssuranceReferenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceReferenceNumber { get; set; }
Public Property AssuranceReferenceNumber As String
    Get
    Set
public:
property String^ AssuranceReferenceNumber {
    String^ get ();
    void set (String^ value);
}


AssuranceText Property

AssuranceText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► AssuranceText
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceText { get; set; }
Public Property AssuranceText As String
    Get
    Set
public:
property String^ AssuranceText {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameters Property

AssuranceTokenParameters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► AssuranceTokenParameters
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public AssuranceTokenParameters AssuranceTokenParameters { get; set; }
Public Property AssuranceTokenParameters As AssuranceTokenParameters
    Get
    Set
public:
property AssuranceTokenParameters^ AssuranceTokenParameters {
    AssuranceTokenParameters^ get ();
    void set (AssuranceTokenParameters^ value);
}


BusinessPurposeOfAssurance Property

BusinessPurposeOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► BusinessPurposeOfAssurance
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessPurposeOfAssurance { get; set; }
Public Property BusinessPurposeOfAssurance As String
    Get
    Set
public:
property String^ BusinessPurposeOfAssurance {
    String^ get ();
    void set (String^ value);
}


ComputationMethods Property

ComputationMethods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► ComputationMethods
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public ComputationMethods ComputationMethods { get; set; }
Public Property ComputationMethods As ComputationMethods
    Get
    Set
public:
property ComputationMethods^ ComputationMethods {
    ComputationMethods^ get ();
    void set (ComputationMethods^ value);
}


DateTimeReference Property

DateTimeReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► DateTimeReference
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeReference { get; set; }
Public Property DateTimeReference As String
    Get
    Set
public:
property String^ DateTimeReference {
    String^ get ();
    void set (String^ value);
}


DomainOfComputationOfAssurance Property

DomainOfComputationOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► DomainOfComputationOfAssurance
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DomainOfComputationOfAssurance { get; set; }
Public Property DomainOfComputationOfAssurance As String
    Get
    Set
public:
property String^ DomainOfComputationOfAssurance {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S1E Class

S1E Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1E
RDPCrystal EDI Library
Security Trailer Level 1
Declaration Syntax
C# Visual Basic Visual C++
public class S1E : DocumentSegment
Public Class S1E _
    Inherits DocumentSegment
public ref class S1E : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S1E()()()() | Initializes a new instance of the S1E class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HashOrAuthenticationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S1E


S1E Constructor

S1E Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1E ► S1E()()()()
RDPCrystal EDI Library
Initializes a new instance of the S1E class
Declaration Syntax
C# Visual Basic Visual C++
public S1E()
Public Sub New
public:
S1E()


HashOrAuthenticationCode Property

HashOrAuthenticationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1E ► HashOrAuthenticationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HashOrAuthenticationCode { get; set; }
Public Property HashOrAuthenticationCode As String
    Get
    Set
public:
property String^ HashOrAuthenticationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1E ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1E ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S1S Class

S1S Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S
RDPCrystal EDI Library
Security Header Level 1
Declaration Syntax
C# Visual Basic Visual C++
public class S1S : DocumentSegment
Public Class S1S _
    Inherits DocumentSegment
public ref class S1S : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S1S()()()() | Initializes a new instance of the S1S class
 | AuthenticationKeyName | Element 4
 | AuthenticationServiceCode | Element 5
 | EncryptionKeyInformation | Element 6
 | EncryptionServiceInformation | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InitializationVector | Element 9
 | LengthOfData | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityOriginatorName | Element 2
 | SecurityRecipientName | Element 3
 | SecurityTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S1S


S1S Constructor

S1S Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► S1S()()()()
RDPCrystal EDI Library
Initializes a new instance of the S1S class
Declaration Syntax
C# Visual Basic Visual C++
public S1S()
Public Sub New
public:
S1S()


AuthenticationKeyName Property

AuthenticationKeyName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► AuthenticationKeyName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationKeyName { get; set; }
Public Property AuthenticationKeyName As String
    Get
    Set
public:
property String^ AuthenticationKeyName {
    String^ get ();
    void set (String^ value);
}


AuthenticationServiceCode Property

AuthenticationServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► AuthenticationServiceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationServiceCode { get; set; }
Public Property AuthenticationServiceCode As String
    Get
    Set
public:
property String^ AuthenticationServiceCode {
    String^ get ();
    void set (String^ value);
}


EncryptionKeyInformation Property

EncryptionKeyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► EncryptionKeyInformation
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionKeyInformation EncryptionKeyInformation { get; set; }
Public Property EncryptionKeyInformation As EncryptionKeyInformation
    Get
    Set
public:
property EncryptionKeyInformation^ EncryptionKeyInformation {
    EncryptionKeyInformation^ get ();
    void set (EncryptionKeyInformation^ value);
}


EncryptionServiceInformation Property

EncryptionServiceInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► EncryptionServiceInformation
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionServiceInformation EncryptionServiceInformation { get; set; }
Public Property EncryptionServiceInformation As EncryptionServiceInformation
    Get
    Set
public:
property EncryptionServiceInformation^ EncryptionServiceInformation {
    EncryptionServiceInformation^ get ();
    void set (EncryptionServiceInformation^ value);
}


InitializationVector Property

InitializationVector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► InitializationVector
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InitializationVector { get; set; }
Public Property InitializationVector As String
    Get
    Set
public:
property String^ InitializationVector {
    String^ get ();
    void set (String^ value);
}


LengthOfData Property

LengthOfData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► LengthOfData
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LengthOfData { get; set; }
Public Property LengthOfData As String
    Get
    Set
public:
property String^ LengthOfData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityOriginatorName Property

SecurityOriginatorName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► SecurityOriginatorName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityOriginatorName { get; set; }
Public Property SecurityOriginatorName As String
    Get
    Set
public:
property String^ SecurityOriginatorName {
    String^ get ();
    void set (String^ value);
}


SecurityRecipientName Property

SecurityRecipientName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► SecurityRecipientName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityRecipientName { get; set; }
Public Property SecurityRecipientName As String
    Get
    Set
public:
property String^ SecurityRecipientName {
    String^ get ();
    void set (String^ value);
}


SecurityTypeCode Property

SecurityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► SecurityTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityTypeCode { get; set; }
Public Property SecurityTypeCode As String
    Get
    Set
public:
property String^ SecurityTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S1S ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S2 Class

S2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2
RDPCrystal EDI Library
Stop-off Address
Declaration Syntax
C# Visual Basic Visual C++
public class S2 : DocumentSegment
Public Class S2 _
    Inherits DocumentSegment
public ref class S2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S2()()()() | Initializes a new instance of the S2 class
 | AddressInformation | Element 2
 | AddressInformation1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StopSequenceNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S2


S2 Constructor

S2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2 ► S2()()()()
RDPCrystal EDI Library
Initializes a new instance of the S2 class
Declaration Syntax
C# Visual Basic Visual C++
public S2()
Public Sub New
public:
S2()


AddressInformation Property

AddressInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2 ► AddressInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation { get; set; }
Public Property AddressInformation As String
    Get
    Set
public:
property String^ AddressInformation {
    String^ get ();
    void set (String^ value);
}


AddressInformation1 Property

AddressInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2 ► AddressInformation1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation1 { get; set; }
Public Property AddressInformation1 As String
    Get
    Set
public:
property String^ AddressInformation1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StopSequenceNumber Property

StopSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2 ► StopSequenceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StopSequenceNumber { get; set; }
Public Property StopSequenceNumber As String
    Get
    Set
public:
property String^ StopSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S2A Class

S2A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A
RDPCrystal EDI Library
Assurance Level 2
Declaration Syntax
C# Visual Basic Visual C++
public class S2A : DocumentSegment
Public Class S2A _
    Inherits DocumentSegment
public ref class S2A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S2A()()()() | Initializes a new instance of the S2A class
 | AssuranceDigest | Element 10
 | AssuranceOriginator | Element 4
 | AssuranceRecipient | Element 5
 | AssuranceReferenceNumber | Element 6
 | AssuranceText | Element 8
 | AssuranceTokenParameters | Element 9
 | BusinessPurposeOfAssurance | Element 1
 | ComputationMethods | Element 2
 | DateTimeReference | Element 7
 | DomainOfComputationOfAssurance | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S2A


S2A Constructor

S2A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► S2A()()()()
RDPCrystal EDI Library
Initializes a new instance of the S2A class
Declaration Syntax
C# Visual Basic Visual C++
public S2A()
Public Sub New
public:
S2A()


AssuranceDigest Property

AssuranceDigest Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► AssuranceDigest
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceDigest { get; set; }
Public Property AssuranceDigest As String
    Get
    Set
public:
property String^ AssuranceDigest {
    String^ get ();
    void set (String^ value);
}


AssuranceOriginator Property

AssuranceOriginator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► AssuranceOriginator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceOriginator { get; set; }
Public Property AssuranceOriginator As String
    Get
    Set
public:
property String^ AssuranceOriginator {
    String^ get ();
    void set (String^ value);
}


AssuranceRecipient Property

AssuranceRecipient Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► AssuranceRecipient
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceRecipient { get; set; }
Public Property AssuranceRecipient As String
    Get
    Set
public:
property String^ AssuranceRecipient {
    String^ get ();
    void set (String^ value);
}


AssuranceReferenceNumber Property

AssuranceReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► AssuranceReferenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceReferenceNumber { get; set; }
Public Property AssuranceReferenceNumber As String
    Get
    Set
public:
property String^ AssuranceReferenceNumber {
    String^ get ();
    void set (String^ value);
}


AssuranceText Property

AssuranceText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► AssuranceText
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceText { get; set; }
Public Property AssuranceText As String
    Get
    Set
public:
property String^ AssuranceText {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameters Property

AssuranceTokenParameters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► AssuranceTokenParameters
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public AssuranceTokenParameters AssuranceTokenParameters { get; set; }
Public Property AssuranceTokenParameters As AssuranceTokenParameters
    Get
    Set
public:
property AssuranceTokenParameters^ AssuranceTokenParameters {
    AssuranceTokenParameters^ get ();
    void set (AssuranceTokenParameters^ value);
}


BusinessPurposeOfAssurance Property

BusinessPurposeOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► BusinessPurposeOfAssurance
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessPurposeOfAssurance { get; set; }
Public Property BusinessPurposeOfAssurance As String
    Get
    Set
public:
property String^ BusinessPurposeOfAssurance {
    String^ get ();
    void set (String^ value);
}


ComputationMethods Property

ComputationMethods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► ComputationMethods
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public ComputationMethods ComputationMethods { get; set; }
Public Property ComputationMethods As ComputationMethods
    Get
    Set
public:
property ComputationMethods^ ComputationMethods {
    ComputationMethods^ get ();
    void set (ComputationMethods^ value);
}


DateTimeReference Property

DateTimeReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► DateTimeReference
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeReference { get; set; }
Public Property DateTimeReference As String
    Get
    Set
public:
property String^ DateTimeReference {
    String^ get ();
    void set (String^ value);
}


DomainOfComputationOfAssurance Property

DomainOfComputationOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► DomainOfComputationOfAssurance
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DomainOfComputationOfAssurance { get; set; }
Public Property DomainOfComputationOfAssurance As String
    Get
    Set
public:
property String^ DomainOfComputationOfAssurance {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S2E Class

S2E Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2E
RDPCrystal EDI Library
Security Trailer Level 2
Declaration Syntax
C# Visual Basic Visual C++
public class S2E : DocumentSegment
Public Class S2E _
    Inherits DocumentSegment
public ref class S2E : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S2E()()()() | Initializes a new instance of the S2E class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HashOrAuthenticationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S2E


S2E Constructor

S2E Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2E ► S2E()()()()
RDPCrystal EDI Library
Initializes a new instance of the S2E class
Declaration Syntax
C# Visual Basic Visual C++
public S2E()
Public Sub New
public:
S2E()


HashOrAuthenticationCode Property

HashOrAuthenticationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2E ► HashOrAuthenticationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HashOrAuthenticationCode { get; set; }
Public Property HashOrAuthenticationCode As String
    Get
    Set
public:
property String^ HashOrAuthenticationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2E ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2E ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S2S Class

S2S Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S
RDPCrystal EDI Library
Security Header Level 2
Declaration Syntax
C# Visual Basic Visual C++
public class S2S : DocumentSegment
Public Class S2S _
    Inherits DocumentSegment
public ref class S2S : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S2S()()()() | Initializes a new instance of the S2S class
 | AuthenticationKeyName | Element 4
 | AuthenticationServiceCode | Element 5
 | EncryptionKeyInformation | Element 6
 | EncryptionServiceInformation | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InitializationVector | Element 9
 | LengthOfData | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityOriginatorName | Element 2
 | SecurityRecipientName | Element 3
 | SecurityTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S2S


S2S Constructor

S2S Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► S2S()()()()
RDPCrystal EDI Library
Initializes a new instance of the S2S class
Declaration Syntax
C# Visual Basic Visual C++
public S2S()
Public Sub New
public:
S2S()


AuthenticationKeyName Property

AuthenticationKeyName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► AuthenticationKeyName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationKeyName { get; set; }
Public Property AuthenticationKeyName As String
    Get
    Set
public:
property String^ AuthenticationKeyName {
    String^ get ();
    void set (String^ value);
}


AuthenticationServiceCode Property

AuthenticationServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► AuthenticationServiceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationServiceCode { get; set; }
Public Property AuthenticationServiceCode As String
    Get
    Set
public:
property String^ AuthenticationServiceCode {
    String^ get ();
    void set (String^ value);
}


EncryptionKeyInformation Property

EncryptionKeyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► EncryptionKeyInformation
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionKeyInformation EncryptionKeyInformation { get; set; }
Public Property EncryptionKeyInformation As EncryptionKeyInformation
    Get
    Set
public:
property EncryptionKeyInformation^ EncryptionKeyInformation {
    EncryptionKeyInformation^ get ();
    void set (EncryptionKeyInformation^ value);
}


EncryptionServiceInformation Property

EncryptionServiceInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► EncryptionServiceInformation
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionServiceInformation EncryptionServiceInformation { get; set; }
Public Property EncryptionServiceInformation As EncryptionServiceInformation
    Get
    Set
public:
property EncryptionServiceInformation^ EncryptionServiceInformation {
    EncryptionServiceInformation^ get ();
    void set (EncryptionServiceInformation^ value);
}


InitializationVector Property

InitializationVector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► InitializationVector
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InitializationVector { get; set; }
Public Property InitializationVector As String
    Get
    Set
public:
property String^ InitializationVector {
    String^ get ();
    void set (String^ value);
}


LengthOfData Property

LengthOfData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► LengthOfData
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LengthOfData { get; set; }
Public Property LengthOfData As String
    Get
    Set
public:
property String^ LengthOfData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityOriginatorName Property

SecurityOriginatorName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► SecurityOriginatorName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityOriginatorName { get; set; }
Public Property SecurityOriginatorName As String
    Get
    Set
public:
property String^ SecurityOriginatorName {
    String^ get ();
    void set (String^ value);
}


SecurityRecipientName Property

SecurityRecipientName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► SecurityRecipientName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityRecipientName { get; set; }
Public Property SecurityRecipientName As String
    Get
    Set
public:
property String^ SecurityRecipientName {
    String^ get ();
    void set (String^ value);
}


SecurityTypeCode Property

SecurityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► SecurityTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityTypeCode { get; set; }
Public Property SecurityTypeCode As String
    Get
    Set
public:
property String^ SecurityTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S2S ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S3A Class

S3A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A
RDPCrystal EDI Library
Assurance Header Level 1
Declaration Syntax
C# Visual Basic Visual C++
public class S3A : DocumentSegment
Public Class S3A _
    Inherits DocumentSegment
public ref class S3A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S3A()()()() | Initializes a new instance of the S3A class
 | AssuranceOriginator | Element 5
 | AssuranceRecipient | Element 6
 | AssuranceReferenceNumber | Element 7
 | AssuranceText | Element 9
 | AssuranceTokenParameters | Element 11
 | BusinessPurposeOfAssurance | Element 2
 | CertificateLookupInformation | Element 10
 | ComputationMethods | Element 3
 | DateTimeReference | Element 8
 | DomainOfComputationOfAssurance | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityVersionReleaseIdentifierCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S3A


S3A Constructor

S3A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► S3A()()()()
RDPCrystal EDI Library
Initializes a new instance of the S3A class
Declaration Syntax
C# Visual Basic Visual C++
public S3A()
Public Sub New
public:
S3A()


AssuranceOriginator Property

AssuranceOriginator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► AssuranceOriginator
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceOriginator { get; set; }
Public Property AssuranceOriginator As String
    Get
    Set
public:
property String^ AssuranceOriginator {
    String^ get ();
    void set (String^ value);
}


AssuranceRecipient Property

AssuranceRecipient Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► AssuranceRecipient
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceRecipient { get; set; }
Public Property AssuranceRecipient As String
    Get
    Set
public:
property String^ AssuranceRecipient {
    String^ get ();
    void set (String^ value);
}


AssuranceReferenceNumber Property

AssuranceReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► AssuranceReferenceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceReferenceNumber { get; set; }
Public Property AssuranceReferenceNumber As String
    Get
    Set
public:
property String^ AssuranceReferenceNumber {
    String^ get ();
    void set (String^ value);
}


AssuranceText Property

AssuranceText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► AssuranceText
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceText { get; set; }
Public Property AssuranceText As String
    Get
    Set
public:
property String^ AssuranceText {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameters Property

AssuranceTokenParameters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► AssuranceTokenParameters
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public AssuranceTokenParameters AssuranceTokenParameters { get; set; }
Public Property AssuranceTokenParameters As AssuranceTokenParameters
    Get
    Set
public:
property AssuranceTokenParameters^ AssuranceTokenParameters {
    AssuranceTokenParameters^ get ();
    void set (AssuranceTokenParameters^ value);
}


BusinessPurposeOfAssurance Property

BusinessPurposeOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► BusinessPurposeOfAssurance
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessPurposeOfAssurance { get; set; }
Public Property BusinessPurposeOfAssurance As String
    Get
    Set
public:
property String^ BusinessPurposeOfAssurance {
    String^ get ();
    void set (String^ value);
}


CertificateLookupInformation Property

CertificateLookupInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► CertificateLookupInformation
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CertificateLookupInformation CertificateLookupInformation { get; set; }
Public Property CertificateLookupInformation As CertificateLookupInformation
    Get
    Set
public:
property CertificateLookupInformation^ CertificateLookupInformation {
    CertificateLookupInformation^ get ();
    void set (CertificateLookupInformation^ value);
}


ComputationMethods Property

ComputationMethods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► ComputationMethods
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public ComputationMethods ComputationMethods { get; set; }
Public Property ComputationMethods As ComputationMethods
    Get
    Set
public:
property ComputationMethods^ ComputationMethods {
    ComputationMethods^ get ();
    void set (ComputationMethods^ value);
}


DateTimeReference Property

DateTimeReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► DateTimeReference
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeReference { get; set; }
Public Property DateTimeReference As String
    Get
    Set
public:
property String^ DateTimeReference {
    String^ get ();
    void set (String^ value);
}


DomainOfComputationOfAssurance Property

DomainOfComputationOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► DomainOfComputationOfAssurance
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DomainOfComputationOfAssurance { get; set; }
Public Property DomainOfComputationOfAssurance As String
    Get
    Set
public:
property String^ DomainOfComputationOfAssurance {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityVersionReleaseIdentifierCode Property

SecurityVersionReleaseIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► SecurityVersionReleaseIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityVersionReleaseIdentifierCode { get; set; }
Public Property SecurityVersionReleaseIdentifierCode As String
    Get
    Set
public:
property String^ SecurityVersionReleaseIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S3E Class

S3E Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3E
RDPCrystal EDI Library
Security Trailer Level 1
Declaration Syntax
C# Visual Basic Visual C++
public class S3E : DocumentSegment
Public Class S3E _
    Inherits DocumentSegment
public ref class S3E : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S3E()()()() | Initializes a new instance of the S3E class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HashOrAuthenticationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S3E


S3E Constructor

S3E Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3E ► S3E()()()()
RDPCrystal EDI Library
Initializes a new instance of the S3E class
Declaration Syntax
C# Visual Basic Visual C++
public S3E()
Public Sub New
public:
S3E()


HashOrAuthenticationCode Property

HashOrAuthenticationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3E ► HashOrAuthenticationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HashOrAuthenticationCode { get; set; }
Public Property HashOrAuthenticationCode As String
    Get
    Set
public:
property String^ HashOrAuthenticationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3E ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3E ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S3S Class

S3S Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S
RDPCrystal EDI Library
Security Header Level 1
Declaration Syntax
C# Visual Basic Visual C++
public class S3S : DocumentSegment
Public Class S3S _
    Inherits DocumentSegment
public ref class S3S : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S3S()()()() | Initializes a new instance of the S3S class
 | AuthenticationKeyName | Element 5
 | AuthenticationServiceCode | Element 6
 | CertificateLookupInformation | Element 7
 | EncryptionKeyInformation | Element 8
 | EncryptionServiceInformation | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InitializationVector | Element 11
 | LengthOfData | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityOriginatorName | Element 3
 | SecurityRecipientName | Element 4
 | SecurityTypeCode | Element 2
 | SecurityVersionReleaseIdentifierCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S3S


S3S Constructor

S3S Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► S3S()()()()
RDPCrystal EDI Library
Initializes a new instance of the S3S class
Declaration Syntax
C# Visual Basic Visual C++
public S3S()
Public Sub New
public:
S3S()


AuthenticationKeyName Property

AuthenticationKeyName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► AuthenticationKeyName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationKeyName { get; set; }
Public Property AuthenticationKeyName As String
    Get
    Set
public:
property String^ AuthenticationKeyName {
    String^ get ();
    void set (String^ value);
}


AuthenticationServiceCode Property

AuthenticationServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► AuthenticationServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationServiceCode { get; set; }
Public Property AuthenticationServiceCode As String
    Get
    Set
public:
property String^ AuthenticationServiceCode {
    String^ get ();
    void set (String^ value);
}


CertificateLookupInformation Property

CertificateLookupInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► CertificateLookupInformation
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CertificateLookupInformation CertificateLookupInformation { get; set; }
Public Property CertificateLookupInformation As CertificateLookupInformation
    Get
    Set
public:
property CertificateLookupInformation^ CertificateLookupInformation {
    CertificateLookupInformation^ get ();
    void set (CertificateLookupInformation^ value);
}


EncryptionKeyInformation Property

EncryptionKeyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► EncryptionKeyInformation
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionKeyInformation EncryptionKeyInformation { get; set; }
Public Property EncryptionKeyInformation As EncryptionKeyInformation
    Get
    Set
public:
property EncryptionKeyInformation^ EncryptionKeyInformation {
    EncryptionKeyInformation^ get ();
    void set (EncryptionKeyInformation^ value);
}


EncryptionServiceInformation Property

EncryptionServiceInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► EncryptionServiceInformation
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionServiceInformation EncryptionServiceInformation { get; set; }
Public Property EncryptionServiceInformation As EncryptionServiceInformation
    Get
    Set
public:
property EncryptionServiceInformation^ EncryptionServiceInformation {
    EncryptionServiceInformation^ get ();
    void set (EncryptionServiceInformation^ value);
}


InitializationVector Property

InitializationVector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► InitializationVector
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string InitializationVector { get; set; }
Public Property InitializationVector As String
    Get
    Set
public:
property String^ InitializationVector {
    String^ get ();
    void set (String^ value);
}


LengthOfData Property

LengthOfData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► LengthOfData
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LengthOfData { get; set; }
Public Property LengthOfData As String
    Get
    Set
public:
property String^ LengthOfData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityOriginatorName Property

SecurityOriginatorName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► SecurityOriginatorName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityOriginatorName { get; set; }
Public Property SecurityOriginatorName As String
    Get
    Set
public:
property String^ SecurityOriginatorName {
    String^ get ();
    void set (String^ value);
}


SecurityRecipientName Property

SecurityRecipientName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► SecurityRecipientName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityRecipientName { get; set; }
Public Property SecurityRecipientName As String
    Get
    Set
public:
property String^ SecurityRecipientName {
    String^ get ();
    void set (String^ value);
}


SecurityTypeCode Property

SecurityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► SecurityTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityTypeCode { get; set; }
Public Property SecurityTypeCode As String
    Get
    Set
public:
property String^ SecurityTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityVersionReleaseIdentifierCode Property

SecurityVersionReleaseIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► SecurityVersionReleaseIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityVersionReleaseIdentifierCode { get; set; }
Public Property SecurityVersionReleaseIdentifierCode As String
    Get
    Set
public:
property String^ SecurityVersionReleaseIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S3S ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S4A Class

S4A Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A
RDPCrystal EDI Library
Assurance Header Level 2
Declaration Syntax
C# Visual Basic Visual C++
public class S4A : DocumentSegment
Public Class S4A _
    Inherits DocumentSegment
public ref class S4A : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S4A()()()() | Initializes a new instance of the S4A class
 | AssuranceOriginator | Element 5
 | AssuranceRecipient | Element 6
 | AssuranceReferenceNumber | Element 7
 | AssuranceText | Element 9
 | AssuranceTokenParameters | Element 11
 | BusinessPurposeOfAssurance | Element 2
 | CertificateLookupInformation | Element 10
 | ComputationMethods | Element 3
 | DateTimeReference | Element 8
 | DomainOfComputationOfAssurance | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityVersionReleaseIdentifierCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S4A


S4A Constructor

S4A Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► S4A()()()()
RDPCrystal EDI Library
Initializes a new instance of the S4A class
Declaration Syntax
C# Visual Basic Visual C++
public S4A()
Public Sub New
public:
S4A()


AssuranceOriginator Property

AssuranceOriginator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► AssuranceOriginator
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceOriginator { get; set; }
Public Property AssuranceOriginator As String
    Get
    Set
public:
property String^ AssuranceOriginator {
    String^ get ();
    void set (String^ value);
}


AssuranceRecipient Property

AssuranceRecipient Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► AssuranceRecipient
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceRecipient { get; set; }
Public Property AssuranceRecipient As String
    Get
    Set
public:
property String^ AssuranceRecipient {
    String^ get ();
    void set (String^ value);
}


AssuranceReferenceNumber Property

AssuranceReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► AssuranceReferenceNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceReferenceNumber { get; set; }
Public Property AssuranceReferenceNumber As String
    Get
    Set
public:
property String^ AssuranceReferenceNumber {
    String^ get ();
    void set (String^ value);
}


AssuranceText Property

AssuranceText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► AssuranceText
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AssuranceText { get; set; }
Public Property AssuranceText As String
    Get
    Set
public:
property String^ AssuranceText {
    String^ get ();
    void set (String^ value);
}


AssuranceTokenParameters Property

AssuranceTokenParameters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► AssuranceTokenParameters
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public AssuranceTokenParameters AssuranceTokenParameters { get; set; }
Public Property AssuranceTokenParameters As AssuranceTokenParameters
    Get
    Set
public:
property AssuranceTokenParameters^ AssuranceTokenParameters {
    AssuranceTokenParameters^ get ();
    void set (AssuranceTokenParameters^ value);
}


BusinessPurposeOfAssurance Property

BusinessPurposeOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► BusinessPurposeOfAssurance
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessPurposeOfAssurance { get; set; }
Public Property BusinessPurposeOfAssurance As String
    Get
    Set
public:
property String^ BusinessPurposeOfAssurance {
    String^ get ();
    void set (String^ value);
}


CertificateLookupInformation Property

CertificateLookupInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► CertificateLookupInformation
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CertificateLookupInformation CertificateLookupInformation { get; set; }
Public Property CertificateLookupInformation As CertificateLookupInformation
    Get
    Set
public:
property CertificateLookupInformation^ CertificateLookupInformation {
    CertificateLookupInformation^ get ();
    void set (CertificateLookupInformation^ value);
}


ComputationMethods Property

ComputationMethods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► ComputationMethods
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public ComputationMethods ComputationMethods { get; set; }
Public Property ComputationMethods As ComputationMethods
    Get
    Set
public:
property ComputationMethods^ ComputationMethods {
    ComputationMethods^ get ();
    void set (ComputationMethods^ value);
}


DateTimeReference Property

DateTimeReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► DateTimeReference
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeReference { get; set; }
Public Property DateTimeReference As String
    Get
    Set
public:
property String^ DateTimeReference {
    String^ get ();
    void set (String^ value);
}


DomainOfComputationOfAssurance Property

DomainOfComputationOfAssurance Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► DomainOfComputationOfAssurance
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DomainOfComputationOfAssurance { get; set; }
Public Property DomainOfComputationOfAssurance As String
    Get
    Set
public:
property String^ DomainOfComputationOfAssurance {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityVersionReleaseIdentifierCode Property

SecurityVersionReleaseIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► SecurityVersionReleaseIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityVersionReleaseIdentifierCode { get; set; }
Public Property SecurityVersionReleaseIdentifierCode As String
    Get
    Set
public:
property String^ SecurityVersionReleaseIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4A ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S4E Class

S4E Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4E
RDPCrystal EDI Library
Security Trailer Level 2
Declaration Syntax
C# Visual Basic Visual C++
public class S4E : DocumentSegment
Public Class S4E _
    Inherits DocumentSegment
public ref class S4E : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S4E()()()() | Initializes a new instance of the S4E class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HashOrAuthenticationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S4E


S4E Constructor

S4E Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4E ► S4E()()()()
RDPCrystal EDI Library
Initializes a new instance of the S4E class
Declaration Syntax
C# Visual Basic Visual C++
public S4E()
Public Sub New
public:
S4E()


HashOrAuthenticationCode Property

HashOrAuthenticationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4E ► HashOrAuthenticationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HashOrAuthenticationCode { get; set; }
Public Property HashOrAuthenticationCode As String
    Get
    Set
public:
property String^ HashOrAuthenticationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4E ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4E ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S4S Class

S4S Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S
RDPCrystal EDI Library
Security Header Level 2
Declaration Syntax
C# Visual Basic Visual C++
public class S4S : DocumentSegment
Public Class S4S _
    Inherits DocumentSegment
public ref class S4S : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S4S()()()() | Initializes a new instance of the S4S class
 | AuthenticationKeyName | Element 5
 | AuthenticationServiceCode | Element 6
 | CertificateLookupInformation | Element 7
 | EncryptionKeyInformation | Element 8
 | EncryptionServiceInformation | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InitializationVector | Element 11
 | LengthOfData | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityOriginatorName | Element 3
 | SecurityRecipientName | Element 4
 | SecurityTypeCode | Element 2
 | SecurityVersionReleaseIdentifierCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S4S


S4S Constructor

S4S Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► S4S()()()()
RDPCrystal EDI Library
Initializes a new instance of the S4S class
Declaration Syntax
C# Visual Basic Visual C++
public S4S()
Public Sub New
public:
S4S()


AuthenticationKeyName Property

AuthenticationKeyName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► AuthenticationKeyName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationKeyName { get; set; }
Public Property AuthenticationKeyName As String
    Get
    Set
public:
property String^ AuthenticationKeyName {
    String^ get ();
    void set (String^ value);
}


AuthenticationServiceCode Property

AuthenticationServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► AuthenticationServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AuthenticationServiceCode { get; set; }
Public Property AuthenticationServiceCode As String
    Get
    Set
public:
property String^ AuthenticationServiceCode {
    String^ get ();
    void set (String^ value);
}


CertificateLookupInformation Property

CertificateLookupInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► CertificateLookupInformation
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CertificateLookupInformation CertificateLookupInformation { get; set; }
Public Property CertificateLookupInformation As CertificateLookupInformation
    Get
    Set
public:
property CertificateLookupInformation^ CertificateLookupInformation {
    CertificateLookupInformation^ get ();
    void set (CertificateLookupInformation^ value);
}


EncryptionKeyInformation Property

EncryptionKeyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► EncryptionKeyInformation
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionKeyInformation EncryptionKeyInformation { get; set; }
Public Property EncryptionKeyInformation As EncryptionKeyInformation
    Get
    Set
public:
property EncryptionKeyInformation^ EncryptionKeyInformation {
    EncryptionKeyInformation^ get ();
    void set (EncryptionKeyInformation^ value);
}


EncryptionServiceInformation Property

EncryptionServiceInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► EncryptionServiceInformation
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public EncryptionServiceInformation EncryptionServiceInformation { get; set; }
Public Property EncryptionServiceInformation As EncryptionServiceInformation
    Get
    Set
public:
property EncryptionServiceInformation^ EncryptionServiceInformation {
    EncryptionServiceInformation^ get ();
    void set (EncryptionServiceInformation^ value);
}


InitializationVector Property

InitializationVector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► InitializationVector
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string InitializationVector { get; set; }
Public Property InitializationVector As String
    Get
    Set
public:
property String^ InitializationVector {
    String^ get ();
    void set (String^ value);
}


LengthOfData Property

LengthOfData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► LengthOfData
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LengthOfData { get; set; }
Public Property LengthOfData As String
    Get
    Set
public:
property String^ LengthOfData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityOriginatorName Property

SecurityOriginatorName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► SecurityOriginatorName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityOriginatorName { get; set; }
Public Property SecurityOriginatorName As String
    Get
    Set
public:
property String^ SecurityOriginatorName {
    String^ get ();
    void set (String^ value);
}


SecurityRecipientName Property

SecurityRecipientName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► SecurityRecipientName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityRecipientName { get; set; }
Public Property SecurityRecipientName As String
    Get
    Set
public:
property String^ SecurityRecipientName {
    String^ get ();
    void set (String^ value);
}


SecurityTypeCode Property

SecurityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► SecurityTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityTypeCode { get; set; }
Public Property SecurityTypeCode As String
    Get
    Set
public:
property String^ SecurityTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityVersionReleaseIdentifierCode Property

SecurityVersionReleaseIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► SecurityVersionReleaseIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityVersionReleaseIdentifierCode { get; set; }
Public Property SecurityVersionReleaseIdentifierCode As String
    Get
    Set
public:
property String^ SecurityVersionReleaseIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S4S ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S5 Class

S5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5
RDPCrystal EDI Library
Stop Off Details
Declaration Syntax
C# Visual Basic Visual C++
public class S5 : DocumentSegment
Public Class S5 _
    Inherits DocumentSegment
public ref class S5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S5()()()() | Initializes a new instance of the S5 class
 | AccomplishCode | Element 11
 | Description | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardPointLocationCode | Element 10
 | StopReasonCode | Element 2
 | StopSequenceNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | Volume | Element 7
 | VolumeUnitQualifier | Element 8
 | Weight | Element 3
 | WeightUnitCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S5


S5 Constructor

S5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► S5()()()()
RDPCrystal EDI Library
Initializes a new instance of the S5 class
Declaration Syntax
C# Visual Basic Visual C++
public S5()
Public Sub New
public:
S5()


AccomplishCode Property

AccomplishCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► AccomplishCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string AccomplishCode { get; set; }
Public Property AccomplishCode As String
    Get
    Set
public:
property String^ AccomplishCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StopReasonCode Property

StopReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► StopReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StopReasonCode { get; set; }
Public Property StopReasonCode As String
    Get
    Set
public:
property String^ StopReasonCode {
    String^ get ();
    void set (String^ value);
}


StopSequenceNumber Property

StopSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► StopSequenceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StopSequenceNumber { get; set; }
Public Property StopSequenceNumber As String
    Get
    Set
public:
property String^ StopSequenceNumber {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► Volume
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► WeightUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


S9 Class

S9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9
RDPCrystal EDI Library
Stop-off Station
Declaration Syntax
C# Visual Basic Visual C++
public class S9 : DocumentSegment
Public Class S9 _
    Inherits DocumentSegment
public ref class S9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | S9()()()() | Initializes a new instance of the S9 class
 | CityName | Element 3
 | CountryCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 8
 | LocationQualifier | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardPointLocationCode | Element 2
 | StateOrProvinceCode | Element 4
 | StopReasonCode | Element 6
 | StopSequenceNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | S9


S9 Constructor

S9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► S9()()()()
RDPCrystal EDI Library
Initializes a new instance of the S9 class
Declaration Syntax
C# Visual Basic Visual C++
public S9()
Public Sub New
public:
S9()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► CountryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► LocationIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► LocationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StopReasonCode Property

StopReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► StopReasonCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StopReasonCode { get; set; }
Public Property StopReasonCode As String
    Get
    Set
public:
property String^ StopReasonCode {
    String^ get ();
    void set (String^ value);
}


StopSequenceNumber Property

StopSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► StopSequenceNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StopSequenceNumber { get; set; }
Public Property StopSequenceNumber As String
    Get
    Set
public:
property String^ StopSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► S9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SA Class

SA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA
RDPCrystal EDI Library
Status Action
Declaration Syntax
C# Visual Basic Visual C++
public class SA : DocumentSegment
Public Class SA _
    Inherits DocumentSegment
public ref class SA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SA()()()() | Initializes a new instance of the SA class
 | ActionCode | Element 2
 | Date | Element 1
 | Date1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name30CharacterFormat | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SA


SA Constructor

SA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► SA()()()()
RDPCrystal EDI Library
Initializes a new instance of the SA class
Declaration Syntax
C# Visual Basic Visual C++
public SA()
Public Sub New
public:
SA()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► ActionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name30CharacterFormat Property

Name30CharacterFormat Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► Name30CharacterFormat
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name30CharacterFormat { get; set; }
Public Property Name30CharacterFormat As String
    Get
    Set
public:
property String^ Name30CharacterFormat {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SAC Class

SAC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC
RDPCrystal EDI Library
Service, Promotion, Allowance, or Charge Information
Declaration Syntax
C# Visual Basic Visual C++
public class SAC : DocumentSegment
Public Class SAC _
    Inherits DocumentSegment
public ref class SAC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SAC()()()() | Initializes a new instance of the SAC class
 | AgencyQualifierCode | Element 3
 | AgencyServicePromotionAllowanceOrChargeCode | Element 4
 | AllowanceChargePercentQualifier | Element 6
 | AllowanceOrChargeIndicator | Element 1
 | AllowanceOrChargeMethodOfHandlingCode | Element 12
 | Amount | Element 5
 | Description | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LanguageCode | Element 16
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OptionNumber | Element 14
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | Quantity | Element 10
 | Quantity1 | Element 11
 | Rate | Element 8
 | ReferenceIdentification | Element 13
 | ServicePromotionAllowanceOrChargeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SAC


SAC Constructor

SAC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► SAC()()()()
RDPCrystal EDI Library
Initializes a new instance of the SAC class
Declaration Syntax
C# Visual Basic Visual C++
public SAC()
Public Sub New
public:
SAC()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AgencyServicePromotionAllowanceOrChargeCode Property

AgencyServicePromotionAllowanceOrChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► AgencyServicePromotionAllowanceOrChargeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyServicePromotionAllowanceOrChargeCode { get; set; }
Public Property AgencyServicePromotionAllowanceOrChargeCode As String
    Get
    Set
public:
property String^ AgencyServicePromotionAllowanceOrChargeCode {
    String^ get ();
    void set (String^ value);
}


AllowanceChargePercentQualifier Property

AllowanceChargePercentQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► AllowanceChargePercentQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceChargePercentQualifier { get; set; }
Public Property AllowanceChargePercentQualifier As String
    Get
    Set
public:
property String^ AllowanceChargePercentQualifier {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeIndicator Property

AllowanceOrChargeIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► AllowanceOrChargeIndicator
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeIndicator { get; set; }
Public Property AllowanceOrChargeIndicator As String
    Get
    Set
public:
property String^ AllowanceOrChargeIndicator {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeMethodOfHandlingCode Property

AllowanceOrChargeMethodOfHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► AllowanceOrChargeMethodOfHandlingCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeMethodOfHandlingCode { get; set; }
Public Property AllowanceOrChargeMethodOfHandlingCode As String
    Get
    Set
public:
property String^ AllowanceOrChargeMethodOfHandlingCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Description
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► LanguageCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OptionNumber Property

OptionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► OptionNumber
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string OptionNumber { get; set; }
Public Property OptionNumber As String
    Get
    Set
public:
property String^ OptionNumber {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Quantity1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Rate
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► ReferenceIdentification
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ServicePromotionAllowanceOrChargeCode Property

ServicePromotionAllowanceOrChargeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► ServicePromotionAllowanceOrChargeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServicePromotionAllowanceOrChargeCode { get; set; }
Public Property ServicePromotionAllowanceOrChargeCode As String
    Get
    Set
public:
property String^ ServicePromotionAllowanceOrChargeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SAL Class

SAL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL
RDPCrystal EDI Library
Salary Information
Declaration Syntax
C# Visual Basic Visual C++
public class SAL : DocumentSegment
Public Class SAL _
    Inherits DocumentSegment
public ref class SAL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SAL()()()() | Initializes a new instance of the SAL class
 | Amount | Element 2
 | Date | Element 6
 | Date1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LaborRate | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SAL


SAL Constructor

SAL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► SAL()()()()
RDPCrystal EDI Library
Initializes a new instance of the SAL class
Declaration Syntax
C# Visual Basic Visual C++
public SAL()
Public Sub New
public:
SAL()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► Amount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► Date1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


LaborRate Property

LaborRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► LaborRate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LaborRate { get; set; }
Public Property LaborRate As String
    Get
    Set
public:
property String^ LaborRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► NumberOfPeriods
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SAL ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SB Class

SB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SB
RDPCrystal EDI Library
Docket Level
Declaration Syntax
C# Visual Basic Visual C++
public class SB : DocumentSegment
Public Class SB _
    Inherits DocumentSegment
public ref class SB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SB()()()() | Initializes a new instance of the SB class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Level | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SB


SB Constructor

SB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SB ► SB()()()()
RDPCrystal EDI Library
Initializes a new instance of the SB class
Declaration Syntax
C# Visual Basic Visual C++
public SB()
Public Sub New
public:
SB()


Level Property

Level Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SB ► Level
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Level { get; set; }
Public Property Level As String
    Get
    Set
public:
property String^ Level {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SBR Class

SBR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR
RDPCrystal EDI Library
Subscriber Information
Declaration Syntax
C# Visual Basic Visual C++
public class SBR : DocumentSegment
Public Class SBR _
    Inherits DocumentSegment
public ref class SBR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SBR()()()() | Initializes a new instance of the SBR class
 | ClaimFilingIndicatorCode | Element 9
 | CoordinationOfBenefitsCode | Element 6
 | EmploymentStatusCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 2
 | InsuranceTypeCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode | Element 1
 | ReferenceIdentification | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SBR


SBR Constructor

SBR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► SBR()()()()
RDPCrystal EDI Library
Initializes a new instance of the SBR class
Declaration Syntax
C# Visual Basic Visual C++
public SBR()
Public Sub New
public:
SBR()


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}


CoordinationOfBenefitsCode Property

CoordinationOfBenefitsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► CoordinationOfBenefitsCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CoordinationOfBenefitsCode { get; set; }
Public Property CoordinationOfBenefitsCode As String
    Get
    Set
public:
property String^ CoordinationOfBenefitsCode {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► EmploymentStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► InsuranceTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► PayerResponsibilitySequenceNumberCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SBT Class

SBT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT
RDPCrystal EDI Library
Subtest
Declaration Syntax
C# Visual Basic Visual C++
public class SBT : DocumentSegment
Public Class SBT _
    Inherits DocumentSegment
public ref class SBT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SBT()()()() | Initializes a new instance of the SBT class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SubtestCode | Element 1
 | TestScoreInterpretationCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SBT


SBT Constructor

SBT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT ► SBT()()()()
RDPCrystal EDI Library
Initializes a new instance of the SBT class
Declaration Syntax
C# Visual Basic Visual C++
public SBT()
Public Sub New
public:
SBT()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


SubtestCode Property

SubtestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT ► SubtestCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SubtestCode { get; set; }
Public Property SubtestCode As String
    Get
    Set
public:
property String^ SubtestCode {
    String^ get ();
    void set (String^ value);
}


TestScoreInterpretationCode Property

TestScoreInterpretationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT ► TestScoreInterpretationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TestScoreInterpretationCode { get; set; }
Public Property TestScoreInterpretationCode As String
    Get
    Set
public:
property String^ TestScoreInterpretationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SBT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SC Class

SC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SC
RDPCrystal EDI Library
Docket Sub-level
Declaration Syntax
C# Visual Basic Visual C++
public class SC : DocumentSegment
Public Class SC _
    Inherits DocumentSegment
public ref class SC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SC()()()() | Initializes a new instance of the SC class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Level | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SubLevel | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SC


SC Constructor

SC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SC ► SC()()()()
RDPCrystal EDI Library
Initializes a new instance of the SC class
Declaration Syntax
C# Visual Basic Visual C++
public SC()
Public Sub New
public:
SC()


Level Property

Level Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SC ► Level
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Level { get; set; }
Public Property Level As String
    Get
    Set
public:
property String^ Level {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SubLevel Property

SubLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SC ► SubLevel
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SubLevel { get; set; }
Public Property SubLevel As String
    Get
    Set
public:
property String^ SubLevel {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCA Class

SCA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA
RDPCrystal EDI Library
Statistical Category Analysis
Declaration Syntax
C# Visual Basic Visual C++
public class SCA : DocumentSegment
Public Class SCA _
    Inherits DocumentSegment
public ref class SCA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCA()()()() | Initializes a new instance of the SCA class
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 5
 | RangeMaximum | Element 7
 | RangeMinimum | Element 6
 | StatisticCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCA


SCA Constructor

SCA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► SCA()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCA class
Declaration Syntax
C# Visual Basic Visual C++
public SCA()
Public Sub New
public:
SCA()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► RangeMaximum
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► RangeMinimum
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


StatisticCode Property

StatisticCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► StatisticCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatisticCode { get; set; }
Public Property StatisticCode As String
    Get
    Set
public:
property String^ StatisticCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCD Class

SCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD
RDPCrystal EDI Library
Sales Commission Employee Detail
Declaration Syntax
C# Visual Basic Visual C++
public class SCD : DocumentSegment
Public Class SCD _
    Inherits DocumentSegment
public ref class SCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCD()()()() | Initializes a new instance of the SCD class
 | AgencyQualifierCode | Element 5
 | Date | Element 2
 | Date1 | Element 4
 | EmploymentStatusCode | Element 1
 | EmploymentStatusCode1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 7
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCD


SCD Constructor

SCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► SCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCD class
Declaration Syntax
C# Visual Basic Visual C++
public SCD()
Public Sub New
public:
SCD()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► AgencyQualifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► EmploymentStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}


EmploymentStatusCode1 Property

EmploymentStatusCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► EmploymentStatusCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode1 { get; set; }
Public Property EmploymentStatusCode1 As String
    Get
    Set
public:
property String^ EmploymentStatusCode1 {
    String^ get ();
    void set (String^ value);
}


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► GenderCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► IndustryCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCH Class

SCH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH
RDPCrystal EDI Library
Line Item Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class SCH : DocumentSegment
Public Class SCH _
    Inherits DocumentSegment
public ref class SCH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCH()()()() | Initializes a new instance of the SCH class
 | AssignedIdentification | Element 12
 | Date | Element 6
 | Date1 | Element 9
 | DateTimeQualifier | Element 5
 | DateTimeQualifier1 | Element 8
 | EntityIdentifierCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | RequestReferenceNumber | Element 11
 | Time | Element 7
 | Time1 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCH


SCH Constructor

SCH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► SCH()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCH class
Declaration Syntax
C# Visual Basic Visual C++
public SCH()
Public Sub New
public:
SCH()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► AssignedIdentification
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Date1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► DateTimeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier1 Property

DateTimeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► DateTimeQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier1 { get; set; }
Public Property DateTimeQualifier1 As String
    Get
    Set
public:
property String^ DateTimeQualifier1 {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► EntityIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RequestReferenceNumber Property

RequestReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► RequestReferenceNumber
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string RequestReferenceNumber { get; set; }
Public Property RequestReferenceNumber As String
    Get
    Set
public:
property String^ RequestReferenceNumber {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Time
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Time1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCL Class

SCL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL
RDPCrystal EDI Library
Rate Basis/Scales
Declaration Syntax
C# Visual Basic Visual C++
public class SCL : DocumentSegment
Public Class SCL _
    Inherits DocumentSegment
public ref class SCL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCL()()()() | Initializes a new instance of the SCL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 5
 | LocationIdentifier1 | Element 6
 | LocationQualifier | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateBasisNumber | Element 2
 | RateBasisNumber1 | Element 3
 | RateBasisQualifier | Element 1
 | StateOrProvinceCode | Element 7
 | TariffAddOnFactor | Element 8
 | TariffClassAdjustmentReference | Element 9
 | TariffClassAdjustmentReference1 | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCL


SCL Constructor

SCL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► SCL()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCL class
Declaration Syntax
C# Visual Basic Visual C++
public SCL()
Public Sub New
public:
SCL()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► LocationIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► LocationIdentifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► LocationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


RateBasisNumber Property

RateBasisNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► RateBasisNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateBasisNumber { get; set; }
Public Property RateBasisNumber As String
    Get
    Set
public:
property String^ RateBasisNumber {
    String^ get ();
    void set (String^ value);
}


RateBasisNumber1 Property

RateBasisNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► RateBasisNumber1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateBasisNumber1 { get; set; }
Public Property RateBasisNumber1 As String
    Get
    Set
public:
property String^ RateBasisNumber1 {
    String^ get ();
    void set (String^ value);
}


RateBasisQualifier Property

RateBasisQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► RateBasisQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateBasisQualifier { get; set; }
Public Property RateBasisQualifier As String
    Get
    Set
public:
property String^ RateBasisQualifier {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TariffAddOnFactor Property

TariffAddOnFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► TariffAddOnFactor
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAddOnFactor { get; set; }
Public Property TariffAddOnFactor As String
    Get
    Set
public:
property String^ TariffAddOnFactor {
    String^ get ();
    void set (String^ value);
}


TariffClassAdjustmentReference Property

TariffClassAdjustmentReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► TariffClassAdjustmentReference
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TariffClassAdjustmentReference { get; set; }
Public Property TariffClassAdjustmentReference As String
    Get
    Set
public:
property String^ TariffClassAdjustmentReference {
    String^ get ();
    void set (String^ value);
}


TariffClassAdjustmentReference1 Property

TariffClassAdjustmentReference1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► TariffClassAdjustmentReference1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TariffClassAdjustmentReference1 { get; set; }
Public Property TariffClassAdjustmentReference1 As String
    Get
    Set
public:
property String^ TariffClassAdjustmentReference1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCM Class

SCM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM
RDPCrystal EDI Library
Credit Score Model
Declaration Syntax
C# Visual Basic Visual C++
public class SCM : DocumentSegment
Public Class SCM _
    Inherits DocumentSegment
public ref class SCM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCM()()()() | Initializes a new instance of the SCM class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EvaluationRatingCode | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCM


SCM Constructor

SCM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► SCM()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCM class
Declaration Syntax
C# Visual Basic Visual C++
public SCM()
Public Sub New
public:
SCM()


EvaluationRatingCode Property

EvaluationRatingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► EvaluationRatingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EvaluationRatingCode { get; set; }
Public Property EvaluationRatingCode As String
    Get
    Set
public:
property String^ EvaluationRatingCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► FreeFormMessage
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► Number
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► ProductServiceID
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCN Class

SCN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN
RDPCrystal EDI Library
Beginning Segment for Cartage Work Assignment
Declaration Syntax
C# Visual Basic Visual C++
public class SCN : DocumentSegment
Public Class SCN _
    Inherits DocumentSegment
public ref class SCN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCN()()()() | Initializes a new instance of the SCN class
 | Amount | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ShipmentMethodOfPayment | Element 4
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCN


SCN Constructor

SCN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► SCN()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCN class
Declaration Syntax
C# Visual Basic Visual C++
public SCN()
Public Sub New
public:
SCN()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► Amount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCO Class

SCO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO
RDPCrystal EDI Library
Shipper’s Car Ordered
Declaration Syntax
C# Visual Basic Visual C++
public class SCO : DocumentSegment
Public Class SCO _
    Inherits DocumentSegment
public ref class SCO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCO()()()() | Initializes a new instance of the SCO class
 | CarTypeCode | Element 4
 | CarTypeCode1 | Element 18
 | CommodityCode | Element 3
 | CommodityCodeQualifier | Element 2
 | CubicCapacity | Element 11
 | DoorTypeCode | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 5
 | EquipmentLength | Element 7
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FloorTypeCode | Element 14
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 8
 | Height1 | Element 15
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProtectiveServiceCode | Element 12
 | Quantity | Element 1
 | Temperature | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | WeightCapacity | Element 10
 | Width | Element 9
 | Width1 | Element 16
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCO


SCO Constructor

SCO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► SCO()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCO class
Declaration Syntax
C# Visual Basic Visual C++
public SCO()
Public Sub New
public:
SCO()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► CarTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


CarTypeCode1 Property

CarTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► CarTypeCode1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode1 { get; set; }
Public Property CarTypeCode1 As String
    Get
    Set
public:
property String^ CarTypeCode1 {
    String^ get ();
    void set (String^ value);
}


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


CubicCapacity Property

CubicCapacity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► CubicCapacity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CubicCapacity { get; set; }
Public Property CubicCapacity As String
    Get
    Set
public:
property String^ CubicCapacity {
    String^ get ();
    void set (String^ value);
}


DoorTypeCode Property

DoorTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► DoorTypeCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string DoorTypeCode { get; set; }
Public Property DoorTypeCode As String
    Get
    Set
public:
property String^ DoorTypeCode {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► EquipmentLength
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


FloorTypeCode Property

FloorTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► FloorTypeCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string FloorTypeCode { get; set; }
Public Property FloorTypeCode As String
    Get
    Set
public:
property String^ FloorTypeCode {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Height
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Height1 Property

Height1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Height1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Height1 { get; set; }
Public Property Height1 As String
    Get
    Set
public:
property String^ Height1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProtectiveServiceCode Property

ProtectiveServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► ProtectiveServiceCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProtectiveServiceCode { get; set; }
Public Property ProtectiveServiceCode As String
    Get
    Set
public:
property String^ ProtectiveServiceCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Temperature
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


WeightCapacity Property

WeightCapacity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► WeightCapacity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string WeightCapacity { get; set; }
Public Property WeightCapacity As String
    Get
    Set
public:
property String^ WeightCapacity {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Width
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Width1 Property

Width1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Width1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Width1 { get; set; }
Public Property Width1 As String
    Get
    Set
public:
property String^ Width1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCP Class

SCP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP
RDPCrystal EDI Library
Beginning Segment for a Cartage Work Assignment Response
Declaration Syntax
C# Visual Basic Visual C++
public class SCP : DocumentSegment
Public Class SCP _
    Inherits DocumentSegment
public ref class SCP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCP()()()() | Initializes a new instance of the SCP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReservationActionCode | Element 3
 | ShipmentOrWorkAssignmentDeclineReasonCode | Element 4
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCP


SCP Constructor

SCP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► SCP()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCP class
Declaration Syntax
C# Visual Basic Visual C++
public SCP()
Public Sub New
public:
SCP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReservationActionCode Property

ReservationActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► ReservationActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReservationActionCode { get; set; }
Public Property ReservationActionCode As String
    Get
    Set
public:
property String^ ReservationActionCode {
    String^ get ();
    void set (String^ value);
}


ShipmentOrWorkAssignmentDeclineReasonCode Property

ShipmentOrWorkAssignmentDeclineReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► ShipmentOrWorkAssignmentDeclineReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrWorkAssignmentDeclineReasonCode { get; set; }
Public Property ShipmentOrWorkAssignmentDeclineReasonCode As String
    Get
    Set
public:
property String^ ShipmentOrWorkAssignmentDeclineReasonCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCS Class

SCS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCS
RDPCrystal EDI Library
Credit Score
Declaration Syntax
C# Visual Basic Visual C++
public class SCS : DocumentSegment
Public Class SCS _
    Inherits DocumentSegment
public ref class SCS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCS()()()() | Initializes a new instance of the SCS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCS


SCS Constructor

SCS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCS ► SCS()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCS class
Declaration Syntax
C# Visual Basic Visual C++
public SCS()
Public Sub New
public:
SCS()


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCS ► FreeFormMessageText
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCS ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SCT Class

SCT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT
RDPCrystal EDI Library
School Type
Declaration Syntax
C# Visual Basic Visual C++
public class SCT : DocumentSegment
Public Class SCT _
    Inherits DocumentSegment
public ref class SCT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SCT()()()() | Initializes a new instance of the SCT class
 | AcademicCreditTypeCode | Element 1
 | DateTimePeriod | Element 5
 | DateTimePeriodFormatQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | SessionCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SCT


SCT Constructor

SCT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► SCT()()()()
RDPCrystal EDI Library
Initializes a new instance of the SCT class
Declaration Syntax
C# Visual Basic Visual C++
public SCT()
Public Sub New
public:
SCT()


AcademicCreditTypeCode Property

AcademicCreditTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► AcademicCreditTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicCreditTypeCode { get; set; }
Public Property AcademicCreditTypeCode As String
    Get
    Set
public:
property String^ AcademicCreditTypeCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► DateTimePeriod
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


SessionCode Property

SessionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► SessionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SessionCode { get; set; }
Public Property SessionCode As String
    Get
    Set
public:
property String^ SessionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SCT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SD1 Class

SD1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1
RDPCrystal EDI Library
Safety Data
Declaration Syntax
C# Visual Basic Visual C++
public class SD1 : DocumentSegment
Public Class SD1 _
    Inherits DocumentSegment
public ref class SD1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SD1()()()() | Initializes a new instance of the SD1 class
 | AgencyQualifierCode | Element 3
 | CountryCode | Element 8
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemDescriptionType | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 5
 | SafetyCharacteristicHazardCode | Element 2
 | SourceSubqualifier | Element 4
 | StateOrProvinceCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SD1


SD1 Constructor

SD1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► SD1()()()()
RDPCrystal EDI Library
Initializes a new instance of the SD1 class
Declaration Syntax
C# Visual Basic Visual C++
public SD1()
Public Sub New
public:
SD1()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► CountryCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ItemDescriptionType Property

ItemDescriptionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► ItemDescriptionType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDescriptionType { get; set; }
Public Property ItemDescriptionType As String
    Get
    Set
public:
property String^ ItemDescriptionType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► ProductDescriptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


SafetyCharacteristicHazardCode Property

SafetyCharacteristicHazardCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► SafetyCharacteristicHazardCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SafetyCharacteristicHazardCode { get; set; }
Public Property SafetyCharacteristicHazardCode As String
    Get
    Set
public:
property String^ SafetyCharacteristicHazardCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► SourceSubqualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SD1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SDP Class

SDP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP
RDPCrystal EDI Library
Ship/Delivery Pattern
Declaration Syntax
C# Visual Basic Visual C++
public class SDP : DocumentSegment
Public Class SDP _
    Inherits DocumentSegment
public ref class SDP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SDP()()()() | Initializes a new instance of the SDP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipDeliveryOrCalendarPatternCode | Element 1
 | ShipDeliveryOrCalendarPatternCode1 | Element 3
 | ShipDeliveryOrCalendarPatternCode2 | Element 5
 | ShipDeliveryOrCalendarPatternCode3 | Element 7
 | ShipDeliveryPatternTimeCode | Element 2
 | ShipDeliveryPatternTimeCode1 | Element 4
 | ShipDeliveryPatternTimeCode2 | Element 6
 | ShipDeliveryPatternTimeCode3 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SDP


SDP Constructor

SDP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► SDP()()()()
RDPCrystal EDI Library
Initializes a new instance of the SDP class
Declaration Syntax
C# Visual Basic Visual C++
public SDP()
Public Sub New
public:
SDP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode1 Property

ShipDeliveryOrCalendarPatternCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryOrCalendarPatternCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode1 { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode1 As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode1 {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode2 Property

ShipDeliveryOrCalendarPatternCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryOrCalendarPatternCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode2 { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode2 As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode2 {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryOrCalendarPatternCode3 Property

ShipDeliveryOrCalendarPatternCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryOrCalendarPatternCode3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode3 { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode3 As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode3 {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryPatternTimeCode Property

ShipDeliveryPatternTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryPatternTimeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode { get; set; }
Public Property ShipDeliveryPatternTimeCode As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryPatternTimeCode1 Property

ShipDeliveryPatternTimeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryPatternTimeCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode1 { get; set; }
Public Property ShipDeliveryPatternTimeCode1 As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode1 {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryPatternTimeCode2 Property

ShipDeliveryPatternTimeCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryPatternTimeCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode2 { get; set; }
Public Property ShipDeliveryPatternTimeCode2 As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode2 {
    String^ get ();
    void set (String^ value);
}


ShipDeliveryPatternTimeCode3 Property

ShipDeliveryPatternTimeCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► ShipDeliveryPatternTimeCode3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode3 { get; set; }
Public Property ShipDeliveryPatternTimeCode3 As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode3 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SDQ Class

SDQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ
RDPCrystal EDI Library
Destination Quantity
Declaration Syntax
C# Visual Basic Visual C++
public class SDQ : DocumentSegment
Public Class SDQ _
    Inherits DocumentSegment
public ref class SDQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SDQ()()()() | Initializes a new instance of the SDQ class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCode1 | Element 5
 | IdentificationCode2 | Element 7
 | IdentificationCode3 | Element 9
 | IdentificationCode4 | Element 11
 | IdentificationCode5 | Element 13
 | IdentificationCode6 | Element 15
 | IdentificationCode7 | Element 17
 | IdentificationCode8 | Element 19
 | IdentificationCode9 | Element 21
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 23
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 6
 | Quantity2 | Element 8
 | Quantity3 | Element 10
 | Quantity4 | Element 12
 | Quantity5 | Element 14
 | Quantity6 | Element 16
 | Quantity7 | Element 18
 | Quantity8 | Element 20
 | Quantity9 | Element 22
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SDQ


SDQ Constructor

SDQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► SDQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the SDQ class
Declaration Syntax
C# Visual Basic Visual C++
public SDQ()
Public Sub New
public:
SDQ()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode1 Property

IdentificationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode1 { get; set; }
Public Property IdentificationCode1 As String
    Get
    Set
public:
property String^ IdentificationCode1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode2 Property

IdentificationCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode2 { get; set; }
Public Property IdentificationCode2 As String
    Get
    Set
public:
property String^ IdentificationCode2 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode3 Property

IdentificationCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode3 { get; set; }
Public Property IdentificationCode3 As String
    Get
    Set
public:
property String^ IdentificationCode3 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode4 Property

IdentificationCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode4 { get; set; }
Public Property IdentificationCode4 As String
    Get
    Set
public:
property String^ IdentificationCode4 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode5 Property

IdentificationCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode5 { get; set; }
Public Property IdentificationCode5 As String
    Get
    Set
public:
property String^ IdentificationCode5 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode6 Property

IdentificationCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode6
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode6 { get; set; }
Public Property IdentificationCode6 As String
    Get
    Set
public:
property String^ IdentificationCode6 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode7 Property

IdentificationCode7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode7
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode7 { get; set; }
Public Property IdentificationCode7 As String
    Get
    Set
public:
property String^ IdentificationCode7 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode8 Property

IdentificationCode8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode8
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode8 { get; set; }
Public Property IdentificationCode8 As String
    Get
    Set
public:
property String^ IdentificationCode8 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode9 Property

IdentificationCode9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCode9
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode9 { get; set; }
Public Property IdentificationCode9 As String
    Get
    Set
public:
property String^ IdentificationCode9 {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► LocationIdentifier
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity6
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}


Quantity7 Property

Quantity7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity7
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity7 { get; set; }
Public Property Quantity7 As String
    Get
    Set
public:
property String^ Quantity7 {
    String^ get ();
    void set (String^ value);
}


Quantity8 Property

Quantity8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity8
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity8 { get; set; }
Public Property Quantity8 As String
    Get
    Set
public:
property String^ Quantity8 {
    String^ get ();
    void set (String^ value);
}


Quantity9 Property

Quantity9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Quantity9
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity9 { get; set; }
Public Property Quantity9 As String
    Get
    Set
public:
property String^ Quantity9 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SDQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SE Class

SE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SE
RDPCrystal EDI Library
Transaction Set Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class SE : DocumentSegment
Public Class SE _
    Inherits DocumentSegment
public ref class SE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SE()()()() | Initializes a new instance of the SE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfIncludedSegments | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SE


SE Constructor

SE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SE ► SE()()()()
RDPCrystal EDI Library
Initializes a new instance of the SE class
Declaration Syntax
C# Visual Basic Visual C++
public SE()
Public Sub New
public:
SE()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfIncludedSegments Property

NumberOfIncludedSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SE ► NumberOfIncludedSegments
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfIncludedSegments { get; set; }
Public Property NumberOfIncludedSegments As String
    Get
    Set
public:
property String^ NumberOfIncludedSegments {
    String^ get ();
    void set (String^ value);
}


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SE ► TransactionSetControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SecurityValue Class

SecurityValue Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SecurityValue
RDPCrystal EDI Library
C033
Declaration Syntax
C# Visual Basic Visual C++
public class SecurityValue : DocumentCompositeElement
Public Class SecurityValue _
    Inherits DocumentCompositeElement
public ref class SecurityValue : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecurityValue()()()() | Initializes a new instance of the SecurityValue class
 | EncodedSecurityValue | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SecurityValueQualifier | Element 1
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | SecurityValue


SecurityValue Constructor

SecurityValue Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SecurityValue ► SecurityValue()()()()
RDPCrystal EDI Library
Initializes a new instance of the SecurityValue class
Declaration Syntax
C# Visual Basic Visual C++
public SecurityValue()
Public Sub New
public:
SecurityValue()


EncodedSecurityValue Property

EncodedSecurityValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SecurityValue ► EncodedSecurityValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EncodedSecurityValue { get; set; }
Public Property EncodedSecurityValue As String
    Get
    Set
public:
property String^ EncodedSecurityValue {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SecurityValue ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SecurityValue ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


SecurityValueQualifier Property

SecurityValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SecurityValue ► SecurityValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityValueQualifier { get; set; }
Public Property SecurityValueQualifier As String
    Get
    Set
public:
property String^ SecurityValueQualifier {
    String^ get ();
    void set (String^ value);
}


SER Class

SER Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER
RDPCrystal EDI Library
Service Charges
Declaration Syntax
C# Visual Basic Visual C++
public class SER : DocumentSegment
Public Class SER _
    Inherits DocumentSegment
public ref class SER : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SER()()()() | Initializes a new instance of the SER class
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 9
 | PriceIdentifierCode | Element 8
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | Quantity | Element 6
 | ReferenceIdentification | Element 11
 | ReferenceIdentificationQualifier | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SER


SER Constructor

SER Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► SER()()()()
RDPCrystal EDI Library
Initializes a new instance of the SER class
Declaration Syntax
C# Visual Basic Visual C++
public SER()
Public Sub New
public:
SER()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► PaymentMethodCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► PriceIdentifierCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► ReferenceIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► UnitPrice
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SER ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SES Class

SES Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES
RDPCrystal EDI Library
Academic Session Header
Declaration Syntax
C# Visual Basic Visual C++
public class SES : DocumentSegment
Public Class SES _
    Inherits DocumentSegment
public ref class SES : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SES()()()() | Initializes a new instance of the SES class
 | Count | Element 2
 | DateTimePeriod | Element 1
 | DateTimePeriod1 | Element 3
 | DateTimePeriod2 | Element 7
 | DateTimePeriod3 | Element 9
 | DateTimePeriodFormatQualifier | Element 6
 | DateTimePeriodFormatQualifier1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 12
 | IdentificationCodeQualifier | Element 11
 | LevelOfIndividualTestOrCourseCode | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 5
 | Name2 | Element 13
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SessionCode | Element 4
 | StatusReasonCode | Element 14
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SES


SES Constructor

SES Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► SES()()()()
RDPCrystal EDI Library
Initializes a new instance of the SES class
Declaration Syntax
C# Visual Basic Visual C++
public SES()
Public Sub New
public:
SES()


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► Count
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► DateTimePeriod
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► DateTimePeriod1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► DateTimePeriod2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod3 Property

DateTimePeriod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► DateTimePeriod3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod3 { get; set; }
Public Property DateTimePeriod3 As String
    Get
    Set
public:
property String^ DateTimePeriod3 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► IdentificationCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► Name1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Name2 Property

Name2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► Name2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Name2 { get; set; }
Public Property Name2 As String
    Get
    Set
public:
property String^ Name2 {
    String^ get ();
    void set (String^ value);
}


SessionCode Property

SessionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► SessionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SessionCode { get; set; }
Public Property SessionCode As String
    Get
    Set
public:
property String^ SessionCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► StatusReasonCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SES ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SFC Class

SFC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SFC
RDPCrystal EDI Library
Storage Facility Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public class SFC : DocumentSegment
Public Class SFC _
    Inherits DocumentSegment
public ref class SFC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SFC()()()() | Initializes a new instance of the SFC class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCharacteristicCode | Element 2
 | FacilityCharacteristicCodeQualifier | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SFC


SFC Constructor

SFC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SFC ► SFC()()()()
RDPCrystal EDI Library
Initializes a new instance of the SFC class
Declaration Syntax
C# Visual Basic Visual C++
public SFC()
Public Sub New
public:
SFC()


FacilityCharacteristicCode Property

FacilityCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SFC ► FacilityCharacteristicCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCharacteristicCode { get; set; }
Public Property FacilityCharacteristicCode As String
    Get
    Set
public:
property String^ FacilityCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


FacilityCharacteristicCodeQualifier Property

FacilityCharacteristicCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SFC ► FacilityCharacteristicCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCharacteristicCodeQualifier { get; set; }
Public Property FacilityCharacteristicCodeQualifier As String
    Get
    Set
public:
property String^ FacilityCharacteristicCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SFC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SFC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SG Class

SG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG
RDPCrystal EDI Library
Shipment Status
Declaration Syntax
C# Visual Basic Visual C++
public class SG : DocumentSegment
Public Class SG _
    Inherits DocumentSegment
public ref class SG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SG()()()() | Initializes a new instance of the SG class
 | Date | Element 4
 | DispositionCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentStatusCode | Element 1
 | StatusReasonCode | Element 2
 | Time | Element 5
 | TimeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SG


SG Constructor

SG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► SG()()()()
RDPCrystal EDI Library
Initializes a new instance of the SG class
Declaration Syntax
C# Visual Basic Visual C++
public SG()
Public Sub New
public:
SG()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► DispositionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentStatusCode Property

ShipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► ShipmentStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentStatusCode { get; set; }
Public Property ShipmentStatusCode As String
    Get
    Set
public:
property String^ ShipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► StatusReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► TimeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SHD Class

SHD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD
RDPCrystal EDI Library
Shipment Detail
Declaration Syntax
C# Visual Basic Visual C++
public class SHD : DocumentSegment
Public Class SHD _
    Inherits DocumentSegment
public ref class SHD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SHD()()()() | Initializes a new instance of the SHD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | OrderSizingFactor | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceBracketIdentifier | Element 9
 | QuantityReceived | Element 2
 | ReferenceIdentification | Element 14
 | ReferenceIdentificationQualifier | Element 13
 | ShipmentOrderStatusCode | Element 12
 | StandardCarrierAlphaCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 10
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 5
 | UnitOrBasisForMeasurementCode2 | Element 7
 | Volume | Element 6
 | Weight | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SHD


SHD Constructor

SHD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► SHD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SHD class
Declaration Syntax
C# Visual Basic Visual C++
public SHD()
Public Sub New
public:
SHD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


OrderSizingFactor Property

OrderSizingFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► OrderSizingFactor
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string OrderSizingFactor { get; set; }
Public Property OrderSizingFactor As String
    Get
    Set
public:
property String^ OrderSizingFactor {
    String^ get ();
    void set (String^ value);
}


PriceBracketIdentifier Property

PriceBracketIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► PriceBracketIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string PriceBracketIdentifier { get; set; }
Public Property PriceBracketIdentifier As String
    Get
    Set
public:
property String^ PriceBracketIdentifier {
    String^ get ();
    void set (String^ value);
}


QuantityReceived Property

QuantityReceived Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► QuantityReceived
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityReceived { get; set; }
Public Property QuantityReceived As String
    Get
    Set
public:
property String^ QuantityReceived {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► ReferenceIdentification
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► Volume
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SHP Class

SHP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP
RDPCrystal EDI Library
Shipped/Received Information
Declaration Syntax
C# Visual Basic Visual C++
public class SHP : DocumentSegment
Public Class SHP _
    Inherits DocumentSegment
public ref class SHP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SHP()()()() | Initializes a new instance of the SHP class
 | Date | Element 4
 | Date1 | Element 6
 | DateTimeQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | QuantityQualifier | Element 1
 | Time | Element 5
 | Time1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SHP


SHP Constructor

SHP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► SHP()()()()
RDPCrystal EDI Library
Initializes a new instance of the SHP class
Declaration Syntax
C# Visual Basic Visual C++
public SHP()
Public Sub New
public:
SHP()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► DateTimeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Time1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SHR Class

SHR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHR
RDPCrystal EDI Library
Railroad Interline Service Special Handling Restrictions
Declaration Syntax
C# Visual Basic Visual C++
public class SHR : DocumentSegment
Public Class SHR _
    Inherits DocumentSegment
public ref class SHR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SHR()()()() | Initializes a new instance of the SHR class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SHR


SHR Constructor

SHR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHR ► SHR()()()()
RDPCrystal EDI Library
Initializes a new instance of the SHR class
Declaration Syntax
C# Visual Basic Visual C++
public SHR()
Public Sub New
public:
SHR()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHR ► SpecialHandlingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SHR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SI Class

SI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI
RDPCrystal EDI Library
Service Characteristic Identification
Declaration Syntax
C# Visual Basic Visual C++
public class SI : DocumentSegment
Public Class SI _
    Inherits DocumentSegment
public ref class SI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SI()()()() | Initializes a new instance of the SI class
 | AgencyQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 3
 | ProductServiceID1 | Element 5
 | ProductServiceID2 | Element 7
 | ProductServiceID3 | Element 9
 | ProductServiceID4 | Element 11
 | ProductServiceID5 | Element 13
 | ProductServiceID6 | Element 15
 | ProductServiceID7 | Element 17
 | ProductServiceID8 | Element 19
 | ProductServiceID9 | Element 21
 | ServiceCharacteristicsQualifier | Element 2
 | ServiceCharacteristicsQualifier1 | Element 4
 | ServiceCharacteristicsQualifier2 | Element 6
 | ServiceCharacteristicsQualifier3 | Element 8
 | ServiceCharacteristicsQualifier4 | Element 10
 | ServiceCharacteristicsQualifier5 | Element 12
 | ServiceCharacteristicsQualifier6 | Element 14
 | ServiceCharacteristicsQualifier7 | Element 16
 | ServiceCharacteristicsQualifier8 | Element 18
 | ServiceCharacteristicsQualifier9 | Element 20
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SI


SI Constructor

SI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► SI()()()()
RDPCrystal EDI Library
Initializes a new instance of the SI class
Declaration Syntax
C# Visual Basic Visual C++
public SI()
Public Sub New
public:
SI()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► AgencyQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID6
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID7
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID8
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ProductServiceID9
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier Property

ServiceCharacteristicsQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier { get; set; }
Public Property ServiceCharacteristicsQualifier As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier1 Property

ServiceCharacteristicsQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier1 { get; set; }
Public Property ServiceCharacteristicsQualifier1 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier1 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier2 Property

ServiceCharacteristicsQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier2 { get; set; }
Public Property ServiceCharacteristicsQualifier2 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier2 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier3 Property

ServiceCharacteristicsQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier3 { get; set; }
Public Property ServiceCharacteristicsQualifier3 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier3 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier4 Property

ServiceCharacteristicsQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier4 { get; set; }
Public Property ServiceCharacteristicsQualifier4 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier4 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier5 Property

ServiceCharacteristicsQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier5
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier5 { get; set; }
Public Property ServiceCharacteristicsQualifier5 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier5 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier6 Property

ServiceCharacteristicsQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier6 { get; set; }
Public Property ServiceCharacteristicsQualifier6 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier6 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier7 Property

ServiceCharacteristicsQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier7
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier7 { get; set; }
Public Property ServiceCharacteristicsQualifier7 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier7 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier8 Property

ServiceCharacteristicsQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier8
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier8 { get; set; }
Public Property ServiceCharacteristicsQualifier8 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier8 {
    String^ get ();
    void set (String^ value);
}


ServiceCharacteristicsQualifier9 Property

ServiceCharacteristicsQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► ServiceCharacteristicsQualifier9
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCharacteristicsQualifier9 { get; set; }
Public Property ServiceCharacteristicsQualifier9 As String
    Get
    Set
public:
property String^ ServiceCharacteristicsQualifier9 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SID Class

SID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID
RDPCrystal EDI Library
Standard Transportation Commodity Code Identification
Declaration Syntax
C# Visual Basic Visual C++
public class SID : DocumentSegment
Public Class SID _
    Inherits DocumentSegment
public ref class SID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SID()()()() | Initializes a new instance of the SID class
 | CommodityCode | Element 2
 | CommodityCodeQualifier | Element 1
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RatingSummaryValueCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
 | YesNoConditionOrResponseCode1 | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SID


SID Constructor

SID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► SID()()()()
RDPCrystal EDI Library
Initializes a new instance of the SID class
Declaration Syntax
C# Visual Basic Visual C++
public SID()
Public Sub New
public:
SID()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► CommodityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RatingSummaryValueCode Property

RatingSummaryValueCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► RatingSummaryValueCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RatingSummaryValueCode { get; set; }
Public Property RatingSummaryValueCode As String
    Get
    Set
public:
property String^ RatingSummaryValueCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SID ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


SII Class

SII Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII
RDPCrystal EDI Library
Sales Item Information
Declaration Syntax
C# Visual Basic Visual C++
public class SII : DocumentSegment
Public Class SII _
    Inherits DocumentSegment
public ref class SII : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SII()()()() | Initializes a new instance of the SII class
 | CompositeUnitOfMeasure | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 2
 | ProductServiceIDQualifier | Element 1
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 5
 | UnitPrice1 | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SII


SII Constructor

SII Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► SII()()()()
RDPCrystal EDI Library
Initializes a new instance of the SII class
Declaration Syntax
C# Visual Basic Visual C++
public SII()
Public Sub New
public:
SII()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► ProductServiceID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► UnitPrice
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


UnitPrice1 Property

UnitPrice1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► UnitPrice1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice1 { get; set; }
Public Property UnitPrice1 As String
    Get
    Set
public:
property String^ UnitPrice1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SII ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SIN Class

SIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN
RDPCrystal EDI Library
Substance Use
Declaration Syntax
C# Visual Basic Visual C++
public class SIN : DocumentSegment
Public Class SIN _
    Inherits DocumentSegment
public ref class SIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SIN()()()() | Initializes a new instance of the SIN class
 | CompositeUnitOfMeasure | Element 6
 | ControlledSubstanceTypeCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 3
 | FrequencyCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SIN


SIN Constructor

SIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► SIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the SIN class
Declaration Syntax
C# Visual Basic Visual C++
public SIN()
Public Sub New
public:
SIN()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ControlledSubstanceTypeCode Property

ControlledSubstanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► ControlledSubstanceTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ControlledSubstanceTypeCode { get; set; }
Public Property ControlledSubstanceTypeCode As String
    Get
    Set
public:
property String^ ControlledSubstanceTypeCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► FreeFormMessageText
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► FrequencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► InformationStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SL1 Class

SL1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1
RDPCrystal EDI Library
Tariff Reference
Declaration Syntax
C# Visual Basic Visual C++
public class SL1 : DocumentSegment
Public Class SL1 _
    Inherits DocumentSegment
public ref class SL1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SL1()()()() | Initializes a new instance of the SL1 class
 | CommodityCode | Element 3
 | DataSourceCode | Element 8
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InternationalDomesticCode | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Scale | Element 4
 | ServiceLevelCode | Element 1
 | ServiceLevelCode1 | Element 6
 | ShipmentMethodOfPayment | Element 7
 | TariffNumber | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SL1


SL1 Constructor

SL1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► SL1()()()()
RDPCrystal EDI Library
Initializes a new instance of the SL1 class
Declaration Syntax
C# Visual Basic Visual C++
public SL1()
Public Sub New
public:
SL1()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


DataSourceCode Property

DataSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► DataSourceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DataSourceCode { get; set; }
Public Property DataSourceCode As String
    Get
    Set
public:
property String^ DataSourceCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


InternationalDomesticCode Property

InternationalDomesticCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► InternationalDomesticCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalDomesticCode { get; set; }
Public Property InternationalDomesticCode As String
    Get
    Set
public:
property String^ InternationalDomesticCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Scale Property

Scale Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► Scale
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Scale { get; set; }
Public Property Scale As String
    Get
    Set
public:
property String^ Scale {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► ServiceLevelCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode1 Property

ServiceLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► ServiceLevelCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode1 { get; set; }
Public Property ServiceLevelCode1 As String
    Get
    Set
public:
property String^ ServiceLevelCode1 {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


TariffNumber Property

TariffNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► TariffNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumber { get; set; }
Public Property TariffNumber As String
    Get
    Set
public:
property String^ TariffNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SL1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SLI Class

SLI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI
RDPCrystal EDI Library
Specific Loan Information
Declaration Syntax
C# Visual Basic Visual C++
public class SLI : DocumentSegment
Public Class SLI _
    Inherits DocumentSegment
public ref class SLI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SLI()()()() | Initializes a new instance of the SLI class
 | DateTimePeriod | Element 7
 | DateTimePeriod1 | Element 11
 | DateTimePeriod2 | Element 13
 | DateTimePeriod3 | Element 21
 | DateTimePeriodFormatQualifier | Element 6
 | DateTimePeriodFormatQualifier1 | Element 10
 | DateTimePeriodFormatQualifier2 | Element 12
 | DateTimePeriodFormatQualifier3 | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterestRate | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanRateTypeCode | Element 5
 | LoanTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 14
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 22
 | Quantity | Element 15
 | Quantity1 | Element 16
 | Quantity2 | Element 17
 | ReferenceIdentification | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCode1 | Element 18
 | YesNoConditionOrResponseCode2 | Element 19
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SLI


SLI Constructor

SLI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► SLI()()()()
RDPCrystal EDI Library
Initializes a new instance of the SLI class
Declaration Syntax
C# Visual Basic Visual C++
public SLI()
Public Sub New
public:
SLI()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriod1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriod2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod3 Property

DateTimePeriod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriod3
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod3 { get; set; }
Public Property DateTimePeriod3 As String
    Get
    Set
public:
property String^ DateTimePeriod3 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier2 Property

DateTimePeriodFormatQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriodFormatQualifier2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier2 { get; set; }
Public Property DateTimePeriodFormatQualifier2 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier3 Property

DateTimePeriodFormatQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► DateTimePeriodFormatQualifier3
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier3 { get; set; }
Public Property DateTimePeriodFormatQualifier3 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier3 {
    String^ get ();
    void set (String^ value);
}


InterestRate Property

InterestRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► InterestRate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InterestRate { get; set; }
Public Property InterestRate As String
    Get
    Set
public:
property String^ InterestRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanRateTypeCode Property

LoanRateTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► LoanRateTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LoanRateTypeCode { get; set; }
Public Property LoanRateTypeCode As String
    Get
    Set
public:
property String^ LoanRateTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► LoanTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► MonetaryAmount2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► PaymentMethodCode
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► Quantity
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► Quantity1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► Quantity2
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLI ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


SLN Class

SLN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN
RDPCrystal EDI Library
Subline Item Detail
Declaration Syntax
C# Visual Basic Visual C++
public class SLN : DocumentSegment
Public Class SLN _
    Inherits DocumentSegment
public ref class SLN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SLN()()()() | Initializes a new instance of the SLN class
 | AssignedIdentification | Element 1
 | AssignedIdentification1 | Element 2
 | BasisOfUnitPriceCode | Element 7
 | CompositeUnitOfMeasure | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 10
 | ProductServiceID1 | Element 12
 | ProductServiceID2 | Element 14
 | ProductServiceID3 | Element 16
 | ProductServiceID4 | Element 18
 | ProductServiceID5 | Element 20
 | ProductServiceID6 | Element 22
 | ProductServiceID7 | Element 24
 | ProductServiceID8 | Element 26
 | ProductServiceID9 | Element 28
 | ProductServiceIDQualifier | Element 9
 | ProductServiceIDQualifier1 | Element 11
 | ProductServiceIDQualifier2 | Element 13
 | ProductServiceIDQualifier3 | Element 15
 | ProductServiceIDQualifier4 | Element 17
 | ProductServiceIDQualifier5 | Element 19
 | ProductServiceIDQualifier6 | Element 21
 | ProductServiceIDQualifier7 | Element 23
 | ProductServiceIDQualifier8 | Element 25
 | ProductServiceIDQualifier9 | Element 27
 | Quantity | Element 4
 | RelationshipCode | Element 3
 | RelationshipCode1 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SLN


SLN Constructor

SLN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► SLN()()()()
RDPCrystal EDI Library
Initializes a new instance of the SLN class
Declaration Syntax
C# Visual Basic Visual C++
public SLN()
Public Sub New
public:
SLN()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification1 Property

AssignedIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► AssignedIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification1 { get; set; }
Public Property AssignedIdentification1 As String
    Get
    Set
public:
property String^ AssignedIdentification1 {
    String^ get ();
    void set (String^ value);
}


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID3
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID4
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID5
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID6
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID7
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID8
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceID9
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RelationshipCode Property

RelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► RelationshipCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipCode { get; set; }
Public Property RelationshipCode As String
    Get
    Set
public:
property String^ RelationshipCode {
    String^ get ();
    void set (String^ value);
}


RelationshipCode1 Property

RelationshipCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► RelationshipCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipCode1 { get; set; }
Public Property RelationshipCode1 As String
    Get
    Set
public:
property String^ RelationshipCode1 {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► UnitPrice
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SLN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SMA Class

SMA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA
RDPCrystal EDI Library
Station Address
Declaration Syntax
C# Visual Basic Visual C++
public class SMA : DocumentSegment
Public Class SMA _
    Inherits DocumentSegment
public ref class SMA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMA()()()() | Initializes a new instance of the SMA class
 | AddressInformation | Element 2
 | AddressTypeCode | Element 1
 | CityName | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 5
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SMA


SMA Constructor

SMA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► SMA()()()()
RDPCrystal EDI Library
Initializes a new instance of the SMA class
Declaration Syntax
C# Visual Basic Visual C++
public SMA()
Public Sub New
public:
SMA()


AddressInformation Property

AddressInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► AddressInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation { get; set; }
Public Property AddressInformation As String
    Get
    Set
public:
property String^ AddressInformation {
    String^ get ();
    void set (String^ value);
}


AddressTypeCode Property

AddressTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► AddressTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AddressTypeCode { get; set; }
Public Property AddressTypeCode As String
    Get
    Set
public:
property String^ AddressTypeCode {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► PostalCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SMB Class

SMB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB
RDPCrystal EDI Library
Beginning Segment for Railroad Station Master File
Declaration Syntax
C# Visual Basic Visual C++
public class SMB : DocumentSegment
Public Class SMB _
    Inherits DocumentSegment
public ref class SMB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMB()()()() | Initializes a new instance of the SMB class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rule260JunctionCode | Element 8
 | StandardPointLocationCode | Element 3
 | StationTypeCode | Element 2
 | StationTypeCode1 | Element 4
 | StationTypeCode2 | Element 5
 | StationTypeCode3 | Element 6
 | StationTypeCode4 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SMB


SMB Constructor

SMB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► SMB()()()()
RDPCrystal EDI Library
Initializes a new instance of the SMB class
Declaration Syntax
C# Visual Basic Visual C++
public SMB()
Public Sub New
public:
SMB()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► Rule260JunctionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► StandardPointLocationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StationTypeCode Property

StationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► StationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StationTypeCode { get; set; }
Public Property StationTypeCode As String
    Get
    Set
public:
property String^ StationTypeCode {
    String^ get ();
    void set (String^ value);
}


StationTypeCode1 Property

StationTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► StationTypeCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StationTypeCode1 { get; set; }
Public Property StationTypeCode1 As String
    Get
    Set
public:
property String^ StationTypeCode1 {
    String^ get ();
    void set (String^ value);
}


StationTypeCode2 Property

StationTypeCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► StationTypeCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StationTypeCode2 { get; set; }
Public Property StationTypeCode2 As String
    Get
    Set
public:
property String^ StationTypeCode2 {
    String^ get ();
    void set (String^ value);
}


StationTypeCode3 Property

StationTypeCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► StationTypeCode3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StationTypeCode3 { get; set; }
Public Property StationTypeCode3 As String
    Get
    Set
public:
property String^ StationTypeCode3 {
    String^ get ();
    void set (String^ value);
}


StationTypeCode4 Property

StationTypeCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► StationTypeCode4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StationTypeCode4 { get; set; }
Public Property StationTypeCode4 As String
    Get
    Set
public:
property String^ StationTypeCode4 {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMB ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SMD Class

SMD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD
RDPCrystal EDI Library
Consolidated Shipment Manifest Data
Declaration Syntax
C# Visual Basic Visual C++
public class SMD : DocumentSegment
Public Class SMD _
    Inherits DocumentSegment
public ref class SMD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMD()()()() | Initializes a new instance of the SMD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PickupOrDeliveryCode | Element 3
 | ServiceLevelCode | Element 1
 | ShipmentMethodOfPayment | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SMD


SMD Constructor

SMD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD ► SMD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SMD class
Declaration Syntax
C# Visual Basic Visual C++
public SMD()
Public Sub New
public:
SMD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PickupOrDeliveryCode Property

PickupOrDeliveryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD ► PickupOrDeliveryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PickupOrDeliveryCode { get; set; }
Public Property PickupOrDeliveryCode As String
    Get
    Set
public:
property String^ PickupOrDeliveryCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD ► ServiceLevelCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SMO Class

SMO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO
RDPCrystal EDI Library
Operational Services
Declaration Syntax
C# Visual Basic Visual C++
public class SMO : DocumentSegment
Public Class SMO _
    Inherits DocumentSegment
public ref class SMO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMO()()()() | Initializes a new instance of the SMO class
 | AutomobileRampFacilityCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImportExportCode | Element 7
 | IntermodalFacilityCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RailCarPlateSizeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
 | YesNoConditionOrResponseCode1 | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SMO


SMO Constructor

SMO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► SMO()()()()
RDPCrystal EDI Library
Initializes a new instance of the SMO class
Declaration Syntax
C# Visual Basic Visual C++
public SMO()
Public Sub New
public:
SMO()


AutomobileRampFacilityCode Property

AutomobileRampFacilityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► AutomobileRampFacilityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AutomobileRampFacilityCode { get; set; }
Public Property AutomobileRampFacilityCode As String
    Get
    Set
public:
property String^ AutomobileRampFacilityCode {
    String^ get ();
    void set (String^ value);
}


ImportExportCode Property

ImportExportCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► ImportExportCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ImportExportCode { get; set; }
Public Property ImportExportCode As String
    Get
    Set
public:
property String^ ImportExportCode {
    String^ get ();
    void set (String^ value);
}


IntermodalFacilityCode Property

IntermodalFacilityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► IntermodalFacilityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalFacilityCode { get; set; }
Public Property IntermodalFacilityCode As String
    Get
    Set
public:
property String^ IntermodalFacilityCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RailCarPlateSizeCode Property

RailCarPlateSizeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► RailCarPlateSizeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RailCarPlateSizeCode { get; set; }
Public Property RailCarPlateSizeCode As String
    Get
    Set
public:
property String^ RailCarPlateSizeCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► Weight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMO ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


SMR Class

SMR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR
RDPCrystal EDI Library
Cross Reference
Declaration Syntax
C# Visual Basic Visual C++
public class SMR : DocumentSegment
Public Class SMR _
    Inherits DocumentSegment
public ref class SMR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMR()()()() | Initializes a new instance of the SMR class
 | CityName | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationQualifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardPointLocationCode | Element 2
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SMR


SMR Constructor

SMR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► SMR()()()()
RDPCrystal EDI Library
Initializes a new instance of the SMR class
Declaration Syntax
C# Visual Basic Visual C++
public SMR()
Public Sub New
public:
SMR()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► CityName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► LocationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► StandardPointLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SMS Class

SMS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS
RDPCrystal EDI Library
Station Codes Segment
Declaration Syntax
C# Visual Basic Visual C++
public class SMS : DocumentSegment
Public Class SMS _
    Inherits DocumentSegment
public ref class SMS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMS()()()() | Initializes a new instance of the SMS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 7
 | LocationIdentifier1 | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 4
 | ReciprocalSwitchCode | Element 5
 | Rule260JunctionCode | Element 3
 | StandardCarrierAlphaCode | Element 1
 | TimeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCode1 | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SMS


SMS Constructor

SMS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► SMS()()()()
RDPCrystal EDI Library
Initializes a new instance of the SMS class
Declaration Syntax
C# Visual Basic Visual C++
public SMS()
Public Sub New
public:
SMS()


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► IdentificationCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► LocationIdentifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► LocationIdentifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► PostalCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


ReciprocalSwitchCode Property

ReciprocalSwitchCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► ReciprocalSwitchCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReciprocalSwitchCode { get; set; }
Public Property ReciprocalSwitchCode As String
    Get
    Set
public:
property String^ ReciprocalSwitchCode {
    String^ get ();
    void set (String^ value);
}


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► Rule260JunctionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► TimeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SMS ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


SN1 Class

SN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1
RDPCrystal EDI Library
Item Detail (Shipment)
Declaration Syntax
C# Visual Basic Visual C++
public class SN1 : DocumentSegment
Public Class SN1 _
    Inherits DocumentSegment
public ref class SN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SN1()()()() | Initializes a new instance of the SN1 class
 | AssignedIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LineItemStatusCode | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | QuantityOrdered | Element 5
 | QuantityShippedToDate | Element 4
 | ReturnableContainerLoadMakeUpCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SN1


SN1 Constructor

SN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► SN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the SN1 class
Declaration Syntax
C# Visual Basic Visual C++
public SN1()
Public Sub New
public:
SN1()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


LineItemStatusCode Property

LineItemStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► LineItemStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LineItemStatusCode { get; set; }
Public Property LineItemStatusCode As String
    Get
    Set
public:
property String^ LineItemStatusCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► QuantityOrdered
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


QuantityShippedToDate Property

QuantityShippedToDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► QuantityShippedToDate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityShippedToDate { get; set; }
Public Property QuantityShippedToDate As String
    Get
    Set
public:
property String^ QuantityShippedToDate {
    String^ get ();
    void set (String^ value);
}


ReturnableContainerLoadMakeUpCode Property

ReturnableContainerLoadMakeUpCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► ReturnableContainerLoadMakeUpCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnableContainerLoadMakeUpCode { get; set; }
Public Property ReturnableContainerLoadMakeUpCode As String
    Get
    Set
public:
property String^ ReturnableContainerLoadMakeUpCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SOI Class

SOI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI
RDPCrystal EDI Library
Source of Income
Declaration Syntax
C# Visual Basic Visual C++
public class SOI : DocumentSegment
Public Class SOI _
    Inherits DocumentSegment
public ref class SOI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SOI()()()() | Initializes a new instance of the SOI class
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfIncomeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SOI


SOI Constructor

SOI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► SOI()()()()
RDPCrystal EDI Library
Initializes a new instance of the SOI class
Declaration Syntax
C# Visual Basic Visual C++
public SOI()
Public Sub New
public:
SOI()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► Number
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


TypeOfIncomeCode Property

TypeOfIncomeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► TypeOfIncomeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfIncomeCode { get; set; }
Public Property TypeOfIncomeCode As String
    Get
    Set
public:
property String^ TypeOfIncomeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SOM Class

SOM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM
RDPCrystal EDI Library
Status of Mortgage
Declaration Syntax
C# Visual Basic Visual C++
public class SOM : DocumentSegment
Public Class SOM _
    Inherits DocumentSegment
public ref class SOM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SOM()()()() | Initializes a new instance of the SOM class
 | Date | Element 6
 | DateTimePeriod | Element 3
 | DateTimePeriod1 | Element 10
 | DateTimePeriod2 | Element 13
 | DateTimePeriodFormatQualifier | Element 2
 | DateTimePeriodFormatQualifier1 | Element 9
 | DateTimePeriodFormatQualifier2 | Element 12
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanStatusCode | Element 1
 | LoanStatusCode1 | Element 8
 | LoanStatusCode2 | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfBankruptcyCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
 | YesNoConditionOrResponseCode1 | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SOM


SOM Constructor

SOM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► SOM()()()()
RDPCrystal EDI Library
Initializes a new instance of the SOM class
Declaration Syntax
C# Visual Basic Visual C++
public SOM()
Public Sub New
public:
SOM()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► DateTimePeriod1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► DateTimePeriod2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier2 Property

DateTimePeriodFormatQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► DateTimePeriodFormatQualifier2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier2 { get; set; }
Public Property DateTimePeriodFormatQualifier2 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanStatusCode Property

LoanStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► LoanStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoanStatusCode { get; set; }
Public Property LoanStatusCode As String
    Get
    Set
public:
property String^ LoanStatusCode {
    String^ get ();
    void set (String^ value);
}


LoanStatusCode1 Property

LoanStatusCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► LoanStatusCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LoanStatusCode1 { get; set; }
Public Property LoanStatusCode1 As String
    Get
    Set
public:
property String^ LoanStatusCode1 {
    String^ get ();
    void set (String^ value);
}


LoanStatusCode2 Property

LoanStatusCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► LoanStatusCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LoanStatusCode2 { get; set; }
Public Property LoanStatusCode2 As String
    Get
    Set
public:
property String^ LoanStatusCode2 {
    String^ get ();
    void set (String^ value);
}


TypeOfBankruptcyCode Property

TypeOfBankruptcyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► TypeOfBankruptcyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfBankruptcyCode { get; set; }
Public Property TypeOfBankruptcyCode As String
    Get
    Set
public:
property String^ TypeOfBankruptcyCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SOM ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


SP Class

SP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP
RDPCrystal EDI Library
Special Program
Declaration Syntax
C# Visual Basic Visual C++
public class SP : DocumentSegment
Public Class SP _
    Inherits DocumentSegment
public ref class SP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SP()()()() | Initializes a new instance of the SP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 2
 | ProgramAndServicesFundingSourceCode | Element 4
 | ProgramParticipationAndServicesCode | Element 3
 | SpecialProgramCategoryCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SP


SP Constructor

SP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► SP()()()()
RDPCrystal EDI Library
Initializes a new instance of the SP class
Declaration Syntax
C# Visual Basic Visual C++
public SP()
Public Sub New
public:
SP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► Name1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► Percent
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ProgramAndServicesFundingSourceCode Property

ProgramAndServicesFundingSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► ProgramAndServicesFundingSourceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramAndServicesFundingSourceCode { get; set; }
Public Property ProgramAndServicesFundingSourceCode As String
    Get
    Set
public:
property String^ ProgramAndServicesFundingSourceCode {
    String^ get ();
    void set (String^ value);
}


ProgramParticipationAndServicesCode Property

ProgramParticipationAndServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► ProgramParticipationAndServicesCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProgramParticipationAndServicesCode { get; set; }
Public Property ProgramParticipationAndServicesCode As String
    Get
    Set
public:
property String^ ProgramParticipationAndServicesCode {
    String^ get ();
    void set (String^ value);
}


SpecialProgramCategoryCode Property

SpecialProgramCategoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► SpecialProgramCategoryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialProgramCategoryCode { get; set; }
Public Property SpecialProgramCategoryCode As String
    Get
    Set
public:
property String^ SpecialProgramCategoryCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPA Class

SPA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA
RDPCrystal EDI Library
Status of Product or Activity
Declaration Syntax
C# Visual Basic Visual C++
public class SPA : DocumentSegment
Public Class SPA _
    Inherits DocumentSegment
public ref class SPA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPA()()()() | Initializes a new instance of the SPA class
 | AgencyQualifierCode | Element 9
 | AmountQualifierCode | Element 4
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 10
 | SourceSubqualifier | Element 11
 | StatusCode | Element 1
 | StatusReasonCode | Element 6
 | StatusReasonCode1 | Element 7
 | StatusReasonCode2 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPA


SPA Constructor

SPA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► SPA()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPA class
Declaration Syntax
C# Visual Basic Visual C++
public SPA()
Public Sub New
public:
SPA()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► AgencyQualifierCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► AmountQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► ProductDescriptionCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► SourceSubqualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► StatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► StatusReasonCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode1 Property

StatusReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► StatusReasonCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode1 { get; set; }
Public Property StatusReasonCode1 As String
    Get
    Set
public:
property String^ StatusReasonCode1 {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode2 Property

StatusReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► StatusReasonCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode2 { get; set; }
Public Property StatusReasonCode2 As String
    Get
    Set
public:
property String^ StatusReasonCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPI Class

SPI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI
RDPCrystal EDI Library
Specification Identifier
Declaration Syntax
C# Visual Basic Visual C++
public class SPI : DocumentSegment
Public Class SPI _
    Inherits DocumentSegment
public ref class SPI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPI()()()() | Initializes a new instance of the SPI class
 | AgencyQualifierCode | Element 10
 | AssignedNumber | Element 12
 | CertificationTypeCode | Element 13
 | EntityPurpose | Element 5
 | EntityStatusCode | Element 6
 | EntityTitle | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalStructureCode | Element 15
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProposalDataDetailIdentifierCode | Element 14
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | ReportTypeCode | Element 8
 | SecurityLevelCode | Element 1
 | SecurityLevelCode1 | Element 9
 | SourceSubqualifier | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPI


SPI Constructor

SPI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► SPI()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPI class
Declaration Syntax
C# Visual Basic Visual C++
public SPI()
Public Sub New
public:
SPI()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► AgencyQualifierCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► AssignedNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► CertificationTypeCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


EntityPurpose Property

EntityPurpose Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► EntityPurpose
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityPurpose { get; set; }
Public Property EntityPurpose As String
    Get
    Set
public:
property String^ EntityPurpose {
    String^ get ();
    void set (String^ value);
}


EntityStatusCode Property

EntityStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► EntityStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityStatusCode { get; set; }
Public Property EntityStatusCode As String
    Get
    Set
public:
property String^ EntityStatusCode {
    String^ get ();
    void set (String^ value);
}


EntityTitle Property

EntityTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► EntityTitle
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTitle { get; set; }
Public Property EntityTitle As String
    Get
    Set
public:
property String^ EntityTitle {
    String^ get ();
    void set (String^ value);
}


HierarchicalStructureCode Property

HierarchicalStructureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► HierarchicalStructureCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalStructureCode { get; set; }
Public Property HierarchicalStructureCode As String
    Get
    Set
public:
property String^ HierarchicalStructureCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProposalDataDetailIdentifierCode Property

ProposalDataDetailIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► ProposalDataDetailIdentifierCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProposalDataDetailIdentifierCode { get; set; }
Public Property ProposalDataDetailIdentifierCode As String
    Get
    Set
public:
property String^ ProposalDataDetailIdentifierCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► ReportTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► SecurityLevelCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}


SecurityLevelCode1 Property

SecurityLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► SecurityLevelCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode1 { get; set; }
Public Property SecurityLevelCode1 As String
    Get
    Set
public:
property String^ SecurityLevelCode1 {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► SourceSubqualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPK Class

SPK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK
RDPCrystal EDI Library
Specimen Kit Information
Declaration Syntax
C# Visual Basic Visual C++
public class SPK : DocumentSegment
Public Class SPK _
    Inherits DocumentSegment
public ref class SPK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPK()()()() | Initializes a new instance of the SPK class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 5
 | IdentificationCodeQualifier | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecimenKitTypeCode | Element 1
 | Temperature | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPK


SPK Constructor

SPK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► SPK()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPK class
Declaration Syntax
C# Visual Basic Visual C++
public SPK()
Public Sub New
public:
SPK()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecimenKitTypeCode Property

SpecimenKitTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► SpecimenKitTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecimenKitTypeCode { get; set; }
Public Property SpecimenKitTypeCode As String
    Get
    Set
public:
property String^ SpecimenKitTypeCode {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► Temperature
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPO Class

SPO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO
RDPCrystal EDI Library
Shipment Purchase Order Detail
Declaration Syntax
C# Visual Basic Visual C++
public class SPO : DocumentSegment
Public Class SPO _
    Inherits DocumentSegment
public ref class SPO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPO()()()() | Initializes a new instance of the SPO class
 | ApplicationErrorConditionCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 1
 | Quantity | Element 4
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Weight | Element 6
 | WeightUnitCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPO


SPO Constructor

SPO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► SPO()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPO class
Declaration Syntax
C# Visual Basic Visual C++
public SPO()
Public Sub New
public:
SPO()


ApplicationErrorConditionCode Property

ApplicationErrorConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► ApplicationErrorConditionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode { get; set; }
Public Property ApplicationErrorConditionCode As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► Weight
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► WeightUnitCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPR Class

SPR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR
RDPCrystal EDI Library
Supplier Rating
Declaration Syntax
C# Visual Basic Visual C++
public class SPR : DocumentSegment
Public Class SPR _
    Inherits DocumentSegment
public ref class SPR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPR()()()() | Initializes a new instance of the SPR class
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 2
 | MeasurementValue1 | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 4
 | RangeMinimum | Element 3
 | RatingCategoryCode | Element 1
 | RatingSummaryValueCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPR


SPR Constructor

SPR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► SPR()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPR class
Declaration Syntax
C# Visual Basic Visual C++
public SPR()
Public Sub New
public:
SPR()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► MeasurementValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


MeasurementValue1 Property

MeasurementValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► MeasurementValue1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue1 { get; set; }
Public Property MeasurementValue1 As String
    Get
    Set
public:
property String^ MeasurementValue1 {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► RangeMaximum
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► RangeMinimum
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


RatingCategoryCode Property

RatingCategoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► RatingCategoryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RatingCategoryCode { get; set; }
Public Property RatingCategoryCode As String
    Get
    Set
public:
property String^ RatingCategoryCode {
    String^ get ();
    void set (String^ value);
}


RatingSummaryValueCode Property

RatingSummaryValueCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► RatingSummaryValueCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RatingSummaryValueCode { get; set; }
Public Property RatingSummaryValueCode As String
    Get
    Set
public:
property String^ RatingSummaryValueCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPS Class

SPS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS
RDPCrystal EDI Library
Sampling Parameters for Summary Statistics
Declaration Syntax
C# Visual Basic Visual C++
public class SPS : DocumentSegment
Public Class SPS _
    Inherits DocumentSegment
public ref class SPS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPS()()()() | Initializes a new instance of the SPS class
 | CompositeUnitOfMeasure | Element 5
 | ConfidenceLimit | Element 4
 | Count | Element 1
 | Count1 | Element 2
 | Count2 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SampleFrequencyValuePerUnitOfMeasurementCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPS


SPS Constructor

SPS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► SPS()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPS class
Declaration Syntax
C# Visual Basic Visual C++
public SPS()
Public Sub New
public:
SPS()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


ConfidenceLimit Property

ConfidenceLimit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► ConfidenceLimit
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ConfidenceLimit { get; set; }
Public Property ConfidenceLimit As String
    Get
    Set
public:
property String^ ConfidenceLimit {
    String^ get ();
    void set (String^ value);
}


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► Count
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}


Count1 Property

Count1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► Count1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Count1 { get; set; }
Public Property Count1 As String
    Get
    Set
public:
property String^ Count1 {
    String^ get ();
    void set (String^ value);
}


Count2 Property

Count2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► Count2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Count2 { get; set; }
Public Property Count2 As String
    Get
    Set
public:
property String^ Count2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SampleFrequencyValuePerUnitOfMeasurementCode Property

SampleFrequencyValuePerUnitOfMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► SampleFrequencyValuePerUnitOfMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SampleFrequencyValuePerUnitOfMeasurementCode { get; set; }
Public Property SampleFrequencyValuePerUnitOfMeasurementCode As String
    Get
    Set
public:
property String^ SampleFrequencyValuePerUnitOfMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SPY Class

SPY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY
RDPCrystal EDI Library
Scope of Power of Attorney
Declaration Syntax
C# Visual Basic Visual C++
public class SPY : DocumentSegment
Public Class SPY _
    Inherits DocumentSegment
public ref class SPY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SPY()()()() | Initializes a new instance of the SPY class
 | ActionCode | Element 1
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ScopeOfPowerOfAttorneyIdentificationCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SPY


SPY Constructor

SPY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY ► SPY()()()()
RDPCrystal EDI Library
Initializes a new instance of the SPY class
Declaration Syntax
C# Visual Basic Visual C++
public SPY()
Public Sub New
public:
SPY()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ScopeOfPowerOfAttorneyIdentificationCode Property

ScopeOfPowerOfAttorneyIdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY ► ScopeOfPowerOfAttorneyIdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ScopeOfPowerOfAttorneyIdentificationCode { get; set; }
Public Property ScopeOfPowerOfAttorneyIdentificationCode As String
    Get
    Set
public:
property String^ ScopeOfPowerOfAttorneyIdentificationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SPY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SR Class

SR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR
RDPCrystal EDI Library
Requested Service Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class SR : DocumentSegment
Public Class SR _
    Inherits DocumentSegment
public ref class SR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SR()()()() | Initializes a new instance of the SR class
 | AssignedIdentification | Element 1
 | Date | Element 8
 | Date1 | Element 9
 | DayRotation | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 10
 | ProductServiceID1 | Element 11
 | Quantity | Element 7
 | Time | Element 3
 | Time1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SR


SR Constructor

SR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► SR()()()()
RDPCrystal EDI Library
Initializes a new instance of the SR class
Declaration Syntax
C# Visual Basic Visual C++
public SR()
Public Sub New
public:
SR()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Date1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


DayRotation Property

DayRotation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► DayRotation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DayRotation { get; set; }
Public Property DayRotation As String
    Get
    Set
public:
property String^ DayRotation {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► FreeFormMessage
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► ProductServiceID
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► ProductServiceID1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Time1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► UnitPrice
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SRA Class

SRA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRA
RDPCrystal EDI Library
Traffic Evaluation Factors
Declaration Syntax
C# Visual Basic Visual C++
public class SRA : DocumentSegment
Public Class SRA _
    Inherits DocumentSegment
public ref class SRA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SRA()()()() | Initializes a new instance of the SRA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementValue | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SRA


SRA Constructor

SRA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRA ► SRA()()()()
RDPCrystal EDI Library
Initializes a new instance of the SRA class
Declaration Syntax
C# Visual Basic Visual C++
public SRA()
Public Sub New
public:
SRA()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRA ► MeasurementValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRA ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SRD Class

SRD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD
RDPCrystal EDI Library
Scale Rate Detail
Declaration Syntax
C# Visual Basic Visual C++
public class SRD : DocumentSegment
Public Class SRD _
    Inherits DocumentSegment
public ref class SRD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SRD()()()() | Initializes a new instance of the SRD class
 | DistanceQualifier | Element 1
 | DistanceQualifier1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 5
 | FreightRate1 | Element 6
 | FreightRate10 | Element 15
 | FreightRate11 | Element 16
 | FreightRate12 | Element 17
 | FreightRate13 | Element 18
 | FreightRate14 | Element 19
 | FreightRate15 | Element 20
 | FreightRate2 | Element 7
 | FreightRate3 | Element 8
 | FreightRate4 | Element 9
 | FreightRate5 | Element 10
 | FreightRate6 | Element 11
 | FreightRate7 | Element 12
 | FreightRate8 | Element 13
 | FreightRate9 | Element 14
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateBasisNumber | Element 2
 | RateBasisNumber1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SRD


SRD Constructor

SRD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► SRD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SRD class
Declaration Syntax
C# Visual Basic Visual C++
public SRD()
Public Sub New
public:
SRD()


DistanceQualifier Property

DistanceQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► DistanceQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DistanceQualifier { get; set; }
Public Property DistanceQualifier As String
    Get
    Set
public:
property String^ DistanceQualifier {
    String^ get ();
    void set (String^ value);
}


DistanceQualifier1 Property

DistanceQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► DistanceQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DistanceQualifier1 { get; set; }
Public Property DistanceQualifier1 As String
    Get
    Set
public:
property String^ DistanceQualifier1 {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRate1 Property

FreightRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate1 { get; set; }
Public Property FreightRate1 As String
    Get
    Set
public:
property String^ FreightRate1 {
    String^ get ();
    void set (String^ value);
}


FreightRate10 Property

FreightRate10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate10
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate10 { get; set; }
Public Property FreightRate10 As String
    Get
    Set
public:
property String^ FreightRate10 {
    String^ get ();
    void set (String^ value);
}


FreightRate11 Property

FreightRate11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate11
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate11 { get; set; }
Public Property FreightRate11 As String
    Get
    Set
public:
property String^ FreightRate11 {
    String^ get ();
    void set (String^ value);
}


FreightRate12 Property

FreightRate12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate12
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate12 { get; set; }
Public Property FreightRate12 As String
    Get
    Set
public:
property String^ FreightRate12 {
    String^ get ();
    void set (String^ value);
}


FreightRate13 Property

FreightRate13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate13
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate13 { get; set; }
Public Property FreightRate13 As String
    Get
    Set
public:
property String^ FreightRate13 {
    String^ get ();
    void set (String^ value);
}


FreightRate14 Property

FreightRate14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate14
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate14 { get; set; }
Public Property FreightRate14 As String
    Get
    Set
public:
property String^ FreightRate14 {
    String^ get ();
    void set (String^ value);
}


FreightRate15 Property

FreightRate15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate15
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate15 { get; set; }
Public Property FreightRate15 As String
    Get
    Set
public:
property String^ FreightRate15 {
    String^ get ();
    void set (String^ value);
}


FreightRate2 Property

FreightRate2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate2 { get; set; }
Public Property FreightRate2 As String
    Get
    Set
public:
property String^ FreightRate2 {
    String^ get ();
    void set (String^ value);
}


FreightRate3 Property

FreightRate3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate3 { get; set; }
Public Property FreightRate3 As String
    Get
    Set
public:
property String^ FreightRate3 {
    String^ get ();
    void set (String^ value);
}


FreightRate4 Property

FreightRate4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate4 { get; set; }
Public Property FreightRate4 As String
    Get
    Set
public:
property String^ FreightRate4 {
    String^ get ();
    void set (String^ value);
}


FreightRate5 Property

FreightRate5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate5
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate5 { get; set; }
Public Property FreightRate5 As String
    Get
    Set
public:
property String^ FreightRate5 {
    String^ get ();
    void set (String^ value);
}


FreightRate6 Property

FreightRate6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate6
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate6 { get; set; }
Public Property FreightRate6 As String
    Get
    Set
public:
property String^ FreightRate6 {
    String^ get ();
    void set (String^ value);
}


FreightRate7 Property

FreightRate7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate7
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate7 { get; set; }
Public Property FreightRate7 As String
    Get
    Set
public:
property String^ FreightRate7 {
    String^ get ();
    void set (String^ value);
}


FreightRate8 Property

FreightRate8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate8
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate8 { get; set; }
Public Property FreightRate8 As String
    Get
    Set
public:
property String^ FreightRate8 {
    String^ get ();
    void set (String^ value);
}


FreightRate9 Property

FreightRate9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► FreightRate9
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate9 { get; set; }
Public Property FreightRate9 As String
    Get
    Set
public:
property String^ FreightRate9 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateBasisNumber Property

RateBasisNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► RateBasisNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateBasisNumber { get; set; }
Public Property RateBasisNumber As String
    Get
    Set
public:
property String^ RateBasisNumber {
    String^ get ();
    void set (String^ value);
}


RateBasisNumber1 Property

RateBasisNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► RateBasisNumber1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateBasisNumber1 { get; set; }
Public Property RateBasisNumber1 As String
    Get
    Set
public:
property String^ RateBasisNumber1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SRE Class

SRE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRE
RDPCrystal EDI Library
Test Scores
Declaration Syntax
C# Visual Basic Visual C++
public class SRE : DocumentSegment
Public Class SRE _
    Inherits DocumentSegment
public ref class SRE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SRE()()()() | Initializes a new instance of the SRE class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TestScoreQualifierCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SRE


SRE Constructor

SRE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRE ► SRE()()()()
RDPCrystal EDI Library
Initializes a new instance of the SRE class
Declaration Syntax
C# Visual Basic Visual C++
public SRE()
Public Sub New
public:
SRE()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRE ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TestScoreQualifierCode Property

TestScoreQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRE ► TestScoreQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TestScoreQualifierCode { get; set; }
Public Property TestScoreQualifierCode As String
    Get
    Set
public:
property String^ TestScoreQualifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SRM Class

SRM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM
RDPCrystal EDI Library
Scale Rates
Declaration Syntax
C# Visual Basic Visual C++
public class SRM : DocumentSegment
Public Class SRM _
    Inherits DocumentSegment
public ref class SRM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SRM()()()() | Initializes a new instance of the SRM class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 1
 | FreightRate1 | Element 2
 | FreightRate10 | Element 11
 | FreightRate11 | Element 12
 | FreightRate12 | Element 13
 | FreightRate13 | Element 14
 | FreightRate14 | Element 15
 | FreightRate15 | Element 16
 | FreightRate2 | Element 3
 | FreightRate3 | Element 4
 | FreightRate4 | Element 5
 | FreightRate5 | Element 6
 | FreightRate6 | Element 7
 | FreightRate7 | Element 8
 | FreightRate8 | Element 9
 | FreightRate9 | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SRM


SRM Constructor

SRM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► SRM()()()()
RDPCrystal EDI Library
Initializes a new instance of the SRM class
Declaration Syntax
C# Visual Basic Visual C++
public SRM()
Public Sub New
public:
SRM()


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRate1 Property

FreightRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate1 { get; set; }
Public Property FreightRate1 As String
    Get
    Set
public:
property String^ FreightRate1 {
    String^ get ();
    void set (String^ value);
}


FreightRate10 Property

FreightRate10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate10
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate10 { get; set; }
Public Property FreightRate10 As String
    Get
    Set
public:
property String^ FreightRate10 {
    String^ get ();
    void set (String^ value);
}


FreightRate11 Property

FreightRate11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate11
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate11 { get; set; }
Public Property FreightRate11 As String
    Get
    Set
public:
property String^ FreightRate11 {
    String^ get ();
    void set (String^ value);
}


FreightRate12 Property

FreightRate12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate12
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate12 { get; set; }
Public Property FreightRate12 As String
    Get
    Set
public:
property String^ FreightRate12 {
    String^ get ();
    void set (String^ value);
}


FreightRate13 Property

FreightRate13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate13
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate13 { get; set; }
Public Property FreightRate13 As String
    Get
    Set
public:
property String^ FreightRate13 {
    String^ get ();
    void set (String^ value);
}


FreightRate14 Property

FreightRate14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate14
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate14 { get; set; }
Public Property FreightRate14 As String
    Get
    Set
public:
property String^ FreightRate14 {
    String^ get ();
    void set (String^ value);
}


FreightRate15 Property

FreightRate15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate15
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate15 { get; set; }
Public Property FreightRate15 As String
    Get
    Set
public:
property String^ FreightRate15 {
    String^ get ();
    void set (String^ value);
}


FreightRate2 Property

FreightRate2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate2 { get; set; }
Public Property FreightRate2 As String
    Get
    Set
public:
property String^ FreightRate2 {
    String^ get ();
    void set (String^ value);
}


FreightRate3 Property

FreightRate3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate3 { get; set; }
Public Property FreightRate3 As String
    Get
    Set
public:
property String^ FreightRate3 {
    String^ get ();
    void set (String^ value);
}


FreightRate4 Property

FreightRate4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate4 { get; set; }
Public Property FreightRate4 As String
    Get
    Set
public:
property String^ FreightRate4 {
    String^ get ();
    void set (String^ value);
}


FreightRate5 Property

FreightRate5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate5
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate5 { get; set; }
Public Property FreightRate5 As String
    Get
    Set
public:
property String^ FreightRate5 {
    String^ get ();
    void set (String^ value);
}


FreightRate6 Property

FreightRate6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate6
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate6 { get; set; }
Public Property FreightRate6 As String
    Get
    Set
public:
property String^ FreightRate6 {
    String^ get ();
    void set (String^ value);
}


FreightRate7 Property

FreightRate7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate7
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate7 { get; set; }
Public Property FreightRate7 As String
    Get
    Set
public:
property String^ FreightRate7 {
    String^ get ();
    void set (String^ value);
}


FreightRate8 Property

FreightRate8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate8
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate8 { get; set; }
Public Property FreightRate8 As String
    Get
    Set
public:
property String^ FreightRate8 {
    String^ get ();
    void set (String^ value);
}


FreightRate9 Property

FreightRate9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► FreightRate9
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate9 { get; set; }
Public Property FreightRate9 As String
    Get
    Set
public:
property String^ FreightRate9 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SRT Class

SRT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT
RDPCrystal EDI Library
Scale Rate Header
Declaration Syntax
C# Visual Basic Visual C++
public class SRT : DocumentSegment
Public Class SRT _
    Inherits DocumentSegment
public ref class SRT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SRT()()()() | Initializes a new instance of the SRT class
 | ChangeTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadingRestriction | Element 9
 | LoadingRestriction1 | Element 10
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumWeightLogic | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 11
 | RateApplicationTypeCode | Element 5
 | RateValueQualifier | Element 3
 | RateValueQualifier1 | Element 4
 | RouteCode | Element 2
 | Scale | Element 6
 | Scale1 | Element 7
 | SpecialChargeDescription | Element 13
 | SpecialChargeOrAllowanceCode | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SRT


SRT Constructor

SRT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► SRT()()()()
RDPCrystal EDI Library
Initializes a new instance of the SRT class
Declaration Syntax
C# Visual Basic Visual C++
public SRT()
Public Sub New
public:
SRT()


ChangeTypeCode Property

ChangeTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► ChangeTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeTypeCode { get; set; }
Public Property ChangeTypeCode As String
    Get
    Set
public:
property String^ ChangeTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadingRestriction Property

LoadingRestriction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► LoadingRestriction
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction { get; set; }
Public Property LoadingRestriction As String
    Get
    Set
public:
property String^ LoadingRestriction {
    String^ get ();
    void set (String^ value);
}


LoadingRestriction1 Property

LoadingRestriction1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► LoadingRestriction1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingRestriction1 { get; set; }
Public Property LoadingRestriction1 As String
    Get
    Set
public:
property String^ LoadingRestriction1 {
    String^ get ();
    void set (String^ value);
}


MinimumWeightLogic Property

MinimumWeightLogic Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► MinimumWeightLogic
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MinimumWeightLogic { get; set; }
Public Property MinimumWeightLogic As String
    Get
    Set
public:
property String^ MinimumWeightLogic {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► Percent
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RateApplicationTypeCode Property

RateApplicationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► RateApplicationTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateApplicationTypeCode { get; set; }
Public Property RateApplicationTypeCode As String
    Get
    Set
public:
property String^ RateApplicationTypeCode {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► RateValueQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► RateValueQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


RouteCode Property

RouteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► RouteCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RouteCode { get; set; }
Public Property RouteCode As String
    Get
    Set
public:
property String^ RouteCode {
    String^ get ();
    void set (String^ value);
}


Scale Property

Scale Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► Scale
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Scale { get; set; }
Public Property Scale As String
    Get
    Set
public:
property String^ Scale {
    String^ get ();
    void set (String^ value);
}


Scale1 Property

Scale1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► Scale1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Scale1 { get; set; }
Public Property Scale1 As String
    Get
    Set
public:
property String^ Scale1 {
    String^ get ();
    void set (String^ value);
}


SpecialChargeDescription Property

SpecialChargeDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► SpecialChargeDescription
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeDescription { get; set; }
Public Property SpecialChargeDescription As String
    Get
    Set
public:
property String^ SpecialChargeDescription {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SRT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SS Class

SS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS
RDPCrystal EDI Library
Docket Control Status
Declaration Syntax
C# Visual Basic Visual C++
public class SS : DocumentSegment
Public Class SS _
    Inherits DocumentSegment
public ref class SS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SS()()()() | Initializes a new instance of the SS class
 | Date | Element 1
 | Date1 | Element 5
 | Date2 | Element 6
 | Date3 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndependenceCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateDistributionCode | Element 3
 | RateLevel | Element 2
 | RateMaintenanceAuthorityCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SS


SS Constructor

SS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► SS()()()()
RDPCrystal EDI Library
Initializes a new instance of the SS class
Declaration Syntax
C# Visual Basic Visual C++
public SS()
Public Sub New
public:
SS()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► Date1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► Date2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► Date3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


IndependenceCode Property

IndependenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► IndependenceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IndependenceCode { get; set; }
Public Property IndependenceCode As String
    Get
    Set
public:
property String^ IndependenceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► NumberOfPeriods
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}


RateDistributionCode Property

RateDistributionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► RateDistributionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateDistributionCode { get; set; }
Public Property RateDistributionCode As String
    Get
    Set
public:
property String^ RateDistributionCode {
    String^ get ();
    void set (String^ value);
}


RateLevel Property

RateLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► RateLevel
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RateLevel { get; set; }
Public Property RateLevel As String
    Get
    Set
public:
property String^ RateLevel {
    String^ get ();
    void set (String^ value);
}


RateMaintenanceAuthorityCode Property

RateMaintenanceAuthorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► RateMaintenanceAuthorityCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RateMaintenanceAuthorityCode { get; set; }
Public Property RateMaintenanceAuthorityCode As String
    Get
    Set
public:
property String^ RateMaintenanceAuthorityCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SSC Class

SSC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC
RDPCrystal EDI Library
Beginning Segment for Service Commitment Advice
Declaration Syntax
C# Visual Basic Visual C++
public class SSC : DocumentSegment
Public Class SSC _
    Inherits DocumentSegment
public ref class SSC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SSC()()()() | Initializes a new instance of the SSC class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 8
 | ReferenceIdentification | Element 2
 | ServiceCommitmentTypeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SSC


SSC Constructor

SSC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► SSC()()()()
RDPCrystal EDI Library
Initializes a new instance of the SSC class
Declaration Syntax
C# Visual Basic Visual C++
public SSC()
Public Sub New
public:
SSC()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► Percent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ServiceCommitmentTypeCode Property

ServiceCommitmentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► ServiceCommitmentTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceCommitmentTypeCode { get; set; }
Public Property ServiceCommitmentTypeCode As String
    Get
    Set
public:
property String^ ServiceCommitmentTypeCode {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SSD Class

SSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD
RDPCrystal EDI Library
Shipment Sort Segregate Data
Declaration Syntax
C# Visual Basic Visual C++
public class SSD : DocumentSegment
Public Class SSD _
    Inherits DocumentSegment
public ref class SSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SSD()()()() | Initializes a new instance of the SSD class
 | ApplicationErrorConditionCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 3
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SSD


SSD Constructor

SSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► SSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SSD class
Declaration Syntax
C# Visual Basic Visual C++
public SSD()
Public Sub New
public:
SSD()


ApplicationErrorConditionCode Property

ApplicationErrorConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► ApplicationErrorConditionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode { get; set; }
Public Property ApplicationErrorConditionCode As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► ReferenceIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SSE Class

SSE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE
RDPCrystal EDI Library
Entry and Exit Information
Declaration Syntax
C# Visual Basic Visual C++
public class SSE : DocumentSegment
Public Class SSE _
    Inherits DocumentSegment
public ref class SSE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SSE()()()() | Initializes a new instance of the SSE class
 | Date | Element 1
 | Date1 | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SSE


SSE Constructor

SSE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► SSE()()()()
RDPCrystal EDI Library
Initializes a new instance of the SSE class
Declaration Syntax
C# Visual Basic Visual C++
public SSE()
Public Sub New
public:
SSE()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► Date1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► Number
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► StatusReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SSS Class

SSS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS
RDPCrystal EDI Library
Special Services
Declaration Syntax
C# Visual Basic Visual C++
public class SSS : DocumentSegment
Public Class SSS _
    Inherits DocumentSegment
public ref class SSS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SSS()()()() | Initializes a new instance of the SSS class
 | AgencyQualifierCode | Element 2
 | AllowanceOrChargeIndicator | Element 1
 | AllowanceOrChargeRate | Element 5
 | Amount | Element 6
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 8
 | ServiceMarksAndNumbers | Element 4
 | SourceSubqualifier | Element 9
 | SpecialServicesCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SSS


SSS Constructor

SSS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► SSS()()()()
RDPCrystal EDI Library
Initializes a new instance of the SSS class
Declaration Syntax
C# Visual Basic Visual C++
public SSS()
Public Sub New
public:
SSS()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeIndicator Property

AllowanceOrChargeIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► AllowanceOrChargeIndicator
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeIndicator { get; set; }
Public Property AllowanceOrChargeIndicator As String
    Get
    Set
public:
property String^ AllowanceOrChargeIndicator {
    String^ get ();
    void set (String^ value);
}


AllowanceOrChargeRate Property

AllowanceOrChargeRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► AllowanceOrChargeRate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AllowanceOrChargeRate { get; set; }
Public Property AllowanceOrChargeRate As String
    Get
    Set
public:
property String^ AllowanceOrChargeRate {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► Amount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► Quantity
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ServiceMarksAndNumbers Property

ServiceMarksAndNumbers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► ServiceMarksAndNumbers
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceMarksAndNumbers { get; set; }
Public Property ServiceMarksAndNumbers As String
    Get
    Set
public:
property String^ ServiceMarksAndNumbers {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► SourceSubqualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


SpecialServicesCode Property

SpecialServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► SpecialServicesCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialServicesCode { get; set; }
Public Property SpecialServicesCode As String
    Get
    Set
public:
property String^ SpecialServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SSS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SST Class

SST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST
RDPCrystal EDI Library
Student Academic Status
Declaration Syntax
C# Visual Basic Visual C++
public class SST : DocumentSegment
Public Class SST _
    Inherits DocumentSegment
public ref class SST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SST()()()() | Initializes a new instance of the SST class
 | DateTimePeriod | Element 3
 | DateTimePeriod1 | Element 6
 | DateTimePeriodFormatQualifier | Element 2
 | DateTimePeriodFormatQualifier1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelOfIndividualTestOrCourseCode | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusReasonCode | Element 1
 | StatusReasonCode1 | Element 4
 | StatusReasonCode2 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SST


SST Constructor

SST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► SST()()()()
RDPCrystal EDI Library
Initializes a new instance of the SST class
Declaration Syntax
C# Visual Basic Visual C++
public SST()
Public Sub New
public:
SST()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► DateTimePeriod1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► StatusReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode1 Property

StatusReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► StatusReasonCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode1 { get; set; }
Public Property StatusReasonCode1 As String
    Get
    Set
public:
property String^ StatusReasonCode1 {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode2 Property

StatusReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► StatusReasonCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode2 { get; set; }
Public Property StatusReasonCode2 As String
    Get
    Set
public:
property String^ StatusReasonCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SST ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


ST Class

ST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ST
RDPCrystal EDI Library
Transaction Set Header
Declaration Syntax
C# Visual Basic Visual C++
public class ST : DocumentSegment
Public Class ST _
    Inherits DocumentSegment
public ref class ST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ST()()()() | Initializes a new instance of the ST class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber | Element 2
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ST


ST Constructor

ST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ST ► ST()()()()
RDPCrystal EDI Library
Initializes a new instance of the ST class
Declaration Syntax
C# Visual Basic Visual C++
public ST()
Public Sub New
public:
ST()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ST ► TransactionSetControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ST ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


STA Class

STA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA
RDPCrystal EDI Library
Statistics
Declaration Syntax
C# Visual Basic Visual C++
public class STA : DocumentSegment
Public Class STA _
    Inherits DocumentSegment
public ref class STA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | STA()()()() | Initializes a new instance of the STA class
 | CompositeUnitOfMeasure | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementQualifier | Element 4
 | MeasurementReferenceIDCode | Element 5
 | MeasurementSignificanceCode | Element 8
 | MeasurementValue | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RangeMaximum | Element 7
 | RangeMinimum | Element 6
 | StatisticCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | STA


STA Constructor

STA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► STA()()()()
RDPCrystal EDI Library
Initializes a new instance of the STA class
Declaration Syntax
C# Visual Basic Visual C++
public STA()
Public Sub New
public:
STA()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MeasurementQualifier Property

MeasurementQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► MeasurementQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementQualifier { get; set; }
Public Property MeasurementQualifier As String
    Get
    Set
public:
property String^ MeasurementQualifier {
    String^ get ();
    void set (String^ value);
}


MeasurementReferenceIDCode Property

MeasurementReferenceIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► MeasurementReferenceIDCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementReferenceIDCode { get; set; }
Public Property MeasurementReferenceIDCode As String
    Get
    Set
public:
property String^ MeasurementReferenceIDCode {
    String^ get ();
    void set (String^ value);
}


MeasurementSignificanceCode Property

MeasurementSignificanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► MeasurementSignificanceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementSignificanceCode { get; set; }
Public Property MeasurementSignificanceCode As String
    Get
    Set
public:
property String^ MeasurementSignificanceCode {
    String^ get ();
    void set (String^ value);
}


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► MeasurementValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► RangeMaximum
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► RangeMinimum
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


StatisticCode Property

StatisticCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► StatisticCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatisticCode { get; set; }
Public Property StatisticCode As String
    Get
    Set
public:
property String^ StatisticCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


STC Class

STC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC
RDPCrystal EDI Library
Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class STC : DocumentSegment
Public Class STC _
    Inherits DocumentSegment
public ref class STC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | STC()()()() | Initializes a new instance of the STC class
 | ActionCode | Element 3
 | CheckNumber | Element 9
 | Date | Element 2
 | Date1 | Element 6
 | Date2 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 12
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareClaimStatus | Element 1
 | HealthCareClaimStatus1 | Element 10
 | HealthCareClaimStatus2 | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | MonetaryAmount1 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | STC


STC Constructor

STC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► STC()()()()
RDPCrystal EDI Library
Initializes a new instance of the STC class
Declaration Syntax
C# Visual Basic Visual C++
public STC()
Public Sub New
public:
STC()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► ActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


CheckNumber Property

CheckNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► CheckNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CheckNumber { get; set; }
Public Property CheckNumber As String
    Get
    Set
public:
property String^ CheckNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► Date1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► Date2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► FreeFormMessageText
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


HealthCareClaimStatus Property

HealthCareClaimStatus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► HealthCareClaimStatus
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus { get; set; }
Public Property HealthCareClaimStatus As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}


HealthCareClaimStatus1 Property

HealthCareClaimStatus1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► HealthCareClaimStatus1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus1 { get; set; }
Public Property HealthCareClaimStatus1 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus1 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}


HealthCareClaimStatus2 Property

HealthCareClaimStatus2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► HealthCareClaimStatus2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus2 { get; set; }
Public Property HealthCareClaimStatus2 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus2 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► MonetaryAmount1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► PaymentMethodCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


STP Class

STP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP
RDPCrystal EDI Library
Study Parameters
Declaration Syntax
C# Visual Basic Visual C++
public class STP : DocumentSegment
Public Class STP _
    Inherits DocumentSegment
public ref class STP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | STP()()()() | Initializes a new instance of the STP class
 | Date | Element 1
 | EntityTitle | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 5
 | Number1 | Element 6
 | Number2 | Element 7
 | Number3 | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentification2 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | STP


STP Constructor

STP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► STP()()()()
RDPCrystal EDI Library
Initializes a new instance of the STP class
Declaration Syntax
C# Visual Basic Visual C++
public STP()
Public Sub New
public:
STP()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EntityTitle Property

EntityTitle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► EntityTitle
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTitle { get; set; }
Public Property EntityTitle As String
    Get
    Set
public:
property String^ EntityTitle {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Number
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Number1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


Number2 Property

Number2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Number2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number2 { get; set; }
Public Property Number2 As String
    Get
    Set
public:
property String^ Number2 {
    String^ get ();
    void set (String^ value);
}


Number3 Property

Number3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Number3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Number3 { get; set; }
Public Property Number3 As String
    Get
    Set
public:
property String^ Number3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► ReferenceIdentification2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


STS Class

STS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS
RDPCrystal EDI Library
Interchange Status Segment
Declaration Syntax
C# Visual Basic Visual C++
public class STS : DocumentSegment
Public Class STS _
    Inherits DocumentSegment
public ref class STS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | STS()()()() | Initializes a new instance of the STS class
 | ActionCode | Element 1
 | ActionDate | Element 2
 | ActionTime | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorReasonCode | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TimeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | STS


STS Constructor

STS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► STS()()()()
RDPCrystal EDI Library
Initializes a new instance of the STS class
Declaration Syntax
C# Visual Basic Visual C++
public STS()
Public Sub New
public:
STS()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ActionDate Property

ActionDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► ActionDate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ActionDate { get; set; }
Public Property ActionDate As String
    Get
    Set
public:
property String^ ActionDate {
    String^ get ();
    void set (String^ value);
}


ActionTime Property

ActionTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► ActionTime
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ActionTime { get; set; }
Public Property ActionTime As String
    Get
    Set
public:
property String^ ActionTime {
    String^ get ();
    void set (String^ value);
}


ErrorReasonCode Property

ErrorReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► ErrorReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorReasonCode { get; set; }
Public Property ErrorReasonCode As String
    Get
    Set
public:
property String^ ErrorReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► TimeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► STS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SUM Class

SUM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM
RDPCrystal EDI Library
Academic Summary
Declaration Syntax
C# Visual Basic Visual C++
public class SUM : DocumentSegment
Public Class SUM _
    Inherits DocumentSegment
public ref class SUM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SUM()()()() | Initializes a new instance of the SUM class
 | AcademicCreditTypeCode | Element 1
 | AcademicGradeOrCourseLevelCode | Element 2
 | AcademicGradePointAverage | Element 9
 | AcademicSummarySource | Element 18
 | ClassRank | Element 11
 | DateTimePeriod | Element 14
 | DateTimePeriodFormatQualifier | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfDays | Element 15
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 5
 | Quantity2 | Element 6
 | Quantity3 | Element 12
 | Quantity4 | Element 16
 | Quantity5 | Element 17
 | RangeMaximum | Element 8
 | RangeMinimum | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
 | YesNoConditionOrResponseCode1 | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SUM


SUM Constructor

SUM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► SUM()()()()
RDPCrystal EDI Library
Initializes a new instance of the SUM class
Declaration Syntax
C# Visual Basic Visual C++
public SUM()
Public Sub New
public:
SUM()


AcademicCreditTypeCode Property

AcademicCreditTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► AcademicCreditTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicCreditTypeCode { get; set; }
Public Property AcademicCreditTypeCode As String
    Get
    Set
public:
property String^ AcademicCreditTypeCode {
    String^ get ();
    void set (String^ value);
}


AcademicGradeOrCourseLevelCode Property

AcademicGradeOrCourseLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► AcademicGradeOrCourseLevelCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradeOrCourseLevelCode { get; set; }
Public Property AcademicGradeOrCourseLevelCode As String
    Get
    Set
public:
property String^ AcademicGradeOrCourseLevelCode {
    String^ get ();
    void set (String^ value);
}


AcademicGradePointAverage Property

AcademicGradePointAverage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► AcademicGradePointAverage
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicGradePointAverage { get; set; }
Public Property AcademicGradePointAverage As String
    Get
    Set
public:
property String^ AcademicGradePointAverage {
    String^ get ();
    void set (String^ value);
}


AcademicSummarySource Property

AcademicSummarySource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► AcademicSummarySource
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string AcademicSummarySource { get; set; }
Public Property AcademicSummarySource As String
    Get
    Set
public:
property String^ AcademicSummarySource {
    String^ get ();
    void set (String^ value);
}


ClassRank Property

ClassRank Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► ClassRank
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ClassRank { get; set; }
Public Property ClassRank As String
    Get
    Set
public:
property String^ ClassRank {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► DateTimePeriod
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfDays Property

NumberOfDays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► NumberOfDays
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfDays { get; set; }
Public Property NumberOfDays As String
    Get
    Set
public:
property String^ NumberOfDays {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Quantity2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Quantity3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Quantity4
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Quantity5
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► RangeMaximum
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► RangeMinimum
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUM ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


SUP Class

SUP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP
RDPCrystal EDI Library
Supplementary Information
Declaration Syntax
C# Visual Basic Visual C++
public class SUP : DocumentSegment
Public Class SUP _
    Inherits DocumentSegment
public ref class SUP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SUP()()()() | Initializes a new instance of the SUP class
 | CertificationClauseCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrintOptionCode | Element 4
 | SupplementaryInformationQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SUP


SUP Constructor

SUP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► SUP()()()()
RDPCrystal EDI Library
Initializes a new instance of the SUP class
Declaration Syntax
C# Visual Basic Visual C++
public SUP()
Public Sub New
public:
SUP()


CertificationClauseCode Property

CertificationClauseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► CertificationClauseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationClauseCode { get; set; }
Public Property CertificationClauseCode As String
    Get
    Set
public:
property String^ CertificationClauseCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► FreeFormMessage
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrintOptionCode Property

PrintOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► PrintOptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PrintOptionCode { get; set; }
Public Property PrintOptionCode As String
    Get
    Set
public:
property String^ PrintOptionCode {
    String^ get ();
    void set (String^ value);
}


SupplementaryInformationQualifier Property

SupplementaryInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► SupplementaryInformationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SupplementaryInformationQualifier { get; set; }
Public Property SupplementaryInformationQualifier As String
    Get
    Set
public:
property String^ SupplementaryInformationQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SUP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SV Class

SV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV
RDPCrystal EDI Library
Service Description
Declaration Syntax
C# Visual Basic Visual C++
public class SV : DocumentSegment
Public Class SV _
    Inherits DocumentSegment
public ref class SV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV()()()() | Initializes a new instance of the SV class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceStandard | Element 2
 | ServiceStandard1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceOfferedCode | Element 4
 | UnitOfTimePeriodOrInterval | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV


SV Constructor

SV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► SV()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV class
Declaration Syntax
C# Visual Basic Visual C++
public SV()
Public Sub New
public:
SV()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ServiceStandard Property

ServiceStandard Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► ServiceStandard
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceStandard { get; set; }
Public Property ServiceStandard As String
    Get
    Set
public:
property String^ ServiceStandard {
    String^ get ();
    void set (String^ value);
}


ServiceStandard1 Property

ServiceStandard1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► ServiceStandard1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceStandard1 { get; set; }
Public Property ServiceStandard1 As String
    Get
    Set
public:
property String^ ServiceStandard1 {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceOfferedCode Property

TypeOfServiceOfferedCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► TypeOfServiceOfferedCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceOfferedCode { get; set; }
Public Property TypeOfServiceOfferedCode As String
    Get
    Set
public:
property String^ TypeOfServiceOfferedCode {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SV1 Class

SV1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1
RDPCrystal EDI Library
Professional Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV1 : DocumentSegment
Public Class SV1 _
    Inherits DocumentSegment
public ref class SV1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV1()()()() | Initializes a new instance of the SV1 class
 | CompositeDiagnosisCodePointer | Element 7
 | CompositeMedicalProcedureIdentifier | Element 1
 | CopayStatusCode | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareProfessionalShortageAreaCode | Element 16
 | LevelOfCareCode | Element 20
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 8
 | MonetaryAmount2 | Element 19
 | MultipleProcedureCode | Element 10
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NationalOrLocalAssignedReviewValue | Element 14
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 18
 | ProviderAgreementCode | Element 21
 | Quantity | Element 4
 | ReferenceIdentification | Element 17
 | ReviewCode | Element 13
 | ServiceTypeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
 | YesNoConditionOrResponseCode1 | Element 11
 | YesNoConditionOrResponseCode2 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV1


SV1 Constructor

SV1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► SV1()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV1 class
Declaration Syntax
C# Visual Basic Visual C++
public SV1()
Public Sub New
public:
SV1()


CompositeDiagnosisCodePointer Property

CompositeDiagnosisCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► CompositeDiagnosisCodePointer
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosisCodePointer CompositeDiagnosisCodePointer { get; set; }
Public Property CompositeDiagnosisCodePointer As CompositeDiagnosisCodePointer
    Get
    Set
public:
property CompositeDiagnosisCodePointer^ CompositeDiagnosisCodePointer {
    CompositeDiagnosisCodePointer^ get ();
    void set (CompositeDiagnosisCodePointer^ value);
}


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► CopayStatusCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► FacilityCodeValue
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}


HealthCareProfessionalShortageAreaCode Property

HealthCareProfessionalShortageAreaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► HealthCareProfessionalShortageAreaCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string HealthCareProfessionalShortageAreaCode { get; set; }
Public Property HealthCareProfessionalShortageAreaCode As String
    Get
    Set
public:
property String^ HealthCareProfessionalShortageAreaCode {
    String^ get ();
    void set (String^ value);
}


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► LevelOfCareCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► MonetaryAmount1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► MonetaryAmount2
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MultipleProcedureCode Property

MultipleProcedureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► MultipleProcedureCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MultipleProcedureCode { get; set; }
Public Property MultipleProcedureCode As String
    Get
    Set
public:
property String^ MultipleProcedureCode {
    String^ get ();
    void set (String^ value);
}


NationalOrLocalAssignedReviewValue Property

NationalOrLocalAssignedReviewValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► NationalOrLocalAssignedReviewValue
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string NationalOrLocalAssignedReviewValue { get; set; }
Public Property NationalOrLocalAssignedReviewValue As String
    Get
    Set
public:
property String^ NationalOrLocalAssignedReviewValue {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► PostalCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► ProviderAgreementCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReviewCode Property

ReviewCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► ReviewCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReviewCode { get; set; }
Public Property ReviewCode As String
    Get
    Set
public:
property String^ ReviewCode {
    String^ get ();
    void set (String^ value);
}


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► ServiceTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV1 ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


SV2 Class

SV2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2
RDPCrystal EDI Library
Institutional Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV2 : DocumentSegment
Public Class SV2 _
    Inherits DocumentSegment
public ref class SV2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV2()()()() | Initializes a new instance of the SV2 class
 | CompositeMedicalProcedureIdentifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelOfCareCode | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | MonetaryAmount1 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NursingHomeResidentialStatusCode | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 1
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | UnitRate | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV2


SV2 Constructor

SV2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► SV2()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV2 class
Declaration Syntax
C# Visual Basic Visual C++
public SV2()
Public Sub New
public:
SV2()


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► LevelOfCareCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► MonetaryAmount1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


NursingHomeResidentialStatusCode Property

NursingHomeResidentialStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► NursingHomeResidentialStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string NursingHomeResidentialStatusCode { get; set; }
Public Property NursingHomeResidentialStatusCode As String
    Get
    Set
public:
property String^ NursingHomeResidentialStatusCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► ProductServiceID
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitRate Property

UnitRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► UnitRate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitRate { get; set; }
Public Property UnitRate As String
    Get
    Set
public:
property String^ UnitRate {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV2 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SV3 Class

SV3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3
RDPCrystal EDI Library
Dental Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV3 : DocumentSegment
Public Class SV3 _
    Inherits DocumentSegment
public ref class SV3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV3()()()() | Initializes a new instance of the SV3 class
 | CompositeDiagnosisCodePointer | Element 11
 | CompositeMedicalProcedureIdentifier | Element 1
 | CopayStatusCode | Element 8
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OralCavityDesignation | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProsthesisCrownOrInlayCode | Element 5
 | ProviderAgreementCode | Element 9
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV3


SV3 Constructor

SV3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► SV3()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV3 class
Declaration Syntax
C# Visual Basic Visual C++
public SV3()
Public Sub New
public:
SV3()


CompositeDiagnosisCodePointer Property

CompositeDiagnosisCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► CompositeDiagnosisCodePointer
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosisCodePointer CompositeDiagnosisCodePointer { get; set; }
Public Property CompositeDiagnosisCodePointer As CompositeDiagnosisCodePointer
    Get
    Set
public:
property CompositeDiagnosisCodePointer^ CompositeDiagnosisCodePointer {
    CompositeDiagnosisCodePointer^ get ();
    void set (CompositeDiagnosisCodePointer^ value);
}


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► CopayStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► FacilityCodeValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


OralCavityDesignation Property

OralCavityDesignation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► OralCavityDesignation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public OralCavityDesignation OralCavityDesignation { get; set; }
Public Property OralCavityDesignation As OralCavityDesignation
    Get
    Set
public:
property OralCavityDesignation^ OralCavityDesignation {
    OralCavityDesignation^ get ();
    void set (OralCavityDesignation^ value);
}


ProsthesisCrownOrInlayCode Property

ProsthesisCrownOrInlayCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► ProsthesisCrownOrInlayCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProsthesisCrownOrInlayCode { get; set; }
Public Property ProsthesisCrownOrInlayCode As String
    Get
    Set
public:
property String^ ProsthesisCrownOrInlayCode {
    String^ get ();
    void set (String^ value);
}


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► ProviderAgreementCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV3 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SV4 Class

SV4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4
RDPCrystal EDI Library
Drug Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV4 : DocumentSegment
Public Class SV4 _
    Inherits DocumentSegment
public ref class SV4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV4()()()() | Initializes a new instance of the SV4 class
 | BasisOfCostDeterminationCode | Element 12
 | BasisOfDaysSupplyDeterminationCode | Element 13
 | CompositeMedicalProcedureIdentifier | Element 2
 | CopayStatusCode | Element 15
 | Description | Element 8
 | DispenseAsWrittenCode | Element 5
 | DosageFormCode | Element 14
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelOfCareCode | Element 17
 | LevelOfServiceCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientLocationCode | Element 16
 | PrescriptionOriginCode | Element 7
 | PriorAuthorizationTypeCode | Element 18
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitDoseCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
 | YesNoConditionOrResponseCode1 | Element 9
 | YesNoConditionOrResponseCode2 | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV4


SV4 Constructor

SV4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► SV4()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV4 class
Declaration Syntax
C# Visual Basic Visual C++
public SV4()
Public Sub New
public:
SV4()


BasisOfCostDeterminationCode Property

BasisOfCostDeterminationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► BasisOfCostDeterminationCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfCostDeterminationCode { get; set; }
Public Property BasisOfCostDeterminationCode As String
    Get
    Set
public:
property String^ BasisOfCostDeterminationCode {
    String^ get ();
    void set (String^ value);
}


BasisOfDaysSupplyDeterminationCode Property

BasisOfDaysSupplyDeterminationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► BasisOfDaysSupplyDeterminationCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfDaysSupplyDeterminationCode { get; set; }
Public Property BasisOfDaysSupplyDeterminationCode As String
    Get
    Set
public:
property String^ BasisOfDaysSupplyDeterminationCode {
    String^ get ();
    void set (String^ value);
}


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► CopayStatusCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► Description
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DispenseAsWrittenCode Property

DispenseAsWrittenCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► DispenseAsWrittenCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DispenseAsWrittenCode { get; set; }
Public Property DispenseAsWrittenCode As String
    Get
    Set
public:
property String^ DispenseAsWrittenCode {
    String^ get ();
    void set (String^ value);
}


DosageFormCode Property

DosageFormCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► DosageFormCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string DosageFormCode { get; set; }
Public Property DosageFormCode As String
    Get
    Set
public:
property String^ DosageFormCode {
    String^ get ();
    void set (String^ value);
}


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► LevelOfCareCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}


LevelOfServiceCode Property

LevelOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► LevelOfServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfServiceCode { get; set; }
Public Property LevelOfServiceCode As String
    Get
    Set
public:
property String^ LevelOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PatientLocationCode Property

PatientLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► PatientLocationCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string PatientLocationCode { get; set; }
Public Property PatientLocationCode As String
    Get
    Set
public:
property String^ PatientLocationCode {
    String^ get ();
    void set (String^ value);
}


PrescriptionOriginCode Property

PrescriptionOriginCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► PrescriptionOriginCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PrescriptionOriginCode { get; set; }
Public Property PrescriptionOriginCode As String
    Get
    Set
public:
property String^ PrescriptionOriginCode {
    String^ get ();
    void set (String^ value);
}


PriorAuthorizationTypeCode Property

PriorAuthorizationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► PriorAuthorizationTypeCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string PriorAuthorizationTypeCode { get; set; }
Public Property PriorAuthorizationTypeCode As String
    Get
    Set
public:
property String^ PriorAuthorizationTypeCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


UnitDoseCode Property

UnitDoseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► UnitDoseCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitDoseCode { get; set; }
Public Property UnitDoseCode As String
    Get
    Set
public:
property String^ UnitDoseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV4 ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


SV5 Class

SV5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5
RDPCrystal EDI Library
Durable Medical Equipment Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV5 : DocumentSegment
Public Class SV5 _
    Inherits DocumentSegment
public ref class SV5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV5()()()() | Initializes a new instance of the SV5 class
 | CompositeMedicalProcedureIdentifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrognosisCode | Element 7
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV5


SV5 Constructor

SV5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► SV5()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV5 class
Declaration Syntax
C# Visual Basic Visual C++
public SV5()
Public Sub New
public:
SV5()


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► FrequencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► PrognosisCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SV6 Class

SV6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6
RDPCrystal EDI Library
Anesthesia Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV6 : DocumentSegment
Public Class SV6 _
    Inherits DocumentSegment
public ref class SV6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV6()()()() | Initializes a new instance of the SV6 class
 | CompositeDiagnosis | Element 5
 | CompositeMedicalProcedureIdentifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeQualifier | Element 2
 | FacilityCodeValue | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 4
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV6


SV6 Constructor

SV6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► SV6()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV6 class
Declaration Syntax
C# Visual Basic Visual C++
public SV6()
Public Sub New
public:
SV6()


CompositeDiagnosis Property

CompositeDiagnosis Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► CompositeDiagnosis
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CompositeDiagnosis { get; set; }
Public Property CompositeDiagnosis As String
    Get
    Set
public:
property String^ CompositeDiagnosis {
    String^ get ();
    void set (String^ value);
}


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


FacilityCodeQualifier Property

FacilityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► FacilityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeQualifier { get; set; }
Public Property FacilityCodeQualifier As String
    Get
    Set
public:
property String^ FacilityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► FacilityCodeValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► MonetaryAmount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV6 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SV7 Class

SV7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7
RDPCrystal EDI Library
Drug Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class SV7 : DocumentSegment
Public Class SV7 _
    Inherits DocumentSegment
public ref class SV7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV7()()()() | Initializes a new instance of the SV7 class
 | CoverageLevelCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrescriptionDenialOverrideCode | Element 3
 | ProductProcessCharacteristicCode | Element 5
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 6
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV7


SV7 Constructor

SV7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► SV7()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV7 class
Declaration Syntax
C# Visual Basic Visual C++
public SV7()
Public Sub New
public:
SV7()


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► CoverageLevelCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrescriptionDenialOverrideCode Property

PrescriptionDenialOverrideCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► PrescriptionDenialOverrideCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PrescriptionDenialOverrideCode { get; set; }
Public Property PrescriptionDenialOverrideCode As String
    Get
    Set
public:
property String^ PrescriptionDenialOverrideCode {
    String^ get ();
    void set (String^ value);
}


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► ReferenceIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SV7 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


SVA Class

SVA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA
RDPCrystal EDI Library
Security Value
Declaration Syntax
C# Visual Basic Visual C++
public class SVA : DocumentSegment
Public Class SVA _
    Inherits DocumentSegment
public ref class SVA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVA()()()() | Initializes a new instance of the SVA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterIDCode | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SecurityValue | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVA


SVA Constructor

SVA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA ► SVA()()()()
RDPCrystal EDI Library
Initializes a new instance of the SVA class
Declaration Syntax
C# Visual Basic Visual C++
public SVA()
Public Sub New
public:
SVA()


FilterIDCode Property

FilterIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA ► FilterIDCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FilterIDCode { get; set; }
Public Property FilterIDCode As String
    Get
    Set
public:
property String^ FilterIDCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SecurityValue Property

SecurityValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA ► SecurityValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public SecurityValue SecurityValue { get; set; }
Public Property SecurityValue As SecurityValue
    Get
    Set
public:
property SecurityValue^ SecurityValue {
    SecurityValue^ get ();
    void set (SecurityValue^ value);
}


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA ► VersionIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SVC Class

SVC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC
RDPCrystal EDI Library
Service Information
Declaration Syntax
C# Visual Basic Visual C++
public class SVC : DocumentSegment
Public Class SVC _
    Inherits DocumentSegment
public ref class SVC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVC()()()() | Initializes a new instance of the SVC class
 | CompositeMedicalProcedureIdentifier | Element 1
 | CompositeMedicalProcedureIdentifier1 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | Quantity | Element 5
 | Quantity1 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVC


SVC Constructor

SVC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► SVC()()()()
RDPCrystal EDI Library
Initializes a new instance of the SVC class
Declaration Syntax
C# Visual Basic Visual C++
public SVC()
Public Sub New
public:
SVC()


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


CompositeMedicalProcedureIdentifier1 Property

CompositeMedicalProcedureIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► CompositeMedicalProcedureIdentifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier1 { get; set; }
Public Property CompositeMedicalProcedureIdentifier1 As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier1 {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SVD Class

SVD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD
RDPCrystal EDI Library
Service Line Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class SVD : DocumentSegment
Public Class SVD _
    Inherits DocumentSegment
public ref class SVD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVD()()()() | Initializes a new instance of the SVD class
 | AssignedNumber | Element 6
 | CompositeMedicalProcedureIdentifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVD


SVD Constructor

SVD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► SVD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SVD class
Declaration Syntax
C# Visual Basic Visual C++
public SVD()
Public Sub New
public:
SVD()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► AssignedNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► IdentificationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SVD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


SW Class

SW Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW
RDPCrystal EDI Library
Switching Charges
Declaration Syntax
C# Visual Basic Visual C++
public class SW : DocumentSegment
Public Class SW _
    Inherits DocumentSegment
public ref class SW : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SW()()()() | Initializes a new instance of the SW class
 | AssignedNumber | Element 9
 | ConditionCode | Element 3
 | ConditionSegmentLogicalConnector | Element 2
 | ConditionValue | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rate | Element 7
 | RateValueQualifier | Element 6
 | Rule260JunctionCode | Element 8
 | StandardCarrierAlphaCode | Element 5
 | TariffApplicationCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SW


SW Constructor

SW Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► SW()()()()
RDPCrystal EDI Library
Initializes a new instance of the SW class
Declaration Syntax
C# Visual Basic Visual C++
public SW()
Public Sub New
public:
SW()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► AssignedNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


ConditionCode Property

ConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► ConditionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionCode { get; set; }
Public Property ConditionCode As String
    Get
    Set
public:
property String^ ConditionCode {
    String^ get ();
    void set (String^ value);
}


ConditionSegmentLogicalConnector Property

ConditionSegmentLogicalConnector Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► ConditionSegmentLogicalConnector
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionSegmentLogicalConnector { get; set; }
Public Property ConditionSegmentLogicalConnector As String
    Get
    Set
public:
property String^ ConditionSegmentLogicalConnector {
    String^ get ();
    void set (String^ value);
}


ConditionValue Property

ConditionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► ConditionValue
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue { get; set; }
Public Property ConditionValue As String
    Get
    Set
public:
property String^ ConditionValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► Rate
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► RateValueQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


Rule260JunctionCode Property

Rule260JunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► Rule260JunctionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Rule260JunctionCode { get; set; }
Public Property Rule260JunctionCode As String
    Get
    Set
public:
property String^ Rule260JunctionCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TariffApplicationCode Property

TariffApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► TariffApplicationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TariffApplicationCode { get; set; }
Public Property TariffApplicationCode As String
    Get
    Set
public:
property String^ TariffApplicationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► SW ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


T1 Class

T1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1
RDPCrystal EDI Library
Transit Inbound Origin
Declaration Syntax
C# Visual Basic Visual C++
public class T1 : DocumentSegment
Public Class T1 _
    Inherits DocumentSegment
public ref class T1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | T1()()()() | Initializes a new instance of the T1 class
 | AssignedNumber | Element 1
 | CityName | Element 5
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 4
 | StandardPointLocationCode | Element 7
 | StateOrProvinceCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransitLevelCode | Element 9
 | TransitRegistrationNumber | Element 8
 | WaybillNumber | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | T1


T1 Constructor

T1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► T1()()()()
RDPCrystal EDI Library
Initializes a new instance of the T1 class
Declaration Syntax
C# Visual Basic Visual C++
public T1()
Public Sub New
public:
T1()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► CityName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TransitLevelCode Property

TransitLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► TransitLevelCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TransitLevelCode { get; set; }
Public Property TransitLevelCode As String
    Get
    Set
public:
property String^ TransitLevelCode {
    String^ get ();
    void set (String^ value);
}


TransitRegistrationNumber Property

TransitRegistrationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► TransitRegistrationNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TransitRegistrationNumber { get; set; }
Public Property TransitRegistrationNumber As String
    Get
    Set
public:
property String^ TransitRegistrationNumber {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► WaybillNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


T2 Class

T2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2
RDPCrystal EDI Library
Transit Inbound Lading
Declaration Syntax
C# Visual Basic Visual C++
public class T2 : DocumentSegment
Public Class T2 _
    Inherits DocumentSegment
public ref class T2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | T2()()()() | Initializes a new instance of the T2 class
 | AssignedNumber | Element 1
 | CityName | Element 9
 | CityName1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 5
 | FreightRate1 | Element 7
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaidInSurchargePercent | Element 12
 | RateValueQualifier | Element 6
 | RateValueQualifier1 | Element 8
 | ThroughSurchargePercent | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 3
 | WeightQualifier | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | T2


T2 Constructor

T2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► T2()()()()
RDPCrystal EDI Library
Initializes a new instance of the T2 class
Declaration Syntax
C# Visual Basic Visual C++
public T2()
Public Sub New
public:
T2()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► CityName
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► CityName1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► FreightRate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRate1 Property

FreightRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► FreightRate1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate1 { get; set; }
Public Property FreightRate1 As String
    Get
    Set
public:
property String^ FreightRate1 {
    String^ get ();
    void set (String^ value);
}


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► LadingDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PaidInSurchargePercent Property

PaidInSurchargePercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► PaidInSurchargePercent
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PaidInSurchargePercent { get; set; }
Public Property PaidInSurchargePercent As String
    Get
    Set
public:
property String^ PaidInSurchargePercent {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► RateValueQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► RateValueQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


ThroughSurchargePercent Property

ThroughSurchargePercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► ThroughSurchargePercent
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ThroughSurchargePercent { get; set; }
Public Property ThroughSurchargePercent As String
    Get
    Set
public:
property String^ ThroughSurchargePercent {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► WeightQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


T3 Class

T3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3
RDPCrystal EDI Library
Transit Inbound Route
Declaration Syntax
C# Visual Basic Visual C++
public class T3 : DocumentSegment
Public Class T3 _
    Inherits DocumentSegment
public ref class T3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | T3()()()() | Initializes a new instance of the T3 class
 | AssignedNumber | Element 1
 | CityName | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 6
 | EquipmentNumber | Element 7
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RoutingSequenceCode | Element 3
 | StandardCarrierAlphaCode | Element 2
 | StandardPointLocationCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | T3


T3 Constructor

T3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► T3()()()()
RDPCrystal EDI Library
Initializes a new instance of the T3 class
Declaration Syntax
C# Visual Basic Visual C++
public T3()
Public Sub New
public:
T3()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► EquipmentInitial
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► EquipmentNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► RoutingSequenceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


T6 Class

T6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6
RDPCrystal EDI Library
Transit Inbound Rates
Declaration Syntax
C# Visual Basic Visual C++
public class T6 : DocumentSegment
Public Class T6 _
    Inherits DocumentSegment
public ref class T6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | T6()()()() | Initializes a new instance of the T6 class
 | AssignedNumber | Element 1
 | CityName | Element 4
 | CityName1 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 2
 | FreightRate1 | Element 5
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 3
 | RateValueQualifier1 | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | T6


T6 Constructor

T6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► T6()()()()
RDPCrystal EDI Library
Initializes a new instance of the T6 class
Declaration Syntax
C# Visual Basic Visual C++
public T6()
Public Sub New
public:
T6()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► CityName1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► FreightRate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


FreightRate1 Property

FreightRate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► FreightRate1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate1 { get; set; }
Public Property FreightRate1 As String
    Get
    Set
public:
property String^ FreightRate1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► RateValueQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


RateValueQualifier1 Property

RateValueQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► RateValueQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier1 { get; set; }
Public Property RateValueQualifier1 As String
    Get
    Set
public:
property String^ RateValueQualifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


T8 Class

T8 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T8
RDPCrystal EDI Library
Free-form Transit Data
Declaration Syntax
C# Visual Basic Visual C++
public class T8 : DocumentSegment
Public Class T8 _
    Inherits DocumentSegment
public ref class T8 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | T8()()()() | Initializes a new instance of the T8 class
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformTransitData | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | T8


T8 Constructor

T8 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T8 ► T8()()()()
RDPCrystal EDI Library
Initializes a new instance of the T8 class
Declaration Syntax
C# Visual Basic Visual C++
public T8()
Public Sub New
public:
T8()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T8 ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


FreeformTransitData Property

FreeformTransitData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T8 ► FreeformTransitData
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformTransitData { get; set; }
Public Property FreeformTransitData As String
    Get
    Set
public:
property String^ FreeformTransitData {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T8 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► T8 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TA1 Class

TA1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1
RDPCrystal EDI Library
Interchange Acknowledgment
Declaration Syntax
C# Visual Basic Visual C++
public class TA1 : DocumentSegment
Public Class TA1 _
    Inherits DocumentSegment
public ref class TA1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TA1()()()() | Initializes a new instance of the TA1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeAcknowledgmentCode | Element 4
 | InterchangeControlNumber | Element 1
 | InterchangeDate | Element 2
 | InterchangeNoteCode | Element 5
 | InterchangeTime | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TA1


TA1 Constructor

TA1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► TA1()()()()
RDPCrystal EDI Library
Initializes a new instance of the TA1 class
Declaration Syntax
C# Visual Basic Visual C++
public TA1()
Public Sub New
public:
TA1()


InterchangeAcknowledgmentCode Property

InterchangeAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► InterchangeAcknowledgmentCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeAcknowledgmentCode { get; set; }
Public Property InterchangeAcknowledgmentCode As String
    Get
    Set
public:
property String^ InterchangeAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► InterchangeControlNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}


InterchangeDate Property

InterchangeDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► InterchangeDate
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeDate { get; set; }
Public Property InterchangeDate As String
    Get
    Set
public:
property String^ InterchangeDate {
    String^ get ();
    void set (String^ value);
}


InterchangeNoteCode Property

InterchangeNoteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► InterchangeNoteCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeNoteCode { get; set; }
Public Property InterchangeNoteCode As String
    Get
    Set
public:
property String^ InterchangeNoteCode {
    String^ get ();
    void set (String^ value);
}


InterchangeTime Property

InterchangeTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► InterchangeTime
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTime { get; set; }
Public Property InterchangeTime As String
    Get
    Set
public:
property String^ InterchangeTime {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TA3 Class

TA3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3
RDPCrystal EDI Library
Interchange Delivery Notice Segment
Declaration Syntax
C# Visual Basic Visual C++
public class TA3 : DocumentSegment
Public Class TA3 _
    Inherits DocumentSegment
public ref class TA3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TA3()()()() | Initializes a new instance of the TA3 class
 | ActionCode | Element 12
 | ActionCode1 | Element 15
 | ActionDate | Element 13
 | ActionDate1 | Element 16
 | ActionTime | Element 14
 | ActionTime1 | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorReasonCode | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstReferenceID | Element 19
 | FirstReferenceIDQualifier | Element 18
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceCode | Element 23
 | ReferenceCode1 | Element 25
 | ReferenceCode2 | Element 27
 | ReferenceCodeQualifier | Element 22
 | ReferenceCodeQualifier1 | Element 24
 | ReferenceCodeQualifier2 | Element 26
 | ReportedControlNumber | Element 5
 | ReportedDate | Element 6
 | ReportedInterchangeReceiverIDQualifier | Element 10
 | ReportedInterchangeSenderIDQualifier | Element 8
 | ReportedReceiverID | Element 11
 | ReportedSenderID | Element 9
 | ReportedStartSegmentID | Element 4
 | ReportedTime | Element 7
 | SecondReferenceID | Element 21
 | SecondReferenceIDQualifier | Element 20
 | ServiceRequestHandlerID | Element 2
 | ServiceRequestHandlerIDQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TA3


TA3 Constructor

TA3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► TA3()()()()
RDPCrystal EDI Library
Initializes a new instance of the TA3 class
Declaration Syntax
C# Visual Basic Visual C++
public TA3()
Public Sub New
public:
TA3()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ActionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ActionCode1 Property

ActionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ActionCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode1 { get; set; }
Public Property ActionCode1 As String
    Get
    Set
public:
property String^ ActionCode1 {
    String^ get ();
    void set (String^ value);
}


ActionDate Property

ActionDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ActionDate
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ActionDate { get; set; }
Public Property ActionDate As String
    Get
    Set
public:
property String^ ActionDate {
    String^ get ();
    void set (String^ value);
}


ActionDate1 Property

ActionDate1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ActionDate1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ActionDate1 { get; set; }
Public Property ActionDate1 As String
    Get
    Set
public:
property String^ ActionDate1 {
    String^ get ();
    void set (String^ value);
}


ActionTime Property

ActionTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ActionTime
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ActionTime { get; set; }
Public Property ActionTime As String
    Get
    Set
public:
property String^ ActionTime {
    String^ get ();
    void set (String^ value);
}


ActionTime1 Property

ActionTime1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ActionTime1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ActionTime1 { get; set; }
Public Property ActionTime1 As String
    Get
    Set
public:
property String^ ActionTime1 {
    String^ get ();
    void set (String^ value);
}


ErrorReasonCode Property

ErrorReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ErrorReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorReasonCode { get; set; }
Public Property ErrorReasonCode As String
    Get
    Set
public:
property String^ ErrorReasonCode {
    String^ get ();
    void set (String^ value);
}


FirstReferenceID Property

FirstReferenceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► FirstReferenceID
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string FirstReferenceID { get; set; }
Public Property FirstReferenceID As String
    Get
    Set
public:
property String^ FirstReferenceID {
    String^ get ();
    void set (String^ value);
}


FirstReferenceIDQualifier Property

FirstReferenceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► FirstReferenceIDQualifier
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string FirstReferenceIDQualifier { get; set; }
Public Property FirstReferenceIDQualifier As String
    Get
    Set
public:
property String^ FirstReferenceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceCode Property

ReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReferenceCode
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceCode { get; set; }
Public Property ReferenceCode As String
    Get
    Set
public:
property String^ ReferenceCode {
    String^ get ();
    void set (String^ value);
}


ReferenceCode1 Property

ReferenceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReferenceCode1
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceCode1 { get; set; }
Public Property ReferenceCode1 As String
    Get
    Set
public:
property String^ ReferenceCode1 {
    String^ get ();
    void set (String^ value);
}


ReferenceCode2 Property

ReferenceCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReferenceCode2
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceCode2 { get; set; }
Public Property ReferenceCode2 As String
    Get
    Set
public:
property String^ ReferenceCode2 {
    String^ get ();
    void set (String^ value);
}


ReferenceCodeQualifier Property

ReferenceCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReferenceCodeQualifier
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceCodeQualifier { get; set; }
Public Property ReferenceCodeQualifier As String
    Get
    Set
public:
property String^ ReferenceCodeQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceCodeQualifier1 Property

ReferenceCodeQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReferenceCodeQualifier1
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceCodeQualifier1 { get; set; }
Public Property ReferenceCodeQualifier1 As String
    Get
    Set
public:
property String^ ReferenceCodeQualifier1 {
    String^ get ();
    void set (String^ value);
}


ReferenceCodeQualifier2 Property

ReferenceCodeQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReferenceCodeQualifier2
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceCodeQualifier2 { get; set; }
Public Property ReferenceCodeQualifier2 As String
    Get
    Set
public:
property String^ ReferenceCodeQualifier2 {
    String^ get ();
    void set (String^ value);
}


ReportedControlNumber Property

ReportedControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedControlNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedControlNumber { get; set; }
Public Property ReportedControlNumber As String
    Get
    Set
public:
property String^ ReportedControlNumber {
    String^ get ();
    void set (String^ value);
}


ReportedDate Property

ReportedDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedDate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedDate { get; set; }
Public Property ReportedDate As String
    Get
    Set
public:
property String^ ReportedDate {
    String^ get ();
    void set (String^ value);
}


ReportedInterchangeReceiverIDQualifier Property

ReportedInterchangeReceiverIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedInterchangeReceiverIDQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedInterchangeReceiverIDQualifier { get; set; }
Public Property ReportedInterchangeReceiverIDQualifier As String
    Get
    Set
public:
property String^ ReportedInterchangeReceiverIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReportedInterchangeSenderIDQualifier Property

ReportedInterchangeSenderIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedInterchangeSenderIDQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedInterchangeSenderIDQualifier { get; set; }
Public Property ReportedInterchangeSenderIDQualifier As String
    Get
    Set
public:
property String^ ReportedInterchangeSenderIDQualifier {
    String^ get ();
    void set (String^ value);
}


ReportedReceiverID Property

ReportedReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedReceiverID
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedReceiverID { get; set; }
Public Property ReportedReceiverID As String
    Get
    Set
public:
property String^ ReportedReceiverID {
    String^ get ();
    void set (String^ value);
}


ReportedSenderID Property

ReportedSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedSenderID
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedSenderID { get; set; }
Public Property ReportedSenderID As String
    Get
    Set
public:
property String^ ReportedSenderID {
    String^ get ();
    void set (String^ value);
}


ReportedStartSegmentID Property

ReportedStartSegmentID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedStartSegmentID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedStartSegmentID { get; set; }
Public Property ReportedStartSegmentID As String
    Get
    Set
public:
property String^ ReportedStartSegmentID {
    String^ get ();
    void set (String^ value);
}


ReportedTime Property

ReportedTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ReportedTime
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReportedTime { get; set; }
Public Property ReportedTime As String
    Get
    Set
public:
property String^ ReportedTime {
    String^ get ();
    void set (String^ value);
}


SecondReferenceID Property

SecondReferenceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► SecondReferenceID
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string SecondReferenceID { get; set; }
Public Property SecondReferenceID As String
    Get
    Set
public:
property String^ SecondReferenceID {
    String^ get ();
    void set (String^ value);
}


SecondReferenceIDQualifier Property

SecondReferenceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► SecondReferenceIDQualifier
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string SecondReferenceIDQualifier { get; set; }
Public Property SecondReferenceIDQualifier As String
    Get
    Set
public:
property String^ SecondReferenceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ServiceRequestHandlerID Property

ServiceRequestHandlerID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ServiceRequestHandlerID
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceRequestHandlerID { get; set; }
Public Property ServiceRequestHandlerID As String
    Get
    Set
public:
property String^ ServiceRequestHandlerID {
    String^ get ();
    void set (String^ value);
}


ServiceRequestHandlerIDQualifier Property

ServiceRequestHandlerIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► ServiceRequestHandlerIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceRequestHandlerIDQualifier { get; set; }
Public Property ServiceRequestHandlerIDQualifier As String
    Get
    Set
public:
property String^ ServiceRequestHandlerIDQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TA3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TAX Class

TAX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX
RDPCrystal EDI Library
Tax Reference
Declaration Syntax
C# Visual Basic Visual C++
public class TAX : DocumentSegment
Public Class TAX _
    Inherits DocumentSegment
public ref class TAX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TAX()()()() | Initializes a new instance of the TAX class
 | CustomsEntryTypeGroupCode | Element 13
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 3
 | LocationIdentifier1 | Element 5
 | LocationIdentifier2 | Element 7
 | LocationIdentifier3 | Element 9
 | LocationIdentifier4 | Element 11
 | LocationQualifier | Element 2
 | LocationQualifier1 | Element 4
 | LocationQualifier2 | Element 6
 | LocationQualifier3 | Element 8
 | LocationQualifier4 | Element 10
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TaxExemptCode | Element 12
 | TaxIdentificationNumber | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TAX


TAX Constructor

TAX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► TAX()()()()
RDPCrystal EDI Library
Initializes a new instance of the TAX class
Declaration Syntax
C# Visual Basic Visual C++
public TAX()
Public Sub New
public:
TAX()


CustomsEntryTypeGroupCode Property

CustomsEntryTypeGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► CustomsEntryTypeGroupCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryTypeGroupCode { get; set; }
Public Property CustomsEntryTypeGroupCode As String
    Get
    Set
public:
property String^ CustomsEntryTypeGroupCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationIdentifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier2 Property

LocationIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationIdentifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier2 { get; set; }
Public Property LocationIdentifier2 As String
    Get
    Set
public:
property String^ LocationIdentifier2 {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier3 Property

LocationIdentifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationIdentifier3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier3 { get; set; }
Public Property LocationIdentifier3 As String
    Get
    Set
public:
property String^ LocationIdentifier3 {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier4 Property

LocationIdentifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationIdentifier4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier4 { get; set; }
Public Property LocationIdentifier4 As String
    Get
    Set
public:
property String^ LocationIdentifier4 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier1 Property

LocationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationQualifier1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier1 { get; set; }
Public Property LocationQualifier1 As String
    Get
    Set
public:
property String^ LocationQualifier1 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier2 Property

LocationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationQualifier2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier2 { get; set; }
Public Property LocationQualifier2 As String
    Get
    Set
public:
property String^ LocationQualifier2 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier3 Property

LocationQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationQualifier3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier3 { get; set; }
Public Property LocationQualifier3 As String
    Get
    Set
public:
property String^ LocationQualifier3 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier4 Property

LocationQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► LocationQualifier4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier4 { get; set; }
Public Property LocationQualifier4 As String
    Get
    Set
public:
property String^ LocationQualifier4 {
    String^ get ();
    void set (String^ value);
}


TaxExemptCode Property

TaxExemptCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► TaxExemptCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TaxExemptCode { get; set; }
Public Property TaxExemptCode As String
    Get
    Set
public:
property String^ TaxExemptCode {
    String^ get ();
    void set (String^ value);
}


TaxIdentificationNumber Property

TaxIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► TaxIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TaxIdentificationNumber { get; set; }
Public Property TaxIdentificationNumber As String
    Get
    Set
public:
property String^ TaxIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TAX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TaxFieldIdentification Class

TaxFieldIdentification Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TaxFieldIdentification
RDPCrystal EDI Library
C037
Declaration Syntax
C# Visual Basic Visual C++
public class TaxFieldIdentification : DocumentCompositeElement
Public Class TaxFieldIdentification _
    Inherits DocumentCompositeElement
public ref class TaxFieldIdentification : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxFieldIdentification()()()() | Initializes a new instance of the TaxFieldIdentification class
 | ApplicationErrorConditionCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaxInformationIdentificationNumber | Element 1
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | TaxFieldIdentification


TaxFieldIdentification Constructor

TaxFieldIdentification Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TaxFieldIdentification ► TaxFieldIdentification()()()()
RDPCrystal EDI Library
Initializes a new instance of the TaxFieldIdentification class
Declaration Syntax
C# Visual Basic Visual C++
public TaxFieldIdentification()
Public Sub New
public:
TaxFieldIdentification()


ApplicationErrorConditionCode Property

ApplicationErrorConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TaxFieldIdentification ► ApplicationErrorConditionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode { get; set; }
Public Property ApplicationErrorConditionCode As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode {
    String^ get ();
    void set (String^ value);
}


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TaxFieldIdentification ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TaxFieldIdentification ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


TaxInformationIdentificationNumber Property

TaxInformationIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TaxFieldIdentification ► TaxInformationIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TaxInformationIdentificationNumber { get; set; }
Public Property TaxInformationIdentificationNumber As String
    Get
    Set
public:
property String^ TaxInformationIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


TBA Class

TBA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA
RDPCrystal EDI Library
Temporary Buydown Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class TBA : DocumentSegment
Public Class TBA _
    Inherits DocumentSegment
public ref class TBA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TBA()()()() | Initializes a new instance of the TBA class
 | CompositeUnitOfMeasure | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TBA


TBA Constructor

TBA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA ► TBA()()()()
RDPCrystal EDI Library
Initializes a new instance of the TBA class
Declaration Syntax
C# Visual Basic Visual C++
public TBA()
Public Sub New
public:
TBA()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TBI Class

TBI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI
RDPCrystal EDI Library
Trade Line Bureau Identifier
Declaration Syntax
C# Visual Basic Visual C++
public class TBI : DocumentSegment
Public Class TBI _
    Inherits DocumentSegment
public ref class TBI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TBI()()()() | Initializes a new instance of the TBI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 3
 | ReferenceIdentification2 | Element 4
 | ReferenceIdentification3 | Element 5
 | ReferenceIdentification4 | Element 6
 | ReferenceIdentification5 | Element 7
 | ReferenceIdentification6 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TBI


TBI Constructor

TBI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► TBI()()()()
RDPCrystal EDI Library
Initializes a new instance of the TBI class
Declaration Syntax
C# Visual Basic Visual C++
public TBI()
Public Sub New
public:
TBI()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► IdentificationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification5 Property

ReferenceIdentification5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification5
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification5 { get; set; }
Public Property ReferenceIdentification5 As String
    Get
    Set
public:
property String^ ReferenceIdentification5 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification6 Property

ReferenceIdentification6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► ReferenceIdentification6
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification6 { get; set; }
Public Property ReferenceIdentification6 As String
    Get
    Set
public:
property String^ ReferenceIdentification6 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TBI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TC2 Class

TC2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TC2
RDPCrystal EDI Library
Commodity
Declaration Syntax
C# Visual Basic Visual C++
public class TC2 : DocumentSegment
Public Class TC2 _
    Inherits DocumentSegment
public ref class TC2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TC2()()()() | Initializes a new instance of the TC2 class
 | CommodityCode | Element 2
 | CommodityCodeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TC2


TC2 Constructor

TC2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TC2 ► TC2()()()()
RDPCrystal EDI Library
Initializes a new instance of the TC2 class
Declaration Syntax
C# Visual Basic Visual C++
public TC2()
Public Sub New
public:
TC2()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TC2 ► CommodityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TC2 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TC2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TC2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TCD Class

TCD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD
RDPCrystal EDI Library
Itemized Call Detail
Declaration Syntax
C# Visual Basic Visual C++
public class TCD : DocumentSegment
Public Class TCD _
    Inherits DocumentSegment
public ref class TCD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TCD()()()() | Initializes a new instance of the TCD class
 | AssignedIdentification | Element 1
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 5
 | LocationIdentifier1 | Element 8
 | LocationQualifier | Element 4
 | LocationQualifier1 | Element 7
 | MeasurementValue | Element 10
 | MeasurementValue1 | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 12
 | MonetaryAmount1 | Element 13
 | MonetaryAmount2 | Element 14
 | MonetaryAmount3 | Element 15
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RelationshipCode | Element 16
 | StateOrProvinceCode | Element 6
 | StateOrProvinceCode1 | Element 9
 | Time | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TCD


TCD Constructor

TCD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► TCD()()()()
RDPCrystal EDI Library
Initializes a new instance of the TCD class
Declaration Syntax
C# Visual Basic Visual C++
public TCD()
Public Sub New
public:
TCD()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► LocationIdentifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► LocationIdentifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► LocationQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier1 Property

LocationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► LocationQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier1 { get; set; }
Public Property LocationQualifier1 As String
    Get
    Set
public:
property String^ LocationQualifier1 {
    String^ get ();
    void set (String^ value);
}


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► MeasurementValue
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}


MeasurementValue1 Property

MeasurementValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► MeasurementValue1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue1 { get; set; }
Public Property MeasurementValue1 As String
    Get
    Set
public:
property String^ MeasurementValue1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► MonetaryAmount
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► MonetaryAmount1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► MonetaryAmount2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► MonetaryAmount3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


RelationshipCode Property

RelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► RelationshipCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipCode { get; set; }
Public Property RelationshipCode As String
    Get
    Set
public:
property String^ RelationshipCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► StateOrProvinceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TCD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TD1 Class

TD1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1
RDPCrystal EDI Library
Carrier Details (Quantity and Weight)
Declaration Syntax
C# Visual Basic Visual C++
public class TD1 : DocumentSegment
Public Class TD1 _
    Inherits DocumentSegment
public ref class TD1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TD1()()()() | Initializes a new instance of the TD1 class
 | CommodityCode | Element 4
 | CommodityCodeQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingDescription | Element 5
 | LadingQuantity | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PackagingCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 8
 | UnitOrBasisForMeasurementCode1 | Element 10
 | Volume | Element 9
 | Weight | Element 7
 | WeightQualifier | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TD1


TD1 Constructor

TD1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► TD1()()()()
RDPCrystal EDI Library
Initializes a new instance of the TD1 class
Declaration Syntax
C# Visual Basic Visual C++
public TD1()
Public Sub New
public:
TD1()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► CommodityCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


LadingDescription Property

LadingDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► LadingDescription
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LadingDescription { get; set; }
Public Property LadingDescription As String
    Get
    Set
public:
property String^ LadingDescription {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► LadingQuantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PackagingCode Property

PackagingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► PackagingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PackagingCode { get; set; }
Public Property PackagingCode As String
    Get
    Set
public:
property String^ PackagingCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► Volume
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► Weight
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► WeightQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TD3 Class

TD3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3
RDPCrystal EDI Library
Carrier Details (Equipment)
Declaration Syntax
C# Visual Basic Visual C++
public class TD3 : DocumentSegment
Public Class TD3 _
    Inherits DocumentSegment
public ref class TD3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TD3()()()() | Initializes a new instance of the TD3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 1
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | EquipmentType | Element 10
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OwnershipCode | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SealNumber | Element 9
 | SealStatusCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 6
 | Weight | Element 5
 | WeightQualifier | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TD3


TD3 Constructor

TD3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► TD3()()()()
RDPCrystal EDI Library
Initializes a new instance of the TD3 class
Declaration Syntax
C# Visual Basic Visual C++
public TD3()
Public Sub New
public:
TD3()


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► EquipmentType
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OwnershipCode Property

OwnershipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► OwnershipCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string OwnershipCode { get; set; }
Public Property OwnershipCode As String
    Get
    Set
public:
property String^ OwnershipCode {
    String^ get ();
    void set (String^ value);
}


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► SealNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealStatusCode Property

SealStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► SealStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SealStatusCode { get; set; }
Public Property SealStatusCode As String
    Get
    Set
public:
property String^ SealStatusCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► Weight
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► WeightQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TD4 Class

TD4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4
RDPCrystal EDI Library
Carrier Details (Special Handling, or Hazardous Materials, or Both)
Declaration Syntax
C# Visual Basic Visual C++
public class TD4 : DocumentSegment
Public Class TD4 _
    Inherits DocumentSegment
public ref class TD4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TD4()()()() | Initializes a new instance of the TD4 class
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousMaterialClassCode | Element 3
 | HazardousMaterialCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 5
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TD4


TD4 Constructor

TD4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► TD4()()()()
RDPCrystal EDI Library
Initializes a new instance of the TD4 class
Declaration Syntax
C# Visual Basic Visual C++
public TD4()
Public Sub New
public:
TD4()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialClassCode Property

HazardousMaterialClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► HazardousMaterialClassCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialClassCode { get; set; }
Public Property HazardousMaterialClassCode As String
    Get
    Set
public:
property String^ HazardousMaterialClassCode {
    String^ get ();
    void set (String^ value);
}


HazardousMaterialCodeQualifier Property

HazardousMaterialCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► HazardousMaterialCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousMaterialCodeQualifier { get; set; }
Public Property HazardousMaterialCodeQualifier As String
    Get
    Set
public:
property String^ HazardousMaterialCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD4 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


TD5 Class

TD5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5
RDPCrystal EDI Library
Carrier Details (Routing Sequence/Transit Time)
Declaration Syntax
C# Visual Basic Visual C++
public class TD5 : DocumentSegment
Public Class TD5 _
    Inherits DocumentSegment
public ref class TD5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TD5()()()() | Initializes a new instance of the TD5 class
 | CountryCode | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 8
 | LocationQualifier | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Routing | Element 5
 | RoutingSequenceCode | Element 1
 | ServiceLevelCode | Element 12
 | ServiceLevelCode1 | Element 13
 | ServiceLevelCode2 | Element 14
 | ShipmentOrderStatusCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransitDirectionCode | Element 9
 | TransitTime | Element 11
 | TransitTimeDirectionQualifier | Element 10
 | TransportationMethodTypeCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TD5


TD5 Constructor

TD5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► TD5()()()()
RDPCrystal EDI Library
Initializes a new instance of the TD5 class
Declaration Syntax
C# Visual Basic Visual C++
public TD5()
Public Sub New
public:
TD5()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► CountryCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► LocationIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► LocationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► Routing
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


RoutingSequenceCode Property

RoutingSequenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► RoutingSequenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RoutingSequenceCode { get; set; }
Public Property RoutingSequenceCode As String
    Get
    Set
public:
property String^ RoutingSequenceCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode Property

ServiceLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► ServiceLevelCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode { get; set; }
Public Property ServiceLevelCode As String
    Get
    Set
public:
property String^ ServiceLevelCode {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode1 Property

ServiceLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► ServiceLevelCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode1 { get; set; }
Public Property ServiceLevelCode1 As String
    Get
    Set
public:
property String^ ServiceLevelCode1 {
    String^ get ();
    void set (String^ value);
}


ServiceLevelCode2 Property

ServiceLevelCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► ServiceLevelCode2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLevelCode2 { get; set; }
Public Property ServiceLevelCode2 As String
    Get
    Set
public:
property String^ ServiceLevelCode2 {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


TransitDirectionCode Property

TransitDirectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► TransitDirectionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TransitDirectionCode { get; set; }
Public Property TransitDirectionCode As String
    Get
    Set
public:
property String^ TransitDirectionCode {
    String^ get ();
    void set (String^ value);
}


TransitTime Property

TransitTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► TransitTime
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransitTime { get; set; }
Public Property TransitTime As String
    Get
    Set
public:
property String^ TransitTime {
    String^ get ();
    void set (String^ value);
}


TransitTimeDirectionQualifier Property

TransitTimeDirectionQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► TransitTimeDirectionQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TransitTimeDirectionQualifier { get; set; }
Public Property TransitTimeDirectionQualifier As String
    Get
    Set
public:
property String^ TransitTimeDirectionQualifier {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TD5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TDS Class

TDS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS
RDPCrystal EDI Library
Total Monetary Value Summary
Declaration Syntax
C# Visual Basic Visual C++
public class TDS : DocumentSegment
Public Class TDS _
    Inherits DocumentSegment
public ref class TDS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TDS()()()() | Initializes a new instance of the TDS class
 | Amount | Element 1
 | Amount1 | Element 2
 | Amount2 | Element 3
 | Amount3 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TDS


TDS Constructor

TDS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► TDS()()()()
RDPCrystal EDI Library
Initializes a new instance of the TDS class
Declaration Syntax
C# Visual Basic Visual C++
public TDS()
Public Sub New
public:
TDS()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► Amount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► Amount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


Amount2 Property

Amount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► Amount2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount2 { get; set; }
Public Property Amount2 As String
    Get
    Set
public:
property String^ Amount2 {
    String^ get ();
    void set (String^ value);
}


Amount3 Property

Amount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► Amount3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount3 { get; set; }
Public Property Amount3 As String
    Get
    Set
public:
property String^ Amount3 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TDS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TED Class

TED Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED
RDPCrystal EDI Library
Technical Error Description
Declaration Syntax
C# Visual Basic Visual C++
public class TED : DocumentSegment
Public Class TED _
    Inherits DocumentSegment
public ref class TED : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TED()()()() | Initializes a new instance of the TED class
 | ApplicationErrorConditionCode | Element 1
 | CopyOfBadDataElement | Element 7
 | DataElementNewContent | Element 8
 | DataElementReferenceNumber | Element 6
 | ElementPositionInSegment | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SegmentIDCode | Element 3
 | SegmentPositionInTransactionSet | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TED


TED Constructor

TED Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► TED()()()()
RDPCrystal EDI Library
Initializes a new instance of the TED class
Declaration Syntax
C# Visual Basic Visual C++
public TED()
Public Sub New
public:
TED()


ApplicationErrorConditionCode Property

ApplicationErrorConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► ApplicationErrorConditionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode { get; set; }
Public Property ApplicationErrorConditionCode As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode {
    String^ get ();
    void set (String^ value);
}


CopyOfBadDataElement Property

CopyOfBadDataElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► CopyOfBadDataElement
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CopyOfBadDataElement { get; set; }
Public Property CopyOfBadDataElement As String
    Get
    Set
public:
property String^ CopyOfBadDataElement {
    String^ get ();
    void set (String^ value);
}


DataElementNewContent Property

DataElementNewContent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► DataElementNewContent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementNewContent { get; set; }
Public Property DataElementNewContent As String
    Get
    Set
public:
property String^ DataElementNewContent {
    String^ get ();
    void set (String^ value);
}


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► DataElementReferenceNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}


ElementPositionInSegment Property

ElementPositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► ElementPositionInSegment
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ElementPositionInSegment { get; set; }
Public Property ElementPositionInSegment As String
    Get
    Set
public:
property String^ ElementPositionInSegment {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► FreeFormMessage
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► SegmentIDCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}


SegmentPositionInTransactionSet Property

SegmentPositionInTransactionSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► SegmentPositionInTransactionSet
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentPositionInTransactionSet { get; set; }
Public Property SegmentPositionInTransactionSet As String
    Get
    Set
public:
property String^ SegmentPositionInTransactionSet {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TED ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TEM Class

TEM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM
RDPCrystal EDI Library
Pick-up Totals
Declaration Syntax
C# Visual Basic Visual C++
public class TEM : DocumentSegment
Public Class TEM _
    Inherits DocumentSegment
public ref class TEM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TEM()()()() | Initializes a new instance of the TEM class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | Quantity1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 4
 | WeightUnitCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TEM


TEM Constructor

TEM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► TEM()()()()
RDPCrystal EDI Library
Initializes a new instance of the TEM class
Declaration Syntax
C# Visual Basic Visual C++
public TEM()
Public Sub New
public:
TEM()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► Quantity1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► WeightUnitCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TEM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TER Class

TER Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER
RDPCrystal EDI Library
Territory
Declaration Syntax
C# Visual Basic Visual C++
public class TER : DocumentSegment
Public Class TER _
    Inherits DocumentSegment
public ref class TER : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TER()()()() | Initializes a new instance of the TER class
 | ClassOfTradeCode | Element 1
 | CountryCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 3
 | GeneralTerritoryCode | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TER


TER Constructor

TER Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► TER()()()()
RDPCrystal EDI Library
Initializes a new instance of the TER class
Declaration Syntax
C# Visual Basic Visual C++
public TER()
Public Sub New
public:
TER()


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► ClassOfTradeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► FreeFormMessageText
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


GeneralTerritoryCode Property

GeneralTerritoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► GeneralTerritoryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string GeneralTerritoryCode { get; set; }
Public Property GeneralTerritoryCode As String
    Get
    Set
public:
property String^ GeneralTerritoryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TER ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TF Class

TF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF
RDPCrystal EDI Library
Tariff Information
Declaration Syntax
C# Visual Basic Visual C++
public class TF : DocumentSegment
Public Class TF _
    Inherits DocumentSegment
public ref class TF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TF()()()() | Initializes a new instance of the TF class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TariffAgencyCode | Element 1
 | TariffNumber | Element 2
 | TariffNumberSuffix | Element 3
 | TariffSupplementIdentifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TF


TF Constructor

TF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► TF()()()()
RDPCrystal EDI Library
Initializes a new instance of the TF class
Declaration Syntax
C# Visual Basic Visual C++
public TF()
Public Sub New
public:
TF()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TariffAgencyCode Property

TariffAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► TariffAgencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAgencyCode { get; set; }
Public Property TariffAgencyCode As String
    Get
    Set
public:
property String^ TariffAgencyCode {
    String^ get ();
    void set (String^ value);
}


TariffNumber Property

TariffNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► TariffNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumber { get; set; }
Public Property TariffNumber As String
    Get
    Set
public:
property String^ TariffNumber {
    String^ get ();
    void set (String^ value);
}


TariffNumberSuffix Property

TariffNumberSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► TariffNumberSuffix
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumberSuffix { get; set; }
Public Property TariffNumberSuffix As String
    Get
    Set
public:
property String^ TariffNumberSuffix {
    String^ get ();
    void set (String^ value);
}


TariffSupplementIdentifier Property

TariffSupplementIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► TariffSupplementIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSupplementIdentifier { get; set; }
Public Property TariffSupplementIdentifier As String
    Get
    Set
public:
property String^ TariffSupplementIdentifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TFA Class

TFA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA
RDPCrystal EDI Library
Tariff Adjustments
Declaration Syntax
C# Visual Basic Visual C++
public class TFA : DocumentSegment
Public Class TFA _
    Inherits DocumentSegment
public ref class TFA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TFA()()()() | Initializes a new instance of the TFA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 1
 | TariffAdjustmentValueAmount | Element 2
 | TariffAdjustmentValueAmount1 | Element 3
 | TariffAdjustmentValueAmount10 | Element 12
 | TariffAdjustmentValueAmount11 | Element 13
 | TariffAdjustmentValueAmount12 | Element 14
 | TariffAdjustmentValueAmount13 | Element 15
 | TariffAdjustmentValueAmount14 | Element 16
 | TariffAdjustmentValueAmount15 | Element 17
 | TariffAdjustmentValueAmount2 | Element 4
 | TariffAdjustmentValueAmount3 | Element 5
 | TariffAdjustmentValueAmount4 | Element 6
 | TariffAdjustmentValueAmount5 | Element 7
 | TariffAdjustmentValueAmount6 | Element 8
 | TariffAdjustmentValueAmount7 | Element 9
 | TariffAdjustmentValueAmount8 | Element 10
 | TariffAdjustmentValueAmount9 | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TFA


TFA Constructor

TFA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TFA()()()()
RDPCrystal EDI Library
Initializes a new instance of the TFA class
Declaration Syntax
C# Visual Basic Visual C++
public TFA()
Public Sub New
public:
TFA()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount Property

TariffAdjustmentValueAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount { get; set; }
Public Property TariffAdjustmentValueAmount As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount1 Property

TariffAdjustmentValueAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount1 { get; set; }
Public Property TariffAdjustmentValueAmount1 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount1 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount10 Property

TariffAdjustmentValueAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount10
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount10 { get; set; }
Public Property TariffAdjustmentValueAmount10 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount10 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount11 Property

TariffAdjustmentValueAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount11
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount11 { get; set; }
Public Property TariffAdjustmentValueAmount11 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount11 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount12 Property

TariffAdjustmentValueAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount12
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount12 { get; set; }
Public Property TariffAdjustmentValueAmount12 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount12 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount13 Property

TariffAdjustmentValueAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount13
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount13 { get; set; }
Public Property TariffAdjustmentValueAmount13 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount13 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount14 Property

TariffAdjustmentValueAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount14
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount14 { get; set; }
Public Property TariffAdjustmentValueAmount14 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount14 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount15 Property

TariffAdjustmentValueAmount15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount15
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount15 { get; set; }
Public Property TariffAdjustmentValueAmount15 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount15 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount2 Property

TariffAdjustmentValueAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount2 { get; set; }
Public Property TariffAdjustmentValueAmount2 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount2 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount3 Property

TariffAdjustmentValueAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount3 { get; set; }
Public Property TariffAdjustmentValueAmount3 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount3 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount4 Property

TariffAdjustmentValueAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount4 { get; set; }
Public Property TariffAdjustmentValueAmount4 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount4 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount5 Property

TariffAdjustmentValueAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount5
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount5 { get; set; }
Public Property TariffAdjustmentValueAmount5 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount5 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount6 Property

TariffAdjustmentValueAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount6
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount6 { get; set; }
Public Property TariffAdjustmentValueAmount6 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount6 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount7 Property

TariffAdjustmentValueAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount7
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount7 { get; set; }
Public Property TariffAdjustmentValueAmount7 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount7 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount8 Property

TariffAdjustmentValueAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount8
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount8 { get; set; }
Public Property TariffAdjustmentValueAmount8 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount8 {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount9 Property

TariffAdjustmentValueAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► TariffAdjustmentValueAmount9
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount9 { get; set; }
Public Property TariffAdjustmentValueAmount9 As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount9 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TFD Class

TFD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFD
RDPCrystal EDI Library
Tariff Adjustments Minimum Charge
Declaration Syntax
C# Visual Basic Visual C++
public class TFD : DocumentSegment
Public Class TFD _
    Inherits DocumentSegment
public ref class TFD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TFD()()()() | Initializes a new instance of the TFD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 1
 | TariffAdjustmentValueAmount | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TFD


TFD Constructor

TFD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFD ► TFD()()()()
RDPCrystal EDI Library
Initializes a new instance of the TFD class
Declaration Syntax
C# Visual Basic Visual C++
public TFD()
Public Sub New
public:
TFD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFD ► RateValueQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


TariffAdjustmentValueAmount Property

TariffAdjustmentValueAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFD ► TariffAdjustmentValueAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAdjustmentValueAmount { get; set; }
Public Property TariffAdjustmentValueAmount As String
    Get
    Set
public:
property String^ TariffAdjustmentValueAmount {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TFM Class

TFM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFM
RDPCrystal EDI Library
Tariff Minimum Rates
Declaration Syntax
C# Visual Basic Visual C++
public class TFM : DocumentSegment
Public Class TFM _
    Inherits DocumentSegment
public ref class TFM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TFM()()()() | Initializes a new instance of the TFM class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightRate | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TFM


TFM Constructor

TFM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFM ► TFM()()()()
RDPCrystal EDI Library
Initializes a new instance of the TFM class
Declaration Syntax
C# Visual Basic Visual C++
public TFM()
Public Sub New
public:
TFM()


FreightRate Property

FreightRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFM ► FreightRate
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreightRate { get; set; }
Public Property FreightRate As String
    Get
    Set
public:
property String^ FreightRate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TFR Class

TFR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR
RDPCrystal EDI Library
Tariff Restrictions
Declaration Syntax
C# Visual Basic Visual C++
public class TFR : DocumentSegment
Public Class TFR _
    Inherits DocumentSegment
public ref class TFR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TFR()()()() | Initializes a new instance of the TFR class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TariffRestrictionDescription | Element 2
 | TariffRestrictionIDCode | Element 1
 | TariffRestrictionValue | Element 3
 | TariffRestrictionValue1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TFR


TFR Constructor

TFR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► TFR()()()()
RDPCrystal EDI Library
Initializes a new instance of the TFR class
Declaration Syntax
C# Visual Basic Visual C++
public TFR()
Public Sub New
public:
TFR()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TariffRestrictionDescription Property

TariffRestrictionDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► TariffRestrictionDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffRestrictionDescription { get; set; }
Public Property TariffRestrictionDescription As String
    Get
    Set
public:
property String^ TariffRestrictionDescription {
    String^ get ();
    void set (String^ value);
}


TariffRestrictionIDCode Property

TariffRestrictionIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► TariffRestrictionIDCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TariffRestrictionIDCode { get; set; }
Public Property TariffRestrictionIDCode As String
    Get
    Set
public:
property String^ TariffRestrictionIDCode {
    String^ get ();
    void set (String^ value);
}


TariffRestrictionValue Property

TariffRestrictionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► TariffRestrictionValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffRestrictionValue { get; set; }
Public Property TariffRestrictionValue As String
    Get
    Set
public:
property String^ TariffRestrictionValue {
    String^ get ();
    void set (String^ value);
}


TariffRestrictionValue1 Property

TariffRestrictionValue1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► TariffRestrictionValue1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffRestrictionValue1 { get; set; }
Public Property TariffRestrictionValue1 As String
    Get
    Set
public:
property String^ TariffRestrictionValue1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TFS Class

TFS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS
RDPCrystal EDI Library
Tax Form
Declaration Syntax
C# Visual Basic Visual C++
public class TFS : DocumentSegment
Public Class TFS _
    Inherits DocumentSegment
public ref class TFS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TFS()()()() | Initializes a new instance of the TFS class
 | Date | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 6
 | IdentificationCodeQualifier | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameControlIdentifier | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentificationQualifier1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TFS


TFS Constructor

TFS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► TFS()()()()
RDPCrystal EDI Library
Initializes a new instance of the TFS class
Declaration Syntax
C# Visual Basic Visual C++
public TFS()
Public Sub New
public:
TFS()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► IdentificationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NameControlIdentifier Property

NameControlIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► NameControlIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string NameControlIdentifier { get; set; }
Public Property NameControlIdentifier As String
    Get
    Set
public:
property String^ NameControlIdentifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TFS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


THE Class

THE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE
RDPCrystal EDI Library
Screen Theater Identification
Declaration Syntax
C# Visual Basic Visual C++
public class THE : DocumentSegment
Public Class THE _
    Inherits DocumentSegment
public ref class THE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | THE()()()() | Initializes a new instance of the THE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 5
 | ReferenceIdentification | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | THE


THE Constructor

THE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► THE()()()()
RDPCrystal EDI Library
Initializes a new instance of the THE class
Declaration Syntax
C# Visual Basic Visual C++
public THE()
Public Sub New
public:
THE()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► IdentificationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► THE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TI Class

TI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI
RDPCrystal EDI Library
Transport Information
Declaration Syntax
C# Visual Basic Visual C++
public class TI : DocumentSegment
Public Class TI _
    Inherits DocumentSegment
public ref class TI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TI()()()() | Initializes a new instance of the TI class
 | CarTypeCode | Element 7
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 3
 | EquipmentNumber | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SealStatusCode | Element 6
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TI


TI Constructor

TI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► TI()()()()
RDPCrystal EDI Library
Initializes a new instance of the TI class
Declaration Syntax
C# Visual Basic Visual C++
public TI()
Public Sub New
public:
TI()


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► CarTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► EquipmentInitial
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► EquipmentNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SealStatusCode Property

SealStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► SealStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SealStatusCode { get; set; }
Public Property SealStatusCode As String
    Get
    Set
public:
property String^ SealStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TIA Class

TIA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA
RDPCrystal EDI Library
Tax Information and Amount
Declaration Syntax
C# Visual Basic Visual C++
public class TIA : DocumentSegment
Public Class TIA _
    Inherits DocumentSegment
public ref class TIA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TIA()()()() | Initializes a new instance of the TIA class
 | CompositeUnitOfMeasure | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixedFormatInformation | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | MonetaryAmount1 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 6
 | Quantity | Element 4
 | TaxFieldIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TIA


TIA Constructor

TIA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► TIA()()()()
RDPCrystal EDI Library
Initializes a new instance of the TIA class
Declaration Syntax
C# Visual Basic Visual C++
public TIA()
Public Sub New
public:
TIA()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


FixedFormatInformation Property

FixedFormatInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► FixedFormatInformation
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation { get; set; }
Public Property FixedFormatInformation As String
    Get
    Set
public:
property String^ FixedFormatInformation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► MonetaryAmount1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► Percent
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


TaxFieldIdentification Property

TaxFieldIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► TaxFieldIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public TaxFieldIdentification TaxFieldIdentification { get; set; }
Public Property TaxFieldIdentification As TaxFieldIdentification
    Get
    Set
public:
property TaxFieldIdentification^ TaxFieldIdentification {
    TaxFieldIdentification^ get ();
    void set (TaxFieldIdentification^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TID Class

TID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID
RDPCrystal EDI Library
Task Identification
Declaration Syntax
C# Visual Basic Visual C++
public class TID : DocumentSegment
Public Class TID _
    Inherits DocumentSegment
public ref class TID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TID()()()() | Initializes a new instance of the TID class
 | ActionCode | Element 6
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Level | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 7
 | ReferenceIdentification1 | Element 8
 | RelationshipTaskIdentifier | Element 3
 | TaskIdentifier | Element 2
 | TaskIDQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WorkStatusCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TID


TID Constructor

TID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► TID()()()()
RDPCrystal EDI Library
Initializes a new instance of the TID class
Declaration Syntax
C# Visual Basic Visual C++
public TID()
Public Sub New
public:
TID()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► ActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Level Property

Level Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► Level
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Level { get; set; }
Public Property Level As String
    Get
    Set
public:
property String^ Level {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► ReferenceIdentification1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


RelationshipTaskIdentifier Property

RelationshipTaskIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► RelationshipTaskIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipTaskIdentifier { get; set; }
Public Property RelationshipTaskIdentifier As String
    Get
    Set
public:
property String^ RelationshipTaskIdentifier {
    String^ get ();
    void set (String^ value);
}


TaskIdentifier Property

TaskIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► TaskIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TaskIdentifier { get; set; }
Public Property TaskIdentifier As String
    Get
    Set
public:
property String^ TaskIdentifier {
    String^ get ();
    void set (String^ value);
}


TaskIDQualifier Property

TaskIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► TaskIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TaskIDQualifier { get; set; }
Public Property TaskIDQualifier As String
    Get
    Set
public:
property String^ TaskIDQualifier {
    String^ get ();
    void set (String^ value);
}


WorkStatusCode Property

WorkStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► WorkStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WorkStatusCode { get; set; }
Public Property WorkStatusCode As String
    Get
    Set
public:
property String^ WorkStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TIS Class

TIS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS
RDPCrystal EDI Library
Title Insurance Services
Declaration Syntax
C# Visual Basic Visual C++
public class TIS : DocumentSegment
Public Class TIS _
    Inherits DocumentSegment
public ref class TIS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TIS()()()() | Initializes a new instance of the TIS class
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | ProductServiceIDQualifier | Element 3
 | TitleInsuranceServicesCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TIS


TIS Constructor

TIS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► TIS()()()()
RDPCrystal EDI Library
Initializes a new instance of the TIS class
Declaration Syntax
C# Visual Basic Visual C++
public TIS()
Public Sub New
public:
TIS()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


TitleInsuranceServicesCode Property

TitleInsuranceServicesCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► TitleInsuranceServicesCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TitleInsuranceServicesCode { get; set; }
Public Property TitleInsuranceServicesCode As String
    Get
    Set
public:
property String^ TitleInsuranceServicesCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TIS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TLN Class

TLN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN
RDPCrystal EDI Library
Tradeline
Declaration Syntax
C# Visual Basic Visual C++
public class TLN : DocumentSegment
Public Class TLN _
    Inherits DocumentSegment
public ref class TLN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TLN()()()() | Initializes a new instance of the TLN class
 | AccountNumber | Element 1
 | DateTimePeriod | Element 13
 | DateTimePeriod1 | Element 17
 | DateTimePeriodFormatQualifier | Element 12
 | DateTimePeriodFormatQualifier1 | Element 16
 | Description | Element 22
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanTypeCode | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 14
 | MonetaryAmount1 | Element 18
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 7
 | Number1 | Element 21
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RatingCode | Element 9
 | RatingCode1 | Element 15
 | RatingCode2 | Element 19
 | RatingRemarksCode | Element 10
 | SourceOfDisclosureCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfAccountCode | Element 4
 | TypeOfAccountCode1 | Element 5
 | TypeOfCreditAccountCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
 | YesNoConditionOrResponseCode1 | Element 3
 | YesNoConditionOrResponseCode2 | Element 20
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TLN


TLN Constructor

TLN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► TLN()()()()
RDPCrystal EDI Library
Initializes a new instance of the TLN class
Declaration Syntax
C# Visual Basic Visual C++
public TLN()
Public Sub New
public:
TLN()


AccountNumber Property

AccountNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► AccountNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► DateTimePeriod
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► DateTimePeriod1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► Description
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanTypeCode Property

LoanTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► LoanTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LoanTypeCode { get; set; }
Public Property LoanTypeCode As String
    Get
    Set
public:
property String^ LoanTypeCode {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► MonetaryAmount
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► MonetaryAmount1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► Number
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► Number1
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


RatingCode Property

RatingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► RatingCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RatingCode { get; set; }
Public Property RatingCode As String
    Get
    Set
public:
property String^ RatingCode {
    String^ get ();
    void set (String^ value);
}


RatingCode1 Property

RatingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► RatingCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string RatingCode1 { get; set; }
Public Property RatingCode1 As String
    Get
    Set
public:
property String^ RatingCode1 {
    String^ get ();
    void set (String^ value);
}


RatingCode2 Property

RatingCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► RatingCode2
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string RatingCode2 { get; set; }
Public Property RatingCode2 As String
    Get
    Set
public:
property String^ RatingCode2 {
    String^ get ();
    void set (String^ value);
}


RatingRemarksCode Property

RatingRemarksCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► RatingRemarksCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string RatingRemarksCode { get; set; }
Public Property RatingRemarksCode As String
    Get
    Set
public:
property String^ RatingRemarksCode {
    String^ get ();
    void set (String^ value);
}


SourceOfDisclosureCode Property

SourceOfDisclosureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► SourceOfDisclosureCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string SourceOfDisclosureCode { get; set; }
Public Property SourceOfDisclosureCode As String
    Get
    Set
public:
property String^ SourceOfDisclosureCode {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode Property

TypeOfAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► TypeOfAccountCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode { get; set; }
Public Property TypeOfAccountCode As String
    Get
    Set
public:
property String^ TypeOfAccountCode {
    String^ get ();
    void set (String^ value);
}


TypeOfAccountCode1 Property

TypeOfAccountCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► TypeOfAccountCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfAccountCode1 { get; set; }
Public Property TypeOfAccountCode1 As String
    Get
    Set
public:
property String^ TypeOfAccountCode1 {
    String^ get ();
    void set (String^ value);
}


TypeOfCreditAccountCode Property

TypeOfCreditAccountCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► TypeOfCreditAccountCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfCreditAccountCode { get; set; }
Public Property TypeOfCreditAccountCode As String
    Get
    Set
public:
property String^ TypeOfCreditAccountCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TLN ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}


TMD Class

TMD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD
RDPCrystal EDI Library
Test Method
Declaration Syntax
C# Visual Basic Visual C++
public class TMD : DocumentSegment
Public Class TMD _
    Inherits DocumentSegment
public ref class TMD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TMD()()()() | Initializes a new instance of the TMD class
 | AgencyQualifierCode | Element 2
 | Date | Element 7
 | Description | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 3
 | ProductProcessCharacteristicCode | Element 1
 | ReferenceIdentification | Element 8
 | SourceSubqualifier | Element 9
 | TestAdministrationMethodCode | Element 4
 | TestMediumCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TMD


TMD Constructor

TMD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► TMD()()()()
RDPCrystal EDI Library
Initializes a new instance of the TMD class
Declaration Syntax
C# Visual Basic Visual C++
public TMD()
Public Sub New
public:
TMD()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► Date
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► Description
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► ProductDescriptionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► ReferenceIdentification
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► SourceSubqualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


TestAdministrationMethodCode Property

TestAdministrationMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► TestAdministrationMethodCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TestAdministrationMethodCode { get; set; }
Public Property TestAdministrationMethodCode As String
    Get
    Set
public:
property String^ TestAdministrationMethodCode {
    String^ get ();
    void set (String^ value);
}


TestMediumCode Property

TestMediumCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► TestMediumCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TestMediumCode { get; set; }
Public Property TestMediumCode As String
    Get
    Set
public:
property String^ TestMediumCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TMD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TOA Class

TOA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA
RDPCrystal EDI Library
Type of Activity
Declaration Syntax
C# Visual Basic Visual C++
public class TOA : DocumentSegment
Public Class TOA _
    Inherits DocumentSegment
public ref class TOA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TOA()()()() | Initializes a new instance of the TOA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LicenseTypeCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StatusCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfActivityCode | Element 1
 | TypeOfRatingCode | Element 4
 | TypeOfRatingCode1 | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TOA


TOA Constructor

TOA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► TOA()()()()
RDPCrystal EDI Library
Initializes a new instance of the TOA class
Declaration Syntax
C# Visual Basic Visual C++
public TOA()
Public Sub New
public:
TOA()


LicenseTypeCode Property

LicenseTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► LicenseTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LicenseTypeCode { get; set; }
Public Property LicenseTypeCode As String
    Get
    Set
public:
property String^ LicenseTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► StatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


TypeOfActivityCode Property

TypeOfActivityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► TypeOfActivityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfActivityCode { get; set; }
Public Property TypeOfActivityCode As String
    Get
    Set
public:
property String^ TypeOfActivityCode {
    String^ get ();
    void set (String^ value);
}


TypeOfRatingCode Property

TypeOfRatingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► TypeOfRatingCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRatingCode { get; set; }
Public Property TypeOfRatingCode As String
    Get
    Set
public:
property String^ TypeOfRatingCode {
    String^ get ();
    void set (String^ value);
}


TypeOfRatingCode1 Property

TypeOfRatingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► TypeOfRatingCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfRatingCode1 { get; set; }
Public Property TypeOfRatingCode1 As String
    Get
    Set
public:
property String^ TypeOfRatingCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TOO Class

TOO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO
RDPCrystal EDI Library
Tooth Identification
Declaration Syntax
C# Visual Basic Visual C++
public class TOO : DocumentSegment
Public Class TOO _
    Inherits DocumentSegment
public ref class TOO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TOO()()()() | Initializes a new instance of the TOO class
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToothCode | Element 2
 | ToothSurface | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TOO


TOO Constructor

TOO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO ► TOO()()()()
RDPCrystal EDI Library
Initializes a new instance of the TOO class
Declaration Syntax
C# Visual Basic Visual C++
public TOO()
Public Sub New
public:
TOO()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ToothCode Property

ToothCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO ► ToothCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ToothCode { get; set; }
Public Property ToothCode As String
    Get
    Set
public:
property String^ ToothCode {
    String^ get ();
    void set (String^ value);
}


ToothSurface Property

ToothSurface Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO ► ToothSurface
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public ToothSurface ToothSurface { get; set; }
Public Property ToothSurface As ToothSurface
    Get
    Set
public:
property ToothSurface^ ToothSurface {
    ToothSurface^ get ();
    void set (ToothSurface^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ToothSurface Class

ToothSurface Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface
RDPCrystal EDI Library
C005
Declaration Syntax
C# Visual Basic Visual C++
public class ToothSurface : DocumentCompositeElement
Public Class ToothSurface _
    Inherits DocumentCompositeElement
public ref class ToothSurface : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToothSurface()()()() | Initializes a new instance of the ToothSurface class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToothSurfaceCode |
 | ToothSurfaceCode1 |
 | ToothSurfaceCode2 |
 | ToothSurfaceCode3 |
 | ToothSurfaceCode4 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ToothSurface


ToothSurface Constructor

ToothSurface Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► ToothSurface()()()()
RDPCrystal EDI Library
Initializes a new instance of the ToothSurface class
Declaration Syntax
C# Visual Basic Visual C++
public ToothSurface()
Public Sub New
public:
ToothSurface()


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)


ToothSurfaceCode Property

ToothSurfaceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► ToothSurfaceCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode { get; set; }
Public Property ToothSurfaceCode As String
    Get
    Set
public:
property String^ ToothSurfaceCode {
    String^ get ();
    void set (String^ value);
}


ToothSurfaceCode1 Property

ToothSurfaceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► ToothSurfaceCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode1 { get; set; }
Public Property ToothSurfaceCode1 As String
    Get
    Set
public:
property String^ ToothSurfaceCode1 {
    String^ get ();
    void set (String^ value);
}


ToothSurfaceCode2 Property

ToothSurfaceCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► ToothSurfaceCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode2 { get; set; }
Public Property ToothSurfaceCode2 As String
    Get
    Set
public:
property String^ ToothSurfaceCode2 {
    String^ get ();
    void set (String^ value);
}


ToothSurfaceCode3 Property

ToothSurfaceCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► ToothSurfaceCode3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode3 { get; set; }
Public Property ToothSurfaceCode3 As String
    Get
    Set
public:
property String^ ToothSurfaceCode3 {
    String^ get ();
    void set (String^ value);
}


ToothSurfaceCode4 Property

ToothSurfaceCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ToothSurface ► ToothSurfaceCode4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode4 { get; set; }
Public Property ToothSurfaceCode4 As String
    Get
    Set
public:
property String^ ToothSurfaceCode4 {
    String^ get ();
    void set (String^ value);
}


TOV Class

TOV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV
RDPCrystal EDI Library
Vehicle Use Information
Declaration Syntax
C# Visual Basic Visual C++
public class TOV : DocumentSegment
Public Class TOV _
    Inherits DocumentSegment
public ref class TOV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TOV()()()() | Initializes a new instance of the TOV class
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | DateTimeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HazardousVehicleTypeCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | QuantityQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TOV


TOV Constructor

TOV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► TOV()()()()
RDPCrystal EDI Library
Initializes a new instance of the TOV class
Declaration Syntax
C# Visual Basic Visual C++
public TOV()
Public Sub New
public:
TOV()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► DateTimeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


HazardousVehicleTypeCode Property

HazardousVehicleTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► HazardousVehicleTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HazardousVehicleTypeCode { get; set; }
Public Property HazardousVehicleTypeCode As String
    Get
    Set
public:
property String^ HazardousVehicleTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► QuantityQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TOV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TPB Class

TPB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB
RDPCrystal EDI Library
Business Professional Title
Declaration Syntax
C# Visual Basic Visual C++
public class TPB : DocumentSegment
Public Class TPB _
    Inherits DocumentSegment
public ref class TPB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TPB()()()() | Initializes a new instance of the TPB class
 | AgencyQualifierCode | Element 3
 | BusinessProfessionalTitleCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SourceSubqualifier | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TPB


TPB Constructor

TPB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► TPB()()()()
RDPCrystal EDI Library
Initializes a new instance of the TPB class
Declaration Syntax
C# Visual Basic Visual C++
public TPB()
Public Sub New
public:
TPB()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► AgencyQualifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


BusinessProfessionalTitleCode Property

BusinessProfessionalTitleCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► BusinessProfessionalTitleCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessProfessionalTitleCode { get; set; }
Public Property BusinessProfessionalTitleCode As String
    Get
    Set
public:
property String^ BusinessProfessionalTitleCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► FreeFormMessageText
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► SourceSubqualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TPD Class

TPD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD
RDPCrystal EDI Library
Trading Partner Detail
Declaration Syntax
C# Visual Basic Visual C++
public class TPD : DocumentSegment
Public Class TPD _
    Inherits DocumentSegment
public ref class TPD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TPD()()()() | Initializes a new instance of the TPD class
 | CommodityCode | Element 3
 | CommodityCodeQualifier | Element 2
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemDescriptionType | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TPD


TPD Constructor

TPD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► TPD()()()()
RDPCrystal EDI Library
Initializes a new instance of the TPD class
Declaration Syntax
C# Visual Basic Visual C++
public TPD()
Public Sub New
public:
TPD()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ItemDescriptionType Property

ItemDescriptionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► ItemDescriptionType
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDescriptionType { get; set; }
Public Property ItemDescriptionType As String
    Get
    Set
public:
property String^ ItemDescriptionType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TPD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TRF Class

TRF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF
RDPCrystal EDI Library
Rating Factors
Declaration Syntax
C# Visual Basic Visual C++
public class TRF : DocumentSegment
Public Class TRF _
    Inherits DocumentSegment
public ref class TRF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TRF()()()() | Initializes a new instance of the TRF class
 | CompositeUnitOfMeasure | Element 2
 | CompositeUnitOfMeasure1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | Quantity1 | Element 5
 | QuantityQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TRF


TRF Constructor

TRF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► TRF()()()()
RDPCrystal EDI Library
Initializes a new instance of the TRF class
Declaration Syntax
C# Visual Basic Visual C++
public TRF()
Public Sub New
public:
TRF()


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TRN Class

TRN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN
RDPCrystal EDI Library
Trace
Declaration Syntax
C# Visual Basic Visual C++
public class TRN : DocumentSegment
Public Class TRN _
    Inherits DocumentSegment
public ref class TRN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TRN()()()() | Initializes a new instance of the TRN class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginatingCompanyIdentifier | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TraceTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TRN


TRN Constructor

TRN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► TRN()()()()
RDPCrystal EDI Library
Initializes a new instance of the TRN class
Declaration Syntax
C# Visual Basic Visual C++
public TRN()
Public Sub New
public:
TRN()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► OriginatingCompanyIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


TraceTypeCode Property

TraceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► TraceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TraceTypeCode { get; set; }
Public Property TraceTypeCode As String
    Get
    Set
public:
property String^ TraceTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TRS Class

TRS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS
RDPCrystal EDI Library
Tax Rate
Declaration Syntax
C# Visual Basic Visual C++
public class TRS : DocumentSegment
Public Class TRS _
    Inherits DocumentSegment
public ref class TRS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TRS()()()() | Initializes a new instance of the TRS class
 | ActionCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformDescription | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | RateApplicationCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TRS


TRS Constructor

TRS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► TRS()()()()
RDPCrystal EDI Library
Initializes a new instance of the TRS class
Declaration Syntax
C# Visual Basic Visual C++
public TRS()
Public Sub New
public:
TRS()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


FreeformDescription Property

FreeformDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► FreeformDescription
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformDescription { get; set; }
Public Property FreeformDescription As String
    Get
    Set
public:
property String^ FreeformDescription {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RateApplicationCode Property

RateApplicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► RateApplicationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateApplicationCode { get; set; }
Public Property RateApplicationCode As String
    Get
    Set
public:
property String^ RateApplicationCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TRS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


TS Class

TS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS
RDPCrystal EDI Library
Tariff Section
Declaration Syntax
C# Visual Basic Visual C++
public class TS : DocumentSegment
Public Class TS _
    Inherits DocumentSegment
public ref class TS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS()()()() | Initializes a new instance of the TS class
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 6
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RateValueQualifier | Element 5
 | TariffItemNumber | Element 2
 | TariffItemSuffix | Element 3
 | TariffSection | Element 1
 | TariffSectionIDCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS


TS Constructor

TS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► TS()()()()
RDPCrystal EDI Library
Initializes a new instance of the TS class
Declaration Syntax
C# Visual Basic Visual C++
public TS()
Public Sub New
public:
TS()


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RateValueQualifier Property

RateValueQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► RateValueQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RateValueQualifier { get; set; }
Public Property RateValueQualifier As String
    Get
    Set
public:
property String^ RateValueQualifier {
    String^ get ();
    void set (String^ value);
}


TariffItemNumber Property

TariffItemNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► TariffItemNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemNumber { get; set; }
Public Property TariffItemNumber As String
    Get
    Set
public:
property String^ TariffItemNumber {
    String^ get ();
    void set (String^ value);
}


TariffItemSuffix Property

TariffItemSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► TariffItemSuffix
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TariffItemSuffix { get; set; }
Public Property TariffItemSuffix As String
    Get
    Set
public:
property String^ TariffItemSuffix {
    String^ get ();
    void set (String^ value);
}


TariffSection Property

TariffSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► TariffSection
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSection { get; set; }
Public Property TariffSection As String
    Get
    Set
public:
property String^ TariffSection {
    String^ get ();
    void set (String^ value);
}


TariffSectionIDCode Property

TariffSectionIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► TariffSectionIDCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSectionIDCode { get; set; }
Public Property TariffSectionIDCode As String
    Get
    Set
public:
property String^ TariffSectionIDCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TS2 Class

TS2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2
RDPCrystal EDI Library
Transaction Supplemental Statistics
Declaration Syntax
C# Visual Basic Visual C++
public class TS2 : DocumentSegment
Public Class TS2 _
    Inherits DocumentSegment
public ref class TS2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS2()()()() | Initializes a new instance of the TS2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 1
 | MonetaryAmount1 | Element 2
 | MonetaryAmount10 | Element 18
 | MonetaryAmount11 | Element 19
 | MonetaryAmount2 | Element 3
 | MonetaryAmount3 | Element 4
 | MonetaryAmount4 | Element 5
 | MonetaryAmount5 | Element 6
 | MonetaryAmount6 | Element 8
 | MonetaryAmount7 | Element 9
 | MonetaryAmount8 | Element 15
 | MonetaryAmount9 | Element 17
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 7
 | Quantity1 | Element 10
 | Quantity2 | Element 11
 | Quantity3 | Element 12
 | Quantity4 | Element 13
 | Quantity5 | Element 14
 | Quantity6 | Element 16
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS2


TS2 Constructor

TS2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► TS2()()()()
RDPCrystal EDI Library
Initializes a new instance of the TS2 class
Declaration Syntax
C# Visual Basic Visual C++
public TS2()
Public Sub New
public:
TS2()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount10
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount11
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount5
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount6
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount7
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount8
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► MonetaryAmount9
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Quantity6
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TS3 Class

TS3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3
RDPCrystal EDI Library
Transaction Statistics
Declaration Syntax
C# Visual Basic Visual C++
public class TS3 : DocumentSegment
Public Class TS3 _
    Inherits DocumentSegment
public ref class TS3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS3()()()() | Initializes a new instance of the TS3 class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | MonetaryAmount1 | Element 6
 | MonetaryAmount10 | Element 15
 | MonetaryAmount11 | Element 16
 | MonetaryAmount12 | Element 17
 | MonetaryAmount13 | Element 18
 | MonetaryAmount14 | Element 19
 | MonetaryAmount15 | Element 20
 | MonetaryAmount16 | Element 21
 | MonetaryAmount17 | Element 22
 | MonetaryAmount18 | Element 24
 | MonetaryAmount2 | Element 7
 | MonetaryAmount3 | Element 8
 | MonetaryAmount4 | Element 9
 | MonetaryAmount5 | Element 10
 | MonetaryAmount6 | Element 11
 | MonetaryAmount7 | Element 12
 | MonetaryAmount8 | Element 13
 | MonetaryAmount9 | Element 14
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 23
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS3


TS3 Constructor

TS3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► TS3()()()()
RDPCrystal EDI Library
Initializes a new instance of the TS3 class
Declaration Syntax
C# Visual Basic Visual C++
public TS3()
Public Sub New
public:
TS3()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► FacilityCodeValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount10
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount11
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount12
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount13 Property

MonetaryAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount13
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount13 { get; set; }
Public Property MonetaryAmount13 As String
    Get
    Set
public:
property String^ MonetaryAmount13 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount14 Property

MonetaryAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount14
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount14 { get; set; }
Public Property MonetaryAmount14 As String
    Get
    Set
public:
property String^ MonetaryAmount14 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount15 Property

MonetaryAmount15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount15
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount15 { get; set; }
Public Property MonetaryAmount15 As String
    Get
    Set
public:
property String^ MonetaryAmount15 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount16 Property

MonetaryAmount16 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount16
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount16 { get; set; }
Public Property MonetaryAmount16 As String
    Get
    Set
public:
property String^ MonetaryAmount16 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount17 Property

MonetaryAmount17 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount17
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount17 { get; set; }
Public Property MonetaryAmount17 As String
    Get
    Set
public:
property String^ MonetaryAmount17 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount18 Property

MonetaryAmount18 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount18
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount18 { get; set; }
Public Property MonetaryAmount18 As String
    Get
    Set
public:
property String^ MonetaryAmount18 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount5
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount6
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount7
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount8
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► MonetaryAmount9
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► Quantity1
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TS3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TSD Class

TSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSD
RDPCrystal EDI Library
Trailer Shipment Details
Declaration Syntax
C# Visual Basic Visual C++
public class TSD : DocumentSegment
Public Class TSD _
    Inherits DocumentSegment
public ref class TSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TSD()()()() | Initializes a new instance of the TSD class
 | AssignedIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Position | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TSD


TSD Constructor

TSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSD ► TSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the TSD class
Declaration Syntax
C# Visual Basic Visual C++
public TSD()
Public Sub New
public:
TSD()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSD ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSD ► Position
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TSI Class

TSI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI
RDPCrystal EDI Library
Automatic Equipment Tag Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class TSI : DocumentSegment
Public Class TSI _
    Inherits DocumentSegment
public ref class TSI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TSI()()()() | Initializes a new instance of the TSI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | Quantity1 | Element 4
 | TagStatusCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TSI


TSI Constructor

TSI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► TSI()()()()
RDPCrystal EDI Library
Initializes a new instance of the TSI class
Declaration Syntax
C# Visual Basic Visual C++
public TSI()
Public Sub New
public:
TSI()


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


TagStatusCode Property

TagStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► TagStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TagStatusCode { get; set; }
Public Property TagStatusCode As String
    Get
    Set
public:
property String^ TagStatusCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TSP Class

TSP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP
RDPCrystal EDI Library
Test Period or Interval
Declaration Syntax
C# Visual Basic Visual C++
public class TSP : DocumentSegment
Public Class TSP _
    Inherits DocumentSegment
public ref class TSP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TSP()()()() | Initializes a new instance of the TSP class
 | AssignedIdentification | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TestPeriodOrIntervalQualifier | Element 1
 | TestPeriodOrIntervalValue | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TSP


TSP Constructor

TSP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► TSP()()()()
RDPCrystal EDI Library
Initializes a new instance of the TSP class
Declaration Syntax
C# Visual Basic Visual C++
public TSP()
Public Sub New
public:
TSP()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► AssignedIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TestPeriodOrIntervalQualifier Property

TestPeriodOrIntervalQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► TestPeriodOrIntervalQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalQualifier { get; set; }
Public Property TestPeriodOrIntervalQualifier As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalQualifier {
    String^ get ();
    void set (String^ value);
}


TestPeriodOrIntervalValue Property

TestPeriodOrIntervalValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► TestPeriodOrIntervalValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TestPeriodOrIntervalValue { get; set; }
Public Property TestPeriodOrIntervalValue As String
    Get
    Set
public:
property String^ TestPeriodOrIntervalValue {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TST Class

TST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST
RDPCrystal EDI Library
Test Score Record
Declaration Syntax
C# Visual Basic Visual C++
public class TST : DocumentSegment
Public Class TST _
    Inherits DocumentSegment
public ref class TST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TST()()()() | Initializes a new instance of the TST class
 | DateTimePeriod | Element 4
 | DateTimePeriod1 | Element 9
 | DateTimePeriod2 | Element 13
 | DateTimePeriodFormatQualifier | Element 3
 | EducationalTestOrRequirementCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LanguageCode | Element 12
 | LevelOfIndividualTestOrCourseCode | Element 7
 | LevelOfIndividualTestOrCourseCode1 | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 5
 | ReferenceIdentification1 | Element 6
 | TestNormingPeriodCode | Element 11
 | TestNormTypeCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 14
 | YesNoConditionOrResponseCode1 | Element 15
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TST


TST Constructor

TST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► TST()()()()
RDPCrystal EDI Library
Initializes a new instance of the TST class
Declaration Syntax
C# Visual Basic Visual C++
public TST()
Public Sub New
public:
TST()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► DateTimePeriod1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► DateTimePeriod2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


EducationalTestOrRequirementCode Property

EducationalTestOrRequirementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► EducationalTestOrRequirementCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EducationalTestOrRequirementCode { get; set; }
Public Property EducationalTestOrRequirementCode As String
    Get
    Set
public:
property String^ EducationalTestOrRequirementCode {
    String^ get ();
    void set (String^ value);
}


LanguageCode Property

LanguageCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► LanguageCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageCode { get; set; }
Public Property LanguageCode As String
    Get
    Set
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode Property

LevelOfIndividualTestOrCourseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► LevelOfIndividualTestOrCourseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode { get; set; }
Public Property LevelOfIndividualTestOrCourseCode As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode {
    String^ get ();
    void set (String^ value);
}


LevelOfIndividualTestOrCourseCode1 Property

LevelOfIndividualTestOrCourseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► LevelOfIndividualTestOrCourseCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfIndividualTestOrCourseCode1 { get; set; }
Public Property LevelOfIndividualTestOrCourseCode1 As String
    Get
    Set
public:
property String^ LevelOfIndividualTestOrCourseCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► ReferenceIdentification
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► ReferenceIdentification1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


TestNormingPeriodCode Property

TestNormingPeriodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► TestNormingPeriodCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TestNormingPeriodCode { get; set; }
Public Property TestNormingPeriodCode As String
    Get
    Set
public:
property String^ TestNormingPeriodCode {
    String^ get ();
    void set (String^ value);
}


TestNormTypeCode Property

TestNormTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► TestNormTypeCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TestNormTypeCode { get; set; }
Public Property TestNormTypeCode As String
    Get
    Set
public:
property String^ TestNormTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TST ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


TSU Class

TSU Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU
RDPCrystal EDI Library
Transaction Summary
Declaration Syntax
C# Visual Basic Visual C++
public class TSU : DocumentSegment
Public Class TSU _
    Inherits DocumentSegment
public ref class TSU : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TSU()()()() | Initializes a new instance of the TSU class
 | CodeListQualifierCode | Element 1
 | Date | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 4
 | Quantity1 | Element 5
 | Time | Element 7
 | TimeCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TSU


TSU Constructor

TSU Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► TSU()()()()
RDPCrystal EDI Library
Initializes a new instance of the TSU class
Declaration Syntax
C# Visual Basic Visual C++
public TSU()
Public Sub New
public:
TSU()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► Date
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► Time
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► TimeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TSU ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TT Class

TT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TT
RDPCrystal EDI Library
Term Text
Declaration Syntax
C# Visual Basic Visual C++
public class TT : DocumentSegment
Public Class TT _
    Inherits DocumentSegment
public ref class TT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TT()()()() | Initializes a new instance of the TT class
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixedFormatInformation | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TT


TT Constructor

TT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TT ► TT()()()()
RDPCrystal EDI Library
Initializes a new instance of the TT class
Declaration Syntax
C# Visual Basic Visual C++
public TT()
Public Sub New
public:
TT()


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TT ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


FixedFormatInformation Property

FixedFormatInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TT ► FixedFormatInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation { get; set; }
Public Property FixedFormatInformation As String
    Get
    Set
public:
property String^ FixedFormatInformation {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TUD Class

TUD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD
RDPCrystal EDI Library
Trade Union Data
Declaration Syntax
C# Visual Basic Visual C++
public class TUD : DocumentSegment
Public Class TUD _
    Inherits DocumentSegment
public ref class TUD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TUD()()()() | Initializes a new instance of the TUD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 3
 | IdentificationCodeQualifier | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TradeUnionCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TUD


TUD Constructor

TUD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD ► TUD()()()()
RDPCrystal EDI Library
Initializes a new instance of the TUD class
Declaration Syntax
C# Visual Basic Visual C++
public TUD()
Public Sub New
public:
TUD()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD ► IdentificationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TradeUnionCode Property

TradeUnionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD ► TradeUnionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TradeUnionCode { get; set; }
Public Property TradeUnionCode As String
    Get
    Set
public:
property String^ TradeUnionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TUD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TXI Class

TXI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI
RDPCrystal EDI Library
Tax Information
Declaration Syntax
C# Visual Basic Visual C++
public class TXI : DocumentSegment
Public Class TXI _
    Inherits DocumentSegment
public ref class TXI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TXI()()()() | Initializes a new instance of the TXI class
 | AssignedIdentification | Element 10
 | DollarBasisForPercent | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | RelationshipCode | Element 7
 | TaxExemptCode | Element 6
 | TaxIdentificationNumber | Element 9
 | TaxJurisdictionCode | Element 5
 | TaxJurisdictionCodeQualifier | Element 4
 | TaxTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TXI


TXI Constructor

TXI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► TXI()()()()
RDPCrystal EDI Library
Initializes a new instance of the TXI class
Declaration Syntax
C# Visual Basic Visual C++
public TXI()
Public Sub New
public:
TXI()


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► AssignedIdentification
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


DollarBasisForPercent Property

DollarBasisForPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► DollarBasisForPercent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DollarBasisForPercent { get; set; }
Public Property DollarBasisForPercent As String
    Get
    Set
public:
property String^ DollarBasisForPercent {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


RelationshipCode Property

RelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► RelationshipCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipCode { get; set; }
Public Property RelationshipCode As String
    Get
    Set
public:
property String^ RelationshipCode {
    String^ get ();
    void set (String^ value);
}


TaxExemptCode Property

TaxExemptCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► TaxExemptCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TaxExemptCode { get; set; }
Public Property TaxExemptCode As String
    Get
    Set
public:
property String^ TaxExemptCode {
    String^ get ();
    void set (String^ value);
}


TaxIdentificationNumber Property

TaxIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► TaxIdentificationNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TaxIdentificationNumber { get; set; }
Public Property TaxIdentificationNumber As String
    Get
    Set
public:
property String^ TaxIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


TaxJurisdictionCode Property

TaxJurisdictionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► TaxJurisdictionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TaxJurisdictionCode { get; set; }
Public Property TaxJurisdictionCode As String
    Get
    Set
public:
property String^ TaxJurisdictionCode {
    String^ get ();
    void set (String^ value);
}


TaxJurisdictionCodeQualifier Property

TaxJurisdictionCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► TaxJurisdictionCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TaxJurisdictionCodeQualifier { get; set; }
Public Property TaxJurisdictionCodeQualifier As String
    Get
    Set
public:
property String^ TaxJurisdictionCodeQualifier {
    String^ get ();
    void set (String^ value);
}


TaxTypeCode Property

TaxTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► TaxTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TaxTypeCode { get; set; }
Public Property TaxTypeCode As String
    Get
    Set
public:
property String^ TaxTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TXN Class

TXN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN
RDPCrystal EDI Library
Transaction Capabilities
Declaration Syntax
C# Visual Basic Visual C++
public class TXN : DocumentSegment
Public Class TXN _
    Inherits DocumentSegment
public ref class TXN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TXN()()()() | Initializes a new instance of the TXN class
 | ActionCode | Element 1
 | ActionCode1 | Element 5
 | ApplicationReceiverCode | Element 6
 | ApplicationSenderCode | Element 7
 | Date | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ResponsibleAgencyCode | Element 2
 | Time | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetIdentifierCode | Element 3
 | VersionReleaseIndustryIdentifierCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TXN


TXN Constructor

TXN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► TXN()()()()
RDPCrystal EDI Library
Initializes a new instance of the TXN class
Declaration Syntax
C# Visual Basic Visual C++
public TXN()
Public Sub New
public:
TXN()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


ActionCode1 Property

ActionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► ActionCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode1 { get; set; }
Public Property ActionCode1 As String
    Get
    Set
public:
property String^ ActionCode1 {
    String^ get ();
    void set (String^ value);
}


ApplicationReceiverCode Property

ApplicationReceiverCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► ApplicationReceiverCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationReceiverCode { get; set; }
Public Property ApplicationReceiverCode As String
    Get
    Set
public:
property String^ ApplicationReceiverCode {
    String^ get ();
    void set (String^ value);
}


ApplicationSenderCode Property

ApplicationSenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► ApplicationSenderCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationSenderCode { get; set; }
Public Property ApplicationSenderCode As String
    Get
    Set
public:
property String^ ApplicationSenderCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► Date
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ResponsibleAgencyCode Property

ResponsibleAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► ResponsibleAgencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ResponsibleAgencyCode { get; set; }
Public Property ResponsibleAgencyCode As String
    Get
    Set
public:
property String^ ResponsibleAgencyCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► Time
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► VersionReleaseIndustryIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


TXP Class

TXP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP
RDPCrystal EDI Library
Tax Payment
Declaration Syntax
C# Visual Basic Visual C++
public class TXP : DocumentSegment
Public Class TXP _
    Inherits DocumentSegment
public ref class TXP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TXP()()()() | Initializes a new instance of the TXP class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | TaxAmount | Element 5
 | TaxAmount1 | Element 7
 | TaxAmount2 | Element 9
 | TaxIdentificationNumber | Element 1
 | TaxInformationIdentificationNumber | Element 4
 | TaxInformationIdentificationNumber1 | Element 6
 | TaxInformationIdentificationNumber2 | Element 8
 | TaxpayerVerification | Element 10
 | TaxPaymentTypeCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TXP


TXP Constructor

TXP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TXP()()()()
RDPCrystal EDI Library
Initializes a new instance of the TXP class
Declaration Syntax
C# Visual Basic Visual C++
public TXP()
Public Sub New
public:
TXP()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TaxAmount Property

TaxAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TaxAmount { get; set; }
Public Property TaxAmount As String
    Get
    Set
public:
property String^ TaxAmount {
    String^ get ();
    void set (String^ value);
}


TaxAmount1 Property

TaxAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxAmount1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TaxAmount1 { get; set; }
Public Property TaxAmount1 As String
    Get
    Set
public:
property String^ TaxAmount1 {
    String^ get ();
    void set (String^ value);
}


TaxAmount2 Property

TaxAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxAmount2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TaxAmount2 { get; set; }
Public Property TaxAmount2 As String
    Get
    Set
public:
property String^ TaxAmount2 {
    String^ get ();
    void set (String^ value);
}


TaxIdentificationNumber Property

TaxIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TaxIdentificationNumber { get; set; }
Public Property TaxIdentificationNumber As String
    Get
    Set
public:
property String^ TaxIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


TaxInformationIdentificationNumber Property

TaxInformationIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxInformationIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TaxInformationIdentificationNumber { get; set; }
Public Property TaxInformationIdentificationNumber As String
    Get
    Set
public:
property String^ TaxInformationIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


TaxInformationIdentificationNumber1 Property

TaxInformationIdentificationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxInformationIdentificationNumber1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TaxInformationIdentificationNumber1 { get; set; }
Public Property TaxInformationIdentificationNumber1 As String
    Get
    Set
public:
property String^ TaxInformationIdentificationNumber1 {
    String^ get ();
    void set (String^ value);
}


TaxInformationIdentificationNumber2 Property

TaxInformationIdentificationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxInformationIdentificationNumber2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TaxInformationIdentificationNumber2 { get; set; }
Public Property TaxInformationIdentificationNumber2 As String
    Get
    Set
public:
property String^ TaxInformationIdentificationNumber2 {
    String^ get ();
    void set (String^ value);
}


TaxpayerVerification Property

TaxpayerVerification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxpayerVerification
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TaxpayerVerification { get; set; }
Public Property TaxpayerVerification As String
    Get
    Set
public:
property String^ TaxpayerVerification {
    String^ get ();
    void set (String^ value);
}


TaxPaymentTypeCode Property

TaxPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► TaxPaymentTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TaxPaymentTypeCode { get; set; }
Public Property TaxPaymentTypeCode As String
    Get
    Set
public:
property String^ TaxPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► TXP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Typed4010Document Class

Typed4010Document Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document
RDPCrystal EDI Library
Represents an X12 4010 Document
Declaration Syntax
C# Visual Basic Visual C++
public class Typed4010Document : TypedDocument
Public Class Typed4010Document _
    Inherits TypedDocument
public ref class Typed4010Document : public TypedDocument
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Typed4010Document()()()() | Initializes a new instance of the Typed4010Document class.
 | Typed4010Document(EDILightWeightDocument) | Initializes a new instance of the Typed4010Document class.
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT) (Inherited from TypedDocument.)
 | AutoPlaceNumOfFunctionalGroups | Places the correct number of functional groups in the IEA segment Element 1(X12) (Inherited from TypedDocument.)
 | AutoPlaceNumOfTransactions | Places the correct number of transaction in the GE segment Element 1(X12) (Inherited from TypedDocument.)
 | CreateSection(LightWeightLoop) | Overridden in edge case scenarios when a custom loop structure is needed (Inherited from TypedDocument.)
 | DestroySegmentsAfter | Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument (Inherited from TypedDocument.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file (Inherited from TypedDocument.)
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document (Inherited from TypedDocument.)
 | GetDocumentSegment(String) | Gets the document item. (Overrides TypedDocument.GetDocumentSegment(String).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(EDILightWeightDocument) | Loads the specified light weight document. (Inherited from TypedDocument.)
 | MainSection | Gets or sets the main section of the TypedDocument (Inherited from TypedDocument.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadISAElementValues | Pads or trims the ISA elements to conform to HIPAA (Inherited from TypedDocument.)
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document (Inherited from TypedDocument.)
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document (Inherited from TypedDocument.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypedDocument
 |  | Typed4010Document


Typed4010Document Constructor

Typed4010Document Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document ► Typed4010Document()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Typed4010Document()()()() | Initializes a new instance of the Typed4010Document class.
 | Typed4010Document(EDILightWeightDocument) | Initializes a new instance of the Typed4010Document class.


Typed4010Document Constructor

Typed4010Document Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document ► Typed4010Document()()()()
RDPCrystal EDI Library
Initializes a new instance of the Typed4010Document class.
Declaration Syntax
C# Visual Basic Visual C++
public Typed4010Document()
Public Sub New
public:
Typed4010Document()


Typed4010Document Constructor (document)

Typed4010Document Constructor (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document ► Typed4010Document(EDILightWeightDocument)
RDPCrystal EDI Library
Initializes a new instance of the Typed4010Document class.
Declaration Syntax
C# Visual Basic Visual C++
public Typed4010Document(
    EDILightWeightDocument document
)
Public Sub New ( _
    document As EDILightWeightDocument _
)
public:
Typed4010Document(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
The document to initialize from


GetDocumentSegment Method (segmentName)

GetDocumentSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document ► GetDocumentSegment(String)
RDPCrystal EDI Library
Gets the document item.
Declaration Syntax
C# Visual Basic Visual C++
protected override DocumentSegment GetDocumentSegment(
    string segmentName
)
Protected Overrides Function GetDocumentSegment ( _
    segmentName As String _
) As DocumentSegment
protected:
virtual DocumentSegment^ GetDocumentSegment(
    String^ segmentName
) override
Parameters
segmentName (String)
Name of the segment.
Return Value


UC Class

UC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC
RDPCrystal EDI Library
Underwriting Category
Declaration Syntax
C# Visual Basic Visual C++
public class UC : DocumentSegment
Public Class UC _
    Inherits DocumentSegment
public ref class UC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UC()()()() | Initializes a new instance of the UC class
 | CodeCategory | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentification1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UC


UC Constructor

UC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► UC()()()()
RDPCrystal EDI Library
Initializes a new instance of the UC class
Declaration Syntax
C# Visual Basic Visual C++
public UC()
Public Sub New
public:
UC()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


UCS Class

UCS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS
RDPCrystal EDI Library
Underwriting Considerations
Declaration Syntax
C# Visual Basic Visual C++
public class UCS : DocumentSegment
Public Class UCS _
    Inherits DocumentSegment
public ref class UCS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UCS()()()() | Initializes a new instance of the UCS class
 | CodeCategory | Element 1
 | CompositeUnitOfMeasure | Element 8
 | Description | Element 2
 | Description1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ItemDescriptionType | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 6
 | ProductServiceIDQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UCS


UCS Constructor

UCS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► UCS()()()()
RDPCrystal EDI Library
Initializes a new instance of the UCS class
Declaration Syntax
C# Visual Basic Visual C++
public UCS()
Public Sub New
public:
UCS()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► Description1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


ItemDescriptionType Property

ItemDescriptionType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► ItemDescriptionType
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ItemDescriptionType { get; set; }
Public Property ItemDescriptionType As String
    Get
    Set
public:
property String^ ItemDescriptionType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► Number
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UCS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


UD Class

UD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD
RDPCrystal EDI Library
Underwriting Status
Declaration Syntax
C# Visual Basic Visual C++
public class UD : DocumentSegment
Public Class UD _
    Inherits DocumentSegment
public ref class UD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UD()()()() | Initializes a new instance of the UD class
 | Amount | Element 12
 | AssignedNumber | Element 7
 | AssignedNumber1 | Element 9
 | CountryCode | Element 15
 | CountryCode1 | Element 17
 | Date | Element 4
 | Description | Element 5
 | Description1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 13
 | OfferBasisCode | Element 6
 | OfferBasisCode1 | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 11
 | StateOrProvinceCode | Element 14
 | StateOrProvinceCode1 | Element 16
 | StatusCode | Element 1
 | StatusCode1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnderwritingDecisionCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UD


UD Constructor

UD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► UD()()()()
RDPCrystal EDI Library
Initializes a new instance of the UD class
Declaration Syntax
C# Visual Basic Visual C++
public UD()
Public Sub New
public:
UD()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Amount
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► AssignedNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


AssignedNumber1 Property

AssignedNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► AssignedNumber1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber1 { get; set; }
Public Property AssignedNumber1 As String
    Get
    Set
public:
property String^ AssignedNumber1 {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► CountryCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


CountryCode1 Property

CountryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► CountryCode1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode1 { get; set; }
Public Property CountryCode1 As String
    Get
    Set
public:
property String^ CountryCode1 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Description1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Number
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


OfferBasisCode Property

OfferBasisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► OfferBasisCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string OfferBasisCode { get; set; }
Public Property OfferBasisCode As String
    Get
    Set
public:
property String^ OfferBasisCode {
    String^ get ();
    void set (String^ value);
}


OfferBasisCode1 Property

OfferBasisCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► OfferBasisCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string OfferBasisCode1 { get; set; }
Public Property OfferBasisCode1 As String
    Get
    Set
public:
property String^ OfferBasisCode1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Percent
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► StateOrProvinceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode1 Property

StateOrProvinceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► StateOrProvinceCode1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode1 { get; set; }
Public Property StateOrProvinceCode1 As String
    Get
    Set
public:
property String^ StateOrProvinceCode1 {
    String^ get ();
    void set (String^ value);
}


StatusCode Property

StatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► StatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode { get; set; }
Public Property StatusCode As String
    Get
    Set
public:
property String^ StatusCode {
    String^ get ();
    void set (String^ value);
}


StatusCode1 Property

StatusCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► StatusCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StatusCode1 { get; set; }
Public Property StatusCode1 As String
    Get
    Set
public:
property String^ StatusCode1 {
    String^ get ();
    void set (String^ value);
}


UnderwritingDecisionCode Property

UnderwritingDecisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► UnderwritingDecisionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnderwritingDecisionCode { get; set; }
Public Property UnderwritingDecisionCode As String
    Get
    Set
public:
property String^ UnderwritingDecisionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


UDA Class

UDA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA
RDPCrystal EDI Library
Underwriting Condition
Declaration Syntax
C# Visual Basic Visual C++
public class UDA : DocumentSegment
Public Class UDA _
    Inherits DocumentSegment
public ref class UDA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UDA()()()() | Initializes a new instance of the UDA class
 | Amount | Element 6
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OfferBasisCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 7
 | Quantity | Element 4
 | QuantityQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UDA


UDA Constructor

UDA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► UDA()()()()
RDPCrystal EDI Library
Initializes a new instance of the UDA class
Declaration Syntax
C# Visual Basic Visual C++
public UDA()
Public Sub New
public:
UDA()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► Amount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OfferBasisCode Property

OfferBasisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► OfferBasisCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OfferBasisCode { get; set; }
Public Property OfferBasisCode As String
    Get
    Set
public:
property String^ OfferBasisCode {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► Percent
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► QuantityQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UDA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


UIT Class

UIT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT
RDPCrystal EDI Library
Unit Detail
Declaration Syntax
C# Visual Basic Visual C++
public class UIT : DocumentSegment
Public Class UIT _
    Inherits DocumentSegment
public ref class UIT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UIT()()()() | Initializes a new instance of the UIT class
 | BasisOfUnitPriceCodeID | Element 3
 | CompositeUnitOfMeasure | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UIT


UIT Constructor

UIT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT ► UIT()()()()
RDPCrystal EDI Library
Initializes a new instance of the UIT class
Declaration Syntax
C# Visual Basic Visual C++
public UIT()
Public Sub New
public:
UIT()


BasisOfUnitPriceCodeID Property

BasisOfUnitPriceCodeID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT ► BasisOfUnitPriceCodeID
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCodeID { get; set; }
Public Property BasisOfUnitPriceCodeID As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCodeID {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT ► UnitPrice
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UIT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


UM Class

UM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM
RDPCrystal EDI Library
Health Care Services Review Information
Declaration Syntax
C# Visual Basic Visual C++
public class UM : DocumentSegment
Public Class UM _
    Inherits DocumentSegment
public ref class UM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UM()()()() | Initializes a new instance of the UM class
 | CertificationTypeCode | Element 2
 | CurrentHealthConditionCode | Element 7
 | DelayReasonCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareServiceLocationInformation | Element 4
 | LevelOfServiceCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrognosisCode | Element 8
 | RelatedCausesInformation | Element 5
 | ReleaseOfInformationCode | Element 9
 | RequestCategoryCode | Element 1
 | ServiceTypeCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UM


UM Constructor

UM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► UM()()()()
RDPCrystal EDI Library
Initializes a new instance of the UM class
Declaration Syntax
C# Visual Basic Visual C++
public UM()
Public Sub New
public:
UM()


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► CertificationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}


CurrentHealthConditionCode Property

CurrentHealthConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► CurrentHealthConditionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentHealthConditionCode { get; set; }
Public Property CurrentHealthConditionCode As String
    Get
    Set
public:
property String^ CurrentHealthConditionCode {
    String^ get ();
    void set (String^ value);
}


DelayReasonCode Property

DelayReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► DelayReasonCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DelayReasonCode { get; set; }
Public Property DelayReasonCode As String
    Get
    Set
public:
property String^ DelayReasonCode {
    String^ get ();
    void set (String^ value);
}


HealthCareServiceLocationInformation Property

HealthCareServiceLocationInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► HealthCareServiceLocationInformation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocationInformation HealthCareServiceLocationInformation { get; set; }
Public Property HealthCareServiceLocationInformation As HealthCareServiceLocationInformation
    Get
    Set
public:
property HealthCareServiceLocationInformation^ HealthCareServiceLocationInformation {
    HealthCareServiceLocationInformation^ get ();
    void set (HealthCareServiceLocationInformation^ value);
}


LevelOfServiceCode Property

LevelOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► LevelOfServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfServiceCode { get; set; }
Public Property LevelOfServiceCode As String
    Get
    Set
public:
property String^ LevelOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► PrognosisCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}


RelatedCausesInformation Property

RelatedCausesInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► RelatedCausesInformation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation RelatedCausesInformation { get; set; }
Public Property RelatedCausesInformation As RelatedCausesInformation
    Get
    Set
public:
property RelatedCausesInformation^ RelatedCausesInformation {
    RelatedCausesInformation^ get ();
    void set (RelatedCausesInformation^ value);
}


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► ReleaseOfInformationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}


RequestCategoryCode Property

RequestCategoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► RequestCategoryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RequestCategoryCode { get; set; }
Public Property RequestCategoryCode As String
    Get
    Set
public:
property String^ RequestCategoryCode {
    String^ get ();
    void set (String^ value);
}


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► ServiceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


UQS Class

UQS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS
RDPCrystal EDI Library
Underwriting Question
Declaration Syntax
C# Visual Basic Visual C++
public class UQS : DocumentSegment
Public Class UQS _
    Inherits DocumentSegment
public ref class UQS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UQS()()()() | Initializes a new instance of the UQS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ReferenceIdentification1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 4
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UQS


UQS Constructor

UQS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► UQS()()()()
RDPCrystal EDI Library
Initializes a new instance of the UQS class
Declaration Syntax
C# Visual Basic Visual C++
public UQS()
Public Sub New
public:
UQS()


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► FreeFormMessageText
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► ReferenceIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UQS ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


UR Class

UR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UR
RDPCrystal EDI Library
Peer Review Organization or Utilization Review
Declaration Syntax
C# Visual Basic Visual C++
public class UR : DocumentSegment
Public Class UR _
    Inherits DocumentSegment
public ref class UR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UR()()()() | Initializes a new instance of the UR class
 | ApprovalCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UR


UR Constructor

UR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UR ► UR()()()()
RDPCrystal EDI Library
Initializes a new instance of the UR class
Declaration Syntax
C# Visual Basic Visual C++
public UR()
Public Sub New
public:
UR()


ApprovalCode Property

ApprovalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UR ► ApprovalCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ApprovalCode { get; set; }
Public Property ApprovalCode As String
    Get
    Set
public:
property String^ ApprovalCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UR ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


USD Class

USD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD
RDPCrystal EDI Library
Usage-Sensitive Detail
Declaration Syntax
C# Visual Basic Visual C++
public class USD : DocumentSegment
Public Class USD _
    Inherits DocumentSegment
public ref class USD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | USD()()()() | Initializes a new instance of the USD class
 | Amount | Element 9
 | AssignedIdentification | Element 2
 | CompositeUnitOfMeasure | Element 5
 | CompositeUnitOfMeasure1 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | Quantity | Element 6
 | Quantity1 | Element 7
 | RangeMaximum | Element 12
 | RangeMinimum | Element 11
 | Rate | Element 3
 | RelationshipCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | USD


USD Constructor

USD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► USD()()()()
RDPCrystal EDI Library
Initializes a new instance of the USD class
Declaration Syntax
C# Visual Basic Visual C++
public USD()
Public Sub New
public:
USD()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Amount
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► AssignedIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


CompositeUnitOfMeasure1 Property

CompositeUnitOfMeasure1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► CompositeUnitOfMeasure1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure1 { get; set; }
Public Property CompositeUnitOfMeasure1 As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure1 {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


RangeMaximum Property

RangeMaximum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► RangeMaximum
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMaximum { get; set; }
Public Property RangeMaximum As String
    Get
    Set
public:
property String^ RangeMaximum {
    String^ get ();
    void set (String^ value);
}


RangeMinimum Property

RangeMinimum Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► RangeMinimum
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string RangeMinimum { get; set; }
Public Property RangeMinimum As String
    Get
    Set
public:
property String^ RangeMinimum {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Rate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


RelationshipCode Property

RelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► RelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RelationshipCode { get; set; }
Public Property RelationshipCode As String
    Get
    Set
public:
property String^ RelationshipCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► USD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


UWI Class

UWI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI
RDPCrystal EDI Library
Underwriting Information
Declaration Syntax
C# Visual Basic Visual C++
public class UWI : DocumentSegment
Public Class UWI _
    Inherits DocumentSegment
public ref class UWI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UWI()()()() | Initializes a new instance of the UWI class
 | DispositionCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnderwritingMethodCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UWI


UWI Constructor

UWI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► UWI()()()()
RDPCrystal EDI Library
Initializes a new instance of the UWI class
Declaration Syntax
C# Visual Basic Visual C++
public UWI()
Public Sub New
public:
UWI()


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► DispositionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


UnderwritingMethodCode Property

UnderwritingMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► UnderwritingMethodCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnderwritingMethodCode { get; set; }
Public Property UnderwritingMethodCode As String
    Get
    Set
public:
property String^ UnderwritingMethodCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► UWI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


V1 Class

V1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1
RDPCrystal EDI Library
Vessel Identification
Declaration Syntax
C# Visual Basic Visual C++
public class V1 : DocumentSegment
Public Class V1 _
    Inherits DocumentSegment
public ref class V1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | V1()()()() | Initializes a new instance of the V1 class
 | CountryCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 9
 | VesselCode | Element 1
 | VesselCodeQualifier | Element 8
 | VesselName | Element 2
 | VesselRequirementCode | Element 6
 | VesselTypeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | V1


V1 Constructor

V1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► V1()()()()
RDPCrystal EDI Library
Initializes a new instance of the V1 class
Declaration Syntax
C# Visual Basic Visual C++
public V1()
Public Sub New
public:
V1()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► CountryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► FlightVoyageNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► VesselCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselCodeQualifier Property

VesselCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► VesselCodeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCodeQualifier { get; set; }
Public Property VesselCodeQualifier As String
    Get
    Set
public:
property String^ VesselCodeQualifier {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► VesselName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


VesselRequirementCode Property

VesselRequirementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► VesselRequirementCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VesselRequirementCode { get; set; }
Public Property VesselRequirementCode As String
    Get
    Set
public:
property String^ VesselRequirementCode {
    String^ get ();
    void set (String^ value);
}


VesselTypeCode Property

VesselTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► VesselTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VesselTypeCode { get; set; }
Public Property VesselTypeCode As String
    Get
    Set
public:
property String^ VesselTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


V2 Class

V2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2
RDPCrystal EDI Library
Vessel Information
Declaration Syntax
C# Visual Basic Visual C++
public class V2 : DocumentSegment
Public Class V2 _
    Inherits DocumentSegment
public ref class V2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | V2()()()() | Initializes a new instance of the V2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Length | Element 14
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 13
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 16
 | Quantity1 | Element 17
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 15
 | Weight | Element 3
 | Weight1 | Element 5
 | Weight2 | Element 7
 | Weight3 | Element 9
 | Weight4 | Element 11
 | WeightUnitCode | Element 4
 | WeightUnitCode1 | Element 6
 | WeightUnitCode2 | Element 8
 | WeightUnitCode3 | Element 10
 | WeightUnitCode4 | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | V2


V2 Constructor

V2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► V2()()()()
RDPCrystal EDI Library
Initializes a new instance of the V2 class
Declaration Syntax
C# Visual Basic Visual C++
public V2()
Public Sub New
public:
V2()


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Length
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► LocationIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Name1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Quantity
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Quantity1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Weight
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Weight1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


Weight2 Property

Weight2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Weight2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Weight2 { get; set; }
Public Property Weight2 As String
    Get
    Set
public:
property String^ Weight2 {
    String^ get ();
    void set (String^ value);
}


Weight3 Property

Weight3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Weight3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Weight3 { get; set; }
Public Property Weight3 As String
    Get
    Set
public:
property String^ Weight3 {
    String^ get ();
    void set (String^ value);
}


Weight4 Property

Weight4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Weight4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Weight4 { get; set; }
Public Property Weight4 As String
    Get
    Set
public:
property String^ Weight4 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► WeightUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode1 Property

WeightUnitCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► WeightUnitCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode1 { get; set; }
Public Property WeightUnitCode1 As String
    Get
    Set
public:
property String^ WeightUnitCode1 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode2 Property

WeightUnitCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► WeightUnitCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode2 { get; set; }
Public Property WeightUnitCode2 As String
    Get
    Set
public:
property String^ WeightUnitCode2 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode3 Property

WeightUnitCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► WeightUnitCode3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode3 { get; set; }
Public Property WeightUnitCode3 As String
    Get
    Set
public:
property String^ WeightUnitCode3 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode4 Property

WeightUnitCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► WeightUnitCode4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode4 { get; set; }
Public Property WeightUnitCode4 As String
    Get
    Set
public:
property String^ WeightUnitCode4 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


V3 Class

V3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3
RDPCrystal EDI Library
Vessel Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class V3 : DocumentSegment
Public Class V3 _
    Inherits DocumentSegment
public ref class V3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | V3()()()() | Initializes a new instance of the V3 class
 | CurrentPortOfLoading | Element 1
 | Date | Element 2
 | Date1 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NextPortOfDischarge | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | V3


V3 Constructor

V3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► V3()()()()
RDPCrystal EDI Library
Initializes a new instance of the V3 class
Declaration Syntax
C# Visual Basic Visual C++
public V3()
Public Sub New
public:
V3()


CurrentPortOfLoading Property

CurrentPortOfLoading Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► CurrentPortOfLoading
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentPortOfLoading { get; set; }
Public Property CurrentPortOfLoading As String
    Get
    Set
public:
property String^ CurrentPortOfLoading {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NextPortOfDischarge Property

NextPortOfDischarge Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► NextPortOfDischarge
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NextPortOfDischarge { get; set; }
Public Property NextPortOfDischarge As String
    Get
    Set
public:
property String^ NextPortOfDischarge {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


V4 Class

V4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V4
RDPCrystal EDI Library
Cargo Location Reference
Declaration Syntax
C# Visual Basic Visual C++
public class V4 : DocumentSegment
Public Class V4 _
    Inherits DocumentSegment
public ref class V4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | V4()()()() | Initializes a new instance of the V4 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VesselStowageLocation | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | V4


V4 Constructor

V4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V4 ► V4()()()()
RDPCrystal EDI Library
Initializes a new instance of the V4 class
Declaration Syntax
C# Visual Basic Visual C++
public V4()
Public Sub New
public:
V4()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


VesselStowageLocation Property

VesselStowageLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V4 ► VesselStowageLocation
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VesselStowageLocation { get; set; }
Public Property VesselStowageLocation As String
    Get
    Set
public:
property String^ VesselStowageLocation {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


V5 Class

V5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5
RDPCrystal EDI Library
Vessel Code
Declaration Syntax
C# Visual Basic Visual C++
public class V5 : DocumentSegment
Public Class V5 _
    Inherits DocumentSegment
public ref class V5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | V5()()()() | Initializes a new instance of the V5 class
 | CountryCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VesselCode | Element 2
 | VesselCodeQualifier | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | V5


V5 Constructor

V5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5 ► V5()()()()
RDPCrystal EDI Library
Initializes a new instance of the V5 class
Declaration Syntax
C# Visual Basic Visual C++
public V5()
Public Sub New
public:
V5()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5 ► CountryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5 ► VesselCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselCodeQualifier Property

VesselCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5 ► VesselCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCodeQualifier { get; set; }
Public Property VesselCodeQualifier As String
    Get
    Set
public:
property String^ VesselCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


V9 Class

V9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9
RDPCrystal EDI Library
Event Detail
Declaration Syntax
C# Visual Basic Visual C++
public class V9 : DocumentSegment
Public Class V9 _
    Inherits DocumentSegment
public ref class V9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | V9()()()() | Initializes a new instance of the V9 class
 | CityName | Element 5
 | CountryCode | Element 7
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Event | Element 2
 | EventCode | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 12
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Length | Element 20
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 10
 | Quantity1 | Element 14
 | StandardPointLocationCode | Element 9
 | StandardPointLocationCode1 | Element 15
 | StateOrProvinceCode | Element 6
 | StatusReasonCode | Element 8
 | Time | Element 4
 | TimeCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalEquipment | Element 16
 | TotalEquipment1 | Element 17
 | TotalEquipment2 | Element 18
 | TrainDelayReasonCode | Element 11
 | Weight | Element 19
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | V9


V9 Constructor

V9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► V9()()()()
RDPCrystal EDI Library
Initializes a new instance of the V9 class
Declaration Syntax
C# Visual Basic Visual C++
public V9()
Public Sub New
public:
V9()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► CityName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Event Property

Event Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Event
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Event { get; set; }
Public Property Event As String
    Get
    Set
public:
property String^ Event {
    String^ get ();
    void set (String^ value);
}


EventCode Property

EventCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► EventCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EventCode { get; set; }
Public Property EventCode As String
    Get
    Set
public:
property String^ EventCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► FreeFormMessage
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Length
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Quantity1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode1 Property

StandardPointLocationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► StandardPointLocationCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode1 { get; set; }
Public Property StandardPointLocationCode1 As String
    Get
    Set
public:
property String^ StandardPointLocationCode1 {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


StatusReasonCode Property

StatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► StatusReasonCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StatusReasonCode { get; set; }
Public Property StatusReasonCode As String
    Get
    Set
public:
property String^ StatusReasonCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► TimeCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


TotalEquipment Property

TotalEquipment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► TotalEquipment
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string TotalEquipment { get; set; }
Public Property TotalEquipment As String
    Get
    Set
public:
property String^ TotalEquipment {
    String^ get ();
    void set (String^ value);
}


TotalEquipment1 Property

TotalEquipment1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► TotalEquipment1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string TotalEquipment1 { get; set; }
Public Property TotalEquipment1 As String
    Get
    Set
public:
property String^ TotalEquipment1 {
    String^ get ();
    void set (String^ value);
}


TotalEquipment2 Property

TotalEquipment2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► TotalEquipment2
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string TotalEquipment2 { get; set; }
Public Property TotalEquipment2 As String
    Get
    Set
public:
property String^ TotalEquipment2 {
    String^ get ();
    void set (String^ value);
}


TrainDelayReasonCode Property

TrainDelayReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► TrainDelayReasonCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TrainDelayReasonCode { get; set; }
Public Property TrainDelayReasonCode As String
    Get
    Set
public:
property String^ TrainDelayReasonCode {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Weight
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► V9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VAD Class

VAD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD
RDPCrystal EDI Library
Vehicle Advice Detail
Declaration Syntax
C# Visual Basic Visual C++
public class VAD : DocumentSegment
Public Class VAD _
    Inherits DocumentSegment
public ref class VAD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VAD()()()() | Initializes a new instance of the VAD class
 | ApplicationErrorConditionCode | Element 7
 | ApplicationErrorConditionCode1 | Element 8
 | ApplicationErrorConditionCode2 | Element 9
 | Date | Element 11
 | DateTimeQualifier | Element 10
 | DealerCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InvoiceNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Rate | Element 4
 | ReferenceIdentification | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleIdentificationNumber | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VAD


VAD Constructor

VAD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► VAD()()()()
RDPCrystal EDI Library
Initializes a new instance of the VAD class
Declaration Syntax
C# Visual Basic Visual C++
public VAD()
Public Sub New
public:
VAD()


ApplicationErrorConditionCode Property

ApplicationErrorConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► ApplicationErrorConditionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode { get; set; }
Public Property ApplicationErrorConditionCode As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode {
    String^ get ();
    void set (String^ value);
}


ApplicationErrorConditionCode1 Property

ApplicationErrorConditionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► ApplicationErrorConditionCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode1 { get; set; }
Public Property ApplicationErrorConditionCode1 As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode1 {
    String^ get ();
    void set (String^ value);
}


ApplicationErrorConditionCode2 Property

ApplicationErrorConditionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► ApplicationErrorConditionCode2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationErrorConditionCode2 { get; set; }
Public Property ApplicationErrorConditionCode2 As String
    Get
    Set
public:
property String^ ApplicationErrorConditionCode2 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► Date
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► DateTimeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


DealerCode Property

DealerCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► DealerCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DealerCode { get; set; }
Public Property DealerCode As String
    Get
    Set
public:
property String^ DealerCode {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► InvoiceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► MonetaryAmount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► Rate
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► ReferenceIdentification
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


VehicleIdentificationNumber Property

VehicleIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► VehicleIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleIdentificationNumber { get; set; }
Public Property VehicleIdentificationNumber As String
    Get
    Set
public:
property String^ VehicleIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VAR Class

VAR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR
RDPCrystal EDI Library
Credit File Variation
Declaration Syntax
C# Visual Basic Visual C++
public class VAR : DocumentSegment
Public Class VAR _
    Inherits DocumentSegment
public ref class VAR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VAR()()()() | Initializes a new instance of the VAR class
 | CreditFileVariationCode | Element 3
 | CreditFileVariationCode1 | Element 4
 | CreditFileVariationCode2 | Element 5
 | CreditFileVariationCode3 | Element 6
 | CreditFileVariationCode4 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VAR


VAR Constructor

VAR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► VAR()()()()
RDPCrystal EDI Library
Initializes a new instance of the VAR class
Declaration Syntax
C# Visual Basic Visual C++
public VAR()
Public Sub New
public:
VAR()


CreditFileVariationCode Property

CreditFileVariationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► CreditFileVariationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditFileVariationCode { get; set; }
Public Property CreditFileVariationCode As String
    Get
    Set
public:
property String^ CreditFileVariationCode {
    String^ get ();
    void set (String^ value);
}


CreditFileVariationCode1 Property

CreditFileVariationCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► CreditFileVariationCode1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CreditFileVariationCode1 { get; set; }
Public Property CreditFileVariationCode1 As String
    Get
    Set
public:
property String^ CreditFileVariationCode1 {
    String^ get ();
    void set (String^ value);
}


CreditFileVariationCode2 Property

CreditFileVariationCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► CreditFileVariationCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CreditFileVariationCode2 { get; set; }
Public Property CreditFileVariationCode2 As String
    Get
    Set
public:
property String^ CreditFileVariationCode2 {
    String^ get ();
    void set (String^ value);
}


CreditFileVariationCode3 Property

CreditFileVariationCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► CreditFileVariationCode3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CreditFileVariationCode3 { get; set; }
Public Property CreditFileVariationCode3 As String
    Get
    Set
public:
property String^ CreditFileVariationCode3 {
    String^ get ();
    void set (String^ value);
}


CreditFileVariationCode4 Property

CreditFileVariationCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► CreditFileVariationCode4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CreditFileVariationCode4 { get; set; }
Public Property CreditFileVariationCode4 As String
    Get
    Set
public:
property String^ CreditFileVariationCode4 {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► IdentificationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VAT Class

VAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT
RDPCrystal EDI Library
Vehicle Attribute
Declaration Syntax
C# Visual Basic Visual C++
public class VAT : DocumentSegment
Public Class VAT _
    Inherits DocumentSegment
public ref class VAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VAT()()()() | Initializes a new instance of the VAT class
 | AgencyQualifierCode | Element 6
 | Amount | Element 3
 | AmountQualifierCode | Element 2
 | CurrencyCode | Element 4
 | Description | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 1
 | IndustryCode1 | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductProcessCharacteristicCode | Element 5
 | Quantity | Element 10
 | SourceSubqualifier | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VAT


VAT Constructor

VAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► VAT()()()()
RDPCrystal EDI Library
Initializes a new instance of the VAT class
Declaration Syntax
C# Visual Basic Visual C++
public VAT()
Public Sub New
public:
VAT()


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► AgencyQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► Amount
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► AmountQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► CurrencyCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► Description
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► IndustryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► IndustryCode1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductProcessCharacteristicCode Property

ProductProcessCharacteristicCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► ProductProcessCharacteristicCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductProcessCharacteristicCode { get; set; }
Public Property ProductProcessCharacteristicCode As String
    Get
    Set
public:
property String^ ProductProcessCharacteristicCode {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


SourceSubqualifier Property

SourceSubqualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► SourceSubqualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SourceSubqualifier { get; set; }
Public Property SourceSubqualifier As String
    Get
    Set
public:
property String^ SourceSubqualifier {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VAT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VC Class

VC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC
RDPCrystal EDI Library
Motor Vehicle Control
Declaration Syntax
C# Visual Basic Visual C++
public class VC : DocumentSegment
Public Class VC _
    Inherits DocumentSegment
public ref class VC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VC()()()() | Initializes a new instance of the VC class
 | AutomotiveManufacturersCode | Element 7
 | BayLocation | Element 6
 | DamageExceptionIndicator | Element 8
 | DealerCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FactoryCarOrderNumber | Element 10
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RouteCode | Element 5
 | SupplementalInspectionCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleDeckPositionCode | Element 2
 | VehicleIdentificationNumber | Element 1
 | VehicleTypeCode | Element 3
 | VesselStowageLocation | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VC


VC Constructor

VC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► VC()()()()
RDPCrystal EDI Library
Initializes a new instance of the VC class
Declaration Syntax
C# Visual Basic Visual C++
public VC()
Public Sub New
public:
VC()


AutomotiveManufacturersCode Property

AutomotiveManufacturersCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► AutomotiveManufacturersCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AutomotiveManufacturersCode { get; set; }
Public Property AutomotiveManufacturersCode As String
    Get
    Set
public:
property String^ AutomotiveManufacturersCode {
    String^ get ();
    void set (String^ value);
}


BayLocation Property

BayLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► BayLocation
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string BayLocation { get; set; }
Public Property BayLocation As String
    Get
    Set
public:
property String^ BayLocation {
    String^ get ();
    void set (String^ value);
}


DamageExceptionIndicator Property

DamageExceptionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► DamageExceptionIndicator
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DamageExceptionIndicator { get; set; }
Public Property DamageExceptionIndicator As String
    Get
    Set
public:
property String^ DamageExceptionIndicator {
    String^ get ();
    void set (String^ value);
}


DealerCode Property

DealerCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► DealerCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DealerCode { get; set; }
Public Property DealerCode As String
    Get
    Set
public:
property String^ DealerCode {
    String^ get ();
    void set (String^ value);
}


FactoryCarOrderNumber Property

FactoryCarOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► FactoryCarOrderNumber
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FactoryCarOrderNumber { get; set; }
Public Property FactoryCarOrderNumber As String
    Get
    Set
public:
property String^ FactoryCarOrderNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RouteCode Property

RouteCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► RouteCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RouteCode { get; set; }
Public Property RouteCode As String
    Get
    Set
public:
property String^ RouteCode {
    String^ get ();
    void set (String^ value);
}


SupplementalInspectionCode Property

SupplementalInspectionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► SupplementalInspectionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SupplementalInspectionCode { get; set; }
Public Property SupplementalInspectionCode As String
    Get
    Set
public:
property String^ SupplementalInspectionCode {
    String^ get ();
    void set (String^ value);
}


VehicleDeckPositionCode Property

VehicleDeckPositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► VehicleDeckPositionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleDeckPositionCode { get; set; }
Public Property VehicleDeckPositionCode As String
    Get
    Set
public:
property String^ VehicleDeckPositionCode {
    String^ get ();
    void set (String^ value);
}


VehicleIdentificationNumber Property

VehicleIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► VehicleIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleIdentificationNumber { get; set; }
Public Property VehicleIdentificationNumber As String
    Get
    Set
public:
property String^ VehicleIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


VehicleTypeCode Property

VehicleTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► VehicleTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleTypeCode { get; set; }
Public Property VehicleTypeCode As String
    Get
    Set
public:
property String^ VehicleTypeCode {
    String^ get ();
    void set (String^ value);
}


VesselStowageLocation Property

VesselStowageLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► VesselStowageLocation
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string VesselStowageLocation { get; set; }
Public Property VesselStowageLocation As String
    Get
    Set
public:
property String^ VesselStowageLocation {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VC1 Class

VC1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1
RDPCrystal EDI Library
Vehicle Detail
Declaration Syntax
C# Visual Basic Visual C++
public class VC1 : DocumentSegment
Public Class VC1 _
    Inherits DocumentSegment
public ref class VC1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VC1()()()() | Initializes a new instance of the VC1 class
 | Color | Element 1
 | Color1 | Element 2
 | CurrencyCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 10
 | Length | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 15
 | MeasurementUnitQualifier | Element 9
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleDimension | Element 3
 | Volume | Element 14
 | VolumeUnitQualifier | Element 13
 | Weight | Element 8
 | WeightUnitCode | Element 7
 | Width | Element 12
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VC1


VC1 Constructor

VC1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► VC1()()()()
RDPCrystal EDI Library
Initializes a new instance of the VC1 class
Declaration Syntax
C# Visual Basic Visual C++
public VC1()
Public Sub New
public:
VC1()


Color Property

Color Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Color
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Color { get; set; }
Public Property Color As String
    Get
    Set
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}


Color1 Property

Color1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Color1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Color1 { get; set; }
Public Property Color1 As String
    Get
    Set
public:
property String^ Color1 {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► CurrencyCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Height
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Length
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► LocationIdentifier
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


MeasurementUnitQualifier Property

MeasurementUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► MeasurementUnitQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementUnitQualifier { get; set; }
Public Property MeasurementUnitQualifier As String
    Get
    Set
public:
property String^ MeasurementUnitQualifier {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► MonetaryAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


VehicleDimension Property

VehicleDimension Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► VehicleDimension
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleDimension { get; set; }
Public Property VehicleDimension As String
    Get
    Set
public:
property String^ VehicleDimension {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Volume
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


VolumeUnitQualifier Property

VolumeUnitQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► VolumeUnitQualifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeUnitQualifier { get; set; }
Public Property VolumeUnitQualifier As String
    Get
    Set
public:
property String^ VolumeUnitQualifier {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Weight
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► WeightUnitCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Width
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VC1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VDI Class

VDI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI
RDPCrystal EDI Library
Value Description or Information
Declaration Syntax
C# Visual Basic Visual C++
public class VDI : DocumentSegment
Public Class VDI _
    Inherits DocumentSegment
public ref class VDI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VDI()()()() | Initializes a new instance of the VDI class
 | CodeCategory | Element 1
 | CompositeQualifierIdentifier | Element 2
 | DateTimePeriod | Element 9
 | DateTimePeriodFormatQualifier | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoanPaymentTypeCode | Element 14
 | LoanPaymentTypeCode1 | Element 15
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Multiplier | Element 12
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 6
 | Number1 | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 4
 | Quantity | Element 3
 | Quantity1 | Element 11
 | RoundingSystemCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOfTimePeriodOrInterval | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VDI


VDI Constructor

VDI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► VDI()()()()
RDPCrystal EDI Library
Initializes a new instance of the VDI class
Declaration Syntax
C# Visual Basic Visual C++
public VDI()
Public Sub New
public:
VDI()


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}


CompositeQualifierIdentifier Property

CompositeQualifierIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► CompositeQualifierIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeQualifierIdentifier CompositeQualifierIdentifier { get; set; }
Public Property CompositeQualifierIdentifier As CompositeQualifierIdentifier
    Get
    Set
public:
property CompositeQualifierIdentifier^ CompositeQualifierIdentifier {
    CompositeQualifierIdentifier^ get ();
    void set (CompositeQualifierIdentifier^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► DateTimePeriod
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoanPaymentTypeCode Property

LoanPaymentTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► LoanPaymentTypeCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode { get; set; }
Public Property LoanPaymentTypeCode As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode {
    String^ get ();
    void set (String^ value);
}


LoanPaymentTypeCode1 Property

LoanPaymentTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► LoanPaymentTypeCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string LoanPaymentTypeCode1 { get; set; }
Public Property LoanPaymentTypeCode1 As String
    Get
    Set
public:
property String^ LoanPaymentTypeCode1 {
    String^ get ();
    void set (String^ value);
}


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Multiplier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Number
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}


Number1 Property

Number1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Number1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Number1 { get; set; }
Public Property Number1 As String
    Get
    Set
public:
property String^ Number1 {
    String^ get ();
    void set (String^ value);
}


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Percent
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Quantity1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}


RoundingSystemCode Property

RoundingSystemCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► RoundingSystemCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string RoundingSystemCode { get; set; }
Public Property RoundingSystemCode As String
    Get
    Set
public:
property String^ RoundingSystemCode {
    String^ get ();
    void set (String^ value);
}


UnitOfTimePeriodOrInterval Property

UnitOfTimePeriodOrInterval Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► UnitOfTimePeriodOrInterval
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOfTimePeriodOrInterval { get; set; }
Public Property UnitOfTimePeriodOrInterval As String
    Get
    Set
public:
property String^ UnitOfTimePeriodOrInterval {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VDI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VEH Class

VEH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH
RDPCrystal EDI Library
Vehicle Information
Declaration Syntax
C# Visual Basic Visual C++
public class VEH : DocumentSegment
Public Class VEH _
    Inherits DocumentSegment
public ref class VEH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VEH()()()() | Initializes a new instance of the VEH class
 | ActionCode | Element 16
 | AgencyQualifierCode | Element 4
 | Amount | Element 13
 | Amount1 | Element 15
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Length | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductDescriptionCode | Element 5
 | ProductDescriptionCode1 | Element 6
 | ProductDescriptionCode2 | Element 7
 | ReferenceIdentification | Element 9
 | StateOrProvinceCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VehicleIdentificationNumber | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | Year | Element 3
 | YesNoConditionOrResponseCode | Element 12
 | YesNoConditionOrResponseCode1 | Element 14
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VEH


VEH Constructor

VEH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► VEH()()()()
RDPCrystal EDI Library
Initializes a new instance of the VEH class
Declaration Syntax
C# Visual Basic Visual C++
public VEH()
Public Sub New
public:
VEH()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► ActionCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► AgencyQualifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► Amount
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Amount1 Property

Amount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► Amount1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Amount1 { get; set; }
Public Property Amount1 As String
    Get
    Set
public:
property String^ Amount1 {
    String^ get ();
    void set (String^ value);
}


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}


Length Property

Length Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► Length
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Length { get; set; }
Public Property Length As String
    Get
    Set
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► LocationIdentifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode Property

ProductDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► ProductDescriptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode { get; set; }
Public Property ProductDescriptionCode As String
    Get
    Set
public:
property String^ ProductDescriptionCode {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode1 Property

ProductDescriptionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► ProductDescriptionCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode1 { get; set; }
Public Property ProductDescriptionCode1 As String
    Get
    Set
public:
property String^ ProductDescriptionCode1 {
    String^ get ();
    void set (String^ value);
}


ProductDescriptionCode2 Property

ProductDescriptionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► ProductDescriptionCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDescriptionCode2 { get; set; }
Public Property ProductDescriptionCode2 As String
    Get
    Set
public:
property String^ ProductDescriptionCode2 {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► ReferenceIdentification
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► StateOrProvinceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


VehicleIdentificationNumber Property

VehicleIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► VehicleIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string VehicleIdentificationNumber { get; set; }
Public Property VehicleIdentificationNumber As String
    Get
    Set
public:
property String^ VehicleIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Year Property

Year Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► Year
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Year { get; set; }
Public Property Year As String
    Get
    Set
public:
property String^ Year {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VEH ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}


VID Class

VID Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID
RDPCrystal EDI Library
Conveyance Identification
Declaration Syntax
C# Visual Basic Visual C++
public class VID : DocumentSegment
Public Class VID _
    Inherits DocumentSegment
public ref class VID : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VID()()()() | Initializes a new instance of the VID class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 1
 | EquipmentInitial | Element 2
 | EquipmentLength | Element 6
 | EquipmentNumber | Element 3
 | EquipmentType | Element 9
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Height | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 10
 | LocationIdentifier | Element 12
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SealNumber | Element 4
 | SealNumber1 | Element 5
 | StandardCarrierAlphaCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceCode | Element 11
 | Width | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VID


VID Constructor

VID Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► VID()()()()
RDPCrystal EDI Library
Initializes a new instance of the VID class
Declaration Syntax
C# Visual Basic Visual C++
public VID()
Public Sub New
public:
VID()


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentLength Property

EquipmentLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► EquipmentLength
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentLength { get; set; }
Public Property EquipmentLength As String
    Get
    Set
public:
property String^ EquipmentLength {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► EquipmentType
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► Height
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► LocationIdentifier
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► SealNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealNumber1 Property

SealNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► SealNumber1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber1 { get; set; }
Public Property SealNumber1 As String
    Get
    Set
public:
property String^ SealNumber1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► TypeOfServiceCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► Width
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Width { get; set; }
Public Property Width As String
    Get
    Set
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VID ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VR Class

VR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR
RDPCrystal EDI Library
Rate Origin
Declaration Syntax
C# Visual Basic Visual C++
public class VR : DocumentSegment
Public Class VR _
    Inherits DocumentSegment
public ref class VR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VR()()()() | Initializes a new instance of the VR class
 | CurrencyCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExParte | Element 9
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 5
 | IdentificationCodeQualifier | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 3
 | TariffAgencyCode | Element 7
 | TariffNumber | Element 2
 | TariffSupplementIdentifier | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VR


VR Constructor

VR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► VR()()()()
RDPCrystal EDI Library
Initializes a new instance of the VR class
Declaration Syntax
C# Visual Basic Visual C++
public VR()
Public Sub New
public:
VR()


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► CurrencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


ExParte Property

ExParte Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► ExParte
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ExParte { get; set; }
Public Property ExParte As String
    Get
    Set
public:
property String^ ExParte {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► IdentificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TariffAgencyCode Property

TariffAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► TariffAgencyCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TariffAgencyCode { get; set; }
Public Property TariffAgencyCode As String
    Get
    Set
public:
property String^ TariffAgencyCode {
    String^ get ();
    void set (String^ value);
}


TariffNumber Property

TariffNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► TariffNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TariffNumber { get; set; }
Public Property TariffNumber As String
    Get
    Set
public:
property String^ TariffNumber {
    String^ get ();
    void set (String^ value);
}


TariffSupplementIdentifier Property

TariffSupplementIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► TariffSupplementIdentifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TariffSupplementIdentifier { get; set; }
Public Property TariffSupplementIdentifier As String
    Get
    Set
public:
property String^ TariffSupplementIdentifier {
    String^ get ();
    void set (String^ value);
}


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


VRC Class

VRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class VRC : DocumentSegment
Public Class VRC _
    Inherits DocumentSegment
public ref class VRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VRC()()()() | Initializes a new instance of the VRC class
 | DateTimePeriod | Element 2
 | DateTimePeriodFormatQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | RecoveryClassificationCode | Element 5
 | RecoveryConditionCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | VRC


VRC Constructor

VRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► VRC()()()()
RDPCrystal EDI Library
Initializes a new instance of the VRC class
Declaration Syntax
C# Visual Basic Visual C++
public VRC()
Public Sub New
public:
VRC()


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► DateTimePeriod
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


RecoveryClassificationCode Property

RecoveryClassificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► RecoveryClassificationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string RecoveryClassificationCode { get; set; }
Public Property RecoveryClassificationCode As String
    Get
    Set
public:
property String^ RecoveryClassificationCode {
    String^ get ();
    void set (String^ value);
}


RecoveryConditionCode Property

RecoveryConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► RecoveryConditionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string RecoveryConditionCode { get; set; }
Public Property RecoveryConditionCode As String
    Get
    Set
public:
property String^ RecoveryConditionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► VRC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W01 Class

W01 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01
RDPCrystal EDI Library
Line Item Detail - Warehouse
Declaration Syntax
C# Visual Basic Visual C++
public class W01 : DocumentSegment
Public Class W01 _
    Inherits DocumentSegment
public ref class W01 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W01()()()() | Initializes a new instance of the W01 class
 | CommodityCode | Element 11
 | CommodityCodeQualifier | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightClassCode | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletBlockAndTiers | Element 12
 | ProductServiceConditionCode | Element 14
 | ProductServiceID | Element 5
 | ProductServiceID1 | Element 7
 | ProductServiceID2 | Element 16
 | ProductServiceIDQualifier | Element 4
 | ProductServiceIDQualifier1 | Element 6
 | ProductServiceIDQualifier2 | Element 15
 | QuantityOrdered | Element 1
 | RateClassCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UPCCaseCode | Element 3
 | WarehouseLotNumber | Element 13
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W01


W01 Constructor

W01 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► W01()()()()
RDPCrystal EDI Library
Initializes a new instance of the W01 class
Declaration Syntax
C# Visual Basic Visual C++
public W01()
Public Sub New
public:
W01()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► CommodityCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


FreightClassCode Property

FreightClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► FreightClassCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightClassCode { get; set; }
Public Property FreightClassCode As String
    Get
    Set
public:
property String^ FreightClassCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PalletBlockAndTiers Property

PalletBlockAndTiers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► PalletBlockAndTiers
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PalletBlockAndTiers { get; set; }
Public Property PalletBlockAndTiers As String
    Get
    Set
public:
property String^ PalletBlockAndTiers {
    String^ get ();
    void set (String^ value);
}


ProductServiceConditionCode Property

ProductServiceConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceConditionCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceConditionCode { get; set; }
Public Property ProductServiceConditionCode As String
    Get
    Set
public:
property String^ ProductServiceConditionCode {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceID
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceID1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceID2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► QuantityOrdered
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


RateClassCode Property

RateClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► RateClassCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RateClassCode { get; set; }
Public Property RateClassCode As String
    Get
    Set
public:
property String^ RateClassCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► UPCCaseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


WarehouseLotNumber Property

WarehouseLotNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► WarehouseLotNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseLotNumber { get; set; }
Public Property WarehouseLotNumber As String
    Get
    Set
public:
property String^ WarehouseLotNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W01 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W03 Class

W03 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03
RDPCrystal EDI Library
Total Shipment Information
Declaration Syntax
C# Visual Basic Visual C++
public class W03 : DocumentSegment
Public Class W03 _
    Inherits DocumentSegment
public ref class W03 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W03()()()() | Initializes a new instance of the W03 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 5
 | UnitOrBasisForMeasurementCode2 | Element 7
 | Volume | Element 4
 | Weight | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W03


W03 Constructor

W03 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► W03()()()()
RDPCrystal EDI Library
Initializes a new instance of the W03 class
Declaration Syntax
C# Visual Basic Visual C++
public W03()
Public Sub New
public:
W03()


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► LadingQuantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► Volume
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W03 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W04 Class

W04 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04
RDPCrystal EDI Library
Item Detail Total
Declaration Syntax
C# Visual Basic Visual C++
public class W04 : DocumentSegment
Public Class W04 _
    Inherits DocumentSegment
public ref class W04 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W04()()()() | Initializes a new instance of the W04 class
 | CommodityCode | Element 11
 | CommodityCodeQualifier | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightClassCode | Element 8
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InboundConditionHoldCode | Element 13
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletBlockAndTiers | Element 12
 | ProductServiceID | Element 5
 | ProductServiceID1 | Element 7
 | ProductServiceID2 | Element 15
 | ProductServiceIDQualifier | Element 4
 | ProductServiceIDQualifier1 | Element 6
 | ProductServiceIDQualifier2 | Element 14
 | RateClassCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UPCCaseCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W04


W04 Constructor

W04 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► W04()()()()
RDPCrystal EDI Library
Initializes a new instance of the W04 class
Declaration Syntax
C# Visual Basic Visual C++
public W04()
Public Sub New
public:
W04()


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► CommodityCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


CommodityCodeQualifier Property

CommodityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► CommodityCodeQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCodeQualifier { get; set; }
Public Property CommodityCodeQualifier As String
    Get
    Set
public:
property String^ CommodityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


FreightClassCode Property

FreightClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► FreightClassCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FreightClassCode { get; set; }
Public Property FreightClassCode As String
    Get
    Set
public:
property String^ FreightClassCode {
    String^ get ();
    void set (String^ value);
}


InboundConditionHoldCode Property

InboundConditionHoldCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► InboundConditionHoldCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string InboundConditionHoldCode { get; set; }
Public Property InboundConditionHoldCode As String
    Get
    Set
public:
property String^ InboundConditionHoldCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


PalletBlockAndTiers Property

PalletBlockAndTiers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► PalletBlockAndTiers
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string PalletBlockAndTiers { get; set; }
Public Property PalletBlockAndTiers As String
    Get
    Set
public:
property String^ PalletBlockAndTiers {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► ProductServiceID
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► ProductServiceID1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► ProductServiceID2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


RateClassCode Property

RateClassCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► RateClassCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string RateClassCode { get; set; }
Public Property RateClassCode As String
    Get
    Set
public:
property String^ RateClassCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► UPCCaseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W04 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W05 Class

W05 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05
RDPCrystal EDI Library
Shipping Order Identification
Declaration Syntax
C# Visual Basic Visual C++
public class W05 : DocumentSegment
Public Class W05 _
    Inherits DocumentSegment
public ref class W05 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W05()()()() | Initializes a new instance of the W05 class
 | ActionCode | Element 7
 | DepositorOrderNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LinkSequenceNumber | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MasterReferenceLinkNumber | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderStatusCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W05


W05 Constructor

W05 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► W05()()()()
RDPCrystal EDI Library
Initializes a new instance of the W05 class
Declaration Syntax
C# Visual Basic Visual C++
public W05()
Public Sub New
public:
W05()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► ActionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


DepositorOrderNumber Property

DepositorOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► DepositorOrderNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DepositorOrderNumber { get; set; }
Public Property DepositorOrderNumber As String
    Get
    Set
public:
property String^ DepositorOrderNumber {
    String^ get ();
    void set (String^ value);
}


LinkSequenceNumber Property

LinkSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► LinkSequenceNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LinkSequenceNumber { get; set; }
Public Property LinkSequenceNumber As String
    Get
    Set
public:
property String^ LinkSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MasterReferenceLinkNumber Property

MasterReferenceLinkNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► MasterReferenceLinkNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MasterReferenceLinkNumber { get; set; }
Public Property MasterReferenceLinkNumber As String
    Get
    Set
public:
property String^ MasterReferenceLinkNumber {
    String^ get ();
    void set (String^ value);
}


OrderStatusCode Property

OrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► OrderStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string OrderStatusCode { get; set; }
Public Property OrderStatusCode As String
    Get
    Set
public:
property String^ OrderStatusCode {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W05 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W06 Class

W06 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06
RDPCrystal EDI Library
Warehouse Shipment Identification
Declaration Syntax
C# Visual Basic Visual C++
public class W06 : DocumentSegment
Public Class W06 _
    Inherits DocumentSegment
public ref class W06 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W06()()()() | Initializes a new instance of the W06 class
 | ActionCode | Element 12
 | AgentShipmentIDNumber | Element 5
 | Date | Element 3
 | DepositorOrderNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LinkSequenceNumber | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MasterReferenceLinkNumber | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 6
 | ReportingCode | Element 1
 | ShipmentIdentificationNumber | Element 4
 | ShippingDateChangeReasonCode | Element 10
 | SpecialHandlingCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionTypeCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W06


W06 Constructor

W06 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► W06()()()()
RDPCrystal EDI Library
Initializes a new instance of the W06 class
Declaration Syntax
C# Visual Basic Visual C++
public W06()
Public Sub New
public:
W06()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► ActionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AgentShipmentIDNumber Property

AgentShipmentIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► AgentShipmentIDNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AgentShipmentIDNumber { get; set; }
Public Property AgentShipmentIDNumber As String
    Get
    Set
public:
property String^ AgentShipmentIDNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DepositorOrderNumber Property

DepositorOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► DepositorOrderNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DepositorOrderNumber { get; set; }
Public Property DepositorOrderNumber As String
    Get
    Set
public:
property String^ DepositorOrderNumber {
    String^ get ();
    void set (String^ value);
}


LinkSequenceNumber Property

LinkSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► LinkSequenceNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LinkSequenceNumber { get; set; }
Public Property LinkSequenceNumber As String
    Get
    Set
public:
property String^ LinkSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MasterReferenceLinkNumber Property

MasterReferenceLinkNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► MasterReferenceLinkNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MasterReferenceLinkNumber { get; set; }
Public Property MasterReferenceLinkNumber As String
    Get
    Set
public:
property String^ MasterReferenceLinkNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


ReportingCode Property

ReportingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► ReportingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportingCode { get; set; }
Public Property ReportingCode As String
    Get
    Set
public:
property String^ ReportingCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


ShippingDateChangeReasonCode Property

ShippingDateChangeReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► ShippingDateChangeReasonCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingDateChangeReasonCode { get; set; }
Public Property ShippingDateChangeReasonCode As String
    Get
    Set
public:
property String^ ShippingDateChangeReasonCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► TransactionTypeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W06 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W07 Class

W07 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07
RDPCrystal EDI Library
Item Detail For Stock Receipt
Declaration Syntax
C# Visual Basic Visual C++
public class W07 : DocumentSegment
Public Class W07 _
    Inherits DocumentSegment
public ref class W07 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W07()()()() | Initializes a new instance of the W07 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 5
 | ProductServiceID1 | Element 7
 | ProductServiceID2 | Element 11
 | ProductServiceIDQualifier | Element 4
 | ProductServiceIDQualifier1 | Element 6
 | ProductServiceIDQualifier2 | Element 10
 | QuantityReceived | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | UPCCaseCode | Element 3
 | WarehouseDetailAdjustmentIdentifier | Element 9
 | WarehouseLotNumber | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W07


W07 Constructor

W07 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► W07()()()()
RDPCrystal EDI Library
Initializes a new instance of the W07 class
Declaration Syntax
C# Visual Basic Visual C++
public W07()
Public Sub New
public:
W07()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► ProductServiceID
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► ProductServiceID1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► ProductServiceID2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


QuantityReceived Property

QuantityReceived Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► QuantityReceived
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityReceived { get; set; }
Public Property QuantityReceived As String
    Get
    Set
public:
property String^ QuantityReceived {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► UPCCaseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


WarehouseDetailAdjustmentIdentifier Property

WarehouseDetailAdjustmentIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► WarehouseDetailAdjustmentIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseDetailAdjustmentIdentifier { get; set; }
Public Property WarehouseDetailAdjustmentIdentifier As String
    Get
    Set
public:
property String^ WarehouseDetailAdjustmentIdentifier {
    String^ get ();
    void set (String^ value);
}


WarehouseLotNumber Property

WarehouseLotNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► WarehouseLotNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseLotNumber { get; set; }
Public Property WarehouseLotNumber As String
    Get
    Set
public:
property String^ WarehouseLotNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W07 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W08 Class

W08 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08
RDPCrystal EDI Library
Receipt Carrier Information
Declaration Syntax
C# Visual Basic Visual C++
public class W08 : DocumentSegment
Public Class W08 _
    Inherits DocumentSegment
public ref class W08 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W08()()()() | Initializes a new instance of the W08 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 4
 | EquipmentNumber | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Routing | Element 3
 | SealNumber | Element 6
 | SealNumber1 | Element 7
 | SealStatusCode | Element 8
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 1
 | UnitLoadOptionCode | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W08


W08 Constructor

W08 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► W08()()()()
RDPCrystal EDI Library
Initializes a new instance of the W08 class
Declaration Syntax
C# Visual Basic Visual C++
public W08()
Public Sub New
public:
W08()


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► EquipmentInitial
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► EquipmentNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► Routing
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► SealNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealNumber1 Property

SealNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► SealNumber1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber1 { get; set; }
Public Property SealNumber1 As String
    Get
    Set
public:
property String^ SealNumber1 {
    String^ get ();
    void set (String^ value);
}


SealStatusCode Property

SealStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► SealStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SealStatusCode { get; set; }
Public Property SealStatusCode As String
    Get
    Set
public:
property String^ SealStatusCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitLoadOptionCode Property

UnitLoadOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► UnitLoadOptionCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitLoadOptionCode { get; set; }
Public Property UnitLoadOptionCode As String
    Get
    Set
public:
property String^ UnitLoadOptionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W08 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W09 Class

W09 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09
RDPCrystal EDI Library
Equipment and Temperature
Declaration Syntax
C# Visual Basic Visual C++
public class W09 : DocumentSegment
Public Class W09 _
    Inherits DocumentSegment
public ref class W09 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W09()()()() | Initializes a new instance of the W09 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 8
 | Quantity | Element 9
 | Temperature | Element 2
 | Temperature1 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 5
 | VentSettingCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W09


W09 Constructor

W09 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► W09()()()()
RDPCrystal EDI Library
Initializes a new instance of the W09 class
Declaration Syntax
C# Visual Basic Visual C++
public W09()
Public Sub New
public:
W09()


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► FreeFormMessage
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► Percent
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► Quantity
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► Temperature
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


Temperature1 Property

Temperature1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► Temperature1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature1 { get; set; }
Public Property Temperature1 As String
    Get
    Set
public:
property String^ Temperature1 {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


VentSettingCode Property

VentSettingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► VentSettingCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VentSettingCode { get; set; }
Public Property VentSettingCode As String
    Get
    Set
public:
property String^ VentSettingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W09 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W1 Class

W1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W1
RDPCrystal EDI Library
Block Identification
Declaration Syntax
C# Visual Basic Visual C++
public class W1 : DocumentSegment
Public Class W1 _
    Inherits DocumentSegment
public ref class W1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W1()()()() | Initializes a new instance of the W1 class
 | BlockIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W1


W1 Constructor

W1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W1 ► W1()()()()
RDPCrystal EDI Library
Initializes a new instance of the W1 class
Declaration Syntax
C# Visual Basic Visual C++
public W1()
Public Sub New
public:
W1()


BlockIdentification Property

BlockIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W1 ► BlockIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BlockIdentification { get; set; }
Public Property BlockIdentification As String
    Get
    Set
public:
property String^ BlockIdentification {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W10 Class

W10 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10
RDPCrystal EDI Library
Warehouse Additional Carrier Information
Declaration Syntax
C# Visual Basic Visual C++
public class W10 : DocumentSegment
Public Class W10 _
    Inherits DocumentSegment
public ref class W10 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W10()()()() | Initializes a new instance of the W10 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletExchangeCode | Element 3
 | QuantityOfPalletsShipped | Element 2
 | SealNumber | Element 4
 | SealNumber1 | Element 5
 | Temperature | Element 6
 | Temperature1 | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitLoadOptionCode | Element 1
 | UnitOrBasisForMeasurementCode | Element 7
 | UnitOrBasisForMeasurementCode1 | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W10


W10 Constructor

W10 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► W10()()()()
RDPCrystal EDI Library
Initializes a new instance of the W10 class
Declaration Syntax
C# Visual Basic Visual C++
public W10()
Public Sub New
public:
W10()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► PalletExchangeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


QuantityOfPalletsShipped Property

QuantityOfPalletsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► QuantityOfPalletsShipped
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOfPalletsShipped { get; set; }
Public Property QuantityOfPalletsShipped As String
    Get
    Set
public:
property String^ QuantityOfPalletsShipped {
    String^ get ();
    void set (String^ value);
}


SealNumber Property

SealNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► SealNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber { get; set; }
Public Property SealNumber As String
    Get
    Set
public:
property String^ SealNumber {
    String^ get ();
    void set (String^ value);
}


SealNumber1 Property

SealNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► SealNumber1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SealNumber1 { get; set; }
Public Property SealNumber1 As String
    Get
    Set
public:
property String^ SealNumber1 {
    String^ get ();
    void set (String^ value);
}


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► Temperature
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


Temperature1 Property

Temperature1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► Temperature1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature1 { get; set; }
Public Property Temperature1 As String
    Get
    Set
public:
property String^ Temperature1 {
    String^ get ();
    void set (String^ value);
}


UnitLoadOptionCode Property

UnitLoadOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► UnitLoadOptionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitLoadOptionCode { get; set; }
Public Property UnitLoadOptionCode As String
    Get
    Set
public:
property String^ UnitLoadOptionCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W10 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W12 Class

W12 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12
RDPCrystal EDI Library
Warehouse Item Detail
Declaration Syntax
C# Visual Basic Visual C++
public class W12 : DocumentSegment
Public Class W12 _
    Inherits DocumentSegment
public ref class W12 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W12()()()() | Initializes a new instance of the W12 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LineItemChangeReasonCode | Element 19
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 8
 | ProductServiceID1 | Element 18
 | ProductServiceID2 | Element 22
 | ProductServiceIDQualifier | Element 7
 | ProductServiceIDQualifier1 | Element 17
 | ProductServiceIDQualifier2 | Element 21
 | QuantityDifference | Element 4
 | QuantityOrdered | Element 2
 | ShipmentOrderStatusCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 5
 | UPCCaseCode | Element 6
 | UPCCaseCode1 | Element 16
 | WarehouseDetailAdjustmentIdentifier | Element 20
 | WarehouseLotNumber | Element 9
 | Weight | Element 10
 | Weight1 | Element 13
 | WeightQualifier | Element 11
 | WeightQualifier1 | Element 14
 | WeightUnitCode | Element 12
 | WeightUnitCode1 | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W12


W12 Constructor

W12 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► W12()()()()
RDPCrystal EDI Library
Initializes a new instance of the W12 class
Declaration Syntax
C# Visual Basic Visual C++
public W12()
Public Sub New
public:
W12()


LineItemChangeReasonCode Property

LineItemChangeReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► LineItemChangeReasonCode
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string LineItemChangeReasonCode { get; set; }
Public Property LineItemChangeReasonCode As String
    Get
    Set
public:
property String^ LineItemChangeReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ProductServiceID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ProductServiceID1
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ProductServiceID2
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


QuantityDifference Property

QuantityDifference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► QuantityDifference
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityDifference { get; set; }
Public Property QuantityDifference As String
    Get
    Set
public:
property String^ QuantityDifference {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► QuantityOrdered
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► UPCCaseCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode1 Property

UPCCaseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► UPCCaseCode1
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode1 { get; set; }
Public Property UPCCaseCode1 As String
    Get
    Set
public:
property String^ UPCCaseCode1 {
    String^ get ();
    void set (String^ value);
}


WarehouseDetailAdjustmentIdentifier Property

WarehouseDetailAdjustmentIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► WarehouseDetailAdjustmentIdentifier
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseDetailAdjustmentIdentifier { get; set; }
Public Property WarehouseDetailAdjustmentIdentifier As String
    Get
    Set
public:
property String^ WarehouseDetailAdjustmentIdentifier {
    String^ get ();
    void set (String^ value);
}


WarehouseLotNumber Property

WarehouseLotNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► WarehouseLotNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseLotNumber { get; set; }
Public Property WarehouseLotNumber As String
    Get
    Set
public:
property String^ WarehouseLotNumber {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► Weight
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► Weight1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► WeightQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightQualifier1 Property

WeightQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► WeightQualifier1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier1 { get; set; }
Public Property WeightQualifier1 As String
    Get
    Set
public:
property String^ WeightQualifier1 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► WeightUnitCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode1 Property

WeightUnitCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► WeightUnitCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode1 { get; set; }
Public Property WeightUnitCode1 As String
    Get
    Set
public:
property String^ WeightUnitCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W12 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W13 Class

W13 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13
RDPCrystal EDI Library
Item Detail Exception
Declaration Syntax
C# Visual Basic Visual C++
public class W13 : DocumentSegment
Public Class W13 _
    Inherits DocumentSegment
public ref class W13 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W13()()()() | Initializes a new instance of the W13 class
 | DamageReasonCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 1
 | ReceivingConditionCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | WarehouseLotNumber | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W13


W13 Constructor

W13 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► W13()()()()
RDPCrystal EDI Library
Initializes a new instance of the W13 class
Declaration Syntax
C# Visual Basic Visual C++
public W13()
Public Sub New
public:
W13()


DamageReasonCode Property

DamageReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► DamageReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DamageReasonCode { get; set; }
Public Property DamageReasonCode As String
    Get
    Set
public:
property String^ DamageReasonCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► Quantity
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReceivingConditionCode Property

ReceivingConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► ReceivingConditionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivingConditionCode { get; set; }
Public Property ReceivingConditionCode As String
    Get
    Set
public:
property String^ ReceivingConditionCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


WarehouseLotNumber Property

WarehouseLotNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► WarehouseLotNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseLotNumber { get; set; }
Public Property WarehouseLotNumber As String
    Get
    Set
public:
property String^ WarehouseLotNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W13 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W14 Class

W14 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14
RDPCrystal EDI Library
Total Receipt Information
Declaration Syntax
C# Visual Basic Visual C++
public class W14 : DocumentSegment
Public Class W14 _
    Inherits DocumentSegment
public ref class W14 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W14()()()() | Initializes a new instance of the W14 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LadingQuantity | Element 5
 | LadingQuantityReceived | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfUnitsShipped | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | QuantityDamagedOnHold | Element 3
 | QuantityReceived | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W14


W14 Constructor

W14 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► W14()()()()
RDPCrystal EDI Library
Initializes a new instance of the W14 class
Declaration Syntax
C# Visual Basic Visual C++
public W14()
Public Sub New
public:
W14()


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► LadingQuantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


LadingQuantityReceived Property

LadingQuantityReceived Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► LadingQuantityReceived
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantityReceived { get; set; }
Public Property LadingQuantityReceived As String
    Get
    Set
public:
property String^ LadingQuantityReceived {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfUnitsShipped Property

NumberOfUnitsShipped Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► NumberOfUnitsShipped
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfUnitsShipped { get; set; }
Public Property NumberOfUnitsShipped As String
    Get
    Set
public:
property String^ NumberOfUnitsShipped {
    String^ get ();
    void set (String^ value);
}


QuantityDamagedOnHold Property

QuantityDamagedOnHold Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► QuantityDamagedOnHold
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityDamagedOnHold { get; set; }
Public Property QuantityDamagedOnHold As String
    Get
    Set
public:
property String^ QuantityDamagedOnHold {
    String^ get ();
    void set (String^ value);
}


QuantityReceived Property

QuantityReceived Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► QuantityReceived
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityReceived { get; set; }
Public Property QuantityReceived As String
    Get
    Set
public:
property String^ QuantityReceived {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W14 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W15 Class

W15 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15
RDPCrystal EDI Library
Warehouse Adjustment Identification
Declaration Syntax
C# Visual Basic Visual C++
public class W15 : DocumentSegment
Public Class W15 _
    Inherits DocumentSegment
public ref class W15 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W15()()()() | Initializes a new instance of the W15 class
 | ActionCode | Element 6
 | AdjustmentNumber | Element 2
 | AdjustmentNumber1 | Element 3
 | Date | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 4
 | TransactionTypeCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W15


W15 Constructor

W15 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► W15()()()()
RDPCrystal EDI Library
Initializes a new instance of the W15 class
Declaration Syntax
C# Visual Basic Visual C++
public W15()
Public Sub New
public:
W15()


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► ActionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}


AdjustmentNumber Property

AdjustmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► AdjustmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentNumber { get; set; }
Public Property AdjustmentNumber As String
    Get
    Set
public:
property String^ AdjustmentNumber {
    String^ get ();
    void set (String^ value);
}


AdjustmentNumber1 Property

AdjustmentNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► AdjustmentNumber1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentNumber1 { get; set; }
Public Property AdjustmentNumber1 As String
    Get
    Set
public:
property String^ AdjustmentNumber1 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► Date
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► TransactionTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W15 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W17 Class

W17 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17
RDPCrystal EDI Library
Warehouse Receipt Identification
Declaration Syntax
C# Visual Basic Visual C++
public class W17 : DocumentSegment
Public Class W17 _
    Inherits DocumentSegment
public ref class W17 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W17()()()() | Initializes a new instance of the W17 class
 | Date | Element 2
 | DepositorOrderNumber | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LinkSequenceNumber | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MasterReferenceLinkNumber | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportingCode | Element 1
 | ShipmentIdentificationNumber | Element 5
 | Time | Element 7
 | TimeQualifier | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WarehouseReceiptNumber | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W17


W17 Constructor

W17 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► W17()()()()
RDPCrystal EDI Library
Initializes a new instance of the W17 class
Declaration Syntax
C# Visual Basic Visual C++
public W17()
Public Sub New
public:
W17()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DepositorOrderNumber Property

DepositorOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► DepositorOrderNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DepositorOrderNumber { get; set; }
Public Property DepositorOrderNumber As String
    Get
    Set
public:
property String^ DepositorOrderNumber {
    String^ get ();
    void set (String^ value);
}


LinkSequenceNumber Property

LinkSequenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► LinkSequenceNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LinkSequenceNumber { get; set; }
Public Property LinkSequenceNumber As String
    Get
    Set
public:
property String^ LinkSequenceNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


MasterReferenceLinkNumber Property

MasterReferenceLinkNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► MasterReferenceLinkNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MasterReferenceLinkNumber { get; set; }
Public Property MasterReferenceLinkNumber As String
    Get
    Set
public:
property String^ MasterReferenceLinkNumber {
    String^ get ();
    void set (String^ value);
}


ReportingCode Property

ReportingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► ReportingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportingCode { get; set; }
Public Property ReportingCode As String
    Get
    Set
public:
property String^ ReportingCode {
    String^ get ();
    void set (String^ value);
}


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► Time
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeQualifier Property

TimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► TimeQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimeQualifier { get; set; }
Public Property TimeQualifier As String
    Get
    Set
public:
property String^ TimeQualifier {
    String^ get ();
    void set (String^ value);
}


WarehouseReceiptNumber Property

WarehouseReceiptNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► WarehouseReceiptNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseReceiptNumber { get; set; }
Public Property WarehouseReceiptNumber As String
    Get
    Set
public:
property String^ WarehouseReceiptNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W17 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W18 Class

W18 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18
RDPCrystal EDI Library
Probe Temperatures
Declaration Syntax
C# Visual Basic Visual C++
public class W18 : DocumentSegment
Public Class W18 _
    Inherits DocumentSegment
public ref class W18 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W18()()()() | Initializes a new instance of the W18 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Temperature | Element 2
 | TemperatureProbeLocationCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W18


W18 Constructor

W18 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18 ► W18()()()()
RDPCrystal EDI Library
Initializes a new instance of the W18 class
Declaration Syntax
C# Visual Basic Visual C++
public W18()
Public Sub New
public:
W18()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Temperature Property

Temperature Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18 ► Temperature
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Temperature { get; set; }
Public Property Temperature As String
    Get
    Set
public:
property String^ Temperature {
    String^ get ();
    void set (String^ value);
}


TemperatureProbeLocationCode Property

TemperatureProbeLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18 ► TemperatureProbeLocationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TemperatureProbeLocationCode { get; set; }
Public Property TemperatureProbeLocationCode As String
    Get
    Set
public:
property String^ TemperatureProbeLocationCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W18 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W19 Class

W19 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19
RDPCrystal EDI Library
Warehouse Adjustment Item Detail
Declaration Syntax
C# Visual Basic Visual C++
public class W19 : DocumentSegment
Public Class W19 _
    Inherits DocumentSegment
public ref class W19 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W19()()()() | Initializes a new instance of the W19 class
 | CreditDebitQuantity | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InventoryTransactionTypeCode | Element 16
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 6
 | ProductServiceID1 | Element 8
 | ProductServiceID2 | Element 18
 | ProductServiceIDQualifier | Element 5
 | ProductServiceIDQualifier1 | Element 7
 | ProductServiceIDQualifier2 | Element 17
 | QuantityOrStatusAdjustmentReasonCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UPCCaseCode | Element 4
 | WarehouseLotNumber | Element 9
 | Weight | Element 10
 | Weight1 | Element 13
 | WeightQualifier | Element 11
 | WeightQualifier1 | Element 14
 | WeightUnitCode | Element 12
 | WeightUnitCode1 | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W19


W19 Constructor

W19 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► W19()()()()
RDPCrystal EDI Library
Initializes a new instance of the W19 class
Declaration Syntax
C# Visual Basic Visual C++
public W19()
Public Sub New
public:
W19()


CreditDebitQuantity Property

CreditDebitQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► CreditDebitQuantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitQuantity { get; set; }
Public Property CreditDebitQuantity As String
    Get
    Set
public:
property String^ CreditDebitQuantity {
    String^ get ();
    void set (String^ value);
}


InventoryTransactionTypeCode Property

InventoryTransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► InventoryTransactionTypeCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string InventoryTransactionTypeCode { get; set; }
Public Property InventoryTransactionTypeCode As String
    Get
    Set
public:
property String^ InventoryTransactionTypeCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► ProductServiceID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► ProductServiceID1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► ProductServiceID2
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}


QuantityOrStatusAdjustmentReasonCode Property

QuantityOrStatusAdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► QuantityOrStatusAdjustmentReasonCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrStatusAdjustmentReasonCode { get; set; }
Public Property QuantityOrStatusAdjustmentReasonCode As String
    Get
    Set
public:
property String^ QuantityOrStatusAdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UPCCaseCode Property

UPCCaseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► UPCCaseCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UPCCaseCode { get; set; }
Public Property UPCCaseCode As String
    Get
    Set
public:
property String^ UPCCaseCode {
    String^ get ();
    void set (String^ value);
}


WarehouseLotNumber Property

WarehouseLotNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► WarehouseLotNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string WarehouseLotNumber { get; set; }
Public Property WarehouseLotNumber As String
    Get
    Set
public:
property String^ WarehouseLotNumber {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► Weight
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► Weight1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► WeightQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightQualifier1 Property

WeightQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► WeightQualifier1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier1 { get; set; }
Public Property WeightQualifier1 As String
    Get
    Set
public:
property String^ WeightQualifier1 {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► WeightUnitCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode1 Property

WeightUnitCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► WeightUnitCode1
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode1 { get; set; }
Public Property WeightUnitCode1 As String
    Get
    Set
public:
property String^ WeightUnitCode1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W19 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W2 Class

W2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2
RDPCrystal EDI Library
Equipment Identification
Declaration Syntax
C# Visual Basic Visual C++
public class W2 : DocumentSegment
Public Class W2 _
    Inherits DocumentSegment
public ref class W2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W2()()()() | Initializes a new instance of the W2 class
 | CarServiceOrderCode | Element 8
 | CarTypeCode | Element 15
 | CommodityCode | Element 3
 | Date | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 4
 | EquipmentInitial | Element 1
 | EquipmentInitial1 | Element 11
 | EquipmentNumber | Element 2
 | EquipmentNumber1 | Element 12
 | EquipmentNumberCheckDigit | Element 13
 | EquipmentStatusCode | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermodalServiceCode | Element 7
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NetTons | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Position | Element 14
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfLocomotiveMaintenanceCode | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 16
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W2


W2 Constructor

W2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► W2()()()()
RDPCrystal EDI Library
Initializes a new instance of the W2 class
Declaration Syntax
C# Visual Basic Visual C++
public W2()
Public Sub New
public:
W2()


CarServiceOrderCode Property

CarServiceOrderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► CarServiceOrderCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CarServiceOrderCode { get; set; }
Public Property CarServiceOrderCode As String
    Get
    Set
public:
property String^ CarServiceOrderCode {
    String^ get ();
    void set (String^ value);
}


CarTypeCode Property

CarTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► CarTypeCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CarTypeCode { get; set; }
Public Property CarTypeCode As String
    Get
    Set
public:
property String^ CarTypeCode {
    String^ get ();
    void set (String^ value);
}


CommodityCode Property

CommodityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► CommodityCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommodityCode { get; set; }
Public Property CommodityCode As String
    Get
    Set
public:
property String^ CommodityCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► Date
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentInitial
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial1 Property

EquipmentInitial1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentInitial1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial1 { get; set; }
Public Property EquipmentInitial1 As String
    Get
    Set
public:
property String^ EquipmentInitial1 {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber1 Property

EquipmentNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentNumber1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber1 { get; set; }
Public Property EquipmentNumber1 As String
    Get
    Set
public:
property String^ EquipmentNumber1 {
    String^ get ();
    void set (String^ value);
}


EquipmentNumberCheckDigit Property

EquipmentNumberCheckDigit Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentNumberCheckDigit
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumberCheckDigit { get; set; }
Public Property EquipmentNumberCheckDigit As String
    Get
    Set
public:
property String^ EquipmentNumberCheckDigit {
    String^ get ();
    void set (String^ value);
}


EquipmentStatusCode Property

EquipmentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► EquipmentStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentStatusCode { get; set; }
Public Property EquipmentStatusCode As String
    Get
    Set
public:
property String^ EquipmentStatusCode {
    String^ get ();
    void set (String^ value);
}


IntermodalServiceCode Property

IntermodalServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► IntermodalServiceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalServiceCode { get; set; }
Public Property IntermodalServiceCode As String
    Get
    Set
public:
property String^ IntermodalServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NetTons Property

NetTons Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► NetTons
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NetTons { get; set; }
Public Property NetTons As String
    Get
    Set
public:
property String^ NetTons {
    String^ get ();
    void set (String^ value);
}


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► Position
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}


TypeOfLocomotiveMaintenanceCode Property

TypeOfLocomotiveMaintenanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► TypeOfLocomotiveMaintenanceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfLocomotiveMaintenanceCode { get; set; }
Public Property TypeOfLocomotiveMaintenanceCode As String
    Get
    Set
public:
property String^ TypeOfLocomotiveMaintenanceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W2 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


W20 Class

W20 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20
RDPCrystal EDI Library
Line-Item Detail - Miscellaneous
Declaration Syntax
C# Visual Basic Visual C++
public class W20 : DocumentSegment
Public Class W20 _
    Inherits DocumentSegment
public ref class W20 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W20()()()() | Initializes a new instance of the W20 class
 | Color | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Pack | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Size | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 9
 | UnitWeight | Element 7
 | Volume | Element 8
 | Weight | Element 4
 | WeightQualifier | Element 5
 | WeightUnitCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W20


W20 Constructor

W20 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► W20()()()()
RDPCrystal EDI Library
Initializes a new instance of the W20 class
Declaration Syntax
C# Visual Basic Visual C++
public W20()
Public Sub New
public:
W20()


Color Property

Color Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Color
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Color { get; set; }
Public Property Color As String
    Get
    Set
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Pack Property

Pack Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Pack
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Pack { get; set; }
Public Property Pack As String
    Get
    Set
public:
property String^ Pack {
    String^ get ();
    void set (String^ value);
}


Size Property

Size Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Size
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Size { get; set; }
Public Property Size As String
    Get
    Set
public:
property String^ Size {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


UnitWeight Property

UnitWeight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► UnitWeight
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitWeight { get; set; }
Public Property UnitWeight As String
    Get
    Set
public:
property String^ UnitWeight {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Volume
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Weight
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► WeightQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► WeightUnitCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W20 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W27 Class

W27 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27
RDPCrystal EDI Library
Carrier Detail
Declaration Syntax
C# Visual Basic Visual C++
public class W27 : DocumentSegment
Public Class W27 _
    Inherits DocumentSegment
public ref class W27 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W27()()()() | Initializes a new instance of the W27 class
 | CarrierRouteChangeReasonCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentDescriptionCode | Element 5
 | EquipmentInitial | Element 6
 | EquipmentNumber | Element 7
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Routing | Element 3
 | ShipmentMethodOfPayment | Element 4
 | ShipmentOrderStatusCode | Element 8
 | SpecialHandlingCode | Element 9
 | StandardCarrierAlphaCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W27


W27 Constructor

W27 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► W27()()()()
RDPCrystal EDI Library
Initializes a new instance of the W27 class
Declaration Syntax
C# Visual Basic Visual C++
public W27()
Public Sub New
public:
W27()


CarrierRouteChangeReasonCode Property

CarrierRouteChangeReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► CarrierRouteChangeReasonCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CarrierRouteChangeReasonCode { get; set; }
Public Property CarrierRouteChangeReasonCode As String
    Get
    Set
public:
property String^ CarrierRouteChangeReasonCode {
    String^ get ();
    void set (String^ value);
}


EquipmentDescriptionCode Property

EquipmentDescriptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► EquipmentDescriptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentDescriptionCode { get; set; }
Public Property EquipmentDescriptionCode As String
    Get
    Set
public:
property String^ EquipmentDescriptionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► EquipmentInitial
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► EquipmentNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► Routing
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


ShipmentOrderStatusCode Property

ShipmentOrderStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► ShipmentOrderStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentOrderStatusCode { get; set; }
Public Property ShipmentOrderStatusCode As String
    Get
    Set
public:
property String^ ShipmentOrderStatusCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W27 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W28 Class

W28 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28
RDPCrystal EDI Library
Consolidation Information
Declaration Syntax
C# Visual Basic Visual C++
public class W28 : DocumentSegment
Public Class W28 _
    Inherits DocumentSegment
public ref class W28 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W28()()()() | Initializes a new instance of the W28 class
 | BillOfLadingWaybillNumber | Element 8
 | ConsolidationCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 6
 | LocationQualifier | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalStopoffs | Element 5
 | Weight | Element 2
 | WeightQualifier | Element 3
 | WeightUnitCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W28


W28 Constructor

W28 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► W28()()()()
RDPCrystal EDI Library
Initializes a new instance of the W28 class
Declaration Syntax
C# Visual Basic Visual C++
public W28()
Public Sub New
public:
W28()


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


ConsolidationCode Property

ConsolidationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► ConsolidationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConsolidationCode { get; set; }
Public Property ConsolidationCode As String
    Get
    Set
public:
property String^ ConsolidationCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► LocationIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► LocationQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


TotalStopoffs Property

TotalStopoffs Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► TotalStopoffs
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TotalStopoffs { get; set; }
Public Property TotalStopoffs As String
    Get
    Set
public:
property String^ TotalStopoffs {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


WeightQualifier Property

WeightQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► WeightQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string WeightQualifier { get; set; }
Public Property WeightQualifier As String
    Get
    Set
public:
property String^ WeightQualifier {
    String^ get ();
    void set (String^ value);
}


WeightUnitCode Property

WeightUnitCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► WeightUnitCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WeightUnitCode { get; set; }
Public Property WeightUnitCode As String
    Get
    Set
public:
property String^ WeightUnitCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W28 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W3 Class

W3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3
RDPCrystal EDI Library
Consignee Information
Declaration Syntax
C# Visual Basic Visual C++
public class W3 : DocumentSegment
Public Class W3 _
    Inherits DocumentSegment
public ref class W3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W3()()()() | Initializes a new instance of the W3 class
 | AbbreviatedCustomerName | Element 3
 | CityName | Element 4
 | CityNameQualifierCode | Element 6
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillNumber | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W3


W3 Constructor

W3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► W3()()()()
RDPCrystal EDI Library
Initializes a new instance of the W3 class
Declaration Syntax
C# Visual Basic Visual C++
public W3()
Public Sub New
public:
W3()


AbbreviatedCustomerName Property

AbbreviatedCustomerName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► AbbreviatedCustomerName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AbbreviatedCustomerName { get; set; }
Public Property AbbreviatedCustomerName As String
    Get
    Set
public:
property String^ AbbreviatedCustomerName {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityNameQualifierCode Property

CityNameQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► CityNameQualifierCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityNameQualifierCode { get; set; }
Public Property CityNameQualifierCode As String
    Get
    Set
public:
property String^ CityNameQualifierCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► WaybillNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W4 Class

W4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4
RDPCrystal EDI Library
Consignor Information
Declaration Syntax
C# Visual Basic Visual C++
public class W4 : DocumentSegment
Public Class W4 _
    Inherits DocumentSegment
public ref class W4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W4()()()() | Initializes a new instance of the W4 class
 | AbbreviatedCustomerName | Element 1
 | CityName | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreightStationAccountingCode | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 2
 | StateOrProvinceCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W4


W4 Constructor

W4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► W4()()()()
RDPCrystal EDI Library
Initializes a new instance of the W4 class
Declaration Syntax
C# Visual Basic Visual C++
public W4()
Public Sub New
public:
W4()


AbbreviatedCustomerName Property

AbbreviatedCustomerName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► AbbreviatedCustomerName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AbbreviatedCustomerName { get; set; }
Public Property AbbreviatedCustomerName As String
    Get
    Set
public:
property String^ AbbreviatedCustomerName {
    String^ get ();
    void set (String^ value);
}


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► CityName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


FreightStationAccountingCode Property

FreightStationAccountingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► FreightStationAccountingCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FreightStationAccountingCode { get; set; }
Public Property FreightStationAccountingCode As String
    Get
    Set
public:
property String^ FreightStationAccountingCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W5 Class

W5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5
RDPCrystal EDI Library
Route Information
Declaration Syntax
C# Visual Basic Visual C++
public class W5 : DocumentSegment
Public Class W5 _
    Inherits DocumentSegment
public ref class W5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W5()()()() | Initializes a new instance of the W5 class
 | CityName | Element 2
 | CityName1 | Element 4
 | CityName2 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 3
 | StandardCarrierAlphaCode2 | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W5


W5 Constructor

W5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► W5()()()()
RDPCrystal EDI Library
Initializes a new instance of the W5 class
Declaration Syntax
C# Visual Basic Visual C++
public W5()
Public Sub New
public:
W5()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► CityName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CityName1 Property

CityName1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► CityName1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CityName1 { get; set; }
Public Property CityName1 As String
    Get
    Set
public:
property String^ CityName1 {
    String^ get ();
    void set (String^ value);
}


CityName2 Property

CityName2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► CityName2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName2 { get; set; }
Public Property CityName2 As String
    Get
    Set
public:
property String^ CityName2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W6 Class

W6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6
RDPCrystal EDI Library
Special Handling Information
Declaration Syntax
C# Visual Basic Visual C++
public class W6 : DocumentSegment
Public Class W6 _
    Inherits DocumentSegment
public ref class W6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W6()()()() | Initializes a new instance of the W6 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SpecialHandlingCode | Element 1
 | SpecialHandlingCode1 | Element 2
 | SpecialHandlingCode2 | Element 3
 | SpecialHandlingCode3 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W6


W6 Constructor

W6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► W6()()()()
RDPCrystal EDI Library
Initializes a new instance of the W6 class
Declaration Syntax
C# Visual Basic Visual C++
public W6()
Public Sub New
public:
W6()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SpecialHandlingCode Property

SpecialHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► SpecialHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode { get; set; }
Public Property SpecialHandlingCode As String
    Get
    Set
public:
property String^ SpecialHandlingCode {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode1 Property

SpecialHandlingCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► SpecialHandlingCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode1 { get; set; }
Public Property SpecialHandlingCode1 As String
    Get
    Set
public:
property String^ SpecialHandlingCode1 {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode2 Property

SpecialHandlingCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► SpecialHandlingCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode2 { get; set; }
Public Property SpecialHandlingCode2 As String
    Get
    Set
public:
property String^ SpecialHandlingCode2 {
    String^ get ();
    void set (String^ value);
}


SpecialHandlingCode3 Property

SpecialHandlingCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► SpecialHandlingCode3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialHandlingCode3 { get; set; }
Public Property SpecialHandlingCode3 As String
    Get
    Set
public:
property String^ SpecialHandlingCode3 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W66 Class

W66 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66
RDPCrystal EDI Library
Warehouse Carrier Information
Declaration Syntax
C# Visual Basic Visual C++
public class W66 : DocumentSegment
Public Class W66 _
    Inherits DocumentSegment
public ref class W66 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W66()()()() | Initializes a new instance of the W66 class
 | Amount | Element 9
 | CODMethodOfPaymentCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FOBPoint | Element 7
 | FOBPointCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PalletExchangeCode | Element 3
 | Routing | Element 5
 | ShipmentMethodOfPayment | Element 1
 | StandardCarrierAlphaCode | Element 10
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 2
 | UnitLoadOptionCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W66


W66 Constructor

W66 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► W66()()()()
RDPCrystal EDI Library
Initializes a new instance of the W66 class
Declaration Syntax
C# Visual Basic Visual C++
public W66()
Public Sub New
public:
W66()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► Amount
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


CODMethodOfPaymentCode Property

CODMethodOfPaymentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► CODMethodOfPaymentCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CODMethodOfPaymentCode { get; set; }
Public Property CODMethodOfPaymentCode As String
    Get
    Set
public:
property String^ CODMethodOfPaymentCode {
    String^ get ();
    void set (String^ value);
}


FOBPoint Property

FOBPoint Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► FOBPoint
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPoint { get; set; }
Public Property FOBPoint As String
    Get
    Set
public:
property String^ FOBPoint {
    String^ get ();
    void set (String^ value);
}


FOBPointCode Property

FOBPointCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► FOBPointCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FOBPointCode { get; set; }
Public Property FOBPointCode As String
    Get
    Set
public:
property String^ FOBPointCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PalletExchangeCode Property

PalletExchangeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► PalletExchangeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PalletExchangeCode { get; set; }
Public Property PalletExchangeCode As String
    Get
    Set
public:
property String^ PalletExchangeCode {
    String^ get ();
    void set (String^ value);
}


Routing Property

Routing Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► Routing
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Routing { get; set; }
Public Property Routing As String
    Get
    Set
public:
property String^ Routing {
    String^ get ();
    void set (String^ value);
}


ShipmentMethodOfPayment Property

ShipmentMethodOfPayment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► ShipmentMethodOfPayment
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentMethodOfPayment { get; set; }
Public Property ShipmentMethodOfPayment As String
    Get
    Set
public:
property String^ ShipmentMethodOfPayment {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


UnitLoadOptionCode Property

UnitLoadOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► UnitLoadOptionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitLoadOptionCode { get; set; }
Public Property UnitLoadOptionCode As String
    Get
    Set
public:
property String^ UnitLoadOptionCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W66 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


W76 Class

W76 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76
RDPCrystal EDI Library
Total Shipping Order
Declaration Syntax
C# Visual Basic Visual C++
public class W76 : DocumentSegment
Public Class W76 _
    Inherits DocumentSegment
public ref class W76 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | W76()()()() | Initializes a new instance of the W76 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OrderSizingFactor | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | QuantityOrdered | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | UnitOrBasisForMeasurementCode1 | Element 5
 | Volume | Element 4
 | Weight | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | W76


W76 Constructor

W76 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► W76()()()()
RDPCrystal EDI Library
Initializes a new instance of the W76 class
Declaration Syntax
C# Visual Basic Visual C++
public W76()
Public Sub New
public:
W76()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


OrderSizingFactor Property

OrderSizingFactor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► OrderSizingFactor
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string OrderSizingFactor { get; set; }
Public Property OrderSizingFactor As String
    Get
    Set
public:
property String^ OrderSizingFactor {
    String^ get ();
    void set (String^ value);
}


QuantityOrdered Property

QuantityOrdered Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► QuantityOrdered
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityOrdered { get; set; }
Public Property QuantityOrdered As String
    Get
    Set
public:
property String^ QuantityOrdered {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}


Volume Property

Volume Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► Volume
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Volume { get; set; }
Public Property Volume As String
    Get
    Set
public:
property String^ Volume {
    String^ get ();
    void set (String^ value);
}


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► W76 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


WGP Class

WGP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP
RDPCrystal EDI Library
Tariff Weight Group
Declaration Syntax
C# Visual Basic Visual C++
public class WGP : DocumentSegment
Public Class WGP _
    Inherits DocumentSegment
public ref class WGP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WGP()()()() | Initializes a new instance of the WGP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight | Element 1
 | Weight1 | Element 2
 | Weight10 | Element 11
 | Weight11 | Element 12
 | Weight12 | Element 13
 | Weight13 | Element 14
 | Weight14 | Element 15
 | Weight15 | Element 16
 | Weight2 | Element 3
 | Weight3 | Element 4
 | Weight4 | Element 5
 | Weight5 | Element 6
 | Weight6 | Element 7
 | Weight7 | Element 8
 | Weight8 | Element 9
 | Weight9 | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | WGP


WGP Constructor

WGP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► WGP()()()()
RDPCrystal EDI Library
Initializes a new instance of the WGP class
Declaration Syntax
C# Visual Basic Visual C++
public WGP()
Public Sub New
public:
WGP()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}


Weight10 Property

Weight10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight10
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Weight10 { get; set; }
Public Property Weight10 As String
    Get
    Set
public:
property String^ Weight10 {
    String^ get ();
    void set (String^ value);
}


Weight11 Property

Weight11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight11
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Weight11 { get; set; }
Public Property Weight11 As String
    Get
    Set
public:
property String^ Weight11 {
    String^ get ();
    void set (String^ value);
}


Weight12 Property

Weight12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight12
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Weight12 { get; set; }
Public Property Weight12 As String
    Get
    Set
public:
property String^ Weight12 {
    String^ get ();
    void set (String^ value);
}


Weight13 Property

Weight13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight13
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Weight13 { get; set; }
Public Property Weight13 As String
    Get
    Set
public:
property String^ Weight13 {
    String^ get ();
    void set (String^ value);
}


Weight14 Property

Weight14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight14
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Weight14 { get; set; }
Public Property Weight14 As String
    Get
    Set
public:
property String^ Weight14 {
    String^ get ();
    void set (String^ value);
}


Weight15 Property

Weight15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight15
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Weight15 { get; set; }
Public Property Weight15 As String
    Get
    Set
public:
property String^ Weight15 {
    String^ get ();
    void set (String^ value);
}


Weight2 Property

Weight2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight2 { get; set; }
Public Property Weight2 As String
    Get
    Set
public:
property String^ Weight2 {
    String^ get ();
    void set (String^ value);
}


Weight3 Property

Weight3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight3 { get; set; }
Public Property Weight3 As String
    Get
    Set
public:
property String^ Weight3 {
    String^ get ();
    void set (String^ value);
}


Weight4 Property

Weight4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Weight4 { get; set; }
Public Property Weight4 As String
    Get
    Set
public:
property String^ Weight4 {
    String^ get ();
    void set (String^ value);
}


Weight5 Property

Weight5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight5
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Weight5 { get; set; }
Public Property Weight5 As String
    Get
    Set
public:
property String^ Weight5 {
    String^ get ();
    void set (String^ value);
}


Weight6 Property

Weight6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight6
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Weight6 { get; set; }
Public Property Weight6 As String
    Get
    Set
public:
property String^ Weight6 {
    String^ get ();
    void set (String^ value);
}


Weight7 Property

Weight7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight7
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Weight7 { get; set; }
Public Property Weight7 As String
    Get
    Set
public:
property String^ Weight7 {
    String^ get ();
    void set (String^ value);
}


Weight8 Property

Weight8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight8
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Weight8 { get; set; }
Public Property Weight8 As String
    Get
    Set
public:
property String^ Weight8 {
    String^ get ();
    void set (String^ value);
}


Weight9 Property

Weight9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Weight9
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Weight9 { get; set; }
Public Property Weight9 As String
    Get
    Set
public:
property String^ Weight9 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WGP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


WS Class

WS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS
RDPCrystal EDI Library
Work Schedule
Declaration Syntax
C# Visual Basic Visual C++
public class WS : DocumentSegment
Public Class WS _
    Inherits DocumentSegment
public ref class WS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WS()()()() | Initializes a new instance of the WS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipDeliveryOrCalendarPatternCode | Element 1
 | Time | Element 2
 | Time1 | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | WS


WS Constructor

WS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS ► WS()()()()
RDPCrystal EDI Library
Initializes a new instance of the WS class
Declaration Syntax
C# Visual Basic Visual C++
public WS()
Public Sub New
public:
WS()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS ► Time
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


Time1 Property

Time1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS ► Time1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time1 { get; set; }
Public Property Time1 As String
    Get
    Set
public:
property String^ Time1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► WS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


X01 Class

X01 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01
RDPCrystal EDI Library
Automated Manifest Archive Status Details
Declaration Syntax
C# Visual Basic Visual C++
public class X01 : DocumentSegment
Public Class X01 _
    Inherits DocumentSegment
public ref class X01 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X01()()()() | Initializes a new instance of the X01 class
 | Date | Element 9
 | DateTimeQualifier | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FlightVoyageNumber | Element 7
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 3
 | LocationQualifier | Element 2
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 10
 | StandardCarrierAlphaCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VesselCode | Element 5
 | VesselCodeQualifier | Element 4
 | VesselName | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | X01


X01 Constructor

X01 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► X01()()()()
RDPCrystal EDI Library
Initializes a new instance of the X01 class
Declaration Syntax
C# Visual Basic Visual C++
public X01()
Public Sub New
public:
X01()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► Date
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► DateTimeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


FlightVoyageNumber Property

FlightVoyageNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► FlightVoyageNumber
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FlightVoyageNumber { get; set; }
Public Property FlightVoyageNumber As String
    Get
    Set
public:
property String^ FlightVoyageNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► LocationIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► LocationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


VesselCode Property

VesselCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► VesselCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCode { get; set; }
Public Property VesselCode As String
    Get
    Set
public:
property String^ VesselCode {
    String^ get ();
    void set (String^ value);
}


VesselCodeQualifier Property

VesselCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► VesselCodeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string VesselCodeQualifier { get; set; }
Public Property VesselCodeQualifier As String
    Get
    Set
public:
property String^ VesselCodeQualifier {
    String^ get ();
    void set (String^ value);
}


VesselName Property

VesselName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► VesselName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VesselName { get; set; }
Public Property VesselName As String
    Get
    Set
public:
property String^ VesselName {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X01 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


X02 Class

X02 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02
RDPCrystal EDI Library
Automated Manifest Bills Eligible/Overdue Archive Details
Declaration Syntax
C# Visual Basic Visual C++
public class X02 : DocumentSegment
Public Class X02 _
    Inherits DocumentSegment
public ref class X02 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X02()()()() | Initializes a new instance of the X02 class
 | BillOfLadingWaybillNumber | Element 3
 | BillOfLadingWaybillNumber1 | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 1
 | StandardCarrierAlphaCode1 | Element 2
 | StandardCarrierAlphaCode2 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | X02


X02 Constructor

X02 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► X02()()()()
RDPCrystal EDI Library
Initializes a new instance of the X02 class
Declaration Syntax
C# Visual Basic Visual C++
public X02()
Public Sub New
public:
X02()


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber1 Property

BillOfLadingWaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► BillOfLadingWaybillNumber1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber1 { get; set; }
Public Property BillOfLadingWaybillNumber1 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode2 Property

StandardCarrierAlphaCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► StandardCarrierAlphaCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode2 { get; set; }
Public Property StandardCarrierAlphaCode2 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode2 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X02 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


X1 Class

X1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1
RDPCrystal EDI Library
Export License
Declaration Syntax
C# Visual Basic Visual C++
public class X1 : DocumentSegment
Public Class X1 _
    Inherits DocumentSegment
public ref class X1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X1()()()() | Initializes a new instance of the X1 class
 | CountryCode | Element 7
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportFilingKeyCode | Element 12
 | ExportLicenseControlCode | Element 6
 | ExportLicenseNumber | Element 2
 | ExportLicenseStatusCode | Element 3
 | ExportLicenseSymbolCode | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 16
 | InternationalDomesticCode | Element 9
 | LadingQuantity | Element 10
 | LadingValue | Element 11
 | LicensingAgencyCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ScheduleCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 13
 | UnitPrice | Element 14
 | USGovernmentLicenseType | Element 15
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | X1


X1 Constructor

X1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► X1()()()()
RDPCrystal EDI Library
Initializes a new instance of the X1 class
Declaration Syntax
C# Visual Basic Visual C++
public X1()
Public Sub New
public:
X1()


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


ExportFilingKeyCode Property

ExportFilingKeyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► ExportFilingKeyCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ExportFilingKeyCode { get; set; }
Public Property ExportFilingKeyCode As String
    Get
    Set
public:
property String^ ExportFilingKeyCode {
    String^ get ();
    void set (String^ value);
}


ExportLicenseControlCode Property

ExportLicenseControlCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► ExportLicenseControlCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ExportLicenseControlCode { get; set; }
Public Property ExportLicenseControlCode As String
    Get
    Set
public:
property String^ ExportLicenseControlCode {
    String^ get ();
    void set (String^ value);
}


ExportLicenseNumber Property

ExportLicenseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► ExportLicenseNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ExportLicenseNumber { get; set; }
Public Property ExportLicenseNumber As String
    Get
    Set
public:
property String^ ExportLicenseNumber {
    String^ get ();
    void set (String^ value);
}


ExportLicenseStatusCode Property

ExportLicenseStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► ExportLicenseStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ExportLicenseStatusCode { get; set; }
Public Property ExportLicenseStatusCode As String
    Get
    Set
public:
property String^ ExportLicenseStatusCode {
    String^ get ();
    void set (String^ value);
}


ExportLicenseSymbolCode Property

ExportLicenseSymbolCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► ExportLicenseSymbolCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ExportLicenseSymbolCode { get; set; }
Public Property ExportLicenseSymbolCode As String
    Get
    Set
public:
property String^ ExportLicenseSymbolCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► IdentificationCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


InternationalDomesticCode Property

InternationalDomesticCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► InternationalDomesticCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalDomesticCode { get; set; }
Public Property InternationalDomesticCode As String
    Get
    Set
public:
property String^ InternationalDomesticCode {
    String^ get ();
    void set (String^ value);
}


LadingQuantity Property

LadingQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► LadingQuantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LadingQuantity { get; set; }
Public Property LadingQuantity As String
    Get
    Set
public:
property String^ LadingQuantity {
    String^ get ();
    void set (String^ value);
}


LadingValue Property

LadingValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► LadingValue
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string LadingValue { get; set; }
Public Property LadingValue As String
    Get
    Set
public:
property String^ LadingValue {
    String^ get ();
    void set (String^ value);
}


LicensingAgencyCode Property

LicensingAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► LicensingAgencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LicensingAgencyCode { get; set; }
Public Property LicensingAgencyCode As String
    Get
    Set
public:
property String^ LicensingAgencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ScheduleCode Property

ScheduleCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► ScheduleCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ScheduleCode { get; set; }
Public Property ScheduleCode As String
    Get
    Set
public:
property String^ ScheduleCode {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► UnitPrice
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


USGovernmentLicenseType Property

USGovernmentLicenseType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► USGovernmentLicenseType
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string USGovernmentLicenseType { get; set; }
Public Property USGovernmentLicenseType As String
    Get
    Set
public:
property String^ USGovernmentLicenseType {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


X2 Class

X2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2
RDPCrystal EDI Library
Import License
Declaration Syntax
C# Visual Basic Visual C++
public class X2 : DocumentSegment
Public Class X2 _
    Inherits DocumentSegment
public ref class X2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X2()()()() | Initializes a new instance of the X2 class
 | Date | Element 2
 | Date1 | Element 3
 | Date2 | Element 5
 | Date3 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImportLicenseNumber | Element 1
 | ImportLicenseNumber1 | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | X2


X2 Constructor

X2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► X2()()()()
RDPCrystal EDI Library
Initializes a new instance of the X2 class
Declaration Syntax
C# Visual Basic Visual C++
public X2()
Public Sub New
public:
X2()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► Date2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► Date3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}


ImportLicenseNumber Property

ImportLicenseNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► ImportLicenseNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ImportLicenseNumber { get; set; }
Public Property ImportLicenseNumber As String
    Get
    Set
public:
property String^ ImportLicenseNumber {
    String^ get ();
    void set (String^ value);
}


ImportLicenseNumber1 Property

ImportLicenseNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► ImportLicenseNumber1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ImportLicenseNumber1 { get; set; }
Public Property ImportLicenseNumber1 As String
    Get
    Set
public:
property String^ ImportLicenseNumber1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


X4 Class

X4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4
RDPCrystal EDI Library
Customs Release Information
Declaration Syntax
C# Visual Basic Visual C++
public class X4 : DocumentSegment
Public Class X4 _
    Inherits DocumentSegment
public ref class X4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X4()()()() | Initializes a new instance of the X4 class
 | BillOfLadingWaybillNumber | Element 1
 | BillOfLadingWaybillNumber1 | Element 8
 | CustomsEntryNumber | Element 4
 | CustomsEntryTypeCode | Element 3
 | Date | Element 5
 | DispositionCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 11
 | EquipmentNumber | Element 12
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 13
 | LocationIdentifier1 | Element 14
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ReferenceIdentification | Element 16
 | ReferenceIdentificationQualifier | Element 15
 | StandardCarrierAlphaCode | Element 9
 | StandardCarrierAlphaCode1 | Element 10
 | Time | Element 6
 | TimeCode | Element 17
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | X4


X4 Constructor

X4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► X4()()()()
RDPCrystal EDI Library
Initializes a new instance of the X4 class
Declaration Syntax
C# Visual Basic Visual C++
public X4()
Public Sub New
public:
X4()


BillOfLadingWaybillNumber Property

BillOfLadingWaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► BillOfLadingWaybillNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber { get; set; }
Public Property BillOfLadingWaybillNumber As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber {
    String^ get ();
    void set (String^ value);
}


BillOfLadingWaybillNumber1 Property

BillOfLadingWaybillNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► BillOfLadingWaybillNumber1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string BillOfLadingWaybillNumber1 { get; set; }
Public Property BillOfLadingWaybillNumber1 As String
    Get
    Set
public:
property String^ BillOfLadingWaybillNumber1 {
    String^ get ();
    void set (String^ value);
}


CustomsEntryNumber Property

CustomsEntryNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► CustomsEntryNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryNumber { get; set; }
Public Property CustomsEntryNumber As String
    Get
    Set
public:
property String^ CustomsEntryNumber {
    String^ get ();
    void set (String^ value);
}


CustomsEntryTypeCode Property

CustomsEntryTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► CustomsEntryTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CustomsEntryTypeCode { get; set; }
Public Property CustomsEntryTypeCode As String
    Get
    Set
public:
property String^ CustomsEntryTypeCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DispositionCode Property

DispositionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► DispositionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DispositionCode { get; set; }
Public Property DispositionCode As String
    Get
    Set
public:
property String^ DispositionCode {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► EquipmentInitial
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► EquipmentNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► LocationIdentifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationIdentifier1 Property

LocationIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► LocationIdentifier1
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier1 { get; set; }
Public Property LocationIdentifier1 As String
    Get
    Set
public:
property String^ LocationIdentifier1 {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► ReferenceIdentification
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode1 Property

StandardCarrierAlphaCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► StandardCarrierAlphaCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode1 { get; set; }
Public Property StandardCarrierAlphaCode1 As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode1 {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► Time
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► TimeCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


X7 Class

X7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X7
RDPCrystal EDI Library
Customs Information
Declaration Syntax
C# Visual Basic Visual C++
public class X7 : DocumentSegment
Public Class X7 _
    Inherits DocumentSegment
public ref class X7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X7()()()() | Initializes a new instance of the X7 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 1
 | FreeFormMessage1 | Element 2
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | X7


X7 Constructor

X7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X7 ► X7()()()()
RDPCrystal EDI Library
Initializes a new instance of the X7 class
Declaration Syntax
C# Visual Basic Visual C++
public X7()
Public Sub New
public:
X7()


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X7 ► FreeFormMessage
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage1 Property

FreeFormMessage1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X7 ► FreeFormMessage1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage1 { get; set; }
Public Property FreeFormMessage1 As String
    Get
    Set
public:
property String^ FreeFormMessage1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► X7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


XD Class

XD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD
RDPCrystal EDI Library
Placement/Pull Data
Declaration Syntax
C# Visual Basic Visual C++
public class XD : DocumentSegment
Public Class XD _
    Inherits DocumentSegment
public ref class XD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XD()()()() | Initializes a new instance of the XD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoadEmptyStatusCode | Element 7
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RejectReasonCode | Element 8
 | Spot | Element 4
 | Spot1 | Element 5
 | StandardCarrierAlphaCode | Element 6
 | SwitchTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Track | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | Zone | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | XD


XD Constructor

XD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► XD()()()()
RDPCrystal EDI Library
Initializes a new instance of the XD class
Declaration Syntax
C# Visual Basic Visual C++
public XD()
Public Sub New
public:
XD()


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LoadEmptyStatusCode Property

LoadEmptyStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► LoadEmptyStatusCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string LoadEmptyStatusCode { get; set; }
Public Property LoadEmptyStatusCode As String
    Get
    Set
public:
property String^ LoadEmptyStatusCode {
    String^ get ();
    void set (String^ value);
}


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► RejectReasonCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}


Spot Property

Spot Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► Spot
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Spot { get; set; }
Public Property Spot As String
    Get
    Set
public:
property String^ Spot {
    String^ get ();
    void set (String^ value);
}


Spot1 Property

Spot1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► Spot1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Spot1 { get; set; }
Public Property Spot1 As String
    Get
    Set
public:
property String^ Spot1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


SwitchTypeCode Property

SwitchTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► SwitchTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SwitchTypeCode { get; set; }
Public Property SwitchTypeCode As String
    Get
    Set
public:
property String^ SwitchTypeCode {
    String^ get ();
    void set (String^ value);
}


Track Property

Track Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► Track
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Track { get; set; }
Public Property Track As String
    Get
    Set
public:
property String^ Track {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Zone Property

Zone Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XD ► Zone
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Zone { get; set; }
Public Property Zone As String
    Get
    Set
public:
property String^ Zone {
    String^ get ();
    void set (String^ value);
}


XH Class

XH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH
RDPCrystal EDI Library
Pro Forma - B13 Information
Declaration Syntax
C# Visual Basic Visual C++
public class XH : DocumentSegment
Public Class XH _
    Inherits DocumentSegment
public ref class XH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XH()()()() | Initializes a new instance of the XH class
 | Amount | Element 4
 | Block20Code | Element 5
 | ChemicalAnalysisPercentage | Element 6
 | CurrencyCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RelatedCompanyIndicationCode | Element 2
 | SpecialChargeOrAllowanceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | XH


XH Constructor

XH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► XH()()()()
RDPCrystal EDI Library
Initializes a new instance of the XH class
Declaration Syntax
C# Visual Basic Visual C++
public XH()
Public Sub New
public:
XH()


Amount Property

Amount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► Amount
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Amount { get; set; }
Public Property Amount As String
    Get
    Set
public:
property String^ Amount {
    String^ get ();
    void set (String^ value);
}


Block20Code Property

Block20Code Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► Block20Code
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Block20Code { get; set; }
Public Property Block20Code As String
    Get
    Set
public:
property String^ Block20Code {
    String^ get ();
    void set (String^ value);
}


ChemicalAnalysisPercentage Property

ChemicalAnalysisPercentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► ChemicalAnalysisPercentage
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ChemicalAnalysisPercentage { get; set; }
Public Property ChemicalAnalysisPercentage As String
    Get
    Set
public:
property String^ ChemicalAnalysisPercentage {
    String^ get ();
    void set (String^ value);
}


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► CurrencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


RelatedCompanyIndicationCode Property

RelatedCompanyIndicationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► RelatedCompanyIndicationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCompanyIndicationCode { get; set; }
Public Property RelatedCompanyIndicationCode As String
    Get
    Set
public:
property String^ RelatedCompanyIndicationCode {
    String^ get ();
    void set (String^ value);
}


SpecialChargeOrAllowanceCode Property

SpecialChargeOrAllowanceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► SpecialChargeOrAllowanceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialChargeOrAllowanceCode { get; set; }
Public Property SpecialChargeOrAllowanceCode As String
    Get
    Set
public:
property String^ SpecialChargeOrAllowanceCode {
    String^ get ();
    void set (String^ value);
}


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► UnitPrice
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


XPO Class

XPO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO
RDPCrystal EDI Library
Preassigned Purchase Order Numbers
Declaration Syntax
C# Visual Basic Visual C++
public class XPO : DocumentSegment
Public Class XPO _
    Inherits DocumentSegment
public ref class XPO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XPO()()()() | Initializes a new instance of the XPO class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PurchaseOrderNumber | Element 1
 | PurchaseOrderNumber1 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | XPO


XPO Constructor

XPO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► XPO()()()()
RDPCrystal EDI Library
Initializes a new instance of the XPO class
Declaration Syntax
C# Visual Basic Visual C++
public XPO()
Public Sub New
public:
XPO()


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PurchaseOrderNumber Property

PurchaseOrderNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► PurchaseOrderNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber { get; set; }
Public Property PurchaseOrderNumber As String
    Get
    Set
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}


PurchaseOrderNumber1 Property

PurchaseOrderNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► PurchaseOrderNumber1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseOrderNumber1 { get; set; }
Public Property PurchaseOrderNumber1 As String
    Get
    Set
public:
property String^ PurchaseOrderNumber1 {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XPO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


XQ Class

XQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ
RDPCrystal EDI Library
Reporting Date/Action
Declaration Syntax
C# Visual Basic Visual C++
public class XQ : DocumentSegment
Public Class XQ _
    Inherits DocumentSegment
public ref class XQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XQ()()()() | Initializes a new instance of the XQ class
 | Date | Element 2
 | Date1 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | XQ


XQ Constructor

XQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ ► XQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the XQ class
Declaration Syntax
C# Visual Basic Visual C++
public XQ()
Public Sub New
public:
XQ()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ ► Date1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ ► TransactionHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► XQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y1 Class

Y1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1
RDPCrystal EDI Library
Space Reservation Request
Declaration Syntax
C# Visual Basic Visual C++
public class Y1 : DocumentSegment
Public Class Y1 _
    Inherits DocumentSegment
public ref class Y1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y1()()()() | Initializes a new instance of the Y1 class
 | CityName | Element 6
 | Date | Element 2
 | DateTimeQualifier | Element 9
 | EntityIdentifierCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SailingFlightDateEstimated | Element 1
 | StandardCarrierAlphaCode | Element 3
 | StateOrProvinceCode | Element 7
 | TariffServiceCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y1


Y1 Constructor

Y1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► Y1()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y1 class
Declaration Syntax
C# Visual Basic Visual C++
public Y1()
Public Sub New
public:
Y1()


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► CityName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► DateTimeQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


SailingFlightDateEstimated Property

SailingFlightDateEstimated Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► SailingFlightDateEstimated
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SailingFlightDateEstimated { get; set; }
Public Property SailingFlightDateEstimated As String
    Get
    Set
public:
property String^ SailingFlightDateEstimated {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}


TariffServiceCode Property

TariffServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► TariffServiceCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TariffServiceCode { get; set; }
Public Property TariffServiceCode As String
    Get
    Set
public:
property String^ TariffServiceCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y2 Class

Y2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2
RDPCrystal EDI Library
Container Details
Declaration Syntax
C# Visual Basic Visual C++
public class Y2 : DocumentSegment
Public Class Y2 _
    Inherits DocumentSegment
public ref class Y2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y2()()()() | Initializes a new instance of the Y2 class
 | ContainerTermsCode | Element 8
 | ContainerTermsCodeQualifier | Element 9
 | ContainerTypeRequestCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentType | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IntermodalServiceCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfContainers | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TotalStopoffs | Element 10
 | TransportationMethodTypeCode | Element 5
 | TypeOfServiceCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y2


Y2 Constructor

Y2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► Y2()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y2 class
Declaration Syntax
C# Visual Basic Visual C++
public Y2()
Public Sub New
public:
Y2()


ContainerTermsCode Property

ContainerTermsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► ContainerTermsCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ContainerTermsCode { get; set; }
Public Property ContainerTermsCode As String
    Get
    Set
public:
property String^ ContainerTermsCode {
    String^ get ();
    void set (String^ value);
}


ContainerTermsCodeQualifier Property

ContainerTermsCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► ContainerTermsCodeQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ContainerTermsCodeQualifier { get; set; }
Public Property ContainerTermsCodeQualifier As String
    Get
    Set
public:
property String^ ContainerTermsCodeQualifier {
    String^ get ();
    void set (String^ value);
}


ContainerTypeRequestCode Property

ContainerTypeRequestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► ContainerTypeRequestCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ContainerTypeRequestCode { get; set; }
Public Property ContainerTypeRequestCode As String
    Get
    Set
public:
property String^ ContainerTypeRequestCode {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► EquipmentType
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


IntermodalServiceCode Property

IntermodalServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► IntermodalServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IntermodalServiceCode { get; set; }
Public Property IntermodalServiceCode As String
    Get
    Set
public:
property String^ IntermodalServiceCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


NumberOfContainers Property

NumberOfContainers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► NumberOfContainers
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfContainers { get; set; }
Public Property NumberOfContainers As String
    Get
    Set
public:
property String^ NumberOfContainers {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TotalStopoffs Property

TotalStopoffs Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► TotalStopoffs
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TotalStopoffs { get; set; }
Public Property TotalStopoffs As String
    Get
    Set
public:
property String^ TotalStopoffs {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► TypeOfServiceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y3 Class

Y3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3
RDPCrystal EDI Library
Space Confirmation
Declaration Syntax
C# Visual Basic Visual C++
public class Y3 : DocumentSegment
Public Class Y3 _
    Inherits DocumentSegment
public ref class Y3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y3()()()() | Initializes a new instance of the Y3 class
 | BookingNumber | Element 1
 | Date | Element 3
 | Date1 | Element 4
 | Date2 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PierName | Element 6
 | StandardCarrierAlphaCode | Element 2
 | StandardPointLocationCode | Element 5
 | TariffServiceCode | Element 10
 | Time | Element 8
 | TimeCode | Element 11
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransportationMethodTypeCode | Element 9
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y3


Y3 Constructor

Y3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Y3()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y3 class
Declaration Syntax
C# Visual Basic Visual C++
public Y3()
Public Sub New
public:
Y3()


BookingNumber Property

BookingNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► BookingNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BookingNumber { get; set; }
Public Property BookingNumber As String
    Get
    Set
public:
property String^ BookingNumber {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Date1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Date2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PierName Property

PierName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► PierName
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PierName { get; set; }
Public Property PierName As String
    Get
    Set
public:
property String^ PierName {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


TariffServiceCode Property

TariffServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► TariffServiceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TariffServiceCode { get; set; }
Public Property TariffServiceCode As String
    Get
    Set
public:
property String^ TariffServiceCode {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Time
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► TimeCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y4 Class

Y4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4
RDPCrystal EDI Library
Container Release
Declaration Syntax
C# Visual Basic Visual C++
public class Y4 : DocumentSegment
Public Class Y4 _
    Inherits DocumentSegment
public ref class Y4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y4()()()() | Initializes a new instance of the Y4 class
 | BookingNumber | Element 1
 | BookingNumber1 | Element 2
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentType | Element 6
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 9
 | LocationQualifier | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfContainers | Element 5
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StandardCarrierAlphaCode | Element 7
 | StandardPointLocationCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TypeOfServiceCode | Element 10
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y4


Y4 Constructor

Y4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► Y4()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y4 class
Declaration Syntax
C# Visual Basic Visual C++
public Y4()
Public Sub New
public:
Y4()


BookingNumber Property

BookingNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► BookingNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BookingNumber { get; set; }
Public Property BookingNumber As String
    Get
    Set
public:
property String^ BookingNumber {
    String^ get ();
    void set (String^ value);
}


BookingNumber1 Property

BookingNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► BookingNumber1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string BookingNumber1 { get; set; }
Public Property BookingNumber1 As String
    Get
    Set
public:
property String^ BookingNumber1 {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentType Property

EquipmentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► EquipmentType
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentType { get; set; }
Public Property EquipmentType As String
    Get
    Set
public:
property String^ EquipmentType {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► LocationIdentifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}


LocationQualifier Property

LocationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► LocationQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier { get; set; }
Public Property LocationQualifier As String
    Get
    Set
public:
property String^ LocationQualifier {
    String^ get ();
    void set (String^ value);
}


NumberOfContainers Property

NumberOfContainers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► NumberOfContainers
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfContainers { get; set; }
Public Property NumberOfContainers As String
    Get
    Set
public:
property String^ NumberOfContainers {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


StandardPointLocationCode Property

StandardPointLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► StandardPointLocationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StandardPointLocationCode { get; set; }
Public Property StandardPointLocationCode As String
    Get
    Set
public:
property String^ StandardPointLocationCode {
    String^ get ();
    void set (String^ value);
}


TypeOfServiceCode Property

TypeOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► TypeOfServiceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string TypeOfServiceCode { get; set; }
Public Property TypeOfServiceCode As String
    Get
    Set
public:
property String^ TypeOfServiceCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y5 Class

Y5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y5
RDPCrystal EDI Library
Space Booking Cancellation
Declaration Syntax
C# Visual Basic Visual C++
public class Y5 : DocumentSegment
Public Class Y5 _
    Inherits DocumentSegment
public ref class Y5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y5()()()() | Initializes a new instance of the Y5 class
 | BookingNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y5


Y5 Constructor

Y5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y5 ► Y5()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y5 class
Declaration Syntax
C# Visual Basic Visual C++
public Y5()
Public Sub New
public:
Y5()


BookingNumber Property

BookingNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y5 ► BookingNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string BookingNumber { get; set; }
Public Property BookingNumber As String
    Get
    Set
public:
property String^ BookingNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y6 Class

Y6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6
RDPCrystal EDI Library
Authentication
Declaration Syntax
C# Visual Basic Visual C++
public class Y6 : DocumentSegment
Public Class Y6 _
    Inherits DocumentSegment
public ref class Y6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y6()()()() | Initializes a new instance of the Y6 class
 | Authority | Element 2
 | AuthorityIdentifierCode | Element 1
 | AuthorizationDate | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y6


Y6 Constructor

Y6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6 ► Y6()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y6 class
Declaration Syntax
C# Visual Basic Visual C++
public Y6()
Public Sub New
public:
Y6()


Authority Property

Authority Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6 ► Authority
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Authority { get; set; }
Public Property Authority As String
    Get
    Set
public:
property String^ Authority {
    String^ get ();
    void set (String^ value);
}


AuthorityIdentifierCode Property

AuthorityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6 ► AuthorityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorityIdentifierCode { get; set; }
Public Property AuthorityIdentifierCode As String
    Get
    Set
public:
property String^ AuthorityIdentifierCode {
    String^ get ();
    void set (String^ value);
}


AuthorizationDate Property

AuthorizationDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6 ► AuthorizationDate
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationDate { get; set; }
Public Property AuthorizationDate As String
    Get
    Set
public:
property String^ AuthorizationDate {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


Y7 Class

Y7 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7
RDPCrystal EDI Library
Priority
Declaration Syntax
C# Visual Basic Visual C++
public class Y7 : DocumentSegment
Public Class Y7 _
    Inherits DocumentSegment
public ref class Y7 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y7()()()() | Initializes a new instance of the Y7 class
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PortCallFileNumber | Element 4
 | Priority | Element 1
 | PriorityCode | Element 2
 | PriorityCodeQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | Y7


Y7 Constructor

Y7 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► Y7()()()()
RDPCrystal EDI Library
Initializes a new instance of the Y7 class
Declaration Syntax
C# Visual Basic Visual C++
public Y7()
Public Sub New
public:
Y7()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


PortCallFileNumber Property

PortCallFileNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► PortCallFileNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PortCallFileNumber { get; set; }
Public Property PortCallFileNumber As String
    Get
    Set
public:
property String^ PortCallFileNumber {
    String^ get ();
    void set (String^ value);
}


Priority Property

Priority Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► Priority
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Priority { get; set; }
Public Property Priority As String
    Get
    Set
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}


PriorityCode Property

PriorityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► PriorityCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PriorityCode { get; set; }
Public Property PriorityCode As String
    Get
    Set
public:
property String^ PriorityCode {
    String^ get ();
    void set (String^ value);
}


PriorityCodeQualifier Property

PriorityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► PriorityCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PriorityCodeQualifier { get; set; }
Public Property PriorityCodeQualifier As String
    Get
    Set
public:
property String^ PriorityCodeQualifier {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Y7 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YNQ Class

YNQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ
RDPCrystal EDI Library
Yes/No Question
Declaration Syntax
C# Visual Basic Visual C++
public class YNQ : DocumentSegment
Public Class YNQ _
    Inherits DocumentSegment
public ref class YNQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | YNQ()()()() | Initializes a new instance of the YNQ class
 | CodeListQualifierCode | Element 8
 | ConditionIndicator | Element 1
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 5
 | FreeFormMessageText1 | Element 6
 | FreeFormMessageText2 | Element 7
 | FreeFormMessageText3 | Element 10
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | YNQ


YNQ Constructor

YNQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► YNQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the YNQ class
Declaration Syntax
C# Visual Basic Visual C++
public YNQ()
Public Sub New
public:
YNQ()


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► CodeListQualifierCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}


ConditionIndicator Property

ConditionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► ConditionIndicator
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator { get; set; }
Public Property ConditionIndicator As String
    Get
    Set
public:
property String^ ConditionIndicator {
    String^ get ();
    void set (String^ value);
}


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► FreeFormMessageText
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText1 Property

FreeFormMessageText1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► FreeFormMessageText1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText1 { get; set; }
Public Property FreeFormMessageText1 As String
    Get
    Set
public:
property String^ FreeFormMessageText1 {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText2 Property

FreeFormMessageText2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► FreeFormMessageText2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText2 { get; set; }
Public Property FreeFormMessageText2 As String
    Get
    Set
public:
property String^ FreeFormMessageText2 {
    String^ get ();
    void set (String^ value);
}


FreeFormMessageText3 Property

FreeFormMessageText3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► FreeFormMessageText3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText3 { get; set; }
Public Property FreeFormMessageText3 As String
    Get
    Set
public:
property String^ FreeFormMessageText3 {
    String^ get ();
    void set (String^ value);
}


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► IndustryCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► YNQ ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


ZA Class

ZA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA
RDPCrystal EDI Library
Product Activity Reporting
Declaration Syntax
C# Visual Basic Visual C++
public class ZA : DocumentSegment
Public Class ZA _
    Inherits DocumentSegment
public ref class ZA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZA()()()() | Initializes a new instance of the ZA class
 | ActivityCode | Element 1
 | Date | Element 5
 | DateTimeQualifier | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | ReferenceIdentification | Element 7
 | ReferenceIdentificationQualifier | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ZA


ZA Constructor

ZA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► ZA()()()()
RDPCrystal EDI Library
Initializes a new instance of the ZA class
Declaration Syntax
C# Visual Basic Visual C++
public ZA()
Public Sub New
public:
ZA()


ActivityCode Property

ActivityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► ActivityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActivityCode { get; set; }
Public Property ActivityCode As String
    Get
    Set
public:
property String^ ActivityCode {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► DateTimeQualifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}


ZC1 Class

ZC1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1
RDPCrystal EDI Library
Beginning Segment For Data Correction Or Change
Declaration Syntax
C# Visual Basic Visual C++
public class ZC1 : DocumentSegment
Public Class ZC1 _
    Inherits DocumentSegment
public ref class ZC1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZC1()()()() | Initializes a new instance of the ZC1 class
 | CorrectionIndicator | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 1
 | StandardCarrierAlphaCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionReferenceDate | Element 5
 | TransactionReferenceNumber | Element 4
 | TransportationMethodTypeCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ZC1


ZC1 Constructor

ZC1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► ZC1()()()()
RDPCrystal EDI Library
Initializes a new instance of the ZC1 class
Declaration Syntax
C# Visual Basic Visual C++
public ZC1()
Public Sub New
public:
ZC1()


CorrectionIndicator Property

CorrectionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► CorrectionIndicator
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CorrectionIndicator { get; set; }
Public Property CorrectionIndicator As String
    Get
    Set
public:
property String^ CorrectionIndicator {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransactionReferenceDate Property

TransactionReferenceDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► TransactionReferenceDate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionReferenceDate { get; set; }
Public Property TransactionReferenceDate As String
    Get
    Set
public:
property String^ TransactionReferenceDate {
    String^ get ();
    void set (String^ value);
}


TransactionReferenceNumber Property

TransactionReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► TransactionReferenceNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionReferenceNumber { get; set; }
Public Property TransactionReferenceNumber As String
    Get
    Set
public:
property String^ TransactionReferenceNumber {
    String^ get ();
    void set (String^ value);
}


TransportationMethodTypeCode Property

TransportationMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► TransportationMethodTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string TransportationMethodTypeCode { get; set; }
Public Property TransportationMethodTypeCode As String
    Get
    Set
public:
property String^ TransportationMethodTypeCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZC1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ZD Class

ZD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD
RDPCrystal EDI Library
Transaction Set Deletion - ID, Reason, and Source
Declaration Syntax
C# Visual Basic Visual C++
public class ZD : DocumentSegment
Public Class ZD _
    Inherits DocumentSegment
public ref class ZD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZD()()()() | Initializes a new instance of the ZD class
 | CorrectionIndicator | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 3
 | EquipmentNumber | Element 4
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ShipmentIdentificationNumber | Element 2
 | StandardCarrierAlphaCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionReferenceDate | Element 6
 | TransactionReferenceNumber | Element 5
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ZD


ZD Constructor

ZD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► ZD()()()()
RDPCrystal EDI Library
Initializes a new instance of the ZD class
Declaration Syntax
C# Visual Basic Visual C++
public ZD()
Public Sub New
public:
ZD()


CorrectionIndicator Property

CorrectionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► CorrectionIndicator
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CorrectionIndicator { get; set; }
Public Property CorrectionIndicator As String
    Get
    Set
public:
property String^ CorrectionIndicator {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► EquipmentInitial
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► EquipmentNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ShipmentIdentificationNumber Property

ShipmentIdentificationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► ShipmentIdentificationNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentIdentificationNumber { get; set; }
Public Property ShipmentIdentificationNumber As String
    Get
    Set
public:
property String^ ShipmentIdentificationNumber {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


TransactionReferenceDate Property

TransactionReferenceDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► TransactionReferenceDate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionReferenceDate { get; set; }
Public Property TransactionReferenceDate As String
    Get
    Set
public:
property String^ TransactionReferenceDate {
    String^ get ();
    void set (String^ value);
}


TransactionReferenceNumber Property

TransactionReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► TransactionReferenceNumber
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionReferenceNumber { get; set; }
Public Property TransactionReferenceNumber As String
    Get
    Set
public:
property String^ TransactionReferenceNumber {
    String^ get ();
    void set (String^ value);
}


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ZR Class

ZR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR
RDPCrystal EDI Library
Waybill Reference Identification
Declaration Syntax
C# Visual Basic Visual C++
public class ZR : DocumentSegment
Public Class ZR _
    Inherits DocumentSegment
public ref class ZR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZR()()()() | Initializes a new instance of the ZR class
 | CorrectionIndicator | Element 13
 | Date | Element 5
 | Date1 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessage | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterlineSettlementSystemStatusActionOrDisputeCode | Element 9
 | InterlineSettlementSystemStatusActionOrDisputeCode1 | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 11
 | ReferenceIdentification1 | Element 12
 | StandardCarrierAlphaCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillNumber | Element 4
 | WaybillResponseCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ZR


ZR Constructor

ZR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► ZR()()()()
RDPCrystal EDI Library
Initializes a new instance of the ZR class
Declaration Syntax
C# Visual Basic Visual C++
public ZR()
Public Sub New
public:
ZR()


CorrectionIndicator Property

CorrectionIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► CorrectionIndicator
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string CorrectionIndicator { get; set; }
Public Property CorrectionIndicator As String
    Get
    Set
public:
property String^ CorrectionIndicator {
    String^ get ();
    void set (String^ value);
}


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► Date1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


FreeFormMessage Property

FreeFormMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► FreeFormMessage
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessage { get; set; }
Public Property FreeFormMessage As String
    Get
    Set
public:
property String^ FreeFormMessage {
    String^ get ();
    void set (String^ value);
}


InterlineSettlementSystemStatusActionOrDisputeCode Property

InterlineSettlementSystemStatusActionOrDisputeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► InterlineSettlementSystemStatusActionOrDisputeCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterlineSettlementSystemStatusActionOrDisputeCode { get; set; }
Public Property InterlineSettlementSystemStatusActionOrDisputeCode As String
    Get
    Set
public:
property String^ InterlineSettlementSystemStatusActionOrDisputeCode {
    String^ get ();
    void set (String^ value);
}


InterlineSettlementSystemStatusActionOrDisputeCode1 Property

InterlineSettlementSystemStatusActionOrDisputeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► InterlineSettlementSystemStatusActionOrDisputeCode1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InterlineSettlementSystemStatusActionOrDisputeCode1 { get; set; }
Public Property InterlineSettlementSystemStatusActionOrDisputeCode1 As String
    Get
    Set
public:
property String^ InterlineSettlementSystemStatusActionOrDisputeCode1 {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► ReferenceIdentification
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► ReferenceIdentification1
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}


StandardCarrierAlphaCode Property

StandardCarrierAlphaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► StandardCarrierAlphaCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string StandardCarrierAlphaCode { get; set; }
Public Property StandardCarrierAlphaCode As String
    Get
    Set
public:
property String^ StandardCarrierAlphaCode {
    String^ get ();
    void set (String^ value);
}


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► WaybillNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


WaybillResponseCode Property

WaybillResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► WaybillResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillResponseCode { get; set; }
Public Property WaybillResponseCode As String
    Get
    Set
public:
property String^ WaybillResponseCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


ZT Class

ZT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT
RDPCrystal EDI Library
Waybill Request Information
Declaration Syntax
C# Visual Basic Visual C++
public class ZT : DocumentSegment
Public Class ZT _
    Inherits DocumentSegment
public ref class ZT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZT()()()() | Initializes a new instance of the ZT class
 | Date | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EquipmentInitial | Element 2
 | EquipmentNumber | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WaybillNumber | Element 4
 | WaybillRequestCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ZT


ZT Constructor

ZT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► ZT()()()()
RDPCrystal EDI Library
Initializes a new instance of the ZT class
Declaration Syntax
C# Visual Basic Visual C++
public ZT()
Public Sub New
public:
ZT()


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► Date
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}


EquipmentInitial Property

EquipmentInitial Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► EquipmentInitial
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentInitial { get; set; }
Public Property EquipmentInitial As String
    Get
    Set
public:
property String^ EquipmentInitial {
    String^ get ();
    void set (String^ value);
}


EquipmentNumber Property

EquipmentNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► EquipmentNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EquipmentNumber { get; set; }
Public Property EquipmentNumber As String
    Get
    Set
public:
property String^ EquipmentNumber {
    String^ get ();
    void set (String^ value);
}


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)


WaybillNumber Property

WaybillNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► WaybillNumber
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillNumber { get; set; }
Public Property WaybillNumber As String
    Get
    Set
public:
property String^ WaybillNumber {
    String^ get ();
    void set (String^ value);
}


WaybillRequestCode Property

WaybillRequestCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► WaybillRequestCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string WaybillRequestCode { get; set; }
Public Property WaybillRequestCode As String
    Get
    Set
public:
property String^ WaybillRequestCode {
    String^ get ();
    void set (String^ value);
}


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► ZT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)


RDPCrystalEDILibrary.Docs.x5010 Namespace

RDPCrystalEDILibrary.Docs.x5010 Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Docs.x5010
Namespace RDPCrystalEDILibrary.Docs.x5010
namespace RDPCrystalEDILibrary.Docs.x5010
Types
All Types Classes
Icon | Type | Description
 | AAA | Request Validation
 | ACT | Account Identification
 | AdjustmentIdentifier | C042
 | AK1 | Functional Group Response Header
 | AK2 | Transaction Set Response Header
 | AK9 | Functional Group Response Trailer
 | AMT | Monetary Amount
 | BGN |
 | BHT | Beginning of Hierarchical Transaction
 | BPR | Beginning Segment for Payment Order/Remittance Advice
 | CAS | Claims Adjustment
 | CL1 | Claim Codes
 | CLM | Health Claim
 | CLP | Claim Level Data
 | CN1 | Contract Information
 | COB | Coordination of Benefits
 | CompositeDiagnosticCodePointer | C004
 | CompositeMedicalProcedureIdentifier | C003
 | CompositeUnitOfMeasure | C001
 | ContextIndentification | C998
 | CR1 | Ambulance Certification
 | CR2 | Chiropractic Certification
 | CR3 | Durable Medical Equipment Certification
 | CR5 | Oxygen Therapy Certification
 | CR6 | Home Health Care Certification
 | CRC | Conditions Indicator
 | CTP | Pricing Information
 | CTX | SegmentContext
 | CUR | Currency
 | DMG | Demographic Information
 | DN1 | Orthodontic Information
 | DN2 | Tooth Summary
 | DSB | Disability Information
 | DTM | Date/Time Reference
 | DTP | Date or Time or Period
 | EB | Eligibility or Benefit Information
 | EC | Employment Class
 | EQ | Eligibility or Benefit Inquiry
 | FRM | Supporting Documentation
 | GE | Functional Group Trailer
 | GS | Functional Group Header
 | HCP | Health Care Pricing
 | HD | Health Coverage
 | HealthCareClaimStatus | C043
 | HealthCareCodeInformation | C022
 | HealthCareServiceLocation | C023
 | HI | Health Care Information Codes
 | HL | Hierarchical Level
 | HLH | Health Information
 | HSD | Health Care Services Delivery
 | ICM | Individual Income
 | IDC | Identification Card
 | IEA | Interchange Control Trailer
 | III | Information
 | IK3 | Error Identification
 | IK4 | Implementation Data Element Note
 | IK5 | Transaction Set Response Trailer
 | INS | Insured Benefit
 | ISA | Interchange Control Header
 | K3 | File Information
 | LE | Loop Trailer
 | LIN | Item Identification
 | LQ | Industry Code
 | LS | Loop Header
 | LUI | Language Use
 | LX | Assigned Number
 | MEA | Measurements
 | MedicareStatusCode | C052
 | MIA | Medicare Inpatient Adjudication
 | MOA | Medicare Outpatient Adjudication
 | MPI | Military Personnel Information
 | MSG | Message Text
 | N1 | Name
 | N3 | Address Information
 | N4 | Geographic Location
 | NM1 | Individual or Organizational Name
 | NTE | Note/Special Instruction
 | OI | Other Health Insurance Information
 | OralCavityDesign | C006
 | PAT | Patient Information
 | PER | Administrative Communications Contact
 | PLA | Place or Location
 | PLB | Provider Level Adjustment
 | PositionInSegment | C030
 | PRV | Provider Information
 | PS1 | Purchase Service
 | PWK | Paperwork
 | QTY | Quantity
 | RaceOrEthnicityInformation | C056
 | RDM | Remittance Delivery Method
 | REF | Reference Identification
 | ReferenceIdentifier | C040
 | ReferenceInSegment | C999
 | RelatedCausesInformation | C024
 | SBR | Subscriber Information
 | SE | Transaction Set Trailer
 | ST | Transaction Set Header
 | STC | Status Information
 | SV1 | Professional Service
 | SV2 | Institutional Service
 | SV3 | Dental Service
 | SV5 | Durable Medical Equipment Service
 | SVC | Service Information
 | SVD | Service Line Adjudication
 | TOO | Tooth Identification
 | ToothSurface | C005
 | TRN | Trace
 | TS2 | Transaction Supplemental Statistics
 | TS3 | Transaction Statistics
 | Typed5010Document | Represents an X12 5010 Document
 | UM | Health Care Services Review Information


AAA Class

AAA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA
RDPCrystal EDI Library
Request Validation
Declaration Syntax
C# Visual Basic Visual C++
public class AAA : DocumentSegment
Public Class AAA _
    Inherits DocumentSegment
public ref class AAA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AAA()()()() | Initializes a new instance of the AAA class
 | AgencyQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FollowupActionCode | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RejectReasonCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 1
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AAA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AAA Constructor

AAA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► AAA()()()()
RDPCrystal EDI Library
Initializes a new instance of the AAA class
Declaration Syntax
C# Visual Basic Visual C++
public AAA()
Public Sub New
public:
AAA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► AgencyQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FollowupActionCode Property

FollowupActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► FollowupActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FollowupActionCode { get; set; }
Public Property FollowupActionCode As String
    Get
    Set
public:
property String^ FollowupActionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► RejectReasonCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AAA ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ACT Class

ACT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT
RDPCrystal EDI Library
Account Identification
Declaration Syntax
C# Visual Basic Visual C++
public class ACT : DocumentSegment
Public Class ACT _
    Inherits DocumentSegment
public ref class ACT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ACT()()()() | Initializes a new instance of the ACT class
 | AccountNumber1 | Element 1
 | AccountNumber2 | Element 6
 | AccountNumberQualifier | Element 5
 | BenefitStatusCode | Element 9
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodTypeCode | Element 8
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ACT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ACT Constructor

ACT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► ACT()()()()
RDPCrystal EDI Library
Initializes a new instance of the ACT class
Declaration Syntax
C# Visual Basic Visual C++
public ACT()
Public Sub New
public:
ACT()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► AccountNumber1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumber2 Property

AccountNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► AccountNumber2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber2 { get; set; }
Public Property AccountNumber2 As String
    Get
    Set
public:
property String^ AccountNumber2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► AccountNumberQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BenefitStatusCode Property

BenefitStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► BenefitStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string BenefitStatusCode { get; set; }
Public Property BenefitStatusCode As String
    Get
    Set
public:
property String^ BenefitStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PaymentMethodTypeCode Property

PaymentMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► PaymentMethodTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodTypeCode { get; set; }
Public Property PaymentMethodTypeCode As String
    Get
    Set
public:
property String^ PaymentMethodTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ACT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier Class

AdjustmentIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AdjustmentIdentifier
RDPCrystal EDI Library
C042
Declaration Syntax
C# Visual Basic Visual C++
public class AdjustmentIdentifier : DocumentCompositeElement
Public Class AdjustmentIdentifier _
    Inherits DocumentCompositeElement
public ref class AdjustmentIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdjustmentIdentifier()()()() | Initializes a new instance of the AdjustmentIdentifier class
 | AdjustmentReasonCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferenceIdentification |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | AdjustmentIdentifier

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier Constructor

AdjustmentIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AdjustmentIdentifier ► AdjustmentIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the AdjustmentIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier()
Public Sub New
public:
AdjustmentIdentifier()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AdjustmentIdentifier ► AdjustmentReasonCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AdjustmentIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AdjustmentIdentifier ► ReferenceIdentification
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AK1 Class

AK1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1
RDPCrystal EDI Library
Functional Group Response Header
Declaration Syntax
C# Visual Basic Visual C++
public class AK1 : DocumentSegment
Public Class AK1 _
    Inherits DocumentSegment
public ref class AK1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK1()()()() | Initializes a new instance of the AK1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionReleaseIndustryIdentifierCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AK1 Constructor

AK1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1 ► AK1()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK1 class
Declaration Syntax
C# Visual Basic Visual C++
public AK1()
Public Sub New
public:
AK1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1 ► FunctionalIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1 ► GroupControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1 ► VersionReleaseIndustryIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AK2 Class

AK2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2
RDPCrystal EDI Library
Transaction Set Response Header
Declaration Syntax
C# Visual Basic Visual C++
public class AK2 : DocumentSegment
Public Class AK2 _
    Inherits DocumentSegment
public ref class AK2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK2()()()() | Initializes a new instance of the AK2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationConventionReference | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber | Element 2
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK2

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AK2 Constructor

AK2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2 ► AK2()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK2 class
Declaration Syntax
C# Visual Basic Visual C++
public AK2()
Public Sub New
public:
AK2()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationConventionReference Property

ImplementationConventionReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2 ► ImplementationConventionReference
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationConventionReference { get; set; }
Public Property ImplementationConventionReference As String
    Get
    Set
public:
property String^ ImplementationConventionReference {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2 ► TransactionSetControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2 ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AK9 Class

AK9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9
RDPCrystal EDI Library
Functional Group Response Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class AK9 : DocumentSegment
Public Class AK9 _
    Inherits DocumentSegment
public ref class AK9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK9()()()() | Initializes a new instance of the AK9 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalGroupAcknowledgmentCode | Element 1
 | FunctionalGroupSyntaxErrorCode1 | Element 5
 | FunctionalGroupSyntaxErrorCode2 | Element 6
 | FunctionalGroupSyntaxErrorCode3 | Element 7
 | FunctionalGroupSyntaxErrorCode4 | Element 8
 | FunctionalGroupSyntaxErrorCode5 | Element 9
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfAcceptedTransactionSets | Element 4
 | NumberOfReceivedTransactionSets | Element 3
 | NumberOfTransactionSetsIncluded | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK9

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AK9 Constructor

AK9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► AK9()()()()
RDPCrystal EDI Library
Initializes a new instance of the AK9 class
Declaration Syntax
C# Visual Basic Visual C++
public AK9()
Public Sub New
public:
AK9()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalGroupAcknowledgmentCode Property

FunctionalGroupAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► FunctionalGroupAcknowledgmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupAcknowledgmentCode { get; set; }
Public Property FunctionalGroupAcknowledgmentCode As String
    Get
    Set
public:
property String^ FunctionalGroupAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalGroupSyntaxErrorCode1 Property

FunctionalGroupSyntaxErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► FunctionalGroupSyntaxErrorCode1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode1 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode1 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalGroupSyntaxErrorCode2 Property

FunctionalGroupSyntaxErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► FunctionalGroupSyntaxErrorCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode2 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode2 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalGroupSyntaxErrorCode3 Property

FunctionalGroupSyntaxErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► FunctionalGroupSyntaxErrorCode3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode3 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode3 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalGroupSyntaxErrorCode4 Property

FunctionalGroupSyntaxErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► FunctionalGroupSyntaxErrorCode4
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode4 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode4 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalGroupSyntaxErrorCode5 Property

FunctionalGroupSyntaxErrorCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► FunctionalGroupSyntaxErrorCode5
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode5 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode5 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfAcceptedTransactionSets Property

NumberOfAcceptedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► NumberOfAcceptedTransactionSets
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfAcceptedTransactionSets { get; set; }
Public Property NumberOfAcceptedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfAcceptedTransactionSets {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfReceivedTransactionSets Property

NumberOfReceivedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► NumberOfReceivedTransactionSets
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfReceivedTransactionSets { get; set; }
Public Property NumberOfReceivedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfReceivedTransactionSets {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► NumberOfTransactionSetsIncluded
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AK9 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AMT Class

AMT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT
RDPCrystal EDI Library
Monetary Amount
Declaration Syntax
C# Visual Basic Visual C++
public class AMT : DocumentSegment
Public Class AMT _
    Inherits DocumentSegment
public ref class AMT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AMT()()()() | Initializes a new instance of the AMT class
 | AmountQualifierCode | Element 1
 | CreditDebitFlagCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AMT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AMT Constructor

AMT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT ► AMT()()()()
RDPCrystal EDI Library
Initializes a new instance of the AMT class
Declaration Syntax
C# Visual Basic Visual C++
public AMT()
Public Sub New
public:
AMT()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT ► AmountQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► AMT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BGN Class

BGN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class BGN : DocumentSegment
Public Class BGN _
    Inherits DocumentSegment
public ref class BGN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BGN()()()() | Beginning Segment
 | ActionCode | Element 8
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification1 | Element 2
 | ReferenceIdentification2 | Element 6
 | SecurityLevelCode | Element 9
 | Time | Element 4
 | TimeCode | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode | Element 1
 | TransactionTypeCode | Element 7
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BGN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BGN Constructor

BGN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► BGN()()()()
RDPCrystal EDI Library
Beginning Segment
Declaration Syntax
C# Visual Basic Visual C++
public BGN()
Public Sub New
public:
BGN()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► ActionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► ReferenceIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► ReferenceIdentification2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► SecurityLevelCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► TimeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► TransactionTypeCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BGN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BHT Class

BHT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT
RDPCrystal EDI Library
Beginning of Hierarchical Transaction
Declaration Syntax
C# Visual Basic Visual C++
public class BHT : DocumentSegment
Public Class BHT _
    Inherits DocumentSegment
public ref class BHT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BHT()()()() | Initializes a new instance of the BHT class
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalStructureCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 3
 | Time | Element 5
 | ToString()()()() | (Overrides DocumentSegment.ToString()()()().)
 | TransactionSetPurposeCode | Element 2
 | TransactionTypeCode | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BHT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BHT Constructor

BHT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► BHT()()()()
RDPCrystal EDI Library
Initializes a new instance of the BHT class
Declaration Syntax
C# Visual Basic Visual C++
public BHT()
Public Sub New
public:
BHT()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HierarchicalStructureCode Property

HierarchicalStructureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► HierarchicalStructureCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalStructureCode { get; set; }
Public Property HierarchicalStructureCode As String
    Get
    Set
public:
property String^ HierarchicalStructureCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► ToString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► TransactionSetPurposeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► TransactionTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BHT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BPR Class

BPR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR
RDPCrystal EDI Library
Beginning Segment for Payment Order/Remittance Advice
Declaration Syntax
C# Visual Basic Visual C++
public class BPR : DocumentSegment
Public Class BPR _
    Inherits DocumentSegment
public ref class BPR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BPR()()()() | Initializes a new instance of the BPR class
 | AccountNumber1 | Element 9
 | AccountNumber2 | Element 15
 | AccountNumber3 | Element 21
 | AccountNumberQualifier1 | Element 8
 | AccountNumberQualifier2 | Element 14
 | AccountNumberQualifier3 | Element 20
 | BusinessFunctionCode | Element 17
 | CreditDebitFlagCode | Element 3
 | Date | Element 16
 | DFI_IdentificationNumber1 | Element 7
 | DFI_IdentificationNumber2 | Element 13
 | DFI_IdentificationNumber3 | Element 19
 | DFI_IDNumberQualifier1 | Element 6
 | DFI_IDNumberQualifier2 | Element 12
 | DFI_IDNumberQualifier3 | Element 18
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginatingCompanyIdentifier | Element 10
 | OriginatingCompanySupplementalCode | Element 11
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentFormatCode | Element 5
 | PaymentMethodCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BPR

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BPR Constructor

BPR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► BPR()()()()
RDPCrystal EDI Library
Initializes a new instance of the BPR class
Declaration Syntax
C# Visual Basic Visual C++
public BPR()
Public Sub New
public:
BPR()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► AccountNumber1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumber2 Property

AccountNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► AccountNumber2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber2 { get; set; }
Public Property AccountNumber2 As String
    Get
    Set
public:
property String^ AccountNumber2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumber3 Property

AccountNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► AccountNumber3
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber3 { get; set; }
Public Property AccountNumber3 As String
    Get
    Set
public:
property String^ AccountNumber3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumberQualifier1 Property

AccountNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► AccountNumberQualifier1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier1 { get; set; }
Public Property AccountNumberQualifier1 As String
    Get
    Set
public:
property String^ AccountNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumberQualifier2 Property

AccountNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► AccountNumberQualifier2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier2 { get; set; }
Public Property AccountNumberQualifier2 As String
    Get
    Set
public:
property String^ AccountNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AccountNumberQualifier3 Property

AccountNumberQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► AccountNumberQualifier3
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier3 { get; set; }
Public Property AccountNumberQualifier3 As String
    Get
    Set
public:
property String^ AccountNumberQualifier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BusinessFunctionCode Property

BusinessFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► BusinessFunctionCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessFunctionCode { get; set; }
Public Property BusinessFunctionCode As String
    Get
    Set
public:
property String^ BusinessFunctionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► CreditDebitFlagCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► Date
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DFI_IdentificationNumber1 Property

DFI_IdentificationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► DFI_IdentificationNumber1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IdentificationNumber1 { get; set; }
Public Property DFI_IdentificationNumber1 As String
    Get
    Set
public:
property String^ DFI_IdentificationNumber1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DFI_IdentificationNumber2 Property

DFI_IdentificationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► DFI_IdentificationNumber2
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IdentificationNumber2 { get; set; }
Public Property DFI_IdentificationNumber2 As String
    Get
    Set
public:
property String^ DFI_IdentificationNumber2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DFI_IdentificationNumber3 Property

DFI_IdentificationNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► DFI_IdentificationNumber3
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IdentificationNumber3 { get; set; }
Public Property DFI_IdentificationNumber3 As String
    Get
    Set
public:
property String^ DFI_IdentificationNumber3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DFI_IDNumberQualifier1 Property

DFI_IDNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► DFI_IDNumberQualifier1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IDNumberQualifier1 { get; set; }
Public Property DFI_IDNumberQualifier1 As String
    Get
    Set
public:
property String^ DFI_IDNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DFI_IDNumberQualifier2 Property

DFI_IDNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► DFI_IDNumberQualifier2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IDNumberQualifier2 { get; set; }
Public Property DFI_IDNumberQualifier2 As String
    Get
    Set
public:
property String^ DFI_IDNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DFI_IDNumberQualifier3 Property

DFI_IDNumberQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► DFI_IDNumberQualifier3
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IDNumberQualifier3 { get; set; }
Public Property DFI_IDNumberQualifier3 As String
    Get
    Set
public:
property String^ DFI_IDNumberQualifier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► OriginatingCompanyIdentifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OriginatingCompanySupplementalCode Property

OriginatingCompanySupplementalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► OriginatingCompanySupplementalCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanySupplementalCode { get; set; }
Public Property OriginatingCompanySupplementalCode As String
    Get
    Set
public:
property String^ OriginatingCompanySupplementalCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PaymentFormatCode Property

PaymentFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► PaymentFormatCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentFormatCode { get; set; }
Public Property PaymentFormatCode As String
    Get
    Set
public:
property String^ PaymentFormatCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► PaymentMethodCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► TransactionHandlingCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► BPR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CAS Class

CAS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS
RDPCrystal EDI Library
Claims Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class CAS : DocumentSegment
Public Class CAS _
    Inherits DocumentSegment
public ref class CAS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAS()()()() | Initializes a new instance of the CAS class
 | ClaimAdjustmentGroupCode | Element 1
 | ClaimAdjustmentReasonCode1 | Element 2
 | ClaimAdjustmentReasonCode2 | Element 5
 | ClaimAdjustmentReasonCode3 | Element 8
 | ClaimAdjustmentReasonCode4 | Element 11
 | ClaimAdjustmentReasonCode5 | Element 14
 | ClaimAdjustmentReasonCode6 | Element 17
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 9
 | MonetaryAmount4 | Element 12
 | MonetaryAmount5 | Element 15
 | MonetaryAmount6 | Element 18
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 4
 | Quantity2 | Element 7
 | Quantity3 | Element 10
 | Quantity4 | Element 13
 | Quantity5 | Element 16
 | Quantity6 | Element 19
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CAS Constructor

CAS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► CAS()()()()
RDPCrystal EDI Library
Initializes a new instance of the CAS class
Declaration Syntax
C# Visual Basic Visual C++
public CAS()
Public Sub New
public:
CAS()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentGroupCode Property

ClaimAdjustmentGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentGroupCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentGroupCode { get; set; }
Public Property ClaimAdjustmentGroupCode As String
    Get
    Set
public:
property String^ ClaimAdjustmentGroupCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentReasonCode1 Property

ClaimAdjustmentReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentReasonCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode1 { get; set; }
Public Property ClaimAdjustmentReasonCode1 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentReasonCode2 Property

ClaimAdjustmentReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentReasonCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode2 { get; set; }
Public Property ClaimAdjustmentReasonCode2 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentReasonCode3 Property

ClaimAdjustmentReasonCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentReasonCode3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode3 { get; set; }
Public Property ClaimAdjustmentReasonCode3 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentReasonCode4 Property

ClaimAdjustmentReasonCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentReasonCode4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode4 { get; set; }
Public Property ClaimAdjustmentReasonCode4 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentReasonCode5 Property

ClaimAdjustmentReasonCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentReasonCode5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode5 { get; set; }
Public Property ClaimAdjustmentReasonCode5 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimAdjustmentReasonCode6 Property

ClaimAdjustmentReasonCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► ClaimAdjustmentReasonCode6
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode6 { get; set; }
Public Property ClaimAdjustmentReasonCode6 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► MonetaryAmount3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► MonetaryAmount4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► MonetaryAmount5
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► MonetaryAmount6
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Quantity2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Quantity3
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Quantity4
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Quantity5
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Quantity6
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CAS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CL1 Class

CL1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1
RDPCrystal EDI Library
Claim Codes
Declaration Syntax
C# Visual Basic Visual C++
public class CL1 : DocumentSegment
Public Class CL1 _
    Inherits DocumentSegment
public ref class CL1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CL1()()()() | Initializes a new instance of the CL1 class
 | AdmissionSourceCode | Element 2
 | AdmissionTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NursingHomeResidentialStatusCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientStatusCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CL1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CL1 Constructor

CL1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► CL1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CL1 class
Declaration Syntax
C# Visual Basic Visual C++
public CL1()
Public Sub New
public:
CL1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdmissionSourceCode Property

AdmissionSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► AdmissionSourceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AdmissionSourceCode { get; set; }
Public Property AdmissionSourceCode As String
    Get
    Set
public:
property String^ AdmissionSourceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdmissionTypeCode Property

AdmissionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► AdmissionTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AdmissionTypeCode { get; set; }
Public Property AdmissionTypeCode As String
    Get
    Set
public:
property String^ AdmissionTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NursingHomeResidentialStatusCode Property

NursingHomeResidentialStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► NursingHomeResidentialStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NursingHomeResidentialStatusCode { get; set; }
Public Property NursingHomeResidentialStatusCode As String
    Get
    Set
public:
property String^ NursingHomeResidentialStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PatientStatusCode Property

PatientStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► PatientStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PatientStatusCode { get; set; }
Public Property PatientStatusCode As String
    Get
    Set
public:
property String^ PatientStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CL1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CLM Class

CLM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM
RDPCrystal EDI Library
Health Claim
Declaration Syntax
C# Visual Basic Visual C++
public class CLM : DocumentSegment
Public Class CLM _
    Inherits DocumentSegment
public ref class CLM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLM()()()() | Initializes a new instance of the CLM class
 | AssignmentOrPlanParticipationCode | Element 7
 | ClaimFilingIndicatorCode | Element 3
 | ClaimStatusCode | Element 17
 | ClaimStatusReasonCode | Element 19
 | ClaimSubmitterIdentifier | Element 1
 | DelayReasonCode | Element 20
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareServiceLocation | Element 5
 | LevelOfServiceCode | Element 14
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonInstitutionalClaimTypeCode | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientSignatureSourceCode | Element 10
 | ProviderAgreementCode | Element 16
 | RelatedCausesInformation | Element 11
 | ReleaseOfInformationCode | Element 9
 | SpecialProgramCode | Element 12
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 6
 | YesNoConditionOrResponseCode2 | Element 8
 | YesNoConditionOrResponseCode3 | Element 13
 | YesNoConditionOrResponseCode4 | Element 15
 | YesNoConditionOrResponseCode5 | Element 18
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CLM Constructor

CLM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► CLM()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLM class
Declaration Syntax
C# Visual Basic Visual C++
public CLM()
Public Sub New
public:
CLM()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AssignmentOrPlanParticipationCode Property

AssignmentOrPlanParticipationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► AssignmentOrPlanParticipationCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string AssignmentOrPlanParticipationCode { get; set; }
Public Property AssignmentOrPlanParticipationCode As String
    Get
    Set
public:
property String^ AssignmentOrPlanParticipationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► ClaimStatusCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimStatusReasonCode Property

ClaimStatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► ClaimStatusReasonCode
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusReasonCode { get; set; }
Public Property ClaimStatusReasonCode As String
    Get
    Set
public:
property String^ ClaimStatusReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimSubmitterIdentifier Property

ClaimSubmitterIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► ClaimSubmitterIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmitterIdentifier { get; set; }
Public Property ClaimSubmitterIdentifier As String
    Get
    Set
public:
property String^ ClaimSubmitterIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DelayReasonCode Property

DelayReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► DelayReasonCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string DelayReasonCode { get; set; }
Public Property DelayReasonCode As String
    Get
    Set
public:
property String^ DelayReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareServiceLocation Property

HealthCareServiceLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► HealthCareServiceLocation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocation HealthCareServiceLocation { get; set; }
Public Property HealthCareServiceLocation As HealthCareServiceLocation
    Get
    Set
public:
property HealthCareServiceLocation^ HealthCareServiceLocation {
    HealthCareServiceLocation^ get ();
    void set (HealthCareServiceLocation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LevelOfServiceCode Property

LevelOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► LevelOfServiceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfServiceCode { get; set; }
Public Property LevelOfServiceCode As String
    Get
    Set
public:
property String^ LevelOfServiceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NonInstitutionalClaimTypeCode Property

NonInstitutionalClaimTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► NonInstitutionalClaimTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string NonInstitutionalClaimTypeCode { get; set; }
Public Property NonInstitutionalClaimTypeCode As String
    Get
    Set
public:
property String^ NonInstitutionalClaimTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PatientSignatureSourceCode Property

PatientSignatureSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► PatientSignatureSourceCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PatientSignatureSourceCode { get; set; }
Public Property PatientSignatureSourceCode As String
    Get
    Set
public:
property String^ PatientSignatureSourceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► ProviderAgreementCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesInformation Property

RelatedCausesInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► RelatedCausesInformation
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation RelatedCausesInformation { get; set; }
Public Property RelatedCausesInformation As RelatedCausesInformation
    Get
    Set
public:
property RelatedCausesInformation^ RelatedCausesInformation {
    RelatedCausesInformation^ get ();
    void set (RelatedCausesInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► ReleaseOfInformationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SpecialProgramCode Property

SpecialProgramCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► SpecialProgramCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialProgramCode { get; set; }
Public Property SpecialProgramCode As String
    Get
    Set
public:
property String^ SpecialProgramCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► YesNoConditionOrResponseCode4
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode5 Property

YesNoConditionOrResponseCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLM ► YesNoConditionOrResponseCode5
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode5 { get; set; }
Public Property YesNoConditionOrResponseCode5 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CLP Class

CLP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP
RDPCrystal EDI Library
Claim Level Data
Declaration Syntax
C# Visual Basic Visual C++
public class CLP : DocumentSegment
Public Class CLP _
    Inherits DocumentSegment
public ref class CLP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLP()()()() | Initializes a new instance of the CLP class
 | ClaimFilingIndicatorCode | Element 6
 | ClaimFrequencyTypeCode | Element 1
 | ClaimStatusCode | Element 2
 | ClaimSubmitterIdentifier | Element 1
 | DiagnosisRelatedGroupCode | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 8
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 4
 | MonetaryAmount3 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientStatusCode | Element 10
 | Percentage | Element 13
 | Quantity | Element 12
 | ReferenceIdentification | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 14
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLP

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CLP Constructor

CLP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► CLP()()()()
RDPCrystal EDI Library
Initializes a new instance of the CLP class
Declaration Syntax
C# Visual Basic Visual C++
public CLP()
Public Sub New
public:
CLP()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimFrequencyTypeCode Property

ClaimFrequencyTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► ClaimFrequencyTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFrequencyTypeCode { get; set; }
Public Property ClaimFrequencyTypeCode As String
    Get
    Set
public:
property String^ ClaimFrequencyTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► ClaimStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimSubmitterIdentifier Property

ClaimSubmitterIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► ClaimSubmitterIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmitterIdentifier { get; set; }
Public Property ClaimSubmitterIdentifier As String
    Get
    Set
public:
property String^ ClaimSubmitterIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DiagnosisRelatedGroupCode Property

DiagnosisRelatedGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► DiagnosisRelatedGroupCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisRelatedGroupCode { get; set; }
Public Property DiagnosisRelatedGroupCode As String
    Get
    Set
public:
property String^ DiagnosisRelatedGroupCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► FacilityCodeValue
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► MonetaryAmount2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► MonetaryAmount3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PatientStatusCode Property

PatientStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► PatientStatusCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string PatientStatusCode { get; set; }
Public Property PatientStatusCode As String
    Get
    Set
public:
property String^ PatientStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► Percentage
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► Quantity
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► ReferenceIdentification
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CLP ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CN1 Class

CN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1
RDPCrystal EDI Library
Contract Information
Declaration Syntax
C# Visual Basic Visual C++
public class CN1 : DocumentSegment
Public Class CN1 _
    Inherits DocumentSegment
public ref class CN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CN1()()()() | Initializes a new instance of the CN1 class
 | ContractTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 3
 | ReferenceIdentification | Element 4
 | TermsDiscountPercent | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CN1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CN1 Constructor

CN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► CN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CN1 class
Declaration Syntax
C# Visual Basic Visual C++
public CN1()
Public Sub New
public:
CN1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► ContractTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► Percent
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TermsDiscountPercent Property

TermsDiscountPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► TermsDiscountPercent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent { get; set; }
Public Property TermsDiscountPercent As String
    Get
    Set
public:
property String^ TermsDiscountPercent {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► VersionIdentifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


COB Class

COB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB
RDPCrystal EDI Library
Coordination of Benefits
Declaration Syntax
C# Visual Basic Visual C++
public class COB : DocumentSegment
Public Class COB _
    Inherits DocumentSegment
public ref class COB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | COB()()()() | Initializes a new instance of the COB class
 | CoordinationOfBenefitsCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode | Element 1
 | ReferenceIdentification | Element 2
 | ServiceTypeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | COB

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


COB Constructor

COB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► COB()()()()
RDPCrystal EDI Library
Initializes a new instance of the COB class
Declaration Syntax
C# Visual Basic Visual C++
public COB()
Public Sub New
public:
COB()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CoordinationOfBenefitsCode Property

CoordinationOfBenefitsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► CoordinationOfBenefitsCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CoordinationOfBenefitsCode { get; set; }
Public Property CoordinationOfBenefitsCode As String
    Get
    Set
public:
property String^ CoordinationOfBenefitsCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► PayerResponsibilitySequenceNumberCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► ServiceTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► COB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeDiagnosticCodePointer Class

CompositeDiagnosticCodePointer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer
RDPCrystal EDI Library
C004
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeDiagnosticCodePointer : DocumentCompositeElement
Public Class CompositeDiagnosticCodePointer _
    Inherits DocumentCompositeElement
public ref class CompositeDiagnosticCodePointer : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeDiagnosticCodePointer()()()() | Initializes a new instance of the CompositeDiagnosticCodePointer class
 | DiagnosisCodePointer1 | Element 1
 | DiagnosisCodePointer2 | Element 2
 | DiagnosisCodePointer3 | Element 3
 | DiagnosisCodePointer4 | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeDiagnosticCodePointer

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeDiagnosticCodePointer Constructor

CompositeDiagnosticCodePointer Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer ► CompositeDiagnosticCodePointer()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeDiagnosticCodePointer class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer()
Public Sub New
public:
CompositeDiagnosticCodePointer()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DiagnosisCodePointer1 Property

DiagnosisCodePointer1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer1 { get; set; }
Public Property DiagnosisCodePointer1 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DiagnosisCodePointer2 Property

DiagnosisCodePointer2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer2 { get; set; }
Public Property DiagnosisCodePointer2 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DiagnosisCodePointer3 Property

DiagnosisCodePointer3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer3
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer3 { get; set; }
Public Property DiagnosisCodePointer3 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DiagnosisCodePointer4 Property

DiagnosisCodePointer4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer4
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer4 { get; set; }
Public Property DiagnosisCodePointer4 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeDiagnosticCodePointer ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Class

CompositeMedicalProcedureIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
C003
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeMedicalProcedureIdentifier : DocumentCompositeElement
Public Class CompositeMedicalProcedureIdentifier _
    Inherits DocumentCompositeElement
public ref class CompositeMedicalProcedureIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeMedicalProcedureIdentifier()()()() | Initializes a new instance of the CompositeMedicalProcedureIdentifier class
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init(LightWeightElement, DocumentSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcedureModifier1 | Element 3
 | ProcedureModifier2 | Element 4
 | ProcedureModifier3 | Element 5
 | ProcedureModifier4 | Element 6
 | ProductServiceID1 | Element 2
 | ProductServiceID2 | Element 8
 | ProductServiceIDQualifier | Element 1
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeMedicalProcedureIdentifier

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Constructor

CompositeMedicalProcedureIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► CompositeMedicalProcedureIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeMedicalProcedureIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier()
Public Sub New
public:
CompositeMedicalProcedureIdentifier()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Init Method (element, ds)

Init Method (element, ds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► Init(LightWeightElement, DocumentSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public void Init(
    LightWeightElement element,
    DocumentSegment ds
)
Public Sub Init ( _
    element As LightWeightElement, _
    ds As DocumentSegment _
)
public:
void Init(
    LightWeightElement^ element,
    DocumentSegment^ ds
)
Parameters
element (LightWeightElement)
ds (DocumentSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProcedureModifier1 Property

ProcedureModifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier1 { get; set; }
Public Property ProcedureModifier1 As String
    Get
    Set
public:
property String^ ProcedureModifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProcedureModifier2 Property

ProcedureModifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier2 { get; set; }
Public Property ProcedureModifier2 As String
    Get
    Set
public:
property String^ ProcedureModifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProcedureModifier3 Property

ProcedureModifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier3 { get; set; }
Public Property ProcedureModifier3 As String
    Get
    Set
public:
property String^ ProcedureModifier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProcedureModifier4 Property

ProcedureModifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProcedureModifier4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier4 { get; set; }
Public Property ProcedureModifier4 As String
    Get
    Set
public:
property String^ ProcedureModifier4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProductServiceID1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProductServiceID2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeMedicalProcedureIdentifier ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeUnitOfMeasure Class

CompositeUnitOfMeasure Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure
RDPCrystal EDI Library
C001
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeUnitOfMeasure : DocumentCompositeElement
Public Class CompositeUnitOfMeasure _
    Inherits DocumentCompositeElement
public ref class CompositeUnitOfMeasure : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeUnitOfMeasure()()()() | Initializes a new instance of the CompositeUnitOfMeasure class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exponent1 | Element 2
 | Exponent2 | Element 5
 | Exponent3 | Element 8
 | Exponent4 | Element 11
 | Exponent5 | Element 14
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier1 | Element 3
 | Multiplier2 | Element 6
 | Multiplier3 | Element 9
 | Multiplier4 | Element 12
 | Multiplier5 | Element 15
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnitOrBasisForMeasurementCode1 | Element 1
 | UnitOrBasisForMeasurementCode2 | Element 4
 | UnitOrBasisForMeasurementCode3 | Element 7
 | UnitOrBasisForMeasurementCode4 | Element 10
 | UnitOrBasisForMeasurementCode5 | Element 13
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | CompositeUnitOfMeasure

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeUnitOfMeasure Constructor

CompositeUnitOfMeasure Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► CompositeUnitOfMeasure()()()()
RDPCrystal EDI Library
Initializes a new instance of the CompositeUnitOfMeasure class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure()
Public Sub New
public:
CompositeUnitOfMeasure()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Exponent1 Property

Exponent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Exponent1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent1 { get; set; }
Public Property Exponent1 As String
    Get
    Set
public:
property String^ Exponent1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Exponent2 Property

Exponent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Exponent2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent2 { get; set; }
Public Property Exponent2 As String
    Get
    Set
public:
property String^ Exponent2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Exponent3 Property

Exponent3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Exponent3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent3 { get; set; }
Public Property Exponent3 As String
    Get
    Set
public:
property String^ Exponent3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Exponent4 Property

Exponent4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Exponent4
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent4 { get; set; }
Public Property Exponent4 As String
    Get
    Set
public:
property String^ Exponent4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Exponent5 Property

Exponent5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Exponent5
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent5 { get; set; }
Public Property Exponent5 As String
    Get
    Set
public:
property String^ Exponent5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Multiplier1 Property

Multiplier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Multiplier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier1 { get; set; }
Public Property Multiplier1 As String
    Get
    Set
public:
property String^ Multiplier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Multiplier2 Property

Multiplier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Multiplier2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier2 { get; set; }
Public Property Multiplier2 As String
    Get
    Set
public:
property String^ Multiplier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Multiplier3 Property

Multiplier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Multiplier3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier3 { get; set; }
Public Property Multiplier3 As String
    Get
    Set
public:
property String^ Multiplier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Multiplier4 Property

Multiplier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Multiplier4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier4 { get; set; }
Public Property Multiplier4 As String
    Get
    Set
public:
property String^ Multiplier4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Multiplier5 Property

Multiplier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► Multiplier5
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier5 { get; set; }
Public Property Multiplier5 As String
    Get
    Set
public:
property String^ Multiplier5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode5 Property

UnitOrBasisForMeasurementCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode5 { get; set; }
Public Property UnitOrBasisForMeasurementCode5 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContextIndentification Class

ContextIndentification Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ContextIndentification
RDPCrystal EDI Library
C998
Declaration Syntax
C# Visual Basic Visual C++
public class ContextIndentification : DocumentCompositeElement
Public Class ContextIndentification _
    Inherits DocumentCompositeElement
public ref class ContextIndentification : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextIndentification()()()() | Initializes a new instance of the ContextIndentification class
 | ContextName |
 | ContextReference |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ContextIndentification

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContextIndentification Constructor

ContextIndentification Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ContextIndentification ► ContextIndentification()()()()
RDPCrystal EDI Library
Initializes a new instance of the ContextIndentification class
Declaration Syntax
C# Visual Basic Visual C++
public ContextIndentification()
Public Sub New
public:
ContextIndentification()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContextName Property

ContextName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ContextIndentification ► ContextName
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ContextName { get; set; }
Public Property ContextName As String
    Get
    Set
public:
property String^ ContextName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContextReference Property

ContextReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ContextIndentification ► ContextReference
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ContextReference { get; set; }
Public Property ContextReference As String
    Get
    Set
public:
property String^ ContextReference {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ContextIndentification ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR1 Class

CR1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1
RDPCrystal EDI Library
Ambulance Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR1 : DocumentSegment
Public Class CR1 _
    Inherits DocumentSegment
public ref class CR1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR1()()()() | Initializes a new instance of the CR1 class
 | Address1 | Element 7
 | Address2 | Element 8
 | AmbulanceTransportCode1 | Element 3
 | AmbulanceTransportReasonCode | Element 4
 | Description1 | Element 9
 | Description2 | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode1 | Element 1
 | UnitOrBasisForMeasurementCode2 | Element 5
 | Weight | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR1 Constructor

CR1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► CR1()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR1 class
Declaration Syntax
C# Visual Basic Visual C++
public CR1()
Public Sub New
public:
CR1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Address1 Property

Address1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Address1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Address2 Property

Address2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Address2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AmbulanceTransportCode1 Property

AmbulanceTransportCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► AmbulanceTransportCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string AmbulanceTransportCode1 { get; set; }
Public Property AmbulanceTransportCode1 As String
    Get
    Set
public:
property String^ AmbulanceTransportCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AmbulanceTransportReasonCode Property

AmbulanceTransportReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► AmbulanceTransportReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string AmbulanceTransportReasonCode { get; set; }
Public Property AmbulanceTransportReasonCode As String
    Get
    Set
public:
property String^ AmbulanceTransportReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Description1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Description2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► UnitOrBasisForMeasurementCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► UnitOrBasisForMeasurementCode2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Weight
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR2 Class

CR2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2
RDPCrystal EDI Library
Chiropractic Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR2 : DocumentSegment
Public Class CR2 _
    Inherits DocumentSegment
public ref class CR2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR2()()()() | Initializes a new instance of the CR2 class
 | Count | Element 1
 | Description1 | Element 10
 | Description2 | Element 11
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NatureOfConditionCode | Element 8
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 2
 | Quantity2 | Element 6
 | Quantity3 | Element 7
 | SubluxationLevelCode1 | Element 3
 | SubluxationLevelCode2 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 5
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 9
 | YesNoConditionOrResponseCode2 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR2

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR2 Constructor

CR2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► CR2()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR2 class
Declaration Syntax
C# Visual Basic Visual C++
public CR2()
Public Sub New
public:
CR2()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Count
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Description1
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Description2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NatureOfConditionCode Property

NatureOfConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► NatureOfConditionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string NatureOfConditionCode { get; set; }
Public Property NatureOfConditionCode As String
    Get
    Set
public:
property String^ NatureOfConditionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Quantity1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Quantity2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Quantity3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SubluxationLevelCode1 Property

SubluxationLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► SubluxationLevelCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SubluxationLevelCode1 { get; set; }
Public Property SubluxationLevelCode1 As String
    Get
    Set
public:
property String^ SubluxationLevelCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SubluxationLevelCode2 Property

SubluxationLevelCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► SubluxationLevelCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SubluxationLevelCode2 { get; set; }
Public Property SubluxationLevelCode2 As String
    Get
    Set
public:
property String^ SubluxationLevelCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR2 ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR3 Class

CR3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3
RDPCrystal EDI Library
Durable Medical Equipment Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR3 : DocumentSegment
Public Class CR3 _
    Inherits DocumentSegment
public ref class CR3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR3()()()() | Initializes a new instance of the CR3 class
 | CertificationTypeCode | Element 1
 | Description | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsulinDependentCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR3

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR3 Constructor

CR3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► CR3()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR3 class
Declaration Syntax
C# Visual Basic Visual C++
public CR3()
Public Sub New
public:
CR3()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► CertificationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► Description
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InsulinDependentCode Property

InsulinDependentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► InsulinDependentCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InsulinDependentCode { get; set; }
Public Property InsulinDependentCode As String
    Get
    Set
public:
property String^ InsulinDependentCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR5 Class

CR5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5
RDPCrystal EDI Library
Oxygen Therapy Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR5 : DocumentSegment
Public Class CR5 _
    Inherits DocumentSegment
public ref class CR5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR5()()()() | Initializes a new instance of the CR5 class
 | CertificationTypeCode | Element 1
 | Description1 | Element 5
 | Description2 | Element 9
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OxygenDeliverySystemCode | Element 17
 | OxygenEquipmentTypeCode1 | Element 3
 | OxygenEquipmentTypeCode2 | Element 4
 | OxygenEquipmentTypeCode3 | Element 18
 | OxygenTestConditionCode | Element 12
 | OxygenTestFindingsCode1 | Element 13
 | OxygenTestFindingsCode2 | Element 14
 | OxygenTestFindingsCode3 | Element 15
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 2
 | Quantity2 | Element 6
 | Quantity3 | Element 7
 | Quantity4 | Element 8
 | Quantity5 | Element 10
 | Quantity6 | Element 11
 | Quantity7 | Element 16
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR5

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR5 Constructor

CR5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► CR5()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR5 class
Declaration Syntax
C# Visual Basic Visual C++
public CR5()
Public Sub New
public:
CR5()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► CertificationTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Description1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Description2
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenDeliverySystemCode Property

OxygenDeliverySystemCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenDeliverySystemCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenDeliverySystemCode { get; set; }
Public Property OxygenDeliverySystemCode As String
    Get
    Set
public:
property String^ OxygenDeliverySystemCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenEquipmentTypeCode1 Property

OxygenEquipmentTypeCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenEquipmentTypeCode1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenEquipmentTypeCode1 { get; set; }
Public Property OxygenEquipmentTypeCode1 As String
    Get
    Set
public:
property String^ OxygenEquipmentTypeCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenEquipmentTypeCode2 Property

OxygenEquipmentTypeCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenEquipmentTypeCode2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenEquipmentTypeCode2 { get; set; }
Public Property OxygenEquipmentTypeCode2 As String
    Get
    Set
public:
property String^ OxygenEquipmentTypeCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenEquipmentTypeCode3 Property

OxygenEquipmentTypeCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenEquipmentTypeCode3
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenEquipmentTypeCode3 { get; set; }
Public Property OxygenEquipmentTypeCode3 As String
    Get
    Set
public:
property String^ OxygenEquipmentTypeCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenTestConditionCode Property

OxygenTestConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenTestConditionCode
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestConditionCode { get; set; }
Public Property OxygenTestConditionCode As String
    Get
    Set
public:
property String^ OxygenTestConditionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenTestFindingsCode1 Property

OxygenTestFindingsCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenTestFindingsCode1
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestFindingsCode1 { get; set; }
Public Property OxygenTestFindingsCode1 As String
    Get
    Set
public:
property String^ OxygenTestFindingsCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenTestFindingsCode2 Property

OxygenTestFindingsCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenTestFindingsCode2
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestFindingsCode2 { get; set; }
Public Property OxygenTestFindingsCode2 As String
    Get
    Set
public:
property String^ OxygenTestFindingsCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OxygenTestFindingsCode3 Property

OxygenTestFindingsCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► OxygenTestFindingsCode3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string OxygenTestFindingsCode3 { get; set; }
Public Property OxygenTestFindingsCode3 As String
    Get
    Set
public:
property String^ OxygenTestFindingsCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity4
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity5
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity6
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity7 Property

Quantity7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Quantity7
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity7 { get; set; }
Public Property Quantity7 As String
    Get
    Set
public:
property String^ Quantity7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR6 Class

CR6 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6
RDPCrystal EDI Library
Home Health Care Certification
Declaration Syntax
C# Visual Basic Visual C++
public class CR6 : DocumentSegment
Public Class CR6 _
    Inherits DocumentSegment
public ref class CR6 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR6()()()() | Initializes a new instance of the CR6 class
 | CertificationTypeCode | Element 8
 | Date1 | Element 2
 | Date10 | Element 21
 | Date2 | Element 5
 | Date3 | Element 9
 | Date4 | Element 12
 | Date5 | Element 13
 | Date6 | Element 14
 | Date7 | Element 18
 | Date8 | Element 19
 | Date9 | Element 20
 | DateTimePeriod1 | Element 4
 | DateTimePeriod2 | Element 16
 | DateTimePeriodFormatQualifier1 | Element 3
 | DateTimePeriodFormatQualifier2 | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalCodeValue | Element 11
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientLocationCode | Element 17
 | ProductServiceIDQualifier | Element 10
 | PrognosisCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 6
 | YesNoConditionOrResponseCode2 | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR6

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CR6 Constructor

CR6 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► CR6()()()()
RDPCrystal EDI Library
Initializes a new instance of the CR6 class
Declaration Syntax
C# Visual Basic Visual C++
public CR6()
Public Sub New
public:
CR6()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► CertificationTypeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date10 Property

Date10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date10
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string Date10 { get; set; }
Public Property Date10 As String
    Get
    Set
public:
property String^ Date10 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date4 Property

Date4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Date4 { get; set; }
Public Property Date4 As String
    Get
    Set
public:
property String^ Date4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date5 Property

Date5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Date5 { get; set; }
Public Property Date5 As String
    Get
    Set
public:
property String^ Date5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date6 Property

Date6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Date6 { get; set; }
Public Property Date6 As String
    Get
    Set
public:
property String^ Date6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date7 Property

Date7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date7
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string Date7 { get; set; }
Public Property Date7 As String
    Get
    Set
public:
property String^ Date7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date8 Property

Date8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date8
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string Date8 { get; set; }
Public Property Date8 As String
    Get
    Set
public:
property String^ Date8 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date9 Property

Date9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Date9
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string Date9 { get; set; }
Public Property Date9 As String
    Get
    Set
public:
property String^ Date9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod1 Property

DateTimePeriod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► DateTimePeriod1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod1 { get; set; }
Public Property DateTimePeriod1 As String
    Get
    Set
public:
property String^ DateTimePeriod1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod2 Property

DateTimePeriod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► DateTimePeriod2
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod2 { get; set; }
Public Property DateTimePeriod2 As String
    Get
    Set
public:
property String^ DateTimePeriod2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier1 Property

DateTimePeriodFormatQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► DateTimePeriodFormatQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier1 { get; set; }
Public Property DateTimePeriodFormatQualifier1 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier2 Property

DateTimePeriodFormatQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► DateTimePeriodFormatQualifier2
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier2 { get; set; }
Public Property DateTimePeriodFormatQualifier2 As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MedicalCodeValue Property

MedicalCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► MedicalCodeValue
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue { get; set; }
Public Property MedicalCodeValue As String
    Get
    Set
public:
property String^ MedicalCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PatientLocationCode Property

PatientLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► PatientLocationCode
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string PatientLocationCode { get; set; }
Public Property PatientLocationCode As String
    Get
    Set
public:
property String^ PatientLocationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► PrognosisCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CR6 ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CRC Class

CRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC
RDPCrystal EDI Library
Conditions Indicator
Declaration Syntax
C# Visual Basic Visual C++
public class CRC : DocumentSegment
Public Class CRC _
    Inherits DocumentSegment
public ref class CRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRC()()()() | Initializes a new instance of the CRC class
 | CodeCategory | Element 1
 | ConditionIndicator1 | Element 3
 | ConditionIndicator2 | Element 4
 | ConditionIndicator3 | Element 5
 | ConditionIndicator4 | Element 6
 | ConditionIndicator5 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRC

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CRC Constructor

CRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► CRC()()()()
RDPCrystal EDI Library
Initializes a new instance of the CRC class
Declaration Syntax
C# Visual Basic Visual C++
public CRC()
Public Sub New
public:
CRC()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► CodeCategory
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConditionIndicator1 Property

ConditionIndicator1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► ConditionIndicator1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator1 { get; set; }
Public Property ConditionIndicator1 As String
    Get
    Set
public:
property String^ ConditionIndicator1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConditionIndicator2 Property

ConditionIndicator2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► ConditionIndicator2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator2 { get; set; }
Public Property ConditionIndicator2 As String
    Get
    Set
public:
property String^ ConditionIndicator2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConditionIndicator3 Property

ConditionIndicator3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► ConditionIndicator3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator3 { get; set; }
Public Property ConditionIndicator3 As String
    Get
    Set
public:
property String^ ConditionIndicator3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConditionIndicator4 Property

ConditionIndicator4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► ConditionIndicator4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator4 { get; set; }
Public Property ConditionIndicator4 As String
    Get
    Set
public:
property String^ ConditionIndicator4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConditionIndicator5 Property

ConditionIndicator5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► ConditionIndicator5
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator5 { get; set; }
Public Property ConditionIndicator5 As String
    Get
    Set
public:
property String^ ConditionIndicator5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CRC ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CTP Class

CTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP
RDPCrystal EDI Library
Pricing Information
Declaration Syntax
C# Visual Basic Visual C++
public class CTP : DocumentSegment
Public Class CTP _
    Inherits DocumentSegment
public ref class CTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTP()()()() | Initializes a new instance of the CTP class
 | BasisOfUnitPriceCode | Element 9
 | ClassOfTradeCode | Element 1
 | CompositeUnitOfMeasure | Element 5
 | ConditionValue | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 8
 | MultiplePriceQuantity | Element 11
 | Multiplier | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceIdentifierCode | Element 2
 | PriceMultiplierQualifier | Element 6
 | Quantity | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTP

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CTP Constructor

CTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► CTP()()()()
RDPCrystal EDI Library
Initializes a new instance of the CTP class
Declaration Syntax
C# Visual Basic Visual C++
public CTP()
Public Sub New
public:
CTP()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► BasisOfUnitPriceCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► ClassOfTradeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► CompositeUnitOfMeasure
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConditionValue Property

ConditionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► ConditionValue
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue { get; set; }
Public Property ConditionValue As String
    Get
    Set
public:
property String^ ConditionValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► MonetaryAmount
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MultiplePriceQuantity Property

MultiplePriceQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► MultiplePriceQuantity
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MultiplePriceQuantity { get; set; }
Public Property MultiplePriceQuantity As String
    Get
    Set
public:
property String^ MultiplePriceQuantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► Multiplier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► PriceIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PriceMultiplierQualifier Property

PriceMultiplierQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► PriceMultiplierQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string PriceMultiplierQualifier { get; set; }
Public Property PriceMultiplierQualifier As String
    Get
    Set
public:
property String^ PriceMultiplierQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► UnitPrice
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CTX Class

CTX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX
RDPCrystal EDI Library
SegmentContext
Declaration Syntax
C# Visual Basic Visual C++
public class CTX : DocumentSegment
Public Class CTX _
    Inherits DocumentSegment
public ref class CTX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTX()()()() | Initializes a new instance of the CTX class
 | ContextIndentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment | Element 5
 | ReferenceInSegment | Element 6
 | SegmentIDCode | Element 2
 | SegmentPositionInTransactionSet | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTX

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CTX Constructor

CTX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► CTX()()()()
RDPCrystal EDI Library
Initializes a new instance of the CTX class
Declaration Syntax
C# Visual Basic Visual C++
public CTX()
Public Sub New
public:
CTX()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContextIndentification Property

ContextIndentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► ContextIndentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public ContextIndentification ContextIndentification { get; set; }
Public Property ContextIndentification As ContextIndentification
    Get
    Set
public:
property ContextIndentification^ ContextIndentification {
    ContextIndentification^ get ();
    void set (ContextIndentification^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► LoopIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► PositionInSegment
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment PositionInSegment { get; set; }
Public Property PositionInSegment As PositionInSegment
    Get
    Set
public:
property PositionInSegment^ PositionInSegment {
    PositionInSegment^ get ();
    void set (PositionInSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceInSegment Property

ReferenceInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► ReferenceInSegment
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceInSegment ReferenceInSegment { get; set; }
Public Property ReferenceInSegment As ReferenceInSegment
    Get
    Set
public:
property ReferenceInSegment^ ReferenceInSegment {
    ReferenceInSegment^ get ();
    void set (ReferenceInSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► SegmentIDCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SegmentPositionInTransactionSet Property

SegmentPositionInTransactionSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► SegmentPositionInTransactionSet
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentPositionInTransactionSet { get; set; }
Public Property SegmentPositionInTransactionSet As String
    Get
    Set
public:
property String^ SegmentPositionInTransactionSet {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CTX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CUR Class

CUR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CUR
RDPCrystal EDI Library
Currency
Declaration Syntax
C# Visual Basic Visual C++
public class CUR : DocumentSegment
Public Class CUR _
    Inherits DocumentSegment
public ref class CUR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CUR()()()() | Initializes a new instance of the CUR class
 | CurrencyCode | Element 2
 | EntityIdentifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CUR

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CUR Constructor

CUR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CUR ► CUR()()()()
RDPCrystal EDI Library
Initializes a new instance of the CUR class
Declaration Syntax
C# Visual Basic Visual C++
public CUR()
Public Sub New
public:
CUR()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CUR ► CurrencyCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CUR ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CUR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► CUR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DMG Class

DMG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG
RDPCrystal EDI Library
Demographic Information
Declaration Syntax
C# Visual Basic Visual C++
public class DMG : DocumentSegment
Public Class DMG _
    Inherits DocumentSegment
public ref class DMG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DMG()()()() | Initializes a new instance of the DMG class
 | BasisOfVerificationCode | Element 8
 | CitizenshipStatusCode | Element 6
 | CodeListQualifierCode | Element 10
 | CountryCode | Element 7
 | DateTimePeriod | Element 2
 | DateTimePeriodFormatQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode | Element 3
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaritalStatusCode | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 9
 | RaceOrEthnicityInformation | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DMG

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DMG Constructor

DMG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► DMG()()()()
RDPCrystal EDI Library
Initializes a new instance of the DMG class
Declaration Syntax
C# Visual Basic Visual C++
public DMG()
Public Sub New
public:
DMG()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BasisOfVerificationCode Property

BasisOfVerificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► BasisOfVerificationCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfVerificationCode { get; set; }
Public Property BasisOfVerificationCode As String
    Get
    Set
public:
property String^ BasisOfVerificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CitizenshipStatusCode Property

CitizenshipStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► CitizenshipStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CitizenshipStatusCode { get; set; }
Public Property CitizenshipStatusCode As String
    Get
    Set
public:
property String^ CitizenshipStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► CodeListQualifierCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► CountryCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► DateTimePeriod
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► GenderCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► IndustryCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MaritalStatusCode Property

MaritalStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► MaritalStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MaritalStatusCode { get; set; }
Public Property MaritalStatusCode As String
    Get
    Set
public:
property String^ MaritalStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► Quantity
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RaceOrEthnicityInformation Property

RaceOrEthnicityInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► RaceOrEthnicityInformation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public RaceOrEthnicityInformation RaceOrEthnicityInformation { get; set; }
Public Property RaceOrEthnicityInformation As RaceOrEthnicityInformation
    Get
    Set
public:
property RaceOrEthnicityInformation^ RaceOrEthnicityInformation {
    RaceOrEthnicityInformation^ get ();
    void set (RaceOrEthnicityInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DMG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DN1 Class

DN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1
RDPCrystal EDI Library
Orthodontic Information
Declaration Syntax
C# Visual Basic Visual C++
public class DN1 : DocumentSegment
Public Class DN1 _
    Inherits DocumentSegment
public ref class DN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN1()()()() | Initializes a new instance of the DN1 class
 | Description | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 1
 | Quantity2 | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DN1 Constructor

DN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► DN1()()()()
RDPCrystal EDI Library
Initializes a new instance of the DN1 class
Declaration Syntax
C# Visual Basic Visual C++
public DN1()
Public Sub New
public:
DN1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► Quantity1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► Quantity2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN1 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DN2 Class

DN2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN2
RDPCrystal EDI Library
Tooth Summary
Declaration Syntax
C# Visual Basic Visual C++
public class DN2 : DocumentSegment
Public Class DN2 _
    Inherits DocumentSegment
public ref class DN2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN2()()()() | Initializes a new instance of the DN2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToothNumber | Element 1
 | ToothStatusCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN2

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DN2 Constructor

DN2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN2 ► DN2()()()()
RDPCrystal EDI Library
Initializes a new instance of the DN2 class
Declaration Syntax
C# Visual Basic Visual C++
public DN2()
Public Sub New
public:
DN2()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothNumber Property

ToothNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN2 ► ToothNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ToothNumber { get; set; }
Public Property ToothNumber As String
    Get
    Set
public:
property String^ ToothNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothStatusCode Property

ToothStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN2 ► ToothStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ToothStatusCode { get; set; }
Public Property ToothStatusCode As String
    Get
    Set
public:
property String^ ToothStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DN2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DSB Class

DSB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB
RDPCrystal EDI Library
Disability Information
Declaration Syntax
C# Visual Basic Visual C++
public class DSB : DocumentSegment
Public Class DSB _
    Inherits DocumentSegment
public ref class DSB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSB()()()() | Initializes a new instance of the DSB class
 | DisabilityTypeCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalCodeValue | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 6
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductOptionCode | Element 5
 | ProductServiceIDQualifier | Element 7
 | Quantity | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WorkIntensityCode | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DSB

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DSB Constructor

DSB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► DSB()()()()
RDPCrystal EDI Library
Initializes a new instance of the DSB class
Declaration Syntax
C# Visual Basic Visual C++
public DSB()
Public Sub New
public:
DSB()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DisabilityTypeCode Property

DisabilityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► DisabilityTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DisabilityTypeCode { get; set; }
Public Property DisabilityTypeCode As String
    Get
    Set
public:
property String^ DisabilityTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MedicalCodeValue Property

MedicalCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► MedicalCodeValue
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue { get; set; }
Public Property MedicalCodeValue As String
    Get
    Set
public:
property String^ MedicalCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► MonetaryAmount
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► OccupationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductOptionCode Property

ProductOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► ProductOptionCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode { get; set; }
Public Property ProductOptionCode As String
    Get
    Set
public:
property String^ ProductOptionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


WorkIntensityCode Property

WorkIntensityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► WorkIntensityCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string WorkIntensityCode { get; set; }
Public Property WorkIntensityCode As String
    Get
    Set
public:
property String^ WorkIntensityCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DSB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DTM Class

DTM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM
RDPCrystal EDI Library
Date/Time Reference
Declaration Syntax
C# Visual Basic Visual C++
public class DTM : DocumentSegment
Public Class DTM _
    Inherits DocumentSegment
public ref class DTM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DTM()()()() | Initializes a new instance of the DTM class
 | Date | Element 2
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | DateTimeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 3
 | TimeCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DTM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DTM Constructor

DTM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► DTM()()()()
RDPCrystal EDI Library
Initializes a new instance of the DTM class
Declaration Syntax
C# Visual Basic Visual C++
public DTM()
Public Sub New
public:
DTM()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► DateTimeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► Time
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► TimeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DTP Class

DTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP
RDPCrystal EDI Library
Date or Time or Period
Declaration Syntax
C# Visual Basic Visual C++
public class DTP : DocumentSegment
Public Class DTP _
    Inherits DocumentSegment
public ref class DTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DTP()()()() | Initializes a new instance of the DTP class
 | DateTimePeriod | Element 3
 | DateTimePeriodFormatQualifier | Element 2
 | DateTimeQualifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DTP

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DTP Constructor

DTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP ► DTP()()()()
RDPCrystal EDI Library
Initializes a new instance of the DTP class
Declaration Syntax
C# Visual Basic Visual C++
public DTP()
Public Sub New
public:
DTP()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP ► DateTimePeriod
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP ► DateTimeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► DTP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EB Class

EB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB
RDPCrystal EDI Library
Eligibility or Benefit Information
Declaration Syntax
C# Visual Basic Visual C++
public class EB : DocumentSegment
Public Class EB _
    Inherits DocumentSegment
public ref class EB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EB()()()() | Initializes a new instance of the EB class
 | CompositeDiagnosticCodePointer | Element 14
 | CompositeMedicalProcedureIdentifier | Element 13
 | CoverageLevelCode | Element 2
 | EligibilityOrBenefitInformationCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceTypeCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percentage | Element 8
 | PlanCoverageDescription | Element 5
 | Quantity | Element 10
 | QuantityQualifier | Element 9
 | ServiceTypeCode | Element 3
 | TimePeriodQualifier | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 11
 | YesNoConditionOrResponseCode2 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EB

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EB Constructor

EB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► EB()()()()
RDPCrystal EDI Library
Initializes a new instance of the EB class
Declaration Syntax
C# Visual Basic Visual C++
public EB()
Public Sub New
public:
EB()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► CompositeDiagnosticCodePointer
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► CoverageLevelCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EligibilityOrBenefitInformationCode Property

EligibilityOrBenefitInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► EligibilityOrBenefitInformationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityOrBenefitInformationCode { get; set; }
Public Property EligibilityOrBenefitInformationCode As String
    Get
    Set
public:
property String^ EligibilityOrBenefitInformationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► InsuranceTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► MonetaryAmount
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► Percentage
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► PlanCoverageDescription
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► Quantity
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► QuantityQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► ServiceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► TimePeriodQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EB ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EC Class

EC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC
RDPCrystal EDI Library
Employment Class
Declaration Syntax
C# Visual Basic Visual C++
public class EC : DocumentSegment
Public Class EC _
    Inherits DocumentSegment
public ref class EC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EC()()()() | Initializes a new instance of the EC class
 | EmploymentClassCode1 | Element 1
 | EmploymentClassCode2 | Element 2
 | EmploymentClassCode3 | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percentage | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EC

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EC Constructor

EC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► EC()()()()
RDPCrystal EDI Library
Initializes a new instance of the EC class
Declaration Syntax
C# Visual Basic Visual C++
public EC()
Public Sub New
public:
EC()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentClassCode1 Property

EmploymentClassCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► EmploymentClassCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode1 { get; set; }
Public Property EmploymentClassCode1 As String
    Get
    Set
public:
property String^ EmploymentClassCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentClassCode2 Property

EmploymentClassCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► EmploymentClassCode2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode2 { get; set; }
Public Property EmploymentClassCode2 As String
    Get
    Set
public:
property String^ EmploymentClassCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentClassCode3 Property

EmploymentClassCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► EmploymentClassCode3
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode3 { get; set; }
Public Property EmploymentClassCode3 As String
    Get
    Set
public:
property String^ EmploymentClassCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► InformationStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► OccupationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► Percentage
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EQ Class

EQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ
RDPCrystal EDI Library
Eligibility or Benefit Inquiry
Declaration Syntax
C# Visual Basic Visual C++
public class EQ : DocumentSegment
Public Class EQ _
    Inherits DocumentSegment
public ref class EQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EQ()()()() | Initializes a new instance of the EQ class
 | CompositeDiagnosticCodePointer | Element 5
 | CompositeMedicalProcedureIdentifier | Element 2
 | CoverageLevelCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceTypeCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EQ

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EQ Constructor

EQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► EQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the EQ class
Declaration Syntax
C# Visual Basic Visual C++
public EQ()
Public Sub New
public:
EQ()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► CompositeDiagnosticCodePointer
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► CoverageLevelCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► InsuranceTypeCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► ServiceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► EQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FRM Class

FRM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM
RDPCrystal EDI Library
Supporting Documentation
Declaration Syntax
C# Visual Basic Visual C++
public class FRM : DocumentSegment
Public Class FRM _
    Inherits DocumentSegment
public ref class FRM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FRM()()()() | Initializes a new instance of the FRM class
 | AssignedIdentification | Element 1
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent | Element 5
 | ReferenceIdentification | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 2
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FRM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FRM Constructor

FRM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► FRM()()()()
RDPCrystal EDI Library
Initializes a new instance of the FRM class
Declaration Syntax
C# Visual Basic Visual C++
public FRM()
Public Sub New
public:
FRM()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► Percent
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► FRM ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GE Class

GE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GE
RDPCrystal EDI Library
Functional Group Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class GE : DocumentSegment
Public Class GE _
    Inherits DocumentSegment
public ref class GE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GE()()()() | Initializes a new instance of the GE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfTransactionSetsIncluded | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GE Constructor

GE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GE ► GE()()()()
RDPCrystal EDI Library
Initializes a new instance of the GE class
Declaration Syntax
C# Visual Basic Visual C++
public GE()
Public Sub New
public:
GE()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GE ► GroupControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GE ► NumberOfTransactionSetsIncluded
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GS Class

GS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS
RDPCrystal EDI Library
Functional Group Header
Declaration Syntax
C# Visual Basic Visual C++
public class GS : DocumentSegment
Public Class GS _
    Inherits DocumentSegment
public ref class GS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GS()()()() | Initializes a new instance of the GS class
 | ApplicationReceiverCode | Element 3
 | ApplicationSenderCode | Element 2
 | Date | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ResponsibleAgencyCode | Element 7
 | Time | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionReleaseIndustryIdentifierCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GS Constructor

GS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► GS()()()()
RDPCrystal EDI Library
Initializes a new instance of the GS class
Declaration Syntax
C# Visual Basic Visual C++
public GS()
Public Sub New
public:
GS()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ApplicationReceiverCode Property

ApplicationReceiverCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► ApplicationReceiverCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationReceiverCode { get; set; }
Public Property ApplicationReceiverCode As String
    Get
    Set
public:
property String^ ApplicationReceiverCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ApplicationSenderCode Property

ApplicationSenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► ApplicationSenderCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationSenderCode { get; set; }
Public Property ApplicationSenderCode As String
    Get
    Set
public:
property String^ ApplicationSenderCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► Date
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► FunctionalIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► GroupControlNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ResponsibleAgencyCode Property

ResponsibleAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► ResponsibleAgencyCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ResponsibleAgencyCode { get; set; }
Public Property ResponsibleAgencyCode As String
    Get
    Set
public:
property String^ ResponsibleAgencyCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► Time
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► VersionReleaseIndustryIdentifierCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► GS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HCP Class

HCP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP
RDPCrystal EDI Library
Health Care Pricing
Declaration Syntax
C# Visual Basic Visual C++
public class HCP : DocumentSegment
Public Class HCP _
    Inherits DocumentSegment
public ref class HCP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HCP()()()() | Initializes a new instance of the HCP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionCode | Element 15
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 2
 | MonetaryAmount2 | Element 3
 | MonetaryAmount3 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PolicyComplianceCode | Element 14
 | PricingMethodology | Element 1
 | ProductServiceID1 | Element 8
 | ProductServiceID2 | Element 10
 | ProductServiceIDQualifier | Element 9
 | Quantity | Element 12
 | Rate | Element 5
 | ReferenceIdentification1 | Element 4
 | ReferenceIdentification2 | Element 6
 | RejectReasonCode | Element 13
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 11
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HCP

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HCP Constructor

HCP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► HCP()()()()
RDPCrystal EDI Library
Initializes a new instance of the HCP class
Declaration Syntax
C# Visual Basic Visual C++
public HCP()
Public Sub New
public:
HCP()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ExceptionCode Property

ExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► ExceptionCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ExceptionCode { get; set; }
Public Property ExceptionCode As String
    Get
    Set
public:
property String^ ExceptionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► MonetaryAmount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► MonetaryAmount2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► MonetaryAmount3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PolicyComplianceCode Property

PolicyComplianceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► PolicyComplianceCode
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string PolicyComplianceCode { get; set; }
Public Property PolicyComplianceCode As String
    Get
    Set
public:
property String^ PolicyComplianceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PricingMethodology Property

PricingMethodology Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► PricingMethodology
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PricingMethodology { get; set; }
Public Property PricingMethodology As String
    Get
    Set
public:
property String^ PricingMethodology {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► ProductServiceID1
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► ProductServiceID2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► ProductServiceIDQualifier
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► Quantity
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► Rate
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► ReferenceIdentification1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► ReferenceIdentification2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► RejectReasonCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HCP ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HD Class

HD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD
RDPCrystal EDI Library
Health Coverage
Declaration Syntax
C# Visual Basic Visual C++
public class HD : DocumentSegment
Public Class HD _
    Inherits DocumentSegment
public ref class HD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HD()()()() | Initializes a new instance of the HD class
 | Count1 | Element 6
 | Count2 | Element 7
 | CoverageLevelCode | Element 5
 | DrugHouseCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceLineCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 2
 | MaintenanceTypeCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnderwritingDecisionCode | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 9
 | YesNoConditionOrResponseCode2 | Element 11
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HD

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HD Constructor

HD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► HD()()()()
RDPCrystal EDI Library
Initializes a new instance of the HD class
Declaration Syntax
C# Visual Basic Visual C++
public HD()
Public Sub New
public:
HD()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Count1 Property

Count1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► Count1
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Count1 { get; set; }
Public Property Count1 As String
    Get
    Set
public:
property String^ Count1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Count2 Property

Count2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► Count2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Count2 { get; set; }
Public Property Count2 As String
    Get
    Set
public:
property String^ Count2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► CoverageLevelCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DrugHouseCode Property

DrugHouseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► DrugHouseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DrugHouseCode { get; set; }
Public Property DrugHouseCode As String
    Get
    Set
public:
property String^ DrugHouseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InsuranceLineCode Property

InsuranceLineCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► InsuranceLineCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceLineCode { get; set; }
Public Property InsuranceLineCode As String
    Get
    Set
public:
property String^ InsuranceLineCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► PlanCoverageDescription
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnderwritingDecisionCode Property

UnderwritingDecisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► UnderwritingDecisionCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string UnderwritingDecisionCode { get; set; }
Public Property UnderwritingDecisionCode As String
    Get
    Set
public:
property String^ UnderwritingDecisionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HD ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareClaimStatus Class

HealthCareClaimStatus Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus
RDPCrystal EDI Library
C043
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareClaimStatus : DocumentCompositeElement
Public Class HealthCareClaimStatus _
    Inherits DocumentCompositeElement
public ref class HealthCareClaimStatus : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareClaimStatus()()()() | Initializes a new instance of the HealthCareClaimStatus class
 | CodeListQualifierCode |
 | EntityIdentifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode1 |
 | IndustryCode2 |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | HealthCareClaimStatus

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareClaimStatus Constructor

HealthCareClaimStatus Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus ► HealthCareClaimStatus()()()()
RDPCrystal EDI Library
Initializes a new instance of the HealthCareClaimStatus class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus()
Public Sub New
public:
HealthCareClaimStatus()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus ► CodeListQualifierCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus ► EntityIdentifierCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus ► IndustryCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareClaimStatus ► IndustryCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation Class

HealthCareCodeInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation
RDPCrystal EDI Library
C022
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareCodeInformation : DocumentCompositeElement
Public Class HealthCareCodeInformation _
    Inherits DocumentCompositeElement
public ref class HealthCareCodeInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareCodeInformation()()()() | Initializes a new instance of the HealthCareCodeInformation class
 | CodeListQualifierCode | Element 1
 | DateTimePeriod | Element 4
 | DateTimePeriodFormatQualifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | Get all the (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode1 | Element 2
 | IndustryCode2 | Element 8
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 5
 | Quantity | Element 6
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | VersionIdentifier | Element 7
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
 | YesNoConditionOrResponseCode | Element 9
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | HealthCareCodeInformation

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation Constructor

HealthCareCodeInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► HealthCareCodeInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the HealthCareCodeInformation class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation()
Public Sub New
public:
HealthCareCodeInformation()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► DateTimePeriod
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► GetString(Char)
RDPCrystal EDI Library
Get all the
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► IndustryCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► IndustryCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► MonetaryAmount
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► VersionIdentifier
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareCodeInformation ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareServiceLocation Class

HealthCareServiceLocation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareServiceLocation
RDPCrystal EDI Library
C023
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareServiceLocation : DocumentCompositeElement
Public Class HealthCareServiceLocation _
    Inherits DocumentCompositeElement
public ref class HealthCareServiceLocation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareServiceLocation()()()() | Initializes a new instance of the HealthCareServiceLocation class
 | ClaimFrequencyTypeCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeQualifier | Element 2
 | FacilityCodeValue | Element 1
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | HealthCareServiceLocation

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareServiceLocation Constructor

HealthCareServiceLocation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareServiceLocation ► HealthCareServiceLocation()()()()
RDPCrystal EDI Library
Initializes a new instance of the HealthCareServiceLocation class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocation()
Public Sub New
public:
HealthCareServiceLocation()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimFrequencyTypeCode Property

ClaimFrequencyTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareServiceLocation ► ClaimFrequencyTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFrequencyTypeCode { get; set; }
Public Property ClaimFrequencyTypeCode As String
    Get
    Set
public:
property String^ ClaimFrequencyTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FacilityCodeQualifier Property

FacilityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareServiceLocation ► FacilityCodeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeQualifier { get; set; }
Public Property FacilityCodeQualifier As String
    Get
    Set
public:
property String^ FacilityCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareServiceLocation ► FacilityCodeValue
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HealthCareServiceLocation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HI Class

HI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI
RDPCrystal EDI Library
Health Care Information Codes
Declaration Syntax
C# Visual Basic Visual C++
public class HI : DocumentSegment
Public Class HI _
    Inherits DocumentSegment
public ref class HI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HI()()()() | Initializes a new instance of the HI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareCodeInformation1 | Element 1
 | HealthCareCodeInformation10 | Element 10
 | HealthCareCodeInformation11 | Element 11
 | HealthCareCodeInformation12 | Element 12
 | HealthCareCodeInformation2 | Element 2
 | HealthCareCodeInformation3 | Element 3
 | HealthCareCodeInformation4 | Element 4
 | HealthCareCodeInformation5 | Element 5
 | HealthCareCodeInformation6 | Element 6
 | HealthCareCodeInformation7 | Element 7
 | HealthCareCodeInformation8 | Element 8
 | HealthCareCodeInformation9 | Element 9
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HI

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HI Constructor

HI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HI()()()()
RDPCrystal EDI Library
Initializes a new instance of the HI class
Declaration Syntax
C# Visual Basic Visual C++
public HI()
Public Sub New
public:
HI()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation1 Property

HealthCareCodeInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation1 { get; set; }
Public Property HealthCareCodeInformation1 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation1 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation10 Property

HealthCareCodeInformation10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation10
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation10 { get; set; }
Public Property HealthCareCodeInformation10 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation10 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation11 Property

HealthCareCodeInformation11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation11
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation11 { get; set; }
Public Property HealthCareCodeInformation11 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation11 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation12 Property

HealthCareCodeInformation12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation12
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation12 { get; set; }
Public Property HealthCareCodeInformation12 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation12 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation2 Property

HealthCareCodeInformation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation2 { get; set; }
Public Property HealthCareCodeInformation2 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation2 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation3 Property

HealthCareCodeInformation3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation3
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation3 { get; set; }
Public Property HealthCareCodeInformation3 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation3 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation4 Property

HealthCareCodeInformation4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation4
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation4 { get; set; }
Public Property HealthCareCodeInformation4 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation4 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation5 Property

HealthCareCodeInformation5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation5
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation5 { get; set; }
Public Property HealthCareCodeInformation5 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation5 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation6 Property

HealthCareCodeInformation6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation6
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation6 { get; set; }
Public Property HealthCareCodeInformation6 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation6 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation7 Property

HealthCareCodeInformation7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation7
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation7 { get; set; }
Public Property HealthCareCodeInformation7 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation7 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation8 Property

HealthCareCodeInformation8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation8
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation8 { get; set; }
Public Property HealthCareCodeInformation8 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation8 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareCodeInformation9 Property

HealthCareCodeInformation9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► HealthCareCodeInformation9
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation9 { get; set; }
Public Property HealthCareCodeInformation9 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation9 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HL Class

HL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL
RDPCrystal EDI Library
Hierarchical Level
Declaration Syntax
C# Visual Basic Visual C++
public class HL : DocumentSegment
Public Class HL _
    Inherits DocumentSegment
public ref class HL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HL()()()() | Initializes a new instance of the HL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalChildCode | Element 4
 | HierarchicalIDNumber | Element 1
 | HierarchicalLevelCode | Element 3
 | HierarchicalParentIDNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HL Constructor

HL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► HL()()()()
RDPCrystal EDI Library
Initializes a new instance of the HL class
Declaration Syntax
C# Visual Basic Visual C++
public HL()
Public Sub New
public:
HL()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HierarchicalChildCode Property

HierarchicalChildCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► HierarchicalChildCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalChildCode { get; set; }
Public Property HierarchicalChildCode As String
    Get
    Set
public:
property String^ HierarchicalChildCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HierarchicalIDNumber Property

HierarchicalIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► HierarchicalIDNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalIDNumber { get; set; }
Public Property HierarchicalIDNumber As String
    Get
    Set
public:
property String^ HierarchicalIDNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HierarchicalLevelCode Property

HierarchicalLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► HierarchicalLevelCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalLevelCode { get; set; }
Public Property HierarchicalLevelCode As String
    Get
    Set
public:
property String^ HierarchicalLevelCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HierarchicalParentIDNumber Property

HierarchicalParentIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► HierarchicalParentIDNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalParentIDNumber { get; set; }
Public Property HierarchicalParentIDNumber As String
    Get
    Set
public:
property String^ HierarchicalParentIDNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HL ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HLH Class

HLH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH
RDPCrystal EDI Library
Health Information
Declaration Syntax
C# Visual Basic Visual C++
public class HLH : DocumentSegment
Public Class HLH _
    Inherits DocumentSegment
public ref class HLH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HLH()()()() | Initializes a new instance of the HLH class
 | CurrentHealthConditionCode | Element 6
 | Description1 | Element 5
 | Description2 | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthRelatedCode | Element 1
 | Height | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight1 | Element 3
 | Weight2 | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HLH

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HLH Constructor

HLH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► HLH()()()()
RDPCrystal EDI Library
Initializes a new instance of the HLH class
Declaration Syntax
C# Visual Basic Visual C++
public HLH()
Public Sub New
public:
HLH()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CurrentHealthConditionCode Property

CurrentHealthConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► CurrentHealthConditionCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentHealthConditionCode { get; set; }
Public Property CurrentHealthConditionCode As String
    Get
    Set
public:
property String^ CurrentHealthConditionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Description1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Description2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthRelatedCode Property

HealthRelatedCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► HealthRelatedCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string HealthRelatedCode { get; set; }
Public Property HealthRelatedCode As String
    Get
    Set
public:
property String^ HealthRelatedCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Height
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Weight1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Weight2 Property

Weight2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Weight2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Weight2 { get; set; }
Public Property Weight2 As String
    Get
    Set
public:
property String^ Weight2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HLH ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HSD Class

HSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD
RDPCrystal EDI Library
Health Care Services Delivery
Declaration Syntax
C# Visual Basic Visual C++
public class HSD : DocumentSegment
Public Class HSD _
    Inherits DocumentSegment
public ref class HSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HSD()()()() | Initializes a new instance of the HSD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods | Element 6
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | QuantityQualifier | Element 1
 | SampleSelectionModulus | Element 4
 | ShipDeliveryOrCalendarPatternCode | Element 7
 | ShipDeliveryPatternTimeCode | Element 8
 | TimePeriodQualifier | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HSD

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HSD Constructor

HSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► HSD()()()()
RDPCrystal EDI Library
Initializes a new instance of the HSD class
Declaration Syntax
C# Visual Basic Visual C++
public HSD()
Public Sub New
public:
HSD()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► NumberOfPeriods
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SampleSelectionModulus Property

SampleSelectionModulus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► SampleSelectionModulus
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SampleSelectionModulus { get; set; }
Public Property SampleSelectionModulus As String
    Get
    Set
public:
property String^ SampleSelectionModulus {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► ShipDeliveryOrCalendarPatternCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ShipDeliveryPatternTimeCode Property

ShipDeliveryPatternTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► ShipDeliveryPatternTimeCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode { get; set; }
Public Property ShipDeliveryPatternTimeCode As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► TimePeriodQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► HSD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ICM Class

ICM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM
RDPCrystal EDI Library
Individual Income
Declaration Syntax
C# Visual Basic Visual C++
public class ICM : DocumentSegment
Public Class ICM _
    Inherits DocumentSegment
public ref class ICM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ICM()()()() | Initializes a new instance of the ICM class
 | CurrencyCode | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier | Element 4
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 3
 | SalaryGrade | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ICM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ICM Constructor

ICM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► ICM()()()()
RDPCrystal EDI Library
Initializes a new instance of the ICM class
Declaration Syntax
C# Visual Basic Visual C++
public ICM()
Public Sub New
public:
ICM()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► CurrencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► FrequencyCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► LocationIdentifier
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SalaryGrade Property

SalaryGrade Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► SalaryGrade
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string SalaryGrade { get; set; }
Public Property SalaryGrade As String
    Get
    Set
public:
property String^ SalaryGrade {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ICM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IDC Class

IDC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC
RDPCrystal EDI Library
Identification Card
Declaration Syntax
C# Visual Basic Visual C++
public class IDC : DocumentSegment
Public Class IDC _
    Inherits DocumentSegment
public ref class IDC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDC()()()() | Initializes a new instance of the IDC class
 | ActionCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCardTypeCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription | Element 1
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IDC

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IDC Constructor

IDC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► IDC()()()()
RDPCrystal EDI Library
Initializes a new instance of the IDC class
Declaration Syntax
C# Visual Basic Visual C++
public IDC()
Public Sub New
public:
IDC()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► ActionCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCardTypeCode Property

IdentificationCardTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► IdentificationCardTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCardTypeCode { get; set; }
Public Property IdentificationCardTypeCode As String
    Get
    Set
public:
property String^ IdentificationCardTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► PlanCoverageDescription
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IDC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IEA Class

IEA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IEA
RDPCrystal EDI Library
Interchange Control Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class IEA : DocumentSegment
Public Class IEA _
    Inherits DocumentSegment
public ref class IEA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IEA()()()() | Initializes a new instance of the IEA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeControlNumber | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfIncludedFunctionalGroups | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IEA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IEA Constructor

IEA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IEA ► IEA()()()()
RDPCrystal EDI Library
Initializes a new instance of the IEA class
Declaration Syntax
C# Visual Basic Visual C++
public IEA()
Public Sub New
public:
IEA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IEA ► InterchangeControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IEA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfIncludedFunctionalGroups Property

NumberOfIncludedFunctionalGroups Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IEA ► NumberOfIncludedFunctionalGroups
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfIncludedFunctionalGroups { get; set; }
Public Property NumberOfIncludedFunctionalGroups As String
    Get
    Set
public:
property String^ NumberOfIncludedFunctionalGroups {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IEA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


III Class

III Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III
RDPCrystal EDI Library
Information
Declaration Syntax
C# Visual Basic Visual C++
public class III : DocumentSegment
Public Class III _
    Inherits DocumentSegment
public ref class III : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | III()()()() | Initializes a new instance of the III class
 | CodeCategory | Element 3
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformMessageText | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 5
 | SurfaceLayerPositionCode1 | Element 7
 | SurfaceLayerPositionCode2 | Element 8
 | SurfaceLayerPositionCode3 | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | III

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


III Constructor

III Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► III()()()()
RDPCrystal EDI Library
Initializes a new instance of the III class
Declaration Syntax
C# Visual Basic Visual C++
public III()
Public Sub New
public:
III()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► CodeCategory
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FreeformMessageText Property

FreeformMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► FreeformMessageText
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformMessageText { get; set; }
Public Property FreeformMessageText As String
    Get
    Set
public:
property String^ FreeformMessageText {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► IndustryCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SurfaceLayerPositionCode1 Property

SurfaceLayerPositionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► SurfaceLayerPositionCode1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode1 { get; set; }
Public Property SurfaceLayerPositionCode1 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SurfaceLayerPositionCode2 Property

SurfaceLayerPositionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► SurfaceLayerPositionCode2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode2 { get; set; }
Public Property SurfaceLayerPositionCode2 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SurfaceLayerPositionCode3 Property

SurfaceLayerPositionCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► SurfaceLayerPositionCode3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode3 { get; set; }
Public Property SurfaceLayerPositionCode3 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► III ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IK3 Class

IK3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3
RDPCrystal EDI Library
Error Identification
Declaration Syntax
C# Visual Basic Visual C++
public class IK3 : DocumentSegment
Public Class IK3 _
    Inherits DocumentSegment
public ref class IK3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IK3()()()() | Initializes a new instance of the IK3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationSegmentSyntaxErrorCode | Element 4
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SegmentIDCode | Element 1
 | SegmentPositionInTransactionSet | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IK3

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IK3 Constructor

IK3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► IK3()()()()
RDPCrystal EDI Library
Initializes a new instance of the IK3 class
Declaration Syntax
C# Visual Basic Visual C++
public IK3()
Public Sub New
public:
IK3()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationSegmentSyntaxErrorCode Property

ImplementationSegmentSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► ImplementationSegmentSyntaxErrorCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationSegmentSyntaxErrorCode { get; set; }
Public Property ImplementationSegmentSyntaxErrorCode As String
    Get
    Set
public:
property String^ ImplementationSegmentSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► LoopIdentifierCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► SegmentIDCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SegmentPositionInTransactionSet Property

SegmentPositionInTransactionSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► SegmentPositionInTransactionSet
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentPositionInTransactionSet { get; set; }
Public Property SegmentPositionInTransactionSet As String
    Get
    Set
public:
property String^ SegmentPositionInTransactionSet {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IK4 Class

IK4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4
RDPCrystal EDI Library
Implementation Data Element Note
Declaration Syntax
C# Visual Basic Visual C++
public class IK4 : DocumentSegment
Public Class IK4 _
    Inherits DocumentSegment
public ref class IK4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IK4()()()() | Initializes a new instance of the IK4 class
 | CopyOfBadDataElement | Element 4
 | DataElementReferenceNumber | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationDataElementSyntaxErrorCode | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IK4

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IK4 Constructor

IK4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► IK4()()()()
RDPCrystal EDI Library
Initializes a new instance of the IK4 class
Declaration Syntax
C# Visual Basic Visual C++
public IK4()
Public Sub New
public:
IK4()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CopyOfBadDataElement Property

CopyOfBadDataElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► CopyOfBadDataElement
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CopyOfBadDataElement { get; set; }
Public Property CopyOfBadDataElement As String
    Get
    Set
public:
property String^ CopyOfBadDataElement {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► DataElementReferenceNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationDataElementSyntaxErrorCode Property

ImplementationDataElementSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► ImplementationDataElementSyntaxErrorCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationDataElementSyntaxErrorCode { get; set; }
Public Property ImplementationDataElementSyntaxErrorCode As String
    Get
    Set
public:
property String^ ImplementationDataElementSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► PositionInSegment
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment PositionInSegment { get; set; }
Public Property PositionInSegment As PositionInSegment
    Get
    Set
public:
property PositionInSegment^ PositionInSegment {
    PositionInSegment^ get ();
    void set (PositionInSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IK5 Class

IK5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5
RDPCrystal EDI Library
Transaction Set Response Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class IK5 : DocumentSegment
Public Class IK5 _
    Inherits DocumentSegment
public ref class IK5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IK5()()()() | Initializes a new instance of the IK5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationTransactionSetSyntaxErrorCode1 | Element 2
 | ImplementationTransactionSetSyntaxErrorCode2 | Element 3
 | ImplementationTransactionSetSyntaxErrorCode3 | Element 4
 | ImplementationTransactionSetSyntaxErrorCode4 | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetAcknowledgmentCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IK5

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IK5 Constructor

IK5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► IK5()()()()
RDPCrystal EDI Library
Initializes a new instance of the IK5 class
Declaration Syntax
C# Visual Basic Visual C++
public IK5()
Public Sub New
public:
IK5()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationTransactionSetSyntaxErrorCode1 Property

ImplementationTransactionSetSyntaxErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► ImplementationTransactionSetSyntaxErrorCode1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode1 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode1 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationTransactionSetSyntaxErrorCode2 Property

ImplementationTransactionSetSyntaxErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► ImplementationTransactionSetSyntaxErrorCode2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode2 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode2 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationTransactionSetSyntaxErrorCode3 Property

ImplementationTransactionSetSyntaxErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► ImplementationTransactionSetSyntaxErrorCode3
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode3 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode3 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationTransactionSetSyntaxErrorCode4 Property

ImplementationTransactionSetSyntaxErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► ImplementationTransactionSetSyntaxErrorCode4
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode4 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode4 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetAcknowledgmentCode Property

TransactionSetAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► TransactionSetAcknowledgmentCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetAcknowledgmentCode { get; set; }
Public Property TransactionSetAcknowledgmentCode As String
    Get
    Set
public:
property String^ TransactionSetAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► IK5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


INS Class

INS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS
RDPCrystal EDI Library
Insured Benefit
Declaration Syntax
C# Visual Basic Visual C++
public class INS : DocumentSegment
Public Class INS _
    Inherits DocumentSegment
public ref class INS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INS()()()() | Initializes a new instance of the INS class
 | BenefitStatusCode | Element 5
 | CityName | Element 14
 | ConfidentialityCode | Element 13
 | ConsolidatedOmnibusBudgetReconciliationAct | Element 7
 | CountryCode | Element 16
 | DateTimePeriod | Element 12
 | DateTimePeriodFormatQualifier | Element 11
 | EmploymentStatusCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 4
 | MaintenanceTypeCode | Element 3
 | MedicareStatusCode | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 17
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode | Element 15
 | StudentStatusCode | Element 9
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 1
 | YesNoConditionOrResponseCode2 | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


INS Constructor

INS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► INS()()()()
RDPCrystal EDI Library
Initializes a new instance of the INS class
Declaration Syntax
C# Visual Basic Visual C++
public INS()
Public Sub New
public:
INS()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


BenefitStatusCode Property

BenefitStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► BenefitStatusCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string BenefitStatusCode { get; set; }
Public Property BenefitStatusCode As String
    Get
    Set
public:
property String^ BenefitStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► CityName
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConfidentialityCode Property

ConfidentialityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► ConfidentialityCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ConfidentialityCode { get; set; }
Public Property ConfidentialityCode As String
    Get
    Set
public:
property String^ ConfidentialityCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ConsolidatedOmnibusBudgetReconciliationAct Property

ConsolidatedOmnibusBudgetReconciliationAct Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► ConsolidatedOmnibusBudgetReconciliationAct
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ConsolidatedOmnibusBudgetReconciliationAct { get; set; }
Public Property ConsolidatedOmnibusBudgetReconciliationAct As String
    Get
    Set
public:
property String^ ConsolidatedOmnibusBudgetReconciliationAct {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► CountryCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► DateTimePeriod
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► EmploymentStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► MaintenanceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MedicareStatusCode Property

MedicareStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► MedicareStatusCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public MedicareStatusCode MedicareStatusCode { get; set; }
Public Property MedicareStatusCode As MedicareStatusCode
    Get
    Set
public:
property MedicareStatusCode^ MedicareStatusCode {
    MedicareStatusCode^ get ();
    void set (MedicareStatusCode^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► Number
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► StateOrProvinceCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StudentStatusCode Property

StudentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► StudentStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string StudentStatusCode { get; set; }
Public Property StudentStatusCode As String
    Get
    Set
public:
property String^ StudentStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► INS ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ISA Class

ISA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA
RDPCrystal EDI Library
Interchange Control Header
Declaration Syntax
C# Visual Basic Visual C++
public class ISA : DocumentSegment
Public Class ISA _
    Inherits DocumentSegment
public ref class ISA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISA()()()() | Initializes a new instance of the ISA class
 | AcknowledgmentRequested | Element 14
 | AuthorizationInformation | Element 2
 | AuthorizationInformationQualifier | Element 1
 | ComponentElementSeparator | Element 16
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeControlNumber | Element 13
 | InterchangeControlVersionNumber | Element 12
 | InterchangeDate | Element 9
 | InterchangeIDQualifier1 | Element 5
 | InterchangeIDQualifier2 | Element 7
 | InterchangeReceiverID | Element 8
 | InterchangeSenderID | Element 6
 | InterchangeTime | Element 10
 | InterchangeUsageIndicator | Element 15
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RepetitionSeparator | Element 11
 | SecurityInformation | Element 4
 | SecurityInformationQualifier | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ISA Constructor

ISA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► ISA()()()()
RDPCrystal EDI Library
Initializes a new instance of the ISA class
Declaration Syntax
C# Visual Basic Visual C++
public ISA()
Public Sub New
public:
ISA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AcknowledgmentRequested Property

AcknowledgmentRequested Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► AcknowledgmentRequested
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentRequested { get; set; }
Public Property AcknowledgmentRequested As String
    Get
    Set
public:
property String^ AcknowledgmentRequested {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AuthorizationInformation Property

AuthorizationInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► AuthorizationInformation
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationInformation { get; set; }
Public Property AuthorizationInformation As String
    Get
    Set
public:
property String^ AuthorizationInformation {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AuthorizationInformationQualifier Property

AuthorizationInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► AuthorizationInformationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationInformationQualifier { get; set; }
Public Property AuthorizationInformationQualifier As String
    Get
    Set
public:
property String^ AuthorizationInformationQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ComponentElementSeparator Property

ComponentElementSeparator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► ComponentElementSeparator
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentElementSeparator { get; set; }
Public Property ComponentElementSeparator As String
    Get
    Set
public:
property String^ ComponentElementSeparator {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeControlNumber
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeControlVersionNumber Property

InterchangeControlVersionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeControlVersionNumber
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlVersionNumber { get; set; }
Public Property InterchangeControlVersionNumber As String
    Get
    Set
public:
property String^ InterchangeControlVersionNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeDate Property

InterchangeDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeDate
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeDate { get; set; }
Public Property InterchangeDate As String
    Get
    Set
public:
property String^ InterchangeDate {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeIDQualifier1 Property

InterchangeIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeIDQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeIDQualifier1 { get; set; }
Public Property InterchangeIDQualifier1 As String
    Get
    Set
public:
property String^ InterchangeIDQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeIDQualifier2 Property

InterchangeIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeIDQualifier2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeIDQualifier2 { get; set; }
Public Property InterchangeIDQualifier2 As String
    Get
    Set
public:
property String^ InterchangeIDQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeReceiverID Property

InterchangeReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeReceiverID
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverID { get; set; }
Public Property InterchangeReceiverID As String
    Get
    Set
public:
property String^ InterchangeReceiverID {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeSenderID Property

InterchangeSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeSenderID
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderID { get; set; }
Public Property InterchangeSenderID As String
    Get
    Set
public:
property String^ InterchangeSenderID {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeTime Property

InterchangeTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeTime
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTime { get; set; }
Public Property InterchangeTime As String
    Get
    Set
public:
property String^ InterchangeTime {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InterchangeUsageIndicator Property

InterchangeUsageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► InterchangeUsageIndicator
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeUsageIndicator { get; set; }
Public Property InterchangeUsageIndicator As String
    Get
    Set
public:
property String^ InterchangeUsageIndicator {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RepetitionSeparator Property

RepetitionSeparator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► RepetitionSeparator
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string RepetitionSeparator { get; set; }
Public Property RepetitionSeparator As String
    Get
    Set
public:
property String^ RepetitionSeparator {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SecurityInformation Property

SecurityInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► SecurityInformation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityInformation { get; set; }
Public Property SecurityInformation As String
    Get
    Set
public:
property String^ SecurityInformation {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SecurityInformationQualifier Property

SecurityInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► SecurityInformationQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityInformationQualifier { get; set; }
Public Property SecurityInformationQualifier As String
    Get
    Set
public:
property String^ SecurityInformationQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ISA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


K3 Class

K3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► K3
RDPCrystal EDI Library
File Information
Declaration Syntax
C# Visual Basic Visual C++
public class K3 : DocumentSegment
Public Class K3 _
    Inherits DocumentSegment
public ref class K3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | K3()()()() | Initializes a new instance of the K3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixedFormatInformation | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RecordFormatCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | K3

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


K3 Constructor

K3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► K3 ► K3()()()()
RDPCrystal EDI Library
Initializes a new instance of the K3 class
Declaration Syntax
C# Visual Basic Visual C++
public K3()
Public Sub New
public:
K3()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FixedFormatInformation Property

FixedFormatInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► K3 ► FixedFormatInformation
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation { get; set; }
Public Property FixedFormatInformation As String
    Get
    Set
public:
property String^ FixedFormatInformation {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► K3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RecordFormatCode Property

RecordFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► K3 ► RecordFormatCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RecordFormatCode { get; set; }
Public Property RecordFormatCode As String
    Get
    Set
public:
property String^ RecordFormatCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► K3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LE Class

LE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LE
RDPCrystal EDI Library
Loop Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class LE : DocumentSegment
Public Class LE _
    Inherits DocumentSegment
public ref class LE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LE()()()() | Initializes a new instance of the LE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LE Constructor

LE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LE ► LE()()()()
RDPCrystal EDI Library
Initializes a new instance of the LE class
Declaration Syntax
C# Visual Basic Visual C++
public LE()
Public Sub New
public:
LE()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LE ► LoopIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LIN Class

LIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN
RDPCrystal EDI Library
Item Identification
Declaration Syntax
C# Visual Basic Visual C++
public class LIN : DocumentSegment
Public Class LIN _
    Inherits DocumentSegment
public ref class LIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LIN()()()() | Initializes a new instance of the LIN class
 | AssignedIdentification | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID1 | Element 3
 | ProductServiceID10 | Element 21
 | ProductServiceID11 | Element 23
 | ProductServiceID12 | Element 25
 | ProductServiceID13 | Element 27
 | ProductServiceID14 | Element 29
 | ProductServiceID15 | Element 31
 | ProductServiceID2 | Element 5
 | ProductServiceID3 | Element 7
 | ProductServiceID4 | Element 9
 | ProductServiceID5 | Element 11
 | ProductServiceID6 | Element 13
 | ProductServiceID7 | Element 15
 | ProductServiceID8 | Element 17
 | ProductServiceID9 | Element 19
 | ProductServiceIDQualifier1 | Element 2
 | ProductServiceIDQualifier10 | Element 20
 | ProductServiceIDQualifier11 | Element 22
 | ProductServiceIDQualifier12 | Element 24
 | ProductServiceIDQualifier13 | Element 26
 | ProductServiceIDQualifier14 | Element 28
 | ProductServiceIDQualifier15 | Element 30
 | ProductServiceIDQualifier2 | Element 4
 | ProductServiceIDQualifier3 | Element 6
 | ProductServiceIDQualifier4 | Element 8
 | ProductServiceIDQualifier5 | Element 10
 | ProductServiceIDQualifier6 | Element 12
 | ProductServiceIDQualifier7 | Element 14
 | ProductServiceIDQualifier8 | Element 16
 | ProductServiceIDQualifier9 | Element 18
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LIN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LIN Constructor

LIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► LIN()()()()
RDPCrystal EDI Library
Initializes a new instance of the LIN class
Declaration Syntax
C# Visual Basic Visual C++
public LIN()
Public Sub New
public:
LIN()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► AssignedIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID10 Property

ProductServiceID10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID10
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID10 { get; set; }
Public Property ProductServiceID10 As String
    Get
    Set
public:
property String^ ProductServiceID10 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID11 Property

ProductServiceID11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID11
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID11 { get; set; }
Public Property ProductServiceID11 As String
    Get
    Set
public:
property String^ ProductServiceID11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID12 Property

ProductServiceID12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID12
RDPCrystal EDI Library
Element 25
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID12 { get; set; }
Public Property ProductServiceID12 As String
    Get
    Set
public:
property String^ ProductServiceID12 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID13 Property

ProductServiceID13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID13
RDPCrystal EDI Library
Element 27
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID13 { get; set; }
Public Property ProductServiceID13 As String
    Get
    Set
public:
property String^ ProductServiceID13 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID14 Property

ProductServiceID14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID14
RDPCrystal EDI Library
Element 29
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID14 { get; set; }
Public Property ProductServiceID14 As String
    Get
    Set
public:
property String^ ProductServiceID14 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID15 Property

ProductServiceID15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID15
RDPCrystal EDI Library
Element 31
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID15 { get; set; }
Public Property ProductServiceID15 As String
    Get
    Set
public:
property String^ ProductServiceID15 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID5
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID6
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID7
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID8
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceID9
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier10 Property

ProductServiceIDQualifier10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier10
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier10 { get; set; }
Public Property ProductServiceIDQualifier10 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier10 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier11 Property

ProductServiceIDQualifier11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier11
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier11 { get; set; }
Public Property ProductServiceIDQualifier11 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier12 Property

ProductServiceIDQualifier12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier12
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier12 { get; set; }
Public Property ProductServiceIDQualifier12 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier12 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier13 Property

ProductServiceIDQualifier13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier13
RDPCrystal EDI Library
Element 26
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier13 { get; set; }
Public Property ProductServiceIDQualifier13 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier13 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier14 Property

ProductServiceIDQualifier14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier14
RDPCrystal EDI Library
Element 28
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier14 { get; set; }
Public Property ProductServiceIDQualifier14 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier14 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier15 Property

ProductServiceIDQualifier15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier15
RDPCrystal EDI Library
Element 30
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier15 { get; set; }
Public Property ProductServiceIDQualifier15 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier15 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier4
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier5
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier6
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier7
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier8
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► ProductServiceIDQualifier9
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LIN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LQ Class

LQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LQ
RDPCrystal EDI Library
Industry Code
Declaration Syntax
C# Visual Basic Visual C++
public class LQ : DocumentSegment
Public Class LQ _
    Inherits DocumentSegment
public ref class LQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LQ()()()() | Initializes a new instance of the LQ class
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode | Element2
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LQ

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LQ Constructor

LQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LQ ► LQ()()()()
RDPCrystal EDI Library
Initializes a new instance of the LQ class
Declaration Syntax
C# Visual Basic Visual C++
public LQ()
Public Sub New
public:
LQ()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LQ ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LQ ► IndustryCode
RDPCrystal EDI Library
Element2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LQ ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LQ ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LS Class

LS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LS
RDPCrystal EDI Library
Loop Header
Declaration Syntax
C# Visual Basic Visual C++
public class LS : DocumentSegment
Public Class LS _
    Inherits DocumentSegment
public ref class LS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LS()()()() | Initializes a new instance of the LS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode | Element 1
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LS Constructor

LS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LS ► LS()()()()
RDPCrystal EDI Library
Initializes a new instance of the LS class
Declaration Syntax
C# Visual Basic Visual C++
public LS()
Public Sub New
public:
LS()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LS ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LS ► LoopIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LS ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LUI Class

LUI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI
RDPCrystal EDI Library
Language Use
Declaration Syntax
C# Visual Basic Visual C++
public class LUI : DocumentSegment
Public Class LUI _
    Inherits DocumentSegment
public ref class LUI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LUI()()()() | Initializes a new instance of the LUI class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 2
 | IdentificationCodeQualifier | Element 1
 | LanguageProficiencyIndicator | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UseOfLanguageIndicator | Element 4
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LUI

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LUI Constructor

LUI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► LUI()()()()
RDPCrystal EDI Library
Initializes a new instance of the LUI class
Declaration Syntax
C# Visual Basic Visual C++
public LUI()
Public Sub New
public:
LUI()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► IdentificationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LanguageProficiencyIndicator Property

LanguageProficiencyIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► LanguageProficiencyIndicator
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageProficiencyIndicator { get; set; }
Public Property LanguageProficiencyIndicator As String
    Get
    Set
public:
property String^ LanguageProficiencyIndicator {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UseOfLanguageIndicator Property

UseOfLanguageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► UseOfLanguageIndicator
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UseOfLanguageIndicator { get; set; }
Public Property UseOfLanguageIndicator As String
    Get
    Set
public:
property String^ UseOfLanguageIndicator {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LUI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LX Class

LX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LX
RDPCrystal EDI Library
Assigned Number
Declaration Syntax
C# Visual Basic Visual C++
public class LX : DocumentSegment
Public Class LX _
    Inherits DocumentSegment
public ref class LX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LX()()()() | Initializes a new instance of the LX class
 | AssignedNumber | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LX

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LX Constructor

LX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LX ► LX()()()()
RDPCrystal EDI Library
Initializes a new instance of the LX class
Declaration Syntax
C# Visual Basic Visual C++
public LX()
Public Sub New
public:
LX()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LX ► AssignedNumber
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LX ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► LX ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MEA Class

MEA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA
RDPCrystal EDI Library
Measurements
Declaration Syntax
C# Visual Basic Visual C++
public class MEA : DocumentSegment
Public Class MEA _
    Inherits DocumentSegment
public ref class MEA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MEA()()()() | Initializes a new instance of the MEA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementQualifier | Element 2
 | MeasurementReferenceIDCode | Element 1
 | MeasurementValue | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MEA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MEA Constructor

MEA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA ► MEA()()()()
RDPCrystal EDI Library
Initializes a new instance of the MEA class
Declaration Syntax
C# Visual Basic Visual C++
public MEA()
Public Sub New
public:
MEA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MeasurementQualifier Property

MeasurementQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA ► MeasurementQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementQualifier { get; set; }
Public Property MeasurementQualifier As String
    Get
    Set
public:
property String^ MeasurementQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MeasurementReferenceIDCode Property

MeasurementReferenceIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA ► MeasurementReferenceIDCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementReferenceIDCode { get; set; }
Public Property MeasurementReferenceIDCode As String
    Get
    Set
public:
property String^ MeasurementReferenceIDCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA ► MeasurementValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MEA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MedicareStatusCode Class

MedicareStatusCode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode
RDPCrystal EDI Library
C052
Declaration Syntax
C# Visual Basic Visual C++
public class MedicareStatusCode : DocumentCompositeElement
Public Class MedicareStatusCode _
    Inherits DocumentCompositeElement
public ref class MedicareStatusCode : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MedicareStatusCode()()()() | Initializes a new instance of the MedicareStatusCode class
 | EligibilityReasonCode1 |
 | EligibilityReasonCode2 |
 | EligibilityReasonCode3 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MedicarePlanCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | MedicareStatusCode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MedicareStatusCode Constructor

MedicareStatusCode Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode ► MedicareStatusCode()()()()
RDPCrystal EDI Library
Initializes a new instance of the MedicareStatusCode class
Declaration Syntax
C# Visual Basic Visual C++
public MedicareStatusCode()
Public Sub New
public:
MedicareStatusCode()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EligibilityReasonCode1 Property

EligibilityReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode ► EligibilityReasonCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityReasonCode1 { get; set; }
Public Property EligibilityReasonCode1 As String
    Get
    Set
public:
property String^ EligibilityReasonCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EligibilityReasonCode2 Property

EligibilityReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode ► EligibilityReasonCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityReasonCode2 { get; set; }
Public Property EligibilityReasonCode2 As String
    Get
    Set
public:
property String^ EligibilityReasonCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EligibilityReasonCode3 Property

EligibilityReasonCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode ► EligibilityReasonCode3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityReasonCode3 { get; set; }
Public Property EligibilityReasonCode3 As String
    Get
    Set
public:
property String^ EligibilityReasonCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MedicarePlanCode Property

MedicarePlanCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MedicareStatusCode ► MedicarePlanCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string MedicarePlanCode { get; set; }
Public Property MedicarePlanCode As String
    Get
    Set
public:
property String^ MedicarePlanCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MIA Class

MIA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA
RDPCrystal EDI Library
Medicare Inpatient Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class MIA : DocumentSegment
Public Class MIA _
    Inherits DocumentSegment
public ref class MIA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIA()()()() | Initializes a new instance of the MIA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 2
 | MonetaryAmount10 | Element 13
 | MonetaryAmount11 | Element 14
 | MonetaryAmount12 | Element 16
 | MonetaryAmount13 | Element 17
 | MonetaryAmount14 | Element 18
 | MonetaryAmount15 | Element 19
 | MonetaryAmount16 | Element 24
 | MonetaryAmount2 | Element 4
 | MonetaryAmount3 | Element 6
 | MonetaryAmount4 | Element 7
 | MonetaryAmount5 | Element 8
 | MonetaryAmount6 | Element 9
 | MonetaryAmount7 | Element 10
 | MonetaryAmount8 | Element 11
 | MonetaryAmount9 | Element 12
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 1
 | Quantity2 | Element 3
 | Quantity3 | Element 15
 | ReferenceIdentification1 | Element 5
 | ReferenceIdentification2 | Element 20
 | ReferenceIdentification3 | Element 21
 | ReferenceIdentification4 | Element 22
 | ReferenceIdentification5 | Element 23
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MIA Constructor

MIA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MIA()()()()
RDPCrystal EDI Library
Initializes a new instance of the MIA class
Declaration Syntax
C# Visual Basic Visual C++
public MIA()
Public Sub New
public:
MIA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount10
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount11
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount12
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount13 Property

MonetaryAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount13
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount13 { get; set; }
Public Property MonetaryAmount13 As String
    Get
    Set
public:
property String^ MonetaryAmount13 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount14 Property

MonetaryAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount14
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount14 { get; set; }
Public Property MonetaryAmount14 As String
    Get
    Set
public:
property String^ MonetaryAmount14 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount15 Property

MonetaryAmount15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount15
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount15 { get; set; }
Public Property MonetaryAmount15 As String
    Get
    Set
public:
property String^ MonetaryAmount15 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount16 Property

MonetaryAmount16 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount16
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount16 { get; set; }
Public Property MonetaryAmount16 As String
    Get
    Set
public:
property String^ MonetaryAmount16 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount3
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount4
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount5
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount6
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount7
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount8
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► MonetaryAmount9
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► Quantity1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► Quantity2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► Quantity3
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► ReferenceIdentification2
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► ReferenceIdentification3
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► ReferenceIdentification4
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification5 Property

ReferenceIdentification5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► ReferenceIdentification5
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification5 { get; set; }
Public Property ReferenceIdentification5 As String
    Get
    Set
public:
property String^ ReferenceIdentification5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MIA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MOA Class

MOA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA
RDPCrystal EDI Library
Medicare Outpatient Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class MOA : DocumentSegment
Public Class MOA _
    Inherits DocumentSegment
public ref class MOA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MOA()()()() | Initializes a new instance of the MOA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 2
 | MonetaryAmount2 | Element 8
 | MonetaryAmount3 | Element 9
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percentage | Element 1
 | ReferenceIdentification1 | Element 3
 | ReferenceIdentification2 | Element 4
 | ReferenceIdentification3 | Element 5
 | ReferenceIdentification4 | Element 6
 | ReferenceIdentification5 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MOA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MOA Constructor

MOA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► MOA()()()()
RDPCrystal EDI Library
Initializes a new instance of the MOA class
Declaration Syntax
C# Visual Basic Visual C++
public MOA()
Public Sub New
public:
MOA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► MonetaryAmount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► MonetaryAmount2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► MonetaryAmount3
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► Percentage
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► ReferenceIdentification1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► ReferenceIdentification2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► ReferenceIdentification3
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► ReferenceIdentification4
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification5 Property

ReferenceIdentification5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► ReferenceIdentification5
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification5 { get; set; }
Public Property ReferenceIdentification5 As String
    Get
    Set
public:
property String^ ReferenceIdentification5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MOA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MPI Class

MPI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI
RDPCrystal EDI Library
Military Personnel Information
Declaration Syntax
C# Visual Basic Visual C++
public class MPI : DocumentSegment
Public Class MPI _
    Inherits DocumentSegment
public ref class MPI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MPI()()()() | Initializes a new instance of the MPI class
 | DateTimePeriod | Element 7
 | DateTimePeriodFormatQualifier | Element 6
 | Description | Element 4
 | EmploymentStatusCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GovernmentServiceAffiliationCode | Element 3
 | InformationStatusCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MilitaryServiceRankCode | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MPI

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MPI Constructor

MPI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► MPI()()()()
RDPCrystal EDI Library
Initializes a new instance of the MPI class
Declaration Syntax
C# Visual Basic Visual C++
public MPI()
Public Sub New
public:
MPI()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► DateTimePeriod
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► Description
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► EmploymentStatusCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GovernmentServiceAffiliationCode Property

GovernmentServiceAffiliationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► GovernmentServiceAffiliationCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string GovernmentServiceAffiliationCode { get; set; }
Public Property GovernmentServiceAffiliationCode As String
    Get
    Set
public:
property String^ GovernmentServiceAffiliationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► InformationStatusCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MilitaryServiceRankCode Property

MilitaryServiceRankCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► MilitaryServiceRankCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MilitaryServiceRankCode { get; set; }
Public Property MilitaryServiceRankCode As String
    Get
    Set
public:
property String^ MilitaryServiceRankCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MPI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MSG Class

MSG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG
RDPCrystal EDI Library
Message Text
Declaration Syntax
C# Visual Basic Visual C++
public class MSG : DocumentSegment
Public Class MSG _
    Inherits DocumentSegment
public ref class MSG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MSG()()()() | Initializes a new instance of the MSG class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformMessageText | Element 1
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrinterCarriageControlCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MSG

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MSG Constructor

MSG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG ► MSG()()()()
RDPCrystal EDI Library
Initializes a new instance of the MSG class
Declaration Syntax
C# Visual Basic Visual C++
public MSG()
Public Sub New
public:
MSG()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FreeformMessageText Property

FreeformMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG ► FreeformMessageText
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformMessageText { get; set; }
Public Property FreeformMessageText As String
    Get
    Set
public:
property String^ FreeformMessageText {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG ► Number
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PrinterCarriageControlCode Property

PrinterCarriageControlCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG ► PrinterCarriageControlCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PrinterCarriageControlCode { get; set; }
Public Property PrinterCarriageControlCode As String
    Get
    Set
public:
property String^ PrinterCarriageControlCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► MSG ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


N1 Class

N1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1
RDPCrystal EDI Library
Name
Declaration Syntax
C# Visual Basic Visual C++
public class N1 : DocumentSegment
Public Class N1 _
    Inherits DocumentSegment
public ref class N1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N1()()()() | Initializes a new instance of the N1 class
 | EntityIdentifierCode1 | Element 1
 | EntityIdentifierCode2 | Element 6
 | EntityRelationshipCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 4
 | IdentificationCodeQualifier | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


N1 Constructor

N1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► N1()()()()
RDPCrystal EDI Library
Initializes a new instance of the N1 class
Declaration Syntax
C# Visual Basic Visual C++
public N1()
Public Sub New
public:
N1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► EntityIdentifierCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode2 Property

EntityIdentifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► EntityIdentifierCode2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode2 { get; set; }
Public Property EntityIdentifierCode2 As String
    Get
    Set
public:
property String^ EntityIdentifierCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► EntityRelationshipCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► IdentificationCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


N3 Class

N3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N3
RDPCrystal EDI Library
Address Information
Declaration Syntax
C# Visual Basic Visual C++
public class N3 : DocumentSegment
Public Class N3 _
    Inherits DocumentSegment
public ref class N3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N3()()()() | Initializes a new instance of the N3 class
 | AddressInformation1 | Element 1
 | AddressInformation2 | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N3

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


N3 Constructor

N3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N3 ► N3()()()()
RDPCrystal EDI Library
Initializes a new instance of the N3 class
Declaration Syntax
C# Visual Basic Visual C++
public N3()
Public Sub New
public:
N3()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AddressInformation1 Property

AddressInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N3 ► AddressInformation1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation1 { get; set; }
Public Property AddressInformation1 As String
    Get
    Set
public:
property String^ AddressInformation1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AddressInformation2 Property

AddressInformation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N3 ► AddressInformation2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation2 { get; set; }
Public Property AddressInformation2 As String
    Get
    Set
public:
property String^ AddressInformation2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


N4 Class

N4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4
RDPCrystal EDI Library
Geographic Location
Declaration Syntax
C# Visual Basic Visual C++
public class N4 : DocumentSegment
Public Class N4 _
    Inherits DocumentSegment
public ref class N4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N4()()()() | Initializes a new instance of the N4 class
 | CityName | Element 1
 | CountryCode | Element 4
 | CountrySubdivisionCode | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationQualifier1 | Element 5
 | LocationQualifier2 | Element 6
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 3
 | StateOrProvinceCode | Element 2
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N4

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


N4 Constructor

N4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► N4()()()()
RDPCrystal EDI Library
Initializes a new instance of the N4 class
Declaration Syntax
C# Visual Basic Visual C++
public N4()
Public Sub New
public:
N4()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► CityName
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► CountryCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CountrySubdivisionCode Property

CountrySubdivisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► CountrySubdivisionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CountrySubdivisionCode { get; set; }
Public Property CountrySubdivisionCode As String
    Get
    Set
public:
property String^ CountrySubdivisionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LocationQualifier1 Property

LocationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► LocationQualifier1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier1 { get; set; }
Public Property LocationQualifier1 As String
    Get
    Set
public:
property String^ LocationQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LocationQualifier2 Property

LocationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► LocationQualifier2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier2 { get; set; }
Public Property LocationQualifier2 As String
    Get
    Set
public:
property String^ LocationQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► PostalCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► N4 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NM1 Class

NM1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1
RDPCrystal EDI Library
Individual or Organizational Name
Declaration Syntax
C# Visual Basic Visual C++
public class NM1 : DocumentSegment
Public Class NM1 _
    Inherits DocumentSegment
public ref class NM1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NM1()()()() | Initializes a new instance of the NM1 class
 | EntityIdentifierCode | Element 1
 | EntityIdentifierCode2 | Element 11
 | EntityRelationshipCode | Element 10
 | EntityTypeQualifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstName | Element 4
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 9
 | IdentificationCodeQualifier | Element 8
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MiddleName | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameLastOrOrganizationName | Element 3
 | NameLastOrOrganizationName2 | Element 12
 | NamePrefix | Element 6
 | NameSuffix | Element 7
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NM1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NM1 Constructor

NM1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► NM1()()()()
RDPCrystal EDI Library
Initializes a new instance of the NM1 class
Declaration Syntax
C# Visual Basic Visual C++
public NM1()
Public Sub New
public:
NM1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► EntityIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode2 Property

EntityIdentifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► EntityIdentifierCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode2 { get; set; }
Public Property EntityIdentifierCode2 As String
    Get
    Set
public:
property String^ EntityIdentifierCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► EntityRelationshipCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityTypeQualifier Property

EntityTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► EntityTypeQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTypeQualifier { get; set; }
Public Property EntityTypeQualifier As String
    Get
    Set
public:
property String^ EntityTypeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FirstName Property

FirstName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► FirstName
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► IdentificationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MiddleName Property

MiddleName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► MiddleName
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MiddleName { get; set; }
Public Property MiddleName As String
    Get
    Set
public:
property String^ MiddleName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NameLastOrOrganizationName Property

NameLastOrOrganizationName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► NameLastOrOrganizationName
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string NameLastOrOrganizationName { get; set; }
Public Property NameLastOrOrganizationName As String
    Get
    Set
public:
property String^ NameLastOrOrganizationName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NameLastOrOrganizationName2 Property

NameLastOrOrganizationName2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► NameLastOrOrganizationName2
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string NameLastOrOrganizationName2 { get; set; }
Public Property NameLastOrOrganizationName2 As String
    Get
    Set
public:
property String^ NameLastOrOrganizationName2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NamePrefix Property

NamePrefix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► NamePrefix
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string NamePrefix { get; set; }
Public Property NamePrefix As String
    Get
    Set
public:
property String^ NamePrefix {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NameSuffix Property

NameSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► NameSuffix
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string NameSuffix { get; set; }
Public Property NameSuffix As String
    Get
    Set
public:
property String^ NameSuffix {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NM1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NTE Class

NTE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NTE
RDPCrystal EDI Library
Note/Special Instruction
Declaration Syntax
C# Visual Basic Visual C++
public class NTE : DocumentSegment
Public Class NTE _
    Inherits DocumentSegment
public ref class NTE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NTE()()()() | Initializes a new instance of the NTE class
 | Description | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteReferenceCode | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NTE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NTE Constructor

NTE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NTE ► NTE()()()()
RDPCrystal EDI Library
Initializes a new instance of the NTE class
Declaration Syntax
C# Visual Basic Visual C++
public NTE()
Public Sub New
public:
NTE()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NTE ► Description
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NTE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NoteReferenceCode Property

NoteReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NTE ► NoteReferenceCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NoteReferenceCode { get; set; }
Public Property NoteReferenceCode As String
    Get
    Set
public:
property String^ NoteReferenceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► NTE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OI Class

OI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI
RDPCrystal EDI Library
Other Health Insurance Information
Declaration Syntax
C# Visual Basic Visual C++
public class OI : DocumentSegment
Public Class OI _
    Inherits DocumentSegment
public ref class OI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OI()()()() | Initializes a new instance of the OI class
 | ClaimFilingIndicatorCode | Element 1
 | ClaimSubmissionReasonCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientSignatureSourceCode | Element 4
 | ProviderAgreementCode | Element 5
 | ReleaseOfInformationCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 3
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OI

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OI Constructor

OI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► OI()()()()
RDPCrystal EDI Library
Initializes a new instance of the OI class
Declaration Syntax
C# Visual Basic Visual C++
public OI()
Public Sub New
public:
OI()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimSubmissionReasonCode Property

ClaimSubmissionReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► ClaimSubmissionReasonCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmissionReasonCode { get; set; }
Public Property ClaimSubmissionReasonCode As String
    Get
    Set
public:
property String^ ClaimSubmissionReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PatientSignatureSourceCode Property

PatientSignatureSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► PatientSignatureSourceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string PatientSignatureSourceCode { get; set; }
Public Property PatientSignatureSourceCode As String
    Get
    Set
public:
property String^ PatientSignatureSourceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► ProviderAgreementCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► ReleaseOfInformationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OI ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesign Class

OralCavityDesign Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign
RDPCrystal EDI Library
C006
Declaration Syntax
C# Visual Basic Visual C++
public class OralCavityDesign : DocumentCompositeElement
Public Class OralCavityDesign _
    Inherits DocumentCompositeElement
public ref class OralCavityDesign : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OralCavityDesign()()()() | Initializes a new instance of the OralCavityDesign class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OralCavityDesignCode1 |
 | OralCavityDesignCode2 |
 | OralCavityDesignCode3 |
 | OralCavityDesignCode4 |
 | OralCavityDesignCode5 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | OralCavityDesign

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesign Constructor

OralCavityDesign Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► OralCavityDesign()()()()
RDPCrystal EDI Library
Initializes a new instance of the OralCavityDesign class
Declaration Syntax
C# Visual Basic Visual C++
public OralCavityDesign()
Public Sub New
public:
OralCavityDesign()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesignCode1 Property

OralCavityDesignCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► OralCavityDesignCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode1 { get; set; }
Public Property OralCavityDesignCode1 As String
    Get
    Set
public:
property String^ OralCavityDesignCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesignCode2 Property

OralCavityDesignCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► OralCavityDesignCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode2 { get; set; }
Public Property OralCavityDesignCode2 As String
    Get
    Set
public:
property String^ OralCavityDesignCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesignCode3 Property

OralCavityDesignCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► OralCavityDesignCode3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode3 { get; set; }
Public Property OralCavityDesignCode3 As String
    Get
    Set
public:
property String^ OralCavityDesignCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesignCode4 Property

OralCavityDesignCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► OralCavityDesignCode4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode4 { get; set; }
Public Property OralCavityDesignCode4 As String
    Get
    Set
public:
property String^ OralCavityDesignCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesignCode5 Property

OralCavityDesignCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► OralCavityDesign ► OralCavityDesignCode5
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode5 { get; set; }
Public Property OralCavityDesignCode5 As String
    Get
    Set
public:
property String^ OralCavityDesignCode5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PAT Class

PAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT
RDPCrystal EDI Library
Patient Information
Declaration Syntax
C# Visual Basic Visual C++
public class PAT : DocumentSegment
Public Class PAT _
    Inherits DocumentSegment
public ref class PAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAT()()()() | Initializes a new instance of the PAT class
 | DateTimePeriod | Element 6
 | DateTimePeriodFormatQualifier | Element 5
 | EmploymentStatusCode | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientLocationCode | Element 2
 | StudentStatusCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 7
 | Weight | Element 8
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 9
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PAT Constructor

PAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► PAT()()()()
RDPCrystal EDI Library
Initializes a new instance of the PAT class
Declaration Syntax
C# Visual Basic Visual C++
public PAT()
Public Sub New
public:
PAT()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► DateTimePeriod
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► DateTimePeriodFormatQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► EmploymentStatusCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PatientLocationCode Property

PatientLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► PatientLocationCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string PatientLocationCode { get; set; }
Public Property PatientLocationCode As String
    Get
    Set
public:
property String^ PatientLocationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StudentStatusCode Property

StudentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► StudentStatusCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StudentStatusCode { get; set; }
Public Property StudentStatusCode As String
    Get
    Set
public:
property String^ StudentStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► Weight
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PAT ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PER Class

PER Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER
RDPCrystal EDI Library
Administrative Communications Contact
Declaration Syntax
C# Visual Basic Visual C++
public class PER : DocumentSegment
Public Class PER _
    Inherits DocumentSegment
public ref class PER : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PER()()()() | Initializes a new instance of the PER class
 | CommunicationNumber1 | Element 4
 | CommunicationNumber2 | Element 6
 | CommunicationNumber3 | Element 8
 | CommunicationNumberQualifier1 | Element 3
 | CommunicationNumberQualifier2 | Element 5
 | CommunicationNumberQualifier3 | Element 7
 | ContactFunctionCode | Element 1
 | ContactInquiryReference | Element 9
 | ContactName | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PER

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PER Constructor

PER Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► PER()()()()
RDPCrystal EDI Library
Initializes a new instance of the PER class
Declaration Syntax
C# Visual Basic Visual C++
public PER()
Public Sub New
public:
PER()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumber1 Property

CommunicationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► CommunicationNumber1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber1 { get; set; }
Public Property CommunicationNumber1 As String
    Get
    Set
public:
property String^ CommunicationNumber1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumber2 Property

CommunicationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► CommunicationNumber2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber2 { get; set; }
Public Property CommunicationNumber2 As String
    Get
    Set
public:
property String^ CommunicationNumber2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumber3 Property

CommunicationNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► CommunicationNumber3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber3 { get; set; }
Public Property CommunicationNumber3 As String
    Get
    Set
public:
property String^ CommunicationNumber3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumberQualifier1 Property

CommunicationNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► CommunicationNumberQualifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier1 { get; set; }
Public Property CommunicationNumberQualifier1 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumberQualifier2 Property

CommunicationNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► CommunicationNumberQualifier2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier2 { get; set; }
Public Property CommunicationNumberQualifier2 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumberQualifier3 Property

CommunicationNumberQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► CommunicationNumberQualifier3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier3 { get; set; }
Public Property CommunicationNumberQualifier3 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContactFunctionCode Property

ContactFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► ContactFunctionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ContactFunctionCode { get; set; }
Public Property ContactFunctionCode As String
    Get
    Set
public:
property String^ ContactFunctionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContactInquiryReference Property

ContactInquiryReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► ContactInquiryReference
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ContactInquiryReference { get; set; }
Public Property ContactInquiryReference As String
    Get
    Set
public:
property String^ ContactInquiryReference {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ContactName Property

ContactName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► ContactName
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ContactName { get; set; }
Public Property ContactName As String
    Get
    Set
public:
property String^ ContactName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PER ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PLA Class

PLA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA
RDPCrystal EDI Library
Place or Location
Declaration Syntax
C# Visual Basic Visual C++
public class PLA : DocumentSegment
Public Class PLA _
    Inherits DocumentSegment
public ref class PLA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLA()()()() | Initializes a new instance of the PLA class
 | ActionCode | Element 1
 | Date | Element 3
 | EntityIdentifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode | Element 5
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PLA Constructor

PLA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► PLA()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLA class
Declaration Syntax
C# Visual Basic Visual C++
public PLA()
Public Sub New
public:
PLA()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► ActionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► EntityIdentifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► MaintenanceReasonCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► Time
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLA ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PLB Class

PLB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB
RDPCrystal EDI Library
Provider Level Adjustment
Declaration Syntax
C# Visual Basic Visual C++
public class PLB : DocumentSegment
Public Class PLB _
    Inherits DocumentSegment
public ref class PLB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLB()()()() | Initializes a new instance of the PLB class
 | AdjustmentIdentifier1 | Element 3
 | AdjustmentIdentifier2 | Element 5
 | AdjustmentIdentifier3 | Element 7
 | AdjustmentIdentifier4 | Element 9
 | AdjustmentIdentifier5 | Element 11
 | AdjustmentIdentifier6 | Element 13
 | Date | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 8
 | MonetaryAmount4 | Element 10
 | MonetaryAmount5 | Element 12
 | MonetaryAmount6 | Element 14
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLB

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PLB Constructor

PLB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► PLB()()()()
RDPCrystal EDI Library
Initializes a new instance of the PLB class
Declaration Syntax
C# Visual Basic Visual C++
public PLB()
Public Sub New
public:
PLB()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier1 Property

AdjustmentIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► AdjustmentIdentifier1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier1 { get; set; }
Public Property AdjustmentIdentifier1 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier1 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier2 Property

AdjustmentIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► AdjustmentIdentifier2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier2 { get; set; }
Public Property AdjustmentIdentifier2 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier2 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier3 Property

AdjustmentIdentifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► AdjustmentIdentifier3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier3 { get; set; }
Public Property AdjustmentIdentifier3 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier3 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier4 Property

AdjustmentIdentifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► AdjustmentIdentifier4
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier4 { get; set; }
Public Property AdjustmentIdentifier4 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier4 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier5 Property

AdjustmentIdentifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► AdjustmentIdentifier5
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier5 { get; set; }
Public Property AdjustmentIdentifier5 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier5 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AdjustmentIdentifier6 Property

AdjustmentIdentifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► AdjustmentIdentifier6
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier6 { get; set; }
Public Property AdjustmentIdentifier6 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier6 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► Date
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► MonetaryAmount3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► MonetaryAmount4
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► MonetaryAmount5
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► MonetaryAmount6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PLB ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PositionInSegment Class

PositionInSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PositionInSegment
RDPCrystal EDI Library
C030
Declaration Syntax
C# Visual Basic Visual C++
public class PositionInSegment : DocumentCompositeElement
Public Class PositionInSegment _
    Inherits DocumentCompositeElement
public ref class PositionInSegment : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PositionInSegment()()()() | Initializes a new instance of the PositionInSegment class
 | ComponentDataElementPositionInComposite |
 | ElementPositionInSegment |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepeatingDataElementPosition |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | PositionInSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PositionInSegment Constructor

PositionInSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PositionInSegment ► PositionInSegment()()()()
RDPCrystal EDI Library
Initializes a new instance of the PositionInSegment class
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment()
Public Sub New
public:
PositionInSegment()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ComponentDataElementPositionInComposite Property

ComponentDataElementPositionInComposite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PositionInSegment ► ComponentDataElementPositionInComposite
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentDataElementPositionInComposite { get; set; }
Public Property ComponentDataElementPositionInComposite As String
    Get
    Set
public:
property String^ ComponentDataElementPositionInComposite {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ElementPositionInSegment Property

ElementPositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PositionInSegment ► ElementPositionInSegment
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ElementPositionInSegment { get; set; }
Public Property ElementPositionInSegment As String
    Get
    Set
public:
property String^ ElementPositionInSegment {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PositionInSegment ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RepeatingDataElementPosition Property

RepeatingDataElementPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PositionInSegment ► RepeatingDataElementPosition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string RepeatingDataElementPosition { get; set; }
Public Property RepeatingDataElementPosition As String
    Get
    Set
public:
property String^ RepeatingDataElementPosition {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PRV Class

PRV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV
RDPCrystal EDI Library
Provider Information
Declaration Syntax
C# Visual Basic Visual C++
public class PRV : DocumentSegment
Public Class PRV _
    Inherits DocumentSegment
public ref class PRV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRV()()()() | Initializes a new instance of the PRV class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProviderCode | Element 1
 | ProviderOrganizationCode | Element 6
 | ProviderSpecialtyInformation | Element 5
 | ReferenceIdentification | Element 3
 | ReferenceIdentificationQualifier | Element 2
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRV

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PRV Constructor

PRV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► PRV()()()()
RDPCrystal EDI Library
Initializes a new instance of the PRV class
Declaration Syntax
C# Visual Basic Visual C++
public PRV()
Public Sub New
public:
PRV()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderCode Property

ProviderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► ProviderCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderCode { get; set; }
Public Property ProviderCode As String
    Get
    Set
public:
property String^ ProviderCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderOrganizationCode Property

ProviderOrganizationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► ProviderOrganizationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderOrganizationCode { get; set; }
Public Property ProviderOrganizationCode As String
    Get
    Set
public:
property String^ ProviderOrganizationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderSpecialtyInformation Property

ProviderSpecialtyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► ProviderSpecialtyInformation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderSpecialtyInformation { get; set; }
Public Property ProviderSpecialtyInformation As String
    Get
    Set
public:
property String^ ProviderSpecialtyInformation {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PRV ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PS1 Class

PS1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1
RDPCrystal EDI Library
Purchase Service
Declaration Syntax
C# Visual Basic Visual C++
public class PS1 : DocumentSegment
Public Class PS1 _
    Inherits DocumentSegment
public ref class PS1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PS1()()()() | Initializes a new instance of the PS1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 1
 | StateOrProvinceCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PS1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PS1 Constructor

PS1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1 ► PS1()()()()
RDPCrystal EDI Library
Initializes a new instance of the PS1 class
Declaration Syntax
C# Visual Basic Visual C++
public PS1()
Public Sub New
public:
PS1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1 ► StateOrProvinceCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PS1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PWK Class

PWK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK
RDPCrystal EDI Library
Paperwork
Declaration Syntax
C# Visual Basic Visual C++
public class PWK : DocumentSegment
Public Class PWK _
    Inherits DocumentSegment
public ref class PWK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PWK()()()() | Initializes a new instance of the PWK class
 | Description | Element 7
 | EntityIdentifierCode | Element 4
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 6
 | IdentificationCodeQualifier | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportCopiesNeeded | Element 3
 | ReportTransmissionCode | Element 2
 | ReportTypeCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PWK

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PWK Constructor

PWK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► PWK()()()()
RDPCrystal EDI Library
Initializes a new instance of the PWK class
Declaration Syntax
C# Visual Basic Visual C++
public PWK()
Public Sub New
public:
PWK()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► EntityIdentifierCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► IdentificationCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► IdentificationCodeQualifier
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReportCopiesNeeded Property

ReportCopiesNeeded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► ReportCopiesNeeded
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReportCopiesNeeded { get; set; }
Public Property ReportCopiesNeeded As String
    Get
    Set
public:
property String^ ReportCopiesNeeded {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► ReportTransmissionCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► ReportTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► PWK ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


QTY Class

QTY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► QTY
RDPCrystal EDI Library
Quantity
Declaration Syntax
C# Visual Basic Visual C++
public class QTY : DocumentSegment
Public Class QTY _
    Inherits DocumentSegment
public ref class QTY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QTY()()()() | Initializes a new instance of the QTY class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity | Element 2
 | QuantityQualifier | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | QTY

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


QTY Constructor

QTY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► QTY ► QTY()()()()
RDPCrystal EDI Library
Initializes a new instance of the QTY class
Declaration Syntax
C# Visual Basic Visual C++
public QTY()
Public Sub New
public:
QTY()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► QTY ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► QTY ► Quantity
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► QTY ► QuantityQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► QTY ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RaceOrEthnicityInformation Class

RaceOrEthnicityInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RaceOrEthnicityInformation
RDPCrystal EDI Library
C056
Declaration Syntax
C# Visual Basic Visual C++
public class RaceOrEthnicityInformation : DocumentCompositeElement
Public Class RaceOrEthnicityInformation _
    Inherits DocumentCompositeElement
public ref class RaceOrEthnicityInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RaceOrEthnicityInformation()()()() | Initializes a new instance of the RaceOrEthnicityInformation class
 | CodeListQualifierCode | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode | Element 3
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaceOrEthnicityCode | Element 1
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | RaceOrEthnicityInformation

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RaceOrEthnicityInformation Constructor

RaceOrEthnicityInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RaceOrEthnicityInformation ► RaceOrEthnicityInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the RaceOrEthnicityInformation class
Declaration Syntax
C# Visual Basic Visual C++
public RaceOrEthnicityInformation()
Public Sub New
public:
RaceOrEthnicityInformation()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RaceOrEthnicityInformation ► CodeListQualifierCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RaceOrEthnicityInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RaceOrEthnicityInformation ► IndustryCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RaceOrEthnicityCode Property

RaceOrEthnicityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RaceOrEthnicityInformation ► RaceOrEthnicityCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RaceOrEthnicityCode { get; set; }
Public Property RaceOrEthnicityCode As String
    Get
    Set
public:
property String^ RaceOrEthnicityCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RDM Class

RDM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM
RDPCrystal EDI Library
Remittance Delivery Method
Declaration Syntax
C# Visual Basic Visual C++
public class RDM : DocumentSegment
Public Class RDM _
    Inherits DocumentSegment
public ref class RDM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDM()()()() | Initializes a new instance of the RDM class
 | CommunicationNumber | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 2
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportTransmissionCode | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RDM Constructor

RDM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM ► RDM()()()()
RDPCrystal EDI Library
Initializes a new instance of the RDM class
Declaration Syntax
C# Visual Basic Visual C++
public RDM()
Public Sub New
public:
RDM()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM ► CommunicationNumber
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM ► Name1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM ► ReportTransmissionCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RDM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


REF Class

REF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF
RDPCrystal EDI Library
Reference Identification
Declaration Syntax
C# Visual Basic Visual C++
public class REF : DocumentSegment
Public Class REF _
    Inherits DocumentSegment
public ref class REF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REF()()()() | Initializes a new instance of the REF class
 | Description | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification | Element 2
 | ReferenceIdentificationQualifier | Element 1
 | ReferenceIdentifier |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REF

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


REF Constructor

REF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► REF()()()()
RDPCrystal EDI Library
Initializes a new instance of the REF class
Declaration Syntax
C# Visual Basic Visual C++
public REF()
Public Sub New
public:
REF()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► Description
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► ReferenceIdentification
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► ReferenceIdentificationQualifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentifier Property

ReferenceIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► ReferenceIdentifier
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier ReferenceIdentifier { get; set; }
Public Property ReferenceIdentifier As ReferenceIdentifier
    Get
    Set
public:
property ReferenceIdentifier^ ReferenceIdentifier {
    ReferenceIdentifier^ get ();
    void set (ReferenceIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► REF ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentifier Class

ReferenceIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier
RDPCrystal EDI Library
C040
Declaration Syntax
C# Visual Basic Visual C++
public class ReferenceIdentifier : DocumentCompositeElement
Public Class ReferenceIdentifier _
    Inherits DocumentCompositeElement
public ref class ReferenceIdentifier : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferenceIdentifier()()()() | Initializes a new instance of the ReferenceIdentifier class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | ReferenceIdentification3 |
 | ReferenceIdentificationQualifier1 |
 | ReferenceIdentificationQualifier2 |
 | ReferenceIdentificationQualifier3 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ReferenceIdentifier

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentifier Constructor

ReferenceIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentifier()()()()
RDPCrystal EDI Library
Initializes a new instance of the ReferenceIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceIdentifier()
Public Sub New
public:
ReferenceIdentifier()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentification1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentification2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentification3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentificationQualifier1 Property

ReferenceIdentificationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentificationQualifier1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier1 { get; set; }
Public Property ReferenceIdentificationQualifier1 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentificationQualifier2 Property

ReferenceIdentificationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentificationQualifier2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier2 { get; set; }
Public Property ReferenceIdentificationQualifier2 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentificationQualifier3 Property

ReferenceIdentificationQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceIdentifier ► ReferenceIdentificationQualifier3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier3 { get; set; }
Public Property ReferenceIdentificationQualifier3 As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceInSegment Class

ReferenceInSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceInSegment
RDPCrystal EDI Library
C999
Declaration Syntax
C# Visual Basic Visual C++
public class ReferenceInSegment : DocumentCompositeElement
Public Class ReferenceInSegment _
    Inherits DocumentCompositeElement
public ref class ReferenceInSegment : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferenceInSegment()()()() | Initializes a new instance of the ReferenceInSegment class
 | DataElementReferenceNumber1 |
 | DataElementReferenceNumber2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ReferenceInSegment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceInSegment Constructor

ReferenceInSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceInSegment ► ReferenceInSegment()()()()
RDPCrystal EDI Library
Initializes a new instance of the ReferenceInSegment class
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceInSegment()
Public Sub New
public:
ReferenceInSegment()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DataElementReferenceNumber1 Property

DataElementReferenceNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceInSegment ► DataElementReferenceNumber1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber1 { get; set; }
Public Property DataElementReferenceNumber1 As String
    Get
    Set
public:
property String^ DataElementReferenceNumber1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DataElementReferenceNumber2 Property

DataElementReferenceNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceInSegment ► DataElementReferenceNumber2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber2 { get; set; }
Public Property DataElementReferenceNumber2 As String
    Get
    Set
public:
property String^ DataElementReferenceNumber2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ReferenceInSegment ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesInformation Class

RelatedCausesInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation
RDPCrystal EDI Library
C024
Declaration Syntax
C# Visual Basic Visual C++
public class RelatedCausesInformation : DocumentCompositeElement
Public Class RelatedCausesInformation _
    Inherits DocumentCompositeElement
public ref class RelatedCausesInformation : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelatedCausesInformation()()()() | Initializes a new instance of the RelatedCausesInformation class
 | CountryCode | Element 5
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RelatedCausesCode1 | Element 1
 | RelatedCausesCode2 | Element 2
 | RelatedCausesCode3 | Element 3
 | StateOrProvinceCode | Element 4
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | RelatedCausesInformation

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesInformation Constructor

RelatedCausesInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► RelatedCausesInformation()()()()
RDPCrystal EDI Library
Initializes a new instance of the RelatedCausesInformation class
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation()
Public Sub New
public:
RelatedCausesInformation()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► CountryCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesCode1 Property

RelatedCausesCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► RelatedCausesCode1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode1 { get; set; }
Public Property RelatedCausesCode1 As String
    Get
    Set
public:
property String^ RelatedCausesCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesCode2 Property

RelatedCausesCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► RelatedCausesCode2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode2 { get; set; }
Public Property RelatedCausesCode2 As String
    Get
    Set
public:
property String^ RelatedCausesCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesCode3 Property

RelatedCausesCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► RelatedCausesCode3
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode3 { get; set; }
Public Property RelatedCausesCode3 As String
    Get
    Set
public:
property String^ RelatedCausesCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► RelatedCausesInformation ► StateOrProvinceCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SBR Class

SBR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR
RDPCrystal EDI Library
Subscriber Information
Declaration Syntax
C# Visual Basic Visual C++
public class SBR : DocumentSegment
Public Class SBR _
    Inherits DocumentSegment
public ref class SBR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SBR()()()() | Initializes a new instance of the SBR class
 | ClaimFilingIndicatorCode | Element 9
 | CoordinationOfBenefitsCode | Element 6
 | EmploymentStatusCode | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode | Element 2
 | InsuranceTypeCode | Element 5
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Name1 | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode | Element 1
 | ReferenceIdentification | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 7
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SBR

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SBR Constructor

SBR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► SBR()()()()
RDPCrystal EDI Library
Initializes a new instance of the SBR class
Declaration Syntax
C# Visual Basic Visual C++
public SBR()
Public Sub New
public:
SBR()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► ClaimFilingIndicatorCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CoordinationOfBenefitsCode Property

CoordinationOfBenefitsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► CoordinationOfBenefitsCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string CoordinationOfBenefitsCode { get; set; }
Public Property CoordinationOfBenefitsCode As String
    Get
    Set
public:
property String^ CoordinationOfBenefitsCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► EmploymentStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► IndividualRelationshipCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► InsuranceTypeCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Name1 Property

Name1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► Name1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Name1 { get; set; }
Public Property Name1 As String
    Get
    Set
public:
property String^ Name1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► PayerResponsibilitySequenceNumberCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► ReferenceIdentification
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SBR ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SE Class

SE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SE
RDPCrystal EDI Library
Transaction Set Trailer
Declaration Syntax
C# Visual Basic Visual C++
public class SE : DocumentSegment
Public Class SE _
    Inherits DocumentSegment
public ref class SE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SE()()()() | Initializes a new instance of the SE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfIncludedSegments | Element 1
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SE Constructor

SE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SE ► SE()()()()
RDPCrystal EDI Library
Initializes a new instance of the SE class
Declaration Syntax
C# Visual Basic Visual C++
public SE()
Public Sub New
public:
SE()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SE ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NumberOfIncludedSegments Property

NumberOfIncludedSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SE ► NumberOfIncludedSegments
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfIncludedSegments { get; set; }
Public Property NumberOfIncludedSegments As String
    Get
    Set
public:
property String^ NumberOfIncludedSegments {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SE ► TransactionSetControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SE ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ST Class

ST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST
RDPCrystal EDI Library
Transaction Set Header
Declaration Syntax
C# Visual Basic Visual C++
public class ST : DocumentSegment
Public Class ST _
    Inherits DocumentSegment
public ref class ST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ST()()()() | Initializes a new instance of the ST class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationConventionReference | Element 3
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber | Element 2
 | TransactionSetIdentifierCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ST

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ST Constructor

ST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST ► ST()()()()
RDPCrystal EDI Library
Initializes a new instance of the ST class
Declaration Syntax
C# Visual Basic Visual C++
public ST()
Public Sub New
public:
ST()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ImplementationConventionReference Property

ImplementationConventionReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST ► ImplementationConventionReference
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationConventionReference { get; set; }
Public Property ImplementationConventionReference As String
    Get
    Set
public:
property String^ ImplementationConventionReference {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST ► TransactionSetControlNumber
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST ► TransactionSetIdentifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ST ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


STC Class

STC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC
RDPCrystal EDI Library
Status Information
Declaration Syntax
C# Visual Basic Visual C++
public class STC : DocumentSegment
Public Class STC _
    Inherits DocumentSegment
public ref class STC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | STC()()()() | Initializes a new instance of the STC class
 | ActionCode | Element 3
 | CheckNumber | Element 9
 | Date1 | Element 2
 | Date2 | Element 6
 | Date3 | Element 8
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText | Element 12
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareClaimStatus1 | Element 1
 | HealthCareClaimStatus2 | Element 10
 | HealthCareClaimStatus3 | Element 11
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | STC

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


STC Constructor

STC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► STC()()()()
RDPCrystal EDI Library
Initializes a new instance of the STC class
Declaration Syntax
C# Visual Basic Visual C++
public STC()
Public Sub New
public:
STC()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► ActionCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CheckNumber Property

CheckNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► CheckNumber
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string CheckNumber { get; set; }
Public Property CheckNumber As String
    Get
    Set
public:
property String^ CheckNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► Date1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► Date2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► Date3
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► FreeFormMessageText
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareClaimStatus1 Property

HealthCareClaimStatus1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► HealthCareClaimStatus1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus1 { get; set; }
Public Property HealthCareClaimStatus1 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus1 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareClaimStatus2 Property

HealthCareClaimStatus2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► HealthCareClaimStatus2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus2 { get; set; }
Public Property HealthCareClaimStatus2 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus2 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareClaimStatus3 Property

HealthCareClaimStatus3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► HealthCareClaimStatus3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus3 { get; set; }
Public Property HealthCareClaimStatus3 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus3 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► PaymentMethodCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► STC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV1 Class

SV1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1
RDPCrystal EDI Library
Professional Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV1 : DocumentSegment
Public Class SV1 _
    Inherits DocumentSegment
public ref class SV1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV1()()()() | Initializes a new instance of the SV1 class
 | CompositeDiagnosticCodePointer | Element 7
 | CompositeMedicalProcedureIdentifier | Element 1
 | CopayStatusCode | Element 15
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 5
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareProfessionalShortageAreaCode | Element 16
 | LevelOfCareCode | Element 20
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 2
 | MonetaryAmount2 | Element 8
 | MonetaryAmount3 | Element 19
 | MultipleProcedureCode | Element 10
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NationalOrLocalAssignedReviewValue | Element 14
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode | Element 18
 | ProviderAgreementCode | Element 21
 | Quantity | Element 4
 | ReferenceIdentification | Element 17
 | ReviewCode | Element 13
 | ServiceTypeCode | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 3
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 | Element 9
 | YesNoConditionOrResponseCode2 | Element 11
 | YesNoConditionOrResponseCode3 | Element 12
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV1

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV1 Constructor

SV1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► SV1()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV1 class
Declaration Syntax
C# Visual Basic Visual C++
public SV1()
Public Sub New
public:
SV1()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► CompositeDiagnosticCodePointer
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► CopayStatusCode
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► FacilityCodeValue
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareProfessionalShortageAreaCode Property

HealthCareProfessionalShortageAreaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► HealthCareProfessionalShortageAreaCode
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string HealthCareProfessionalShortageAreaCode { get; set; }
Public Property HealthCareProfessionalShortageAreaCode As String
    Get
    Set
public:
property String^ HealthCareProfessionalShortageAreaCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► LevelOfCareCode
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► MonetaryAmount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► MonetaryAmount2
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► MonetaryAmount3
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MultipleProcedureCode Property

MultipleProcedureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► MultipleProcedureCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MultipleProcedureCode { get; set; }
Public Property MultipleProcedureCode As String
    Get
    Set
public:
property String^ MultipleProcedureCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NationalOrLocalAssignedReviewValue Property

NationalOrLocalAssignedReviewValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► NationalOrLocalAssignedReviewValue
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string NationalOrLocalAssignedReviewValue { get; set; }
Public Property NationalOrLocalAssignedReviewValue As String
    Get
    Set
public:
property String^ NationalOrLocalAssignedReviewValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► PostalCode
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► ProviderAgreementCode
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► Quantity
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► ReferenceIdentification
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReviewCode Property

ReviewCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► ReviewCode
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string ReviewCode { get; set; }
Public Property ReviewCode As String
    Get
    Set
public:
property String^ ReviewCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► ServiceTypeCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► YesNoConditionOrResponseCode1
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► YesNoConditionOrResponseCode2
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV1 ► YesNoConditionOrResponseCode3
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV2 Class

SV2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2
RDPCrystal EDI Library
Institutional Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV2 : DocumentSegment
Public Class SV2 _
    Inherits DocumentSegment
public ref class SV2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV2()()()() | Initializes a new instance of the SV2 class
 | CompositeMedicalProcedureIdentifier | Element 2
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelOfCareCode | Element 10
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 3
 | MonetaryAmount2 | Element 7
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NursingHomeResidentialStatusCode | Element 9
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductOrServiceID | Element 1
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 4
 | UnitRate | Element 6
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 8
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV2

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV2 Constructor

SV2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► SV2()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV2 class
Declaration Syntax
C# Visual Basic Visual C++
public SV2()
Public Sub New
public:
SV2()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► LevelOfCareCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► MonetaryAmount1
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► MonetaryAmount2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


NursingHomeResidentialStatusCode Property

NursingHomeResidentialStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► NursingHomeResidentialStatusCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string NursingHomeResidentialStatusCode { get; set; }
Public Property NursingHomeResidentialStatusCode As String
    Get
    Set
public:
property String^ NursingHomeResidentialStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductOrServiceID Property

ProductOrServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► ProductOrServiceID
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOrServiceID { get; set; }
Public Property ProductOrServiceID As String
    Get
    Set
public:
property String^ ProductOrServiceID {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitRate Property

UnitRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► UnitRate
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string UnitRate { get; set; }
Public Property UnitRate As String
    Get
    Set
public:
property String^ UnitRate {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV2 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV3 Class

SV3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3
RDPCrystal EDI Library
Dental Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV3 : DocumentSegment
Public Class SV3 _
    Inherits DocumentSegment
public ref class SV3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV3()()()() | Initializes a new instance of the SV3 class
 | CompositeDiagnosticCodePointer | Element 11
 | CompositeMedicalProcedureIdentifier | Element 1
 | CopayStatusCode | Element 8
 | Description | Element 7
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 3
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OralCavityDesign | Element 4
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProsthesisCrownOrInlayCode | Element 5
 | ProviderAgreementCode | Element 9
 | Quantity | Element 6
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode | Element 10
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV3

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV3 Constructor

SV3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► SV3()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV3 class
Declaration Syntax
C# Visual Basic Visual C++
public SV3()
Public Sub New
public:
SV3()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► CompositeDiagnosticCodePointer
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► CopayStatusCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► Description
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► FacilityCodeValue
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OralCavityDesign Property

OralCavityDesign Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► OralCavityDesign
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public OralCavityDesign OralCavityDesign { get; set; }
Public Property OralCavityDesign As OralCavityDesign
    Get
    Set
public:
property OralCavityDesign^ OralCavityDesign {
    OralCavityDesign^ get ();
    void set (OralCavityDesign^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProsthesisCrownOrInlayCode Property

ProsthesisCrownOrInlayCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► ProsthesisCrownOrInlayCode
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string ProsthesisCrownOrInlayCode { get; set; }
Public Property ProsthesisCrownOrInlayCode As String
    Get
    Set
public:
property String^ ProsthesisCrownOrInlayCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► ProviderAgreementCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► Quantity
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV3 ► YesNoConditionOrResponseCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV5 Class

SV5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5
RDPCrystal EDI Library
Durable Medical Equipment Service
Declaration Syntax
C# Visual Basic Visual C++
public class SV5 : DocumentSegment
Public Class SV5 _
    Inherits DocumentSegment
public ref class SV5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV5()()()() | Initializes a new instance of the SV5 class
 | CompositeMedicalProcedureIdentifier | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode | Element 6
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 4
 | MonetaryAmount2 | Element 5
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrognosisCode | Element 7
 | Quantity | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode | Element 2
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV5

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SV5 Constructor

SV5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► SV5()()()()
RDPCrystal EDI Library
Initializes a new instance of the SV5 class
Declaration Syntax
C# Visual Basic Visual C++
public SV5()
Public Sub New
public:
SV5()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► FrequencyCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► MonetaryAmount1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► MonetaryAmount2
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► PrognosisCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► Quantity
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► UnitOrBasisForMeasurementCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SV5 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SVC Class

SVC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC
RDPCrystal EDI Library
Service Information
Declaration Syntax
C# Visual Basic Visual C++
public class SVC : DocumentSegment
Public Class SVC _
    Inherits DocumentSegment
public ref class SVC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVC()()()() | Initializes a new instance of the SVC class
 | CompositeMedicalProcedureIdentifier1 | Element 1
 | CompositeMedicalProcedureIdentifier2 | Element 6
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 2
 | MonetaryAmount2 | Element 3
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | Quantity1 | Element 5
 | Quantity2 | Element 7
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVC

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SVC Constructor

SVC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► SVC()()()()
RDPCrystal EDI Library
Initializes a new instance of the SVC class
Declaration Syntax
C# Visual Basic Visual C++
public SVC()
Public Sub New
public:
SVC()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier1 Property

CompositeMedicalProcedureIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► CompositeMedicalProcedureIdentifier1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier1 { get; set; }
Public Property CompositeMedicalProcedureIdentifier1 As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier1 {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier2 Property

CompositeMedicalProcedureIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► CompositeMedicalProcedureIdentifier2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier2 { get; set; }
Public Property CompositeMedicalProcedureIdentifier2 As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier2 {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► MonetaryAmount1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► MonetaryAmount2
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► Quantity1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► Quantity2
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVC ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SVD Class

SVD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD
RDPCrystal EDI Library
Service Line Adjudication
Declaration Syntax
C# Visual Basic Visual C++
public class SVD : DocumentSegment
Public Class SVD _
    Inherits DocumentSegment
public ref class SVD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVD()()()() | Initializes a new instance of the SVD class
 | AssignedNumber | Element 6
 | CompositeMedicalProcedureIdentifier | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode | Element 1
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount | Element 2
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID | Element 4
 | Quantity | Element 5
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVD

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


SVD Constructor

SVD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► SVD()()()()
RDPCrystal EDI Library
Initializes a new instance of the SVD class
Declaration Syntax
C# Visual Basic Visual C++
public SVD()
Public Sub New
public:
SVD()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► AssignedNumber
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► CompositeMedicalProcedureIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► IdentificationCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► MonetaryAmount
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► ProductServiceID
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► Quantity
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► SVD ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TOO Class

TOO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO
RDPCrystal EDI Library
Tooth Identification
Declaration Syntax
C# Visual Basic Visual C++
public class TOO : DocumentSegment
Public Class TOO _
    Inherits DocumentSegment
public ref class TOO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TOO()()()() | Initializes a new instance of the TOO class
 | CodeListQualifierCode | Element 1
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToothCode | Element 2
 | ToothSurface | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TOO

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TOO Constructor

TOO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO ► TOO()()()()
RDPCrystal EDI Library
Initializes a new instance of the TOO class
Declaration Syntax
C# Visual Basic Visual C++
public TOO()
Public Sub New
public:
TOO()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO ► CodeListQualifierCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothCode Property

ToothCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO ► ToothCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ToothCode { get; set; }
Public Property ToothCode As String
    Get
    Set
public:
property String^ ToothCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurface Property

ToothSurface Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO ► ToothSurface
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public ToothSurface ToothSurface { get; set; }
Public Property ToothSurface As ToothSurface
    Get
    Set
public:
property ToothSurface^ ToothSurface {
    ToothSurface^ get ();
    void set (ToothSurface^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TOO ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurface Class

ToothSurface Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface
RDPCrystal EDI Library
C005
Declaration Syntax
C# Visual Basic Visual C++
public class ToothSurface : DocumentCompositeElement
Public Class ToothSurface _
    Inherits DocumentCompositeElement
public ref class ToothSurface : public DocumentCompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToothSurface()()()() | Initializes a new instance of the ToothSurface class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides DocumentCompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToothSurfaceCode1 |
 | ToothSurfaceCode2 |
 | ToothSurfaceCode3 |
 | ToothSurfaceCode4 |
 | ToothSurfaceCode5 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from DocumentCompositeElement.)
Inheritance Hierarchy
Object
 | DocumentCompositeElement
 |  | ToothSurface

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurface Constructor

ToothSurface Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► ToothSurface()()()()
RDPCrystal EDI Library
Initializes a new instance of the ToothSurface class
Declaration Syntax
C# Visual Basic Visual C++
public ToothSurface()
Public Sub New
public:
ToothSurface()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► GetString(Char)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurfaceCode1 Property

ToothSurfaceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► ToothSurfaceCode1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode1 { get; set; }
Public Property ToothSurfaceCode1 As String
    Get
    Set
public:
property String^ ToothSurfaceCode1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurfaceCode2 Property

ToothSurfaceCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► ToothSurfaceCode2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode2 { get; set; }
Public Property ToothSurfaceCode2 As String
    Get
    Set
public:
property String^ ToothSurfaceCode2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurfaceCode3 Property

ToothSurfaceCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► ToothSurfaceCode3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode3 { get; set; }
Public Property ToothSurfaceCode3 As String
    Get
    Set
public:
property String^ ToothSurfaceCode3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurfaceCode4 Property

ToothSurfaceCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► ToothSurfaceCode4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode4 { get; set; }
Public Property ToothSurfaceCode4 As String
    Get
    Set
public:
property String^ ToothSurfaceCode4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ToothSurfaceCode5 Property

ToothSurfaceCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► ToothSurface ► ToothSurfaceCode5
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode5 { get; set; }
Public Property ToothSurfaceCode5 As String
    Get
    Set
public:
property String^ ToothSurfaceCode5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TRN Class

TRN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN
RDPCrystal EDI Library
Trace
Declaration Syntax
C# Visual Basic Visual C++
public class TRN : DocumentSegment
Public Class TRN _
    Inherits DocumentSegment
public ref class TRN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TRN()()()() | Initializes a new instance of the TRN class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginatingCompanyIdentifier | Element 3
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification1 | Element 2
 | ReferenceIdentification2 | Element 4
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TraceTypeCode | Element 1
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TRN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TRN Constructor

TRN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► TRN()()()()
RDPCrystal EDI Library
Initializes a new instance of the TRN class
Declaration Syntax
C# Visual Basic Visual C++
public TRN()
Public Sub New
public:
TRN()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► OriginatingCompanyIdentifier
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► ReferenceIdentification1
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► ReferenceIdentification2
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TraceTypeCode Property

TraceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► TraceTypeCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string TraceTypeCode { get; set; }
Public Property TraceTypeCode As String
    Get
    Set
public:
property String^ TraceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TRN ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TS2 Class

TS2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2
RDPCrystal EDI Library
Transaction Supplemental Statistics
Declaration Syntax
C# Visual Basic Visual C++
public class TS2 : DocumentSegment
Public Class TS2 _
    Inherits DocumentSegment
public ref class TS2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS2()()()() | Initializes a new instance of the TS2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 1
 | MonetaryAmount10 | Element 17
 | MonetaryAmount11 | Element 18
 | MonetaryAmount12 | Element 19
 | MonetaryAmount2 | Element 2
 | MonetaryAmount3 | Element 3
 | MonetaryAmount4 | Element 4
 | MonetaryAmount5 | Element 5
 | MonetaryAmount6 | Element 6
 | MonetaryAmount7 | Element 8
 | MonetaryAmount8 | Element 9
 | MonetaryAmount9 | Element 15
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 7
 | Quantity2 | Element 10
 | Quantity3 | Element 11
 | Quantity4 | Element 12
 | Quantity5 | Element 13
 | Quantity6 | Element 14
 | Quantity7 | Element 16
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS2

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TS2 Constructor

TS2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► TS2()()()()
RDPCrystal EDI Library
Initializes a new instance of the TS2 class
Declaration Syntax
C# Visual Basic Visual C++
public TS2()
Public Sub New
public:
TS2()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount1
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount10
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount11
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount12
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount2
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount3
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount4
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount5
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount6
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount7
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount8
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► MonetaryAmount9
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity1
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity2
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity3
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity4
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity5
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity6
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity7 Property

Quantity7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Quantity7
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity7 { get; set; }
Public Property Quantity7 As String
    Get
    Set
public:
property String^ Quantity7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS2 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TS3 Class

TS3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3
RDPCrystal EDI Library
Transaction Statistics
Declaration Syntax
C# Visual Basic Visual C++
public class TS3 : DocumentSegment
Public Class TS3 _
    Inherits DocumentSegment
public ref class TS3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS3()()()() | Initializes a new instance of the TS3 class
 | Date | Element 3
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue | Element 2
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 | Element 5
 | MonetaryAmount10 | Element 14
 | MonetaryAmount11 | Element 15
 | MonetaryAmount12 | Element 16
 | MonetaryAmount13 | Element 17
 | MonetaryAmount14 | Element 18
 | MonetaryAmount15 | Element 19
 | MonetaryAmount16 | Element 20
 | MonetaryAmount17 | Element 21
 | MonetaryAmount18 | Element 22
 | MonetaryAmount19 | Element 24
 | MonetaryAmount2 | Element 6
 | MonetaryAmount3 | Element 7
 | MonetaryAmount4 | Element 8
 | MonetaryAmount5 | Element 9
 | MonetaryAmount6 | Element 10
 | MonetaryAmount7 | Element 11
 | MonetaryAmount8 | Element 12
 | MonetaryAmount9 | Element 13
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 | Element 4
 | Quantity2 | Element 23
 | ReferenceIdentification | Element 1
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS3

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


TS3 Constructor

TS3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► TS3()()()()
RDPCrystal EDI Library
Initializes a new instance of the TS3 class
Declaration Syntax
C# Visual Basic Visual C++
public TS3()
Public Sub New
public:
TS3()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► Date
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► FacilityCodeValue
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount1
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount10
RDPCrystal EDI Library
Element 14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount11
RDPCrystal EDI Library
Element 15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount12
RDPCrystal EDI Library
Element 16
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount13 Property

MonetaryAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount13
RDPCrystal EDI Library
Element 17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount13 { get; set; }
Public Property MonetaryAmount13 As String
    Get
    Set
public:
property String^ MonetaryAmount13 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount14 Property

MonetaryAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount14
RDPCrystal EDI Library
Element 18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount14 { get; set; }
Public Property MonetaryAmount14 As String
    Get
    Set
public:
property String^ MonetaryAmount14 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount15 Property

MonetaryAmount15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount15
RDPCrystal EDI Library
Element 19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount15 { get; set; }
Public Property MonetaryAmount15 As String
    Get
    Set
public:
property String^ MonetaryAmount15 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount16 Property

MonetaryAmount16 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount16
RDPCrystal EDI Library
Element 20
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount16 { get; set; }
Public Property MonetaryAmount16 As String
    Get
    Set
public:
property String^ MonetaryAmount16 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount17 Property

MonetaryAmount17 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount17
RDPCrystal EDI Library
Element 21
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount17 { get; set; }
Public Property MonetaryAmount17 As String
    Get
    Set
public:
property String^ MonetaryAmount17 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount18 Property

MonetaryAmount18 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount18
RDPCrystal EDI Library
Element 22
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount18 { get; set; }
Public Property MonetaryAmount18 As String
    Get
    Set
public:
property String^ MonetaryAmount18 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount19 Property

MonetaryAmount19 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount19
RDPCrystal EDI Library
Element 24
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount19 { get; set; }
Public Property MonetaryAmount19 As String
    Get
    Set
public:
property String^ MonetaryAmount19 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount2
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount3
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount4
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount5
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount6
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount7
RDPCrystal EDI Library
Element 11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount8
RDPCrystal EDI Library
Element 12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► MonetaryAmount9
RDPCrystal EDI Library
Element 13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► Quantity1
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► Quantity2
RDPCrystal EDI Library
Element 23
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► ReferenceIdentification
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► TS3 ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Typed5010Document Class

Typed5010Document Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document
RDPCrystal EDI Library
Represents an X12 5010 Document
Declaration Syntax
C# Visual Basic Visual C++
public class Typed5010Document : TypedDocument
Public Class Typed5010Document _
    Inherits TypedDocument
public ref class Typed5010Document : public TypedDocument
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Typed5010Document()()()() | Initializes a new instance of the Typed5010Document class.
 | Typed5010Document(EDILightWeightDocument) | Initializes a new instance of the Typed5010Document class.
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT) (Inherited from TypedDocument.)
 | AutoPlaceNumOfFunctionalGroups | Places the correct number of functional groups in the IEA segment Element 1(X12) (Inherited from TypedDocument.)
 | AutoPlaceNumOfTransactions | Places the correct number of transaction in the GE segment Element 1(X12) (Inherited from TypedDocument.)
 | CreateSection(LightWeightLoop) | Overridden in edge case scenarios when a custom loop structure is needed (Inherited from TypedDocument.)
 | DestroySegmentsAfter | Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument (Inherited from TypedDocument.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file (Inherited from TypedDocument.)
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document (Inherited from TypedDocument.)
 | GetDocumentSegment(String) | Gets the document item. (Overrides TypedDocument.GetDocumentSegment(String).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(EDILightWeightDocument) | Loads the specified light weight document. (Inherited from TypedDocument.)
 | MainSection | Gets or sets the main section of the TypedDocument (Inherited from TypedDocument.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadISAElementValues | Pads or trims the ISA elements to conform to HIPAA (Inherited from TypedDocument.)
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document (Inherited from TypedDocument.)
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document (Inherited from TypedDocument.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypedDocument
 |  | Typed5010Document

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Typed5010Document Constructor

Typed5010Document Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document ► Typed5010Document()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Typed5010Document()()()() | Initializes a new instance of the Typed5010Document class.
 | Typed5010Document(EDILightWeightDocument) | Initializes a new instance of the Typed5010Document class.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Typed5010Document Constructor

Typed5010Document Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document ► Typed5010Document()()()()
RDPCrystal EDI Library
Initializes a new instance of the Typed5010Document class.
Declaration Syntax
C# Visual Basic Visual C++
public Typed5010Document()
Public Sub New
public:
Typed5010Document()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Typed5010Document Constructor (document)

Typed5010Document Constructor (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document ► Typed5010Document(EDILightWeightDocument)
RDPCrystal EDI Library
Initializes a new instance of the Typed5010Document class.
Declaration Syntax
C# Visual Basic Visual C++
public Typed5010Document(
    EDILightWeightDocument document
)
Public Sub New ( _
    document As EDILightWeightDocument _
)
public:
Typed5010Document(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
The document to initialize from

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


GetDocumentSegment Method (segmentName)

GetDocumentSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document ► GetDocumentSegment(String)
RDPCrystal EDI Library
Gets the document item.
Declaration Syntax
C# Visual Basic Visual C++
protected override DocumentSegment GetDocumentSegment(
    string segmentName
)
Protected Overrides Function GetDocumentSegment ( _
    segmentName As String _
) As DocumentSegment
protected:
virtual DocumentSegment^ GetDocumentSegment(
    String^ segmentName
) override
Parameters
segmentName (String)
Name of the segment.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UM Class

UM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM
RDPCrystal EDI Library
Health Care Services Review Information
Declaration Syntax
C# Visual Basic Visual C++
public class UM : DocumentSegment
Public Class UM _
    Inherits DocumentSegment
public ref class UM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UM()()()() | Initializes a new instance of the UM class
 | CertificationTypeCode | Element 2
 | CurrentHealthConditionCode | Element 7
 | DelayReasonCode | Element 10
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareServiceLocation | Element 4
 | LevelOfServiceCode | Element 6
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrognosisCode | Element 8
 | RelatedCausesInformation | Element 5
 | ReleaseOfInformationCode | Element 9
 | RequestCategoryCode | Element 1
 | ServiceTypeCode | Element 3
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | UM

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


UM Constructor

UM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► UM()()()()
RDPCrystal EDI Library
Initializes a new instance of the UM class
Declaration Syntax
C# Visual Basic Visual C++
public UM()
Public Sub New
public:
UM()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► CertificationTypeCode
RDPCrystal EDI Library
Element 2
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


CurrentHealthConditionCode Property

CurrentHealthConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► CurrentHealthConditionCode
RDPCrystal EDI Library
Element 7
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentHealthConditionCode { get; set; }
Public Property CurrentHealthConditionCode As String
    Get
    Set
public:
property String^ CurrentHealthConditionCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


DelayReasonCode Property

DelayReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► DelayReasonCode
RDPCrystal EDI Library
Element 10
Declaration Syntax
C# Visual Basic Visual C++
public string DelayReasonCode { get; set; }
Public Property DelayReasonCode As String
    Get
    Set
public:
property String^ DelayReasonCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


HealthCareServiceLocation Property

HealthCareServiceLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► HealthCareServiceLocation
RDPCrystal EDI Library
Element 4
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocation HealthCareServiceLocation { get; set; }
Public Property HealthCareServiceLocation As HealthCareServiceLocation
    Get
    Set
public:
property HealthCareServiceLocation^ HealthCareServiceLocation {
    HealthCareServiceLocation^ get ();
    void set (HealthCareServiceLocation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


LevelOfServiceCode Property

LevelOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► LevelOfServiceCode
RDPCrystal EDI Library
Element 6
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfServiceCode { get; set; }
Public Property LevelOfServiceCode As String
    Get
    Set
public:
property String^ LevelOfServiceCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► Load(LightWeightSegment)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► PrognosisCode
RDPCrystal EDI Library
Element 8
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RelatedCausesInformation Property

RelatedCausesInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► RelatedCausesInformation
RDPCrystal EDI Library
Element 5
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation RelatedCausesInformation { get; set; }
Public Property RelatedCausesInformation As RelatedCausesInformation
    Get
    Set
public:
property RelatedCausesInformation^ RelatedCausesInformation {
    RelatedCausesInformation^ get ();
    void set (RelatedCausesInformation^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► ReleaseOfInformationCode
RDPCrystal EDI Library
Element 9
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RequestCategoryCode Property

RequestCategoryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► RequestCategoryCode
RDPCrystal EDI Library
Element 1
Declaration Syntax
C# Visual Basic Visual C++
public string RequestCategoryCode { get; set; }
Public Property RequestCategoryCode As String
    Get
    Set
public:
property String^ RequestCategoryCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► ServiceTypeCode
RDPCrystal EDI Library
Element 3
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► UM ► Write(WriteArguments)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


RDPCrystalEDILibrary.PrinterForms Namespace

RDPCrystalEDILibrary.PrinterForms Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.PrinterForms
Namespace RDPCrystalEDILibrary.PrinterForms
namespace RDPCrystalEDILibrary.PrinterForms
Types
All Types Classes
Icon | Type | Description
 | Box24 | Represents Services Lines on a CMS 1500 form
 | CMS1500Form | Represents a CMS 1500 Form
 | CMSFormData | Represents form fields on a CMS-1500 form
 | DateField | Represent a date form field. For example 'MM dd yy'
 | FormBase | Base class for all forms
 | FormEventArgs | Represents FormEventArgs
 | FormField | An object used to encapulate the data of a cell and formatting
 | FormPrinter | Represents a class that can draw data on an image or printer
 | LicenseException | Exception thrown when a license is invalid
 | PackageLicense |
 | PhoneField | Represent a phone form field. For example, '123 2342333'
 | PriceField | Represent a price/number form field. For example, '123.00'
 | Service |
 | TextField | Represent a text form field
 | UB04Date | Represent a UB04 date form field. For example 'MMddyy'
 | UB04Form | Represents a UB04 Form
 | UB04FormData |


Box24 Class

Box24 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24
RDPCrystal EDI Library
Represents Services Lines on a CMS 1500 form
Declaration Syntax
C# Visual Basic Visual C++
public class Box24
Public Class Box24
public ref class Box24
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Box24()()()() | Initializes a new instance of the Box24 class
 | Box24Aa |
 | Box24Ab |
 | Box24B |
 | Box24C |
 | Box24D |
 | Box24E |
 | Box24F |
 | Box24G |
 | Box24H |
 | Box24IShaded |
 | Box24J |
 | Box24JShaded |
 | Box24Mod1 |
 | Box24Mod2 |
 | Box24Mod3 |
 | Box24Mod4 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Box24

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24 Constructor

Box24 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24()()()()
RDPCrystal EDI Library
Initializes a new instance of the Box24 class
Declaration Syntax
C# Visual Basic Visual C++
public Box24()
Public Sub New
public:
Box24()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24Aa Property

Box24Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box24Aa { get; set; }
Public Property Box24Aa As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box24Aa {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24Ab Property

Box24Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box24Ab { get; set; }
Public Property Box24Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box24Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24B Property

Box24B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24B { get; set; }
Public Property Box24B As String
    Get
    Set
public:
property String^ Box24B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24C Property

Box24C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24C { get; set; }
Public Property Box24C As String
    Get
    Set
public:
property String^ Box24C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24D Property

Box24D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24D { get; set; }
Public Property Box24D As String
    Get
    Set
public:
property String^ Box24D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24E Property

Box24E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24E { get; set; }
Public Property Box24E As String
    Get
    Set
public:
property String^ Box24E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24F Property

Box24F Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24F
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box24F { get; set; }
Public Property Box24F As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box24F {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24G Property

Box24G Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24G
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24G { get; set; }
Public Property Box24G As String
    Get
    Set
public:
property String^ Box24G {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24H Property

Box24H Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24H
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24H { get; set; }
Public Property Box24H As String
    Get
    Set
public:
property String^ Box24H {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24IShaded Property

Box24IShaded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24IShaded
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24IShaded { get; set; }
Public Property Box24IShaded As String
    Get
    Set
public:
property String^ Box24IShaded {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24J Property

Box24J Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24J
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24J { get; set; }
Public Property Box24J As String
    Get
    Set
public:
property String^ Box24J {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24JShaded Property

Box24JShaded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24JShaded
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24JShaded { get; set; }
Public Property Box24JShaded As String
    Get
    Set
public:
property String^ Box24JShaded {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24Mod1 Property

Box24Mod1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24Mod1
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24Mod1 { get; set; }
Public Property Box24Mod1 As String
    Get
    Set
public:
property String^ Box24Mod1 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24Mod2 Property

Box24Mod2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24Mod2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24Mod2 { get; set; }
Public Property Box24Mod2 As String
    Get
    Set
public:
property String^ Box24Mod2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24Mod3 Property

Box24Mod3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24Mod3
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24Mod3 { get; set; }
Public Property Box24Mod3 As String
    Get
    Set
public:
property String^ Box24Mod3 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24Mod4 Property

Box24Mod4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Box24 ► Box24Mod4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24Mod4 { get; set; }
Public Property Box24Mod4 As String
    Get
    Set
public:
property String^ Box24Mod4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CMS1500Form Class

CMS1500Form Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMS1500Form
RDPCrystal EDI Library
Represents a CMS 1500 Form
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CMS1500Form : FormBase
Public NotInheritable Class CMS1500Form _
    Inherits FormBase
public ref class CMS1500Form sealed : public FormBase
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CMS1500Form()()()() | Creates a CMS 1500 Form
 | BeforePrint | Event raised before printing or print previewing this form (Inherited from FormBase.)
 | Counter | (Inherited from FormBase.)
 | CreateCells()()()() | (Overrides FormBase.CreateCells()()()().)
 | Data | Get the data to display in the form
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FontColor | Get/set the forecolor of cells (Inherited from FormBase.)
 | form | (Inherited from FormBase.)
 | FormFont | Get/set Print Font (Inherited from FormBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | margins | (Inherited from FormBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumPages | (Inherited from FormBase.)
 | PageSettings | Printer Settings for the form (Inherited from FormBase.)
 | Print()()()() | Prints the CMS1500 Data (Overrides FormBase.Print()()()().)
 | PrintCellRectangle | Get/set whether a rectangle should be printed around each field (Inherited from FormBase.)
 | PrintDocument | Gets the PrintDocument (Inherited from FormBase.)
 | PrinterName | Get/set the name of the printer to send data to (Inherited from FormBase.)
 | PrintMargin | Get/set X and Y starting point (Inherited from FormBase.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FormBase
 |  | CMS1500Form

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CMS1500Form Constructor

CMS1500Form Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMS1500Form ► CMS1500Form()()()()
RDPCrystal EDI Library
Creates a CMS 1500 Form
Declaration Syntax
C# Visual Basic Visual C++
public CMS1500Form()
Public Sub New
public:
CMS1500Form()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CreateCells Method

CreateCells Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMS1500Form ► CreateCells()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateCells()
Protected Overrides Sub CreateCells
protected:
virtual void CreateCells() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMS1500Form ► Data
RDPCrystal EDI Library
Get the data to display in the form
Declaration Syntax
C# Visual Basic Visual C++
public List<CMSFormData> Data { get; }
Public ReadOnly Property Data As List(Of CMSFormData)
    Get
public:
property List<CMSFormData^>^ Data {
    List<CMSFormData^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Print Method

Print Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMS1500Form ► Print()()()()
RDPCrystal EDI Library
Prints the CMS1500 Data
Declaration Syntax
C# Visual Basic Visual C++
public override void Print()
Public Overrides Sub Print
public:
virtual void Print() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CMSFormData Class

CMSFormData Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData
RDPCrystal EDI Library
Represents form fields on a CMS-1500 form
Declaration Syntax
C# Visual Basic Visual C++
public class CMSFormData
Public Class CMSFormData
public ref class CMSFormData
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CMSFormData()()()() | Initializes a new instance of the CMSFormData class
 | Box10Aa |
 | Box10Ab |
 | Box10Ba |
 | Box10Bb |
 | Box10Bc |
 | Box10Ca |
 | Box10Cb |
 | Box10d |
 | Box11 |
 | Box11A |
 | Box11Ab |
 | Box11Ac |
 | Box11B |
 | Box11C |
 | Box11Da |
 | Box11Db |
 | Box12A |
 | Box12B |
 | Box13 |
 | Box14A |
 | Box14B |
 | Box15A |
 | Box15B |
 | Box16A |
 | Box16B |
 | Box17 |
 | Box17A |
 | Box17B |
 | Box18A |
 | Box18B |
 | Box19 |
 | Box1A |
 | Box1Aa |
 | Box1B |
 | Box1C |
 | Box1D |
 | Box1E |
 | Box1F |
 | Box1G |
 | Box2 |
 | Box20Aa |
 | Box20Ab |
 | Box20B |
 | Box21 |
 | Box21A |
 | Box21B |
 | Box21C |
 | Box21D |
 | Box21E |
 | Box21F |
 | Box21G |
 | Box21H |
 | Box21I |
 | Box21J |
 | Box21K |
 | Box21L |
 | Box22A |
 | Box22B |
 | Box23 |
 | Box24 |
 | Box25A |
 | Box25B |
 | Box25C |
 | Box26 |
 | Box27A |
 | Box27B |
 | Box28 |
 | Box29 |
 | Box30 |
 | Box31A |
 | Box31B |
 | Box32 |
 | Box32A |
 | Box33 |
 | Box33A |
 | Box33B |
 | Box33C |
 | Box3A |
 | Box3B |
 | Box3C |
 | Box4 |
 | Box5A |
 | Box5B |
 | Box5C |
 | Box5D |
 | Box5E |
 | Box6A |
 | Box6B |
 | Box6C |
 | Box6D |
 | Box7A |
 | Box7B |
 | Box7C |
 | Box7D |
 | Box7E |
 | Box9 |
 | Box9A |
 | Box9B |
 | Box9C |
 | Box9D |
 | BoxHeader |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateTestData()()()() | Generates sample form fields data
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
CMSFormData

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CMSFormData Constructor

CMSFormData Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► CMSFormData()()()()
RDPCrystal EDI Library
Initializes a new instance of the CMSFormData class
Declaration Syntax
C# Visual Basic Visual C++
public CMSFormData()
Public Sub New
public:
CMSFormData()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Aa Property

Box10Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Aa { get; set; }
Public Property Box10Aa As Boolean
    Get
    Set
public:
property bool Box10Aa {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Ab Property

Box10Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Ab { get; set; }
Public Property Box10Ab As Boolean
    Get
    Set
public:
property bool Box10Ab {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Ba Property

Box10Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Ba { get; set; }
Public Property Box10Ba As Boolean
    Get
    Set
public:
property bool Box10Ba {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Bb Property

Box10Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Bb { get; set; }
Public Property Box10Bb As Boolean
    Get
    Set
public:
property bool Box10Bb {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Bc Property

Box10Bc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Bc
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box10Bc { get; set; }
Public Property Box10Bc As String
    Get
    Set
public:
property String^ Box10Bc {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Ca Property

Box10Ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Ca
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Ca { get; set; }
Public Property Box10Ca As Boolean
    Get
    Set
public:
property bool Box10Ca {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10Cb Property

Box10Cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10Cb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Cb { get; set; }
Public Property Box10Cb As Boolean
    Get
    Set
public:
property bool Box10Cb {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10d Property

Box10d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box10d
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box10d { get; set; }
Public Property Box10d As String
    Get
    Set
public:
property String^ Box10d {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11 Property

Box11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box11 { get; set; }
Public Property Box11 As String
    Get
    Set
public:
property String^ Box11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11A Property

Box11A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box11A { get; set; }
Public Property Box11A As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box11A {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11Ab Property

Box11Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Ab { get; set; }
Public Property Box11Ab As Boolean
    Get
    Set
public:
property bool Box11Ab {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11Ac Property

Box11Ac Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11Ac
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Ac { get; set; }
Public Property Box11Ac As Boolean
    Get
    Set
public:
property bool Box11Ac {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11B Property

Box11B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box11B { get; set; }
Public Property Box11B As String
    Get
    Set
public:
property String^ Box11B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11C Property

Box11C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box11C { get; set; }
Public Property Box11C As String
    Get
    Set
public:
property String^ Box11C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11Da Property

Box11Da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11Da
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Da { get; set; }
Public Property Box11Da As Boolean
    Get
    Set
public:
property bool Box11Da {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11Db Property

Box11Db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box11Db
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Db { get; set; }
Public Property Box11Db As Boolean
    Get
    Set
public:
property bool Box11Db {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box12A Property

Box12A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box12A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box12A { get; set; }
Public Property Box12A As String
    Get
    Set
public:
property String^ Box12A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box12B Property

Box12B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box12B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box12B { get; set; }
Public Property Box12B As String
    Get
    Set
public:
property String^ Box12B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box13 Property

Box13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box13
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box13 { get; set; }
Public Property Box13 As String
    Get
    Set
public:
property String^ Box13 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box14A Property

Box14A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box14A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box14A { get; set; }
Public Property Box14A As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box14A {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box14B Property

Box14B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box14B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box14B { get; set; }
Public Property Box14B As String
    Get
    Set
public:
property String^ Box14B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box15A Property

Box15A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box15A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box15A { get; set; }
Public Property Box15A As String
    Get
    Set
public:
property String^ Box15A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box15B Property

Box15B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box15B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box15B { get; set; }
Public Property Box15B As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box15B {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box16A Property

Box16A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box16A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box16A { get; set; }
Public Property Box16A As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box16A {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box16B Property

Box16B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box16B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box16B { get; set; }
Public Property Box16B As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box16B {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box17 Property

Box17 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box17
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box17 { get; set; }
Public Property Box17 As String
    Get
    Set
public:
property String^ Box17 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box17A Property

Box17A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box17A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box17A { get; set; }
Public Property Box17A As String
    Get
    Set
public:
property String^ Box17A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box17B Property

Box17B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box17B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box17B { get; set; }
Public Property Box17B As String
    Get
    Set
public:
property String^ Box17B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box18A Property

Box18A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box18A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box18A { get; set; }
Public Property Box18A As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box18A {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box18B Property

Box18B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box18B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box18B { get; set; }
Public Property Box18B As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box18B {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box19 Property

Box19 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box19
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box19 { get; set; }
Public Property Box19 As String
    Get
    Set
public:
property String^ Box19 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1A Property

Box1A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1A { get; set; }
Public Property Box1A As Boolean
    Get
    Set
public:
property bool Box1A {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1Aa Property

Box1Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box1Aa { get; set; }
Public Property Box1Aa As String
    Get
    Set
public:
property String^ Box1Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1B Property

Box1B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1B { get; set; }
Public Property Box1B As Boolean
    Get
    Set
public:
property bool Box1B {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1C Property

Box1C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1C { get; set; }
Public Property Box1C As Boolean
    Get
    Set
public:
property bool Box1C {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1D Property

Box1D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1D { get; set; }
Public Property Box1D As Boolean
    Get
    Set
public:
property bool Box1D {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1E Property

Box1E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1E { get; set; }
Public Property Box1E As Boolean
    Get
    Set
public:
property bool Box1E {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1F Property

Box1F Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1F
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1F { get; set; }
Public Property Box1F As Boolean
    Get
    Set
public:
property bool Box1F {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1G Property

Box1G Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box1G
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box1G { get; set; }
Public Property Box1G As Boolean
    Get
    Set
public:
property bool Box1G {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box2 Property

Box2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box2
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box2 { get; set; }
Public Property Box2 As String
    Get
    Set
public:
property String^ Box2 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box20Aa Property

Box20Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box20Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box20Aa { get; set; }
Public Property Box20Aa As Boolean
    Get
    Set
public:
property bool Box20Aa {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box20Ab Property

Box20Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box20Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box20Ab { get; set; }
Public Property Box20Ab As Boolean
    Get
    Set
public:
property bool Box20Ab {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box20B Property

Box20B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box20B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box20B { get; set; }
Public Property Box20B As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box20B {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21 Property

Box21 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21 { get; set; }
Public Property Box21 As String
    Get
    Set
public:
property String^ Box21 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21A Property

Box21A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21A { get; set; }
Public Property Box21A As String
    Get
    Set
public:
property String^ Box21A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21B Property

Box21B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21B { get; set; }
Public Property Box21B As String
    Get
    Set
public:
property String^ Box21B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21C Property

Box21C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21C { get; set; }
Public Property Box21C As String
    Get
    Set
public:
property String^ Box21C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21D Property

Box21D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21D { get; set; }
Public Property Box21D As String
    Get
    Set
public:
property String^ Box21D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21E Property

Box21E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21E { get; set; }
Public Property Box21E As String
    Get
    Set
public:
property String^ Box21E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21F Property

Box21F Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21F
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21F { get; set; }
Public Property Box21F As String
    Get
    Set
public:
property String^ Box21F {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21G Property

Box21G Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21G
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21G { get; set; }
Public Property Box21G As String
    Get
    Set
public:
property String^ Box21G {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21H Property

Box21H Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21H
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21H { get; set; }
Public Property Box21H As String
    Get
    Set
public:
property String^ Box21H {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21I Property

Box21I Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21I
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21I { get; set; }
Public Property Box21I As String
    Get
    Set
public:
property String^ Box21I {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21J Property

Box21J Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21J
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21J { get; set; }
Public Property Box21J As String
    Get
    Set
public:
property String^ Box21J {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21K Property

Box21K Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21K
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21K { get; set; }
Public Property Box21K As String
    Get
    Set
public:
property String^ Box21K {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21L Property

Box21L Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box21L
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21L { get; set; }
Public Property Box21L As String
    Get
    Set
public:
property String^ Box21L {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box22A Property

Box22A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box22A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box22A { get; set; }
Public Property Box22A As String
    Get
    Set
public:
property String^ Box22A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box22B Property

Box22B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box22B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box22B { get; set; }
Public Property Box22B As String
    Get
    Set
public:
property String^ Box22B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box23 Property

Box23 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box23
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box23 { get; set; }
Public Property Box23 As String
    Get
    Set
public:
property String^ Box23 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24 Field

Box24 Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box24
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<Box24> Box24
Public Box24 As List(Of Box24)
public:
List<Box24^>^ Box24

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box25A Property

Box25A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box25A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box25A { get; set; }
Public Property Box25A As String
    Get
    Set
public:
property String^ Box25A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box25B Property

Box25B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box25B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box25B { get; set; }
Public Property Box25B As Boolean
    Get
    Set
public:
property bool Box25B {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box25C Property

Box25C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box25C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box25C { get; set; }
Public Property Box25C As Boolean
    Get
    Set
public:
property bool Box25C {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box26 Property

Box26 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box26
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box26 { get; set; }
Public Property Box26 As String
    Get
    Set
public:
property String^ Box26 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box27A Property

Box27A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box27A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box27A { get; set; }
Public Property Box27A As Boolean
    Get
    Set
public:
property bool Box27A {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box27B Property

Box27B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box27B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box27B { get; set; }
Public Property Box27B As Boolean
    Get
    Set
public:
property bool Box27B {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box28 Property

Box28 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box28
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box28 { get; set; }
Public Property Box28 As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box28 {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box29 Property

Box29 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box29
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box29 { get; set; }
Public Property Box29 As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box29 {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box30 Property

Box30 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box30
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box30 { get; set; }
Public Property Box30 As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box30 {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box31A Property

Box31A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box31A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box31A { get; set; }
Public Property Box31A As String
    Get
    Set
public:
property String^ Box31A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box31B Property

Box31B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box31B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box31B { get; set; }
Public Property Box31B As String
    Get
    Set
public:
property String^ Box31B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box32 Property

Box32 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box32
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box32 { get; set; }
Public Property Box32 As String
    Get
    Set
public:
property String^ Box32 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box32A Property

Box32A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box32A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box32A { get; set; }
Public Property Box32A As String
    Get
    Set
public:
property String^ Box32A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33 Property

Box33 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box33
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box33 { get; set; }
Public Property Box33 As String
    Get
    Set
public:
property String^ Box33 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33A Property

Box33A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box33A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box33A { get; set; }
Public Property Box33A As String
    Get
    Set
public:
property String^ Box33A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33B Property

Box33B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box33B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box33B { get; set; }
Public Property Box33B As String
    Get
    Set
public:
property String^ Box33B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33C Property

Box33C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box33C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box33C { get; set; }
Public Property Box33C As String
    Get
    Set
public:
property String^ Box33C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box3A Property

Box3A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box3A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box3A { get; set; }
Public Property Box3A As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box3A {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box3B Property

Box3B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box3B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box3B { get; set; }
Public Property Box3B As Boolean
    Get
    Set
public:
property bool Box3B {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box3C Property

Box3C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box3C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box3C { get; set; }
Public Property Box3C As Boolean
    Get
    Set
public:
property bool Box3C {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box4 Property

Box4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box4 { get; set; }
Public Property Box4 As String
    Get
    Set
public:
property String^ Box4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box5A Property

Box5A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box5A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box5A { get; set; }
Public Property Box5A As String
    Get
    Set
public:
property String^ Box5A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box5B Property

Box5B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box5B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box5B { get; set; }
Public Property Box5B As String
    Get
    Set
public:
property String^ Box5B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box5C Property

Box5C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box5C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box5C { get; set; }
Public Property Box5C As String
    Get
    Set
public:
property String^ Box5C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box5D Property

Box5D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box5D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box5D { get; set; }
Public Property Box5D As String
    Get
    Set
public:
property String^ Box5D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box5E Property

Box5E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box5E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box5E { get; set; }
Public Property Box5E As String
    Get
    Set
public:
property String^ Box5E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box6A Property

Box6A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box6A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6A { get; set; }
Public Property Box6A As Boolean
    Get
    Set
public:
property bool Box6A {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box6B Property

Box6B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box6B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6B { get; set; }
Public Property Box6B As Boolean
    Get
    Set
public:
property bool Box6B {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box6C Property

Box6C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box6C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6C { get; set; }
Public Property Box6C As Boolean
    Get
    Set
public:
property bool Box6C {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box6D Property

Box6D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box6D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6D { get; set; }
Public Property Box6D As Boolean
    Get
    Set
public:
property bool Box6D {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box7A Property

Box7A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box7A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box7A { get; set; }
Public Property Box7A As String
    Get
    Set
public:
property String^ Box7A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box7B Property

Box7B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box7B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box7B { get; set; }
Public Property Box7B As String
    Get
    Set
public:
property String^ Box7B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box7C Property

Box7C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box7C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box7C { get; set; }
Public Property Box7C As String
    Get
    Set
public:
property String^ Box7C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box7D Property

Box7D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box7D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box7D { get; set; }
Public Property Box7D As String
    Get
    Set
public:
property String^ Box7D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box7E Property

Box7E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box7E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box7E { get; set; }
Public Property Box7E As String
    Get
    Set
public:
property String^ Box7E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9 Property

Box9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box9
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9 { get; set; }
Public Property Box9 As String
    Get
    Set
public:
property String^ Box9 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9A Property

Box9A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box9A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9A { get; set; }
Public Property Box9A As String
    Get
    Set
public:
property String^ Box9A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9B Property

Box9B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box9B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9B { get; set; }
Public Property Box9B As String
    Get
    Set
public:
property String^ Box9B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9C Property

Box9C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box9C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9C { get; set; }
Public Property Box9C As String
    Get
    Set
public:
property String^ Box9C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9D Property

Box9D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► Box9D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9D { get; set; }
Public Property Box9D As String
    Get
    Set
public:
property String^ Box9D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


BoxHeader Property

BoxHeader Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► BoxHeader
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string BoxHeader { get; set; }
Public Property BoxHeader As String
    Get
    Set
public:
property String^ BoxHeader {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GenerateTestData Method

GenerateTestData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► CMSFormData ► GenerateTestData()()()()
RDPCrystal EDI Library
Generates sample form fields data
Declaration Syntax
C# Visual Basic Visual C++
public static CMSFormData GenerateTestData()
Public Shared Function GenerateTestData As CMSFormData
public:
static CMSFormData^ GenerateTestData()
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


DateField Class

DateField Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField
RDPCrystal EDI Library
Represent a date form field. For example 'MM dd yy'
Declaration Syntax
C# Visual Basic Visual C++
public class DateField : FormField
Public Class DateField _
    Inherits FormField
public ref class DateField : public FormField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DateField(String) | Creates a new date field
 | DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double) | Creates a new date field
 | DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment) | Creates a new date field
 | DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new date field
 | Data | Get/set field data
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()()() | Get formatted field data (Overrides FormField.GetText()()()().)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Height of field in cm (Inherited from FormField.)
 | HorizontalAlignment | Get/set horizontal alignment (Inherited from FormField.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/set field name (Inherited from FormField.)
 | RectangleF | Get bounds of field (Inherited from FormField.)
 | ToString()()()() | Gets the string representation of this field (Inherited from FormField.)
 | VerticalAlignment | Get/set vertical alignment (Inherited from FormField.)
 | Width | Width of field in cm (Inherited from FormField.)
 | X | Get/set X offset in cm (Inherited from FormField.)
 | Y | Get/set Y offset in cm (Inherited from FormField.)
Inheritance Hierarchy
Object
 | FormField
 |  | DateField
 |  |  | UB04Date

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


DateField Constructor

DateField Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► DateField()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | DateField(String) | Creates a new date field
 | DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double) | Creates a new date field
 | DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment) | Creates a new date field
 | DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new date field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


DateField Constructor (name)

DateField Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► DateField(String)
RDPCrystal EDI Library
Creates a new date field
Declaration Syntax
C# Visual Basic Visual C++
public DateField(
    string name
)
Public Sub New ( _
    name As String _
)
public:
DateField(
    String^ name
)
Parameters
name (String)
name of field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


DateField Constructor (name, data, x, y, width, height)

DateField Constructor (name, data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double)
RDPCrystal EDI Library
Creates a new date field
Declaration Syntax
C# Visual Basic Visual C++
public DateField(
    string name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of DateTime), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
DateField(
    String^ name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'DateTime>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


DateField Constructor (name, data, x, y, width, height, ha)

DateField Constructor (name, data, x, y, width, height, ha)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment)
RDPCrystal EDI Library
Creates a new date field
Declaration Syntax
C# Visual Basic Visual C++
public DateField(
    string name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of DateTime), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment _
)
public:
DateField(
    String^ name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'DateTime>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


DateField Constructor (name, data, x, y, width, height, sa, lineAlignment)

DateField Constructor (name, data, x, y, width, height, sa, lineAlignment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► DateField(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment, StringAlignment)
RDPCrystal EDI Library
Creates a new date field
Declaration Syntax
C# Visual Basic Visual C++
public DateField(
    string name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of DateTime), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    sa As StringAlignment, _
    lineAlignment As StringAlignment _
)
public:
DateField(
    String^ name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'DateTime>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
sa (StringAlignment)
lineAlignment (StringAlignment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► Data
RDPCrystal EDI Library
Get/set field data
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Data { get; set; }
Public Property Data As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Data {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GetText Method

GetText Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► DateField ► GetText()()()()
RDPCrystal EDI Library
Get formatted field data
Declaration Syntax
C# Visual Basic Visual C++
public override string GetText()
Public Overrides Function GetText As String
public:
virtual String^ GetText() override
Return Value
formatted field data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormBase Class

FormBase Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase
RDPCrystal EDI Library
Base class for all forms
Declaration Syntax
C# Visual Basic Visual C++
public abstract class FormBase
Public MustInherit Class FormBase
public ref class FormBase abstract
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormBase()()()() | Initializes a new instance of the FormBase class
 | BeforePrint | Event raised before printing or print previewing this form
 | Counter |
 | CreateCells()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FontColor | Get/set the forecolor of cells
 | form |
 | FormFont | Get/set Print Font
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | margins |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumPages |
 | PageSettings | Printer Settings for the form
 | Print()()()() | Prints form
 | PrintCellRectangle | Get/set whether a rectangle should be printed around each field
 | PrintDocument | Gets the PrintDocument
 | PrinterName | Get/set the name of the printer to send data to
 | PrintMargin | Get/set X and Y starting point
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FormBase
 |  | CMS1500Form
 |  | UB04Form

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormBase Constructor

FormBase Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► FormBase()()()()
RDPCrystal EDI Library
Initializes a new instance of the FormBase class
Declaration Syntax
C# Visual Basic Visual C++
public FormBase()
Public Sub New
public:
FormBase()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


BeforePrint Event

BeforePrint Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► BeforePrint
RDPCrystal EDI Library
Event raised before printing or print previewing this form
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<FormEventArgs> BeforePrint
Public Event BeforePrint As EventHandler(Of FormEventArgs)
public:
 event EventHandler<FormEventArgs^>^ BeforePrint {
    void add (EventHandler<FormEventArgs^>^ value);
    void remove (EventHandler<FormEventArgs^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Counter Property

Counter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► Counter
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected int Counter { get; set; }
Protected Property Counter As Integer
    Get
    Set
protected:
property int Counter {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CreateCells Method

CreateCells Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► CreateCells()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void CreateCells()
Protected Overridable Sub CreateCells
protected:
virtual void CreateCells()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FontColor Property

FontColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► FontColor
RDPCrystal EDI Library
Get/set the forecolor of cells
Declaration Syntax
C# Visual Basic Visual C++
public Color FontColor { get; set; }
Public Property FontColor As Color
    Get
    Set
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


form Field

form Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► form
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected FormPrinter form
Protected form As FormPrinter
protected:
FormPrinter^ form

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormFont Property

FormFont Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► FormFont
RDPCrystal EDI Library
Get/set Print Font
Declaration Syntax
C# Visual Basic Visual C++
public Font FormFont { get; set; }
Public Property FormFont As Font
    Get
    Set
public:
property Font^ FormFont {
    Font^ get ();
    void set (Font^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


margins Field

margins Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► margins
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected Point margins
Protected margins As Point
protected:
Point margins

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


NumPages Property

NumPages Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► NumPages
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected int NumPages { get; set; }
Protected Property NumPages As Integer
    Get
    Set
protected:
property int NumPages {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PageSettings Property

PageSettings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► PageSettings
RDPCrystal EDI Library
Printer Settings for the form
Declaration Syntax
C# Visual Basic Visual C++
public PageSettings PageSettings { get; }
Public ReadOnly Property PageSettings As PageSettings
    Get
public:
property PageSettings^ PageSettings {
    PageSettings^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Print Method

Print Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► Print()()()()
RDPCrystal EDI Library
Prints form
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Print()
Public Overridable Sub Print
public:
virtual void Print()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrintCellRectangle Property

PrintCellRectangle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► PrintCellRectangle
RDPCrystal EDI Library
Get/set whether a rectangle should be printed around each field
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintCellRectangle { get; set; }
Public Property PrintCellRectangle As Boolean
    Get
    Set
public:
property bool PrintCellRectangle {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrintDocument Property

PrintDocument Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► PrintDocument
RDPCrystal EDI Library
Gets the PrintDocument
Declaration Syntax
C# Visual Basic Visual C++
public PrintDocument PrintDocument { get; }
Public ReadOnly Property PrintDocument As PrintDocument
    Get
public:
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrinterName Property

PrinterName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► PrinterName
RDPCrystal EDI Library
Get/set the name of the printer to send data to
Declaration Syntax
C# Visual Basic Visual C++
public string PrinterName { get; set; }
Public Property PrinterName As String
    Get
    Set
public:
property String^ PrinterName {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrintMargin Property

PrintMargin Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormBase ► PrintMargin
RDPCrystal EDI Library
Get/set X and Y starting point
Declaration Syntax
C# Visual Basic Visual C++
public Point PrintMargin { get; set; }
Public Property PrintMargin As Point
    Get
    Set
public:
property Point PrintMargin {
    Point get ();
    void set (Point value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormEventArgs Class

FormEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormEventArgs
RDPCrystal EDI Library
Represents FormEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class FormEventArgs : EventArgs
Public Class FormEventArgs _
    Inherits EventArgs
public ref class FormEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cells | Get cells that will be printed
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FormEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Cells Property

Cells Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormEventArgs ► Cells
RDPCrystal EDI Library
Get cells that will be printed
Declaration Syntax
C# Visual Basic Visual C++
public List<FormField> Cells { get; }
Public ReadOnly Property Cells As List(Of FormField)
    Get
public:
property List<FormField^>^ Cells {
    List<FormField^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormField Class

FormField Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField
RDPCrystal EDI Library
An object used to encapulate the data of a cell and formatting
Declaration Syntax
C# Visual Basic Visual C++
public abstract class FormField
Public MustInherit Class FormField
public ref class FormField abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormField(String) | Creates a new field
 | FormField(String, Double, Double, Double, Double) | Creates a new field
 | FormField(String, Double, Double, Double, Double, StringAlignment) | Creates a new field
 | FormField(String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new field
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()()() | Get formatted field data
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Height of field in cm
 | HorizontalAlignment | Get/set horizontal alignment
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/set field name
 | RectangleF | Get bounds of field
 | ToString()()()() | Gets the string representation of this field (Overrides Object.ToString()()()().)
 | VerticalAlignment | Get/set vertical alignment
 | Width | Width of field in cm
 | X | Get/set X offset in cm
 | Y | Get/set Y offset in cm
Inheritance Hierarchy
Object
 | FormField
 |  | DateField
 |  | PhoneField
 |  | PriceField
 |  | TextField

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormField Constructor

FormField Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► FormField()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | FormField(String) | Creates a new field
 | FormField(String, Double, Double, Double, Double) | Creates a new field
 | FormField(String, Double, Double, Double, Double, StringAlignment) | Creates a new field
 | FormField(String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormField Constructor (name)

FormField Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► FormField(String)
RDPCrystal EDI Library
Creates a new field
Declaration Syntax
C# Visual Basic Visual C++
public FormField(
    string name
)
Public Sub New ( _
    name As String _
)
public:
FormField(
    String^ name
)
Parameters
name (String)
name of field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormField Constructor (name, x, y, width, height)

FormField Constructor (name, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► FormField(String, Double, Double, Double, Double)
RDPCrystal EDI Library
Creates a new field
Declaration Syntax
C# Visual Basic Visual C++
public FormField(
    string name,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    name As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
FormField(
    String^ name,
    double x,
    double y,
    double width,
    double height
)
Parameters
name (String)
name of field
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormField Constructor (name, x, y, width, height, ha)

FormField Constructor (name, x, y, width, height, ha)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► FormField(String, Double, Double, Double, Double, StringAlignment)
RDPCrystal EDI Library
Creates a new field
Declaration Syntax
C# Visual Basic Visual C++
public FormField(
    string name,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Public Sub New ( _
    name As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment _
)
public:
FormField(
    String^ name,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Parameters
name (String)
name of field
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormField Constructor (name, x, y, width, height, ha, va)

FormField Constructor (name, x, y, width, height, ha, va)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► FormField(String, Double, Double, Double, Double, StringAlignment, StringAlignment)
RDPCrystal EDI Library
Creates a new field
Declaration Syntax
C# Visual Basic Visual C++
public FormField(
    string name,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Public Sub New ( _
    name As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment, _
    va As StringAlignment _
)
public:
FormField(
    String^ name,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Parameters
name (String)
name of field
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment
va (StringAlignment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GetText Method

GetText Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► GetText()()()()
RDPCrystal EDI Library
Get formatted field data
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetText()
Public Overridable Function GetText As String
public:
virtual String^ GetText()
Return Value
formatted field data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► Height
RDPCrystal EDI Library
Height of field in cm
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


HorizontalAlignment Property

HorizontalAlignment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► HorizontalAlignment
RDPCrystal EDI Library
Get/set horizontal alignment
Declaration Syntax
C# Visual Basic Visual C++
public StringAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As StringAlignment
    Get
    Set
public:
property StringAlignment HorizontalAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► Name
RDPCrystal EDI Library
Get/set field name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


RectangleF Property

RectangleF Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► RectangleF
RDPCrystal EDI Library
Get bounds of field
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF RectangleF { get; }
Public ReadOnly Property RectangleF As RectangleF
    Get
public:
property RectangleF RectangleF {
    RectangleF get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► ToString()()()()
RDPCrystal EDI Library
Gets the string representation of this field
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


VerticalAlignment Property

VerticalAlignment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► VerticalAlignment
RDPCrystal EDI Library
Get/set vertical alignment
Declaration Syntax
C# Visual Basic Visual C++
public StringAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As StringAlignment
    Get
    Set
public:
property StringAlignment VerticalAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► Width
RDPCrystal EDI Library
Width of field in cm
Declaration Syntax
C# Visual Basic Visual C++
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


X Property

X Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► X
RDPCrystal EDI Library
Get/set X offset in cm
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; set; }
Public Property X As Double
    Get
    Set
public:
property double X {
    double get ();
    void set (double value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Y Property

Y Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormField ► Y
RDPCrystal EDI Library
Get/set Y offset in cm
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormPrinter Class

FormPrinter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter
RDPCrystal EDI Library
Represents a class that can draw data on an image or printer
Declaration Syntax
C# Visual Basic Visual C++
public class FormPrinter : Component
Public Class FormPrinter _
    Inherits Component
public ref class FormPrinter : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormPrinter(IContainer) | Initializes a new instance of the FormPrinter class
 | FormPrinter()()()() | Initializes a new instance of the FormPrinter class
 | BeforePrint | Event raised before printing or print previewing this form
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Document | Respresents a document that gets printed
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Fields | Fields To Print
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | Font | Font of the Fields
 | FontColor | Set/get printing font color
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImageX | Get/set X position to start printing on the image
 | ImageY | Get/set Y position to start printing on the image
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PageSettings | Get/set and page settings
 | Print()()()() | Prints form
 | Print(Graphics, Single, Single) |
 | PrintCellRectangle | Prints a rectangle around each field
 | PrintToImage(Image) | Print form to Image
 | PrintUppercase | Prints the contents of each field in uppercase
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | FormPrinter

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormPrinter Constructor

FormPrinter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► FormPrinter()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | FormPrinter(IContainer) | Initializes a new instance of the FormPrinter class
 | FormPrinter()()()() | Initializes a new instance of the FormPrinter class

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormPrinter Constructor

FormPrinter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► FormPrinter()()()()
RDPCrystal EDI Library
Initializes a new instance of the FormPrinter class
Declaration Syntax
C# Visual Basic Visual C++
public FormPrinter()
Public Sub New
public:
FormPrinter()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FormPrinter Constructor (container)

FormPrinter Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► FormPrinter(IContainer)
RDPCrystal EDI Library
Initializes a new instance of the FormPrinter class
Declaration Syntax
C# Visual Basic Visual C++
public FormPrinter(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
FormPrinter(
    IContainer^ container
)
Parameters
container (IContainer)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


BeforePrint Event

BeforePrint Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► BeforePrint
RDPCrystal EDI Library
Event raised before printing or print previewing this form
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler BeforePrint
Public Event BeforePrint As EventHandler
public:
 event EventHandler^ BeforePrint {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
True to release both managed and unmanaged resources; false to release only unmanaged resources

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Document Property

Document Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Document
RDPCrystal EDI Library
Respresents a document that gets printed
Declaration Syntax
C# Visual Basic Visual C++
public PrintDocument Document { get; }
Public ReadOnly Property Document As PrintDocument
    Get
public:
property PrintDocument^ Document {
    PrintDocument^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Fields Property

Fields Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Fields
RDPCrystal EDI Library
Fields To Print
Declaration Syntax
C# Visual Basic Visual C++
public List<FormField> Fields { get; }
Public ReadOnly Property Fields As List(Of FormField)
    Get
public:
property List<FormField^>^ Fields {
    List<FormField^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Font Property

Font Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Font
RDPCrystal EDI Library
Font of the Fields
Declaration Syntax
C# Visual Basic Visual C++
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


FontColor Property

FontColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► FontColor
RDPCrystal EDI Library
Set/get printing font color
Declaration Syntax
C# Visual Basic Visual C++
public Color FontColor { get; set; }
Public Property FontColor As Color
    Get
    Set
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ImageX Property

ImageX Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► ImageX
RDPCrystal EDI Library
Get/set X position to start printing on the image
Declaration Syntax
C# Visual Basic Visual C++
public float ImageX { get; set; }
Public Property ImageX As Single
    Get
    Set
public:
property float ImageX {
    float get ();
    void set (float value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ImageY Property

ImageY Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► ImageY
RDPCrystal EDI Library
Get/set Y position to start printing on the image
Declaration Syntax
C# Visual Basic Visual C++
public float ImageY { get; set; }
Public Property ImageY As Single
    Get
    Set
public:
property float ImageY {
    float get ();
    void set (float value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PageSettings Property

PageSettings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► PageSettings
RDPCrystal EDI Library
Get/set and page settings
Declaration Syntax
C# Visual Basic Visual C++
public PageSettings PageSettings { get; set; }
Public Property PageSettings As PageSettings
    Get
    Set
public:
property PageSettings^ PageSettings {
    PageSettings^ get ();
    void set (PageSettings^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Print Method

Print Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Print()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Print()()()() | Prints form
 | Print(Graphics, Single, Single) |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Print Method

Print Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Print()()()()
RDPCrystal EDI Library
Prints form
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Print()
Public Overridable Sub Print
public:
virtual void Print()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Print Method (g, leftMargin, topMargin)

Print Method (g, leftMargin, topMargin)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Print(Graphics, Single, Single)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Print(
    Graphics g,
    float leftMargin,
    float topMargin
)
Public Overridable Sub Print ( _
    g As Graphics, _
    leftMargin As Single, _
    topMargin As Single _
)
public:
virtual void Print(
    Graphics^ g,
    float leftMargin,
    float topMargin
)
Parameters
g (Graphics)
leftMargin (Single)
topMargin (Single)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrintCellRectangle Property

PrintCellRectangle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► PrintCellRectangle
RDPCrystal EDI Library
Prints a rectangle around each field
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintCellRectangle { get; set; }
Public Property PrintCellRectangle As Boolean
    Get
    Set
public:
property bool PrintCellRectangle {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrintToImage Method (image)

PrintToImage Method (image)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► PrintToImage(Image)
RDPCrystal EDI Library
Print form to Image
Declaration Syntax
C# Visual Basic Visual C++
public void PrintToImage(
    Image image
)
Public Sub PrintToImage ( _
    image As Image _
)
public:
void PrintToImage(
    Image^ image
)
Parameters
image (Image)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PrintUppercase Property

PrintUppercase Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► PrintUppercase
RDPCrystal EDI Library
Prints the contents of each field in uppercase
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintUppercase { get; set; }
Public Property PrintUppercase As Boolean
    Get
    Set
public:
property bool PrintUppercase {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


LicenseException Class

LicenseException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► LicenseException
RDPCrystal EDI Library
Exception thrown when a license is invalid
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LicenseException : Exception
<SerializableAttribute> _
Public Class LicenseException _
    Inherits Exception
[SerializableAttribute]
public ref class LicenseException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | LicenseException

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PackageLicense Class

PackageLicense Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PackageLicense
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static class PackageLicense
Public NotInheritable Class PackageLicense
public ref class PackageLicense abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsValidLicense<(Of <<'(T>)>>)(Object) |
 | IsValidLicense()()()() |
 | Key |
Inheritance Hierarchy
Object
PackageLicense

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


IsValidLicense Method

IsValidLicense Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PackageLicense ► IsValidLicense()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | IsValidLicense<(Of <<'(T>)>>)(Object) |
 | IsValidLicense()()()() |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


IsValidLicense Method

IsValidLicense Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PackageLicense ► IsValidLicense()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidLicense()
Public Shared Function IsValidLicense As Boolean
public:
static bool IsValidLicense()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


IsValidLicense Method (instance)

IsValidLicense<(Of <(<'T>)>)> Method (instance)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PackageLicense ► IsValidLicense<(Of <<'(T>)>>)(Object)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidLicense<T>(
    Object instance
)

Public Shared Function IsValidLicense(Of T) ( _
    instance As Object _
) As Boolean
public:
generic<typename T>
static bool IsValidLicense(
    Object^ instance
)
Generic Template Parameters
T
Parameters
instance (Object)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Key Field

Key Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PackageLicense ► Key
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static string Key
Public Shared Key As String
public:
static String^ Key

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PhoneField Class

PhoneField Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField
RDPCrystal EDI Library
Represent a phone form field. For example, '123 2342333'
Declaration Syntax
C# Visual Basic Visual C++
public class PhoneField : FormField
Public Class PhoneField _
    Inherits FormField
public ref class PhoneField : public FormField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PhoneField(String) | Creates a new phone field
 | PhoneField(String, String, Double, Double, Double, Double) | Creates a new phone field
 | PhoneField(String, String, Double, Double, Double, Double, StringAlignment) | Creates a new phone field
 | PhoneField(String, String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new phone field
 | Data | Get/set field data
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()()() | Get formatted field data (Overrides FormField.GetText()()()().)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Height of field in cm (Inherited from FormField.)
 | HorizontalAlignment | Get/set horizontal alignment (Inherited from FormField.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/set field name (Inherited from FormField.)
 | RectangleF | Get bounds of field (Inherited from FormField.)
 | ToString()()()() | Gets the string representation of this field (Inherited from FormField.)
 | VerticalAlignment | Get/set vertical alignment (Inherited from FormField.)
 | Width | Width of field in cm (Inherited from FormField.)
 | X | Get/set X offset in cm (Inherited from FormField.)
 | Y | Get/set Y offset in cm (Inherited from FormField.)
Inheritance Hierarchy
Object
 | FormField
 |  | PhoneField

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PhoneField Constructor

PhoneField Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► PhoneField()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | PhoneField(String) | Creates a new phone field
 | PhoneField(String, String, Double, Double, Double, Double) | Creates a new phone field
 | PhoneField(String, String, Double, Double, Double, Double, StringAlignment) | Creates a new phone field
 | PhoneField(String, String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new phone field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PhoneField Constructor (name)

PhoneField Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► PhoneField(String)
RDPCrystal EDI Library
Creates a new phone field
Declaration Syntax
C# Visual Basic Visual C++
public PhoneField(
    string name
)
Public Sub New ( _
    name As String _
)
public:
PhoneField(
    String^ name
)
Parameters
name (String)
name of field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PhoneField Constructor (name, data, x, y, width, height)

PhoneField Constructor (name, data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► PhoneField(String, String, Double, Double, Double, Double)
RDPCrystal EDI Library
Creates a new phone field
Declaration Syntax
C# Visual Basic Visual C++
public PhoneField(
    string name,
    string data,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
PhoneField(
    String^ name,
    String^ data,
    double x,
    double y,
    double width,
    double height
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PhoneField Constructor (name, data, x, y, width, height, ha)

PhoneField Constructor (name, data, x, y, width, height, ha)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► PhoneField(String, String, Double, Double, Double, Double, StringAlignment)
RDPCrystal EDI Library
Creates a new phone field
Declaration Syntax
C# Visual Basic Visual C++
public PhoneField(
    string name,
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment _
)
public:
PhoneField(
    String^ name,
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PhoneField Constructor (name, data, x, y, width, height, ha, va)

PhoneField Constructor (name, data, x, y, width, height, ha, va)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► PhoneField(String, String, Double, Double, Double, Double, StringAlignment, StringAlignment)
RDPCrystal EDI Library
Creates a new phone field
Declaration Syntax
C# Visual Basic Visual C++
public PhoneField(
    string name,
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment, _
    va As StringAlignment _
)
public:
PhoneField(
    String^ name,
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment
va (StringAlignment)
vertical alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► Data
RDPCrystal EDI Library
Get/set field data
Declaration Syntax
C# Visual Basic Visual C++
public string Data { get; set; }
Public Property Data As String
    Get
    Set
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GetText Method

GetText Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PhoneField ► GetText()()()()
RDPCrystal EDI Library
Get formatted field data
Declaration Syntax
C# Visual Basic Visual C++
public override string GetText()
Public Overrides Function GetText As String
public:
virtual String^ GetText() override
Return Value
formatted field data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PriceField Class

PriceField Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField
RDPCrystal EDI Library
Represent a price/number form field. For example, '123.00'
Declaration Syntax
C# Visual Basic Visual C++
public class PriceField : FormField
Public Class PriceField _
    Inherits FormField
public ref class PriceField : public FormField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PriceField(String) | Creates a new date field
 | PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double) | Creates a new price field
 | PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double, StringAlignment) | Creates a new price field
 | PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new price field
 | Data | Get/set field data
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()()() | Get formatted field data (Overrides FormField.GetText()()()().)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Height of field in cm (Inherited from FormField.)
 | HorizontalAlignment | Get/set horizontal alignment (Inherited from FormField.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/set field name (Inherited from FormField.)
 | RectangleF | Get bounds of field (Inherited from FormField.)
 | ToString()()()() | Gets the string representation of this field (Inherited from FormField.)
 | VerticalAlignment | Get/set vertical alignment (Inherited from FormField.)
 | Width | Width of field in cm (Inherited from FormField.)
 | X | Get/set X offset in cm (Inherited from FormField.)
 | Y | Get/set Y offset in cm (Inherited from FormField.)
Inheritance Hierarchy
Object
 | FormField
 |  | PriceField

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PriceField Constructor

PriceField Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► PriceField()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | PriceField(String) | Creates a new date field
 | PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double) | Creates a new price field
 | PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double, StringAlignment) | Creates a new price field
 | PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new price field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PriceField Constructor (name)

PriceField Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► PriceField(String)
RDPCrystal EDI Library
Creates a new date field
Declaration Syntax
C# Visual Basic Visual C++
public PriceField(
    string name
)
Public Sub New ( _
    name As String _
)
public:
PriceField(
    String^ name
)
Parameters
name (String)
name of field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PriceField Constructor (name, data, x, y, width, height)

PriceField Constructor (name, data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double)
RDPCrystal EDI Library
Creates a new price field
Declaration Syntax
C# Visual Basic Visual C++
public PriceField(
    string name,
    Nullable<decimal> data,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of Decimal), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
PriceField(
    String^ name,
    Nullable<Decimal> data,
    double x,
    double y,
    double width,
    double height
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'Decimal>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PriceField Constructor (name, data, x, y, width, height, ha)

PriceField Constructor (name, data, x, y, width, height, ha)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double, StringAlignment)
RDPCrystal EDI Library
Creates a new price field
Declaration Syntax
C# Visual Basic Visual C++
public PriceField(
    string name,
    Nullable<decimal> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of Decimal), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment _
)
public:
PriceField(
    String^ name,
    Nullable<Decimal> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'Decimal>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


PriceField Constructor (name, data, x, y, width, height, ha, va)

PriceField Constructor (name, data, x, y, width, height, ha, va)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► PriceField(String, Nullable<(Of <<'(Decimal>)>>), Double, Double, Double, Double, StringAlignment, StringAlignment)
RDPCrystal EDI Library
Creates a new price field
Declaration Syntax
C# Visual Basic Visual C++
public PriceField(
    string name,
    Nullable<decimal> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of Decimal), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment, _
    va As StringAlignment _
)
public:
PriceField(
    String^ name,
    Nullable<Decimal> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'Decimal>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment
va (StringAlignment)
vertical alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► Data
RDPCrystal EDI Library
Get/set field data
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Data { get; set; }
Public Property Data As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Data {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GetText Method

GetText Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► PriceField ► GetText()()()()
RDPCrystal EDI Library
Get formatted field data
Declaration Syntax
C# Visual Basic Visual C++
public override string GetText()
Public Overrides Function GetText As String
public:
virtual String^ GetText() override
Return Value
formatted field data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Service Class

Service Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class Service
Public Class Service
public ref class Service
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Service()()()() | Initializes a new instance of the Service class
 | Box42 |
 | Box43 |
 | Box44 |
 | Box45 |
 | Box46 |
 | Box47 |
 | Box48 |
 | Box49 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Service

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Service Constructor

Service Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Service()()()()
RDPCrystal EDI Library
Initializes a new instance of the Service class
Declaration Syntax
C# Visual Basic Visual C++
public Service()
Public Sub New
public:
Service()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box42 Property

Box42 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box42
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box42 { get; set; }
Public Property Box42 As String
    Get
    Set
public:
property String^ Box42 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box43 Property

Box43 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box43
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box43 { get; set; }
Public Property Box43 As String
    Get
    Set
public:
property String^ Box43 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box44 Property

Box44 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box44
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box44 { get; set; }
Public Property Box44 As String
    Get
    Set
public:
property String^ Box44 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box45 Property

Box45 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box45
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box45 { get; set; }
Public Property Box45 As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box45 {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box46 Property

Box46 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box46
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box46 { get; set; }
Public Property Box46 As String
    Get
    Set
public:
property String^ Box46 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box47 Property

Box47 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box47
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box47 { get; set; }
Public Property Box47 As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box47 {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box48 Property

Box48 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box48
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box48 { get; set; }
Public Property Box48 As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box48 {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box49 Property

Box49 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► Service ► Box49
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box49 { get; set; }
Public Property Box49 As String
    Get
    Set
public:
property String^ Box49 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Class

TextField Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField
RDPCrystal EDI Library
Represent a text form field
Declaration Syntax
C# Visual Basic Visual C++
public class TextField : FormField
Public Class TextField _
    Inherits FormField
public ref class TextField : public FormField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextField(String) | Creates a new text field
 | TextField(String, String, Double, Double, Double, Double) | Creates a new text field
 | TextField(String, String, Double, Double, Double, Double, StringAlignment) | Creates a new text field
 | TextField(String, String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new text field
 | TextField(String, String, Double, Double, SizeF, StringAlignment, StringAlignment) | Creates a new text field
 | Data | Get/set field data
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()()() | Get formatted field data (Overrides FormField.GetText()()()().)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Height of field in cm (Inherited from FormField.)
 | HorizontalAlignment | Get/set horizontal alignment (Inherited from FormField.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/set field name (Inherited from FormField.)
 | RectangleF | Get bounds of field (Inherited from FormField.)
 | ToString()()()() | Gets the string representation of this field (Inherited from FormField.)
 | VerticalAlignment | Get/set vertical alignment (Inherited from FormField.)
 | Width | Width of field in cm (Inherited from FormField.)
 | X | Get/set X offset in cm (Inherited from FormField.)
 | Y | Get/set Y offset in cm (Inherited from FormField.)
Inheritance Hierarchy
Object
 | FormField
 |  | TextField

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Constructor

TextField Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► TextField()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | TextField(String) | Creates a new text field
 | TextField(String, String, Double, Double, Double, Double) | Creates a new text field
 | TextField(String, String, Double, Double, Double, Double, StringAlignment) | Creates a new text field
 | TextField(String, String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a new text field
 | TextField(String, String, Double, Double, SizeF, StringAlignment, StringAlignment) | Creates a new text field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Constructor (name)

TextField Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► TextField(String)
RDPCrystal EDI Library
Creates a new text field
Declaration Syntax
C# Visual Basic Visual C++
public TextField(
    string name
)
Public Sub New ( _
    name As String _
)
public:
TextField(
    String^ name
)
Parameters
name (String)
name of field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Constructor (name, data, x, y, width, height)

TextField Constructor (name, data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► TextField(String, String, Double, Double, Double, Double)
RDPCrystal EDI Library
Creates a new text field
Declaration Syntax
C# Visual Basic Visual C++
public TextField(
    string name,
    string data,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
TextField(
    String^ name,
    String^ data,
    double x,
    double y,
    double width,
    double height
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Constructor (name, data, x, y, width, height, ha)

TextField Constructor (name, data, x, y, width, height, ha)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► TextField(String, String, Double, Double, Double, Double, StringAlignment)
RDPCrystal EDI Library
Creates a new text field
Declaration Syntax
C# Visual Basic Visual C++
public TextField(
    string name,
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment _
)
public:
TextField(
    String^ name,
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Constructor (name, data, x, y, width, height, ha, va)

TextField Constructor (name, data, x, y, width, height, ha, va)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► TextField(String, String, Double, Double, Double, Double, StringAlignment, StringAlignment)
RDPCrystal EDI Library
Creates a new text field
Declaration Syntax
C# Visual Basic Visual C++
public TextField(
    string name,
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment, _
    va As StringAlignment _
)
public:
TextField(
    String^ name,
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha,
    StringAlignment va
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment
va (StringAlignment)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


TextField Constructor (name, data, x, y, s, ha, va)

TextField Constructor (name, data, x, y, s, ha, va)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► TextField(String, String, Double, Double, SizeF, StringAlignment, StringAlignment)
RDPCrystal EDI Library
Creates a new text field
Declaration Syntax
C# Visual Basic Visual C++
public TextField(
    string name,
    string data,
    double x,
    double y,
    SizeF s,
    StringAlignment ha,
    StringAlignment va
)
Public Sub New ( _
    name As String, _
    data As String, _
    x As Double, _
    y As Double, _
    s As SizeF, _
    ha As StringAlignment, _
    va As StringAlignment _
)
public:
TextField(
    String^ name,
    String^ data,
    double x,
    double y,
    SizeF s,
    StringAlignment ha,
    StringAlignment va
)
Parameters
name (String)
name of field
data (String)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
s (SizeF)
ha (StringAlignment)
horizontal alignment
va (StringAlignment)
vertical alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► Data
RDPCrystal EDI Library
Get/set field data
Declaration Syntax
C# Visual Basic Visual C++
public string Data { get; set; }
Public Property Data As String
    Get
    Set
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GetText Method

GetText Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► TextField ► GetText()()()()
RDPCrystal EDI Library
Get formatted field data
Declaration Syntax
C# Visual Basic Visual C++
public override string GetText()
Public Overrides Function GetText As String
public:
virtual String^ GetText() override
Return Value
formatted field data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04Date Class

UB04Date Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Date
RDPCrystal EDI Library
Represent a UB04 date form field. For example 'MMddyy'
Declaration Syntax
C# Visual Basic Visual C++
public class UB04Date : DateField
Public Class UB04Date _
    Inherits DateField
public ref class UB04Date : public DateField
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UB04Date(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double) | Creates a new UB04Date field
 | UB04Date(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment) | Creates a new UB04Date field
 | Data | Get/set field data (Inherited from DateField.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()()() | Get formatted field data (Overrides DateField.GetText()()()().)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Height of field in cm (Inherited from FormField.)
 | HorizontalAlignment | Get/set horizontal alignment (Inherited from FormField.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/set field name (Inherited from FormField.)
 | RectangleF | Get bounds of field (Inherited from FormField.)
 | ToString()()()() | Gets the string representation of this field (Inherited from FormField.)
 | VerticalAlignment | Get/set vertical alignment (Inherited from FormField.)
 | Width | Width of field in cm (Inherited from FormField.)
 | X | Get/set X offset in cm (Inherited from FormField.)
 | Y | Get/set Y offset in cm (Inherited from FormField.)
Inheritance Hierarchy
Object
 | FormField
 |  | DateField
 |  |  | UB04Date

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04Date Constructor

UB04Date Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Date ► UB04Date()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | UB04Date(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double) | Creates a new UB04Date field
 | UB04Date(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment) | Creates a new UB04Date field

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04Date Constructor (name, data, x, y, width, height)

UB04Date Constructor (name, data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Date ► UB04Date(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double)
RDPCrystal EDI Library
Creates a new UB04Date field
Declaration Syntax
C# Visual Basic Visual C++
public UB04Date(
    string name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of DateTime), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
UB04Date(
    String^ name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'DateTime>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04Date Constructor (name, data, x, y, width, height, ha)

UB04Date Constructor (name, data, x, y, width, height, ha)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Date ► UB04Date(String, Nullable<(Of <<'(DateTime>)>>), Double, Double, Double, Double, StringAlignment)
RDPCrystal EDI Library
Creates a new UB04Date field
Declaration Syntax
C# Visual Basic Visual C++
public UB04Date(
    string name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Public Sub New ( _
    name As String, _
    data As Nullable(Of DateTime), _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    ha As StringAlignment _
)
public:
UB04Date(
    String^ name,
    Nullable<DateTime> data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment ha
)
Parameters
name (String)
name of field
data (Nullable<(Of <(<'DateTime>)>)>)
field data
x (Double)
x location (in cm)
y (Double)
y location (in cm)
width (Double)
width of field (in cm)
height (Double)
height of field (in cm)
ha (StringAlignment)
horizontal alignment

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GetText Method

GetText Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Date ► GetText()()()()
RDPCrystal EDI Library
Get formatted field data
Declaration Syntax
C# Visual Basic Visual C++
public override string GetText()
Public Overrides Function GetText As String
public:
virtual String^ GetText() override
Return Value
formatted field data

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04Form Class

UB04Form Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Form
RDPCrystal EDI Library
Represents a UB04 Form
Declaration Syntax
C# Visual Basic Visual C++
public sealed class UB04Form : FormBase
Public NotInheritable Class UB04Form _
    Inherits FormBase
public ref class UB04Form sealed : public FormBase
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UB04Form()()()() | Creates a UB04 Form
 | BeforePrint | Event raised before printing or print previewing this form (Inherited from FormBase.)
 | Counter | (Inherited from FormBase.)
 | CreateCells()()()() | (Overrides FormBase.CreateCells()()()().)
 | Data | Get/set the data to display in the form
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FontColor | Get/set the forecolor of cells (Inherited from FormBase.)
 | form | (Inherited from FormBase.)
 | FormFont | Get/set Print Font (Inherited from FormBase.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | margins | (Inherited from FormBase.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumPages | (Inherited from FormBase.)
 | PageSettings | Printer Settings for the form (Inherited from FormBase.)
 | Print()()()() | Prints form (Inherited from FormBase.)
 | PrintCellRectangle | Get/set whether a rectangle should be printed around each field (Inherited from FormBase.)
 | PrintDocument | Gets the PrintDocument (Inherited from FormBase.)
 | PrinterName | Get/set the name of the printer to send data to (Inherited from FormBase.)
 | PrintMargin | Get/set X and Y starting point (Inherited from FormBase.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | FormBase
 |  | UB04Form

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04Form Constructor

UB04Form Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Form ► UB04Form()()()()
RDPCrystal EDI Library
Creates a UB04 Form
Declaration Syntax
C# Visual Basic Visual C++
public UB04Form()
Public Sub New
public:
UB04Form()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


CreateCells Method

CreateCells Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Form ► CreateCells()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected override void CreateCells()
Protected Overrides Sub CreateCells
protected:
virtual void CreateCells() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04Form ► Data
RDPCrystal EDI Library
Get/set the data to display in the form
Declaration Syntax
C# Visual Basic Visual C++
public List<UB04FormData> Data { get; }
Public ReadOnly Property Data As List(Of UB04FormData)
    Get
public:
property List<UB04FormData^>^ Data {
    List<UB04FormData^>^ get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04FormData Class

UB04FormData Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class UB04FormData
Public Class UB04FormData
public ref class UB04FormData
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UB04FormData()()()() | Initializes a new instance of the UB04FormData class
 | Box10 |
 | Box11 |
 | Box12 |
 | Box13 |
 | Box14 |
 | Box15 |
 | Box16 |
 | Box17 |
 | Box18 |
 | Box19 |
 | Box1A |
 | Box1B |
 | Box1C |
 | Box1D |
 | Box20 |
 | Box21 |
 | Box22 |
 | Box23 |
 | Box24 |
 | Box25 |
 | Box26 |
 | Box27 |
 | Box28 |
 | Box29 |
 | Box2A |
 | Box2B |
 | Box2C |
 | Box2D |
 | Box30 |
 | Box31Aa |
 | Box31Ab |
 | Box31Ba |
 | Box31Bb |
 | Box32Aa |
 | Box32Ab |
 | Box32Ba |
 | Box32Bb |
 | Box33Aa |
 | Box33Ab |
 | Box33Ba |
 | Box33Bb |
 | Box34Aa |
 | Box34Ab |
 | Box34Ba |
 | Box34Bb |
 | Box35Aa |
 | Box35Ab |
 | Box35Ac |
 | Box35Ba |
 | Box35Bb |
 | Box35Bc |
 | Box36Aa |
 | Box36Ab |
 | Box36Ac |
 | Box36Ba |
 | Box36Bb |
 | Box36Bc |
 | Box37A |
 | Box37B |
 | Box38 |
 | Box39Aa |
 | Box39Ab |
 | Box39Ba |
 | Box39Bb |
 | Box39Ca |
 | Box39Cb |
 | Box39Da |
 | Box39Db |
 | Box3A |
 | Box3B |
 | Box4 |
 | Box40Aa |
 | Box40Ab |
 | Box40Ba |
 | Box40Bb |
 | Box40Ca |
 | Box40Cb |
 | Box40Da |
 | Box40Db |
 | Box41Aa |
 | Box41Ab |
 | Box41Ba |
 | Box41Bb |
 | Box41Ca |
 | Box41Cb |
 | Box41Da |
 | Box41Db |
 | Box5 |
 | Box50A |
 | Box50B |
 | Box50C |
 | Box51A |
 | Box51B |
 | Box51C |
 | Box52A |
 | Box52B |
 | Box52C |
 | Box53A |
 | Box53B |
 | Box53C |
 | Box54A |
 | Box54B |
 | Box54C |
 | Box55A |
 | Box55B |
 | Box55C |
 | Box56 |
 | Box57A |
 | Box57B |
 | Box57C |
 | Box58A |
 | Box58B |
 | Box58C |
 | Box59A |
 | Box59B |
 | Box59C |
 | Box60A |
 | Box60B |
 | Box60C |
 | Box61A |
 | Box61B |
 | Box61C |
 | Box62A |
 | Box62B |
 | Box62C |
 | Box63A |
 | Box63B |
 | Box63C |
 | Box64A |
 | Box64B |
 | Box64C |
 | Box65A |
 | Box65B |
 | Box65C |
 | Box66 |
 | Box67 |
 | Box67A |
 | Box67B |
 | Box67C |
 | Box67D |
 | Box67E |
 | Box67F |
 | Box67G |
 | Box67H |
 | Box67I |
 | Box67J |
 | Box67K |
 | Box67L |
 | Box67M |
 | Box67N |
 | Box67O |
 | Box67P |
 | Box67Q |
 | Box68A |
 | Box68B |
 | Box69 |
 | Box6A |
 | Box6B |
 | Box7 |
 | Box70A |
 | Box70B |
 | Box70C |
 | Box71 |
 | Box72A |
 | Box72B |
 | Box72C |
 | Box73 |
 | Box74A |
 | Box74aa |
 | Box74ab |
 | Box74B |
 | Box74ba |
 | Box74bb |
 | Box74ca |
 | Box74cb |
 | Box74da |
 | Box74db |
 | Box74ea |
 | Box74eb |
 | Box75 |
 | Box76A |
 | Box76B |
 | Box76C |
 | Box76D |
 | Box76E |
 | Box77A |
 | Box77B |
 | Box77C |
 | Box77D |
 | Box77E |
 | Box78A |
 | Box78B |
 | Box78C |
 | Box78D |
 | Box78E |
 | Box79A |
 | Box79B |
 | Box79C |
 | Box79D |
 | Box79E |
 | Box80 |
 | Box81Aa |
 | Box81Ab |
 | Box81Ac |
 | Box81Ba |
 | Box81Bb |
 | Box81Bc |
 | Box81Ca |
 | Box81Cb |
 | Box81Cc |
 | Box81Da |
 | Box81Db |
 | Box81Dc |
 | Box8A |
 | Box8B |
 | Box9A |
 | Box9B |
 | Box9C |
 | Box9D |
 | Box9E |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateTestData()()()() |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ServiceLineBox23A |
 | ServiceLineBox23B |
 | ServiceLineBox23C |
 | ServiceLineBox23D |
 | ServiceLineBox23E |
 | Services |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UB04FormData

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


UB04FormData Constructor

UB04FormData Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► UB04FormData()()()()
RDPCrystal EDI Library
Initializes a new instance of the UB04FormData class
Declaration Syntax
C# Visual Basic Visual C++
public UB04FormData()
Public Sub New
public:
UB04FormData()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box10 Property

Box10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box10
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box10 { get; set; }
Public Property Box10 As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box10 {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box11 Property

Box11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box11
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box11 { get; set; }
Public Property Box11 As String
    Get
    Set
public:
property String^ Box11 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box12 Property

Box12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box12
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box12 { get; set; }
Public Property Box12 As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box12 {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box13 Property

Box13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box13
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box13 { get; set; }
Public Property Box13 As String
    Get
    Set
public:
property String^ Box13 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box14 Property

Box14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box14
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box14 { get; set; }
Public Property Box14 As String
    Get
    Set
public:
property String^ Box14 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box15 Property

Box15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box15
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box15 { get; set; }
Public Property Box15 As String
    Get
    Set
public:
property String^ Box15 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box16 Property

Box16 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box16
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box16 { get; set; }
Public Property Box16 As String
    Get
    Set
public:
property String^ Box16 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box17 Property

Box17 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box17
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box17 { get; set; }
Public Property Box17 As String
    Get
    Set
public:
property String^ Box17 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box18 Property

Box18 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box18
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box18 { get; set; }
Public Property Box18 As String
    Get
    Set
public:
property String^ Box18 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box19 Property

Box19 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box19
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box19 { get; set; }
Public Property Box19 As String
    Get
    Set
public:
property String^ Box19 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1A Property

Box1A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box1A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box1A { get; set; }
Public Property Box1A As String
    Get
    Set
public:
property String^ Box1A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1B Property

Box1B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box1B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box1B { get; set; }
Public Property Box1B As String
    Get
    Set
public:
property String^ Box1B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1C Property

Box1C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box1C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box1C { get; set; }
Public Property Box1C As String
    Get
    Set
public:
property String^ Box1C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box1D Property

Box1D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box1D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box1D { get; set; }
Public Property Box1D As String
    Get
    Set
public:
property String^ Box1D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box20 Property

Box20 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box20
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box20 { get; set; }
Public Property Box20 As String
    Get
    Set
public:
property String^ Box20 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box21 Property

Box21 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box21
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box21 { get; set; }
Public Property Box21 As String
    Get
    Set
public:
property String^ Box21 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box22 Property

Box22 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box22
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box22 { get; set; }
Public Property Box22 As String
    Get
    Set
public:
property String^ Box22 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box23 Property

Box23 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box23
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box23 { get; set; }
Public Property Box23 As String
    Get
    Set
public:
property String^ Box23 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box24 Property

Box24 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box24
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box24 { get; set; }
Public Property Box24 As String
    Get
    Set
public:
property String^ Box24 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box25 Property

Box25 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box25
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box25 { get; set; }
Public Property Box25 As String
    Get
    Set
public:
property String^ Box25 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box26 Property

Box26 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box26
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box26 { get; set; }
Public Property Box26 As String
    Get
    Set
public:
property String^ Box26 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box27 Property

Box27 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box27
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box27 { get; set; }
Public Property Box27 As String
    Get
    Set
public:
property String^ Box27 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box28 Property

Box28 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box28
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box28 { get; set; }
Public Property Box28 As String
    Get
    Set
public:
property String^ Box28 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box29 Property

Box29 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box29
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box29 { get; set; }
Public Property Box29 As String
    Get
    Set
public:
property String^ Box29 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box2A Property

Box2A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box2A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box2A { get; set; }
Public Property Box2A As String
    Get
    Set
public:
property String^ Box2A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box2B Property

Box2B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box2B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box2B { get; set; }
Public Property Box2B As String
    Get
    Set
public:
property String^ Box2B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box2C Property

Box2C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box2C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box2C { get; set; }
Public Property Box2C As String
    Get
    Set
public:
property String^ Box2C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box2D Property

Box2D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box2D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box2D { get; set; }
Public Property Box2D As String
    Get
    Set
public:
property String^ Box2D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box30 Property

Box30 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box30
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box30 { get; set; }
Public Property Box30 As String
    Get
    Set
public:
property String^ Box30 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box31Aa Property

Box31Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box31Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box31Aa { get; set; }
Public Property Box31Aa As String
    Get
    Set
public:
property String^ Box31Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box31Ab Property

Box31Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box31Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box31Ab { get; set; }
Public Property Box31Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box31Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box31Ba Property

Box31Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box31Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box31Ba { get; set; }
Public Property Box31Ba As String
    Get
    Set
public:
property String^ Box31Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box31Bb Property

Box31Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box31Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box31Bb { get; set; }
Public Property Box31Bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box31Bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box32Aa Property

Box32Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box32Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box32Aa { get; set; }
Public Property Box32Aa As String
    Get
    Set
public:
property String^ Box32Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box32Ab Property

Box32Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box32Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box32Ab { get; set; }
Public Property Box32Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box32Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box32Ba Property

Box32Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box32Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box32Ba { get; set; }
Public Property Box32Ba As String
    Get
    Set
public:
property String^ Box32Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box32Bb Property

Box32Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box32Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box32Bb { get; set; }
Public Property Box32Bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box32Bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33Aa Property

Box33Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box33Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box33Aa { get; set; }
Public Property Box33Aa As String
    Get
    Set
public:
property String^ Box33Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33Ab Property

Box33Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box33Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box33Ab { get; set; }
Public Property Box33Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box33Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33Ba Property

Box33Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box33Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box33Ba { get; set; }
Public Property Box33Ba As String
    Get
    Set
public:
property String^ Box33Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box33Bb Property

Box33Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box33Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box33Bb { get; set; }
Public Property Box33Bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box33Bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box34Aa Property

Box34Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box34Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box34Aa { get; set; }
Public Property Box34Aa As String
    Get
    Set
public:
property String^ Box34Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box34Ab Property

Box34Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box34Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box34Ab { get; set; }
Public Property Box34Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box34Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box34Ba Property

Box34Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box34Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box34Ba { get; set; }
Public Property Box34Ba As String
    Get
    Set
public:
property String^ Box34Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box34Bb Property

Box34Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box34Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box34Bb { get; set; }
Public Property Box34Bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box34Bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box35Aa Property

Box35Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box35Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box35Aa { get; set; }
Public Property Box35Aa As String
    Get
    Set
public:
property String^ Box35Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box35Ab Property

Box35Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box35Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box35Ab { get; set; }
Public Property Box35Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box35Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box35Ac Property

Box35Ac Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box35Ac
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box35Ac { get; set; }
Public Property Box35Ac As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box35Ac {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box35Ba Property

Box35Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box35Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box35Ba { get; set; }
Public Property Box35Ba As String
    Get
    Set
public:
property String^ Box35Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box35Bb Property

Box35Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box35Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box35Bb { get; set; }
Public Property Box35Bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box35Bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box35Bc Property

Box35Bc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box35Bc
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box35Bc { get; set; }
Public Property Box35Bc As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box35Bc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box36Aa Property

Box36Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box36Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box36Aa { get; set; }
Public Property Box36Aa As String
    Get
    Set
public:
property String^ Box36Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box36Ab Property

Box36Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box36Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box36Ab { get; set; }
Public Property Box36Ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box36Ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box36Ac Property

Box36Ac Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box36Ac
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box36Ac { get; set; }
Public Property Box36Ac As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box36Ac {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box36Ba Property

Box36Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box36Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box36Ba { get; set; }
Public Property Box36Ba As String
    Get
    Set
public:
property String^ Box36Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box36Bb Property

Box36Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box36Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box36Bb { get; set; }
Public Property Box36Bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box36Bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box36Bc Property

Box36Bc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box36Bc
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box36Bc { get; set; }
Public Property Box36Bc As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box36Bc {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box37A Property

Box37A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box37A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box37A { get; set; }
Public Property Box37A As String
    Get
    Set
public:
property String^ Box37A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box37B Property

Box37B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box37B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box37B { get; set; }
Public Property Box37B As String
    Get
    Set
public:
property String^ Box37B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box38 Property

Box38 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box38
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box38 { get; set; }
Public Property Box38 As String
    Get
    Set
public:
property String^ Box38 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Aa Property

Box39Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box39Aa { get; set; }
Public Property Box39Aa As String
    Get
    Set
public:
property String^ Box39Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Ab Property

Box39Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box39Ab { get; set; }
Public Property Box39Ab As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box39Ab {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Ba Property

Box39Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box39Ba { get; set; }
Public Property Box39Ba As String
    Get
    Set
public:
property String^ Box39Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Bb Property

Box39Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box39Bb { get; set; }
Public Property Box39Bb As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box39Bb {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Ca Property

Box39Ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Ca
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box39Ca { get; set; }
Public Property Box39Ca As String
    Get
    Set
public:
property String^ Box39Ca {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Cb Property

Box39Cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Cb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box39Cb { get; set; }
Public Property Box39Cb As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box39Cb {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Da Property

Box39Da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Da
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box39Da { get; set; }
Public Property Box39Da As String
    Get
    Set
public:
property String^ Box39Da {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box39Db Property

Box39Db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box39Db
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box39Db { get; set; }
Public Property Box39Db As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box39Db {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box3A Property

Box3A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box3A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box3A { get; set; }
Public Property Box3A As String
    Get
    Set
public:
property String^ Box3A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box3B Property

Box3B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box3B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box3B { get; set; }
Public Property Box3B As String
    Get
    Set
public:
property String^ Box3B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box4 Property

Box4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box4
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box4 { get; set; }
Public Property Box4 As String
    Get
    Set
public:
property String^ Box4 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Aa Property

Box40Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box40Aa { get; set; }
Public Property Box40Aa As String
    Get
    Set
public:
property String^ Box40Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Ab Property

Box40Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box40Ab { get; set; }
Public Property Box40Ab As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box40Ab {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Ba Property

Box40Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box40Ba { get; set; }
Public Property Box40Ba As String
    Get
    Set
public:
property String^ Box40Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Bb Property

Box40Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box40Bb { get; set; }
Public Property Box40Bb As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box40Bb {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Ca Property

Box40Ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Ca
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box40Ca { get; set; }
Public Property Box40Ca As String
    Get
    Set
public:
property String^ Box40Ca {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Cb Property

Box40Cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Cb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box40Cb { get; set; }
Public Property Box40Cb As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box40Cb {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Da Property

Box40Da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Da
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box40Da { get; set; }
Public Property Box40Da As String
    Get
    Set
public:
property String^ Box40Da {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box40Db Property

Box40Db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box40Db
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box40Db { get; set; }
Public Property Box40Db As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box40Db {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Aa Property

Box41Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box41Aa { get; set; }
Public Property Box41Aa As String
    Get
    Set
public:
property String^ Box41Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Ab Property

Box41Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box41Ab { get; set; }
Public Property Box41Ab As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box41Ab {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Ba Property

Box41Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box41Ba { get; set; }
Public Property Box41Ba As String
    Get
    Set
public:
property String^ Box41Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Bb Property

Box41Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box41Bb { get; set; }
Public Property Box41Bb As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box41Bb {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Ca Property

Box41Ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Ca
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box41Ca { get; set; }
Public Property Box41Ca As String
    Get
    Set
public:
property String^ Box41Ca {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Cb Property

Box41Cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Cb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box41Cb { get; set; }
Public Property Box41Cb As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box41Cb {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Da Property

Box41Da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Da
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box41Da { get; set; }
Public Property Box41Da As String
    Get
    Set
public:
property String^ Box41Da {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box41Db Property

Box41Db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box41Db
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box41Db { get; set; }
Public Property Box41Db As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box41Db {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box5 Property

Box5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box5
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box5 { get; set; }
Public Property Box5 As String
    Get
    Set
public:
property String^ Box5 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box50A Property

Box50A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box50A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box50A { get; set; }
Public Property Box50A As String
    Get
    Set
public:
property String^ Box50A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box50B Property

Box50B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box50B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box50B { get; set; }
Public Property Box50B As String
    Get
    Set
public:
property String^ Box50B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box50C Property

Box50C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box50C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box50C { get; set; }
Public Property Box50C As String
    Get
    Set
public:
property String^ Box50C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box51A Property

Box51A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box51A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box51A { get; set; }
Public Property Box51A As String
    Get
    Set
public:
property String^ Box51A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box51B Property

Box51B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box51B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box51B { get; set; }
Public Property Box51B As String
    Get
    Set
public:
property String^ Box51B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box51C Property

Box51C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box51C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box51C { get; set; }
Public Property Box51C As String
    Get
    Set
public:
property String^ Box51C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box52A Property

Box52A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box52A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box52A { get; set; }
Public Property Box52A As String
    Get
    Set
public:
property String^ Box52A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box52B Property

Box52B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box52B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box52B { get; set; }
Public Property Box52B As String
    Get
    Set
public:
property String^ Box52B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box52C Property

Box52C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box52C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box52C { get; set; }
Public Property Box52C As String
    Get
    Set
public:
property String^ Box52C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box53A Property

Box53A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box53A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box53A { get; set; }
Public Property Box53A As String
    Get
    Set
public:
property String^ Box53A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box53B Property

Box53B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box53B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box53B { get; set; }
Public Property Box53B As String
    Get
    Set
public:
property String^ Box53B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box53C Property

Box53C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box53C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box53C { get; set; }
Public Property Box53C As String
    Get
    Set
public:
property String^ Box53C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box54A Property

Box54A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box54A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box54A { get; set; }
Public Property Box54A As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box54A {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box54B Property

Box54B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box54B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box54B { get; set; }
Public Property Box54B As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box54B {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box54C Property

Box54C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box54C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box54C { get; set; }
Public Property Box54C As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box54C {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box55A Property

Box55A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box55A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box55A { get; set; }
Public Property Box55A As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box55A {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box55B Property

Box55B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box55B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box55B { get; set; }
Public Property Box55B As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box55B {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box55C Property

Box55C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box55C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> Box55C { get; set; }
Public Property Box55C As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> Box55C {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box56 Property

Box56 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box56
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box56 { get; set; }
Public Property Box56 As String
    Get
    Set
public:
property String^ Box56 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box57A Property

Box57A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box57A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box57A { get; set; }
Public Property Box57A As String
    Get
    Set
public:
property String^ Box57A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box57B Property

Box57B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box57B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box57B { get; set; }
Public Property Box57B As String
    Get
    Set
public:
property String^ Box57B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box57C Property

Box57C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box57C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box57C { get; set; }
Public Property Box57C As String
    Get
    Set
public:
property String^ Box57C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box58A Property

Box58A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box58A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box58A { get; set; }
Public Property Box58A As String
    Get
    Set
public:
property String^ Box58A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box58B Property

Box58B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box58B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box58B { get; set; }
Public Property Box58B As String
    Get
    Set
public:
property String^ Box58B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box58C Property

Box58C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box58C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box58C { get; set; }
Public Property Box58C As String
    Get
    Set
public:
property String^ Box58C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box59A Property

Box59A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box59A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box59A { get; set; }
Public Property Box59A As String
    Get
    Set
public:
property String^ Box59A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box59B Property

Box59B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box59B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box59B { get; set; }
Public Property Box59B As String
    Get
    Set
public:
property String^ Box59B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box59C Property

Box59C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box59C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box59C { get; set; }
Public Property Box59C As String
    Get
    Set
public:
property String^ Box59C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box60A Property

Box60A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box60A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box60A { get; set; }
Public Property Box60A As String
    Get
    Set
public:
property String^ Box60A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box60B Property

Box60B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box60B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box60B { get; set; }
Public Property Box60B As String
    Get
    Set
public:
property String^ Box60B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box60C Property

Box60C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box60C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box60C { get; set; }
Public Property Box60C As String
    Get
    Set
public:
property String^ Box60C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box61A Property

Box61A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box61A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box61A { get; set; }
Public Property Box61A As String
    Get
    Set
public:
property String^ Box61A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box61B Property

Box61B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box61B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box61B { get; set; }
Public Property Box61B As String
    Get
    Set
public:
property String^ Box61B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box61C Property

Box61C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box61C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box61C { get; set; }
Public Property Box61C As String
    Get
    Set
public:
property String^ Box61C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box62A Property

Box62A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box62A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box62A { get; set; }
Public Property Box62A As String
    Get
    Set
public:
property String^ Box62A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box62B Property

Box62B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box62B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box62B { get; set; }
Public Property Box62B As String
    Get
    Set
public:
property String^ Box62B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box62C Property

Box62C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box62C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box62C { get; set; }
Public Property Box62C As String
    Get
    Set
public:
property String^ Box62C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box63A Property

Box63A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box63A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box63A { get; set; }
Public Property Box63A As String
    Get
    Set
public:
property String^ Box63A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box63B Property

Box63B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box63B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box63B { get; set; }
Public Property Box63B As String
    Get
    Set
public:
property String^ Box63B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box63C Property

Box63C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box63C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box63C { get; set; }
Public Property Box63C As String
    Get
    Set
public:
property String^ Box63C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box64A Property

Box64A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box64A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box64A { get; set; }
Public Property Box64A As String
    Get
    Set
public:
property String^ Box64A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box64B Property

Box64B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box64B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box64B { get; set; }
Public Property Box64B As String
    Get
    Set
public:
property String^ Box64B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box64C Property

Box64C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box64C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box64C { get; set; }
Public Property Box64C As String
    Get
    Set
public:
property String^ Box64C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box65A Property

Box65A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box65A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box65A { get; set; }
Public Property Box65A As String
    Get
    Set
public:
property String^ Box65A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box65B Property

Box65B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box65B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box65B { get; set; }
Public Property Box65B As String
    Get
    Set
public:
property String^ Box65B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box65C Property

Box65C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box65C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box65C { get; set; }
Public Property Box65C As String
    Get
    Set
public:
property String^ Box65C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box66 Property

Box66 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box66
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box66 { get; set; }
Public Property Box66 As String
    Get
    Set
public:
property String^ Box66 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67 Property

Box67 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67 { get; set; }
Public Property Box67 As String
    Get
    Set
public:
property String^ Box67 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67A Property

Box67A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67A { get; set; }
Public Property Box67A As String
    Get
    Set
public:
property String^ Box67A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67B Property

Box67B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67B { get; set; }
Public Property Box67B As String
    Get
    Set
public:
property String^ Box67B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67C Property

Box67C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67C { get; set; }
Public Property Box67C As String
    Get
    Set
public:
property String^ Box67C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67D Property

Box67D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67D { get; set; }
Public Property Box67D As String
    Get
    Set
public:
property String^ Box67D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67E Property

Box67E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67E { get; set; }
Public Property Box67E As String
    Get
    Set
public:
property String^ Box67E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67F Property

Box67F Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67F
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67F { get; set; }
Public Property Box67F As String
    Get
    Set
public:
property String^ Box67F {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67G Property

Box67G Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67G
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67G { get; set; }
Public Property Box67G As String
    Get
    Set
public:
property String^ Box67G {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67H Property

Box67H Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67H
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67H { get; set; }
Public Property Box67H As String
    Get
    Set
public:
property String^ Box67H {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67I Property

Box67I Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67I
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67I { get; set; }
Public Property Box67I As String
    Get
    Set
public:
property String^ Box67I {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67J Property

Box67J Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67J
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67J { get; set; }
Public Property Box67J As String
    Get
    Set
public:
property String^ Box67J {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67K Property

Box67K Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67K
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67K { get; set; }
Public Property Box67K As String
    Get
    Set
public:
property String^ Box67K {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67L Property

Box67L Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67L
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67L { get; set; }
Public Property Box67L As String
    Get
    Set
public:
property String^ Box67L {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67M Property

Box67M Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67M
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67M { get; set; }
Public Property Box67M As String
    Get
    Set
public:
property String^ Box67M {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67N Property

Box67N Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67N
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67N { get; set; }
Public Property Box67N As String
    Get
    Set
public:
property String^ Box67N {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67O Property

Box67O Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67O
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67O { get; set; }
Public Property Box67O As String
    Get
    Set
public:
property String^ Box67O {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67P Property

Box67P Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67P
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67P { get; set; }
Public Property Box67P As String
    Get
    Set
public:
property String^ Box67P {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box67Q Property

Box67Q Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box67Q
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box67Q { get; set; }
Public Property Box67Q As String
    Get
    Set
public:
property String^ Box67Q {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box68A Property

Box68A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box68A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box68A { get; set; }
Public Property Box68A As String
    Get
    Set
public:
property String^ Box68A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box68B Property

Box68B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box68B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box68B { get; set; }
Public Property Box68B As String
    Get
    Set
public:
property String^ Box68B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box69 Property

Box69 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box69
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box69 { get; set; }
Public Property Box69 As String
    Get
    Set
public:
property String^ Box69 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box6A Property

Box6A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box6A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box6A { get; set; }
Public Property Box6A As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box6A {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box6B Property

Box6B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box6B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box6B { get; set; }
Public Property Box6B As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box6B {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box7 Property

Box7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box7
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box7 { get; set; }
Public Property Box7 As String
    Get
    Set
public:
property String^ Box7 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box70A Property

Box70A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box70A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box70A { get; set; }
Public Property Box70A As String
    Get
    Set
public:
property String^ Box70A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box70B Property

Box70B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box70B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box70B { get; set; }
Public Property Box70B As String
    Get
    Set
public:
property String^ Box70B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box70C Property

Box70C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box70C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box70C { get; set; }
Public Property Box70C As String
    Get
    Set
public:
property String^ Box70C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box71 Property

Box71 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box71
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box71 { get; set; }
Public Property Box71 As String
    Get
    Set
public:
property String^ Box71 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box72A Property

Box72A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box72A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box72A { get; set; }
Public Property Box72A As String
    Get
    Set
public:
property String^ Box72A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box72B Property

Box72B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box72B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box72B { get; set; }
Public Property Box72B As String
    Get
    Set
public:
property String^ Box72B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box72C Property

Box72C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box72C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box72C { get; set; }
Public Property Box72C As String
    Get
    Set
public:
property String^ Box72C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box73 Property

Box73 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box73
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box73 { get; set; }
Public Property Box73 As String
    Get
    Set
public:
property String^ Box73 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74A Property

Box74A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box74A { get; set; }
Public Property Box74A As String
    Get
    Set
public:
property String^ Box74A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74aa Property

Box74aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box74aa { get; set; }
Public Property Box74aa As String
    Get
    Set
public:
property String^ Box74aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74ab Property

Box74ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box74ab { get; set; }
Public Property Box74ab As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box74ab {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74B Property

Box74B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box74B { get; set; }
Public Property Box74B As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box74B {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74ba Property

Box74ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box74ba { get; set; }
Public Property Box74ba As String
    Get
    Set
public:
property String^ Box74ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74bb Property

Box74bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box74bb { get; set; }
Public Property Box74bb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box74bb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74ca Property

Box74ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74ca
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box74ca { get; set; }
Public Property Box74ca As String
    Get
    Set
public:
property String^ Box74ca {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74cb Property

Box74cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74cb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box74cb { get; set; }
Public Property Box74cb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box74cb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74da Property

Box74da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74da
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box74da { get; set; }
Public Property Box74da As String
    Get
    Set
public:
property String^ Box74da {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74db Property

Box74db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74db
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box74db { get; set; }
Public Property Box74db As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box74db {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74ea Property

Box74ea Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74ea
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box74ea { get; set; }
Public Property Box74ea As String
    Get
    Set
public:
property String^ Box74ea {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box74eb Property

Box74eb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box74eb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> Box74eb { get; set; }
Public Property Box74eb As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> Box74eb {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box75 Property

Box75 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box75
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box75 { get; set; }
Public Property Box75 As String
    Get
    Set
public:
property String^ Box75 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box76A Property

Box76A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box76A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box76A { get; set; }
Public Property Box76A As String
    Get
    Set
public:
property String^ Box76A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box76B Property

Box76B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box76B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box76B { get; set; }
Public Property Box76B As String
    Get
    Set
public:
property String^ Box76B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box76C Property

Box76C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box76C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box76C { get; set; }
Public Property Box76C As String
    Get
    Set
public:
property String^ Box76C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box76D Property

Box76D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box76D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box76D { get; set; }
Public Property Box76D As String
    Get
    Set
public:
property String^ Box76D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box76E Property

Box76E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box76E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box76E { get; set; }
Public Property Box76E As String
    Get
    Set
public:
property String^ Box76E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box77A Property

Box77A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box77A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box77A { get; set; }
Public Property Box77A As String
    Get
    Set
public:
property String^ Box77A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box77B Property

Box77B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box77B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box77B { get; set; }
Public Property Box77B As String
    Get
    Set
public:
property String^ Box77B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box77C Property

Box77C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box77C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box77C { get; set; }
Public Property Box77C As String
    Get
    Set
public:
property String^ Box77C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box77D Property

Box77D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box77D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box77D { get; set; }
Public Property Box77D As String
    Get
    Set
public:
property String^ Box77D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box77E Property

Box77E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box77E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box77E { get; set; }
Public Property Box77E As String
    Get
    Set
public:
property String^ Box77E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box78A Property

Box78A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box78A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box78A { get; set; }
Public Property Box78A As String
    Get
    Set
public:
property String^ Box78A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box78B Property

Box78B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box78B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box78B { get; set; }
Public Property Box78B As String
    Get
    Set
public:
property String^ Box78B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box78C Property

Box78C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box78C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box78C { get; set; }
Public Property Box78C As String
    Get
    Set
public:
property String^ Box78C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box78D Property

Box78D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box78D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box78D { get; set; }
Public Property Box78D As String
    Get
    Set
public:
property String^ Box78D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box78E Property

Box78E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box78E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box78E { get; set; }
Public Property Box78E As String
    Get
    Set
public:
property String^ Box78E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box79A Property

Box79A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box79A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box79A { get; set; }
Public Property Box79A As String
    Get
    Set
public:
property String^ Box79A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box79B Property

Box79B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box79B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box79B { get; set; }
Public Property Box79B As String
    Get
    Set
public:
property String^ Box79B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box79C Property

Box79C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box79C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box79C { get; set; }
Public Property Box79C As String
    Get
    Set
public:
property String^ Box79C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box79D Property

Box79D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box79D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box79D { get; set; }
Public Property Box79D As String
    Get
    Set
public:
property String^ Box79D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box79E Property

Box79E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box79E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box79E { get; set; }
Public Property Box79E As String
    Get
    Set
public:
property String^ Box79E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box80 Property

Box80 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box80
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box80 { get; set; }
Public Property Box80 As String
    Get
    Set
public:
property String^ Box80 {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Aa Property

Box81Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Aa
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Aa { get; set; }
Public Property Box81Aa As String
    Get
    Set
public:
property String^ Box81Aa {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Ab Property

Box81Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Ab
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Ab { get; set; }
Public Property Box81Ab As String
    Get
    Set
public:
property String^ Box81Ab {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Ac Property

Box81Ac Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Ac
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Ac { get; set; }
Public Property Box81Ac As String
    Get
    Set
public:
property String^ Box81Ac {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Ba Property

Box81Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Ba
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Ba { get; set; }
Public Property Box81Ba As String
    Get
    Set
public:
property String^ Box81Ba {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Bb Property

Box81Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Bb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Bb { get; set; }
Public Property Box81Bb As String
    Get
    Set
public:
property String^ Box81Bb {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Bc Property

Box81Bc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Bc
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Bc { get; set; }
Public Property Box81Bc As String
    Get
    Set
public:
property String^ Box81Bc {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Ca Property

Box81Ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Ca
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Ca { get; set; }
Public Property Box81Ca As String
    Get
    Set
public:
property String^ Box81Ca {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Cb Property

Box81Cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Cb
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Cb { get; set; }
Public Property Box81Cb As String
    Get
    Set
public:
property String^ Box81Cb {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Cc Property

Box81Cc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Cc
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Cc { get; set; }
Public Property Box81Cc As String
    Get
    Set
public:
property String^ Box81Cc {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Da Property

Box81Da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Da
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Da { get; set; }
Public Property Box81Da As String
    Get
    Set
public:
property String^ Box81Da {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Db Property

Box81Db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Db
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Db { get; set; }
Public Property Box81Db As String
    Get
    Set
public:
property String^ Box81Db {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box81Dc Property

Box81Dc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box81Dc
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box81Dc { get; set; }
Public Property Box81Dc As String
    Get
    Set
public:
property String^ Box81Dc {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box8A Property

Box8A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box8A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box8A { get; set; }
Public Property Box8A As String
    Get
    Set
public:
property String^ Box8A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box8B Property

Box8B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box8B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box8B { get; set; }
Public Property Box8B As String
    Get
    Set
public:
property String^ Box8B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9A Property

Box9A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box9A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9A { get; set; }
Public Property Box9A As String
    Get
    Set
public:
property String^ Box9A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9B Property

Box9B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box9B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9B { get; set; }
Public Property Box9B As String
    Get
    Set
public:
property String^ Box9B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9C Property

Box9C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box9C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9C { get; set; }
Public Property Box9C As String
    Get
    Set
public:
property String^ Box9C {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9D Property

Box9D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box9D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9D { get; set; }
Public Property Box9D As String
    Get
    Set
public:
property String^ Box9D {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Box9E Property

Box9E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Box9E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Box9E { get; set; }
Public Property Box9E As String
    Get
    Set
public:
property String^ Box9E {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


GenerateTestData Method

GenerateTestData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► GenerateTestData()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static UB04FormData GenerateTestData()
Public Shared Function GenerateTestData As UB04FormData
public:
static UB04FormData^ GenerateTestData()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ServiceLineBox23A Property

ServiceLineBox23A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► ServiceLineBox23A
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLineBox23A { get; set; }
Public Property ServiceLineBox23A As String
    Get
    Set
public:
property String^ ServiceLineBox23A {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ServiceLineBox23B Property

ServiceLineBox23B Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► ServiceLineBox23B
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceLineBox23B { get; set; }
Public Property ServiceLineBox23B As String
    Get
    Set
public:
property String^ ServiceLineBox23B {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ServiceLineBox23C Property

ServiceLineBox23C Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► ServiceLineBox23C
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<DateTime> ServiceLineBox23C { get; set; }
Public Property ServiceLineBox23C As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> ServiceLineBox23C {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ServiceLineBox23D Property

ServiceLineBox23D Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► ServiceLineBox23D
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> ServiceLineBox23D { get; set; }
Public Property ServiceLineBox23D As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> ServiceLineBox23D {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ServiceLineBox23E Property

ServiceLineBox23E Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► ServiceLineBox23E
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<decimal> ServiceLineBox23E { get; set; }
Public Property ServiceLineBox23E As Nullable(Of Decimal)
    Get
    Set
public:
property Nullable<Decimal> ServiceLineBox23E {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


Services Field

Services Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► UB04FormData ► Services
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<Service> Services
Public Services As List(Of Service)
public:
List<Service^>^ Services

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


RDPCrystalEDILibrary.Rules Namespace

RDPCrystalEDILibrary.Rules Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Rules
Namespace RDPCrystalEDILibrary.Rules
namespace RDPCrystalEDILibrary.Rules
Types
All Types Classes
Icon | Type | Description
 | CodeCondition |
 | CodeConditionEventArgs | Represents a CodeCondition
 | Condition |
 | ElementListNode |
 | ElementPositionNode |
 | ElseIfStatement |
 | ErrorNode |
 | GeneralRule |
 | GeneralSelfRule |
 | IfStatement |
 | Indexer |
 | IndexerList |
 | IntegerList |
 | Lexer |
 | LocalCode |
 | Node |
 | RegexMatcher |
 | SegmentPositionNode |
 | StringList |
 | TokenDefinition |
 | Tokens |
 | UsageNode |


CodeCondition Class

CodeCondition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeCondition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class CodeCondition : Node
Public Class CodeCondition _
    Inherits Node
public ref class CodeCondition : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeCondition(String, Int32) | Initializes a new instance of the CodeCondition class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | CodeCondition

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeCondition Constructor (text, depth)

CodeCondition Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeCondition ► CodeCondition(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the CodeCondition class
Declaration Syntax
C# Visual Basic Visual C++
public CodeCondition(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
CodeCondition(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Id Property

Id Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeCondition ► Id
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeCondition ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeConditionEventArgs Class

CodeConditionEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs
RDPCrystal EDI Library
Represents a CodeCondition
Declaration Syntax
C# Visual Basic Visual C++
public class CodeConditionEventArgs : EventArgs
Public Class CodeConditionEventArgs _
    Inherits EventArgs
public ref class CodeConditionEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeConditionEventArgs()()()() | Creates a new CodeCondition object
 | CodeCondition | The CodeCondition being evaluated
 | ConditionValid | Set whether this condition is true or false
 | CurrentLoop | The current loop being evaluated
 | CurrentSegment | The current segment being evaluated
 | CurrentSegmentSchema | The schema of the current segment being validated
 | DataLoop | All the Loops and Segments encountered so far
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FoundElements | Elements found in the current segments. This only applies to SELF Rules
 | FoundSegments | Segments found in the current hierarchies
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CodeConditionEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeConditionEventArgs Constructor

CodeConditionEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► CodeConditionEventArgs()()()()
RDPCrystal EDI Library
Creates a new CodeCondition object
Declaration Syntax
C# Visual Basic Visual C++
public CodeConditionEventArgs()
Public Sub New
public:
CodeConditionEventArgs()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeCondition Property

CodeCondition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► CodeCondition
RDPCrystal EDI Library
The CodeCondition being evaluated
Declaration Syntax
C# Visual Basic Visual C++
public CodeCondition CodeCondition { get; set; }
Public Property CodeCondition As CodeCondition
    Get
    Set
public:
property CodeCondition^ CodeCondition {
    CodeCondition^ get ();
    void set (CodeCondition^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ConditionValid Property

ConditionValid Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► ConditionValid
RDPCrystal EDI Library
Set whether this condition is true or false
Declaration Syntax
C# Visual Basic Visual C++
public bool ConditionValid { get; set; }
Public Property ConditionValid As Boolean
    Get
    Set
public:
property bool ConditionValid {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CurrentLoop Property

CurrentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► CurrentLoop
RDPCrystal EDI Library
The current loop being evaluated
Declaration Syntax
C# Visual Basic Visual C++
public Loop CurrentLoop { get; set; }
Public Property CurrentLoop As Loop
    Get
    Set
public:
property Loop^ CurrentLoop {
    Loop^ get ();
    void set (Loop^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CurrentSegment Property

CurrentSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► CurrentSegment
RDPCrystal EDI Library
The current segment being evaluated
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment CurrentSegment { get; set; }
Public Property CurrentSegment As LightWeightSegment
    Get
    Set
public:
property LightWeightSegment^ CurrentSegment {
    LightWeightSegment^ get ();
    void set (LightWeightSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CurrentSegmentSchema Property

CurrentSegmentSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► CurrentSegmentSchema
RDPCrystal EDI Library
The schema of the current segment being validated
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CurrentSegmentSchema { get; set; }
Public Property CurrentSegmentSchema As DataSegment
    Get
    Set
public:
property DataSegment^ CurrentSegmentSchema {
    DataSegment^ get ();
    void set (DataSegment^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DataLoop Property

DataLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► DataLoop
RDPCrystal EDI Library
All the Loops and Segments encountered so far
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop DataLoop { get; set; }
Public Property DataLoop As LightWeightLoop
    Get
    Set
public:
property LightWeightLoop^ DataLoop {
    LightWeightLoop^ get ();
    void set (LightWeightLoop^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FoundElements Property

FoundElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► FoundElements
RDPCrystal EDI Library
Elements found in the current segments. This only applies to SELF Rules
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<int, string> FoundElements { get; set; }
Public Property FoundElements As Dictionary(Of Integer, String)
    Get
    Set
public:
property Dictionary<int, String^>^ FoundElements {
    Dictionary<int, String^>^ get ();
    void set (Dictionary<int, String^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FoundSegments Property

FoundSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► CodeConditionEventArgs ► FoundSegments
RDPCrystal EDI Library
Segments found in the current hierarchies
Declaration Syntax
C# Visual Basic Visual C++
public FoundSegmentCollection FoundSegments { get; set; }
Public Property FoundSegments As FoundSegmentCollection
    Get
    Set
public:
property FoundSegmentCollection^ FoundSegments {
    FoundSegmentCollection^ get ();
    void set (FoundSegmentCollection^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Condition Class

Condition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class Condition : Node
Public Class Condition _
    Inherits Node
public ref class Condition : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Condition(String, Int32) | Initializes a new instance of the Condition class
 | CodeCondition |
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | ElementPosition |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode) | Uses to validate rules from the RULES Section
 | Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>)) | Used for Self Rules
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstOpPosition |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | operands |
 | Operator |
 | operators |
 | SecondOpPosition |
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Value |
Inheritance Hierarchy
Object
 | Node
 |  | Condition

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Condition Constructor (text, depth)

Condition Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Condition(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the Condition class
Declaration Syntax
C# Visual Basic Visual C++
public Condition(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
Condition(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CodeCondition Property

CodeCondition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► CodeCondition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public CodeCondition CodeCondition { get; set; }
Public Property CodeCondition As CodeCondition
    Get
    Set
public:
property CodeCondition^ CodeCondition {
    CodeCondition^ get ();
    void set (CodeCondition^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPosition Property

ElementPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► ElementPosition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public ElementPositionNode ElementPosition { get; set; }
Public Property ElementPosition As ElementPositionNode
    Get
    Set
public:
property ElementPositionNode^ ElementPosition {
    ElementPositionNode^ get ();
    void set (ElementPositionNode^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method

Evaluate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Evaluate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode) | Uses to validate rules from the RULES Section
 | Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>)) | Used for Self Rules

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method (validator, foundSegments, sp)

Evaluate Method (validator, foundSegments, sp)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode)
RDPCrystal EDI Library
Uses to validate rules from the RULES Section
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    EDIValidator validator,
    FoundSegmentCollection foundSegments,
    SegmentPositionNode sp
)
Public Function Evaluate ( _
    validator As EDIValidator, _
    foundSegments As FoundSegmentCollection, _
    sp As SegmentPositionNode _
) As Boolean
public:
bool Evaluate(
    EDIValidator^ validator,
    FoundSegmentCollection^ foundSegments,
    SegmentPositionNode^ sp
)
Parameters
validator (EDIValidator)
foundSegments (FoundSegmentCollection)
sp (SegmentPositionNode)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method (validator, foundElements)

Evaluate Method (validator, foundElements)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>))
RDPCrystal EDI Library
Used for Self Rules
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    EDIValidator validator,
    Dictionary<int, string> foundElements
)
Public Function Evaluate ( _
    validator As EDIValidator, _
    foundElements As Dictionary(Of Integer, String) _
) As Boolean
public:
bool Evaluate(
    EDIValidator^ validator,
    Dictionary<int, String^>^ foundElements
)
Parameters
validator (EDIValidator)
foundElements (Dictionary<(Of <(<'Int32, String>)>)>)
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FirstOpPosition Property

FirstOpPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► FirstOpPosition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode FirstOpPosition { get; set; }
Public Property FirstOpPosition As SegmentPositionNode
    Get
    Set
public:
property SegmentPositionNode^ FirstOpPosition {
    SegmentPositionNode^ get ();
    void set (SegmentPositionNode^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


operands Field

operands Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► operands
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<Condition> operands
Public operands As List(Of Condition)
public:
List<Condition^>^ operands

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Operator Property

Operator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Operator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public RuleOperator Operator { get; set; }
Public Property Operator As RuleOperator
    Get
    Set
public:
property RuleOperator Operator {
    RuleOperator get ();
    void set (RuleOperator value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


operators Field

operators Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► operators
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<string> operators
Public operators As List(Of String)
public:
List<String^>^ operators

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SecondOpPosition Property

SecondOpPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► SecondOpPosition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode SecondOpPosition { get; set; }
Public Property SecondOpPosition As SegmentPositionNode
    Get
    Set
public:
property SegmentPositionNode^ SecondOpPosition {
    SegmentPositionNode^ get ();
    void set (SegmentPositionNode^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Value Property

Value Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Value
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementListNode Class

ElementListNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ElementListNode : Node
Public Class ElementListNode _
    Inherits Node
public ref class ElementListNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementListNode(String, Int32) | Initializes a new instance of the ElementListNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | ElementListNode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementListNode Constructor (text, depth)

ElementListNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode ► ElementListNode(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the ElementListNode class
Declaration Syntax
C# Visual Basic Visual C++
public ElementListNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ElementListNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPositionNode Class

ElementPositionNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ElementPositionNode : Node
Public Class ElementPositionNode _
    Inherits Node
public ref class ElementPositionNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementPositionNode(String, Int32) | Initializes a new instance of the ElementPositionNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | ElementPositionNode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPositionNode Constructor (text, depth)

ElementPositionNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode ► ElementPositionNode(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the ElementPositionNode class
Declaration Syntax
C# Visual Basic Visual C++
public ElementPositionNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ElementPositionNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Index Field

Index Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode ► Index
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int Index
Public Index As Integer
public:
int Index

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElseIfStatement Class

ElseIfStatement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ElseIfStatement : Node
Public Class ElseIfStatement _
    Inherits Node
public ref class ElseIfStatement : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElseIfStatement(String, Int32) | Initializes a new instance of the ElseIfStatement class
 | Condition |
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode) |
 | Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>)) |
 | False |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | True |
Inheritance Hierarchy
Object
 | Node
 |  | ElseIfStatement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElseIfStatement Constructor (text, depth)

ElseIfStatement Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► ElseIfStatement(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the ElseIfStatement class
Declaration Syntax
C# Visual Basic Visual C++
public ElseIfStatement(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ElseIfStatement(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Condition Property

Condition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► Condition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Condition Condition { get; set; }
Public Property Condition As Condition
    Get
    Set
public:
property Condition^ Condition {
    Condition^ get ();
    void set (Condition^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method

Evaluate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► Evaluate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode) |
 | Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>)) |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method (validator, foundSegments, sp)

Evaluate Method (validator, foundSegments, sp)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    EDIValidator validator,
    FoundSegmentCollection foundSegments,
    SegmentPositionNode sp
)
Public Function Evaluate ( _
    validator As EDIValidator, _
    foundSegments As FoundSegmentCollection, _
    sp As SegmentPositionNode _
) As Boolean
public:
bool Evaluate(
    EDIValidator^ validator,
    FoundSegmentCollection^ foundSegments,
    SegmentPositionNode^ sp
)
Parameters
validator (EDIValidator)
foundSegments (FoundSegmentCollection)
sp (SegmentPositionNode)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method (validator, foundElements)

Evaluate Method (validator, foundElements)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>))
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    EDIValidator validator,
    Dictionary<int, string> foundElements
)
Public Function Evaluate ( _
    validator As EDIValidator, _
    foundElements As Dictionary(Of Integer, String) _
) As Boolean
public:
bool Evaluate(
    EDIValidator^ validator,
    Dictionary<int, String^>^ foundElements
)
Parameters
validator (EDIValidator)
foundElements (Dictionary<(Of <(<'Int32, String>)>)>)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


False Property

False Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► False
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Node False { get; set; }
Public Property False As Node
    Get
    Set
public:
property Node^ False {
    Node^ get ();
    void set (Node^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


True Property

True Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElseIfStatement ► True
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Node True { get; set; }
Public Property True As Node
    Get
    Set
public:
property Node^ True {
    Node^ get ();
    void set (Node^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ErrorNode Class

ErrorNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class ErrorNode : Node
Public Class ErrorNode _
    Inherits Node
public ref class ErrorNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorNode(String, Int32) | Initializes a new instance of the ErrorNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | EDIMessage |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageString |
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | ErrorNode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ErrorNode Constructor (text, depth)

ErrorNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► ErrorNode(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the ErrorNode class
Declaration Syntax
C# Visual Basic Visual C++
public ErrorNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ErrorNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EDIMessage Property

EDIMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► EDIMessage
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidationMessage EDIMessage { get; set; }
Public Property EDIMessage As EDIValidationMessage
    Get
    Set
public:
property EDIValidationMessage EDIMessage {
    EDIValidationMessage get ();
    void set (EDIValidationMessage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MessageString Property

MessageString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► MessageString
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string MessageString { get; set; }
Public Property MessageString As String
    Get
    Set
public:
property String^ MessageString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralRule Class

GeneralRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralRule : Node
Public Class GeneralRule _
    Inherits Node
public ref class GeneralRule : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeneralRule(String, Int32) | Initializes a new instance of the GeneralRule class
 | Defs | (Inherited from Node.)
 | DepSegmentPositionNode |
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfStatement |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | GeneralRule

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralRule Constructor (text, depth)

GeneralRule Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► GeneralRule(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the GeneralRule class
Declaration Syntax
C# Visual Basic Visual C++
public GeneralRule(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
GeneralRule(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DepSegmentPositionNode Property

DepSegmentPositionNode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► DepSegmentPositionNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode DepSegmentPositionNode { get; set; }
Public Property DepSegmentPositionNode As SegmentPositionNode
    Get
    Set
public:
property SegmentPositionNode^ DepSegmentPositionNode {
    SegmentPositionNode^ get ();
    void set (SegmentPositionNode^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IfStatement Property

IfStatement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► IfStatement
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public IfStatement IfStatement { get; set; }
Public Property IfStatement As IfStatement
    Get
    Set
public:
property IfStatement^ IfStatement {
    IfStatement^ get ();
    void set (IfStatement^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralSelfRule Class

GeneralSelfRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralSelfRule : Node
Public Class GeneralSelfRule _
    Inherits Node
public ref class GeneralSelfRule : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeneralSelfRule(String, Int32) | Initializes a new instance of the GeneralSelfRule class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfStatement |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Symbol |
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | GeneralSelfRule

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GeneralSelfRule Constructor (text, depth)

GeneralSelfRule Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► GeneralSelfRule(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the GeneralSelfRule class
Declaration Syntax
C# Visual Basic Visual C++
public GeneralSelfRule(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
GeneralSelfRule(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IfStatement Property

IfStatement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► IfStatement
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public IfStatement IfStatement { get; set; }
Public Property IfStatement As IfStatement
    Get
    Set
public:
property IfStatement^ IfStatement {
    IfStatement^ get ();
    void set (IfStatement^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Symbol Property

Symbol Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► Symbol
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Symbol { get; set; }
Public Property Symbol As String
    Get
    Set
public:
property String^ Symbol {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IfStatement Class

IfStatement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class IfStatement : Node
Public Class IfStatement _
    Inherits Node
public ref class IfStatement : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IfStatement(String, Int32) | Initializes a new instance of the IfStatement class
 | Condition |
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | DerivedTrue | This will contain the true action of the if or elseif statement that evaulates to true
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode) |
 | Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>)) |
 | False |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | IfStatement

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IfStatement Constructor (text, depth)

IfStatement Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► IfStatement(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the IfStatement class
Declaration Syntax
C# Visual Basic Visual C++
public IfStatement(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
IfStatement(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Condition Property

Condition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► Condition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Condition Condition { get; set; }
Public Property Condition As Condition
    Get
    Set
public:
property Condition^ Condition {
    Condition^ get ();
    void set (Condition^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DerivedTrue Property

DerivedTrue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► DerivedTrue
RDPCrystal EDI Library
This will contain the true action of the if or elseif statement that evaulates to true
Declaration Syntax
C# Visual Basic Visual C++
public Node DerivedTrue { get; set; }
Public Property DerivedTrue As Node
    Get
    Set
public:
property Node^ DerivedTrue {
    Node^ get ();
    void set (Node^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method

Evaluate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► Evaluate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode) |
 | Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>)) |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method (validator, foundSegments, sp)

Evaluate Method (validator, foundSegments, sp)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► Evaluate(EDIValidator, FoundSegmentCollection, SegmentPositionNode)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    EDIValidator validator,
    FoundSegmentCollection foundSegments,
    SegmentPositionNode sp
)
Public Function Evaluate ( _
    validator As EDIValidator, _
    foundSegments As FoundSegmentCollection, _
    sp As SegmentPositionNode _
) As Boolean
public:
bool Evaluate(
    EDIValidator^ validator,
    FoundSegmentCollection^ foundSegments,
    SegmentPositionNode^ sp
)
Parameters
validator (EDIValidator)
foundSegments (FoundSegmentCollection)
sp (SegmentPositionNode)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Evaluate Method (validator, foundElements)

Evaluate Method (validator, foundElements)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► Evaluate(EDIValidator, Dictionary<(Of <<'(Int32, String>)>>))
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    EDIValidator validator,
    Dictionary<int, string> foundElements
)
Public Function Evaluate ( _
    validator As EDIValidator, _
    foundElements As Dictionary(Of Integer, String) _
) As Boolean
public:
bool Evaluate(
    EDIValidator^ validator,
    Dictionary<int, String^>^ foundElements
)
Parameters
validator (EDIValidator)
foundElements (Dictionary<(Of <(<'Int32, String>)>)>)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


False Property

False Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► False
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Node False { get; set; }
Public Property False As Node
    Get
    Set
public:
property Node^ False {
    Node^ get ();
    void set (Node^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Indexer Class

Indexer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Indexer
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class Indexer : Node
Public Class Indexer _
    Inherits Node
public ref class Indexer : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Indexer(String, Int32) | Initializes a new instance of the Indexer class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | Indexer

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Indexer Constructor (text, depth)

Indexer Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Indexer ► Indexer(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the Indexer class
Declaration Syntax
C# Visual Basic Visual C++
public Indexer(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
Indexer(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Index Field

Index Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Indexer ► Index
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int Index
Public Index As Integer
public:
int Index

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IndexerList Class

IndexerList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IndexerList
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class IndexerList : Node
Public Class IndexerList _
    Inherits Node
public ref class IndexerList : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexerList(String, Int32) | Initializes a new instance of the IndexerList class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | IndexerList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IndexerList Constructor (text, depth)

IndexerList Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IndexerList ► IndexerList(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the IndexerList class
Declaration Syntax
C# Visual Basic Visual C++
public IndexerList(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
IndexerList(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IndexerList ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IntegerList Class

IntegerList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IntegerList
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class IntegerList : Node
Public Class IntegerList _
    Inherits Node
public ref class IntegerList : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerList(String, Int32) | Initializes a new instance of the IntegerList class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | IntegerList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IntegerList Constructor (text, depth)

IntegerList Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IntegerList ► IntegerList(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the IntegerList class
Declaration Syntax
C# Visual Basic Visual C++
public IntegerList(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
IntegerList(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IntegerList ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Lexer Class

Lexer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Lexer : IDisposable
Public NotInheritable Class Lexer _
    Implements IDisposable
public ref class Lexer sealed : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Lexer(TextReader, List<(Of <<'(TokenDefinition>)>>)) | Initializes a new instance of the Lexer class
 | Dispose()()()() | Releases all resources used by the Lexer
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LineNumber |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Next()()()() |
 | Position |
 | Token |
 | TokenContents |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Lexer

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Lexer Constructor (reader, tokenDefinitions)

Lexer Constructor (reader, tokenDefinitions)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Lexer(TextReader, List<(Of <<'(TokenDefinition>)>>))
RDPCrystal EDI Library
Initializes a new instance of the Lexer class
Declaration Syntax
C# Visual Basic Visual C++
public Lexer(
    TextReader reader,
    List<TokenDefinition> tokenDefinitions
)
Public Sub New ( _
    reader As TextReader, _
    tokenDefinitions As List(Of TokenDefinition) _
)
public:
Lexer(
    TextReader^ reader,
    List<TokenDefinition^>^ tokenDefinitions
)
Parameters
reader (TextReader)
tokenDefinitions (List<(Of <(<' TokenDefinition >)>)>)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Dispose()()()()
RDPCrystal EDI Library
Releases all resources used by the Lexer
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LineNumber Property

LineNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► LineNumber
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int LineNumber { get; private set; }
Public Property LineNumber As Integer
    Get
    Private Set
public:
property int LineNumber {
    int get ();
    private: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Next Method

Next Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Next()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public bool Next()
Public Function Next As Boolean
public:
bool Next()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Position
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int Position { get; private set; }
Public Property Position As Integer
    Get
    Private Set
public:
property int Position {
    int get ();
    private: void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Token Property

Token Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Token
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Object Token { get; private set; }
Public Property Token As Object
    Get
    Private Set
public:
property Object^ Token {
    Object^ get ();
    private: void set (Object^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TokenContents Property

TokenContents Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► TokenContents
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string TokenContents { get; private set; }
Public Property TokenContents As String
    Get
    Private Set
public:
property String^ TokenContents {
    String^ get ();
    private: void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LocalCode Class

LocalCode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class LocalCode : Node
Public Class LocalCode _
    Inherits Node
public ref class LocalCode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalCode(String, Int32) | Initializes a new instance of the LocalCode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | LocalCode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LocalCode Constructor (text, depth)

LocalCode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode ► LocalCode(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the LocalCode class
Declaration Syntax
C# Visual Basic Visual C++
public LocalCode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
LocalCode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> Values
Public Values As HashSet(Of String)
public:
HashSet<String^>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Node Class

Node Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class Node
Public Class Node
public ref class Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Node(String, Int32) | Initializes a new instance of the Node class
 | Defs |
 | Depth | Depth is used only for printing out data to the console for debugging
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator
 | Sequence |
 | Text |
 | ToRuleString()()()() |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | Node
 |  | CodeCondition
 |  | Condition
 |  | ElementListNode
 |  | ElementPositionNode
 |  | ElseIfStatement
 |  | ErrorNode
 |  | GeneralRule
 |  | GeneralSelfRule
 |  | IfStatement
 |  | Indexer
 |  | IndexerList
 |  | IntegerList
 |  | LocalCode
 |  | SegmentPositionNode
 |  | StringList
 |  | UsageNode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Node Constructor (text, depth)

Node Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Node(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the Node class
Declaration Syntax
C# Visual Basic Visual C++
public Node(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
Node(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Defs Field

Defs Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Defs
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected List<TokenDefinition> Defs
Protected Defs As List(Of TokenDefinition)
protected:
List<TokenDefinition^>^ Defs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Depth Property

Depth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Depth
RDPCrystal EDI Library
Depth is used only for printing out data to the console for debugging
Declaration Syntax
C# Visual Basic Visual C++
public int Depth { get; set; }
Public Property Depth As Integer
    Get
    Set
public:
property int Depth {
    int get ();
    void set (int value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Name
RDPCrystal EDI Library
Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Sequence Field

Sequence Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Sequence
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
protected List<string> Sequence
Protected Sequence As List(Of String)
protected:
List<String^>^ Sequence

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Text Property

Text Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Text
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ToRuleString()
Public Overridable Function ToRuleString As String
public:
virtual String^ ToRuleString()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► ToString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RegexMatcher Class

RegexMatcher Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public sealed class RegexMatcher
Public NotInheritable Class RegexMatcher
public ref class RegexMatcher sealed
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RegexMatcher(String) | Initializes a new instance of the RegexMatcher class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Match(String) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
RegexMatcher

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RegexMatcher Constructor (regex)

RegexMatcher Constructor (regex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher ► RegexMatcher(String)
RDPCrystal EDI Library
Initializes a new instance of the RegexMatcher class
Declaration Syntax
C# Visual Basic Visual C++
public RegexMatcher(
    string regex
)
Public Sub New ( _
    regex As String _
)
public:
RegexMatcher(
    String^ regex
)
Parameters
regex (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Match Method (text)

Match Method (text)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher ► Match(String)
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public int Match(
    string text
)
Public Function Match ( _
    text As String _
) As Integer
public:
int Match(
    String^ text
)
Parameters
text (String)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher ► ToString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentPositionNode Class

SegmentPositionNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class SegmentPositionNode : Node
Public Class SegmentPositionNode _
    Inherits Node
public ref class SegmentPositionNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SegmentPositionNode(String, Int32) | Initializes a new instance of the SegmentPositionNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | ElementPosition |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | SegmentPositionNode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentPositionNode Constructor (text, depth)

SegmentPositionNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► SegmentPositionNode(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the SegmentPositionNode class
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
SegmentPositionNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementPosition Field

ElementPosition Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► ElementPosition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition ElementPosition
Public ElementPosition As ElementPosition
public:
ElementPosition^ ElementPosition

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


StringList Class

StringList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► StringList
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class StringList : Node
Public Class StringList _
    Inherits Node
public ref class StringList : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringList(String, Int32) | Initializes a new instance of the StringList class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | StringList

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


StringList Constructor (text, depth)

StringList Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► StringList ► StringList(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the StringList class
Declaration Syntax
C# Visual Basic Visual C++
public StringList(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
StringList(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► StringList ► Values
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Values
Public Values As List(Of String)
public:
List<String^>^ Values

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TokenDefinition Class

TokenDefinition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public sealed class TokenDefinition
Public NotInheritable Class TokenDefinition
public ref class TokenDefinition sealed
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TokenDefinition(String, Object) | Initializes a new instance of the TokenDefinition class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Matcher |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Token |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
TokenDefinition

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


TokenDefinition Constructor (regex, token)

TokenDefinition Constructor (regex, token)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition ► TokenDefinition(String, Object)
RDPCrystal EDI Library
Initializes a new instance of the TokenDefinition class
Declaration Syntax
C# Visual Basic Visual C++
public TokenDefinition(
    string regex,
    Object token
)
Public Sub New ( _
    regex As String, _
    token As Object _
)
public:
TokenDefinition(
    String^ regex,
    Object^ token
)
Parameters
regex (String)
token (Object)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Matcher Field

Matcher Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition ► Matcher
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public readonly RegexMatcher Matcher
Public ReadOnly Matcher As RegexMatcher
public:
initonly RegexMatcher^ Matcher

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Token Field

Token Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition ► Token
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public readonly Object Token
Public ReadOnly Token As Object
public:
initonly Object^ Token

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Tokens Class

Tokens Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static class Tokens
Public NotInheritable Class Tokens
public ref class Tokens abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AND |
 | CODECONDITION |
 | COMMA |
 | CompositeElementHasWrongValue |
 | CompositeElementMissing |
 | CompositeElementNotRecommended |
 | CompositeElementNotUsed |
 | CompositeElementRecommended |
 | CONDITION |
 | CONTAINS |
 | DEFAULT |
 | DOT |
 | ElementHasWrongValue |
 | ELEMENTLIST |
 | ElementMissing |
 | ElementNotRecommended |
 | ElementNotUsed |
 | ElementRecommended |
 | ELEMPOS |
 | ELSE |
 | ELSEIF |
 | ELSEIFSTATEMENT |
 | END |
 | ENDSWITH |
 | EQUAL |
 | EQUALSS |
 | ERROR |
 | FLOAT |
 | GREATERTHAN |
 | GREATERTHANOREQUALTO |
 | IF |
 | IFSTATEMENT |
 | INDEXER |
 | INT |
 | INTEGERINDEXLIST |
 | INTEGERLIST |
 | LEFT |
 | LEFTBRACKET |
 | LENGTHEQUAL |
 | LENGTHGREATERTHAN |
 | LENGTHLESSTHAN |
 | LENGTHNOTEQUAL |
 | LESSTHAN |
 | LESSTHANOREQUALTO |
 | LOCALCODE |
 | NOTCONTAINS |
 | NOTENDSWITH |
 | NOTEQUAL |
 | NOTRECOMMENDED |
 | NOTSTARTSWITH |
 | NOTUSED |
 | NULL |
 | OPTIONAL |
 | OR |
 | RECOMMENDED |
 | REQUIRED |
 | RIGHT |
 | RIGHTBRACKET |
 | SegmentMissing |
 | SegmentNotRecommended |
 | SegmentNotUsed |
 | SegmentRecommended |
 | SEGPOS |
 | SEMICOLON |
 | SPACE |
 | STARTSWITH |
 | STRING |
 | STRINGLIST |
 | SYMBOL |
 | THEN |
 | USAGE |
Inheritance Hierarchy
Object
Tokens

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


AND Field

AND Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► AND
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition AND
Public Shared AND As TokenDefinition
public:
static TokenDefinition^ AND

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CODECONDITION Field

CODECONDITION Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CODECONDITION
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CODECONDITION
Public Shared CODECONDITION As TokenDefinition
public:
static TokenDefinition^ CODECONDITION

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


COMMA Field

COMMA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► COMMA
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition COMMA
Public Shared COMMA As TokenDefinition
public:
static TokenDefinition^ COMMA

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementHasWrongValue Field

CompositeElementHasWrongValue Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementHasWrongValue
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementHasWrongValue
Public Shared CompositeElementHasWrongValue As TokenDefinition
public:
static TokenDefinition^ CompositeElementHasWrongValue

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementMissing Field

CompositeElementMissing Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementMissing
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementMissing
Public Shared CompositeElementMissing As TokenDefinition
public:
static TokenDefinition^ CompositeElementMissing

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementNotRecommended Field

CompositeElementNotRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementNotRecommended
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementNotRecommended
Public Shared CompositeElementNotRecommended As TokenDefinition
public:
static TokenDefinition^ CompositeElementNotRecommended

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementNotUsed Field

CompositeElementNotUsed Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementNotUsed
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementNotUsed
Public Shared CompositeElementNotUsed As TokenDefinition
public:
static TokenDefinition^ CompositeElementNotUsed

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CompositeElementRecommended Field

CompositeElementRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementRecommended
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementRecommended
Public Shared CompositeElementRecommended As TokenDefinition
public:
static TokenDefinition^ CompositeElementRecommended

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CONDITION Field

CONDITION Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CONDITION
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CONDITION
Public Shared CONDITION As TokenDefinition
public:
static TokenDefinition^ CONDITION

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CONTAINS Field

CONTAINS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CONTAINS
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CONTAINS
Public Shared CONTAINS As TokenDefinition
public:
static TokenDefinition^ CONTAINS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DEFAULT Field

DEFAULT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► DEFAULT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition DEFAULT
Public Shared DEFAULT As TokenDefinition
public:
static TokenDefinition^ DEFAULT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


DOT Field

DOT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► DOT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition DOT
Public Shared DOT As TokenDefinition
public:
static TokenDefinition^ DOT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementHasWrongValue Field

ElementHasWrongValue Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementHasWrongValue
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementHasWrongValue
Public Shared ElementHasWrongValue As TokenDefinition
public:
static TokenDefinition^ ElementHasWrongValue

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ELEMENTLIST Field

ELEMENTLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELEMENTLIST
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELEMENTLIST
Public Shared ELEMENTLIST As TokenDefinition
public:
static TokenDefinition^ ELEMENTLIST

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementMissing Field

ElementMissing Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementMissing
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementMissing
Public Shared ElementMissing As TokenDefinition
public:
static TokenDefinition^ ElementMissing

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNotRecommended Field

ElementNotRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementNotRecommended
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementNotRecommended
Public Shared ElementNotRecommended As TokenDefinition
public:
static TokenDefinition^ ElementNotRecommended

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementNotUsed Field

ElementNotUsed Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementNotUsed
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementNotUsed
Public Shared ElementNotUsed As TokenDefinition
public:
static TokenDefinition^ ElementNotUsed

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ElementRecommended Field

ElementRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementRecommended
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementRecommended
Public Shared ElementRecommended As TokenDefinition
public:
static TokenDefinition^ ElementRecommended

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ELEMPOS Field

ELEMPOS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELEMPOS
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELEMPOS
Public Shared ELEMPOS As TokenDefinition
public:
static TokenDefinition^ ELEMPOS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ELSE Field

ELSE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELSE
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELSE
Public Shared ELSE As TokenDefinition
public:
static TokenDefinition^ ELSE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ELSEIF Field

ELSEIF Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELSEIF
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELSEIF
Public Shared ELSEIF As TokenDefinition
public:
static TokenDefinition^ ELSEIF

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ELSEIFSTATEMENT Field

ELSEIFSTATEMENT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELSEIFSTATEMENT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELSEIFSTATEMENT
Public Shared ELSEIFSTATEMENT As TokenDefinition
public:
static TokenDefinition^ ELSEIFSTATEMENT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


END Field

END Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► END
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition END
Public Shared END As TokenDefinition
public:
static TokenDefinition^ END

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ENDSWITH Field

ENDSWITH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ENDSWITH
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ENDSWITH
Public Shared ENDSWITH As TokenDefinition
public:
static TokenDefinition^ ENDSWITH

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EQUAL Field

EQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► EQUAL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition EQUAL
Public Shared EQUAL As TokenDefinition
public:
static TokenDefinition^ EQUAL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


EQUALSS Field

EQUALSS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► EQUALSS
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition EQUALSS
Public Shared EQUALSS As TokenDefinition
public:
static TokenDefinition^ EQUALSS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ERROR Field

ERROR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ERROR
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ERROR
Public Shared ERROR As TokenDefinition
public:
static TokenDefinition^ ERROR

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


FLOAT Field

FLOAT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► FLOAT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition FLOAT
Public Shared FLOAT As TokenDefinition
public:
static TokenDefinition^ FLOAT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GREATERTHAN Field

GREATERTHAN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► GREATERTHAN
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition GREATERTHAN
Public Shared GREATERTHAN As TokenDefinition
public:
static TokenDefinition^ GREATERTHAN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GREATERTHANOREQUALTO Field

GREATERTHANOREQUALTO Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► GREATERTHANOREQUALTO
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition GREATERTHANOREQUALTO
Public Shared GREATERTHANOREQUALTO As TokenDefinition
public:
static TokenDefinition^ GREATERTHANOREQUALTO

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IF Field

IF Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► IF
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition IF
Public Shared IF As TokenDefinition
public:
static TokenDefinition^ IF

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IFSTATEMENT Field

IFSTATEMENT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► IFSTATEMENT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition IFSTATEMENT
Public Shared IFSTATEMENT As TokenDefinition
public:
static TokenDefinition^ IFSTATEMENT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


INDEXER Field

INDEXER Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INDEXER
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INDEXER
Public Shared INDEXER As TokenDefinition
public:
static TokenDefinition^ INDEXER

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


INT Field

INT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INT
Public Shared INT As TokenDefinition
public:
static TokenDefinition^ INT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


INTEGERINDEXLIST Field

INTEGERINDEXLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INTEGERINDEXLIST
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INTEGERINDEXLIST
Public Shared INTEGERINDEXLIST As TokenDefinition
public:
static TokenDefinition^ INTEGERINDEXLIST

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


INTEGERLIST Field

INTEGERLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INTEGERLIST
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INTEGERLIST
Public Shared INTEGERLIST As TokenDefinition
public:
static TokenDefinition^ INTEGERLIST

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LEFT Field

LEFT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LEFT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LEFT
Public Shared LEFT As TokenDefinition
public:
static TokenDefinition^ LEFT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LEFTBRACKET Field

LEFTBRACKET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LEFTBRACKET
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LEFTBRACKET
Public Shared LEFTBRACKET As TokenDefinition
public:
static TokenDefinition^ LEFTBRACKET

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LENGTHEQUAL Field

LENGTHEQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LENGTHEQUAL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LENGTHEQUAL
Public Shared LENGTHEQUAL As TokenDefinition
public:
static TokenDefinition^ LENGTHEQUAL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LENGTHGREATERTHAN Field

LENGTHGREATERTHAN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LENGTHGREATERTHAN
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LENGTHGREATERTHAN
Public Shared LENGTHGREATERTHAN As TokenDefinition
public:
static TokenDefinition^ LENGTHGREATERTHAN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LENGTHLESSTHAN Field

LENGTHLESSTHAN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LENGTHLESSTHAN
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LENGTHLESSTHAN
Public Shared LENGTHLESSTHAN As TokenDefinition
public:
static TokenDefinition^ LENGTHLESSTHAN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LENGTHNOTEQUAL Field

LENGTHNOTEQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LENGTHNOTEQUAL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LENGTHNOTEQUAL
Public Shared LENGTHNOTEQUAL As TokenDefinition
public:
static TokenDefinition^ LENGTHNOTEQUAL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LESSTHAN Field

LESSTHAN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LESSTHAN
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LESSTHAN
Public Shared LESSTHAN As TokenDefinition
public:
static TokenDefinition^ LESSTHAN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LESSTHANOREQUALTO Field

LESSTHANOREQUALTO Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LESSTHANOREQUALTO
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LESSTHANOREQUALTO
Public Shared LESSTHANOREQUALTO As TokenDefinition
public:
static TokenDefinition^ LESSTHANOREQUALTO

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


LOCALCODE Field

LOCALCODE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LOCALCODE
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LOCALCODE
Public Shared LOCALCODE As TokenDefinition
public:
static TokenDefinition^ LOCALCODE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NOTCONTAINS Field

NOTCONTAINS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTCONTAINS
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTCONTAINS
Public Shared NOTCONTAINS As TokenDefinition
public:
static TokenDefinition^ NOTCONTAINS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NOTENDSWITH Field

NOTENDSWITH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTENDSWITH
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTENDSWITH
Public Shared NOTENDSWITH As TokenDefinition
public:
static TokenDefinition^ NOTENDSWITH

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NOTEQUAL Field

NOTEQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTEQUAL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTEQUAL
Public Shared NOTEQUAL As TokenDefinition
public:
static TokenDefinition^ NOTEQUAL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NOTRECOMMENDED Field

NOTRECOMMENDED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTRECOMMENDED
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTRECOMMENDED
Public Shared NOTRECOMMENDED As TokenDefinition
public:
static TokenDefinition^ NOTRECOMMENDED

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NOTSTARTSWITH Field

NOTSTARTSWITH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTSTARTSWITH
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTSTARTSWITH
Public Shared NOTSTARTSWITH As TokenDefinition
public:
static TokenDefinition^ NOTSTARTSWITH

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NOTUSED Field

NOTUSED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTUSED
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTUSED
Public Shared NOTUSED As TokenDefinition
public:
static TokenDefinition^ NOTUSED

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


NULL Field

NULL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NULL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NULL
Public Shared NULL As TokenDefinition
public:
static TokenDefinition^ NULL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OPTIONAL Field

OPTIONAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► OPTIONAL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition OPTIONAL
Public Shared OPTIONAL As TokenDefinition
public:
static TokenDefinition^ OPTIONAL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


OR Field

OR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► OR
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition OR
Public Shared OR As TokenDefinition
public:
static TokenDefinition^ OR

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RECOMMENDED Field

RECOMMENDED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► RECOMMENDED
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition RECOMMENDED
Public Shared RECOMMENDED As TokenDefinition
public:
static TokenDefinition^ RECOMMENDED

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


REQUIRED Field

REQUIRED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► REQUIRED
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition REQUIRED
Public Shared REQUIRED As TokenDefinition
public:
static TokenDefinition^ REQUIRED

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RIGHT Field

RIGHT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► RIGHT
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition RIGHT
Public Shared RIGHT As TokenDefinition
public:
static TokenDefinition^ RIGHT

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RIGHTBRACKET Field

RIGHTBRACKET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► RIGHTBRACKET
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition RIGHTBRACKET
Public Shared RIGHTBRACKET As TokenDefinition
public:
static TokenDefinition^ RIGHTBRACKET

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentMissing Field

SegmentMissing Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentMissing
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentMissing
Public Shared SegmentMissing As TokenDefinition
public:
static TokenDefinition^ SegmentMissing

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentNotRecommended Field

SegmentNotRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentNotRecommended
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentNotRecommended
Public Shared SegmentNotRecommended As TokenDefinition
public:
static TokenDefinition^ SegmentNotRecommended

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentNotUsed Field

SegmentNotUsed Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentNotUsed
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentNotUsed
Public Shared SegmentNotUsed As TokenDefinition
public:
static TokenDefinition^ SegmentNotUsed

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SegmentRecommended Field

SegmentRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentRecommended
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentRecommended
Public Shared SegmentRecommended As TokenDefinition
public:
static TokenDefinition^ SegmentRecommended

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SEGPOS Field

SEGPOS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SEGPOS
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SEGPOS
Public Shared SEGPOS As TokenDefinition
public:
static TokenDefinition^ SEGPOS

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SEMICOLON Field

SEMICOLON Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SEMICOLON
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SEMICOLON
Public Shared SEMICOLON As TokenDefinition
public:
static TokenDefinition^ SEMICOLON

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SPACE Field

SPACE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SPACE
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SPACE
Public Shared SPACE As TokenDefinition
public:
static TokenDefinition^ SPACE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


STARTSWITH Field

STARTSWITH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► STARTSWITH
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition STARTSWITH
Public Shared STARTSWITH As TokenDefinition
public:
static TokenDefinition^ STARTSWITH

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


STRING Field

STRING Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► STRING
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition STRING
Public Shared STRING As TokenDefinition
public:
static TokenDefinition^ STRING

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


STRINGLIST Field

STRINGLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► STRINGLIST
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition STRINGLIST
Public Shared STRINGLIST As TokenDefinition
public:
static TokenDefinition^ STRINGLIST

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SYMBOL Field

SYMBOL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SYMBOL
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SYMBOL
Public Shared SYMBOL As TokenDefinition
public:
static TokenDefinition^ SYMBOL

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


THEN Field

THEN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► THEN
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition THEN
Public Shared THEN As TokenDefinition
public:
static TokenDefinition^ THEN

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


USAGE Field

USAGE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► USAGE
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition USAGE
Public Shared USAGE As TokenDefinition
public:
static TokenDefinition^ USAGE

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UsageNode Class

UsageNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class UsageNode : Node
Public Class UsageNode _
    Inherits Node
public ref class UsageNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UsageNode(String, Int32) | Initializes a new instance of the UsageNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Usage |
Inheritance Hierarchy
Object
 | Node
 |  | UsageNode

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UsageNode Constructor (text, depth)

UsageNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode ► UsageNode(String, Int32)
RDPCrystal EDI Library
Initializes a new instance of the UsageNode class
Declaration Syntax
C# Visual Basic Visual C++
public UsageNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
UsageNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode ► ToRuleString()()()()
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode ► Usage
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RDPCrystalEDILibrary.UI.Winforms Namespace

RDPCrystalEDILibrary.UI.Winforms Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.UI.Winforms
Namespace RDPCrystalEDILibrary.UI.Winforms
namespace RDPCrystalEDILibrary.UI.Winforms
Types
All Types Classes
Icon | Type | Description
 | EDINodeSelectedEventArgs |
 | TreeGenerator |


EDINodeSelectedEventArgs Class

EDINodeSelectedEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► EDINodeSelectedEventArgs
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public class EDINodeSelectedEventArgs : EventArgs
Public Class EDINodeSelectedEventArgs _
    Inherits EventArgs
public ref class EDINodeSelectedEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SelectedObject |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EDINodeSelectedEventArgs

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


SelectedObject Property

SelectedObject Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► EDINodeSelectedEventArgs ► SelectedObject
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public Object SelectedObject { get; set; }
Public Property SelectedObject As Object
    Get
    Set
public:
property Object^ SelectedObject {
    Object^ get ();
    void set (Object^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


TreeGenerator Class

TreeGenerator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public static class TreeGenerator
Public NotInheritable Class TreeGenerator
public ref class TreeGenerator abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildEDIDocumentTree(EDIDocument, Boolean) | Builds the EDI document tree.
 | BuildRulesTree(EDIRulesReader) | Builds the rules tree.
 | BuildValidatedDataTree(EDIValidator) | Builds the validated data tree.
Inheritance Hierarchy
Object
TreeGenerator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


BuildEDIDocumentTree Method (document, expandLoopNode)

BuildEDIDocumentTree Method (document, expandLoopNode)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator ► BuildEDIDocumentTree(EDIDocument, Boolean)
RDPCrystal EDI Library
Builds the EDI document tree.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode BuildEDIDocumentTree(
    EDIDocument document,
    bool expandLoopNode
)
Public Shared Function BuildEDIDocumentTree ( _
    document As EDIDocument, _
    expandLoopNode As Boolean _
) As TreeNode
public:
static TreeNode^ BuildEDIDocumentTree(
    EDIDocument^ document,
    bool expandLoopNode
)
Parameters
document (EDIDocument)
The document.
expandLoopNode (Boolean)
if set to true [expand loop node].
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


BuildRulesTree Method (reader)

BuildRulesTree Method (reader)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator ► BuildRulesTree(EDIRulesReader)
RDPCrystal EDI Library
Builds the rules tree.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode BuildRulesTree(
    EDIRulesReader reader
)
Public Shared Function BuildRulesTree ( _
    reader As EDIRulesReader _
) As TreeNode
public:
static TreeNode^ BuildRulesTree(
    EDIRulesReader^ reader
)
Parameters
reader (EDIRulesReader)
The reader.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


BuildValidatedDataTree Method (validator)

BuildValidatedDataTree Method (validator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator ► BuildValidatedDataTree(EDIValidator)
RDPCrystal EDI Library
Builds the validated data tree.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode BuildValidatedDataTree(
    EDIValidator validator
)
Public Shared Function BuildValidatedDataTree ( _
    validator As EDIValidator _
) As TreeNode
public:
static TreeNode^ BuildValidatedDataTree(
    EDIValidator^ validator
)
Parameters
validator (EDIValidator)
The validator.
Return Value

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


RDPCrystalEDILibrary.UI.Winforms.Controls Namespace

RDPCrystalEDILibrary.UI.Winforms.Controls Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.UI.Winforms.Controls
Namespace RDPCrystalEDILibrary.UI.Winforms.Controls
namespace RDPCrystalEDILibrary.UI.Winforms.Controls
Types
All Types Classes Delegates
Icon | Type | Description
 | EDIDocumentViewer | A high performance, low memory UI component that allows you to view your loaded documents in a hierarchical fashion
 | ValidationUnit..::..ErrorEvent |
 | ValidationUnit..::..ValidationButtonClickedEvent |
 | ValidationUnit..::..ValidationCompletedEvent |
 | ValidationUnit |


EDIDocumentViewer Class

EDIDocumentViewer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer
RDPCrystal EDI Library
A high performance, low memory UI component that allows you to view your loaded documents in a hierarchical fashion
Declaration Syntax
C# Visual Basic Visual C++
public class EDIDocumentViewer : UserControl
Public Class EDIDocumentViewer _
    Inherits UserControl
public ref class EDIDocumentViewer : public UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIDocumentViewer()()()() | Initializes a new instance of the EDIDocumentViewer class.
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
 | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
 | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
 | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
 | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | ClearDocument()()()() | Removes all nodes
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates a handle for the control. (Inherited from Control.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DocumentCreator |
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
 | LoadDocument(EDILightWeightDocument) | Loads a EDILightWeightDocument into the EDIDocumentViewer
 | LoadDocument(EDIDocument) | Loads a EDIDocument into the EDIDocumentViewer
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NodeSelected | Occurs when a node is selected
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | Raises the HandleCreated event. (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | Raises the HandleDestroyed event. (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. (Inherited from Control.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | EDIDocumentViewer

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


EDIDocumentViewer Constructor

EDIDocumentViewer Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► EDIDocumentViewer()()()()
RDPCrystal EDI Library
Initializes a new instance of the EDIDocumentViewer class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocumentViewer()
Public Sub New
public:
EDIDocumentViewer()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ClearDocument Method

ClearDocument Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► ClearDocument()()()()
RDPCrystal EDI Library
Removes all nodes
Declaration Syntax
C# Visual Basic Visual C++
public void ClearDocument()
Public Sub ClearDocument
public:
void ClearDocument()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


DocumentCreator Field

DocumentCreator Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► DocumentCreator
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public DocumentCreator DocumentCreator
Public DocumentCreator As DocumentCreator
public:
DocumentCreator DocumentCreator

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


LoadDocument Method

LoadDocument Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► LoadDocument()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | LoadDocument(EDILightWeightDocument) | Loads a EDILightWeightDocument into the EDIDocumentViewer
 | LoadDocument(EDIDocument) | Loads a EDIDocument into the EDIDocumentViewer

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


LoadDocument Method (document)

LoadDocument Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► LoadDocument(EDIDocument)
RDPCrystal EDI Library
Loads a EDIDocument into the EDIDocumentViewer
Declaration Syntax
C# Visual Basic Visual C++
public void LoadDocument(
    EDIDocument document
)
Public Sub LoadDocument ( _
    document As EDIDocument _
)
public:
void LoadDocument(
    EDIDocument^ document
)
Parameters
document (EDIDocument)
the document to load

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


LoadDocument Method (document)

LoadDocument Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► LoadDocument(EDILightWeightDocument)
RDPCrystal EDI Library
Loads a EDILightWeightDocument into the EDIDocumentViewer
Declaration Syntax
C# Visual Basic Visual C++
public void LoadDocument(
    EDILightWeightDocument document
)
Public Sub LoadDocument ( _
    document As EDILightWeightDocument _
)
public:
void LoadDocument(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
the document to load

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


NodeSelected Event

NodeSelected Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► NodeSelected
RDPCrystal EDI Library
Occurs when a node is selected
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EDINodeSelectedEventArgs> NodeSelected
Public Event NodeSelected As EventHandler(Of EDINodeSelectedEventArgs)
public:
 event EventHandler<EDINodeSelectedEventArgs^>^ NodeSelected {
    void add (EventHandler<EDINodeSelectedEventArgs^>^ value);
    void remove (EventHandler<EDINodeSelectedEventArgs^>^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationUnit Class

ValidationUnit Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ValidationUnit : UserControl
Public NotInheritable Class ValidationUnit _
    Inherits UserControl
public ref class ValidationUnit sealed : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationUnit()()()() | Creates a new validation object
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
 | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
 | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
 | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
 | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | CheckDataTypeRequirements | Check that elements values are correct for their specified data types
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates a handle for the control. (Inherited from Control.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | Delimiters | Get/set EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | EDIFile | Get/set the file to validate
 | EDIFileBackColor | Get/set background color of EDI File Section
 | EDIFileForeColor | Get/set forecolor color of EDI File Section
 | EDIFileType | Get/set the type of EDI file to validate
 | EDIRuleFile | Get/set the validation rules file
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorOccurred | Event raised when an unexpected error occurrs
 | ErrorTableBackColor | Get/set background color of Error table
 | ErrorTableForeColor | Forecolor color of Error table
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | ExportToCSV(String) | Export Errors and Warnings to Comma Separated File list
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HideEDIFileSection | Get/set if the EDI File Section section should be visible
 | HideLoadDataSection | Get/set if the Load Data section should be visible
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
 | LoadFile | Get/set if the file should be loaded into the validation unit
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | NumberOfErrors | Get the number of errors
 | NumberOfWarnings | Get the number of warnings
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | Raises the HandleCreated event. (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | Raises the HandleDestroyed event. (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. (Inherited from Control.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreventInfiniteLoopWhileSearching | If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowFileInputSection | Get/set if the File Input section should be visible
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuppressValidationCompleteMessage | Get/set if the validation complete message box should be surpressed
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrackDownUnrecognizedLoops | If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
 | TrimString | String to ignore at between segment delimiters
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | ValidateFile()()()() | Validate an EDI file
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | ValidationButtonClicked | Event raised when the validation button is clicked
 | ValidationCompleted | Event raised when validation has completed
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | ValidationUnit

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationUnit Constructor

ValidationUnit Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit()()()()
RDPCrystal EDI Library
Creates a new validation object
Declaration Syntax
C# Visual Basic Visual C++
public ValidationUnit()
Public Sub New
public:
ValidationUnit()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► AutoDetectDelimiters
RDPCrystal EDI Library
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


CheckDataTypeRequirements Property

CheckDataTypeRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► CheckDataTypeRequirements
RDPCrystal EDI Library
Check that elements values are correct for their specified data types
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckDataTypeRequirements { get; set; }
Public Property CheckDataTypeRequirements As Boolean
    Get
    Set
public:
property bool CheckDataTypeRequirements {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Delimiters
RDPCrystal EDI Library
Get/set EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Dispose(Boolean)
RDPCrystal EDI Library
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFile
RDPCrystal EDI Library
Get/set the file to validate
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


EDIFileBackColor Property

EDIFileBackColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFileBackColor
RDPCrystal EDI Library
Get/set background color of EDI File Section
Declaration Syntax
C# Visual Basic Visual C++
public Color EDIFileBackColor { get; set; }
Public Property EDIFileBackColor As Color
    Get
    Set
public:
property Color EDIFileBackColor {
    Color get ();
    void set (Color value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


EDIFileForeColor Property

EDIFileForeColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFileForeColor
RDPCrystal EDI Library
Get/set forecolor color of EDI File Section
Declaration Syntax
C# Visual Basic Visual C++
public Color EDIFileForeColor { get; set; }
Public Property EDIFileForeColor As Color
    Get
    Set
public:
property Color EDIFileForeColor {
    Color get ();
    void set (Color value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFileType
RDPCrystal EDI Library
Get/set the type of EDI file to validate
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


EDIRuleFile Property

EDIRuleFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIRuleFile
RDPCrystal EDI Library
Get/set the validation rules file
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRuleFile { get; set; }
Public Property EDIRuleFile As String
    Get
    Set
public:
property String^ EDIRuleFile {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ErrorOccurred Event

ErrorOccurred Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ErrorOccurred
RDPCrystal EDI Library
Event raised when an unexpected error occurrs
Declaration Syntax
C# Visual Basic Visual C++
public event ValidationUnit..::..ErrorEvent ErrorOccurred
Public Event ErrorOccurred As ValidationUnit..::..ErrorEvent
public:
 event ValidationUnit..::..ErrorEvent^ ErrorOccurred {
    void add (ValidationUnit..::..ErrorEvent^ value);
    void remove (ValidationUnit..::..ErrorEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ErrorTableBackColor Property

ErrorTableBackColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ErrorTableBackColor
RDPCrystal EDI Library
Get/set background color of Error table
Declaration Syntax
C# Visual Basic Visual C++
public Color ErrorTableBackColor { get; set; }
Public Property ErrorTableBackColor As Color
    Get
    Set
public:
property Color ErrorTableBackColor {
    Color get ();
    void set (Color value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ErrorTableForeColor Property

ErrorTableForeColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ErrorTableForeColor
RDPCrystal EDI Library
Forecolor color of Error table
Declaration Syntax
C# Visual Basic Visual C++
public Color ErrorTableForeColor { get; set; }
Public Property ErrorTableForeColor As Color
    Get
    Set
public:
property Color ErrorTableForeColor {
    Color get ();
    void set (Color value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ExportToCSV Method (filePath)

ExportToCSV Method (filePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ExportToCSV(String)
RDPCrystal EDI Library
Export Errors and Warnings to Comma Separated File list
Declaration Syntax
C# Visual Basic Visual C++
public void ExportToCSV(
    string filePath
)
Public Sub ExportToCSV ( _
    filePath As String _
)
public:
void ExportToCSV(
    String^ filePath
)
Parameters
filePath (String)
path and name of file

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


HideEDIFileSection Property

HideEDIFileSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► HideEDIFileSection
RDPCrystal EDI Library
Get/set if the EDI File Section section should be visible
Declaration Syntax
C# Visual Basic Visual C++
public bool HideEDIFileSection { get; set; }
Public Property HideEDIFileSection As Boolean
    Get
    Set
public:
property bool HideEDIFileSection {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


HideLoadDataSection Property

HideLoadDataSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► HideLoadDataSection
RDPCrystal EDI Library
Get/set if the Load Data section should be visible
Declaration Syntax
C# Visual Basic Visual C++
public bool HideLoadDataSection { get; set; }
Public Property HideLoadDataSection As Boolean
    Get
    Set
public:
property bool HideLoadDataSection {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


LoadFile Property

LoadFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► LoadFile
RDPCrystal EDI Library
Get/set if the file should be loaded into the validation unit
Declaration Syntax
C# Visual Basic Visual C++
public bool LoadFile { get; set; }
Public Property LoadFile As Boolean
    Get
    Set
public:
property bool LoadFile {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


NumberOfErrors Property

NumberOfErrors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► NumberOfErrors
RDPCrystal EDI Library
Get the number of errors
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfErrors { get; }
Public ReadOnly Property NumberOfErrors As Integer
    Get
public:
property int NumberOfErrors {
    int get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


NumberOfWarnings Property

NumberOfWarnings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► NumberOfWarnings
RDPCrystal EDI Library
Get the number of warnings
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfWarnings { get; }
Public ReadOnly Property NumberOfWarnings As Integer
    Get
public:
property int NumberOfWarnings {
    int get ();
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


PreventInfiniteLoopWhileSearching Property

PreventInfiniteLoopWhileSearching Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► PreventInfiniteLoopWhileSearching
RDPCrystal EDI Library
If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
Declaration Syntax
C# Visual Basic Visual C++
public bool PreventInfiniteLoopWhileSearching { get; set; }
Public Property PreventInfiniteLoopWhileSearching As Boolean
    Get
    Set
public:
property bool PreventInfiniteLoopWhileSearching {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ShowFileInputSection Property

ShowFileInputSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ShowFileInputSection
RDPCrystal EDI Library
Get/set if the File Input section should be visible
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowFileInputSection { get; set; }
Public Property ShowFileInputSection As Boolean
    Get
    Set
public:
property bool ShowFileInputSection {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


SuppressValidationCompleteMessage Property

SuppressValidationCompleteMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► SuppressValidationCompleteMessage
RDPCrystal EDI Library
Get/set if the validation complete message box should be surpressed
Declaration Syntax
C# Visual Basic Visual C++
public bool SuppressValidationCompleteMessage { get; set; }
Public Property SuppressValidationCompleteMessage As Boolean
    Get
    Set
public:
property bool SuppressValidationCompleteMessage {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


TrackDownUnrecognizedLoops Property

TrackDownUnrecognizedLoops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► TrackDownUnrecognizedLoops
RDPCrystal EDI Library
If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
Declaration Syntax
C# Visual Basic Visual C++
public bool TrackDownUnrecognizedLoops { get; set; }
Public Property TrackDownUnrecognizedLoops As Boolean
    Get
    Set
public:
property bool TrackDownUnrecognizedLoops {
    bool get ();
    void set (bool value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► TrimString
RDPCrystal EDI Library
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidateFile Method

ValidateFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidateFile()()()()
RDPCrystal EDI Library
Validate an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void ValidateFile()
Public Sub ValidateFile
public:
void ValidateFile()

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationButtonClicked Event

ValidationButtonClicked Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationButtonClicked
RDPCrystal EDI Library
Event raised when the validation button is clicked
Declaration Syntax
C# Visual Basic Visual C++
public event ValidationUnit..::..ValidationButtonClickedEvent ValidationButtonClicked
Public Event ValidationButtonClicked As ValidationUnit..::..ValidationButtonClickedEvent
public:
 event ValidationUnit..::..ValidationButtonClickedEvent^ ValidationButtonClicked {
    void add (ValidationUnit..::..ValidationButtonClickedEvent^ value);
    void remove (ValidationUnit..::..ValidationButtonClickedEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationCompleted Event

ValidationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationCompleted
RDPCrystal EDI Library
Event raised when validation has completed
Declaration Syntax
C# Visual Basic Visual C++
public event ValidationUnit..::..ValidationCompletedEvent ValidationCompleted
Public Event ValidationCompleted As ValidationUnit..::..ValidationCompletedEvent
public:
 event ValidationUnit..::..ValidationCompletedEvent^ ValidationCompleted {
    void add (ValidationUnit..::..ValidationCompletedEvent^ value);
    void remove (ValidationUnit..::..ValidationCompletedEvent^ value);
}

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationUnit.ErrorEvent Delegate

ValidationUnit..::..ErrorEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit..::..ErrorEvent
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ErrorEvent(
    Object sender,
    GeneralEventArgs e
)
Public Delegate Sub ErrorEvent ( _
    sender As Object, _
    e As GeneralEventArgs _
)
public delegate void ErrorEvent(
    Object^ sender,
    GeneralEventArgs^ e
)
Parameters
sender (Object)
e (GeneralEventArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationUnit.ValidationButtonClickedEvent Delegate

ValidationUnit..::..ValidationButtonClickedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit..::..ValidationButtonClickedEvent
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationButtonClickedEvent(
    Object sender
)
Public Delegate Sub ValidationButtonClickedEvent ( _
    sender As Object _
)
public delegate void ValidationButtonClickedEvent(
    Object^ sender
)
Parameters
sender (Object)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidationUnit.ValidationCompletedEvent Delegate

ValidationUnit..::..ValidationCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit..::..ValidationCompletedEvent
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationCompletedEvent(
    Object sender,
    ValidationEventsArgs e
)
Public Delegate Sub ValidationCompletedEvent ( _
    sender As Object, _
    e As ValidationEventsArgs _
)
public delegate void ValidationCompletedEvent(
    Object^ sender,
    ValidationEventsArgs^ e
)
Parameters
sender (Object)
e (ValidationEventsArgs)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ConvertFromInvariantString Method

ConvertFromInvariantString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertFromInvariantString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture.
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


IsValid Method

IsValid Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► IsValid()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | IsValid(Object) | Returns whether the given value object is valid for this type.
 | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetStandardValuesSupported Method

GetStandardValuesSupported Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetStandardValuesSupported()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list.
 | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementListConditionalConstraint ► GetElementOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ResumeLayout Method

ResumeLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ResumeLayout()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ConvertFrom Method

ConvertFrom Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertFrom()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ConvertFrom(Object) | Converts the given value to the type of this converter.
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


PerformLayout Method

PerformLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► PerformLayout()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UpdateBounds Method

UpdateBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► UpdateBounds()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Select Method

Select Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Select()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


RtlTranslateAlignment Method

RtlTranslateAlignment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► RtlTranslateAlignment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


GetStandardValues Method

GetStandardValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetStandardValues()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for.
 | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


SetBounds Method

SetBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► SetBounds()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetCreateInstanceSupported()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value.
 | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Invalidate Method

Invalidate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Invalidate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


SetBounds Method

SetBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► SetBounds()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ToEDIString Method

ToEDIString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x5010 ► Typed5010Document ► ToEDIString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.Docs.x5010 (Module: RDPCrystalEDILibrary.Docs.x5010) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ConvertToString Method

ConvertToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertToString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ConvertToString(Object) | Converts the specified value to a string representation.
 | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context.
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


UpdateBounds Method

UpdateBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► UpdateBounds()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ConvertFromString Method

ConvertFromString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertFromString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ConvertFromString(String) | Converts the specified text to an object.
 | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context.
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.PrinterForms ► FormPrinter ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.PrinterForms (Module: RDPCrystalEDILibrary.PrinterForms) Version: 1.0.0.4 (1.0.0.4)


ToEDIString Method

ToEDIString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document ► ToEDIString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document


RtlTranslateAlignment Method

RtlTranslateAlignment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► RtlTranslateAlignment()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Validate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Invoke Method

Invoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Invoke()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateSegmentLoop Method

CreateSegmentLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegmentLoop()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CreateSegmentLoop(String, Int32, Int32, Usage, String) |
 | CreateSegmentLoop(String) |

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Invalidate Method

Invalidate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Invalidate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ResumeLayout Method

ResumeLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► ResumeLayout()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


PerformLayout Method

PerformLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► PerformLayout()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


GetChildAtPoint Method

GetChildAtPoint Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► GetChildAtPoint()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► AccessibilityNotifyClients()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementConditionalConstraint ► GetElementOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Select Method

Select Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Select()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ConvertToInvariantString Method

ConvertToInvariantString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertToInvariantString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation.
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Invoke Method

Invoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Invoke()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


CreateInstance Method

CreateInstance Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CreateInstance()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object.
 | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetChildAtPoint Method

GetChildAtPoint Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► GetChildAtPoint()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementRequiredConstraint ► GetElementOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetPropertiesSupported Method

GetPropertiesSupported Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetPropertiesSupported()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter.GetPropertiesSupported(ITypeDescriptorContext).)
 | GetPropertiesSupported()()()() | Returns whether this object supports properties.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


GetStandardValuesExclusive Method

GetStandardValuesExclusive Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetStandardValuesExclusive()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list.
 | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Docs.x4010 ► Typed4010Document ► GenerateEDIFile()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► AccessibilityNotifyClients()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetProperties Method

GetProperties Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetProperties()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
 | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter.
 | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Scale Method

Scale Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Scale()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


CanConvertTo Method

CanConvertTo Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CanConvertTo()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
 | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ConvertTo Method

ConvertTo Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertTo()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


RDPCrystalEDILibrary

RDPCrystalEDILibrary
RDPCrystalEDILibrary
RDPCrystal EDI Library
Namespaces
Namespace | Description
RDPCrystalEDILibrary | RDPCrystal EDI Library
RDPCrystalEDILibrary.Docs.x4010 |
RDPCrystalEDILibrary.Docs.x5010 |
RDPCrystalEDILibrary.PrinterForms |
RDPCrystalEDILibrary.Rules |
RDPCrystalEDILibrary.UI.Winforms |
RDPCrystalEDILibrary.UI.Winforms.Controls |


CanConvertFrom Method

CanConvertFrom Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CanConvertFrom()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
 | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Validate()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


ValidateChildren Method

ValidateChildren Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidateChildren()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementExclusionConstraint ► GetElementOrdinalsString()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


ValidateChildren Method

ValidateChildren Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► ValidateChildren()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Scale Method

Scale Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Scale()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


BeginInvoke Method

BeginInvoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► BeginInvoke()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► MemberwiseClone()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)


BeginInvoke Method

BeginInvoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► BeginInvoke()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 9.6.0.0 (9.6.0.0)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Dispose()()()()
RDPCrystal EDI Library
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Copyright 2020 Crystal Universe Software Inc.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 9.6.0.0 (9.6.0.0)