Welcome! - PowerTCP Telnet for .NET CF

PowerTCP Telnet for .NET CF
Welcome!
Send comments on this topic.

PowerTCP Telnet for .NET CF fills the Telnet and remote access communication gap in the .NET Compact Framework by providing stream-based Telnet communication that can be plugged into any Compact Framework 2.0+ application.

Overview

This latest version of the venerable PowerTCP product line gets a new .NET 2.0 re-design that leverages the power of the latest .NET environments to provide the most advanced Internet Communications components available. Some of the features include:

  • Auto-login capabilities
  • Auto-option negotiation with easy configuration options
  • Secure SSL Telnet support
  • Blocking reads that wait for defined delimiters, specifically designed for scripting applications
  • Start method for easily implemented multi-threaded applications, including cross-threading marshaling support
  • PTY property binds a TextBox to the Telnet component as a ready-made interface for interactive online communications
  • Logging event for easy debugging and session logging
  • Proxy support
  • Includes Rexec, Rsh and Rlogin components in addition to Telnet

Background

The Visual Basic environment introduced the use of components (VBX and OCX), but typically only executed on the UI thread. Though multi-threaded support was added at the Operating System level, developers needed C++ to created multi-threaded applications.

When 32-bit application support was added to Visual Basic, PowerTCP was able to use background worker threads to execute communication tasks, and not interfere with the UI. Events, however, could only be raised on the UI thread.

.NET Version 1

The use of worker threads, delegates and events was greatly improved under .NET 1.0:

  • Background threads could be conveniently started
  • Events could be raised on worker threads

In fact, the multi-threaded environment became so powerful that users needed to become aware of concepts like thread safety and synchronization, which were never of concern before.

PowerTCP evolved as well, providing an interface that included blocking methods (which block the executing thread until completion), pseudo-blocking methods (which block the UI thread until completion, but process events while doing so), and asynchronous methods (which execute on background threads). The goal was to provide as complete an interface as possible, without making it complex or difficult to use.

.NET Version 2

The .NET environment has evolved, and so has its users. Customers are developing more applications for ASP.NET, more console applications, and more service applications. Lacking UIs, pseudo-blocking and asynchronous methods are not relevant for these environments. There are also trends towards greater levels of customer control. For these reasons, PowerTCP for .NET 4.x was designed with the following emphases:

  • Improved Asynchronous Support
    Traditional PowerTCP asynchronous support provided a means for executing methods on worker threads, but this required a signaling mechanism indicating when operations completed. This resulted in difficult-to-maintain, event-driven code. With the new design, code is more self-documenting, uses fewer resources, and is more flexible to use. Please see Asynchronous Operation for a more detailed examination of the benefits of this new design.

  • Improved Re-Use of .NET 2.0 Features
    PowerTCP 4.x has taken advantage of generics, improved support for X509 certificates, and other features introduced in .NET 2.0. Now that most users have migrated from .NET 1.x, PowerTCP can be upgraded without sacrificing backward compatibility. Of course, the .NET 1.x product line will still be licensed for use in the .NET 1.x environment to support legacy applications.

  • Integrated Security
    Secure Socket Layer (SSL) security is integrated into the core product, so that SSL encryption is included in each new product.

  • Support for .NET CF (Compact Framework)
    Comprehensive support of the Compact Framework has been extended with the new design.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component

Documentation Version 4.2
© 2010 Dart Communications. All Rights Reserved.


Getting Started - PowerTCP Telnet for .NET CF

Getting Started
Send comments on this topic.

In addition to perusing this documentation, it is highly recommended that the user examine the sample applications available on the website.

For the most basic quick-start, create a new Windows Application project in Visual Studio, drag the Telnet component and a button onto the form, and add code to your Click event handler. Examine this documentation for simple example snippets to emulate.

Sample Applications

All samples include C# and VB.NET version.

Sample | Description
Automated Client | Demonstrates execution of an automated application using Telnet.
rCommands Client | Demonstrates use of the Rexec, Rlogin and Rsh components.
Telnet Client | Demonstrates a user-interactive Telnet client.

Download the Telnet for .NET CF Sample Applications

Support Options

Our mission at Dart is to deliver high quality Internet connectivity solutions to Internet application developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

You must have an active connection to the Internet to view these links.

Paid Support Options
Discusses the paid support options available.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Dart Solutions
Discusses the custom development support offered by Dart Solutions.

Authenticode Signing

Dart installation executables are authenticode signed with a "Dart Communications" digital certificate to ensure against tampering during distribution.

Dart dlls included in the installation bin directory are .NET strong name signed, but not authenticode signed. These dlls are used by the sample applications and typically referenced in users' products.

For those users who require dlls signed by the author company (for example, for Windows logo compliance), dlls that have been signed with the "Dart Communications" digital certificate are also included in the product. These dlls are contained in the "Signed Distributables" sub-folder under the installation bin folder.

In accordance with the End-User Licensing Agreement, pre-compiled Dart dlls may NOT be signed with a user's own certificate. However, for users who wish to independently sign these dlls, Dart offers Enterprise licenses which allow for this. Please contact sales@dart.com for more information.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Licensing and Trial Operation - PowerTCP Telnet for .NET CF

Licensing and Trial Operation
Send comments on this topic.

Licensing the Product

The Developer License

Licensed components require the presence of a Developer License in order to create a valid runtime license resource. Developer Licenses are specific to the user's development machine, and to the version of the Dart assembly used.

Obtaining a Developer License

After purchase of the product, the developer is furnished with a Product Key (Serial Number) that licenses development for a single user on up to two machines.

To obtain the Developer License, run the included DartActivateLicense utility and enter the Product Key. This utility opens a web browser and navigates to the Dart Customer Center, where a zip file containing the Developer License file is available for download. If an Internet connection does not exist, the utility provides a URL for downloading the Developer License file at a later date.

Subscription customers can obtain a Product Key for a product that has been upgraded by visiting the "My Products" page of the Customer Center and clicking on the listed current license.

Location of the Developer License

The Developer License file should be extracted from the downloaded zip file and saved to the following location:

Program Files \ Dart \ PowerTCP Telnet for .NET CF \ <Version Number> \ bin

where <Version Number> is a placeholder for the product version number associated with the license.

This location is also accessible from a shortcut added to the Start menu:

Start \ All Programs \ Dart \ PowerTCP Telnet for .NET CF \ <Version Number> \ Binaries Folder

At runtime, the component will search this location for the Developer License. No trial messages are subsequently seen.

The Developer License should never be deployed with an application.

Versioning

Developer Licenses are version-specific. Each minor version of the product (for example, 4.0 and 4.1) requires a separate Developer License. Build updates to the product (for example, 4.0.0 and 4.0.1) do not require new Developer Licenses. Minor version upgrades are available to developers with active subscriptions for the product.

Developer License Filename

The Developer License filename has the following format:

Dart.Telnet.CF.developer.dartlic

Important!!!

A machine must have a Developer License to license runtime use.

The .licenses Resource

An <appname>.licenses resource file is linked into the developed assembly during compilation. This file contains either the Product Key or a trial expiration date. This resource is read at runtime to confirm that the topmost managed assembly is licensed. A LicenseException is thrown if no license is found.

The licenses.licx File

When a licensed control or component is added to a Visual Studio project using the designer, a licenses.licx text file is created (if one does not already exist) and added to the project. A single-line entry is added to the file, which includes the licensed Class (for example, "Dart.Telnet.Telnet"), the Assembly name (for example, "Dart.Telnet.CF"), and some optional information such as Version Number. This file can be found in the Solution Explorer.

The presence of this licx file triggers the Microsoft license compiler utility (lc.exe) to create the .licenses resource during compilation.

Manual Creation of the licenses.licx

If the licenses.licx file is not automatically updated (such as when a licensed component is created in code or when the target platform is a device), the licenses.licx entry must be added manually. If it does not already exist in the project, a new text file named "licenses.licx" must be added to the Project. It is not enough for the file to exist in the working directory, or for it to be added to the Solution. The entry for the licensed component is a single line that includes the name of the component and the assembly name, separated by a comma. For example:

Dart.Telnet.Telnet, Dart.Telnet.CF20

Web Site Projects

Web Site projects include an App_Licenses.dll that must be rebuilt when changes are made to the licenses.licx file. This is accomplished by right-clicking on the licenses.licx file in the Solution Explorer, and selecting the "Rebuild Runtime Licenses" option.

Compilation Environments That Do Not Support the licenses.licx File, Like MONO

For environments that do not recognize the licenses.licx file, Dart has its own License Compiler application. This utility can be used to generate the <appname>.licenses resource file, which can then be added to the project as an embedded resource, or linked during compilation using the appropriate resource switch. Please contact Dart Support for help with compilation in environments that do not recognize the licenses.licx file.

Scripting Environments

A Developer License can be used in place of the license resource for environments without compilation.

Troubleshooting

LicenseExceptions thrown by the executing application should provide detailed information regarding the problem causing the exception.

In addition, the product utilizes the system's Application Event log, under the "Dart Components" source (or the ".NET Runtime" source, if the "Dart Components" log could not be created).

Important!!!

  • The license resource must be for the Entry (topmost managed) Assembly (exe or dll).
  • Cases in which the Entry Assembly is not the topmost executing application are considered "Plug-In" scenarios and require a Plug-In Distribution License or an ISV Distribution License (see below for more details).

Plug-In and ISV Licensing

Please contact Dart Sales to further explore the Plug-In and ISV licensing options.

Plug-In Distribution License

In "Plug-In" scenarios, a license resource cannot be created for the topmost executing assembly. This includes cases where the developed project is a

  • COM interop dll to be used by unmanaged applications
  • Managed dll to be used by managed applications developed by non-licensed users of the product

For most applications, Dart's intellectual property is protected when a strongly bound license resource is added. When used in a plug-in, however, there is no licensing relationship with the using application, as it is not strongly bound to the Dart product. Visual Studio, Firefox, IE, Access, BizTalk and many other products support the use of plug-ins. In addition, some users create their own plug-in environments. Dart's plug-in licensing naturally extends to these environments.

Plug-in operation requires the purchase of a Plug-In Distribution License. This license does not require the license resource be embedded in the topmost executing assembly.

ISV Distribution License

For Independent Software Developers (ISVs) or Enterprises who wish to bypass all licensing mechanisms, Dart offers the ISV Distribution License. The ISV license permits the tight integration of Dart source code directly into a library or application.

Trial Operation

At Runtime

Components used by applications running in trial mode will periodically show a trial message, and, after seven days of operation, expire.

7-Day Trial

An application compiled with a trial license can be deployed to other platforms for testing, but the license expires after 7 days.

  • No messages are shown during the Trial License's first 4 days.
  • After 4 days, the user is informed of the date the trial license will expire.
  • After 7 days, the user is informed of the trial's expiration. The application will cease functioning and throw a License Exception when used.
  • A trial license can be reset by recompiling the application.

Trial Messages

  • Trial messages and exceptions will always appear in the system's Application event log under the "Dart Components" source (or the ".NET Runtime" source, if the "Dart Components" log could not be created).
  • A trial message or exception will also appear in a MessageBox, if the environment is capable of showing MessageBoxes.
  • Components used in ASP.NET applications will show trial messages or exceptions in client-side alert boxes when possible.

Important!!!

For environments without an active desktop (for example, under some Windows service and web application scenarios), examine the Application event log for trial messages and exceptions.

With the exception of the trial messages and instance expiration exception, runtime trial operation is the same as licensed operation. The same dll is used for both trial and licensed operation.

During Development

A trial message is always displayed when a 7-Day Trial license is created.

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Product Page - PowerTCP Telnet for .NET CF

[image]
PowerTCP Telnet for .NET CF
Telnet Overview
Send comments on this topic.

The following information provides a basic understanding of the TELNET protocol and related concepts. This topic does not attempt to demonstrate usage of PowerTCP Telnet for .NET. For information of this type, see Asynchronous Operation and Assembly Overview.

Protocol Overview

TELNET (Telecommunications Network Protocol) is a data communications protocol—a set of rules for communications between computers. Telnet communication is the same for all systems, permitting it to work between different types of computers and operating systems. Telnet is often used for remote login—accessing one computer from another. A typical Telnet application would use the protocol to move data between a terminal emulator and a UNIX server (host).

Many host computers support the Telnet protocol. Its main use is online terminal communications; Telnet can be used to log in to remote machines and issue commands just as if the user was situated at the actual machine. Telnet can also be used to access remote databases, control other computers, distribute work among multiple systems, and remotely execute many applications.

Telnet is built upon TCP, and provides additional features that make it an upper-layer protocol. Using Telnet, both ends of a connection send data to each other. Typically, a terminal sends commands to a host, and the host responds with messages or data. For example, a user at a terminal may type "help" and the host may respond with "Type a command to get help on."

Telnet provides option negotiation as a means for establishing conventions between two machines. During a session, either host may send the other a command—requesting or volunteering a specific option. For example, the process of option negotiation determines if either computer will support echoing.

Telnet Connections

Connections are made on a port, which is a method of distinguishing multiple communications on a single computer. Most Telnet connections are made to port 23, the standard Telnet port.

To make a connection, specify a port and host name or address to connect to. All computers on a network have a distinguishing IP address. Standard IPv4 addresses have the following same format:

nnn.nnn.nnn.nnn

where each nnn is a number from 0 to 255 (except for the first octet, which may be from 0 to 247). This means an IPv4 address is 32bits long, allowing nearly 2^32 unique values. A typical IP address might be 129.229.1.2.

PowerTCP provides full support for IPv6. IPv6 was established as the next generation Internet protocol, in order to greatly increase the number of available IP addresses. IPv6 addresses have the following hexadecimal format:

xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx

where each xxxx is a hex value from 0000 to FFFF (0 to 65535). This means an IPv6 address is 128bits long, allowing 2^128 unique values. A typical address might be fe80::211:d800:97:c915. Note that "::" indicates a consecutive group of 0 values.

Most networks also support computer names, where the network will translate a name (such as "server3") into an IP address.

Network Virtual Terminal

The Network Virtual Terminal (NVT) is a concept used by Telnet to represent both hosts in a connection. The NVT is an imaginary character-based device with a keyboard and a printer (input and output). Incoming data goes to the printer, and input from the keyboard goes to the other end of the Telnet connection. Both ends of a Telnet connection must support the NVT.

The NVT supports the 7-bit character set known as NVT ASCII. NVT ASCII is the same as normal ASCII text, except that only 7 bits represent the character. The eighth high bit of the byte must be set to 0. In NVT ASCII, an end of line is represented by a two-character sequence CR, LF (carriage return, line-feed).

Both ends of a Telnet connection map their own terminal device characteristics to and from the NVT. For example, a program must change all 8-bit ASCII characters to the NVT character set. The NVT is intended to strike a balance between being overly restrictive (not providing some computers a rich enough vocabulary for mapping into their local character sets) and being overly inclusive (penalizing users with modest terminals).

Please refer to RFC 854 for more information on the NVT.

Binary Data

PowerTCP provides full support for binary data transmission. When sending, the following basic Telnet encoding rules are applied:

  1. Every byte of value 255 (IAC) is doubled up into a two-byte (255, 255) value.
  2. Every byte of value 13 (CR) not followed by a byte of value 10 (LF) is transformed into a two-byte (13, 0) value.

For all data received, the reciprocal transformation takes place within the Telnet component. This mechanism, established by RFC 854, enables the transmission of 8-bit binary data over a single Telnet channel.

There is also a TransmitBinary option that can be easily set using the Binary property of the Telnet component. When set to RequestOn, the TransmitBinary option is negotiated for both directions. When in this mode, a naked CR is not padded with a following NULL when data is sent. When data is received, any CR NULL encountered is used unaltered. All other padding (such as the doubling of IAC bytes) remains the same.

Option Negotiation

Option negotiation is the process of two computers agreeing on what features they will or will not provide. Each computer may send and respond to commands. A typical option negotiation session may occur as follows (although over 40 different options might be negotiated):

Computer A | Computer B
1. I will echo back what you send to me. |
 | 2. OK, Do echo back what I send to you.
3. Do suppress go–aheads. |
 | 4. No, I won't suppress go–aheads.

Either machine may initiate option negotiation. One machine may request that the other machine support or not support an option, or inform the machine that it will or won't support an option. The other may then respond that it will or won't support an option, or request that the other computer support or not support an option. The following table describes the four option negotiation commands:

Command | Description
WILL | The sender wants to support the option
WONT | The sender will not support the option
DO | The sender wants the receiver to support the option
DONT | The sender wants the receiver to not support the option

The different pairs of commands and responding commands follow:

Command | Response | Option Used
WILL I will support this option | DO I do support this option | Yes
WILL I will support this option | DONT No, don't support it | No
WONT I won't support this option | DONT OK, don't support it | No
DO Do support this option | WILL OK, I will support it | Yes
DO Do support this option | WONT No, I won't support it | No
DONT Don't support this option | WONT OK, I won't support it | No

Note If a machine does not want an option supported (WONT/DONT), the other machine must comply, responding with a DONT or WONT.

Telnet also provides suboption negotiation—negotiating details about a specific option. An example is the "terminal type" option. For both computers to decide to support the same terminal type, instead of using a different option for each individual terminal type, a suboption is negotiated. A typical suboption negotiation is shown below:

Computer A | Computer B
1. I will support different terminal types. |
 | 2. OK, Do support different terminal types.
3. OK, send your terminal type suboption. |
 | 4. My terminal type suboption is "IBMPC".

Option negotiation and suboption negotiation makes Telnet very flexible and adaptable to many different terminal configurations. Refer to the applicable RFCs for more information on Telnet and Telnet option negotiation.

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Asynchronous Operation - PowerTCP Telnet for .NET CF

[image]
PowerTCP Telnet for .NET CF
Asynchronous Operation
Send comments on this topic.

The following provides information on using PowerTCP components in an asynchronous manner, by executing method calls on worker threads.

Introduction

Traditional PowerTCP asynchronous support provided a means for executing methods on worker threads, but this required a signaling mechanism indicating when operations completed. This resulted in difficult-to-maintain, event-driven code.

With the new version 4.0 design, code is more self-documenting, uses fewer resources, and is more flexible to use. A convenient Start method allows the user to string together multiple blocking methods with the following benefits:

  • Less event-driven code. Methods are called inline, producing self-documenting code that is easier to write and maintain.
  • Marshal methods are included that permit the user to conveniently marshal data back to the UI thread for display in any UI control.
  • A simplified and more efficient interface.
  • Removal of all asynchronous methods. The simple Start method allows users to conveniently execute directly on a worker thread.
  • No need for pseudo-blocking functionality. Problems associated with possible re-entrancy (caused when UI messages are processes while a communication method is in progress) are eliminated.
  • A single worker thread can be used to string together any combination of blocking methods, allowing the user to execute any combination of methods without using multiple worker threads in serial (a requirement of less advanced designs).

The Start Method

All PowerTCP components fully support both synchronous (blocking) and asynchronous (non-blocking) use. However, the simple, streamlined interface contain only blocking methods. How can this be?

Each component contains a Start method call, which will execute one or more functions on a separate worker thread. In other words, any function containing blocking calls can be made asynchronous by simply passing it to the Start method. The syntax for this method is simple (C# and VB code snippets follow):

C# Copy Code

telnet1.Start(myBlockingFunction, myObject); //Can also be called without passing an object

private void myBlockingFunction(Telnet telnet, object myObject)
{
   ...
}

Visual Basic Copy Code

telnet1.Start(AddressOf myBlockingFunction, myObject)  'Can also be called without passing an object

Private Sub myBlockingFunction(ByVal telnet As Telnet, ByVal myObject As Object)
   ...
End Sub

There are several advantages to this approach.

First, a function that performs some process is the same, whether it will be executed synchronously or asynchronously. It is no longer necessary to write separate code for blocking and non-blocking applications.

Second, asynchronous code can be written in a sequential, step-by-step manner. It is no longer necessary to implement numerous event handlers, with code that jumps from one handler to another.

Third, it is no longer necessary to keep track of state in event handlers. For example, take the simple case where the following sequence must take place:

  1. Receive data A
  2. Send data B
  3. Receive data C
  4. Send data D

In other asynchronous implementations, an event will fire signifying data received. In this paradigm, a state machine must be implemented in the event handler (if A received then send B, else if C received then send D). With the new approach, a function is written with sequential statement (Receive A, Send B, Receive C, Send D). This produces code that is much easier to debug and to maintain.

Marshaling Data

The above example demonstrates how the Start method provides code that is easy to write, debug and maintain. But now the functions are operating on their own threads. How does the code report back to the main thread?

PowerTCP components have convenient Marshal method calls which are paired with events that fire on the main thread. For example (C# and VB code snippets follow):

C# Copy Code

telnet1.Marshal(telnet1.Read(buffer, 0, 1024), null) //Execute on worker thread

private void telnet1_Data(object sender, DataEventArgs e)
{
   //Whenever data is received, display it in UI element (raised on the UI thread)
   textDisplay.Text += e.Data.ToString();
}

Visual Basic Copy Code

telnet1.Marshal(telnet1.Read(buffer, 0, 1024), Nothing) 'Execute on worker thread

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Data
   'Whenever data is received, display it in UI element (raised on the UI thread)
   textDisplay.Text += e.Data.ToString()
End Sub

This is an easy-to-use mechanism for marshaling data back to the main thread.

Typical Uses

Below are two typical asynchronous use examples.

In the first example, the developer wants to automate a session in the background, without interfering with the user-interface. A button, textbox and the PowerTCP component are added to the form. Pressing the button will initiate a session with communication displayed in the textbox. The automateSession function, which could also be used in a strictly blocking application, is passed to the Start call to be executed on a worker thread (C# and VB code snippets follow).

C# Copy Code

private void button1_Click(object sender, EventArgs e)
{
    //Event handlers were added in the designer
    //Start the process on a worker thread (no state info passed in)
    telnet1.Start(automateSession, null);
}

private void automateSession(Telnet telnet, object notUsed)
{
    //This function executes on a worker thread, providing multi-threaded, asynchronous operation
    try
    {
        //Connect
        telnet.Connect("myServer");

        //Login to the server, marshal data to the UI thread
        telnet.Marshal(telnet.Login("myUsername", "myPassword", "$"), null);

        //Send a list command
        telnet.Write("ls -la\r");

        //Wait for prompt, marshal data to the UI thread
        telnet.Marshal(telnet.Read("$"), null);

        //Send an exit command; server will close the connection
        telnet.Write("exit\r");

        //Read any remaining data before the shutdown
        telnet.Marshal(telnet.ReadToEnd(), null);
    }
    catch (Exception ex)
    {
        //Report errors to the UI thread
        telnet.Marshal(ex);
    }
}

void telnet1_Data(object sender, DataEventArgs e)
{
    //Add data received to the textbox
    textBox1.Text += e.Data.ToString();
}

void telnet1_Error(object sender, System.IO.ErrorEventArgs e)
{
    //Add error messages to the textbox
    textBox1.Text += e.GetException().Message;
}

void telnet1_StateChanged(object sender, EventArgs e)
{
    //Change appearance of textbox when connected
    textBox1.BackColor = (telnet1.State == ConnectionState.Closed)
        ? SystemColors.ControlDark
        : SystemColors.ControlLight;
}

Visual Basic Copy Code

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Event handlers were added in the designer
    'Start the process on a worker thread (no state info passed in)
    telnet1.Start(AddressOf automateSession, Nothing)
End Sub

Private Sub automateSession(ByVal telnet As Telnet, ByVal notUsed As Object)
    'This function executes on a worker thread, providing multi-threaded, asynchronous operation
    Try
        'Connect
        telnet.Connect("myServer")

        'Login to the server, marshal data to the UI thread
        telnet.Marshal(telnet.Login("myUsername", "myPassword", "$"), Nothing)

        'Send a list command
        telnet.Write("ls -la" & Constants.vbCr)

        'Wait for prompt, marshal data to the UI thread
        telnet.Marshal(telnet.Read("$"), Nothing)

        'Send an exit command; server will close the connection
        telnet.Write("exit" & Constants.vbCr)

        'Read any remaining data before the shutdown
        telnet.Marshal(telnet.ReadToEnd(), Nothing)
    Catch ex As Exception
        'Report errors to the UI thread
        telnet.Marshal(ex)
    End Try
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Data
    'Add data received to the textbox
    textBox1.Text += e.Data.ToString())

End Sub

Private Sub telnet1_Error(ByVal sender As Object, ByVal e As System.IO.ErrorEventArgs) Handles telnet1.Error
    'Add error messages to the textbox
    textBox1.Text += e.GetException().Message
End Sub

Private Sub telnet1_StateChanged(ByVal sender As Object, ByVal e As EventArgs) Handles telnet1.StateChanged
    'Change appearance of textbox when connected
    If (telnet1.State = ConnectionState.Closed) Then
        textBox1.BackColor = SystemColors.ControlDark
    Else
        textBox1.BackColor = SystemColors.ControlLight
    End If
End Sub

In the second example, the developer wants to receive data whenever it is available, but again, without interfering with the ongoing processes of the application. Event handlers (not shown) are implemented as in the first example (C# and VB code snippets follow).

C# Copy Code

private void button1_Click(object sender, EventArgs e)
{
   //Start the process on a worker thread (no state info passed in)
   telnet1.Start(receiveData, null);
}

private void receiveData(Telnet telnet, object notUsed)
{
   //This function executes on a worker thread, providing multi-threaded, asynchronous operation
   try
   {
       //Connect to the server, marshal data to the UI thread
       telnet.Connect("myServer");

       //Receive data when it is sent by the remote host
       byte[] buffer = new byte[1024];
       while (telnet.State == ConnectionState.Connected)
           telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
   }
   catch (Exception ex)
   {
       //Report errors to the UI thread
       telnet.ReportError(ex);
   }
}

Visual Basic Copy Code

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
   'Start the process on a worker thread (no state info passed in)
   telnet1.Start(AddressOf receiveData, Nothing)
End Sub

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
   'This function executes on a worker thread, providing multi-threaded, asynchronous operation
   Try
      'Connect and login to the server, marshal data to the UI thread
      telnet.Connect("myServer")

      'Receive data when it is sent by the remote host
      Dim buffer() As Byte = New Byte(1023){}
      Do While telnet.State = ConnectionState.Connected
         telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
      Loop
   Catch ex As Exception
      'Report errors to the UI thread
      telnet.Marshal(ex)
   End Try
End Sub

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Assembly Overview

Dart.Telnet.CF Assembly
See Also Send comments on this topic.
Dart products contain two namespaces - one specific to the product and one common to multiple Dart products.

Namespaces

Namespace | Description
Dart.Common | Namespace under which classes common to multiple Dart products reside.
Dart.Telnet |

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Dart.Common Namespace

Dart.Common Namespace
See Also Inheritance Hierarchy Send comments on this topic.
Namespace under which classes common to multiple Dart products reside.

Classes

 | Class | Description
Class | AuthenticationException | Thrown when a client or server cannot be authenticated.
Class | ComponentBase | Base class for PowerTCP Components.
Class | ComponentErrorEventArgs | Provides data for the ComponentBase.Error event.
Class | DartLicenseException | The base class for all Dart component license exceptions.
Class | Data | Encapsulates data read into a buffer.
Class | DataEventArgs | Provides data for the Data event.
Class | LicenseException | Thrown when a component fails it's license check.
Class | LogData | Provides data and its direction to the Log event.
Class | LogEventArgs | Provides data for the LogData event.
Class | Proxy | Provides an easy way to manage communication with proxy servers.
Class | PtyBase | This class provides support for interactive on-line terminal access using controls derived from TextBoxBase.
Class | SocketBase | Base class for PowerTCP Components.
Class | SocketOption | Contains socket options that may be set by TCP and UDP sockets. These options are automatically applied to the connection used.
Class | SslInfo | Provides information on the SSL channel.
Class | TcpBase | Base class for components utilizing protocols built upon the TCP protocol.
Class | TcpSocketOption | Contains socket options that may be set by TCP sockets.
Class | UserStateEventArgs | Provides data for the UserState event.
Class | X509CertificateCollection | A generic list of X509Certificate objects.
Class | X509Chain | Represents a chain-building engine for X509Certificate certificates. Not implemented.
Class | X509ChainPolicy | Represents the chain policy to be applied when building an X509 certificate chain. This class cannot be inherited.

Structures

 | Structure | Description
Structure | X509ChainStatus | Provides a simple structure for storing X509 chain status and error information.

Delegates

 | Delegate | Description
Delegate | ComponentErrorEventHandler | Represents the method that will handle an event raised due to an component error.
Delegate | DataEventHandler | Represents the method that will handle an event raised by the user calling Marshal.
Delegate | LocalCertificateSelectionCallback | Selects the local Secure Sockets Layer (SSL) certificate used for authentication.
Delegate | LogEventHandler | Represents the method that will handle an event containing unencrypted data passing to and from the socket.
Delegate | RemoteCertificateValidationCallback | Verifies the remote Secure Sockets Layer (SSL) certificate used for authentication.
Delegate | UserStateEventHandler | Represents the method that will handle an event raised by the user calling Marshal.

Enumerations

 | Enumeration | Description
Enumeration | CipherAlgorithmType | Defines the possible cipher algorithms for the SslStream class.
Enumeration | ConnectionState | Defines the possible states of the connection.
Enumeration | DataDirection | Enumerates the directions data travels.
Enumeration | ExchangeAlgorithmType | Specifies the algorithm used to create keys shared by the client and server.
Enumeration | HashAlgorithmType | Specifies the algorithm used for generating message authentication codes (MACs).
Enumeration | ProxyType | Enumerates the supported proxy types.
Enumeration | SslPolicyErrors | Enumerates Secure Socket Layer (SSL) policy errors. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Enumeration | SslProtocols | Defines the possible values of SslProtocols.
Enumeration | X509ChainStatusFlags | Defines the status of an X509 chain. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Enumeration | X509RevocationFlag | Specifies which X509 certificates in the chain should be checked for revocation.
Enumeration | X509RevocationMode | Specifies the mode used to check for X509 certificate revocation.

See Also

Reference

Dart.Telnet.CF Assembly


AuthenticationException Class

[image]
PowerTCP Telnet for .NET CF
AuthenticationException Class
Members See Also Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

Thrown when a client or server cannot be authenticated.

Object Model

AuthenticationException Class

Syntax

Visual Basic (Declaration)
Public Class AuthenticationException
   Inherits System.SystemException
Visual Basic (Usage) Copy Code
Dim instance As AuthenticationException
C#
public class AuthenticationException : System.SystemException
Managed Extensions for C++
public __gc class AuthenticationException : public System.SystemException
C++/CLI
public ref class AuthenticationException : public System.SystemException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
Dart.Common.AuthenticationException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthenticationException Members
Dart.Common Namespace


AuthenticationException Class Members

[image]
PowerTCP Telnet for .NET CF
AuthenticationException Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

The following tables list the members exposed by AuthenticationException.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Overloaded. Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

AuthenticationException Class
Dart.Common Namespace


ComponentBase Class

[image]
PowerTCP Telnet for .NET CF
ComponentBase Class
Members See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

Base class for PowerTCP Components.

Object Model

ComponentBase Class

Syntax

Visual Basic (Declaration)
Public Class ComponentBase
   Inherits System.ComponentModel.Component
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
C#
public class ComponentBase : System.ComponentModel.Component
Managed Extensions for C++
public __gc class ComponentBase : public System.ComponentModel.Component
C++/CLI
public ref class ComponentBase : public System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Members
Dart.Common Namespace


ComponentBase Class Members

[image]
PowerTCP Telnet for .NET CF
ComponentBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

The following tables list the members exposed by ComponentBase.

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component.
public Field | Tag | Gets or sets an object that stores any user data.
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread.
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event.
protected Method | OnUserState | Raises the UserState event.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method.
public Event | UserState | Raised when user state information is marshaled.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


ComponentBase Class Methods

[image]
PowerTCP Telnet for .NET CF
ComponentBase Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread.
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event.
protected Method | OnUserState | Raises the UserState event.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


Marshal Method

[image]
PowerTCP Telnet for .NET CF
Marshal Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Marshal Method

Marshals an exception to the UI thread.

Overload List

Overload | Description
Marshal(Exception) | Marshals an exception to the UI thread.
Marshal(Object) | Marshals user state information to the UI thread.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


Marshal(Exception) Method

[image]
PowerTCP Telnet for .NET CF
Marshal(Exception) Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class > Marshal Method : Marshal(Exception) Method

exception
The Exception to be marshaled.
Marshals an exception to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim exception As Exception

instance.Marshal(exception)
C#
public void Marshal(
   Exception exception
)
Managed Extensions for C++
public: void Marshal(
   Exception* exception
)
C++/CLI
public:
void Marshal(
   Exception^ exception
)

Parameters

exception
The Exception to be marshaled.

Remarks

This method is used to marshal exceptions from a worker thread back to the UI thread for typical display purposes. It calls the OnError method, which raises the Error event.

This method automatically marshals any unhandled exceptions generated by worker threads created with the Start method.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Marshal(Object) Method

[image]
PowerTCP Telnet for .NET CF
Marshal(Object) Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class > Marshal Method : Marshal(Object) Method

userState
The user state information to be marshaled.
Marshals user state information to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal userState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim userState As Object

instance.Marshal(userState)
C#
public void Marshal(
   object userState
)
Managed Extensions for C++
public: void Marshal(
   Object* userState
)
C++/CLI
public:
void Marshal(
   Object^ userState
)

Parameters

userState
The user state information to be marshaled.

Remarks

This method can be used to marshal user state information from a worker thread back to the UI thread for typical display purposes. It calls the OnUserState method, which raises the UserState event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


OnError Method

[image]
PowerTCP Telnet for .NET CF
OnError Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : OnError Method

e
A ComponentErrorEventArgs object that contains the exception.
Raises the Error event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnError( _
   ByVal e As ComponentErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim e As ComponentErrorEventArgs

instance.OnError(e)
C#
protected virtual void OnError(
   ComponentErrorEventArgs e
)
Managed Extensions for C++
protected: virtual void OnError(
   ComponentErrorEventArgs* e
)
C++/CLI
protected:
virtual void OnError(
   ComponentErrorEventArgs^ e
)

Parameters

e
A ComponentErrorEventArgs object that contains the exception.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnError method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnError in a derived class, be sure to call the base class OnError method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


OnUserState Method

[image]
PowerTCP Telnet for .NET CF
OnUserState Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : OnUserState Method

e
A UserStateEventArgs object containing user state information.
Raises the UserState event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUserState( _
   ByVal e As UserStateEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim e As UserStateEventArgs

instance.OnUserState(e)
C#
protected virtual void OnUserState(
   UserStateEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUserState(
   UserStateEventArgs* e
)
C++/CLI
protected:
virtual void OnUserState(
   UserStateEventArgs^ e
)

Parameters

e
A UserStateEventArgs object containing user state information.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnUserState method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnUserState in a derived class, be sure to call the base class OnUserState method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Properties

[image]
PowerTCP Telnet for .NET CF
ComponentBase Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


SynchronizingObject Property

[image]
PowerTCP Telnet for .NET CF
SynchronizingObject Property
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : SynchronizingObject Property

Gets or sets the object used to marshal data to the UI thread.

Syntax

Visual Basic (Declaration)
Public Property SynchronizingObject As Control
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Control

instance.SynchronizingObject = value

value = instance.SynchronizingObject
C#
public Control SynchronizingObject {get; set;}
Managed Extensions for C++
public: __property Control* get_SynchronizingObject();
public: __property void set_SynchronizingObject(
   Control* value
);
C++/CLI
public:
property Control^ SynchronizingObject {
   Control^ get();
   void set (    Control^ value);
}

Remarks

This property determines the thread on which the component's event handlers are called. This is usually the same thread the component was created on.

This property is automatically set to the containing control when used in the Windows Forms designer. This is typically the form or user control in which the component is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Fields

[image]
PowerTCP Telnet for .NET CF
ComponentBase Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component.
public Field | Tag | Gets or sets an object that stores any user data.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


Encoding Field

[image]
PowerTCP Telnet for .NET CF
Encoding Field
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Encoding Field

Character encoding used by the component.

Syntax

Visual Basic (Declaration)
Public Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Encoding

value = instance.Encoding

instance.Encoding = value
C#
public Encoding Encoding
Managed Extensions for C++
public: Encoding* Encoding
C++/CLI
public:
Encoding^ Encoding

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


Tag Field

[image]
PowerTCP Telnet for .NET CF
Tag Field
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Tag Field

Gets or sets an object that stores any user data.

Syntax

Visual Basic (Declaration)
Public Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Object

value = instance.Tag

instance.Tag = value
C#
public object Tag
Managed Extensions for C++
public: Object* Tag
C++/CLI
public:
Object^ Tag

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Events

[image]
PowerTCP Telnet for .NET CF
ComponentBase Class Events
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method.
public Event | UserState | Raised when user state information is marshaled.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


Error Event

[image]
PowerTCP Telnet for .NET CF
Error Event
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Error Event

Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method.

Syntax

Visual Basic (Declaration)
Public Event Error As ComponentErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As ComponentErrorEventHandler

AddHandler instance.Error, handler
C#
public event ComponentErrorEventHandler Error
Managed Extensions for C++
public: __event ComponentErrorEventHandler* Error
C++/CLI
public:
event ComponentErrorEventHandler^ Error

Remarks

This event is always raised on the UI thread so that data can be used with UI components.

See SynchronizingObject for important information on updating UI controls from within this event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


UserState Event

[image]
PowerTCP Telnet for .NET CF
UserState Event
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : UserState Event

Raised when user state information is marshaled.

Syntax

Visual Basic (Declaration)
Public Event UserState As UserStateEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As UserStateEventHandler

AddHandler instance.UserState, handler
C#
public event UserStateEventHandler UserState
Managed Extensions for C++
public: __event UserStateEventHandler* UserState
C++/CLI
public:
event UserStateEventHandler^ UserState

Remarks

This event is raised when an object is passed to the Marshal method.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentErrorEventArgs Class

[image]
PowerTCP Telnet for .NET CF
ComponentErrorEventArgs Class
Members See Also Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventArgs Class

Provides data for the ComponentBase.Error event.

Object Model

ComponentErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ComponentErrorEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ComponentErrorEventArgs
C#
public class ComponentErrorEventArgs
Managed Extensions for C++
public __gc class ComponentErrorEventArgs
C++/CLI
public ref class ComponentErrorEventArgs

Inheritance Hierarchy

System.Object
Dart.Common.ComponentErrorEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventArgs Members
Dart.Common Namespace


ComponentErrorEventArgs Class Members

[image]
PowerTCP Telnet for .NET CF
ComponentErrorEventArgs Class Members
See Also Methods Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventArgs Class

The following tables list the members exposed by ComponentErrorEventArgs.

Public Constructors

 | Name | Description
public Constructor | ComponentErrorEventArgs Constructor | Wrap an exception within this class.
Top

Public Methods

 | Name | Description
public Method | GetException | Returns the Exception marshaled to the UI thread.
Top

See Also

Reference

ComponentErrorEventArgs Class
Dart.Common Namespace


ComponentErrorEventArgs Constructor

[image]
PowerTCP Telnet for .NET CF
ComponentErrorEventArgs Constructor
See Also Send comments on this topic.
Dart.Common Namespace > ComponentErrorEventArgs Class : ComponentErrorEventArgs Constructor

exception
Exception to wrap.
Wrap an exception within this class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim exception As Exception

Dim instance As New ComponentErrorEventArgs(exception)
C#
public ComponentErrorEventArgs(
   Exception exception
)
Managed Extensions for C++
public: ComponentErrorEventArgs(
   Exception* exception
)
C++/CLI
public:
ComponentErrorEventArgs(
   Exception^ exception
)

Parameters

exception
Exception to wrap.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventArgs Class
ComponentErrorEventArgs Members


ComponentErrorEventArgs Class Methods

[image]
PowerTCP Telnet for .NET CF
ComponentErrorEventArgs Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventArgs Class

"

For a list of all members of this type, see ComponentErrorEventArgs members.

"

Public Methods

 | Name | Description
public Method | GetException | Returns the Exception marshaled to the UI thread.
Top

See Also

Reference

ComponentErrorEventArgs Class
Dart.Common Namespace


GetException Method

[image]
PowerTCP Telnet for .NET CF
GetException Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentErrorEventArgs Class : GetException Method

Returns the Exception marshaled to the UI thread.

Syntax

Visual Basic (Declaration)
Public Function GetException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As ComponentErrorEventArgs
Dim value As Exception

value = instance.GetException()
C#
public Exception GetException()
Managed Extensions for C++
public: Exception* GetException();
C++/CLI
public:
Exception^ GetException();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventArgs Class
ComponentErrorEventArgs Members


DartLicenseException Class

[image]
PowerTCP Telnet for .NET CF
DartLicenseException Class
Members See Also Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

The base class for all Dart component license exceptions.

Object Model

DartLicenseException Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DartLicenseException
   Inherits System.Exception
Visual Basic (Usage) Copy Code
Dim instance As DartLicenseException
C#
public abstract class DartLicenseException : System.Exception
Managed Extensions for C++
public __gc abstract class DartLicenseException : public System.Exception
C++/CLI
public ref class DartLicenseException abstract : public System.Exception

Remarks

Use the DartLicenseException class to catch runtime licensing exceptions. These exceptions are thrown at component creation time and during access of select properites or methods. The Message property will provide a description of the specific licensing problem encountered. The InnerException property should also be examined for additional details.

Inheritance Hierarchy

System.Object
System.Exception
Dart.Common.DartLicenseException
Dart.Common.LicenseBadDeveloperFileException
Dart.Common.LicenseInvalidException
Dart.Common.LicenseNotFoundException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DartLicenseException Members
Dart.Common Namespace


DartLicenseException Class Members

[image]
PowerTCP Telnet for .NET CF
DartLicenseException Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

The following tables list the members exposed by DartLicenseException.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Overloaded. Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Common Namespace


Data Class

[image]
PowerTCP Telnet for .NET CF
Data Class
Members See Also Send comments on this topic.
Dart.Common Namespace : Data Class

Encapsulates data read into a buffer.

Object Model

Data Class

Syntax

Visual Basic (Declaration)
Public Class Data
Visual Basic (Usage) Copy Code
Dim instance As Data
C#
public class Data
Managed Extensions for C++
public __gc class Data
C++/CLI
public ref class Data

Inheritance Hierarchy

System.Object
Dart.Common.Data
Dart.Common.LogData

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Members
Dart.Common Namespace


Data Class Members

[image]
PowerTCP Telnet for .NET CF
Data Class Members
See Also Fields Methods Send comments on this topic.
Dart.Common Namespace : Data Class

The following tables list the members exposed by Data.

Public Constructors

 | Name | Description
public Constructor | Data Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Buffer | Gets the buffer provided to the Read method.
public Field | Count | The number of bytes read or written.
public Field | Delimiter | Gets the search string used in some Read overloads.
public Field | Encoding | Gets the character encoding used by the Data object.
public Field | Offset | The offset into the buffer provided by the Read method.
Top

Public Methods

 | Name | Description
public Method | ToString | Gets the data as a decoded string.
Top

See Also

Reference

Data Class
Dart.Common Namespace


Data Constructor

[image]
PowerTCP Telnet for .NET CF
Data Constructor
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : Data Constructor

Overload List

Overload | Description
Data Constructor() | Default constructor.
Data Constructor(Byte[],Int32,Int32) | Creates a Data object using the system default encoding.
Data Constructor(Byte[],Int32,Int32,Encoding) | Creates a Data object using the specified encoding.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


Data Constructor()

[image]
PowerTCP Telnet for .NET CF
Data Constructor()
See Also Send comments on this topic.
Dart.Common Namespace > Data Class > Data Constructor : Data Constructor()

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Data()
C#
public Data()
Managed Extensions for C++
public: Data();
C++/CLI
public:
Data();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members
Overload List


Data Constructor(Byte[],Int32,Int32)

[image]
PowerTCP Telnet for .NET CF
Data Constructor(Byte[],Int32,Int32)
See Also Send comments on this topic.
Dart.Common Namespace > Data Class > Data Constructor : Data Constructor(Byte[],Int32,Int32)

buffer
The buffer holding byte data values.
offset
The number of offset bytes where the data starts.
count
The number of bytes with data values.
Creates a Data object using the system default encoding.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Data(buffer, offset, count)
C#
public Data(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
The buffer holding byte data values.
offset
The number of offset bytes where the data starts.
count
The number of bytes with data values.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members
Overload List


Data Constructor(Byte[],Int32,Int32,Encoding)

[image]
PowerTCP Telnet for .NET CF
Data Constructor(Byte[],Int32,Int32,Encoding)
See Also Send comments on this topic.
Dart.Common Namespace > Data Class > Data Constructor : Data Constructor(Byte[],Int32,Int32,Encoding)

buffer
The buffer holding byte data values.
offset
The number of offset bytes where the data starts.
count
The number of bytes with data values.
encoding
The encoding type to use.
Creates a Data object using the specified encoding.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal encoding As Encoding _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim encoding As Encoding

Dim instance As New Data(buffer, offset, count, encoding)
C#
public Data(
   byte[] buffer,
   int offset,
   int count,
   Encoding encoding
)
Managed Extensions for C++
public: Data(
   byte[]* buffer,
   int offset,
   int count,
   Encoding* encoding
)
C++/CLI
public:
Data(
   array<byte>^ buffer,
   int offset,
   int count,
   Encoding^ encoding
)

Parameters

buffer
The buffer holding byte data values.
offset
The number of offset bytes where the data starts.
count
The number of bytes with data values.
encoding
The encoding type to use.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members
Overload List


Data Class Methods

[image]
PowerTCP Telnet for .NET CF
Data Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : Data Class

"

For a list of all members of this type, see Data members.

"

Public Methods

 | Name | Description
public Method | ToString | Gets the data as a decoded string.
Top

See Also

Reference

Data Class
Dart.Common Namespace


ToString Method

[image]
PowerTCP Telnet for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : ToString Method

Gets the data as a decoded string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The Buffer decoded into a string using the Encoding property.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


Data Class Fields

[image]
PowerTCP Telnet for .NET CF
Data Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : Data Class

"

For a list of all members of this type, see Data members.

"

Public Fields

 | Name | Description
public Field | Buffer | Gets the buffer provided to the Read method.
public Field | Count | The number of bytes read or written.
public Field | Delimiter | Gets the search string used in some Read overloads.
public Field | Encoding | Gets the character encoding used by the Data object.
public Field | Offset | The offset into the buffer provided by the Read method.
Top

See Also

Reference

Data Class
Dart.Common Namespace


Buffer Field

[image]
PowerTCP Telnet for .NET CF
Buffer Field
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : Buffer Field

Gets the buffer provided to the Read method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Buffer As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value() As Byte

value = instance.Buffer
C#
public readonly byte[] Buffer
Managed Extensions for C++
public: readonly byte[]* Buffer
C++/CLI
public:
readonly array<byte>^ Buffer

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


Count Field

[image]
PowerTCP Telnet for .NET CF
Count Field
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : Count Field

The number of bytes read or written.

Syntax

Visual Basic (Declaration)
Public ReadOnly Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Integer

value = instance.Count
C#
public readonly int Count
Managed Extensions for C++
public: readonly int Count
C++/CLI
public:
readonly int Count

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


Delimiter Field

[image]
PowerTCP Telnet for .NET CF
Delimiter Field
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : Delimiter Field

Gets the search string used in some Read overloads.

Syntax

Visual Basic (Declaration)
Public ReadOnly Delimiter As String
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As String

value = instance.Delimiter
C#
public readonly string Delimiter
Managed Extensions for C++
public: readonly string* Delimiter
C++/CLI
public:
readonly String^ Delimiter

Property Value

A null if no delimiter was used in the Read call. Otherwise, the delimiter string.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


Encoding Field

[image]
PowerTCP Telnet for .NET CF
Encoding Field
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : Encoding Field

Gets the character encoding used by the Data object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Encoding

value = instance.Encoding
C#
public readonly Encoding Encoding
Managed Extensions for C++
public: readonly Encoding* Encoding
C++/CLI
public:
readonly Encoding^ Encoding

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


Offset Field

[image]
PowerTCP Telnet for .NET CF
Offset Field
See Also Send comments on this topic.
Dart.Common Namespace > Data Class : Offset Field

The offset into the buffer provided by the Read method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Integer

value = instance.Offset
C#
public readonly int Offset
Managed Extensions for C++
public: readonly int Offset
C++/CLI
public:
readonly int Offset

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Data Class
Data Members


DataEventArgs Class

[image]
PowerTCP Telnet for .NET CF
DataEventArgs Class
Members See Also Send comments on this topic.
Dart.Common Namespace : DataEventArgs Class

Provides data for the Data event.

Object Model

DataEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class DataEventArgs
   Inherits UserStateEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
C#
public class DataEventArgs : UserStateEventArgs
Managed Extensions for C++
public __gc class DataEventArgs : public UserStateEventArgs
C++/CLI
public ref class DataEventArgs : public UserStateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Common.UserStateEventArgs
Dart.Common.DataEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DataEventArgs Members
Dart.Common Namespace


DataEventArgs Class Members

[image]
PowerTCP Telnet for .NET CF
DataEventArgs Class Members
See Also Fields Methods Send comments on this topic.
Dart.Common Namespace : DataEventArgs Class

The following tables list the members exposed by DataEventArgs.

Public Constructors

 | Name | Description
public Constructor | DataEventArgs Constructor | Initializes a new instance of the DataEventArgs class.
Top

Public Fields

 | Name | Description
public Field | Data | Gets the data provided by the TcpBase.Data or TcpBase.Log events.
public Field | UserState | Gets the user information provided by the UserState event. (Inherited from Dart.Common.UserStateEventArgs)
Top

Public Methods

 | Name | Description
public Method | ToString | Gets the Data property as a decoded string.
Top

See Also

Reference

DataEventArgs Class
Dart.Common Namespace


DataEventArgs Constructor

[image]
PowerTCP Telnet for .NET CF
DataEventArgs Constructor
See Also Send comments on this topic.
Dart.Common Namespace > DataEventArgs Class : DataEventArgs Constructor

data
state
Initializes a new instance of the DataEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As Data, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim data As Data
Dim state As Object

Dim instance As New DataEventArgs(data, state)
C#
public DataEventArgs(
   Data data,
   object state
)
Managed Extensions for C++
public: DataEventArgs(
   Data* data,
   Object* state
)
C++/CLI
public:
DataEventArgs(
   Data^ data,
   Object^ state
)

Parameters

data
state

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DataEventArgs Class
DataEventArgs Members


DataEventArgs Class Methods

[image]
PowerTCP Telnet for .NET CF
DataEventArgs Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : DataEventArgs Class

"

For a list of all members of this type, see DataEventArgs members.

"

Public Methods

 | Name | Description
public Method | ToString | Gets the Data property as a decoded string.
Top

See Also

Reference

DataEventArgs Class
Dart.Common Namespace


ToString Method

[image]
PowerTCP Telnet for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Common Namespace > DataEventArgs Class : ToString Method

Gets the Data property as a decoded string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The Data.Buffer decoded into a string using the Data.Encoding specified.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DataEventArgs Class
DataEventArgs Members


DataEventArgs Class Fields

[image]
PowerTCP Telnet for .NET CF
DataEventArgs Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : DataEventArgs Class

"

For a list of all members of this type, see DataEventArgs members.

"

Public Fields

 | Name | Description
public Field | Data | Gets the data provided by the TcpBase.Data or TcpBase.Log events.
public Field | UserState | Gets the user information provided by the UserState event. (Inherited from Dart.Common.UserStateEventArgs)
Top

See Also

Reference

DataEventArgs Class
Dart.Common Namespace


Data Field

[image]
PowerTCP Telnet for .NET CF
Data Field
See Also Send comments on this topic.
Dart.Common Namespace > DataEventArgs Class : Data Field

Gets the data provided by the TcpBase.Data or TcpBase.Log events.

Syntax

Visual Basic (Declaration)
Public ReadOnly Data As Data
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
Dim value As Data

value = instance.Data
C#
public readonly Data Data
Managed Extensions for C++
public: readonly Data* Data
C++/CLI
public:
readonly Data^ Data

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DataEventArgs Class
DataEventArgs Members


LicenseException Class

[image]
PowerTCP Telnet for .NET CF
LicenseException Class
Members See Also Send comments on this topic.
Dart.Common Namespace : LicenseException Class

Thrown when a component fails it's license check.

Object Model

LicenseException Class

Syntax

Visual Basic (Declaration)
Public Class LicenseException
   Inherits System.SystemException
Visual Basic (Usage) Copy Code
Dim instance As LicenseException
C#
public class LicenseException : System.SystemException
Managed Extensions for C++
public __gc class LicenseException : public System.SystemException
C++/CLI
public ref class LicenseException : public System.SystemException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
Dart.Common.LicenseException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LicenseException Members
Dart.Common Namespace


LicenseException Class Members

[image]
PowerTCP Telnet for .NET CF
LicenseException Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : LicenseException Class

The following tables list the members exposed by LicenseException.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | LicensedType | The Type of the licensed object.
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Overloaded. Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

LicenseException Class
Dart.Common Namespace


LicenseException Class Properties

[image]
PowerTCP Telnet for .NET CF
LicenseException Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : LicenseException Class

"

For a list of all members of this type, see LicenseException members.

"

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | LicensedType | The Type of the licensed object.
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

LicenseException Class
Dart.Common Namespace


LicensedType Property

[image]
PowerTCP Telnet for .NET CF
LicensedType Property
See Also Send comments on this topic.
Dart.Common Namespace > LicenseException Class : LicensedType Property

The Type of the licensed object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensedType As Type
Visual Basic (Usage) Copy Code
Dim instance As LicenseException
Dim value As Type

value = instance.LicensedType
C#
public Type LicensedType {get;}
Managed Extensions for C++
public: __property Type* get_LicensedType();
C++/CLI
public:
property Type^ LicensedType {
   Type^ get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LicenseException Class
LicenseException Members


LogData Class

[image]
PowerTCP Telnet for .NET CF
LogData Class
Members See Also Send comments on this topic.
Dart.Common Namespace : LogData Class

Provides data and its direction to the Log event.

Object Model

LogData Class

Syntax

Visual Basic (Declaration)
Public Class LogData
   Inherits Data
Visual Basic (Usage) Copy Code
Dim instance As LogData
C#
public class LogData : Data
Managed Extensions for C++
public __gc class LogData : public Data
C++/CLI
public ref class LogData : public Data

Inheritance Hierarchy

System.Object
Dart.Common.Data
Dart.Common.LogData

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LogData Members
Dart.Common Namespace


LogData Class Members

[image]
PowerTCP Telnet for .NET CF
LogData Class Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : LogData Class

The following tables list the members exposed by LogData.

Public Fields

 | Name | Description
public Field | Buffer | Gets the buffer provided to the Read method. (Inherited from Dart.Common.Data)
public Field | Count | The number of bytes read or written. (Inherited from Dart.Common.Data)
public Field | Delimiter | Gets the search string used in some Read overloads. (Inherited from Dart.Common.Data)
public Field | Direction | Indicates whether data is incoming (received) or outgoing (sent).
public Field | Encoding | Gets the character encoding used by the Data object. (Inherited from Dart.Common.Data)
public Field | Offset | The offset into the buffer provided by the Read method. (Inherited from Dart.Common.Data)
Top

See Also

Reference

LogData Class
Dart.Common Namespace


LogData Class Fields

[image]
PowerTCP Telnet for .NET CF
LogData Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : LogData Class

"

For a list of all members of this type, see LogData members.

"

Public Fields

 | Name | Description
public Field | Buffer | Gets the buffer provided to the Read method. (Inherited from Dart.Common.Data)
public Field | Count | The number of bytes read or written. (Inherited from Dart.Common.Data)
public Field | Delimiter | Gets the search string used in some Read overloads. (Inherited from Dart.Common.Data)
public Field | Direction | Indicates whether data is incoming (received) or outgoing (sent).
public Field | Encoding | Gets the character encoding used by the Data object. (Inherited from Dart.Common.Data)
public Field | Offset | The offset into the buffer provided by the Read method. (Inherited from Dart.Common.Data)
Top

See Also

Reference

LogData Class
Dart.Common Namespace


Direction Field

[image]
PowerTCP Telnet for .NET CF
Direction Field
See Also Send comments on this topic.
Dart.Common Namespace > LogData Class : Direction Field

Indicates whether data is incoming (received) or outgoing (sent).

Syntax

Visual Basic (Declaration)
Public ReadOnly Direction As DataDirection
Visual Basic (Usage) Copy Code
Dim instance As LogData
Dim value As DataDirection

value = instance.Direction
C#
public readonly DataDirection Direction
Managed Extensions for C++
public: readonly DataDirection Direction
C++/CLI
public:
readonly DataDirection Direction

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LogData Class
LogData Members


LogEventArgs Class

[image]
PowerTCP Telnet for .NET CF
LogEventArgs Class
Members See Also Send comments on this topic.
Dart.Common Namespace : LogEventArgs Class

Provides data for the LogData event.

Object Model

LogEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class LogEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As LogEventArgs
C#
public class LogEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class LogEventArgs : public System.EventArgs
C++/CLI
public ref class LogEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Common.LogEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LogEventArgs Members
Dart.Common Namespace


LogEventArgs Class Members

[image]
PowerTCP Telnet for .NET CF
LogEventArgs Class Members
See Also Fields Methods Send comments on this topic.
Dart.Common Namespace : LogEventArgs Class

The following tables list the members exposed by LogEventArgs.

Public Fields

 | Name | Description
public Field | Data | Gets data read from or written to the stream.
Top

Public Methods

 | Name | Description
public Method | ToString | Gets the Data property as a decoded string.
Top

See Also

Reference

LogEventArgs Class
Dart.Common Namespace


LogEventArgs Class Methods

[image]
PowerTCP Telnet for .NET CF
LogEventArgs Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : LogEventArgs Class

"

For a list of all members of this type, see LogEventArgs members.

"

Public Methods

 | Name | Description
public Method | ToString | Gets the Data property as a decoded string.
Top

See Also

Reference

LogEventArgs Class
Dart.Common Namespace


ToString Method

[image]
PowerTCP Telnet for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Common Namespace > LogEventArgs Class : ToString Method

Gets the Data property as a decoded string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As LogEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The Data.Buffer decoded into a string using the Data.Encoding specified.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LogEventArgs Class
LogEventArgs Members


LogEventArgs Class Fields

[image]
PowerTCP Telnet for .NET CF
LogEventArgs Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : LogEventArgs Class

"

For a list of all members of this type, see LogEventArgs members.

"

Public Fields

 | Name | Description
public Field | Data | Gets data read from or written to the stream.
Top

See Also

Reference

LogEventArgs Class
Dart.Common Namespace


Data Field

[image]
PowerTCP Telnet for .NET CF
Data Field
See Also Send comments on this topic.
Dart.Common Namespace > LogEventArgs Class : Data Field

Gets data read from or written to the stream.

Syntax

Visual Basic (Declaration)
Public ReadOnly Data As LogData
Visual Basic (Usage) Copy Code
Dim instance As LogEventArgs
Dim value As LogData

value = instance.Data
C#
public readonly LogData Data
Managed Extensions for C++
public: readonly LogData* Data
C++/CLI
public:
readonly LogData^ Data

Remarks

If SSL encryption is being used then Data is reported prior to encrypting or after decrypting.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LogEventArgs Class
LogEventArgs Members


Proxy Class

[image]
PowerTCP Telnet for .NET CF
Proxy Class
Members See Also Send comments on this topic.
Dart.Common Namespace : Proxy Class

Provides an easy way to manage communication with proxy servers.

Object Model

Proxy Class

Syntax

Visual Basic (Declaration)
Public Class Proxy
Visual Basic (Usage) Copy Code
Dim instance As Proxy
C#
public class Proxy
Managed Extensions for C++
public __gc class Proxy
C++/CLI
public ref class Proxy

Remarks

The Proxy class provides extensive native support for proxy servers. Simply set the appropriate properties of the Proxy class and proxy use occurs transparently.

Inheritance Hierarchy

System.Object
Dart.Common.Proxy

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Members
Dart.Common Namespace


Proxy Class Members

[image]
PowerTCP Telnet for .NET CF
Proxy Class Members
See Also Properties Send comments on this topic.
Dart.Common Namespace : Proxy Class

The following tables list the members exposed by Proxy.

Public Properties

 | Name | Description
public Property | AddressFamily | Gets or sets a value which specifies the address family to use when communicating with the proxy server.
public Property | HostNameOrAddress | Gets or sets a value which specifies the proxy server to use.
public Property | Password | Gets or sets a value which specifies the proxy password to use.
public Property | Port | Gets or sets a value which specifies the proxy port to connect to.
public Property | Type | Gets or sets the type of proxy to use.
public Property | Username | Gets or sets a value which specifies the proxy username to use.
Top

See Also

Reference

Proxy Class
Dart.Common Namespace


Proxy Class Properties

[image]
PowerTCP Telnet for .NET CF
Proxy Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : Proxy Class

"

For a list of all members of this type, see Proxy members.

"

Public Properties

 | Name | Description
public Property | AddressFamily | Gets or sets a value which specifies the address family to use when communicating with the proxy server.
public Property | HostNameOrAddress | Gets or sets a value which specifies the proxy server to use.
public Property | Password | Gets or sets a value which specifies the proxy password to use.
public Property | Port | Gets or sets a value which specifies the proxy port to connect to.
public Property | Type | Gets or sets the type of proxy to use.
public Property | Username | Gets or sets a value which specifies the proxy username to use.
Top

See Also

Reference

Proxy Class
Dart.Common Namespace


AddressFamily Property

[image]
PowerTCP Telnet for .NET CF
AddressFamily Property
See Also Send comments on this topic.
Dart.Common Namespace > Proxy Class : AddressFamily Property

Gets or sets a value which specifies the address family to use when communicating with the proxy server.

Syntax

Visual Basic (Declaration)
Public Property AddressFamily As AddressFamily
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As AddressFamily

instance.AddressFamily = value

value = instance.AddressFamily
C#
public AddressFamily AddressFamily {get; set;}
Managed Extensions for C++
public: __property AddressFamily get_AddressFamily();
public: __property void set_AddressFamily(
   AddressFamily value
);
C++/CLI
public:
property AddressFamily AddressFamily {
   AddressFamily get();
   void set (    AddressFamily value);
}

Remarks

AddressFamily.InterNetwork and AddressFamily.InterNetworkV6 can be used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Class
Proxy Members


HostNameOrAddress Property

[image]
PowerTCP Telnet for .NET CF
HostNameOrAddress Property
See Also Send comments on this topic.
Dart.Common Namespace > Proxy Class : HostNameOrAddress Property

Gets or sets a value which specifies the proxy server to use.

Syntax

Visual Basic (Declaration)
Public Property HostNameOrAddress As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.HostNameOrAddress = value

value = instance.HostNameOrAddress
C#
public string HostNameOrAddress {get; set;}
Managed Extensions for C++
public: __property string* get_HostNameOrAddress();
public: __property void set_HostNameOrAddress(
   string* value
);
C++/CLI
public:
property String^ HostNameOrAddress {
   String^ get();
   void set (    String^ value);
}

Property Value

A string representing the proxy server to use.

Remarks

Specifies the address or host name of the proxy server. Format in dot notation ("111.111.111.111") or by host name ("myserver").

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Class
Proxy Members


Password Property

[image]
PowerTCP Telnet for .NET CF
Password Property
See Also Send comments on this topic.
Dart.Common Namespace > Proxy Class : Password Property

Gets or sets a value which specifies the proxy password to use.

Syntax

Visual Basic (Declaration)
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.Password = value

value = instance.Password
C#
public string Password {get; set;}
Managed Extensions for C++
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the password used to access the proxy.

Remarks

The password to use for authentication on some proxies. Also see Username.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Class
Proxy Members


Port Property

[image]
PowerTCP Telnet for .NET CF
Port Property
See Also Send comments on this topic.
Dart.Common Namespace > Proxy Class : Port Property

Gets or sets a value which specifies the proxy port to connect to.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As Integer

instance.Port = value

value = instance.Port
C#
public int Port {get; set;}
Managed Extensions for C++
public: __property int get_Port();
public: __property void set_Port(
   int value
);
C++/CLI
public:
property int Port {
   int get();
   void set (    int value);
}

Property Value

An integer value representing the proxy port. This value is changed when it is 0 and the lished when the Type property is set.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Class
Proxy Members


Type Property

[image]
PowerTCP Telnet for .NET CF
Type Property
See Also Send comments on this topic.
Dart.Common Namespace > Proxy Class : Type Property

Gets or sets the type of proxy to use.

Syntax

Visual Basic (Declaration)
Public Property Type As ProxyType
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As ProxyType

instance.Type = value

value = instance.Type
C#
public ProxyType Type {get; set;}
Managed Extensions for C++
public: __property ProxyType get_Type();
public: __property void set_Type(
   ProxyType value
);
C++/CLI
public:
property ProxyType Type {
   ProxyType get();
   void set (    ProxyType value);
}

Property Value

A ProxyType enumerated value.

Remarks

The Port property is set to a default value when this property is set and the Port property is 0. Setting this property to ProxyType.None always sets the Port property to 0.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Class
Proxy Members


Username Property

[image]
PowerTCP Telnet for .NET CF
Username Property
See Also Send comments on this topic.
Dart.Common Namespace > Proxy Class : Username Property

Gets or sets a value which specifies the proxy username to use.

Syntax

Visual Basic (Declaration)
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.Username = value

value = instance.Username
C#
public string Username {get; set;}
Managed Extensions for C++
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value representing the username used to access the proxy.

Remarks

The username to use for authentication on some proxies. Also see Password.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Proxy Class
Proxy Members


PtyBase Class

[image]
PowerTCP Telnet for .NET CF
PtyBase Class
Members See Also Send comments on this topic.
Dart.Common Namespace : PtyBase Class

This class provides support for interactive on-line terminal access using controls derived from TextBoxBase.

Object Model

PtyBase ClassProxy ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class PtyBase
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
C#
public class PtyBase : TcpBase
Managed Extensions for C++
public __gc class PtyBase : public TcpBase
C++/CLI
public ref class PtyBase : public TcpBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Common.PtyBase
Dart.Telnet.Rlogin
Dart.Telnet.Telnet

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

PtyBase Members
Dart.Common Namespace


PtyBase Class Members

[image]
PowerTCP Telnet for .NET CF
PtyBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Common Namespace : PtyBase Class

The following tables list the members exposed by PtyBase.

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support.
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Overridden. Raises the Data event.
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Overridden. Raises the StateChanged event.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Common Namespace


PtyBase Class Methods

[image]
PowerTCP Telnet for .NET CF
PtyBase Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : PtyBase Class

"

For a list of all members of this type, see PtyBase members.

"

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Overridden. Raises the Data event.
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Overridden. Raises the StateChanged event.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Common Namespace


OnData Method

[image]
PowerTCP Telnet for .NET CF
OnData Method
See Also Send comments on this topic.
Dart.Common Namespace > PtyBase Class : OnData Method

e
A DataEventArgs object that contains the event data.
Raises the Data event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnData( _
   ByVal e As DataEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim e As DataEventArgs

instance.OnData(e)
C#
protected override void OnData(
   DataEventArgs e
)
Managed Extensions for C++
protected: void OnData(
   DataEventArgs* e
) override
C++/CLI
protected:
void OnData(
   DataEventArgs^ e
) override

Parameters

e
A DataEventArgs object that contains the event data.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnData method allows the PtyBase class to capture marshalled data without attaching a delegate.

Note to Inheritors: When overriding OnData in a derived class, be sure to call the base class OnData method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

PtyBase Class
PtyBase Members


OnStateChanged Method

[image]
PowerTCP Telnet for .NET CF
OnStateChanged Method
See Also Send comments on this topic.
Dart.Common Namespace > PtyBase Class : OnStateChanged Method

e
An EventArgs.
Raises the StateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnStateChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim e As EventArgs

instance.OnStateChanged(e)
C#
protected override void OnStateChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnStateChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnStateChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs.

Remarks

When the State changes to ConnectionState.Connected, this class captures keyboard input and sends it over the connection, and reads input on a worker thread. That data is marshaled to the OnData method, where it is displayed in the textbox.

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnStateChanged method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnStateChanged in a derived class, be sure to call the base class OnStateChanged method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

PtyBase Class
PtyBase Members


PtyBase Class Properties

[image]
PowerTCP Telnet for .NET CF
PtyBase Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : PtyBase Class

"

For a list of all members of this type, see PtyBase members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support.
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PtyBase Class
Dart.Common Namespace


Pty Property

[image]
PowerTCP Telnet for .NET CF
Pty Property
See Also Send comments on this topic.
Dart.Common Namespace > PtyBase Class : Pty Property

Gets or sets a display control to use for automatic pseudo terminal support.

Syntax

Visual Basic (Declaration)
Public Property Pty As TextBoxBase
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As TextBoxBase

instance.Pty = value

value = instance.Pty
C#
public TextBoxBase Pty {get; set;}
Managed Extensions for C++
public: __property TextBoxBase* get_Pty();
public: __property void set_Pty(
   TextBoxBase* value
);
C++/CLI
public:
property TextBoxBase^ Pty {
   TextBoxBase^ get();
   void set (    TextBoxBase^ value);
}

Remarks

Set this property to a control derived from TextBoxBase and call Connect to start an online session. Data received from the host will be displayed, and keyboard input will automatically be sent to the remote host.

The Multiline property on the Pty control is set to true. You may wish to set the Font property to a fixed-width font and set the Wordwrap property to false. Also, if the SynchronizingObject is null, it will be set to the Pty control.

These properties can be changed from their default values after this property is set.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

PtyBase Class
PtyBase Members


SocketBase Class

[image]
PowerTCP Telnet for .NET CF
SocketBase Class
Members See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

Base class for PowerTCP Components.

Object Model

SocketBase Class

Syntax

Visual Basic (Declaration)
Public Class SocketBase
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
C#
public class SocketBase : ComponentBase
Managed Extensions for C++
public __gc class SocketBase : public ComponentBase
C++/CLI
public ref class SocketBase : public ComponentBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketBase Members
Dart.Common Namespace


SocketBase Class Members

[image]
PowerTCP Telnet for .NET CF
SocketBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Common Namespace : SocketBase Class

The following tables list the members exposed by SocketBase.

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications.
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


SocketBase Class Properties

[image]
PowerTCP Telnet for .NET CF
SocketBase Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications.
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


Socket Property

[image]
PowerTCP Telnet for .NET CF
Socket Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketBase Class : Socket Property

Gets the socket used by the component for communications.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Socket As Socket
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
Dim value As Socket

value = instance.Socket
C#
public Socket Socket {get;}
Managed Extensions for C++
public: __property Socket* get_Socket();
C++/CLI
public:
property Socket^ Socket {
   Socket^ get();
}

Property Value

The Socket used for UDP or TCP communications. Returns null when not in use.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketBase Class
SocketBase Members


SocketOption Class

[image]
PowerTCP Telnet for .NET CF
SocketOption Class
Members See Also Send comments on this topic.
Dart.Common Namespace : SocketOption Class

Contains socket options that may be set by TCP and UDP sockets. These options are automatically applied to the connection used.

Object Model

SocketOption Class

Syntax

Visual Basic (Declaration)
Public Class SocketOption
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
C#
public class SocketOption
Managed Extensions for C++
public __gc class SocketOption
C++/CLI
public ref class SocketOption

Inheritance Hierarchy

System.Object
Dart.Common.SocketOption
Dart.Common.TcpSocketOption

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Members
Dart.Common Namespace


SocketOption Class Members

[image]
PowerTCP Telnet for .NET CF
SocketOption Class Members
See Also Fields Properties Send comments on this topic.
Dart.Common Namespace : SocketOption Class

The following tables list the members exposed by SocketOption.

Public Fields

 | Name | Description
public Field | LocalEndPoint | Gets or sets the desired local IPEndPoint (address and port) the socket should be bound to.
Top

Public Properties

 | Name | Description
public Property | LocalPortRange | Gets or sets the port range desired.
public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer.
public Property | ReceiveTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Receive call will time out.
public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer.
public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out.
Top

See Also

Reference

SocketOption Class
Dart.Common Namespace


SocketOption Class Properties

[image]
PowerTCP Telnet for .NET CF
SocketOption Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : SocketOption Class

"

For a list of all members of this type, see SocketOption members.

"

Public Properties

 | Name | Description
public Property | LocalPortRange | Gets or sets the port range desired.
public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer.
public Property | ReceiveTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Receive call will time out.
public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer.
public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out.
Top

See Also

Reference

SocketOption Class
Dart.Common Namespace


LocalPortRange Property

[image]
PowerTCP Telnet for .NET CF
LocalPortRange Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketOption Class : LocalPortRange Property

Gets or sets the port range desired.

Syntax

Visual Basic (Declaration)
Public Property LocalPortRange As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.LocalPortRange = value

value = instance.LocalPortRange
C#
public int LocalPortRange {get; set;}
Managed Extensions for C++
public: __property int get_LocalPortRange();
public: __property void set_LocalPortRange(
   int value
);
C++/CLI
public:
property int LocalPortRange {
   int get();
   void set (    int value);
}

Remarks

If LocalEndPoint > 0, then the socket will be bound to a port between LocalEndPoint.Port and (LocalEndPoint.Port + LocalPortRange), inclusive.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Class
SocketOption Members


ReceiveBufferSize Property

[image]
PowerTCP Telnet for .NET CF
ReceiveBufferSize Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketOption Class : ReceiveBufferSize Property

Gets or sets a value that specifies the size of the system receive buffer.

Syntax

Visual Basic (Declaration)
Public Property ReceiveBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.ReceiveBufferSize = value

value = instance.ReceiveBufferSize
C#
public int ReceiveBufferSize {get; set;}
Managed Extensions for C++
public: __property int get_ReceiveBufferSize();
public: __property void set_ReceiveBufferSize(
   int value
);
C++/CLI
public:
property int ReceiveBufferSize {
   int get();
   void set (    int value);
}

Property Value

An integer with a default value of 8192.

Remarks

Increasing the buffer size may help performance when transferring large amounts of data, or when high bandwidth, high latency connections (such as a satellite broadband provider) are used.

The value cannot be changed on CF devices.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Class
SocketOption Members


ReceiveTimeout Property

[image]
PowerTCP Telnet for .NET CF
ReceiveTimeout Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketOption Class : ReceiveTimeout Property

Gets or sets a value that specifies the amount of time after which the underlying Socket Receive call will time out.

Syntax

Visual Basic (Declaration)
Public Property ReceiveTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
public int ReceiveTimeout {get; set;}
Managed Extensions for C++
public: __property int get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   int value
);
C++/CLI
public:
property int ReceiveTimeout {
   int get();
   void set (    int value);
}

Property Value

The time-out value in milliseconds. The default value is 0, which indicates an infinite time-out period.

Remarks

A value of 0 or -1 indicates an infinite time-out period.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Class
SocketOption Members


SendBufferSize Property

[image]
PowerTCP Telnet for .NET CF
SendBufferSize Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketOption Class : SendBufferSize Property

Gets or sets a value that specifies the size of the system send buffer.

Syntax

Visual Basic (Declaration)
Public Property SendBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.SendBufferSize = value

value = instance.SendBufferSize
C#
public int SendBufferSize {get; set;}
Managed Extensions for C++
public: __property int get_SendBufferSize();
public: __property void set_SendBufferSize(
   int value
);
C++/CLI
public:
property int SendBufferSize {
   int get();
   void set (    int value);
}

Property Value

An integer with a default value of 8192.

Remarks

Increasing the buffer size may help performance when transferring large amounts of data, or when high bandwidth, high latency connections (such as a satellite broadband provider) are used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Class
SocketOption Members


SendTimeout Property

[image]
PowerTCP Telnet for .NET CF
SendTimeout Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketOption Class : SendTimeout Property

Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out.

Syntax

Visual Basic (Declaration)
Public Property SendTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.SendTimeout = value

value = instance.SendTimeout
C#
public int SendTimeout {get; set;}
Managed Extensions for C++
public: __property int get_SendTimeout();
public: __property void set_SendTimeout(
   int value
);
C++/CLI
public:
property int SendTimeout {
   int get();
   void set (    int value);
}

Property Value

The time-out value in milliseconds. The default value is 0, which indicates an infinite time-out period.

Remarks

Values between 1 and 499 will be changed to 500, as 500 is the minimum positive value. Values of 0 and -1 indicate an infinite time-out period.

This option has no affect on CF devices (the Write method will not time out).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Class
SocketOption Members


SocketOption Class Fields

[image]
PowerTCP Telnet for .NET CF
SocketOption Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : SocketOption Class

"

For a list of all members of this type, see SocketOption members.

"

Public Fields

 | Name | Description
public Field | LocalEndPoint | Gets or sets the desired local IPEndPoint (address and port) the socket should be bound to.
Top

See Also

Reference

SocketOption Class
Dart.Common Namespace


LocalEndPoint Field

[image]
PowerTCP Telnet for .NET CF
LocalEndPoint Field
See Also Send comments on this topic.
Dart.Common Namespace > SocketOption Class : LocalEndPoint Field

Gets or sets the desired local IPEndPoint (address and port) the socket should be bound to.

Syntax

Visual Basic (Declaration)
Public LocalEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As IPEndPoint

value = instance.LocalEndPoint

instance.LocalEndPoint = value
C#
public IPEndPoint LocalEndPoint
Managed Extensions for C++
public: IPEndPoint* LocalEndPoint
C++/CLI
public:
IPEndPoint^ LocalEndPoint

Remarks

Socket.Bind will be used bind the socket to the specified endpoint.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketOption Class
SocketOption Members


SslInfo Class

[image]
PowerTCP Telnet for .NET CF
SslInfo Class
Members See Also Send comments on this topic.
Dart.Common Namespace : SslInfo Class

Provides information on the SSL channel.

Object Model

SslInfo Class

Syntax

Visual Basic (Declaration)
Public Class SslInfo
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
C#
public class SslInfo
Managed Extensions for C++
public __gc class SslInfo
C++/CLI
public ref class SslInfo

Inheritance Hierarchy

System.Object
Dart.Common.SslInfo

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Members
Dart.Common Namespace


SslInfo Class Members

[image]
PowerTCP Telnet for .NET CF
SslInfo Class Members
See Also Properties Send comments on this topic.
Dart.Common Namespace : SslInfo Class

The following tables list the members exposed by SslInfo.

Public Properties

 | Name | Description
public Property | CipherAlgorithm | Gets the cipher algorithm used by the SSL channel.
public Property | CipherStrength | Gets the strength of the cipher used to secure the SSL channel.
public Property | HashAlgorithm | Gets the hash algorithm used for generating Message Authentication Codes (MACs).
public Property | HashStrength | Gets the strength of the hash algorithm used to secure the SSL channel.
public Property | KeyExchangeAlgorithm | Gets the key exchange algorithm used by the SSL channel.
public Property | KeyExchangeStrength | Gets the strength of the key exchange algorithm used by the SSL channel.
public Property | LocalCertificate | Gets the certificate used to authenticate the local endpoint.
public Property | Protocol | Gets the SSL Protocol used by the SSL channel.
public Property | RemoteCertificate | Gets the certificate used to authenticate the remote endpoint.
Top

See Also

Reference

SslInfo Class
Dart.Common Namespace


SslInfo Class Properties

[image]
PowerTCP Telnet for .NET CF
SslInfo Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : SslInfo Class

"

For a list of all members of this type, see SslInfo members.

"

Public Properties

 | Name | Description
public Property | CipherAlgorithm | Gets the cipher algorithm used by the SSL channel.
public Property | CipherStrength | Gets the strength of the cipher used to secure the SSL channel.
public Property | HashAlgorithm | Gets the hash algorithm used for generating Message Authentication Codes (MACs).
public Property | HashStrength | Gets the strength of the hash algorithm used to secure the SSL channel.
public Property | KeyExchangeAlgorithm | Gets the key exchange algorithm used by the SSL channel.
public Property | KeyExchangeStrength | Gets the strength of the key exchange algorithm used by the SSL channel.
public Property | LocalCertificate | Gets the certificate used to authenticate the local endpoint.
public Property | Protocol | Gets the SSL Protocol used by the SSL channel.
public Property | RemoteCertificate | Gets the certificate used to authenticate the remote endpoint.
Top

See Also

Reference

SslInfo Class
Dart.Common Namespace


CipherAlgorithm Property

[image]
PowerTCP Telnet for .NET CF
CipherAlgorithm Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : CipherAlgorithm Property

Gets the cipher algorithm used by the SSL channel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CipherAlgorithm As CipherAlgorithmType
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As CipherAlgorithmType

value = instance.CipherAlgorithm
C#
public CipherAlgorithmType CipherAlgorithm {get;}
Managed Extensions for C++
public: __property CipherAlgorithmType get_CipherAlgorithm();
C++/CLI
public:
property CipherAlgorithmType CipherAlgorithm {
   CipherAlgorithmType get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


CipherStrength Property

[image]
PowerTCP Telnet for .NET CF
CipherStrength Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : CipherStrength Property

Gets the strength of the cipher used to secure the SSL channel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CipherStrength As Integer
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As Integer

value = instance.CipherStrength
C#
public int CipherStrength {get;}
Managed Extensions for C++
public: __property int get_CipherStrength();
C++/CLI
public:
property int CipherStrength {
   int get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


HashAlgorithm Property

[image]
PowerTCP Telnet for .NET CF
HashAlgorithm Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : HashAlgorithm Property

Gets the hash algorithm used for generating Message Authentication Codes (MACs).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HashAlgorithm As HashAlgorithmType
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As HashAlgorithmType

value = instance.HashAlgorithm
C#
public HashAlgorithmType HashAlgorithm {get;}
Managed Extensions for C++
public: __property HashAlgorithmType get_HashAlgorithm();
C++/CLI
public:
property HashAlgorithmType HashAlgorithm {
   HashAlgorithmType get();
}

Remarks

MACs are used to detect tampering and forgery.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


HashStrength Property

[image]
PowerTCP Telnet for .NET CF
HashStrength Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : HashStrength Property

Gets the strength of the hash algorithm used to secure the SSL channel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HashStrength As Integer
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As Integer

value = instance.HashStrength
C#
public int HashStrength {get;}
Managed Extensions for C++
public: __property int get_HashStrength();
C++/CLI
public:
property int HashStrength {
   int get();
}

Property Value

An integer bits value, typically 128 or 160.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


KeyExchangeAlgorithm Property

[image]
PowerTCP Telnet for .NET CF
KeyExchangeAlgorithm Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : KeyExchangeAlgorithm Property

Gets the key exchange algorithm used by the SSL channel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyExchangeAlgorithm As ExchangeAlgorithmType
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As ExchangeAlgorithmType

value = instance.KeyExchangeAlgorithm
C#
public ExchangeAlgorithmType KeyExchangeAlgorithm {get;}
Managed Extensions for C++
public: __property ExchangeAlgorithmType get_KeyExchangeAlgorithm();
C++/CLI
public:
property ExchangeAlgorithmType KeyExchangeAlgorithm {
   ExchangeAlgorithmType get();
}

Remarks

The key exchange algorithm protects information used to generate shared keys.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


KeyExchangeStrength Property

[image]
PowerTCP Telnet for .NET CF
KeyExchangeStrength Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : KeyExchangeStrength Property

Gets the strength of the key exchange algorithm used by the SSL channel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyExchangeStrength As Integer
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As Integer

value = instance.KeyExchangeStrength
C#
public int KeyExchangeStrength {get;}
Managed Extensions for C++
public: __property int get_KeyExchangeStrength();
C++/CLI
public:
property int KeyExchangeStrength {
   int get();
}

Property Value

An integer bits value, typically 512, 768, 1024 or 2048.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


LocalCertificate Property

[image]
PowerTCP Telnet for .NET CF
LocalCertificate Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : LocalCertificate Property

Gets the certificate used to authenticate the local endpoint.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocalCertificate As X509Certificate
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As X509Certificate

value = instance.LocalCertificate
C#
public X509Certificate LocalCertificate {get;}
Managed Extensions for C++
public: __property X509Certificate* get_LocalCertificate();
C++/CLI
public:
property X509Certificate^ LocalCertificate {
   X509Certificate^ get();
}

Property Value

An X509Certificate object representing the authentication certificate supplied by the local host.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


Protocol Property

[image]
PowerTCP Telnet for .NET CF
Protocol Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : Protocol Property

Gets the SSL Protocol used by the SSL channel.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Protocol As SslProtocols
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As SslProtocols

value = instance.Protocol
C#
public SslProtocols Protocol {get;}
Managed Extensions for C++
public: __property SslProtocols get_Protocol();
C++/CLI
public:
property SslProtocols Protocol {
   SslProtocols get();
}

Property Value

An SslProtocols enumerated value.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


RemoteCertificate Property

[image]
PowerTCP Telnet for .NET CF
RemoteCertificate Property
See Also Send comments on this topic.
Dart.Common Namespace > SslInfo Class : RemoteCertificate Property

Gets the certificate used to authenticate the remote endpoint.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemoteCertificate As X509Certificate
Visual Basic (Usage) Copy Code
Dim instance As SslInfo
Dim value As X509Certificate

value = instance.RemoteCertificate
C#
public X509Certificate RemoteCertificate {get;}
Managed Extensions for C++
public: __property X509Certificate* get_RemoteCertificate();
C++/CLI
public:
property X509Certificate^ RemoteCertificate {
   X509Certificate^ get();
}

Property Value

An X509Certificate object representing the authentication certificate supplied by the remote host.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SslInfo Class
SslInfo Members


TcpBase Class

[image]
PowerTCP Telnet for .NET CF
TcpBase Class
Members See Also Send comments on this topic.
Dart.Common Namespace : TcpBase Class

Base class for components utilizing protocols built upon the TCP protocol.

Object Model

TcpBase ClassProxy ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class TcpBase
   Inherits SocketBase
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
C#
public class TcpBase : SocketBase
Managed Extensions for C++
public __gc class TcpBase : public SocketBase
C++/CLI
public ref class TcpBase : public SocketBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Common.PtyBase
Dart.Telnet.Rexec
Dart.Telnet.Rsh

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Members
Dart.Common Namespace


TcpBase Class Members

[image]
PowerTCP Telnet for .NET CF
TcpBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Common Namespace : TcpBase Class

The following tables list the members exposed by TcpBase.

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised.
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called.
public Property | Proxy | Gets the proxy server information used by the component.
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy).
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase.
public Property | State | Gets the status of the connection.
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection.
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection.
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection.
public Method | Close | Overloaded. Gracefully closes the connection.
public Method | Connect | Overloaded. Connects to the specified remote endpoint.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel.
public Method | GetStream | Provides access to the underlying Stream.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread.
public Method | Read | Overloaded. Receives data from the remote host.
public Method | ReadToEnd | Receives data until the connection is closed.
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection.
public Method | Write | Overloaded. Sends data to the remote host.
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event.
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event.
protected Method | OnStateChanged | Raises the StateChanged event.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user.
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data.
public Event | StateChanged | Raised when the value of the State property changes.
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Common Namespace


TcpBase Class Methods

[image]
PowerTCP Telnet for .NET CF
TcpBase Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : TcpBase Class

"

For a list of all members of this type, see TcpBase members.

"

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection.
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection.
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection.
public Method | Close | Overloaded. Gracefully closes the connection.
public Method | Connect | Overloaded. Connects to the specified remote endpoint.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel.
public Method | GetStream | Provides access to the underlying Stream.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread.
public Method | Read | Overloaded. Receives data from the remote host.
public Method | ReadToEnd | Receives data until the connection is closed.
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection.
public Method | Write | Overloaded. Sends data to the remote host.
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event.
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event.
protected Method | OnStateChanged | Raises the StateChanged event.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Common Namespace


Abort Method

[image]
PowerTCP Telnet for .NET CF
Abort Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Abort Method

Performs a hard close of the connection.

Syntax

Visual Basic (Declaration)
Public Sub Abort()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.Abort()
C#
public void Abort()
Managed Extensions for C++
public: void Abort();
C++/CLI
public:
void Abort();

Remarks

This method resets the connection and immediately clears the socket state.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClient Method

[image]
PowerTCP Telnet for .NET CF
AuthenticateAsClient Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : AuthenticateAsClient Method

Authenticates the server when establishing a secure connection.

Overload List

Overload | Description
AuthenticateAsClient(String) | Authenticates the server when establishing a secure connection.
AuthenticateAsClient(String,X509CertificateCollection,SslProtocols,Boolean,RemoteCertificateValidationCallback,LocalCertificateSelectionCallback) | Authenticates the server when establishing a secure connection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClient(String) Method

[image]
PowerTCP Telnet for .NET CF
AuthenticateAsClient(String) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > AuthenticateAsClient Method : AuthenticateAsClient(String) Method

targetHost
The name of the remote host to be authenticated.
Authenticates the server when establishing a secure connection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AuthenticateAsClient( _
   ByVal targetHost As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim targetHost As String

instance.AuthenticateAsClient(targetHost)
C#
public void AuthenticateAsClient(
   string targetHost
)
Managed Extensions for C++
public: void AuthenticateAsClient(
   string* targetHost
)
C++/CLI
public:
void AuthenticateAsClient(
   String^ targetHost
)

Parameters

targetHost
The name of the remote host to be authenticated.

Remarks

The targetHost must match the server certificate name. If authentication fails, an AuthenticationException will occur.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsClient(String,X509CertificateCollection,SslProtocols,Boolean,RemoteCertificateValidationCallback,LocalCertificateSelectionCallback) Method

[image]
PowerTCP Telnet for .NET CF
AuthenticateAsClient(String,X509CertificateCollection,SslProtocols,Boolean,RemoteCertificateValidationCallback,LocalCertificateSelectionCallback) Method
See Also Example Send comments on this topic.
Dart.Common Namespace > TcpBase Class > AuthenticateAsClient Method : AuthenticateAsClient(String,X509CertificateCollection,SslProtocols,Boolean,RemoteCertificateValidationCallback,LocalCertificateSelectionCallback) Method

targetHost
The name of the remote host to be authenticated.
clientCertificates
A collection of client certificates to select from during the authentication.
enabledSslProtocols
The enabled SSL protocols.
checkCertificateRevocation
Whether or not the certificate revocation list is checked during authentication.
userCertificateValidationCallback
The callback function that executes after the server presents its certificate.
userCertificateSelectionCallback
The callback function that executes after the server requests a certificate.
Authenticates the server when establishing a secure connection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AuthenticateAsClient( _
   ByVal targetHost As String, _
   ByVal clientCertificates As X509CertificateCollection, _
   ByVal enabledSslProtocols As SslProtocols, _
   ByVal checkCertificateRevocation As Boolean, _
   ByVal userCertificateValidationCallback As RemoteCertificateValidationCallback, _
   ByVal userCertificateSelectionCallback As LocalCertificateSelectionCallback _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim targetHost As String
Dim clientCertificates As X509CertificateCollection
Dim enabledSslProtocols As SslProtocols
Dim checkCertificateRevocation As Boolean
Dim userCertificateValidationCallback As RemoteCertificateValidationCallback
Dim userCertificateSelectionCallback As LocalCertificateSelectionCallback

instance.AuthenticateAsClient(targetHost, clientCertificates, enabledSslProtocols, checkCertificateRevocation, userCertificateValidationCallback, userCertificateSelectionCallback)
C#
public void AuthenticateAsClient(
   string targetHost,
   X509CertificateCollection clientCertificates,
   SslProtocols enabledSslProtocols,
   bool checkCertificateRevocation,
   RemoteCertificateValidationCallback userCertificateValidationCallback,
   LocalCertificateSelectionCallback userCertificateSelectionCallback
)
Managed Extensions for C++
public: void AuthenticateAsClient(
   string* targetHost,
   X509CertificateCollection* clientCertificates,
   SslProtocols enabledSslProtocols,
   bool checkCertificateRevocation,
   RemoteCertificateValidationCallback* userCertificateValidationCallback,
   LocalCertificateSelectionCallback* userCertificateSelectionCallback
)
C++/CLI
public:
void AuthenticateAsClient(
   String^ targetHost,
   X509CertificateCollection^ clientCertificates,
   SslProtocols enabledSslProtocols,
   bool checkCertificateRevocation,
   RemoteCertificateValidationCallback^ userCertificateValidationCallback,
   LocalCertificateSelectionCallback^ userCertificateSelectionCallback
)

Parameters

targetHost
The name of the remote host to be authenticated.
clientCertificates
A collection of client certificates to select from during the authentication.
enabledSslProtocols
The enabled SSL protocols.
checkCertificateRevocation
Whether or not the certificate revocation list is checked during authentication.
userCertificateValidationCallback
The callback function that executes after the server presents its certificate.
userCertificateSelectionCallback
The callback function that executes after the server requests a certificate.

Example

This example demonstrates the AuthenticateAsClient call and the callback that executes when a certificate is received.
C# Copy Code
private void doAuthentication(string server, SslProtocols protocol, bool checkRevocation)
{
    //Authenticate server and specify certificate callback functions
    myComponent.AuthenticateAsClient(server, null, protocol, checkRevocation, certificateReceived, null);
}

private static bool certificateReceived(object sender,
    System.Security.Cryptography.X509Certificates.X509Certificate certificate,
    X509Chain chain, SslPolicyErrors sslPolicyErrors)
{
    //Return true if the server certificate is ok
    if (sslPolicyErrors == SslPolicyErrors.None)
        return true;

    bool acceptCertificate = true;
    string msg = "The server could not be validated for the following reason(s):\r\n";

    //The server did not present a certificate
    if ((sslPolicyErrors &
        SslPolicyErrors.RemoteCertificateNotAvailable) == SslPolicyErrors.RemoteCertificateNotAvailable)
    {
        msg = msg + "\r\n    -The server did not present a certificate.\r\n";
        acceptCertificate = false;
    }
    else
    {
        //The certificate does not match the server name
        if ((sslPolicyErrors &
            SslPolicyErrors.RemoteCertificateNameMismatch) == SslPolicyErrors.RemoteCertificateNameMismatch)
        {
            msg = msg + "\r\n    -The certificate name does not match the authenticated name.\r\n";
            acceptCertificate = false;
        }

        //There is some other problem with the certificate
        if ((sslPolicyErrors &
            SslPolicyErrors.RemoteCertificateChainErrors) == SslPolicyErrors.RemoteCertificateChainErrors)
        {
            foreach (X509ChainStatus item in chain.ChainStatus)
            {
                if (item.Status != X509ChainStatusFlags.RevocationStatusUnknown &&
                    item.Status != X509ChainStatusFlags.OfflineRevocation)
                    break;

                if (item.Status != X509ChainStatusFlags.NoError)
                {
                    msg = msg + "\r\n    -" + item.StatusInformation;
                    acceptCertificate = false;
                }
            }
        }
    }

    //If Validation failed, present message box
    if (acceptCertificate == false)
    {
        msg = msg + "\r\nDo you wish to override the security check?";
        if (MessageBox.Show(msg, "Security Alert: Server could not be validated",
            MessageBoxButtons.YesNo, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1) == DialogResult.Yes)
            acceptCertificate = true;
    }

    return acceptCertificate;
}
Visual Basic Copy Code
Private Sub doAuthentication(ByVal server As String, ByVal protocol As SslProtocols, _
    ByVal checkRevocation As Boolean)
    'Authenticate server and specify certificate callback functions
    myComponent.AuthenticateAsClient(server, Nothing, protocol, checkRevocation, _
        AddressOf certificateReceived, Nothing)
End Sub

Private Shared Function certificateReceived(ByVal sender As Object, _
    ByVal certificate As System.Security.Cryptography.X509Certificates.X509Certificate, _
    ByVal chain As X509Chain, ByVal sslPolicyErrors As SslPolicyErrors) As Boolean
    'Return true if the server certificate is ok
    If sslPolicyErrors = SslPolicyErrors.None Then
        Return True
    End If

    Dim acceptCertificate As Boolean = True
    Dim msg As String = "The server could not be validated for the following reason(s):" & Constants.vbCrLf

    'The server did not present a certificate
    If (sslPolicyErrors And _
        SslPolicyErrors.RemoteCertificateNotAvailable) = SslPolicyErrors.RemoteCertificateNotAvailable Then
        msg = msg & Constants.vbCrLf & "    -The server did not present a certificate." & Constants.vbCrLf
        acceptCertificate = False
    Else
        'The certificate does not match the server name
        If ((sslPolicyErrors And _
            SslPolicyErrors.RemoteCertificateNameMismatch) = SslPolicyErrors.RemoteCertificateNameMismatch) Then
            msg = msg & Constants.vbCrLf & _
                "    -The certificate name does not match the authenticated name." & Constants.vbCrLf
                acceptCertificate = False
        End If

        'There is some other problem with the certificate
        If (sslPolicyErrors And _
            SslPolicyErrors.RemoteCertificateChainErrors) = SslPolicyErrors.RemoteCertificateChainErrors Then
            For Each item As X509ChainStatus In chain.ChainStatus
                If item.Status <> X509ChainStatusFlags.RevocationStatusUnknown AndAlso _
                    item.Status <> X509ChainStatusFlags.OfflineRevocation Then
                    Exit For
                End If

                If (item.Status <> X509ChainStatusFlags.NoError) Then
                    msg = msg & Constants.vbCrLf & "    -" & item.StatusInformation
                    acceptCertificate = False
                End If
            Next item
        End If
    End If

    'If Validation failed, present message box
    If acceptCertificate = False Then
        msg = msg & Constants.vbCrLf & "Do you wish to override the security check?"
        If MessageBox.Show(msg, "Security Alert: Server could not be validated", _
            MessageBoxButtons.YesNo, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1) _
               = System.Windows.Forms.DialogResult.Yes Then
           acceptCertificate = True
        End If
    End If

    Return acceptCertificate
End Function

Remarks

The targetHost must match the server certificate name. If authentication fails, an AuthenticationException will occur.

To accept or reject a certificate "on-the-fly" implement a userCertificateValidationCallback function.

To select a client certificate "on-the-fly" implement a userCertificateSelectionCallback function.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsServer Method

[image]
PowerTCP Telnet for .NET CF
AuthenticateAsServer Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : AuthenticateAsServer Method

Authenticates a client when establishing a secure connection.

Overload List

Overload | Description
AuthenticateAsServer(X509Certificate) | Authenticates a client when establishing a secure connection.
AuthenticateAsServer(X509Certificate,Boolean,SslProtocols,Boolean,RemoteCertificateValidationCallback) | Authenticates a client when establishing a secure connection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsServer(X509Certificate) Method

[image]
PowerTCP Telnet for .NET CF
AuthenticateAsServer(X509Certificate) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > AuthenticateAsServer Method : AuthenticateAsServer(X509Certificate) Method

serverCertificate
The certificate to provide the client.
Authenticates a client when establishing a secure connection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AuthenticateAsServer( _
   ByVal serverCertificate As X509Certificate _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim serverCertificate As X509Certificate

instance.AuthenticateAsServer(serverCertificate)
C#
public void AuthenticateAsServer(
   X509Certificate serverCertificate
)
Managed Extensions for C++
public: void AuthenticateAsServer(
   X509Certificate* serverCertificate
)
C++/CLI
public:
void AuthenticateAsServer(
   X509Certificate^ serverCertificate
)

Parameters

serverCertificate
The certificate to provide the client.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsServer(X509Certificate,Boolean,SslProtocols,Boolean,RemoteCertificateValidationCallback) Method

[image]
PowerTCP Telnet for .NET CF
AuthenticateAsServer(X509Certificate,Boolean,SslProtocols,Boolean,RemoteCertificateValidationCallback) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > AuthenticateAsServer Method : AuthenticateAsServer(X509Certificate,Boolean,SslProtocols,Boolean,RemoteCertificateValidationCallback) Method

serverCertificate
The certificate to provide the client.
clientCertificateRequired
Whether or not the client is required to provide a certificate.
enabledSslProtocols
The enabled SSL protocols.
checkCertificateRevocation
Whether or not the certificate revocation list is checked during authentication.
userCertificateValidationCallback
The callback function that executes after the client presents its certificate.
Authenticates a client when establishing a secure connection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AuthenticateAsServer( _
   ByVal serverCertificate As X509Certificate, _
   ByVal clientCertificateRequired As Boolean, _
   ByVal enabledSslProtocols As SslProtocols, _
   ByVal checkCertificateRevocation As Boolean, _
   ByVal userCertificateValidationCallback As RemoteCertificateValidationCallback _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim serverCertificate As X509Certificate
Dim clientCertificateRequired As Boolean
Dim enabledSslProtocols As SslProtocols
Dim checkCertificateRevocation As Boolean
Dim userCertificateValidationCallback As RemoteCertificateValidationCallback

instance.AuthenticateAsServer(serverCertificate, clientCertificateRequired, enabledSslProtocols, checkCertificateRevocation, userCertificateValidationCallback)
C#
public void AuthenticateAsServer(
   X509Certificate serverCertificate,
   bool clientCertificateRequired,
   SslProtocols enabledSslProtocols,
   bool checkCertificateRevocation,
   RemoteCertificateValidationCallback userCertificateValidationCallback
)
Managed Extensions for C++
public: void AuthenticateAsServer(
   X509Certificate* serverCertificate,
   bool clientCertificateRequired,
   SslProtocols enabledSslProtocols,
   bool checkCertificateRevocation,
   RemoteCertificateValidationCallback* userCertificateValidationCallback
)
C++/CLI
public:
void AuthenticateAsServer(
   X509Certificate^ serverCertificate,
   bool clientCertificateRequired,
   SslProtocols enabledSslProtocols,
   bool checkCertificateRevocation,
   RemoteCertificateValidationCallback^ userCertificateValidationCallback
)

Parameters

serverCertificate
The certificate to provide the client.
clientCertificateRequired
Whether or not the client is required to provide a certificate.
enabledSslProtocols
The enabled SSL protocols.
checkCertificateRevocation
Whether or not the certificate revocation list is checked during authentication.
userCertificateValidationCallback
The callback function that executes after the client presents its certificate.

Remarks

To accept or reject a certificate "on-the-fly" implement a userCertificateValidationCallback function.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Close Method

[image]
PowerTCP Telnet for .NET CF
Close Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Close Method

Gracefully closes the connection.

Overload List

Overload | Description
Close() | Gracefully closes the connection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Close() Method

[image]
PowerTCP Telnet for .NET CF
Close() Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Close Method : Close() Method

Gracefully closes the connection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.Close()
C#
public virtual void Close()
Managed Extensions for C++
public: virtual void Close();
C++/CLI
public:
virtual void Close();

Remarks

This method enters a normal TIME_WAIT state after the connection is closed.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Connect Method

[image]
PowerTCP Telnet for .NET CF
Connect Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Connect Method

Connects to the specified remote endpoint.

Overload List

Overload | Description
Connect(IPEndPoint) | Connects to the specified remote endpoint.
Connect(IPAddress[]) | Connects to one in a specified list of IP addresses.
Connect(String) | Connects to a host name or address using the default server port.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Connect(IPEndPoint) Method

[image]
PowerTCP Telnet for .NET CF
Connect(IPEndPoint) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Connect Method : Connect(IPEndPoint) Method

remoteEP
The endpoint to connect to.
Connects to the specified remote endpoint.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal remoteEP As IPEndPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim remoteEP As IPEndPoint

instance.Connect(remoteEP)
C#
public void Connect(
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: void Connect(
   IPEndPoint* remoteEP
)
C++/CLI
public:
void Connect(
   IPEndPoint^ remoteEP
)

Parameters

remoteEP
The endpoint to connect to.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Connect(IPAddress[]) Method

[image]
PowerTCP Telnet for .NET CF
Connect(IPAddress[]) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Connect Method : Connect(IPAddress[]) Method

addresses
An array of addresses to connect to.
Connects to one in a specified list of IP addresses.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal addresses() As IPAddress _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim addresses() As IPAddress

instance.Connect(addresses)
C#
public void Connect(
   IPAddress[] addresses
)
Managed Extensions for C++
public: void Connect(
   IPAddress*[]* addresses
)
C++/CLI
public:
void Connect(
   array<IPAddress^>^ addresses
)

Parameters

addresses
An array of addresses to connect to.

Remarks

The component attempts to connect to each address in the array, until a successful connection is established.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Connect(String) Method

[image]
PowerTCP Telnet for .NET CF
Connect(String) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Connect Method : Connect(String) Method

hostNameOrAddress
The host name or address to connect to.
Connects to a host name or address using the default server port.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public virtual void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: virtual void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
virtual void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
The host name or address to connect to.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


GetSslInfo Method

[image]
PowerTCP Telnet for .NET CF
GetSslInfo Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : GetSslInfo Method

Provides information on the SSL channel.

Syntax

Visual Basic (Declaration)
Public Function GetSslInfo() As SslInfo
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As SslInfo

value = instance.GetSslInfo()
C#
public SslInfo GetSslInfo()
Managed Extensions for C++
public: SslInfo* GetSslInfo();
C++/CLI
public:
SslInfo^ GetSslInfo();

Return Value

An SslInfo object containing information on the SSl channel.

Remarks

This property provides information on the algorithm and strength of the cipher, hash and key exchange used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


GetStream Method

[image]
PowerTCP Telnet for .NET CF
GetStream Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : GetStream Method

Provides access to the underlying Stream.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Stream

value = instance.GetStream()
C#
public virtual Stream GetStream()
Managed Extensions for C++
public: virtual Stream* GetStream();
C++/CLI
public:
virtual Stream^ GetStream();

Return Value

The underlying Stream object used by the component.

Remarks

Derived classes can override this method to provide a stream that implements an upper-layer protocol.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Marshal Method

[image]
PowerTCP Telnet for .NET CF
Marshal Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Marshal Method

Marshals data to the UI thread.

Overload List

Overload | Description
Marshal(Data,Object) | Marshals data to the UI thread.
Marshal(Exception) | Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Marshal(Object) | Marshals user state information to the UI thread. (Inherited from Dart.Common.ComponentBase)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Marshal(Data,Object) Method

[image]
PowerTCP Telnet for .NET CF
Marshal(Data,Object) Method
See Also Example Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Marshal Method : Marshal(Data,Object) Method

data
The data to be marshaled.
state
State information to be marshaled.
Marshals data to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal data As Data, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim data As Data
Dim state As Object

instance.Marshal(data, state)
C#
public void Marshal(
   Data data,
   object state
)
Managed Extensions for C++
public: void Marshal(
   Data* data,
   Object* state
)
C++/CLI
public:
void Marshal(
   Data^ data,
   Object^ state
)

Parameters

data
The data to be marshaled.
state
State information to be marshaled.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method is used to marshal data from a worker thread back to the UI thread for typical display purposes. It calls the OnData method, which raises the Data event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


OnData Method

[image]
PowerTCP Telnet for .NET CF
OnData Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : OnData Method

e
A DataEventArgs object that contains the event data.
Raises the Data event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnData( _
   ByVal e As DataEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim e As DataEventArgs

instance.OnData(e)
C#
protected virtual void OnData(
   DataEventArgs e
)
Managed Extensions for C++
protected: virtual void OnData(
   DataEventArgs* e
)
C++/CLI
protected:
virtual void OnData(
   DataEventArgs^ e
)

Parameters

e
A DataEventArgs object that contains the event data.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnData method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnData in a derived class, be sure to call the base class OnData method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


OnLog Method

[image]
PowerTCP Telnet for .NET CF
OnLog Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : OnLog Method

e
A LogEventArgs object containing data to log.
Raises the Log event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLog( _
   ByVal e As LogEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim e As LogEventArgs

instance.OnLog(e)
C#
protected virtual void OnLog(
   LogEventArgs e
)
Managed Extensions for C++
protected: virtual void OnLog(
   LogEventArgs* e
)
C++/CLI
protected:
virtual void OnLog(
   LogEventArgs^ e
)

Parameters

e
A LogEventArgs object containing data to log.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnLog method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnLog in a derived class, be sure to call the base class OnLog method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


OnStateChanged Method

[image]
PowerTCP Telnet for .NET CF
OnStateChanged Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : OnStateChanged Method

e
An EventArgs.
Raises the StateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnStateChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim e As EventArgs

instance.OnStateChanged(e)
C#
protected virtual void OnStateChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnStateChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnStateChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnStateChanged method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnStateChanged in a derived class, be sure to call the base class OnStateChanged method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Read Method

[image]
PowerTCP Telnet for .NET CF
Read Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Read Method

Receives data from the remote host.

Overload List

Overload | Description
Read(Byte[],Int32,Int32) | Receives data from the remote host.
Read(Byte[]) | Receives data from the remote host.
Read(String) | Receives data until a delimiter is found.
Read(String[]) | Receives data until a delimiter is found.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Read(Byte[],Int32,Int32) Method

[image]
PowerTCP Telnet for .NET CF
Read(Byte[],Int32,Int32) Method
See Also Example Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
size
The number of bytes to receive.
Receives data from the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal size As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim size As Integer
Dim value As Data

value = instance.Read(buffer, offset, size)
C#
public Data Read(
   byte[] buffer,
   int offset,
   int size
)
Managed Extensions for C++
public: Data* Read(
   byte[]* buffer,
   int offset,
   int size
)
C++/CLI
public:
Data^ Read(
   array<byte>^ buffer,
   int offset,
   int size
)

Parameters

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
size
The number of bytes to receive.

Return Value

A Data object encapsulating the received data.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method will read as much data as is available, up to the number of bytes specified by the size parameter.

This method will block until data is available or the ReceiveTimeout property has expired.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read(Byte[]) Method

[image]
PowerTCP Telnet for .NET CF
Read(Byte[]) Method
See Also Example Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Read Method : Read(Byte[]) Method

buffer
The byte array used to store the received data.
Receives data from the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim value As Data

value = instance.Read(buffer)
C#
public Data Read(
   byte[] buffer
)
Managed Extensions for C++
public: Data* Read(
   byte[]* buffer
)
C++/CLI
public:
Data^ Read(
   array<byte>^ buffer
)

Parameters

buffer
The byte array used to store the received data.

Return Value

A Data object encapsulating the received data.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method will read as much data as is available, up to the size of the buffer.

This method will block until data is available or the ReceiveTimeout property has expired.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read(String) Method

[image]
PowerTCP Telnet for .NET CF
Read(String) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Read Method : Read(String) Method

delimiter
A delimiter string to search for. If null, the socket is read until a timeout occurs or the server closes the connection.
Receives data until a delimiter is found.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal delimiter As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiter As String
Dim value As Data

value = instance.Read(delimiter)
C#
public Data Read(
   string delimiter
)
Managed Extensions for C++
public: Data* Read(
   string* delimiter
)
C++/CLI
public:
Data^ Read(
   String^ delimiter
)

Parameters

delimiter
A delimiter string to search for. If null, the socket is read until a timeout occurs or the server closes the connection.

Return Value

A Data object encapsulating the received data.

Remarks

This method blocks until the delimiter is found, the timeout period expires, or the server closes the connection. If the method times out, all received data will be returned, and an exception will NOT be thrown. Instead, the returned Data.Delimiter will be null, indicating the delimiter was not found.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read(String[]) Method

[image]
PowerTCP Telnet for .NET CF
Read(String[]) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Read Method : Read(String[]) Method

delimiters
An array of delimiters to search for. If null, the socket is read until a timeout occurs or the server closes the connection.
Receives data until a delimiter is found.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal delimiters() As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiters() As String
Dim value As Data

value = instance.Read(delimiters)
C#
public Data Read(
   string[] delimiters
)
Managed Extensions for C++
public: Data* Read(
   string*[]* delimiters
)
C++/CLI
public:
Data^ Read(
   array<String^>^ delimiters
)

Parameters

delimiters
An array of delimiters to search for. If null, the socket is read until a timeout occurs or the server closes the connection.

Return Value

A Data object encapsulating the received data.

Remarks

This method blocks until a delimiter is found, the timeout period expires, or the server closes the connection. If the method times out, all received data will be returned, and an exception will NOT be thrown. Instead, the returned Data.Delimiter will be null, indicating no delimiter was not found.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToEnd Method

[image]
PowerTCP Telnet for .NET CF
ReadToEnd Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : ReadToEnd Method

Receives data until the connection is closed.

Syntax

Visual Basic (Declaration)
Public Function ReadToEnd() As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Data

value = instance.ReadToEnd()
C#
public Data ReadToEnd()
Managed Extensions for C++
public: Data* ReadToEnd();
C++/CLI
public:
Data^ ReadToEnd();

Return Value

A Data object encapsulating the received data.

Remarks

This method blocks until the connection is closed. Data will not be made available until that time and the method returns.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


ShutdownSsl Method

[image]
PowerTCP Telnet for .NET CF
ShutdownSsl Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : ShutdownSsl Method

Signals the remote host to shutdown the SSL connection.

Syntax

Visual Basic (Declaration)
Public Sub ShutdownSsl()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.ShutdownSsl()
C#
public void ShutdownSsl()
Managed Extensions for C++
public: void ShutdownSsl();
C++/CLI
public:
void ShutdownSsl();

Remarks

This method provides a means for switching a secure connection to a non-secure connection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Write Method

[image]
PowerTCP Telnet for .NET CF
Write Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Write Method

Sends data to the remote host.

Overload List

Overload | Description
Write(Byte[]) | Sends data to the remote host.
Write(String) | Sends data to the remote host.
Write(Byte[],Int32,Int32) | Sends data to the remote host.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Write(Byte[]) Method

[image]
PowerTCP Telnet for .NET CF
Write(Byte[]) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Write Method : Write(Byte[]) Method

buffer
Byte array of data to send.
Sends data to the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal buffer() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte

instance.Write(buffer)
C#
public void Write(
   byte[] buffer
)
Managed Extensions for C++
public: void Write(
   byte[]* buffer
)
C++/CLI
public:
void Write(
   array<byte>^ buffer
)

Parameters

buffer
Byte array of data to send.

Remarks

This method synchronously sends data to the remote host over an existing connection. It will block until a buffer is available to accept the data or the SendTimeout value has expired.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Write(String) Method

[image]
PowerTCP Telnet for .NET CF
Write(String) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Write Method : Write(String) Method

data
String of data to send.
Sends data to the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim data As String

instance.Write(data)
C#
public void Write(
   string data
)
Managed Extensions for C++
public: void Write(
   string* data
)
C++/CLI
public:
void Write(
   String^ data
)

Parameters

data
String of data to send.

Remarks

This method synchronously sends data to the remote host over an existing connection. It will block until a buffer is available to accept the data or the SendTimeout value has expired.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Write(Byte[],Int32,Int32) Method

[image]
PowerTCP Telnet for .NET CF
Write(Byte[],Int32,Int32) Method
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class > Write Method : Write(Byte[],Int32,Int32) Method

buffer
Byte array of data to send.
offset
The position in the data buffer at which to begin sending data.
count
The number of bytes to send.
Sends data to the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public void Write(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Byte array of data to send.
offset
The position in the data buffer at which to begin sending data.
count
The number of bytes to send.

Remarks

This method synchronously sends data to the remote host over an existing connection. It will block until a buffer is available to accept the data or the SendTimeout value has expired.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


TcpBase Class Properties

[image]
PowerTCP Telnet for .NET CF
TcpBase Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : TcpBase Class

"

For a list of all members of this type, see TcpBase members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised.
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called.
public Property | Proxy | Gets the proxy server information used by the component.
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy).
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase.
public Property | State | Gets the status of the connection.
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TcpBase Class
Dart.Common Namespace


EnableLogEvent Property

[image]
PowerTCP Telnet for .NET CF
EnableLogEvent Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : EnableLogEvent Property

Gets or sets a value indicating whether the TcpBase.Log event should be raised.

Syntax

Visual Basic (Declaration)
Public Property EnableLogEvent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Boolean

instance.EnableLogEvent = value

value = instance.EnableLogEvent
C#
public bool EnableLogEvent {get; set;}
Managed Extensions for C++
public: __property bool get_EnableLogEvent();
public: __property void set_EnableLogEvent(
   bool value
);
C++/CLI
public:
property bool EnableLogEvent {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


NetworkStream Property

[image]
PowerTCP Telnet for .NET CF
NetworkStream Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : NetworkStream Property

Returns the NetworkStream object created when Connect() is called.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkStream As NetworkStream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As NetworkStream

value = instance.NetworkStream
C#
public NetworkStream NetworkStream {get;}
Managed Extensions for C++
public: __property NetworkStream* get_NetworkStream();
C++/CLI
public:
property NetworkStream^ NetworkStream {
   NetworkStream^ get();
}

Remarks

Returns null when no TCP connection exists.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Proxy Property

[image]
PowerTCP Telnet for .NET CF
Proxy Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Proxy Property

Gets the proxy server information used by the component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proxy As Proxy
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Proxy

value = instance.Proxy
C#
public Proxy Proxy {get;}
Managed Extensions for C++
public: __property Proxy* get_Proxy();
C++/CLI
public:
property Proxy^ Proxy {
   Proxy^ get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


RemoteEndPoint Property

[image]
PowerTCP Telnet for .NET CF
RemoteEndPoint Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : RemoteEndPoint Property

Gets the remote address and port of the server (never the proxy).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As IPEndPoint

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
}

Property Value

The IPEndPoint of the remote host. Returns null if the State is ConnectionState.Closed.

Example

This example demonstrates using the component State to update the UI.
C# Copy Code
private void myComponent_StateChanged(object sender, EventArgs e)
{
    //Always raised when connection is established or closed (State property changes)
    switch (myComponent.State)
    {
        case Dart.Common.ConnectionState.Connected:
        case Dart.Common.ConnectionState.ConnectedAndSecure:
            //Update interface to indicate connection
            textDisplay.ReadOnly = false;
            textDisplay.BackColor = Color.WhiteSmoke;
            Text = (myComponent.State == Dart.Common.ConnectionState.Connected)
                ? APP_NAME + "  [Connected to " + myComponent.RemoteEndPoint.Address.ToString() + ":" +
                    myComponent.RemoteEndPoint.Port.ToString() + "]"
                : APP_NAME + "  [Securely Connected to " + myComponent.RemoteEndPoint.Address.ToString() + ":" +
                    myComponent.RemoteEndPoint.Port.ToString() + "]";
            break;

        case Dart.Common.ConnectionState.Closed:
            //Update interface to indicate no connection
            textDisplay.ReadOnly = true;
            textDisplay.BackColor = Color.Silver;
            this.Text = APP_NAME + "  [Not Connected]";
            break;
    }
}
C# Copy Code
Private Sub myComponent_StateChanged(ByVal sender As Object, ByVal e As EventArgs) Handles myComponent.StateChanged
    'Always raised when Connection is established or closed (State property changes)
    Select Case myComponent.State
        Case Dart.Common.ConnectionState.Connected, Dart.Common.ConnectionState.ConnectedAndSecure
            'Update interface to indicate connection
            textDisplay.ReadOnly = False
            textDisplay.BackColor = Color.WhiteSmoke
            If (myComponent.State = Dart.Common.ConnectionState.Connected) Then
                Text = APP_NAME & "  [Connected to " & myComponent.RemoteEndPoint.Address.ToString() _
                    & ":" & myComponent.RemoteEndPoint.Port.ToString() & "]"
            Else
                Text = APP_NAME & "  [Securely Connected to " & myComponent.RemoteEndPoint.Address.ToString() _
                    & ":" & myComponent.RemoteEndPoint.Port.ToString() & "]"
            End If

        Case Dart.Common.ConnectionState.Closed
            'Update interface to indicate no connection
            textDisplay.ReadOnly = True
            textDisplay.BackColor = Color.Silver
            Me.Text = APP_NAME & "  [Not Connected]"
    End Select
End Sub

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


SocketOption Property

[image]
PowerTCP Telnet for .NET CF
SocketOption Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : SocketOption Property

Gets the socket options for classes derived from TcpBase.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SocketOption As TcpSocketOption
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As TcpSocketOption

value = instance.SocketOption
C#
public TcpSocketOption SocketOption {get;}
Managed Extensions for C++
public: __property TcpSocketOption* get_SocketOption();
C++/CLI
public:
property TcpSocketOption^ SocketOption {
   TcpSocketOption^ get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


State Property

[image]
PowerTCP Telnet for .NET CF
State Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : State Property

Gets the status of the connection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As ConnectionState

value = instance.State
C#
public ConnectionState State {get;}
Managed Extensions for C++
public: __property ConnectionState get_State();
C++/CLI
public:
property ConnectionState State {
   ConnectionState get();
}

Example

This example demonstrates using the component State to update the UI.
C# Copy Code
private void myComponent_StateChanged(object sender, EventArgs e)
{
    //Always raised when connection is established or closed (State property changes)
    switch (myComponent.State)
    {
        case Dart.Common.ConnectionState.Connected:
        case Dart.Common.ConnectionState.ConnectedAndSecure:
            //Update interface to indicate connection
            textDisplay.ReadOnly = false;
            textDisplay.BackColor = Color.WhiteSmoke;
            Text = (myComponent.State == Dart.Common.ConnectionState.Connected)
                ? APP_NAME + "  [Connected to " + myComponent.RemoteEndPoint.Address.ToString() + ":" +
                    myComponent.RemoteEndPoint.Port.ToString() + "]"
                : APP_NAME + "  [Securely Connected to " + myComponent.RemoteEndPoint.Address.ToString() + ":" +
                    myComponent.RemoteEndPoint.Port.ToString() + "]";
            break;

        case Dart.Common.ConnectionState.Closed:
            //Update interface to indicate no connection
            textDisplay.ReadOnly = true;
            textDisplay.BackColor = Color.Silver;
            this.Text = APP_NAME + "  [Not Connected]";
            break;
    }
}
C# Copy Code
Private Sub myComponent_StateChanged(ByVal sender As Object, ByVal e As EventArgs) Handles myComponent.StateChanged
    'Always raised when Connection is established or closed (State property changes)
    Select Case myComponent.State
        Case Dart.Common.ConnectionState.Connected, Dart.Common.ConnectionState.ConnectedAndSecure
            'Update interface to indicate connection
            textDisplay.ReadOnly = False
            textDisplay.BackColor = Color.WhiteSmoke
            If (myComponent.State = Dart.Common.ConnectionState.Connected) Then
                Text = APP_NAME & "  [Connected to " & myComponent.RemoteEndPoint.Address.ToString() _
                    & ":" & myComponent.RemoteEndPoint.Port.ToString() & "]"
            Else
                Text = APP_NAME & "  [Securely Connected to " & myComponent.RemoteEndPoint.Address.ToString() _
                    & ":" & myComponent.RemoteEndPoint.Port.ToString() & "]"
            End If

        Case Dart.Common.ConnectionState.Closed
            'Update interface to indicate no connection
            textDisplay.ReadOnly = True
            textDisplay.BackColor = Color.Silver
            Me.Text = APP_NAME & "  [Not Connected]"
    End Select
End Sub

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


TcpBase Class Events

[image]
PowerTCP Telnet for .NET CF
TcpBase Class Events
See Also Send comments on this topic.
Dart.Common Namespace : TcpBase Class

"

For a list of all members of this type, see TcpBase members.

"

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user.
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data.
public Event | StateChanged | Raised when the value of the State property changes.
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Common Namespace


Data Event

[image]
PowerTCP Telnet for .NET CF
Data Event
See Also Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Data Event

Raised when the Marshal method is called by the user.

Syntax

Visual Basic (Declaration)
Public Event Data As DataEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As DataEventHandler

AddHandler instance.Data, handler
C#
public event DataEventHandler Data
Managed Extensions for C++
public: __event DataEventHandler* Data
C++/CLI
public:
event DataEventHandler^ Data

Remarks

This event is always raised on the UI thread so that data can be used with UI components.

See SynchronizingObject for important information on updating UI controls from within this event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


Log Event

[image]
PowerTCP Telnet for .NET CF
Log Event
See Also Example Send comments on this topic.
Dart.Common Namespace > TcpBase Class : Log Event

Used to capture protocol data.

Syntax

Visual Basic (Declaration)
Public Event Log As LogEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As LogEventHandler

AddHandler instance.Log, handler
C#
public event LogEventHandler Log
Managed Extensions for C++
public: __event LogEventHandler* Log
C++/CLI
public:
event LogEventHandler^ Log

Example

This example demonstrates logging sent and received data to a file on disk.
C# Copy Code
logFile =
    new FileStream(Path.GetDirectoryName(Assembly.GetExecutingAssembly().GetName().CodeBase) +
        "\\logFile.txt", FileMode.Append, FileAccess.Write);
}

private void myComponent_Log(object sender, LogEventArgs e)
{
    string prompt = (e.Data.Direction == DataDirection.In) ? "Recv: " : "Sent: ";
    logFile.Write(System.Text.Encoding.Default.GetBytes(prompt), 0,prompt.Length);
    logFile.Write(e.Data.Buffer, e.Data.Offset, e.Data.Count);
    logFile.Write(System.Text.Encoding.Default.GetBytes("\r\n"), 0, 2);
}
Visual Basic Copy Code
Dim logFile As New FileStream(Path.GetDirectoryName(Assembly.GetExecutingAssembly().GetName().CodeBase) + _
    "\logFile.txt", FileMode.Append, FileAccess.Write)

Private Sub myComponent_Log(ByVal sender As Object, ByVal e As LoggingEventArgs) Handles myComponent.Log
    Dim prompt As String = ""
    If e.DataDirection = DataDirection.In) Then
        prompt = "Recv: "
    Else
        prompt = "Sent: "
    End If
    logFile.Write(System.Text.Encoding.Default.GetBytes(prompt), 0, prompt.Length)
    logFile.Write(e.Data.Buffer, e.Data.Offset, e.Data.Count)
    logFile.Write(System.Text.Encoding.Default.GetBytes(vbCrLf), 0, 2)
End Sub

Remarks

The handler must be added before connecting. Set EnableLogEvent to turn logging on and off.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


StateChanged Event

[image]
PowerTCP Telnet for .NET CF
StateChanged Event
See Also Example Send comments on this topic.
Dart.Common Namespace > TcpBase Class : StateChanged Event

Raised when the value of the State property changes.

Syntax

Visual Basic (Declaration)
Public Event StateChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler

AddHandler instance.StateChanged, handler
C#
public event EventHandler StateChanged
Managed Extensions for C++
public: __event EventHandler* StateChanged
C++/CLI
public:
event EventHandler^ StateChanged

Example

This example demonstrates using the component State to update the UI.
C# Copy Code
private void myComponent_StateChanged(object sender, EventArgs e)
{
    //Always raised when connection is established or closed (State property changes)
    switch (myComponent.State)
    {
        case Dart.Common.ConnectionState.Connected:
        case Dart.Common.ConnectionState.ConnectedAndSecure:
            //Update interface to indicate connection
            textDisplay.ReadOnly = false;
            textDisplay.BackColor = Color.WhiteSmoke;
            Text = (myComponent.State == Dart.Common.ConnectionState.Connected)
                ? APP_NAME + "  [Connected to " + myComponent.RemoteEndPoint.Address.ToString() + ":" +
                    myComponent.RemoteEndPoint.Port.ToString() + "]"
                : APP_NAME + "  [Securely Connected to " + myComponent.RemoteEndPoint.Address.ToString() + ":" +
                    myComponent.RemoteEndPoint.Port.ToString() + "]";
            break;

        case Dart.Common.ConnectionState.Closed:
            //Update interface to indicate no connection
            textDisplay.ReadOnly = true;
            textDisplay.BackColor = Color.Silver;
            this.Text = APP_NAME + "  [Not Connected]";
            break;
    }
}
C# Copy Code
Private Sub myComponent_StateChanged(ByVal sender As Object, ByVal e As EventArgs) Handles myComponent.StateChanged
    'Always raised when Connection is established or closed (State property changes)
    Select Case myComponent.State
        Case Dart.Common.ConnectionState.Connected, Dart.Common.ConnectionState.ConnectedAndSecure
            'Update interface to indicate connection
            textDisplay.ReadOnly = False
            textDisplay.BackColor = Color.WhiteSmoke
            If (myComponent.State = Dart.Common.ConnectionState.Connected) Then
                Text = APP_NAME & "  [Connected to " & myComponent.RemoteEndPoint.Address.ToString() _
                    & ":" & myComponent.RemoteEndPoint.Port.ToString() & "]"
            Else
                Text = APP_NAME & "  [Securely Connected to " & myComponent.RemoteEndPoint.Address.ToString() _
                    & ":" & myComponent.RemoteEndPoint.Port.ToString() & "]"
            End If

        Case Dart.Common.ConnectionState.Closed
            'Update interface to indicate no connection
            textDisplay.ReadOnly = True
            textDisplay.BackColor = Color.Silver
            Me.Text = APP_NAME & "  [Not Connected]"
    End Select
End Sub

Remarks

This method is raised on the UI thread if the SynchronizingObject is set. Otherwise this event is raised on a worker thread.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpBase Class
TcpBase Members


TcpSocketOption Class

[image]
PowerTCP Telnet for .NET CF
TcpSocketOption Class
Members See Also Send comments on this topic.
Dart.Common Namespace : TcpSocketOption Class

Contains socket options that may be set by TCP sockets.

Object Model

TcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class TcpSocketOption
   Inherits SocketOption
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
C#
public class TcpSocketOption : SocketOption
Managed Extensions for C++
public __gc class TcpSocketOption : public SocketOption
C++/CLI
public ref class TcpSocketOption : public SocketOption

Inheritance Hierarchy

System.Object
Dart.Common.SocketOption
Dart.Common.TcpSocketOption

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpSocketOption Members
Dart.Common Namespace


TcpSocketOption Class Members

[image]
PowerTCP Telnet for .NET CF
TcpSocketOption Class Members
See Also Fields Properties Send comments on this topic.
Dart.Common Namespace : TcpSocketOption Class

The following tables list the members exposed by TcpSocketOption.

Public Fields

 | Name | Description
public Field | LocalEndPoint | Gets or sets the desired local IPEndPoint (address and port) the socket should be bound to. (Inherited from Dart.Common.SocketOption)
Top

Public Properties

 | Name | Description
public Property | ExclusiveAddressUse | Gets or Sets a value that restricts the use of local ports to only one socket each.
public Property | LocalPortRange | Gets or sets the port range desired. (Inherited from Dart.Common.SocketOption)
public Property | NoDelay | Gets or sets a value that disables the use of Nagle's algorithm so that data is sent immediately.
public Property | OutOfBandInline | Gets or sets a value that indicates whether out-of-band (urgent) data is read as normal in-line data.
public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer. (Inherited from Dart.Common.SocketOption)
public Property | ReceiveTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Receive call will time out. (Inherited from Dart.Common.SocketOption)
public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer. (Inherited from Dart.Common.SocketOption)
public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out. (Inherited from Dart.Common.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Common Namespace


TcpSocketOption Class Properties

[image]
PowerTCP Telnet for .NET CF
TcpSocketOption Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : TcpSocketOption Class

"

For a list of all members of this type, see TcpSocketOption members.

"

Public Properties

 | Name | Description
public Property | ExclusiveAddressUse | Gets or Sets a value that restricts the use of local ports to only one socket each.
public Property | LocalPortRange | Gets or sets the port range desired. (Inherited from Dart.Common.SocketOption)
public Property | NoDelay | Gets or sets a value that disables the use of Nagle's algorithm so that data is sent immediately.
public Property | OutOfBandInline | Gets or sets a value that indicates whether out-of-band (urgent) data is read as normal in-line data.
public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer. (Inherited from Dart.Common.SocketOption)
public Property | ReceiveTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Receive call will time out. (Inherited from Dart.Common.SocketOption)
public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer. (Inherited from Dart.Common.SocketOption)
public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out. (Inherited from Dart.Common.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Common Namespace


ExclusiveAddressUse Property

[image]
PowerTCP Telnet for .NET CF
ExclusiveAddressUse Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpSocketOption Class : ExclusiveAddressUse Property

Gets or Sets a value that restricts the use of local ports to only one socket each.

Syntax

Visual Basic (Declaration)
Public Property ExclusiveAddressUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.ExclusiveAddressUse = value

value = instance.ExclusiveAddressUse
C#
public bool ExclusiveAddressUse {get; set;}
Managed Extensions for C++
public: __property bool get_ExclusiveAddressUse();
public: __property void set_ExclusiveAddressUse(
   bool value
);
C++/CLI
public:
property bool ExclusiveAddressUse {
   bool get();
   void set (    bool value);
}

Property Value

Set to true if a specific local port number is desired for multiple active connections; otherwise false. The default is false.

Remarks

Set this option if a specific local port number is desired for multiple active connections.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


NoDelay Property

[image]
PowerTCP Telnet for .NET CF
NoDelay Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpSocketOption Class : NoDelay Property

Gets or sets a value that disables the use of Nagle's algorithm so that data is sent immediately.

Syntax

Visual Basic (Declaration)
Public Property NoDelay As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.NoDelay = value

value = instance.NoDelay
C#
public bool NoDelay {get; set;}
Managed Extensions for C++
public: __property bool get_NoDelay();
public: __property void set_NoDelay(
   bool value
);
C++/CLI
public:
property bool NoDelay {
   bool get();
   void set (    bool value);
}

Property Value

False if Nagle's algorithm is used; otherwise true. The default value is false.

Remarks

When small pieces of data (such as single bytes) are send many times consecutively, inefficient packets can be sent with one byte of useful data and 40 bytes of header information. Nagle's algorithm specifies that this type of data should be automatically concatenated and sent in a single packet. When true, Nagle's algorithm is defeated and data is immediately sent in a dedicated packet. When false, Nagle's algorithm is used and consecutive Socket Send calls might send data in a single (more efficient) packet.

Setting this property to true may result in a speed optimization (because packets are sent immediately, without having to wait to see if Send is called again). Setting this property to false results in data being transmitted more efficiently.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


OutOfBandInline Property

[image]
PowerTCP Telnet for .NET CF
OutOfBandInline Property
See Also Send comments on this topic.
Dart.Common Namespace > TcpSocketOption Class : OutOfBandInline Property

Gets or sets a value that indicates whether out-of-band (urgent) data is read as normal in-line data.

Syntax

Visual Basic (Declaration)
Public Property OutOfBandInline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.OutOfBandInline = value

value = instance.OutOfBandInline
C#
public bool OutOfBandInline {get; set;}
Managed Extensions for C++
public: __property bool get_OutOfBandInline();
public: __property void set_OutOfBandInline(
   bool value
);
C++/CLI
public:
property bool OutOfBandInline {
   bool get();
   void set (    bool value);
}

Property Value

True if urgent data is to be read as normal in-line data, otherwise false. The default value is false.

Remarks

When the "urgent" socket flag is set, the packet contains data that should be acted upon before "non-urgent" data. Setting this property to true will cause this urgent data to be read in-line. To minimize interoperability problems, developers are advised not to use out-of-band data unless it is required to interoperate with an existing service.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


UserStateEventArgs Class

[image]
PowerTCP Telnet for .NET CF
UserStateEventArgs Class
Members See Also Send comments on this topic.
Dart.Common Namespace : UserStateEventArgs Class

Provides data for the UserState event.

Object Model

UserStateEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UserStateEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
C#
public class UserStateEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class UserStateEventArgs : public System.EventArgs
C++/CLI
public ref class UserStateEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Common.UserStateEventArgs
Dart.Common.DataEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Members
Dart.Common Namespace


UserStateEventArgs Class Members

[image]
PowerTCP Telnet for .NET CF
UserStateEventArgs Class Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : UserStateEventArgs Class

The following tables list the members exposed by UserStateEventArgs.

Public Constructors

 | Name | Description
public Constructor | UserStateEventArgs Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | UserState | Gets the user information provided by the UserState event.
Top

See Also

Reference

UserStateEventArgs Class
Dart.Common Namespace


UserStateEventArgs Constructor

[image]
PowerTCP Telnet for .NET CF
UserStateEventArgs Constructor
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class : UserStateEventArgs Constructor

Overload List

Overload | Description
UserStateEventArgs Constructor() | Default constructor.
UserStateEventArgs Constructor(Object) | Initializes a new instance of the UserStateEventArgs class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


UserStateEventArgs Constructor()

[image]
PowerTCP Telnet for .NET CF
UserStateEventArgs Constructor()
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class > UserStateEventArgs Constructor : UserStateEventArgs Constructor()

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UserStateEventArgs()
C#
public UserStateEventArgs()
Managed Extensions for C++
public: UserStateEventArgs();
C++/CLI
public:
UserStateEventArgs();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members
Overload List


UserStateEventArgs Constructor(Object)

[image]
PowerTCP Telnet for .NET CF
UserStateEventArgs Constructor(Object)
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class > UserStateEventArgs Constructor : UserStateEventArgs Constructor(Object)

state
Initializes a new instance of the UserStateEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim state As Object

Dim instance As New UserStateEventArgs(state)
C#
public UserStateEventArgs(
   object state
)
Managed Extensions for C++
public: UserStateEventArgs(
   Object* state
)
C++/CLI
public:
UserStateEventArgs(
   Object^ state
)

Parameters

state

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members
Overload List


UserStateEventArgs Class Fields

[image]
PowerTCP Telnet for .NET CF
UserStateEventArgs Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : UserStateEventArgs Class

"

For a list of all members of this type, see UserStateEventArgs members.

"

Public Fields

 | Name | Description
public Field | UserState | Gets the user information provided by the UserState event.
Top

See Also

Reference

UserStateEventArgs Class
Dart.Common Namespace


UserState Field

[image]
PowerTCP Telnet for .NET CF
UserState Field
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class : UserState Field

Gets the user information provided by the UserState event.

Syntax

Visual Basic (Declaration)
Public ReadOnly UserState As Object
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
Dim value As Object

value = instance.UserState
C#
public readonly object UserState
Managed Extensions for C++
public: readonly Object* UserState
C++/CLI
public:
readonly Object^ UserState

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


X509CertificateCollection Class

[image]
PowerTCP Telnet for .NET CF
X509CertificateCollection Class
Members See Also Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

A generic list of X509Certificate objects.

Object Model

X509CertificateCollection ClassX509Certificate Class

Syntax

Visual Basic (Declaration)
Public Class X509CertificateCollection
   Inherits System.Collections.Generic.List(Of X509Certificate)
Visual Basic (Usage) Copy Code
Dim instance As X509CertificateCollection
C#
public class X509CertificateCollection : System.Collections.Generic.List<X509Certificate>
Managed Extensions for C++
public __gc class X509CertificateCollection : public System.Collections.Generic.List<X509Certificate>
C++/CLI
public ref class X509CertificateCollection : public System.Collections.Generic.List<X509Certificate>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
Dart.Common.X509CertificateCollection

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509CertificateCollection Members
Dart.Common Namespace


X509CertificateCollection Class Members

[image]
PowerTCP Telnet for .NET CF
X509CertificateCollection Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

The following tables list the members exposed by X509CertificateCollection.

Public Constructors

 | Name | Description
public Constructor | X509CertificateCollection Constructor |
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Count | Gets the number of elements actually contained in the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

See Also

Reference

X509CertificateCollection Class
Dart.Common Namespace


X509CertificateCollection Constructor

[image]
PowerTCP Telnet for .NET CF
X509CertificateCollection Constructor
See Also Send comments on this topic.
Dart.Common Namespace > X509CertificateCollection Class : X509CertificateCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New X509CertificateCollection()
C#
public X509CertificateCollection()
Managed Extensions for C++
public: X509CertificateCollection();
C++/CLI
public:
X509CertificateCollection();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509CertificateCollection Class
X509CertificateCollection Members


X509Chain Class

[image]
PowerTCP Telnet for .NET CF
X509Chain Class
Members See Also Send comments on this topic.
Dart.Common Namespace : X509Chain Class

Represents a chain-building engine for X509Certificate certificates. Not implemented.

Object Model

X509Chain Class

Syntax

Visual Basic (Declaration)
Public Class X509Chain
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
C#
public class X509Chain
Managed Extensions for C++
public __gc class X509Chain
C++/CLI
public ref class X509Chain

Inheritance Hierarchy

System.Object
Dart.Common.X509Chain

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Members
Dart.Common Namespace


X509Chain Class Members

[image]
PowerTCP Telnet for .NET CF
X509Chain Class Members
See Also Fields Methods Send comments on this topic.
Dart.Common Namespace : X509Chain Class

The following tables list the members exposed by X509Chain.

Public Constructors

 | Name | Description
public Constructor | X509Chain Constructor |
Top

Public Fields

 | Name | Description
public Field | ChainPolicy | Gets or sets the X509ChainPolicy to use when building an X.509 certificate chain.
public Field | ChainStatus | Gets the status of each element in an X509Chain object.
Top

Public Methods

 | Name | Description
public Method | Build | Builds an X.509 chain using the policy specified in X509ChainPolicy.
Top

See Also

Reference

X509Chain Class
Dart.Common Namespace


X509Chain Constructor

[image]
PowerTCP Telnet for .NET CF
X509Chain Constructor
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : X509Chain Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New X509Chain()
C#
public X509Chain()
Managed Extensions for C++
public: X509Chain();
C++/CLI
public:
X509Chain();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


X509Chain Class Methods

[image]
PowerTCP Telnet for .NET CF
X509Chain Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : X509Chain Class

"

For a list of all members of this type, see X509Chain members.

"

Public Methods

 | Name | Description
public Method | Build | Builds an X.509 chain using the policy specified in X509ChainPolicy.
Top

See Also

Reference

X509Chain Class
Dart.Common Namespace


Build Method

[image]
PowerTCP Telnet for .NET CF
Build Method
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : Build Method

certificate
Builds an X.509 chain using the policy specified in X509ChainPolicy.

Syntax

Visual Basic (Declaration)
Public Function Build( _
   ByVal certificate As X509Certificate _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
Dim certificate As X509Certificate
Dim value As Boolean

value = instance.Build(certificate)
C#
public bool Build(
   X509Certificate certificate
)
Managed Extensions for C++
public: bool Build(
   X509Certificate* certificate
)
C++/CLI
public:
bool Build(
   X509Certificate^ certificate
)

Parameters

certificate

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


X509Chain Class Fields

[image]
PowerTCP Telnet for .NET CF
X509Chain Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : X509Chain Class

"

For a list of all members of this type, see X509Chain members.

"

Public Fields

 | Name | Description
public Field | ChainPolicy | Gets or sets the X509ChainPolicy to use when building an X.509 certificate chain.
public Field | ChainStatus | Gets the status of each element in an X509Chain object.
Top

See Also

Reference

X509Chain Class
Dart.Common Namespace


ChainPolicy Field

[image]
PowerTCP Telnet for .NET CF
ChainPolicy Field
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : ChainPolicy Field

Gets or sets the X509ChainPolicy to use when building an X.509 certificate chain.

Syntax

Visual Basic (Declaration)
Public ChainPolicy As X509ChainPolicy
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
Dim value As X509ChainPolicy

value = instance.ChainPolicy

instance.ChainPolicy = value
C#
public X509ChainPolicy ChainPolicy
Managed Extensions for C++
public: X509ChainPolicy* ChainPolicy
C++/CLI
public:
X509ChainPolicy^ ChainPolicy

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


ChainStatus Field

[image]
PowerTCP Telnet for .NET CF
ChainStatus Field
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : ChainStatus Field

Gets the status of each element in an X509Chain object.

Syntax

Visual Basic (Declaration)
Public ChainStatus As X509ChainStatus()
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
Dim value() As X509ChainStatus

value = instance.ChainStatus

instance.ChainStatus = value
C#
public X509ChainStatus[] ChainStatus
Managed Extensions for C++
public: X509ChainStatus[]* ChainStatus
C++/CLI
public:
array<X509ChainStatus>^ ChainStatus

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


X509ChainPolicy Class

[image]
PowerTCP Telnet for .NET CF
X509ChainPolicy Class
Members See Also Send comments on this topic.
Dart.Common Namespace : X509ChainPolicy Class

Represents the chain policy to be applied when building an X509 certificate chain. This class cannot be inherited.

Object Model

X509ChainPolicy Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class X509ChainPolicy
Visual Basic (Usage) Copy Code
Dim instance As X509ChainPolicy
C#
public sealed class X509ChainPolicy
Managed Extensions for C++
public __gc __sealed class X509ChainPolicy
C++/CLI
public ref class X509ChainPolicy sealed

Inheritance Hierarchy

System.Object
Dart.Common.X509ChainPolicy

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Members
Dart.Common Namespace


X509ChainPolicy Class Members

[image]
PowerTCP Telnet for .NET CF
X509ChainPolicy Class Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : X509ChainPolicy Class

The following tables list the members exposed by X509ChainPolicy.

Public Constructors

 | Name | Description
public Constructor | X509ChainPolicy Constructor |
Top

Public Fields

 | Name | Description
public Field | RevocationFlag | Gets or sets values for X509 revocation flags.
public Field | RevocationMode | Gets or sets values for X509 certificate revocation mode.
Top

See Also

Reference

X509ChainPolicy Class
Dart.Common Namespace


X509ChainPolicy Constructor

[image]
PowerTCP Telnet for .NET CF
X509ChainPolicy Constructor
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainPolicy Class : X509ChainPolicy Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New X509ChainPolicy()
C#
public X509ChainPolicy()
Managed Extensions for C++
public: X509ChainPolicy();
C++/CLI
public:
X509ChainPolicy();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Class
X509ChainPolicy Members


X509ChainPolicy Class Fields

[image]
PowerTCP Telnet for .NET CF
X509ChainPolicy Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : X509ChainPolicy Class

"

For a list of all members of this type, see X509ChainPolicy members.

"

Public Fields

 | Name | Description
public Field | RevocationFlag | Gets or sets values for X509 revocation flags.
public Field | RevocationMode | Gets or sets values for X509 certificate revocation mode.
Top

See Also

Reference

X509ChainPolicy Class
Dart.Common Namespace


RevocationFlag Field

[image]
PowerTCP Telnet for .NET CF
RevocationFlag Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainPolicy Class : RevocationFlag Field

Gets or sets values for X509 revocation flags.

Syntax

Visual Basic (Declaration)
Public RevocationFlag As X509RevocationFlag
Visual Basic (Usage) Copy Code
Dim instance As X509ChainPolicy
Dim value As X509RevocationFlag

value = instance.RevocationFlag

instance.RevocationFlag = value
C#
public X509RevocationFlag RevocationFlag
Managed Extensions for C++
public: X509RevocationFlag RevocationFlag
C++/CLI
public:
X509RevocationFlag RevocationFlag

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Class
X509ChainPolicy Members


RevocationMode Field

[image]
PowerTCP Telnet for .NET CF
RevocationMode Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainPolicy Class : RevocationMode Field

Gets or sets values for X509 certificate revocation mode.

Syntax

Visual Basic (Declaration)
Public RevocationMode As X509RevocationMode
Visual Basic (Usage) Copy Code
Dim instance As X509ChainPolicy
Dim value As X509RevocationMode

value = instance.RevocationMode

instance.RevocationMode = value
C#
public X509RevocationMode RevocationMode
Managed Extensions for C++
public: X509RevocationMode RevocationMode
C++/CLI
public:
X509RevocationMode RevocationMode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Class
X509ChainPolicy Members


CipherAlgorithmType Enumeration

[image]
PowerTCP Telnet for .NET CF
CipherAlgorithmType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : CipherAlgorithmType Enumeration

Defines the possible cipher algorithms for the SslStream class.

Syntax

Visual Basic (Declaration)
Public Enum CipherAlgorithmType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CipherAlgorithmType
C#
public enum CipherAlgorithmType : System.Enum
Managed Extensions for C++
__value public enum CipherAlgorithmType : public System.Enum
C++/CLI
public enum class CipherAlgorithmType : public System.Enum

Members

Member | Description
Aes | The Advanced Encryption Standard (AES) algorithm.
Aes128 | The Advanced Encryption Standard (AES) algorithm with a 128 bit key.
Aes192 | The Advanced Encryption Standard (AES) algorithm with a 192 bit key.
Aes256 | The Advanced Encryption Standard (AES) algorithm with a 256 bit key.
Des | The Data Encryption Standard (DES) algorithm.
None | No encryption algorithm is used.
Rc2 | Rivest's Code 2 (RC2) algorithm.
Rc4 | Rivest's Code 4 (RC4) algorithm.
TripleDes | The Triple Data Encryption Standard (3DES) algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.CipherAlgorithmType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


ConnectionState Enumeration

[image]
PowerTCP Telnet for .NET CF
ConnectionState Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : ConnectionState Enumeration

Defines the possible states of the connection.

Syntax

Visual Basic (Declaration)
Public Enum ConnectionState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ConnectionState
C#
public enum ConnectionState : System.Enum
Managed Extensions for C++
__value public enum ConnectionState : public System.Enum
C++/CLI
public enum class ConnectionState : public System.Enum

Members

Member | Description
Closed | The connection is closed.
Connected | The TCP connection is established but not secure.
ConnectedAndSecure | The connection is connected and secure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.ConnectionState

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


DataDirection Enumeration

[image]
PowerTCP Telnet for .NET CF
DataDirection Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : DataDirection Enumeration

Enumerates the directions data travels.

Syntax

Visual Basic (Declaration)
Public Enum DataDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DataDirection
C#
public enum DataDirection : System.Enum
Managed Extensions for C++
__value public enum DataDirection : public System.Enum
C++/CLI
public enum class DataDirection : public System.Enum

Members

Member | Description
In | Data was received (using the Read method).
Out | Data was sent (using the Write method).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.DataDirection

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


ExchangeAlgorithmType Enumeration

[image]
PowerTCP Telnet for .NET CF
ExchangeAlgorithmType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : ExchangeAlgorithmType Enumeration

Specifies the algorithm used to create keys shared by the client and server.

Syntax

Visual Basic (Declaration)
Public Enum ExchangeAlgorithmType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ExchangeAlgorithmType
C#
public enum ExchangeAlgorithmType : System.Enum
Managed Extensions for C++
__value public enum ExchangeAlgorithmType : public System.Enum
C++/CLI
public enum class ExchangeAlgorithmType : public System.Enum

Members

Member | Description
DiffieHellman | The Diffie Hellman ephemeral key exchange algorithm.
None | No key exchange algorithm is used.
RsaKeyX | The RSA public-key exchange algorithm.
RsaSign | The RSA public-key signature algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.ExchangeAlgorithmType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


HashAlgorithmType Enumeration

[image]
PowerTCP Telnet for .NET CF
HashAlgorithmType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : HashAlgorithmType Enumeration

Specifies the algorithm used for generating message authentication codes (MACs).

Syntax

Visual Basic (Declaration)
Public Enum HashAlgorithmType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HashAlgorithmType
C#
public enum HashAlgorithmType : System.Enum
Managed Extensions for C++
__value public enum HashAlgorithmType : public System.Enum
C++/CLI
public enum class HashAlgorithmType : public System.Enum

Members

Member | Description
Md5 | The Message Digest 5 (MD5) hashing algorithm.
None | No hashing algorithm is used.
Sha1 | The Secure Hashing Algorithm (SHA1).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.HashAlgorithmType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


ProxyType Enumeration

[image]
PowerTCP Telnet for .NET CF
ProxyType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : ProxyType Enumeration

Enumerates the supported proxy types.

Syntax

Visual Basic (Declaration)
Public Enum ProxyType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ProxyType
C#
public enum ProxyType : System.Enum
Managed Extensions for C++
__value public enum ProxyType : public System.Enum
C++/CLI
public enum class ProxyType : public System.Enum

Members

Member | Description
HttpConnect | Http-Connect proxy. The Username and Password properties are used.
None | No proxy server is used.
Socks4 | SOCKS v4 proxy. The Username property is used.
Socks5 | SOCKS v5 proxy. The Username and Password properties are used.

Remarks

This enumeration is used by the Proxy property.

Set the Proxy.Type property to the proper ProxyType of your proxy server before calling any method that requires communication with the server.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.ProxyType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


SslPolicyErrors Enumeration

[image]
PowerTCP Telnet for .NET CF
SslPolicyErrors Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : SslPolicyErrors Enumeration

Enumerates Secure Socket Layer (SSL) policy errors. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum SslPolicyErrors
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SslPolicyErrors
C#
[FlagsAttribute()]
public enum SslPolicyErrors : System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum SslPolicyErrors : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class SslPolicyErrors : public System.Enum

Members

Member | Description
None | No SSL policy errors.
RemoteCertificateChainErrors | ChainStatus has returned a non empty array.
RemoteCertificateNameMismatch | Certificate name mismatch.
RemoteCertificateNotAvailable | Certificate not available.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.SslPolicyErrors

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


SslProtocols Enumeration

[image]
PowerTCP Telnet for .NET CF
SslProtocols Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : SslProtocols Enumeration

Defines the possible values of SslProtocols.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum SslProtocols
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SslProtocols
C#
[FlagsAttribute()]
public enum SslProtocols : System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum SslProtocols : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class SslProtocols : public System.Enum

Members

Member | Description
Default | Specifies that either Secure Sockets Layer (SSL) 3.0 or Transport Layer Security (TLS) 1.0 are acceptable for secure communications.
None | No SSL encryption is to be used.
Ssl2 | Specifies the SSL 2.0 protocol. SSL 2.0 has been superseded by the TLS protocol and is provided for backward compatibility only.
Ssl3 | Specifies the SSL 3.0 protocol. SSL 3.0 has been superseded by the TLS protocol and is provided for backward compatibility only.
Tls | Specifies the TLS 1.0 security protocol. The TLS protocol is defined in IETF RFC 2246.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.SslProtocols

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509ChainStatusFlags Enumeration

[image]
PowerTCP Telnet for .NET CF
X509ChainStatusFlags Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : X509ChainStatusFlags Enumeration

Defines the status of an X509 chain. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum X509ChainStatusFlags
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatusFlags
C#
[FlagsAttribute()]
public enum X509ChainStatusFlags : System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum X509ChainStatusFlags : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class X509ChainStatusFlags : public System.Enum

Members

Member | Description
CtlNotSignatureValid | Specifies that the certificate trust list (CTL) contains an invalid signature.
CtlNotTimeValid | Specifies that the certificate trust list (CTL) is not valid because of an invalid time value, such as one that indicates that the CTL has expired.
CtlNotValidForUsage | Specifies that the certificate trust list (CTL) is not valid for this use.
Cyclic | Specifies that the X509 chain could not be built.
HasExcludedNameConstraint | Specifies that the X509 chain is invalid because a certificate has excluded a name constraint.
HasNotDefinedNameConstraint | Specifies that the certificate has an undefined name constant.
HasNotPermittedNameConstraint | Specifies that the certificate has an impermissible name constraint.
HasNotSupportedNameConstraint | Specifies that the certificate does not have a supported name constant or has a name constant that is unsupported.
InvalidBasicConstraints | Specifies that the X509 chain is invalid due to invalid basic constraints.
InvalidExtension | Specifies that the X509 chain is invalid due to an invalid extension.
InvalidNameConstraints | Specifies that the X509 chain is invalid due to invalid name constraints.
InvalidPolicyConstraints | Specifies that the X509 chain is invalid due to invalid policy constraints.
NoError | Specifies that the X509 chain has no errors.
NoIssuanceChainPolicy | Specifies that there is no certificate policy extension in the certificate. This error would occur if a group policy has specified that all certificates must have a certificate policy.
NotSignatureValid | Specifies that the X509 chain is invalid due to an invalid certificate signature.
NotTimeNested | Specifies that the CA (certificate authority) certificate and the issued certificate have validity periods that are not nested. For example, the CA cert can be valid from January 1 to December 1 and the issued certificate from January 2 to December 2, which would mean the validity periods are not nested.
NotTimeValid | Specifies that the X509 chain is not valid due to an invalid time value, such as a value that indicates an expired certificate.
NotValidForUsage | Specifies that the key usage is not valid.
OfflineRevocation | Specifies that the online certificate revocation list (CRL) the X509 chain relies on is currently offline.
PartialChain | Specifies that the X509 chain could not be built up to the root certificate.
RevocationStatusUnknown | Specifies that it is not possible to determine whether the certificate has been revoked. This can be due to the certificate revocation list (CRL) being offline or unavailable.
Revoked | Specifies that the X509 chain is invalid due to a revoked certificate.
UntrustedRoot | Specifies that the X509 chain is invalid due to an untrusted root certificate.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.X509ChainStatusFlags

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509RevocationFlag Enumeration

[image]
PowerTCP Telnet for .NET CF
X509RevocationFlag Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : X509RevocationFlag Enumeration

Specifies which X509 certificates in the chain should be checked for revocation.

Syntax

Visual Basic (Declaration)
Public Enum X509RevocationFlag
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As X509RevocationFlag
C#
public enum X509RevocationFlag : System.Enum
Managed Extensions for C++
__value public enum X509RevocationFlag : public System.Enum
C++/CLI
public enum class X509RevocationFlag : public System.Enum

Members

Member | Description
EndCertificateOnly | Only the end certificate is checked for revocation.
EntireChain | The entire chain of certificates is checked for revocation.
ExcludeRoot | The entire chain, except the root certificate, is checked for revocation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.X509RevocationFlag

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509RevocationMode Enumeration

[image]
PowerTCP Telnet for .NET CF
X509RevocationMode Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : X509RevocationMode Enumeration

Specifies the mode used to check for X509 certificate revocation.

Syntax

Visual Basic (Declaration)
Public Enum X509RevocationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As X509RevocationMode
C#
public enum X509RevocationMode : System.Enum
Managed Extensions for C++
__value public enum X509RevocationMode : public System.Enum
C++/CLI
public enum class X509RevocationMode : public System.Enum

Members

Member | Description
NoCheck | No revocation check is performed on the certificate.
Offline | A revocation check is made using a cached certificate revocation list (CRL).
Online | A revocation check is made using an online certificate revocation list (CRL).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.X509RevocationMode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509ChainStatus Structure

[image]
PowerTCP Telnet for .NET CF
X509ChainStatus Structure
Members See Also Send comments on this topic.
Dart.Common Namespace : X509ChainStatus Structure

Provides a simple structure for storing X509 chain status and error information.

Object Model

X509ChainStatus Structure

Syntax

Visual Basic (Declaration)
Public Structure X509ChainStatus
   Inherits System.ValueType
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatus
C#
public struct X509ChainStatus : System.ValueType
Managed Extensions for C++
public __value struct X509ChainStatus : public System.ValueType
C++/CLI
public value class X509ChainStatus : public System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Dart.Common.X509ChainStatus

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainStatus Members
Dart.Common Namespace


X509ChainStatus Structure Members

[image]
PowerTCP Telnet for .NET CF
X509ChainStatus Structure Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : X509ChainStatus Structure

"

The following tables list the members exposed by X509ChainStatus.

"

Public Fields

 | Name | Description
public Field | Status | Specifies the status of the X509 chain.
public Field | StatusInformation | Specifies a description of the ChainStatus value.
Top

See Also

Reference

X509ChainStatus Structure
Dart.Common Namespace


X509ChainStatus Structure Fields

[image]
PowerTCP Telnet for .NET CF
X509ChainStatus Structure Fields
See Also Send comments on this topic.
Dart.Common Namespace : X509ChainStatus Structure

"

For a list of all members of this type, see X509ChainStatus members.

"

Public Fields

 | Name | Description
public Field | Status | Specifies the status of the X509 chain.
public Field | StatusInformation | Specifies a description of the ChainStatus value.
Top

See Also

Reference

X509ChainStatus Structure
Dart.Common Namespace


Status Field

[image]
PowerTCP Telnet for .NET CF
Status Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainStatus Structure : Status Field

Specifies the status of the X509 chain.

Syntax

Visual Basic (Declaration)
Public Status As X509ChainStatusFlags
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatus
Dim value As X509ChainStatusFlags

value = instance.Status

instance.Status = value
C#
public X509ChainStatusFlags Status
Managed Extensions for C++
public: X509ChainStatusFlags Status
C++/CLI
public:
X509ChainStatusFlags Status

Remarks

The flag can be used to determine the details of a chain error.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainStatus Structure
X509ChainStatus Members


StatusInformation Field

[image]
PowerTCP Telnet for .NET CF
StatusInformation Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainStatus Structure : StatusInformation Field

Specifies a description of the ChainStatus value.

Syntax

Visual Basic (Declaration)
Public StatusInformation As String
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatus
Dim value As String

value = instance.StatusInformation

instance.StatusInformation = value
C#
public string StatusInformation
Managed Extensions for C++
public: string* StatusInformation
C++/CLI
public:
String^ StatusInformation

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainStatus Structure
X509ChainStatus Members


ComponentErrorEventHandler Delegate

[image]
PowerTCP Telnet for .NET CF
ComponentErrorEventHandler Delegate
See Also Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventHandler Delegate

sender
The source of the event.
e
A ComponentsErrorEventArgs that contains error arguments.
Represents the method that will handle an event raised due to an component error.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ComponentErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As ComponentErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ComponentErrorEventHandler(AddressOf HandlerMethod)
C#
public delegate void ComponentErrorEventHandler(
   object sender,
   ComponentErrorEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ComponentErrorEventHandler(
   Object* sender,
   ComponentErrorEventArgs* e
)
C++/CLI
public delegate void ComponentErrorEventHandler(
   Object^ sender,
   ComponentErrorEventArgs^ e
)

Parameters

sender
The source of the event.
e
A ComponentsErrorEventArgs that contains error arguments.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventHandler Members
Dart.Common Namespace


DataEventHandler Delegate

[image]
PowerTCP Telnet for .NET CF
DataEventHandler Delegate
See Also Send comments on this topic.
Dart.Common Namespace : DataEventHandler Delegate

sender
The source of the event.
e
A DataEventArgs that contains buffered data.
Represents the method that will handle an event raised by the user calling Marshal.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataEventHandler(
   object sender,
   DataEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataEventHandler(
   Object* sender,
   DataEventArgs* e
)
C++/CLI
public delegate void DataEventHandler(
   Object^ sender,
   DataEventArgs^ e
)

Parameters

sender
The source of the event.
e
A DataEventArgs that contains buffered data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DataEventHandler Members
Dart.Common Namespace


LocalCertificateSelectionCallback Delegate

[image]
PowerTCP Telnet for .NET CF
LocalCertificateSelectionCallback Delegate
See Also Send comments on this topic.
Dart.Common Namespace : LocalCertificateSelectionCallback Delegate

sender
An object that contains state information for this validation.
targetHost
The host server specified by the client.
localCertificates
An X509CertificateCollection containing local certificates.
remoteCertificate
The certificate used to authenticate the remote party.
acceptableIssuers
A String array of certificate issuers acceptable to the remote party.
Selects the local Secure Sockets Layer (SSL) certificate used for authentication.

Syntax

Visual Basic (Declaration)
Public Delegate Function LocalCertificateSelectionCallback( _
   ByVal sender As Object, _
   ByVal targetHost As String, _
   ByVal localCertificates As X509CertificateCollection, _
   ByVal remoteCertificate As X509Certificate, _
   ByVal acceptableIssuers() As String _
) As X509Certificate
Visual Basic (Usage) Copy Code
Dim instance As New LocalCertificateSelectionCallback(AddressOf HandlerMethod)
C#
public delegate X509Certificate LocalCertificateSelectionCallback(
   object sender,
   string targetHost,
   X509CertificateCollection localCertificates,
   X509Certificate remoteCertificate,
   string[] acceptableIssuers
)
Managed Extensions for C++
public: __gc __delegate X509Certificate* LocalCertificateSelectionCallback(
   Object* sender,
   string* targetHost,
   X509CertificateCollection* localCertificates,
   X509Certificate* remoteCertificate,
   string*[]* acceptableIssuers
)
C++/CLI
public delegate X509Certificate^ LocalCertificateSelectionCallback(
   Object^ sender,
   String^ targetHost,
   X509CertificateCollection^ localCertificates,
   X509Certificate^ remoteCertificate,
   array<String^>^ acceptableIssuers
)

Parameters

sender
An object that contains state information for this validation.
targetHost
The host server specified by the client.
localCertificates
An X509CertificateCollection containing local certificates.
remoteCertificate
The certificate used to authenticate the remote party.
acceptableIssuers
A String array of certificate issuers acceptable to the remote party.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LocalCertificateSelectionCallback Members
Dart.Common Namespace


LogEventHandler Delegate

[image]
PowerTCP Telnet for .NET CF
LogEventHandler Delegate
See Also Send comments on this topic.
Dart.Common Namespace : LogEventHandler Delegate

sender
The source of the event.
e
A LogDataEventArgs that contains data being read or written.
Represents the method that will handle an event containing unencrypted data passing to and from the socket.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LogEventHandler( _
   ByVal sender As Object, _
   ByVal e As LogEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LogEventHandler(AddressOf HandlerMethod)
C#
public delegate void LogEventHandler(
   object sender,
   LogEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void LogEventHandler(
   Object* sender,
   LogEventArgs* e
)
C++/CLI
public delegate void LogEventHandler(
   Object^ sender,
   LogEventArgs^ e
)

Parameters

sender
The source of the event.
e
A LogDataEventArgs that contains data being read or written.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LogEventHandler Members
Dart.Common Namespace


RemoteCertificateValidationCallback Delegate

[image]
PowerTCP Telnet for .NET CF
RemoteCertificateValidationCallback Delegate
See Also Send comments on this topic.
Dart.Common Namespace : RemoteCertificateValidationCallback Delegate

sender
An object that contains state information for this validation.
certificate
The certificate used to authenticate the remote party.
chain
The chain of certificate authorities associated with the remote certificate. Not implemented (always null).
sslPolicyErrors
One or more errors associated with the remote certificate.
Verifies the remote Secure Sockets Layer (SSL) certificate used for authentication.

Syntax

Visual Basic (Declaration)
Public Delegate Function RemoteCertificateValidationCallback( _
   ByVal sender As Object, _
   ByVal certificate As X509Certificate, _
   ByVal chain As X509Chain, _
   ByVal sslPolicyErrors As SslPolicyErrors _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As New RemoteCertificateValidationCallback(AddressOf HandlerMethod)
C#
public delegate bool RemoteCertificateValidationCallback(
   object sender,
   X509Certificate certificate,
   X509Chain chain,
   SslPolicyErrors sslPolicyErrors
)
Managed Extensions for C++
public: __gc __delegate bool RemoteCertificateValidationCallback(
   Object* sender,
   X509Certificate* certificate,
   X509Chain* chain,
   SslPolicyErrors sslPolicyErrors
)
C++/CLI
public delegate bool RemoteCertificateValidationCallback(
   Object^ sender,
   X509Certificate^ certificate,
   X509Chain^ chain,
   SslPolicyErrors sslPolicyErrors
)

Parameters

sender
An object that contains state information for this validation.
certificate
The certificate used to authenticate the remote party.
chain
The chain of certificate authorities associated with the remote certificate. Not implemented (always null).
sslPolicyErrors
One or more errors associated with the remote certificate.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

RemoteCertificateValidationCallback Members
Dart.Common Namespace


UserStateEventHandler Delegate

[image]
PowerTCP Telnet for .NET CF
UserStateEventHandler Delegate
See Also Send comments on this topic.
Dart.Common Namespace : UserStateEventHandler Delegate

sender
The source of the event.
e
A UserStateEventArgs that contains user data.
Represents the method that will handle an event raised by the user calling Marshal.

Syntax

Visual Basic (Declaration)
Public Delegate Sub UserStateEventHandler( _
   ByVal sender As Object, _
   ByVal e As UserStateEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UserStateEventHandler(AddressOf HandlerMethod)
C#
public delegate void UserStateEventHandler(
   object sender,
   UserStateEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void UserStateEventHandler(
   Object* sender,
   UserStateEventArgs* e
)
C++/CLI
public delegate void UserStateEventHandler(
   Object^ sender,
   UserStateEventArgs^ e
)

Parameters

sender
The source of the event.
e
A UserStateEventArgs that contains user data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventHandler Members
Dart.Common Namespace


Dart.Telnet Namespace

Dart.Telnet Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Classes

 | Class | Description
Class | CommandEventArgs | Contains Telnet command event data.
Class | Option | Encapsulates a Telnet option.
Class | OptionCollection | A collection of Option objects.
Class | OptionEventArgs | Contains option event data.
Class | Rexec | The Rexec component enables use of the remote execution protocol within any .NET application.
Class | Rlogin | The Rlogin component enables use of the remote login protocol within any .NET application.
Class | Rsh | The Rsh component enables use of the remote shell protocol within any .NET application.
Class | Telnet | The Telnet component enables use of the Telnet protocol within any .NET application.

Delegates

 | Delegate | Description
Delegate | CommandEventHandler | Represents the method that will handle an event in which a command is received.
Delegate | OptionEventHandler | Represents the method that will handle an event in which an option status changes.
Delegate | RexecThreadStart | Represents the method that will execute on a worker thread when Start is used.
Delegate | RloginThreadStart | Represents the method that will execute on a worker thread when Start is used.
Delegate | RshThreadStart | Represents the method that will execute on a worker thread when Start is used.
Delegate | TelnetThreadStart | Represents the method that will execute on a worker thread when Start is used.

Enumerations

 | Enumeration | Description
Enumeration | Command | Enumerates the TELNET protocol commands that can be sent.
Enumeration | OptionCode | Enumerates the supported Telnet options.
Enumeration | OptionState | Enumerates the current state of an Option object.

See Also

Reference

Dart.Telnet.CF Assembly


CommandEventArgs Class

[image]
PowerTCP Telnet for .NET CF
CommandEventArgs Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : CommandEventArgs Class

Contains Telnet command event data.

Object Model

CommandEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CommandEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
C#
public class CommandEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CommandEventArgs : public System.EventArgs
C++/CLI
public ref class CommandEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.CommandEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

CommandEventArgs Members
Dart.Telnet Namespace


CommandEventArgs Class Members

[image]
PowerTCP Telnet for .NET CF
CommandEventArgs Class Members
See Also Properties Methods Send comments on this topic.
Dart.Telnet Namespace : CommandEventArgs Class

The following tables list the members exposed by CommandEventArgs.

Public Properties

 | Name | Description
public Property | Command | The command sent by the remote host.
public Property | OptionCode | The option pertaining to the received command.
public Property | SubOption | Suboption pertaining to the received command.
Top

Public Methods

 | Name | Description
public Method | ToString | A readable string representing the command.
Top

See Also

Reference

CommandEventArgs Class
Dart.Telnet Namespace


CommandEventArgs Class Methods

[image]
PowerTCP Telnet for .NET CF
CommandEventArgs Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : CommandEventArgs Class

"

For a list of all members of this type, see CommandEventArgs members.

"

Public Methods

 | Name | Description
public Method | ToString | A readable string representing the command.
Top

See Also

Reference

CommandEventArgs Class
Dart.Telnet Namespace


ToString Method

[image]
PowerTCP Telnet for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Telnet Namespace > CommandEventArgs Class : ToString Method

A readable string representing the command.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string containing the command, option and suboption.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


CommandEventArgs Class Properties

[image]
PowerTCP Telnet for .NET CF
CommandEventArgs Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : CommandEventArgs Class

"

For a list of all members of this type, see CommandEventArgs members.

"

Public Properties

 | Name | Description
public Property | Command | The command sent by the remote host.
public Property | OptionCode | The option pertaining to the received command.
public Property | SubOption | Suboption pertaining to the received command.
Top

See Also

Reference

CommandEventArgs Class
Dart.Telnet Namespace


Command Property

[image]
PowerTCP Telnet for .NET CF
Command Property
See Also Send comments on this topic.
Dart.Telnet Namespace > CommandEventArgs Class : Command Property

The command sent by the remote host.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Command As Command
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As Command

value = instance.Command
C#
public Command Command {get;}
Managed Extensions for C++
public: __property Command get_Command();
C++/CLI
public:
property Command Command {
   Command get();
}

Remarks

This property represents the command sent by the remote host. For example, if the command from the server was a DO ECHO command (asking the client to enable echoing), this property will be set to Command.Do.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


OptionCode Property

[image]
PowerTCP Telnet for .NET CF
OptionCode Property
See Also Send comments on this topic.
Dart.Telnet Namespace > CommandEventArgs Class : OptionCode Property

The option pertaining to the received command.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionCode As OptionCode
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As OptionCode

value = instance.OptionCode
C#
public OptionCode OptionCode {get;}
Managed Extensions for C++
public: __property OptionCode get_OptionCode();
C++/CLI
public:
property OptionCode OptionCode {
   OptionCode get();
}

Remarks

This property represents the option to which the command pertains. For example, if the command from the server was a DO ECHO command (asking the client to enable echoing) this property would be set to OptionCode.Echo.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


SubOption Property

[image]
PowerTCP Telnet for .NET CF
SubOption Property
See Also Send comments on this topic.
Dart.Telnet Namespace > CommandEventArgs Class : SubOption Property

Suboption pertaining to the received command.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubOption As Byte()
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value() As Byte

value = instance.SubOption
C#
public byte[] SubOption {get;}
Managed Extensions for C++
public: __property byte[]* get_SubOption();
C++/CLI
public:
property array<byte>^ SubOption {
   array<byte>^ get();
}

Property Value

A byte array containing formatted data associated with the option.

Remarks

This property contains optional suboption data. Suboption usage is specific to a limited number of options. For the exact format of the suboption data, refer to the RFC that documents the option in question.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


Option Class

[image]
PowerTCP Telnet for .NET CF
Option Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : Option Class

Encapsulates a Telnet option.

Object Model

Option Class

Syntax

Visual Basic (Declaration)
Public Class Option
Visual Basic (Usage) Copy Code
Dim instance As Option
C#
public class Option
Managed Extensions for C++
public __gc class Option
C++/CLI
public ref class Option

Remarks

The Telnet protocol allows for option negotiation to provide advanced capabilities to the default NVT (Network Virtual Terminal). Both client and server can request to enable or disable options. Both hosts can accept or deny requests as well. The Option object represents an option.

To add a Telnet option, create a new Option object, and add it to the ClientOptions or ServerOptions collection. Adding the Option to Telnet.ClientOptions causes the Telnet component to send a WILL or WONT command to the server concerning the option. Adding the Option to Telnet.ServerOptions causes the Telnet component to sent a DO or DONT command to the server concerning the option. The State can either be set to OptionState.RequestOn (to use the option by requesting it), or OptionState.Allow (to use the option if the remote host requests it). To not use an option, either do not add it to a OptionCollection, or, if already present, remove it. After option negotiation occurs, check the State property to see if the option was negotiated successfully (OptionState.On) or negotiated unsuccessfully (OptionState.Off).

Inheritance Hierarchy

System.Object
Dart.Telnet.Option

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Members
Dart.Telnet Namespace


Option Class Members

[image]
PowerTCP Telnet for .NET CF
Option Class Members
See Also Properties Methods Send comments on this topic.
Dart.Telnet Namespace : Option Class

The following tables list the members exposed by Option.

Public Constructors

 | Name | Description
public Constructor | Option Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Code | Gets or sets the code of the option to use.
public Property | State | Gets or sets the current state of the Option.
public Property | SubOption | Gets or sets the suboption information for options.
Top

Public Methods

 | Name | Description
public Method | Reset | Reinitializes the Option.State for a new connection.
Top

See Also

Reference

Option Class
Dart.Telnet Namespace


Option Constructor

[image]
PowerTCP Telnet for .NET CF
Option Constructor
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class : Option Constructor

Overload List

Overload | Description
Option Constructor() | Initializes a new instance of Option.
Option Constructor(OptionCode) | Initializes a new instance of Option.
Option Constructor(OptionCode,OptionState) | Initializes a new instance of Option.
Option Constructor(OptionCode,Byte[]) | Initializes a new instance of Option.
Option Constructor(OptionCode,Byte[],OptionState) | Initializes a new instance of Option.
Option Constructor(Byte[],Int32,Int32) | Initializes a new instance of Option.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members


Option Constructor()

[image]
PowerTCP Telnet for .NET CF
Option Constructor()
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor()

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Option()
C#
public Option()
Managed Extensions for C++
public: Option();
C++/CLI
public:
Option();

Remarks

This constructor creates a new instance of Option with the State set to OptionState.Off.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode)

[image]
PowerTCP Telnet for .NET CF
Option Constructor(OptionCode)
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode)

code
The option code.
Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode

Dim instance As New Option(code)
C#
public Option(
   OptionCode code
)
Managed Extensions for C++
public: Option(
   OptionCode code
)
C++/CLI
public:
Option(
   OptionCode code
)

Parameters

code
The option code.

Remarks

This constructor creates a new instance of Option, with Code set to the value of code and State set to OptionState.Off.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,OptionState)

[image]
PowerTCP Telnet for .NET CF
Option Constructor(OptionCode,OptionState)
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,OptionState)

code
The option code.
state
The option state.
Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal state As OptionState _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim state As OptionState

Dim instance As New Option(code, state)
C#
public Option(
   OptionCode code,
   OptionState state
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   OptionState state
)
C++/CLI
public:
Option(
   OptionCode code,
   OptionState state
)

Parameters

code
The option code.
state
The option state.

Remarks

This constructor creates a new instance of Option, with Code and State set.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,Byte[])

[image]
PowerTCP Telnet for .NET CF
Option Constructor(OptionCode,Byte[])
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,Byte[])

code
The option code.
subOption
The option suboption.
Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim subOption() As Byte

Dim instance As New Option(code, subOption)
C#
public Option(
   OptionCode code,
   byte[] subOption
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   byte[]* subOption
)
C++/CLI
public:
Option(
   OptionCode code,
   array<byte>^ subOption
)

Parameters

code
The option code.
subOption
The option suboption.

Remarks

This constructor creates a new instance of Option, with Code set to the value of code, SubOption set to the value of subOption and State set to OptionState.Off.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,Byte[],OptionState)

[image]
PowerTCP Telnet for .NET CF
Option Constructor(OptionCode,Byte[],OptionState)
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,Byte[],OptionState)

code
The option code.
subOption
The option suboption.
state
The option state.
Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte, _
   ByVal state As OptionState _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim subOption() As Byte
Dim state As OptionState

Dim instance As New Option(code, subOption, state)
C#
public Option(
   OptionCode code,
   byte[] subOption,
   OptionState state
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   byte[]* subOption,
   OptionState state
)
C++/CLI
public:
Option(
   OptionCode code,
   array<byte>^ subOption,
   OptionState state
)

Parameters

code
The option code.
subOption
The option suboption.
state
The option state.

Remarks

This constructor creates a new instance of Option, with Code, SubOption and State set.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(Byte[],Int32,Int32)

[image]
PowerTCP Telnet for .NET CF
Option Constructor(Byte[],Int32,Int32)
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(Byte[],Int32,Int32)

buffer
Contains option data.
offset
Contains the offset into buffer.
count
Contains the option data count.
Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Option(buffer, offset, count)
C#
public Option(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Option(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Option(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Contains option data.
offset
Contains the offset into buffer.
count
Contains the option data count.

Remarks

This constructor creates a new instance of Option with State set to OptionState.Off.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members
Overload List


Option Class Methods

[image]
PowerTCP Telnet for .NET CF
Option Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : Option Class

"

For a list of all members of this type, see Option members.

"

Public Methods

 | Name | Description
public Method | Reset | Reinitializes the Option.State for a new connection.
Top

See Also

Reference

Option Class
Dart.Telnet Namespace


Reset Method

[image]
PowerTCP Telnet for .NET CF
Reset Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class : Reset Method

Reinitializes the Option.State for a new connection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As Option

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Remarks

This method causes the State property of the Option object to revert back to its original state. If the Option.State was OptionState.RequestOff, it is set to OptionState.Off.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members


Option Class Properties

[image]
PowerTCP Telnet for .NET CF
Option Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : Option Class

"

For a list of all members of this type, see Option members.

"

Public Properties

 | Name | Description
public Property | Code | Gets or sets the code of the option to use.
public Property | State | Gets or sets the current state of the Option.
public Property | SubOption | Gets or sets the suboption information for options.
Top

See Also

Reference

Option Class
Dart.Telnet Namespace


Code Property

[image]
PowerTCP Telnet for .NET CF
Code Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class : Code Property

Gets or sets the code of the option to use.

Syntax

Visual Basic (Declaration)
Public Property Code As OptionCode
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value As OptionCode

instance.Code = value

value = instance.Code
C#
public OptionCode Code {get; set;}
Managed Extensions for C++
public: __property OptionCode get_Code();
public: __property void set_Code(
   OptionCode value
);
C++/CLI
public:
property OptionCode Code {
   OptionCode get();
   void set (    OptionCode value);
}

Property Value

An OptionCode value representing the code for the option.

Remarks

This property will reflect one of the defined Telnet option code values represented by the OptionCode enumeration. For information about each option, please see the appropriate RFC for that option.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members


State Property

[image]
PowerTCP Telnet for .NET CF
State Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class : State Property

Gets or sets the current state of the Option.

Syntax

Visual Basic (Declaration)
Public Property State As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value As OptionState

instance.State = value

value = instance.State
C#
public OptionState State {get; set;}
Managed Extensions for C++
public: __property OptionState get_State();
public: __property void set_State(
   OptionState value
);
C++/CLI
public:
property OptionState State {
   OptionState get();
   void set (    OptionState value);
}

Property Value

An OptionState value representing the current state of the Option.

Remarks

Option negotiation with PowerTCP Telnet for .NET can be broken down into three general states:

State 1 - Setting the option:

Any requested options must be added to either the ClientOptions or ServerOptions collections. Any options added to these collections are part of the automatic option negotiation. When adding new options to the collection:

  • Set to OptionState.RequestOn to request the option (default value).
  • Set to OptionState.Allow to enable the option if the remote host requests it.
  • Remove Options from the collection to respond negatively to server requests.

State 2 - Requesting the option:

Option negotiation is typically handled internally by the Telnet component when a new connection occurs. During this time, Code is OptionCode.Waiting, indicating a request has been sent but a response has not yet been received.

State 3 - Negotiation complete:

After option negotiation has completed, check Option.Code to see the negotiation results. It should be one of two values:

  • OptionCode.Off if the option is not used.
  • OptionCode.On if the option is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members


SubOption Property

[image]
PowerTCP Telnet for .NET CF
SubOption Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Option Class : SubOption Property

Gets or sets the suboption information for options.

Syntax

Visual Basic (Declaration)
Public Property SubOption As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value() As Byte

instance.SubOption = value

value = instance.SubOption
C#
public byte[] SubOption {get; set;}
Managed Extensions for C++
public: __property byte[]* get_SubOption();
public: __property void set_SubOption(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ SubOption {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array representing the suboption information.

Remarks

Some options require addition suboption information. Set this property to a byte array representing the suboption data. The formatting of the data in the byte array will vary depending on the option. See the appropriate RFC for the option to determine how to format the data.

Popular suboptions are encapsulated by high level properties for ease of use. Examples include TerminalType and WindowSize.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Option Class
Option Members


OptionCollection Class

[image]
PowerTCP Telnet for .NET CF
OptionCollection Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : OptionCollection Class

A collection of Option objects.

Object Model

OptionCollection ClassOption Class

Syntax

Visual Basic (Declaration)
Public Class OptionCollection
   Inherits System.Collections.Generic.List(Of Option)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
C#
public class OptionCollection : System.Collections.Generic.List<Option>
Managed Extensions for C++
public __gc class OptionCollection : public System.Collections.Generic.List<Option>
C++/CLI
public ref class OptionCollection : public System.Collections.Generic.List<Option>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
Dart.Telnet.OptionCollection

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Members
Dart.Telnet Namespace


OptionCollection Class Members

[image]
PowerTCP Telnet for .NET CF
OptionCollection Class Members
See Also Properties Methods Send comments on this topic.
Dart.Telnet Namespace : OptionCollection Class

The following tables list the members exposed by OptionCollection.

Public Constructors

 | Name | Description
public Constructor | OptionCollection Constructor | Initializes an instance of the OptionCollection object.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<Option>)
public Property | Count | Gets the number of elements actually contained in the List. (Inherited from System.Collections.Generic.List<Option>)
public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<Option>)
public Property | TransmitBinary | Gets a value indicating if the "TRANSMIT-BINARY" option was negotiated for the OptionCollection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a new Option to the OptionCollection object.
public Method | AddRange | Adds an array of Option objects to the OptionCollection.
public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from System.Collections.Generic.List<Option>)
public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<Option>)
public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
public Method | Find | Overloaded. Returns the Option object which matches the specified code.
public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<Option>)
public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<Option>)
public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<Option>)
public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<Option>)
public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<Option>)
public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<Option>)
public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Top

See Also

Reference

OptionCollection Class
Dart.Telnet Namespace


OptionCollection Constructor

[image]
PowerTCP Telnet for .NET CF
OptionCollection Constructor
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class : OptionCollection Constructor

Initializes an instance of the OptionCollection object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New OptionCollection()
C#
public OptionCollection()
Managed Extensions for C++
public: OptionCollection();
C++/CLI
public:
OptionCollection();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members


OptionCollection Class Methods

[image]
PowerTCP Telnet for .NET CF
OptionCollection Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : OptionCollection Class

"

For a list of all members of this type, see OptionCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a new Option to the OptionCollection object.
public Method | AddRange | Adds an array of Option objects to the OptionCollection.
public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from System.Collections.Generic.List<Option>)
public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<Option>)
public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
public Method | Find | Overloaded. Returns the Option object which matches the specified code.
public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<Option>)
public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<Option>)
public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<Option>)
public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<Option>)
public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<Option>)
public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<Option>)
public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<Option>)
public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Top

See Also

Reference

OptionCollection Class
Dart.Telnet Namespace


Add Method

[image]
PowerTCP Telnet for .NET CF
Add Method
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class : Add Method

Adds a new Option to the OptionCollection object.

Overload List

Overload | Description
Add(Option) | Adds a new Option to the OptionCollection object.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members


Add(Option) Method

[image]
PowerTCP Telnet for .NET CF
Add(Option) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class > Add Method : Add(Option) Method

value
The Option to add to the OptionCollection object.
Adds a new Option to the OptionCollection object.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal value As Option _
)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim value As Option

instance.Add(value)
C#
public void Add(
   Option value
)
Managed Extensions for C++
public: void Add(
   Option* value
)
C++/CLI
public:
void Add(
   Option^ value
)

Parameters

value
The Option to add to the OptionCollection object.

Remarks

Use this method to add a new Option to the OptionCollection, to ensure it is used during option negotiation.

If an existing item has the same Code as the new option, the existing item is removed to prevent duplication.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members
Overload List


AddRange Method

[image]
PowerTCP Telnet for .NET CF
AddRange Method
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class : AddRange Method

items
The array of Option objects to add to the OptionCollection.
Adds an array of Option objects to the OptionCollection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub AddRange( _
   ByVal items() As Option _
)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim items() As Option

instance.AddRange(items)
C#
public new void AddRange(
   Option[] items
)
Managed Extensions for C++
public: new void AddRange(
   Option*[]* items
)
C++/CLI
public:
new void AddRange(
   array<Option^>^ items
)

Parameters

items
The array of Option objects to add to the OptionCollection.

Remarks

Use this method to add an array of Options to the OptionCollection, to ensure they are used during option negotiation.

If an existing item has the same Code as the new option, the existing item is removed to prevent duplication.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members


Find Method

[image]
PowerTCP Telnet for .NET CF
Find Method
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class : Find Method

Returns the Option object which matches the specified code.

Overload List

Overload | Description
Find(OptionCode) | Returns the Option object which matches the specified code.
Find(Predicate{Option}) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<Option>)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members


Find(OptionCode) Method

[image]
PowerTCP Telnet for .NET CF
Find(OptionCode) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class > Find Method : Find(OptionCode) Method

code
The OptionCode of the option to find.
Returns the Option object which matches the specified code.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal code As OptionCode _
) As Option
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim code As OptionCode
Dim value As Option

value = instance.Find(code)
C#
public Option Find(
   OptionCode code
)
Managed Extensions for C++
public: Option* Find(
   OptionCode code
)
C++/CLI
public:
Option^ Find(
   OptionCode code
)

Parameters

code
The OptionCode of the option to find.

Return Value

The Option which matches the specified code.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members
Overload List


OptionCollection Class Properties

[image]
PowerTCP Telnet for .NET CF
OptionCollection Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : OptionCollection Class

"

For a list of all members of this type, see OptionCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<Option>)
public Property | Count | Gets the number of elements actually contained in the List. (Inherited from System.Collections.Generic.List<Option>)
public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<Option>)
public Property | TransmitBinary | Gets a value indicating if the "TRANSMIT-BINARY" option was negotiated for the OptionCollection.
Top

See Also

Reference

OptionCollection Class
Dart.Telnet Namespace


TransmitBinary Property

[image]
PowerTCP Telnet for .NET CF
TransmitBinary Property
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionCollection Class : TransmitBinary Property

Gets a value indicating if the "TRANSMIT-BINARY" option was negotiated for the OptionCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TransmitBinary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim value As Boolean

value = instance.TransmitBinary
C#
public bool TransmitBinary {get;}
Managed Extensions for C++
public: __property bool get_TransmitBinary();
C++/CLI
public:
property bool TransmitBinary {
   bool get();
}

Property Value

A boolean which determines if the TRANSMIT-BINARY option has been negotiated.

Remarks

Setting the Binary property to true will cause the Telnet component to attempt to negotiate the "TRANSMIT-BINARY" option for both ClientOptions and ServerOptions. Check this property for both these collections after option negotiation has completed to determine if negotiation was successful.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionCollection Class
OptionCollection Members


OptionEventArgs Class

[image]
PowerTCP Telnet for .NET CF
OptionEventArgs Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : OptionEventArgs Class

Contains option event data.

Object Model

OptionEventArgs ClassOption Class

Syntax

Visual Basic (Declaration)
Public Class OptionEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As OptionEventArgs
C#
public class OptionEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class OptionEventArgs : public System.EventArgs
C++/CLI
public ref class OptionEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.OptionEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionEventArgs Members
Dart.Telnet Namespace


OptionEventArgs Class Members

[image]
PowerTCP Telnet for .NET CF
OptionEventArgs Class Members
See Also Properties Send comments on this topic.
Dart.Telnet Namespace : OptionEventArgs Class

The following tables list the members exposed by OptionEventArgs.

Public Properties

 | Name | Description
public Property | Option | The updated option causing the event.
Top

See Also

Reference

OptionEventArgs Class
Dart.Telnet Namespace


OptionEventArgs Class Properties

[image]
PowerTCP Telnet for .NET CF
OptionEventArgs Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : OptionEventArgs Class

"

For a list of all members of this type, see OptionEventArgs members.

"

Public Properties

 | Name | Description
public Property | Option | The updated option causing the event.
Top

See Also

Reference

OptionEventArgs Class
Dart.Telnet Namespace


Option Property

[image]
PowerTCP Telnet for .NET CF
Option Property
See Also Send comments on this topic.
Dart.Telnet Namespace > OptionEventArgs Class : Option Property

The updated option causing the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Option As Option
Visual Basic (Usage) Copy Code
Dim instance As OptionEventArgs
Dim value As Option

value = instance.Option
C#
public Option Option {get;}
Managed Extensions for C++
public: __property Option* get_Option();
C++/CLI
public:
property Option^ Option {
   Option^ get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionEventArgs Class
OptionEventArgs Members


Rexec Class

[image]
PowerTCP Telnet for .NET CF
Rexec Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : Rexec Class

The Rexec component enables use of the remote execution protocol within any .NET application.

Object Model

Rexec ClassProxy ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rexec
   Inherits Dart.Common.TcpBase
Visual Basic (Usage) Copy Code
Dim instance As Rexec
C#
public class Rexec : Dart.Common.TcpBase
Managed Extensions for C++
public __gc class Rexec : public Dart.Common.TcpBase
C++/CLI
public ref class Rexec : public Dart.Common.TcpBase

Remarks

Use the Rexec component to execute a command on a remote host (typically a UNIX host). To use the Rexec component, call one of the Connect methods to connect, then call Execute to execute the command, and then use one of the Read methods to read the results of the command.

Rexec and Rsh perform the same task using different authentication techniques. Rsh requires static information be added to .rhosts and/or hosts.equiv, whereas Rexec simply uses dynamic username/password information for authentication.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Telnet.Rexec

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Members
Dart.Telnet Namespace


Rexec Class Members

[image]
PowerTCP Telnet for .NET CF
Rexec Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Telnet Namespace : Rexec Class

The following tables list the members exposed by Rexec.

Public Constructors

 | Name | Description
public Constructor | Rexec Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerPort | Gets or sets the remote host port.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Executes a command on the remote host.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Raises the StateChanged event. (Inherited from Dart.Common.TcpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Rexec Constructor

[image]
PowerTCP Telnet for .NET CF
Rexec Constructor
See Also Send comments on this topic.
Dart.Telnet Namespace > Rexec Class : Rexec Constructor

Overload List

Overload | Description
Rexec Constructor() | Initializes a new instance of the Rexec component.
Rexec Constructor(IContainer) | Initializes a new instance of the Rexec component.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Class
Rexec Members


Rexec Constructor()

[image]
PowerTCP Telnet for .NET CF
Rexec Constructor()
See Also Send comments on this topic.
Dart.Telnet Namespace > Rexec Class > Rexec Constructor : Rexec Constructor()

Initializes a new instance of the Rexec component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rexec()
C#
public Rexec()
Managed Extensions for C++
public: Rexec();
C++/CLI
public:
Rexec();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Class
Rexec Members
Overload List


Rexec Constructor(IContainer)

[image]
PowerTCP Telnet for .NET CF
Rexec Constructor(IContainer)
See Also Send comments on this topic.
Dart.Telnet Namespace > Rexec Class > Rexec Constructor : Rexec Constructor(IContainer)

container
The container to which the Rexec component is added.
Initializes a new instance of the Rexec component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rexec(container)
C#
public Rexec(
   IContainer container
)
Managed Extensions for C++
public: Rexec(
   IContainer* container
)
C++/CLI
public:
Rexec(
   IContainer^ container
)

Parameters

container
The container to which the Rexec component is added.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Class
Rexec Members
Overload List


Rexec Class Methods

[image]
PowerTCP Telnet for .NET CF
Rexec Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : Rexec Class

"

For a list of all members of this type, see Rexec members.

"

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Executes a command on the remote host.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Raises the StateChanged event. (Inherited from Dart.Common.TcpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Execute Method

[image]
PowerTCP Telnet for .NET CF
Execute Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rexec Class : Execute Method

username
The login name of the user account.
password
The password of the user account.
command
The command to execute.
Executes a command on the remote host.

Syntax

Visual Basic (Declaration)
Public Sub Execute( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal command As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim username As String
Dim password As String
Dim command As String

instance.Execute(username, password, command)
C#
public void Execute(
   string username,
   string password,
   string command
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* password,
   string* command
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ password,
   String^ command
)

Parameters

username
The login name of the user account.
password
The password of the user account.
command
The command to execute.

Remarks

Use the Connect method to first connect to the remote host on the well-known port of 512. Then use Execute to authenticate using username and password and execute the command specified by command.

Use one of the Read methods to get the server's output.

When the server responds to a REXEC command, the first byte received indicates success/failure (0 for success, 1 for failure). When using the Rexec component, if the first byte is a 1 (meaning failure) an IOException is thrown. The Exception.Message will contain the response from the server without the first byte.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Class
Rexec Members


Start Method

[image]
PowerTCP Telnet for .NET CF
Start Method
See Also Example Send comments on this topic.
Dart.Telnet Namespace > Rexec Class : Start Method

worker
RexecThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.
Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As RexecThreadStart, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim worker As RexecThreadStart
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   RexecThreadStart worker,
   object state
)
Managed Extensions for C++
public: void Start(
   RexecThreadStart* worker,
   Object* state
)
C++/CLI
public:
void Start(
   RexecThreadStart^ worker,
   Object^ state
)

Parameters

worker
RexecThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Class
Rexec Members


Rexec Class Properties

[image]
PowerTCP Telnet for .NET CF
Rexec Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : Rexec Class

"

For a list of all members of this type, see Rexec members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerPort | Gets or sets the remote host port.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


ServerPort Property

[image]
PowerTCP Telnet for .NET CF
ServerPort Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Rexec Class : ServerPort Property

Gets or sets the remote host port.

Syntax

Visual Basic (Declaration)
Public Property ServerPort As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim value As Integer

instance.ServerPort = value

value = instance.ServerPort
C#
public int ServerPort {get; set;}
Managed Extensions for C++
public: __property int get_ServerPort();
public: __property void set_ServerPort(
   int value
);
C++/CLI
public:
property int ServerPort {
   int get();
   void set (    int value);
}

Property Value

Integer defaults to 512.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rexec Class
Rexec Members


Rlogin Class

[image]
PowerTCP Telnet for .NET CF
Rlogin Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : Rlogin Class

The Rlogin component enables use of the remote login protocol within any .NET application.

Object Model

Rlogin ClassProxy ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rlogin
   Inherits Dart.Common.PtyBase
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
C#
public class Rlogin : Dart.Common.PtyBase
Managed Extensions for C++
public __gc class Rlogin : public Dart.Common.PtyBase
C++/CLI
public ref class Rlogin : public Dart.Common.PtyBase

Remarks

Use the Rlogin component to login to a remote host (typically a UNIX host). To use the Rlogin component, call the Connect and Login methods, passing in the appropriate parameters. Once connected, send commands to the remote host by using Write; receive data from the remote host using Read.

Rlogin is similar to Telnet, but has less complexity. Rlogin does not support telnet option negotiation, but does support the window size construct.

Rlogin requires authorization for the local host running the application. To do this, add the appropriate entries to the hosts.equiv or .rhosts files located on the remote host. These files enable login from other machines and users. The hosts.equiv file is a system file containing names of remote hosts authorized to execute the remote protocol. If not authorized in this file, the remote host looks for the .rhosts file located in the user's account on the remote host. The .rhosts file contains lines of host names and login names paired together. If the remote hosts .rhosts file lacks an entry for the client, the server will request an interactive login, like Telnet.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Common.PtyBase
Dart.Telnet.Rlogin

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Members
Dart.Telnet Namespace


Rlogin Class Members

[image]
PowerTCP Telnet for .NET CF
Rlogin Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Telnet Namespace : Rlogin Class

The following tables list the members exposed by Rlogin.

Public Constructors

 | Name | Description
public Constructor | Rlogin Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Common.PtyBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerPort | Gets or sets the remote host port.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
public Property | TerminalTypeSpeed | Gets or sets the terminal type and speed.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Overridden. Connects to an Rlogin server.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Login | Overloaded. Log into an Rlogin server.
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Raises the StateChanged event. (Inherited from Dart.Common.TcpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Rlogin Constructor

[image]
PowerTCP Telnet for .NET CF
Rlogin Constructor
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class : Rlogin Constructor

Overload List

Overload | Description
Rlogin Constructor() | Initializes a new instance of the Rlogin component.
Rlogin Constructor(IContainer) | Initializes a new instance of the Rlogin component.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Constructor()

[image]
PowerTCP Telnet for .NET CF
Rlogin Constructor()
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class > Rlogin Constructor : Rlogin Constructor()

Initializes a new instance of the Rlogin component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rlogin()
C#
public Rlogin()
Managed Extensions for C++
public: Rlogin();
C++/CLI
public:
Rlogin();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Rlogin Constructor(IContainer)

[image]
PowerTCP Telnet for .NET CF
Rlogin Constructor(IContainer)
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class > Rlogin Constructor : Rlogin Constructor(IContainer)

container
The container to which the Rlogin component is added.
Initializes a new instance of the Rlogin component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rlogin(container)
C#
public Rlogin(
   IContainer container
)
Managed Extensions for C++
public: Rlogin(
   IContainer* container
)
C++/CLI
public:
Rlogin(
   IContainer^ container
)

Parameters

container
The container to which the Rlogin component is added.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Rlogin Class Methods

[image]
PowerTCP Telnet for .NET CF
Rlogin Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : Rlogin Class

"

For a list of all members of this type, see Rlogin members.

"

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Overridden. Connects to an Rlogin server.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Login | Overloaded. Log into an Rlogin server.
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Raises the StateChanged event. (Inherited from Dart.Common.TcpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Connect Method

[image]
PowerTCP Telnet for .NET CF
Connect Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class : Connect Method

Connects to an Rlogin server.

Overload List

Overload | Description
Connect(String) | Connects to an Rlogin server.
Connect(IPEndPoint) | Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
Connect(IPAddress[]) | Connects to one in a specified list of IP addresses. (Inherited from Dart.Common.TcpBase)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members


Connect(String) Method

[image]
PowerTCP Telnet for .NET CF
Connect(String) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class > Connect Method : Connect(String) Method

hostNameOrAddress
The remote host name or address to connect to.
Connects to an Rlogin server.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public override void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
) override
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
) override

Parameters

hostNameOrAddress
The remote host name or address to connect to.

Remarks

This method attempts to connect to the remote host at the default port of 513.

Since the rlogin and rsh protocols require a local port between 512 and 1023 (inclusively), this library attempts to bind to an open local port within this range. This feature allows you to use this protocol hundreds of times without running out of local ports.

Set ServerPort to connect to a port other than 513.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Login Method

[image]
PowerTCP Telnet for .NET CF
Login Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class : Login Method

Log into an Rlogin server.

Overload List

Overload | Description
Login(String) | Log into an Rlogin server.
Login(String,String) | Log into an Rlogin server.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members


Login(String) Method

[image]
PowerTCP Telnet for .NET CF
Login(String) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class > Login Method : Login(String) Method

username
The username sent during login.
Log into an Rlogin server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal username As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim username As String

instance.Login(username)
C#
public void Login(
   string username
)
Managed Extensions for C++
public: void Login(
   string* username
)
C++/CLI
public:
void Login(
   String^ username
)

Parameters

username
The username sent during login.

Remarks

This method should be used after the Connect method completes successfully.

The username is the login name of the user as known on the server.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Login(String,String) Method

[image]
PowerTCP Telnet for .NET CF
Login(String,String) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class > Login Method : Login(String,String) Method

username
The username sent during login.
clientUsername
Login name of the user on the client host.
Log into an Rlogin server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal username As String, _
   ByVal clientUsername As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim username As String
Dim clientUsername As String

instance.Login(username, clientUsername)
C#
public void Login(
   string username,
   string clientUsername
)
Managed Extensions for C++
public: void Login(
   string* username,
   string* clientUsername
)
C++/CLI
public:
void Login(
   String^ username,
   String^ clientUsername
)

Parameters

username
The username sent during login.
clientUsername
Login name of the user on the client host.

Remarks

This method should be used after the Connect method completes successfully.

The username is the login name of the user as known on the server. The clientUsername may be used if the client username differs from the server username.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Start Method

[image]
PowerTCP Telnet for .NET CF
Start Method
See Also Example Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class : Start Method

worker
RloginThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.
Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As RloginThreadStart, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim worker As RloginThreadStart
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   RloginThreadStart worker,
   object state
)
Managed Extensions for C++
public: void Start(
   RloginThreadStart* worker,
   Object* state
)
C++/CLI
public:
void Start(
   RloginThreadStart^ worker,
   Object^ state
)

Parameters

worker
RloginThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Class Properties

[image]
PowerTCP Telnet for .NET CF
Rlogin Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : Rlogin Class

"

For a list of all members of this type, see Rlogin members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Common.PtyBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerPort | Gets or sets the remote host port.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
public Property | TerminalTypeSpeed | Gets or sets the terminal type and speed.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


ServerPort Property

[image]
PowerTCP Telnet for .NET CF
ServerPort Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class : ServerPort Property

Gets or sets the remote host port.

Syntax

Visual Basic (Declaration)
Public Property ServerPort As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As Integer

instance.ServerPort = value

value = instance.ServerPort
C#
public int ServerPort {get; set;}
Managed Extensions for C++
public: __property int get_ServerPort();
public: __property void set_ServerPort(
   int value
);
C++/CLI
public:
property int ServerPort {
   int get();
   void set (    int value);
}

Property Value

Integer defaults to 513.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members


TerminalTypeSpeed Property

[image]
PowerTCP Telnet for .NET CF
TerminalTypeSpeed Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Rlogin Class : TerminalTypeSpeed Property

Gets or sets the terminal type and speed.

Syntax

Visual Basic (Declaration)
Public Property TerminalTypeSpeed As String
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As String

instance.TerminalTypeSpeed = value

value = instance.TerminalTypeSpeed
C#
public string TerminalTypeSpeed {get; set;}
Managed Extensions for C++
public: __property string* get_TerminalTypeSpeed();
public: __property void set_TerminalTypeSpeed(
   string* value
);
C++/CLI
public:
property String^ TerminalTypeSpeed {
   String^ get();
   void set (    String^ value);
}

Property Value

A string representing the terminal type and speed. Defaults to "vt320/19200".

Remarks

The Rlogin protocol dictates that client terminal type and terminal speed is sent to the remote host during login. Set this property before logging in.

The format for this string is [terminal type]/[terminal speed]. For example, "vt320/19200".

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rlogin Class
Rlogin Members


Rsh Class

[image]
PowerTCP Telnet for .NET CF
Rsh Class
Members See Also Send comments on this topic.
Dart.Telnet Namespace : Rsh Class

The Rsh component enables use of the remote shell protocol within any .NET application.

Object Model

Rsh ClassProxy ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rsh
   Inherits Dart.Common.TcpBase
Visual Basic (Usage) Copy Code
Dim instance As Rsh
C#
public class Rsh : Dart.Common.TcpBase
Managed Extensions for C++
public __gc class Rsh : public Dart.Common.TcpBase
C++/CLI
public ref class Rsh : public Dart.Common.TcpBase

Remarks

Use the Rsh component to execute a command on a remote host (typically a UNIX host). To use the Rsh component, call Connect to connect, call one of the Execute methods to execute the command, and then use one of the Read methods to read the results of the command.

Rexec and Rsh perform the same task using different authentication techniques. Rsh requires static information be added to .rhosts and/or hosts.equiv, whereas Rexec simply uses dynamic username/password information for authentication.

Using Rsh requires authorization for the local host running the application. To do this, add the appropriate entries to the hosts.equiv or .rhosts files located on the remote host. These files enable login from other machines and users. The hosts.equiv file is a system file containing names of remote hosts authorized to execute the remote protocol. If not authorized in this file, the remote host looks for the .rhosts file located in the user's account on the remote host. The .rhosts file contains lines of host names and login names paired together. Your local host with login name is authorized if found in this file.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Telnet.Rsh

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Members
Dart.Telnet Namespace


Rsh Class Members

[image]
PowerTCP Telnet for .NET CF
Rsh Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Telnet Namespace : Rsh Class

The following tables list the members exposed by Rsh.

Public Constructors

 | Name | Description
public Constructor | Rsh Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerPort | Gets or sets the remote host port.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Overridden. Connects to an Rsh server.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Overloaded. Execute a command on the Rsh server.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Raises the StateChanged event. (Inherited from Dart.Common.TcpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Rsh Constructor

[image]
PowerTCP Telnet for .NET CF
Rsh Constructor
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class : Rsh Constructor

Overload List

Overload | Description
Rsh Constructor() | Initializes a new instance of the Rsh component.
Rsh Constructor(IContainer) | Initializes a new instance of the Rsh component.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members


Rsh Constructor()

[image]
PowerTCP Telnet for .NET CF
Rsh Constructor()
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class > Rsh Constructor : Rsh Constructor()

Initializes a new instance of the Rsh component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rsh()
C#
public Rsh()
Managed Extensions for C++
public: Rsh();
C++/CLI
public:
Rsh();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members
Overload List


Rsh Constructor(IContainer)

[image]
PowerTCP Telnet for .NET CF
Rsh Constructor(IContainer)
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class > Rsh Constructor : Rsh Constructor(IContainer)

container
The container to which the Rsh component is added.
Initializes a new instance of the Rsh component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rsh(container)
C#
public Rsh(
   IContainer container
)
Managed Extensions for C++
public: Rsh(
   IContainer* container
)
C++/CLI
public:
Rsh(
   IContainer^ container
)

Parameters

container
The container to which the Rsh component is added.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members
Overload List


Rsh Class Methods

[image]
PowerTCP Telnet for .NET CF
Rsh Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : Rsh Class

"

For a list of all members of this type, see Rsh members.

"

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Overridden. Connects to an Rsh server.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Overloaded. Execute a command on the Rsh server.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Common.TcpBase)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnStateChanged | Raises the StateChanged event. (Inherited from Dart.Common.TcpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Connect Method

[image]
PowerTCP Telnet for .NET CF
Connect Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class : Connect Method

Connects to an Rsh server.

Overload List

Overload | Description
Connect(String) | Connects to an Rsh server.
Connect(IPEndPoint) | Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
Connect(IPAddress[]) | Connects to one in a specified list of IP addresses. (Inherited from Dart.Common.TcpBase)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members


Connect(String) Method

[image]
PowerTCP Telnet for .NET CF
Connect(String) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class > Connect Method : Connect(String) Method

hostNameOrAddress
The remote host name or address to connect to.
Connects to an Rsh server.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public override void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
) override
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
) override

Parameters

hostNameOrAddress
The remote host name or address to connect to.

Remarks

This method attempts to connect to the remote host at the default port of 514.

Since the rlogin and rsh protocols require a local port between 512 and 1023 (inclusively), this library attempts to bind to an open local port within this range. This feature allows you to use this protocol hundreds of times without running out of local ports.

Set ServerPort to connect to a port other than 514.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members
Overload List


Execute Method

[image]
PowerTCP Telnet for .NET CF
Execute Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class : Execute Method

Execute a command on the Rsh server.

Overload List

Overload | Description
Execute(String,String) | Execute a command on the Rsh server.
Execute(String,String,String) | Execute a command on the Rsh server.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members


Execute(String,String) Method

[image]
PowerTCP Telnet for .NET CF
Execute(String,String) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class > Execute Method : Execute(String,String) Method

username
The login name of the user account.
command
The command to execute.
Execute a command on the Rsh server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Execute( _
   ByVal username As String, _
   ByVal command As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim username As String
Dim command As String

instance.Execute(username, command)
C#
public void Execute(
   string username,
   string command
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* command
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ command
)

Parameters

username
The login name of the user account.
command
The command to execute.

Remarks

This method executes the command specified by command. A Read method should be used to get the results.

Set ServerPort to connect to a port other than 514.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members
Overload List


Execute(String,String,String) Method

[image]
PowerTCP Telnet for .NET CF
Execute(String,String,String) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class > Execute Method : Execute(String,String,String) Method

username
The login name of the user as known to the server.
command
The command to execute.
clientUsername
Login name of the user on the client host.
Execute a command on the Rsh server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Execute( _
   ByVal username As String, _
   ByVal command As String, _
   ByVal clientUsername As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim username As String
Dim command As String
Dim clientUsername As String

instance.Execute(username, command, clientUsername)
C#
public void Execute(
   string username,
   string command,
   string clientUsername
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* command,
   string* clientUsername
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ command,
   String^ clientUsername
)

Parameters

username
The login name of the user as known to the server.
command
The command to execute.
clientUsername
Login name of the user on the client host.

Remarks

This method executes the command specified by command. A Read method should be used to get the results.

The username is the login name of the user as known on the server. The clientUsername may be used if the client username differs from the server username.

Set ServerPort to connect to a port other than 514.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members
Overload List


Start Method

[image]
PowerTCP Telnet for .NET CF
Start Method
See Also Example Send comments on this topic.
Dart.Telnet Namespace > Rsh Class : Start Method

worker
RshThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.
Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As RshThreadStart, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim worker As RshThreadStart
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   RshThreadStart worker,
   object state
)
Managed Extensions for C++
public: void Start(
   RshThreadStart* worker,
   Object* state
)
C++/CLI
public:
void Start(
   RshThreadStart^ worker,
   Object^ state
)

Parameters

worker
RshThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members


Rsh Class Properties

[image]
PowerTCP Telnet for .NET CF
Rsh Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : Rsh Class

"

For a list of all members of this type, see Rsh members.

"

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerPort | Gets or sets the remote host port.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


ServerPort Property

[image]
PowerTCP Telnet for .NET CF
ServerPort Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Rsh Class : ServerPort Property

Gets or sets the remote host port.

Syntax

Visual Basic (Declaration)
Public Property ServerPort As Integer
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim value As Integer

instance.ServerPort = value

value = instance.ServerPort
C#
public int ServerPort {get; set;}
Managed Extensions for C++
public: __property int get_ServerPort();
public: __property void set_ServerPort(
   int value
);
C++/CLI
public:
property int ServerPort {
   int get();
   void set (    int value);
}

Property Value

Integer defaults to 514.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Rsh Class
Rsh Members


Telnet Class

[image]
PowerTCP Telnet for .NET CF
Telnet Class
Members Example See Also Send comments on this topic.
Dart.Telnet Namespace : Telnet Class

The Telnet component enables use of the Telnet protocol within any .NET application.

Object Model

Telnet ClassOptionCollection ClassOption ClassProxy ClassOptionCollection ClassOption ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Telnet
   Inherits Dart.Common.PtyBase
Visual Basic (Usage) Copy Code
Dim instance As Telnet
C#
public class Telnet : Dart.Common.PtyBase
Managed Extensions for C++
public __gc class Telnet : public Dart.Common.PtyBase
C++/CLI
public ref class Telnet : public Dart.Common.PtyBase

Example

The following example demonstrates execution of an automated session using the Telnet component.
C# Copy Code
private Telnet telnet1;

private void button1_Click(object sender, EventArgs e)
{
    //Dynamically create an instance of the Telnet component
    //The component can also be dragged onto a form, so that the
    //properties and event handlers can be managed in the designer
    telnet1 = new Telnet();

    //Events should fire on the UI thread
    telnet1.SynchronizingObject = this;

    //Add event handlers
    telnet1.Data += new DataEventHandler(telnet1_Data);
    telnet1.Error += new Dart.Common.ComponentErrorEventHandler(telnet1_Error);
    telnet1.StateChanged += new EventHandler(telnet1_StateChanged);

    //Start the process on a worker thread
    telnet1.Start(automateSession, null);
}

private void automateSession(Telnet telnet, object notUsed)
{
    //This function executes on a worker thread, providing multi-threaded, asynchronous operation
    try
    {
        //Connect to the server
        telnet.Connect("myServer");

        //Login and marshal data to the UI thread
        telnet.Marshal(telnet.Login("myUsername", "myPassword", "$"), null);

        //Send a list command
        telnet.Write("ls -la\r");

        //Wait for prompt, marshal data to the UI thread
        telnet.Marshal(telnet.Read("$"), null);

        //Send an exit command; server will close the connection
        telnet.Write("exit\r");

        //Read any remaining data before the shutdown
        telnet.Marshal(telnet.ReadToEnd(), null);
    }
    catch (Exception ex)
    {
        //Report errors to the UI thread
        telnet.Marshal(ex);
    }
}

void telnet1_Data(object sender, DataEventArgs e)
{
    //Add data received to the textbox
    textBox1.AppendText(e.Data.ToString());
}

void telnet1_Error(object sender, Dart.Common.ComponentErrorEventArgs e)
{
    //Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message);
}

void telnet1_StateChanged(object sender, EventArgs e)
{
    //Change appearance of textbox when connected
    textBox1.BackColor = (telnet1.State == ConnectionState.Closed)
    ? SystemColors.ControlDark
    : SystemColors.ControlLight;
}
Visual Basic Copy Code
Private telnet1 As Telnet

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button2.Click
    'Dynamically create an instance of the Telnet component
    'The component can also be dragged onto a form, so that the
    'properties and event handlers can be managed in the designer
    telnet1 = New Telnet()

    'Events should fire on the UI thread
    telnet1.SynchronizingObject = Me

    'Add event handlers
    AddHandler telnet1.Data, AddressOf telnet1_Data
    AddHandler telnet1.Error, AddressOf telnet1_Error
    AddHandler telnet1.StateChanged, AddressOf telnet1_StateChanged

    'Start the process on a worker thread
    telnet1.Start(AddressOf automateSession, Nothing)
End Sub

Private Sub automateSession(ByVal telnet As Telnet, ByVal notUsed As Object)
    'This function executes on a worker thread, providing multi-threaded, asynchronous operation
    Try
        'Connect to the server
        telnet.Connect("myServer")

        'Login and marshal data to the UI thread
        telnet.Marshal(telnet.Login("myUsername", "myPassword", "$"), Nothing)

        'Send a list command
        telnet.Write("ls -la" & Constants.vbCr)

        'Wait for prompt, marshal data to the UI thread
        telnet.Marshal(telnet.Read("$"), Nothing)

        'Send an exit command; server will close the connection
        telnet.Write("exit" & Constants.vbCr)

        'Read any remaining data before the shutdown
        telnet.Marshal(telnet.ReadToEnd(), Nothing)
    Catch ex As Exception
        'Report errors to the UI thread
        telnet.Marshal(ex)
    End Try
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs)
    'Add data received to the textbox
    textBox1.AppendText(e.Data.ToString())
End Sub

Private Sub telnet1_Error(ByVal sender As Object, ByVal e As Dart.Common.ComponentErrorEventHandler)
    'Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message)
End Sub

Private Sub telnet1_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    'Change appearance of textbox when connected
    If (telnet1.State = ConnectionState.Closed) Then
        textBox1.BackColor = SystemColors.ControlDark
    Else
        textBox1.BackColor = SystemColors.ControlLight
    End If
End Sub

Remarks

The Telnet component establishes and manages Telnet-level streams of data. Methods for establishing connections, handling option negotiation, and sending and receiving data greatly simplify Telnet communications for the user, while still providing many options for advanced customization. Secure SSL connections, asynchronous use, and advanced option negotiation are all fully supported.

The Telnet component can optionally be bound to a display for easy user-interactive development.

Using the Telnet Component

The Telnet component's clean interface provides clear, straight-forward use. All methods calls are blocking calls, making programming an intuitive step-by-step process. Functions can be passed to the Start method, to execute on independent threads, without blocking the user interface. Marshaling data from these threads is very convenient using the Marshal method. See the Asynchronous Operation page for more information on this topic.

  • Connecting: To connect to a host, use the Connect method. Once connected, establish a secure connection using AuthenticateAsClient.

  • Default option negotiation: The Telnet component uses a default option negotiation sequence which occurs automatically after login. To add or remove options to negotiate, modify the ClientOptions and ServerOptions collections appropriately. The ClientOptionChanged and ServerOptionChanged events fire when the state of an option changes.

  • Customized option negotiation: Manual option negotiation is also possible. Use the SendOption call to send option commands, and and the CommandReceived event to examine server responses.

  • Sending Data: Once a connection is established, send data using the Write method, which includes overloads for sending data as byte arrays or as strings.

  • Receiving Data: Receive data using the Read method. This method returns a Data object containing data read off the data stream. Data in this object can easily be converted to a string using its ToString method. The Read method includes overloads for reading until a specified delimiter is found. A set of delimiters can also be specified for situations in which one of several responses may be received. Marshal data to the Data event by calling the Marshal method.

  • Sending commands: Use the SendMethod method to send any non-option control command to the host.

Binding the Telnet Component to a Display

Set the Pty (pseudo terminal) property to bind the Telnet component to a display control derived from TextBoxBase (such as a standard TextBox), and call Connect to establish a connection to the specified host. Once connected, keystrokes will be sent automatically, and data received will appear in the text area.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Common.PtyBase
Dart.Telnet.Telnet

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Members
Dart.Telnet Namespace


Telnet Class Members

[image]
PowerTCP Telnet for .NET CF
Telnet Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Telnet Namespace : Telnet Class

The following tables list the members exposed by Telnet.

Public Constructors

 | Name | Description
public Constructor | Telnet Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Binary | Gets or sets the state of the Telnet Transmit-Binary option.
public Property | ClientOptions | Gets a collection of desired client options.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Echo | Gets or sets the state of the Telnet Echo option.
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Common.PtyBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerOptions | Gets a collection of desired server options.
public Property | ServerPort | Gets or sets the remote Telnet port to connect to.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
public Property | TerminalType | Gets or sets the terminal type used for the Telnet TerminalType option.
public Property | WindowSize | Gets or sets the window-size used for the Telnet WindowSize option.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Overridden. Provides access to the underlying Stream.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Login | Overloaded. Logs into a telnet server using standard prompts.
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | Refresh | Negotiates Telnet options that have been added to the ClientOptions and ServerOptions collections.
public Method | SendCommand | Sends a Telnet (non-option) command to the server.
public Method | SendOption | Sends a Telnet option to the server.
public Method | SendSubOption | Sends a suboption request or response to the server.
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnClientOptionChanged | Raises the ClientOptionChanged event.
protected Method | OnCommandReceived | Raises the CommandReceived event.
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnServerOptionChanged | Raises the ServerOptionChanged event.
protected Method | OnStateChanged | Overridden. Raises the StateChanged event.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | ClientOptionChanged | Raised when a client Telnet option has changed state (WILL or WONT confirmed).
public Event | CommandReceived | Raised when a Telnet command is received from the server.
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | ServerOptionChanged | Raised when a server Telnet option has changed state (DO or DONT confirmed).
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


Telnet Constructor

[image]
PowerTCP Telnet for .NET CF
Telnet Constructor
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : Telnet Constructor

Overload List

Overload | Description
Telnet Constructor() | Initializes a new instance of the Telnet component.
Telnet Constructor(IContainer) | Initializes a new instance of the Telnet component.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Telnet Constructor()

[image]
PowerTCP Telnet for .NET CF
Telnet Constructor()
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class > Telnet Constructor : Telnet Constructor()

Initializes a new instance of the Telnet component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Telnet()
C#
public Telnet()
Managed Extensions for C++
public: Telnet();
C++/CLI
public:
Telnet();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members
Overload List


Telnet Constructor(IContainer)

[image]
PowerTCP Telnet for .NET CF
Telnet Constructor(IContainer)
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class > Telnet Constructor : Telnet Constructor(IContainer)

container
Initializes a new instance of the Telnet component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Telnet(container)
C#
public Telnet(
   IContainer container
)
Managed Extensions for C++
public: Telnet(
   IContainer* container
)
C++/CLI
public:
Telnet(
   IContainer^ container
)

Parameters

container

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members
Overload List


Telnet Class Methods

[image]
PowerTCP Telnet for .NET CF
Telnet Class Methods
See Also Send comments on this topic.
Dart.Telnet Namespace : Telnet Class

"

For a list of all members of this type, see Telnet members.

"

Public Methods

 | Name | Description
public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | AuthenticateAsServer | Overloaded. Authenticates a client when establishing a secure connection. (Inherited from Dart.Common.TcpBase)
public Method | Close | Gracefully closes the connection. (Inherited from Dart.Common.TcpBase)
public Method | Connect | Overloaded. Connects to the specified remote endpoint. (Inherited from Dart.Common.TcpBase)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSslInfo | Provides information on the SSL channel. (Inherited from Dart.Common.TcpBase)
public Method | GetStream | Overridden. Provides access to the underlying Stream.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Login | Overloaded. Logs into a telnet server using standard prompts.
public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Common.TcpBase)
public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Common.TcpBase)
public Method | ReadToEnd | Receives data until the connection is closed. (Inherited from Dart.Common.TcpBase)
public Method | Refresh | Negotiates Telnet options that have been added to the ClientOptions and ServerOptions collections.
public Method | SendCommand | Sends a Telnet (non-option) command to the server.
public Method | SendOption | Sends a Telnet option to the server.
public Method | SendSubOption | Sends a suboption request or response to the server.
public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Common.TcpBase)
public Method | Start | Starts a worker thread on which the specified delegate function executes.
public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Common.TcpBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnClientOptionChanged | Raises the ClientOptionChanged event.
protected Method | OnCommandReceived | Raises the CommandReceived event.
protected Method | OnData | Raises the Data event. (Inherited from Dart.Common.TcpBase)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnLog | Raises the Log event. (Inherited from Dart.Common.TcpBase)
protected Method | OnServerOptionChanged | Raises the ServerOptionChanged event.
protected Method | OnStateChanged | Overridden. Raises the StateChanged event.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


GetStream Method

[image]
PowerTCP Telnet for .NET CF
GetStream Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : GetStream Method

Provides access to the underlying Stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Stream

value = instance.GetStream()
C#
public override Stream GetStream()
Managed Extensions for C++
public: Stream* GetStream(); override
C++/CLI
public:
Stream^ GetStream(); override

Return Value

The underlying Stream object used by the component.

Remarks

If a connection is not established, operations on the stream will result in null reference exceptions.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Login Method

[image]
PowerTCP Telnet for .NET CF
Login Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : Login Method

Logs into a telnet server using standard prompts.

Overload List

Overload | Description
Login(String,String,String) | Logs into a telnet server using standard prompts.
Login(String,String,String,String,String,Int32) | Logs into a telnet server using specified prompts.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Login(String,String,String) Method

[image]
PowerTCP Telnet for .NET CF
Login(String,String,String) Method
See Also Example Send comments on this topic.
Dart.Telnet Namespace > Telnet Class > Login Method : Login(String,String,String) Method

username
The username provided for login.
password
The password provided for login.
commandPrompt
The command prompt used by the remote host.
Logs into a telnet server using standard prompts.

Syntax

Visual Basic (Declaration)
Public Overloads Function Login( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal commandPrompt As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim username As String
Dim password As String
Dim commandPrompt As String
Dim value As Data

value = instance.Login(username, password, commandPrompt)
C#
public Data Login(
   string username,
   string password,
   string commandPrompt
)
Managed Extensions for C++
public: Data* Login(
   string* username,
   string* password,
   string* commandPrompt
)
C++/CLI
public:
Data^ Login(
   String^ username,
   String^ password,
   String^ commandPrompt
)

Parameters

username
The username provided for login.
password
The password provided for login.
commandPrompt
The command prompt used by the remote host.

Return Value

A Data object containing the data received during the login.

Example

The following example demonstrates execution of an automated session using the Telnet component.
C# Copy Code
private Telnet telnet1;

private void button1_Click(object sender, EventArgs e)
{
    //Dynamically create an instance of the Telnet component
    //The component can also be dragged onto a form, so that the
    //properties and event handlers can be managed in the designer
    telnet1 = new Telnet();

    //Events should fire on the UI thread
    telnet1.SynchronizingObject = this;

    //Add event handlers
    telnet1.Data += new DataEventHandler(telnet1_Data);
    telnet1.Error += new Dart.Common.ComponentErrorEventHandler(telnet1_Error);
    telnet1.StateChanged += new EventHandler(telnet1_StateChanged);

    //Start the process on a worker thread
    telnet1.Start(automateSession, null);
}

private void automateSession(Telnet telnet, object notUsed)
{
    //This function executes on a worker thread, providing multi-threaded, asynchronous operation
    try
    {
        //Connect to the server
        telnet.Connect("myServer");

        //Login and marshal data to the UI thread
        telnet.Marshal(telnet.Login("myUsername", "myPassword", "$"), null);

        //Send a list command
        telnet.Write("ls -la\r");

        //Wait for prompt, marshal data to the UI thread
        telnet.Marshal(telnet.Read("$"), null);

        //Send an exit command; server will close the connection
        telnet.Write("exit\r");

        //Read any remaining data before the shutdown
        telnet.Marshal(telnet.ReadToEnd(), null);
    }
    catch (Exception ex)
    {
        //Report errors to the UI thread
        telnet.Marshal(ex);
    }
}

void telnet1_Data(object sender, DataEventArgs e)
{
    //Add data received to the textbox
    textBox1.Text += e.Data.ToString();
}

void telnet1_Error(object sender, Dart.Common.ComponentErrorEventArgs e)
{
    //Add error messages to the textbox
    textBox1.Text += e.GetException().Message;
}

void telnet1_StateChanged(object sender, EventArgs e)
{
    //Change appearance of textbox when connected
    textBox1.BackColor = (telnet1.State == Dart.Common.ConnectionState.Closed)
    ? SystemColors.ControlDark
    : SystemColors.ControlLight;
}
Visual Basic Copy Code
Private telnet1 As Telnet

Private Sub button2_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button2.Click
    'Dynamically create an instance of the Telnet component
    'The component can also be dragged onto a form, so that the
    'properties and event handlers can be managed in the designer
    telnet1 = New Telnet()

    'Events should fire on the UI thread
    telnet1.SynchronizingObject = Me

    'Add event handlers
    AddHandler telnet1.Data, AddressOf telnet1_Data
    AddHandler telnet1.Error, AddressOf telnet1_Error
    AddHandler telnet1.StateChanged, AddressOf telnet1_StateChanged

    'Start the process on a worker thread
    telnet1.Start(AddressOf automateSession, Nothing)
End Sub

Private Sub automateSession(ByVal telnet As Telnet, ByVal notUsed As Object)
    'This function executes on a worker thread, providing multi-threaded, asynchronous operation
    Try
        'Connect to the server
        telnet.Connect("myServer")

        'Login and marshal data to the UI thread
        telnet.Marshal(telnet.Login("myUsername", "myPassword", "$"), Nothing)

        'Send a list command
        telnet.Write("ls -la" & Constants.vbCr)

        'Wait for prompt, marshal data to the UI thread
        telnet.Marshal(telnet.Read("$"), Nothing)

        'Send an exit command; server will close the connection
        telnet.Write("exit" & Constants.vbCr)

        'Read any remaining data before the shutdown
        telnet.Marshal(telnet.ReadToEnd(), Nothing)
    Catch ex As Exception
        'Report errors to the UI thread
        telnet.Marshal(ex)
    End Try
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs)
    'Add data received to the textbox
    textBox1.Text += e.Data.ToString()
End Sub

Private Sub telnet1_Error(ByVal sender As Object, ByVal e As Dart.Common.ComponentErrorEventHandler)
    'Add error messages to the textbox
    textBox1.Text += e.GetException().Message
End Sub

Private Sub telnet1_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    'Change appearance of textbox when connected
    If (telnet1.State = Dart.Common.ConnectionState.Closed) Then
        textBox1.BackColor = SystemColors.ControlDark
    Else
        textBox1.BackColor = SystemColors.ControlLight
    End If
End Sub

Remarks

For an established connection, this function will send username and password after receiving standard login prompts ("gin:" and "word:", respectively). It will then read the data sent by the remote host up to the commandPrompt.

The return value contains a record of all data received during this process. A return value with no data indicates that the server closed the connection.

A SocketException will be thrown with an ErrorCode of 10060 (receive timeout) if the password or login prompt is not provided by the server within 6 seconds from when it is expected.

This method blocks until the login process completes successfully, the default receive timeout period of 6 seconds expires on any socket read, or the server closes the connection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members
Overload List


Login(String,String,String,String,String,Int32) Method

[image]
PowerTCP Telnet for .NET CF
Login(String,String,String,String,String,Int32) Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class > Login Method : Login(String,String,String,String,String,Int32) Method

usernamePrompt
The expected username prompt.
username
The username provided for login.
passwordPrompt
The expected password prompt.
password
The password provided for login.
commandPrompt
The command prompt used by the remote host.
timeout
The maximum number of milliseconds to wait for each expected prompt.
Logs into a telnet server using specified prompts.

Syntax

Visual Basic (Declaration)
Public Overloads Function Login( _
   ByVal usernamePrompt As String, _
   ByVal username As String, _
   ByVal passwordPrompt As String, _
   ByVal password As String, _
   ByVal commandPrompt As String, _
   ByVal timeout As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim usernamePrompt As String
Dim username As String
Dim passwordPrompt As String
Dim password As String
Dim commandPrompt As String
Dim timeout As Integer
Dim value As Data

value = instance.Login(usernamePrompt, username, passwordPrompt, password, commandPrompt, timeout)
C#
public Data Login(
   string usernamePrompt,
   string username,
   string passwordPrompt,
   string password,
   string commandPrompt,
   int timeout
)
Managed Extensions for C++
public: Data* Login(
   string* usernamePrompt,
   string* username,
   string* passwordPrompt,
   string* password,
   string* commandPrompt,
   int timeout
)
C++/CLI
public:
Data^ Login(
   String^ usernamePrompt,
   String^ username,
   String^ passwordPrompt,
   String^ password,
   String^ commandPrompt,
   int timeout
)

Parameters

usernamePrompt
The expected username prompt.
username
The username provided for login.
passwordPrompt
The expected password prompt.
password
The password provided for login.
commandPrompt
The command prompt used by the remote host.
timeout
The maximum number of milliseconds to wait for each expected prompt.

Return Value

A Data object containing the data received during the login.

Remarks

For an established connection, this function will send username and password after receiving the specified login prompts. It will then read the data sent by the remote host up to the commandPrompt.

The return value contains a record of all data received during this process. A return value with no data typically indicates that the server closed the connection.

This method blocks until the login process completes successfully, the receive timeout period expires on any socket read, or the server closes the connection.

A SocketException will be thrown with an ErrorCode of 10060 (receive timeout) if the password or login prompt is not provided by the server within the timeout period specified. An exception will NOT be thrown if a timeout occurs waiting for the command prompt. Instead, the method will return and the Data.Delimiter will be null. Note that a successful login with an incorrectly specified command prompt will result in the method blocking for the timeout period before returning with the actual prompt, manifesting in a perceived delay. An incorrect password could result in a similar delay.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members
Overload List


OnClientOptionChanged Method

[image]
PowerTCP Telnet for .NET CF
OnClientOptionChanged Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : OnClientOptionChanged Method

e
An OptionEventArgs.
Raises the ClientOptionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClientOptionChanged( _
   ByVal e As OptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim e As OptionEventArgs

instance.OnClientOptionChanged(e)
C#
protected virtual void OnClientOptionChanged(
   OptionEventArgs e
)
Managed Extensions for C++
protected: virtual void OnClientOptionChanged(
   OptionEventArgs* e
)
C++/CLI
protected:
virtual void OnClientOptionChanged(
   OptionEventArgs^ e
)

Parameters

e
An OptionEventArgs.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnClientOptionChanged method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnClientOptionChanged in a derived class, be sure to call the base class OnClientOptionChanged method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


OnCommandReceived Method

[image]
PowerTCP Telnet for .NET CF
OnCommandReceived Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : OnCommandReceived Method

e
A CommandEventArgs.
Raises the CommandReceived event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCommandReceived( _
   ByVal e As CommandEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim e As CommandEventArgs

instance.OnCommandReceived(e)
C#
protected virtual void OnCommandReceived(
   CommandEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCommandReceived(
   CommandEventArgs* e
)
C++/CLI
protected:
virtual void OnCommandReceived(
   CommandEventArgs^ e
)

Parameters

e
A CommandEventArgs.

Remarks

Raising an event invokes the event handler through a delegate.

The OnCommandReceived method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnCommandReceived in a derived class, be sure to call the base class OnCommandReceived method, so that registered delegates receive the event.

This event is not marshaled to the UI thread, even if the SynchronizingObject is set.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


OnServerOptionChanged Method

[image]
PowerTCP Telnet for .NET CF
OnServerOptionChanged Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : OnServerOptionChanged Method

e
An OptionEventArgs.
Raises the ServerOptionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnServerOptionChanged( _
   ByVal e As OptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim e As OptionEventArgs

instance.OnServerOptionChanged(e)
C#
protected virtual void OnServerOptionChanged(
   OptionEventArgs e
)
Managed Extensions for C++
protected: virtual void OnServerOptionChanged(
   OptionEventArgs* e
)
C++/CLI
protected:
virtual void OnServerOptionChanged(
   OptionEventArgs^ e
)

Parameters

e
An OptionEventArgs.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnServerOptionChanged method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnServerOptionChanged in a derived class, be sure to call the base class OnServerOptionChanged method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


OnStateChanged Method

[image]
PowerTCP Telnet for .NET CF
OnStateChanged Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : OnStateChanged Method

e
An EventArgs.
Raises the StateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnStateChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim e As EventArgs

instance.OnStateChanged(e)
C#
protected override void OnStateChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnStateChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnStateChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnStateChanged method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnStateChanged in a derived class, be sure to call the base class OnStateChanged method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Refresh Method

[image]
PowerTCP Telnet for .NET CF
Refresh Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : Refresh Method

Negotiates Telnet options that have been added to the ClientOptions and ServerOptions collections.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As Telnet

instance.Refresh()
C#
public void Refresh()
Managed Extensions for C++
public: void Refresh();
C++/CLI
public:
void Refresh();

Remarks

This method performs option negotiation for any non-negotiated option. Requests for all options set to OptionState.RequestOff or OptionState.RequestOn are sent to the server. The Telnet component automatically executes this method when performing option negotiation.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


SendCommand Method

[image]
PowerTCP Telnet for .NET CF
SendCommand Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : SendCommand Method

command
The command to send.
Sends a Telnet (non-option) command to the server.

Syntax

Visual Basic (Declaration)
Public Function SendCommand( _
   ByVal command As Command _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim command As Command
Dim value() As Byte

value = instance.SendCommand(command)
C#
public byte[] SendCommand(
   Command command
)
Managed Extensions for C++
public: byte[]* SendCommand(
   Command command
)
C++/CLI
public:
array<byte>^ SendCommand(
   Command command
)

Parameters

command
The command to send.

Return Value

A byte array containing the bytes sent.

Remarks

Telnet control functions are commands which represent functions that are implemented on most servers. For example, most servers provide an "IP" function that permits the user to interrupt or abort a process.

See Command for a list of control functions.

For manual option negotiation, use SendOption.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


SendOption Method

[image]
PowerTCP Telnet for .NET CF
SendOption Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : SendOption Method

command
The command to send with the option.
code
The option to negotiate.
Sends a Telnet option to the server.

Syntax

Visual Basic (Declaration)
Public Function SendOption( _
   ByVal command As Command, _
   ByVal code As OptionCode _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim command As Command
Dim code As OptionCode
Dim value() As Byte

value = instance.SendOption(command, code)
C#
public byte[] SendOption(
   Command command,
   OptionCode code
)
Managed Extensions for C++
public: byte[]* SendOption(
   Command command,
   OptionCode code
)
C++/CLI
public:
array<byte>^ SendOption(
   Command command,
   OptionCode code
)

Parameters

command
The command to send with the option.
code
The option to negotiate.

Remarks

Option negotiation typically occurs automatically by the Telnet component. Using this method will disable the automatic negotiation. Once disabled, all options must be negotiated manually.

To manually negotiate options:

  1. Clear both ClientOptions and ServerOptions.
  2. Use SendOption from within the CommandReceived event in response to commands from the server.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


SendSubOption Method

[image]
PowerTCP Telnet for .NET CF
SendSubOption Method
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : SendSubOption Method

code
The option pertaining to the suboption.
subOption
The suboption to negotiate.
Sends a suboption request or response to the server.

Syntax

Visual Basic (Declaration)
Public Function SendSubOption( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim code As OptionCode
Dim subOption() As Byte
Dim value() As Byte

value = instance.SendSubOption(code, subOption)
C#
public byte[] SendSubOption(
   OptionCode code,
   byte[] subOption
)
Managed Extensions for C++
public: byte[]* SendSubOption(
   OptionCode code,
   byte[]* subOption
)
C++/CLI
public:
array<byte>^ SendSubOption(
   OptionCode code,
   array<byte>^ subOption
)

Parameters

code
The option pertaining to the suboption.
subOption
The suboption to negotiate.

Return Value

The bytes sent to the remote host.

Remarks

Option megotiation typically occurs automatically by the Telnet component. Suboption data is sent by the Telnet component when a new option (containing the appropriate suboption data) is added to either ClientOptions or ServerOptions. Only use this method if automatic option negotiation is not used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Start Method

[image]
PowerTCP Telnet for .NET CF
Start Method
See Also Example Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : Start Method

worker
TelnetThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.
Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As TelnetThreadStart, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim worker As TelnetThreadStart
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   TelnetThreadStart worker,
   object state
)
Managed Extensions for C++
public: void Start(
   TelnetThreadStart* worker,
   Object* state
)
C++/CLI
public:
void Start(
   TelnetThreadStart^ worker,
   Object^ state
)

Parameters

worker
TelnetThreadStart delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data back to the UI. This specific example uses the Telnet component, but the code is the same for any component that derives from TcpBase.
C# Copy Code
//Receive data on a separate thread
telnet1.Start(receiveData, null);

private void receiveData(Telnet telnet, object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (telnet.State != Dart.Common.ConnectionState.Closed)
        telnet.Marshal(telnet.Read(buffer, 0, 1024), null);
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.Text + e.Data.ToString();
}
Visual Basic Copy Code
'Receive data on a separate thread
telnet.Start(AddressOf receiveData, Nothing)

Private Sub receiveData(ByVal telnet As Telnet, ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023){}
    Do While telnet.State <> ConnectionState.Closed
        telnet.Marshal(telnet.Read(buffer, 0, 1024), Nothing)
    Loop
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles telnet1.Read
    'Whenever data is received, display it
    textDisplay.Text = e.Data.ToString()
End Sub

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Properties

[image]
PowerTCP Telnet for .NET CF
Telnet Class Properties
See Also Send comments on this topic.
Dart.Telnet Namespace : Telnet Class

"

For a list of all members of this type, see Telnet members.

"

Public Properties

 | Name | Description
public Property | Binary | Gets or sets the state of the Telnet Transmit-Binary option.
public Property | ClientOptions | Gets a collection of desired client options.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Echo | Gets or sets the state of the Telnet Echo option.
public Property | EnableLogEvent | Gets or sets a value indicating whether the TcpBase.Log event should be raised. (Inherited from Dart.Common.TcpBase)
public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Common.TcpBase)
public Property | Proxy | Gets the proxy server information used by the component. (Inherited from Dart.Common.TcpBase)
public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Common.PtyBase)
public Property | RemoteEndPoint | Gets the remote address and port of the server (never the proxy). (Inherited from Dart.Common.TcpBase)
public Property | ServerOptions | Gets a collection of desired server options.
public Property | ServerPort | Gets or sets the remote Telnet port to connect to.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SocketOption | Gets the socket options for classes derived from TcpBase. (Inherited from Dart.Common.TcpBase)
public Property | State | Gets the status of the connection. (Inherited from Dart.Common.TcpBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
public Property | TerminalType | Gets or sets the terminal type used for the Telnet TerminalType option.
public Property | WindowSize | Gets or sets the window-size used for the Telnet WindowSize option.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | Gets a value that indicates whether the System.ComponentModel.Component is currently in design mode. (Inherited from System.ComponentModel.Component)
protected Property | Events | Gets the list of event handlers that are attached to this System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


Binary Property

[image]
PowerTCP Telnet for .NET CF
Binary Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : Binary Property

Gets or sets the state of the Telnet Transmit-Binary option.

Syntax

Visual Basic (Declaration)
Public Property Binary As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionState

instance.Binary = value

value = instance.Binary
C#
public OptionState Binary {get; set;}
Managed Extensions for C++
public: __property OptionState get_Binary();
public: __property void set_Binary(
   OptionState value
);
C++/CLI
public:
property OptionState Binary {
   OptionState get();
   void set (    OptionState value);
}

Property Value

An OptionState with a default value of Off.

Remarks

Setting this property adds an option to both ClientOptions and ServerOptions.

To determine negotiation success, check both ClientOptions and ServerOptions. If State is OptionState.On for both, negotiation was successful.

The TRANSMIT-BINARY option is used to send data without padding naked CR characters with NULL. When enabled, naked CR bytes (A CR not followed by a LF) are transmitted without adding a NULL after the CR, and are received without stripping the NULL from CR/NULL sequences found.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


ClientOptions Property

[image]
PowerTCP Telnet for .NET CF
ClientOptions Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : ClientOptions Property

Gets a collection of desired client options.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientOptions As OptionCollection
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionCollection

value = instance.ClientOptions
C#
public OptionCollection ClientOptions {get;}
Managed Extensions for C++
public: __property OptionCollection* get_ClientOptions();
C++/CLI
public:
property OptionCollection^ ClientOptions {
   OptionCollection^ get();
}

Example

The following example demonstrates how to set options for automatic option negotiation.
C# Copy Code
if (telnet1.ServerPort == 23)
{
    //Standard telnet port, add standard telnet options
    telnet1.ClientOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.WindowSize,
        new Byte[] { ((Byte)(0)), ((Byte)(80)), ((Byte)(0)), ((Byte)(24)) }, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.TerminalType,
        new System.Byte[] { ((Byte)(0)), ((Byte)(116)), ((Byte)(116)), ((Byte)(121)) }, OptionState.RequestOn));

    telnet1.ServerOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.Echo, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.OutputPageSize, null, OptionState.RequestOn));
}
else
{
    //Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear();
    telnet1.ServerOptions.Clear();
}
Visual Basic Copy Code
If telnet1.ServerPort = 23 Then
    'Standard telnet port, add standart telnet options
    telnet1.ClientOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.WindowSize, _
        New System.Byte() { (CByte(0)), (CByte(80)), (CByte(0)), (CByte(24)) }, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.TerminalType, _
        New System.Byte() { (CByte(0)), (CByte(116)), (CByte(116)), (CByte(121)) }, OptionState.RequestOn))

    telnet1.ServerOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.Echo, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.OutputPageSize, Nothing, OptionState.RequestOn))
Else
    'Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear()
    telnet1.ServerOptions.Clear()
End If

Remarks

The client will send a WILL command for the options within the collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Echo Property

[image]
PowerTCP Telnet for .NET CF
Echo Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : Echo Property

Gets or sets the state of the Telnet Echo option.

Syntax

Visual Basic (Declaration)
Public Property Echo As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionState

instance.Echo = value

value = instance.Echo
C#
public OptionState Echo {get; set;}
Managed Extensions for C++
public: __property OptionState get_Echo();
public: __property void set_Echo(
   OptionState value
);
C++/CLI
public:
property OptionState Echo {
   OptionState get();
   void set (    OptionState value);
}

Property Value

An OptionState with a default value of RequestOn.

Remarks

When on, the remote host will echo all Telnet data it receives back to the client.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


ServerOptions Property

[image]
PowerTCP Telnet for .NET CF
ServerOptions Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : ServerOptions Property

Gets a collection of desired server options.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerOptions As OptionCollection
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionCollection

value = instance.ServerOptions
C#
public OptionCollection ServerOptions {get;}
Managed Extensions for C++
public: __property OptionCollection* get_ServerOptions();
C++/CLI
public:
property OptionCollection^ ServerOptions {
   OptionCollection^ get();
}

Example

The following example demonstrates how to set options for automatic option negotiation.
C# Copy Code
if (telnet1.ServerPort == 23)
{
    //Standard telnet port, add standard telnet options
    telnet1.ClientOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.WindowSize,
        new Byte[] { ((Byte)(0)), ((Byte)(80)), ((Byte)(0)), ((Byte)(24)) }, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.TerminalType,
        new System.Byte[] { ((Byte)(0)), ((Byte)(116)), ((Byte)(116)), ((Byte)(121)) }, OptionState.RequestOn));

    telnet1.ServerOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.Echo, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.OutputPageSize, null, OptionState.RequestOn));
}
else
{
    //Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear();
    telnet1.ServerOptions.Clear();
}
Visual Basic Copy Code
If telnet1.ServerPort = 23 Then
    'Standard telnet port, add standart telnet options
    telnet1.ClientOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.WindowSize, _
        New System.Byte() { (CByte(0)), (CByte(80)), (CByte(0)), (CByte(24)) }, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.TerminalType, _
        New System.Byte() { (CByte(0)), (CByte(116)), (CByte(116)), (CByte(121)) }, OptionState.RequestOn))

    telnet1.ServerOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.Echo, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.OutputPageSize, Nothing, OptionState.RequestOn))
Else
    'Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear()
    telnet1.ServerOptions.Clear()
End If

Remarks

The client will send a DO command for the options within the collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


ServerPort Property

[image]
PowerTCP Telnet for .NET CF
ServerPort Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : ServerPort Property

Gets or sets the remote Telnet port to connect to.

Syntax

Visual Basic (Declaration)
Public Property ServerPort As Integer
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Integer

instance.ServerPort = value

value = instance.ServerPort
C#
public int ServerPort {get; set;}
Managed Extensions for C++
public: __property int get_ServerPort();
public: __property void set_ServerPort(
   int value
);
C++/CLI
public:
property int ServerPort {
   int get();
   void set (    int value);
}

Property Value

An integer. Defaults to the well-known port 23.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


TerminalType Property

[image]
PowerTCP Telnet for .NET CF
TerminalType Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : TerminalType Property

Gets or sets the terminal type used for the Telnet TerminalType option.

Syntax

Visual Basic (Declaration)
Public Property TerminalType As String
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As String

instance.TerminalType = value

value = instance.TerminalType
C#
public string TerminalType {get; set;}
Managed Extensions for C++
public: __property string* get_TerminalType();
public: __property void set_TerminalType(
   string* value
);
C++/CLI
public:
property String^ TerminalType {
   String^ get();
   void set (    String^ value);
}

Property Value

tty

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


WindowSize Property

[image]
PowerTCP Telnet for .NET CF
WindowSize Property
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : WindowSize Property

Gets or sets the window-size used for the Telnet WindowSize option.

Syntax

Visual Basic (Declaration)
Public Property WindowSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Size

instance.WindowSize = value

value = instance.WindowSize
C#
public Size WindowSize {get; set;}
Managed Extensions for C++
public: __property Size get_WindowSize();
public: __property void set_WindowSize(
   Size value
);
C++/CLI
public:
property Size WindowSize {
   Size get();
   void set (    Size value);
}

Property Value

A Size object with default Width and Height values of 80 and 24.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Events

[image]
PowerTCP Telnet for .NET CF
Telnet Class Events
See Also Send comments on this topic.
Dart.Telnet Namespace : Telnet Class

"

For a list of all members of this type, see Telnet members.

"

Public Events

 | Name | Description
public Event | ClientOptionChanged | Raised when a client Telnet option has changed state (WILL or WONT confirmed).
public Event | CommandReceived | Raised when a Telnet command is received from the server.
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | ServerOptionChanged | Raised when a server Telnet option has changed state (DO or DONT confirmed).
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


ClientOptionChanged Event

[image]
PowerTCP Telnet for .NET CF
ClientOptionChanged Event
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : ClientOptionChanged Event

Raised when a client Telnet option has changed state (WILL or WONT confirmed).

Syntax

Visual Basic (Declaration)
Public Event ClientOptionChanged As OptionEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As OptionEventHandler

AddHandler instance.ClientOptionChanged, handler
C#
public event OptionEventHandler ClientOptionChanged
Managed Extensions for C++
public: __event OptionEventHandler* ClientOptionChanged
C++/CLI
public:
event OptionEventHandler^ ClientOptionChanged

Event Data

The event handler receives an argument of type OptionEventArgs containing data related to this event. The following OptionEventArgs properties provide information specific to this event.

Property | Description
Option | The updated option causing the event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


CommandReceived Event

[image]
PowerTCP Telnet for .NET CF
CommandReceived Event
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : CommandReceived Event

Raised when a Telnet command is received from the server.

Syntax

Visual Basic (Declaration)
Public Event CommandReceived As CommandEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As CommandEventHandler

AddHandler instance.CommandReceived, handler
C#
public event CommandEventHandler CommandReceived
Managed Extensions for C++
public: __event CommandEventHandler* CommandReceived
C++/CLI
public:
event CommandEventHandler^ CommandReceived

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs properties provide information specific to this event.

Property | Description
Command | The command sent by the remote host.
OptionCode | The option pertaining to the received command.
SubOption | Suboption pertaining to the received command.

Remarks

A CommandEventArgs object containing information required to handle the command is provided to the event handler. For example, CommandEventArgs.Command contains the Command sent from the server.

If a reply is sent to the server using SendOption from within the event handler, it is assumed option negotiation will be handled by the developer and automatic option negotiation is turned off.

This event is not marshaled to the UI thread, even if the SynchronizingObject is set.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


ServerOptionChanged Event

[image]
PowerTCP Telnet for .NET CF
ServerOptionChanged Event
See Also Send comments on this topic.
Dart.Telnet Namespace > Telnet Class : ServerOptionChanged Event

Raised when a server Telnet option has changed state (DO or DONT confirmed).

Syntax

Visual Basic (Declaration)
Public Event ServerOptionChanged As OptionEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As OptionEventHandler

AddHandler instance.ServerOptionChanged, handler
C#
public event OptionEventHandler ServerOptionChanged
Managed Extensions for C++
public: __event OptionEventHandler* ServerOptionChanged
C++/CLI
public:
event OptionEventHandler^ ServerOptionChanged

Event Data

The event handler receives an argument of type OptionEventArgs containing data related to this event. The following OptionEventArgs properties provide information specific to this event.

Property | Description
Option | The updated option causing the event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Telnet Class
Telnet Members


Command Enumeration

[image]
PowerTCP Telnet for .NET CF
Command Enumeration
See Also Send comments on this topic.
Dart.Telnet Namespace : Command Enumeration

Enumerates the TELNET protocol commands that can be sent.

Syntax

Visual Basic (Declaration)
Public Enum Command
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Command
C#
public enum Command : System.Enum
Managed Extensions for C++
__value public enum Command : public System.Enum
C++/CLI
public enum class Command : public System.Enum

Members

Member | Description
AO | 245 Abort output. Invokes a function on the recipient to stop sending output data while continuing the current process.
Ayt | 246 Are you there. Invokes a function on the recipient to provide printable evidence that it is still up and running.
Brk | 243 Break. Indicates the "Break" key on the recipient host was hit.
DM | 242 Data stream portion of a Synch. If the sender is sending Urgent data, this notifies the recipient to resume normal processing.
Do | 253 Used during option negotiation. Indicates the request that the other party perform, or confirmation that you are expecting the other party to perform, the indicated option.
Dont | 254 Used during option negotiation. Indicates the demand that the other party stop performing, or confirmation that you are no longer expecting the other party to perform, the indicated option.
EC | 247 Erase character. Invokes a function on the recipient to "delete" the preceding undeleted character from the incoming stream of data.
EL | 248 Erase line. Invokes a function on the recipient to "delete" the preceding undeleted line from the incoming stream of data.
GA | 249 Go ahead. Typically is suppressed.
Iac | 255 Interpret As Command byte (255). Tells the recipient to interpret the next byte as a command.
IP | 244 Interrupt process. Invokes a function on the recipient to suspend, interrupt, abort, or terminate a user process.
Nop | 241 No operation.
SB | 250 Used during option negotiation to establish/provide data for a suboption. Indicates what follows is subnegotiation of the indicated option.
SE | 240 Marks the end of subnegotiation parameters.
Will | 251 Used during option negotiation. Indicates the desire to begin performing, or confirmation that you are now performing, the indicated option.
Wont | 252 Used during option negotiation. Indicates the refusal to perform, or continue performing, the indicated option.

Remarks

The Telnet protocol uses "in-band" signaling to send commands. A special byte, the Interpret As Command (Iac) byte, is sent to instruct the receiver to interpret the next byte as a command. Telnet commands can fall under several categories. Some commands are used solely during option negotiation (DO, DONT, WILL, WONT) to help establish options that both client and server will use. Other commands represent control functions (Ayt, Brk, Nop, etc) used to emit a particular response from the server.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.Command

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Telnet Namespace


OptionCode Enumeration

[image]
PowerTCP Telnet for .NET CF
OptionCode Enumeration
See Also Send comments on this topic.
Dart.Telnet Namespace : OptionCode Enumeration

Enumerates the supported Telnet options.

Syntax

Visual Basic (Declaration)
Public Enum OptionCode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionCode
C#
public enum OptionCode : System.Enum
Managed Extensions for C++
__value public enum OptionCode : public System.Enum
C++/CLI
public enum class OptionCode : public System.Enum

Members

Member | Description
ApproxMessageSize | 4 Approx Message Size Negotiation option.
Authentication | 37 Authentication option. Used to request or confirm that the host is willing to send authentication information. See RFC 1416, RFC 2941, RFC 2942, RFC 2943, and RFC 2951 for more information.
ByteMacro | 19 Byte-Macro option. Used to request or confirm that macro bytes may be used in place of certain strings. See RFC 735 for more information.
CharacterSet | 42 CHARSET option. Used to request or confirm that character set information can be passed between hosts. See RFC 2066 for more information.
ComPort | 44 Com Port Control option. See RFC 2217 for more information.
DataEntryTerminal | 20 Data Entry Terminal option. Used to request or agree to send or receive commands to control the Data Entry Terminal. See RFC 732 or RFC 1043 for more information.
Echo | 1 ECHO option. Used to request or confirm that characters received are echoed back to the NVT. See RFC 857 for more information.
EncryptionOption | 38 Data Encryption option. Used to request or confirm that the host is willing to send/receive encrypted data. See RFC 2946 for more information.
EndOfRecord | 25 END-OF-RECORD option. Used to request or confirm that the EOR character can be used when sending data to delimit blocks of data or records. See RFC 885 for more information.
Environment | 36 Environment option. Used to request or confirm that environment information can be passed between hosts. See RFC 1408 for more information.
ExtendedAscii | 17 EXTENDED-ASCII option. Used to request or confirm that extended ASCII may be transmitted. See RFC 698 for more information.
ExtendedOptionsList | 255 EXOPL, Extended-Options-List option.
ForwardX | 49 FORWARD_X option.
Kermit | 47 Kermit option. Used to request or confirm the communication can use the Kermit protocol. See RFC 2840 for more information.
LineMode | 34 Linemode option. Used to request or confirm that linemode is used. See RFC 1184 for more information.
Logout | 18 LOGOUT option. Used to request or confirm that the other client is forcibly logged off at the end. See RFC 727 for more information.
NewEnvironment | 39 Environment option. Used to request or confirm that environment information can be passed between hosts. See RFC 1572 for more information.
None | -1 No option specified.
OutputCarriageReturnDisp | 10 Negotiate About Output Carriage-Return Disposition option. See RFC 652 for more information.
OutputFormfeedDisp | 13 Negotiate About Output Formfeed Disposition option. See RFC 655 for more information.
OutputHorizontalTabDisp | 12 Negotiate About Output Horizontal Tab Disposition option. See RFC 654 for more information.
OutputHorizontalTabstops | 11 Negotiate About Output Horizontal Tabstops option. See RFC 653 for more information.
OutputLinefeedDisp | 16 Negotiate About Output Linefeed Disposition option. See RFC 658 for more information.
OutputLineWidth | 8 Output Line Width option.
OutputMarking | 27 Output Marking Telnet option. Designed to allow a Server to send a banner to a User so that this banner would be displayed on the screen independently of the application software running in the Server. See RFC 933 for more information.
OutputPageSize | 9 Output Page Size option.
OutputVerticalTabDisp | 15 Negotiate About Output Vertical Tab Disposition option. See RFC 657 for more information.
OutputVerticalTabstops | 14 Negotiate About Vertical Tabstops option. See RFC 656 for more information.
PragmaHeartbeat | 140 TELOPT PRAGMA HEARTBEAT option.
PragmaLogon | 138 TELOPT PRAGMA LOGON option.
Regime3270 | 29 3270 Regime option. Used to request or confirm that 3270 Regimes be supported. See RFC 1041 for more information.
RemoteControlledTransAndEcho | 7 Remote Controlled Transmission and Echoing Telnet option. See RFC 563 and RFC 726 for more information.
RemoteSerialPort | 43 RSP option. Telnet remote serial port.
SendLocation | 23 SEND-LOCATION option. Used to request or confirm that the user can send their location to the Telnet server. See RFC 779 for more information.
SendUrl | 48 SEND-URL option.
SspiLogon | 139 TELOPT SSPI LOGON option.
StartTls | 46 Start TLS option.
Status | 5 STATUS option. Used to request or confirm the receiver's current option status. See RFC 859 for more information.
SupDup | 21 SUPDUP option. See RFC 734 or RFC 736 for more information.
SupDupOutput | 22 SUPDUP-Output option. See RFC 749 for more information.
SuppressGoAheads | 3 SUPPRESS-GO-AHEAD option. Used to request or confirm that the GO-AHEAD is not sent. See RFC 858 for more information.
SuppressLocalEcho | 45 Suppress local echo option.
TacacsUserIdentification | 26 TACACS User Identification Telnet option. Designed to facilitate double login avoidance for communication between TAC hosts. See RFC 927 for more information.
TerminalLocation | 28 Terminal Location Number option. Used to request or confirm usage of a TTYLOC. See RFC 946 for more information.
TerminalSpeed | 32 Terminal Speed option. Used to request or confirm that terminal speed information can be sent in a suboption. See RFC 1079 for more information.
TerminalType | 24 TERMINAL-TYPE option. Used to request or confirm that terminal-type is sent in a subsequent suboption. See RFC 1091 for more information.
TimingMark | 6 TIMING-MARK option. Used to request or or send a TIMING-MARK echo, used for synchronization. See RFC 860 for more information.
TN3270E | 40 TN3270 option. Used to request or confirm that 3270 device family enhancements can be used. See RFC 2355 for more information.
ToggleFlowControl | 33 Remote Flow Control option. Used to request or confirm that flow control can be used. See RFC 1372 for more information.
TransmitBinary | 0 TRANSMIT-BINARY option. Used to request or confirm that received data is to be interpreted as 8 bits of binary data. See RFC 856 for more information.
WindowSize | 31 Negotiate About Window Size option. Used by a client to request if they can convey window size to a server. See RFC 1073 for more information.
X3Pad | 30 X.3 Pad option. See RFC 1035 for more information.
Xauth | 41 XAUTH option.
XDisplayLocation | 35 X Display Location option. Used to request or confirm that the X display location of the client can be sent to the server. See RFC 1096 for more information.

Remarks

The Telnet protocol defines a framework from which both sides of a Telnet connection can negotiate options, enhancing the NVT. For information on a particular value, please consult the RFC for the option.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.OptionCode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Telnet Namespace


OptionState Enumeration

[image]
PowerTCP Telnet for .NET CF
OptionState Enumeration
See Also Send comments on this topic.
Dart.Telnet Namespace : OptionState Enumeration

Enumerates the current state of an Option object.

Syntax

Visual Basic (Declaration)
Public Enum OptionState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionState
C#
public enum OptionState : System.Enum
Managed Extensions for C++
__value public enum OptionState : public System.Enum
C++/CLI
public enum class OptionState : public System.Enum

Members

Member | Description
Allow |
Off |
On |
RequestOff |
RequestOn |
Waiting |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.OptionState

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Telnet Namespace


CommandEventHandler Delegate

[image]
PowerTCP Telnet for .NET CF
CommandEventHandler Delegate
See Also Send comments on this topic.
Dart.Telnet Namespace : CommandEventHandler Delegate

sender
The source of the event.
e
A CommandEventArgs containing command data.
Represents the method that will handle an event in which a command is received.

Syntax

Visual Basic (Declaration)
Public Delegate Sub CommandEventHandler( _
   ByVal sender As Object, _
   ByVal e As CommandEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New CommandEventHandler(AddressOf HandlerMethod)
C#
public delegate void CommandEventHandler(
   object sender,
   CommandEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void CommandEventHandler(
   Object* sender,
   CommandEventArgs* e
)
C++/CLI
public delegate void CommandEventHandler(
   Object^ sender,
   CommandEventArgs^ e
)

Parameters

sender
The source of the event.
e
A CommandEventArgs containing command data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

CommandEventHandler Members
Dart.Telnet Namespace


OptionEventHandler Delegate

[image]
PowerTCP Telnet for .NET CF
OptionEventHandler Delegate
See Also Send comments on this topic.
Dart.Telnet Namespace : OptionEventHandler Delegate

sender
The source of the event.
e
An OptionEventArgs containing option data.
Represents the method that will handle an event in which an option status changes.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OptionEventHandler( _
   ByVal sender As Object, _
   ByVal e As OptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New OptionEventHandler(AddressOf HandlerMethod)
C#
public delegate void OptionEventHandler(
   object sender,
   OptionEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void OptionEventHandler(
   Object* sender,
   OptionEventArgs* e
)
C++/CLI
public delegate void OptionEventHandler(
   Object^ sender,
   OptionEventArgs^ e
)

Parameters

sender
The source of the event.
e
An OptionEventArgs containing option data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OptionEventHandler Members
Dart.Telnet Namespace


RexecThreadStart Delegate

[image]
PowerTCP Telnet for .NET CF
RexecThreadStart Delegate
See Also Send comments on this topic.
Dart.Telnet Namespace : RexecThreadStart Delegate

rexec
The Rexec component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.
Represents the method that will execute on a worker thread when Start is used.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RexecThreadStart( _
   ByVal rexec As Rexec, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New RexecThreadStart(AddressOf HandlerMethod)
C#
public delegate void RexecThreadStart(
   Rexec rexec,
   object state
)
Managed Extensions for C++
public: __gc __delegate void RexecThreadStart(
   Rexec* rexec,
   Object* state
)
C++/CLI
public delegate void RexecThreadStart(
   Rexec^ rexec,
   Object^ state
)

Parameters

rexec
The Rexec component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

RexecThreadStart Members
Dart.Telnet Namespace


RloginThreadStart Delegate

[image]
PowerTCP Telnet for .NET CF
RloginThreadStart Delegate
See Also Send comments on this topic.
Dart.Telnet Namespace : RloginThreadStart Delegate

rlogin
The Rlogin component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.
Represents the method that will execute on a worker thread when Start is used.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RloginThreadStart( _
   ByVal rlogin As Rlogin, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New RloginThreadStart(AddressOf HandlerMethod)
C#
public delegate void RloginThreadStart(
   Rlogin rlogin,
   object state
)
Managed Extensions for C++
public: __gc __delegate void RloginThreadStart(
   Rlogin* rlogin,
   Object* state
)
C++/CLI
public delegate void RloginThreadStart(
   Rlogin^ rlogin,
   Object^ state
)

Parameters

rlogin
The Rlogin component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

RloginThreadStart Members
Dart.Telnet Namespace


RshThreadStart Delegate

[image]
PowerTCP Telnet for .NET CF
RshThreadStart Delegate
See Also Send comments on this topic.
Dart.Telnet Namespace : RshThreadStart Delegate

rsh
The Rsh component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.
Represents the method that will execute on a worker thread when Start is used.

Syntax

Visual Basic (Declaration)
Public Delegate Sub RshThreadStart( _
   ByVal rsh As Rsh, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New RshThreadStart(AddressOf HandlerMethod)
C#
public delegate void RshThreadStart(
   Rsh rsh,
   object state
)
Managed Extensions for C++
public: __gc __delegate void RshThreadStart(
   Rsh* rsh,
   Object* state
)
C++/CLI
public delegate void RshThreadStart(
   Rsh^ rsh,
   Object^ state
)

Parameters

rsh
The Rsh component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

RshThreadStart Members
Dart.Telnet Namespace


TelnetThreadStart Delegate

[image]
PowerTCP Telnet for .NET CF
TelnetThreadStart Delegate
See Also Send comments on this topic.
Dart.Telnet Namespace : TelnetThreadStart Delegate

telnet
The Telnet component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.
Represents the method that will execute on a worker thread when Start is used.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TelnetThreadStart( _
   ByVal telnet As Telnet, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New TelnetThreadStart(AddressOf HandlerMethod)
C#
public delegate void TelnetThreadStart(
   Telnet telnet,
   object state
)
Managed Extensions for C++
public: __gc __delegate void TelnetThreadStart(
   Telnet* telnet,
   Object* state
)
C++/CLI
public delegate void TelnetThreadStart(
   Telnet^ telnet,
   Object^ state
)

Parameters

telnet
The Telnet component used to start execution of this method on a worker thread.
state
Any additional information provided by the user.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TelnetThreadStart Members
Dart.Telnet Namespace


Product Page - PowerTCP Telnet for .NET CF

[image]
PowerTCP Telnet for .NET CF
Delete Me
Send comments on this topic.

Delete me

See Also

Reference

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


AuthenticationException Class Methods

[image]
PowerTCP Telnet for .NET CF
AuthenticationException Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

"

For a list of all members of this type, see AuthenticationException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Overloaded. Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

AuthenticationException Class
Dart.Common Namespace


AuthenticationException Class Properties

[image]
PowerTCP Telnet for .NET CF
AuthenticationException Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

"

For a list of all members of this type, see AuthenticationException members.

"

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

AuthenticationException Class
Dart.Common Namespace


DartLicenseException Class Methods

[image]
PowerTCP Telnet for .NET CF
DartLicenseException Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

"

For a list of all members of this type, see DartLicenseException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Overloaded. Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Common Namespace


DartLicenseException Class Properties

[image]
PowerTCP Telnet for .NET CF
DartLicenseException Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

"

For a list of all members of this type, see DartLicenseException members.

"

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Common Namespace


LicenseException Class Methods

[image]
PowerTCP Telnet for .NET CF
LicenseException Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : LicenseException Class

"

For a list of all members of this type, see LicenseException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Overloaded. Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

LicenseException Class
Dart.Common Namespace


PtyBase Class Events

[image]
PowerTCP Telnet for .NET CF
PtyBase Class Events
See Also Send comments on this topic.
Dart.Common Namespace : PtyBase Class

"

For a list of all members of this type, see PtyBase members.

"

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Common Namespace


PtyBase Class Fields

[image]
PowerTCP Telnet for .NET CF
PtyBase Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : PtyBase Class

"

For a list of all members of this type, see PtyBase members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Common Namespace


SocketBase Class Events

[image]
PowerTCP Telnet for .NET CF
SocketBase Class Events
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


SocketBase Class Fields

[image]
PowerTCP Telnet for .NET CF
SocketBase Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


SocketBase Class Methods

[image]
PowerTCP Telnet for .NET CF
SocketBase Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | Returns an object that represents a service provided by the System.ComponentModel.Component or by its System.ComponentModel.Container. (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


TcpBase Class Fields

[image]
PowerTCP Telnet for .NET CF
TcpBase Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : TcpBase Class

"

For a list of all members of this type, see TcpBase members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Common Namespace


TcpSocketOption Class Fields

[image]
PowerTCP Telnet for .NET CF
TcpSocketOption Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : TcpSocketOption Class

"

For a list of all members of this type, see TcpSocketOption members.

"

Public Fields

 | Name | Description
public Field | LocalEndPoint | Gets or sets the desired local IPEndPoint (address and port) the socket should be bound to. (Inherited from Dart.Common.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Common Namespace


X509CertificateCollection Class Methods

[image]
PowerTCP Telnet for .NET CF
X509CertificateCollection Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

"

For a list of all members of this type, see X509CertificateCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

See Also

Reference

X509CertificateCollection Class
Dart.Common Namespace


X509CertificateCollection Class Properties

[image]
PowerTCP Telnet for .NET CF
X509CertificateCollection Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

"

For a list of all members of this type, see X509CertificateCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Count | Gets the number of elements actually contained in the List. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

See Also

Reference

X509CertificateCollection Class
Dart.Common Namespace


Dart.Common Namespace Inheritance Hierarchy

Dart.Common Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Common.ComponentBase.WorkerWrapperParams
Dart.Common.ComponentErrorEventArgs
Dart.Common.Data
Dart.Common.LogData
Dart.Common.License
Dart.Common.ProductLicense
Dart.Common.DeveloperLicense
Dart.Common.LicenseAccessProvider
Dart.Common.LicenseManager
Dart.Common.Proxy
Dart.Common.SocketOption
Dart.Common.TcpSocketOption
Dart.Common.SslInfo
Dart.Common.X509Chain
Dart.Common.X509ChainPolicy
System.Collections.Generic.List<T>
Dart.Common.X509CertificateCollection
System.ComponentModel.Component
System.MarshalByRefObject
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Common.TcpBase
Dart.Common.PtyBase
Dart.Telnet.Rlogin
Dart.Telnet.Telnet
Dart.Telnet.Rexec
Dart.Telnet.Rsh
System.EventArgs
Dart.Common.LogEventArgs
Dart.Common.UserStateEventArgs
Dart.Common.DataEventArgs
System.Exception
Dart.Common.DartLicenseException
Dart.Common.LicenseBadDeveloperFileException
Dart.Common.LicenseInvalidException
Dart.Common.LicenseFormatException
Dart.Common.LicenseVerificationException
Dart.Common.LicenseNotFoundException
System.IO.BinaryReader
Dart.Common.LicenseReader
System.IO.Stream
System.MarshalByRefObject
Dart.Common.PipeStream
Dart.Common.LogStream
Dart.Common.SslStream
Dart.Telnet.TelnetStream
System.SystemException
System.Exception
Dart.Common.AuthenticationException
Dart.Common.LicenseException
System.ValueType
Dart.Common.CERT_CHAIN_CONTEXT
Dart.Common.CERT_CHAIN_ELEMENT
Dart.Common.CERT_CHAIN_PARA
Dart.Common.CERT_CHAIN_POLICY_PARA
Dart.Common.CERT_CHAIN_POLICY_STATUS
Dart.Common.CERT_CONTEXT
Dart.Common.CERT_ENHKEY_USAGE
Dart.Common.CERT_EXTENSION
Dart.Common.CERT_INFO
Dart.Common.CERT_NAME_BLOB
Dart.Common.CERT_PUBLIC_KEY_INFO
Dart.Common.CERT_REVOCATION_CRL_INFO
Dart.Common.CERT_REVOCATION_INFO
Dart.Common.CERT_SIMPLE_CHAIN
Dart.Common.CERT_TRUST_LIST_INFO
Dart.Common.CERT_USAGE_MATCH
Dart.Common.CRL_CONTEXT
Dart.Common.CRL_ENTRY
Dart.Common.CRL_INFO
Dart.Common.CRYPT_ALGORITHM_IDENTIFIER
Dart.Common.CRYPT_ATTRIBUTE
Dart.Common.CRYPT_BIT_BLOB
Dart.Common.CRYPTOAPI_BLOB
Dart.Common.CTL_CONTEXT
Dart.Common.CTL_ENTRY
Dart.Common.CTL_INFO
Dart.Common.CTL_USAGE
Dart.Common.SCHANNEL_CRED
Dart.Common.SecBuffer
Dart.Common.SecBufferDesc
Dart.Common.SecHandle
Dart.Common.SecPkgContext_ConnectionInfo
Dart.Common.SecPkgContext_IssuerListInfoEx
Dart.Common.SecPkgContext_StreamSizes
Dart.Common.X509ChainStatus

See Also

Reference

Dart.Telnet.CF Assembly


Rexec Class Events

[image]
PowerTCP Telnet for .NET CF
Rexec Class Events
See Also Send comments on this topic.
Dart.Telnet Namespace : Rexec Class

"

For a list of all members of this type, see Rexec members.

"

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Rexec Class Fields

[image]
PowerTCP Telnet for .NET CF
Rexec Class Fields
See Also Send comments on this topic.
Dart.Telnet Namespace : Rexec Class

"

For a list of all members of this type, see Rexec members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Rlogin Class Events

[image]
PowerTCP Telnet for .NET CF
Rlogin Class Events
See Also Send comments on this topic.
Dart.Telnet Namespace : Rlogin Class

"

For a list of all members of this type, see Rlogin members.

"

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Rlogin Class Fields

[image]
PowerTCP Telnet for .NET CF
Rlogin Class Fields
See Also Send comments on this topic.
Dart.Telnet Namespace : Rlogin Class

"

For a list of all members of this type, see Rlogin members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Rsh Class Events

[image]
PowerTCP Telnet for .NET CF
Rsh Class Events
See Also Send comments on this topic.
Dart.Telnet Namespace : Rsh Class

"

For a list of all members of this type, see Rsh members.

"

Public Events

 | Name | Description
public Event | Data | Raised when the Marshal method is called by the user. (Inherited from Dart.Common.TcpBase)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Log | Used to capture protocol data. (Inherited from Dart.Common.TcpBase)
public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Common.TcpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Rsh Class Fields

[image]
PowerTCP Telnet for .NET CF
Rsh Class Fields
See Also Send comments on this topic.
Dart.Telnet Namespace : Rsh Class

"

For a list of all members of this type, see Rsh members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Telnet Class Fields

[image]
PowerTCP Telnet for .NET CF
Telnet Class Fields
See Also Send comments on this topic.
Dart.Telnet Namespace : Telnet Class

"

For a list of all members of this type, see Telnet members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


Dart.Telnet Namespace Inheritance Hierarchy

Dart.Telnet Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Common.PipeStream
System.IO.Stream
System.MarshalByRefObject
Dart.Telnet.TelnetStream
Dart.Common.PtyBase
Dart.Common.TcpBase
Dart.Common.SocketBase
Dart.Common.ComponentBase
System.ComponentModel.Component
System.MarshalByRefObject
Dart.Telnet.Rlogin
Dart.Telnet.Telnet
Dart.Common.TcpBase
Dart.Common.SocketBase
Dart.Common.ComponentBase
System.ComponentModel.Component
System.MarshalByRefObject
Dart.Telnet.Rexec
Dart.Telnet.Rsh
Dart.Telnet.Option
System.Collections.Generic.List<T>
Dart.Telnet.OptionCollection
System.EventArgs
Dart.Telnet.CommandEventArgs
Dart.Telnet.OptionEventArgs

See Also

Reference

Dart.Telnet.CF Assembly